... Cercle Trigonométique ... Courbe Sinus Cosinus et Tangente

Le cercle trigonométrique


Trigonométrie

Histoire des fonctions trigonométriques

Tablette Plimpton 322.

L’histoire des fonctions trigonométriques semble avoir débuté il y a environ 4 000 ans. Nous savons de façon certaine que les Babyloniens déterminaient des approximations de mesures d'angles ou de longueurs de côtés de triangles rectangles. Plusieurs tables de nombres gravés sur de l'argile séchée en témoignent. Une tablette babylonienne écrite en cunéiforme, nommée Plimpton 322 (environ 1900 av. J.-C.) montre quinze triplets pythagoriciens et une colonne de nombres, qui peut être interprétée comme une table de sécantes[1]. Il y a cependant de nombreux débats à ce sujet pour savoir s'il s'agit bien d'une table trigonométrique.

Sommaire

  • 1 Premières utilisations des rapports de longueur dans le triangle
  • 2 Formules sur les fonctions trigonométriques
    • 2.1 En Inde
    • 2.2 Monde arabe et musulman
    • 2.3 Développements ultérieurs
    • 2.4 Sinus, cosinus, tangentes etc.
    • 2.5 Formules de de Moivre et d'Euler
  • 3 Notes et références
  • 4 Lien externe

Premières utilisations des rapports de longueur dans le triangle

L'utilisation la plus ancienne du sinus apparaît dans les Shulba Sutras (en) écrits en indien ancien entre le VIIIe siècle av. J.-C. et le VIe siècle av. J.-C., dans lesquels la valeur du sinus de π/4 (45°) est correctement calculée comme égale à 1/√2 avec une procédure pour cercler un carré (l'inverse de quarrer un cercle), bien que les indiens n'eussent pas encore développé la notion de sinus dans un sens général[2].

Une image artistique de Claudius Ptolémée.

Les rapports trigonométriques furent étudiés indépendamment par Hipparque de Nicée (-180/-125) dans un ouvrage « De l'étude des droites dans le cercle »[3]. Hipparque est reconnu comme le premier mathématicien à avoir disposé de « tables trigonométriques » (tables des longueurs d'arcs de cercle et des longueurs des cordes sous-tendues, qui sont en fait des sinus de l'angle moitié[4]) ; elles lui servirent à calculer l'excentricité des orbites lunaire et solaire, et à estimer les grandeurs et distances relatives du Soleil et de la lune. Toutefois, il n'est pas possible d'affirmer à coup sûr qu'il en soit l'initiateur, bien que Ptolémée (deux siècles plus tard) soit de cet avis : si les historiens des mathématiques s'accordent en général pour désigner Hipparque comme le premier compilateur de tables de cordes, les uns vont jusqu'à en faire l'inventeur de la trigonométrie, alors que d'autres considèrent qu'il s'est borné, en la matière, à présenter de manière pratique des connaissances déjà acquises de longue date[5].

Formules sur les fonctions trigonométriques

Plus tard, au IIe siècle, Ptolémée d’Alexandrie poursuivit ce travail dans son « Almageste », en établissant des égalités de rapport équivalentes aux formules d'addition et de soustraction donnant sin(A + B) et cos(A + B). Ptolémée établit une formule équivalente à la formule de l’angle moitié sin2(A/2) = (1 – cosA)/2 et dressa une table de ses résultats. Aucune des tables d’Hipparque ou de Ptolémée ne survécurent, mais les descriptions faites par d’autres auteurs antiques laissent peu de doute quant à leur existence[6].

En Inde

Les développements significatifs de la trigonométrie suivant furent réalisés en Inde. L'astronome et mathématicien indien Aryabhata (476-550), dans son ouvrage Arya-Siddhanta, définit pour la première fois le sinus (moderne) à partir de la relation entre la moitié d'un angle et la moitié d'une corde, tout en définissant également le cosinus, le contre-sinus (ou sinus verse), et l'inverse du sinus. Ses travaux contiennent aussi les tables les plus anciennes existant actuellement des valeurs du sinus et du contre-sinus (1 − cosinus), de tous les angles compris entre 0° et 90° à intervalles de 3,75°, avec une précision de quatre décimales. Il employait les mots jya pour le sinus, kojya pour le cosinus, ukramajya pour le contre-sinus, et otkram jya pour l'inverse du sinus. Les mots jya et kojya auraient pu devenir sinus et cosinus respectivement après une erreur de traduction.

Notre sinus moderne est dérivé du mot latin sinus qui signifie « compartiment » ou « pli », venant d'une traduction erronée (par l'intermédiaire de l'arabe), du mot sanskrit jiva, aussi écrit jya[4]. Aryabhata employait le mot ardha-jiva (demi-corde), qui fut abrégé en jiva, puis transcrit avec des caractères différents par les Arabes en jiba (جب). Des traducteurs européens comme Robert de Chester et Gérard de Crémone de Tolède au XIIe siècle confondirent jiba avec jaib (جب), qui désigne un « compartiment », probablement parce que jiba (جب) et jaib (جب) sont écrits de la même façon dans le manuscrit arabe (ce système d'écriture, dans une de ses formes, ne fournit pas au lecteur toutes les informations sur les voyelles).

D'autres mathématiciens indiens poursuivirent les travaux d'Aryabhata en trigonométrie. Varahamihira établit les formules [image] Bhaskara I produisit une formule pour calculer le sinus d'un angle aigu sans utilisation de table. Brahmagupta trouva la formule [image] et la formule dite d'interpolation de Brahmagupta (en), permettant d'approximer les valeurs du sinus, qui apparaît comme un cas particulier de la formule d'interpolation de Newton–Stirling au deuxième ordre.

Monde arabe et musulman

Les travaux indiens furent traduits plus tard et furent améliorés par les mathématiciens islamiques. Le mathématicien perse Muhammad ibn Mūsā al-Khuwārizmī produisit des tables des sinus et des tangentes, et apporta aussi sa contribution à la trigonométrie sphérique. Vers le Xe siècle, d'après l'œuvre d'Abu l-Wafa, il apparaît que les mathématiciens musulmans employaient chacune des six fonctions trigonométriques, et disposaient de tables à intervalles de 0,25°, avec 8 décimales exactes, ainsi que des tables de valeurs de la fonction tangente. Abu l-Wafa produisit également la formule trigonométrique sin 2x = 2 sin x cos x. Le mathématicien perse Omar Khayyam résolut les équations cubiques en employant des solutions numériques approximatives obtenues par interpolation dans des tables trigonométriques.

Tous ces premiers travaux ont traité principalement la trigonométrie comme un complément de l'astronomie ; il est possible que le mathématicien indien Bhaskara II et le mathématicien perse Nasir ad-Din at-Tusi fussent les premiers à avoir considéré la trigonométrie comme un sujet d'étude. Ils énoncèrent aussi la loi des sinus et énumérèrent les six types de triangles droits en trigonométrie sphérique. Regiomontanus fut peut-être le premier mathématicien d'Europe à considérer la trigonométrie comme une autre discipline mathématique, dans son ouvrage De triangulis omnimodus écrit en 1464, et aussi dans le suivant Tabulae directionum où il utilisa la fonction tangente, sans la nommer.

Au XIIIe siècle, Nasir ad-Din at-Tusi énonça la formule des sinus et en apporta une preuve. Dans le travail du mathématicien perse Ghiyath al-Kashi (XIVe siècle), se trouvent des tables trigonométriques donnant des valeurs de la fonction sinus avec quatre chiffres après la virgule dans le système sexagésimal (ce qui correspond à 8 décimales exactes dans le système de numération décimal) à partir de 1 degré à intervalle de 1/60°. Le mathématicien timouride Ulugh Beg (XIVe siècle) présenta des tables de sinus et de tangentes correctes à 8 décimales après la virgule.

Développements ultérieurs

Madhava (vers 1400) au sud de l'Inde accomplit des avancées en analyse dans l'étude des fonctions trigonométriques et leurs développements en séries infinies. Il développa les concepts de séries entières et de séries de Taylor, et produisit les développements en séries trigonométriques de sinus, cosinus, tangente et arc tangente. En utilisant les approximations en série de Taylor du sinus et du cosinus, il forma une table de sinus avec douze décimales exactes et une table de cosinus à neuf décimales exactes. Il donna des développements en série de π, π/4, du rayon, du diamètre, de la circonférence et de l'angle θ en termes de fonctions trigonométriques. Ses travaux furent poursuivis par ses disciples à l'école du Kerala jusqu'au XVe siècle[7].

Sinus, cosinus, tangentes etc.

Le traité Canon doctrinæ triangulorum (1551) de Georg Joachim Rheticus, un élève de Copernic, fut probablement le premier ouvrage dans lequel les fonctions trigonométriques étaient définies directement en termes de triangles rectangles au lieu de cercles, et où figuraient des tables des six fonctions trigonométriques. Une version étendue de ce traité fut achevé en 1596 par Valentin Otho un élève de Rheticus.

En 1579, dans son Canon Mathematicus, François Viète prolonge les travaux de Georg Joachim Rheticus en des tables dont la précision ne sera dépassée que par Pitiscus, en 1613. Il donne les premières[8] « formules » (sous forme rhétorique) permettant de relier entre elles les six lignes trigonométriques[9]. L'emploi de ces formules pour calculer rapidement et avec grande précision le sinus d'un angle d'une minute est détaillé dans cet ouvrage volumineux et qui sert de référence pour les calculateurs européens. Viète donne à cette occasion [image] et les valeurs des lignes trigonométrique en nombre décimaux avec une précision de 11 à 12 chiffres. En outre, cet ouvrage étend l'emploi de ces lignes trigonométriques à la trigonométrie sphérique et donne les « formules » permettant de relier les angles et les longueurs d'un triangle rectangle tracé sur la sphère[10]. Le même type de préoccupations occupe alors toute l'Europe. Il est lié tant aux recherches astronomiques qu'à l'essor du commerce maritime. Cela est particulièrement vrai des livres de trigonométrie anglais comme celui de Robert Hues, qui fut imprimé et réimprimé plus de seize fois en vingt ans, ou des préoccupations d'un Jacques Aleaume à l'université de Leyde.

Formules de de Moivre et d'Euler

Articles détaillés : Formule de de Moivre et Formule d'Euler.

Suite aux travaux de Bombelli, les racines de nombres négatifs s'imposent dans les calculs en Europe. Ces nombres imaginaires ou inconcevables[réf. nécessaire] deviendront nos nombres complexes. Dans un premier temps, les mathématiciens européens découvrent des formules remarquables faisant intervenir l'unité imaginaire i (à l'époque notée √–1). Entre autres, les formules sur sin(A + B) et cos(A + B) obtenues par Ptolémée se résument avantageusement par [image] Cette égalité implique la formule de de Moivre. Pressenti par de Moivre en 1730, ce travail fut rédigé par Euler dans l'ouvrage Introductio in analysin infinitorum (1748). Il fut en grande partie à l'origine des considérations analytiques des fonctions trigonométriques en Europe en les définissant à partir de développements en séries, et présenta sa formule : eix = cosx + i sinx. Il employa les abréviations modernes sin, cos, tan, cot, sec, et csc.

Brook Taylor définit les séries de Taylor générales et donna les développements en séries et des approximations de chacune des six fonctions trigonométriques. Les travaux de James Gregory et Colin Maclaurin furent aussi très influents dans le développement des séries trigonométriques.

Le Cours d'Analyse (en) de Cauchy enseigné à l'École Polytechnique a permis de rendre plus rigoureuse l'analyse et en particulier de donner un sens à la somme d'une série entière. Avec Cauchy, les travaux cités peuvent rigoureusement être justifiés. Aujourd'hui, dans l'enseignement supérieur, les fonctions cosinus et sinus sont obtenues comme parties réelle et imaginaire de l'exponentielle complexe définie comme somme d'une série entière. Les formules de Ptolémée découlent alors des propriétés de l'exponentielle (présentation à contre-sens historique).

Notes et références

(en) Cet article est partiellement ou en totalité issu de l’article de Wikipédia en anglais intitulé « History of trigonometry » (voir la liste des auteurs).

  1. ↑ (en) George G. Joseph, The Crest of the Peacock: Non-European Roots of Mathematics, Londres, Penguin Books,‎ 2000, 2e éd. (ISBN 0-691-00659-8), p. 383-384.
  2. ↑ Joseph 2000, p. 232.
  3. ↑ Cité par Théon d'Alexandrie dans son Commentaire de l'Almageste.
  4. ↑ a et b (en) John J. O’Connor et Edmund F. Robertson, « Trigonometric functions », dans MacTutor History of Mathematics archive, université de St Andrews (lire en ligne)..
  5. ↑ Cf. Á. Szabó et E. Maula (trad. Michel Federspiel), Les débuts de l'astronomie, de la géographie et de la trigonométrie chez les Grecs, Paris, J. Vrin, coll. « Mathesis »,‎ 1986 (ISBN 2-7116-0911-1). Dans l'ensemble de l'ouvrage, les auteurs s'opposent avec force arguments à Neugebauer et Toomer en défendant l'idée d'une évolution progressive et constante des connaissances mathématiques au moins depuis le second tiers du Ve siècle. Selon eux, les connaissances géométriques, trigonométriques et même, dans une moindre mesure, astronomiques des Grecs sont nettement plus anciennes qu'admis généralement. Sur la question des cordes, voir les p. 142 ss.
  6. ↑ (en) Carl Benjamin Boyer et Uta Merzbach (de), A History of Mathematics, John Wiley & Sons (1re éd. 1968), 3e éd., 2011 (ISBN 978-0-47063056-3), p. 158-168.
  7. ↑ (en) John J. O’Connor et Edmund F. Robertson, « Madhava of Sangamagramma », dans MacTutor History of Mathematics archive, université de St Andrews (lire en ligne)..
  8. ↑ Celles de Rheticus n'étant pas encore publiées par Otho.
  9. ↑ Michel Chasles, Aperçu historique sur l'origine et le développement des méthodes en géométrie.
  10. ↑ Frédéric Ritter, La trigonométrie de François Viète.

Lien externe

(en) Eli Maor, Trigonometric Delights, Princeton, USA, Princeton University Press,‎ 2002, 6 x 9 in, 256 p. (ISBN 978-0-691-09541-7, présentation en ligne, lire en ligne) — Présente de multiples documents sur l'histoire de la trigonométrie.


Trigonométrie

Triangle rectangle trigo.svg

Cercle trigonométrique et angles remarquables

Planche sur la Trigonométrie, 1728 Cyclopaedia.

  • 1 Présentation

    • 1.1 Histoire de la trigonométrie

      • 1.1.1 Premières techniques de mesure du triangle

      • 1.1.2 Les astronomes grecs

      • 1.1.3 Essor dans le monde musulman

      • 1.1.4 En Europe : redécouverte de Ptolémée

    • 1.2 Applications

  • 2 Trigonométrie

  • 3 Formules de trigonométrie

    • 3.1 Identité remarquable

    • 3.2 Formules d'addition et de différence des arcs

    • 3.3 Formules de duplication des arcs

    • 3.4 Formules d'addition et de différence de deux sinus et de deux cosinus converties en produit

    • 3.5 Formules de développement et de factorisation (formules de Simpson)

    • 3.6 Formules de l'arc moitié

    • 3.7 Théorème d'Al-Kashi ou loi des cosinus

    • 3.8 Résoudre un triangle

    • 3.9 Aire du triangle

  • 4 Quelques problèmes célèbres

  • 5 Notes et références

La trigonométrie (du grec τρίγωνος / trígonos, « triangulaire », et μέτρον / métron, « mesure ») est une branche des mathématiques qui traite des relations entre distances et angles dans les triangles et

des fonctions trigonométriques telles que sinus, cosinus et tangente.

Présentation

Histoire de la trigonométrie

Premières techniques de mesure du triangle

Cette section ne cite pas suffisamment ses sources (janvier 2011). Pour l'améliorer, ajoutez des références vérifiables [Comment faire ?] ou le modèle {{Référence nécessaire}} sur les passages nécessitant une source.

Les origines de la trigonométrie remontent aux civilisations d’Égypte antique, de Mésopotamie et de la vallée de l’Indus, il y a plus de 4 000 ans[1]. Il semblerait que les Babyloniens aient basé la trigonométrie sur un système numérique à base 60. Lagadha (ca -1350 ; ca -1200) aurait été le premier mathématicien à utiliser la géométrie et la trigonométrie pour l’astronomie et dont on retrouve une trace écrite ; la plupart de ses travaux aurait aujourd’hui disparu,[réf. nécessaire], mais son Vedanga Jyotisha nous est parvenu.

La première utilisation du sinus apparaît dans les Sulba Sutras (en) en Inde, entre ca 800 et ca 500 avant Jésus-Christ[réf. nécessaire], où le sinus de π/4 (ou 45°) est correctement calculé comme 1/√2 dans un problème de construction d’un cercle de même aire qu’un carré donné (le contraire de la quadrature du cercle).

Les astronomes grecs[modifier | modifier le code]

L'astronome et mathématicien grec Hipparque de Nicée (-190 ; -120) construisit les premières tables trigonométriques sous la forme de tables de cordes : elles faisaient correspondre à chaque valeur de l'angle au centre (avec une division du cercle en 360°), la longueur de la corde interceptée dans le cercle, pour un rayon fixe donné. Ce calcul correspond au double du sinus de l'angle moitié, et donne donc, d'une certaine façon, ce que nous appelons aujourd'hui une table de sinus. Toutefois, les tables d'Hipparque n'étant pas parvenues jusqu'à nous, elles ne nous sont connues que par le grec Ptolémée, qui les publia, vers l'an 150, avec leur mode de construction dans son Almageste. C'est ainsi qu'elles furent redécouvertes à la fin du Moyen Âge par Georg von Purbach et son élève Regiomontanus. On attribue à Ménélaos d'Alexandrie (fin du Ier siècle) des développements en trigonométrie sphérique, au moins partiellement présents dans l'Almageste et longtemps attribués à Ptolémée lui-même.

Le mathématicien indien Âryabhata, en 499, donne une table des sinus et des cosinus. Il utilise zya pour sinus, kotizya pour cosinus et otkram zya pour l'inverse du sinus. Il introduit aussi le sinus verse.

Un autre mathématicien indien, Brahmagupta, utilise en 628 l'interpolation numérique pour calculer la valeur des sinus jusqu'au second ordre.

Essor dans le monde musulman

C'est dans le monde musulman que la trigonométrie prend le statut de discipline à part entière et se détache de l'astronomie[2].

Omar Khayyam (1048-1131) combine l'utilisation de la trigonométrie et la théorie de l'approximation pour fournir des méthodes de résolutions d'équations algébriques par la géométrie. Des méthodes détaillées de constructions de tables de sinus et cosinus pour tous les angles sont écrites par le mathématicien Bhāskara II en 1150. Il développe aussi la trigonométrie sphérique. Au XIIIe siècle, Nasir al-Din Tusi, à la suite de Bhāskara, est probablement un des premiers à considérer la trigonométrie comme une discipline distincte des mathématiques. Enfin, au XIVe siècle, Al-Kachi réalise des tables de fonctions trigonométriques lors de ses études en astronomie.

En Europe : redécouverte de Ptolémée

En Europe, la trigonométrie se développe vers le milieu du XIVe siècle avec la traduction en latin des œuvres de Ptolémée. Les pionniers en ce domaine sont Georg von Purbach et surtout son étudiant Regiomontanus. Suivent au début du XVIe siècle les traités d'Oronce Finé, Pedro Nunes et Joachim Rheticus. Le mathématicien silésien Bartholomäus Pitiscus publie un travail remarquable sur la trigonométrie en 1595, dont le titre (Trigonometria) a donné son nom à la discipline. C'est le mathématicien flamand Adrien Romain qui introduit la notation moderne [image].

Applications

Les applications de la trigonométrie sont extrêmement nombreuses. En particulier, elle est utilisée en astronomie et en navigation avec notamment la technique de triangulation. Les autres champs où la trigonométrie intervient sont (liste non exhaustive) : physique, électricité, électronique, mécanique, acoustique, optique, statistiques, économie, biologie, chimie, médecine, météorologie, géodésie, géographie, cartographie, cryptographie, etc.

Trigonométrie

Triangle ABC

Une définition possible des fonctions trigonométriques est d'utiliser les triangles rectangles, c’est-à-dire les triangles qui possèdent un angle droit (90° degrés ou π/2 radians).

Et parce que la somme des angles d'un triangle fait 180° (ou π radians), l'angle le plus grand dans un tel triangle est l'angle droit. Le côté le plus long dans un triangle rectangle, c’est-à-dire le côté opposé à l'angle le plus grand (l'angle droit), s'appelle l'hypoténuse.

Dans la figure à droite, l'angle [image] forme l'angle droit. Le côté [AB] l'hypoténuse.

Les fonctions trigonométriques se définissent ainsi, en notant A l'angle [image] :

Ce sont les fonctions trigonométriques les plus importantes. Elles ont été définies pour les angles entre 0° et 90° (soit entre 0 et π/2 radians). En utilisant le cercle unité, on peut étendre cette définition.

Formules de trigonométrie

Pour plus de formules, voir l'article : Identité trigonométrique.

Identité remarquable

Quel que soit l'angle A, on a (d'après le théorème de Pythagore):

Formules d'addition et de différence des arcs

Formules de duplication des arcs

Formules d'addition et de différence de deux sinus et de deux cosinus converties en produit

Formules de développement et de factorisation (formules de Simpson)

Développement

Des formules d'addition et de différence ci-dessus, on déduit :

en particulier

en particulier

(équivalente à la précédente par interversion de A et B)

Factorisation

Les formules d'addition et de différence de deux sinus et de deux cosinus converties en produit (cf. avant-dernier paragraphe ci-dessus) permettent la transformation suivante en posant d'abord :

et [image], d'où :

et [image], alors :

(équivalente à la précédente en remplaçant q par -q)

Formules de l'arc moitié

Ces formules interviennent dans de très nombreux problèmes. En posant :

on a :

Théorème d'Al-Kashi ou loi des cosinus

Cette formule a une importance particulière en triangulation et a servi à l'origine en astronomie. On doit au mathématicien Ghiyath al-Kashi, de l'école de Samarcande, de mettre le théorème sous une forme utilisable pour la triangulation au cours du XVe siècle.

Démonstration

Dans un triangle ABC quelconque, soient a = BC, b = AC et c = AB. On a :

Remarque : lorsque [image] ° ou [image], on a a^2 = b^2 + c^2, c'est-à-dire le théorème de Pythagore.

Résoudre un triangle

C’est, étant donné un côté et deux angles adjacents, ou un angle et deux côtés adjacents, ou à la rigueur deux côtés b et c et leur angle B, trouver le triangle correspondant, c’est-à-dire a, b, c, A, B et C (et vérifier une des règles non appliquée dans le processus).

On résout ce genre de problème à l’aide des formules précédentes (plus la formule de projection évidente a = b · cos C + c · cos B).

Par exemple :

Sur l’axe Ox, OB = 1 et OC = 1,5. OBM = 60° et OCM = 30°. Trouver M :

Faire l’épure ; M se trouve en (x = 0,75 ; y = 0,45) environ.

Raisonner : dans le triangle BMC, B = 120° et C = 30° donc M = 30° ; donc le triangle est isocèle en B et BM = 0,5.

Puis CM = 2 × 0,5 × cos C = √3/2.

Soit H la projection de M sur l’axe : HM = y et l'angle HMB vaut 30°.

Il en résulte que y = √3/4 = 0,433 et x = 1 - 0,5 / 2 = 0,75.

La distance OM = √3/2 = MC, l’azimut de M vaut 30°, et l’angle OMB vaut 90°.

Il est rare que ce soit aussi simple en pratique.

En général, on demande quatre à six chiffres significatifs. Les calculettes ont considérablement réduit le travail assez fastidieux de « réduction des triangles ». Rappelons que la mesure du degré de l’arc méridien terrestre de Paris s’est effectuée de la sorte entre Malvoisine et Montlhéry par l’abbé Picard, dans le milieu du XVIIe siècle.

Aire du triangle

L'aire A du triangle se détermine à l'aide de la longueur de deux côtés et du sinus de l'angle qu'ils forment : A = 1/2 a × b × sin(Ĉ) D'une telle égalité, appliquée à chaque sommet du triangle, on peut déduire la loi des sinus.

La formule précédente, complétée par la loi des cosinus, permet également d'établir la formule de Héron :

A = √p (p - a) (p - b) (p - c),

où a, b et c sont les longueurs de ses côtés et p désigne le demi-périmètre du triangle :

p = (a + b + c) / 2.

Quelques problèmes célèbres

  • La flèche d’une corde AB sous tendant l’arc AOB = 2 α : soit I le milieu de AB, et CD le diamètre passant par I ; alors :

ID = flèche telle que f · (2R - f) = (R · sin α)²

  • Aire de l'onglet :

S = R² · [α - sin(2α)/2] ;

Quand α est petit, on compare cette aire à celle de la parabole osculatrice 1/3·f·AB (théorème d'Archimède) : la différence est d'ordre supérieur à trois.

  • John Machin a été le premier à calculer π avec 100 décimales, en 1706, grâce à sa formule. Des formules de ce type ont été utilisées jusqu’à nos jours, pour calculer un grand nombre de décimales de π.
  • Polygones réguliers constructibles à la règle et au compas :

l’heptagone et l’ennéagone ne sont pas constructibles, mais le polygone à 17 côtés (heptadécagone) est constructible (théorème de Gauss-Wantzel).

En revanche, on peut construire par pliage l’heptagone et l’ennéagone.

On prouve également que pour A = 2π/7 (intervenant dans la construction de l’heptagone par pliage), on a :

sin A · sin(2A) · sin(3A) = √7/8 et

cos A · cos(2A) · cos(3A) = 1/8.

Des formules semblables existent pour l'ennéagone.

Notes et références

  1. ↑ Aaboe, Asger: Episodes from the Early History of Astronomy New York: Springer, 2001. ISBN 0-387-95136-9 d'après l'article en anglais : http://en.wikipedia.org/wiki/Trigonometry
  2. ↑ http://www.dailymotion.com/video/xavcjs_les-mathematiques-arabes-4-6_tech


Accueil

Accueil CHM

Normal, dit comme ça,
vous ne risquez pas de comprendre.


Trigonométrie

Sinus (mathématiques)

Représentation graphique d'une période de la fonction sinus.

Le sinus, en mathématiques, est une fonction d'un angle. Dans un triangle rectangle, le sinus d'un angle est le rapport de la longueur du côté opposé par la longueur de l'hypoténuse.

Le sinus est habituellement cité en premier parmi les fonctions trigonométriques.

Les fonctions trigonométriques sont habituellement définies comme le rapport de deux côtés d'un triangle rectangle, et peuvent être définies de manière équivalente comme la longueur de différents segments sur le cercle unité. Les définitions plus modernes les caractérisent par des séries entières ou comme des solutions d'équations différentielles particulières, permettant leur extension à des valeurs arbitraires et aux nombres complexes.

La fonction sinus est utilisée couramment pour modéliser des phénomènes périodiques comme les ondes sonores ou lumineuses ou encore les variations de température au cours de l'année.

L'origine de la fonction sinus peut être retracée aux fonctions jyā et koṭi-jyā (en), utilisées en astronomie indienne pendant la période Gupta (Surya Siddhanta), via des traductions du sanskrit à l'arabe et de l'arabe au latin[1].

Sommaire

  • 1 Définitions
    • 1.1 Définitions dans un triangle rectangle
    • 1.2 Définitions à partir du cercle unité
    • 1.3 Définitions à partir des séries entières
  • 2 Propriétés
    • 2.1 Réciproque
    • 2.2 Dérivée
    • 2.3 Intégrale
    • 2.4 Limites
    • 2.5 Valeurs remarquables
  • 3 Relation avec les nombres complexes
    • 3.1 Sinus avec un argument complexe
      • 3.1.1 Fraction partielle et développement en série du sinus complexe
      • 3.1.2 Utilisation du sinus complexe
    • 3.2 Graphiques complexes
  • 4 Note et références

Définitions

Définitions dans un triangle rectangle

Pour définir le sinus d'un angle [image], considérons un triangle rectangle arbitraire qui contient l'angle [image].

Sinus = Côté opposé / Hypoténuse

Les côtés du triangle rectangle sont appelés :

  • l’hypoténuse : c'est le côté opposé à l'angle droit, une jambe de l'angle [image] et le côté le plus long du triangle,
  • le côté opposé : c'est le côté opposé à l'angle [image] qui nous intéresse,
  • le côté adjacent : c'est le côté qui est une jambe de l'angle [image], qui n'est pas l'hypoténuse.

On notera :

h : la longueur de l'hypoténuse,
o : la longueur du côté opposé,

Ce rapport ne dépend pas du triangle rectangle particulier choisi, aussi longtemps qu'il contient l'angle [image], puisque tous ces triangles rectangles sont semblables.

Définitions à partir du cercle unité

est égal a la longueur du segment indiqué en rouge.

En trigonométrie, le cercle unité est le cercle de rayon un centré à l'origine (0, 0) d'un système de coordonnées cartésiennes.

Considérons l'intersection entre une droite passant par l'origine, faisant un angle [image] avec la moitié positive de l'axe x, et le cercle unité. Alors la composante verticale de cette intersection est égale à [image].

Animation montrant le graphique de y = sin(x) (où x est l'angle en radians) sur le cercle unité

Définitions à partir des séries entières

Ici, et généralement en analyse, il est de la plus grande importance que tous les angles soient mesurés en radians. On peut alors définir :

Cette définition est équivalente à celles données ci-dessus ; on peut le justifier avec la théorie des séries de Taylor. Cette définition est souvent utilisée comme point de départ des traités rigoureux d'analyse et de la définition du nombre π puisque la théorie des séries est bien connue. La dérivabilité et la continuité sont alors faciles à établir, de même que les formules d'Euler en analyse complexe reliant les fonctions trigonométriques à la fonction exponentielle, ainsi que l'identité d'Euler. La définition utilisant les séries a l'avantage supplémentaire de permettre de prolonger la fonction sinus en une fonction analytique dans tout le plan complexe.

Propriétés

Réciproque

Représentation graphique de la fonction arc sinus

Les fonctions trigonométriques ne sont pas bijectives (ni même injectives, puisqu'elles sont périodiques) ; elles n'admettent donc pas de bijections réciproques. En les restreignant à certains intervalles de départ et d'arrivée, les fonctions trigonométriques peuvent réaliser des bijections. L'application réciproque arcsin est habituellement définie par :

pour tous réels x et y :

si et seulement si

La fonction arcsin est donc une bijection de [–1, 1] sur [–π/2, π/2] et vérifie

et

Dérivée

La dérivée de la fonction sinus est la fonction cosinus :

Démonstration

Cette propriété est immédiate avec les définitions à partir des séries entières des fonctions sinus et cosinus. On en déduit en particulier que

Inversement, on peut déduire cette limite de la définition géométrique (cf. § « Limites ») puis s'en servir pour calculer la dérivée :

On utilise la formule des différences de sinus, sinp – sinq = 2 cos((p + q)/2) sin((p – q)/2), pour transformer le numérateur :

Intégrale

Une primitive de sin est –cos, ce qui s'écrit usuellement : Autrement dit : pour tout x 0,

est la « constante d'intégration ».

Limites

Article connexe : Sinus cardinal.
Justification

Considérons le cercle unité sur la figure suivante, et supposons que l'angle θ est compris entre 0 et π/2.

Sin x over x full fig.svg

Intéressons nous aux différentes aires présentes dans cette figure :

Nous pouvons constater que l'aire du triangle rouge ( [image]) est plus petite que celle du secteur circulaire bleu ( S) qui est elle-même plus petite que l'aire du triangle vert ( [image]). On note donc :

A(T_R) < A(S) < A(T_V).

L'aire du triangle rouge est donnée par :

(base fois hauteur sur deux),

l'aire de du secteur circulaire bleu :

et l'aire du triangle vert :

Alors :

Puisque prendre l'inverse de chaque membre positif d'une inéquation renverse l'inégalité, on trouve :

Multiplier chaque terme par la quantité positive (sinθ)/2 ne change pas le sens des inégalités et donne :

Or quand θ tend vers zéro, cos(θ) tend vers 1 ; sin(θ)/θ est donc pris en « étau » entre ces deux bornes. On peut donc conclure, par le théorème des gendarmes que :

Par parité, la limite à gauche en 0 est la même.

(Voir le § « Exemple » de l'article sur le théorème des gendarmes.)

Valeurs remarquables

sin(x)
Quelques angles communs (θ) sur le cercle unité. Les angles sont indiqués en degrés et en radians, ainsi que leur intersection avec le cercle unité (cos θ, sin θ).
x (angle) |  |  | sin x
Degrés | Radians | Grades | Exacte | Décimale
0° | 0 | 0g | 0 | 0
180° |  | 200g
15° |  | 16 2/3g |  | 0,258819045102521
165° |  | 183 1/3g
30° |  | 33 1/3g |  | 0,5
150° |  | 166 2/3g
45° |  | 50g |  | 0,707106781186548
135° |  | 150g
60° |  | 66 2/3g |  | 0,866025403784439
120° |  | 133 1/3g
75° |  | 83 1/3g |  | 0,965925826289068
105° |  | 116 2/3g
90° |  | 100g | 1 | 1

Relation avec les nombres complexes

Une illustration du plan complexe. Les nombres imaginaires se trouvent sur l'axe des ordonnées.

Le sinus est utilisé pour déterminer la partie imaginaire d'un nombre complexe z donné en coordonnées polaires, par son module r et son argument φ :

où i désigne l'unité imaginaire.

La partie imaginaire de z est

Bien qu'acceptant aussi des nombres complexes, le paramètre donné à la fonction sinus est généralement un nombre réel.

Sinus avec un argument complexe

Coloration de domaine (en) de sin(z) quand les parties réelle et imaginaire de z sont comprises dans [–π, π]. La luminosité indique le module, la saturation représente[Comment ?] la magnitude imaginaire et réelle[Quoi ?].

sin(z) comme un champ vectoriel

La définition de la fonction sinus comme série entière s'étend telle quelle à des arguments complexes z :

C'est une fonction entière. Aussi, pour x réel,

et pour iy imaginaire pur,

Il est aussi parfois utile d'exprimer la fonction sinus complexe en termes des parties réelle et imaginaire de son argument :

Fraction partielle et développement en série du sinus complexe

Utilisant la technique de développement en éléments simples (en) d'une fonction méromorphe, on peut trouver la série infinie :

On trouve de même

Utilisant la technique de développement du produit, on peut en tirer

Utilisation du sinus complexe

sin z se trouve dans l'équation fonctionnelle pour la fonction Gamma,

laquelle se trouve à son tour dans l'équation fonctionnelle pour la fonction zêta de Riemann,

Comme toute fonction holomorphe, sin z est harmonique, c'est-à-dire solution de l'équation de Laplace à deux dimensions :

Graphiques complexes

Fonction sinus dans le plan complexe
Complex sin real 01 Pengo.svg | Complex sin imag 01 Pengo.svg | Complex sin abs 01 Pengo.svg
partie réelle | partie imaginaire | module

Sin-1 dans le plan complexe
Complex arcsin real 01 Pengo.svg | Complex arcsin imag 01 Pengo.svg | Complex arcsin abs 01 Pengo.svg
partie réelle | partie imaginaire | module

Note et références

Sur les autres projets Wikimedia :

  • sinus, sur le Wiktionnaire

(en) Cet article est partiellement ou en totalité issu de l’article de Wikipédia en anglais intitulé « Sine » (voir la liste des auteurs).

  1. ↑ (en) Carl B. Boyer, A History of Mathematics, John Wiley & Sons,‎ 1991, 2e éd. (ISBN 0-471-54397-7), p. 210


Trigonométrie

Sinus verse

La fonction sinus verse

Le sinus verse est une fonction trigonométrique peu utilisée de nos jours. Elle est généralement notée versin, vers ou encore sin v. et définie comme :

Historiquement utilisée dans les calculs d'approximation et dans la navigation (par exemple pour le calcul de la distance du grand cercle), elle est tombée en désuétude avec l'arrivée des calculs informatiques.

Lien externe

(en) Eric W. Weisstein, « Versine », MathWorld


Trigonométrie

Sinus intégral

Page d'aide sur l'homonymie Ne pas confondre avec la fonction sinus cardinal.

La fonction sinus intégral, notée Si, est une fonction spéciale de la physique mathématique introduite par Fresnel dans l'étude des vibrations lumineuses, est définie pour tout réel x par l'intégrale :

où la fonction sin est la fonction sinus.

Tracé de Si(x) pour

Sommaire

  • 1 Historique
  • 2 Propriétés
  • 3 Références
  • 4 Voir aussi
    • 4.1 Articles connexes
    • 4.2 Bibliographie
    • 4.3 Liens externes

Historique

Cette fonction a été utilisée par Oscar Xavier Schlömilch (pour représenter certaines intégrales définies) avec la notation moderne [image] dès 1846[1]. Une première tabulation de cette fonction (pour [image] … ,10), due à Carl Anton Bretschneider (de), a été republiée par Schlömilch en 1848[2]. Jean Denis Fenolio a publié en 1857 un mémoire[3] suggérant plusieurs formules pour le calcul numérique de la fonction [image]. Davide Besso (ru) a publié en 1868[4] une table de valeurs de [image] pour x multiple entier de [image]. Une tabulation plus précise que celles de Bretschneider et Besso a été publiée en 1870 par J. W. L. Glaisher[5], qui donne aussi un historique de l'utilisation de cette fonction dans la littérature mathématique. Des tables détaillées des fonctions cosinus intégral, exponentielle intégrale et sinus intégral ont été publiées en 1940 par la Federal Works Agency (en), sous la direction d'Arnold D. Lowan[6]. L'introduction du volume 1 de ces tables contient (p. 26) une bibliographie des applications de ces fonctions en physique et en ingénierie.

Propriétés

  • La fonction est continue, infiniment dérivable sur ℝ, et [image] où [image] est la fonction sinus cardinal.
  • La fonction Si est développable en série entière sur ℝ, et on a [image] Ce développement permet d'étendre la fonction Si en une fonction analytique définie sur tout le plan complexe.
  • . Il s'agit de l'intégrale de Dirichlet.
  • Une formule intéressante : (coefficient binomial généralisé).

Références

  1. ↑ O. Schlömilch, « Note sur quelques intégrales définies », J. reine angew. Math., vol. 33, no 316,‎ 1846 (lire en ligne)
  2. ↑ (de) O. Schlömilch, Analytische Studien vol. 1, 1848, p. 196
  3. ↑ J. D. Fenolio, Essai sur le sinus intégral, Turin, imprimerie royale, 1857
  4. ↑ (it) D. Besso, « Sull'integral seno e l'integral coseno », dans Giornale di matematiche (Battaglini (it)), vol. 6, 1868, p. 313
  5. ↑ (en) J. W. L. Glaisher, « Tables of the Numerical Values of the Sine-integral, Cosine-integral, and Exponential-integral », dans Philos. Trans. R. Soc., vol. 160, 1870, p. 387
  6. ↑ (en) Arnold L. Lowan (éd.), Tables of Sine, Cosine and Exponential Integrals, t. 1 et t.2, New York, 1940

Voir aussi

Articles connexes

  • Cosinus intégral
  • Exponentielle intégrale
  • Logarithme intégral

Bibliographie

  • (en) Eugen Jahnke (de) et Fritz Emde (de), Tables of higher functions, McGraw Hill, 1960, p. 18
  • (en) Milton Abramowitz et Irene Stegun, Handbook of Mathematical Functions with Formulas, Graphs, and Mathematical Tables [détail de l’édition] (lire en ligne)

Liens externes

  • (en) Sine Integral dans functions.wolfram.com
  • (en) Eric W. Weisstein, « Sine integral », MathWorld
  • (en) N. M. Temme, « Exponential, Logarithmic, Sine, and Cosine Integrals » dans dlmf.nist.gov
  • (en) « The Special Function Si(x) », dans le Dynamic Dictionary of Mathematical Functions


Trigonométrie

Sinus hyperbolique

Graphe de la fonction sinus hyperbolique sur une partie de ℝ

Le sinus hyperbolique est, en mathématiques, une fonction hyperbolique.

Sommaire

  • 1 Définition
  • 2 Propriétés
    • 2.1 Propriétés générales
    • 2.2 Propriétés trigonométriques
    • 2.3 Développement en série de Taylor
  • 3 Valeurs
  • 4 Zéros
  • 5 Fonction réciproque
  • 6 Voir aussi
  • 7 Références

Définition

La fonction sinus hyperbolique, notée sinh (ou sh)[1] est la fonction complexe suivante :

où [image] est l'exponentielle complexe.

La fonction sinus hyperbolique est la partie impaire de l'exponentielle complexe.

La fonction sinus hyperbolique est en quelque sorte l'analogue de la fonction sinus dans la géométrie hyperbolique.

Propriétés

Propriétés générales

  • sinh est continue et même holomorphe donc infiniment dérivable. Sa dérivée est cosh, la fonction cosinus hyperbolique.
  • sinh est impaire.
  • Les primitives de sinh sont cosh+C, à une constante d'intégration C près.
  • La restriction de sinh à ℝ est strictement croissante, concave sur ]-∞,0[ et convexe sur ]0,+∞[.

Propriétés trigonométrique

De par les définitions des fonctions sinus et cosinus hyperbolique, on peut déduire les égalités suivantes :

Ces égalités sont analogues à la formule d'Euler en trigonométrie classique.

De même que les coordonnées (cos(t), sin(t)) définissent un cercle, (cosh(t), sinh(t)) définissent la branche positive d'une hyperbole équilatérale. On a en effet pour t > 0 :

.

D'autre part, pour [image] :

L'utilisation de formules trigonométriques telles que [image] permet aussi d'obtenir des relations plus anecdotiques, telle que (pour tout réel x non nul) :

;

voir également l'article Gudermannien

Développement en série de Taylor

La série de Taylor de la fonction sinh converge sur ℂ tout entier et est donnée par :

Valeurs

Quelques valeurs de sinh :

Zéros

Tous les zéros de [image] sont des imaginaires purs : .

Démonstration

Soit [image] y avec [image] alors

Fonction réciproque

Graphe de la fonction argument sinus hyperbolique sur une partie de ℝ

sinh admet une fonction réciproque, notée arsinh (ou argsinh ou argsh ou parfois sinh-1)[2], et nommée argument sinus hyperbolique. Il s'agit d'une fonction multiforme complexe. Sa branche principale est généralement choisie en posant comme coupure les segments [image] et [image].

La restriction-corestriction de sinh de ℝ dans ℝ admet une réciproque : ; il est facile de démontrer ce résultat en utilisant que [image], et donc, en posant [image] on aura [image].

Voir aussi

Sur les autres projets Wikimedia :

  • la fonction sinus hyperbolique, sur Wikimedia Commons
  • la fonction argsinus hyperbolique, sur Wikimedia Commons
  • Fonction hyperbolique
  • Cosinus hyperbolique
  • Tangente hyperbolique

Références

  1. ↑ La norme internationale ISO 80000-2:2009 recommande sinh
  2. ↑ La norme ISO 80000-2:2009 recommande arsinh


Trigonométrie

Sinus cardinal

  • sinc1(x): Sinus cardinal non normalisé
  • sincπ(x): Sinus cardinal normalisé

En mathématiques, la fonction sinus cardinal est une fonction spéciale définie à partir de la fonction trigonométrique sinus apparaissant fréquemment dans des problèmes de physique ondulatoire.

Sommaire

  • 1 Définitions
  • 2 Propriétés
    • 2.1 Propriétés élémentaires
    • 2.2 Résultats de calcul infinitésimal
    • 2.3 Transformée de Fourier
  • 3 Liens avec les fonctions spéciales
  • 4 Utilisation et applications
  • 5 Notes et références
  • 6 Voir aussi
    • 6.1 Articles connexes
    • 6.2 Liens externes

Définitions[ modifier | modifier le code ]

La fonction sinus cardinal est définie par : (définition 1) où [image] désigne la fonction sinus.

Comme souvent en mathématiques[réf. nécessaire], il existe une autre définition couramment utilisée : (définition 2).

Quand une confusion pourra être possible, on notera par la suite [image] (resp. ) la première (et respectivement la seconde) version de la fonction. La seconde est parfois nommée sinus cardinal normalisé.

Propriétés[ modifier | modifier le code ]

Propriétés élémentaires[ modifier | modifier le code ]

La valeur en zéro semble de prime abord non définie, mais le calcul de limite est possible : on reconnaît en [image] un taux d'accroissement pour la fonction sinus, dont la limite en 0 est le nombre dérivé du sinus en 0, égale à [image], ce qui permet de définir la fonction en posant sinc(0) = 1, en opérant ainsi un prolongement par continuité.

Les zéros de la fonction sont atteints en [image] (première définition) ou [image] (seconde définition)

Abscisses et valeurs des extrema
x |  |  |  |
0 | 0 | 1 | 1 | 0
4.493409 | 1.430297 | −0.217234 | 0.047190 | −13.261459
7.725252 | 2.459024 | 0.128375 | 0.016480 | −17.830421
10.904122 | 3.470890 | −0.091325 | 0.008340 | −20.788187
14.066194 | 4.477409 | 0.070913 | 0.005029 | −22.985427
17.220755 | 5.481537 | −0.057972 | 0.003361 | −24.735664
20.371303 | 6.484387 | 0.049030 | 0.002404 | −26.190829
23.519452 | 7.486474 | −0.042480 | 0.001805 | −27.436388
26.666054 | 8.488069 | 0.037475 | 0.001404 | −28.525278
29.811599 | 9.489327 | −0.033525 | 0.001124 | −29.492589
32.956389 | 10.490344 | 0.030329 | 0.000920 | −30.362789
36.100622 | 11.491185 | −0.027690 | 0.000767 | −31.153625
39.244432 | 12.491891 | 0.025473 | 0.000649 | −31.878380
42.387914 | 13.492492 | −0.023585 | 0.000556 | −32.547257

La valeur où le carré de [image] vaut 0,5 est atteinte pour x = ± 1.39156 environ (ce qui permet de définir la largeur de la bande passante à −3 dB en puissance, de la fonction)

Résultats de calcul infinitésimal[ modifier | modifier le code ]

La fonction est développable en série entière sur la droite réelle : .

De là vient que le sinus cardinal est indéfiniment dérivable sur [image]. Il peut même être étendu en une fonction holomorphe sur tout le plan complexe, en employant la formule précédente pour tout x complexe.

Les primitives de la fonction sinus cardinal ne peuvent être calculées à l'aide des fonctions élémentaires. Il est habituel de définir une fonction spéciale, la fonction sinus intégral comme la primitive du sinus cardinal nulle en 0 : .

On démontre que l'intégrale [image] converge. Il s'agit de l'intégrale de Dirichlet, valant [image]. Cependant la fonction sinus cardinal n'est pas intégrable sur [image] au sens de Lebesgue (ni d'ailleurs à aucun autre sens, pas même à celui de l'intégrale de jauge), car la convergence n'est pas absolue ; en d'autres termes, on a [image].

Transformée de Fourier[ modifier | modifier le code ]

La transformée de Fourier du sinus cardinal est la fonction porte : où la fonction porte est définie de la manière suivante : .

La transformée de Fourier de la fonction porte telle que définie ci-dessus est également un sinus cardinal : .

Liens avec les fonctions spéciales[ modifier | modifier le code ]

Le sinus cardinal apparait dans l'expression des fonctions de Bessel sphériques de première espèce, en particulier,

Le sinus cardinal normalisé apparait dans la formule des compléments, qui peut se réécrire :

Utilisation et applications[ modifier | modifier le code ]

  • E. T. Whittaker a montré que la fonction sinus cardinal joue un rôle central dans la théorie de l'interpolation sur un réseau de points équidistants[1].
  • Étant donné que la transformée de Fourier de la fonction porte est très couramment utilisée, le sinus cardinal est forcément très présent, notamment en physique ondulatoire (car les phénomènes de diffraction de Fraunhofer sont traités par transformée de Fourier) ainsi qu'en traitement numérique du signal. Plus précisément, en théorie de la communication, la fonction sinus cardinal permet la synthèse exacte des signaux à spectre de support fini (formule de Shannon, 1949). En particulier, le sinus cardinal est fréquemment rencontré en théorie des antennes, en acoustique, en radar, pour la diffraction par une fente, etc.
  • La même idée est à la base de l’approximation sigma de Cornelius Lanczos.
  • On utilise également souvent le carré du sinus cardinal, car celui-ci donne l'intensité ou la puissance du signal dont l'amplitude est en sinus cardinal. Souvent, on cherchera à réduire l'influence des maxima secondaires du module (qui donne lieu à des lobes secondaires indésirables).
  • Étant donné que les valeurs décroissent rapidement, le carré de la fonction sinus cardinal est souvent représenté en échelle logarithmique.

Notes et références[ modifier | modifier le code ]

  1. ↑ Cf. Edmund Taylor Whittaker, « On the functions which are represented by the expansions of the interpolation theory », Proc. Royal Soc. of Edinburgh, no 35,‎ 1915, p. 181-194 ; et J. M. Whittaker, Interpolatory function theory, Londres, Cambridge University Press, coll. « Cambridge Tracts in Mathematics and Mathematical Physics »,‎ 1935.

Voir aussi[ modifier | modifier le code ]

Sur les autres projets Wikimedia :

  • Sinc, sur Wikimedia Commons

Articles connexes[ modifier | modifier le code ]

  • Traitement numérique du signal

Liens externes[ modifier | modifier le code ]

  • (en) Eric W. Weisstein, « Sinc Function », MathWorld
  • Portail de l’analyse Portail de l’analyse
  • Portail de la physique Portail de la physique
Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Sinus_cardinal&oldid=114754761 ».
Catégories :
  • Trigonométrie
  • Fonction remarquable
  • Fonction spéciale
Catégories cachées :
  • Article à référence nécessaire
  • Catégorie Commons avec lien local identique sur Wikidata
  • Portail:Analyse/Articles liés
  • Projet:Mathématiques/Articles
  • Portail:Physique/Articles liés
  • Portail:Sciences/Articles liés

Menu de navigation

Outils personnels

  • Créer un compte
  • Se connecter

Espaces de noms

  • Article
  • Discussion

Variantes

Affichages

  • Lire
  • Modifier
  • Modifier le code
  • Historique

Plus

Navigation

  • Accueil
  • Portails thématiques
  • Article au hasard
  • Contact

Contribuer

  • Débuter sur Wikipédia
  • Aide
  • Communauté
  • Modifications récentes
  • Faire un don

Imprimer / exporter

  • Créer un livre
  • Télécharger comme PDF
  • Version imprimable

Outils

  • Pages liées
  • Suivi des pages liées
  • Importer un fichier
  • Pages spéciales
  • Adresse de cette version
  • Information sur la page
  • Élément Wikidata
  • Citer cette page

Autres langues

  • Català
  • Čeština
  • Deutsch
  • English
  • Esperanto
  • Español
  • فارسی
  • עברית
  • Magyar
  • Italiano
  • 日本語
  • ភាសាខ្មែរ
  • 한국어
  • Nederlands
  • Polski
  • Português
  • Русский
  • Slovenčina
  • Svenska
  • Українська
  • Tiếng Việt
  • 中文
Modifier les liens
  • Dernière modification de cette page le 5 mai 2015 à 17:26.
  • Droit d'auteur : les textes sont disponibles sous licence Creative Commons paternité partage à l’identique ; d’autres conditions peuvent s’appliquer. Voyez les conditions d’utilisation pour plus de détails, ainsi que les crédits graphiques. En cas de réutilisation des textes de cette page, voyez comment citer les auteurs et mentionner la licence.
    Wikipedia® est une marque déposée de la Wikimedia Foundation, Inc., organisation de bienfaisance régie par le paragraphe 501(c)(3) du code fiscal des États-Unis.
  • Politique de confidentialité
  • À propos de Wikipédia
  • Avertissements
  • Développeurs
  • Version mobile
  • Powered by MediaWiki


Trigonométrie

Cosinus

Représentation graphique sur un intervalle de deux périodes de la fonction cosinus.

La fonction cosinus est une fonction mathématique d'un angle. Dans un triangle rectangle, le cosinus d'un angle est le rapport de la longueur du côté adjacent par la longueur de l'hypoténuse.

Le cosinus est habituellement cité en deuxième parmi les fonctions trigonométriques.

Les fonctions trigonométriques sont habituellement définies comme le rapport de deux côtés d'un triangle rectangle, et peuvent être définies de manière équivalente comme la longueur de différents segments sur le cercle unité. Les définitions plus modernes les caractérisent par des séries entières ou comme des solutions d'équations différentielles particulières, permettant leur extension à des valeurs arbitraires et aux nombres complexes.

La fonction cosinus est utilisée couramment pour modéliser des phénomènes périodiques comme les ondes sonores ou lumineuses ou encore les variations de température au cours de l'année.

Sommaire

  • 1 Définitions
    • 1.1 Définitions dans un triangle rectangle
    • 1.2 Définitions à partir du cercle unité
    • 1.3 Définitions à partir des séries entières
  • 2 Propriétés
    • 2.1 Réciproque
    • 2.2 Dérivée
    • 2.3 Intégrale
    • 2.4 Limites
    • 2.5 Valeurs remarquables
  • 3 Relation avec les nombres complexes
    • 3.1 Cosinus avec un argument complexe
  • 4 Note et références

Définitions

Définitions dans un triangle rectangle

Cosinus Â = Côté adjacent (noté a) / Hypoténuse (noté h)

Pour définir le cosinus d'un angle Â, noté cos Â, considérons un triangle rectangle arbitraire qui contient l'angle Â.

Cosinus de l'angle Â = Côté adjacent / Hypoténuse

Les côtés du triangle rectangle sont appelés :

  • l’hypoténuse : c'est le côté opposé à l'angle droit, une jambe de l'angle Â et le côté le plus long du triangle.
  • le côté opposé : c'est le côté opposé à l'angle Â qui nous intéresse.
  • le côté adjacent : c'est le côté qui est une jambe de l'angle Â, qui n'est pas l'hypoténuse.

On notera :

h : la longueur de l'hypoténuse,
a : la longueur du côté adjacent,

Alors :

cos Â = a / h

Ce rapport ne dépend pas du triangle rectangle particulier choisi, aussi longtemps qu'il contient l'angle, puisque tous ces triangles rectangles sont semblables.

Définitions à partir du cercle unité

cos w est égal à la longueur du segment indiqué en noir. Le segment rouge indique le rayon du cercle..

En trigonométrie, le cercle unité est le cercle de rayon 1 centré à l'origine (0, 0) d'un système de coordonnées cartésiennes.

Considérons l'intersection entre une droite passant par l'origine, faisant un angle w avec la moitié positive de l'axe x, et le cercle unité. Alors la composante horizontale de cette intersection est égale à

Animation montrant le graphique de y = cos(x) (où x est l'angle en radians) sur le cercle unité

Définitions à partir des séries entières

Le cosinus peut être défini à partir de la série entière, vraie pour tout x réel :

Ce développement peut s'obtenir de deux façons : en considérant le développement en série entière de la fonction exponentielle et en utilisant la formule d'Euler

ou en cherchant l'écriture sous forme de série entière du problème de Cauchy :

dont la fonction cosinus est l'unique solution.

Propriétés

Réciproque

Article détaillé : Fonction réciproque.

La fonction cosinus est 2π-périodique, il est donc impossible de définir une fonction réciproque sur toute la droite réelle. Aussi, on considère sa restriction sur [0,π], qui elle est bien bijective, et on définit alors la fonction réciproque arc cosinus :

qui vérifie donc

Dérivée[ modifier | modifier le code ]

La dérivée de la fonction cosinus est la fonction sinus multipliée par -1 :

Intégrale

Une primitive de cos est sin, ce qui s'écrit usuellement :

Limites

La fonction cosinus est continue en tout point, donc admet une limite pour tout x réel fini. Cependant, du fait de sa périodicité, les limites en ±∞ ne peuvent être définies.

Valeurs remarquables

Quelques angles communs (θ) sur le cercle unité. Les angles sont indiqués en degrés et en radians, ainsi que leur intersection avec le cercle unité (cos θ, sin θ).
x (angle) |  |  | ±cos x
Degrés | Radians | Grades | Exacte | Décimale
0° | 0 | 0g | 1 | 1
180° |  | 200g
15° |  | 16 2/3g |  | 0,965925826289068
165° |  | 183 1/3g
30° |  | 33 1/3g |  | 0,866025403784439
150° |  | 166 2/3g
45° |  | 50g |  | 0,707106781186548
135° |  | 150g
60° |  | 66 2/3g |  | 0,5
120° |  | 133 1/3g
75° |  | 83 1/3g |  | 0,258819045102521
105° |  | 116 2/3g
90° |  | 100g | 0 | 0
  • La racine de l'équation x - cos(x)=0 est un nombre remarquable : le nombre de Dottie.

Relation avec les nombres complexes

Cette section est vide, insuffisamment détaillée ou incomplète. Votre aide est la bienvenue !

Le cosinus est utilisé pour déterminer la partie réelle d'un nombre complexe z donné en coordonnées polaires, par son module r et son argument φ :

Cosinus avec un argument complexe

Valeurs de la fonction cosinus sur le plan complexe.

La fonction cosinus peut s'étendre sur le domaine complexe, où elle est une fonction entière :

Note et références

(en) Eric W. Weisstein, « Cosine », MathWorld


Trigonométrie

Cosinus intégral

La fonction cosinus intégral, notée Ci est définie par l'intégrale : où la fonction cos est la fonction cosinus.

Propriétés

  • La fonction est continue, infiniment dérivable sur [image], et
  • La fonction Ci admet le développement suivant sur [image] : où [image] est la constante d'Euler-Mascheroni. Ce développement permet d'étendre la fonction Ci en une fonction analytique définie sur tout le plan complexe privé de la demi-droite des réels négatifs. La somme de la série vaut également [image].
  • Les primitives de Ci(x) sont de la forme F(x) = x*Ci(x)-sin(x)+ k (k réel).

Voir aussi

  • Exponentielle intégrale
  • Logarithme intégral
  • Sinus intégral

Bibliographie

  • Abramowitz et Stegun, Handbook of Mathematical Functions.


Trigonométrie

Cosinus hyperbolique

Graphe de la fonction cosinus hyperbolique sur une partie de ℝ

Le cosinus hyperbolique est, en mathématiques, une fonction hyperbolique.

Sommaire

  • 1 Définition
  • 2 Propriétés
    • 2.1 Propriétés générales
    • 2.2 Propriétés trigonométriques
    • 2.3 Développement en série de Taylor
    • 2.4 Polynômes de Tchebychev
  • 3 Valeurs
  • 4 Zéros
  • 5 Fonction réciproque
  • 6 Utilisation
    • 6.1 Physique
    • 6.2 Architecture
  • 7 Voir aussi
  • 8 Notes et références

Définition

La fonction cosinus hyperbolique, notée cosh (ou ch)[1], est la fonction complexe suivante :

où [image] est l'exponentielle complexe.

La fonction cosinus hyperbolique est donc la partie paire de l'exponentielle complexe. Elle se restreint en une fonction réelle d'une variable réelle.

La fonction cosinus hyperbolique restreinte à ℝ est en quelque sorte l'analogue de la fonction cosinus dans la géométrie hyperbolique.

La notation Ch. x a été introduite par Vincenzo Riccati au XVIIIe siècle.

Propriétés

Propriétés générales

  • cosh est continue et même holomorphe donc de classe C∞ (i.e. infiniment dérivable). Sa dérivée est sinh, la fonction sinus hyperbolique.
  • cosh est paire.
  • Les primitives de cosh sont sinh + C, à une constante d'intégration C près.
  • cosh est strictement croissante sur ℝ+.

Propriétés trigonométriques

Des définitions des fonctions cosinus et sinus hyperboliques, on peut déduire les égalités suivantes, valables pour tout complexe z et analogues aux formules d'Euler en trigonométrie circulaire :

Quand t décrit ℝ, de même que le point de coordonnées (cos(t), sin(t)) parcourt un cercle d'équation x^2 + y^2 = 1, celui de coordonnées (cosh(t), sinh(t)) parcourt donc une branche d'une hyperbole équilatère d'équation x^2- y^2 = 1 .

D'autre part, pour tous nombres complexes x et y :

L'utilisation de formules trigonométriques telles que [image] permet aussi d'obtenir des relations plus anecdotiques, telle que (pour tout réel x) :

;

voir également l'article Gudermannien.

Développement en série de Taylor

La série de Taylor de la fonction [image] converge sur ℂ tout entier et est donnée par :

Polynômes de Tchebychev

Soit [image] le n-ième polynôme de Tchebychev, en prolongeant aux complexes la relation (vraie pour tout t réel) [image], on obtient pour tout t réel la relation

.

Valeurs

Quelques valeurs de cosh :

Zéros

Tous les zéros de [image] sont des imaginaires purs. Plus précisément, pour tout nombre complexe z,

En effet, soit [image] avec x,y réels. On a alors [image], donc

.

Fonction réciproque

Graphe de la fonction argument cosinus hyperbolique sur [1, +∞[

Sur [0, +∞[, cosh est continue et strictement croissante ; sa valeur en 0 est 1 et sa limite en +∞ est +∞. C'est donc une bijection de [0, +∞[ dans [1, +∞[. Sa bijection réciproque, notée arcosh (ou argch), est nommée argument cosinus hyperbolique.

Sur ℂ, il s'agit d'une fonction multivaluée complexe. Sa branche principale est généralement choisie en posant comme coupure la demi-droite ]–∞, 1].

Pour x∈ [1, +∞[, il existe deux réels dont le cosh vaut x : En effet, en posant t = arcosh(x) et en utilisant que cosh2t – sinh2t = 1 et t > 0, on obtient

La fonction arcosh est dérivable sur ]1, +∞[ et

Utilisation

Physique

La courbe représentative de la fonction cosh sur ℝ décrit une chaînette, c’est-à-dire la forme d'un câble fixé aux deux extrémités et soumis à la pesanteur.

L'arche du Gateway

Architecture

Le cosinus hyperbolique correspond en architecture à l'arc caténaire issu au départ de l'ingénierie des ponts suspendus. Antoni Gaudí a été l'un des premiers à l'utiliser massivement en architecture commune avec en particulier deux de ses œuvres les plus connues : la crypte de la Colonia Güell et la Sagrada Família.

L'arche du Gateway à Saint-Louis (Missouri) possède la forme d'une chaînette renversée. Elle s'élève à 192 m en son centre et enjambe 192 m à sa base. Les points de cette arche satisfont approximativement l'équation

pour -96 < x < 96.

Voir aussi

Sur les autres projets Wikimedia :

  • Fonction cosinus hyperbolique, sur Wikimedia Commons
  • Fonction argcosinus hyperbolique, sur Wikimedia Commons
  • Fonction hyperbolique
  • Sinus hyperbolique
  • Tangente hyperbolique


Trigonométrie

Cosinus hyperbolique réciproque

Le cosinus hyperbolique réciproque est, en mathématiques, une fonction hyperbolique.

Définition

La fonction cosinus hyperbolique réciproque, notée arcosh (ou argch)[1] est la fonction suivante :

Notes et références

  1. ↑ La norme ISO 31-11 recommande la notation « arcosh » pour cette fonction.


Trigonométrie

Tangente hyperbolique

Graphe de la fonction tangente hyperbolique sur une partie de ℝ

La tangente hyperbolique est, en mathématiques, une fonction hyperbolique.

Sommaire

  • 1 Définition
  • 2 Propriétés
    • 2.1 Propriétés générales
    • 2.2 Développement en série de Taylor
    • 2.3 Développement en fraction continue
  • 3 Valeurs
  • 4 Fonction réciproque
  • 5 Applications
  • 6 Notes et références
  • 7 Voir aussi

Définition

La fonction tangente hyperbolique, notée tanh (ou th)[1] est la fonction complexe suivante :

où [image] est la fonction sinus hyperbolique et [image] la fonction cosinus hyperbolique. Cette définition est analogue à celle de la fonction tangente comme rapport du sinus et du cosinus, et d'ailleurs, on a (pour tous les z du domaine de définition) [image], ou encore [image].

La tangente hyperbolique peut s'exprimer à l'aide de la fonction exponentielle :

Propriétés

Propriétés générales

  • Sur son domaine de définition, tanh est holomorphe (donc continue et même infiniment dérivable), de dérivée égale à
  • tanh est donc une solution de l'équation différentielle
  • Elle est périodique, de période iπ.
  • C'est une fonction impaire.
  • Elle vérifie la formule d'addition
  • Sa restriction à ℝ est une bijection strictement croissante de ℝ dans ]–1, 1[.
  • Sur ℝ, une primitive de tanh est ln ∘cosh.

Développement en série de Taylor

Le développement en série de Taylor en 0 de tanh s'exprime à l'aide des nombres de Bernoulli Bk, définis par la série entière suivante (de rayon de convergence 2π) :

Le rayon de convergence de cette série entière est π/2.

Démonstration

Ce développement se déduit immédiatement de celui, plus simple, de la fonction cotangente hyperbolique : pour 0 < |z| < π,

à l'aide de l'identité

Développement en fraction continue

La restriction de tanh à ℝ admet un développement en fraction continue généralisée [2] :

Valeurs

Quelques valeurs de tanh :

Fonction réciproque

La bijection réciproque de la restriction de tanh à ℝ, notée artanh (ou argtanh ou argth ou encore parfois tanh−1)[3], s'explicite par :

où ln désigne le logarithme naturel.

Plus généralement, la fonction tanh se restreint en une bijection de ℝ+i]–π/2, π/2[ dans ℂ\(]–∞, –1]∪[1, +∞[), dont la réciproque est décrite par :

où Log désigne la détermination principale du logarithme complexe.

En effet, pout tout z du domaine de définition de tanh, le complexe tanh(z) est l'image de u = e2z par la fonction u ↦ v = (u – 1)/(u + 1). Or cette fonction est une bijection de ℂ\{–1} dans ℂ\{1}, de réciproque v ↦ u = (1 + v)/(1 – v), et elle envoie ℂ\ℝ– sur ℂ\(]–∞, –1]∪[1, +∞[).

Applications

La fonction tangente hyperbolique passe graduellement d'une valeur –1 à une valeur 1. Elle peut donc être utilisée pour représenter un phénomène de transition progressive, « douce », entre deux états.

Certains phénomènes (physiques, économiques…) ne peuvent pas être décrits par une fonction unique sur tout le domaine d'étude. C'est le cas typiquement d'un matériau subissant des changements de phase dans le domaine de température et de pression étudié. On définit alors deux domaines conjoints (ou plus), et une fonction différente sur chaque domaine ; il peut s'agir d'une fonction ayant la même forme mais des paramètres différents. On a donc une fonction de la forme

la grandeur xt étant une constante, la valeur frontière.

Dans certains cas, ces fonctions à gauche et à droite ne se raccordent pas parfaitement : la fonction globale n'est alors pas dérivable, voire pas continue. En particulier, si les paramètres des fonctions ƒ1 et ƒ2 sont établis par régression sur des données mesurées, il n'y a pas de raccordement par construction (ƒ1(xt) ≠ ƒ2(xt)). Cet effet de seuil peut conduire à des problèmes calculatoires si cette fonction est utilisée pour résoudre numériquement (par ordinateur) un problème, typiquement résolution numérique d'une équation différentielle ou bien optimisation ; on peut alors avoir une instabilité numérique, un calcul itératif qui diverge.

Fonctions de transition.

Pour résoudre ce problème, et si les fonctions ƒ1 et ƒ2 sont définies sur tout l'ensemble d'étude, on peut glisser progressivement d'une fonction à l'autre en utilisant des « fonctions de transition » construites à partir d'une tangente hyperbolique : on définit deux fonctions g1 et g2 de la forme

où l est un facteur de largeur. On définit alors la fonction globale

.

Dans le cadre de la relativité restreinte, le calcul des transformations de Lorentz fait aussi appel à la fonction tangente hyperbolique[réf. souhaitée].

Notes et références

  1. ↑ La norme internationale ISO 80000-2:2009 recommande tanh
  2. ↑ J. H. Lambert, « Mémoire sur quelques propriétés remarquables des quantités transcendantes circulaires et logarithmiques », Mémoires de l'Académie des Sciences de Berlin, vol. 17,‎ 1761, p. 265-322 (lire en ligne).
  3. ↑ La norme ISO 80000-2:2009 (en) recommande artanh.

Voir aussi

Sur les autres projets Wikimedia :

  • les fonctions tangente hyperbolique et argtangente hyperbolique, sur Wikimedia Commons

Sigmoïde


Trigonométrie

Arc cosinus

Représentation graphique

En mathématiques, l’arc cosinus d'un nombre réel compris au sens large entre −1 et 1 est l'unique mesure d'angle dont le cosinus vaut ce nombre, entre l'angle nul et l'angle plat.

La fonction qui associe à tout nombre réel compris au sens large entre −1 et 1 la valeur de son arc cosinus en radians est notée arccos[1] (Acos en notation française, et cos−1, parfois acos ou acs, en notation anglo-saxonne).

Il s'agit alors de la réciproque de la fonction trigonométrique cosinus sur l'intervalle [0, π], et dans un repère cartésien (ortho)normé du plan, la courbe représentative de arc cosinus s'obtient à partir de la courbe de la restriction du cosinus par la réflexion d'axe la droite d'équation y = x
N.B. Dans la représentation graphique ci-contre, le repère n'est pas normé

Sommaire

  • 1 Dérivée
  • 2 Forme intégrale indéfinie
  • 3 Primitives
  • 4 Relation entre arc cosinus et arc sinus
  • 5 Forme logarithmique
  • 6 Voir aussi
  • 7 Notes et références

Dérivée

Comme dérivée d'une fonction réciproque, arccos est dérivable sur ]–1, 1[ et vérifie

Cette formule s'obtient grâce au théorème sur la dérivée d'une fonction réciproque.

Forme intégrale indéfinie

Cette fonction peut s'écrire sous la forme d'une intégrale indéfinie :

Primitives

Les primitives de l'arc cosinus s'obtiennent par intégration par parties :

Relation entre arc cosinus et arc sinus

arccos(x) (bleu) et arcsin(x) (rouge)
Preuve par la dérivée.

Soit f la fonction qui à x dans [–1, 1] associe [image] Sa dérivée, définie sur ]–1, 1[, est nulle :

donc f est constante sur ]–1, 1[, et même sur [–1, 1] par continuité. Donc :

Preuve trigonométrique.

Pour tout x dans [–1, 1], on pose

On calcule

Or [image] donc

Donc

Donc

Forme logarithmique

On peut exprimer la fonction arc cosinus avec un logarithme complexe :

Voir aussi

Sur les autres projets Wikimedia :

  • Fonctions circulaires réciproques, sur Wikiversity
  • Fonctions trigonométriques
  • Arc sinus
  • Arc tangente


Trigonométrie

Arc sinus

Représentation graphique

En mathématiques, l’arc sinus d'un nombre réel compris au sens large entre −1 et 1 est l'unique mesure d'angle dont le sinus vaut ce nombre, et comprise au sens large entre −π/2 et π/2.

La fonction qui associe à tout nombre réel compris au sens large entre −1 et 1 la valeur de son arc sinus en radians est notée arcsin[1] (Arc sin ou Asin en notation française, sin−1, asin ou asn en notation anglo-saxonne). Il s'agit alors de la bijection réciproque de la fonction sinus sur l'intervalle [-π/2, π/2].

Dans un repère cartésien (ortho)normé du plan, la courbe représentative de la fonction arc sinus est obtenue à partir de la courbe représentative de la restriction de la fonction sinus à l'intervalle [-π/2, π/2] par une réflexion d'axe la droite d'équation y = x.

Sommaire

  • 1 Dérivée
  • 2 Forme intégrale indéfinie
  • 3 Primitives
  • 4 Relation entre arc sinus et arc cosinus
  • 5 Forme logarithmique
  • 6 Voir aussi
  • 7 Notes et références

Dérivée

Comme dérivée d'une bijection réciproque, arcsin est dérivable sur ]−1, 1[ et vérifie

Cette formule s'obtient grâce au théorème sur la dérivée d'une bijection réciproque et à la relation

Forme intégrale indéfinie

Cette fonction peut s'écrire sous la forme d'une intégrale indéfinie :

Primitives

Les primitives de l'arc sinus s'obtiennent par intégration par parties :

arccos(x) (bleu) et arcsin(x) (rouge)

Relation entre arc sinus et arc cosinus

Voir section détaillée « Relation entre arc cosinus et arc sinus » de l'article « arc cosinus »

Forme logarithmique

On peut exprimer la fonction arc sinus avec un logarithme complexe :

Voir aussi

Sur les autres projets Wikimedia :

  • Fonctions circulaires réciproques, sur Wikiversity
  • Fonction trigonométrique
  • Arc cosinus
  • Arc tangente


Trigonométrie

Arc tangente

Représentation graphique

En mathématiques, l’arc tangente d'un nombre réel est la mesure d'un angle orienté dont la tangente vaut ce nombre.

La fonction qui à tout nombre réel associe la valeur de son arc tangente en radians est la réciproque de la restriction de la fonction tangente à l'intervalle ]-π/2, π/2[. La notation est arctan[1] (Atan, arctg en notation française ; atan ou tan-1, en notation anglo-saxonne, cette dernière pouvant être confondue avec la notation de l'inverse (1/tan).

Pour tout réel x :

Dans un repère cartésien (ortho)normé du plan, la courbe représentative de la fonction arc tangente est obtenue à partir de la courbe représentative de la restriction de la fonction tangente à l'intervalle ]-π/2, π/2[ par une réflexion d'axe la droite d'équation y = x.

Sommaire

  • 1 Parité
  • 2 Dérivée
  • 3 Développement en série de Taylor
  • 4 Équation fonctionnelle
  • 5 Fonction réciproque
  • 6 Logarithme complexe
  • 7 Intégration
    • 7.1 Primitive
    • 7.2 Utilisation de la fonction arctangente
  • 8 Formule remarquable
  • 9 Voir aussi
  • 10 Notes et références

Parité

La fonction arctan est impaire, c'est-à-dire que (pour tout x)

Dérivée

Comme dérivée d'une fonction réciproque, arctan est dérivable et vérifie :

Démonstration détaillée

On applique à f = tan le théorème de dérivée d'une fonction réciproque (d'une fonction dérivable dont la dérivée ne s'annule pas) :

qui, puisque [image] prouve que la dérivée de arctan existe et vaut :

Développement en série de Taylor

Le développement en série de Taylor de la fonction arc tangente[2] est :

Cette série entière converge vers arctan quand |x| ≤ 1 et x ≠ ±i. La fonction arc tangente est cependant définie sur tout ℝ (et même — cf. § « Fonction réciproque » — sur un domaine du plan complexe contenant à la fois ℝ et le disque unité fermé privé des deux points ±i).

Démonstration

La série entière

est nulle en 0, son rayon de convergence vaut 1, et sa dérivée (sur le disque unité ouvert) est égale à la série géométrique

Elle coïncide donc sur ce disque avec la fonction arctan. De plus, d'après la démonstration du test de Dirichlet (par sommation par parties), cette série entière converge uniformément sur le disque unité fermé privé d'un voisinage arbitrairement petit de ±i. En ±i, elle diverge comme la série harmonique.

Le développement en série peut être utilisé pour effectuer un calcul approché du nombre π : la formule la plus simple est le cas x = 1, appelée formule de Leibniz

La formule de Machin, plus sophistiquée,

fut utilisée par John Machin en 1706 pour calculer les 100 premières décimales de π et par William Shanks en 1873 pour calculer les 707 premières décimales, sur lesquelles seules 527 étaient justes.

Équation fonctionnelle

De Arctan( 1/x) on peut déduire Arctan(x) et inversement, par les équations fonctionnelles suivantes :

Démonstrations

Démontrons la première équation (la seconde s'en déduit par imparité, ou se démontre de même).

  • Une première méthode est de vérifier que la dérivée est nulle.

On a en effet :

et

donc

On en déduit que Arctan( 1/x) + Arctan(x) est constante sur ]0, +∞[, et l'on trouve facilement la valeur de cette constante en calculant par exemple la valeur prise en x = 1.

  • Une deuxième méthode est de remarquer que pour tout x > 0, si θ désigne l'Arctan de x alors
  • Une troisième méthode est de déduire cette formule de la formule remarquable ci-dessous en faisant tendre y vers 1/x par valeurs inférieures.

Fonction réciproque

Par définition, Arctan est la fonction réciproque de la restriction de la fonction tan à l'intervalle ]-π/2, π/2[ :

Ainsi, pour tout réel x, tan(Arctan(x)) = x. Mais l'équation Arctan(tan(y)) = y n'est vérifiée que pour y compris entre –π/2 et π/2.

Dans le plan complexe, la fonction tan est bijective de ]–π/2, π/2[+iℝ dans ℂ privé des deux demi-droites ]–∞, –1]i et [1, +∞[i de l'axe imaginaire pur, d'après son lien avec la fonction tangente hyperbolique et les propriétés de cette dernière. La définition ci-dessus de Arctan s'étend donc en :

Logarithme complexe

Par construction, la fonction arctangente est reliée à la fonction argument tangente hyperbolique et s'exprime donc, comme elle, par un logarithme complexe :

Intégration

Primitive[ modifier | modifier le code ]

La primitive de la fonction arc tangente qui s'annule en 0 est

Cette formule se démontre grâce à une intégration par parties.

Utilisation de la fonction arctangente

La fonction arc tangente joue un rôle important dans l'intégration des expressions de la forme

Si le discriminant D = b2 – 4ac est positif ou nul, l'intégration est possible en revenant à une fraction partielle. Si le discriminant est strictement négatif, on peut faire la substitution par

qui donne pour l'expression à intégrer

L'intégrale est alors

Formule remarquable

où

Démonstration

Supposons xy ≠ 1 et posons a = Arctan x, b = Arctan y. Alors,

Il suffit pour conclure de remarquer que a + b appartient à


Trigonométrie

Al-Battani

Crystal Clear app fonts.svg Cette page contient des caractères spéciaux ou non latins. Si certains caractères de cet article s’affichent mal (carrés vides, points d’interrogation…), consultez la page d’aide Unicode.

Al-Battani (env. 855- 923) était un astronome et mathématicien du sud-est de l'Anatolie (on écrit aussi Al Batani, et en latin : Albategnius, Albategni, Albatenius ; nom complet : Abū ʿAbdullāh Muḥammad ibn Jābir ibn Sinān ar-Raqqī al-Ḥarrani aṣ-Ṣabiʾ al-Battānī), né à Harran près d' Urfa en Turquie. Son épithète as-Sabi suggère que ses ancêtres étaient membres de la secte des Sabéens qui adoraient les étoiles, comme son contemporain et originaire de la même ville Thābit ibn Qurra, mais son nom complet affirme qu'il était musulman. On le désigne parfois comme le « Ptolémée des Arabes ».

Al-Battani a travaillé en Syrie, à Ar-Raqqa et à Damas où il est mort.

Son œuvre majeure, le Kitāb az-Zīj al-Sabi (le « Livre des tables sabéennes ») composé de 57 chapitres, traduit en latin sous le titre de De Motu Stellarum par Platon de Tivoli (Plato Tiburtinus) en 1116 (imprimé en 1537 par Melanchthon, annoté par Regiomontanus), a considérablement influencé l' astronomie européenne. Une réédition apparut à Bologne en 1645. Le manuscrit original de Platon est conservé à la bibliothèque du Vatican. La bibliothèque de l'Escorial possède un manuscrit de chronologie astronomique d'al-Battani.

Un cratère lunaire porte le nom Albategnius en son honneur.

Astronomie

Il a corrigé certains calculs de Ptolémée et il a produit de nouvelles tables pour le Soleil et pour la Lune, qui ont longtemps fait autorité. Il a aussi traité la division de la sphère céleste. Il a découvert le mouvement de l' apogée du Soleil, calculé les valeurs de la précession des équinoxes (54,5" par an) et l'inclinaison de l'axe terrestre (23° 35').

Copernic dans son célèbre ouvrage revolutionibus orbium coelestium rédigé en 1543 se réfère à Al-Battani le citant sous le nom latin de Machometi Aracenfis ce qui indique qu'il s'est largement inspiré de ce savant musulman du IX e siècle.

Mathématiques

Probablement sans connaître les travaux de l'astronome indien du V e siècle Âryabhata, il a introduit l'usage du sinus dans les calculs, et en partie celui de la tangente, formant ainsi les bases de la trigonométrie moderne.

Il a utilisé les idées d' al-Marwazi sur les tangentes (ou « ombres ») pour développer des méthodes de calcul des tangentes et des cotangentes, et il en a dressé des tables.

Il a créé plusieurs formules trigonométriques :

Il a aussi résolu l'équation

en la traduisant par l'équation suivante:

Liens externes

  • Notices d’autorité : Fichier d’autorité international virtuel • International Standard Name Identifier • Bibliothèque nationale de France • Système universitaire de documentation • Bibliothèque du Congrès • Gemeinsame Normdatei • WorldCat
v · m Les grandes figures de l’ Âge d'or islamique
au VIII e siècle | Jabir Ibn Hayyan · Aboû Nouwâs
au IX e siècle | Al-Battani · Abbas Ibn Firnas · Al-Hallaj · Abu Kamil · Al-Kindi · Al-Khwârizmî · Al-Marwazi · Al-Razi · Tabari
au X e siècle | Ibn Fadlân · Al-Fârâbî · Ibn al-Nadim · Al-Mas'ûdî · Abu Al-Qasim · Ibrahim ibn Sinan · Al-Soufi · Aboûl-Wafâ
au XI e siècle | Alhazen · Avicenne · Al-Bakri · Al-Biruni · Al-Ghazâlî · Ibn Hazm · Ibn Jazla · Omar Khayyam · Al-Maari
au XII e siècle | Avempace · Averroès · Al-Djazari · Al Idrissi · Abou Madyane · Ibn Tufayl
au XIII e siècle | Ibn Arabî · Farid al-Din Attar · Ibn al-Baitar · Ibn Nafis · Djalâl ad-Dîn Rûmî · Saadi · Ibn Taymiyya · Nasir ad-Din at-Tusi
au XIV e siècle | Ibn Battûta · Ibn Khaldoun · Ibn al-Khatib · Qadi-zadeh Roumi
au XV e siècle | Al-Kashi · Ali Qushji
au XVI e siècle et au XVII e siècle | Taqi al-Din · Al Maqqari · Sinan · Hassan al-Wazzan


Trigonométrie

Angle

En géométrie, la notion générale d'angle se décline en plusieurs concepts apparentés.

Dans son sens ancien, l'angle est une figure plane, portion de plan délimitée par deux droites sécantes. C'est ainsi qu'on parle des angles d'un polygone. Cependant, l'usage est maintenant d'employer le terme « secteur angulaire » pour une telle figure. L'angle peut désigner également une portion de l'espace délimitée par deux plans (angle dièdre). La mesure de tels angles porte couramment mais abusivement le nom d'angle elle aussi.

En un sens plus abstrait, l'angle est une classe d'équivalence, c'est-à-dire un ensemble obtenu en assimilant entre eux tous les angles-figures identifiables par isométrie. L'une quelconque des figures identifiées est alors appelée représentant de l'angle. Tous ces représentants ayant même mesure, on peut parler de mesure de l'angle abstrait.

Il est possible de définir une notion d'angle orienté en géométrie euclidienne du plan, ainsi que d'étendre la notion d'angle au cadre des espaces vectoriels préhilbertiens ou des variétés riemanniennes.

Le mot angle dérive du latin angulus, le coin.

Sommaire

  • 1 L'angle comme figure du plan ou de l'espace
    • 1.1 Secteur angulaire et angle
    • 1.2 Valeur d'un angle
    • 1.3 Nom des angles
  • 2 Angle géométrique
  • 3 Angles orientés dans le plan
  • 4 Angles orientés de vecteurs
    • 4.1 Rotations vectorielles
    • 4.2 Un angle orienté de vecteurs est une classe d'équivalence
    • 4.3 Les angles orientés de vecteurs forment un groupe
      • 4.3.1 Somme d'angles orientés
    • 4.4 Enfin une vraie mesure d'angles
      • 4.4.1 Effet des isométries sur les angles orientés de vecteurs
  • 5 Angles dans l'espace
  • 6 Usage
  • 7 Notes et références
  • 8 Voir aussi
    • 8.1 Articles connexes
    • 8.2 Liens externes

L'angle comme figure du plan ou de l'espace

Secteur angulaire et angle

secteurs angulaires obtenus par intersection des demi-plans délimités par des droites sécantes

Un secteur angulaire est une figure plane obtenue par intersection ou réunion de deux demi-plans délimités par des droites sécantes ou confondues.

L'angle d'un secteur angulaire est le nombre réel positif qui mesure la proportion du plan occupée par le secteur angulaire. Les unités utilisées pour le quantifier sont le radian, le quadrant et ses subdivisions le degré, ses sous-unités et le grade. Les angles sont fréquemment notés par une lettre grecque minuscule, par exemple α, β, θ, ρ... Lorsque l'angle est au sommet d'un polygone et qu'il n'y a pas d'ambiguïté, on utilise alors le nom du sommet surmonté d'un chapeau, par exemple Â.

L'angle peut aussi s'interpréter comme l'ouverture du secteur angulaire, c'est-à-dire la « vitesse » à laquelle s'éloignent les droites l'une de l'autre lorsque l'on s'éloigne du point d'intersection. C'est la mesure de l'inclinaison d'une droite par rapport à l'autre.

Valeur d'un angle

Définition des angles par la proportion d'une portion de disque centré sur l'intersection des droites

Pour évaluer cet angle, cette « proportion de surface », on prend un disque centré au point d'intersection, et on effectue le rapport entre l'aire de la portion de disque interceptée par le secteur angulaire et l'aire totale du disque. On peut montrer que cela revient également à faire le rapport entre la longueur de l'arc intercepté et la circonférence du cercle ; cette valeur inférieure à 1 est appelée nombre de tour. La valeur 1/4 (quart de tour) correspond au quadrant.

Une unité couramment utilisée est le degré, qui est le résultat de la division du quadrant en 90 parts égales. Le tour complet correspond donc à 360 degrés. La minute d'arc est un sous-multiple du degré, égale à 1/60 de degré. De même, la seconde d'arc est égale à 1/60 de la minute d'arc, soit 1/3600 de degré. On utilise plus rarement le grade, qui correspond à une subdivision centésimale du quadrant.

Définition du radian, unité de mesure de l'angle

L'unité internationale de mesure des angles est cependant le radian, défini comme le rapport entre la longueur de l'arc intercepté et le rayon du cercle. Le tour complet correspond donc à [image] radians.

Les angles peuvent être calculés à partir des longueurs des côtés de polygones, notamment de triangles, en utilisant la trigonométrie.

L'unité de mesure des angles utilisée principalement par les militaires est le millième. Il est l'angle sous lequel on voit 1 mètre à 1 kilomètre. 6283 millièmes correspond à 2π radians ou 360 degrés, soit 360 °/arctan(1 m/1000m). Autrement-dit, millième = mrad (milliradian).

« Sur le terrain », les angles peuvent être mesurés avec un appareil appelé goniomètre ; il comporte en général une règle courbe graduée en degrés, appelée rapporteur.

Nom des angles

Les angles correspondant à un nombre entier de quadrants portent un nom particulier

Valeur des angles particulier dans les diverses unités
angle | nombre de tours | nombre de quadrants | radians | degré | grade
angle plein | 1 tour | 4 quadrants | 2π rad | 360° | 400 gr
angle plat | 1/2 tour | 2 quadrants | π rad | 180° | 200 gr
angle droit | 1/4 de tour | 1 quadrant | π/2 rad | 90° | 100 gr
angle nul | 0 tour | 0 quadrant | 0 rad | 0° | 0 gr

L'angle droit est obtenu en considérant deux droites qui divisent le plan en quatre secteurs égaux. De telles droites sont dites « orthogonales » ou « perpendiculaires ».

Définition des angles droit, plat, complémentaires et supplémentaires.

Les qualificatifs suivant sont employés pour les angles prenant des valeurs intermédiaires entre ces valeurs remarquables :

  • l'angle rentrant est un angle supérieur à l'angle plat ;
  • l'angle saillant est un angle inférieur à l'angle plat ;
  • l'angle obtus est compris entre 90° et 180° ;
  • l'angle aigu est compris entre 0° et 90°.

Pour qualifier les valeurs relatives de deux angles, on emploie les expressions suivantes :

  • deux angles sont complémentaires quand leur somme fait 90 ° ; si deux angles sont complémentaires, chacun est dit être le complément de l'autre ;
  • deux angles sont supplémentaires quand leur somme fait 180 °.

On emploie encore d'autres expressions pour qualifier la position des angles sur une figure, c'est-à-dire plus justement, la position relative de secteurs angulaires :

  • deux secteurs angulaires sont opposés par le sommet, lorsqu'ils ont le même sommet et que les côtés de l'un sont dans le prolongement de ceux de l'autre. Dans ce cas les angles correspondants sont égaux.
  • deux secteurs angulaires sont adjacents lorsqu'ils ont le même sommet, un côté commun, et que leur intersection est égale à ce côté commun. Les angles s'ajoutent lorsqu'on considère la réunion de ces secteurs.
  • les angles alternes-externes et les angles alternes-internes sont formés par deux droites coupées par une sécante. Ces angles ont la même mesure lorsque les deux droites sont parallèles.

Remarque, deux angles complémentaires ou supplémentaires ne sont pas nécessairement adjacents : Par exemple, dans un triangle ABE rectangle en B, les angles Â et Ê sont complémentaires.

Par extension, on définit également les angles entre des demi-droites, des segments de droite et des vecteurs, en prolongeant les droites portant ces objets jusqu'à leur intersection. La définition par des demi-droites ou des vecteurs permet de lever l'indétermination entre les angles supplémentaires, c'est-à-dire de définir sans ambiguïté quel secteur angulaire utiliser pour définir l'inclinaison des directions.

Angle géométrique

Un angle géométrique est un objet mathématique pouvant être représenté par un secteur angulaire. On peut l'interpréter de plusieurs façons : divergence entre deux directions, directions des faces d'un objet (coin), direction visée par rapport au nord (angle donné par une boussole)…

est un angle géométrique.

On a par ailleurs :

On confond fréquemment « mesure de l'angle » et « angle ». Ainsi par exemple un angle « plat » est appelé abusivement angle « égal » à 180.

Cet abus est appliqué largement dans la suite de cet article.

D'autre part un angle droit par exemple, peut être représenté par plusieurs secteurs angulaires différents, mais comme ils sont tous « superposables », ils représentent tous le même angle. En mathématiques on parle de « classe d'équivalence ».

Angles orientés dans le plan

Si le plan est orienté, un même angle peut être déclaré aussi bien positif que négatif, selon le sens dans lequel on « tourne » du premier vecteur au second. Par convention, on oriente le plan dans le sens dit « trigonométrique », c'est-à-dire dans le sens inverse des aiguilles d'une montre (ou « sens anti-horaire »). Si l'on considère deux demi-droites ou vecteurs, alors l'ordre dans lequel on cite les demi-droites ou les vecteurs définit le sens de l'angle, donc son signe ; ainsi :

Angles orientés : l'orientation du plan permet de donner un signe à l'angle ; l'illustration souligne l'égalité en alpha et alpha-2π

Les angles sont définis à un nombre entier de tours près. Ainsi, le plan complet peut être défini par un tour complet dans le sens positif, deux tours complets dans le sens positif, un tour complet dans le sens négatif... En radians, on dit que les angles sont définis à 2π près (« à-deux-pi-près »). Par exemple, si l'angle α est droit de sens direct, il est noté :

ou bien

Cette dernière notation se lit : « alpha est congru à pi-sur-deux modulo deux-pi ».

On remarque notamment que pour deux demi-droites (ou deux vecteurs) données, le fait de choisir la « petite » ou la « grande » portion de plan importe peu, puisque α ≡ α - 2π (cf. illustration ci-dessus).

Angles orientés de vecteurs

Rotations vectorielles

Rappelons à leur sujet deux points cruciaux pour la suite :

  • Les isométries positives du plan sont, parmi les transformations préservant les longueurs, celles dont le déterminant vaut 1. Ce sont les rotations vectorielles planes. Elles forment le sous-groupe commutatif SO(2) du groupe orthogonal O(2) du plan.
  • Proposition.—Si u et v sont deux vecteurs unités distincts, il existe une unique rotation f envoyant u sur v. D'où une application T : (u,v) → f, des couples de vecteurs unitaires vers les rotations.

Un angle orienté de vecteurs est une classe d'équivalence

  • En disant que (u,v)R(u',v') s'il existe une rotation g telle que u'=g(u) et v'=g(v), on définit une relation d'équivalence R sur les couples de vecteurs unitaires. On appelle angle orienté de vecteurs les classes d'équivalence dans cette relation. En confondant abusivement un représentant et sa classe, on a par exemple : (-u,-v) = (u,v) par le demi-tour.
  • L'application T : (u, v)→ f « passe au quotient par R » et l'application S obtenue, des classes de R-équivalence vers les rotations, est bijective. Autrement dit :

Théorème — L'angle orienté de vecteurs est caractérisé par la rotation associée : T(u,v) = T(u',v') si et seulement si (u,v)R(u',v').

Démonstration

Par définition, (u,v)R(u',v') si et seulement si la rotation qui envoie u sur u' est la même que celle qui envoie v sur v', autrement dit : T(u,u')=T(v,v'). Par commutativité du groupe des rotations, ceci équivaut à T(u',v)oT(u,u')=T(v,v')oT(u',v), i.e. T(u,v)=T(u',v').

Le choix de l'une des deux orientations du plan détermine l'un des deux isomorphismes du groupe SO(2) des rotations avec le groupe U des nombres complexes de module 1. L'exponentielle complexe permet alors de définir l'angle d'une rotation à 2π près. Si f=T(u,v) est une rotation d'angle [image], on dira aussi que [image] est une mesure de l'angle orienté de vecteurs (u,v). Pour être digne d'un tel nom, il manque à cette mesure le caractère additif. Avec les angles géométriques, on a des ennuis additifs quand ils sont trop grands ! Pour les angles orientés de vecteurs, il faut d'abord définir la somme...

Les angles orientés de vecteurs forment un groupe

Somme d'angles orientés

La somme est définie en tirant en arrière le long de la bijection S la composition dans SO(2). En confondant un représentant avec sa classe, cela donne :

  • Le groupe des angles orientés de vecteurs est commutatif, comme SO(2).
  • Avec T(u,v)oT(v,w)=T(u,w) on obtient pour les angles la relation de Chasles (u,v)+(v,w)=(u,w)
  • L'angle plein correspond à l'identité : (u,u) = 0
  • (v,u)+(u,v) = (v,v) = 0 et donc (v,u) est l'opposé de (u,v)
  • L'angle plat est la moitié d'un plein : (-Id) o (-Id) = Id. L'angle plat s'écrit donc (u,-u).
  • Il y a deux angles droits, solutions de 2(u, v) = (u, –u)[1].

Enfin une vraie mesure d'angles

Une orientation du plan étant choisie, la mesure d'un angle orienté de vecteurs est définie par :

,

où la matrice est celle de T(u,v) dans n'importe quelle base orthonormée directe.

C'est un isomorphisme du groupe des angles orientés dans le groupe additif des « réels modulo 2π » ; ainsi la mesure des angles est enfin additive !

Effet des isométries sur les angles orientés de vecteurs

  • Les isométries positives conservent les angles orientés de vecteurs par construction.
  • Les réflexions orthogonales (isométries planes indirectes) renversent les angles orientés de vecteurs : si u et v sont deux vecteurs unitaires non opposés, la réflexion sD d'axe D dirigé par u+v échange u et v et donc (u,v) en son opposé (v,u). Toute réflexion s'obtient en composant sD avec une rotation (on fait tourner l'axe) ; une telle réflexion renverse encore l'angle (u,v).

Angles dans l'espace

Deux droites sécantes sont nécessairement coplanaires, donc l'angle entre les droites est défini dans ce plan, de la même manière que ci-dessus. Pour orienter le plan, on choisit un vecteur normal au plan : le plan est alors orienté dans le sens trigonométrique lorsque le vecteur normal pointe vers l'observateur. Si l'on a défini une base [image] dans ce plan, alors on choisit pour vecteur normal [image].

orientation d'un plan par un vecteur normal
Orientation d'un plan par un vecteur normal

Pour définir l'angle entre deux plans, on considère l'angle que font leurs vecteurs normaux.

Pour définir l'angle entre un plan et une droite, on considère l'angle α entre la droite et sa projection orthogonale sur le plan, ou encore l'angle complémentaire entre la droite et la normale au plan : on retranche l'angle β entre la droite et la normale au plan de l'angle droit (α = π/2 - β en radians).

Pour définir l'angle entre deux droites quelconques de l'espace, on considère l'angle que font leurs vecteurs directeurs (dont le cosinus est égal au produit scalaire de ces vecteurs unitaires), ou encore l'angle planaire que fait une des deux droites avec une quelconque parallèle à l'autre qui la coupe. Cet angle est défini modulo les mêmes choix d'orientation évoqués ci-dessus.

On définit également les angles solides : on prend un point (parfois appelé « point d'observation ») et une surface dans l'espace (la « surface observée »), l'angle solide est la proportion de l'espace délimitée par le cône ayant pour sommet le point considéré et s'appuyant sur le contour de la surface. L'unité est le stéradian (sr en abrégé), l'espace complet fait 4π sr.

Usage

  • En géodésie (géographie)
    • azimut : angle par rapport à l'axe Nord-Sud sur un plan contenant cet axe et le point visé, compté par rapport au Nord compté dans le sens des aiguilles d'une montre ;
    • latitude : angle que fait une verticale partant d'un point et allant au centre de la Terre par rapport au plan de l'équateur ; les points ayant la même latitude forment un cercle[2] appelé « parallèle »
    • longitude : angle permettant de se repérer sur Terre : angle que fait le plan contenant l'axe Nord-Sud et le point considéré (appelé « plan méridien ») avec un plan de référence contenant aussi l'axe Nord-Sud ; l'intersection d'un plan méridien avec la surface de la Terre est un demi grand-cercle [2] appelé méridien ; le méridien de référence est le méridien de Greenwich
    • droite de hauteur : position d'un point calculé (comprenant azimuth et différence angulaire) par rapport à un point estimé
    • pente : tangente de l'angle d'un terrain vis-à-vis de l'horizontale
  • En astronomie
    • azimut (ou azimuth) : lorsque l'on vise un point depuis le centre de la Terre, angle par rapport à l'axe Nord-Sud sur un plan contenant cet axe et le point visé, compté par rapport au Sud
    • diamètre apparent : angle sous lequel on voit un objet ou un astre
    • distance zénithale : angle entre la verticale et le point visé
    • hauteur : angle entre l'horizontale et le point visé
    • inclinaison : angle entre le plan de l'orbite d'un corps céleste et le plan de référence
    • parallaxe : angle formé par le regard d'une personne qui fixe un point quelconque d'un objet et son changement de position
    • nadir : angle droit vers le bas verticalement par rapport au tour de l'horizon de l'observateur
    • zénith : angle droit vers le haut verticalement par rapport au tour de l'horizon de l'observateur
Par ailleurs, la notion d'angle permet de définir une unité de longueur, le parsec
  • En optique géométrique
    • angle d'incidence : angle entre un vecteur et le vecteur de la surface, par exemple en réflexion et en réfraction, angle entre un rayon lumineux et la normale à la surface d'un dioptre
    • parallaxe
  • En aérodynamique :
    • angle d'attaque
    • assiette
  • En balistique
    • hausse
  • Angle mort

Notes et références

  1. ↑ Michèle Audin, Géométrie (L3M1), EDP Sciences,‎ 2006, 3e éd. (ISBN 2-86883-883-9, lire en ligne), p. 76.
  2. ↑ a et b On suppose ici que la Terre est sphérique, ce qui n'est pas tout à fait vrai : sa forme générale est légèrement aplatie aux deux pôles, et sa surface présente des aspérités (fosses océaniques, montagnes).

Voir aussi

Sur les autres projets Wikimedia :

  • angle, sur le Wiktionnaire

Articles connexes

  • Angle (télédétection)
  • Angulation
  • Angle trièdre
  • Coordonnées polaires
  • Géométrie euclidienne
  • Géométrie vectorielle
  • Orientation
  • Trigonométrie
  • Bissectrice
  • Théorème de la bissectrice
  • Cercle unité
  • Système de coordonnées équatoriales

Liens externes

  • (en) Définitions, sur le site mathopenref.com
  • (en) David A. Wallis History of Angle Measurement, Proceedings, FIG Workshop Week 2005 & 8th International Conference on the Global Spatial Data Infrastructure, Le Caire, Égypte, avril 2005 [PDF]


Trigonométrie

Applications de la trigonométrie

Les applications de la trigonométrie sont nombreuses et très variées. Les applications mentionnées explicitement dans les manuels et les cours sur la trigonométrie sont souvent des utilisations pratiques, notamment en navigation, pour l' orientation, pour l' arpentage, pour la construction d'édifices… Elle est également employée dans certains domaines d'étude ou de recherche, principalement en mathématiques, en physique et en technologie. Pour les non scientifiques, la trigonométrie est connue principalement pour ses applications aux problèmes de mesure, cependant elle est aussi souvent employée dans des matières insoupçonnées comme en théorie de la musique ou en théorie des nombres de manière encore plus technique. Les branches des mathématiques de l'étude des séries de Fourier et des transformations de Fourier, comptant fortement sur la connaissance des fonctions trigonométriques, trouvent des applications dans un certain nombre de secteurs, incluant les statistiques.

Sommaire

  • 1 Domaines auxquels la trigonométrie s'applique
  • 2 Interaction de ces domaines avec la trigonométrie
  • 3 Séries de Fourier
  • 4 Les transformations de Fourier
  • 5 Statistiques
  • 6 Une simple expérience avec des lunettes polarisées
  • 7 Théorie des nombres
  • 8 Exponentielles complexes

Domaines auxquels la trigonométrie s'applique

Les domaines scientifiques utilisant la trigonométrie sont :

l' acoustique, l' architecture, l' astronomie (et ainsi la navigation, sur les océans, dans les airs et dans l'espace ; voir l'article Distance du grand cercle), la biologie, la cartographie, la chimie, le génie civil, l' infographie, la géophysique, la cristallographie, les sciences économiques (en particulier dans l'étude des marchés financiers), l' électrotechnique, l' électronique, la topographie et la géodésie, beaucoup de sciences physiques, la construction mécanique, l' imagerie médicale ( tomographie axiale calculée et ultrasons), la météorologie, la théorie de la musique, la théorie des nombres (et par conséquent la cryptographie), l' océanographie, l' optique, la pharmacologie, la phonétique, la théorie des probabilités, la psychologie, la séismologie, les statistiques, et la perception visuelle.

Interaction de ces domaines avec la trigonométrie

Le fait que ces domaines utilisent la trigonométrie ne signifie pas que la connaissance de la trigonométrie soit requise pour pouvoir les aborder. Cela signifie que certains points dans ces domaines ne peuvent pas être compris sans la trigonométrie. Par exemple, un professeur de musique pourrait éventuellement ne rien connaître des mathématiques, mais savoir que Pythagore fut l'un des premiers à avoir apporté sa contribution à la théorie mathématique de la musique.

Dans certains des domaines listés juste avant il est facile d'imaginer comment la trigonométrie pourrait être employée. Par exemple, en navigation et en arpentage, les utilisations de la trigonométrie sont limitées à des cas simples, et ne requièrent que des connaissances figurant dans un manuel de trigonométrie pour débutant. Dans le cas de la théorie de la musique, l'application de la trigonométrie est liée au travail commencé par Pythagore, qui observa que les sons obtenus en pinçant deux cordes de différentes longueurs sont plus harmonieux lorsque les deux longueurs sont des petits multiples entiers d'une longueur commune. La ressemblance entre la forme d'une corde vibrante et une sinusoïde n'est pas un hasard. En océanographie, la ressemblance entre la forme de certaines vagues et une sinusoïde n'est non plus le fruit du hasard. Dans d'autres domaines, notamment en climatologie, en biologie, et en sciences économiques, il existe des périodicités saisonnières. L'étude de ces dernières implique souvent la nature périodique des fonctions sinus et cosinus.

Séries de Fourier

Beaucoup de domaine se servent de la trigonométrie d'une manière si avancée qu'il est impossible d'en discuter dans un simple article. Souvent ces utilisations font intervenir des outils appelés série de Fourier, et qui portent le nom du mathématicien et physicien français des XVIII e et XIX e siècles Joseph Fourier. Les séries de Fourier possèdent une très grande variété d'applications dans beaucoup de domaines scientifiques, en particulier dans tous les phénomènes impliquant des périodicités saisonnières mentionnées ci-dessus, dans les mouvements ondulatoires, et par conséquent dans l'étude des radiations, en acoustique, en sismologie, dans la modulation des ondes radios en électronique, et dans la technologie de l'énergie électrique.

Une série de Fourier est une somme de la forme:

où chacun des carrés ( [image]) représente un certain nombre appelé coefficient, et les trois petits points signifient que des termes sont ajoutés une infinité de fois. Fourier employa ces séries pour étudier les flux de chaleur l'écoulement et la diffusion de la matière (la diffusion est le processus par lequel, lorsque vous laissez tomber un morceau de sucre dans un verre d'eau, le sucre se répartit graduellement par l'eau, (ou lorsqu'un polluant se propage dans l'air, ou n'importe quelle substance dissoute se répand dans n'importe quel fluide).

Les séries de Fourier s'appliquent également à des sujets d'étude dont le lien avec les mouvements ondulatoires est loin d'être évident. Un exemple omniprésent est la compression numérique par laquelle des données images, les audios et vidéos sont compressées dans une taille beaucoup plus petite rendant possible leur transmission via le téléphone, les Émissions de télévision ou de radio, et les réseaux informatiques.

Un autre exemple, mentionné ci-dessus, est la diffusion de la matière.

Parmi tant d'autres, il y a aussi: la géométrie des nombres, les problèmes isopérimétriques, les répétitions dans une promenade aléatoire, la réciprocité quadratique, le théorème de la limite centrale, l' inégalité d'Heisenberg.

Les transformations de Fourier

Un concept plus abstrait que les séries de Fourier est la notion de transformée de Fourier. Les transformées de Fourier font intervenir des intégrales plutôt que des sommes, et sont employées dans un aussi grand nombre de domaines scientifiques variés. Beaucoup de lois naturelles expriment une relation entre une variation de quantités et les quantités elles-mêmes.

Par exemple: le taux de changement d'une population est parfois conjointement proportionnel à la population actuelle et à la part de la population pour laquelle la capacité de transport fait défaut. Ce genre de rapport s'appelle une équation différentielle. Si ces informations sont fournies, alors nous pouvons essayer d'exprimer la population en fonction du temps, et de « résoudre » l'équation. Les transformations de Fourier peuvent être employées pour convertir certaines équations différentielles en équations algébriques pour lesquelles des méthodes de résolution sont connues. Les transformations de Fourier ont beaucoup d'applications. Dans presque n'importe quel contexte scientifique dans lequel figurent les mots spectre, harmonique, ou résonance, les transformations de Fourier ou les séries de Fourier ne sont pas loin.

Statistiques

Certains psychologues ont affirmé que les quotients intellectuels d'une population étaient répartis selon une loi normale. Environ 40 % de l'aire sous la courbe se trouve dans l'intervalle de 100 à 120 ; également, environ 40 % des individus de la population ont obtenu entre 100 et 120 à des examens de QI. Environ 9 % de l'aire sous la courbe se trouve dans l'intervalle de 120 à 140 ; également, environ 9 % des individus de la population ont obtenu entre 120 et 140 à des examens de QI, etc. De même beaucoup d'autres choses sont distribuées selon une « courbe gaussienne », y compris les erreurs de mesure de quantités physiques. Pourquoi cette omniprésence des « gaussiennes » ? Il y a une raison théorique à cela, et elle invoque les transformées de Fourier et par conséquent les fonctions trigonométriques. Il s'agit de l'une des nombreuses applications de la transformée de Fourier aux statistiques.

Les fonctions trigonométriques sont également appliquées lorsque les statisticiens étudient les périodicités saisonnières, qui sont souvent représentées par des séries de Fourier.

Une simple expérience avec des lunettes polarisées

Prenons deux paires de lunettes de soleil identiques avec des verres polarisés (des lunettes de soleil non polarisées ne conviennent pas pour cette expérience). Plaçons la lentille gauche d'une paire sur la lentille droite de l'autre, toutes les deux alignées de la même façon. Tournons lentement une paire, et observons la quantité de lumière les traversant diminuer jusqu'à ce que les deux lentilles soient à angle droit quand aucune lumière ne passe plus. Quand l'angle duquel une paire est tournée est θ, quelle est la fraction de la lumière pénétrant dans les lentilles pour un angle nul qui passe à travers ? Réponse : c'est cos2 θ. Par exemple, quand l'angle est de 60 degrés, seulement une fraction de 1/4 de la quantité de lumière quand l'angle est de 0 degré pénètre dans la série de deux lentilles, puisque le cosinus de 60 degrés est égal à 1/2.

Théorie des nombres

Il y a un lien entre la trigonométrie et la théorie des nombres. Grossièrement parlant, nous pourrions dire que la théorie des nombres traite les propriétés qualitatives des nombres plutôt que quantitatives. Un concept central en théorie des nombres est celui de la divisibilité (exemple : 42 est divisible par 14 mais pas par 15). L'idée de réduire une fraction à des termes les plus petits possibles emploie également le concept de la divisibilité : par exemple, 15/42 ne comporte pas les plus petits termes possibles parce que 15 et 42 sont tous les deux divisibles par 3. Regardez les suites suivantes de fractions :

Éliminons ceux qui ne sont pas en plus petits termes ; gardons seulement ceux qui sont en plus petits termes

Puis utilisons la trigonométrie :

La valeur de la somme est –1. Comment savons-nous cela ? Parce que 42 a un nombre impair de facteurs premiers dans sa décomposition et aucun d'eux n'est répété : 42 = 2 × 3 × 7. (S'il y avait eu un nombre pair de facteurs premiers non-répétés alors la somme aurait été égale à 1 ; s'il avait eu des facteurs premiers répétés dans sa décomposition (par exemple, 60 = 2 × 2 × 3 × 5) alors la somme auraient été nulle ; la somme est la valeur de la fonction de Möbius en 42). Ceci laisse entendre la possibilité d'appliquer l' analyse de Fourier à la théorie des nombres.

Exponentielles complexes

Dans beaucoup d'applications de la trigonométrie, il est plus commode de convertir des fonctions trigonométriques en exponentielles complexes en utilisant deux identités dérivées de la formule d'Euler :

Ceci conduit à des calculs plus simples, puisqu'elles réduisent les utilisations des formules trigonométriques à l'application de règles sur la manipulation des exposants.

( en) Cet article est partiellement ou en totalité issu de l’article de Wikipédia en anglais intitulé « Uses of trigonometry » ( voir la liste des auteurs) .


Trigonométrie

Atan2

En trigonométrie, la fonction atan2 à deux arguments est une variation de la fonction arc tangente. Pour tout arguments réels x et y non nuls, atan2(y, x) est l'angle en radians entre la partie positive de l'axe des x d'un plan, et le point de ce plan aux coordonnées (x, y). Cet angle est positif pour les angles dans le sens anti-horaire dit sens trigonométrique (moitié haute du plan, y > 0) et négatif dans l'autre (moitié basse du plan, y < 0).

La fonction atan2 fut en premier lieu introduite dans les langages de programmation informatique, mais elle est désormais aussi couramment utilisée dans les autres sciences et ingénieries. Elle est au moins aussi vieille que le langage de programmation Fortran et on la trouve maintenant dans la plupart des autres langages.

En termes mathématiques, atan2 retourne la valeur principale (en) de la fonction argument appliquée sur le nombre complexe x + iy. Soit atan2(y, x) = Pr arg(x + iy) = Arg(x + iy). Le résultat pourrait varier de 2π sans aucun impact sur l'angle, mais pour garantir son unicité, on utilise la valeur principale dans l'intervalle ]–π, π]. Soit –π < atan2(y, x) ≤ π.

La fonction atan2 est utilisée dans beaucoup d'applications impliquants des vecteurs de l'espace Euclidien, comme pour trouver la direction d'un point à un autre. Une des utilisations principales est la conversion des matrices de rotation en angles d'Euler, pour faire pivoter des représentations graphiques informatiques.

Dans certains langages informatiques, l'ordre des paramètres est inversé, ou la fonction est dénommée différemment. Sur les calculatrices scientifiques, le résultat de la fonction est souvent issu de la conversion des coordonnées rectangulaires (x, y) en coordonnées polaires.

Sommaire

  • 1 Motivation
  • 2 Définition
  • 3 Variations
  • 4 Illustrations
  • 5 Référence
  • 6 Liens externes

Motivation

La fonction arc tangente à un seul argument ne fait pas la différence entre des directions diamétralement opposées. Par exemple, l'angle anti-horaire à partir de l'axe des x jusqu'au vecteur <1, 1>, calculé de la façon habituelle comme arctan(1/1), donne π/4 (radians), ou 45°. De la même façon, l'angle entre l'axe des x jusqu'au vecteur < -1, -1 >, avec la même méthode arctan(-1/-1), donne encore π/4, même si la réponse clairement attendue serait plutôt −3π/4, ou −135°.

La fonction "atan2" prend en compte le signe des deux composants du vecteur, et place l'angle dans le bon quadrant. Ainsi, atan2(1, 1) = π/4 et atan2(−1, −1) = −3π/4.

De plus, la méthode habituelle ne fonctionne pas dans le cas d'un angle de ±π/2 (ou ±90°). Par exemple, une tentative pour trouver l'angle entre l'axe des x et le vecteur <0, 1>, nécessite l'évaluation de arctan(1/0), qui échoue à cause de la division par zéro. Alors que atan2(1, 0) donne la bonne réponse π/2.

Quand les calculs sont effectués à la main, les corrections de quadrant nécessaires et la gestion des exceptions peuvent être faites par observation, mais dans un programme informatique, il est extrêmement utile de disposer d'une fonction unique qui délivre toujours un résultat correct non ambigu.

Définition

Pour y ≠ 0:

Où [image] est l'angle compris dans [0,π/2[ de façon à ce que [image] et sgn est la fonction signe.

Et:

Notes:

  • Cela donne des résultats compris dans ]-π, π], qui peut être translaté dans [0,2π[ en ajoutant 2π aux valeurs négatives.
  • Traditionnellement, atan2(0,0) est non défini.
    • La fonction C, et la plupart des autres implémentations informatiques, sont conçues pour les efforts de transformations des coordonnées cartésiennes en polaires, et donc définissent toujours atan2(0,0). Dans les implémentations sans zéro signé, ou lorsque sont donnés des arguments zéro positif, le résultat est normalement défini à 0. La valeur rendue sera toujours comprise dans ]-π,π] plutôt que sortir en erreur ou retourner NaN ("Not a Number", cad "Pas un Nombre").
    • Les systèmes gérants les mathématiques symboliques devraient normalement retourner une valeur non définie pour atan2(0,0) ou bien signaler qu'une anomalie s'est produite.
  • Pour les systèmes comme la virgule flottante IEEE 754 qui savent gérer le zéro signé, les infinis ou NaN, il est habituel d'implémenter des extensions capables d'étendre les résultats possibles pour inclure -π et -0. Ces dernières pourraient aussi retourner NaN ou lever une exception lorsqu'un des arguments reçus est un NaN.

La bibliothèque mathématique libre FDLIBM disponible dans netlib montre dans son code source comment implémenter atan2 avec une gestion de valeurs spéciales IEEE.

Pour les systèmes ne disposant pas d'un multiplicateur hardware, la fonction atan2 peut être implémentée numériquement d'une manière fiable avec la méthode CORDIC. Dans ce genre de cas, il sera surement préférable de calculer atan(y) par atan2(y,1).

L'expression suivante dérivée de la formule de la tangente de l'arc moitié peut aussi être utilisée pour définir atan2. Cette expression devrait être plus adaptée à un usage symbolique que la définition précédente. Elle est néanmoins totalement inadaptée à l'utilisation en virgule flottante; la division provoque un débordement au voisinage de la partie négative de l'axe des x, et donne un NaN ou une erreur pour atan2(0,0).

Variations

Illustrations

Le diagramme ci-dessous présente les valeurs prises par atan2 sur des points remarquables du cercle unitaire. Les valeurs, en radians, sont inscrites en bleu à l'intérieur du cercle. Les quatre points (1,0), (0,1), (-1,0), and (0,-1) sont notés à l'extérieur du cercle. Notez que l'ordre des arguments est inversé; la fonction atan2(y,x) donne l'angle correspondant au point (x,y).

Le schéma suivant montre les valeurs prises par atan2 pour les points du cercle unitaire. Sur l'axe des X, on a les angles complexes des points. Ils partent de 0 (point (0, 1)) et vont dans le sens trigonométrique en passant par les points :

  • (0, 1) qui a pour angle complexe π/2 en radians,
  • (–1, 0) qui a pour angle complexe π,
  • (–1, –1) qui a pour angle complexe 3π/2,

jusqu'à (1, 0) qui a pour angle complexe 0 = 2π modulo 2π.

Sur ce schéma, on peut voir clairement apparaitre la discontinuité de la fonction atan2. Quand un point z traverse la partie négative de l'axe réel — par exemple va de (0, 1) à (0, –1) en passant par (–1, 0) — son argument devrait aller de π/2 à 3π/2 en passant par π. Mais la valeur de la fonction atan2 (valeur principale de l'argument) va de π/2 à π, puis saute à –π (discontinuité), pour aller vers –π/2.

Ci-dessous une vue 3D montrant la différence entre atan2(y, x) et arctan(y/x).

Référence

(en) Cet article est partiellement ou en totalité issu de l’article de Wikipédia en anglais intitulé « atan2 » (voir la liste des auteurs).

Liens externes

  • (en) Java 1.6 SE JavaDoc
  • (en) C++ Programmer's Reference
  • (en) MATLAB Function Reference
  • (en) Mathematica Function Reference (note argument order is reversed)
  • (en) atan2 at Everything2
  • (en) PicBasic Pro solution atan2 for a PIC18F
  • (en) Bearing Between Two Points
  • (en) Arctan and Polar Coordinates
  • (en) What's 'Arccos'?


Trigonométrie

Cercle trigonométrique

En mathématiques, le cercle trigonométrique est un cercle qui permet d'illustrer et de définir des notions comme celles d'angle, de radian et les fonctions trigonométriques : cosinus, sinus, tangente. Il s'agit du cercle dont le rayon est égal à 1 et qui est centré sur l'origine du repère, dans le plan usuel muni d'un repère orthonormé.

Sommaire

  • 1 Fonctions trigonométriques sur le cercle
  • 2 Valeur et équivalents des expressions
  • 3 Le cercle trigonométrique et le repérage polaire
  • 4 Article connexe

Fonctions trigonométriques sur le cercle

Illustration du cercle trigonométrique unitaire ; la variable t est la mesure de l'angle.

Soit [image] un repère orthonormé du plan euclidien.

Soit M un point du cercle trigonométrique de coordonnées (x, y) et [image] son vecteur associé. Si un réel t est une mesure de l'angle [image] alors

et l'équation cartésienne du cercle donne immédiatement une identité trigonométrique connue :

Le cercle trigonométrique peut aussi donner un moyen intuitif de réaliser que les fonctions sinus et cosinus sont des fonctions périodiques, vérifiant les relations :

Ces égalités s'interprètent par le fait que le point (x, y) reste le même après avoir ajouté ou retranché un multiple entier de 2π et ainsi effectué plusieurs tours complets du cercle. Lorsqu'elles sont définies à partir d'un triangle rectangle, les valeurs des fonctions sinus, cosinus et d'autres fonctions trigonométriques n'ont de sens que pour des angles compris entre 0 et π/2 rad, mais dans le cercle trigonométrique leurs valeurs prennent un sens en n'importe quel réel.

Toutes les fonctions trigonométriques de l'angle θ peuvent être construites géométriquement dans un cercle unitaire centré sur O.

Le rapporteur est un instrument de mesure matérialisant le cercle trigonométrique.

Valeur et équivalents des expressions

Plan d'un cercle trigonométrique avec ses équivalents de pi sous forme de cosinus et sinus.
Expression | 0 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
Valeur en degrés | 0 | 30 | 45 | 60 | 90 | 120 | 135 | 150 | 180 | 210 | 225 | 240 | 270 | 300 | 315 | 330 | 360
Équivalent cosinus | 1 |  |  |  | 0 |  |  |  | -1 |  |  |  | 0 |  |  |  | 1
Équivalent sinus | 0 |  |  |  | 1 |  |  |  | 0 |  |  |  | -1 |  |  |  | 0

Le cercle trigonométrique et le repérage polaire

Le cercle trigonométrique est un cas particulier simple de la représentation en coordonnées polaires d'un point M du plan. Au couple de composantes cartésiennes (x, y), on substitue un couple (r,θ), où r est la distance, positive, de M à l'origine, et θ un angle congru à l'angle orienté [image]. Cette approche permet alors de définir le cercle trigonométrique comme le lieu des points vérifiant en coordonnées polaires r = 1.


Trigonométrie

Utilisateur:Charles Dyon/Polynôme minimal trigonométrique

En mathématiques, et plus précisément en algèbre, les nombres algébriques sont caractérisés par leur polynôme minimal. Cet article recense les polynômes minimaux trigonométriques, c'est-à-dire ceux correspondant aux nombres de la forme :

,

lesquels sont algébriques, et à ce titre, admettent un polynôme minimal à coefficients dans ℚ. On obtient même des polynômes de degrés moindres en acceptant que les coefficients du polynôme appartiennent à un corps quadratique ℚ(√d), d étant un diviseur de n ; un tel polynôme appartient donc à ℚ(√d)[X].

Sommaire

  • 1 Polynôme minimaux de nombres de la forme 2cos(k/n) ou 2sin(k/n)
    • 1.1 Polynômes du premier degré
    • 1.2 Polynômes du second degré
    • 1.3 Polynômes du troisième degré
    • 1.4 Polynômes du quatrième degré
    • 1.5 Polynômes du cinquième degré
  • 2 Polynômes minimaux de nombres de la forme tan(k/n).
    • 2.1 Polynômes du premier degré
    • 2.2 Polynômes du second degré
    • 2.3 Polynômes du troisième degré
    • 2.4 Polynômes du quatrième degré
    • 2.5 Polynômes du cinquième degré
  • 3 Formules générales en relation avec les coefficients des polynomes minimaux trigonométriques.
    • 3.1 Formules de sommations
    • 3.2 Formules de produits

Polynôme minimaux de nombres de la forme 2cos(k /n) ou 2sin(k /n)

Ci-dessous se trouvent, dans l'ordre des degrés croissants, les premiers polynômes minimaux des nombres de la forme 2.cos(k [image] /n) ou de la forme 2.sin(k [image] /n). Le facteur 2 n'est là que pour simplifier les coefficients du polynôme.

Polynômes du premier degré

  • sont respectivement les polynômes minimaux des nombres :

    qui peuvent aussi se mettre sous la forme :

  • sont respectivement les polynômes minimaux dans [image] et [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

Polynômes du second degré

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

Polynômes du troisième degré

  • x^3 - x^2 - 2x + 1 ~
    est le polynôme minimal des nombres :

    qui peuvent aussi se mettre sous la forme :
  • x^3 + x^2 - 2x - 1 ~
    est le polynôme minimal des nombres :

    qui peuvent aussi se mettre sous la forme :
  • x^3 - 3x - 1 ~
    est le polynôme minimal des nombres :

    qui peuvent aussi se mettre sous la forme :
  • x^3 - 3x + 1 ~
    est le polynôme minimal des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :
    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :
    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

  • est le polynôme minimal dans [image] des nombres :

  • est le polynôme minimal dans [image] des nombres :

  • est le polynôme minimal dans [image] des nombres :

Polynômes du quatrième degré

  • x^4 - 4x^2 + 2 ~
    est le polynôme minimal des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :
  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :
  • x^4 - 5x^2 + 5 ~
    est le polynôme minimal des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

  • est le polynôme minimal dans [image] des nombres :

    qui peuvent aussi se mettre sous la forme :

Polynômes du cinquième degré

x^5 + x^4 - 4x^3 - 3x^2 + 3x + 1 ~

est le polynôme minimal des nombres :

Qui peuvent aussi se mettre sous la forme :

x^5 - x^4 - 4x^3 + 3x^2 + 3x - 1 ~

Est le polynôme minimal des nombres :

Qui peuvent aussi se mettre sous la forme :

Est le polynôme minimal dans [image] des nombres :

Qui peuvent aussi se mettre sous la forme :

Est le polynôme minimal dans [image] des nombres :

Qui peuvent aussi se mettre sous la forme :

Est le polynôme minimal dans [image] des nombres :

Qui peuvent aussi se mettre sous la forme :

Est le polynôme minimal dans [image] des nombres :

Qui peuvent aussi se mettre sous la forme :

Est le polynôme minimal dans [image] des nombres :

Qui peuvent aussi se mettre sous la forme :

Est le polynôme minimal dans [image] des nombres :

Qui peuvent aussi se mettre sous la forme :

Etc.

Polynômes minimaux de nombres de la forme tan(k /n).

Ci-dessous se trouvent, dans l'ordre des degrés croissants, les premiers polynômes minimaux des nombres de la forme tan(kπ/n).

Polynômes du premier degré

sont respectivement les polynômes minimaux des nombres :

sont respectivement les polynômes minimaux dans [image] des nombres :

Polynômes du second degré

x^2 - 4x + 1 ~

Est le polynôme minimal des nombres :

x^2 + 4x + 1 ~

est le polynôme minimal des nombres :

est le polynôme minimal dans [image] des nombres :

est le polynôme minimal dans [image] des nombres :

Polynômes du troisième degré

est le polynôme minimal dans [image] des nombres :

est le polynôme minimal dans [image] des nombres :

est le polynôme minimal dans [image] des nombres :

est le polynôme minimal dans [image] des nombres :

est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

est le polynôme minimal dans [image] des nombres :

est le polynôme minimal dans [image] des nombres :

est le polynôme minimal dans [image] des nombres :

est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Polynômes du quatrième degré

x^4 - 10x^2 + 5 ~

Est le polynôme minimal des nombres :

x^4 - 2x^2 + 2 ~

Est le polynôme minimal des nombres :

x^4 - 4x^3 - 14x^2 - 4x + 1 ~

Est le polynôme minimal des nombres :

x^4 + 4x^3 - 14x^2 + 4x + 1 ~

Est le polynôme minimal des nombres :

x^4 + 8x^3 + 2x^2 - 8x + 1 ~

Est le polynôme minimal des nombres :

x^4 - 8x^3 + 2x^2 + 8x + 1 ~

Est le polynôme minimal des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Polynômes du cinquième degré

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Est le polynôme minimal dans [image] des nombres :

Etc...

Formules générales en relation avec les coefficients des polynomes minimaux trigonométriques.

On trouvera ci-dessous quelques formules relatives aux relations entre coefficients et racines d'un polynome annulateur des nombres trigonométriques traités dans cet article. Certaines de ces formules font apparaître au second membre la racine d'un diviseur du dénominateur se trouvant dans l'argument des fonctions trigonométriques au premier membre. Ce qui permet d'entrevoir les raisons pour lesquelles, on trouve dans les coefficients du polynôme minimal de telle racines.

Formules de sommations

Formules de produits

(Dans ce qui suit Ent(x) désigne la partie entière de x)

Dans la suite, on désignera par P(n), l'ensemble des nombres entiers inférieurs à n et premier avec n. Par exemple :

On désignera aussi par [image], l'ensemble des nombres premiers.

On a alors :

Pour tout n ayant au moins 2 nombres premiers impairs dans sa décomposition en facteurs premiers, on a :

Pour tout n qui n'est pas une puissance de 2, on a :

Pour tout n ayant au moins 2 nombres premiers impairs dans sa décomposition en facteurs premiers, on a :

Si 2n+1 est une puissance d'un nombre premier p,

Si 2n+1 contient au moins deux nombres premiers distincts dans sa décomposition en facteurs premiers,

Etc...


Trigonométrie

Construction des tables trigonométriques

Les tables de fonctions trigonométriques sont utiles dans beaucoup de domaines. Avant l'existence des calculatrices de poche, les tables trigonométriques étaient essentielles pour la navigation, dans les sciences et dans la technologie. La réalisation de tables de valeurs approchées des fonctions représentait un domaine d'étude important, et mena au développement des premiers dispositifs de calcul mécaniques.

Les ordinateurs modernes et les calculatrices de poche génèrent maintenant les valeurs des fonctions trigonométriques à la demande, en utilisant des bibliothèques de code mathématique. Souvent, ces bibliothèques utilisent des tables internes calculées d'avance, et la valeur requise est obtenue en utilisant une méthode d'interpolation appropriée.

Des tables trigonométriques simples sont maintenant souvent utilisées en infographie, où en général des valeurs précises ne sont pas nécessaires et les calculs doivent être effectués très rapidement.

Sommaire

  • 1 Une approximation rapide, mais très imprécise
  • 2 Développements en série
  • 3 Voir aussi
    • 3.1 Articles connexes

Une approximation rapide, mais très imprécise

Donnons un algorithme rapide, mais imprécis, pour construire une table a de taille N, de valeurs approchées de sin(2π n/N), et une autre table b de valeurs approchées de cos(2πn/N) (0 ≤ n ≤ N - 1) :

a[0] = 0
b[0] = 1
a[n+1] = a[n] + d × b[n]
b[n+1] = b[n] - d × a[n+1]

pour n = 0, …, N - 1, où d = 2π/N.

Malheureusement, ce n'est pas un algorithme utile pour produire des tables de sinus, pour un certain nombre de raisons. Il fonctionnera seulement quand le nombre N sera très grand, et en utilisant l'arithmétique en précision infinie.

Par exemple, avec une taille de table N = 256, la dernière valeur du sinus est évaluée à -0,024 386 06 au lieu de 0, et pour N = 1 024, l'algorithme donne comme dernière valeur -0,006 124 031.

Si les valeurs de sinus et de cosinus obtenues par cet algorithme devaient être représentée sur un graphique, nous obtiendrions une spirale au lieu d'un cercle.

Développements en série

Article détaillé : Fonction trigonométrique#Définitions à partir des séries entières.


Trigonométrie

CORDIC

CORDIC (sigle de COordinate Rotation DIgital Computer : « calcul numérique par rotation de coordonnées ») est un algorithme de calcul des fonctions trigonométriques et hyperboliques, notamment utilisé dans les calculatrices. Il a été décrit pour la première fois en 1959 par Jack E. Volder. Il ressemble à des techniques qui avaient été décrites par Henry Briggs en 1624.

Il s'agit d'un algorithme de choix lorsqu'aucune implantation matérielle d'un multiplicateur n'est disponible (sur certains microcontrôleurs simples ou des FPGA). De plus, l'algorithme du CORDIC s'adapte bien au calcul à la chaîne. À l'origine, la programmation du CORDIC reposait sur un système binaire.

Durant les années 1970, les versions décimales du CORDIC (avec des nombres codés en BCD) commencèrent à apparaître, notamment dans les calculatrices où les critères de coût du matériel sont plus importants que la vitesse de traitement. Un autre avantage du CORDIC est sa flexibilité puisqu'il permet de calculer plusieurs fonctions avec quasiment le même code.

Sommaire

  • 1 Description
  • 2 Algorithme
    • 2.1 Fonctions trigonométriques
    • 2.2 Fonctions hyperboliques
    • 2.3 Fonctions linéaires
      • 2.3.1 Multiplication
      • 2.3.2 Division
  • 3 Bibliographie
  • 4 Notes et références
  • 5 Voir aussi
    • 5.1 Articles connexes
    • 5.2 Liens externes

Description

CORDIC permet de déterminer le sinus ou le cosinus d'un angle donné en radians sous un format à virgule fixe. Pour trouver le sinus ou le cosinus d'un angle [image], on recherche la coordonnée x ou y du point du cercle unité lui correspondant. CORDIC commence les calculs avec un vecteur [image] tel que :

Durant la première itération, le vecteur subit une rotation de 45° dans le sens anti-horaire (sens trigonométrique) afin d'obtenir un nouveau vecteur [image]. Des itérations successives doivent engendrer une rotation du vecteur dans la bonne direction. À chaque itération, la rotation est faite d'un angle prédéterminé et moindre que le précédent. Ceci jusqu'à converger vers l'angle voulu.

Illustration de plusieurs itérations de CORDIC

Plus formellement, à chaque itération i, on calcule un nouveau vecteur grâce à la multiplication du vecteur [image] avec la matrice de rotation [image] :

La matrice de rotation [image] s'obtient selon la formule suivante :

En factorisant le terme [image] on obtient :

Le facteur [image] prend les valeurs +1 ou -1 et sert à indiquer le sens de la rotation. Si l'on restreint les choix possibles pour l'angle [image] de manière à ce que [image] soit égal à [image] alors la multiplication par la tangente devient une multiplication par une puissance de 2. Une opération aisée à réaliser informatiquement puisqu'en binaire il s'agit d'un décalage de bits.

Le calcul devient :

avec

Ces coefficients [image] peuvent être ignorés pendant les itérations et factorisés en un seul coefficient multiplicatif final (dépendant de n) :

qui peut être calculé à l'avance et prémémorisé. Également, lorsque n tend vers l'infini, ce produit tend vers une constante :

(0,60725294…)

Après suffisamment d'itérations, l'angle du vecteur sera proche de l'angle [image] voulu.

La dernière étape consiste à déterminer à chaque itération le sens de rotation, trigonométrique ou horaire (un résultat reporté sur la valeur de [image]). Pour ce faire, on regarde l'angle [image] actuel du vecteur que l'on soustrait à l'angle désiré. On teste si cette différence est positive (rotation dans le sens horaire) ou négative (sens trigonométrique), de façon à s'approcher de l'angle [image].

,

Les valeurs de [image] sont précalculées dans une table prémémorisée de valeurs. Toutefois, pour des angles petits, on utilise l'approximation [image] dans une représentation en virgule fixe, permettant ainsi de réduire la taille de cette table.

Comme illustré dans le schéma ci-dessus, le sinus de l'angle [image] est la coordonnée y du vecteur final [image], alors que la coordonnée x correspond au cosinus.

Algorithme

En 1971, John Stephen Walther de Hewlett Packard, a présenté une généralisation de l'algorithme qui fut mise en œuvre dans la calculatrice HP-35. Cette méthode permet de calculer notamment les fonctions hyperboliques mais également d'autres fonctions comme l'exponentielle, la division ou la multiplication. La généralisation se présente comme suit[1] :

avec [image], [image] des constantes définies à l'avance et [image] (en fonction de la valeur de [image]).

Fonctions trigonométriques

On utilise la généralisation avec les paramètres :

m = 1~
x_0 = 1
y_0 = 0~
(en radians)

À la fin de n itérations, on a [image] et [image].

Cette méthode ne fonctionne que si :

En pratique cela ne pose pas de problème car les fonctions trigonométriques peuvent toujours être ramenées au cas [image] en exploitant leurs propriétés les plus connues (voir Identité trigonométrique).

Fonctions hyperboliques

On utilise la généralisation avec les paramètres :

m = -1~
y_0 = 0~
(en radians)

À la fin de n itérations, on a [image] et [image], ainsi que [image].

Cette méthode ne fonctionne que si la valeur absolue de z est inférieure à environ 1,05. Des transformations d'expressions grâce à des identités trigonométriques permettent de contourner ces problèmes en faisant en sorte que les paramètres soient dans l'intervalle requis. La répétition de certaines itérations résout les problèmes de convergence[1].

Fonctions linéaires

CORDIC permet également de calculer la multiplication ou la division entre des nombres a et b.

Multiplication

m = 0~
x_0 = a
y_0 = 0~
z_0 = b~

À la fin de n itérations, on a [image]. En pratique, elle est peu intéressante car son domaine est restreint. Il faut impérativement que [image].

Division

m = 0~
x_0 = b~
y_0 = a~
z_0 = 0~

À la fin de n itérations, on a [image]. Elle a aussi un domaine d'application restreint puisque la condition suivante doit être respectée :

Bibliographie

  • Jack E. Volder, The CORDIC Trigonometric Computing Technique, IRE Transactions on Electronic Computers, septembre 1959
  • Daggett, D. H., Decimal-Binary conversions in CORDIC, IRE Transactions on Electronic Computers, Vol. EC-8 no 5, p. 335-339, IRE, septembre 1959.
  • J. E. Meggitt, Pseudo Division and Pseudo Multiplication Processes, IBM Journal, avril 1962.
  • Vladimir Baykov, Problems of Elementary Functions Evaluation Based on Digit by Digit (CORDIC) Technique, rapport de thèse, Université d'État de Leningrad d'ingénierie électrique, 1972
  • Schmid, Hermann, Decimal computation. New York, Wiley, 1974
  • V.D.Baykov, V.B.Smolov, Hardware implementation of elementary functions in computers, Université d'État de Leningrad, 1975, 96p.
  • Senzig, Don, Calculator Algorithms, IEEE Compcon Reader Digest, Catalogue IEEE no 75 CH 0920-9C, p. 139-141, IEEE, 1975.
  • V.D.Baykov, S.A.Seljutin, Elementary functions evaluation in microcalculators, Moscou, Radio & svjaz, 1982,64p.
  • Vladimir D.Baykov, Vladimir B.Smolov, Special-purpose processors: iterative algorithms and structures, Moscou, Radio & svjaz, 1985, 288 pages
  • M. E. Frerking, Digital Signal Processing in Communication Systems, 1994
  • Vitit Kantabutra, On hardware for computing exponential and trigonometric functions, IEEE Trans. Computers 45 (3), 328-339 (1996).
  • Andraka, Ray, A survey of CORDIC algorithms for FPGA based computers
  • 'Le Secret des Algorithmes, Jacques Laporte, Paris 1981
  • (en) Jean-Michel Muller, Elementary Functions – Algorithms and Implementation, 2nd Ed., Boston, Birkhäuser,‎ 2006, 2e éd. (ISBN 978-0-8176-4372-0, LCCN 2005048094)
  • Lefèvre V., Zimmerman P., janvier 2004, Arithmétique flottante, Rapport de Recherche INRIA no 5105.

Notes et références

Voir aussi

  Sigles d’une seule lettre
  Sigles de deux lettres
  Sigles de trois lettres
  Sigles de quatre lettres
  Sigles de cinq lettres
> Sigles de six lettres
  Sigles de sept lettres
  Sigles de huit lettres

Articles connexes

  • Calcul numérique
  • Approximation de fonction
  • Variante de la Méthode de calcul du cosinus
  • Réalisation d'un coprocesseur CORDIC dans la WIKIversité

Liens externes[ modifier | modifier le code ]

  • (en) Dspguru - Questions sur CORDIC
  • (en) Synthèse sonore en FPGA
  • (en) Vecteurs arbitraires dans CORDIC
  • (en) méthode CORDIC à doubles itérations
  • (en) discussions sur USENET
  • (en) D'autres discussions sur USENET
  • (en) Calculs de Arccos et [image] avec CORDIC
  • (en) programmation de CORDIC basée sur des tampons
  • (en) http://www.math.niu.edu/~rusin/known-math/94/cordic
  • (en) Implémentation de CORDIC dans la ROM du HP-35 - Jacques Laporte (analyse pas à pas du firmware)
  • (en) Digit by digit methods, Jacques Laporte, Paris 2006 (la filiation entre CORDIC et les anciennes méthodes notamment celle de Briggs)


Trigonométrie

Formules trigonométriques en kπ/7

Cet article répertorie les formules trigonométriques correspondant à des angles multiples de π/7.

Sommaire

  • 1 Valeur approchée
  • 2 Quelques solutions d'équations
  • 3 Formules homogènes
  • 4 Formules de linéarisation
  • 5 Autres formules découlant des précédentes
  • 6 Propriétés remarquables
  • 7 Notes et références

Valeur approchée

Tracé (approximatif) d'un angle de

cos (π/7) n'est pas un nombre constructible (comme on peut le démontrer en utilisant le théorème de Wantzel et l'équation du troisième degré donnée ci-dessous), ce qui implique qu'il n'existe pas de construction rigoureuse à la règle et au compas de l'heptagone régulier.

On a cependant avec une assez bonne approximation : . Cette valeur peut permettre de construire à la règle et au compas un angle ayant une mesure proche de [image].

On trace un segment [AB] et un point P tel que : Soit C le point d'interception entre le cercle de centre A et de rayon AB avec la perpendiculaire à (AB) passant par P. Alors l'angle [image] a approximativement une mesure de [image].

Quelques solutions d'équations

L'équation :

X^3 - X^2 -2X +1 = 0 ~

a pour racines :

L'équation :

X^3 + X^2 -2X - 1 = 0 ~

a pour racines :

L'équation :

a pour racines :

L'équation :

a pour racines :

L'équation :

a pour racines :

L'équation :

a pour racines :

Formules homogènes

Formules de linéarisation

Autres formules découlant des précédentes

Pour d'autres valeurs de k dans kπ/7, on peut se ramener aux formules précédentes en tenant compte du fait que, pour [image] :

Propriétés remarquables

Nous avons[1] :

Pour les premières valeurs positives de k, on obtient :

etc.

Pour les premières valeurs négatives de k, on obtient :

Notes et références

  1. ↑ Roman Witula, Ramanujan type trigonometric formulas: the general form for the argument 2Pi/7, J. Integer Seq., 12 (2009), Article 09.8.5.


Trigonométrie

Formule d'Euler

Formule d'Euler

La formule d'Euler est une égalité mathématique, attribuée au mathématicien suisse Leonhard Euler. Elle s'écrit pour tout nombre réel x,

et se généralise aux x complexes.

Ici, e est la base naturelle des logarithmes, i est l'unité imaginaire, sin et cos sont des fonctions trigonométriques.

Sommaire

  • 1 Description
  • 2 Démonstrations
    • 2.1 Par les séries de Taylor
    • 2.2 Par le calcul différentiel
  • 3 Historique
  • 4 Applications
  • 5 Voir aussi
    • 5.1 Articles connexes
  • 6 Références

Description

Cette formule peut être interprétée en disant que la fonction x ↦ eix, appelée fonction cis[1], décrit le cercle unité dans le plan complexe lorsque x varie dans l'ensemble des nombres réels.
x représente la mesure de l'angle orienté que fait la demi-droite d'extrémité l'origine et passant par un point du cercle unité avec la demi-droite des réels positifs. La formule n'est valable que si sin et cos ont des arguments exprimés en radians plutôt qu'en degrés.

La démonstration est basée sur les développements de la fonction exponentielle z ↦ ez de la variable complexe z et des fonctions sin et cos considérées à variables réelles.
En fait, la même démonstration montre que la formule d'Euler est encore valable pour tous les nombres complexes x.

La formule établit un puissant lien entre l'analyse et la trigonométrie. Elle est utilisée pour représenter les nombres complexes sous forme trigonométrique et permet la définition du logarithme pour les arguments complexes. En utilisant les propriétés de l'exponentielle

et

(qui sont aussi valables pour tous les nombres complexes a, b et pour tout entier k), il devient facile de dériver plusieurs identités trigonométriques ou d'en déduire la formule de de Moivre. La formule d'Euler permet une interprétation des fonctions cosinus et sinus comme combinaisons linéaires de fonctions exponentielles :

Ces formules (aussi appelées formules d'Euler) peuvent servir de définition des fonctions trigonométriques de variable complexe x. On les obtient en écrivant deux fois la formule d'Euler :

et en additionnant ou soustrayant ces égalités pour déterminer cosinus ou sinus.

Dans les équations différentielles, la fonction x ↦ eix, est souvent utilisée pour simplifier les dérivations, même si le problème est de déterminer les solutions réelles exprimées à l'aide de sinus et cosinus. L'identité d'Euler est une conséquence immédiate de la formule d'Euler.

En électrotechnique et dans d'autres domaines, les signaux qui varient périodiquement en fonction du temps sont souvent décrits par des combinaisons linéaires des fonctions sinus et cosinus (voir analyse de Fourier), et ces dernières sont plus commodément exprimées comme parties réelles de fonctions exponentielles avec des exposants imaginaires, en utilisant la formule d'Euler.

Démonstrations

Par les séries de Taylor

Article détaillé : série de Taylor.

Le développement en série de la fonction exp de la variable réelle t peut s'écrire :

et s'étend à tout nombre complexe t : le développement en série de Taylor reste absolument convergent et définit l'exponentielle complexe.

En particulier pour t = ix avec x réel :

Cette série, séparée en deux, devient, en utilisant que [image] :

On voit ainsi apparaître les développements en série de Taylor des fonctions cosinus et sinus :

ce qui, en remplaçant dans l'expression précédente de eix, donne bien :

Par le calcul différentiel[ modifier | modifier le code ]

Article détaillé : § « Par une équation différentielle » de l'article sur l'exponentielle de base a.

Pour tout nombre complexe k, la seule application f : ℝ → ℂ vérifiant f ' = kf et f(0) = 1 est l'application x ↦ exp(kx) (la démonstration est identique à celle pour k réel, donnée dans l'article détaillé).

L'application f définie par [image] vérifie

Elle coïncide donc avec l'application x ↦ exp(ix).

Historique

Article détaillé : Histoire des nombres complexes.

La formule d'Euler fut mise en évidence pour la première fois par Roger Cotes en 1714 sous la forme ln(cosx + i sinx) = ix (où ln désigne le logarithme népérien, c'est-à-dire le logarithme de base e)[2],[3]. Ce fut Euler qui publia la formule sous sa forme actuelle en 1748, en basant sa démonstration sur la formule de de Moivre et à l'aide d'équivalents et de passages à la limite[4],[5]. Aucun des deux mathématiciens ne donna une interprétation géométrique de la formule : l'interprétation des nombres complexes comme des affixes de points d'un plan ne fut vraiment évoquée que cinquante années plus tard (voir Caspar Wessel).

Applications

  • Un exemple d'application en électromagnétisme est le courant alternatif : puisque la différence de potentiel d'un tel circuit oscille, elle peut être représentée par un nombre complexe : Afin d'obtenir une quantité mesurable, on prend la partie réelle[6] :

  • La linéarisation, qui repose sur la formule d'Euler et la formule du binôme de Newton, transforme tout polynôme en cos(x) et sin(x) en une combinaison linéaire de divers cos(nx) et sin(nx), ce qui rend alors immédiat le calcul de ses primitives.

Voir aussi

Articles connexes

  • Théorème de Descartes-Euler
  • Relation d'Euler dans le triangle
  • Méthode d'Euler, calcul approché d'équations différentielles et de primitives
  • Identité d'Euler, la fameuse identité : eiπ + 1 = 0

Références

  1. ↑ (en) Alan Sultan et Alice F. Artzt, The mathematics that every secondary school math teacher needs to know, Studies in Mathematical Thinking and Learning, Taylor & Francis, 2010, p. 326.
  2. ↑ Dominique Flament, Histoire des nombres complexes : Entre algèbre et géométrie, Paris, CNRS Éditions,‎ 2003 (ISBN 2 271 06128 8) , p. 80.
  3. ↑ (en) John Stillwell, Mathematics and Its History [détail des éditions], p. 294.
  4. ↑ L. Euler, Introduction à l'analyse infinitésimale, article 138.
  5. ↑ Flament 2003, p. 83-84.
  6. ↑ Voir des exemples dans : Electromagnetism (2e édition), I.S. Grant, W.R. Phillips, Manchester Physics Series, 2008 ISBN 0-471-92712-0.
v · m Nombre e
Applications | Intérêts composés · Identité d'Euler · Formule d'Euler · Demi-vie · Croissance exponentielle · Décroissance exponentielle
Définitions | Démonstration de l'irrationalité de e · Représentations de e · Théorème d'Hermite-Lindemann
Personnes | John Napier · Jacques Bernoulli · Leonhard Euler


Trigonométrie

Fonction trigonométrique

Toutes les valeurs des fonctions trigonométriques d'un angle θ peuvent être représentées géométriquement.

En mathématiques, les fonctions trigonométriques sont des fonctions dont la variable est une mesure d' angle. Elles permettent de relier les longueurs des côtés d'un triangle (τρίγωνον, trigonon en grec) en fonction de la mesure des angles aux sommets. Plus généralement, les fonctions trigonométriques sont importantes pour étudier les triangles et les polygones, les cercles (on les appelle aussi fonctions circulaires) et modéliser des phénomènes périodiques.

Les trois fonctions trigonométriques les plus utilisées sont le sinus (noté sin ), le cosinus ( cos ) et la tangente ( tan [ 1 ] , – tang ou tg –). Les relations entre les différentes fonctions trigonométriques constituent les identités trigonométriques. En analyse mathématique, ces fonctions peuvent aussi être définies à partir de la somme de séries entières ou comme les solutions d' équations différentielles ce qui permet de les généraliser à des nombres complexes.

Selon les domaines d'application, en navigation maritime ou aérienne notamment, d'autres fonctions sont utilisées : cotangente, sécante, cosécante, sinus verse, haversine, exsécante, etc.

Par ailleurs, sur le modèle des fonctions trigonométriques, on définit aussi des fonctions hyperboliques dont le nom dérive des premières : sinus hyperbolique ( sinh ), cosinus hyperbolique ( cosh ), tangente hyperbolique ( tanh ), etc.

Sommaire

  • 1 Histoire
  • 2 Lignes trigonométriques
  • 3 Définitions dans un triangle rectangle
  • 4 Définitions à partir du cercle unité
  • 5 Définition à partir du produit scalaire
  • 6 Définitions à partir des séries entières
  • 7 Représentations graphiques
  • 8 Propriétés des fonctions trigonométriques
    • 8.1 Valeurs remarquables
    • 8.2 Zéros
    • 8.3 Relations entre sinus et cosinus
    • 8.4 Relations trigonométriques
    • 8.5 Parité des fonctions
    • 8.6 Dérivées
    • 8.7 Limites
    • 8.8 Relations avec la fonction exponentielle et les nombres complexes
  • 9 Fonctions réciproques
  • 10 Applications
    • 10.1 En trigonométrie
    • 10.2 En analyse harmonique
    • 10.3 Fonctions de transition
  • 11 Notes et références
  • 12 Voir aussi
    • 12.1 Bibliographie
    • 12.2 Articles connexes
    • 12.3 Liens externes

Histoire

Article détaillé : Histoire des fonctions trigonométriques.

Les traces les plus anciennes d'utilisation de sinus seraient apparues dans les Sulba Sutras (en) écrits en sanskrit védique dans la période des VIII e au VI e siècles av. J.-C. .

Les fonctions trigonométriques furent plus tard étudiées par Hipparque de Nicée (185-125 av. J.-C.), Âryabhata (476-550), Varahamihira, Brahmagupta, Al-Khawarizmi, Abu l-Wafa, Omar Khayyam, Bhāskara II, Nasir ad-Din at-Tusi, Regiomontanus (1464), Al-Kachi ( XIV e siècle), Ulugh Beg ( XIV e siècle), Madhava (1400), Rheticus et son disciple Valentin Otho.

L'ouvrage Introductio in analysin infinitorum (1748) de Leonhard Euler fut en grande partie à l'origine des considérations analytiques des fonctions trigonométriques en Europe en les définissant à partir de développements en séries, et présenta les formules d'Euler.

Lignes trigonométriques

Un triangle quelconque rectiligne (ou sphérique) possède six parties dont trois côtés et trois angles. Toutes ces parties ne sont pas utiles à la construction du triangle, par exemple les seules données de la longueur de deux de ses côtés et de l'angle entre ces côtés permet de compléter le triangle. Mais connaissant seulement les trois angles, il est impossible de retrouver le triangle, puisqu'il existe une infinité de triangles ayant les trois mêmes angles ( triangles semblables). En fait il suffit de connaître trois de ces parties dont au moins un côté pour construire un triangle.

Le problème de la détermination avec exactitude des parties manquantes du triangle fut étudié en particulier en Europe à partir du Moyen Âge. Les méthodes géométriques ne donnant, à l'exception des cas simples, que des constructions approximatives et insuffisantes à cause de l'imperfection des instruments utilisés, les recherches s'orientèrent plutôt vers des méthodes numériques afin d'obtenir des constructions avec un degré de précision voulu.

Et l'un des objectifs de la trigonométrie fut donc de donner des méthodes pour calculer toutes les parties d'un triangle, c'est-à-dire pour résoudre un triangle. Pendant longtemps les géomètres cherchèrent en vain des relations entre les angles et les côtés des triangles. Une de leurs plus grandes idées fut de se servir des arcs plutôt que des angles pour effectuer leurs mesures.

Ces arcs de cercle ont pour centre un sommet du triangle et sont compris entre les côtés se rapportant à ce sommet. Ces considérations menèrent tout naturellement les géomètres à remplacer les arcs par les segments de droites dont ils dépendent.

Ces segments s'appellent les lignes trigonométriques. Il s'agit en fait d'un autre vocable pour désigner les fonctions trigonométriques ( sin , cos , tan …) appelées aussi fonctions circulaires. Des relations entre les côtés et certaines lignes liées aux arcs s'établissent de manière que les lignes puissent être déterminées à partir de certains arcs et réciproquement. Une convention fondamentale oblige alors à ne considérer que les lignes trigonométriques rapportées à des cercles de rayon 1. Ces lignes trigonométriques définissent les fonctions trigonométriques modernes.

Les fonctions trigonométriques mathématiques sont celles qui s'appliquent à des mesures d'angles données en radians. Mais il est encore d'usage de garder les mêmes noms de fonctions pour les autres unités de mesures comme les degrés ou les grades.

Définitions dans un triangle rectangle

Triangle rectangle trigo.svg

En notant θ l'angle formé entre un rayon du cercle unité et l'axe x horizontal, on obtient un triangle rectangle formé par le centre du cercle, l'intersection du rayon avec le cercle unité et la projection orthogonale de cette intersection sur l'axe horizontal. La longueur de la hauteur verticale de ce triangle correspond au sinus de l'angle θ ( sin (θ)), la longueur de la base de ce triangle est égale à cos (θ) et la pente, c'est-à-dire la hauteur divisée par la longueur, vaut tan (θ).

Pour définir les fonctions trigonométriques en un angle Â, considérons un triangle rectangle arbitraire qui contient l'angle Â.

Les côtés du triangle rectangle sont appelés :

  • l’ hypoténuse : c'est le côté opposé à l'angle droit, constituant une jambe de l'angle Â et le côté le plus long du triangle ;
  • le côté adjacent : c'est le côté joignant l'angle droit depuis Â, constituant une jambe de l'angle Â, qui n'est pas l'hypoténuse ;
  • le côté opposé : c'est le côté opposé à l'angle Â, joignant l'angle droit, qui n'est pas l'hypoténuse.

On notera :

h : la longueur de l'hypoténuse,
a : la longueur du côté adjacent,
o : la longueur du côté opposé.
Les rapports des longueurs des côtés du triangle donnent son sinus, son cosinus et sa tangente. Les rapports des longueurs des côtés du triangle donnent son sinus, son cosinus et sa tangente. Les rapports des longueurs des côtés du triangle donnent son sinus, son cosinus et sa tangente.
Les rapports des longueurs des côtés du triangle donnent son sinus, son cosinus et sa tangente.

Les différents rapports de ces trois longueurs ne dépendent pas du triangle rectangle particulier choisi, s'il contient toujours l'angle Â, puisque tous ces triangles rectangles sont semblables.

  • Le sinus d'un angle est le rapport de la longueur du côté opposé par la longueur de l'hypoténuse : sin(Â) = longueur du côté opposé / longueur de l'hypoténuse = o/h.
  • Le cosinus d'un angle est le rapport de la longueur du côté adjacent par la longueur de l'hypoténuse : cos(Â) = longueur de côté adjacent / longueur de l'hypoténuse = a/h.
  • La tangente d'un angle est le rapport de la longueur du côté opposé à la longueur du côté adjacent : tan(Â) = longueur du côté opposé / longueur du côté adjacent = o/a. Notons que l'on a : tan =sin/cos.

Les trois fonctions restantes sont définies en utilisant les trois fonctions ci-dessus.

  • La cosécante de Â, notée csc(Â) ou cosec(Â), est l' inverse 1/sin(Â) du sinus de Â, c'est-à-dire le rapport de la longueur de l'hypoténuse par la longueur du côté opposé : csc(Â) = longueur de l'hypoténuse / longueur du côté opposé = h/o.
  • La sécante de Â, notée sec(Â), est l'inverse 1/cos(Â) du cosinus de Â, c'est-à-dire le rapport de la longueur de l'hypoténuse par la longueur du côté adjacent : sec(Â) = longueur de l'hypoténuse / longueur du côté adjacent = h/a.
  • La cotangente de Â, notée cot(Â), est l'inverse 1/tan(Â) de la tangente de Â, c'est-à-dire le rapport de la longueur du côté adjacent par la longueur du côté opposé : cot(Â) = longueur du côté adjacent / longueur du côté opposé = a/o.

Définitions à partir du cercle unité

Tracé des fonctions sinus et cosinus à partir du cercle unité.
Valeurs exactes placées sur le cercle unité.

Les six fonctions trigonométriques peuvent également être définies à partir du cercle unité. La définition géométrique ne fournit presque pas de moyens pour le calcul pratique ; en effet elle se fonde sur des triangles rectangles pour la plupart des angles. Le cercle trigonométrique, en revanche, permet la définition des fonctions trigonométriques pour tous les réels positifs ou négatifs, pas seulement pour des angles de mesure en radians comprise entre 0 et π/2 .

Dans un plan muni d'un repère orthonormé [image], le cercle trigonométrique est le cercle de centre O et de rayon 1. Si l'on considère un point A(xA, yA) sur le cercle, alors on a :

Sur le cercle ci-contre, nous avons représenté certains angles communs, et nous avons indiqué leurs mesures en radians figurant dans l'intervalle [–2π, 2π] , soit deux mesures par angle et même trois pour l'angle nul.

Notez que nous mesurons les angles positifs dans le sens trigonométrique, contraire à celui des aiguilles d'une horloge, et les angles négatifs dans le sens horaire. Une demi-droite qui fait un angle θ avec la demi-droite positive Ox de l'axe des abscisses coupe le cercle en un point de coordonnées (cos θ, sin θ). Géométriquement, cela provient du fait que l'hypoténuse du triangle rectangle ayant pour sommets les points de coordonnées (0, 0), (cos θ, 0) et (cos θ, sin θ) est égale au rayon du cercle donc à 1. Le cercle unité peut être considéré comme une façon de regarder un nombre infini de triangles obtenus en changeant les longueurs des côtés opposés et adjacents mais en gardant la longueur de leur hypoténuse égale à 1.

On a donc : ainsi que

Le cercle unité a pour équation : Cela donne immédiatement la relation

Définition à partir du produit scalaire

En géométrie vectorielle, le cosinus est défini à partir du produit scalaire de deux vecteurs u et v et de leurs normes ||u|| et ||v|| par :

Définitions à partir des séries entières

Ici, et généralement en analyse, il est de la plus grande importance que tous les angles soient mesurés en radians. On peut alors définir sin et cos à l'aide de séries entières :

Ces définitions sont équivalentes à celles données ci-dessus ; on peut le justifier avec la théorie des séries de Taylor, et avec le fait que la dérivée du sinus est le cosinus et que celle du cosinus est l'opposé du sinus.

Ces définitions sont souvent utilisées comme point de départ des traités rigoureux d' analyse et de la définition du nombre π puisque la théorie des séries est bien connue. La dérivabilité et la continuité sont alors faciles à établir, de même que les formules d'Euler en analyse complexe reliant les fonctions trigonométriques à la fonction exponentielle, ainsi que l' identité d'Euler. Les définitions utilisant les séries ont l'avantage supplémentaire de permettre de prolonger les fonctions sinus et cosinus en des fonctions analytiques dans tout le plan complexe.

Il n'est pas possible d'obtenir des séries aussi simples pour les autres fonctions trigonométriques, mais on a, par exemple

où Bn est le n-ème nombre de Bernoulli. Ces expressions se traduisent sous forme de fractions continues généralisées ; elles ont permis à Lambert de démontrer l' irrationalité du nombre π (cf. l'article « Fraction continue et approximation diophantienne »).

À défaut de série entière simple, il existe pour la fonction cotangente une série absolument convergente, obtenue comme limite de sommes d' éléments simples correspondant à des pôles opposés [ 2 ] , [ 3 ] : On en déduit [ 4 ] :

Représentations graphiques

Les courbes des fonctions sinus et cosinus sont appelées sinusoïdes.

Représentations graphiques des fonctions sinus, cosinus et tangente. Représentations abc graphiques des fonctions sinus, cosinus et tangente. Représentations graphiques des fonctions sinus, cosinus et tangente.
Représentations graphiques des fonctions sinus, cosinus et tangente.

Propriétés des fonctions trigonométriques

Valeurs remarquables

Article détaillé : Table de lignes trigonométriques exactes.
Article connexe : Polynôme minimal des valeurs spéciales trigonométriques.

Il existe des tables de valeurs des fonctions trigonométriques, mais ces valeurs peuvent également être calculées par une calculatrice. Pour quelques angles simples, les valeurs peuvent être calculées exactement à la main : elles sont indiquées dans le tableau suivant. Exemples :

Triangle rectangle isocèle : c = √ 2
Triangle équilatéral divisé en 2 pour calcul du sin, du cos, et de la tan pour 30° et 60°
  • Pour 45 degrés ( π /4 radians) : les deux angles du triangle rectangle sont égaux ; les longueurs a et b étant égales, nous pouvons choisir a = b = 1. On détermine alors le sinus, le cosinus et la tangente d'un angle de 45 degrés en utilisant le théorème de Pythagore (voir figure à gauche) :
  • Pour 30 degrés ( π/6 radians) et 60 degrés ( π/3 radians) : on considère un triangle équilatéral de longueur latérale 2. Tous ses angles internes sont de 60 degrés. En le divisant en deux parties égales, on considère un des deux triangles rectangles obtenus ayant un angle de 30° et un angle de 60°. Le petit côté de ce triangle rectangle est égal au demi-côté du triangle équilatéral : il vaut 1. Le troisième côté de ce triangle rectangle est d'une longueur c telle que (voir figure à droite) :
Angle |  | Sinus |  | Cosinus |  | Tangente
Degrés | Radians | Exact | Décimal | Exact | Décimal | Exacte | Décimale
 | 0 |  | 0 |  | 1 | 0 | 0
 |  |  | 0,2588… |  | 0,9659… |  | 0,2679…
 |  |  | 0,3826… |  | 0,9238… |  | 0,4142…
 |  |  | 0,5 |  | 0,8660… |  | 0,5773…
 |  |  | 0,7071… |  | 0,7071… | 1 | 1
 |  |  | 0,8660… |  | 0,5 |  | 1,7320…
 |  |  | 0,9238… |  | 0,3826… |  | 2,4142…
 |  |  | 0,9659… |  | 0,2588… |  | 3,7320…
 |  |  | 1 |  | 0 | ind. | infini
 |  |  | 0,8660… |  | –0,5 |  | –1,7320…
 |  |  | 0,7071… |  | –0,7071… | -1 | –1
 |  |  | 0,5 |  | –0,8660… |  | –0,5773…
 |  |  | 0 |  | –1 | 0 | 0

On peut se souvenir de certaines de ces valeurs en construisant la table suivante : en mettant dans l'ordre 0, π/6 (30°), π/4 (45°), π/3 (60°) et π/2 (90°), le sinus prend les valeurs √ n /2, et pour le cosinus, on prend l'ordre inverse.

  • Autres valeurs remarquables :
avec [image] le nombre d'or

Zéros

Les zéros de sin sont les réels qui s'écrivent k π (pour un certain entier relatif k). Ceux de cos sont les π /2 + k π .

Relations entre sinus et cosinus

NB : Les valeurs d'angles sont en radians.

Pour définir les angles strictement plus grands que 2π ou strictement négatifs, il suffit d'effectuer des rotations autour du cercle. De cette façon, le sinus et le cosinus deviennent des fonctions périodiques de période 2π , c'est-à-dire que pour tout angle θ et tout entier k :

Grâce au cercle, et avec des considérations géométriques simples, on peut voir que

Démonstration
  1. car θ + π et θ sont diamétralement opposés sur le cercle ;
  2. car π/2 – θ est le point symétrique de θ par rapport à la bissectrice de [image] ;
  3. car θ + π/2 se déduit de θ par rotation d'un quart de tour.
  4. car π – θ est le symétrique de θ par rapport à [image] ;
  5. car –θ est le symétrique de θ par rapport à

Ces formules font partie des identités trigonométriques.

Relations trigonométriques

À partir des formules d'addition (dont se déduisent celles de différence)

on démontre les formules de Simpson

et celles impliquant la « tangente de l'arc moitié » t = tan(a/2) :

Parité des fonctions

Les fonctions sinus et tangente sont impaires : pour tout réel x ,

et (si x appartient au domaine de définition de tan , c'est-à-dire s'il n'est pas de la forme π/2 + kπ avec k ∈ ℤ)

La fonction cosinus est paire : pour tout réel x ,

Dérivées

Fonction | sin | cos | tan | cot | arcsin | arccos | arctan | sec | csc
Dérivée |  |  |  |  |  |  |  |  |

On trouvera d'autres relations sur la page consacrée aux identités trigonométriques.

Limites

Les fonctions trigonométriques étant périodiques non constantes, elles ne possèdent pas de limite à l'infini.

La fonction tangente, non définie en π/2 + kπ , possède une limite infinie à gauche et à droite en ces points :

Relations avec la fonction exponentielle et les nombres complexes

Article détaillé : Trigonométrie complexe.

On peut montrer à partir de la définition des séries que les fonctions sinus et cosinus sont respectivement la partie imaginaire et la partie réelle de la fonction exponentielle quand son argument est imaginaire pur :

où i 2 = –1, ou encore :

Cette relation est généralement connue sous le nom de formule d'Euler. On en déduit que

Fonctions réciproques

Les fonctions trigonométriques ne sont pas bijectives. En les restreignant à certains intervalles, les fonctions trigonométriques réalisent des bijections. Les applications réciproques ( arcsin, arccos, arctan, arccsc, arcsec et arccot) sont habituellement définies par (pour tous réels x et y) :

  • y = arcsin x si et seulement si –π/2 ≤ y ≤ π/2 et x = sin y,
  • y = arccos x si et seulement si 0 ≤ y ≤ π et x = cos y,
  • y = arctan x si et seulement si –π/2 < y < π/2 et x = tan y,
  • y = arccsc x si et seulement si –π/2 ≤ y ≤ π/2 , y ≠ 0 et x = csc y,
  • y = arcsec x si et seulement si 0 ≤ y ≤ π , y ≠ π/2 et x = sec y,
  • y = arccot x si et seulement si 0 < y < π et x = cot y.

Ces fonctions peuvent s'écrire sous forme d'intégrales indéfinies :

Égalités pratiques :

Applications

Article détaillé : Applications de la trigonométrie.

Les fonctions trigonométriques, comme leur nom le suggère, ont une importance cruciale en trigonométrie, mais interviennent aussi dans l'étude des fonctions périodiques.

En trigonométrie

En trigonométrie, elles fournissent des relations intéressantes entre les longueurs des côtés et les angles d'un triangle quelconque.

Considérons un triangle quelconque :

Triangle avec hauteur.svg
  • la loi des sinus s'écrit :

Cette relation peut être démontrée en divisant le triangle en deux triangles rectangles et en utilisant la définition ci-dessus du sinus.

Le nombre commun [image] apparaissant dans le théorème est l'inverse du diamètre du cercle circonscrit au triangle (cercle passant par les trois points A, B et C). La loi des sinus est utile pour calculer des longueurs inconnues des côtés dans un triangle quelconque si deux angles et un côté sont connus. C'est une situation courante survenant dans la triangulation, une technique pour déterminer des distances inconnues en mesurant deux angles et une distance.

  • la loi des cosinus ou théorème d'Al-Kashi est une généralisation du théorème de Pythagore

À nouveau, ce théorème peut être démontré en divisant le triangle en deux triangles rectangles. La loi des cosinus est utile pour déterminer les données inconnues d'un triangle si deux des côtés et un angle sont connus. Remarquons que l'angle connu doit être contenu dans les deux côtés dont nous connaissons la longueur.

  • Il y a également la loi des tangentes :

L'utilisation des fonctions trigonométriques ne se limite pas seulement à l'étude des triangles. Les fonctions trigonométriques sont des fonctions périodiques dont les représentations graphiques correspondent à des modèles caractéristiques d'ondes, utilisés pour modéliser des phénomènes oscillatoires tels que le bruit ou les ondes de la lumière. Chaque signal peut être écrit comme une somme (en général infinie) de fonctions de sinus et de cosinus de différentes fréquences ; ce sont les séries de Fourier.

En analyse harmonique

Animation montrant la décomposition additive d'un signal carré lorsque le nombre d'harmoniques s'accroît

Les fonctions sinus et cosinus apparaissent aussi dans la description d'un mouvement harmonique simple, un concept important en physique. Dans ce contexte les fonctions sinus et cosinus sont utilisées pour décrire les projections sur un espace à une dimension d'un mouvement circulaire uniforme, le mouvement d'une masse au bout d'un ressort, ou une approximation des oscillations de faible écart angulaire d'un pendule.

Les fonctions trigonométriques sont aussi importantes dans d'autres domaines que celui de l'étude des triangles. Elles sont périodiques et leurs représentations graphiques sont des sinusoïdes et peuvent servir à modéliser des phénomènes périodiques comme le son, les ondes de lumière. Tout signal, vérifiant certaines propriétés, peut être décrit par une somme (généralement infinie) de fonctions sinus et cosinus de différentes fréquences ; c'est l'idée de base de l' analyse de Fourier, dans laquelle les séries trigonométriques sont utilisées pour résoudre de nombreux problèmes aux valeurs limites dans des équations aux dérivées partielles. Par exemple un signal carré, peut être décrit par une série de Fourier :

Fonctions de transition

Lorsque x parcourt [-π/2 ; π/2], la fonction sinus passe de la valeur -1 à la valeur 1. Elle est continue et dérivable, et ses tangentes sont horizontales aux extrémités de l'intervalle (les dérivées s'annulent en -π/2 et π/2). Cela en fait donc une fonction de choix pour remplacer une fonction de Heavyside, qui n'est elle pas continue.

Par exemple, si l'on veut qu'un dispositif passe d'une valeur y = a à une valeur b à l'instant t0, on peut le piloter par une loi de type

où τ est la durée de la transition. Ce type de loi de pilotage permet d'éviter un trop grand écart entre la valeur visée et la valeur instantanée, et des phénomènes de type oscillations amorties.

Par exemple, si un mobile doit subir une phase d'accélération puis une phase de décélération, on peut utiliser des lois sinusoïdales pour les transitions de vitesse. On s'assure ainsi que l'accélération est continue.

Article détaillé : À-coup#Loi sinusoïdale en vitesse.

Notes et références

  1. ↑ Extraits de la norme à l'usage des CPGE, p. 6 .
  2. ↑ Martin Aigner et Günter M. Ziegler , Raisonnements divins , Springer,‎ 2002 ( ISBN 978-2-28759723-7 , lire en ligne), chap. 19 (« La fonction cotangente et l'astuce de Herglotz »), p. 139-142 .
  3. ↑ ( en) Reinhold Remmert , Theory of Complex Functions , Springer, coll. « GTM » ( no 122),‎ 1991 ( ISBN 978-0-387-97195-7 , lire en ligne), p. 327 .
  4. ↑ Remmert 1991, p. 329-330.

Voir aussi

Sur les autres projets Wikimedia :

  • Fonctions circulaires, sur Wikiversity
  • Mnémoniques de trigonométrie, sur Wikibooks

Bibliographie

  • Adrien Guilmin, Cours élémentaire de trigonométrie rectiligne (1863), sur Gallica
  • Étienne-Louis Lefébure de Fourcy, Elémens de trigonométrie (1836), sur Gallica
  • ( en) Eli Maor, Trigonometric Delights, Princeton Univ. Press. (1998). Reprint edition (2002) ( ISBN 0-691-09541-8 )
  • ( en) Tristan Needham (en) , Preface" to Visual Complex Analysis. Oxford University Press, 1999 ( ISBN 0-19-853446-9 )
  • ( en) John J. O’Connor et Edmund F. Robertson , « The trigonometric functions » , dans MacTutor History of Mathematics archive , université de St Andrews ( lire en ligne) .
  • ( en) Ian Pearce , « Madhava of Sangamagramma » , dans John J. O'Connor et Edmund F. Robertson, MacTutor History of Mathematics archive , université de St Andrews ( lire en ligne)
  • ( en) Eric W. Weisstein, « Tangent », MathWorld

Articles connexes

  • Trigonométrie
  • Algorithme de calcul CORDIC
  • Table trigonométrique
  • Similarité cosinus
  • Sinus cardinal
  • Trigonométrie complexe
  • Trigonométrie hyperbolique

Liens externes

  • Étymologie du mot « sinus » sur le site « Principia » d' histoire et philosophie des sciences
  • Isométries de la sinusoïde et morphisme : note pour lycéens (étudiants du secondaire), sur le site personnel de X. Hubaut, professeur à l' Université libre de Bruxelles


Trigonométrie

Fonction hyperbolique

Une demi-droite passant par l'origine intersecte l'hyperbole d'équation x2 – y2 = 1 au point (cosha, sinha), où a est le double de l'aire algébrique de la surface délimitée par la demi-droite, l'hyperbole et l'axe des x. Voir aussi une version animée de ce schéma, avec une comparaison avec les fonctions trigonométriques.

En mathématiques, on appelle fonctions hyperboliques les fonctions cosinus hyperbolique, sinus hyperbolique et tangente hyperbolique. Les noms « sinus », « cosinus » et « tangente » proviennent de leur ressemblance avec les fonctions trigonométriques (dites « circulaires » car en relation avec le cercle unité x2 + y2 = 1) et le terme « hyperbolique » provient de leur relation avec l'hyperbole d'équation x2 – y2 = 1.

Elles sont utilisées en analyse pour le calcul intégral, la résolution des équations différentielles mais aussi en géométrie hyperbolique.

Sommaire

  • 1 Histoire
  • 2 Définitions
    • 2.1 Sinus hyperbolique
    • 2.2 Cosinus hyperbolique
    • 2.3 Tangente hyperbolique
    • 2.4 Cotangente hyperbolique
    • 2.5 Sécante hyperbolique
    • 2.6 Cosécante hyperbolique
    • 2.7 Tableau de variations
  • 3 Propriétés
  • 4 Applications réciproques
    • 4.1 Argument sinus hyperbolique
    • 4.2 Argument cosinus hyperbolique
    • 4.3 Argument tangente hyperbolique
    • 4.4 Argument cotangente hyperbolique
    • 4.5 Démonstrations de ces résultats
  • 5 Notes et références
  • 6 Voir aussi
    • 6.1 Article connexe
    • 6.2 Lien externe

Histoire

Les fonctions hyperboliques ont été inventées par le jésuite Vincenzo Riccati dans les années 1760 alors qu'il cherchait, avec son collègue Saladini, à calculer l'aire sous l'hyperbole d'équation x2 – y2 = 1. La méthode géométrique qu'il employa alors était très similaire à celle que l'on peut utiliser pour calculer l'aire d'un cercle d'équation x2 + y2 = 1. Le calcul de l'aire du cercle fait intervenir les fonctions trigonométriques classiques que Riccati nommait cosinus et sinus circulaires. Par analogie, il appela alors les fonctions qu'il venait de créer cosinus et sinus hyperboliques. Ce fut un choix heureux, car cette ressemblance ne s'arrête pas à la méthode de calcul d'aire mais aussi à toutes les formules trigonométriques. Cependant, pourtant au fait du travail de son contemporain Euler, il n'utilisa pas la fonction exponentielle pour les définir mais seulement des considérations géométriques. L'autre grand mathématicien ayant étudié les fonctions hyperboliques est Jean-Henri Lambert, qui en fit une étude complète en 1770. Cette quasi simultanéité fait que l'on attribue parfois à Lambert la paternité des fonctions hyperboliques, bien que les écrits de Riccati lui soient antérieurs de quelques années.

Définitions

Les fonctions hyperboliques sont analogues aux fonctions trigonométriques ou fonctions circulaires. Ce sont les fonctions :

Sinus hyperbolique
Cosinus hyperbolique
Tangente hyperbolique

Sinus hyperbolique

Article détaillé : Sinus hyperbolique.

Définie comme étant la partie impaire de la fonction exponentielle, c’est-à-dire par :

sinh — ou sh — est une bijection de classe C∞ de ℝ dans ℝ strictement croissante, et impaire. Sa dérivée est le cosinus hyperbolique. Son application réciproque est l'argument sinus hyperbolique.

Cosinus hyperbolique

Article détaillé : Cosinus hyperbolique.

Définie comme étant la partie paire de la fonction exponentielle, c’est-à-dire par :

cosh — ou ch — est une application de ℝ dans [1, +∞[ strictement croissante sur ℝ+, et paire. cosh est de classe C∞ sur ℝ et sa dérivée est le sinus hyperbolique. Sa restriction à ℝ+ est une bijection à valeurs dans [1, +∞[ dont l'application réciproque est l'argument cosinus hyperbolique.

Tangente hyperbolique

Article détaillé : Tangente hyperbolique.

Définie par :

tanh — ou th — est une bijection de classe C∞ de ℝ dans ]–1, 1[ strictement croissante, et impaire. Sa dérivée est [image]. Son application réciproque est l'argument tangente hyperbolique.

Cotangente hyperbolique

Définie par :

coth est une bijection de classe C∞ de ℝ* dans ]–∞, –1[∪]1, +∞[. Sa dérivée est [image]. Son application réciproque est l'argument cotangente hyperbolique.

Sécante hyperbolique

Définie par :

Cosécante hyperbolique

Définie par :

Tableau de variations

Les fonctions sinh, tanh, et coth sont impaires et la fonction cosh est paire, on peut donc réduire leur domaine d'étude à [0, +∞[.

x | 0 | +
cosh x | 1 | +
sinh x | 0 | +
tanh x | 0 | +1
coth x | + | +1

Propriétés

Par construction,

On en déduit la formule suivante :

De même que les points (cosx, sinx) décrivent un cercle lorsque x parcourt ℝ, les points (coshx, shx) décrivent une branche d'hyperbole.

Le paramètre x ne peut pas être interprété comme un angle, ni comme une longueur d'arc ; les fonctions hyperboliques sont périodiques, mais de période imaginaire pure.

La fonction cosh admet 1 pour minimum, en 0.

La fonction sinh est impaire et ainsi sinh(0) = 0.

Les fonctions hyperboliques satisfont à des relations, très ressemblantes aux identités trigonométriques. En fait, la règle d'Osborn[1] dit que l'on peut convertir n'importe quelle identité trigonométrique en une identité hyperbolique en la développant complètement à l'aide de puissances entières de sinus et cosinus, changeant sin en sinh et cos en cosh, et remplaçant le signe de chaque terme qui contient un produit de deux sinus en son opposé.

Cela nous permet d'obtenir par exemple, les formules d'addition et de soustraction :

et des « formules d'angle moitié » (la deuxième étant valide si x est positif ou nul) :

De ces expressions on déduit les formules suivantes relatives à la tangente hyperbolique :

On a de même :

La fonction cosinus hyperbolique est convexe. Elle intervient dans la définition de la chaînette, laquelle correspond à la forme que prend un câble suspendu à ses extrémités et soumis à son propre poids.

Puisque la fonction exponentielle peut être prolongée à l'ensemble des nombres complexes, nous pouvons aussi étendre les définitions des fonctions hyperboliques à l'ensemble des nombres complexes. Les fonctions sinus hyperbolique et cosinus hyperbolique sont alors holomorphes et même entières.

Des formules d'Euler, on obtient immédiatement:

Ou encore:

D'autres relations entre fonctions hyperboliques et circulaires sont données par la fonction de Gudermann ou Gudermannien.

Applications réciproques

Argument sinus hyperbolique

Argument sinus hyperbolique

arsinh — ou argsh[2] — est l'application réciproque de sinh. C'est une bijection de ℝ dans ℝ, impaire et strictement croissante. arsinh est dérivable sur ℝ et sa dérivée est [image]. arsinh admet la forme logarithmique suivante :

Argument cosinus hyperbolique

Argument cosinus hyperbolique

arcosh — ou argch[3] — est l'application réciproque de la restriction de cosh dans ℝ+. C'est une bijection de [1, +∞[ dans ℝ+, strictement croissante. arcosh est dérivable sur ]1, +∞[ et sa dérivée est [image]. arcosh admet une forme logarithmique :

Argument tangente hyperbolique

Argument tangente hyperbolique

artanh — ou argth[4] — est l'application réciproque de tanh. C'est une bijection de ]–1, 1[ dans ℝ, impaire, strictement croissante. artanh est dérivable sur ]–1, 1[ et sa dérivée est [image]. artanh admet une forme logarithmique :

Argument cotangente hyperbolique

arcoth — ou argcoth[5] — est l'application réciproque de coth. C'est une bijection de ]–∞, –1[∪]1, +∞[ dans ℝ*. arcoth est dérivable sur ]–∞, –1[∪]1, +∞[ et sa dérivée est [image]. arcoth admet une forme logarithmique :

Démonstrations de ces résultats

Le calcul explicite de ces formes logarithmiques revient à résoudre, par exemple, l'équation [image] ; posant [image], on est amené à l'équation du second degré [image], dont la seule solution positive est [image], mais il peut être plus simple de remarquer que, puisque [image], on aura [image].

Notes et références

  1. ↑ (en) Eric W. Weisstein, « Osborn's Rule », MathWorld.
  2. ↑ La norme ISO 31-11 recommande la notation « arsinh » pour cette fonction.
  3. ↑ La norme ISO 31-11 recommande la notation « arcosh » pour cette fonction.
  4. ↑ La norme ISO 31-11 recommande la notation « artanh » pour cette fonction.
  5. ↑ La norme ISO 31-11 recommande la notation « arcoth » pour cette fonction.

Voir aussi

Sur les autres projets Wikimedia :

  • Trigonométrie hyperbolique, sur Wikiversity

Article connexe

Primitives de fonctions hyperboliques réciproques

Lien externe

(en) « Vincent Riccati, S.J. (1707 - 1775) and his hyperbolic functions »


Trigonométrie

Fonction de Gudermann

En mathématiques, la fonction de Gudermann, appelée aussi parfois gudermannien, et notée gd, nommée en l'honneur de Christoph Gudermann, fait le lien entre la trigonométrie circulaire et la trigonométrie hyperbolique sans faire intervenir les nombres complexes.

Sommaire

  • 1 Définition
  • 2 Fonction réciproque
  • 3 Applications
  • 4 Voir aussi
  • 5 Références

Définition

Fonction de Gudermann avec son asymptote (en gris) : .

La fonction de Gudermann est définie sur l'ensemble des réels par :

La dérivée de la fonction de Gudermann est la fonction [image].

Le réel [image], appelé parfois gudermannien de t, est relié à ce dernier par les relations :

Fonction réciproque

La réciproque de la fonction de Gudermann est définie sur [image] par :

La dérivée de cette fonction réciproque est la fonction [image].

Applications

  • Les coordonnées de Mercator d'un point de la sphère sont définies par [image] et [image].

Elles sont ainsi définies de sorte que les loxodromies de la sphère soient représentées par des droites dans le plan x,y.

  • Le changement de variable [image] permet de transformer des intégrales de fonctions circulaires en intégrales de fonctions hyperboliques ; par exemple, [image].
  • Ceci explique pourquoi on peut choisir des fonctions circulaires ou hyperboliques lors de changement de variables dans le calcul d'intégrales :

Quand on rencontre du [image], on utilise [image] ou [image], et on utilise aussi [image] ou [image].

Quand on rencontre du [image], on utilise [image] ou [image].

  • Paramétrisation d'un cercle ou d'une droite hyperbolique.

Si on pose [image], on a évidemment une paramétrisation du demi-cercle de rayon 1 dans le demi-plan x>0 ; [image] est la distance curviligne dans le demi-plan euclidien entre le point (x,y) et le point (1,0), et t est aussi une distance, mais mesurée entre ces deux points dans le demi-plan considéré comme demi-plan de Poincaré pour la géométrie hyperbolique.

Voir aussi

  • La projection de Mercator
  • Les fonctions elliptiques de Jacobi

Références

  • (en) CRC Handbook of Mathematical Sciences 5th ed. pp 323–5.
  • (en) Cet article est partiellement ou en totalité issu de l’article de Wikipédia en anglais intitulé « Gudermannian function » (voir la liste des auteurs).


Trigonométrie

Inégalité de Huygens

Inégalité de Huygens sur le cercle trigonométrique

L'inégalité de Huygens est un résultat mathématique établissant que, sur l'intervalle [image] de [image], l'inégalité suivante est vérifiée : .

Cette inégalité signifie que, dans le dessin ci-contre, la longueur de l'arc BC est inférieure à la moyenne pondérée de la longueur CD affectée du coefficient 2 et de la longueur BE affectée du coefficient 1, ou, plus simplement, que la longueur de l'arc BC est plus petite que celle du segment [BG].

Sommaire

  • 1 Démonstration par l'utilisation de la dérivée
  • 2 Note historique
  • 3 Notes et références
  • 4 Voir aussi
    • 4.1 Articles connexes
    • 4.2 Bibliographie

Démonstration par l'utilisation de la dérivée

Soit f fonction qui à tout x de [image], associe [image].
Cette fonction est dérivable sur cet intervalle comme somme de fonctions dérivables. La fonction dérivée de f est la fonction f' qui à tout x de l'intervalle considéré associe :

.

Sur l'intervalle considéré, les inégalités suivantes sont vérifiées : et [image].

Donc, [image] et la fonction f est croissante sur l'intervalle considéré.

On remarque l'égalité : f(0) = 0 par conséquent :

Note historique

Cette inégalité, associée à cette minoration[1]:

fournit un meilleur encadrement de x que le simple encadrement

Appliqué à [image], cet encadrement sert à améliorer la méthode d'Archimède pour calculer Pi. En fait, Snell, dans sa Cyclometria (1621) énonçait déjà cette formule, mais sans la démontrer rigoureusement[2]. Huygens dans son ouvrage de Circuli dimensione (1654) se propose de démontrer ces inégalités et d'en présenter d'autres, utiles à la quadrature du cercle approchée[3]. Ce problème ancien, déjà abordé par Nicolas de Cuse dans son De mathematica perfectione (1512), avait fait l'objet plus récemment d'un travail de Grégoire de Saint-Vincent, Opus geometricum quadraturae circuli (1647).

La démonstration de Huygens diffère de celle indiquée ci-dessus : elle est géométrique. Bien que Huygens dans des travaux ultérieurs sur la cycloïde détermine les tangentes de diverses courbes, il restera toujours prudent vis-à-vis du calculus.

La démonstration que l'on peut tirer du de Circuli[4], est assez astucieuse et se réfère, d'une part à une inégalité d'aires, itérée, d'autre part à des propriétés de proportionnalités entre segments.

Il existe de nos jours des dizaines d'inégalités de ce type[5] démontrées maintenant avec des outils d'analyse (Développement limité, règle de l'Hôpital sur la monotonie,...)

Notes et références

  1. ↑ Christian Huygens, De circuli magnitudine inventa, Théorème VII Proposition VII, Œuvres complètes de Christiaan Huygens. Travaux de mathématiques pures, 1652-1656 / publ. par la Société hollandaise des sciences, p 132
  2. ↑ Cf. « Œuvres complètes de Christiaan Huygens. Travaux de mathématiques pures, 1652-1656 », Société hollandaise des sciences, p. 95
  3. ↑ Huygens craint en particulier de se faire devancer par Marcus Marci (Œuvres complètes de Christiaan Huygens. Travaux de mathématiques pures, 1652-1656 / publ. par la Société hollandaise des sciences, p. 98)
  4. ↑ Christian Huygens, De circuli magnitudine inventa, théorèmes IV, VI, VIII et IX
  5. ↑ Voir par exemple Some new inequalities of the Huygens type, Ling Zhu, 2009,ou encore The natural approach of wilker-cusa-huygens inequalities, Cristinel Mortici, 2010


Trigonométrie

Identité trigonométrique

Une identité trigonométrique est une relation impliquant des fonctions trigonométriques et qui est vérifiée pour toutes les valeurs des variables intervenant dans la relation. Ces identités peuvent être utiles quand une expression comportant des fonctions trigonométriques a besoin d'être simplifiée. Elles constituent donc une « boîte à outils » utile pour la résolution de problèmes.

Les fonctions trigonométriques sont définies géométriquement ou analytiquement. Elles servent beaucoup en intégration, pour intégrer des fonctions « non trigonométriques » : un procédé habituel consiste à effectuer un changement de variable en utilisant une fonction trigonométrique, et à simplifier ensuite l'intégrale obtenue avec les identités trigonométriques.

Notation : si ƒ est une fonction trigonométrique, ƒ2 désigne la fonction qui à tout réel x associe le carré de ƒ(x). Par exemple : cos2 x = (cos x)2.

Sommaire

  • 1 Relations entre fonctions trigonométriques
  • 2 Propriétés liées au cercle trigonométrique
    • 2.1 Symétries, parité
    • 2.2 Périodicité, décalages
    • 2.3 Équations trigonométriques
  • 3 Formules d'addition et de différence
  • 4 Formules de duplication et d'angle moitié
    • 4.1 Formules de l'angle double
    • 4.2 Formules de réduction du carré
    • 4.3 Formules d'angle moitié
    • 4.4 Formules impliquant la « tangente de l'arc moitié »
  • 5 Formules de Simpson
    • 5.1 Transformation de produits en sommes
    • 5.2 Transformation de sommes en produits
  • 6 Formules d'Euler
  • 7 Formule de Moivre et formules d'angle multiple
  • 8 Linéarisation
  • 9 Fonctions trigonométriques réciproques
  • 10 Propriétés métriques dans un triangle quelconque
    • 10.1 Théorème d'Al-Kashi ou loi des cosinus
    • 10.2 Formule des sinus
    • 10.3 Formule des différences des côtés
  • 11 Identités sans variable
  • 12 En analyse
    • 12.1 Encadrement
    • 12.2 Dérivées
    • 12.3 Primitives
  • 13 Articles connexes
  • 14 Notes et références

Relations entre fonctions trigonométriques

Les relations entre fonctions trigonométriques résultent d'une part de définitions

et d'autre part de l'application du théorème de Pythagore, notamment :

Relations entre fonctions trigonométriques dans le premier quadrant ( [image] )[1].
 | cos | sin | tan | cot | sec | csc
cos |  |  |  |  |  |
sin |  |  |  |  |  |
tan |  |  |  |  |  |
cot |  |  |  |  |  |
sec |  |  |  |  |  |
csc |  |  |  |  |  |

Propriétés liées au cercle trigonométrique

Symétries, parité

Parité - Réflexion d'axe (θ = 0) | Réflexion d'axe (θ = π/4) | Réflexion d'axe (θ = π/2)

Note : Toutes ces formules sont également valables pour des ajouts d'angles, il suffit pour cela de prendre l'opposé : . Il suffit ensuite d'appliquer la formule de simplification correspondante de la première colonne.

Périodicité, décalages

Décalage de π/2 | Décalage de π (Période de tan et cot) | Décalage de 2π (Période de sin et cos)

Équations trigonométriques

Certaines des équations ci-dessus sont renforcées par les équivalences suivantes :

Formules d'addition et de différence

Les deux formules principales sont les formules d'addition pour le cosinus et le sinus :

En remplaçant [image] par son opposé, on obtient aussi les formules de différence :

Le moyen le plus rapide pour les démontrer est, à partir de la définition analytique du cosinus et du sinus, d'utiliser les formules d'Euler. On peut, alternativement, les déduire de la définition géométrique.

Démonstration géométrique

Il existe de nombreuses démonstrations possibles, utilisant les propriétés d'une corde dans un cercle, la relation entre cosinus d'un angle et produit scalaire, la propriété du changement de repère, etc. La démonstration proposée ici utilise l'expression de la matrice d'une rotation plane (dans une base orthonormée directe) en fonction du cosinus et du sinus de son angle :

La rotation vectorielle plane d'angle a + b est la composée des rotations d'angles a et b donc sa matrice est le produit des matrices Ra et Rb :

Les formules s'obtiennent alors par identification.

On en déduit les formules d'addition et de différence pour la tangente :

Démonstration

La formule s'obtient par quotient, puis division au numérateur et dénominateur par cos a cos b :

Une autre conséquence intéressante de ces égalités est qu'elles permettent de ramener la combinaison linéaire d'un sinus et d'un cosinus à un sinus : où [image] si α est positif et [image] sinon.

Formules de duplication et d'angle moitié

Formules de l'angle double

Appelées aussi « formules d'angle double », elles peuvent être obtenues, pour les deux premières, en remplaçant θ1 et θ2 par x dans les formules d’addition ou en utilisant la formule de Moivre avec n = 2. Les deux suivantes se déduisent du théorème de Pythagore.

Formules de réduction du carré

Ces formules permettent d'écrire cos2 θ, sin2 θ et tan2 θ en fonction du cosinus de l'angle double.

Formules d'angle moitié

Démonstration

Les deux premières identités se déduisent des formules de réduction des carrés en remplaçant x par x/2.

La troisième s'obtient en écrivant [image] où l'égalité finale vient des formules d'angle double.

La dernière (où sin x est supposé non nul) se déduit de

Une conséquence[réf. nécessaire]

Une conséquence de la formule du cosinus de l'angle moitié est la suivante :

avec (n - 1) radicaux imbriqués et autant de nombres « 2 » sous ces radicaux. En passant à la limite, on a une démonstration du fait que :

Formules impliquant la « tangente de l'arc moitié »

Si l'on pose

on a :

Dans le cas de changement de variable en intégration, on ajoutera :

Ces formules permettent de simplifier des calculs trigonométriques en se ramenant à des calculs sur des fractions rationnelles. Elles permettent aussi de déterminer l'ensemble des points rationnels du cercle unité.

Formules de Simpson

Transformation de produits en sommes

Ces formules peuvent être démontrées en développant leurs membres de droite en utilisant les formules d'addition

Transformation de sommes en produits

Il suffit de remplacer a par [image] et b par [image] dans les formules de transformation de produit en somme.

Formules d'Euler

où i est l'unité imaginaire. On en déduit que

Article détaillé : Formules d'Euler.
Article connexe : Trigonométrie complexe.

Formule de Moivre et formules d'angle multiple

La formule de de Moivre s'écrit :

Si [image] est le n -ième polynôme de Tchebychev alors

Pour tout entier naturel n on a

un coefficient binomial.

Le noyau de Dirichlet [image] est la fonction définie par :

pour tout réel x,

Le produit de convolution de n'importe quelle fonction de carré intégrable et de période [image] avec le noyau de Dirichlet coïncide avec la somme d'ordre n de sa série de Fourier.

Linéarisation

La linéarisation d'une expression cospx sinqx, qui a pour but de l'exprimer comme combinaison linéaire de divers cos(nx) (si q est pair) ou sin(nx) (si q est impair) — par exemple pour en calculer une primitive — commence par l'utilisation des formules d'Euler :

Il suffit ensuite de

  • développer chacun des deux facteurs grâce à la formule du binôme de Newton,
  • développer le produit des deux sommes obtenues (par distributivité),
  • simplifier les termes en utilisant que
  • puis les regrouper, sachant que

Si l'un des deux exposants p ou q est nul, en appelant « degré » la valeur de l'autre, on a :

Formules de linéarisation de degré 2 ou 3

Les formules de linéarisation de degré 2 sont les « formules de réduction du carré » vues plus haut.

Formules de linéarisation de degré quelconque

Fonctions trigonométriques réciproques

Ce sont les fonctions réciproques des fonctions sinus, cosinus et tangente.

Si x > 0 alors

.

Si x < 0 alors le côté droit de l'égalité doit être remplacé par [image].

où

Beaucoup d'identités similaires aux suivantes peuvent être obtenues à partir du théorème de Pythagore.

Relations entre fonctions trigonométriques inverses pour x>0
 | arccos | arcsin | arctan | arccot
arccos |  |  |  |
arcsin |  |  |  |
arctan |  |  |  |
arccot |  |  |  |

Propriétés métriques dans un triangle quelconque

Article détaillé : résolution d'un triangle.
Cet article ou cette section concernant les mathématiques doit être recyclé.
Une réorganisation et une clarification du contenu est nécessaire. Discutez des points à améliorer en page de discussion.

Théorème d'Al-Kashi ou loi des cosinus

Article détaillé : Théorème d'Al-Kashi.

Soit un triangle ABC, dans lequel on utilise les notations usuelles : d'une part α, β et γ pour les angles et, d'autre part, a, b et c pour les longueurs des côtés respectivement opposés à ces angles. Alors on a :

Formule des sinus

Fig. 1 - Notations usuelles dans un triangle quelconque.

Soit un triangle ABC de côtés de longueurs a, b et c (le côté [AB] est de longueur c, etc.), d'aire S, de hauteur h, de demi-périmètre p et dont le rayon du cercle circonscrit est R (voir figure ci-contre). Nous avons l'égalité suivante :

Il suffit de voir que ha = 2S avec [image] donc [image]. D'autre part soit I le point de concours des bissectrices r le cercle inscrit ra +rb + rc = 2S = 2rp.

Formule des différences des côtés

(Se rappeler que [image] étant aigu, [image] et appliquer le théorème d'Al-Kashi.)

Identités sans variable

Richard Feynman s'est rappelé toute sa vie cette curieuse identité, qu'il appelait Morrie's law :

Une telle identité est un exemple d'identité qui ne contient pas de variable et s'obtient à partir de l'égalité :

Les relations suivantes peuvent aussi être considérées comme des identités sans variable :

Il se trouve que la mesure en degrés des angles ne donne pas une formule plus simple qu'avec la mesure en radians lorsque nous considérons cette identité avec 21 aux dénominateurs :

Mais les facteurs 1, 2, 4, 5, 8, 10 peuvent nous faire penser aux entiers inférieurs à 21/2 qui n'ont pas de facteur commun avec 21. Les derniers exemples sont des conséquences d'un résultat de base sur les polynômes cyclotomiques ; les cosinus sont les parties réelles des racines de ces polynômes ; la somme des zéros donne la valeur de la fonction de Möbius en 21 (dans le tout dernier cas qui précède) ; seulement la moitié des racines sont présentes dans la relation précédente.

En analyse

En analyse, il est essentiel que les angles qui apparaissent comme arguments de fonctions trigonométriques soient mesurés en radians ; s'ils sont mesurés en degrés ou dans n'importe quelle autre unité, alors les relations reportées ci-dessous deviennent fausses.

Encadrement

L'analyse consiste souvent à encadrer une fonction. La signification géométrique du sinus et de la tangente « montre [2] » — et le théorème des accroissements finis démontre — que

Détails
  • L'argument géométrique consiste (cf. figure ci-contre et § « Limites » de l'article sur la fonction sinus) à encadrer l'aire d'un secteur circulaire du disque unité, d'angle θ = x, par celle de deux triangles :
    • l'aire du triangle OAD, contenu dans le secteur, vaut (sinθ)/2 ;
    • celle du secteur vaut par définition θ/2 ;
    • celle du triangle OCD, qui le contient, vaut (tanθ)/2.
  • La preuve analytique consiste à considérer un réel y (fourni par le théorème des accroissements finis) tel que
    et à remarquer que

Cet encadrement est souvent utilisé ; deux exemples sont la méthode d'Archimède pour le calcul du nombre π (voir quadrature du cercle) et le problème de Bâle.

Dérivées

Les dérivées de sin et cos peuvent se déduire l'une de l'autre par décalage de π/2. Elles sont :

Exemples de démonstrations
  • Si les fonctions trigonométriques sont définies géométriquement, on se convainc d'abord de l'encadrement ci-dessus, dont on déduit immédiatement (grâce au théorème des gendarmes) [image] Cette limite permet de calculer les dérivées de sin et cos, à partir de la définition du nombre dérivé comme limite d'un taux d'accroissement, en transformant la différence en produit dans le numérateur de ce taux.
  • Si les fonctions trigonométriques sont définies analytiquement, alors les dérivées peuvent être obtenues en dérivant les séries entières terme à terme.

Les autres fonctions trigonométriques peuvent être dérivées en utilisant les identités précédentes et les règles de dérivation. Par exemple :

Primitives

Les identités sur les intégrales peuvent être trouvées dans la table des primitives de fonctions trigonométriques.

Articles connexes

  • Fonction hyperbolique
  • Trigonométrie

Notes et références

  1. ↑ (en) Milton Abramowitz et Irene Stegun, Handbook of Mathematical Functions with Formulas, Graphs, and Mathematical Tables [détail de l’édition] (lire en ligne), p. 73, 4.3.45.
  2. ↑ (en) Fred Richman, « A Circular Argument », The College Mathematics Journal (en), vol. 24, no 2,‎ mars 1993, p. 160-162 (lire en ligne).


Trigonométrie

Loi des sinus

Fig. 1 - Notations usuelles dans un triangle quelconque.

En trigonométrie, la loi des sinus est une relation de proportionnalité entre les longueurs des côtés d'un triangle et les sinus des angles respectivement opposés.

On considère un triangle quelconque ABC, représenté sur la Fig. 1 ci-contre, où les angles sont désignés par les minuscules grecques et les côtés opposés aux angles par la minuscule latine correspondante :

  • a = BC et α = angle formé par [AB] et [AC] ;
  • b = AC et β = angle formé par [BA] et [BC] ;
  • c = AB et γ = angle formé par [CA] et [CB].

La formule dite des sinus est alors :

,

On a même mieux :

,

où R est le rayon du cercle circonscrit au triangle ABC et

est l'aire du triangle donnée à partir du demi-périmètre p par la formule de Héron.

La relation de proportionnalité est parfois résumée ainsi :

Le théorème peut être utilisé

  • pour déterminer le rayon du cercle circonscrit
  • pour résoudre un triangle dont on connaît deux angles et un côté.

Sommaire

  • 1 Démonstrations
    • 1.1 En exprimant une hauteur de deux manières
    • 1.2 Par le calcul de l'aire du triangle
  • 2 Voir aussi
    • 2.1 Liens externes
    • 2.2 Articles connexes

Démonstrations[ modifier | modifier le code ]

En exprimant une hauteur de deux manières[ modifier | modifier le code ]

Law of sines proof.svg

On considère un triangle de côtés a, b, et c, et α, β, γ ses angles aux sommets A, B, et C. La hauteur issue de C divise le triangle ABC en deux triangles rectangles. Notons h cette hauteur ; on peut appliquer la définition du sinus dans les deux petits triangles rectangles pour exprimer h :

Dont on tire deux expressions pour h :

et donc :

En faisant de même avec la hauteur issue de A on obtient :

Par le calcul de l'aire du triangle

L'aire S du triangle peut se calculer en choisissant le côté AB=c comme base et h comme hauteur et on obtient alors:

Ainsi l'aire S du triangle peut être exprimée de l'une de ces trois façons selon le côté que l'on choisit comme base:

En multipliant par 2/abc on obtient:

Finalement en prenant l'inverse on obtient bien la relation énoncée

Voir aussi

Liens externes

  • (en) Eric W. Weisstein, « Law of Sines », MathWorld
  • (en) Eric W. Weisstein, « Generalized Law of Sines », MathWorld

Articles connexes

  • Trigonométrie :
    • sinus ;
    • fonction trigonométrique ;
    • trigonométrie sphérique ;
    • triangulation.
  • Géométrie du triangle :
    • loi des cosinus ;
    • loi des tangentes ;
    • résolution d'un triangle.

(en) Cet article est partiellement ou en totalité issu de l’article de Wikipédia en anglais intitulé « Law of sines » (voir la liste des auteurs).


Trigonométrie

Loi des cosinus

En mathématiques, la loi des cosinus est un théorème de géométrie couramment utilisé en trigonométrie, qui relie dans un triangle la longueur d'un côté à celles des deux autres et au cosinus de l'angle formé par ces deux côtés. Cette loi s'exprime de façon analogue en géométrie plane, sphérique ou hyperbolique.

En ce qui concerne la géométrie plane, elle est également connue sous les noms de théorème d'Al-Kashi, en France, ou encore théorème de Pythagore généralisé[1]. Il généralise en effet le théorème de Pythagore aux triangles non rectangles. Bien qu'un résultat similaire (avec des longueurs seulement) était déjà connu d'Euclide[2], le nom francisé du mathématicien perse Ghiyath al-Kashi (1380 - 1429) apparut dans les années 1990 dans les manuels scolaires édités en France, les appellations théorème de Pythagore généralisé ou loi des cosinus étant utilisées jusque-là.

Sommaire

  • 1 En géométrie plane
    • 1.1 Énoncé
    • 1.2 Histoire
    • 1.3 Le théorème et ses applications
    • 1.4 Démonstrations
      • 1.4.1 Démonstration d'Euclide
      • 1.4.2 Démonstration d'Al-Kashi
      • 1.4.3 Par un découpage d'aires
      • 1.4.4 Par le théorème de Pythagore
      • 1.4.5 En utilisant la puissance d'un point par rapport à un cercle
      • 1.4.6 À l'aide du produit scalaire
  • 2 En géométrie non euclidienne
    • 2.1 En géométrie sphérique
    • 2.2 En géométrie hyperbolique
  • 3 Généralisation à l'espace euclidien
  • 4 Notes et références
  • 5 Voir aussi
    • 5.1 Articles connexes
    • 5.2 Liens externes
    • 5.3 Bibliographie

En géométrie plane

Énoncé

Fig. 1 - Notations usuelles dans un triangle quelconque.

La loi des cosinus s'énonce de la façon suivante :

Soit un triangle ABC, dans lequel on utilise les notations usuelles exposées sur la figure 1 : d'une part α, β et γ pour les angles et, d'autre part, a, b et c pour les longueurs des côtés respectivement opposés à ces angles.

Histoire

Fig. 2 - Triangle ABC avec hauteur BH.

Les Éléments d'Euclide datant du IIIe siècle av. J.-C., contenaient déjà une approche géométrique de la généralisation du théorème de Pythagore : les propositions 12 et 13 du livre II, traitent séparément le cas d'un triangle obtusangle et celui d'un triangle acutangle. L'absence de fonction trigonométrique et d'algèbre oblige à formuler le théorème en termes de différences d'aires. Aussi la proposition 12 énonce-t-elle :

« Dans les triangles obtusangles, le carré du côté qui soutend l'angle obtus est plus grand que les carrés des côtés qui comprennent l'angle obtus, de deux fois le rectangle compris sous celui des côtés de l'angle obtus sur le prolongement duquel tombe la perpendiculaire, et sous la droite prise extérieurement de la perpendiculaire à l'angle obtus. »

— Euclide, Les Éléments[3]

En notant ABC le triangle d'angle obtus C et H le pied de la hauteur issue de B (cf. Fig. 2 ci-contre), les notations modernes permettent de résumer l'énoncé ainsi :

AB² = CA² + CB² + 2 CH x AC

Il fallut attendre la trigonométrie arabo-musulmane au Moyen Âge pour voir le théorème évoluer dans sa forme et dans sa portée. Durant la même période sont établies les premières tables trigonométriques, pour les fonctions sinus et cosinus. En 1428, on trouve un énoncé du théorème, utilisant les cosinus, dans l'œuvre d'al-Kashi, Les clés de l'arithmétique[4].

C'est au début du XIXe siècle que les notations algébriques modernes permettent d'écrire le théorème sous sa forme actuelle et qu'il prend dans de nombreuses langues le nom de loi (ou théorème) des cosinus.

Le théorème et ses applications[ modifier | modifier le code ]

Fig. 3 - Utilisation du théorème d'Al-Kashi : angle ou côté inconnu.

La loi des cosinus généralise le théorème de Pythagore, puisqu'elle permet d'énoncer que l'angle [image] est droit (autrement dit [image] = 0) si et seulement si [image].

Plus généralement, le théorème s'utilise en triangulation (voir Fig. 3) pour résoudre un triangle, à savoir déterminer

  • le troisième côté d'un triangle dont on connaît un angle et les côtés adjacents :
  • les angles d'un triangle dont on connaît les trois côtés :

Ces formules sont instables numériquement dans le cas de triangles en épingle, c'est-à-dire lorsque c est petit devant a et b — ou, de façon équivalente, lorsque γ est petit devant 1.

Il existe un corollaire de la loi des cosinus : pour deux triangles directement semblables ABC et A'B'C'

Démonstrations

Tout comme le théorème de Pythagore, le théorème d'Al-Kashi possède de nombreuses démonstrations, certaines utilisant des propriétés sur les aires comme celles d'Euclide ou d'Al-Kashi, d'autres utilisant des propriétés trigonométriques ou liées au cercle. Enfin, le théorème d'Al-Kashi peut être vu comme une application des propriétés sur le produit scalaire [5].

Démonstration d'Euclide

Fig. 4 - Démonstration du théorème d'Al-Kashi pour un angle obtus : « selon Euclide ».

La démonstration d'Euclide[6] par la proposition 12 (angle obtus) et 13 (angle aigu) s'appuie sur le théorème de Pythagore et fait intervenir le point H pied de la hauteur issue de B. Pour Euclide cette propriété est une propriété sur des aires. Pour l'angle obtus (proposition 12), Euclide construit le carré extérieur au triangle AHB de côté [AH] et remarque que

Il lui suffit alors d'ajouter l'aire du carré de côté HB

et d'utiliser le théorème de Pythagore deux fois

triangle rectangle AHB
AB^2 = AH^2 + HB^2
triangle rectangle CHB
CB^2 = HB^2 + CH^2

On obtient

Une démonstration analogue est réalisable pour l'angle aigu.

Démonstration d'Al-Kashi

Fig. 5 - Démonstration du théorème d'Al-Kashi pour un triangle acutangle : « selon Al-Kashi ».

Dans son livre Clé de l'arithmétique en 1429[7], Al-Kashi généralise le théorème de Pythagore et introduit dans l'égalité la trigonométrie. Pour lui aussi, cette propriété est liée aux aires. Ainsi dans un triangle aigu ABC, il mène par A et par B les hauteurs du triangle qui découpent dans les carrés s'appuyant sur CB et CA des rectangles. La somme des aires des rectangles de diagonales BF et AG correspond à l'aire du carré sous AB et les rectangles de diagonales CF et CG ont une même aire égale à CB × CA × cos(C) Ce qui donne effectivement

Une démonstration analogue est envisageable pour un triangle obtusangle en opérant par soustraction d'aires.

Par un découpage d'aires

Fig. 6a - Démonstration du théorème d'Al-Kashi pour les triangles à angles aigus : « méthode du découpage ».
Fig. 6b - Démonstration du théorème d'Al-Kashi dans le cas d'un angle obtus : « méthode du découpage »

Un certain nombre des démonstrations du théorème font intervenir un calcul d'aires [8]. Il convient en effet de remarquer que

  • , [image] et [image] sont les aires de carrés de côtés respectifs a, b et c ;
  • est celle d'un parallélogramme de côtés a et b formant un angle [image], le changement de signe de [image] lorsque l'angle [image] devient obtus rendant une étude par cas obligatoire.

La figure 6a (ci-contre) découpe un heptagone de deux manières différentes de sorte à démontrer le théorème d'Al-Kashi dans le cas d'un angle aigu. Interviennent :

  • en rose, les aires [image], [image] à gauche, et les aires [image] et [image] à droite ;
  • en bleu, le triangle ABC, à droite comme à gauche ;
  • en gris, quelques triangles supplémentaires, identiques au triangle ABC et en même nombre dans les deux découpages.

L'égalité des aires de droite et de gauche donne

.

La figure 6b (ci-contre) découpe un hexagone de deux manières différentes de façon à démontrer le théorème d'Al-Kashi dans le cas d'un angle obtus. La figure montre

  • en rose, les aires [image], [image] et [image] à gauche, et l'aire [image] à droite ;
  • en bleu, deux fois le triangle ABC, à droite comme à gauche.

L'égalité des aires à droite et à gauche donne

.

Une démonstration rigoureuse nécessiterait de prouver que les deux découpages sont effectivement identiques, ce qui utilise principalement les cas d'égalité des triangles.

Par le théorème de Pythagore

Fig. 7 - Démonstration du théorème d'Al-Kashi en utilisant les relations trigonométriques.

La figure 7 (ci-contre) indique la manière de procéder pour démontrer le théorème d'Al-Kashi dans le cas d'un triangle à angles aigus en utilisant le théorème de Pythagore sur un sous-triangle rectangle formé en prenant le pied de la hauteur[9] . Seule la dernière étape n'est pas indiquée sur la figure : le théorème de Pythagore s'applique au triangle rectangle dont l'hypoténuse est le côté c :

en utilisant l'identité remarquable

On obtient le résultat escompté, après simplification.

La méthode est en tous points similaire pour les angles obtus, et conduit à un résultat identique.

En utilisant la puissance d'un point par rapport à un cercle[ modifier | modifier le code ]

Fig. 8 - Démonstration du théorème d'Al-Kashi en utilisant la puissance d'un point par rapport à un cercle.

On considère le cercle de centre B et de rayon [BC] (cf. figure ci-contre). Il coupe la droite (AC) en C et K. La puissance du point A par rapport au dit cercle est :

d'où

.

Contrairement aux précédentes, pour cette démonstration, il n'est pas nécessaire de recourir à une étude par cas. En effet, les mesures algébriques permettent de traiter pareillement un angle aigu ( [image]) et un angle obtus ( [image]).

On trouve trace de l'utilisation de la puissance d'un point par rapport à un cercle pour déterminer tous les angles d'un triangle dont les longueurs sont connues, dans l'œuvre de Nicolas Copernic, Des révolutions des sphères célestes. Il présente ainsi deux algorithmes, l'un utilisant le théorème de Pythagore généralisé présent dans l'œuvre d'Euclide[10], l'autre utilisant la puissance d'un point par rapport à un cercle[11].

Ainsi dans une figure analogue à celle ci-contre, il fait remarquer que, a et c étant connus, la puissance du point A par rapport au cercle tracé est connue

en langage mathématique actuel, elle vaut

Il en déduit que, puisque b est connu, AK est connu

en effet [image] donc

Puisque AK est connu, alors CK est connu.

en effet, dans la figure ci-contre,

Enfin, il fait remarquer que CK étant connu, l'angle KCB est connu

en effet,

Et puisque l'angle KCB est connu, il en est de même de l'angle ACB

Ainsi, on retrouve la règle du cosinus :

Ne manipulant pas les mesures algébriques, Nicolas Copernic présente deux cas de figure pour l'angle obtus et l'angle aigu, travaille sur un cercle dont le rayon correspond au plus petit côté, et ne présente pas de formule, mais un algorithme de calcul. Une utilisation analogue de la puissance d'un point par rapport à un cercle pour retrouver la règle du cosinus est faite par Pitiscus [12].

À l'aide du produit scalaire

En utilisant le calcul vectoriel, plus précisément le produit scalaire, il est possible de retrouver le théorème d'Al-Kashi en quelques lignes[5] :

En géométrie non euclidienne

Pour une surface non euclidienne de courbure K, on note R le rayon de courbure. Il vérifie

.

On définit alors les dimensions réduites du triangle :

,
,
.

Dans le cas d'un triangle sphérique, a, b et c correspondent à la mesure angulaire des segments de grand arc [BC], [AC] et [AB] (voir Fig. 7).

En géométrie sphérique

Fig. 9 - Triangle sphérique : dimensions réduites a, b et c ; angles α, β et γ.

Le développement de la trigonométrie sphérique dans le monde arabo-musulman et le travail d'al-Battani sur celle-ci, conduisent Delambre dans son Histoire de l'astronomie du Moyen-Âge[13] à attribuer à al-Battani, la première version de la loi des cosinus en trigonométrie sphérique. Cependant, pour Anton von Braunmühl (en) [14], le travail d'al-Battani ne met pas en évidence de formule générale, et il faut attendre Regiomontanus, qui s'appuyant sur les travaux d'al-Battani, énonce et démontre la loi à l'aide des sinus verses [15],[16].

Dans un triangle sphérique ABC (Fig. 9), la loi des cosinus s'écrit[17] :

Démonstration : Considérons un triangle sphérique ABC dans une sphère de centre O et de rayon 1, de sorte que OA = OB = OC = 1. Le vecteur [image] est le vecteur tangent en C au grand cercle passant par A et C. En effet, il appartient au plan OAC et il est orthogonal à [image] puisque le produit scalaire [image]. De plus, il est facile de vérifier que sa norme vaut [image] en calculant son carré scalaire. De même, le vecteur [image] est le vecteur tangent en C au grand cercle passant par B et C, et sa norme est [image]. L'angle entre les deux vecteurs est donc [image]. On obtient alors la loi des cosinus en effectuant le produit scalaire des deux vecteurs, ce qui donne :

Il existe une identité similaire qui relie les trois angles :

Lorsque le rayon de courbure tend vers l'infini, c’est-à-dire lorsque a, b et c tendent vers 0, la loi des cosinus sphérique se simplifie pour donner la version euclidienne de la même loi. Pour le montrer, on utilise les développements limités suivants :

et on identifie les coefficients du second ordre dans la relation [image], ce qui donne :

En géométrie hyperbolique[ modifier | modifier le code ]

Dans un triangle hyperbolique ABC, la loi des cosinus s'écrit[18]

.

Lorsque le rayon de courbure devient très grand devant les dimensions du triangle, on retrouve la loi des cosinus euclidienne à partir des développements limités

,

en identifiant les termes du second ordre.

Généralisation à l'espace euclidien

Fig. 10 - Tétraèdre : faces et angles diédraux.

On considère un tétraèdre A1A2A3A4 de l'espace euclidien. La figure 10 ci-contre présente les notations concernant les sommets, faces et angles dans le tétraèdre :

  • la face opposée au sommet [image];
  • la surface de [image];
  • le plan dans lequel [image] est plongée ;
  • l'angle diédral [image].

Alors, surfaces et angles vérifient[19] :

Notes et références

  1. ↑ Renée Honvault : Une approche possible de la géométrie plane page 41
  2. ↑ Pythagore et son théorème
  3. ↑ Les oeuvres d'Euclide, traduction de F.Peyrard, Paris (1819), réédité par Blanchard (1993). On peut également consulter une traduction plus ancienne datant de 1632
  4. ↑ Youssef Guergour, « Le roi de Saragosse Al-Mutaman Ibn Hud et le théorème de Pythagore : ses sources et ses prolongements », LUL, vol. 28,‎ 2005 (ISSN 0210-8615, lire en ligne)
  5. ↑ a et b La formule d'Al-Kashi, vue comme application du produit scalaire, est présente dans les programmes de mathématiques de première S de l'enseignement français (voir BO du 31 aout 2000)
  6. ↑ Éléments d'Euclide selon la traduction d'Henrion (1632) p. 99-104
  7. ↑ Selon Guergour 2005, la démonstration se trouve dans KASHI (al) (1967): Miftam al-misab [Clé de l'Arithmétique], al-Damardache, A. S. & al-Manfi al-Shikh, M. M. (Edit.), Le Caire, Dar al-Kitab al-cArabi li at-tibaqa wa an-Nashr, p. 130-138.
  8. ↑ Voir par exemple Nelsen, Roger B. (2000), Proofs without Words II: More Exercises in Visual Thinking, p. 9 (publié par la Mathematical Association of America), et plus généralement l'article preuve sans mots
  9. ↑ Küstner, Hellwitch, Kästner, Petite encyclopédie des mathématiques, Édition Didier, 1980, ch 11-2, p. 265
  10. ↑ N. Copernic, De révolutionibus orbium coelestium, Livre I, Chapitre XII, paragraphe VII, p. 20 (Lire en ligne)
  11. ↑ N. Copernic, De révolutionibus orbium coelestium, Livre I, Chapitre XII, paragraphe VII, p. 21 (Lire en ligne)
  12. ↑ David Eugene Smith, A source book in mathematics, Volume 1, p. 435
  13. ↑ opus cité [books.google.fr/books?hl=fr&id=zceNcM0k73gC&pg=PA17#v=onepage&q&f=false pp 17-20]
  14. ↑ Anton von Braunmühl., Vorlesungen über Geschichte der Trigonometrie, 1900 note1 p. 53
  15. ↑ A. von Braunmühl., Vorlesungen über Geschichte der Trigonometrie, 1900 p; 131 et suivantes
  16. ↑ Tony Phillips, The True History of the Law of Cosines. , 2006-12-02
  17. ↑ Voir l'article trigonométrie sphérique., et une démonstration différente de celle de l'article, par exemple, le "cours" de cartographie de David Madore
  18. ↑ Voir l'article géométrie hyperbolique ; pour des démonstrations de ces formules, on pourra par exemple se référer à ce TD de DEA (mais qui utilise des connaissances assez avancées)
  19. ↑ (en) Lee, J. R. "The Law of Cosines in a Tetrahedron." J. Korea Soc. Math. Ed. Ser. B: Pure Appl. Math. 4, 1-6, 1997.

Voir aussi

Articles connexes

Trigonométrie | Géométrie du triangle | Mathématiciens
triangulation | théorème de Pythagore | Euclide
trigonométrie sphérique | Livre II des Éléments d'Euclide | al-Battani
fonction trigonométrique | loi des sinus | Ghiyath al-Kashi
 | loi des tangentes | François Viète

Liens externes

Ces liens ont servi de sources de l'article

  • Les Éléments, tome II, Euclide, sur la Bibliothèque nationale française en ligne.
  • Law of cosines, sur le site Math World (en anglais)

Bibliographie

  • N. Éfimov, Géométrie Supérieure, Moscou, Éditions MIR, 1981
  • Collectif, Petite Encyclopédie des Mathématiques, Paris, Éditions K. Pagoulatos, 1980
  • Antoine Arnauld, Nouveaux éléments de géométrie, Paris, Charles Savreux, 1667,p. 295-296 (Sixième théorème)
  • Amiot, Éléments de géométrie, Paris, Delagrave, 14e édition, 1870, p. 109-111
  • Cirodde, Leçons de géométrie, Paris, Hachette, 3e édition, 1858, p. 111-112 (théorème XI)


Trigonométrie

Loi des tangentes

Fig. 1 - Notations usuelles dans un triangle quelconque.

En trigonométrie, la loi des tangentes est une relation entre la longueur de deux côtés d'un triangle et la mesure de deux de ses angles.

On considère un triangle quelconque ABC, représenté sur la Fig. 1 ci-contre, où les angles sont désignés par les minuscules grecques et les côtés opposés aux angles par la minuscule latine correspondante :

  • a = BC et α = Â ;
  • b = AC et β = B ;
  • c = AB et γ = C.

Alors,

.

Généralisation aux géométries non euclidiennes

Fig. 2 - Triangle sphérique : dimensions réduites a, b et c ; angles α, β et γ.

Pour une surface non euclidienne de courbure K, on note ρ le rayon de courbure. Il vérifie

.

On définit alors les dimensions réduites du triangle :

,
,
.

Dans le cas d'un triangle sphérique, a, b et c correspondent à la mesure angulaire des segments de grand arc [BC], [AC] et [AB] (voir Fig. 2).

Géométrie sphérique

Dans un triangle sphérique ABC (Fig. 2), la loi des tangentes devient :

.

Voir également

  • Trigonométrie
    • Fonction trigonométrique
    • Trigonométrie sphérique
    • Triangulation
  • Géométrie du triangle
    • Résolution d'un triangle
    • Théorème d'Al-Kashi
    • Loi des sinus


Trigonométrie

Loi de Morrie

La loi de Morrie est l'identité trigonométrique suivante :

cosinus de 20 degrés multiplié par cosinus de 40 degrés multiplié par cosinus de 80 degrés égale un huitième

Le nom de cette « curiosité » est dû au physicien Richard Feynman.

Sommaire

  • 1 Histoire
  • 2 Généralisation
  • 3 Identités similaires pour les autres fonctions trigonométriques
  • 4 Démonstration
  • 5 Références

Histoire

Feynman avait l'habitude de nommer ainsi cette identité car c'est un de ses camarades, nommé Morrie Jacobs, qui la lui avait fait connaître durant sa scolarité ; il s'en est ensuite souvenu toute sa vie, de même que les circonstances dans lesquelles il en a appris l'existence (dans le magasin de cuir du père de Morrie)[Gleick 1].

Il y fait référence dans une lettre à Morrie datée du 27 janvier 1987 [Gleick 2].

Généralisation

Il s'agit d'un cas particulier de l'identité plus générale[MAA 1] :

La curiosité tient au fait que dans ce cas particulier (avec n = 3 et [image]), le membre de droite vaut 1. En effet, avec ces deux valeurs particulières, on a :

Il existe diverses autres généralisations de cette identité, citées notamment dans un livre de trigonométrie de 1930[MAA 2],[1].

Identités similaires pour les autres fonctions trigonométriques

Il existe une identité similaire pour la fonction sinus :

Naturellement, en divisant l'identité pour la fonction sinus par celle pour la fonction cosinus, une troisième identité se dégage pour la fonction tangente :

Démonstration

En utilisant la formule de l'angle double pour la fonction sinus :

on trouve l'expression de [image] :

Il suit :

En multipliant toutes ces expressions les unes avec les autres, on obtient :

Dans la partie droite de l'expression, les numérateurs et dénominateurs intermédiaires s'annulent, ne laissant que le premier dénominateur ( [image]) et le numérateur final ( [image]), ainsi qu'une puissance de 2 au dénominateur ( [image] car il y a n termes) ; il vient alors :

ce qui est équivalent à la généralisation de l'identité.

Références

  • (en) James Gleick, Genius : The Life and Science of Richard Feynman, New York, Pantheon Books,‎ 1992, 532 p. (ISBN 0-679-40836-3).
  1. ↑ Gleick, op. cit., p. 47 : « If a boy named Morrie Jacobs told him that the cosine of 20 degrees multiplied by the cosine of 40 degrees multiplied by the cosine of 80 degrees equaled exactly one-eighth, he would remember that curiosity for the rest of his life, and he would remember that he was standing in Morrie's father's leather shop when he learned it. ».
  2. ↑ Gleick, op. cit., p. 450.
  • Dans Mathematics Magazine, Mathematical Association of America :
  1. ↑ (en) William A. Beyer, James D. Louck et Doron Zeilberger, « Math Bite : A Generalization of a Curiosity that Feynman Remembered All His Life », Mathematics Magazine, vol. 69, no 1,‎ février 1996, p. 43–44 (DOI 10.2307/2691393).
  2. ↑ (en) Garry J. Tee, « Math Bite : Further Generalizations of a Curiosity that Feynman Remembered All His Life », Mathematics Magazine, vol. 72, no 1,‎ février 1999, p. 44 (lire en ligne).
  • (en) Ernest C. Anderson, « Morrie's Law and Experimental Mathematics », Journal of Recreational Mathematics, no 29,‎ 1998, p. 85–88.
  • (en) Eric W. Weisstein, « Morrie's Law », MathWorld.
  • Autres références :
  1. ↑ (en) Clement V. Durell et Alan Robson, Advanced Trigonometry, George Bell & Sons,‎ 1930, p. 225–226.


Trigonométrie

Noyau de Dirichlet

Tracé des premiers noyaux de Dirichlet.

En mathématiques, le n-ième noyau de Dirichlet – nommé ainsi en l'honneur du mathématicien allemand Johann Dirichlet – est le polynôme trigonométrique défini par :

.

C'est donc une fonction 2π-périodique de classe [image]. Elle vérifie de plus :

  • si x n'est pas un multiple entier de [image] alors [image],
  • si x est un multiple entier de [image] alors [image].

Le noyau de Dirichlet permet notamment d'améliorer la convergence des séries de Fourier. Il intervient aussi en optique, pour rendre compte des franges et des compositions d'ondes cohérentes.

Sommaire

  • 1 Considérations élémentaires
    • 1.1 Équivalence des deux écritures du noyau de Dirichlet
    • 1.2 Propriétés du noyau de Dirichlet
  • 2 Opérateur associé
  • 3 Introduction au formalisme des distributions
  • 4 Voir aussi

Considérations élémentaires

Équivalence des deux écritures du noyau de Dirichlet

Lorsque [image], c'est-à-dire lorsque x appartient à [image], le noyau de Dirichlet est la somme de 2n+1 termes chacun égaux à 1, et vaut donc 2n+1.

Lorsque [image], l'identité trigonométrique qui apparaît au début de l'article peut être établie par le calcul d'une somme d'une série géométrique de raison [image].

Rappelons que la somme partielle au rang n d'une série géométrique de raison r≠1 vaut

Ici c'est une somme symétrique qui nous intéresse

L'expression à gauche du symbole égal nous incite à penser que la somme est une fonction symétrique de r et 1/r. Mais dans l'expression à droite du symbole égal, il est difficile de diagnostiquer une telle symétrie par rapport à ces deux quantités. Le remède est de multiplier à la fois le numérateur et le dénominateur par r-1/2, pour obtenir

Dans le cas où r = eix nous avons:

et alors « -2i » disparaît.

Variante.

Un autre guide pour le calcul peut être l'idée suivante : le calcul de la somme ou de la différence de deux complexes de même module se fait en introduisant l'angle moitié

On procède ainsi au numérateur et au dénominateur.

Propriétés du noyau de Dirichlet

  • C'est un polynôme trigonométrique, donc une fonction [image], 2π-périodique ;
  • il est pair ;
  • sa valeur moyenne est 1 ;
  • le comportement asymptotique de sa norme de la convergence en moyenne est :
.
Démonstration

L'idée générale est de se ramener à une fonction sinus cardinal. En effet, pour [image],

On reconnaît dans le second terme de cette somme une fonction prolongeable par continuité en 0, donc continue, et bornée indépendamment de n. Dès lors, il suffit de montrer la propriété pour le premier terme de la somme qui est un sinus cardinal.

Pour ce dernier, il s'agit d'un résultat classique : on introduit la valeur moyenne du numérateur

Alors

La démonstration, se faisant par intégration par parties ou comparaison série-intégrale, est détaillée dans l'article sinus cardinal.

Opérateur associé

Le n-ième terme de la série de Fourier d'une fonction 2π-périodique et intégrable f s'écrit :

;

L'identité précédente est un produit de convolution, ou l'application d'un opérateur à noyau.

C'est à partir de cette expression et des propriétés du noyau de Dirichlet qu'on démontre le théorème de Dirichlet sur la convergence des séries de Fourier.

Cet opérateur est un opérateur borné sur l'espace des fonctions continues, dont la norme d'opérateur est majorée par [image].

En spécialisant l'étude en un point x particulier, l'application [image] a pour norme d'opérateur [image] lui-même, qui tend vers l'infini avec n. À l'aide du théorème de Banach-Steinhaus, on peut en déduire qu'il existe des fonctions continues dont la série de Fourier diverge au point x.

Introduction au formalisme des distributions

Le noyau de Dirichlet est 2π fois la somme d'ordre n du développement en séries de Fourier d'une « fonction », en distribution, de période 2π donnée par

où δ est la fonction delta de Dirac, qui n'est pas vraiment une fonction, dans le sens d'application d'un ensemble vers un autre, mais est plutôt une «fonction généralisée», aussi appelée une distribution. En d'autres termes, le développement en série de Fourier de cette « fonction » s'écrit

Cette « fonction périodique delta » est l'élément neutre pour le produit de convolution défini sur l'ensemble des fonctions de période 2π par

Autrement dit,

pour toute fonction f de période 2π,

Le produit de convolution de Dn avec n'importe quelle fonction f de période 2π est égal à la somme d'ordre n du développement en série de Fourier de f, i.e., nous avons

où

est le k-ième coefficient de Fourier de f.

Voir aussi

  • Série de Fourier
  • Noyau de Fejér


Trigonométrie

Modulo

Page d'aide sur l'homonymie. Cette page d’homonymie répertorie les différents sujets et articles partageant un même nom.

Sur les autres projets Wikimedia :

  • modulo, sur le Wiktionnaire

Modulo est un terme de mathématiques relatif à la congruence, notamment :

  • modulo n : en arithmétique modulaire on parle d'entiers congrus modulo n ;
  • la mesure d'angles orientés, modulo 2π ;
  • en informatique, le modulo est une fonction qui au couple (a, b) d'entiers associe le reste r de la division euclidienne de a par b.

Voir aussi

  • Modulor, en architecture
  • Module Page d'aide sur l'homonymie
Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Modulo&oldid=115044634 ».
Catégories :
  • Homonymie
  • Arithmétique modulaire
  • Algèbre
  • Trigonométrie


Trigonométrie

Primitives de fonctions trigonométriques

Cet article donne les primitives de fonctions trigonométriques.

L'expression log(tan(x/2 + π/4)) fut d'abord découverte par hasard, en comparant les premières tables de logarithmes des tangentes avec des tables nautiques (d'intégrales définies de la fonction sécante) calculées en 1599 par Edward Wright, mais la coïncidence resta inexpliquée jusqu'à l'invention du calcul infinitésimal [1].

Note et référence[ modifier | modifier le code ]

  1. ↑ Michael Spivak, Calculus,‎ 1967 (lire en ligne), p. 326.

Articles connexes[ modifier | modifier le code ]

  • Fonction de Gudermann
  • Intégrale de la fonction sécante (en)
  • Projection de Mercator
  • Règles de Bioche
v · m
Primitives de fonctions
Rationnelles · Logarithmes · Exponentielles · Irrationnelles · Trigonométriques · Hyperboliques · Circulaires réciproques · Hyperboliques réciproques
  • Portail de l’analyse Portail de l’analyse
Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Primitives_de_fonctions_trigonométriques&oldid=114429465 ».
Catégories :
  • Analyse réelle
  • Trigonométrie
  • Formulaire de mathématiques
Catégories cachées :
  • Article contenant un appel à traduction en anglais
  • Portail:Analyse/Articles liés
  • Projet:Mathématiques/Articles

Menu de navigation

Outils personnels

  • Créer un compte
  • Se connecter

Espaces de noms

  • Article
  • Discussion

Variantes

Affichages

  • Lire
  • Modifier
  • Modifier le code
  • Historique

Plus

Navigation

  • Accueil
  • Portails thématiques
  • Article au hasard
  • Contact

Contribuer

  • Débuter sur Wikipédia
  • Aide
  • Communauté
  • Modifications récentes
  • Faire un don

Imprimer / exporter

  • Créer un livre
  • Télécharger comme PDF
  • Version imprimable

Outils

  • Pages liées
  • Suivi des pages liées
  • Importer un fichier
  • Pages spéciales
  • Adresse de cette version
  • Information sur la page
  • Élément Wikidata
  • Citer cette page

Autres langues

  • العربية
  • Azərbaycanca
  • Български
  • Bosanski
  • Català
  • کوردی
  • Čeština
  • English
  • Español
  • Euskara
  • فارسی
  • Galego
  • हिन्दी
  • Hrvatski
  • Հայերեն
  • Bahasa Indonesia
  • Italiano
  • 日本語
  • ភាសាខ្មែរ
  • Nederlands
  • Norsk bokmål
  • Português
  • Română
  • Русский
  • Srpskohrvatski / српскохрватски
  • Slovenščina
  • Српски / srpski
  • தமிழ்
  • Türkçe
  • Українська
  • Tiếng Việt
  • 中文
Modifier les liens
  • Dernière modification de cette page le 24 avril 2015 à 11:53.
  • Droit d'auteur : les textes sont disponibles sous licence Creative Commons paternité partage à l’identique ; d’autres conditions peuvent s’appliquer. Voyez les conditions d’utilisation pour plus de détails, ainsi que les crédits graphiques. En cas de réutilisation des textes de cette page, voyez comment citer les auteurs et mentionner la licence.
    Wikipedia® est une marque déposée de la Wikimedia Foundation, Inc., organisation de bienfaisance régie par le paragraphe 501(c)(3) du code fiscal des États-Unis.
  • Politique de confidentialité
  • À propos de Wikipédia
  • Avertissements
  • Développeurs
  • Version mobile
  • Powered by MediaWiki


Trigonométrie

Primitives de fonctions hyperboliques réciproques

Cet article donne les primitives des fonctions réciproques des fonctions hyperboliques. Elles s'obtiennent dans la plupart des cas par intégration par parties.

v · m
Primitives de fonctions
Rationnelles · Logarithmes · Exponentielles · Irrationnelles · Trigonométriques · Hyperboliques · Circulaires réciproques · Hyperboliques réciproques
  • Portail de l’analyse Portail de l’analyse
Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Primitives_de_fonctions_hyperboliques_réciproques&oldid=114429088 ».
Catégories :
  • Analyse réelle
  • Trigonométrie
  • Formulaire de mathématiques
Catégories cachées :
  • Portail:Analyse/Articles liés
  • Projet:Mathématiques/Articles

Menu de navigation

Outils personnels

  • Créer un compte
  • Se connecter

Espaces de noms

  • Article
  • Discussion

Variantes

Affichages

  • Lire
  • Modifier
  • Modifier le code
  • Historique

Plus

Navigation

  • Accueil
  • Portails thématiques
  • Article au hasard
  • Contact

Contribuer

  • Débuter sur Wikipédia
  • Aide
  • Communauté
  • Modifications récentes
  • Faire un don

Imprimer / exporter

  • Créer un livre
  • Télécharger comme PDF
  • Version imprimable

Outils

  • Pages liées
  • Suivi des pages liées
  • Importer un fichier
  • Pages spéciales
  • Adresse de cette version
  • Information sur la page
  • Élément Wikidata
  • Citer cette page

Autres langues

  • العربية
  • Bosanski
  • Català
  • Čeština
  • English
  • Español
  • Euskara
  • فارسی
  • Galego
  • Hrvatski
  • Bahasa Indonesia
  • Italiano
  • 日本語
  • ភាសាខ្មែរ
  • Nederlands
  • Русский
  • Srpskohrvatski / српскохрватски
  • Slovenščina
  • Shqip
  • Српски / srpski
  • தமிழ்
  • Українська
  • Tiếng Việt
  • 中文
Modifier les liens
  • Dernière modification de cette page le 24 avril 2015 à 11:40.
  • Droit d'auteur : les textes sont disponibles sous licence Creative Commons paternité partage à l’identique ; d’autres conditions peuvent s’appliquer. Voyez les conditions d’utilisation pour plus de détails, ainsi que les crédits graphiques. En cas de réutilisation des textes de cette page, voyez comment citer les auteurs et mentionner la licence.
    Wikipedia® est une marque déposée de la Wikimedia Foundation, Inc., organisation de bienfaisance régie par le paragraphe 501(c)(3) du code fiscal des États-Unis.
  • Politique de confidentialité
  • À propos de Wikipédia
  • Avertissements
  • Développeurs
  • Version mobile
  • Powered by MediaWiki


Trigonométrie

Polynôme trigonométrique
Cet article est une ébauche concernant les mathématiques.
Vous pouvez partager vos connaissances en l’améliorant (comment ?) selon les recommandations des projets correspondants.
Consultez la liste des tâches à accomplir en page de discussion.

En mathématiques, un polynôme trigonométrique (ou polynôme trigonométrique complexe) P est une fonction, définie par une somme d'exponentielles :

Où les coefficients [image] de P sont complexes ou réels.

Somme de fonctions trigonométriques[ modifier | modifier le code ]

En particulier, on peut exprimer tout polynôme trigonométrique comme somme de sinus et de cosinus :

Les deux familles de coefficients (ak)k et (bk)k peuvent être déduites de (ck)k, et vice versa. P est une fonction réelle si et seulement si les (ak)k et (bk)k sont réels. Les coefficients ak sont tous nuls si et seulement si le polynôme est impair. De même, les coefficients bk sont tous nuls si et seulement si le polynôme est pair.

Une somme infinie de coefficients trigonométriques est appelée série trigonométrique.

Théorème de Stone-Weierstrass[ modifier | modifier le code ]

D'après le théorème de Stone-Weierstrass, pour toute fonction f continue et T-périodique, il existe une suite (Tn) de polynômes trigonométriques qui converge uniformément vers f.

Cette propriété essentielle est, au travers du théorème de Fejér, également une conséquence de la convergence uniforme des séries de Fourier pour de telles fonctions.

Articles connexes[ modifier | modifier le code ]

  • Polynôme de Tchebychev
  • Série trigonométrique
  • Série de Fourier
  • Somme exponentielle (en)
  • Fonction presque périodique
  • Portail de l’analyse Portail de l’analyse
Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Polynôme_trigonométrique&oldid=103902644 ».
Catégories :
  • Théorie de Fourier
  • Trigonométrie
  • Polynôme
Catégories cachées :
  • Wikipédia:ébauche mathématiques
  • Article contenant un appel à traduction en anglais
  • Portail:Analyse/Articles liés
  • Projet:Mathématiques/Articles

Menu de navigation

Outils personnels

  • Créer un compte
  • Se connecter

Espaces de noms

  • Article
  • Discussion

Variantes

Affichages

  • Lire
  • Modifier
  • Modifier le code
  • Historique

Plus

Navigation

  • Accueil
  • Portails thématiques
  • Article au hasard
  • Contact

Contribuer

  • Débuter sur Wikipédia
  • Aide
  • Communauté
  • Modifications récentes
  • Faire un don

Imprimer / exporter

  • Créer un livre
  • Télécharger comme PDF
  • Version imprimable

Outils

  • Pages liées
  • Suivi des pages liées
  • Importer un fichier
  • Pages spéciales
  • Adresse de cette version
  • Information sur la page
  • Élément Wikidata
  • Citer cette page

Autres langues

  • العربية
  • Български
  • Deutsch
  • English
  • Italiano
  • 日本語
  • Polski
  • Русский
  • 中文
Modifier les liens
  • Dernière modification de cette page le 18 mai 2014 à 08:45.
  • Droit d'auteur : les textes sont disponibles sous licence Creative Commons paternité partage à l’identique ; d’autres conditions peuvent s’appliquer. Voyez les conditions d’utilisation pour plus de détails, ainsi que les crédits graphiques. En cas de réutilisation des textes de cette page, voyez comment citer les auteurs et mentionner la licence.
    Wikipedia® est une marque déposée de la Wikimedia Foundation, Inc., organisation de bienfaisance régie par le paragraphe 501(c)(3) du code fiscal des États-Unis.
  • Politique de confidentialité
  • À propos de Wikipédia
  • Avertissements
  • Développeurs
  • Version mobile
  • Powered by MediaWiki


Trigonométrie

Polynôme minimal des valeurs spéciales trigonométriques

Dans un polygone régulier à n côtés, l'angle au centre est de mesure 2 a avec [image].

En mathématiques, et plus précisément en algèbre, on peut trouver des polynômes minimaux P(x) à coefficients rationnels tels que les valeurs spéciales trigonométriques [image], [image] ou [image] soient des solutions de l'équation P(x) = 0.

Les polynômes minimaux sont des polynômes unitaires, c'est-à-dire dont le coefficient du terme de plus haut degré vaut 1, et qui sont irréductibles, c'est-à-dire qu'ils ne peuvent plus être factorisés en un produit de polynômes à coefficients rationnels[Note 1].

Les mesures d'angles de la forme [image] se rencontrent dans de nombreux problèmes géométriques ; en particulier, les mesures d'angles de la forme [image] correspondent aux angles au centre des polygones réguliers [Note 2].

Sommaire

  • 1 Approche intuitive
  • 2 Nature algébrique des valeurs spéciales trigonométriques
    • 2.1 Le théorème
    • 2.2 Degré algébrique
  • 3 Expression des valeurs spéciales trigonométriques à l'aide de radicaux
    • 3.1 Expression avec des racines carrées
    • 3.2 Expression avec des racines n-ièmes
  • 4 Polynômes à coefficients non rationnels
  • 5 Calculer le polynôme minimal à coefficients rationnels
    • 5.1 Pourquoi les polynômes de Tchebychev ne suffisent pas
    • 5.2 Avec les polynômes cyclotomiques
  • 6 Formules explicites du polynôme minimal
  • 7 Listes de polynômes minimaux
  • 8 Notes et références
    • 8.1 Notes
    • 8.2 Références
  • 9 Voir aussi
    • 9.1 Bibliographie
    • 9.2 Articles connexes
    • 9.3 Lien externe

Approche intuitive[ modifier | modifier le code ]

Pour établir que [image], on peut s'aider d'un triangle équilatéral.

Lorsque l'on apprend la trigonométrie, on constate vite que le cosinus et le sinus des mesures de certains angles ont une forme particulière, qui fait intervenir des racines carrées. Ainsi, pour un angle de mesure 30 degrés, soit [image] radians, le théorème de Pythagore permet de démontrer que :

Si l'on pose [image], cela revient à dire que a est une des solutions de l'équation [image]. L'autre solution de cette équation est [image], où l'on retrouve aussi une mesure d'angle de la forme [image].

L'équation [image] a une forme simple, elle s'exprime sous la forme P(x) = 0, où P(x) est un polynôme unitaire à coefficients rationnels : ses solutions sont des nombres algébriques. a est aussi solution de [image], mais Q(x) est de degré plus élevé que P(x) ; en fait, P(x) est de degré minimal parmi les polynômes à coefficients rationnels annulant a, c'est un polynôme minimal.

Les questions qui viennent naturellement sont :

  • tous les nombres de la forme [image], [image] et [image] sont-ils algébriques ?
    La réponse est oui.
  • peut-on toujours les exprimer à l'aide de racines carrées ?
    La réponse est cette fois non.
  • peut-on tout du moins toujours les exprimer à l'aide de racines n-ièmes ?
    La réponse est oui si l'on s'autorise à travailler dans les nombres complexes.
  • comment trouve-t-on les polynômes minimaux associés à ces nombres ?

On verra aussi que l'on peut réduire le degré de ces polynômes, quitte à ne plus travailler seulement avec des polynômes à coefficients rationnels.

Nature algébrique des valeurs spéciales trigonométriques[ modifier | modifier le code ]

Le théorème[ modifier | modifier le code ]

Théorème — Les nombres de la forme [image], [image] et [image] sont algébriques.

En voici une première démonstration :

Démonstration

On remarque d'abord que l'exponentielle complexe de la forme [image] est algébrique. En effet, en notant [image], on a [image] et x est donc solution de l'équation polynomiale à coefficients rationnels x^{2n} - 1 = 0.

Par ailleurs, on sait que [image]. D'après le résultat précédent, [image] est algébrique. Comme l'ensemble des nombres algébriques muni de l'addition et de la multiplication est un corps, son inverse [image] l'est aussi. De la même façon, leur somme l'est encore, et en divisant le résultat par 2, on obtient toujours un nombre algébrique. est donc algébrique.

Le sinus et la tangente s'expriment également en fonction de l'exponentielle complexe. On peut donc conclure de façon analogue que le sinus et la tangente d'un nombre de la forme [image] sont eux aussi algébriques.

Cette démonstration est courte et élégante, mais elle utilise le fait que l'ensemble des nombres algébriques, muni de l'addition et de la multiplication, est un corps, ce qui est un résultat très puissant et difficile à démontrer. Si l'on veut se restreindre à des outils plus élémentaires, on peut mener la démonstration suivante :

Démonstration

La formule de De Moivre indique que, pour un nombre entier n et un nombre réel t, [image].
On en déduit que [image] et [image], où [image] et [image] désignent respectivement la partie réelle et la partie imaginaire d'un nombre complexe z.
Cela donne la formule : .
On en déduit que [image] s'annule quand le polynôme réel [image] s'annule.
Par ailleurs, [image] : est donc racine du polynôme à coefficients entiers [image], et il est donc algébrique.

Pour en déduire que le cosinus et le sinus de [image] sont eux aussi algébriques, il convient de faire un certain nombre de remarques préliminaires. Soit a un nombre algébrique, donc racine d'un polynôme P(x) à coefficients rationnels. On peut dire que :

  • b = a + p, où p est entier relatif, est lui aussi algébrique, car b est racine de P(x-p) ;
  • c = -a est lui aussi algébrique, car il est racine de P(-x) ;
  • d = 1/a est également algébrique, car il est racine de [image] ;
  • est également algébrique, car il est racine de [image].

En effet, les polynômes en question peuvent tous se développer en polynômes en x à coefficients rationnels.

Comme [image] et comme [image], en appliquant de façon répétée les propriétés ci-dessus, on en déduit que [image] et [image] sont aussi algébriques pour les valeurs où la tangente est définie. On complète en remarquant que, pour les valeurs où la tangente n'est pas définie, le sinus et le cosinus valent 1 ou 0, qui sont des nombres algébriques.

Cette seconde démonstration est constructive, car elle fournit au passage une expression d'un polynôme annulateur, c'est-à-dire d'un polynôme P(x) tel que P(x) = 0 pour [image], [image] ou [image]. Malheureusement, le polynôme en question est au moins de degré n, il n'a aucune raison d'être un polynôme minimal.

Degré algébrique[ modifier | modifier le code ]

Le degré d'un nombre algébrique est la valeur minimale du degré des polynômes dont il est racine. Derrick Lehmer a donné des expressions analytiques du degré des valeurs spéciales trigonométriques[1],[2] :

  • le degré de [image] vaut :
    • 1 si n = 1 ou 2 ;
    • si [image] ;
  • le degré de [image] vaut :
    • si PGCD(n, 8) = 1 ou 2 ;
    • si PGCD(n, 8) = 4 ;
    • si PGCD(n, 8) = 8,

où [image] est la fonction indicatrice d'Euler. La démonstration fait appel à la théorie de Galois.

Expression des valeurs spéciales trigonométriques à l'aide de radicaux[ modifier | modifier le code ]

Expression avec des racines carrées[ modifier | modifier le code ]

La construction de l'heptagone régulier à la règle et au compas de cette animation n'est pas exacte.

Certains polygones réguliers ne peuvent pas être construits à la règle et au compas.

Par exemple, considérons l'heptagone régulier d'angle au centre de mesure [image]. Le théorème de Wantzel a une conséquence qui affirme que les polynômes minimaux correspondant aux nombres constructibles à la règle et au compas ont forcément un degré qui est une puissance de 2. Ce n'est pas le cas du polynôme minimal de [image], qui est [image], du troisième degré. L'heptagone ne peut donc être construit à la règle et au compas.

Les premières valeurs de n telles que le polygone régulier à n côtés soit constructible sont 3, 4, 5, 6, 8, 10, 12, 15, 16, 17, 20, 24, 30, 32, 34, 40, 48, 51, 60 et 64. Gauss a donné dès 1796 une expression de ces nombres, montrant en particulier la constructibilité de l'heptadécagone [Note 3]. Le tableau suivant résume les valeurs, quand elles existent et peuvent être exprimées avec des racines carrées, des sinus, cosinus et tangente des angles de mesure [image] avec [image] :

n |  |  |
12 |  |  |
11 | Pas d'expression | Pas d'expression | Pas d'expression
10 |  |  |
9 | Pas d'expression | Pas d'expression | Pas d'expression
8 |  |  |
7 | Pas d'expression | Pas d'expression | Pas d'expression
6 |  |  |
5 |  |  |
4 |  |  | 1
3 |  |  |
2 | 1 | 0 | Indéfinie
1 | 0 | -1 | 0

Expression avec des racines n-ièmes[ modifier | modifier le code ]

Lorsque l'on essaye de résoudre l'équation du troisième degré [image] par la méthode de Cardan, on s'aperçoit que l'on est dans le casus irreducibilis (en) qui ne peut justement se résoudre dans les nombres réels qu'en repassant par la trigonométrie. Cela explique qu'on ne trouvera jamais une expression de [image] avec des racines carrées ou cubiques réelles dans un formulaire de trigonométrie : on ne peut qu'en donner une valeur approchée, ou indiquer l'équation polynomiale dont il est la solution.

Pourtant, une expression par radicaux de [image] existe, à condition d'autoriser l'emploi de racines cubiques de nombres complexes ; cette expression est donnée par la méthode de Cardan [Note 4] :

Il en va de même pour [image], lui aussi racine d'une équation polynomiale de degré 3.

Qu'en est-il pour les polynômes de degré plus élevé encore ? Abel et Galois ont montré qu'il est impossible d'exprimer en général les racines d'un polynôme du cinquième degré par radicaux. On pourrait donc penser que c'est en particulier le cas de [image], dont le polynôme minimal est de degré 5. Mais ce polynôme minimal s'avère avoir pour groupe de Galois le groupe cyclique, et donc [image] possède une expression par radicaux (de nombres complexes)[3]. Une analyse plus générale montre qu'en fait, [image] peut s'exprimer par radicaux (complexes) quel que soit n[4],[2].

Polynômes à coefficients non rationnels[ modifier | modifier le code ]

Considérons le cas de [image]. C'est une racine du polynôme minimal du quatrième degré [image].

Il se trouve que ce polynôme peut se factoriser en le produit [image]. Le nombre qui nous intéresse est racine du premier facteur, [image]. Ce polynôme du second degré a cette fois des coefficients qui ne sont plus rationnels, mais de la forme [image], avec a et b rationnels. L'ensemble des nombres de cette forme est noté [image].

On peut ainsi obtenir, dans certains cas, des polynômes de degrés moindres en acceptant que les coefficients du polynôme appartiennent à un corps quadratique [image], d étant un diviseur de n. Un tel polynôme appartient donc à [image].

Calculer le polynôme minimal à coefficients rationnels[ modifier | modifier le code ]

Pourquoi les polynômes de Tchebychev ne suffisent pas[ modifier | modifier le code ]

Il est facile de trouver un polynôme annulateur pour [image]. En effet, en notant [image] le n -ième polynôme de Tchebychev de première espèce, on a : . Or [image]. En posant P(x) = T_n(x) - (-1)^k, on voit que x est solution de P(x) = 0.

Malheureusement, le polynôme P(x) trouvé par cette méthode est de degré n ; dans la plupart des cas, il est loin d'être minimal.

Avec les polynômes cyclotomiques[ modifier | modifier le code ]

William E. Heierman présente une méthode pratique pour calculer le polynôme minimal des valeurs spéciales trigonométriques[5],[Note 5]. Nous présentons ici cette méthode uniquement dans le cas du cosinus.

Supposons que l'on cherche à calculer le polynôme minimal pour [image]. Il est de la forme [image] où k = 2 et n = 15 sont premiers entre eux.

Soit [image] le 15e polynôme cyclotomique usuel. On trouve dans une table ou par le calcul que :

est de degré 8. On multiplie [image] par [image] :

On écrit ensuite les puissances de z + z^{-1} de 0 à 4, calculées à l'aide du binôme de Newton, dans un tableau :

On les multiplie par des coefficients entiers de manière à retrouver l'expression de [image] après avoir additionné les résultats :

On obtient un nouveau polynôme [image] en t = z + z^{-1} :

Cela a fonctionné parce que les polynômes cyclotomiques sont des polynômes palindromiques (en), c'est-à-dire dont les coefficients sont identiques, qu'on les lise dans l'ordre des termes de degré croissant ou décroissant.

Pour [image], on a [image]. Or, lorsque k et n sont premiers entre eux, cette valeur complexe est justement une des valeurs pour lesquelles le polynôme cyclotomique [image] s'annule[Note 6]. Le nombre [image] est donc racine de :

.

On peut de plus montrer que [image] est irréductible en produit de polynômes à coefficients rationnels.

En s'arrangeant pour avoir un coefficient de plus haut degré égal à 1, on en déduit le polynôme minimal cherché :

On remarque au passage qu'il est de degré [image], où [image] est la fonction indicatrice d'Euler [Note 7].

Formules explicites du polynôme minimal[ modifier | modifier le code ]

Scott Beslin et Valerio De Angelis ont donné une expression d'un polynôme non réductible s'annulant pour [image] dans le cas particulier où n est un nombre premier [6] :

C'est un polynôme de degré n - 1.

Ils fournissent aussi une expression d'un polynôme non réductible s'annulant pour [image], toujours dans le cas où n est premier :

étant un polynôme en [image], cette expression donne bien un polynôme en x malgré la présence de la racine carrée. C'est un polynôme de degré [image].

Listes de polynômes minimaux[ modifier | modifier le code ]

Wolfdieter Lang donne des listes des premiers polynômes minimaux de [image] et de [image] [7]. Voici un extrait de ces listes retravaillé pour faire apparaître les polynômes minimaux de [image] et de [image] :

n | Polynôme minimal de | Polynôme minimal de
12 |  |
11 |  |
10 |  |
9 |  |
8 |  |
7 |  |
6 |  |
5 |  |
4 |  |
3 |  |
2 | x | x - 1
1 | x + 1 | x

Notes et références[ modifier | modifier le code ]

Notes[ modifier | modifier le code ]

  1. ↑ Un polynôme irréductible sur l'ensemble des polynômes à coefficients rationnels ne l'est pas forcément si l'on prend des coefficients réels ou complexes. Par exemple, [image] se factorise en [image], bien qu'on ne puisse pas l'exprimer en produit de polynômes à coefficients rationnels.
  2. ↑ On peut toujours passer des fonctions trigonométriques de [image] à des expressions faisant intervenir [image] à l'aide des polynômes de Tchebychev, par exemple [image].
  3. ↑ C'est le théorème de Gauss-Wantzel ; Gauss n'a démontré que la constructibilité des polygones de cette liste ; c'est Wantzel qui a montré l'impossibilité de construire les autres polygones.
  4. ↑ Avec la convention suivante : soit un nombre complexe [image], où r est un nombre réel positif et [image] est dans l'intervalle [image], la racine cubique « principale » de z est [image].
  5. ↑ William E. Heierman appelle les valeurs spéciales trigonométriques « fonctions trigonométriques de valeurs rationnellement commensurables avec [image] ».
  6. ↑ En effet, le n ème polynôme cyclotomique est par définition [image].
  7. ↑ La fonction indicatrice d'Euler ne prenant que des valeurs paires à partir de n = 3, il n'y a pas de problème à prendre la moitié de sa valeur.

Références[ modifier | modifier le code ]

  1. ↑ (en) D. H. Lehmer, « A Note on Trigonometric Algebraic Numbers », American Mathematical Monthly, no 40,‎ 1933, p. 165-166
  2. ↑ a et b (en) Skip Garibaldi, « Somewhat More than Governors Need to Know about Trigonometry », Mathematics Magazine, vol. 81, no 3,‎ juin 2008, p. 191 à 200 (lire en ligne)
  3. ↑ (en) Site de Literka
  4. ↑ (en) Un survol de cette question sur le site de MathOverflow
  5. ↑ (en) William E. Heierman, « Minimal polynomials for trig functions of angles rationally commensurate with π »,‎ 4 juin 2009
  6. ↑ (en) Scott Beslin et Valerio De Angelis, « The Minimal Polynomials of sin (2π/p) and cos (2π/p) », Mathematics Magazine, vol. 77, no 2,‎ 2004, p. 146 à 149
  7. ↑ (en) Wolfdieter Lang, « Minimal Polynomials of 2cos(π/n) » et (en) Wolfdieter Lang, « Minimal Polynomials of sin(2π/n) »

Voir aussi[ modifier | modifier le code ]

Bibliographie[ modifier | modifier le code ]

  • (en) Peter Brown, The circle dividers, Parabola volume 36, numéro 1.
  • (en) David Surowski et Paul McCombs, Homogenous polynomials and the minimal polynomial of cos(2π/n)
  • (en) W. Watkins et J. Zeitlin, The Minimal Polynomial of cos(2Pi/n), Am. Math. Monthly 100,5 (1993) 471-4. (première page)

Articles connexes[ modifier | modifier le code ]

  • Nombre algébrique
  • Polynôme minimal d'un nombre algébrique
  • Construction à la règle et au compas
  • Table de lignes trigonométriques exactes
  • Formules trigonométriques en kπ/7
  • Théorème de Gauss-Wantzel
  • Polynôme de Tchebychev
  • Polynôme cyclotomique

Lien externe[ modifier | modifier le code ]

  • (en) Eric W. Weisstein, « Trigonometry Angles », MathWorld

  • Portail de l’algèbre Portail de l’algèbre
  • Portail de la géométrie Portail de la géométrie
Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Polynôme_minimal_des_valeurs_spéciales_trigonométriques&oldid=101667736 ».
Catégories :
  • Trigonométrie
  • Théorie algébrique des nombres
Catégories cachées :
  • Article contenant un appel à traduction en anglais
  • Portail:Algèbre/Articles liés
  • Portail:Sciences/Articles liés
  • Projet:Mathématiques/Articles
  • Portail:Géométrie/Articles liés

Menu de navigation

Outils personnels

  • Créer un compte
  • Se connecter

Espaces de noms

  • Article
  • Discussion

Variantes

Affichages

  • Lire
  • Modifier
  • Modifier le code
  • Historique

Plus

Navigation

  • Accueil
  • Portails thématiques
  • Article au hasard
  • Contact

Contribuer

  • Débuter sur Wikipédia
  • Aide
  • Communauté
  • Modifications récentes
  • Faire un don

Imprimer / exporter

  • Créer un livre
  • Télécharger comme PDF
  • Version imprimable

Outils

  • Pages liées
  • Suivi des pages liées
  • Importer un fichier
  • Pages spéciales
  • Adresse de cette version
  • Information sur la page
  • Élément Wikidata
  • Citer cette page

Autres langues

Modifier les liens
  • Dernière modification de cette page le 28 février 2014 à 14:50.
  • Droit d'auteur : les textes sont disponibles sous licence Creative Commons paternité partage à l’identique ; d’autres conditions peuvent s’appliquer. Voyez les conditions d’utilisation pour plus de détails, ainsi que les crédits graphiques. En cas de réutilisation des textes de cette page, voyez comment citer les auteurs et mentionner la licence.
    Wikipedia® est une marque déposée de la Wikimedia Foundation, Inc., organisation de bienfaisance régie par le paragraphe 501(c)(3) du code fiscal des États-Unis.
  • Politique de confidentialité
  • À propos de Wikipédia
  • Avertissements
  • Développeurs
  • Version mobile
  • Powered by MediaWiki


Trigonométrie

Résolution d'un triangle

En géométrie, la résolution d'un triangle consiste en la détermination des différents éléments d'un triangle (longueurs des côtés, mesure des angles, aire) à partir de certains autres. Historiquement, la résolution des triangles fut motivée

  • en cartographie, pour la mesure des distances par triangulation ;
  • en géométrie euclidienne chez les grecs, pour la résolution de nombreux problèmes de géométrie ;
  • en navigation, pour le point, qui utilise des calculs de coordonnées terrestres et astronomiques (trigonométrie sphérique).

Aujourd'hui, la résolution des triangles continue d'être utilisée dans un grand nombre de problèmes faisant intervenir la triangulation (architecture, relevés cadastraux, vision binoculaire) et, plus généralement, la trigonométrie (astronomie, cartographie).

En géométrie euclidienne, la donnée de trois des éléments du triangles, dont au moins un côté[1], est nécessaire et suffisante à la résolution du triangle, l'un des cas de résolution pouvant admettre deux solutions. En géométrie sphérique ou hyperbolique, la donnée des trois angles est également suffisante. La résolution fait intervenir la trigonométrie, en particulier certaines relations classiques dans le triangle comme le théorème d'Al-Kashi, la loi des sinus, la loi des tangentes, et la somme de ses angles.

Sommaire

  • 1 Histoire
  • 2 Cas de résolution en géométrie euclidienne
    • 2.1 Les trois côtés
    • 2.2 Un angle et les deux côtés adjacents
    • 2.3 Un angle, le côté opposé et un côté adjacent
    • 2.4 Deux angles et le côté commun
    • 2.5 Deux angles et un côté non commun
  • 3 Cas de résolution en géométrie sphérique
    • 3.1 Les trois côtés
    • 3.2 Un angle et les deux côtés adjacents
    • 3.3 Un angle, le côté opposé et un côté adjacent
    • 3.4 Deux angles et le côté commun
    • 3.5 Deux angles et un côté non commun
    • 3.6 Les trois angles
  • 4 Exemples d'application
    • 4.1 Triangulation
    • 4.2 Distance entre deux points du globe
  • 5 Notes et références
  • 6 Voir aussi
    • 6.1 Articles connexes
    • 6.2 Liens externes

Histoire

Cette section est vide, insuffisamment détaillée ou incomplète. Votre aide est la bienvenue !

Cas de résolution en géométrie euclidienne

La résolution d'un triangle en géométrie euclidienne utilise un certain nombre de relations entre éléments du triangle. Les plus souvent utilisées sont

  • le théorème d'Al-Kashi ;
  • la formule de Héron ;
  • la loi des sinus ;
  • la loi des tangentes ;
  • la somme des angles d'un triangle vaut π rad soit 180 °,

bien qu'il soit également possible d'utiliser d'autres relations pour aboutir à une solution.

Ci-dessous sont listés les différents cas de figure en fonction des trois éléments connus parmi les trois angles et les trois côtés. Les formules analytiques sont données pour les côtés et/ou les angles inconnus, ainsi que l'aire S. Elles doivent être adaptées pour une détermination numérique car, prises telles quelles, elles donnent des erreurs importantes pour les triangles « en épingle », c'est-à-dire dont un des côtés est petit par rapport aux autres et les triangles « presque rectangles », c'est-à-dire dont un des angles fait environ 90°.

Les trois côtés

Resolve triangle with a b c.png

On considère un triangle dont les trois côtés a, b et c sont connus. Les angles sont déduits à partir du théorème d'Al-Kashi et l'aire (S) à partir de la formule de Héron :

  • , avec

(Chacun des facteurs dans l'expression de S est positif, d'après l'inégalité triangulaire.)

Un angle et les deux côtés adjacents

Resolve triangle with a b gamma.png

On considère un triangle dont l'angle γ est connu, ainsi que les deux côtés adjacents a et b. Le dernier côté s'obtient grâce au théorème d'Al-Kashi, les deux angles manquants par la loi des tangentes et le complément à π, et l'aire par la formule du produit vectoriel :

Un angle, le côté opposé et un côté adjacent

Resolve triangle with b c beta.png

On considère un triangle dont un angle β est connu, ainsi qu'un côté adjacent de cet angle c et le côté opposé b. Le deuxième angle γ s'obtient par la loi des sinus, le dernier angle α par complément à π et le dernier côté par la loi des sinus :

Si β est aigu et que b < c, il existe une seconde solution :

La résolution n'est pas possible pour toutes les valeurs des paramètres. La condition suivante doit être réalisée :

.

Deux angles et le côté commun

Resolve triangle with c alpha beta.png

On considère un triangle dont un côté c et les deux angles α et β qui le bordent sont connus. Le dernier angle s'obtient par complément à π et les deux autres côtés par la loi des sinus :

Deux angles et un côté non commun

On considère un triangle dont deux angles α et β sont connus, ainsi qu'un côté non commun à ces deux angles a. Le dernier angle s'obtient par complément à π et les deux autres côtés par la loi des sinus :

Cas de résolution en géométrie sphérique

La résolution d'un triangle en géométrie sphérique (géométrie non euclidienne) est légèrement différente du cas euclidien, car la loi des sinus ne permet pas d'obtenir un côté de manière univoque — uniquement son sinus. De plus, un triangle sphérique dont les trois angles sont connus est soluble, contrairement à un triangle du plan euclidien et la solution est unique.

Les formules utilisées pour résoudre un triangle sphérique sont :

  • les généralisations de la loi des cosinus (variantes portant sur les angles et sur les côtés) ;
  • le théorème de l'Huilier ;
  • les analogies de Napier ;
  • la somme des angles d'un triangle vaut π plus l'excès E (=S/R²).

Les trois côtés

Solve spherical triangle with a b c.png

Dans un triangle dont les trois côtés a, b et c sont connus, les angles s'obtiennent par la généralisation du théorème d'Al-Kashi et l'aire par le théorème de l'Huilier :

  • ,
  • ,
  • ,
  • où [image].

Un angle et les deux côtés adjacents

Solve spherical triangle with a b gamma.png

Dans un triangle où deux côtés a et b et l'angle qu'ils forment γ sont connus, le dernier côté s'obtient par le théorème d'Al-Kashi généralisé et les deux angles restants par les analogies de Napier :

  • ,
  • ,
  • ,
  • .

Un angle, le côté opposé et un côté adjacent

Solve spherical triangle with b c beta.png

On considère un triangle dont un angle β, un côté adjacent c et le côté opposé b sont connus. L'angle γ s'obtient par la loi des sinus et les éléments restants par les analogies de Napier. Il n'y a de solution que si

.

Alors

  • ,
  • ,
  • .

Une autre solution existe lorsque b > c et que γ est aigu :

  • , etc.

Deux angles et le côté commun

Solve spherical triangle with c alpha beta.png

Dans un triangle où deux angles α et β sont connus, ainsi que le côté commun à ces angles c, le dernier angle s'obtient par la formule d'al-Kashi et les deux derniers côtés par les analogies de Napier. Les formules pour l'angle manquant et les côtés ressemblent à celles du cas de résolution complémentaire (un angle et les deux côtés adjacents connus) :

  • ,
  • ,
  • ,
  • .

Deux angles et un côté non commun

Solve spherical triangle with a alpha beta.png

On considère un triangle dans lequel deux angles α et β sont connus, ainsi qu'un côté opposé à l'un de ces angles a. Le côté b se trouve par la loi des sinus et les éléments restants par les analogies de Napier. On notera la similitude entre les équations ci-dessous et le cas de résolution complémentaire (un angle, le côté opposé et un côté adjacent) :

  • ,
  • ,
  • ,
  • .

Si a est aigu et que α > β, il existe une autre solution :

  • , etc.

Les trois angles

Solve spherical triangle with alpha beta gamma.png

Dans le cas où les trois angles sont connus, les côtés s'obtiennent par une variante du théorème d'Al-Kashi pour les angles. Les formules donnant les côtés sont semblables à celles du cas de résolution complémentaire (les trois côtés connus) :

  • ,
  • ,
  • .

Exemples d'application

Triangulation

Voir l'article détaillé Triangulation.

Fig. 1 — Détermination de la distance d'un navire par triangulation

La figure 1 ci-contre indique une méthode de détermination de la distance d'un bateau par triangulation : de deux points dont on connaît la distance l, on mesure sa direction, que ce soit l'azimut à l'aide d'une boussole, ou les angles α et β avec la ligne joignant les deux points. Les mesures effectuées, il est possible d'en déduire la distance graphiquement en reportant les éléments connus sur un graphique avec une échelle idoine. Une formule analytique peut être par ailleurs trouvée en résolvant le triangle dont on connaît deux angles et le côté commun :

.

Une variante est utilisée en navigation côtière : les angles sont estimés grâce aux azimuts des amers (points de référence sur terre) vus depuis le navire.

Fig. 2 — Détermination de la hauteur d'une montagne par triangulation

Une autre possibilité est la mesure de la hauteur h d'une colline ou d'une montagne depuis une vallée en mesurant sa hauteur angulaire α et β en deux points de distance connue l. La figure 2 ci-contre donne un cas simplifié dans lequel les points de mesure et la projection du sommet sur le sol sont alignés. La hauteur de la montagne peut être déterminée graphiquement ou bien analytiquement par résolution du triangle (même cas que précédemment) :

.

Dans la pratique la méthode de résolution se heurte à quelques difficultés : le terrain n'est pas forcément plat, ce qui nécessite un estimation de la pente entre les deux points ; le sommet réel n'est pas forcément observable depuis la plaine et le point le plus haut tel qu'observé varie de position entre les deux points d'observation par effet de tangence ; les différents éléments du relief doivent être triangulés de proche en proche à partir des côtes ce qui accumule les erreurs de mesure. Ainsi, la cartographie par satellite a modifié de plusieurs mètres les valeurs traditionnelles estimées de certains sommets.[réf. nécessaire] Malgré ces difficultés, au XIXe siècle, Friedrich Georg Wilhelm von Struve a fait construire l'arc géodésique de Struve, une chaîne de repères géodésiques traversant l'Europe sur 2800 km de la Norvège à la Mer Noire et dont le but était de mesurer la taille et la forme de la terre : en 1853, le scientifique obtient une mesure d'un arc de méridien terrestre à 188 m près (2×10-5) et de l'aplatissement de la terre à 1 % près[2].

Distance entre deux points du globe

Distance on earth.png

On considère deux points du globe A et B de latitudes respectives λA et λB, et de longitudes LA et LB. Pour déterminer leur distance on considère le triangle ABC, où C est le pôle nord. Dans ce triangle sont connus :

La résolution du triangle dans le cas où un angle et les deux côtés adjacents sont connus permet de conclure que

,

où R est le rayon de la terre. Les coordonnées doivent être converties en radians pour une application numérique, à moins que la calculatrice accepte les degrés dans les fonctions trigonométriques.

Notes et références

  1. ↑ En effet, comme le rappelle l'abbé Boscovich: « les trois côtés ne sont pas déterminés par les trois angles parce que leur somme y étant toujours égale à deux angles droits, la détermination des trois angles ne donne rien de plus que la détermination de deux seuls » (Opera Pertinentia ad Opticam et Astronomiam, Volume 4, 1785, p. 316)
  2. ↑ (en) J.R. Smith, The Struve Geodesic Arc

Voir aussi

Articles connexes

  • relations dans le triangle
    • loi des sinus
    • loi des cosinus
    • loi des tangentes
    • formule de Héron et théorème de l'Huilier
  • triangulation
  • trigonométrie
    • fonction trigonométrique
    • trigonométrie sphérique

Liens externes

  • Triangulateur, Résolution numérique et symbolique de triangle à partir d'un minimum de données. Avec dessin du triangle.
  • Triangle calculator, site en anglais permettant la résolution numérique d'un triangle plan.
  • TriSph : programme de résolution des triangles sphériques configurable à différentes applications pratiques et configuré pour la gnomonique
  • Spherical trigonometry du site anglais Math World


Trigonométrie

Radian

Radian
Définition de l'angle en radians. Définition de l'angle en radians.
Informations
Système | Unités dérivées du système international
Unité de... | Angle plan
Symbole | rad
modifier Consultez la documentation du modèle

Le radian (symbole : rad) est l'unité dérivée du système international qui mesure les angles plans.

Sommaire

  • 1 Définition
  • 2 Petits angles
  • 3 Relations entre grades, degrés et radians
  • 4 Voir aussi
    • 4.1 Bibliographie
    • 4.2 Articles connexes
    • 4.3 Notes et références

Définition

Considérons un secteur angulaire, formé de deux droites concourantes distinctes, et un cercle de rayon r tracé dans un plan contenant ces deux droites, dont le centre est le point d'intersection des droites. Alors, la valeur de l'angle en radians est le rapport entre la longueur L de l'arc de cercle intercepté par les droites et le rayon r.

Un angle d'un radian intercepte sur la circonférence de ce cercle un arc d'une longueur égale au rayon. Un cercle complet représente un angle de 2π radians, appelé angle plein.

L'utilisation des radians est impérative lorsque l'on dérive ou intègre une fonction trigonométrique : en effet, l'angle pouvant se retrouver en facteur, seule la valeur en radians a un sens. De ce fait, le calcul des fonctions trigonométriques par une série de Taylor suppose l'expression des angles en radians.

Petits angles

Pour les petits angles exprimés en radians, sin x ≈ tan x ≈ x.

  • Pour un angle de valeur inférieure à 0,17 radian l'erreur est de moins de 1 % ;
  • Pour un angle de valeur inférieure à 0,05 radian l'erreur est de moins de 0,1 % (TVF, p. 39).

Il n'y a aucune formule de ce genre avec les valeurs en grades et degrés.

Dans le domaine de la topographie, où on traite d'angles faibles, on utilise le mil angulaire, une unité pratique, définie comme l'angle qu'intercepte une longueur de 1 mm à une distance de 1 m. Elle sert, par exemple, à déterminer la distance d'une mire de hauteur connue par la mesure de sa taille apparente. Dans les conditions où elle sert, cette unité s'identifie avec un milliradian.

Relations entre grades, degrés et radians

Un tour complet équivaut à 2π radians, 360 degrés, 400 grades.

Par conséquent,

  • Un radian vaut environ 57,3° ou 57° 18' (360°÷2π) ;
  • un degré vaut approximativement 17,5 milliradians.

Les formules de conversion entre les degrés et les radians sont :

.

Les formules de conversion entre les grades et les radians sont :

.

Voici quelques angles particuliers et leur équivalence avec les grades et degrés :

nom de l'angle | valeur en radians | valeur en grades | valeur en degrés
angle nul | 0 rad | 0 gon | 0°
milliradian | 0,001 | 0,063 661 977 gon | 0° 3′ 26″ 16‴ soit 0,0573°
 | π/6 rad | 33,333 333 gon | 30°
 | π/4 rad | 50 gon | 45°
radian | 1 rad | 63,661 977 gon | 57° 17′ 44″ 48‴
 | π/3 rad | 66,666 666 gon | 60°
angle droit | π/2 rad | 100 gon | 90°
 | 2π/3 rad | 133,333 333 gon | 120°
 | 3π/4 rad | 150 gon | 135°
angle plat | π rad | 200 gon | 180°
 | 5π/4 rad | 250 gon | 225°
 | 3π/2 rad | 300 gon | 270°
 | 7π/4 rad | 350 gon | 315°
angle plein | 2π rad | 400 gon | 360°

Un angle de 57,3° intercepte un arc de longueur égale au rayon. Avec une circonférence de 360 cm, un radian intercepte un arc de longueur égale au rayon = 57,3 cm.

Pour les angles â inférieurs à 3°, utiles pour l'astronomie, on peut confondre la longueur de l'arc intercepté par l'angle â avec le côté opposé à l'angle â. Ainsi, un angle de 1 degré intercepte un arc de 1 cm sur un cercle de 3,6 m de circonférence[réf. souhaitée].

De façon générale, pour les angles inférieurs à 3° :

Voir aussi

Sur les autres projets Wikimedia :

  • radian, sur le Wiktionnaire

Bibliographie

  • Richard Taillet, Loïc Villain et Pascal Febvre, Dictionnaire de physique, Bruxelles, De Boeck,‎ 2013, p. 569 « Radian »

Articles connexes

  • Angle
  • Mil angulaire
  • Degré (angle)
  • Grade (angle)

Notes et références

v · m
Système international d’unités
Unités de base ampère · candela · kelvin · kilogramme · mètre · mole · seconde
Unités dérivées becquerel · coulomb · degré Celsius · farad · gray · henry · hertz · joule · katal · lumen · lux · newton · ohm · pascal · radian · siemens · sievert · stéradian · tesla · volt · watt · weber
Préfixes yocto · zepto · atto · femto · pico · nano · micro · milli · centi · déci · déca · hecto · kilo · méga · giga · téra · péta · exa · zetta · yotta


Trigonométrie

Série trigonométrique

Une série trigonométrique est une suite particulière de polynômes trigonométriques. La série possède une fréquence fondamentale f, et on somme successivement des fonctions trigonométriques de fréquence n.f pour des valeurs entières de n.

Le terme d'ordre n de la série a donc la forme suivante

si on travaille avec des notations complexes. Mais on utilise aussi couramment

si on a une série trigonométrique à valeurs réelles.

L'exemple le plus classique de série trigonométrique est la série de Fourier associée à une fonction périodique intégrable.

Sommaire

  • 1 Théorème d'unicité de Cantor
  • 2 Lien avec les séries de Fourier
  • 3 Le problème de l'existence d'une décomposition
  • 4 Notes et références
  • 5 Bibliographie

Théorème d'unicité de Cantor

On doit à Georg Cantor le théorème d'unicité pour les séries trigonométriques, prouvé en 1870.

Théorème : si une série trigonométrique converge en tout point vers la fonction nulle, alors tous ses coefficients sont nuls. Ainsi deux séries trigonométriques qui ont la même limite simple ont les mêmes coefficients.

Cantor a lui-même étendu son résultat, le rendant valable lorsqu'il y a convergence en tout point sauf un nombre fini (c'est d'ailleurs en cherchant à généraliser ce résultat que Cantor sera amené à introduire la notion de nombre ordinal).

D'autres extensions ont suivi. On appelle ensemble d'unicité un sous-ensemble de la droite réelle, défini modulo 2π, sur le complémentaire duquel le résultat d'unicité de Cantor s'étend.

  • En 1909, Young démontre que les ensembles dénombrables sont des ensembles d'unicité ;
  • on sait depuis leur définition par Lebesgue que les ensembles d'unicité sont de mesure nulle (pour la mesure de Lebesgue) ;
  • en 1916, Dmitry Menchoff (en) donne un exemple d'ensemble de mesure nulle qui n'est pas un ensemble d'unicité[1] ;
  • de nombreux résultats plus précis se sont ajoutés depuis.

Lien avec les séries de Fourier

Selon un théorème de Lebesgue de 1902, si une série trigonométrique converge simplement vers une fonction bornée, alors c'est la série de Fourier de cette fonction. Comme le résultat de Menchoff signalé ci-dessus l'illustre, ce théorème serait en défaut si on remplaçait la convergence simple par une convergence presque partout.

Ces théorèmes d'unicité ne doivent pas être confondus avec le théorème d'injectivité des coefficients de Fourier : deux fonctions ayant les mêmes coefficients de Fourier sont égales presque partout. Voir l'article série de Fourier.

Le problème de l'existence d'une décomposition

Si f est une fonction mesurable, finie presque partout, un théorème de Menchoff montre qu'il existe une série trigonométrique qui converge vers f presque partout[2].

Notes et références

  1. ↑ D. Menchoff, « Sur l'unicité du développement trigonométrique », C.R. Acad. Sci. Paris, vol. 163,‎ 1916, p. 433-436
  2. ↑ D. Menchoff, « Sur la représentation des fonctions mesurables par des séries trigonométriques », Mat. Sb., vol. 9(51), no 3,‎ 1941, p. 667-692 (lire en ligne)

Bibliographie

  • Jean-Pierre Kahane et Pierre-Gilles Lemarié-Rieusset, Séries de Fourier et ondelettes [détail de l’édition]
  • (en) Antoni Zygmund, Trigonometric Series, CUP,‎ 2002, 3e éd. (ISBN 978-0-52189053-3, lire en ligne)
  • (en) Nina Bari, A Treatise on Trigonometric Series, Macmillan, 1964


Trigonométrie

Trigonométrie sphérique

La trigonométrie sphérique est un ensemble de relations analogues à celles de la trigonométrie euclidienne mais portant sur les angles et distances repérés sur une sphère.

La figure de base est le triangle sphérique, délimité non plus par des segments de droites mais par des arcs de grands cercles de cette sphère. Les règles habituelles de la trigonométrie euclidienne ne sont pas applicables ; par exemple la somme des angles d'un triangle situé sur une sphère est supérieure à 180 degrés.

Sommaire

  • 1 Le triangle sphérique
    • 1.1 Formules fondamentales
      • 1.1.1 Conventions
      • 1.1.2 Formule des cosinus et relation duale
      • 1.1.3 Formule des sinus
      • 1.1.4 Troisième formule fondamentale et relation duale
      • 1.1.5 Formule des cotangentes
    • 1.2 Autres formules
      • 1.2.1 Formules des demi-angles et demi-côtés
      • 1.2.2 Formules de Gauss
      • 1.2.3 Analogies de Napier
      • 1.2.4 Aire du triangle sphérique
      • 1.2.5 Formule de l'Huilier
  • 2 Triangle polaire
  • 3 Aperçu historique
  • 4 Applications
  • 5 Notes et références
  • 6 Voir aussi
    • 6.1 Articles connexes
    • 6.2 Liens externes

Le triangle sphérique

Formules fondamentales

triangle sphérique

Conventions

On considère trois points A, B et C sur une sphère comme représentés par la figure ci-contre, ainsi que les arcs de grands cercles qui les relient. On note α, parfois [image], l'angle du triangle au sommet A, et de façon analogue pour les autres sommets. On note a, b et c les angles sous-tendus au centre O de la sphère par la partie de grand cercle correspondante. Ainsi a désigne l'angle BOC, etc. Un angle de 2π correspond à un grand cercle entier. Bien entendu les longueurs se déduisent de a, b et c en les multipliant par le rayon de la sphère.

Formule des cosinus et relation duale

L'une des relations les plus importantes de la trigonométrie sphérique, donnée par François Viète en 1593 dans son De Varorium[1] est la formule des cosinus, qui relie la longueur d'un côté à celles de deux autres côtés ainsi qu'à l'angle entre eux :

qu'il ne faut pas confondre avec la relation duale, obtenue en remplaçant dans cette relation tous les grands cercles par leurs points polaires :

La formule des cosinus se démontre de plusieurs façons. L'une d'elle consiste à exprimer de différentes manières le produit scalaire, dans l'espace euclidien ambiant, entre les vecteurs reliant le centre O de la sphère aux points A et B. Une autre est détaillée ci dessous.

Dans le cas particulier où le triangle est rectangle en C, on obtient

,

formule correspondant au théorème de Pythagore pour la trigonométrie sphérique. On remarque que si le triangle est suffisamment petit pour que l'on puisse remplacer les cosinus par leur développement limité au deuxième ordre, on retrouve effectivement le théorème de Pythagore.

La formule des cosinus permet notamment de calculer la distance entre deux points A et B sur la Terre en fonction de leurs latitudes et longitudes. Pour cela, on place C au pôle nord, de sorte que a est le complémentaire de la latitude [image] de A, b le complémentaire de celle [image] de B, et [image] la différence de longitude [image]. On obtient directement[2]

(où R = 6 400 km est le rayon terrestre).

Formule des sinus

On remarque que d'après la relation duale évoquée précédemment, un triangle sphérique est déterminé par ses trois angles, ce qui est très différent du cas du triangle euclidien (plan). Il y a une analogie parfaite (de dualité), dans le triangle sphérique, entre longueurs des côtés et angles aux sommets. La formule des sinus illustre cette analogie :

ou encore

ce qui doit se comprendre comme « les trois quantités de gauche sont dans les mêmes proportions que les trois quantités de droite (le rapport entre deux quelconques à gauche est le même que le rapport correspondant à droite) ».

Troisième formule fondamentale et relation duale

La formule des cosinus peut également s'écrire sous la forme

Des expressions analogues pour [image] et [image] on déduit ce qui est parfois appelé[réf. nécessaire] la troisième formule fondamentale de la trigonométrie sphérique (les deux premières étant celles des cosinus et des sinus), qui relie trois longueurs à deux angles du triangle :

Il est intéressant de remarquer la similarité avec la formule des cosinus [image].

La relation duale peut quant à elle s'écrire

à comparer avec la relation duale de la formule des cosinus [image].

Formule des cotangentes

À partir de la troisième formule fondamentale, on obtient aisément la dernière formule dite des cotangentes, qui relie quatre éléments successifs du triangle sphérique :

Pour obtenir cette formule, il suffit de diviser la relation duale de la troisième formule fondamentale par [image] puis d'utiliser la formule des sinus.

Démonstration des formules fondamentales

a, b et c désignent les longueurs, A, B et C désignent les sommets, α, β et γ désignent les angles du triangle sphérique.

Démonstration par changement de repère

1) On forme deux repères orthonormés directs R et R' de même premier vecteur, et tels que A soit le pôle nord du système de coordonnées sphériques associé au premier repère et B le pôle nord du second. On note [image] et [image] avec

On prend alors

On en déduit

La formule du double produit vectoriel conduit à

De même,

2) Le changement de repère (de R vers R') est une rotation dans l'espace autour de l'axe commun aux deux repères. Comme l'angle entre [image] et [image] est c, on en déduit que la matrice de passage est

3) On donne maintenant les coordonnées de C dans le repère R.

On remarque que b est la colatitude dans le repère sphérique de pôle nord A associé au repère cartésien, alors que α désigne l'angle (au pôle) entre le vecteur [image] et le demi-plan vertical (A,O,C), donc la longitude vaut α-(π/2).
On en déduit que C, de coordonnées sphériques [image], a pour coordonnées cartésiennes dans le premier repère

4) On donne de même les coordonnées de C dans le second repère R'.

Cette fois, le pôle nord est le point B, la colatitude est a, et β est l'angle que fait le demi-plan vertical (B,O,C) avec le vecteur [image], donc la longitude vaut (π/2)-β.
On en déduit que C, de coordonnées sphériques [image], a pour coordonnées cartésiennes dans le second repère

5) La formule de changement de base s'écrit alors :

On en déduit d'un seul coup la formule des sinus, la troisième formule fondamentale de la trigonométrie sphérique et la formule des cosinus :
Démonstration à l'aide du produit scalaire

Considérons un triangle sphérique ABC situé sur la surface d’une sphère unité de centre O. En projetant les points A et C sur l’axe OB respectivement en F et E. On a donc :

A noter : est un repère orthonormé, [image] est perpendiculaire à [image] et n'est pas parallèle à

Il s'en suit:
Par ailleurs:
Donc:
Or:
Donc:

Par permutation circulaire, on obtient les différentes relations:

Autres formules

Formules des demi-angles et demi-côtés

Soit [image] le demi-périmètre du triangle. Alors on a

et pour les formules duales, avec [image] :

.

Ces formules qui, comme la relation fondamentale, lient un angle au centre aux trois côtés du triangle sphérique ne contiennent pas de somme. Elles étaient très utilisées pour les calculs pratiques à l'aide de tables de logarithmes.

Formules de Gauss

On a [image] et [image] ainsi que [image] et

On en déduit la loi des tangentes en trigonométrie sphérique :

Analogies de Napier

Elles s'obtiennent en combinant deux à deux les formules de Gauss :

Aire du triangle sphérique

En anglais, elle est connue sous le nom de formule de Girard. De façon remarquable, l'aire du triangle sphérique se calcule très simplement à partir de ses trois angles : elle est exactement égale à son « défaut d'euclidianité » (différence entre la somme des angles du triangle et [image]) multiplié par le carré du rayon R de la sphère. Soit :

Remarque : ε est un angle solide s'exprimant en stéradians (pour [image] et [image] exprimés en radians). Cette formule se montre de façon élémentaire[3]. Elle se fait en trois étapes :

  • Lorsque la sphère est découpée en 4 secteurs (« fuseaux » ou « lunes » chez Legendre) par deux plans diamétraux, l'aire d'un des secteurs ainsi découpé est proportionnelle à l'angle [image] des deux plans. Elle vaut donc
    .
  • Les trois plans diamétraux qui définissent un triangle sphérique découpent sur la sphère douze fuseaux dont six contiennent ce triangle ou son symétrique, de même aire, par rapport au centre la sphère. Ces six fuseaux recouvrent la sphère, le triangle et son symétrique étant recouverts trois fois chacun, le reste ne l'étant qu'une seule fois. Ainsi, la somme des aires des six fuseaux est celle de la sphère augmentée quatre fois de celle du triangle. Il s'en déduit :
    .
  • Ainsi, après transformation :
    Cette formule, découverte par Thomas Harriot, mais non publiée, fut donnée pour la première fois par Albert Girard vers 1625.

Formule de l'Huilier

Cette formule est analogue à la formule de Héron qui calcule l'aire d'un triangle euclidien en fonction de ses côtés, et elle fait la même chose pour le triangle sphérique :

(on rappelle qu'on a appelé s=(a+b+c)/2 le demi-périmètre).

Triangle polaire

Triangle (ABC) et son triangle polaire (A'B'C'). (OC') est l'axe de rotation du grand cercle (AB), etc.

Sur une sphère de centre O, on considère deux points A et B distincts et non diamétralement opposés. La droite passant par O et orthogonale au plan OAB rencontre la sphère en deux points qui sont appelés les pôles du plan (OAB).

Pour un triangle ABC tracé sur une sphère, on appelle C' le pôle du plan (OAB) situé sur le même hémisphère que C. On construit de même les points A' et B'. Le triangle (A'B'C') est appelé le triangle polaire du triangle ABC.

Par construction, les grands cercles (C'B') et (C'A') coupent le grand cercle (AB) en angle droit. Il en est de même des deux grands cercles (B'A') et (B'C') pour le grand cercle (AC), etc. Les côtés du triangle polaire sont donc perpendiculaires chacun à deux côtés du triangle d'origine.

La transformation qui, a un triangle, associe son triangle polaire est une application involutive[4], c'est-à-dire que le triangle polaire du triangle (A'B'C') est le triangle (ABC).

Les côtés du triangle (A'B'C') sont les supplémentaires des angles du triangle (ABC). Ce qui s'exprime par les égalités suivantes[4]: et par propriété de l'involution, les angles du triangle polaire sont les supplémentaires des côtés du triangle (ABC). Soit

Ces relations permettent de déduire, à partir des formules fondamentales, les formules duales citées plus haut.

Aperçu historique

Article détaillé : Histoire des fonctions trigonométriques.

La trigonométrie, et en particulier la trigonométrie sphérique, doit beaucoup aux astronomes et mathématiciens grecs Hipparque de Nicée [5] ainsi que Ménélaos d'Alexandrie [6], mais aussi aux mathématiciens persans de langue arabe et indiens. Parmi les plus célèbres figurent Bhāskara II[réf. nécessaire], Abu Nasr Mansur, Abu l-Wafa et Al-Biruni qui démontrent la règle des sinus pour un triangle quelconque ainsi que les formules pour le triangle rectangle[7]. La trigonométrie sphérique occupe une place importante dans les traités d'astronomie arabe et des traités spécifiques lui sont consacrés comme le traité de trigonométrie sphérique d'Ibn Muʿādh al-Jayyānī (XIe siècle), un mathématicien de l'Andalousie alors sous domination musulmane ou celui de Nasir ad-Din at-Tusi (XIIIe siècle)[6].

Applications

Calculs de coordonnées :

  • en astronomie, pour les changements relatifs aux divers systèmes de coordonnées angulaires : déclinaison, ascension droite, angle horaire, azimut et distance zénithale (ou hauteur) ;
Article détaillé : Système de coordonnées célestes.
  • en géographie (latitude et longitude) ;
  • en optique pour l'utilisation de la sphère de Poincaré ;
  • en statistiques sur la sphère de l'iconographie des corrélations.

Considérons également l'application aux panneaux solaires plans.

Notes et références

  1. ↑ Michel Chasles : Mémoires sur les questions proposées par l'Académie royale des sciences de Bruxelles page 54.
  2. ↑ Comment obtenir la distance entre deux points connus en longitude et latitude sur la sphère sur le site géodésie.ign.fr
  3. ↑ Quelques explications sur le site du Palais de la découverte
  4. ↑ a et b Pour une démonstration on peut lire, Trigonométrie sphérique de Pierre-Yves Créach, pp. 13-15
  5. ↑ Œuvres complètes de François Arago. François Arago, tome 3, page 158 (Gide, Paris - 1855).
  6. ↑ a et b Marie-Thérèse Debarnot, « Trigonométrie », dans Roshdi Rashed, Histoire des sciences arabes, vol. 2, Seuil,‎ 1997.
  7. ↑ Debarnot 1997, p. 172-176.

Voir aussi

Articles connexes

  • Théorème de Ménélaüs
  • Résolution d'un triangle
  • Géométrie non euclidienne

Liens externes

  • Un cours de trigonométrie sphérique sur le site personnel "Mathématiques au Lycée" de P.Y. Créach
  • Un "cours" de cartographie et de trigonométrie sphérique sur le site personnel de David Madore
  • Trigonométrie sphérique pour l'astronomie sur le site personnel "Astronomie - Sphère céleste"
  • TriSph : programme de résolution des triangles sphériques configurable à différentes applications pratiques et configuré pour la gnomonique
  • "Le livre d'instruction sur les plans déviants et les plans simples" est un manuscrit en arabe qui remonte à 1740 et parle de la trigonométrie sphérique, avec des diagrammes.


Trigonométrie

Trigonométrie de Wildberger

La trigonométrie de Wildberger (dite aussi trigonométrie rationnelle car elle ne fait aucun recours aux nombres irrationnels), constitue une réécriture de la trigonométrie traditionnelle. Elle s’en distingue en évitant non seulement l’usage des fonctions trigonométriques classiques, mais même l’usage de nombre transcendant tel que π dans l’écriture des formules.

Elle fut publiée en 2005 dans Divine Proportions: Rational Trigonometry to Universal Geometry par Norman Wildberger, Ph.D. de mathématiques de l'université Yale et actuellement professeur associé en mathématiques à l’université de Nouvelle-Galles du Sud à Sydney.

Sommaire

  • 1 Historique
  • 2 Le retournement de Wildberger
    • 2.1 Quadrance
    • 2.2 Ouverture
  • 3 Restriction actuelle
  • 4 Positionnement
  • 5 Applications
  • 6 Voir aussi
    • 6.1 Bibliographie
    • 6.2 Lien externe

Historique

On pratiquait depuis un quart de siècle la trigonométrie entière utilisée dès les premiers jeux graphiques sur ordinateur, afin d’éviter le recours aux fonctions flottantes dont le calcul était lent (jusqu’au 80486, les processeur de la gamme i386 n’avaient pas de coprocesseur arithmétique en standard). Cette trigonométrie simplifiée dont la résolution ne dépassait ni ne voulait dépasser la résolution du pixel présentait le double mérite :

  • de sa simplicité de mise en œuvre (par utilisation intensive à la fois de tables et des formules du style sin(a + b) = sina*cosb + sinb*cosa, etc.
  • d’une vitesse de calcul alors largement supérieure à celle du flottant

Le retournement de Wildberger

Wildberger retourne le problème en partant au contraire des méthodes d’addition des sinus et cosinus pris cette fois-ci comme axiomes de théorie, et développe une trigonométrie en nombres rationnels, en présentant cette construction comme plus satisfaisante pour l’esprit que l’introduction « classique ». Celle-ci évite d’introduire la notion de nombre réel, abstraction certes intéressante en soi, mais qui n’a pas d’intérêt dans le domaine spécifique du calcul numérique : il est toujours possible de pousser une précision aussi loin qu’on le désire en employant dans son système uniquement des rationnels, et sans avoir, à aucun moment du calcul, à postuler l’existence de nombres réels.

Cette approche n’est pas sans rappeler historiquement la reprise de la géométrie d’Euclide uniquement par le compas, et sans avoir à utiliser la règle dans les constructions (Georg Mohr et Lorenzo Mascheroni). Selon Wildberger, la construction de la trigonométrie est nettement simplifiée par cette méthode, et il est toujours possible de montrer par la suite que les axiomes choisis correspondent bien à ce qui est observé dans le monde euclidien.

Quadrance

Afin d’éviter le recours à la notion de racine carrée, c’est la notion de quadrance (carré de la distance) qui est utilisée dans cette trigonométrie. L’inégalité triangulaire restant respectée, cette modification légère n’a pas d’incidence sur l’ensemble.

Ouverture

Pour des raisons similaires, et avec les mêmes effets, les angles sont remplacés par des ouvertures (spread) qui sont le carré du sinus de l’angle. Elles présentent l’intérêt elles aussi de se calculer de façon simple en n’utilisant que l’arithmétique des nombres rationnels.

Restriction actuelle

Wildberger n’a pour le moment achevé cette théorie que pour la géométrie plane.

Positionnement

La démarche de Wildberger s’apparente aux méthodes constructivistes à la mode depuis quelques années en mathématiques, et elles-mêmes influencées par les paradigmes de l’algorithmique.

Sur un plan épistémologique et plus généralement philosophique, on y retrouve aussi la traditionnelle complémentarité d’approche entre

  • l’algorithmique des Babyloniens (où l’important est le résultat du calcul)

et

  • l’abstraction générale plus typique des mathématiques et de la pensée grecque.

Applications

Les applications par exemple de Conception assistée par ordinateur, de cartographie ou a fortiori des jeux vidéo ont fortement à gagner d’avancées dans le domaine de la trigonométrie en nombre rationnels.

  • pour résoudre de façon unifiée (c’est-à-dire sans bricolages ad hoc, et donc de façon aisément portable) les questions de grandes variations d’échelle qui limitent la plage de travail de logiciels comme CATIA : cette géométrie s’abstrait en effet des considérations de granulation introduites
    • par l’architecture flottante
    • par les différences considérables de résolution des unités de sortie
    • par les fonctions approchées (polynômes) de calcul des irrationnels : des calculs sur les rationnels se font de façon exacte jusqu’à l’arrondi ou l’antialiasing final au moment de l’affichage, ce calcul pouvant être reporté sur une carte graphique conçue en ce sens
  • afin de gagner largement en vitesse sur les temps de calcul

Cela ne représente toutefois qu’un simple intérêt anecdotique de la théorie, comme a pu l’être autrefois la synthèse d'image pour les fractales : intéressant pour la rendre visible, mais ne lui étant pas directement nécessaire.

Voir aussi

Bibliographie

(en) N.J. Wildberger, A Rational Approach to Trigonometry, Math Horizons (en), vol. 15, n° 2, novembre 2007, p. 16-20

Lien externe

(en) Site sur le livre de Wildberger


Trigonométrie

Trigonométrie complexe

Extension des fonctions circulaires

Dans le plan des nombres complexes, grâce aux formules d'Euler, les fonctions trigonométriques peuvent se définir ainsi :

De même que leurs fonctions réciproques :

Ces fonctions réciproques souffrent des mêmes problèmes d'indétermination que le logarithme complexe.

Formules d'addition

Pour tous nombres complexes a et b, on a par exemple :

Démonstration

d'où (en remplaçant b par ib) :

Pour les autres fonctions trigonométriques, on fait de même. Pour tan, cot, tanh et coth, mieux vaut utiliser leurs propriétés suivantes :

Sujets liés

  • Fonction trigonométrique
  • Fonction exponentielle
  • Exponentielle complexe
  • Fonction hyperbolique
  • Nombre complexe


Trigonométrie

Triangle (géométries non euclidiennes)

Triangle sphérique trirectangle (somme des angles : 270°).

En géométrie, un triangle se définit sur une surface comme une figure fermée à trois côtés, ces trois côtés étant des arcs de géodésiques de cette surface. Cette surface peut être entre autres sphérique, hyperbolique ou plane, et les triangles correspondants sont dits sphériques, hyperboliques ou plans.

Propriétés

Contrairement au triangle défini en géométrie euclidienne, la somme des angles d'un triangle peut être différente de 180°. Par exemple, la somme des angles d'un triangle sphérique est supérieure à 180°

Il existe donc des triangles rectangles, birectangles ou trirectangles qui possèdent respectivement un, deux et trois angles droits.

Voir aussi

  • Trigonométrie sphérique


Trigonométrie

Transformation complexe

La transformation complexe est une méthode mathématiques permettant de dériver, d'intégrer ou d'appliquer facilement des opérations arithmétiques (+, -, x et /) à des grandeurs fonctions sinusoïdales du temps. Elle remplace avantageusement la représentation de Fresnel dans des situations compliquées.

Principe

À une grandeur : , fonction sinusoïdale du temps d'expression :

,

on fait correspondre un nombre complexe :

  • de module :
  • d'argument :
  • notation exponentielle : ,
    • remarque : il est fréquent que l'on abrège la notation exponentielle sous la forme :
,
Dans ce cas, il faut conserver en mémoire l'existence de ω pour les dérivations ou les intégrations.

En électricité, pour les courants et les tensions, il est d'usage d'utiliser un nombre complexe dont le module est égal à la valeur efficace de la grandeur :

Opérations élémentaires

  • Opérations arithmétiques : on se ramène à des opérations sur les nombres complexes, puis on applique la transformation inverse pour obtenir la grandeur sinusoïdale qui correspond au résultat de l'opération.
  • Dérivation
On dérive le nombre complexe image :
,
on obtient :
ou encore
  • Intégration
On intègre le nombre complexe image et on obtient :
, ou encore

Représentation complexe des courants et tensions (généralisable)

Dans un circuit en régime permanent sinusoidal composé de composants linéaires, un courant ou une tension est une fonction g(t) du type :

,

On note [image] un nombre complexe associé à g(t) égal à :

  • est égal à la valeur efficace de g,
  • est égale à la phase totale de g (incluant le [image] ).

est appelée amplitude complexe[1] de s car elle caractérise le signal tandis que le terme [image] est commun à tous les signaux du circuit. On remarque que [image] dans le cas d'une fonction en sinus sinon [image] dans le cas d'une fonction en cosinus. est donc l'élément mathématique qui porte les informations de phase et d'amplitude de s(t) . Ce sont donc les amplitudes complexes qui sont recherchées pour décrire un circuit en régime sinusoidal. La notation sous forme exponentielle permet d'éviter l'utilisation de formules trigonométriques et elle est à mettre en liens avec l'Impédance (électricité) complexe.


Trigonométrie

Théorème de l'Huilier

Notations dans un triangle sphérique

En trigonométrie sphérique, le théorème de l'Huilier relie l'aire d'un triangle sphérique à la longueur de ses côtés ; il constitue ainsi une généralisation de la formule de Héron à une géométrie non euclidienne.

Dans un triangle sphérique (voir figure ci-contre) dessiné sur la sphère de rayon R, dont les côtés ont pour dimensions angulaires a, b et c, on note le demi-périmètre

.

Le théorème de l'Huilier énonce que la surface du triangle vaut

.

La formule de Héron est le cas limite de l'égalité ci-dessus quand la courbure de la sphère devient suffisamment petite et qu'on se rapproche de la géométrie euclidienne : en effet, lorsque a, b et c deviennent petits devant 1 — R est grand devant BC, AC et AB — l'approximation

peut être menée.

Voir également

  • trigonométrie
    • triangle
    • résolution d'un triangle
    • formule de Héron
    • trigonométrie sphérique
  • mathématiciens
    • Simon l'Huilier

Bibliographie

  • Théorème de l'Huilier sur le site anglais Math World.


Trigonométrie

 Théorème de Girard — Wikipédia

Théorème de Girard

Triangle sphérique

En mathématiques, le théorème de Girard est un théorème de géométrie sphérique démontré par Albert Girard :

Soient α, β, et γ les mesures en radians des angles d'un triangle sphérique sur une sphère de rayon R. L'aire de ce triangle sphérique est égale à (α + β + γ - π) × R².


Trigonométrie

Table de lignes trigonométriques exactes

Cercle trigonométrique et angles remarquables

Cette table de lignes trigonométriques exactes rassemble certaines valeurs des fonctions sinus, cosinus, tangente et cotangente sous forme d'expressions algébriques à l'aide de radicaux. Ces expressions sont obtenues à partir des valeurs remarquables pour les angles de 30° (dans le triangle équilatéral) et de 36° (dans le pentagone régulier) et à l'aide des identités trigonométriques de duplication et d'addition des angles.

Cette table est nécessairement incomplète, dans le sens où il est toujours possible de déduire une expression algébrique pour l'angle moitié. En outre, de telles expressions sont en théorie calculables pour les angles de tout polygone régulier dont le nombre de côtés est un nombre premier de Fermat, or ici seuls les deux premiers ont été exploités : 3 et 5.

Sommaire

  • 1 Tables de valeurs
  • 2 Applications
    • 2.1 Triangles de dérivation
  • 3 Construction
    • 3.1 Lignes élémentaires
    • 3.2 Division d'un angle en cinq
    • 3.3 Simplification des expressions
  • 4 Moyen mnémotechnique
  • 5 Voir aussi
  • 6 Liens externes

Tables de valeurs

Table de lignes trigonométriques exactes
angle | sinus | cosinus | tangente | cotangente
0° = 0 rad | 0 | 1 | 0 | (valeur interdite) | angle nul
15° = π/12 rad |  |  |  |  | dodécagone régulier
18° = π/10 rad |  |  |  |  | décagone régulier
22,5° = π/8 rad |  |  |  |  | octogone régulier
30° = π/6 rad |  |  |  |  | hexagone régulier
36° = π/5 rad |  |  |  |  | pentagone régulier
45° = π/4 rad |  |  | 1 | 1 | carré

Par soustraction, on obtient une expression pour les lignes trigonométriques d'un angle de 3°, c'est-à-dire π/60 rad, puis de tous ses multiples.

Expression des lignes trigonométriques pour les premiers multiples de 3°
3° (polygone régulier à 60 côtés)
6° (polygone régulier à 30 côtés)
9° (polygone régulier à 20 côtés)
12° (polygone régulier à 15 côtés)
15° (dodécagone régulier)
18° (décagone régulier)
21°
24°
27°
30° (hexagone régulier)
33°
36° (pentagone régulier)
39°
42°
45° (carré)

Il n'existe pas d'expression algébrique des lignes trigonométriques à l'aide de radicaux réels pour l'angle de 1°, mais il en existe une formulée à l'aide de racines cubiques de nombres complexes.

Article détaillé : trisection de l'angle.

Applications

Ces constantes peuvent être utilisées pour exprimer le volume du dodécaèdre régulier en fonction de son arête a : .

Triangles de dérivation

Polygone régulier (à N côtés) et son triangle droit fondamental, d'angle au centre 180/N°

La dérivation des constantes de sinus, cosinus et tangente sous formes radiales est basée sur la constructibilité des triangles droits.

Ici se trouvent des triangles droits faits à partir de sections symétriques de polygones réguliers qui sont utilisés pour calculer les rapports trigonométriques fondamentaux. Chaque triangle droit représente trois points dans un polygone régulier : un sommet, un centre d'arête contenant ce sommet et le centre du polygone. Un N-gone peut être divisé en 2N triangles droits avec des angles de [image] degrés, pour N = 3, 4, 5, ...

Construction

Lignes élémentaires

Les lignes trigonométriques pour les angles de 0°, 90°, 45°, 30° et 60° peuvent être calculés dans le cercle trigonométrique à l'aide du théorème de Pythagore.

Division d'un angle en cinq

Les formules [image] et [image] permettent de résoudre les équations [image] ou [image] en se ramenant à l'équation [image]. Cette dernière équation a pour solution évidente 0 et en posant le changement de variable Y = y^2, se réduit à une équation quadratique 16Y^2 - 20 Y + 5 = 0.

Pour résoudre [image] ou [image], il suffit de résoudre de manière analogue l'équation 16 y^5 - 20 y^3 + 5y - 1 = 0 qui se factorise sous la forme (y - 1)(4y^2 + 2y - 1)^2 = 0.

Simplification des expressions

Si le dénominateur est une racine carrée, multiplier le numérateur et le dénominateur par ce radical.

Si le dénominateur est la somme ou la différence de deux termes, multiplier le numérateur et le dénominateur par le conjugué du dénominateur. Le conjugué est identique, excepté le signe entre les termes qui est changé.

Quelquefois, séparer la fraction en somme de deux fractions, puis les simplifier séparément peut aider.

S'il existe un terme compliqué, avec seulement une sorte de radical dans un terme, ce plan peut aider. Élever au carré le terme, combiner les termes qui se ressemblent et prendre la racine carrée. Ceci peut enlever un gros radical avec un radical plus petit à l'intérieur, mais il est souvent meilleur que l'original.

Article détaillé : radical imbriqué.

En général, les radicaux imbriqués ne peuvent pas être réduits.

Mais si pour [image],

est rationnel,

et pour les deux [image] et [image] sont rationnels,

avec le choix approprié pour les quatre signes [image],

Alors

Exemple

Moyen mnémotechnique

On peut se restituer une partie de la table on considérant la suite « racine de n sur deux » :

n | Angle | sin
0 | 0 |
1 | 30°, π/6 rad |
2 | 45°, π/4 rad |
3 | 60°, π/3 rad |
4 | 90°, π/2 rad |

La valeur du cosinus est obtenue en lisant la table à l'envers.

Voir aussi

  • Fonction trigonométrique
  • Identité trigonométrique
  • Polygone constructible
  • Polynôme minimal des valeurs spéciales trigonométriques

Liens externes

  • (en) Eric W. Weisstein, « Constructible Polygon », MathWorld
  • (en) Regular Polygon, sur mathforum.org
  • (en) Naming Polygons and Polyhedra, sur mathforum.org
  • Portail de la géométrie Portail de la géométrie
  • Portail de l’algèbre Portail de l’algèbre
Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Table_de_lignes_trigonométriques_exactes&oldid=111978452 ».
Catégories :
  • Trigonométrie
  • Algèbre
  • Formulaire de mathématiques


Sommaire

BONJOUR
Musique "Invention BWV988" J.S. BACH 1685-1750

Tutoriel et Help

Borland BC555

Nous veillons aux respects des droits d'auteur : si par erreur un contenu protégé est disponible sans indication sur ce site, merci de contacter l'administrateur, il sera retiré ou mis à jour dans les plus brefs délais.