Sommaire

BONJOUR
Musique "Invention BWV784" J.S. BACH 1685-1750

Tutoriel et Help

Style & CSS


Accueil

Accueil CHM


Accueil

La page vide

Normal, dit comme ça,
vous ne risquez pas de comprendre.


Vu dans ... http://gilles.dubois10.free.fr/analyse_reelle/derivrolle.html

Le résultat qui suit a été publié initialement en 1690 par le mathématicien français Michel Rolle.

Soit f une fonction numérique définie et continue sur l'intervalle compact [a,b] on suppose en outre que f est dérivable en tout point de ]a,b[.
Dans ces conditions, si f(a)=f(b) il existe au moins un point x0∈]a,b[ tel que f'(x0)=0.
La preuve est immédiate:

Soit f est constante sur [a,b] auquel cas f'(x)=0 ∀x∈]a,b[.
Soit f prend des valeurs > f(a), dans ce cas f admet sur [a,b] un maximum (absolu) ( et ce maximum ne peut être f(a), il est donc atteint en un point x0∈]a,b[.
Soit f prend des valeurs <f(a), dans ce cas f admet sur [a,b] un minimum (absolu) ( et ce minimum ne peut être f(a), il est donc atteint en un point x0∈]a,b[.

De sorte qu'il suffit d'appliquer la condition nécessaire pour un extremum local.
Voici une image vous permettant de visualiser le théorème de Rolle.
Le théorème s'applique aux intervalles [a,b] et [b,c].
Constater qu'à chaque fois il y a (au moins) une annulation de la dérivée à l'intérieur de chaque intervalle.


Vu dans ... https://ljk.imag.fr/membres/Bernard.Ycart/mel/dc/node6.html

Section : Cours
Avant : Dérivées successives
Après : Fonctions convexes

Théorème des accroissements finis

En un point où la dérivée d'une fonction s'annule, les accroissements de la fonction sont négligeables devant les accroissements de la variable. Souvent, c'est un point où les variations de la fonction changent de sens, donc un maximum ou un minimum.

Définition 6 Soit $ f$ une fonction de [image] dans [image] , définie sur un intervalle ouvert $ I$ . Soit $ a$ un point de $ I$ . On dit que $ a$ est un
maximum local de $ f$ si

minimum local de $ f$ si

Insistons sur l'adjectif local . Il suffit que la valeur de $ f$ en $ a$ soit la plus grande des valeurs prises par $ f$ sur un petit intervalle autour de $ a$ pour que $ f$ soit un maximum local. Cette valeur n'est pas nécessairement la plus grande prise par $ f$ sur tout son domaine de définition (voir le graphe de la figure 3).

Théorème 4 Soit $ f$ une fonction de [image] dans [image] , définie sur un intervalle ouvert $ I$ . Si $ f$ présente un extremum (maximum ou minimum) local en un point $ a$ de $ I$ , et si $ f$ est dérivable en $ a$ , alors [image] .

Démonstration : Si $ a$ est un minimum local de $ f$ , alors c'est un maximum local de $ -f$ : quitte à remplacer $ f$ par $ -f$ , nous pouvons supposer que $ a$ est un maximum local.

Donc pour tout $ x$ dans l'intervalle [image] ,

donc

Pour tout $ x$ dans l'intervalle [image] ,

donc

D'où le résultat. Reprenons l'exemple de la figure 2 : . La dérivée est :

Elle s'annule en [image] , et $ f$ admet effectivement un maximum en ce point. Mais savoir que [image] permet seulement d'affirmer que la tangente en ce point est horizontale. Il se pourrait que la dérivée en un point soit nulle sans que la fonction admette un extremum en ce point : par exemple la fonction [image] en 0 . D'autre part, une fonction peut présenter un extremum en $ a$ , sans être dérivable en ce point (par exemple la fonction [image] en 0 ).

Voici un autre exemple (figure 3). Soit $ f$ la fonction définie par :

Figure:Graphe de la fonction [image] .
Le taux d'accroissement de $ f$ en 0 est [image] , qui tend vers 0 . La dérivée de $ f$ en 0 est donc nulle. Pourtant, tout intervalle contenant 0 , contient aussi des valeurs positives, et des valeurs négatives (et aussi une infinité d'extrema locaux). Nous allons appliquer le théorème 4, pour démontrer le théorème de Rolle .

Théorème 5 Soient $ a$ et $ b$ deux réels tels que $ a<b$ . Soit $ f$ une fonction de $ [a,b]$ dans [image] , continue sur $ [a,b]$ , dérivable sur $ ]a,b[ $ . Si [image] , alors la dérivée de $ f$ s'annule sur $ ]a,b[ $ .

Démonstration : Une application continue sur intervalle fermé borné, atteint sa borne inférieure $ m$ et sa borne supérieure $ M$ : il existe [image] tels que pour tout [image] ,

Si [image] , l'application $ f$ est constante sur $ [a,b]$ , et sa dérivée est identiquement nulle. Si $ m<M$ , alors l'une au moins de ces deux valeurs est différente de $ f(a)$ (et donc de $ f(b)$ ). Si $ m<f(a)$ , alors [image] est un minimum pour $ f$ , et donc [image] , d'après le théorème précédent. Si $ M>f(a)$ , alors [image] est un maximum pour $ f$ , et donc [image] .
Figure 4:Théorème de Rolle.
Figure 5:Théorème des accroissements finis.
On en déduit le résultat le plus important de cette section, le théorème des accroissements finis .

Théorème 6 Soient $ a$ et $ b$ deux réels tels que $ a<b$ . Soit $ f$ une fonction de $ [a,b]$ dans [image] , continue sur $ [a,b]$ , dérivable sur $ ]a,b[ $ .

Démonstration : Considérons la fonction $ g$ , qui à [image] associe

La fonction $ g$ est continue sur $ [a,b]$ , dérivable sur $ ]a,b[ $ . De plus, elle prend la même valeur en $ a$ et $ b$ :

D'après le théorème de Rolle, la dérivée de $ g$ s'annule en un point $ c$ de $ ]a,b[ $ .

D'où le résultat. Graphiquement, le théorème des accroissements finis dit que la courbe représentative de $ f$ sur $ [a,b]$ possède au moins une tangente parallèle à la sécante passant par $ (a,f(a))$ et $ (b,f(b))$ (figure 5). Si $ f(x)$ représente la position d'un mobile à l'instant $ x$ , le théorème des accroissements finis dit que en au moins un point, la vitesse instantanée doit être égale à la vitesse moyenne sur l'intervalle.

Le plus souvent en pratique, on ne sait rien de la valeur de $ c$ qui est telle que la tangente en $ c$ est parallèle à la sécante. Mais de son existence découlent des inégalités permettant d'obtenir des renseignements précis sur les accroissements de la fonction. Le théorème des accroissements finis permet aussi d'établir le lien entre le sens de variation de $ f$ et le signe de sa dérivée.

Proposition 6 Soit $ I$ un intervalle ouvert non vide, et $ f$ une fonction dérivable sur $ I$ . La fonction $ f$ est :
croissante sur $ I$ si et seulement si $ f'$ est positive ou nulle sur $ I$ ,
décroissante sur $ I$ si et seulement si $ f'$ est négative ou nulle sur $ I$ .

Démonstration : La fonction $ f$ est croissante si et seulement si $ -f$ est décroissante. Il suffit donc de démontrer le premier point. Si $ f$ est croissante, alors ses taux d'accroissement sont tous positifs ou nuls :

Comme la dérivée en chaque point est limite de taux d'accroissement, elle est aussi positive ou nulle.

Réciproquement, soient $ x$ et $ y$ deux points de $ I$ tels que $ x<y$ . Appliquons le théorème des accroissements finis à $ f$ sur l'intervalle $ [x,y]$ : il existe [image] tel que :

Donc [image] . Ce résultat n'est valable que sur un intervalle : la fonction [image] a une dérivée négative sur [image] , pourtant elle n'est pas décroissante. D'autre part, si la dérivée est strictement positive, alors la fonction est strictement croissante. La réciproque est fausse. La fonction peut être strictement croissante même si la dérivée s'annule en certains points (par exemple [image] ). Comme autre application du théorème des accroissements finis, il est possible d'obtenir la dérivée en un point comme prolongement par continuité de la dérivée calculée sur un intervalle.

Proposition 7 Soient $ a$ et $ b$ deux réels tels que $ a<b$ . Soit $ f$ une fonction de [image] dans [image] , continue sur l'intervalle $ [a,b]$ , dérivable sur $ ]a,b[ $ . Si $ f'$ admet une limite finie en $ a$ , alors $ f$ est dérivable à droite en $ a$ et :

Démonstration : Soit [image] . Appliquons le théorème des accroissements finis sur l'intervalle $ [a,x]$ . Il existe [image] tel que

Soit $ l$ la limite à droite de $ f'$ en $ a$ . Pour tout [image] , il existe [image] tel que

Donc pour [image] ,

D'où le résultat. Ce résultat n'est qu'une condition suffisante. Il peut se faire que la dérivée existe sans qu'elle soit continue. Par exemple la fonction [image] a une dérivée nulle en 0 (figure 3). Pourtant sa dérivée en $ x$ , [image] , n'a pas de limite en 0 .


Théorème des accroissements finis — Wikipédia

Vu dans ... https://fr.wikipedia.org/wiki/Th%C3%A9or%C3%A8me_des_accroissements_finis

Théorème des accroissements finis

Il existe un point où la pente de la tangente est égale à la pente de la corde.

Fonction d'une variable réelle à valeurs réelles

Énoncé

Pour toute fonction réelle d'une variable réelle f : [a, b] → ℝ ( a et b réels tels que a < b ), supposée continue sur l'intervalle fermé [a, b] et dérivable sur l'intervalle ouvert ]a, b[ , il existe un réel c dans ]a, b[ vérifiant :

f(b) - f(a) / b - a = f'(c)

Graphiquement, le théorème des accroissements finis indique que, pour toute droite sécante en deux points à une courbe différentiable, il existe une tangente parallèle à la sécante.

On peut illustrer ainsi le théorème : « Si un véhicule parcourt une distance à la vitesse moyenne de 60 km/h, alors son compteur (censé indiquer avec une précision infinie la vitesse instantanée) a indiqué au moins une fois la vitesse précise de 60 km/h. »

La solution c n'est pas unique en général. Plus précisément, pour une fonction dérivable sur un intervalle I , la solution c est unique pour tous a < b dans I si et seulement si f est strictement convexe ou strictement concave [ 2 ] .

Deux conséquences directes du théorème des accroissements finis sont :

  • le lien entre monotonie et signe de la dérivée ;
  • le théorème « limite de la dérivée » (si une fonction f, continue en a, est dérivable sauf peut-être en a, mais si sa dérivée a une limite finie au point a, alors f est en fait de classe C1 en a).

Théorème des accroissements finis généralisé

Ce théorème s'applique dans le cas de deux fonctions continues sur [a,b] et dérivables sur ]a, b[ . Il assure [ 1 ] qu'il existe un réel c de l'intervalle ]a, b[ tel que

(f(b)-f(a))g'(c)=(g(b)-g(a))f'(c)
Il existe un point de l' arc paramétré où la tangente est parallèle à la corde.

Géométriquement, il signifie que toute courbe représentative d'une fonction différentiable de ℝ dans ℝ2, t ↦ (f(t), g(t)) , possède une tangente parallèle à l'une quelconque de ses cordes.

Dans le cas où g ' ne s'annule pas sur ]a, b[ , l'égalité peut s'écrire [ 1 ] :

{ {f(b)-f(a)}{g(b)-g(a)}}= {f'(c)}{g'(c)}}.}

Sous cette forme, le théorème est appelé théorème de la moyenne de Cauchy. Il peut être utilisé pour démontrer la règle de L'Hôpital.

Remarque
Si a = –∞ ou b = +∞ et si f et g sont dérivables sur ]a, b[ et possèdent en a et b des limites finies, notées f(a), f(b), g(a) et g(b), on obtient par la même méthode (en remplaçant le théorème de Rolle par une généralisation adaptée) une conclusion identique.

Inégalité des accroissements finis

Soit f : [a, b] → ℝ (avec a et b réels tels que a < b). Si :

  • f est continue sur l'intervalle fermé [a, b] ;
  • f est dérivable sur l'intervalle ouvert ]a, b[ ;
  • M est un réel tel que, pour tout élément x de ]a, b[, |f'(x)| ≤ M ;

alors { \left|{{f(b)-f(a)} \over {b-a}}\right|\leq M}

Il existe de même une « inégalité des accroissements finis généralisée » :

Soient f et g : [a, b] → ℝ continues sur [a,b] et dérivables sur ]a, b[, avec g' de signe constant. Si J est un intervalle de ℝ tel que, pour tout x de ]a, b[, f'(x) ∈ g'(x)J alors, f(b) – f(a) ∈ (g(b) – g(a))J.

On peut même démontrer directement, sans le théorème des accroissements finis, que cette conclusion reste vraie si la dérivabilité de f et g (et les hypothèses sur f'(x) et g'(x)) ne sont vérifiées que sur le complémentaire d'un ensemble dénombrable [ 4 ] , [ 5 ] , [ 6 ] .

Théorème des accroissements finis et intégration

Article détaillé : Théorème de la moyenne.
  • Une version intégrale du TAF est le théorème de la moyenne :
    Pour toute fonction u à valeurs réelles, continue sur un segment [a, b] avec a < b, il existe un réel c de ]a, b[ tel que

    { u(c)= {1}{b-a}}\int _{a}^{b}u(x)~\mathrm {d} x.}

  • L'analogue intégral du théorème des accroissements finis généralisé est un théorème de la moyenne généralisé :
    Pour toutes fonctions u et v à valeurs réelles, continues sur un segment [a, b] avec a < b, v gardant un signe constant sur [a, b], il existe un réel c de ]a, b[ tel que
    { u(c)\int _{a}^{b}v(x)~\mathrm {d} x=\int _{a}^{b}u(x)v(x)~\mathrm {d} x.}

Réciproque partielle

Pour la fonction sinus, la pente maximale des tangentes n'est pas la pente d'une corde.
Lorsque la valeur f'(c) = λ est atteinte en des points arbitrairement proches de c (ici : c = λ = 0), il arrive qu'aucune des cordes de pente λ ne traverse l'axe x = c.

Puisque le théorème des accroissements finis garantit que (pour une fonction f { f} f vérifiant les hypothèses) tout taux d'accroissement est un nombre dérivé, une question naturelle est : réciproquement, tout nombre dérivé est-il un taux d'accroissement ?

La réponse est : non. Par exemple (cf. figure ci-contre), pour la fonction sin : R → R { \sin :\mathbb {R} \to \mathbb {R} } [image] , le nombre dérivé sin ′ ⁡ ( 0 ) = cos ⁡ ( 0 ) = 1 { \sin '\left(0\right)=\cos \left(0\right)=1} [image] n'est pas un taux d'accroissement. Mais la pathologie de ce cas ( 1 { 1} 1 est ici la valeur maximum de f ′ { f'} f' ) est la seule obstruction.

Le théorème des accroissements finis possède en effet la réciproque partielle suivante (réciproque « faible [ 7 ] ») :

Pour toute fonction f { f} f dérivable sur un intervalle, toute valeur non extrémale de f ′ { f'} f' est un taux d'accroissement de f { f} f [ 8 ] .

Autrement dit : toute tangente au graphe de f { f} f dont la pente f ′ ( c ) { f'(c)} [image] n'est ni maximum, ni minimum, possède une parallèle sécante au graphe en deux points. Le TAF permet en outre d'affirmer [ 8 ] que si la valeur f ′ ( c ) { f'(c)} [image] n'est atteinte qu'au point c { c} c , alors les deux extrémités de la corde sont de part et d'autre du point de tangence [ 7 ] (réciproque « forte »).

La « réciproque faible » ci-dessus se déduit du lemme suivant, qui (joint au TAF lui-même) permet aussi de démontrer que toute fonction dérivée vérifie la propriété des valeurs intermédiaires :

Pour toute fonction f { f} f dérivable sur un intervalle, tout réel strictement compris entre deux nombres dérivés de f { f} f est un taux d'accroissement de f { f} f [ 8 ] .

La « réciproque forte » se localise facilement : pour toute fonction f { f} f dérivable sur un intervalle, si λ = f ′ ( c ) { \lambda =f'(c)} [image] n'est pas un extremum local de f ′ { f'} f' et si, au voisinage de c { c} c , la valeur λ { \lambda } [image] n'est atteinte par f ′ { f'} f' qu'en c { c} c , alors λ { \lambda } [image] est encore un taux d'accroissement de f { f} f entre deux points x { x} x et y { y} y tels que x < c < y { x<c<y} [image] [ 7 ] . (Pour la nécessité de la seconde hypothèse, cf. figure ci-contre.)

Pour le théorème des accroissements finis généralisés, on démontre de même des réciproques analogues [ 9 ] .

Fonction d'une variable vectorielle à valeurs réelles

Soient Ω { \Omega } [image] un ouvert d'un espace vectoriel normé E (par exemple E = ℝn, ce qui inclut le cas E = ℂ identifié à ℝ2), x { x} x un point de Ω { \Omega } [image] et h { h} h un vecteur non nul de E tel que [ x , x + h ] ⊂ Ω { [x,x+h]\subset \Omega } [image] , et f : Ω → R { f:\Omega \to \mathbb {R} } [image] une fonction continue sur [ x , x + h ] { [x,x+h]} [image] et différentiable suivant le vecteur h sur ] x , x + h [ { ]x,x+h[} [image] . Alors il existe ξ ∈ ] x , x + h [ { \xi \in ]x,x+h[} [image] tel que

f ( x + h ) − f ( x ) = D h f ( ξ ) , { f(x+h)-f(x)=D_{h}f(\xi ),}

par simple application du théorème des accroissements finis à la fonction composée g : t ∈ [ 0 , 1 ] ↦ f ( x + t h ) ∈ R . { g:t\in [0,1]\mapsto f(x+th)\in \mathbb {R} .}

Fonction à valeurs vectorielles

Pour une telle fonction, il n'existe pas d'analogue du théorème (avec égalité) des accroissements finis, ni même de son cas particulier qu'est le théorème de Rolle (cf. § Remarques de l'article sur ce théorème).

À défaut, lorsque l'espace d'arrivée de f est ℝn, on peut appliquer le théorème des accroissements finis à chacune des composantes réelles fk de la fonction f = (f1, … , fn), mais les ck que l'on construit ainsi (ou les ξk comme ci-dessus si la variable est vectorielle) n'ont aucune raison d'être égaux.

On peut cependant établir une inégalité des accroissements finis dans ce cadre.

Inégalité des accroissements finis

Soient a < b deux réels, E un espace localement convexe et deux fonctions

f : [ a , b ] → E et g : [ a , b ] → R { f:[a,b]\to E\quad {\text{et}}\quad g:[a,b]\to \mathbb {R} }

supposées continues sur [a, b] et dérivables sur ]a, b[ .

Si g' est de signe constant alors, pour tout sous- ensemble convexe fermé A de E tel que

∀ t ∈ ] a , b [ f ′ ( t ) ∈ g ′ ( t ) A , { \forall t\in ]a,b[\quad f'(t)\in g'(t)A,}

on a :

f ( b ) − f ( a ) ∈ ( g ( b ) − g ( a ) ) A . { f(b)-f(a)\in (g(b)-g(a))A.}

Lorsque g' est non seulement de signe constant mais à valeurs non nulles, la conclusion se reformule en :

f ( b ) − f ( a ) g ( b ) − g ( a ) ∈ Co ¯ ( { f ′ ( t ) g ′ ( t ) , t ∈ ] a , b [ } ) , { {f(b)-f(a)}{g(b)-g(a)}}\in {\overline {\text{Co}}}\left(\left\{ {f'(t)}{g'(t)}},~t\in ]a,b[\right\}\right),}

où « Co » désigne l' enveloppe convexe fermée.

En particulier si g (t) = t, on obtient [ 10 ] : f(b) – f(a) ∈ (b – a) Co ({f'(t), t ∈ [a, b]}).

Remarques.

  • Ce théorème est d'autant plus surprenant qu’il n'existe pas de théorème de Rolle vectoriel, ou, ce qui revient au même, il n’y a pas d'égalité des accroissements finis mais seulement une inégalité, comme en témoigne la fonction définie par f(t) = eit qui satisfait f(0) = f(2π) alors que sa dérivée ne s'annule pas sur [0, 2π] .
  • Il en découle qu’une fonction dérivable dont la dérivée est nulle ne peut être que constante.
  • Il se déduit directement de son homologue pour les fonctions à valeurs réelles, en utilisant le théorème de Hahn-Banach [ 11 ] ou sa version géométrique qu'est le théorème d'Eidelheit [ 12 ] .
  • Sa conclusion reste valide, avec une démonstration identique, sous des hypothèses plus faibles :
    • il suffit que f'(t) et g'(t) existent (et vérifient les propriétés indiquées) pour t appartenant au complémentaire d'un ensemble dénombrable [ 11 ] ;
    • pour f, la continuité et la différentiabilité peuvent être prises au sens faible [ 12 ] .

Corollaire

On en déduit immédiatement le corollaire suivant (qui se démontre aussi directement [ 13 ] , [ 14 ] , [ 15 ] ) :

Soient a < b deux réels, E un espace vectoriel normé et deux fonctions

f : [ a , b ] → E et g : [ a , b ] → R { f:\left[a,b\right]\to E\quad {\text{et}}\quad g:[a,b]\to \mathbb {R} }

supposées continues sur [a, b] et dérivables sur ]a, b[ .

Si

∀ t ∈ ] a , b [ ‖ f ′ ( t ) ‖ ≤ g ′ ( t ) { \forall t\in \left]a,b\right[\quad \|f'(t)\|\leq g'(t)}

alors

‖ f ( b ) − f ( a ) ‖ ≤ g ( b ) − g ( a ) . { \|f(b)-f(a)\|\leq g(b)-g(a).}

En particulier si, pour une certaine constante M (nécessairement positive ou nulle), on a

∀ t ∈ ] a , b [ ‖ f ′ ( t ) ‖ ≤ M { \forall t\in \left]a,b\right[\quad \|f'(t)\|\leq M}

alors

‖ f ( b ) − f ( a ) ‖ ≤ M ( b − a ) . { \|f(b)-f(a)\|\leq M(b-a).}

Fonction d'une variable vectorielle à valeurs vectorielles

Le corollaire précédent permet de majorer l'accroissement d'une fonction différentiable si l'on connaît une majoration de sa différentielle. Plus précisément [ 16 ] :

Soient E et F deux espaces vectoriels normés réels, U un ouvert de E et f : U → F une application différentiable. Pour tout segment [a,b] inclus dans U, on a :

‖ f ( b ) − f ( a ) ‖ F ≤ ( sup x ∈ [ a , b ] ‖ f ′ ( x ) ‖ ) ‖ b − a ‖ E { \|f(b)-f(a)\|_{F}\leq \left(\sup _{x\in [a,b]}\|f\,{'}(x)\|\right)\|b-a\|_{E}}

où, pour tout point x de U, ║f ' (x)║ est la norme d'opérateur de la différentielle de f au point x .

Ce corollaire est une conséquence immédiate du précédent, appliqué à la fonction de la variable réelle [ 0 , 1 ] → F , t ↦ f [ ( 1 − t ) a + t b ] . { [0,1]\to F,\,t\mapsto f\left[(1-t)a+tb\right].}

Il n'a bien sûr d'intérêt que si le sup qu'il fait intervenir est fini, c'est-à-dire si la différentielle de f est bornée sur [a, b] . Cette condition est assurée en particulier si f est de classe C1 sur U.

Il se généralise à tout ouvert U connexe et à toute fonction dont la différentielle est bornée par k. Si dU(a, b) est la borne inférieure des longueurs des lignes polygonales joignant a à b et incluses dans U, on a

‖ f ( b ) − f ( a ) ‖ F ≤ k d U ( a , b ) . { \|f(b)-f(a)\|_{F}\leq kd_{U}(a,b).}

Application en cinématique

En cinématique, pour déterminer l'orientation de la tangente, on utilise la corde.
Il s'écoule 0,04 s entre le relevé de deux points.

En cinématique, le vecteur vitesse d'un point d'un mobile est tangent à la trajectoire de ce point. À partir d'un enregistrement du mouvement (succession de positions relevées à intervalle de temps constant), on peut déterminer la direction du vecteur vitesse au point i en considérant la corde (Mi-1Mi+1).

En effet, sur un petit intervalle, la pente de la tangente varie peu, donc on estime que la valeur en Mi vérifie le théorème des accroissements finis.


Colin Maclaurin

Vu dans ... http://serge.mehl.free.fr/chrono/Maclaurin.html

ChronoMath, une chronologie des MATHÉMATIQUES
à l'usage des professeurs de mathématiques, des étudiants et des élèves des lycées & collèges

MACLAURIN (ou Mac-Laurin) Colin, écossais, 1698-1746

Brillant élève de Simson à l'université de Glasgow dont il sera diplômé à 17 ans. Il obtint à 19 ans une chaire d'enseignement des mathématiques à l'université d'Aberdeen. Ami de Newton , il fut un fervent défenseur de sa méthode des fluxions (calcul différentiel). Parrainé par ce dernier, il succède à Grégory à l'université d'Édimbourg (1725). Il conservera ce poste jusqu'à sa mort. Son ancien élève Stewart lui succédera.

Grand géomètre, très apprécié par Lagrange, il étudia toutes sortes de courbes algébriques d'ordre élevé (Geometrica organica, De linearum geometricorum proprietatibus, 1720), Maclaurin est à l'origine des développements en série entière des fonctions numériques par la méthode des coefficients indéterminés (A complet system of the fluxions, 1742), prolongement des travaux de Newton et de Taylor .

Grâce au nouvel outil différentiel, on lui doit la résolution de nombreux de problèmes de mathématiques appliquées, notamment dans le domaine de la mécanique en corrélation avec les travaux de son ami Newton (attraction de points matériels.

Formule de Maclaurin (1742) :

Ce développement n'est pas une simple application de la formule de Taylor en 0. Maclaurin l'obtint par un calcul rigoureux :

Si f est de classe Cn dans un voisinage V de zéro et si f admet une dérivée d'ordre n+1 sur V, alors, il existe un réel cx de V tel que :

➔ f(n) désigne ici la fonction dérivée n-ème de f dont la définition par récurrence est :

f(o) = f et f(n) = [f(n-1)]'. C'est dire que f(1) = f ', f(2) = f '', etc. » d'Alembert

Si nous notons rn le dernier terme du second membre : une condition nécessaire et suffisante pour que la série de Maclaurin converge est que f soit indéfiniment dérivable sur V et que rn tende vers 0 pour tout x fixé dans V. On obtient ainsi un très grand nombre de développements limités au voisinage de zéro :

Exemple 1 : considérons la célèbre fonction exponentielle x → ex, identique à toutes ses dérivées. vu que e0 = 1, on a :

ex = 1 + x + x2/2! + x3/3! + ... + xn/n! + ...

Exemple 2 : considérons la fonction sinus f(x) = sin x. on a f(o) = o, puis

  • (sin x)' = cos x , (sin x)" = - sin x , (sin x)''' = - cos x , (sin x)'''' = (sin x)(4) = sin (x)

D'une façon générale (sin x)(2n) fournit un sinus, nul au point zéro. Le développement ne contiendra donc que les (sin x)(2n+1)(o) = (-1)n et par suite :

sin x = x - x3/3!+ x5/5! - x7/7! + . ..

Ce développement fut obtenu auparavant par Leibniz.

Formule de Taylor et expression des restes du développement d'ordre n : »

Formule de Maclaurin pour les polynômes :

Si P est un polynôme de degré n, toutes ses dérivées d'ordre supérieur à n sont nulles. On a alors pour tout réel x :

P(x) = P(o) + xP'(o) + x2P''(o)/2! + ... + xkP(k)(o)/k! +...+ xnP(n)(o)/n!

Un calcul de e, base des logarithmes népériens : »

Formules d'Euler-Maclaurin :

On suppose f de classe C2 sur l'intervalle [a,b] : f est dérivable jusqu'à l'ordre 2 au moins et ses dérivées f ' et f " sont continues. Dans ces conditions :

➔ Ce résultat s'obtient très simplement au moyen de deux intégrations par parties successives de l'intégrale du second membre. En utilisant le second théorème de la moyenne (formule de Bonnet), on obtient une approximation de l'intégrale de f sur [a,b] qui n'est autre que la méthode des trapèzes avec une erreur ne pouvant excéder M(b - a)3/12 où M désigne le maximum de |f ''(x)| sur [a,b]. Il existe donc c dans [a,b] tel que :

Lorsque f est de classe C2n sur l'intervalle [a,b], on peut démontrer une seconde formule plus élaborée donnant une valeur approchée d'une intégrale et utilisant les nombres de Bernoulli :

On pose Δf(k) = f(k)(b) - f(k)(a), différence des dérivées k-èmes en b et a. Rappelons que les Bk sont nuls si k est impair autre que 1. Dans ces conditions, il existe c dans [a,b] tel que :

On pourra trouver la preuve de cette formule dans tout cours d'analyse niveau Math Spé. En particulier (certes non récent mais incontournable par sa clarté et la précision de la pensée) : Jean Bass, Cours de mathématiques, Tome 1, Éd. Dunod, Paris - 1969/71/78.

______ ☼ ______

E xemple : On a tracé ci-dessous la courbe d'équation : y = f(x) = x4 - 2x3 - 1

L'aire hachurée correspond à l'opposée de l'intégrale de f sur [0,2]. Exprimée en unités d'aires, la mesure de cette aire est exactement 3,6. La 1ère formule d'Euler-Maclaurin fournit une valeur "très" erronée et une erreur non moins élevée puisqu'elle correspond à la méthode des trapèzes avec un pas h = 2. Cette formule prend tout son sens lorsqu'on subdivise l'intervalle. On vérifiera qu'avec 100 points (h = 1/50), on obtient 3,5997...

La seconde formule d'Euler-Maclaurin appliquée à cette fonction conduit à (n max = 2) : -2 - 2 × (1/6) × 8 - (32/24) × (-1/30) × 24 = -3,6. C'est la bonne valeur. Mais pourquoi donc ? Parce qu'ici, notre dérivée 4ème est constante, égale à 24 pour tout x : le choix de c n'influe donc pas !

Travaux sur les courbes algébriques :

Maclaurin étudia également les courbes algébriques (détermination, intersections) et, par là, les systèmes d'équations qu'il résout par la méthode des déterminants (ce dernier terme et la théorie seront dus à Cauchy ) jusqu'à l'ordre 4.

Il énonce que deux telles courbes de degrés respectifs n et p doivent se couper en au plus np points. Ce qui ne fut pas sans soulever quelques difficultés et aspects contradictoires... Ces travaux seront repris par Cramer (1750) et Euler, indépendamment semble-t-il des travaux de Maclaurin et ce sera Plücker qui en donnera une explication définitive (1839) corroborant les résultats de Euler.

Pour en savoir un peu plus : » http://serge.mehl.free.fr/anx/paradox_cram.html


Développement limité de Mc Laurin

Vu dans ... http://www.jybaudot.fr/Analysesup/mclaurin.html

Le développement limité de Mc Laurin

DL(0) usuels et exemple

Un développement limité (DL) au voisinage de zéro porte le nom de Colin Mc Laurin. Vu sous cet angle, ce grand mathématicien écossais n’aurait rien fait d’autre que d’appliquer la formule de Taylor en un voisinage particulier, ce qui est évidemment faux. Toutefois, l’objet de ce site n’est pas de rendre justice en relatant les apports des uns et des autres aux mathématiques mais d’expliquer l’usage de quelques outils. En l’occurrence, voici quelques DL usuels au voisinage de 0 (on remarque vite que ces égalités deviennent ineptes si x s'éloigne de 0), ainsi qu’un petit exercice.

DL(0) usuels

Note : le DL(0) de ln x s’obtient facilement puisqu’il suffit remplacer les x de la dernière formule par des (x – 1).

Fonctions trigonométriques :

DL de fonctions trigonométriques

Fonctions trigonométriques réciproques :

DL fonctions trigo réciproques

Fonctions hyperboliques :

DL de fonctions hyperboliques

Fonctions hyperboliques réciproques :

DL fonctions hyperboliques réciproques

Rappel de la formule générale

DL de Mc Laurin

Exercice

Trouver de deux façons différentes un polynôme d’ordre 3 qui, au voisinage de 0, présente un comportement proche de la fonction suivante :

Première technique, avec les dérivées successives (application de la formule).

1- On sait que le sinus de 0 est égal à 0. Donc, f(0) = e0 = 1

2- La dérivée d’une exponentielle a pour forme u’eu. La dérivée de sin x est cos x. donc f’(x) = cos x esin x et f’(0) = 1 × 1 = 1

3- Quelle est la dérivée seconde ? La dérivée première se présentant sous une forme u × v, la dérivée seconde a pour structure u’v + v’u avec u = cos x (donc u’ = -sin x) et v = esin x (donc v’ = cos x esin x).

Donc, f’’(0) = 1

4- Terminons par la dérivée d’ordre 3. La tâche devient rude.

Le premier terme : (-sin x esin x)’ = -cos x esin x – sin x cos x esin x, donc , en 0, -1 – 0 = -1

Le second terme : (cos² x esin x)’. Sachant que la dérivée de cos² x est 2cos x × –sin x nous avons (2cos x × –sin x)esinx + cos³x esin x = 0 + 1 = 1.

Donc, f(3)(0) = -1 + 1 = 0

Conclusion : le DL3(0) de f(x) est :

Seconde technique, utilisant les composées de fonctions usuelles :

En appliquant la formule du DL de sin x (voir haut), on obtient, à l’ordre 3 :

DL du sinus

Incorporons ce résultat au DL de ex (voir encore plus haut) :

Les calculs se poursuivent par un travail de nettoyage qui aboutit à l’expression développée d’une fonction polynomiale de degré 9 dont je vous fais grâce. Mais si l’on ne retient que les termes de degré inférieur ou égal à 3, on retrouve bien le DL3(0) auquel nous sommes parvenu avec les dérivées successives.


Dérivées - Différentielles-Formule de Taylor. Formule de Mac-Laurin. Développements limités usuels

Formule de Taylor. Formule de Mac-Laurin. Développements limités usuels

Définition

Une fonction [image] définie et continue au voisinage de [image] admet un développement limité d'ordre [image] au voisinage de [image] s'il existe un polynôme [image] de degré [image] au plus tel que :

Formule de Taylor

Si la fonction [image] est définie, continue et dérivable jusqu'à l'ordre [image] sur un intervalle [image] contenant [image] alors le développement limité de [image] à l'ordre [image] au voisinage de [image] s'écrit :

Exemple

Déterminer le développement limité du polynôme [image] suivant les puissances de

Par définition

or

et

et

d'où

Formule de Mac Laurin

Quand le développement de Taylor s'effectue au voisinage de [image] nous obtenons la formule de Mac Laurin :

Exemple

Déterminer le développement limité de Mac Laurin de la fonction

d'où

Tableau des DL usuels de Mac Laurin


Résumé de cours : séries entières

Vu dans ... http://www.bibmath.net/ressources/index.php?action=affiche&quoi=mathspe/cours/serieent.html

Développements en séries entières usuels

e x cos x sin x cosh x sinh x 1 1 − x ln ( 1 + x ) arctan ( x ) ( 1 + x ) α = = = = = = = = = ∑ n ≥ 0 x n n ! , R = + ∞ ∑ n ≥ 0 ( − 1 ) n x 2 n ( 2 n ) ! , R = + ∞ ∑ n ≥ 0 ( − 1 ) n x 2 n + 1 ( 2 n + 1 ) ! , R = + ∞ ∑ n ≥ 0 x 2 n ( 2 n ) ! , R = + ∞ ∑ n ≥ 0 x 2 n + 1 ( 2 n + 1 ) ! , R = + ∞ ∑ n ≥ 0 x n , R = 1 ∑ n ≥ 1 ( − 1 ) n + 1 n x n , R = 1 ∑ n ≥ 0 ( − 1 ) n 2 n + 1 x 2 n + 1 , R = 1 ∑ n ≥ 0 α ( α − 1 ) ⋯ ( α − n + 1 ) n ! x n , R = 1


Vu dans ... http://www.cosmovisions.com/Taylor.htm

Brook Taylor

Brook Taylor est un mathématicien, né à Edmonton ( village du comté de Middlesex, à huit milles de Londres) le 18 août 1685, mort à Londres le 29 décembre 1731. Son père, John Taylor, écuyer, était fils d'un puritain rigoureux, Nathaniel Taylor, l'un de ceux que Cromwell, par un acte du 14 juin 1653, déclara propres à représenter le comté de Bedford au parlement. John Taylor conservait à un haut degré la sévérité de doctrine que ses ancêtres lui avaient transmise; mais cette sévérité, quoique maintenue encore par l'esprit du temps, se trouva sensiblement atténuée chez Brook. De là une source fâcheuse de mésintelligence entre le père et le fils. Heureusement le premier était très sensible aux jouissances de la musique; il accueillait avec beaucoup de bienveillance et recevait très généreusement les hommes distingués par leur habileté dans cet art.

Le jeune Brook, instruit par leurs leçons, et animé du désir d'obtenir l'indulgence paternelle pour le relâchement de ses principes, devint de très bonne heure un excellent musicien. Un tableau de famille le représente, à treize ans, au milieu de ses frères et soeurs, recevant des mains des deux aînées une couronne ornée des emblèmes de l'harmonie. La date de cette scène correspond à l'an 1698 : le célèbre Haendel, qui a donné son premier opéra à Hambourg, en 1703, et qui n'est venu se fixer en Angleterre, qu'en 1710, n'était pas encore connu; Brook Taylor n'avait pu s'exercer que sur les anciennes compositions anglaises et écossaises.
-

Taylor.
Brook Taylor (1685-1731).

La musique ne fut pas le seul des beaux-arts qu'il cultiva avec succès : on conserve de lui des dessins et des tableaux dont le mérite est vanté, et qui ne seraient pas déplacés parmi les bons ouvrages des artistes de profession. Il dessinait la figure avec une pureté de trait et une grâce de pinceau remarquables; mais il avait un goût de préférence pour le paysage. Ses tableaux originaux dans ce genre, assez ordinairement peints en détrempe, rivalisent en vigueur et en beauté de coloris avec les tableaux à l'huile, et offrent surtout des modèles intéressants de l'application des règles de perspectives linéaire et aérienne.

Le même homme qui possédait à un degré si éminent les talent de la musique et de la peinture, a, comme on va le voir, traité des questions de haute théorie tenant à ces deux arts, avec une profondeur et une supériorité qui le placent dans les premiers rangs des mathématiciens de son temps. Il est naturel de conclure de ces faits, que l'éducation de Taylor n'a pas été bornée aux exercice, de peinture et de musique : ces exercices ne furent pour lui que des objets de délassement ses études sérieuses et principales étaient celles des langues, de la littérature et des mathématiques; il s'y livra avec un tel succès, qu'à l'âge de quinze ans, il était déjà désigné pour l'université, et qu'en 1701, il fut nommé membre du collège de Cambridge. A cette époque les mathématiques acquéraient une grande faveur dans l'université; les exemples de la considération accordée par le monde savant aux mathématiciens distingués excitaient puissamment l'émulation des jeunes gens capables d'une application soutenue et doués d'un esprit pénétrant.

On présume que, dès les premiers moments de son admission à l'université de Cambridge, Taylor s'élança dans la carrière ouverte par Newton à ceux qui voulaient, comme on disait alors, expliquer et calculer les phénomènes du Système du monde; c'est du moins ce qu'il est naturel de conclure des relations d'estime qui le lièrent promptement avec les savants qui s'occupaient de la mécanique céleste. Il composa, en 1708, un mémoire sur les centres d'oscillation, qui fut publié quelques années après dans les Philosophical Transactions [image] . En 1709, il obtint le grade de bachelier ès lois; et, en 1712, il fut élu membre de la Royal Society.

Pendant les quatre années qui précédèrent cette élection, il entretint une correspondance avec le professeur Keill, sur diverses questions de mathématiques; sir William Young, son petit-fils, possédait une de ses lettres datée de 1712, adressée à Méchain, et contenant une solution détaillée du problème de Kepler, avec des applications: Cette même année, 1712, il présenta à la Royal Society, trois mémoires; l'un sur l'ascension de l'eau entre deux surfaces planes, le second sur les centres d'oscillation, et le troisième sur le célèbre problème de la corde vibrante, dont nous parlerons dans la suite de cette page. Il semble, d'après sa correspondance avec Keill, qu'en 1713, il avait présenté un quatrième mémoire sur son sujet favori, la musique, qui n'est pas imprimé dans les Philosophical Transactions. Le rang distingué auquel il s'était placé parmi les hommes adonnés aux sciences exactes lui acquit beaucoup de considération dans la Royal Society, qui, en 1714, le choisit pour secrétaire, et il prit, cette même année, à Cambridge, le grade de docteur ès lois.

De grands débats existaient alors entre les mathématiciens anglais et ceux du continent; Taylor était, dans les rangs des premiers, regardé comme un auxiliaire d'une haute importance. Ces débats avaient lieu principalement sur le vaste champ de recherches, nouvellement ouvert par les découvertes mathématiques de Newton et de Leibniz; les incursions faites à l'aide du calcul infinitésimal sur un sol naguère inconnu, ou trop péniblement exploré, mettaient en évidence de grandes richesses, sources ordinaires des grandes dissensions. La priorité des inventions, le mérite tant des méthodes analytiques que des solutions de problèmes, la mesure des forces, etc., fournissaient matière à des discussions que l'amour-propre irritable et blessé rendait trop souvent aigres et partiales.

Cependant au milieu de la foule de productions publiées par les différents partis, et condamnées à l'oubli comme les circonstances qui les avaient fait naître, apparaissaient quelques conceptions originales, fécondes, et qu'on pourrait appeler monumentales : une de ces conceptions est due à Taylor; nous y reviendrons quand nous aurons achevé l'indication de ses autres ouvrages. Vers 1714, il donna, dans une lettre adressée à sir Hans Sloane, un détail d'expériences sur le magnétisme qui ont été publiées dans les Philosophical Transactions, et l'année suivante, 1715, il y ajouta un essai curieux sur les lois de l'attraction magnétique : An account of an experiment for the discovery of the laws of magnetic attraction. Cette année 1715 correspond à la date d'impression que porte une partie des exemplaires de son Methodus incrementorum, traité auquel s'applique l'expression de conception monumentale, employée ci-dessus.
Enfin la même année vit paraître un autre ouvrage de sa composition, sur la perspective, qui eut un grand succès, malgré la critique amère qu'en fit Bernoulli. Parmi les reproches que ce célèbre mathématicien faisait à Taylor, se trouvait celui de s'être approprié une méthode qui ne lui appartenait pas; et de fait, cette méthode avait été donnée longtemps auparavant (en l'an 1600), à Pesaro, par Guido Ubaldi, dans un traité bien rédigé et dont les décorateurs de théâtre se servaient fort utilement. Mais il semble bien que chacun des deux a été inventeur de son côté. L'ouvrage original de Taylor a eu trois éditions en Angleterre; et l'on en a fait une traduction française, qui a été imprimée à Lyon, en 1753. A la suite des trois éditions anglaises, a paru une publication de Kirby, intitulée Perspective de Taylor, rendue facile, « Brook Taylor's perspective made easy ». Cette publication , devenue le Vade mecum des artistes les moins instruits, levait entièrement la principale objection de Bernoulli, portant sur les difficultés qui devaient éloigner les artistes de l'étude d'un ouvrage, selon lui, trop abstrait, eu égard à leur instruction première.

Quatre mémoires composés vers 1717 : 1° Sur les équations numériques, les séries infinies; 2° Un problème proposé par Leibniz; 3° le Mouvement parabolique des projectiles; 4° enfin des recherches, publiées en 1721, sur la dilatation, par la chaleur, des liquides renfermées dans les thermomètres : An experiment made to ascertain the proportion of expansion of liquor in the thermometer, with regard to the degree of heat, paraissent être les derniers ouvrages sur les sciences mathématiques et physiques dont Taylor se soit occupé. Un traité des logarithmes, qu'il avait confié à son ami lord Paislay, n'a jamais été publié.

On cite de lui quelques productions bien différentes, quant à leur genre, de celles qui étaient les objets de ses méditations ordinaires, et dont les dates, la dernière exceptée, se rapportent aux années comprises entre 1715 et 1720: une controverse avec le comte de Montmort, sur la doctrine de Malebranche; des fragments d'un traité sur les sacrifices juifs ; une longue dissertation sur la non culpabilité de l'action de manger du sang : On the Lawfulness of eating blood; enfin un essai intitulé Contemplatio philosophica, composé vers 1730, dans les derniers temps de sa vie, à une époque où sa santé était tout à fait dérangée, et publié, en 1793, par son petit-fils William Young. Newton affectionnait aussi les études et les compositions théologiques; mais c'est à l'auteur des Principia que l'immortalité est assurée; et, quoique dans un rang bien moins éminent; l'inventeur de la célèbre formule analytique que les mathématiciens appellent Théorème de Taylor a pour toujours inscrit son nom dans les fastes de l'analyse mathématique.

Ce théorème est le principal résultat, ou plutôt le résumé du livre ci-dessus mentionné, ayant pour titre : Methodus incrementorum directa et inversa, imprimé à Londres en 1715. Lagrange semble être le premier qui ait bien mis en évidence tout le parti qu'on peut tirer du Théorème de Taylor dans la haute analyse. Les biographes n'ont pas même soupçonné le mérite du Methodus incrementorum, et Montucla lui-même ne dit rien de ce traité dans son Histoire des mathématiques. L'énonciation analytique du théorème dont il s'agit constitue ce que les mathématiciens appellent une série ou un système, une suite de termes algébriques, liés entre eux par de certaines lois, et dont le nombre, en général infini, devient fini ou limité dans des cas particuliers. Cette série est appelée convergente ou divergente, respectivement, suivant que les valeurs de ses termes successifs sont continuellement décroissantes ou croissantes.

Il faut remonter jusqu'à Archimède pour trouver le premier exemple des séries infinies, que celui-ci a employées dans le Traité des Spirales, à carrer des espaces. Cavalieri a fait de ce moyen le fondement de sa Méthode des indivisibles; seulement ces séries sont sommées par des considérations géométriques, et représentées par des figures, ou par une suite de lignes droites. Wallis, dans son Arithmetica infinitorum, publiée en 1665, a traité les séries algébriquement, et les a appliquées à la quadrature d'un système de courbes du genre de celles qu'on appelle paraboliques, lequel genre renferme, comme cas individuel, la parabole carrée par Archimède. Le même auteur dans sa Mathesis universalis, sive Arithmeticum opus integrum, ann. 1657, cap. 33, donne un exemple, le premier à ce qu'il semble, d'une série algébrique proprement dite, c'est-à-dire ordonnée suivant une suite de termes dont le nombre est en général infini, contenant chacun une puissance d'une quantité indéterminée. Mercator dans sa Logarithmotechnia, publiée en 1668, a carré l'hyperbole par un développement en série; Brounker, James Gregory, Newton et Leibniz ont ensuite apporté leur contribution; et nous leur devons des séries importantes. En 1689, 1692, 1696, 1698, et 1704, Jacques Bernoulli fit soutenir, sous sa présidence, cinq thèses ayant pour objet la doctrine des séries. Ces thèses ont été réunies à la fin de son Ars conjectandi, publié par son neveu, en 1711, et imprimées longtemps après, dans le recueil de ses oeuvres. Vers cette époque, Brook Taylor s'occupait de la méthode des incréments ou des différences auxquelles on a mal à propos ajouté l'épithète finies, lui donnait un algorithme, et embrassait le calcul inverse dans ses recherches. Newton n'a fait ni l'un ni l'autre, soit dans son livre De systemate mundi (le troisième des Principia, soit dans son Methodus differentialis (ann. 1711), où l'on trouve une méthode d'interpolation bien connue; et Taylor est arrivé au célèbre théorème qui porte son nom, en passant des incréments finis aux incréments évanouissants : ce qui est remarquable, eu égard à l'époque où il écrivait.

Voici maintenant ce que ce théorème donne immédiatement : si l'on a une expression analytique composée de plusieurs termes dans lesquels une quantité variable entre sous des formes quelconques, ce que les mathématiciens appellent une fonction de cette quantité, et que la variable subisse un accroissement ou une diminution, il en résultera un changement correspondant dans la valeur de la fonction; et c'est ce changement dont le Théorème de Taylor donne la valeur générale. Cette valeur générale se trouve exprimée par une suite de termes dans lesquels entrent les différentielles (ce que Taylor après Newton appelle les fluxions), de différents ordres, de la fonction, combinées avec les puissances successives de l'incrément de la variable.

La formule du binôme de Newton , celle de Maclaurin pour le développement des fonctions, etc., s'en déduisent comme cas particuliers. Pour avoir une idée précise du rang que la formule de Taylor doit occuper parmi les découvertes analytiques, il faut entendre Lagrange qui en a fait la base de sa théorie des fonctions analytiques :

« Dans un mémoire imprimé parmi ceux de l'Académie de Berlin, 1772, dit Lagrange, j'avançai que la théorie du développement des fonctions en série contenait les vrais principes du calcul différentiel, dégagés de toute considération d'infiniment petits ou de limites; et je démontrai, par cette théorie, le Théorème de Taylor, qu'on peut regarder comme le principe fondamental de ce calcul, et qu'on n'avait encore démontré que par le secours de ce même calcul, ou par la considération des différences infiniment petites. Depuis, Arbogast a présenté à l'Académie un beau mémoire où la même idée est exposée avec des développements et des applications qui lui appartiennent » (Journal de l'école polytechnique, 9e cahier, p. 5).
Ainsi voilà un théorème qui, établi d'abord par une certaine marche de raisonnement, conduit ensuite à la connaissance et à l'usage des plus puissants instruments connus de découverte en mathématiques, sans embarrasser l'esprit par des considérations d'infiniment petits, de limites, etc. On a étendu le théorème de Taylor à une fonction d'un nombre quelconque de variables; on a trouvé le moyen de substituer à un terme de sa série d'un rang quelconque une expression qui représente la somme de ce terme et de tous les suivants, etc.

Nous ne pouvons pas terminer la notice de ses travaux mathématiques sans mentionner un chapitre très remarquable de son Methodus incrementorum (propos. 21, probl. 17, p. 86), dans lequel il donne une solution du problème fameux de la corde vibrante, plus complète et plus approfondie que les solutions publiées avant la sienne. Nous en avons parlé à l'article Sauveur auquel nous renvoyons.

Taylor, cédant à d'instantes invitations, fit un voyage à Paris, en 1716. La philosophie newtonienne y était alors cultivée; et les savants de cette capitale avaient un grand désir de connaître le secrétaire de la Royal Society. Il y fut reçu avec les témoignages les plus flatteurs de considération et d'estime; et le charme de ses entretiens ajouta encore à l'excellente opinion que ses ouvrages et sa réputation avaient fait concevoir de lui. Les mathématiciens ne furent pas les seules personnes qui l'accueillirent: il se lia avec lord Bolingbroke, le comte de Caylus, etc. Il revint à Londres au commencement de 1717 ; et après la composition de trois des traités que nous avons cités, sa santé se trouva tellement altérée que, pour la rétablir et goûter quelque repos, il prit le parti d'aller à Aix-la-Chapelle.

Désirant s'occuper de sujets moraux et religieux, il se démit, en 1718, de sa place de secrétaire de la Royal Society. De retour en Angleterre, en 1719, il partagea son temps entre les compositions religieuses et la peinture qu'il aima toujours. On pense que la retraite à laquelle il se condamnait, a pu abréger sa vie. Vers la fin de 1720, il se rendit à l'invitation que lui fit lord Bolingbroke, d'aller passer quelque temps à la Source, maison de campagne voisine d'Orléans, que ce lord tenait de son épouse veuve d'un neveu de madame de Maintenon, le marquis de Villette. L'année suivante, Taylor épousa miss Bridges de Vallington, dans le comté de Surrey, jeune demoiselle d'une bonne famille, mais qui avait peu de fortune. Ce mariage lui occasionna une rupture avec son père, qui refusa son consentement; la mort de cette épouse, arrivée en 1723, et celle d'un enfant qu'il en avait eu et qui pouvait devenir un moyen de réconciliation, affecta vivement sa sensibilité. Cependant il passa les deux années qui suivirent ces événements malheureux dans l'habitation de son père à Bifrons. Là les soins tendres et empressés de ses soeurs, et le charme de la musique, non seulement adoucirent ses chagrins, mais le déterminèrent à se fixer sans retour à la campagne. Il contracta, en 1725, un second mariage qui eut l'entière approbation de son père et de sa famille, avec Sabetta, fille de John Sawbridge, écuyer d'Olanting, dans le comté de Kent. Son père étant mort en 1729, la propriété de Bifrons lui échut par succession. Il eut la douleur, l'année suivante, de perdre encore sa seconde femme, à la suite d'une couche. La fille dont la naissance donna lieu à ce funeste événement est devenue la mère de William Young à qui l'on doit des notes sur la vie privée de son grand-père.

A dater de 1730, la santé de Taylor déclina tellement que ses amis perdirent tout espoir de le voir se rétablir. La cessation des travaux, sérieux devenait nécessaire, et cependant c'est à cette époque, comme nous l'avons dit, que Taylor composa la Contemplatio philosophica, où l'on voit ce que peut un esprit géométrique, quoique dans un corps malade, appliqué à des questions de métaphysique. Le chagrin qui l'accablait rendait infructueux les soins de ses parents et les consolations de ses nombreux amis, dans les premiers rangs desquels il faut placer Bolingbroke. Taylor ne survécut qu'un peu plus d'un an à sa seconde épouse, et mourut le 29 décembre 1731 , à l'âge de 46 ans.. Il fut inhumé au cimetière de Saint Ann's Soho. (P-NY).


Séries de Taylor, de MacLaurin - Analyse - Mathématique du secondaire

Vu dans ... https://xavier.hubaut.info/coursmath/ana/taylor.htm

Mathématique du secondaire

Xavier Hubaut, professeur émérite - Université Libre de Bruxelles

Séries de Taylor et de MacLaurin

Dans l'article sur les approximations, nous avons vu apparaître les développements en série de Taylor (appelés de MacLaurin lorsqu'on part de la valeur 0 de la variable).
Rappelons que si f ( x ) f ( x ) est une fonction dérivable autant de fois que l'on veut, le développement de MacLaurin est :

f ( x ) = f ( 0 ) + f ′ ( 0 ) x + f ′′ ( 0 ) x 2 2 ! + f ′′′ ( 0 ) x 3 3 ! + . . . f ( x ) = f ( 0 ) + f ′ ( 0 ) x + f ″ ( 0 ) x 2 2 ! + f ‴ ( 0 ) x 3 3 ! + . . .

Sans discuter du lien entre la fonction de départ et la série, nous nous attacherons à la convergence du développement en série.
En effet, l'idée de départ était d'obtenir une approximation d'une fonction donnée au voisinage de la valeur 0 de la variable x x , par une suite de polynômes en x x . Pour améliorer le plus possible cette approximation, on en est arrivé à considérer un polynôme de degré infini, appelé série de puissances entières de x x ou, plus brièvement, série entières de x x .
Arrivé à ce stade, on peut se demander ce qu'il se passe avec cette série lorsqu'on s'écarte de cette valeur 0.

Notre but est d'étudier la convergence (ou la divergence) de certaines séries entières sans faire au préalable une étude générale de la convergence ce type de séries, ce qui est manifestement hors programme.

Nous avons rencontré le développement de 4 fonctions fondamentales en série de MacLaurin, à savoir, les fonctions sinus, cosinus, exponentielle et sa réciproque, logarithme. Nous vous conseillons, dans chacun des cas, de garder à l'écran le graphique correspondant à la fonction étudiée.

Commençons par les fonctions goniométriques dont les séries sont très semblables : sinus et cosinus.

s i n x = x − x 3 3 ! + x 5 5 ! − x 7 7 ! + x 9 9 ! − x 11 11 ! + x 13 13 ! − x 15 15 ! + x 17 17 ! − x 19 19 ! + . . . s i n x = x − x 3 3 ! + x 5 5 ! − x 7 7 ! + x 9 9 ! − x 11 11 ! + x 13 13 ! − x 15 15 ! + x 17 17 ! − x 19 19 ! + . . .
et
c o s x = 1 − x 2 2 ! + x 4 4 ! − x 6 6 ! + x 8 8 ! − x 10 10 ! + x 12 12 ! − x 14 14 ! + x 16 16 ! − x 18 18 ! + . . . c o s x = 1 − x 2 2 ! + x 4 4 ! − x 6 6 ! + x 8 8 ! − x 10 10 ! + x 12 12 ! − x 14 14 ! + x 16 16 ! − x 18 18 ! + . . .

Pour visualiser les approximations successives, vous pouvez afficher le développement en série de ces deux fonctions, la fonction sinus et la fonction cosinus.
Dans chacun des deux cas la suite des polynômes (séries limitées) semble épouser de mieux en mieux l'allure de la courbe représentative de la fonction. Les deux séries associées semblent bien toutes deux converger. Encore faut-il le démontrer !

Une première remarque : la valeur de x x étant choisie, il existe un rang à partir duquel les valeurs absolues de termes de la série décroissent et tendent vers 0. En effet, tous les termes sont de la forme | x | n / n ! | x | n / n ! (avec les n tous impairs ou les n tous pairs). Dès que n > | x | n > | x | , ces valeurs absolues vont en décroissant ; en effet, | x | n / n ! | x | n / n ! est évidemment supérieur à | x | n + 2 / ( n + 2 ) ! | x | n + 2 / ( n + 2 ) ! ; de plus, ils tendent vers 0.
Malheureusement, nous savons bien que ce n'est pas encore suffisant pour assurer la convergence (voir l'exemple de la suite harmonique)

Une autre observation : nous constatons qu'il s'agit dans les deux cas de séries alternées, c'est-à-dire formées de termes consécutifs de signe opposés.
Mais alors, pour une valeur donnée de x x , il existe une valeur de n (dans le cas considéré ici, dès que n > | x | n > | x | à partir de laquelle les valeurs absolues des termes commencent à décroître et à tendre vers 0.

Pour une valeur donnée de x x , nous représentons qualitativement ci-dessus les valeurs successives de f ( x ) f ( x ) en fonction de n n .
Les corrections successives se font à chaque étape par addition de termes de signe contraire et la différence entre deux approximations consécutives est à chaque fois égale au terme ajouté ; cette différence tend donc vers 0. Les valeurs de f ( x ) f ( x ) successivement obtenues enserreront donc de plus en plus une valeur limite.
On en conclut que chacune des deux séries sera convergente pour toute valeur de x x .

Passons à présent à la série de MacLaurin de l' exponentielle.

e x p x = 1 + x + x 2 2 ! + x 3 3 ! + x 4 4 ! + x 5 5 ! + x 6 6 ! + x 7 7 ! + x 8 8 ! + x 9 9 ! + . . . e x p x = 1 + x + x 2 2 ! + x 3 3 ! + x 4 4 ! + x 5 5 ! + x 6 6 ! + x 7 7 ! + x 8 8 ! + x 9 9 ! + . . .

Les termes de la série sont du même type que précédemment. Donc certaines des conclusions restent valables.
Pour une valeur donnée de x x , à partir d'un certain rang (en fait dès que n > | x | n > | x | ) la valeur absolue des termes va en décroissant.
Si x < 0 x < 0 , la série est à nouveau alternée, et convergera donc.

Par contre si x > 0 x > 0 , bien que le graphique semble nous rassurer, la convergence n'est pas encore assurée ; il faut la démontrer rigoureusement.

Pour cela, il nous faut trouver d'autres armes. Connaissons-nous une série convergente dont tous les termes sont positifs ? Mais oui, la série géométrique dont la raison r est en valeur absolue inférieure à 1 ! Nous savons que la série 1 + r + r ² + r ³ + . . . 1 + r + r ² + r ³ + . . . converge vers 1 / ( 1 − r ) 1 / ( 1 − r ) .

Nous allons procéder par comparaison avec cette série convergente. Soit une valeur positive de x x et n n un naturel supérieur à x x . Nous allons examiner la série partielle commençant à x n / n ! x n / n ! . Nous pouvons écrire cette série : x n / n ! ( 1 + x / ( n + 1 ) + x ² / ( n + 1 ) ( n + 2 ) + . . . ) x n / n ! ( 1 + x / ( n + 1 ) + x ² / ( n + 1 ) ( n + 2 ) + . . . ) . Chacun des termes peut être majoré par un autre plus simple ; on a évidemment :

x k / ( ( n + 1 ) ( n + 2 ) . . . ( n + k ) < x k / n k = ( x / n ) k x k / ( ( n + 1 ) ( n + 2 ) . . . ( n + k ) < x k / n k = ( x / n ) k

La parenthèse est ainsi majorée par une série géométrique de raison x / n < 1 x / n < 1 qui est convergente. Cela entraîne immédiatement la convergence de la suite partielle et de là celle de la série de MacLaurin de l'exponentielle.

En résumé la série est convergente quelque soit pour tout x x .

Passons au dernier exemple rencontré, la série de MacLaurin associée à la fonction logarithme (népérien) de 1 + x 1 + x :

l n ( 1 + x ) = x − x 2 2 + x 3 3 − x 4 4 + x 5 5 − x 6 6 + x 7 7 − x 8 8 + x 9 9 − x 10 10 . . . l n ( 1 + x ) = x − x 2 2 + x 3 3 − x 4 4 + x 5 5 − x 6 6 + x 7 7 − x 8 8 + x 9 9 − x 10 10 . . .

En regardant attentivement les approximations successives, le doute commence à nous envahir !

Si pour les valeurs − 1 < x ≤ 0 − 1 < x ≤ 0 , tout semble bien se passer, il n'en n'est pas de même pour x > 0 x > 0 ; jusqu'à la valeur 1, le tracé des approximations successives de la série colle de plus à celui de la fonction ; au delà de la valeur 1, au contraire, la convergence semble complètement déraper. Comment cela est-il possible ? Tout fonctionnait remarquablement bien jusqu'à présent et la série de MacLaurin n'est pas tellement différente des précédentes.

A nouveau, pour les valeurs positives de x x , la série est alternée.

Mais..., contrairement à ce qui se passait dans les autres cas, le terme général ne tend pas vers 0 et c'est cela qui nous empêche de raisonner comme avant. Pour x ≤ 1 x ≤ 1 , les termes décroissent et tendent vers 0, mais dès que x x dépasse la valeur 1, les numérateurs des fractions successives croissent trop rapidement et les termes deviennent de plus en plus grands (en valeur absolue). Conclusion : pour 0 ≤ x ≤ 1 0 ≤ x ≤ 1 la série converge ; par contre, elle diverge si 1 < x 1 < x . Il ne nous reste qu'à vérifier la convergence pour − 1 < x < 0 − 1 < x < 0 . Nous pouvons procéder par comparaison de la série opposée − x + x ² / 2 − x ³ / 3 + . . . − x + x ² / 2 − x ³ / 3 + . . . avec la série géométrique | x | + | x | 2 + | x | 3 − . . . | x | + | x | 2 + | x | 3 − . . . Tous les termes de notre série sont positifs et majorés par ceux de la série géométrique choisie qui converge puisque | x | < 1 | x | < 1 ; il en résulte que notre série converge lorsque − 1 < x ≤ 0 − 1 < x ≤ 0 .

En résumé, alors que les 3 premières séries de MacLaurin, s i n x , c o s x , e x p x s i n x , c o s x , e x p x , convergent pour toutes les valeurs de x x , la dernière, celle de l n ( 1 + x ) l n ( 1 + x ) , converge uniquement lorsque x ∈ ] − 1 , + 1 ] x ∈ ] − 1 , + 1 ] . L'intervalle de convergence, s'il est centré, porte le nom de "rayon de convergence".

Dans les cas étudiés plus haut, le "rayon de convergence" est infini dans les 3 premiers cas, alors qu'il est centré en 0 et égal à 1 dans le dernier cas.


Formules de Taylor

Le résultat de base, le seul que vous ayez vraiment besoin de retenir, dit que sous les hypothèses de la définition 1, le reste de Taylor [image] est négligeable devant [image] au voisinage de 0, donc la fonction admet un développement limité, dont la partie polynomiale est son polynôme de Taylor d'ordre $ n$ . C'est le théorème de Taylor-Young.

Théorème 2 Soient $ I$ un intervalle ouvert contenant 0, et $ n$ un entier. Soit $ f$ une fonction dérivable $ n-1$ fois sur $ I$ , et dont la dérivée $ n$ -ième en 0 existe. Soit [image] son reste de Taylor d'ordre $ n$ en 0 :

Au voisinage de 0, [image] est négligeable devant [image] :

Démonstration : c'est une récurrence assez simple. Pour [image] , le résultat est une autre manière d'exprimer la dérivabilité de $ f$ en 0. En effet,

équivaut à :

Par définition, ceci signifie que $ f(x)-f(0)-(x-0)f'(0)$ est négligeable devant $ x$ au voisinage de 0 :

Supposons maintenant que le résultat soit vrai à l'ordre $ n-1$ . Si $ f$ vérifie les hypothèses à l'ordre $ n$ , alors $ f'$ les vérifie à l'ordre $ n-1$ . Or, le polynôme de Taylor d'ordre $ n-1$ de $ f'$ est exactement [image] .

L'hypothèse de récurrence entraîne que :

En revenant aux définitions, ceci signifie que pour tout [image] , il existe [image] tel que :

Fixons $ x$ dans l'intervalle [image] et appliquons le théorème des accroissement finis à [image] , sur l'intervalle $ [0,x]$ :

Alors :

Le raisonnement est le même pour [image] . Nous avons donc montré que [image] est négligeable devant [image] . D'où le résultat, par récurrence. La plupart des fonctions que vous aurez à manipuler sont indéfiniment dérivables sur leur domaine de définition. Elles admettent donc des développements limités à tout ordre.

Corollaire 1 Soit $ f$ une fonction de [image] dans [image] , indéfiniment dérivable sur un intervalle ouvert $ I$ contenant 0. Pour tout entier $ n$ , $ f$ admet un développement limité d'ordre $ n$ en 0. Soit [image] son reste de Taylor d'ordre $ n$ . Au voisinage de 0,

Démonstration : D'après le théorème 2, $ f$ admet un développement limité aux ordres $ n$ et $ n+1$ , pour tout $ n$ . Or :

Comme [image] est négligeable devant [image] , le rapport de [image] à [image] tend vers $ 1$ . D'où le résultat. Moyennant une hypothèse à peine plus forte que celle du théorème 2, on peut donner un résultat plus précis sur le reste de Taylor [image] : la formule de Taylor avec reste intégral.

Théorème 3 Soit $ n$ un entier et $ I$ un intervalle ouvert contenant 0. Soit $ f$ une fonction de classe [image] sur $ I$ (c'est-à-dire $ n+1$ fois dérivable, de dérivée $ (n+1)$ -ième continue). Soit [image] son reste de Taylor d'ordre $ n$ en 0.

(3)

Démonstration : c'est encore une récurrence. Pour [image] , la formule est le théorème fondamental de l'Analyse :

Pour $ n$ quelconque, posons :

et intégrons par parties.

Si on suppose la formule vraie à l'ordre [image] , alors [image] , or :

donc [image] : le résultat est vrai à l'ordre $ n$ . Il est donc vrai pour tout $ n$ , par récurrence.

Section : Cours
Avant : Polynômes de Taylor
Après : Opérations sur les développements limités

© UJF Grenoble, 2011 Mentions légales


La décomposition en séries de Fourier - Interstices

Vu dans ... https://interstices.info/la-decomposition-en-series-de-fourier

Onde sinusoïdale Image de parameter_bond, sur Flickr.
Publié le : 29/11/2018
Par : Romain Joly
Niveau intermédiaire
Niveau 2 : Intermédiaire

La décomposition en séries de Fourier

L’idée révolutionnaire de Joseph Fourier est que les fonctions trigonométriques sinus et cosinus permettent de décomposer n’importe quelle fonction. Découvrez-la à l'aide d'exemples imagés.

Joseph Fourier
Par Jules Boilly — « Portraits et Histoire des Hommes Utiles, Collection de Cinquante Portraits, » Société Montyon et Franklin, 1839-1840. Domaine public.

Au début du XIXe siècle, Joseph Fourier étudie la propagation de la chaleur et est le premier à décrire son évolution mathématiquement par l’ équation de la chaleur. Dans le cas d’une tige, cette équation admet des solutions particulières s’exprimant à l’aide des fonctions trigonométriques sinus et cosinus. L’idée révolutionnaire de Joseph Fourier est que ces fonctions particulières permettent de décomposer n’importe quelle fonction et de décrire ainsi l’évolution de la chaleur dans n’importe quelle situation : c’est la décomposition en série de Fourier, que l’on retrouve pour la résolution de l’équation de la chaleur mais aussi dans les fichiers MP3, dans l’analyse de signaux, dans l’imagerie médicale…

Le but de cet article est de découvrir à l’aide d’exemples imagés cette décomposition introduite par Joseph Fourier.

La famille des fonctions sinus

La décomposition de Fourier que nous allons voir s’appuie sur une famille de fonctions sinus. Les sinus font partie des fonctions trigonométriques et ont donc une longue histoire. Ils apparaissent dans les problèmes géométriques utilisant des angles et ont surtout été développés pour l’astronomie, une science très importante dans l’Antiquité. Pour aboutir à leur forme actuelle, ils sont partis de la Grèce antique, allés jusqu’en Inde pour revenir par la Perse et l’Arabie et enfin en Europe à la Renaissance. L’utilisation de ces sinus par Joseph Fourier n’est pas liée à un problème géométrique mais plutôt à leurs propriétés mathématiques, comme nous l’expliquerons plus loin.

La famille des sinus qui nous intéresse ici est plus précisément définie comme suit : pour chaque entier n, on regarde la fonction qui à x entre 0 et 1 associe sin(nπx). Pour nous familiariser avec ces fonctions, traçons le graphe de quelques-unes d’entre elles.

Le premier sinus qui nous intéresse est sin(πx). Son graphe sur l’intervalle [0,1] est tracé ci-dessous. La fonction part de 0, forme une large bosse montant jusqu’à la valeur 1 pour revenir ensuite à 0.
Le deuxième sinus de cet article est sin(2πx). Son graphe sur l’intervalle [0,1] est tracé ci-dessous. La fonction part de 0, forme une bosse au-dessus de l’axe y=0 puis une autre sous l’axe pour revenir ensuite à 0.
Le troisième sinus forme lui un graphe avec trois bosses comme ci-dessous.
Sans surprise, le quatrième sinus a un graphe composé de quatre bosses entre 0 et 1.

On peut bien sûr continuer ainsi : sin(5πx) forme cinq bosses, sin(10πx) forme dix bosses… Pour diversifier les formes obtenues avec ces fonctions, on peut les combiner en sommes pondérées par des coefficients.

Ci-dessous, le graphe de la fonction sin(πx)+sin(4πx). On voit les quatre bosses du sin(4πx) mais aussi l’influence de sin(πx) qui remonte la partie centrale du graphe.
Notre deuxième exemple de combinaison de sinus est 0.4sin(πx)+0.4sin(4πx)-0.3sin(4πx). Avec trois sinus et des coefficients, le graphe est plus complexe. On obtient ainsi une forme qui s’éloigne des graphes des fonctions sin(nπx) seules.

Pour mieux comprendre comment la forme du graphe se crée grâce à la combinaison des fonctions sinus, voici en animation deux exemples de combinaisons de trois fonctions sinus. Le premier correspond à l’exemple précédent, le deuxième à -0.2sin(2πx)-0.5sin(3πx)-0.4sin(8πx).

On peut ainsi créer différentes formes en combinant ces différents sinus. Mais jusqu’où peut-on aller ? C’est là que se trouve l’idée révolutionnaire de Joseph Fourier.

La décomposition de Fourier

Nous venons de voir que les fonctions sin(nπx) engendrent différentes formes si on regarde leurs combinaisons. Avant les travaux de Joseph Fourier, on savait comment utiliser ces combinaisons pour obtenir certaines solutions d’équations. Mais l’idée révolutionnaire de Joseph Fourier est qu’on peut obtenir ainsi toutes les solutions car toutes les fonctions dans l’intervalle [0,1] peuvent être obtenues en combinant des sin(nπx). Daniel Bernoulli avait déjà utilisé ce principe, mais il semble que Joseph Fourier soit le premier à le formaliser mathématiquement.

Théorème : toute fonction f sur l’intervalle [0,1] se décompose comme une combinaison infinie des fonctions sin(nπx)
f ( x ) = a 1 sin ( π x ) + a 2 sin ( 2 π x ) + a 3 sin ( 3 π x ) + a 4 sin ( 4 π x ) + a 5 sin ( 5 π x ) + … f ( x ) = a 1 sin ⁡ ( π x ) + a 2 sin ⁡ ( 2 π x ) + a 3 sin ⁡ ( 3 π x ) + a 4 sin ⁡ ( 4 π x ) + a 5 sin ⁡ ( 5 π x ) + …
De plus, les coefficients an sont donnés par la formule
a n = 2 ∫ f ( x ) sin ( n π x ) d x a n = 2 ∫ f ( x ) sin ⁡ ( n π x ) d x

Pour rendre ce théorème mathématiquement rigoureux, il faudrait préciser ce qu’on entend par cette somme infinie (les «…» ne voulant rien dire en science) et ce que veut dire l’égalité à f (qui est plus subtile que l’on pourrait penser). Joseph Fourier avait bien compris ces problèmes et les avait résolus avec la rigueur en cours à l’époque.

Nous n’allons pas entrer dans les détails mathématiques de ce théorème et de ces formules. Pour cet article, ce qu’il nous faut retenir en pratique est que :

  1. Toute fonction f peut être approchée par des combinaisons finies de fonctions sin(nπx) avec une erreur aussi petite que voulue.
  2. Les coefficients an de cette combinaison sont donnés par une formule explicite et peuvent être calculés facilement.

Illustrons ce principe par un premier exemple. La famille des sinus ne contient que des fonctions formant des bosses lisses, de douces collines. Peut-on obtenir un graphe plus pointu en les combinant ? «Oui» nous dit le théorème ci-dessus, «il suffit de bien ajuster les coefficients de la combinaison».

Prenons un autre exemple. On regarde la fonction f dont le graphe est ci-contre. Il s’agit d’une sorte de creux qui n’occupe que la première moitié du segment. Il ne s’agit pas d’un mode sinusoïdal et en fait, il ne s’agit pas non plus d’une combinaison d’un nombre fini de sin(nπx). Pourtant, on va pouvoir approcher très précisément cette forme par des combinaisons de sin(nπx) comme l’annonce le théorème de Fourier ci-dessus. Les bons coefficients seront difficiles à trouver à la main, mais on dispose de la formule plus haut : il suffit de faire le calcul (ou de le faire faire par un ordinateur).

Dans les exemples ci-dessus, on approche petit à petit la forme voulue à l’aide de six sinus. Plus on va en ajouter, plus la forme sera approchée avec précision. Rappelons que ces approximations comprenant de plus en plus de sinus sont obtenues par des formules. Ce qu’on appelle décomposition de Fourier est donc calculable automatiquement par un ordinateur et de façon très rapide.

Avec dix sinus, cela devient difficile de faire la différence avec l’original, sauf au niveau du raccord entre le creux et la partie plate.

-0.424sin(πx)-0.5sin(2πx)-0.254sin(3πx)+0.06sin(5πx)-0.028sin(7πx)+0.016sin(9πx)-0.011sin(11πx)+0.007sin(13πx)-0.005sin(15πx)
Avec 25 sinus, on obtient une très bonne représentation de la fonction initiale. Le dessin du graphe initial contient 1000 points donc 1000 informations. Or on peut obtenir le dessin ci-dessous avec seulement 25 coefficients donc 25 informations. La qualité est très bonne avec 97,5% d’espace gagné. C’est l’idée derrière les formats compressés JPEG ou MP3.

La décomposition de Fourier permet donc de décomposer une fonction en somme de sinus. Cela ouvre la voie à des applications pratiques comme la compression d’images, en dosant le nombre de sinus utilisés, mais aussi de nombreuses autres qui seront abordées dans cette série d’articles.

Le théorème de Fourier nous dit que toute fonction peut être ainsi décomposée en sinus. Est-ce que cela fonctionne vraiment pour toutes les fonctions ? Oui, pour toutes les fonctions f, du moins celles qui représentent des données physiques pour lesquelles l’énergie ∫ f 2 ∫ f 2 est définie. Cela fonctionne même pour des fonctions qui ne sont pas continues, c’est-à-dire qui admettent des sauts. Ceci était tellement surprenant pour l’époque que certains mathématiciens ont pris cette propriété comme un argument indiquant que le résultat devait être faux : comment une fonction avec un saut pourrait-elle être approchée par des fonctions qui sont continues ?
Mais Joseph Fourier avait bien raison et a fini par imposer son point de vue. Ce type de propriété paradoxale a poussé les mathématiciens à reprendre de façon plus rigoureuse les bases de l’analyse mathématique.

Avec six sinus, il est difficile d’obtenir un saut abrupt.
Avec 30 sinus, on obtient déjà une forme de créneau.
Avec 100 sinus, on obtient bien un créneau avec un saut très abrupt. Il reste encore de petites oscillations aux endroits où le graphe varie brusquement. Il s’agit du phénomène de Gibbs que l’on peut aussi voir sur les images JPEG.

Pour finir, nous allons nous amuser avec la décomposition de deux fonctions, l’une rouge et l’autre bleue. Nous allons faire apparaître petit à petit plus de sinus de leur décomposition.

Avec un seul sinus on n’a pas vraiment d’informations.
0,19sin(πx)
-0.19sin(πx)
Avec deux sinus, on a une sorte de cacahouète.
0,19sin(πx) + 0.086sin(3πx)
-0.19sin(πx) – 0.065sin(3πx)
Avec cinq sinus… un vaisseau spatial ?
0,19sin(πx) + 0.086sin(3πx) + 0.044sin(5πx)
– 0.035sin(7πx) + 0.038sin(9πx)

-0.19sin(πx) – 0.065sin(3πx) – 0.05sin(5πx)
– 0.0028sin(7πx) + 0.002sin(9πx)
Avec dix sinus, on devine un papillon ?
0,19sin(πx) + 0.086sin(3πx) + 0.044sin(5πx)
– 0.035sin(7πx) + 0.038sin(9πx) + 0.005sin(11πx) – 0.004sin(13πx) +
0.007sin(15πx) + 0.004sin(17πx) + 0.008sin(19πx)

-0.19sin(πx) – 0.065sin(3πx) – 0.05sin(5πx)
– 0.0028sin(7πx) + 0.002sin(9πx) – 0.001sin(11πx) – 0.024sin(13πx)
+ 0.005sin(15πx) – 0.003sin(17πx) – 0.001sin(19πx)
Avec 20 sinus, cela se précise
0,19sin(πx) + 0.086sin(3πx) + 0.044sin(5πx)
– 0.035sin(7πx) + 0.038sin(9πx) + 0.005sin(11πx) – 0.004sin(13πx) +
0.007sin(15πx) + 0.004sin(17πx) + 0.008sin(19πx) + …

-0.19sin(πx) – 0.065sin(3πx) – 0.05sin(5πx)
– 0.0028sin(7πx) + 0.002sin(9πx) – 0.001sin(11πx) – 0.024sin(13πx)
+ 0.005sin(15πx) – 0.003sin(17πx) – 0.001sin(19πx) + …
Avec 80 sinus, c’est presque parfait, sauf de petites oscillations, surtout proches des endroits où le graphe varie brusquement : c’est de nouveau une manifestation du phénomène de Gibbs.
0,19sin(πx) + 0.086sin(3πx) + 0.044sin(5πx)
– 0.035sin(7πx) + 0.038sin(9πx) + 0.005sin(11πx) – 0.004sin(13πx) +
0.007sin(15πx) + 0.004sin(17πx) + 0.008sin(19πx) + …

-0.19sin(πx) – 0.065sin(3πx) – 0.05sin(5πx)
– 0.0028sin(7πx) + 0.002sin(9πx) – 0.001sin(11πx) – 0.024sin(13πx)
+ 0.005sin(15πx) – 0.003sin(17πx) – 0.001sin(19πx) + …
Avec 150 sinus, l’image apparaît parfaitement.
0,19sin(πx) + 0.086sin(3πx) + 0.044sin(5πx)
– 0.035sin(7πx) + 0.038sin(9πx) + 0.005sin(11πx) – 0.004sin(13πx) +
0.007sin(15πx) + 0.004sin(17πx) + 0.008sin(19πx) + …

-0.19sin(πx) – 0.065sin(3πx) – 0.05sin(5πx)
– 0.0028sin(7πx) + 0.002sin(9πx) – 0.001sin(11πx) – 0.024sin(13πx)
+ 0.005sin(15πx) – 0.003sin(17πx) – 0.001sin(19πx) + …

N’est-ce pas surprenant ? Encore une fois, c’est la puissance de la décomposition de Fourier : on peut partir de n’importe quelle fonction et tous les calculs sont donnés par des formules explicites qu’il n’y a qu’à appliquer. Le point difficile ici était d’avoir une formule pour les courbes du dessin. Ces formules semblent avoir été introduites par un professeur américain en 2011 et une de leurs premières traces se trouve sur le forum reddit. Elles sont maintenant connues sous de nom de Batcurves. On pourra consulter cette page sur Stackexchange pour des explications sur les formules. On pourra aussi trouver cette vidéo qui dramatise un peu l’application de la décomposition de Fourier à la Batcurve. Notez que dans cette vidéo, la décomposition se fait selon des cosinus à la place des sinus, mais le principe est exactement le même.

Application aux cordes vibrantes

La transformation de Fourier a été introduite dans le cadre de l’ équation de la chaleur. Comme nous n’avons pas l’habitude de « voir » la chaleur, le tracé des solutions de son équation ne nous serait pas très familier. Dans cet article, nous allons donc plutôt regarder les solutions de l’ équation des cordes vibrantes. Il s’agit de décrire les oscillations d’une corde fixée à ses deux bouts : corde de guitare, de piano, corde à sauter… Quel rapport avec la propagation de la chaleur ? C’est la magie des mathématiques ! Les deux problèmes sont physiquement très différents, mais la décomposition de Fourier est un outil mathématique suffisamment puissant pour intervenir dans les deux cas. Jean le Rond d’Alembert et Leonhard Euler avaient introduit et étudié l’équation des cordes vibrantes. Ils savaient qu’elle possède des solutions particulières décrites par notre famille des sinus.

L’animation ci-contre présente une corde vibrant selon la fonction sin(πx). Plus précisément, c’est la fonction cos(πt)sin(πx), qui dépend à la fois du temps t et de l’espace x, qui est solution de l’équation des cordes vibrantes. Cette solution est très particulière dans le sens où la forme de la corde est toujours celle du premier sinus, elle ne fait qu’osciller au cours du temps : l’amplitude du mouvement, en chaque point x, varie dans le temps selon la fonction cos(πt). On appelle cette vibration particulière le premier mode de vibration. Dans le cadre musical, c’est ce mode qui sera responsable de la note produite par la corde. On parle à ce moment-là de mode fondamental.

Si les sinus sont des fonctions importantes pour cette équation des cordes vibrantes, c’est que, comme l’équation de la chaleur, elle fait intervenir des dérivées secondes. Si on dérive deux fois de suite une fonction sinus, on retombe sur la même fonction, à un facteur près. C’est pour cela que le profil de la solution ci-contre reste en permanence celui d’une fonction sinus.

Le premier mode des cordes vibrantes

Si on regarde les autres sinus, on obtient encore des solutions particulières de l’équation des cordes vibrantes. Ces solutions ne sont que les sinus vus plus hauts que l’on fait vibrer de plus en plus rapidement. On peut facilement voir ces modes de vibration en faisant osciller une corde que l’on tient par une main. Musicalement, ces modes de vibrations de la corde de guitare (ou piano, ou violon…) sont responsables des harmoniques du son et de ce qu’on appelle le timbre de la note.

Le deuxième mode d’oscillation correspond à la solution cos(2πt)sin(2πx). Sa fréquence d’oscillation est deux fois plus rapide que celle du premier mode, aussi bien en temps qu’en espace. Pour une corde d’instrument de musique, ce mode produit un son une octave au-dessus de l’oscillation du mode fondamental vu plus haut. On parle de la première harmonique.
Le troisième mode d’oscillation correspond à la solution cos(3πt)sin(3πx). Sa fréquence d’oscillation est trois fois plus rapide que celle du premier mode. Musicalement, il est responsable de la deuxième harmonique.
Le quatrième mode d’oscillation correspond à la solution cos(4πt)sin(4πx) qui oscille quatre fois plus rapidement que le mode fondamental. Et ainsi de suite…

Source : vidéo Youtube du
Scientibus par F. Louradour, Faculté des Sciences de Limoges.
Nous avons déjà vu la fonction sin(πx)+sin(4πx) qui est la somme de deux de nos fonctions sinus. Si on lâche une corde avec cette forme, elle oscillera comme ci-contre.
La solution cos(πt)sin(πx)+cos(4πt)sin(4πx) de l’équation des cordes vibrantes est la somme des vibrations des premier et quatrième modes. On voit qu’il ne s’agit pas d’un mode propre comme les oscillations des sinus car le profil de la corde se déforme au cours du temps au lieu de simplement osciller. La corde revient quand même régulièrement dans sa position initiale, une fois que le premier mode a fait un aller-retour et donc que le quatrième a eu le temps d’en faire quatre.
Nous avons déjà vu la fonction 0,4sin(πx)+0,4sin(2πx)-0,3sin(6πx) qui est la somme de trois de nos fonctions sinus déjà vues avec des coefficients. Si on lâche une corde avec cette forme, elle oscillera comme ci-contre.
La solution 0,4cos(πt)sin(πx)+0,4cos(2πt)sin(2πx)-0,3cos(6πt)sin(6πx) de l’équation des cordes vibrantes est la somme des vibrations de trois des modes sinusoïdaux avec les coefficients associés. Il ne s’agit pas d’un mode propre puisque le profil de la corde se déforme au cours du temps.

Nous venons de voir que les fonctions sin(nπx) engendrent des solutions importantes pour l’équation des cordes vibrantes. Comme dit dans l’introduction, il en est de même pour l’équation de la chaleur. Dans les deux cas, on peut aussi obtenir de nouvelles solutions en faisant des combinaisons des solutions données par les sinus. Cette façon d’obtenir des solutions était déjà connue à l’époque de Fourier, par exemple déjà utilisée par Daniel Bernoulli.

La révolution apportée par Joseph Fourier est que sa décomposition montre que toutes les solutions de l’équation des cordes vibrantes s’écrivent comme combinaisons des solutions données par les modes en sinus. Si on reprend la forme en creux vue plus haut, on peut obtenir l’évolution d’une corde lâchée selon cette forme.

On commence par décomposer la forme en creux comme une combinaison de fonctions sinus. Nous avons déjà vu cela plus haut. Pour rappel, les coefficients sont donnés par une formule explicite et sont donc calculables facilement.
-0,42sin(πx) – 0.5sin(2πx) – 0,26sin(3πx) + 0.06sin(5πx) – 0.03sin(7πx) +…
On peut aussi utiliser la description de notre courbe initiale en fonction de sinus pour regarder comment se comporte une corde mise initialement suivant notre forme ci-contre. Il suffit de remplacer les sinus dans la décomposition par les modes de vibrations. C’est cette idée qui a poussé Fourier à étudier la décomposition qui porte son nom. Il s’agit d’une méthode efficace toujours utilisée aujourd’hui dans les simulations numériques en recherche et en industrie.
-0,42cos(πt)sin(πx) – 0.5cos(2πt)sin(2πx) – 0,26cos(3πt)sin(3πx) + 0.06cos(5πt)sin(5πx) – 0.03cos(7πt)sin(7πx) +…

Peut-être que la simulation de la vibration de la corde ci-dessus vous semble irréelle. Il est en effet difficile de voir une corde vibrer ainsi car le modèle utilisé ne tient pas compte des amortissements et de la dissipation d’énergie. Si on veut obtenir une simulation plus fine, on peut diminuer petit à petit l’amplitude des oscillations. En outre, dans la réalité, la dissipation est plus forte pour les hautes fréquences, c’est-à-dire les modes sin(nπx) avec n grand. On obtient alors une simulation comme ci-contre qui est plus réaliste. Plus on attend, plus les deux premiers modes sin(2πx) et finalement sin(πx) sont visibles. Encore une fois, cette animation est principalement basée sur la décomposition en différents modes introduite par Joseph Fourier.

Une histoire qui continue

Si les fonctions cosinus et sinus sont connues depuis l’Antiquité, ce n’est qu’au XVIIIe siècle qu’on commence à comprendre leur importance en dehors des problèmes géométriques. Vers 1810, Joseph Fourier est le premier à énoncer que toute fonction peut se décomposer comme une somme infinie de ces fonctions trigonométriques cosinus et sinus. Il montre aussi que les calculs pour obtenir cette décomposition sont simples et explicites. Il faudra plusieurs années pour que les mathématiciens s’approprient ce résultat en en comprenant toute sa profondeur et en le rendant plus rigoureux. À partir de la décennie 1980, l’avènement du numérique ouvre un vaste champ d’applications pour la décomposition introduite par Joseph Fourier et pour ses descendantes les ondelettes : traitement du signal, fichier MP3, images JPEG, simulations numériques pour l’ingénierie…

L’auteur remercie Christian Jutten ainsi que le comité éditorial d’Interstices pour lui avoir proposé le projet d’article et pour leur relecture attentive.
Les images et gif animés ont été produits par l’auteur grâce à un programme Python et au logiciel Gimp.


Vu dans ... http://villemin.gerard.free.fr/Wwwgvmm/Analyse/Fourier.htm

SÉRIE DE FOURIER

TRANSFORMÉE DE FOURIER

Outil pratique qui permet de faire des calculs sur des [image] fonctions bizarroïdes, mais répétitives. Celles-ci sont transformées en sommes de fonctions périodiques (sinus et cosinus) plus simples.

Dans un mémoire daté de 1807, Joseph FOURIER, mathématicien français, affirma, qu’il était possible, dans certaines conditions, de décomposer une fonction périodique sous la forme d’une somme infinie de signaux sinusoïdaux.

Il est plus facile de connaître les propriétés de la fonction en analysant les propriétés de chacune des composantes.

Encore une histoire de changement de monde permettant d'aborder un problème plus simplement…

Anglais :Fourier Series / Fourier Transform

Des formes d'ondes très différentes

* Seule la forme sinusoïdale peut être représentée sous la forme d'une fonction : y = a. sin ( x )

* Ce n'est pas possible (simplement) pour les autres ( quoique!). Les transformées de Fourier le permettent. Ce sont des suites infinies de fonctions sinusoïdales qui sommées, tendent vers la fonction à définir.

Addition de sinusoïdes

* En haut le graphe de quatre sinusoïdes:

sin( x) en rouge,

0,8 sin (2x) en vert ,

0,4 sin (3x) en jaune , et

0,2 sin (7x) en bleu .

* En bas, en rouge, la somme de ces quatre courbes.

* En ajoutant des sinusoïdes et en ajustant

* leur amplitude,

* leur fréquence, et

* leur phase

il est possible d'obtenir une approximation d'une onde quelconque.

Effet de la phase

Tous les paramètres sont ceux vus ci-dessus sauf pour la deuxième courbe en 2x qui devient:
0,8 sin (2x + pi/2 )

Soit un déphasage d'un quart de tour (Pi/2).

Créneaux définis par séries de Fourier

* Succession de superpositions de sinusoïdes qui forme un signal se rapprochant d'un créneau.

* Inversement un créneau peut être décrit par les coefficients de ces fonctions sinus ou cosinus.

* Conclusion

* En continuant à ajouter des fonctions cosinus, et

* Avec les coefficients impairs successifs,

* Alternativement négatifs et positifs,

* On se rapproche de plus en plus de la fonction en créneau.

Autres exemples

* Exemple de ligne brisée avec seulement cinq termes:

HISTORIQUE

* Fourier (1768-1830) est connu pour ses travaux sur la chaleur.

* Il met au point une modélisation à base d' équations faisant intervenir des dérivées, et il trouve une manière générale de la résoudre.

* Cette méthode est si générale qu'elle devient cet outil formidable qu'est

La transformée de Fourier.

* Et, plus récemment, avec les besoins des ordinateurs:

La transformée de Fourier rapide

FFT : Fast Fourier Transform .

Ce que disait Fourier

* Ce mouvement peut toujours être décomposé en plusieurs autres dont chacun s'accomplit comme s'il avait lieu seul. Cette superposition des effets simples est un des éléments fondamentaux de la théorie de la chaleur.

* Cette remarque est essentielle, en ce qu'elle conduit à connaître comment les fonctions entièrement arbitraires peuvent ainsi être développées en séries de sinus d'arc multiples.

Biblio très complète sur ce sujet : Fourier - Créateur de la physique mathématique

THÉORIE – Série de Fourier
* Soit une fonction périodique f(x) |  | f(x) =
* Elle peut être développée en série de Fourier. Elle comporte trois éléments: | * Un terme constant a0, appelé composante continue. | a0
 | * Une composante fondamentale caractérisée par les valeurs de a1 et b1. | + a1 cos x + b1 sin x
 | * Des harmoniques (multiples de la fréquence fondamentale) caractérisées par les valeurs des autres coefficients de Fourier: an et bn . | + a2 cos 2x + b2 sin 2x +… + an cos ( n.x ) + bn sin ( n.x ) +…

* Coefficients de Fourier

qui se prêteraient bien à une interprétation en nombres complexes.

* L'outil correspondant est appelé transformée de Fourier:

* Détermination des coefficients;

* Formule d'Euler – Fourier;

* Dans l'intervalle [image] .

an et bn nombres réels

cn = an e+ i . bn

DROITE en Fourier
* Fonction | f(x) = x dans l'intervalle:
* Détermination des coefficients | Le calcul est donné à titre indicatif; il dépasse de loin le cadre de ce site.
* Soit | x = 2 sinx – sin2x + 2/3 sin3x – 2 sin4x + …

Illustration selon la quantité de coefficients

Bilan

La transformée de Fourier est un bon outil pour tous ceux qui ont à traiter des signaux périodiques, ou des fonctions intégrables. Elle décompose celles-ci en leur spectre de fréquences élémentaires. Les coefficients obtenus sont appelés séries de Fourier.

L'étude des fonctions par cette méthode s'appelle l'analyse harmonique. Une façon de décrire les fonctions périodiques. La fonction est:

* décomposable en suite de ses coefficients de Fourier ( analyse ); ou

* reconstruite à l'aide de la suite de ses coefficients ( synthèse ).

Cet outil, y compris la transformée de Fourier rapide ( FFT ), sont utilisés en traitement du signal: radar, sonar, communication, analyse d'images … L'analyse de spectre en radar ou en sonar est l'outil principal de la classification qui permet l'identification d'un contact par sa signature spectrale (sorte d'empreintes digitales).

ENGLISH CORNER

* Joseph Fourier (1768-1830), introduced the concept of Fourier series in his major work on the mathematical theory of heat conduction: The Analytic Theory of Heat. He established the partial differential equation governing heat diffusion and solved it using an infinite series of trigonometric (sine and cosine) functions.

Fonction dents de scie

* Il est vrai qu'il est possible, néanmoins, de définir certaines fonctions relativement simplement. Voici la représentation de la dent de scie:


Vu dans ... http://www.tangentex.com/AnalyseFourier.htm

Construire et analyser un signal avec Fourier

1 - Le principe de superposition
2 - Les mathématiques
3 - Construire un signal
4 - Décomposer un signal en sinusoïdes
5 - L'analyse spectrale

Le principe de superposition

Les séries de Fourier sont nées de la physique, plus précisément de l'étude de la propagation de la chaleur. Joseph Fourier, à travers ces outils et leur extension, la transformée de Fourier, a doté les physiciens d'un des arsenaux mathématiques les plus importants pour leurs travaux. Chaque étudiant en physique et chaque élève ingénieur va passer des heures et des heures à les étudier.
Il n'est pas question ici de rentrer dans les détails mathématiques de ces outils mais plutôt d'aborder de manière simple leur utilisation et de tenter d'en donner une compréhension intuitive.

Linéarité et superposition

L'analyse de Fourier est entièrement basée sur la possibilité de superposer plusieurs fonctions sinusoïdales pour produire une onde plus complexe. Nous avons déjà abordé ce sujet dans la page consacrée aux rappels sur les ondes. Rappelons de quoi il s'agit.

L'équation d'onde de d'Alembert, équation différentielle qui régit la propagation des ondes mécaniques et électromagnétiques, est une équation linéaire. Cela signifie, entre autre, que si s1 et s2 sont deux solutions de cette équation, leur combinaison linéaire ?s1 + ?s2 est aussi une solution de l'équation. Il en découle immédiatement que la somme de plusieurs ondes est une onde.

Un exemple

Plutôt qu'un long discours, je vous propose un petit programme qui illustre la superposition de plusieurs ondes. C'est le programme Maple Ondes1.mpl, qui visualise 2 ondes de pulsation différente ainsi que leur somme. Vous pouvez bien sur le modifier pour changer les pulsations ou encore ajouter une ou plusieurs ondes. Voilà un exemple d'exécution :

Les deux ondes sont en rouge et bleu. La somme des deux ondes est en vert. Je vous laisse analyser ce graphique, en particulier l'amplitude de l'onde verte et sa période...

La notion de signal

La notion de signal est maintenant abordée en TS. Mon livre de physique de TS (le "Sirius" de Nathan) définit le signal comme une grandeur physique (par exemple tension électrique, champ électromagnétique) qui transmet de l'information. Il précise qu'un signal peut être analogique (variation continue) ou numérique (variation discrète).
Complétons un peu cette définition. Un signal est le résultat de la mesure d'un phénomène physique. Il dépend de quantités comme le temps, l'espace ou la fréquence, pour ne citer que les variables les plus courantes. Pour que ce signal puisse être traité et compris par l'observateur, il est la plupart du temps transformé en signal électrique, c'est à dire une variation continue de tension (ou de courant). Et pour être traité par un ordinateur, il doit être de surcroit transformé en signal numérique, c'est à dire discrétisé et quantifié. Ce qui introduit une nouvelle notion, celle d'échantillonnage, abordée elle aussi en cours de TS. L'ensemble de ces traitements forment ce qu'on appelle en physique la chaine d'acquisition d'un signal, que l'on peut résumer sous la forme :
GRANDEUR PHYSIQUE -> [capteur] -> GRANDEUR ELECTRIQUE -> [Echantillonneur] -> SIGNAL NUMERIQUE
Ce signal peut être périodique, ce qui nous facilite la vie ou bien non périodique. Dans ce dernier cas, on tentera par divers artifices de le rendre périodique.

Il reste maintenant à modéliser ce signal numérique, c'est à dire à trouver la fonction mathématique qui décrira le mieux le signal numérique, et donc, aux erreurs de traitement près, l'évolution de la grandeur physique, ce qui est quand même la préoccupation essentielle du physicien. Parce que bien sur, tous les traitements (acquisition, amplification, échantillonnage, quantification, transport, etc.) que subit le signal introduisent des erreurs...

Cette démarche est très courante et vous l'avez déjà pratiqué! Lorsque vous visualisez à l'aide d'un oscilloscope numérique la forme d'un courant électrique provenant d'une prise, vous avez capté la grandeur physique (la tension), l'oscillo l'a échantillonné et visualisé et vous avez modélisé la forme de la courbe avec une fonction sinusoïdale, parce que la variation de cette fonction correspond à ce que vous voyez !

Ce n'est pas toujours aussi simple et la forme d'un signal peut être complexe. C'est pour résoudre le problème de la modélisation d'un signal complexe (au sens compliqué) que l'on utilise l'analyse de Fourier et sa petite soeur la transformée de Fourier.

Les mathématiques

Le théorème de Fourier

Enonçons brutalement ce théorème, qu'il n'est pas question de démontrer ic i: soit f(x) une fonction réelle (ou complexe) d'une variable réelle x, fonction 2π π-périodique, présentant sur l'intervalle [-π π, π π] un nombre fini de discontinuités et d'extrema, et telle que ∫+π−π|f(x)|dx∫−π+π|f(x)|dx ait une valeur finie. Alors, on peut décomposer f(x) en série de Fourier, c'est à dire écrire f(x) sous la forme :

f(x)=a02+∑n=−1+∞(ancos(nx)+bnsin(nx))f(x)=a 0 2+∑n=−1+∞(an cos⁡(nx)+bn sin⁡(nx))

avec an=1π∫+π−πf(x)cos(nx)dx an=1 π∫−π+π f(x)cos⁡(nx)dx et bn=1π∫+π−πf(x)sin(nx)dx bn=1 π∫−π+π f(x)sin⁡(nx)dx
ou encore, sous forme complexe :

f(x)=∑n=−∞+∞cnexp(inx)aveccn=12π∫+π−πf(x)exp(−inx)dx f(x)=∑n=−∞+∞cn exp⁡(inx)avec cn=1 2 π∫−π+π f(x)exp⁡(−inx)dx

Notons, ce qui nous servira plus loin, que l'on peut exprimer cn en fonction de an et bn. En appliquant la formule d'Euler qui exprime la relation entre une exponentielle complexe et les sinus et cosinus, nous obtenons cn = (an - ibn)/2.

On peut généraliser cette décomposition aux fonctions T-périodiques, avec T=2πω T=2 π ω, ce qui nous donne en posant x=ωt x=ωt :

f(t)=a02+∑n=−1+∞(ancos(nωt)+bnsin(nωt))f(t)=a 0 2+∑n=−1+∞(an cos⁡(nωt)+bn sin⁡(nωt))

avec an=2T∫+T2−T2f(t)cos(nωt)dt an=2 T∫−T 2+T 2 f(t)cos⁡(nωt)dt et bn=2T∫+T2−T2f(t)sin(nωt)dt bn=2 T∫−T 2+T 2 f(t)sin⁡(nωt)dt

Ces formules nous permettent donc théoriquement de transformer n'importe quel signal T-périodique en une somme de sinus et de cosinus, ou mieux car plus maniables, en une somme d'exponentielles complexes. Pour opérer la même transformation sur un signal non périodique, on utilise un outil mathématique extrémement puissant que l'on nomme transformée de Fourier. Il en existe de nombreuses implémentations numériques, dont la célébre FFT.

Le théorème de Parseval

Le théorème de Parseval établit une relation entre la valeur moyenne du carré du module d'une fonction périodique et les coefficients de la série de Fourier décrivant la fonction. En physique, il exprime donc la façon dont l'énergie du phénomène périodique se répartit selon les différentes harmoniques de la fonction.
Il s'établit ainsi, en adoptant la forme complexe de la série de Fourier :

12π∫+π−π|f(x)|2dx=∑n=−∞+∞|cn|2 1 2 π∫−π+π|f(x)|2 dx=∑n=−∞+∞|cn|2

Quelques définitions

Fréquence

Soit T la période de la fonction f(t) T-périodique, avec T=2πω T=2 π ω. On appelle ν=1T ν=1 T la fréquence fondamentale de f(t). Les multiples de ν ν sont appelés les harmoniques de f(t).

Spectres

Considérons la fonction f(t) , T-périodique développée en série de Fourier complexe:

f(t)=∑n=−∞+∞cnexp(inωt)f(t)=∑n=−∞+∞cn exp⁡(inωt)

On appelle spectre de la fonction f(t) l'ensemble des (nν nν, cn). On distingue :

  • le spectre d'amplitude de f(t), qui est la représentation de |cn| en fonction de nν nν
  • le spectre de phase de f(t), qui est la représentation de arg(cn) en fonction de nν nν

Construire un signal

Des créneaux

Avant d'étudier la décomposition d'un signal périodique en somme de sinusoïdes, nous allons nous amuser à tenter de reconstituer un signal en appliquant le principe de superposition décrit plus haut. Cela revient à tenter de reconstituer le signal en sommant des ondes de fréquences différentes.

Je vous propose de faire l'exercice sur un signal appelé créneau. Il est décrit par la fonction f(t) définie par f(t) = 1 si 0 <= t < π π et f(t) = -1 si π π <= t < 2π 2 π. Je vais donc vous proposer un programme Maple, qui trace des créneaux puis qui va superposer une somme des sinusoïdes, en plus ou moins grand nombre, pour vérifier visuellement le principe de synthèse d'un signal.

Construction d'un créneau

Voilà la forme de la courbe en créneaux, telle que la produit le programme Maple SyntheseFourier:

Synthèse par sommes de sinusoïdes

Il s'agit d'essayer de reconstruire la fonction créneaux avec une somme de sinusoïdes bien choisies. Commençons par trouver une sinusoïde de même période que la fonction f(t).

Elle apparaît en bleu, superposée à f(t). Il s'agit de la fonction f(t)=4πsin(t)f(t)=4 π sin(t). On constate que les deux fonctions ont la même période mais une amplitude différente.
Essayons d'améliorer ce résultat:

La fonction tracée en vert est f(t)=4π(sin(t)+13sin(3t))f(t)=4 π(sin(t)+13 sin(3 t)). Vous notez que sa forme se rapproche déjà plus de la forme du créneau. Continuons l'exercice :

La fonction tracée en rouge est f(t)=4π(sin(t)+13sin(3t)+15sin(5t))f(t)=4 π(sin(t)+13 sin(3 t)+15 sin(5 t)). Il y a encore une petite amélioration... Poussons maintenant l'exercie plus loin en tracant la courbe avec un nombre plus grand de sinusoïdes, 10 par exemple, et voyons ce que cela donne:

Donc, la fonction tracée est f(t)=4π(sin(t)+13sin(3t)+15sin(5t)+..+119sin(19t))f(t)=4 π(sin(t)+13 sin(3 t)+15 sin(5 t)+..+119 sin(19 t)). Son graphe se rapproche beaucoup de celui de la fonction créneau, n'est-ce pas ! En augmentant le nombre de termes, on s'en rapprochera de plus en plus ...
Mais me direz-vous, pourquoi avoir choisi ces termes en particulier ? Parce que j'ai un peu triché et que j'ai calculé la décomposition de Fourier avant pour connaitre les termes à utiliser !

Ce n'est qu'un exemple simple de ce que l'on peut faire en synthèse de signal en utilisant les séries de Fourier. Il est bien sur possible de produire d'autres signaux, comme une dent de scie, des escaliers et que sais-je encore !

Décomposer un signal en sinusoïdes

Voyons maintenant comment décomposer un signal en sinusoïdes, c'est à dire comment calculer les coefficients de la série de Fourier associée à la fonction f(t) qui définit le signal. Il n'est bien sur pas question de les calculer à la main, nous allons nous aider de Maple, avec le programme AnalyseFourier. Voilà la série qu'il propose pour un développement de la fonction créneau à l'ordre 19 :

4*sin(t)/Pi+(4/3)*sin(3*t)/Pi+(4/5)*sin(5*t)/Pi+(4/7)*sin(7*t)/Pi+(4/9)*sin(9*t)/Pi+(4/11)*sin(11*t)/Pi+(4/13)*sin(13*t)/Pi+(4/15)*sin(15*t)/Pi+(4/17)*sin(17*t)/Pi+(4/19)*sin(19*t)/Pi

Cela vous rappelle sans doute quelque chose...

Il est donc possible de décomposer n'importe quel signal périodique en une somme de sinus (ou d'exponentielles complexes), avec une précision arbitraire. Cette possibilité est largement utilisée en traitement du signal et dans certains appareils courants de traitement du son: un equalizer par exemple !

L'analyse spectrale

L'analyse spectrale fait son apparition dans le programme de TS, ce qui est une excellente chose ! En effet, c'est un des outils les plus répandus dans la "boite à outils" des physiciens. Dans le programme, il s'agit d'aborder la décomposition d'un son complexe en sons purs (superposition de sinusoïdes). Nous avons vu ce point ci-dessus. mais le programme mentionne aussi le spectre d'un signal. Il aborde la notion de spectre d'amplitude en présentant l'amplitude des différentes harmoniques d'un signal. Une anecdote : dans le "Sirius", il est question dans le texte d'un diagramme en batons (forme assez traditionnelle de présentation d'un spectre, que je vais présenter ci-dessous) alors que la figure proposée est un spectre continu, tel que le présente d'habitude un analyseur de spectres.

J'ai donc adapté mon programme AnalyseFourier afin qu'il produise le spectre d'amplitude et de puissance du signal créneau.

Spectre d'amplitude

Le spectre d'amplitude représente sous forme d'un batonnet, l'amplitude de chaque harmonique du signal. Ici, j'ai calculé et visualisé le spectre du créneau que nous avons traité dans les paragraphes ci-dessus, pour les harmoniques jusqu'au rang 19.

Comment est-il calculé ? Tout simplement en calculant le module des coefficients cn de la décomposition par l'analyse de Fourier. Pour rappel, cn est un nombre complexe égal à an - i*bn, et donc |cn| = sqrt(an2 + bn2).

On peut noter plusieurs points:

  • Comme on l'a constaté dans l'analyse de Fourier, le signal créneau ne possède que des harmoniques impaires, les harmoniques paires sont nulles. C'est une caractèristique de la fonction créneau... Le coefficient a0 est également nul (bien sur!).
  • Si vous comparez la valeur des coefficients résulant de l'analyse de Fourier et la valeur lue sur le spectre, vous constaterez leur identité. Par exemple, pour la fondamentale, le coefficient vaut 4/?, ce qui correspond bien à la valuer lue, soit 1,3 environ (1,27).
  • Notez la valeur relative de l'amplitude de la fondamentale et celle de la première harmonique, celle de rang 3: un rapport de 3 à 1. Puis l'amplitude des harmoniques de rang plus élevé décroit régulièrement. Notez aussi, que le signal creneau est assez riche en harmoniques (essayez de tracer le spectre pour les rangs supérieurs ...). C'est une caractéristique des signaux à fronts raides, qui sont riches en harmoniques.

Spectre de puissance

Le spectre de puissance donne une indication sur la répartition de l'énergie transportée par le signal en fonction de l'harmonique. Il s'obtient en calculant le carré du module de cn pour chaque harmonique.

On remarque qu'une partie écrasante de l'énergie est transportée par la fondamentale. Les autres harmoniques contribuent de manière négligeable, sauf la seconde harmonique (ici celle de rang 3).

Les spectres sont des outils très puissants dans la conception et l'analyse des systèmes de traitement du signal. Il existe des appareils électroniques perfectionnés qui fournissent en temps réel le spectre d'un signal (amplitude, phase ou puissance).


Série de Fourier

Vu dans ... http://www.silicium628.fr/cours/serie_fourier

Série de Fourier (1)

Approche graphique

Soit la fonction sinusoïdale:

f(x)= sin(x)

Ajoutons lui la fonction:

g(x)=1/3 sin (3x)

de fréquence 3 fois plus grande et d'amplitude trois fois plus petite

Puis ajoutons:

h(x)=1/5 sin (5x)

Puis ajoutons:

i(x)=1/7 sin (7x)

Puis ajoutons:

j(x)=1/9 sin (9x)

Puis ajoutons:

k(x)=1/11 sin (11x)

etc...

La courbe obtenue s'éloigne de plus en plus de la sinusoïde pour se rapprocher d'un rectangle dont les fronts de montée et de descente sont de plus en plus raides.

Si nous ajoutons des sinusoïdes suivant cette progression, en nombre infini, nous obtenons effectivement une fonction rectangulaire.

On peut obtenir n'importe quelle fonction périodique (rectangle, dent de scie, triangle, etc...) en choisissant judicieusement les coefficients pour les amplitudes et les fréquences.

Réciproquement ont peut décomposer n'importe quelle fonction périodique en une somme de fonctions sinusoïdales de fréquences multiples de celle de la fonction de départ, cette ensemble de fonctions formant ce qu'on appelle un développement en série de Fourier.

Toutefois la fonction de départ doit satisfaire à certaines conditions dites conditions de Dirichlet (fonction définie, périodique, continue ou comprenant un nombre fini de discontinuités.

Nous allons voir de quelle manière on peut calculer les coefficients, connaissant la fonction à obtenir.

page suivante...

Silicium628


Série de Fourier

Vu dans ... http://www.silicium628.fr/cours/serie_fourier

Série de Fourier (2)

Etude analytique

Nous avons entrevu graphiquement qu'il est possible de décomposer n'importe quelle fonction périodique répondant aux conditions de Dirichlet en une somme (infinie) de fonctions sinusoïdales de fréquences multiples de celle de la fonction de départ, cette ensemble de fonctions formant ce qu'on appelle un développement en série de Fourier. En pratique, on peut se contenter d'une suite finie de composantes pour approcher la fonction avec une précision voulue.

Intérêt du développement en série de Fourier:

Lorsqu'un signal périodique de forme quelconque est appliqué à l'entrée d'un système linéaire, il en ressort déformé si la fonction de transfert complexe n'est pas purement réelle. Mais un signal sinusoïdal pur, lui, ne sera pas déformé, il reste une sinusoïde pure à la sortie, de même fréquence. Cette sinusoïde n'aura pas forcément la même amplitude ni la même phase, mais la fréquence et la forme sont conservées.

Dès lors, le développement du signal en série de Fourier permet d' effectuer les calculs sur des sinusoïdes en les multipliant simplement et séparément par la fonction de transfert complexe du système. Pour connaître le signal en sortie, il suffit d'additionner ces différentes composantes sinusoïdales ainsi traitées.

D'autre part la décomposition des signaux en série de Fourier permet d'obtenir ce qu'on appelle le spectre du signal, formé par l'ensemble des composantes sinusoïdales, et représenté par des raies discrètes situées à des fréquences multiples de la fondamentale, appelées harmoniques. Et la connaissance de ce spectre permet d'évaluer la bande passante nécessaire au système lorsqu'il s'agit de transmettre le signal incident sans déformation.

Le développement en série de Fourier permet également d'analyser les systèmes de modulation et de transmission de données.

En électronique, la distorsion qui résulte de l'atténuation ou de la suppression de certains harmoniques (substantif masculin) de rang élevé est appelée distorsion harmonique.

1Etude analytique:

La décomposition d'une fonction [image] en série de Fourier s'écrit (en prenant t, le temps comme variable, mais ça peut être [image] vaiable d'espace dans le cas de traitement d'images par exemple, ou une autre variable):

étant la période de la fonction

et [image] la " pulsation "

On peut aussi l'écrire sous forme exponentielle complexe:

étant l'imaginaire pur, [image] (le [image] des mathématiciens)

1.1Calcul du coefficient

Commençons par la forme en sin-cos:

Pour le coefficient [image] rien de plus simple, il suffit d'intégrer [image] sur un intervalle égal à une période, tous les termes sinusoïdaux s'annulent, il reste [image] qui est la valeur moyenne de la fonction:

Donc nous obtenons la valeur du coefficient [image]:

J'avoue que j'ai décomposé toutes les étapes rien que pour le plaisir de voir toutes ces belles intégrales! En fait le résultat était évident dès le départ.

Remarque: Le calcul peut se faire sur n'importe quel intervalle de longueur d'une période,

[ [image]] et pas seulement [ [image]]

Précisons le seul point signifiant de ce calcul, à savoir l'intégrale définie de la fonction sinus sur une période:

Pourquoi [image] ?

est ma période;

Dés lors on peut écrire:

Or la fonction cosinus est périodique de période [image] et

ainsi que:

J'ai détaillé ce point parce qu'il sera réutilisé pour le calcul des autres coefficients.

De même nous avons:

Car

1.2Calcul des coefficients et

Pour les électroniciens et autre radio-amateurs, je ne résiste pas à l'envie de dévoiler que nous allons utiliser le principe de la démodulation synchrone pour chacune des harmoniques, en multipliant le signal par une fonction sinus de fréquence n-multiple de la fondamentale, suivie par une intégration. Mais on va le faire mathématiquement:

Rappel:
=

Multiplions donc notre fonction par [image] et intégrons:

On voit immédiatement que le premier terme est nul (voir calculs précédents)

il reste:

Deux cas sont à envisager:

1.2.1Cas

Si [image] alors tout s'annule. En effet on peut poser [image] et [image] et on retombe dans des calculs vu plus haut à savoir que les intégrales sur l'intervalle T de toutes ces sinusoïdes et cosinusoïdes s'annulent.

Si [image] , il n'en va pas de même:

1.2.2Cas n=p:

Donc le fait de multiplier par [image] permet de trouver les coefficients [image] qui valent donc:

Je vous laisse calculer les coefficients [image] en multipliant cette fois par [image] et vous obtiendrez:

1.3Fonctions paires et impaires:

Une fonction [image] est dite paire si

Elle est dite impaire si

(Une fonction peut n'être ni paire ni impaire)

Les fonctions impaires se décomposent en séries de Fourier ne comprenant que des termes en sinus.

Les fonctions paires se décomposent en séries de Fourier ne comprenant que des termes en cosinus plus éventuellement le terme constant.


Série de Fourier

Vu dans ... http://www.silicium628.fr/cours/serie_fourier

Série de Fourier (3)

Signal carré

Soit la fonction périodique « rectangulaire » (dite aussi « signal carré ») représentée sur la figure suivante.

C'est la fonction que nous avions obtenue lors de notre approche graphique des série de Fourier.

Cette fonction étant impaire ( [image]), elle se décompose en une série de Fourier ne comprenant que des termes en sinus:

La valeur moyenne de la fonction étant nulle, [image] est nul.

Calculons les coefficients [image] en appliquant les résultats obtenus précédemment:

L'intervalle [image] correspond à une période complète.

Calcul de

L'astuce, vous l'aurez remarqué, consiste à scinder l'intégrale en deux parties, pour lesquelles la fonction [image] a une valeur analytique bien déterminée (constante en l'occurrence, 1 et -1). Mais continuons,

sachant que: donc:

Le résultat diffère selon que

en effet:

Cas pair:

Donc il n'y a pas d'harmoniques de rang pair pour cette fonction carrée.

Cas impair:

(n=2k+1)

puisque

Nous obtenons la série de Fourrier suivante, pour ce signal carré:

ou encore:

Remarques:

Le facteur [image] montre que l'amplitude de la fréquence fondamentale est un peu supérieure à celle de la fonction carrée obtenue.

Nous retrouvons bien les amplitudes en 1/n et les harmoniques de rang n impairs uniquement, comme nous l'avions proposé lors de l'approche graphique.

Voici d'ailleurs cette synthèse graphique à laquelle j'ai rajouté une sinusoïde d'amplitude [image] qui vient en effet tangenter le signal carré (elle ne figure bien sûr pas dans la somme).

On remarquera les petites cornes à proximité de la discontinuité de la fonction. On pourrait penser qu'elles disparaissent lorsque le nombre de composantes augmente, il n'en est rien. C'est ce qu'on appelle le phénomène de Gibbs. Voir à ce propos cet article sur Wikipédia:
  • http://fr.wikipedia.org/wiki/Ph%C3%A9nom%C3%A8ne_de_Gibbs

L'ensemble des amplitudes de la fondamentale et des harmoniques en fonction de la fréquence peut être représenté sur un graphique que l'on appelle le spectre en fréquence du signal.

Voici ce spectre (vue d'artiste comme on dit) pour notre signal carré. Les amplitudes décroissent suivant une courbe en 1/f

En musique c'est la forme des signaux sonores et donc le contenu spectral qui constitue le timbre d'un instrument. C'est également ce qui permet de reconnaître les voix, et même ce qui permet de discerner l'information contenue dans le langage parlé, en ce qui concerne l'espèce humaine en tous cas. Les oiseaux quant à eux semblent plutôt utiliser des fréquences relativement pures, mais ô combien variées!

En électronique, l'appareil de mesure qui permet de visualiser ce spectre s'appelle un analyseur de spectre. Il peut être conçu suivant le principe mathématique à la base du calcul analytique des coefficients a et b, à savoir une multiplication du signal par un signal sinusoïdal de fréquence ajustable et connue puis une intégration qui peut être réalisée par un filtre passe bas ou un filtre de bande étroit centré sur la fréquence d'analyse. Un signal wobulé (à fréquence glissante) permet d'obtenir un balayage continu du spectre sur un écran d'oscilloscope. Il est également possible de numériser le signal à analyser et d'effectuer une transformée de Fourier dite "rapide " (FFT) grâce à une astuce conceptuelle. J'y reviendrai mais je voudrais au préalable vous parler de la transformée de Laplace.

Les transformées de Fourier (qui sont une extension des séries de Fourier pour les signaux non périodiques) ne sont pas que fréquentielles, elle peuvent aussi être spatiales, pour le traitement d'images par exemple.

Les transformées de Fourier constituent le domaine de l'analyse harmonique qui est une branche des mathématiques.

Liens externes:
  • http://fr.wikipedia.org/wiki/Séries_de_Fourier
  • http://fr.wikipedia.org/wiki/Analyse_harmonique_(mathématiques)
  • http://fr.wikipedia.org/wiki/Traitement_d'images


Série de Fourier

Vu dans ... http://www.silicium628.fr/cours/serie_fourier

Série de Fourier (4)

Signal triangulaire

Après le signal carré, analysons maintenant le signal triangulaire suivant:

Cette fonction étant paire ( [image]), elle se décompose en une série de Fourier ne comprenant que des termes en cosinus:

La valeur moyenne de la fonction étant nulle, [image] est nul.

Calcul des coefficients

L'intervalle [image] correspond à une période complète.

Astuce simplificatrice:

Puisque la fonction est symétrique par rapport à l'axe t=0 (elle est paire), on peut calculer l'intégrale définie sur l'intervalle [image] soit une demi période et multiplier par deux le résultat obtenu pour obtenir l'intégrale définie de

Sur la figure ci-dessous, nous avons:

Nous pouvons donc dans ce cas, écrire:

avec [image] pour

en effet (voir la figure pour la détermination de l'équation de cette droite):

Rappel: Intégration par parties:

posons:

si n est impair nous avons:

Si n est pair, le (-1) écrit en violet devient (+1) ce qui annule le coefficient [image] correspondant.

Il n'y a donc que des harmoniques impairs pour ce signal triangulaire.

Le série de Fourier de notre signal triangulaire est donc la suivante:

Voici le graphe de cette fonction synthétisé avec le logiciel libre Kmplot pour Linux

On voit que la série converge très rapidement vers la fonction triangulaire. Il faut dire qu'elle est très proche de la fonction - cosinus...

C'est aussi la raison pour laquelle il est facile d'obtenir un signal (presque) sinusoïdal en "rabotant" un signal triangulaire à l'aide de conposants non linéaires comme par exemple une diode dont on exploite la courbe du courant en fonction de la tension directe au voisinage du coude de conduction. Ce procédé est mis en oeuvre dans certains composants intégrés célèbres "générateurs de fonctions".

Autre méthode de calcul:

Ce signal triangulaire n'est autre que la primitive du signal carré étudié précédemment, et dont nous connaissons la série de Fourier. Et comme une série de Fourier est une somme de termes, rien de plus simple que d'en calculer l'intégrale.

Toutefois ce n'est pas la primitive de n'importe quelle fonction rectangulaire, et certainement pas de celle d'amplitude +/-1 !

La dérivée de notre signal triangulaire (c'est à dire la pente du triangle) doit être égale (par définition) à la valeur crête de la fonction rectangulaire.

La fonction triangulaire, nous l'avons vu plus haut peut s'écrire pour

La dérivée est donc:

Donc notre fonction triangulaire est la primitive de la fonction rectangulaire de valeur crête [image] ce qui aboutit à un calcul nettement plus simple que le calcul direct:

Nous pouvons donc écrire, sachant que

Après ça vous me direz que ce n'est pas beau les Maths ? Mais ce n'est pas tout:

Remarque: calcul de pi

Si on fait ω=0 [image] on obtient

et donc:

c'est à dire:

Ce qui conduit directement à une méthode pour calculer [image]:

Celle-là on ne l'avait pas vu venir, n'est-ce pas?

Mais à propos, est-ce bien exact?
J'ai programmé (vite fait...) une petite application en Pascal (sous le logiciel libre Lazarus (equiv. Open Source de Delphi) pour Linux) qui calcule cette suite en boucle et voici le résultat après l'avoir laissé tourner 15mn sur un Duron 4GHz et effectuer douze millions de pas:(on peut faire beaucoup mieux, j'i mis un timer 1ms pour pouvoir observer le défilement des décimales, c'est amusant...)

Soit 8 chiffres significatifs exacts, sachant que pour obtenir les suivants il suffit de laisser tourner plus longtemps.


Série de Fourier

Vu dans ... http://www.silicium628.fr/cours/serie_fourier

Série de Fourier (5)

FORME COMPLEXE

Il existe une autre forme de développement d'une fonction en série de Fourier: le développement en série de Fourier complexe,
dite aussi sous « forme exponentielle »

Nous avons vu que lorsqu'une fonction est paire (ou impaire), son développement en série de Fourier réelle ne comporte que des termes en cosinus (ou respectivement en sinus). Toutefois certaines fonctions, bien que périodiques, ne sont ni paires ni impaires, et dans ce cas il y a à la fois des termes en sinus et en cosinus. Il est alors plus simple pour ces fonctions de calculer le développement en série de Fourier complexe. On en déduit ensuite simplement les coefficients de la transformée réelle.

Mais commençons par calculer les coefficients complexes

Procédons d'une manière analogue à celle utilisée pour le calcul des coefficients réel, à savoir l'intégration sur une période du produit de [image] par (en l'occurrence) une exponentielle complexe de la fréquence concernée (avec un petit signe - pour que ça marche du premier coup! ce qui revient en fait à diviser...):

soit donc la période [image] telle que [image] comme vu à maintes reprises.

La somme comprend toutes les fréquences multiples de [image] (c'est à dire les fréquences [image]) alors que nous multiplions l'ensemble par une seule fréquence

or

et en particulier:

Notre intégrale devient:

Donc dans le cas où [image] l'intégrale est nulle.

Mais ce n'est pas le cas si [image] :

cas

Nous en déduisons la valeur des coefficients

Rappelons que

Remarque:

est donc la valeur moyenne de la fonction.

Correspondance entre les coefficients DSF réels et DSF complexes:

DSF réelle | DSF complexe

Nous en déduisons les relations suivantes:

Et dans l'autre sens:


Série de Fourier

Vu dans ... http://www.silicium628.fr/cours/serie_fourier

Série de Fourier (6)

Développement en série de Fourier complexe

Signal carré

Rappel:

Donc pour [image] impair [image] :

(Pour n pair, tout s'annule).

On remarque que la partie réelle de [image] est nulle, [image] est imaginaire pur, donc le développement en série de Fourier à coefficients réels ne comporte que des sinus, de rangs impairs puisque n est impair.

En appliquant la formule de correspondance entre DSF complexe et DSF réel, nous obtenons:

Nous retrouvons le développement en série de Fourier réel tel qui nous l'avions précédemment obtenu par le calcul direct des coefficients réels: