Sommaire

BONJOUR
Musique "Invention BWV784" J.S. BACH 1685-1750

Tutoriel et Help

MATHEMATIQUES

Nous veillons aux respects des droits d'auteur : si par erreur un contenu protégé est disponible sans indication sur ce site, merci de contacter l'administrateur, il sera retiré ou mis à jour dans les plus brefs délais.


Accueil

Accueil CHM

Normal, dit comme ça,
vous ne risquez pas de comprendre.


Matrice (mathématiques) — Wikipédia

Matrice (mathématiques)

Un article de Wikipédia, l'encyclopédie libre.
Aller à : navigation, rechercher
Page d’aide sur l’homonymie L’article Théorie des matrices présente des applications pratiques des matrices.
Page d'aide sur l'homonymie Pour les articles homonymes, voir Matrice.

En mathématiques, les matrices sont des tableaux de nombres qui servent à interpréter en termes calculatoires et donc opérationnels les résultats théoriques de l'algèbre linéaire et même de l'algèbre bilinéaire. Toutes les disciplines étudiant des phénomènes linéaires utilisent les matrices. Quant aux phénomènes non linéaires, on en donne souvent des approximations linéaires, comme en optique géométrique avec les approximations de Gauss.

Sommaire

[masquer]
  • 1 Historique
    • 1.1 Histoire de la notion de matrice
    • 1.2 Histoire des déterminants
    • 1.3 Autres utilisations mathématiques du mot « matrice »
  • 2 Définitions
  • 3 Espaces de matrices
    • 3.1 Addition et multiplication par un scalaire
      • 3.1.1 Base canonique de l'espace des matrices
    • 3.2 Produit matriciel
      • 3.2.1 Matrice identité et inverse d'une matrice
    • 3.3 Algèbre des matrices carrées
    • 3.4 Actions du groupe linéaire
  • 4 Interprétations linéaires
    • 4.1 Coordonnées
    • 4.2 Applications linéaires
      • 4.2.1 Transposition
      • 4.2.2 Remarque
    • 4.3 Systèmes d'équations linéaires
  • 5 Interprétations bilinéaires
    • 5.1 Matrice d'une forme bilinéaire
    • 5.2 Matrice d'une forme quadratique
    • 5.3 Formule de changement de base
    • 5.4 Matrices congruentes
  • 6 Catalogue partiel
  • 7 Décomposition d'une matrice
    • 7.1 Réduction d'une matrice carrée
    • 7.2 Décomposition LU
    • 7.3 Décomposition QR
    • 7.4 Décomposition polaire
  • 8 Normes
    • 8.1 Normes d'algèbre
    • 8.2 Structure d'espace vectoriel euclidien
  • 9 Exponentielle d'une matrice
  • 10 Notes et références
  • 11 Voir aussi
    • 11.1 Bibliographie
    • 11.2 Articles connexes
    • 11.3 Liens externes

Historique[ modifier | modifier le code ]

Histoire de la notion de matrice[ modifier | modifier le code ]

Bien que le calcul matriciel proprement dit n'apparaisse qu'au début du XIXe siècle, les matrices, en tant que tableaux de nombres, ont une longue histoire d'applications à la résolution d'équations linéaires. Le texte chinois Les Neuf Chapitres sur l'art mathématique, écrit vers le IIe siècle av. J.-C., est le premier exemple connu de l'utilisation de tableaux pour résoudre des systèmes d'équations [1], introduisant même le concept de déterminant. En 1545, Girolamo Cardano fait connaître cette méthode en Europe en publiant son Ars Magna[2]. Le mathématicien japonais Seki Kōwa utilise indépendamment les mêmes techniques pour résoudre des systèmes d'équations en 1683[3]. Aux Pays-Bas, Johan de Witt représente des transformations géométriques à l'aide de tableaux dans son livre de 1659, Elementa curvarum linearum[2]. Entre 1700 et 1710, Leibniz montre comment utiliser les tableaux pour noter des données ou des solutions, et expérimente plus de 50 systèmes de tableaux à cet effet[2]. En 1750, Gabriel Cramer publie la règle qui porte son nom [4].

En 1850, le terme de « matrix » (qui sera traduit par matrice) est forgé (sur la racine latine mater) par James Joseph Sylvester [5], qui le voit comme un objet donnant naissance à la famille de déterminants actuellement appelés mineurs, c'est-à-dire les déterminants des sous-matrices obtenues en retirant des lignes et des colonnes. Dans un article de 1851, Sylvester précise :

« Dans des articles antérieurs, j'ai appelé matrix un tableau rectangulaire de termes à partir desquels plusieurs systèmes de déterminants peuvent être engendrés, comme issus des entrailles d'un parent commun »[6].

En 1854, Arthur Cayley publie un traité sur les transformations géométriques utilisant les matrices de façon beaucoup plus générale que tout ce qui a été fait avant lui. Il définit les opérations usuelles du calcul matriciel (addition, multiplication et division) et montre les propriétés d'associativité et de distributivité de la multiplication[2]. Jusque là, l'utilisation des matrices s'était essentiellement limité au calcul des déterminants ; cette approche abstraite des opérations sur les matrices est révolutionnaire. En 1858, Cayley publie son A Memoir on the Theory of Matrices[7],[8], dans lequel il énonce et démontre le théorème de Cayley-Hamilton [2] pour les matrices 2×2.

Beaucoup de théorèmes ne sont d'ailleurs démontrés au début que pour de petites matrices : après Cauchy, Hamilton généralise le théorème aux matrices 4×4, et ce n'est qu'en 1898 que Frobenius, étudiant les formes bilinéaires, démontre le théorème en dimension quelconque. C'est aussi à la fin du XIXe siècle que Wilhelm Jordan établit la méthode d'élimination de Gauss-Jordan (généralisant la méthode de Gauss pour les matrices échelonnées). Au début du XXe siècle, les matrices occupent une place centrale en algèbre linéaire [9], en partie grâce au rôle qu'elles jouent dans la classification des systèmes de nombres hypercomplexes du siècle précédent.

Un mathématicien anglais du nom de Cullis est le premier, en 1913, à utiliser la notation moderne des crochets (ou des parenthèses) pour représenter les matrices, ainsi que de la notation systématique A = [ai,j] pour représenter la matrice dont ai,j est le terme de la i-ème ligne et de la j-ème colonne[2].

La formulation de la mécanique quantique au moyen de la mécanique matricielle, due à Heisenberg, Born et Jordan, amena à étudier des matrices comportant un nombre infini de lignes et de colonnes[10]. Par la suite, von Neumann précisa les fondements mathématiques de la mécanique quantique, en remplaçant ces matrices par des opérateurs linéaires sur des espaces de Hilbert.

Histoire des déterminants[ modifier | modifier le code ]

Article détaillé : Histoire des déterminants

L'étude théorique des déterminants vient de plusieurs sources[11]. Des problèmes de théorie des nombres amènent Gauss à relier à des matrices (ou plus précisément à leur déterminant) les coefficients d'une forme quadratique ainsi que les applications linéaires en dimension trois. Gotthold Eisenstein développe ces notions, remarquant en particulier qu'en notation moderne, le produit des matrices est non-commutatif. Cauchy est le premier à démontrer des résultats généraux sur les déterminants, en utilisant comme définition du déterminant de la matrice A = [ai,j] le résultat de la substitution, dans le polynôme a 1 a 2 ⋯ a n ∏ i < j ( a j − a i ) {\displaystyle a_{1}a_{2}\cdots a_{n}\prod _{i<j}(a_{j}-a_{i})\;} [image] , des puissances ajk par ajk. Il montre aussi, en 1829, que les valeurs propres d'une matrice symétrique sont réelles[12]. Jacobi étudie les « déterminants fonctionnels » (appelés par la suite jacobiens par Sylvester), utilisés pour décrire des transformations géométriques d'un point de vue infinitésimal ; les livres Vorlesungen über die Theorie der Determinanten[13] de Leopold Kronecker et Zur Determinantentheorie[14] de Karl Weierstrass, tous deux publiés en 1903, définissent pour la première fois les déterminants de manière axiomatique comme formes multilinéaires alternées.

Autres utilisations mathématiques du mot « matrice »[ modifier | modifier le code ]

Deux mathématiciens notables au moins ont utilisé le mot dans un sens inhabituel.

Bertrand Russell et Alfred North Whitehead, dans leur Principia Mathematica, utilisent le mot « matrice » dans le cadre de leur axiome de réductibilité (en). Cet axiome permet de réduire le type d'une fonction, les fonctions de type 0 étant identiques à leur extension (en) ; ils appellent « matrice » une fonction n'ayant que des variables libres [15]. Ainsi, par exemple, une fonction Φ(x, y) de deux variables x et y peut être réduite à une collection de fonctions d'une seule variable, par exemple y, en “considérant” la fonction pour toutes les valeurs ai substituées à la variable x puis réduite à une « matrice » de valeurs en procédant de même pour y : ∀bj∀ai: Φ(ai, bj).

Alfred Tarski, dans son Introduction à la logique de 1946, utilise le mot « matrice » comme un synonyme de table de vérité [16].

Définitions[ modifier | modifier le code ]

Une matrice à m lignes et n colonnes est un tableau rectangulaire de m × n nombres, rangés ligne par ligne. Il y a m lignes, et dans chaque ligne n nombres.

Plus formellement et plus généralement, soient I, J et K trois ensembles (K sera souvent muni d'une structure d'anneau ou même de corps commutatif).

On appelle matrice de type (I, J)[17] à coefficients dans K, toute famille d'éléments de K indexée par le produit cartésien I × J, c'est-à-dire toute application A de I × J dans K.

Le plus souvent, comme dans toute la suite de cet article, les ensembles I et J sont finis et même égaux à des ensembles de nombres entiers {1, …, m} et {1, …, n}. Dans ce cas, on dit que la matrice a m lignes et n colonnes, ou qu'elle est de dimension ou taille (m, n). En notant ai,j l'image d'un couple (i, j) par l'application A, la matrice peut alors être notée

A = ( a i , j ) 1 ≤ i ≤ m , 1 ≤ j ≤ n {\displaystyle A=(a_{i,j})_{1\leq i\leq m,1\leq j\leq n}}

ou plus simplement (ai,j) si le contexte s'y prête.

On représente généralement une matrice sous la forme d'un tableau rectangulaire. Par exemple, est représentée ci-dessous une matrice A, à coefficients entiers, et de dimension (3,4) :

A = ( 0 1 2 3 4 5 6 7 8 9 10 11 ) {\displaystyle A={\begin{pmatrix}0&1&2&3\\4&5&6&7\\8&9&10&11\\\end{pmatrix}}}

Dans cette représentation, le premier coefficient de la dimension est le nombre de lignes, et le deuxième, le nombre de colonnes du tableau. Une matrice pour laquelle le nombre m de lignes est égal au nombre n de colonnes sera dite matrice carrée de taille (ou d’ordre) n. Une matrice ne comportant qu'une seule ligne et n colonnes est appelée matrice ligne de taille n. Une matrice comportant m lignes et une seule colonne est appelée matrice colonne de taille m.

Pour repérer un coefficient d'une matrice, on indique son indice de ligne puis son indice de colonne, les lignes se comptant du haut vers le bas et les colonnes de la gauche vers la droite. Par exemple, on notera ai,j, les coefficients de la matrice A, i compris entre 1 et 3 désignant le numéro de la ligne sur laquelle figure le coefficient envisagé, et j compris entre 1 et 4 désignant son numéro de colonne ; ainsi a2,4=7.

La disposition générale des coefficients d'une matrice A de taille (m,n) est donc la suivante

A = ( a 1 , 1 a 1 , 2 ⋯ a 1 , n a 2 , 1 a 2 , 2 ⋯ a 2 , n ⋮ ⋮ ⋱ ⋮ a m , 1 a m , 2 ⋯ a m , n ) {\displaystyle A={\begin{pmatrix}a_{1,1}&a_{1,2}&\cdots &a_{1,n}\\a_{2,1}&a_{2,2}&\cdots &a_{2,n}\\\vdots &\vdots &\ddots &\vdots \\a_{m,1}&a_{m,2}&\cdots &a_{m,n}\\\end{pmatrix}}}

Les coefficients a i , j {\displaystyle a_{i,j}} [image] avec i = j {\displaystyle i=j} [image] sont dits diagonaux, ceux avec i ≠ j {\displaystyle i\neq j} [image] sont dits extradiagonaux.

Une sous-matrice de A {\displaystyle A} A est une matrice obtenue en sélectionnant une partie I ⊂ { 1 , … , m } {\displaystyle I\subset \{1,\ldots ,m\}} [image] de ses lignes et une partie J ⊂ { 1 , … , n } {\displaystyle J\subset \{1,\ldots ,n\}} [image] de ses colonnes ; on la note A I , J {\displaystyle A_{I,J}} [image] . On dit qu'une sous-matrice est principale si I = J {\displaystyle I=J} [image] dans la définition précédente. La diagonale de A {\displaystyle A} A est le vecteur

diag ⁡ ( A ) := ( a 1 , 1 a 2 , 2 ⋮ a p , p ) , {\displaystyle \operatorname {diag} (A):={\begin{pmatrix}a_{1,1}\\a_{2,2}\\\vdots \\a_{p,p}\end{pmatrix}},}

où p := min ( m , n ) {\displaystyle p:=\min(m,n)} [image] .

Pour effectuer certaines opérations, il peut être utile de travailler sur le système des lignes ou des colonnes d'une matrice. On pourra alors l'écrire sous une des formes suivantes

A = ( L 1 L 2 ⋮ L m ) {\displaystyle A={\begin{pmatrix}L_{1}\\L_{2}\\\vdots \\L_{m}\\\end{pmatrix}}} [image] ou A = ( C 1 C 2 … C n ) . {\displaystyle A={\begin{pmatrix}C_{1}&C_{2}&\dots &C_{n}\\\end{pmatrix}}.}

L'ensemble des matrices à coefficients dans K possédant m lignes et n colonnes est noté M m , n ( K ) {\displaystyle M_{m,n}(K)} [image] (ou parfois M ( m , n , K ) {\displaystyle M(m,n,K)} M(m,n,K) ).

Lorsque m = n on note plus simplement M n ( K ) {\displaystyle M_{n}(K)} [image] .

Soit K un ensemble et A = ( a i , j ) 1 ≤ i ≤ m , 1 ≤ j ≤ n ∈ M m , n ( K ) {\displaystyle A=(a_{i,j})_{1\leq i\leq m,\ 1\leq j\leq n}\in M_{m,n}(K)} [image] ; on appelle matrice transposée de A {\displaystyle A} A la matrice A T = ( a j , i ) 1 ≤ j ≤ n , 1 ≤ i ≤ m ∈ M n , m ( K ) {\displaystyle A^{\mathsf {T}}=(a_{j,i})_{1\leq j\leq n,\ 1\leq i\leq m}\in M_{n,m}(K)} [image] . Si K est un magma, A T = ( a j , i ) 1 ≤ j ≤ n , 1 ≤ i ≤ m ∈ M n , m ( K o p ) {\displaystyle A^{\mathsf {T}}=(a_{j,i})_{1\leq j\leq n,\ 1\leq i\leq m}\in M_{n,m}(K^{op})} [image] où K o p {\displaystyle K^{op}} [image] est le magma opposé de K.

Par exemple, avec la matrice A des exemples précédents, on a

A T = ( 0 4 8 1 5 9 2 6 10 3 7 11 ) . {\displaystyle A^{\mathsf {T}}={\begin{pmatrix}0&4&8\\1&5&9\\2&6&10\\3&7&11\\\end{pmatrix}}.}

Espaces de matrices[ modifier | modifier le code ]

On suppose maintenant que K est muni d'une structure d'anneau ; les éléments de K seront appelés scalaires, par opposition aux matrices dont nous allons voir qu'elles peuvent être considérées comme des vecteurs.

Addition et multiplication par un scalaire[ modifier | modifier le code ]

On définit sur M m , n ( K ) {\displaystyle M_{m,n}(K)} [image] une loi de composition interne provenant de l'addition des scalaires :

( a i , j ) + ( b i , j ) = ( c i , j ) {\displaystyle (a_{i,j})+(b_{i,j})=(c_{i,j})} [image] , où c i , j = a i , j + b i , j {\displaystyle c_{i,j}=a_{i,j}+b_{i,j}} [image] .

On ne peut additionner que deux matrices de même taille.

  • Exemple :
( 0 1 2 3 4 5 6 7 ) + ( 0 0 1 1 0 1 0 1 ) = ( 0 1 3 4 4 6 6 8 ) {\displaystyle {\begin{array}{l}{\begin{pmatrix}0&1&2&3\\4&5&6&7\\\end{pmatrix}}+{\begin{pmatrix}0&0&1&1\\0&1&0&1\\\end{pmatrix}}={\begin{pmatrix}0&1&3&4\\4&6&6&8\\\end{pmatrix}}\end{array}}}

Pour chaque valeur du couple (m, n), l'espace M m , n ( K ) {\displaystyle M_{m,n}(K)} [image] devient alors un groupe abélien, d'élément neutre la matrice nulle, celle dont tous les coefficients valent 0.

On définit aussi une opération à droite de K sur chaque espace M m , n ( K ) {\displaystyle M_{m,n}(K)} [image] en associant, à chaque scalaire λ dans K et à chaque matrice ( a i , j ) {\displaystyle (a_{i,j})} [image] à coefficients dans K, la matrice ( a i , j ) λ = ( a i , j λ ) {\displaystyle (a_{i,j})\lambda =(a_{i,j}\lambda )} [image] obtenue en effectuant la multiplication à droite, dans K, de tous les coefficients de la matrice initiale par λ {\displaystyle \lambda } [image] : c'est la multiplication par un scalaire. Lorsque l'anneau est commutatif, la multiplication peut également s'effectuer à gauche.

En reprenant toujours la matrice A du premier exemple :

2 A = ( 0 2 4 6 8 10 12 14 16 18 20 22 ) {\displaystyle 2A={\begin{pmatrix}0&2&4&6\\8&10&12&14\\16&18&20&22\\\end{pmatrix}}}

Les espaces M m , n ( K ) {\displaystyle M_{m,n}(K)} [image] ainsi obtenus ont donc une structure de K-module à droite, et plus particulièrement de K-espace vectoriel, si K est un corps commutatif.

Base canonique de l'espace des matrices[ modifier | modifier le code ]

Le K-module M m , n ( K ) {\displaystyle M_{m,n}(K)} [image] est libre de rang mn,, c'est-à-dire qu'il possède une base de mn éléments : il suffit de considérer la base canonique ( E i , j ) 1 ⩽ i ⩽ m , 1 ⩽ j ⩽ n {\displaystyle (E_{i,j})_{1\leqslant i\leqslant m,\ 1\leqslant j\leqslant n}} [image] . La matrice E i , j {\displaystyle E_{i,j}} [image] est celle dont tous les coefficients sont nuls sauf celui d'indice ( i , j ) {\displaystyle (i,j)} (i,j) , qui vaut 1.

Les coordonnées dans la base canonique d'une matrice A sont ses coefficients :

A = ∑ 1 ⩽ i ⩽ n 1 ⩽ j ⩽ p a i , j E i , j {\displaystyle A=\sum _{1\leqslant i\leqslant n \atop 1\leqslant j\leqslant p}a_{i,j}E_{i,j}}
  • Exemple (cas commutatif) :

( 0 1 2 4 3 1 ) = 0 ⋅ ( 1 0 0 0 0 0 ) + 1 ⋅ ( 0 1 0 0 0 0 ) + 2 ⋅ ( 0 0 1 0 0 0 ) + 4 ⋅ ( 0 0 0 1 0 0 ) + 3 ⋅ ( 0 0 0 0 1 0 ) + 1 ⋅ ( 0 0 0 0 0 1 ) {\displaystyle {\begin{pmatrix}0&1&2\\4&3&1\\\end{pmatrix}}=0\cdot {\begin{pmatrix}1&0&0\\0&0&0\\\end{pmatrix}}+1\cdot {\begin{pmatrix}0&1&0\\0&0&0\\\end{pmatrix}}+2\cdot {\begin{pmatrix}0&0&1\\0&0&0\\\end{pmatrix}}+4\cdot {\begin{pmatrix}0&0&0\\1&0&0\\\end{pmatrix}}+3\cdot {\begin{pmatrix}0&0&0\\0&1&0\\\end{pmatrix}}+1\cdot {\begin{pmatrix}0&0&0\\0&0&1\\\end{pmatrix}}}

Produit matriciel[ modifier | modifier le code ]

Article détaillé : Produit matriciel.

On commence par définir le produit d'une matrice ligne par une matrice colonne[18],[19]. Soit n un nombre entier, L une matrice ligne, xi ses coefficients, C une matrice colonne, yi ses coefficients. On les suppose toutes deux de taille n. On définit alors le produit, considéré comme un scalaire ou une matrice de dimension (1, 1) :

L C = ( x 1 … x n ) ( y 1 ⋮ y n ) = ∑ 1 ≤ i ≤ n x i y i {\displaystyle LC={\begin{pmatrix}x_{1}&\dots &x_{n}\end{pmatrix}}{\begin{pmatrix}y_{1}\\\vdots \\y_{n}\end{pmatrix}}=\sum _{1\leq i\leq n}x_{i}y_{i}}

On remarque la condition de compatibilité sur les tailles des matrices (égalité du nombre de colonnes de la première avec le nombre de lignes de la deuxième). On définit maintenant plus généralement un produit entre deux matrices, la première, (xi,j) dans Mm,n(K), la deuxième, (yi,j) dans Mn,p(K), toujours avec une condition de compatibilité sur les tailles (et l'ordre des facteurs de la multiplication ne peut en général pas être changé). Le résultat obtenu est une matrice de Mm,p(K), dont les coefficients (zi,j) sont obtenus par :

z i , j = ∑ 1 ≤ k ≤ n x i , k y k , j = x i , 1 y 1 , j + x i , 2 y 2 , j + ⋯ + x i , n y n , j {\displaystyle z_{i,j}=\sum _{1\leq k\leq n}x_{i,k}y_{k,j}=x_{i,1}y_{1,j}+x_{i,2}y_{2,j}+\cdots +x_{i,n}y_{n,j}}

À la lumière de l'exemple de la multiplication d'une matrice ligne par une matrice colonne, on peut reformuler cette définition en disant que ce coefficient est égal au produit de la ligne i de la première matrice par la colonne j de la deuxième, ce qui s'écrit de la manière suivante, si les Li sont les lignes de la première matrice, et les Cj les colonnes de la deuxième, le produit est : ( L 1 ⋮ L m ) ( C 1 … C p ) = ( L 1 C 1 L 1 C 2 … L 1 C p L 2 C 1 L 2 C 2 … L 2 C p ⋮ ⋮ ⋮ L m C 1 L m C 2 … L m C p ) {\displaystyle {\begin{pmatrix}L_{1}\\\vdots \\L_{m}\end{pmatrix}}{\begin{pmatrix}C_{1}&\dots &C_{p}\end{pmatrix}}={\begin{pmatrix}L_{1}C_{1}&L_{1}C_{2}&\dots &L_{1}C_{p}\\L_{2}C_{1}&L_{2}C_{2}&\dots &L_{2}C_{p}\\\vdots &\vdots &&\vdots \\L_{m}C_{1}&L_{m}C_{2}&\dots &L_{m}C_{p}\\\end{pmatrix}}} [image] .

Le produit matriciel est associatif, distributif à droite et à gauche par rapport à l'addition matricielle. En revanche, même lorsque les dimensions permettent de donner un sens à la question et même si l'anneau des scalaires est commutatif, un produit de matrices ne commute en général pas : AB n'est pas en général égal à BA, par exemple :

A = ( 0 0 1 0 ) B = ( 1 0 0 0 ) A B = ( 0 0 1 0 ) B A = ( 0 0 0 0 ) . {\displaystyle A={\begin{pmatrix}0&0\\1&0\end{pmatrix}}\quad B={\begin{pmatrix}1&0\\0&0\\\end{pmatrix}}\quad AB={\begin{pmatrix}0&0\\1&0\\\end{pmatrix}}\quad BA={\begin{pmatrix}0&0\\0&0\\\end{pmatrix}}.}

Remarque : le produit de deux matrices non nulles peut être nul, comme l'exemple au-dessus.

Il arrive même, selon les tailles respectives des matrices A et B, que l'un des deux produits existe et pas l'autre.

La transposition et le produit matriciel sont compatibles au sens suivant :

∀ A ∈ M n , p ( K ) , ∀ B ∈ M p , q ( K ) , ( A B ) T = B T ⋅ A T {\displaystyle \forall A\in M_{n,p}(K),\ \forall B\in M_{p,q}(K),\ \left(AB\right)^{\mathsf {T}}=B^{\mathsf {T}}\cdot A^{\mathsf {T}}}

(même si l'anneau K n'est pas commutatif, en se rappelant que les matrices transposées ont leurs coefficients dans l'anneau opposé Kop).

Matrice identité et inverse d'une matrice[ modifier | modifier le code ]

Articles détaillés : Matrice identité et Matrice inversible.

Pour chaque nombre entier n, on note In la matrice carrée de taille n dont les coefficients diagonaux sont égaux à 1 et dont les autres coefficients sont nuls ; elle est appelée matrice identité de taille n.

I 1 = ( 1 ) I 2 = ( 1 0 0 1 ) I 3 = ( 1 0 0 0 1 0 0 0 1 ) I n = ( δ i , j ) 1 ≤ i ≤ n , 1 ≤ j ≤ n {\displaystyle I_{1}={\begin{pmatrix}1\end{pmatrix}}\quad I_{2}={\begin{pmatrix}1&0\\0&1\end{pmatrix}}\quad I_{3}={\begin{pmatrix}1&0&0\\0&1&0\\0&0&1\end{pmatrix}}\quad I_{n}=(\delta _{i,j})_{1\leq i\leq n,1\leq j\leq n}}

où δi,j désigne le symbole de Kronecker.

Sous réserve de compatibilité des tailles, les matrices In sont neutres à droite et à gauche pour la multiplication.

∀ A ∈ M m , n ( K ) , I m A = A I n = A . {\displaystyle \forall A\in M_{m,n}(K),\ I_{m}\,A=A\,I_{n}=A.}

Soit A une matrice de dimension (m, n). On dit que A est inversible à droite (respectivement à gauche) s'il existe une matrice B de taille (n, m) telle que AB = Im (respectivement BA = In). Elle est simplement dite inversible si elle l'est à la fois à droite et à gauche. Le sous-ensemble de Mn(K) constitué des matrices inversibles possède une structure de groupe pour le produit matriciel ; il est appelé groupe linéaire et noté GLn(K).

Pour une matrice carrée à coefficients dans un anneau commutatif K, être inversible à droite ou à gauche ou avoir un déterminant inversible dans K (c'est-à-dire non nul si K est un corps) sont trois propriétés équivalentes.

Algèbre des matrices carrées[ modifier | modifier le code ]

Lorsque l'anneau K est commutatif, l'ensemble M n ( K ) {\displaystyle M_{n}(K)} [image] des matrices carrées de taille n est donc muni d'une structure de K-algèbre associative et unitaire avec l'addition matricielle, le produit par un scalaire et le produit matriciel.

On appelle matrice scalaire une matrice de la forme I n λ {\displaystyle I_{n}\lambda } [image] où λ est un élément de l'anneau K.

I n a = ( a 0 … 0 0 a … 0 ⋮ ⋮ ⋱ ⋮ 0 0 … a ) {\displaystyle I_{n}a={\begin{pmatrix}a&0&\dots &0\\0&a&\dots &0\\\vdots &\vdots &\ddots &\vdots \\0&0&\dots &a\end{pmatrix}}}

Ces matrices s'appellent matrices scalaires car elles se comportent comme des scalaires, vis-à-vis de la multiplication :

∀ λ ∈ K , ∀ A ∈ M n ( K ) , A ( I n λ ) = A λ . {\displaystyle \forall \lambda \in K,\ \forall A\in M_{n}(K),\ A(I_{n}\lambda )=A\lambda ~.}

Lorsque K est commutatif, ou à défaut, lorsque λ est central dans K, c'est-à-dire lorsque λ commute avec tous les éléments de K, on a en outre :

∀ λ ∈ K , ∀ A ∈ M n ( K ) , ( λ I n ) A = A λ . {\displaystyle \forall \lambda \in K,\ \forall A\in M_{n}(K),(\lambda I_{n})\ A=A\lambda ~.}

Réciproquement, toute matrice B {\displaystyle B} B de M n ( K ) {\displaystyle M_{n}(K)} [image] telle que ∀ A ∈ M n ( K ) , A B = B A {\displaystyle \forall A\in M_{n}(K),\ AB=BA} [image] est une matrice scalaire I n λ {\displaystyle I_{n}\lambda } [image] où λ est central dans K (ceci se démontre en prenant pour A les matrices de la base canonique).

Une matrice de la forme :

( a 1 0 … 0 0 a 2 … 0 ⋮ ⋮ ⋱ ⋮ 0 0 … a n ) {\displaystyle {\begin{pmatrix}a_{1}&0&\dots &0\\0&a_{2}&\dots &0\\\vdots &\vdots &\ddots &\vdots \\0&0&\dots &a_{n}\end{pmatrix}}}

sera dite matrice diagonale.

Outre le déterminant, une autre fonction à noter est la trace. Toutes deux apparaissent dans un objet plus général, le polynôme caractéristique, qui à son tour permet d'obtenir certaines caractérisations des matrices diagonalisables (c'est-à-dire semblables à une matrice diagonale), ou de la trigonalisation.

Actions du groupe linéaire[ modifier | modifier le code ]

Articles détaillés : Action de groupe, Matrices équivalentes et Matrices semblables.

Il existe plusieurs manières de faire agir le groupe linéaire G L n ( K ) {\displaystyle GL_{n}(K)} [image] sur les espaces de matrices, notamment :

  • action par multiplication à gauche de G L m ( K ) {\displaystyle GL_{m}(K)} [image] sur M m , n ( K ) {\displaystyle M_{m,n}(K)} [image] , qui à P et A, associe PA,
  • action (à droite) par multiplication à droite de G L n ( K ) {\displaystyle GL_{n}(K)} [image] sur M m , n ( K ) {\displaystyle M_{m,n}(K)} [image] , qui à Q ∈ G L n ( K ) {\displaystyle Q\in GL_{n}(K)} [image] et A ∈ M m , n ( K ) {\displaystyle A\in M_{m,n}(K)} [image] , associe A Q − 1 {\displaystyle AQ^{-1}} [image] ,
  • action par conjugaison de G L n ( K ) {\displaystyle GL_{n}(K)} [image] sur M n ( K ) {\displaystyle M_{n}(K)} [image] , qui à P ∈ G L n ( K ) {\displaystyle P\in GL_{n}(K)} [image] et A ∈ M n ( K ) {\displaystyle A\in M_{n}(K)} [image] , associe P A P − 1 {\displaystyle PAP^{-1}} [image] .

On décrit maintenant les résultats classiques sur ces actions, lorsque les scalaires forment un corps commutatif. Les deux premières actions sont souvent considérées simultanément ; on s'intéresse donc à la question : deux matrices A et B de dimension (m,n) étant données, existe-t-il des matrices P ∈ G L m ( K ) {\displaystyle P\in GL_{m}(K)} [image] et Q ∈ G L n ( K ) {\displaystyle Q\in GL_{n}(K)} [image] telles que A = P B Q − 1 {\displaystyle A=PBQ^{-1}} [image] ? Si tel est le cas, les deux matrices A et B sont dites équivalentes. Le résultat principal est que deux matrices sont équivalentes si et seulement si elles ont même rang, ce qui s'exprime encore en disant que le rang est un invariant complet pour les doubles classes définies par les deux actions de multiplication à gauche et à droite. Par ailleurs, une matrice étant donnée, on peut trouver d'autres matrices privilégiées (les matrices échelonnées) dans la même orbite pour une de ces actions par la méthode du pivot de Gauss.

Pour l'action par conjugaison, deux matrices carrées A et B de taille n dans la même orbite admettent une relation de la forme A = P B P − 1 {\displaystyle A=PBP^{-1}} [image] , pour une certaine matrice P inversible de taille n ; deux telles matrices sont dites semblables. La description d'un système complet d'invariants est plus délicate. On appelle ces invariants les invariants de similitude. D'un point de vue algorithmique, la réduction d'une matrice quelconque à une matrice sous une forme privilégiée se fait par un algorithme inspiré de celui du pivot de Gauss, voir théorème des facteurs invariants.

Interprétations linéaires[ modifier | modifier le code ]

Un intérêt principal des matrices est qu'elles permettent d'écrire commodément les opérations habituelles de l'algèbre linéaire, avec une certaine canonicité.

Coordonnées[ modifier | modifier le code ]

Articles détaillés : Base et Rang.

Le premier point est de remarquer que le K-module Kn s'identifie canoniquement à l'espace de matrices colonne M n , 1 ( K ) {\displaystyle M_{n,1}(K)} [image] : si ei est le n-uplet de Kn dont tous les coefficients sont nuls, sauf le i-ème qui vaut 1, on lui associe la i-ème matrice colonne E i , 1 {\displaystyle E_{i,1}} [image] de la base canonique de M n , 1 ( K ) {\displaystyle M_{n,1}(K)} [image] (celle dont tous les coefficients sont nuls sauf le i-ème qui vaut 1), et on étend l'identification par linéarité ; la matrice associée à chaque n-uplet sera appelée matrice coordonnée canonique.

D'autres identifications sont cependant possibles ; lorsqu'on peut parler de base (si l'anneau des scalaires est un corps, par exemple), on peut associer les matrices colonnes élémentaires à n'importe quelle base de l'espace Kn (ou plus généralement d'un K-module libre), puis à nouveau étendre par linéarité ; les matrices associées seront appelées matrices coordonnées dans la base envisagée.

On peut juxtaposer les matrices coordonnées, dans une base fixée, de plusieurs n-uplets. On obtient ainsi la matrice coordonnée d'une famille de vecteurs. Le rang de la matrice est alors défini comme la dimension de la famille de ces vecteurs. En particulier la matrice d'une base dans une autre base est appelée matrice de passage entre ces deux bases, ou matrice de changement de base. Si X et X' sont les matrices coordonnées du même vecteur dans deux bases B et C, et que P est la matrice de la base C dans la base B, on a la relation (une matrice de passage est toujours inversible) :

X = P X ′ X ′ = P − 1 X {\displaystyle X=PX'\quad X'=P^{-1}X}

Applications linéaires[ modifier | modifier le code ]

Articles détaillés : Matrice d'une application linéaire et Changement de bases.

Soient E et F deux espaces vectoriels de dimensions respectives n et m sur un corps commutatif[20] K, B une base de E, C une base de F et φ une application linéaire de E dans F.

On appelle matrice de φ dans le couple de bases (B, C) la matrice matB,C(φ) de Mm,n(K) telle que pour tout vecteur x de E, si l'on note y = φ(x), X = matB(x) et Y = matC(y), alors :

Y = m a t B , C ( φ ) × X . {\displaystyle Y=mat_{B,C}(\varphi )\times X.}

Si ψ est une deuxième application linéaire, de F dans un troisième espace vectoriel G de base D, alors, relativement aux bases B, C, D, la matrice de la composée ψ∘φ est égale au produit des matrices de ψ et φ. Plus précisément :

m a t B , D ( ψ ∘ φ ) = m a t C , D ( ψ ) × m a t B , C ( φ ) . {\displaystyle mat_{B,D}(\psi \circ \varphi )=mat_{C,D}(\psi )\times mat_{B,C}(\varphi ).}

L'application de L(E, F) dans Mm,n(K) qui à chaque φ associe sa matrice dans (B, C) est un isomorphisme d'espaces vectoriels.

Pour toute matrice M de Mm,n(K), l'application X ↦ MX du K-espace vectoriel Mn,1(K) dans le K-espace vectoriel Mm,1(K) est linéaire. C'est un point clef du lien entre algèbre linéaire et matrices. En conséquence, il arrive souvent que l'on identifie la matrice M avec cette application linéaire. On parlera alors de noyau de la matrice, d'espaces propres de la matrice, d'image de la matrice, etc.

Si B et B' sont deux bases de E, C et C' deux bases de F, P = matB(B') la matrice de passage de B vers B' et Q la matrice de passage de C vers C', alors les deux matrices M et M' d'une même application linéaire de E dans F, dans les couples de bases (B, C) et (B', C'), sont liées par : M' = Q−1MP. On constate ainsi que deux matrices équivalentes sont deux matrices qui représentent la même application linéaire dans des bases différentes. En particulier, dans le cas d'un endomorphisme, si l'on impose B = C et B' = C', la formule précédente devient : M' = P−1MP et deux matrices semblables sont deux matrices qui représentent le même endomorphisme dans des bases différentes.

Transposition[ modifier | modifier le code ]

Article détaillé : Application transposée.

Soient de nouveau E et F deux K-espaces vectoriels de dimensions finies[20], de bases respectives B et C, et φ une application linéaire de E dans F. L'application linéaire transposée tφ : F* → E* entre leurs duals est définie par

∀ y ∗ ∈ F ∗ , ∀ x ∈ E , ⟨ t φ ( y ∗ ) , x ⟩ = ⟨ y ∗ , φ ( x ) ⟩ . {\displaystyle \forall y^{*}\in F^{*},\forall x\in E,\quad \left\langle ^{\operatorname {t} }\!\varphi \left(y^{*}\right),x\right\rangle =\left\langle y^{*},\varphi \left(x\right)\right\rangle .}

Sa matrice dans le couple de bases duales (C*, B*) est liée à celle de φ dans (B, C) par :

m a t C ∗ , B ∗ ( t φ ) = t ( m a t B , C ( φ ) ) . {\displaystyle mat_{C^{*},B^{*}}(^{\operatorname {t} }\!\varphi )=^{\operatorname {t} }\!(mat_{B,C}(\varphi )).}

Remarque[ modifier | modifier le code ]

Lorsque l'anneau n'est pas commutatif, si l'on représente les vecteurs par des matrices colonne, l'algèbre linéaire n'est compatible avec le calcul matriciel que si les modules ou espaces vectoriels considérés sont à droite, comme dans les articles détaillés signalés ci-dessus, une application linéaire correspondant à la multiplication à gauche d'un vecteur colonne par la matrice qui la représente. Si l'on tient à avoir des modules ou espaces vectoriels à gauche, il faut représenter les vecteurs par des matrices ligne, une application linéaire étant cette fois représentée par la multiplication à droite d'un vecteur ligne par la matrice qui la représente[21].

Systèmes d'équations linéaires[ modifier | modifier le code ]

Article détaillé : Système d'équations linéaires.

En général, un système de m équations linéaires à n inconnues peut être écrit sous la forme suivante :

{ a 1 , 1 x 1 + a 1 , 2 x 2 + . . . + a 1 , n x n = b 1 a 2 , 1 x 1 + a 2 , 2 x 2 + . . . + a 2 , n x n = b 2 ⋮ ⋮ a m , 1 x 1 + a m , 2 x 2 + . . . + a m , n x n = b m {\displaystyle \left\{{\begin{matrix}a_{1,1}x_{1}+a_{1,2}x_{2}+...+a_{1,n}x_{n}=b_{1}\\a_{2,1}x_{1}+a_{2,2}x_{2}+...+a_{2,n}x_{n}=b_{2}\\\vdots \\\vdots \\a_{m,1}x_{1}+a_{m,2}x_{2}+...+a_{m,n}x_{n}=b_{m}\end{matrix}}\right.}

Où x 1 , . . . , x n {\displaystyle x_{1},...,x_{n}} x_1, ..., x_n sont les inconnues et les nombres a i , j {\displaystyle a_{i,j}} [image] sont les coefficients du système.

Ce système peut s'écrire sous la forme matricielle :

A x = b {\displaystyle Ax=b}

avec :

A = ( a 1 , 1 a 1 , 2 ⋯ a 1 , n a 2 , 1 a 2 , 2 ⋯ a 2 , n ⋮ ⋮ ⋱ ⋮ a m , 1 a m , 2 ⋯ a m , n ) ; x = ( x 1 x 2 ⋮ x n ) et b = ( b 1 b 2 ⋮ b m ) ; {\displaystyle A={\begin{pmatrix}a_{1,1}&a_{1,2}&\cdots &a_{1,n}\\a_{2,1}&a_{2,2}&\cdots &a_{2,n}\\\vdots &\vdots &\ddots &\vdots \\a_{m,1}&a_{m,2}&\cdots &a_{m,n}\end{pmatrix}};\qquad x={\begin{pmatrix}x_{1}\\x_{2}\\\vdots \\x_{n}\end{pmatrix}}\quad {\text{et}}\quad b={\begin{pmatrix}b_{1}\\b_{2}\\\vdots \\b_{m}\end{pmatrix}};}

la théorie de la résolution des systèmes utilise les invariants liés à la matrice A (appelée matrice du système), par exemple son rang, et, dans le cas où A est inversible, son déterminant (voir l'article règle de Cramer).

Interprétations bilinéaires[ modifier | modifier le code ]

Dans ce paragraphe, l'anneau K des scalaires sera supposé commutatif. Dans la plupart des applications, ce sera un corps commutatif.

Le cas non commutatif existe aussi mais il faut prendre quelques précautions et les notations deviennent trop lourdes pour cet article.

Matrice d'une forme bilinéaire[ modifier | modifier le code ]

Soient E un K-module libre et B = (e1, … , en) une base de E.

Soit f : E × E → K {\displaystyle f:E\times E\to K} [image] une forme bilinéaire. On définit la matrice de f {\displaystyle f} f dans la base B par la formule suivante :

m a t B f = ( f ( e i , e j ) ) 1 ≤ i ≤ n , 1 ≤ j ≤ n = ( f ( e 1 , e 1 ) f ( e 1 , e 2 ) … f ( e 1 , e n ) f ( e 2 , e 1 ) f ( e 2 , e 2 ) … f ( e 2 , e n ) ⋮ ⋮ ⋱ ⋮ f ( e n , e 1 ) f ( e n , e 2 ) … f ( e n , e n ) ) {\displaystyle mat_{B}\,f=(f(e_{i},e_{j}))_{1\leq i\leq n,\ 1\leq j\leq n}={\begin{pmatrix}f(e_{1},e_{1})&f(e_{1},e_{2})&\dots &f(e_{1},e_{n})\\f(e_{2},e_{1})&f(e_{2},e_{2})&\dots &f(e_{2},e_{n})\\\vdots &\vdots &\ddots &\vdots \\f(e_{n},e_{1})&f(e_{n},e_{2})&\dots &f(e_{n},e_{n})\\\end{pmatrix}}}

Dans le cas particulier où K = ℝ et f {\displaystyle f} f est un produit scalaire, cette matrice est appelée matrice de Gram.

La matrice m a t B f {\displaystyle mat_{B}\,f} [image] est symétrique (respectivement antisymétrique) si et seulement si la forme bilinéaire f {\displaystyle f} f est symétrique (respectivement antisymétrique).

Soient x {\displaystyle x} x et y {\displaystyle y} y deux vecteurs de E. Notons X {\displaystyle X} X et Y {\displaystyle Y} Y leurs coordonnées dans la base B et A = m a t B f {\displaystyle A=mat_{B}\,f} [image] . On a alors la formule : f ( x , y ) = t X A Y {\displaystyle f(x,y)=^{\operatorname {t} }\!X~A~Y} [image] .

Deux formes bilinéaires sont égales si et seulement si elles ont la même matrice dans une base donnée.

Matrice d'une forme quadratique[ modifier | modifier le code ]

Lorsque K est un corps de caractéristique différente de 2, on appelle matrice d'une forme quadratique la matrice de la forme bilinéaire symétrique dont est issue la forme quadratique.

Formule de changement de base[ modifier | modifier le code ]

Soient E un K-module libre et B, C deux bases de E. Soit f : E × E → K {\displaystyle f:E\times E\to K} [image] une forme bilinéaire.

Notons M = m a t B f {\displaystyle M=mat_{B}\,f} [image] la matrice de f {\displaystyle f} f dans la base B et M ′ = m a t C f {\displaystyle M'=mat_{C}\,f} [image] la matrice de f {\displaystyle f} f dans la base C. Notons P = m a t B C {\displaystyle P=mat_{B\,C}} [image] la matrice de passage. On a alors la formule de changement de base pour une forme bilinéaire (à ne pas confondre avec celle pour une application linéaire) :

M ′ = t P M P {\displaystyle M'=^{\operatorname {t} }\!P~M~P}

Matrices congruentes[ modifier | modifier le code ]

Article détaillé : Matrices congruentes.

Deux matrices carrées A et B sont dites congruentes s'il existe une matrice inversible P telle que

A = t P B P . {\displaystyle A=^{\operatorname {t} }\!P~B~P~.}

Deux matrices congruentes sont deux matrices qui représentent la même forme bilinéaire dans deux bases différentes.

Lorsque K est un corps de caractéristique différente de 2, toute matrice symétrique est congruente à une matrice diagonale. L'algorithme utilisé s'appelle réduction de Gauss à ne pas confondre avec le pivot de Gauss.

Catalogue partiel[ modifier | modifier le code ]

Articles détaillés : Matrice symétrique, Matrice antisymétrique, Matrice hermitienne, Matrice orthogonale et Matrice unitaire.

Une matrice est dite symétrique si elle est égale à sa transposée et antisymétrique si elle est opposée à sa transposée.

Une matrice A à coefficients complexes est dite hermitienne si elle est égale à la transposée de sa matrice conjuguée A.

Une matrice A est dite

  • orthogonale si elle est à coefficient réels et si tA A = A tA = I,
  • unitaire si elle est à coefficients complexes et si tA A = A tA = I

(Pour plus d'exemples, voir en bas de page : « Articles connexes » et palette « Matrices ».)

Décomposition d'une matrice[ modifier | modifier le code ]

On utilise abusivement le terme décomposition d'une matrice, qu'il s'agisse d'une véritable décomposition (en somme) comme dans la décomposition de Dunford ou d'une factorisation comme dans la plupart des autres décompositions.

Réduction d'une matrice carrée[ modifier | modifier le code ]

Articles détaillés : Réduction d'endomorphisme, matrice diagonalisable, trigonalisation, polynôme d'endomorphisme et polynôme minimal d'un endomorphisme.
  • Réduire une matrice, c'est trouver une matrice qui lui est semblable la plus simple possible.
  • Une matrice diagonalisable est une matrice semblable à une matrice diagonale : A {\displaystyle A} A est diagonalisable s'il existe une matrice inversible P {\displaystyle P} P et une matrice diagonale D {\displaystyle D} D telles que A = P − 1 D P {\displaystyle A=P^{-1}DP} [image] .
  • Sur un corps algébriquement clos, on dispose de la réduction de Jordan qui est optimale et il existe des décompositions intermédiaires comme la décomposition de Dunford qui utilise les sous-espaces caractéristiques ou celle de Frobenius qui utilise les sous-espaces cycliques.
  • Les polynômes d'endomorphismes jouent un rôle crucial dans les techniques de réduction.

Décomposition LU[ modifier | modifier le code ]

Article détaillé : Décomposition LU.
  • C'est une factorisation en produit de deux matrices triangulaires.
  • En lien avec le pivot de Gauss, c'est une méthode qui permet d'inverser une matrice.

Décomposition QR[ modifier | modifier le code ]

Article détaillé : Décomposition QR.
  • C'est un résultat sur les matrices à coefficients réels ou à coefficients complexes.
  • C'est une factorisation en produit d'une matrice orthogonale et d'une matrice triangulaire.
  • C'est une traduction matricielle du procédé de Gram-Schmidt.

Décomposition polaire[ modifier | modifier le code ]

Article détaillé : Décomposition polaire.
  • C'est un résultat sur les matrices à coefficients réels ou à coefficients complexes.
  • C'est une factorisation en produit d'une matrice orthogonale et d'une matrice symétrique définie positive dans le cas réel, en produit d'une matrice unitaire et d'une matrice hermitienne définie positive dans le cas complexe.
  • On peut décomposer à droite ou à gauche.
  • On a unicité de la factorisation pour les matrices inversibles.

Normes[ modifier | modifier le code ]

Normes d'algèbre[ modifier | modifier le code ]

Article détaillé : Norme matricielle.

Dans tout ce paragraphe, K = ℝ ou ℂ.

Une norme matricielle est une norme d'algèbre sur l'algèbre Mn(K), c'est-à-dire une norme d'espace vectoriel qui est de plus sous-multiplicative.

Le rayon spectral d'une matrice carrée A à coefficients complexes est le plus grand module de ses valeurs propres. Il est égal à la borne inférieure des normes matricielles de A.

Sur Mn(K), toute norme N subordonnée à une norme sur Kn est une norme d'algèbre vérifiant de plus N(In) = 1 (la réciproque est fausse).

Structure d'espace vectoriel euclidien[ modifier | modifier le code ]

L'espace vectoriel M m , n ( R ) {\displaystyle M_{m,n}(\mathbb {R} )} [image] , canoniquement isomorphe à R m n {\displaystyle \mathbb {R} ^{mn}} [image] , hérite de sa structure euclidienne. Le produit scalaire se transcrit en

( A , B ) ∈ M m , n ( R ) × M m , n ( R ) ↦ ⟨ A , B ⟩ := tr ⁡ ( t A B ) = ∑ 1 ≤ i ≤ m 1 ≤ j ≤ n A i j B i j ∈ R , {\displaystyle (A,B)\in M_{m,n}(\mathbb {R} )\times M_{m,n}(\mathbb {R} )\mapsto \langle A,B\rangle :=\operatorname {tr} (^{\operatorname {t} }\!A~B)=\sum _{\scriptstyle 1\leq i\leq m \atop \scriptstyle 1\leq j\leq n}A_{ij}B_{ij}\in \mathbb {R} ,}

où tr {\displaystyle \operatorname {tr} } [image] désigne la trace (i.e., tr M = ∑ i = 1 n M i i {\displaystyle \textstyle \operatorname {tr} \,M=\sum _{i=1}^{n}M_{ii}} [image] ) et les A i j {\displaystyle A_{ij}} [image] (resp. B i j {\displaystyle B_{ij}} [image] ) désignent les éléments de A {\displaystyle A} A (resp. B {\displaystyle B} B ). La norme associée à ce produit scalaire est la norme de Frobenius ou norme de Hilbert-Schmidt :

∥ A ∥ F = ( ∑ 1 ≤ i ≤ m 1 ≤ j ≤ n A i j 2 ) 1 2 = ∥ σ ( A ) ∥ 2 , {\displaystyle \|A\|_{F}=\left(\sum _{1\leq i\leq m \atop 1\leq j\leq n}A_{ij}^{2}\right)^{\frac {1}{2}}=\|\sigma (A)\|_{2},}

où σ ( A ) {\displaystyle \sigma (A)} [image] est le vecteur des valeurs singulières de A {\displaystyle A} A et ∥ ⋅ ∥ 2 {\displaystyle \|\cdot \|_{2}} [image] est la norme euclidienne.

Si m = n > 1 {\displaystyle m=n>1} [image] , il ne s'agit pas d'une norme subordonnée, puisque ∥ I n ∥ F = n ≠ 1. {\displaystyle \|I_{n}\|_{F}={\sqrt {n}}\neq 1.}

L'inégalité de Cauchy-Schwarz s'écrit (comme pour tout produit scalaire) : pour tout A {\displaystyle A} A , B ∈ R m × n {\displaystyle B\in \mathbb {R} ^{m\times n}} [image] , on a

⟨ A , B ⟩ ⩽ ∥ A ∥ F ∥ B ∥ F . {\displaystyle \langle A,B\rangle \leqslant \|A\|_{F}\,\|B\|_{F}.}

Cette inégalité peut être renforcée par l'inégalité de trace de von Neumann[22] : pour tout A {\displaystyle A} A , B ∈ R m × n {\displaystyle B\in \mathbb {R} ^{m\times n}} [image] , on a

⟨ A , B ⟩ ⩽ σ ( A ) T σ ( B ) , {\displaystyle \langle A,B\rangle \leqslant \sigma (A)^{\mathsf {T}}\sigma (B),}

où σ ( A ) {\displaystyle \sigma (A)} [image] est le vecteur des valeurs singulières de A {\displaystyle A} A , rangées en ordre décroissant. Elle a la même structure que l'inégalité de Ky Fan, laquelle suppose que les matrices sont carrées et symétriques (on peut alors remplacer σ ( ⋅ ) {\displaystyle \sigma (\cdot )} [image] par le vecteur des valeurs propres).

L'espace vectoriel Mm,n(ℂ) est muni d'une structure similaire d'espace hermitien.

Exponentielle d'une matrice[ modifier | modifier le code ]

Article détaillé : Exponentielle d'une matrice.

Soit A ∈ M n ( C ) {\displaystyle A\in M_{n}(\mathbb {C} )} [image] , Soit N {\displaystyle N} N une norme d'algèbre et ∑ a n z n {\displaystyle \sum a_{n}z^{n}} [image] une série entière de rayon de convergence R {\displaystyle R} R .

Alors si N ( A ) < R {\displaystyle N(A)<R} N(A) < R , la série ∑ a n A n {\displaystyle \sum a_{n}A^{n}} [image] est absolument convergente. (On le montre en utilisant que N ( A n ) ≤ N ( A ) n {\displaystyle N(A^{n})\leq N(A)^{n}} [image] .)

En particulier, on peut définir, pour toute matrice carrée complexe, la quantité

exp ⁡ ( A ) = ∑ k = 0 + ∞ 1 k ! A k {\displaystyle \exp(A)=\sum _{k=0}^{+\infty }{\frac {1}{k!}}A^{k}}

Le calcul effectif de cette exponentielle se fait par réduction de la matrice.

L'exponentielle joue un rôle central dans l'étude des systèmes linéaires d'équations différentielles.

Notes et références[ modifier | modifier le code ]

  1. ↑ Chapitre 8 : Fang cheng - La disposition rectangulaire : problèmes à plusieurs inconnues, résolus selon un principe similaire à l'élimination de Gauss.
  2. ↑ a, b, c, d, e et f (en) Discrete Mathematics 4th Ed. Dossey, Otto, Spense, Vanden Eynden, Addison Wesley, 10 octobre 2001, ISBN 978-0321079121 (pages 564-565).
  3. ↑ (en) Joseph Needham et Wang Ling, Science and Civilisation in China, vol. III, Cambridge, Cambridge University Press, 1959 (ISBN 9780521058018, lire en ligne [archive]), p. 117.
  4. ↑ Gabriel Cramer, Introduction à l'Analyse des lignes courbes algébriques, Genève, Europeana, 1750 (lire en ligne [archive]), p. 656–659.
  5. ↑ De nombreuses sources affirment qu'il l'aurait fait en 1848, mais Sylvester n'a rien publié cette année-là. (voir The Collected Mathematical Papers of James Joseph Sylvester (Cambridge, England: Cambridge University Press, 1904), vol. 1. [archive]). Sa première utilisation du terme matrix, en 1850, figure dans Additions to the articles in the September number of this journal, “On a new class of theorems,” and on Pascal's theorem, The London, Edinburgh and Dublin Philosophical Magazine and Journal of Science, 37 : 363-370. (1850), page 369 [archive] : « For this purpose we must commence, not with a square, but with an oblong arrangement of terms consisting, suppose, of m lines and n columns. This will not in itself represent a determinant, but is, as it were, a Matrix out of which we may form various systems of determinants […] ».
  6. ↑ « I have in previous papers defined a “Matrix” as a rectangular array of terms, out of which different systems of determinants may be engendered as from the womb of a common parent » dans The Collected Mathematical Papers of James Joseph Sylvester : 1837–1853, Article 37 [archive], p. 247.
  7. ↑ Phil. Trans. 1858, vol. 148, pp. 17-37 Math. Papers II 475-496.
  8. ↑ Jean Dieudonné, Abrégé d'histoire des mathématiques 1700-1900, Paris, FR, Hermann, 1978.
  9. ↑ (en) Maxime Bôcher, Introduction to Higher Algebra, New York, NY, Dover Publications, 2004 (ISBN 978-0-486-49570-5).
  10. ↑ (en) Jagdish Mehra et Helmut Rechenberg, The Historical Development of Quantum Theory, Berlin, DE; New York, NY, Springer-Verlag, 1987 (ISBN 978-0-387-96284-9).
  11. ↑ (en) Eberhard Knobloch, The intersection of history and mathematics, vol. 15, Basel, Boston, Berlin, Birkhäuser, 1994, chap. From Gauss to Weierstrass: determinant theory and its historical evaluations, p. 51–66
  12. ↑ (en) Thomas Hawkins, Cauchy and the spectral theory of matrices, vol. 2, Historia Mathematica, 1975, 1–29 p. (ISSN 0315-0860, DOI 10.1016/0315-0860(75)90032-4)
  13. ↑ (de) Kurt Hensel, Leopold Kronecker's Werke, Teubner, 1897 (lire en ligne [archive])
  14. ↑ (de) Karl Weierstrass, Collected works, vol. 3, 1915 (lire en ligne [archive]), p. 271–286
  15. ↑ « Let us give the name of matrix to any function, of however many variables, which does not involve any apparent variables. Then any possible function other than a matrix is derived from a matrix by means of generalization, i.e., by considering the proposition which asserts that the function in question is true with all possible values or with some value of one of the arguments, the other argument or arguments remaining undetermined » . Alfred North Whitehead et Bertrand Russell, Principia Mathematica to *56, Cambridge at the University Press, Cambridge UK (1913, réédition de 1962) voir page 162.
  16. ↑ (en) Alfred Tarski, Introduction to Logic and the Methodology of Deductive Sciences, Dover Publications, Inc, New York NY, 1946 ISBN 0-486-28462-X. (lire en ligne [archive])
  17. ↑ Voir N. Bourbaki, Algèbre, Chapitres 1 à 3, Springer, 2006, 2e éd. (lire en ligne [archive]), A II.139, qui parle aussi de « matrice vide » dans le cas où I ou J est l'ensemble vide.
  18. ↑ On peut remarquer que ce produit est donné par une formule analogue à celle donnant le produit scalaire usuel ; cette remarque sera exploitée plus loin.
  19. ↑ Dans le cas plus général d'ensembles éventuellement infinis d'indices, on peut demander à K d'être muni d'une topologie, pour définir le produit comme la somme d'une série (convergente). Sans topologie, on peut également demander aux colonnes (ou aux lignes) des matrices de ne contenir qu'un nombre fini d'éléments non nuls ; c'est d'ailleurs toujours le cas quand ces matrices représentent des applications linéaires entre espaces vectoriels munis de bases, même infinies. Paul Halmos, qui donne ces diverses définitions, ajoute néanmoins que « Not much of matrix theory carries over to infinite-dimensional spaces, and what does is not so useful, but it sometimes helps. » (la théorie des matrices s'étend peu aux espaces de dimension infinie, et ce qui s'étend n'est guère utile, mais peut parfois aider), dans P. Halmos, A Hilbert space problem book, 1982, p. 23.
  20. ↑ a et b Cette définition et les propriétés associées se généralisent à des K-modules à droite libres de type fini sur un anneau (non nécessairement commutatif).
  21. ↑ Voir par exemple : (en) Henri Bourlès et Bogdan Marinescu, Linear Time-Varying Systems: Algebraic-Analytic Approach, Springer, 2011, 638 p. (ISBN 3642197264, lire en ligne [archive]), §§ 2.2.4-2.2.6 ; cette formulation est très courante dans la théorie des D-modules.
  22. ↑ J. von Neumann (1937). Some matrix inequalities and metrization of matrix-space. Tomsk University Review, 1, 286–300. Collected Works, Pergamon, Oxford, 1962, Volume IV, 205-218

Voir aussi[ modifier | modifier le code ]

Sur les autres projets Wikimedia :

  • Matrice, sur Wikiversity

Bibliographie[ modifier | modifier le code ]

  • J.-M. Arnaudiès et H. Fraysse Cours de mathématiques, Dunod, 1980
  • Rached Mneimné, Réduction des endomorphismes, Calvage et Mounet, Paris, 2006 (ISBN 978-2-916352-01-5)

Articles connexes[ modifier | modifier le code ]

  • Comatrice
  • Conditionnement (analyse numérique)
  • Formule du binôme pour deux matrices qui commutent
  • Matrice de rotation
  • Matrice de transition
  • Matrices liées aux problèmes de complémentarité linéaire : M-matrice, Matrice dégénérée, Matrice suffisante, P-matrice, P0-matrice, Q-matrice, Q0-matrice, R0-matrice, S-matrice, Z-matrice
  • Matrice quaternionique
  • Norme matricielle
  • Paire de matrices commutantes
  • Représentation de groupe
  • Tenseur

Liens externes[ modifier | modifier le code ]

Frédéric Brechenmacher, Les matrices : formes de représentation et pratiques opératoires (1850-1930)

[afficher]
v · m
Matrices
Forme | Carrée · Triangulaire · Diagonale · Tridiagonale · Élémentaire · Échelonnée · Creuse · Aléatoire · Circulante · Hankel · Toeplitz · Vandermonde · Hessenberg
Transformée | Transposée · Conjuguée · Adjointe · Inverse · Comatrice
Relation | équivalentes · semblables · congruentes
Propriété | Inversible · Diagonalisable · Semi-simple · Trigonalisable · Symétrique · Antisymétrique · Hermitienne · Normale · Orthogonale · Unitaire · Symplectique · de Hadamard · Autoadjointe positive · Définie positive · Diagonale dominante · Nilpotente
Famille | Identité · De Casteljau · Cartan · Hilbert · Mueller · Pauli · Dirac · Householder
Associée | Permutation · Passage · Compagnon · Sylvester · Adjacence · Laplacienne · Hessienne · Jacobienne · Génératrice · Contrôle · Corrélation · Gram · Variance-covariance · Inertie · Jones · Gains · Stochastique
Résultats
Décompositions LU · QR · Cholesky · Schur · Polaire · Valeurs singulières
Diagonalisation · Trigonalisation · Réduction de Jordan · Facteurs invariants
Articles liés | CKM · Théorie des matrices · Algèbre linéaire · Algèbre bilinéaire · Addition matricielle
[afficher]
v · m
Algèbre linéaire générale
  • Vecteur
  • Scalaire
  • Combinaison linéaire
  • Espace vectoriel
  • Matrice
Famille de vecteurs
  • Famille génératrice
  • Famille libre (indépendance linéaire)
  • Base
  • Théorème de la base incomplète
  • Rang
  • Colinéarité
 Mathématiques
Sous-espace
  • Sous-espace vectoriel
  • Somme de Minkowski
  • Somme directe
  • Sous-espace supplémentaire
  • Dimension
  • Codimension
  • Droite
  • Plan
  • Hyperplan
Morphisme et
notions relatives
  • Application linéaire
  • Noyau
  • Conoyau
  • Lemme des noyaux
  • Pseudo-inverse
  • Théorème de factorisation
  • Théorème du rang
  • Équation linéaire
  • Système d'équations linéaires
  • Élimination de Gauss-Jordan
  • Forme linéaire
  • Espace dual
  • Orthogonalité
  • Base duale
  • Endomorphisme linéaire
  • Valeur propre, vecteur propre et espace propre
  • Projecteur
  • Symétrie
  • Matrice diagonalisable
  • Diagonalisation
  • Endomorphisme nilpotent
Dimension finie
  • Espace vectoriel de dimension finie
  • Trace
  • Déterminant Article de qualité
  • Polynôme caractéristique
  • Polynôme d'endomorphisme
  • Théorème de Cayley-Hamilton
  • Polynôme minimal d'un endomorphisme
  • Invariants de similitude
  • Réduction d'endomorphisme
  • Réduction de Jordan
  • Décomposition de Dunford
  • Décomposition de Frobenius
Enrichissements
de structure
  • Norme
  • Produit scalaire
  • Forme quadratique
  • Espace vectoriel topologique
  • Orientation
  • Algèbre sur un corps
  • Algèbre de Lie
  • Complexe différentiel
Développements
  • Théorie des matrices
  • Représentation de groupe
  • Analyse fonctionnelle
  • Algèbre multilinéaire
  • Module sur un anneau
  • Portail de l’algèbre Portail de l’algèbre
Ce document provient de « https://fr.wikipedia.org/w/index.php?title=Matrice_(mathématiques)&oldid=127699930 ».
Catégorie :
  • Matrice
| [+]
Catégories cachées :
  • Article contenant un appel à traduction en anglais
  • Portail:Algèbre/Articles liés
  • Portail:Sciences/Articles liés
  • Projet:Mathématiques/Articles
  • Bon article dans une autre langue
  • Bon article en anglais
  • Bon article en chinois
  • Article de qualité en ourdou

Menu de navigation

Outils personnels

  • Non connecté
  • Discussion
  • Contributions
  • Créer un compte
  • Se connecter

Espaces de noms

  • Article
  • Discussion

Variantes

Affichages

  • Lire
  • Modifier
  • Modifier le code
  • Historique

Plus

Navigation

  • Accueil
  • Portails thématiques
  • Article au hasard
  • Contact

Contribuer

  • Débuter sur Wikipédia
  • Aide
  • Communauté
  • Modifications récentes
  • Faire un don

Outils

  • Pages liées
  • Suivi des pages liées
  • Importer un fichier
  • Pages spéciales
  • Adresse permanente
  • Information sur la page
  • Élément Wikidata
  • Citer cette page

Imprimer / exporter

  • Créer un livre
  • Télécharger comme PDF
  • Version imprimable

Dans d’autres projets

  • Wikimédia Commons
  • Wikiversité

Dans d’autres langues

  • Afrikaans
  • አማርኛ
  • العربية
  • Azərbaycanca
  • Беларуская
  • Беларуская (тарашкевіца)‎
  • Български
  • বাংলা
  • Bosanski
  • Català
  • کوردیی ناوەندی
  • Čeština
  • Dansk
  • Deutsch
  • Ελληνικά
  • English
  • Esperanto
  • Español
  • Eesti
  • Euskara
  • فارسی
  • Suomi
  • Gaeilge
  • 贛語
  • Galego
  • עברית
  • हिन्दी
  • Hrvatski
  • Magyar
  • Հայերեն
  • Bahasa Indonesia
  • Íslenska
  • Italiano
  • 日本語
  • ქართული
  • 한국어
  • Latina
  • ລາວ
  • Lietuvių
  • Latviešu
  • Олык марий
  • Македонски
  • മലയാളം
  • Bahasa Melayu
  • မြန်မာဘာသာ
  • नेपाली
  • Nederlands
  • Norsk nynorsk
  • Norsk bokmål
  • ਪੰਜਾਬੀ
  • Polski
  • Piemontèis
  • پنجابی
  • Português
  • Română
  • Русский
  • Sicilianu
  • Srpskohrvatski / српскохрватски
  • සිංහල
  • Simple English
  • Slovenčina
  • Slovenščina
  • Soomaaliga
  • Shqip
  • Српски / srpski
  • Svenska
  • தமிழ்
  • ไทย
  • Türkçe
  • Українська
  • اردو
  • Tiếng Việt
  • 中文
  • 粵語
Modifier les liens
  • Dernière modification de cette page le 9 juillet 2016, à 06:32.
  • Droit d'auteur : les textes sont disponibles sous licence Creative Commons attribution, partage dans les mêmes conditions ; d’autres conditions peuvent s’appliquer. Voyez les conditions d’utilisation pour plus de détails, ainsi que les crédits graphiques. En cas de réutilisation des textes de cette page, voyez comment citer les auteurs et mentionner la licence.
    Wikipedia® est une marque déposée de la Wikimedia Foundation, Inc., organisation de bienfaisance régie par le paragraphe 501(c)(3) du code fiscal des États-Unis.
  • Politique de confidentialité
  • À propos de Wikipédia
  • Avertissements
  • Développeurs
  • Déclaration sur les cookies
  • Version mobile
  • Powered by MediaWiki


Calcul matriciel

Dernière mise à jour : 9 Septembre 2008

  1. Définitions

  2. Opérations sur les matrices

    1. Addition, soustraction
    2. Multiplication par un nombre
    3. Transposition
    4. Multiplication des matrices
    5. Inversion des matrices carrées
    6. Déterminant d'une matrice carrée

  3. Application aux systèmes d'équations linéaires

    1. Formulation matricielle
    2. Cas d'une matrice régulière
    3. Cas d'une matrice singulière

I. Définitions

Une matrice n × m est un tableau de nombres à n lignes et m colonnes :

Exemple avec n = 2, m = 3 :

n et m sont les dimensions de la matrice.

Une matrice est symbolisée par une lettre en caractères gras, par exemple A. On note Aij l'élément situé à l'intersection de la ligne i et de la colonne j (la ligne est toujours nommée en premier).

On note [Aij] la matrice d'élément général Aij. On a donc : A = [Aij]

Si m = 1, la matrice est appelée vecteur (plus précisément vecteur-colonne) :

N.B. : Dans ce chapitre, nous utiliserons des lettres majuscules pour les matrices et des lettres minuscules pour les vecteurs, mais ce n'est pas obligatoire.

Si n = m, la matrice est appelée matrice carrée.

Quelques matrices carrées particulières (Exemples avec n = 4)

Matrice unité | Parfois notée In n est la dimension de la matrice (soit I4 dans cet exemple)
Matrice diagonale | notée diag(Dii)
Matrice triangulaire supérieure (Upper triangular matrix, U) |
Matrice triangulaire inférieure (Lower triangular matrix, L) |

Une matrice carrée A est dite symétrique si :

Aji = Aij

pour tout i différent de j

II. Opérations sur les matrices

II.A. Addition, soustraction

L'addition et la soustraction des matrices se font terme à terme. Les matrices doivent avoir les mêmes dimensions :

II.B. Multiplication par un nombre

Chaque terme de la matrice est multiplié par le nombre :

II.C. Transposition

La transposée AT (aussi notée A') d'une matrice A est la matrice obtenue en échangeant les lignes et les colonnes de A :

La transposée d'un vecteur-colonne est un vecteur-ligne :

II.D. Multiplication des matrices

Définissons tout d'abord le produit d'un vecteur-ligne xT par un vecteur-colonne y :

Ce produit est appelé produit scalaire des vecteurs x et y, noté x · y. Les vecteurs doivent avoir la même dimension.

Le produit matriciel s'en déduit : le produit de la matrice A (n × m) par la matrice B (m × p) est la matrice C (n × p) telle que l'élément Cij est égal au produit scalaire de la ligne i de la matrice A par la colonne j de la matrice B.

Exemple :

On a en effet, en effectuant les produits ligne par colonne :

Propriétés :

  • Le produit matriciel est :

    • associatif : ABC = (AB)C = A(BC)
    • distributif par rapport à l'addition : A(B + C) = AB + AC
    • non commutatif : AB n'est pas égal à BA en général.

  • La matrice unité I est élément neutre pour la multiplication : AIm = InA = A, si la matrice A est de dimensions n × m.

  • Transposée d'un produit : (AB)T = BTAT (Attention au changement d'ordre !).

Quelques produits particuliers :

(x et y sont des vecteurs-colonnes, A est une matrice)

Carré scalaire.
Sa racine carrée (xTx)½ est appelée norme du vecteur ( notée [image] )
Produit extérieur des vecteurs x et y
(Matrice d'élément général xiyj)
Ne pas confondre avec le produit scalaire.
Forme quadratique (si A est symétrique)
Forme bilinéaire (dite symétrique si A est symétrique)

II.E. Inversion des matrices carrées

Une matrice carrée A est dite inversible ou régulière s'il existe une matrice carrée A-1 (appelée matrice inverse) telle que :

A × A-1 = A-1 × A = I

Si A-1 n'existe pas, la matrice A est dite singulière

Propriétés :

  • (A-1)-1 = A

  • (AT)-1 = (A-1)T

  • (AB)-1 = B-1A-1 (Attention au changement d'ordre !)

  • [diag(Dii)]-1 = diag(1/Dii)

  • La matrice A est dite orthogonale si A-1 = AT

II.F. Déterminant d'une matrice carrée

Pour une matrice 2 × 2, on montre que la matrice inverse est donnée par :

Le nombre ad - bc est appelé déterminant de la matrice A, noté :

La matrice inverse A-1 n'existe donc que si det A est différent de zéro.

La matrice A est singulière si det A = 0, régulière dans le cas contraire. Ce résultat se généralise à une matrice de dimension quelconque.

Propriétés des déterminants :

  • det(AT) = det(A)

  • det(AB) = det(A) × det(B)

  • Le déterminant d'une matrice triangulaire ou diagonale est égal au produit des éléments diagonaux. En particulier, det(I) = 1 (si I est la matrice unité)

  • Si A est régulière, det(A-1) = 1 / det(A)
    puisque det(AA-1) = det(A) × det(A-1) = det(I) = 1

  • Si A est orthogonale, det(A) = ±1
    puisque det(AAT) = [det(A)]2 = det(I) = 1

III. Application aux systèmes d'équations linéaires

III.A. Formulation matricielle

Un système de n équations linéaires à n inconnues est de la forme :

a11x1 + a12x2 + ... + a1nxn = b1
a21x1 + a22x2 + ... + a2nxn = b2
....................................................
an1x1 + an2x2 + ... + annxn = bn

où les aij sont les coefficients du système, les xi les inconnues et les bi les termes constants.

Un tel système peut s'écrire sous forme matricielle :

Ax = b

avec :

III.B. Cas d'une matrice régulière

Si la matrice A est régulière, on a, en multipliant à gauche par A-1 :

A-1Ax = A-1b

Soit :

x = A-1b

Exemple :

Soit le système de 2 équations à 2 inconnues :

2x1 + 3x2 = 9
x1 - x2 = 2

On a successivement :

Soit : x1 = 3, x2 = 1.

III.C. Cas d'une matrice singulière

Lorsque la matrice est singulière, deux cas sont à envisager :

  • Système indéterminé

    S'il est possible d'exprimer p équations en fonction des autres, le système admet une infinité de solutions. On peut retenir le vecteur x qui a la plus faible norme.

    L'ensemble des solutions forme un sous-espace de dimension r = n - p dans l'espace de dimension n. Le nombre r est le rang de la matrice.

    Exemple :

    x1 + x2 = 3
    2x1 +2x2 = 6

    Le déterminant vaut : 1 × 2 - 1 × 2 = 0. La matrice est bien singulière.

    La deuxième équation est égale à la première multipliée par 2. Il n'y a en fait qu'une seule équation : x1 + x2 = 3. C'est l'équation d'une droite (espace de dimension 1) dans le plan (x1, x2). La matrice est de rang 1.

  • Système impossible

    Si les équations ne peuvent pas être exprimées les unes en fonction des autres, le système n'admet aucune solution. On peut cependant calculer un vecteur x tel que la norme du vecteur Ax - b soit minimale (bien que non nulle). Ce vecteur constitue la meilleure approximation de la solution au sens des moindres carrés (voir le cours sur la régression linéaire).

    Exemple :

    x1 + x2 = 3
    2x1 +2x2 = 8

    La deuxième équation divisée par 2 donnerait x1 + x2 = 4, ce qui est incompatible avec la première équation. Le système n'a pas de solution.


CALCUL MATRICIEL

next up previous index
Next: Espaces vectoriels Index

CALCUL MATRICIEL

Licence ``Sciences et Technologies''

Première année, second semestre

Université de Provence

Année Universitaire 2007-08

B. TORRÉSANI

  • Espaces vectoriels
    • Notions ensemblistes
      • Ensembles
      • Union, intersection
      • Produit Cartésien
      • Applications, fonctions
    • L'espace vectoriel
      • Exemples
      • Le cas de
      • Norme, produit scalaire et angle
    • Définitions: espace vectoriel
      • Espace vectoriel
      • Exemples
    • Familles de vecteurs, sous-espaces vectoriels, dimension
      • Sous-espace vectoriel
      • Familles de vecteurs: familles libres, liées, génératrices
      • Bases, dimension
      • Union et intersection d'espaces vectoriels
      • Somme et somme directe d'espaces vectoriels
    • Le pivot de Gauss
      • La méthode, sur un exemple simple
      • Application à la question: ``une famille de vecteurs est-elle libre ?''
      • Application à la question: ``une famille de vecteurs est-elle génératrice ?''

  • Calcul Matriciel
    • Matrices
      • Définitions
      • Opérations simples sur les matrices
    • Produit de matrices
      • Le produit ``Matrice [image] Vecteur''
      • Produits de matrices carrées
      • Produits de matrices rectangulaires
      • Transposée d'un produit de deux matrices
      • Puissances d'une matrice carrée
      • Inverse d'une matrice carrée
    • Matrices, systèmes linéaires, et pivot de Gauss
    • Matrices particulières

  • Applications Linéaires
    • Applications linéaires
      • Premières définitions et propriétés
      • Matrice d'un vecteur dans une base
      • Applications linéaires et matrices
      • Composition des applications linéaires et produit matriciel
      • Matrice de l'inverse d'une application linéaire
    • Image et noyau d'une application linéaire
      • Definitions
      • Théorème de la dimension
    • Matrices et changements de base
      • Matrice de changement de base
      • Changement de base et composantes d'un vecteur
      • Changement de base et application linéaire
    • Théorie du rang

  • Déterminants, inversion de matrices
    • Déterminants
      • Déterminants en dimension 2
      • Application à la résolution d'un système linéaire de deux équations à deux inconnues.
      • Déterminant en dimension 3
      • Déterminant d'une matrice carrée quelconque
    • Déterminants, produits et inversion de matrices
    • Systèmes de Cramer

  • Diagonalisation des matrices et réduction des endomorphismes
    • Diagonalisation
      • Endomorphismes diagonalisables et trigonalisables
      • Vecteurs propres, valeurs propres
      • Diagonalisation, polynôme caractéristique
      • Quelques remarques sur les polynômes et leur factorisation
      • Caractérisation des endomorphismes diagonalisables
      • Exemples
    • Quelques classes particulières d'endomorphismes
      • La structure d'espace Euclidien de
      • La structure d'espace Hermitien de
    • Applications de la diagonalisation
      • Puissances, exponentielle,... et fonction d'une matrice
        • Puissances
        • Exponentielle d'une matrice
        • Autres fonctions
      • Application aux suites
      • Systèmes différentiels

  • Index
  • About this document ...

Bruno Torresani 2009-02-18


Espaces vectoriels

next up previous index
Next: Calcul Matriciel Up: CALCUL MATRICIEL Previous: CALCUL MATRICIEL Index

Subsections
  • Notions ensemblistes
    • Ensembles
    • Union, intersection
    • Produit Cartésien
    • Applications, fonctions

  • L'espace vectoriel
    • Exemples
    • Le cas de
    • Norme, produit scalaire et angle

  • Définitions: espace vectoriel
    • Espace vectoriel
    • Exemples

  • Familles de vecteurs, sous-espaces vectoriels, dimension
    • Sous-espace vectoriel
    • Familles de vecteurs: familles libres, liées, génératrices
    • Bases, dimension
    • Union et intersection d'espaces vectoriels
    • Somme et somme directe d'espaces vectoriels

  • Le pivot de Gauss
    • La méthode, sur un exemple simple
    • Application à la question: ``une famille de vecteurs est-elle libre ?''
    • Application à la question: ``une famille de vecteurs est-elle génératrice ?''

Espaces vectoriels

La notion d'espace vectoriel est une notion centrale dans de nombreux problèmes de mathématiques, physique, chimie,.... En effet, la propriété de linéarité est commune, au moins en première approximation, à beaucoup de solutions de problèmes simples (problème de vibration de cordes ou ressorts, de propagation de la chaleur,...).

On peut résumer la propriété de linéarité de la façon suivante: si $ u$ et $ v$ sont deux solutions d'un problème donné, alors $ u+v$ est solution également, ainsi que [image] pour tout nombre (appelé scalaire) [image] .

Le cadre mathématique adapté à ce type de situation est le cadre des espaces vectoriels, qui est étudié dans ce chapitre. Les éléments des espaces vectoriels sont appelés vecteurs, notion qui généralise les vecteurs rencontrés en géométrie vectorielle. Pour bien distinguer les différents objets mathématiques manipulés, on notera dans ce chapitre les vecteurs avec une flèche (par exemple, [image] ), notation qu'on oubliera ensuite.

Notions ensemblistes

On va dans ce chapitre manipuler des objets, et définir des opérations entre ces objets. Le langage adapté à la manipulation des objets est celui de la théorie des ensembles, dont on ébauche ici quelques aspects importants.

Ensembles

Il n'est pas nécessaire d'introduire la notion d'ensemble (qu'on nomme aussi parfois collection, famille ou regroupement), constitué d'éléments. Le nombre d'éléments d'un ensemble est appelé son cardinal. Le cardinal d'un ensemble $ A$ est noté [image] , ou [image] .

Une relation importante entre deux ensembles est la relation d'inclusion. Un ensemble $ A$ est inclus dans un ensemble $ B$ , relation que l'on note

si tout élément de $ A$ est aussi élément de $ B$ . On note ceci sous la forme

$ A$ est alors un sous-ensemble de $ B$ .

REMARQUE 1.1 Il existe un ensemble remarquable, qui est inclus dans tout ensemble: l'ensemble vide, noté [image] . Tout ensemble $ A$ est également inclus dans lui même. On a donc pour tout ensemble $ A$ ,

REMARQUE 1.2 Il est fondamental de bien saisir la différence entre les notions d'appartenance à un ensemble, et d'inclusion dans un ensemble. Par exemple, le nombre [image] appartient à l'ensemble [image] des nombres réels, alors que l'ensemble [image] des nombres entiers est quant à lui inclus dans l'ensemble des nombres réels.

Par contre, le singleton [image] , c'est à dire l'ensemble constitué de l'unique élément [image] , est un sous-ensemble de [image] . On note cela

Deux ensembles $ A$ et $ B$ sont égaux si tout élément de $ A$ est élément de $ B$ (c'est à dire [image] ), et vice versa ( [image] ). Ainsi, on a la propriété fondamentale

Pour démontrer que deux ensembles sont égaux, on doit donc démontrer les deux relations d'inclusion, c'est à dire
  • signifie: , [image] .
  • signifie: , [image] .

Union, intersection

Etant donnés deux ensembles $ A$ et $ B$ , leur union [image] est l'ensemble formé des éléments de $ A$ et des éléments de $ B$

Leur intersection est constituée des éléments communs à $ A$ et $ B$ :

Les opérations de réunion et d'intersection possèdent un certain nombre de propriétés importantes, listées ci-dessous. Les démontrer est un bon exercice. A défaut, on peut s'en convaincre en dessinant des ``patates'' (qu'on appelle diagrammes de Venn). Dans ces propriétés, $ E,F$ et $ G$ sont des ensembles.
  1. Union et intersection sont associatives: , et [image] .
  2. Union et intersection sont commutatives: , et [image] .
  3. Distributivité [image] , et [image] .

Etant donnés deux ensembles $ E$ et $ F$ , on a parfois à considérer l'ensemble des éléments de $ E$ qui n'appartiennent pas à $ F$ . Cet ensemble est appelé la différence `` $ E$ moins $ F$ '', et est noté

Lorsque $ F$ est un sous-ensemble de $ E$ , [image] est appellé le complémentaire de $ F$ dans $ E$ , et on le note [image] ou encore [image] lorsqu'aucune confusion n'est possible.

Finalement, on utilise également la notion de différence symétrique de deux ensembles $ E$ et $ F$ , notée [image] , qui est constituée des éléments de $ E$ n'appartenant pas à $ F$ et des éléments de $ F$ n'appartenant pas à $ E$ :

Produit Cartésien

Tout d'abord, distinguons les notions de paire et de couple. Une paire est un ensemble de deux objets. Un couple est lui aussi formé de deux objets, mais on distingue le premier (appelé première composante du couple) du second (appelé seconde composante du couple). Conventionnellement, on note [image] la paire constituée des objets $ a$ et $ b$ , et $ (a,b)$ le couple constitué de ces mêmes objets. On a donc [image] , alors que [image] .

Etant donnés deux ensembles $ A$ et $ B$ , le produit cartésien de $ A$ et $ B$ , noté [image] , est l'ensemble des couples dont le premier élément appartient à $ A$ et le second appartient à $ B$ :

Si $ A$ et $ B$ sont deux ensembles finis, de cardinaux respectifs [image] et [image] , alors le cardinal de [image] vaut $ n_A n_B$ :

Etant donnés trois ensembles $ A$ , $ B$ et $ C$ , le produit Cartésien des ensembles [image] et $ C$ sera noté [image] (et pas [image] ). Si [image] , [image] et [image] , on notera $ (a,b,c)$ le couple $ ((a,b),c)$ , que l'on appellera triplet.

On définira similairement les produits Cartésiens de 4 ensembles, 5 ensembles, et ainsi de suite. Un produit Cartésien de $ p$ ensembles sera formé de $ p$ -uplets.

Applications, fonctions

Une application d'un ensemble $ A$ vers un ensemble $ B$ est un objet mathématique qui associe à tout élément $ x$ de $ A$ un unique élément [image] de $ B$ . $ A$ est l'ensemble de départ, et $ B$ est l'ensemble d'arrivée.

$ y$ est l'image de $ x$ , et $ x$ est l'antécédent de $ y$ .

On utilisera dans la suite de ce cours les notions fondamentales suivantes:

  1. L'application [image] est injective si tout [image] a au plus un antécédent [image] .
  2. L'application [image] est surjective si tout [image] a au moins un antécédent [image] .
  3. L'application [image] est bijective si elle est injective et surjective, en d'autres termes si tout [image] a un et un seul antécédent [image] .

EXEMPLE 1.1
  • L'application ``carré'': n'est pas surjective: les nombres négatifs n'ont pas d'antécédents dans [image] .
  • Cette même application ``carré''est surjective lorsque l'on change l'ensemble d'arrivée: : tout réel positif [image] est le carré d'un réel, et admet donc un antécédent, par exemple [image] .
  • Elle n'est par contre pas injective: tout [image] (sauf [image] ) admet deux antécédents dans [image] : .
  • Cependant, elle peut le devenir si l'on change encore une fois les ensembles dans lesquels cette application est considérée. En effet, l'application [image] est cette fois injective (tout réel positif admet une unique racine carrée réelle positive), tout en restant surjective. Il s'agit donc cette fois d'une bijection.

REMARQUE 1.3 Rappelons ce qu'est une fonction. Etant donnés deux ensembles $ E$ et $ F$ , une fonction [image] associe à tout élément de $ E$ 1 ou 0 élément de $ F$ : ainsi, tout élément de $ E$ n'a pas nécessairement une image par la fonction $ f$ .

L'ensemble des éléments de $ E$ qui possèdent une image par la fonction est appelé ensemble de définition de la fonction $ f$ , noté [image] .

Ainsi, toute fonction [image] n'est pas nécessairement une application. Par contre, la même fonction $ f$ devient une application, si on change l'ensemble de départ: est une application.

Un exemple de fonction se trouve en FIG. [*] , représentée par un diagramme sagittal.

Figure: Diagramme sagittal d'une fonction [image] , qui devient application par restriction à son domaine de définition [image] .
Image sagittal

L'espace vectoriel

Un espace vectoriel est un ensemble dont les éléments, appelés vecteurs, constituent une généralisation abstraite de la notion usuelle (c'est à dire plus géométrique) de vecteur. A ce titre, les éléments d'un espace vectoriel peuvent être additionnés, et multipliés par des nombres.

Exemples

Commençons par quelques exemples simples d'espaces vectoriels ``classiques''.

EXEMPLE 1.2 L'exemple le plus simple d'espace vectoriel est la droite réelle [image] , c'est à dire l'ensemble des nombres réels, que l'on appelle dans ce contexte la droite vectorielle. On sait effectuer sur les réels les opérations suivantes:
  • Addition: pour tous [image] , on sait définir $ u+v$ , qui appartient lui aussi à [image] .
  • Multiplication par un scalaire (ici un nombre réel): pour tout [image] et pour tout [image] , [image] .

EXEMPLE 1.3 Autre exemple: le plan vectoriel, défini comme l'ensemble des couples de réels

Les deux opérations précédentes sont encore bien définies:
  • Addition: pour tous [image] , on sait définir [image] , qui appartient lui aussi à [image] , par la relation

  • Multiplication par un scalaire (ici un nombre réel): pour tout [image] et pour tout [image] , [image] est de la forme

Dans ces deux cas ci-dessus, l'addition est commutative ( [image] ) et associative ( [image] ); il existe un vecteur nul [image] , tel que pour tout [image] , [image] , et tout vecteur [image] possède un opposé (ou inverse), que l'on note [image] (voir en FIG. [*] ).

Figure: Commutativité (à gauche) et associativité (à droite) de l'addition

Quant à la multiplication par un scalaire, elle possède des propriétés voisines (mais pas identiques): elle est commutative ( [image] ) et distributive par rapport à l'addition ( [image] , et [image] ). De plus, la multiplication par le scalaire 1 ne change rien ( [image] ).

Ces propriétés (avec d'autres) sont en fait des propriétés ``génériques'', qui permettent de définir la notion d'espace vectoriel, comme on le verra.

Le cas de

On définit l'espace [image] de la façon suivante.

Dans [image] , ces deux opérations possèdent les mêmes propriétés que celles que nous avons vues plus haut dans le cas de [image] . Elles font de [image] un [image] -espace vectoriel, dont on donnera la définition précise plus loin.

Norme, produit scalaire et angle

En plus de sa structure d'espace vectoriel, [image] est également équipé d'autres outils, comme la norme (qui associe à tout vecteur sa ``longueur''), et le produit scalaire (qui associe à toute paire de vecteurs un scalaire, décrivant leur ``ressemblance''), qui lui confèrent une structure d'espace Euclidien.

La norme d'un vecteur [image] de [image] (qui représente donc sa ``longueur'') est définie par

(1.1)

Dans le cas de [image] , cette égalité correspond au théorème de Pythagore, si l'on identifie les deux composantes [image] du couple [image] aux coordonnées Cartésiennes du point $ M$ du plan tel que [image] .

La norme vérifie l'inégalité triangulaire: pour tous [image] ,

(1.2)

Le produit scalaire de deux vecteurs est défini par

(1.3)

et vérifie la propriété suivante, qui est essentielle

Interprétation: on a donc

et donc il existe [image] tel que

est l'angle entre les deux vecteurs [image] et [image] .

Ces opérations munissent [image] d'une structure d'espace Euclidien. Dans un premier temps, nous nous focaliserons essentiellement sur la structure d'espace vectoriel, laissant de côté les notions de norme et produit scalaire. Nous reviendrons sur ces notions plus tard, lorsque nous traiterons la diagonalisation des matrices.

Définitions: espace vectoriel

La notion centrale de ce chapitre est la notion d'espace vectoriel. On se limitera ici aux notions d'espaces vectoriels sur [image] et sur [image] , qui sont les plus couramment utilisées. On parlera de [image] -espace vectoriel ou de [image] -espace vectoriel. Lorsque les propriétés étudiées sont vraies indifféremment dans les cas réel ou complexe, on parlera de [image] -espace vectoriel ( [image] représentant génériquement [image] ou [image] ), ou d'espace vectoriel tout simplement.

Espace vectoriel

En sciences appliquées, en particulier en physique et en chimie, on est souvent amené à manipuler des nombres complexes. C'est pourquoi il est utile d'étendre la notion d'espace vectoriel aux nombres complexes. La définition d'un [image] -espace vectoriel est presque identique à la définition d'un [image] -espace vectoriel, la seule différence étant que la multiplication par un scalaire est cette fois la multiplication par un nombre complexe.

REMARQUE 1.4 On peut vérifier que tout [image] -espace vectoriel est automatiquement un [image] -espace vectoriel. La réciproque est fausse.

Exemples

Outre les exemples géométriques ( [image] ) que nous avons vus plus haut, on utilise souvent d'autres exemples d'espaces vectoriels, dans bien des domaines.
  • Le premier exemple qui vienne à l'esprit est celui de l'espace

    (1.4)

    on peut facilement vérifier que [image] est un [image] -espace vectoriel, dès lors que l'on définit l'addition et la multiplication par un scalaire comme suit: pour tous [image] , [image] et [image] ,

    et

  • , et en particulier [image] , est également un [image] -espace vectoriel, comme on peut le vérifier facilement.
  • Considérons l'ensemble des solutions d'un système homogène de deux équations linéaires

    où [image] . L'ensemble des solutions est un sous-ensemble de [image] , dont on peut montrer qu'il s'agit d'un espace vectoriel, lorsque l'on le munit de l'addition et la multiplication scalaire de [image] .
  • Un autre exemple simple est l'exemple des espaces de polynômes. Etant donné un entier $ d$ , on considère l'ensemble [image] des polynômes de degré inférieur ou égal à $ d$ à coefficients complexes, c'est à dire des fonctions

    les nombres [image] étant des nombres complexes. Cet ensemble de polynômes est muni d'une structure de [image] -espace vectoriel, grâce à l'addition et la multiplication par un scalaire suivantes: pour tous polynômes $ P,P'$ de degré inférieur ou égal à $ d$ , et tout complexe [image] , $ P+P'$ et [image] sont les polynômes définis par

  • est également un [image] -espace vectoriel. L'ensemble des polynômes de degré inférieur ou égal à $ d$ à coefficients réels est un [image] -espace vectoriel, mais pas un [image] -espace vectoriel.
  • On note [image] l'ensemble des fonctions définies sur [image] , à valeurs dans [image] . On montre facilement qu'en définissant l'addition des fonctions et leur multiplication par un scalaire comme

    acquiert une structure de [image] -espace vectoriel.
  • On considère l'ensemble des fonctions [image] , solutions d'une équation différentielle linéaire homogène donnée, par exemple

    On peut facilement vérifier que l'ensemble de ces solutions forme un [image] -espace vectoriel, en définissant l'addition et la multiplication par un scalaire comme ci-dessus.

Familles de vecteurs, sous-espaces vectoriels, dimension

Sous-espace vectoriel

EXEMPLE 1.4 Par exemple, considérons l'espace vectoriel [image] , et le sous-ensemble

Figure: Le plan vectoriel dans [image] , d'équation [image] . On note qu'il passe par l'origine.

Il est possible de montrer que $ F$ est un sous-espace vectoriel de [image] , c'est à dire que tous les axiomes des définition [*] et [*] sont satisfaits. On le démontrera un peu plus loin, de façon plus simple.

EXEMPLE 1.5 Revenons sur l'exemple que nous avons évoqué un peu plus haut, du système homogène de deux équations linéaires à deux inconnues

Comme on l'a vu, les solutions de ce système forment un sous-ensemble de [image] . Montrons maintenant qu'il s'agit d'un sous-espace vectoriel de [image] .
  • Soient $ (x,y)$ et $ (x',y')$ deux solutions de ce système. Alors on voit facilement que $ a(x+x') + b(y+y')=0$ et $ c(x+x') + d(y+y')=0$ , donc $ (x,y) + (x',y')$ est également solution.
  • Soit $ (x,y)$ une solution, et soit [image] . On a aussi [image] et [image] , de sorte que [image] est solution.
On a bien montré que l'ensemble des solutions est un sous-espace vectoriel de [image] , c'est donc un [image] -espace vectoriel.

Etant donnés un espace vectoriel $ E$ et un sous-ensemble $ F$ , montrer que $ F$ est un sous-espace vectoriel de $ E$ demande de vérifier tous les axiomes de la définition [*] . Cela n'est en fait pas nécessaire, grâce au résultat suivant.

Preuve: Ces conditions sont évidemment nécessaires. Pour prouver qu'elles sont suffisantes, remarquons que les axiomes ( [*] ) à ( [*] ) sont satisfaits dans $ E$ , et comme [image] , ils sont donc sautomatiquement satisfaits dans $ F$ , à l'exception de l'existence de l'élément neutre ( [*] ) et de l'opposé ( [*] ), qu'il faut vérifier. Ces deux propriétés sont conséquence des hypothèses: en effet, pour tout [image] , [image] , de sorte que [image] . De plus, pour tout [image] , [image] , ce qui conclut la démonstration.

De façon plus générale, on déduit de ce résultat le corollaire

Preuve: Il suffit de démontrer que ( [*] ) est équivalente aux équations ( [*] ) et ( [*] ), ce qui est immédiat.

Revenons à l'exemple [*] ci-dessus. Pour montrer qu'un tel $ F$ est un sous-espace vectoriel de [image] , il suffit donc de montrer que $ F$ est non-vide, ce qui est assuré dès lors que l'on remarque que par exemple, [image] , et que pour tous [image] et [image] , ( [*] ) est satisfaite. Considérons donc [image] et [image] , et calculons, pour des [image] quelconques,

Alors, on voit facilement que

car [image] . Ceci prouve donc que ce $ F$ est bien un sous-espace vectoriel de [image] . Il s'agit d'un plan vectoriel.

Familles de vecteurs: familles libres, liées, génératrices

Soit $ E$ un espace vectoriel (réel ou complexe) et soient [image] $ p$ vecteurs de $ E$ . Si [image] sont $ p$ scalaires, alors on dit que le vecteur

(1.5)

est une combinaison linéaire des vecteurs [image] .

On dit aussi que la famille [image] engendre $ E$ , et on note

Notons qu'il existe toujours une infinité de familles génératrices pour un espace vectoriel.

EXEMPLE 1.6 Reprenons l'exemple du plan vectoriel $ F$ de l'exemple [*] . Il est facile de voir que tout [image] est de la forme [image] . On peut alors écrire

de sorte que les vecteurs [image] et [image] forment une famille génératrice de $ F$ .

Considérons maintenant les vecteurs [image] et [image] . Ces deux vecteurs forment ils une famille génératrice de $ F$ ?

Pour s'en assurer, soit [image] , quelconque. La question est, ``existe-t-il [image] tels que

Cette équation vectorielle est équivalente au système de trois équations linéaires à deux inconnues ( [image] et [image] )

Par substitution, ce système est équivalent à

qui est lui même équivalent à

Ainsi, pour tous $ x,y$ , on a bien trouvé [image] et [image] satisfaisant à la condition ci-dessus, donc la famille [image] est bien une famille génératrice pour $ F$ .

On vérifie aussi facilement que pour tout [image] , on peut écrire par exemple [image] , de sorte que la famille [image] engendre $ F$ elle aussi.

Par exemple, [image] et [image] sont de dimension finie. Par contre, on peut trouver beaucoup d'exemples d'espaces vectoriels de dimension infinie, comme des espaces vectoriels de suites ou de fonctions. On ne considèrera pas de tels exemples dans ce cours.

EXEMPLE 1.7 Reprenons de nouveau l'exemple [*] ci-dessus. On peut vérifier que [image] est une famille libre. Par exemple, supposons que [image] . Cette équation peut s'écrire [image] , ce qui implique [image] . Ainsi, [image] et [image] sont linéairement indépendants.

En revanche, considérons maintenant la famille [image] . Soit [image] , et supposons [image] . Ceci implique que [image] , équation qui admet des solutions non-nulles: . Donc la famille [image] est liée.

Preuve: Soit [image] une famille libre de $ p$ vecteurs dans $ E$ , et supposons qu'il existe des nombres [image] et [image] tels que

Alors on en déduit que

d'où, la famille étant libre,

et donc .

EXEMPLE 1.8 Dans , considérons deux vecteurs orthogonaux et , comme dans la FIG. [*] , et posons

Figure: Un seul développementUne infinité de développements

La famille est une famille libre, alors que la famille est une famille liée. Ceci se traduit par le fait qu'un vecteur quelconque de s'écrit de façon unique comme combinaison linéaire de et , alors qu'il existe une infinité de façons différentes de l'écrire comme combinaison linéaire de , , et . En effet, considérons par exemple le vecteur . Cette expression constitue l'unique écriture de comme combinaison linéaire de et . Par contre, on peut également écrire, pour tout ,

Ceci étant vrai pour tout , on obtient ainsi une infinité de décompositions possibles.

REMARQUE 1.5 Dans un -espace vectoriel, la notion de dépendance linéaire ou indépendance linéaire d'une famille de vecteurs dépend évidemment de . Par exemple, prenons qui, comme nous l'avons vu, peut être muni d'une structure de $ CC$ -espace vectoriel et de -espace vectoriel. Dans le -espace vectoriel , la famille de vecteurs est une famille libre: en effet, il n'existe pas , non simultanément nuls, tels que . Par contre, dans le -espace vectoriel , il s'agit d'une famille liée, car on peut trouver , non simultanément nuls, tels que (prendre ). Pour préciser les choses, on parle parfois de famille -libre ou -liée ( ou ).

Bases, dimension

Clairement, toute famille libre n'est pas obligatoirement génératrice, et toute famille génératrice n'est pas obligatoirement libre. La notion de base représente en quelque sorte le ``juste compromis'' entre ces deux notions, comme on va le voir dans l'exemple qui suit.

EXEMPLE 1.9 Reprenons l'exemple du -espace vectoriel . Les vecteurs , et forment une famille dont on vérifie facilement qu'elle est
  • Libre: soit une combinaison linéaire quelconque de et . Alors , et implique .
  • Génératrice: pour tout , on a obligatoirement .
Il est clair que si l'on enlève un élément à cette famille, la famille résultante n'est plus génératrice: par exemple, tout ne peut pas s'écrire comme combinaison linéaire de et seuls. Par contre, si on ajoute n'importe quel vecteur à cette famille, la famille résultante ne sera pas libre, le nouveau vecteur pouvant s'exprimer comme combinaison linéaire des trois premiers.

Ainsi, la famille représente le bon compromis pour écrire les éléments de comme combinaisons linéaires. C'est ce que l'on appelle une base de , en l'occurrence la base canonique de .

Dans le cas de , la base canonique de est la famille constituée des vecteurs , pour , le seul élément non-nul du vecteur étant le $ j$ -ième.

Le théorème qui suit, que nous donnons sans démonstration, est un résultat fondamental.

Par exemple, la dimension de est égale à $ n$ , la base canonique de ayant $ n$ éléments.

Pour illustrer ce résultat, il est utile de considérer un exemple simple.

EXEMPLE 1.10 Dans , on considère les deux vecteurs et . On voit facilement qu'ils forment une famille libre, et qu'on peut toujours leur adjoindre une troisième vecteur, par exemple pour obtenir une famille génératrice.

Similairement, partant d'une famille génératrice de 4 vecteurs de , on voit facilement qu'on peut lui enlever un vecteur, la famille résultante étant maintenant libre, et toujours génératrice.

REMARQUE 1.6 Notons que la dépendance de la dimension d'un -espace vectoriel est un aspect important. Prenons par exemple le cas de . La dimension de change selon que est considéré comme -espace vectoriel ou -espace vectoriel. On peut facilement montrer que , alors que .

Ce résultat a de nombreuses conséquences ``pratiques''. Celle qui suit se démontre aisément.

Preuve: Considérons une famille de plus de $ n$ vecteurs, et supposons qu'elle soit libre; d'après le théorème de la dimension, elle peut être complétée pour former une base, mais celle-ci aurait alors plus de $ n$ vecteurs, ce qui est impossible. Donc la famille ne peut être libre. Considérons maintenant une famille de moins de $ n$ vecteurs, et supposons qu'elle soit génératrice. On peut alors en extraire une base, qui aurait alors moins de $ n$ vecteurs, ce qui est encore une fois impossible. La famille ne peut donc pas êtretre génératrice.

Soit $ E$ un espace vectoriel de dimension $ n$ , et soit une famille libre de $ n$ vecteurs de $ E$ . Supposons qu'elle ne soit pas génératrice. Alors d'après le 2) du théorème [*] , on peut la compléter pour former une base de $ E$ . Mais celle-ci a alors plus de $ n$ éléments, ce qui est impossible. Donc la famille est nécessairement génératrice.

Similairement, soit une famille génératrice de $ E$ , supposons qu'elle ne soit pas libre. Alors d'après le 1) du théorème [*] , on peut lui enlever des éléments pour obtenir une base, mais celle-ci compte moins de $ n$ éléments, ce qui est impossible. Donc la famille est obligatoirement libre.

On a donc montré

Finalement, on déduit de la définition d'une famille génératrice et de la proposition [*] l'existence et l'unicité du développement d'un vecteur sur une base:

Dans le cas simple de (ou ), dont on a vu plus haut la base canonique, il est facile de voir que les composantes d'un vecteur dans cette base canonique ne sont autres que les nombres .

Dans un cas plus général, la détermination des composantes d'un vecteur sur une base demande un peu plus de travail.

EXEMPLE 1.11 Comment déterminer les composantes d'un vecteur par rapport à une base ? Prenons l'exemple de , et de la base constituée par les deux vecteurs et . Considérons un vecteur de , par exemple . On cherche à écrire

ce qui revient à résoudre le système

Ce système se résoud facilement, et conduit à et .

Dans des cas plus complexes, il est possible d'utiliser des techniques plus systématiques, comme par exemple la méthode du pivot de Gauss, décrite un peu pus loin.

Union et intersection d'espaces vectoriels

Soient $ F$ et $ G$ deux sous-espaces vectoriels d'un espace vectoriel $ E$ . On considère la réunion de $ F$ et $ G$

(1.6)

est clairement un sous-ensemble de $ E$ , par construction. Par contre, ça n'est pas un sous-espace vectoriel de $ E$ en général.

EXEMPLE 1.12 Prenons , et

$ F$ et $ G$ sont deux sous-espaces vectoriels de $ E$ (de dimension ). Par contre, n'est pas un sous-espace vectoriel de $ E$ , donc n'est pas un espace vectoriel. Par exemple, soient et , ils appartiennent tous deux à , mais .

Considérons maintenant l'intersection de deux sous-espaces vectoriels $ F$ et $ G$ de $ E$

(1.7)

Soient . Alors et ; donc, $ F$ et $ G$ étant des sous-espaces vectoriels de $ E$ , et , d'où . On a ainsi montré

EXEMPLE 1.13 Si nous reprenons l'exemple précédent, nous voyons bien que

est limité au seul vecteur nul de ... ce qui est bien un sous-espace vectoriel, de dimension 0.

Somme et somme directe d'espaces vectoriels

Etant donnés deux sous-espaces vectoriels $ F$ et $ G$ d'un espace vectoriel donné $ E$ , il est possible de considérer l'ensemble formé des sommes d'éléments de $ F$ et $ G$ . Il est facile de montrer que cet ensemble est en fait un espace vectoriel.

Supposons que et soient deux sous-espaces vectoriels de $ E$ , et soit . Soit . Alors il existe et tels que . Supposons qu'il existe un autre couple de vecteurs et tels que . Alors on a , c'est à dire une égalité entre un vecteur de et un vecteur de . A ce point, de deux choses l'une: soit , auquel cas ces deux vecteurs sont nécessairement nuls. Soit , et on peut avoir et . On a donc montré

Qu'en est-il de la dimension de la somme de deux sous-espaces vectoriels de dimension finie ? Si $ F$ et $ G$ sont de dimension finie, disons $ m$ et $ n$ , alors ils admettent chacun une base de respectivement $ m$ et $ n$ élements. L'union de ces deux bases est une famille génératrice de $ F+G$ , qui est ainsi de dimension inférieure ou égale à $ m+n$ . Si la somme $ F+G$ est une somme directe, c'est à dire si , alors l'union des deux bases est cette fois une base de , et la dimension de est alors égale à $ m+n$ . On a donc montré

EXEMPLE 1.14 Prenons , et soient

On voit facilement que , donc la somme $ F+G$ est une somme directe. De plus, $ F$ est de dimension 2 (par exemple, une base de $ F$ est donnée par les vecteurs et ), et $ G$ est de dimension $ 2$ (base: ).

On a alors

Dans l'exemple [*] ci-dessus, cette égalité est bien vérifiée.

EXEMPLE 1.15 Prenons , et soit

une droite vectorielle. Alors, on peut vérifier que les supplémentaires de $ F$ sont toutes les droites vectorielles du plan différentes de $ F$ .

Le pivot de Gauss

La méthode du pivot de Gauss (ou élimination de Gauss) est une technique simple et puissante de résolution de systèmes linéaires, de la forme

(1.8)

les et les étant $ mn$ et $ m$ scalaires, respectivement, et étant les $ n$ inconnues.

Commençons par l'illustrer sur un exemple, avant de voir en quoi elle peut être utile pour résoudre des problèmes simples d'algèbre linéaire.

La base de la méthode du pivot de Gauss pour la résolution de systèmes linéaires est l'ensemble des trois propriétés fondamentales: La solution d'un système d'équations linéaires ne change pas si

  1. On permute l'ordre des équations
  2. On multiplie (terme à terme) une équation par un scalaire non-nul.
  3. On ajoute à une équation une combinaison linéaire quelconque des autres équations

La méthode, sur un exemple simple

Considérons le système linéaire de trois équations à trois inconnues

(1.9)

La méthode de Gauss consiste à substituer à ce système un autre système d'équations, équivalent, dans lequel on élimine par substitutions successives des variables. Par exemple, dans le cas qui nous intéresse, en remplaçant les deux dernières équations $ (b)$ et $ (c)$ par $ 2(a)-(b)$ et $ 3(a)-(c)$ respectivement (au sens de la soustraction des équations ``terme à terme''), on obtient

puis en substituant à $ (c')$ l'équation , on obtient le système étagé suivant

qui est facile à résoudre: $ (c'')$ donne , puis en substituant dans $ (b')$ on obtient $ y=(-3-11z)/4 = 10/27$ , puis finalement $ (a)$ donne .

Application à la question: ``une famille de vecteurs est-elle libre ?''

La méthode du pivot de Gauss possède de nombreuses applications. Par exemple, étant donnée une famille de vecteurs, elle peut permettre de dire si cette famille est une famille libre. En d'autres termes, étant donnés un certain nombre de vecteurs de (ou ) (avec , sans quoi la famille est automatiquement liée), existe-t-il des scalaires tels que

(1.10)

S'il existe de tels scalaires, non simultanément nuls, alors la famille est liée. Sinon, la famille est libre.

Si l'on connait les composantes des vecteurs dans la base canonique, cette équation vectorielle peut s'écrire comme un système de $ n$ équations linéaires, que l'on peut résoudre par la méthode du pivot.

EXEMPLE 1.16 Dans , considérons les vecteurs , et , et cherchons une éventuelle relation de la forme . Cette équation vectorielle se ramène alors au système

Le pivot de Gauss permet de transformer ce système en

puis

qui implique . Le système est bien un système libre dans (et en est donc une base).

Une autre question reliée, qui peut également être traitée par élimination de Gauss: étant donnée une famille de vecteurs, trouver (s'il en existe) une relation linéaire entre ces vecteurs. Cette question se formule de façon identique à la précédente: il faut trouver les scalaires dans ( [*] ).

EXEMPLE 1.17 Dans , considérons les vecteurs , et , et cherchons une éventuelle relation de la forme . Cette équation vectorielle se ramène alors au système

Le pivot de Gauss permet de transformer ce système en

et il n'est pas nécessaire d'aller plus loin pour voir que les deux dernières équations sont équivalentes, et donnent , d'où . La relation linéaire recherchée est donc, en prenant ,

ce que l'on peut encore écrire

de sorte que tout s'écrit comme combinaison linéaire de et . Ainsi

qui est un sous-espace vectoriel de de dimension deux (car la famille est une famille libre.

On verra plus bas comment caractériser ce sous-espace vectoriel.

Application à la question: ``une famille de vecteurs est-elle génératrice ?''

En d'autres termes, étant donnés un certain nombre de vecteurs de (ou ) (avec , sans quoi la famille ne peut être génératrice), peut-on trouver pour tout des scalaires tels que

Si l'on connait les composantes des vecteurs , dans la base canonique, cette équation vectorielle peut s'écrire comme un système de $ n$ équations linéaires (inhomogène cette fois), que l'on peut résoudre par la méthode du pivot.

EXEMPLE 1.18 Dans , considérons les vecteurs , et . Soit , quelconque, la question est de savoir si l'on peut écrire . Cette équation vectorielle est équivalente à un système inhomogène de trois équations linéaires

Le pivot de Gauss permet de transformer ce système en

puis en

La troisième équation se simplifie en

d'où on déduit ensuite puis par

Ainsi, pour tout , on a bien pu l'exprimer comme combinaison linéaire de , , et , ces trois vecteurs constituent donc une famille génératrice de .

EXEMPLE [*] (SUITE) Comment caractériser le sous-espace vectoriel de engendré par les vecteurs ? Il suffit de considérer un vecteur quelconque

En posant , on a donc

syst ème qui se met sous la forme

d'où on déduit que $ 4(x-y) = 3(z-y)$ , et donc l'équation de

Notons qu'on aurait obtenu exactement le même résultat en exprimant comme combinaison linéaire de et ... au prix de calculs un peu plus longs.

next up previous index
Next: Calcul Matriciel Up: CALCUL MATRICIEL Previous: CALCUL MATRICIEL Index


Calcul Matriciel

next up previous index
Next: Applications Linéaires Up: CALCUL MATRICIEL Previous: Espaces vectoriels Index

Subsections
  • Matrices
    • Définitions
    • Opérations simples sur les matrices

  • Produit de matrices
    • Le produit ``Matrice [image] Vecteur''
    • Produits de matrices carrées
    • Produits de matrices rectangulaires
    • Transposée d'un produit de deux matrices
    • Puissances d'une matrice carrée
    • Inverse d'une matrice carrée

  • Matrices, systèmes linéaires, et pivot de Gauss
  • Matrices particulières

Calcul Matriciel

Les matrices jouent un rôle fondamental en algèbre linéaire, où elles fournissent un outil de calcul irremplaçable. L'objectif de ce chapitre est de donner les premières définitions et les bases du calcul matriciel, qui seront utilisées dans les chapitres suivants. On fait également le lien avec les systèmes linéaires, et la méthode du pivot de Gauss.

Matrices

On va introduire ici les matrices, comme de nouveaux objets mathématiques, puis un certain nombre d'opérations sur et avec des matrices. Ceci nous permettra de voir que certaines matrices, à savoir les matrices carrées, peuvent être considérées comme une généralisation des nombres usuels (réels, complexes,...), dans la mesure où on verra qu'on peut les additionner et les multiplier entre elles. On verra qu'il existe toutefois quelques différences importantes entre matrices et nombres, comme par exemple le fait que le produit des matrices carrées n'est pas commutatif.

Définitions

Les cas particuliers les plus couramment rencontrés sont les suivants:

  1. Matrices carrées: ce sont des matrices dont le nombre de lignes $ M$ est égal au nombre $ N$ de colonnes. On vera que ces matrices carrées possèdent un certain nombre de propriétés spécifiques que n'ont pas les matrices ``rectangulaires'' quelconques.
  2. Matrices colonnes (parfois appelées ``vecteurs colonne''): ce sont des matrices

    Etant donné un vecteur [image] dans un espace vectoriel de dimension finie $ E$ , et une base [image] de ce dernier, on a vu que [image] admet une unique décomposition comme combinaison linéaire sur la base [image] :

    est donc complètement caractérisé par ses coordonnées dans la base [image] , que l'on a coutume de représenter par une matrice colonne

    Il est très important de remarquer que cette matrice colonne dépend non seulement de [image] , mais aussi de la base [image] . Si une autre base [image] est choisie, les coordonnées changent: en général.
  3. Matrices lignes: (parfois appelées ``vecteurs ligne'', ou ``covecteurs''): ce sont des matrices [image] .

    Une matrice ligne n'est finalement pas autre chose qu'un $ N$ -uplet, on peut donc identifier l'ensemble [image] avec [image] .

La matrice identité [image] est une matrice [image] dont tous les éléments sont nuls, sauf les éléments diagonaux qui valent 1:

(2.1)

Opérations simples sur les matrices

On peut effectuer un certain nombre d'opérations simples sur les matrices.
  1. Addition des matrices: Soient $ A,B$ deux matrices [image] . La matrice [image] est la matrice [image] , dont les éléments sont les nombres $ c_{ij} = a_{ij} + b_{ij}$ :

    (2.2)

    On ne peut additionner que des matrices de même taille
    La matrices résultante est de même taille
  2. Multiplication par un scalaire. Soit $ A$ une matrice [image] , et soit [image] un scalaire (réel ou complexe). Le produit de [image] par $ A$ est la matrice [image] notée [image] , et définie par

    (2.3)

    La matrices résultante est de même taille que la matrice initiale
  3. Transposition. Soit $ A$ une matrice [image] . La transposée de $ A$ , notée $ B = {}^T A$ , est la matrice [image] définie par $ b_{ij} = a_{ji}$ :

    (2.4)

    Par exemple, la transposée d'une matrice carrée est encore une matrice carrée de même taille; la transposée d'une matrice colonne de $ M$ éléments est une matrice ligne de $ M$ éléments, et la transposée d'une matrice ligne de $ N$ éléments est une matrice colonne de $ N$ éléments.
  4. Conjugaison Hermitienne. Soit $ A$ une matrice [image] . La conjuguée Hermitienne de $ A$ , notée $ B = {}^H A$ , est la matrice [image] définie par [image] :

    (2.5)

    La conjuguée Hermitienne d'une matrice carrée est encore une matrice carrée de même taille; la conjuguée Hermitienne d'une matrice colonne de $ M$ éléments est une matrice ligne de $ M$ éléments, et la conjuguée Hermitienne d'une matrice ligne de $ N$ éléments est une matrice colonne de $ N$ éléments.

Par exemple, la transposée de la matrice

est la matrice

alors que sa conjuguée Hermitienne est la matrice

Une conséquence importante des deux premières propriétés listées ci-dessus est le théorème suivant:

En effet, les opérations d'addition des matrices et de multiplications des matrices par un scalaire sont bien définies. On peut aussi facilement vérifier que tous les axiomes de la définition d'un [image] (ou [image] )-espace vectoriel sont bien satisfaits.

Produit de matrices

Sous certaines conditions, les matrices peuvent être multipliées entre elles, pour donner d'autres matrices. La règle d'or du produit matriciel est la suivante:

Dans un produit [image] de deux matrices $ A$ et $ B$ , les lignes de $ A$ sont multipliées élément par élément par les colonnes de $ B$ . Il faut donc que les lignes de $ A$ aient le même nombre d'éléments que les colonnes de $ B$ .

Le produit ``Matrice Vecteur''

L'une des opérations fondamentales est le produit d'une matrice par un vecteur colonne. La règle opératoire est simple.

Soit [image] une matrice [image] (c'est à dire, à $ M$ lignes et $ N$ colonnes), et soit [image] une matrice colonne, à $ N$ lignes:

Alors [image] est une matrice colonne, à $ M$ lignes

Cette opération est bien conforme à la règle d'or énoncée plus haut: la longueur des lignes de la matrice (donc, le nombre de colonnes) est égale au nombre d'éléments (c'est à dire de lignes) de la colonne.

EXEMPLE 2.1 Calculons par exemple

EXEMPLE 2.2 Application: considérons un système linéaire de deux équations à trois inconnues $ x,y,z$ :

On vérifie facilement que ce système peut se mettre sous la forme d'une égalité entre deux matrices colonne (à deux lignes)

EXEMPLE 2.3 Dans le plan, on peut exprimer l'action d'une rotation d'angle [image] autour de l'origine sur les coordonnées $ (x,y)$ d'un point du plan (voir FIG. [*] ci dessous), sous forme matricielle

Figure: Rotation d'angle [image] autour de l'origine du plan.

En effet, en notant [image] , le point initial peut être décrit par ses coordonnées polaires [image] , et son image par la rotation par ses coordonnées polaires [image] . On a donc

ce qui coïncide avec l'égalité ci-dessus.

EXEMPLE 2.4 Dans [image] , les rotations autour de l'origine sont plus complexes. La notion de base reste la notion de rotation dans un plan; par exemple, la matrice associée à la rotation d'angle [image] dans le plan $ xOy$ , autour de l'axe $ z$ , est de la forme

alors que la matrice de la rotation d'angle [image] dans le plan $ yOz$ , donc autour de l'axe $ x$ , s'écrit

Figure: Paramétrisation d'une rotation de [image] par ses angles d'Euler.

Il est possible de démontrer que toute matrice de rotation de l'espace [image] peut se mettre sous la forme d'un produit de trois matrices

les trois angles [image] sont appelés angles d'Euler de $ R$ .

EXEMPLE 2.5 En mécanique classique, on repère les coordonnées spatio-temporelles d'un point par rapport à un référentiel Galiléen par une matrice colonne

Etant donné un second référentiel Galiléen, en translation uniforme de vitesse [image] par rapport au premier, les coordonnées spatio-temporelles du point par rapport au second référentiel peuvent s'exprimer sous forme matricielle, faisant intervenir la matrice Galiléenne

On peut en effet écrire les nouvelles coordonnées

L'action de la matrice identité [image] est particulièrement simple: étant donné une matrice colonne, notée [image] , on a

(2.6)

Produits de matrices carrées

Soient $ A$ et $ B$ deux matrices carrées [image] . Le produit [image] est bien défini, et donne encore une matrice

(2.7)

ce que l'on synthétise sous la forme suivante

(2.8)

Par exemple, le produit de deux matrices [image] s'écrit

EXEMPLE 2.6 Si l'on reprend le cas des matrices de rotation du plan vue dans l'exemple [*] : on sait que la composée d'une rotation d'angle [image] autour de l'origine par une rotation d'angle [image] autour de l'origine est toujours une rotation autour de l'origine du plan, d'angle [image] . Au niveau matriciel, une peu de trigonométrie montre que

EXEMPLE 2.7 Reprenons cette fois l'exemple des matrices Galiléennes de l'exemple [*] ci-dessus. Il est clair que si un premier référentiel est animé d'un mouvement rectiligne de vitesse [image] par rapport à un second, lui même animé d'un mouvement rectiligne de vitesse [image] par rapport à un troisième, le premier est animé d'un mouvement rectiligne de vitesse [image] par rapport au troisième. En termes de matrice, les coordonnées du point considéré par rapport au troisième référentiel s'expriment sous la forme

ce qui amène à considérer le produit matriciel [image] . On obtient alors facilement

d'où

On peut noter que dans ces deux derniers exemples, le produit de ces matrices était commutatif. Par exemple, [image] . Il est important de se souvenir que tel n'est pas toujours le cas, comme le montre l'exemple suivant: on a

alors que

Donc, le produit matriciel est (en général) non commutatif. Par contre, quelques calculs permettent de montrer que

REMARQUE 2.1
  1. Soient $ A,B$ et $ C$ trois matrices carrées. L'égalité [image] entre les produits de matrices $ AB$ et $ AC$ n'implique pas [image] .
  2. Etant données deux matrices carrées $ A$ et $ B$ , on peut avoir [image] sans que [image] ni [image] .

Là encore, la matrice identité joue un rôle particulier. On vérifie aisément, en utilisant la définition du produit des matrices carrées

Produits de matrices rectangulaires

Il est parfois possible de multiplier entre elles des matrices rectangulaires. Un premier exemple est le produit ``matrice-vecteur'' que nous avons vu plus haut. Le cas des matrices carrées est lui aussi un exemple particulier.

Dans le cas général, il n'est pas possible de multiplier n'importe quelle matrice par n'importe quelle matrice. La règle d'or énoncée plus haut impose des contraintes fortes.

Plus précisément, pour pouvoir multiplier deux matrices $ A$ et $ B$ , il faut et il suffit que les lignes de $ A$ aient même longueur que les colonnes de $ B$ . Voir en FIG. [*] pour une preprésentation graphique de la situation.

Figure: Représentation schématique du produit de matrices rectangulaires

Ainsi, si [image] est une matrice [image] et si [image] est une matrice [image] , alors on pourra effectuer le produit [image] . $ C$ est alors une matrice [image] , dont les éléments sont donnés par

(2.9)

ce que l'on synthétise sous la forme suivante

(2.10)

EXEMPLE 2.8 Calculons le produit d'une matrice [image] par une matrice

on obtient bien une matrice [image] .

La question de la commutativité des matrices rectangulaires ne se pose pas (à moins qu'elles ne soient carrées). Si $ A$ et $ B$ ne sont pas des matrices carrées, on ne pourra pas calculer à la fois le produit $ AB$ et le produit $ BA$ . Par contre, on a

Transposée d'un produit de deux matrices

Il est possible de montrer le résultat suivant, donné sans démonstration ici.

Ainsi, la transposition inverse l'ordre des matrices dans un produit matriciel.

De façon plus générale, cette propriété reste vraie dans le cas de produits de plusieurs matrices: étant données une famille de matrices [image] telles que le produit [image] ait un sens, on a

Puissances d'une matrice carrée

Partant de la définition du produit de matrices carrées, on peut considérer le cas particulier des puissances d'une matrice. En effet, étant donnée une matrice [image] , on peut considérer les matrices [image] définies par

et par récurrence la $ N$ -ième puissance d'une matrice $ A$

(2.11)

EXEMPLE 2.9 Reprenons le cas des rotations du plan, en posant

et utilisant les calculs précédents, on voit facilement que

et plus généralement, par récurrence

A quoi cela sert-il ? supposons que nous ayions à étudier une transformation linéaire du plan, associant à un point $ P$ de coordonnées $ (x,y)$ le point $ P'$ de coordonnées $ (ax+by,cx+dy)$ . Organisant les coordonnées sous forme d'un vecteur colonne, on peut écrire

avec une matrice

Si on applique une deuxième fois cette transformation, on va aboutir à un nouveau point du plan dont les coordonnées sont données par

et en appliquant $ k$ fois cette transformation, on aboutit à un nouveau point du plan dont les coordonnées sont données par

On verra à la fin de ce cours des techniques permettant de calculer simplement des puissances d'une matrice.

Inverse d'une matrice carrée

On a déjà vu que les matrices carrées possèdent un statut particulier. En effet, le produit de deux matrices de [image] est encore une matrice de [image] . De plus, on a vu que la matrice identité [image] joue un rôle d'élément neutre pour le produit matriciel dans [image] . Il est donc naturel de s'interroger sur l'existence d'une notion d'inverse d'une matrice.

On verra plus loin qu'il est possible de simplifier cette définition, et de montrer le résultat suivant.

REMARQUE 2.2 On peut considérer que les matrices sont en quelque sorte une généralisation des nombres, puisque l'on peut les additionner, les soustraire et les multiplier. La première différence de marque entre nombres et matrices tient dans le fait que le produit matriciel n'est pas commutatif en général, contrairement au produit des nombres. Une seconde différence fondamentale est que toute matrice n'admet pas nécessairement une matrice inverse (parmi les nombres, seul le nombre zéro n'admet pas d'inverse). On verra par exemple que des matrices très simples, telles que

et bien d'autres encore, n'admettent pas d'inverse. C'est ce qui fait une des difficultés,... mais aussi le piment du calcul matriciel...

Etant donnée une matrice [image] , rechercher l'inverse de $ A$ revient à résoudre (si possible) un système de [image] équations à [image] inconnues. Ceci dit, il est possible de simplifier le problème d'inversion, en exploitant les connexions avec les systèmes linéaires.

En effet, étant donné une matrice colonne [image] , considérons le système linéaire, posé sous forme matricielle

Síl existe $ B$ telle que [image] , alors on pourra écrire

ou encore

c'est à dire que l'on aura résolu le système linéaire. Inversement, la solution du système linéaire, si elle existe, prendra nécessairement cette forme. Par conséquent, inverser $ A$ équivaut à résoudre le système linéaire [image] pour un membre de droite $ V$ quelconque.

EXEMPLE 2.10 Reprenons l'exemple d'une matrice de rotation [image] . Naturellement, la matrice inverse ne pàeut être autre que [image] . Vérifions le en résolvant le système linéaire

autrement dit

qui équivaut à

En reportant la seconde équation dans la première, on obtient [image] , d'où la solution sous forme matricielle

et finalement

Considérons deux matrices carrées [image] , supposées inversibles. On peut alors former le produit [image] , et calculer

On a donc montré

REMARQUE 2.3 On pourrait s'étonner que l'inverse du produit de deux matrices soit le produit des inverses, dans l'ordre inverse. En fait, ceci est tout sauf surprenant, si l'on interprète correctement les choses. En prenant une analogie dans la vie courante, quelle est l'opération inverse de l'opération matinale ``mettre ses chaussettes puis mettre ses chaussures'' ? on ôte tout d'abord ses chaussures, avant d'ôter ses chaussettes. Il se passe la même chose avec les matrices. Multiplier par $ AB$ une matrice colonne revient à la multiplier par $ B$ , puis multiplier le résultat par $ A$ . L'opération inverse sera donc de multiplier par [image] , puis par [image] , ce qui revient à multiplier par [image] .

Matrices, systèmes linéaires, et pivot de Gauss

Le pivot de Gauss, qu'on a vu précédemment, peut se mettre sous forme matricielle. En effet, considérons un système linéaire de $ n$ équations à $ m$ inconnues

Ce système linéaire peut se mettre sous forme matricielle

et les manipulations que nous avons effectuées dans le cadre de l'application de la méthode du pivot peuvent elles aussi s'écrire sous cette forme.

On peut par exemple introduire la notation suivante, en accolant à la matrice $ A$ la colonne de $ b$ , séparée par une ligne verticale pour éviter tout risque de confusion avec une matrice:

Attention ! Il s'agit uniquement d'une notation destinée à simplifier l'écriture d'un système linéaire. Ceci n'introduit aucun objet mathématique nouveau.

Reprenant ce que nous avons vu au chapitre précédent, on peut de nouveau dire que l'ensemble des solutions du système ne change pas lorsque

  1. On permute l'ordre des lignes
  2. On multiplie (terme à terme) une ligne par un scalaire non-nul.
  3. On ajoute à une ligne une combinaison linéaire quelconque des autres lignes.

EXEMPLE 2.11 Reprenons le système linéaire de trois équations à trois inconnues

(2.12)

Sous forme matricielle, on peut reformuler ce système via le tableau

que l'on transforme en

puis en forme échelonnée

On obtient donc directement la solution: la dernière ligne nous donne [image] , la deuxième $ y=(-3-11z)/4 = 10/27$ , puis finalement la première donne [image] .

Matrices particulières

Certaines matrices carrées possèdent des propriétés caractéristiques qui ont d'importantes conséquences. On en donne une liste non exhaustive ci dessous.

Notons que les éléments diagonaux d'une matrice antisymétrique sont nécessairement nuls.

On peut facilement démontrer que tout matrice peut s'écrire comme somme d'une matrice symétrique et d'une matrice antisymétrique. En effet, étant donnée une matrice $ A$ quelconque, il suffit d'écrire

On vérifie facilement que

et

de sorte que [image] est symétrique, et [image] est antisymétrique.

EXEMPLE 2.12 La matrice

peut sécrire

EXEMPLE 2.13 Dans [image] , considérons la matrice

qui agit sur les vecteurs colonne par rotation d'angle [image] de leurs composantes

Il est immédiat de vérifier que [image] n'est ni symétrique ni antisymétrique, mais que

Notons par exemple que toute matrice réelle symétrique est Hermitienne, et que toute matrice réelle antisymétrique est anti-Hermitienne. Par ailleurs, les éléments diagonaux d'une matrice anti-Hermitienne sont nécessairement nuls.

Dans le même esprit que ce que nous avons vu plus haut, tout matrice peut s'écrire comme somme de'une matrice Hermitienne et d'une matrice anti-Hermitienne. En effet, étant donnée une matrice $ A$ quelconque, il suffit d'écrire

On vérifie facilement que

et

de sorte que [image] est Hermitienne, et [image] est anti-Hermitienne.

EXEMPLE 2.14 Dans [image] , considérons la matrice de rotation [image] . On a

et on voit facilement que pour tout [image] ,

donc pour tout [image] , [image] est une matrice orthogonale.

EXEMPLE 2.15 La matrice carrée

est évidemment nilpotente. Plus généralement, on peut montrer que toute matrice dont tous les éléments placés au dessus de la diagonale (ou en dessous) sont nuls, c'est à dire toute matrice de la forme

où [image] représente un nombre quelconque, est nilpotente.

next up previous index
Next: Applications Linéaires Up: CALCUL MATRICIEL Previous: Espaces vectoriels Index


Applications Linéaires

next up previous index
Next: Déterminants, inversion de matrices Up: CALCUL MATRICIEL Previous: Calcul Matriciel Index

Subsections
  • Applications linéaires
    • Premières définitions et propriétés
    • Matrice d'un vecteur dans une base
    • Applications linéaires et matrices
    • Composition des applications linéaires et produit matriciel
    • Matrice de l'inverse d'une application linéaire

  • Image et noyau d'une application linéaire
    • Definitions
    • Théorème de la dimension

  • Matrices et changements de base
    • Matrice de changement de base
    • Changement de base et composantes d'un vecteur
    • Changement de base et application linéaire

  • Théorie du rang

Applications Linéaires

Applications linéaires

On rappelle qu'une application

d'un ensemble $ E$ vers un ensemble $ F$ associe à tout élément [image] un élément [image] .
  • est surjective si tout élément de $ F$ possède un antécédent par [image] :

  • est injective si deux éléments quelconques de $ E$ ne peuvent avoir la même image par [image] :

  • est bijective si elle est à la fois injective et surjective. Alors, chaque élément de $ E$ est en correspondance avec un élément de $ F$ , et vice versa. On parle de correspondance bi-univoque.

Premières définitions et propriétés

La notion fondamentale de ce chapitre est la notion d'application linéaire. Une application linéaire d'un espace vectoriel vers un autre est une application qui préserve l'addition et la multiplication scalaire. Plus précisément:

EXEMPLE 3.1 Soient $ E,F$ deux [image] -espaces vectoriels. Soit [image] l'application définie par

( [image] étant le vecteur nul dans $ F$ ). Il est facile de vérifier que [image] est une application linéaire.

EXEMPLE 3.2 Soit $ E$ un [image] -espace vectoriel. Soit [image] l'application définie par

Il est facile de vérifier que [image] est une application linéaire, appelée application identité, et notée

EXEMPLE 3.3 Soit [image] , et soit [image] . Soit [image] , définie par

Vérifions que [image] est une application linéaire. Calculons

ce qui montre la première égalité. De plus,

ce qui achève la démonstration.

EXEMPLE 3.4 Soit [image] et soit [image] définie par

Il est manifeste que [image] n'est pas une application linéaire. De même, les applications

ne sont pas des applications linéaires (au moins tant que [image] dans le cas e la première).

EXEMPLE 3.5 On considère l'ensemble [image] des applications [image] dérivables à dérivée continue, et l'ensemble [image] des applications [image] continues. Il est possible de démontrer que [image] et [image] sont des espaces vectoriels: ce sont des sous-ensembles de [image] , dont on a déjà vu qu'il était un [image] -espace vectoriel. De plus, la somme de deux fonctions continues est continue, tout comme le produit d'une fonction continue par un réel. est donc un sous-espace vectoriel de [image] , et par conséquent c'est un [image] -espace vectoriel. On montre de même que [image] est donc un sous-espace vectoriel de [image] , et donc un [image] -espace vectoriel.

Soit $ D$ l'application qui à [image] associe sa dérivée (qui est donc une fonction continue)

On sait que

donc $ D$ est une application linéaire.

Un cas particulier d'application linéaire est fourni par les projections. Soit $ E$ un espace vectoriel, et soient $ F$ et $ G$ deux sous-espaces vectoriels supplémentaires dans $ E$ :

Alors, on sait que pour tout [image] , il existe un unique [image] et un unique [image] tels que

L'application qui associe à tout [image] le vecteur [image] est appelée projection de $ E$ sur $ F$ , parallèlement à $ G$ .

EXEMPLE 3.6 Prenons [image] , et soient

$ F$ et $ G$ sont tous deux de dimension 1; une base de $ F$ est constituée par le vecteur $ (1,2)$ , et une base de $ G$ est constituée par le vecteur $ (1,3)$ .

Pour tout [image] , on sait donc qu'il existe un unique couple de réels [image] tel que

Un calcul explicite montre que

Soit maintenant [image] associant à [image] le vecteur [image] . On a alors

Notons que l'on a aussi

Figure: Projection sur $ F$ parallèlement à $ G$ .
Image Proj

Matrice d'un vecteur dans une base

Soit $ E$ un espace vectoriel de dimension $ n$ , et soit

une base de $ E$ . On a déjà vu que tout vecteur [image] peut se décomposer de façon unique comme combinaison linéaire des vecteurs de la base

Ceci permet d'associer à [image] sa matrice (colonne) dans la base [image] , notée [image] ou plus simplement (lorsqu'il n'y a pas de confusion possible) [image] :

(3.1)

Il est évident que la matrice d'un vecteur dépend de la base choisie. On verra plus loin comment la matrice est modifiée lorsque l'on change de base.

Applications linéaires et matrices

On va maintenant voir que les matrices s'introduisent aussi naturellement dans le cadre de l'étude des applications linéaires, dès lors que l'on a choisi une base dans chacun des espaces vectoriels concernés. En effet, soient $ E$ et $ F$ deux [image] -espaces vectoriels, avec [image] et [image] , et soit

une application linéaire. Soit [image] une base de $ E$ , et soit [image] une base de $ F$ .

Pour tout [image] , on sait que [image] . Donc, [image] admet une unique décomposition en combinaison linéaire de la base [image] de $ F$ : il existe une unique famille de scalaires [image] telle que

(3.2)

que l'on synthétise sous la forme d'une équation générique

Ces scalaires [image] peuvent se mettre sous la forme d'une matrice [image] .

REMARQUE 3.1 Il existe une façon simple d'écrire cette matrice. Partant du système ( [*] ), on peut écrire les matrices colonne des images [image] dans la base [image] :

Ainsi, la matrice [image] s'obtient en mettant côte à côte ces matrices colonnes.

EXEMPLE 3.7 Considérons le cas [image] , et soit [image] la base canonique de $ E$ :

Soit [image] la projection de $ E$ sur le sous-espace vectoriel engendré par [image] , parallèlement à [image] .

Alors [image] et [image] . La matrice de [image] dans la base canonique [image] est donc

EXEMPLE 3.8 On considère l'application linéaire [image] , qui à tout [image] associe le vecteur obtenu à partir de [image] par rotation d'angle [image] . On a alors

La matrice de l'application linéaire [image] dans la base canonique est la matrice

que nous avons déjà rencontrée.

Quelle est l'utilité des matrices dans ce contexte ? le calcul matriciel permet de calculer directement les coordonnées par rapport à une base [image] de $ F$ de l'image d'un vecteur [image] , connaissant ses composantes par rapport à une base [image] de $ E$ .

Preuve: Supposons que $ E$ soit de dimension [image] , et que $ F$ soit de dimension [image] . Soit [image] . La linéarité de l'application [image] donne

Si on note [image] les composantes de [image] dans la base de $ F$ , c'est à dire

on obtient bien par identification

ce qui est bien le produit matriciel annoncé.

Notons que dans ce cas, la matrice colonne [image] est une matrice à $ n$ lignes, la matrice [image] est une matrice à $ m$ lignes, et donc la matrice [image] est une matrice à $ n$ lignes et $ m$ colonnes. On a bien, conformément aux règles du calcul matriciel

EXEMPLE [*] (SUITE) Reprenons l'exemple de la rotation ci-dessus. Soit [image] , et soit

sa matrice dans la base canonique. On a donc

et donc

Le calcul donne

et on vérifie facilement que

EXEMPLE 3.9 Soient [image] et [image] , munis de leurs bases canoniques respectives [image] et [image] (on rappelle que [image] et [image] , alors que [image] , [image] et [image] ).

Soit

On voit facilement que

et donc la matrice de [image] par rapport à ces deux bases vaut

On vérifie facilement que pour tous [image] ,

Composition des applications linéaires et produit matriciel

La relation étroite entre les applications linéaires et le produit matriciel apparaît plus clairement grâce au résultat fondamental suivant, qui exprime la matrice de la composée de deux applications linéaires (voir FIG. [*] ci dessous) en fonction de leurs matrices

Figure: Composition de deux applications linéaires.
Image Composition

Preuve: Soit [image] , et soit [image] sa matrice colonne. Par l'associativité du produit matriciel, on a

Mais on a aussi

d'où on déduit le résultat.

EXEMPLE 3.10 Dans [image] , on considère les deux applications linéaires suivantes: , la rotation d'angle [image] autour de l'origine, et [image] , définie par

On a donc [image] . Calculons

On a donc

de sorte que la matrice de [image] vaut

On vérifie bien de plus que

Matrice de l'inverse d'une application linéaire

Supposons que [image] soit une application linéaire de $ E$ dans $ F$ . Etant données deux bases de $ E$ et $ F$ respectivement, on a vu que l'on peut associer à [image] sa matrice par rapport à ces deux bases.

Supposons maintenant que [image] soit bijective. Alors il existe [image] telle que [image] . Dans ce cas, on peut associer à [image] une matrice, qui est reliée à [image] . Plus précisément, on a:

Preuve: Supposons que [image] soit bijective. Alors on sait que

et donc

(où [image] ). De même,

et donc

On en déduit donc que [image] est inversible, et que

Réciproquement, supposant que [image] est inversible, on en déduit de façon similaire que [image] est nécessairement un isomorphisme.

REMARQUE 3.2 Comment calcule-t-on l'inverse d'une matrice ? Le calcul de l'inverse d'une matrice carrée peut se ramener à la résolution d'un système linéaire, à autant d'équations que d'inconnues. Si celui possède une solution, on montre qu'elle est unique, et la matrice est alors inversible.

Prenons l'exemple de la matrice

Si $ A$ est inversible, alors [image] , il existe [image] tel que

Ceci équivaut au système de deux équations à deux inconnues

qui admet pour solution $ (x',y')=(-2x+y,3x/2 -y/2)$ , qui se met sous forme matricielle

d'où on déduit

Image et noyau d'une application linéaire

Definitions

EXEMPLE 3.11 Soit [image] , définie par

On voit alors facilement que

Cet ensemble est en fait un sous-espace vectoriel de dimension 2 de [image] . On vérifie en effet qu'il n'est pas vide, et qu'il est stable par addition et multiplication scalaire.

Il s'agit d'un plan vectoriel dans [image] .

Cette propriété est en fait une propriété générique de l'image d'une application linéaire.

Preuve: La première propriété est une conséquence de la seconde, qu'il suffit donc de démontrer. Pour cela, soient [image] . Alors il existe [image] et [image] tels que [image] , et [image] . Donc,

d'après la linéarité de [image] . $ E'$ étant un sous-espace vectoriel de $ E$ , [image] appartient donc à $ E'$ , et [image] est donc l'image par [image] d'un élément de $ E'$ . Donc, [image] .

Soit maintenant [image] . On a

et comme [image] , on a donc bien [image] , ce qui conclut la démonstration.

EXEMPLE 3.12 Soit [image] , définie par

Soit [image] . On a [image] si $ (x,y,z)$ vérifie

Ce système se résout facilement, par exemple par la méthode du pivot de Gauss, et on voit facilement que [image] si et seulement si [image] pour un certain [image] . Ceci définit en fait un sous-espace vectoriel de dimension 1 de [image] .

Preuve: Soient [image] ; alors [image] et [image] . Donc

De plus, pour tout [image] ,

ce qui conclut la preuve.

Preuve: Supposons que [image] soit injective. Alors, comme [image] , [image] implique nécessairement que [image] . Réciproquement, supposons que [image] , et soient [image] tels que [image] . Alors par linéarité de [image] , on a [image] , d'où [image] , et donc [image] .

Théorème de la dimension

Preuve:

  1. Supposons que [image] soit injective, que [image] soit une famille libre de vecteurs de $ E$ , et qu'il existe [image] tels que

    Alors, par linéarité de [image] , ceci est équivalent à

    qui implique

    par injectivité de [image] , et donc

    car la famille [image] est libre. Ceci démontre le premier point.
  2. Supposons que [image] soit surjective, et que [image] soit une famille génératrice de $ E$ . Alors [image] , il existe [image] tel que [image] . De plus, il existe [image] tels que

    de sorte que l'on a, par linéarité de

    Ceci prouve le second point.
  3. Si [image] est une base de $ E$ , c'est donc une famille libre et génératrice. Si [image] est bijective, [image] est elle aussi libre et génératrice, et c'est donc une base de $ F$ .

REMARQUE 3.3 On dit que deux espaces vectoriels sont isomorphes si il existe un isomorphisme entre eux. Une conséquence importante de ce résultat est que deux espaces vectoriels de dimension finie isomorphes sont nécessairement de même dimension.

EXEMPLE 3.13 Reprenons l'exemple de l'application linéaire [image] , définie par

On a vu plus haut que [image] est un sous-espace vectoriel de [image] de dimension 1. On peut donc en déduire que le rang de [image] est égal à deux, que que l'on va vérifier.

Soit [image] . Il existe [image] tel que

Ce système est équivalent au système

qui n'admet de solution que si $ b-2a = c-3a$ , c'est à dire [image] . Ainsi, on a montré que

qui est bien un sous-espace vectoriel de dimension 2 de [image] .

Dans ces conditions, on peut déduire du résultat ci-dessus

Preuve: Il suffit de démontrer que les deux premières assertions sont équivalentes. Supposons tout d'abord que [image] soit injective. Alors [image] , est donc de dimension nulle. Par conséquent,

étant un sous-espace vectoriel de $ F$ , il est alors nécessairement égal à $ F$ , d'où [image] est surjective.

Inversement, supposons que [image] soit surjective. Alors [image] , d'où on déduit, par les mêmes arguments, que [image] , d'où [image] est nécessairement injective.

Matrices et changements de base

On a déjà vu que le choix d'une base dans un espace vectoriel de dimension finie $ E$ permettait de caractériser les vecteurs de $ E$ par les matrices colonnes de leurs composantes par rapport à cette base. Naturellement, lorsque l'on change de base, la matrice colonne des composantes change également.

Matrice de changement de base

Considérons un [image] -espace vectoriel de dimension $ n$ , et soient [image] et [image] deux bases de $ E$ . Naturellement, les éléments de [image] peuvent se décomposer sur la base [image] : il existe [image] scalaires [image] tels que

(3.3)

REMARQUE 3.4 Il existe une façon simple d'écrire cette matrice de passage. Partant du système ( [*] ), on peut écrire les matrices colonne des nouveaux vecteurs de base [image] dans la base [image] :

Ainsi, la matrice $ P$ s'obtient en mettant côte à côte ces matrices colonnes.

EXEMPLE 3.14 Le cas le plus simple est celui où les bases et sont identiques: pour tout $ k$ . On vérifie facilement que dans ce cas, la matrice de passage est la matrice identité.

Si par contre est constituée des mêmes vecteurs que , mais que ceux-ci sont numérotés différemment, la matrice de passage est toujours constituée uniquement de zéros et de uns, mais n'est plus la matrice identité. Par exemple, dans , si on prend , et , la matrice de passage correspondante sera de la forme

EXEMPLE 3.15 Dans , muni de sa base canonique , on considère les trois vecteurs , et . Ces trois vecteurs forment une base de , vérifions le. Supposons qu'il existe tels que

ceci équivaut au système linéaire homogène

dont on vérifie facilement qu'il n'admet que la solution triviale . est donc une famille libre dans . Comme et que cette famille est constituée de 3 vecteurs, c'est une base de , que l'on note . La matrice de passage correspondante prend la forme

REMARQUE 3.5 En comparant l'équation ( [*] ) à l'équation ( [*] ), on peut voir que la matrice de passage n'est autre que la matrice de l'application linéaire identité de $ E$ par rapport aux bases et :

(3.4)

Une conséquence immédiate est

Preuve: En notant , on a

ce qui suffit à montrer cette propriété.

Changement de base et composantes d'un vecteur

Les matrices de passage fournissent un outil très simple d'utilisation pour calculer les composantes d'un vecteur dans une nouvelle base , à partir des composantes dans une première base .

En effet, considérons deux bases et d'un -espace vectoriel $ E$ de dimension $ n$ , et soit la matrice de passage correspondante.

Soit , et soient ses composantes par rapport à la base : on écrit

On peut alors écrire aussi

Or, étant une base de $ E$ elle aussi, il existe une et une seule façon de décomposer sur :

d'où on déduit, par identification

où on reconnait le produit matriciel

La matrice de passage étant toujours inversible on a donc montré

EXEMPLE 3.16 Reprenons l'exemple [*] . Etant donné un vecteur , de matrice

dans la base , ses coordonnées dans la base s'obtiennent par

Il faut donc calculer l'inverse de la matrice $ P$ . Si

alors

ce qui, pour notre choix de $ P$ , revient au système linéaire

La solution du système est donnée par

d'où on déduit

et donc les composantes du vecteur dans la base :

Changement de base et application linéaire

Comme on l'a vu, la matrice d'une application linéaire dépend elle aussi de la base considérée. Considérons tout d'abord le cas d'un endomorphisme

d'un espace vectoriel $ E$ de dimension $ n$ . Soient, comme plus haut, et deux bases de $ E$ , et soit $ P$ la matrice de passage correspondante. Soit , et soit . On a alors

où on a noté la matrice de dans la base . En restant dans la base , on a aussi

Ceci étant vrai pour tout , on a donc montré:

REMARQUE 3.6 Dans le cas plus général d'applications linéaires d'un espace vectoriel $ E$ vers un espace vectoriel $ F$ , il est possible de montrer une propriété similaire, plus complexe, qu'on n'abordera pas ici.

EXEMPLE 3.17 Dans , muni de sa base canonique , on considère les vecteurs

On peut vérifier que la famille est une base de . La matrice de passage correspondante est la matrice

Comme précédemment, son inverse se calcule directement, et on obtient

Soit l'endomorphisme de , défini par

La matrice de dans la base canonique est la matrice

La matrice dans la base s'obtient quant à elle grâce au résultat ci-dessus:

On aurait pu obtenir ce résultat différemment, en calculant directement

Ensuite, puisque est la matrice de passage , on en déduit que

d'où

ce qui conduit au même résultat pour la matrice . On peut en fait vérifier que ce second calcul est tout à fait identique au premier, sous une autre forme.

Deux matrices semblables représentent le même endomorphisme dans deux bases différentes. La matrice $ P$ intervenant dans la définition [*] est la matrice de passage correspondante: ses colonnes représentent les composantes des nouveaux vecteurs de base dans l'ancienne base.

Théorie du rang

On a déjà rencontré auparavant la notion de rang d'une application linéaire : rappelons qu'il s'agit de la dimension du sous-espace vectoriel engendré par les images des élements de $ E$ .

Le rang d'une application linéaire peut aussi être compris en termes matriciels.

EXEMPLE 3.18 Considérons par exemple la matrice

Par définition, le rang de $ A$ est donc la dimension du sous-espace vectoriel de engendré par les vecteurs colonne

Il s'agit d'une famille de 5 vecteurs dans un espace de dimension 3, elle est donc nécessairement liée. On sait par contre qu'on peut toujours en extraire une base. Cherchons quelles sont les relations linéaires entre ces vecteurs, c'est à dire les relations de la forme

pour 5 scalaires . Ceci équivaut au système linéaire homogène

En utilisant la méthode du pivot, résoudre ce système équivaut à échelonner la matrice $ A$ elle même ce qui donne dans un premier temps la matrice

puis, les deux dernières lignes étant équivalentes, la matrice échelonnée

Ainsi, l'ensemble des solutions de ce système (c'est à dire l'ensemble des ) est un sous-espace vectoriel de dimension 3 de : pour tous , en prenant

on a bien

Ceci s'écrit, pour tous

ou encore, pour tous

ce qui finalement équivaut aux 3 relations linéaires

Ainsi, , et sont complètement déterminés par et , qui forment une base du sous-espace engendré par ces 5 vecteurs colonne. Celui-ci est de dimension 2, donc .

Il existe une relation entre le rang d'une application linéaire et celui de sa matrice.

Notons que ceci implique que le rang d'une matrice est invariant par changement de bases, puisque le rang de ne dépend pas des bases choisies.

REMARQUE 3.7 Il est possible de montrer que si $ A$ est une matrice, et si est sa transposée, leurs rangs sont égaux:

(3.5)

Cette propriété est parfois utile, comme dans l'exemple suivant.

EXEMPLE 3.19 On considère la famille de trois vecteurs de

Le rang de la famille est égal au rang de la matrice

Cette matrice est la transposée de la matrice $ A$ de l'exemple [*] , donc .

next up previous index
Next: Déterminants, inversion de matrices Up: CALCUL MATRICIEL Previous: Calcul Matriciel Index


Déterminants, inversion de matrices

next up previous index
Next: Diagonalisation des matrices et Up: CALCUL MATRICIEL Previous: Applications Linéaires Index

Subsections
  • Déterminants
    • Déterminants en dimension 2
    • Application à la résolution d'un système linéaire de deux équations à deux inconnues.
    • Déterminant en dimension 3
    • Déterminant d'une matrice carrée quelconque

  • Déterminants, produits et inversion de matrices
  • Systèmes de Cramer

Déterminants, inversion de matrices

On a déjà vu dans le chapitre précédent comment on peut dans des cas simples calculer l'inverse d'une matrice. Dans des cas plus complexes, comme par exemple dans le cas de matrices de grandes taille, il est parfois utile d'utiliser une approche différente, basée sur la notion de déterminant.

Déterminants

Déterminants en dimension 2

Soient [image] et [image] deux vecteurs de [image] . On se pose le problème de calculer l'aire [image] du parallélogramme engendré par [image] et [image] .

Une construction géométrique simple (voir FIG. [*] ) permet de montrer que cette aire vaut

Cette quantité est directement reliée à ce que l'on appelle le déterminant des vecteurs [image] et [image] .

Figure: Détermination géométrique de l'aire d'un parallèlogramme, et relation avec le déterminant des deux vecteurs engendrant ce parallélogramme.
Image determinantw1

REMARQUE 4.1 Cette construction géométrique a aussi la vertu de montrer que contrairement à ce que la formule ci-dessus pourrait laisser croire, le déterminant est indépendant du repère orthonormé choisi.

Le déterminant est quant à lui défini de la façon suivante:

Ce déterminant possède certaines propriétés simples, dont on verra la forme plus générale dans le cas de matrices plus grandes. Les propriétés les plus importantes sont les propriétés de bilinéarité et d'antisymétrie.

  • Bilinéarité: pour tous [image] ,
    (4.1)
    (4.2)

    et pour tous [image] et [image] ,
    (4.3)
    (4.4)

    On dit que dans [image] , le déterminant est une forme bilinéaire (c'est à dire linéaire par rapport à ses deux arguments).
  • Antisymétrie: pour tous

    (4.5)

    On dit que dans [image] , le déterminant est une forme bilinéaire antisymétrique, ou alternée.

Le déterminant d'une matrice [image] est défini de façon similaire, en utilisant les colonnes des matrices

On note également le déterminant d'une matrice sous la forme

(4.6)

EXEMPLE 4.1 On voit facilement que

EXEMPLE 4.2 matrice de rotation. Nous avons déjà rencontré les matrices de rotation d'angle [image] du plan

Un calcul simple montre que

ce qui est somme toute logique si on se souvient que le déterminant de la matrice est égal au déterminant de ses colonnes, qui est égal (au signe près) à l'aire du parallèlogramme qu'ils définissent, à savoir un carré de côté 1.

On peut vérifier directement la propriété suivante à partir de la définition du déterminant.

Le déterminant des matrices [image] hérite des propriétés du déterminant des vecteurs, à savoir les propriétés d'antisymétrie et de bilinéarité. Ces propriétés, combinées au lemme ci-dessus, conduisent aux propriétés suivantes.

  • Le déterminant d'une matrice [image] change de signe lorsque l'on permute les deux colonnes de la matrice.

  • En appliquant cette propriété à la transposée de la matrice [image] on montre aussi que le déterminant d'une matrice [image] change de signe lorsque l'on permute les deux lignes de la matrice:

  • Bilinéarité: pour tous [image] ,

    et

  • En appliquant cette propriété à la transposée de la matrice [image] , on a aussi pour tous [image] ,

    et

Application à la résolution d'un système linéaire de deux équations à deux inconnues.

Considérons le système linéaire de deux équations à deux inconnues

Supposons par exemple [image] ; en éliminant $ x$ de la seconde équation, on obtient

d'où en reportant dans la première équation,

on tire, à condition que [image] ,

et de là

En termes matriciels, le système peut aussi s'écrire

et on reconnaît

Ceci étant vrai pour tous $ u,v$ , on en déduit

On voit bien apparaître le rôle du déterminant dans ce résultat. Comme on le verra, ce résultat restera vrai pour des matrices carrées de taille quelconque.

Notons aussi que la solution est de la forme

Comme on l'a vu, le dénominateur de $ x$ et $ y$ n'est autre que le déterminant de la matrice [image] . Le numérateur de $ x$ est le déterminant d'une autre matrice, obtenue à partir de [image] en substituant à la première colonne la colonne [image] . Le numérateur de $ y$ est quant à lui le déterminant de la matrice obtenue à partir de [image] en substituant à la seconde colonne la colonne [image] .

Là encore, ce résultat n'est pas une coïncidence, mais n'est que le cas particulier d'une situation plus générale, dans laquelle on verra que les déterminants jouent un rôle central pour la résolution de systèmes linéaires.

Déterminant en dimension 3

Comme en dimension 2, il est possible d'introduire le déterminant de trois vecteurs de [image] de façon géométrique: le volume du parallélépipède engendré par ces trois vecteurs est égal à la valeur absolue du déterminant de ces trois vecteurs. On définit alors le déterminant d'une matrice [image] comme le déterminant de ses trois vecteurs colonne.

Cette définition est toutefois difficile à utiliser en dimensions supérieures, et on préfère en donner une autre, plus opératoire.

On peut vérifier que ce déterminant possède toutes les propriétés que nous avions déjà rencontrées dans le cas des matrices [image] :

  • Trilinéarité: pour toute matrice [image] , et pour tous [image] ,

    Aussi, pour tout [image] ,

    et de même pour les colonnes 2 et 3.
  • Antisymétrie: lorsque l'on permute deux colonnes adjacentes, le déterminant change de signe: par exemple

    Par contre, ceci n'est plus nécessairement vrai lorsque les colonnes ne sont pas adjacentes. Par exemple, on a en permutant cette fois les colonnes 2 et 3 de cette dernière matrice

    les deux changements de signes provenant des deux permutations s'étant compensés.

Calculons maintenant, pour [image] ,

Ainsi, le Lemme [*] reste vrai pour les matrices

Par conséquent, on peut appliquer toutes les propriétés que nous avons énoncées ci-dessus (bilinéarité, antisymétrie,...) en remplaçant les colonnes par les lignes.

De plus, ces propriétés donnent d'autres possibilités pour calculer le déterminant d'une matrice. On a besoin pour cela d'introduire une notation nouvelle. Etant donnée [image] , on notera [image] la matrice à $ n-1$ lignes et $ n-1$ colonnes obtenue en supprimant la $ i$ -ième ligne et la $ j$ -ième colonne de $ A$ :

(4.7)

On a alors

Ce théorème est intéressant, car il montre qu'il existe plusieurs façons différentes de calculer un déterminant, et qu'il est donc possible de choisir celle qui sera la plus simple, comme on va le voir dans l'exemple ci-dessous.

EXEMPLE 4.3 Soit à calculer

En développant ce déterminant par rapport à sa première ligne, comme dans la définition, on a à calculer trois déterminants [image] . Si par contre on développe par rapport à la deuxième ligne, on obtient

Le résultat suivant est essentiel, dans la mesure où il permet dans certains cas de montrer qu'un déterminant est nul sans faire le moindre calcul.

Preuve: Il suffit de montrer cette proposition dans le cas des colonnes. Pour démontrer le cas des lignes, il suffit d'appliquer les résultats concernant les colonnes à la transposée de la matrice $ A$ , qui possède le même déterminant.

  1. On voit facilement que si la première colonne de $ A$ est nulle, le déterminant de $ A$ est nul. Si $ A$ possède une colonne nulle, on peut par permutations se ramener à une matrice dont la première colonne est nulle. Le déterminant de cette dernière matrice (qui est égal au déterminant de $ A$ , à un signe près) est nul, et donc [image] .
  2. Supposons que $ A$ possède deux colonnes adjacentes identiques; alors en les permutant (ce qui ne change rien !), on change le signe du déterminant. Ce dernier est nécessairement nul. Si $ A$ possède deux colonnes identiques, on peut par permutations remplacer $ A$ par une matrice $ B$ ayant (au signe près) le même déterminant et deux colonnes adjacentes identiques. Donc [image] , d'où [image] .
  3. Supposons que $ A$ possède deux colonnes proportionnelles, par exemple

    Alors

  4. Finalement, supposons par exemple que la seconde colonne soit combinaison linéaire de la première et la troisième:

    Alors d'après les propriétés de linéarité, on a

Il est possible de démontrer que la dernière propriété est en fait une condition nécessaire et suffisante: si et seulement si il existe une colonne de $ A$ qui soit combinaison linéaire des autres, c'est à dire si la famille des colonnes n'est pas libre. Ce résultat a un corollaire immédiat:

Finalement, en se basant sur les propriétés ci-dessus, on peut facilement voir que la méthode du pivot de Gauss peut s'appliquer pour calculer un déterminant.

EXEMPLE 4.4 En appliquant cette règle, on voit par exemple que

Dans ce calcul on a utilisé le pivot, puis le fait que le déterminant d'une matrice triangulaire supérieure est égal au produit de ses termes diagonaux.

On peut également organiser le calcul différemment, comme suit:

On a ici utilisé le pivot différemment, puis le fait que le déterminant d'une matrice triangulaire inférieure est égal au produit de ses termes diagonaux.

Déterminant d'une matrice carrée quelconque

La définition du déterminant d'une matrice carrée [image] se fait par récurrence.

EXEMPLE 4.5 Considérons la matrice

L'application directe de la définition donne

EXEMPLE 4.6 Les exemples les plus simples sont ceux de la matrice nulle [image] et de la matrice identité [image] . On a dans ces cas [image] , et [image] .

EXEMPLE 4.7 Il est facile aussi de montrer, à partir de cette définition, que le déterminant d'une matrice diagonale est égal au produit des termes diagonaux:

Ceci reste vrai lorsque la matrice est triangulaire supérieure (c'est à dire lorsque tous les éléments situés en dessous de la diagonale sont nuls), ou triangulaire inférieure (c'est à dire lorsque tous les éléments situés au dessus de la diagonale sont nuls).

EXEMPLE 4.8 Soit

On a
0

Les propriétés essentielles des déterminants sont résumées dans le théorème fondamental suivant.

Comme dans le cas des matrices [image] et [image] , on a les résultats fondamentaux

Le résultat suivant est le pendant direct de la proposition [*] , qui se généralise donc à la dimension $ n$ . On peut vérifier que la preuve de la proposition [*] n'a rien de spécifique aux matrices [image] , et reste valable dans un cas quelconque.

Il s'ensuit que l'on ne modifie pas le déterminant d'une matrice lorsque

  • on ajoute à une ligne une combinaison linéaire quelconque des autres lignes.
  • on ajoute à une colonne une combinaison linéaire quelconque des autres colonnes.
Ceci permet d'utiliser des techniques que nous avons déjà vu en étudiant la méthode du pivot pour calculer des déterminants: on peut jouer sur les lignes (ou les colonnes) pour remplacer des coefficients par des valeurs nulles, et ainsi simplifier des calculs de déterminants.

EXEMPLE 4.9 Soit à calculer le déterminant

En soustrayant des lignes, on a

Il suffit alors de développer par rapport à la première colonne, pour obtenir

On s'est ainsi épargné des calculs pénibles.

Comme en dimensions 2 et 3, ce résultat a un corollaire immédiat

Le résultat suivant est une généralisation directe du Théorème [*]

EXEMPLE 4.10 Reprenons l'exemple [*] , et considérons la matrice

En développant le déterminant suivant la première colonne, on obtient

EXEMPLE 4.11 En utilisant cette propriété, on peut montrer que le déterminant d'une matrice triangulaire inférieure est égal au produit des termes diagonaux:

il suffit pour cela de développer suivant la première ligne; seul le premier terme est non nul, et conduit au déterminant d'une matrice [image] , elle aussi triangulaire inférieure, à laquelle on peut appliquer le même traitement, et ainsi de suite. De même, en développant suivant la première colonne, on peut montrer que le déterminant d'une matrice triangulaire supérieure est égal au produit des termes diagonaux:

Déterminants, produits et inversion de matrices

Les déterminants ont un comportement très simple vis à vis du produit matriciel, comme le montre le résultat suivant, donné sans démonstration.

Ce résultat a un certain nombre d'importants corollaires.

Supposons que $ A$ soit inversible. Alors, de $ A{^{-1}}A= I_n$ , on déduit que [image] , et que [image] . Inversement, supposons que [image] . Alors les colonnes de $ A$ forment une base de [image] , et $ A$ n'est autre que la matrice de passage de la base canonique à cette nouvelle base. Une matrice de passage étant toujours inversible, on en déduit que $ A$ est inversible. On a donc montré:

Soient $ A$ et $ B$ deux matrices semblables , c'est à dire représentant le même endomorphisme dans deux bases différentes. Alors on sait que $ B = P{^{-1}}A P$ , $ P$ étant la matrice de passage. Par suite, on a

d'où

Soit $ E$ un [image] -espace vectoriel, et soit [image] . On peut définir la notion de déterminant de [image] .

Nous pouvons facilement vérifier ce dernier point. Soit [image] une autre base de $ E$ , et soit [image] la matrice de passage correspondante. On a alors

d'où [image] et [image] sont semblables, et ont donc même déterminant.

Le résultat suivant permet de calculer effectivement l'inverse d'une matrice, tout du moins lorsque celle-ci n'est pas trop grande.

EXEMPLE 4.12 On considère la matrice

et on suppose que son déterminant $ ad-bc$ est non nul. La matrice des cofacteurs de [image] est la matrice

d'où

EXEMPLE 4.13 Soit

On a

et donc, comme

EXEMPLE 4.14 Considérons maintenant la matrice

Le calcul donne

et donc, puisque [image] ,

Systèmes de Cramer

Une des applications de ce que nous venons de voir concerne l'utilisation des déterminants pour la résolution de systèmes linéaires. On considère des systèmes linéaires de la forme

(4.8)

que l'on met sous forme matricielle

(4.9)

où [image] , et où $ X$ et $ B$ sont des matrices colonne à $ n$ et $ m$ lignes respectivement.

Les systèmes de Cramer peuvent être résolus de façon simple, grâce à ce que nous avons vu plus haut. Comme [image] , $ A$ est inversible, et on peut donc écrire

En explicitant [image] et son action sur $ B$ , on peut alors montrer le résultat suivant, donné ici sans démonstration.

EXEMPLE 4.15 Considérons le système

On voit facilement par le calcul que

d'où on déduit directement la solution

REMARQUE 4.2 Lorsque le déterminant de la matrice $ A$ est nul, la méthode de Cramer ne s'applique plus. Le système est soit inconsistent (c'est à dire qu'il n'existe pas de solution), soit dépendant (il existe une infinité de solutions). Dans un cas comme dans l'autre, une autre méthode doit être employée.

REMARQUE 4.3 Pour conclure, remarquons que le calcul d'un déterminant peut faire intervenir un très grand nombre de termes lorsque la matrice est de grande taille. Ainsi, utiliser des déterminants pour résoudre des systèmes linéaires de grande taille n'est pas nécessairement à conseiller. Il est dans ce cas préférable de revenir à la méthode du pivot.

next up previous index
Next: Diagonalisation des matrices et Up: CALCUL MATRICIEL Previous: Applications Linéaires Index


Diagonalisation des matrices et réduction des endomorphismes

next up previous index
Next: Index Up: CALCUL MATRICIEL Previous: Déterminants, inversion de matrices Index

Subsections
  • Diagonalisation
    • Endomorphismes diagonalisables et trigonalisables
    • Vecteurs propres, valeurs propres
    • Diagonalisation, polynôme caractéristique
    • Quelques remarques sur les polynômes et leur factorisation
    • Caractérisation des endomorphismes diagonalisables
    • Exemples

  • Quelques classes particulières d'endomorphismes
    • La structure d'espace Euclidien de
    • La structure d'espace Hermitien de

  • Applications de la diagonalisation
    • Puissances, exponentielle,... et fonction d'une matrice
      • Puissances
      • Exponentielle d'une matrice
      • Autres fonctions
    • Application aux suites
    • Systèmes différentiels

Diagonalisation des matrices et réduction des endomorphismes

Etant donnés un espace vectoriel $ E$ , et un endomorphisme [image] de $ E$ , on sait qu'une matrice de [image] dépend de la base de $ E$ dans laquelle elle est exprimée. D'où la question: est il possible de trouver une base particulière de $ E$ dans laquelle la matrice serait la plus simple possible. Pour illustrer cette problématique, il est utile de considérer quelques exemples simples.

EXEMPLE 5.1 Dans [image] , on considère une application linéaire [image] . Supposons qu'on ait trouvé deux vecteurs [image] et [image] tels que la famille [image] soit libre, et que [image] et [image] . Alors, la famille étant libre, c'est une base de [image] , et tout vecteur [image] admet une unique décomposition de la forme [image] . Par exemple, dans la figure [*] , on a [image] . Alors l'image de [image] par [image] est très facile à calculer. étant linéaire, on a

. En l'occurrence, on voit facilement sur la figure [*] comment est obtenu [image] .
Figure: Construction de l'image d'un vecteur du plan par une application linéaire [image] , connaissant deux vecteurs [image] et [image] sur lesquels [image] agit par multiplication par un scalaire (ici 1 et 2).
Image VectPropres

Représenter une application linéaire par une matrice diagonale peut aussi être très utile pour expliciter des suites de vecteurs, comme on le voit dans l'exemple ci-dessous, ou résoudre certains systèmes d'équations différentielles.

EXEMPLE 5.2 Dans [image] , soit [image] l'endomorphisme défini par

Sa matrice dans la base canonique [image] est

On considère maintenant les vecteurs

dont on vérifie facilement qu'ils forment une base de [image] (puisqu'ils ne sont pas colinéaires), notée [image] . Il est clair que

de sorte que la matrice de [image] dans la base [image] est diagonale

En quoi cela simplifie-t-il les choses ? il suffit de voir que n'importe quel vecteur du plan [image] s'écrit de façon unique

et que l'action de [image] sur cette forme est particulièrement simple:

EXEMPLE 5.3 Dans [image] , on considère la suite de vecteurs [image] , définie par

et on cherche à exprimer [image] et [image] en fonction de [image] et [image] . Ce problème peut se simplifier par un changement de base approprié. En notant [image] la base canonique, la matrice du vecteur [image] vaut

et on peut donc écrire

On considère une nouvelle base [image] définie par

La matrice de passage prend la forme

et on montre facilement par le calcul que son inverse est donnée par

Dans la nouvelle base, la matrice $ A$ devient

Ecrivons maintenant

On peut donc écrire aussi

et finalement montrer par récurrence

Maintenant, remarquons que comme la matrice $ D$ est diagonale,

et que par récurrence, on a aussi

On voit alors que

De là on déduit la solution de notre problème:

Cet exemple nous montre que dès lors que l'on peut trouver une base dans laquelle un endomorphisme a une matrice diagonale, des calculs ultérieurs se simplifient considérablement.

Diagonalisation

Les questions qui se posent maintenant sont essentiellement les deux questions suivantes:
  1. Quels sont les endomorphismes qui peuvent être représentés par une matrice diagonale dans une base bien choisie ?
  2. Lorsque c'est possible, comment déterminer cette base et la matrice diagonale ?

Endomorphismes diagonalisables et trigonalisables

Dans ce qui suit, on se focalisera essentiellement sur la diagonalisation des endomorphismes, si elle est possible.

Considérons un endomorphisme [image] de $ E$ , et notons $ A$ sa matrice par rapport à une base de référence [image] . Supposons qu'il existe effectivement une base [image] de $ E$ telle que la matrice de [image] soit diagonalisable, et notons [image] la matrice diagonale correspondante. Notons [image] la matrice de passage de la base de référence à la base [image] ; on a donc $ D=P{^{-1}}A P$ , d'où on tire

(5.1)

Une importante application de cette propriété est qu'elle permet de calculer très simplement des puissances d'une matrice. En effet, supposons que $ A$ soit diagonalisable; alors on peut calculer

où la matrice [image] est elle aussi diagonale, de la forme

Plus généralement, on peut montrer par récurrence

Vecteurs propres, valeurs propres

La diagonalisabilité est une notion étroitement liée à la notion de valeur propre et de vecteur propre.

On a alors

Preuve: Supposons qu'il existe une base [image] de $ E$ formée de vecteurs propres, et notons [image] les valeurs propres correspondantes. Alors dans cette base, la matrice de [image] est automatiquement diagonale.

Inversement, supposons [image] diagonalisable. Alors il est tout aussi clair que les vecteurs de base sont des vecteurs propres de [image] .

En pratique, on commence tout d'abord par chercher les valeurs propres de l'endomorphisme considéré (voir l'exemple ci-dessous, ou la section suivante). On peut ensuite rechercher le ou les vecteur(s) propre(s) associé(s) à une valeur propre ainsi obtenue [image] en résolvant l'équation

EXEMPLE 5.4 Soit [image] défini par

Chercher des vecteurs propres de [image] revient à chercher des couples [image] tels que

pour un certain [image] . La première équation nous donne [image] , d'où en reportant dans la seconde on obtient

Si [image] , alors nécessairement [image] , et $ (x,y)$ est le vecteur nul, qui ne peut être vecteur propre par définition. En supposant donc [image] , en simplifiant par $ x$ on aboutit à l'équation du second degré en

qui donne les valeurs propres possibles: et [image] .

Cherchons s'il existe des vecteurs propres associés. Dans le cas de [image] , le vecteur propre associé $ (x,y)$ est tel que $ 3x-y = 0$ , d'où [image] est de la forme [image] , pour n'importe quel [image] . Dans le cas de [image] , le vecteur propre associé est tel que $ 2x = -y$ , d'où [image] est de la forme [image] , pour n'importe quel [image] . L'endomorphisme considéré est donc diagonalisable.

Diagonalisation, polynôme caractéristique

On a vu dans l'exemple ci-dessus un cas où la recherche de valeurs propres se ramenait à une recherche de racines d'un polynôme. Cette situation n'était pas un cas particulier, comme on va le voir.

Soit [image] une valeur propre de l'endomorphisme [image] . Ceci veut dire qu'il existe [image] tel que [image] , autrement dit

Ainsi, l'application linéaire [image] n'est pas injective, d'où comme on l'a vu au chapitre [*]

On rappelle que le déterminant d'un endomorphisme est égal au déterminant de sa matrice dans une base quelconque (et ne dépend pas du choix de la base).

Notons [image] la matrice de [image] dans une base donnée:

Alors

et l'équation [image] se ramène à une équation de degré $ n$ en [image] :

les [image] étant des scalaires. Cette équation est appelée équation caractéristique, et son membre de gauche est le polynôme caractéristique, noté [image] .

On a donc montré le résultat

EXEMPLE 5.5 Reprenons l'exemple [*] ci dessus. La matrice de [image] est

et l'équation caractéristique prend la forme

ce qui revient à

ce qui est précisément l'équation que nous avions obtenue.

Quelques remarques sur les polynômes et leur factorisation

.

Soit [image] ou [image] . On note [image] l'ensemble des polynômes d'indéterminée $ X$ . On rappelle que [image] est une racine du polynôme [image] si $ P(x)$ peut s'écrire sous la forme

$ Q$ étant un autre polynôme de [image] .

Il est possible de démontrer que dans ce cas, le polynôme $ P$ peut être complètement factorisé, et se mettre sous la forme

(5.2)

où [image] est une constante, et où [image] sont les racines de $ P$ . Comme on l'a vu, les racines ne sont pas nécessairement distinctes. En notant [image] les $ p$ racines distinctes de $ P$ , on introduit leur multiplicité

qui est le nombre d'occurrences de [image] parmi les racines [image] . On a alors

(5.3)

$ p$ étant donc le nombre de racines distinctes. En identifiant ces deux expressions, on montre également que

(5.4)

$ n$ étant le degré du polynôme $ P$ .

Tout polynôme n'est pas nécessairement scindé dans [image] . Par exemple, le polynôme

n'est pas scindé dans [image] . Par contre, il l'est dans [image] , car il admet deux racines de partie imaginaire non nulle

Plus généralement, on sait bien que pour un polynôme de degré deux

celui-ci sera scindé sur [image] si son discriminant [image] est positif ou nul, et sera toujours scindé sur [image] . Cette dernière propriété se généralise en fait à des polyhnômes de degré quelconque:

Caractérisation des endomorphismes diagonalisables

Pour qu'un endomorphisme soit diagonalisable, il faut donc nécessairement que son polynôme caractéristique soit scindé. Malheureusement, cette condition n'est pas suffisante, et il faut donc préciser davantage les choses.

La caractérisation des endomorphismes diagonalisables repose sur la notion de sous-espace propre.

REMARQUE 5.1 Notons que
  • Si [image] n'est pas valeur propre de [image] , alors [image] .
  • Si [image] est valeur propre de [image] , alors [image] est l'union de l'ensemble des vecteurs propres de [image] de valeur propre [image] , et du singleton [image] .

Preuve: Il est clair que si [image] est tel que [image] et [image] , avec [image] , on a nécessairement [image] .

Ce résultat, conjuqué à la définition d'un endomorphisme diagonalisable, a une conséquence immédiate

La dernière question en suspens concerne le lien entre les valeurs propres et les sous-espaces propres.

Dans le cas particulier où toutes les racines sont des racines simples, on a directement

Exemples

On considère ci-dessous une série d'endomorphismes de [image] (ou [image] ) définis par leurs matrices, qui donnent un éventail des situations possibles.

EXEMPLE 5.6

Le polynôme caractéristique de $ A$ prend la forme

On a trois valeurs propres distinctes, l'endomorphisme considéré est donc diagonalisable. Cherchons maintenant les vecteurs propres correspondants. Pour cela, calculons tout d'abord

Les composantes $ (x,y,z)$ d'un vecteur propre [image] associé à la valeur propre [image] doivent donc satisfaire le système

c'est à dire le système homogène

dont toutes les solutions satisfont [image] et [image] . Par conséquent, on peut choisir

Cherchons maintenant un vecteur propre [image] associé à la valeur propre [image] . Ses composantes $ (x,y,z)$ doivent donc satisfaire le système

c'est à dire le système homogène

dont toutes les solutions satisfont [image] et [image] . Par conséquent, on peut choisir

Finalement, les composantes du vecteur propre [image] associé à [image] satisfont le système homogène

dont les solutions sont de la forme $ (-2z,3z/2,z)$ , de sorte qu'un vecteur propre est

La matrice de passage de la base canonique à la base des vecteurs propres prend la forme

EXEMPLE 5.7 On considère l'endomorphisme dont la matrice dans la base canonique est

Son polynôme caractéristique vaut

On a cette fois une racine double [image] et une racine simple [image] . Pour voir si $ B$ est diagonalisable, il faut étudier le sous-espace propre [image] . Soit donc [image] . On a alors le système

c'est à dire le système homogène

qui équivaut à la seule équation [image] . L'ensemble des solutions est un espace vectoriel de dimension deux, dont on peut prendre comme base

Donc $ B$ est diagonalisable. Pour terminer, on peut aussi trouver un vecteur propre associé à [image] , en résolvant le système

c'est à dire le système homogène

qui équivaut à

dont les solutions satisfont [image] . On peut donc prendre comme vecteur propre [image] , et écrire

avec

EXEMPLE 5.8 On considère l'endomorphisme dont la matrice dans la base canonique est

Le polynôme caractéristique est donné par

est racine évidente. Pour connaitre les autres racines, il faut factoriser le polynôme [image] . Son discriminant vaut [image] , dont les deux racines sont des nombres complexes conjugués l'un de l'autre. Par conséquent, $ C$ n'est pas [image] -diagonalisable, [image] n'étant pas [image] -scindé. Par contre, [image] est [image] -scindé, et admet 3 racines (complexes) distinctes. Donc, $ C$ est [image] -diagonalisable, et on pourra donc lui associer une base de vecteurs propres. Les valeurs propres sont complexes, de partie imaginaire non-nulle.

EXEMPLE 5.9 On considère l'endomorphisme dont la matrice dans la base canonique est

Le polynôme caractéristique est (en développant le déterminant par rapport à la seconde ligne)

Là encore, on a une racine double [image] . Etudions le sous-espace propre associé. Soit [image] , il doit satisfaire le système

c'est à dire le système homogène

dont les solutions sont de la forme $ (x,0,-5x/2)$ . L'ensemble des solutions est donc un espace vectoriel de dimension 1, alors que la multiplicité de [image] vaut 2. Donc, $ E$ n'est pas diagonalisable.

Quelques classes particulières d'endomorphismes

La structure d'espace Euclidien de

Jusqu'à présent, nous n'avons exploité que la structure d'espace vectoriel de [image] . Or on sait que [image] est aussi muni d'autres types d'opérations, telles que la norme et le produit scalaire.

On vérifie facilement que si [image] et [image] , alors

Sans entrer dans les détails de la démonstration, qui va au delà des objectifs de ce cours, il est quand même utile de donner le résultat suivant, qui donne un critère simple poir la diagonalisabilité des matrices réelles.

Par conséquent, lorsque l'on est en présence d'une matrice réelle symétrique [image] , on est assuré de pouvoir trouver une base de vecteurs propres [image] qui est orthonormée, c'est à dire telle que

La structure d'espace Hermitien de

Dans le cas complexe, le résultat précédent ne s'applique pas. Cependant, il peut être généralisé, en introduisant une structure généralisant celle d'espace Euclidien.

Ceci nous permet d'étendre au cas complexe le théorème précédent. La condition qui remplace la condition de symétrie de la matrice est cette fois une condition d'Hermiticité:

Applications de la diagonalisation

La réduction des endomorphismes et la diagonalisation des matrices permettent de simplifier considérablement un certain nombre de calculs, comme par exemple le calcul de puissances d'une matrice, ou la résolution de systèmes différentiels linéaires.

Sans entrer dans les détails, on peut en donner quelques exemples ici. Avant d'entrer dans le vif du sujet, il est intéressant de souligner l'aspect le plus important des calculs que nous allons faire. Dans tous les cas, la diagonalisation de la matrice considérée va nous permettre de transformer un problème matriciel, donc compliqué, en un problème dans lequel les variables sont découplées, ce qui nous ramènera à des problèmes faisant intervenir des nombres et non plus des matrices.

Par exemple, le calcul des puissances d'une matrice devient très simple dès lors que l'on a diagonalisé la matrice: la puissance $ n$ -ième d'une matrice diagonale s'obtient en élevant tous ses éléments de matrice à la puissance $ n$ , ce qui est faux pour des matrices non diagonales.

Puissances, exponentielle,... et fonction d'une matrice

Puissances

Soit [image] une matrice Hermitienne (ce résultat s'applique tout aussi bien aux matrices réelles symétriques). Nous avons vu que $ A$ est nécessairement diagonalisable: en notant $ D$ la matrice diagonale des valeurs propres de $ A$ , et $ P$ la matrice de passage correspondante, on a donc

Pour calculer le carré de $ A$ , on calcule donc

car le carré d'une matrice diagonale est toujours une matrice diagonale, dont les éléments diagonaux sont les carrés des éléments diagonaux de la matrice de départ.

Plus généralement, on montre que pour tout entier positif $ k$ ,

Exponentielle d'une matrice

L'exponentielle d'une matrice $ A$ est définie par la série entière

et on peut donc lui appliquer le résultat précédent si $ A$ est Hermitienne:

expression calculable si on sait calculer l'exponentielle d'une matrice diagonale.

On peut en fait facilement voir que [image] prend une forme simple

Ainsi, l'exponentielle d'une matrice diagonale est la matrice diagonale dont les éléments diagonaux sont les exponentielles des éléments diagonaux de la matrice de départ.

Autres fonctions

Ces calculs peuvent se généraliser à d'autres fonctions que des exponentielles. Par exemple, soit $ f$ une fonction à valeurs réelles, telle que $ f$ admette un développement en série entière convergent en 0 (cette hypothèse est très importante):

Alors, en utilisant les mêmes arguments que ci-dessus, il va être possible de définir $ f(A)$ pour une matrice Hermitienne $ A$ , par

ce qui donne

Application aux suites

Pour simplifier, on va ici considérer le cas [image] .

On considère des instants discrets [image] et on suppose que les mouvements d'un point dans l'espace tridimensionnel, repéré par le vecteur [image] , évoluent suivant une suite de la forme

où $ A$ est une matrice réelle symétrique, donc diagonalisable. On peut donc écrire encore une fois [image] , où [image] est la matrice de passage de la base canonique [image] à la base qui diagonalise $ A$ , que l'on note [image] , et où [image] est la matrice diagonale des valeurs propres de $ A$ , notées [image] et [image] .

Notons

la matrice de [image] dans la base [image] . On voit facilement que

On en déduit donc la solution, c'est à dire l'expression de [image] en fonction de la condition initiale [image] :

Systèmes différentiels

Le même type de raisonnement s'applique également à la résolution de systèmes d'équations différentielles linéaires du premier ordre couplées. Là encore, on va se limiter au cas de systèmes de trois équations, le cas général se traitant de façon identique. On considère les positions $ (x(t),y(t),z(t)$ d'un point matériel, représentées sous forme matricielle par

et on suppose qu'elles sont décrites par un système d'équations différentielles, que l'on écrit sous forme matricielle, en posant

où $ A$ est une matrice réelle symétrique, donc diagonalisable.

En diagonalisant la matrice $ A$ comme ci-dessus, on aboutit au système matriciel

d'où on déduit

Posons

$ V(t$ est la matrice colonne des coordonnées de [image] dans la base qui diagonalise la matrice $ A$ . De plus, on voit facilement que

Ainsi, on aboutit à un nouveau système

autrement dit

dont les solutions sont

Sout forme matricielle, on a donc

On en déduit la solution du système

next up previous index
Next: Index Up: CALCUL MATRICIEL Previous: Déterminants, inversion de matrices Index


Index

Addition
Angles d'Euler
Application identité
Application injective , [*]
Application surjective
Base canonique , [*]
Combinaison linéaire
Déterminant
Droite vectorielle
Elimination de Gauss
Espace Euclidien , [*] , [*]
Espace Hermitien
Espace vectoriel , [*] , [*]
Espaces vectoriels isomorphes
Exponentielle d'une matrice
Forme alternée
Forme Bilinéaire , [*]
Inverse
Linéarité
Matrice carrée
Matrice colonne
Matrice de rotation
Matrice Galiléenne
Matrice identité
Matrice ligne
Matrices semblables
Multiplication par un scalaire
Multiplicité d'un polynôme
Norme
Norme Euclidienne
Opposé
Pivot de Gauss
Plan vectoriel
PolynÊquation caractéristique
Polynôme caractéristique
Produit Hermitien
Produit scalaire , [*]
Projection
Puissance d'une matrice
Racine d'un polynôme
Rotation
Scalaire
Système linéaire
Vecteur , [*]
Vecteur colonne
Vecteur ligne
Vecteur nul


About this document ...

CALCUL MATRICIEL

This document was generated using the LaTeX2HTML translator Version 2002-2-1 (1.71)

Copyright © 1993, 1994, 1995, 1996, Nikos Drakos, Computer Based Learning Unit, University of Leeds.
Copyright © 1997, 1998, 1999, Ross Moore, Mathematics Department, Macquarie University, Sydney.

The command line arguments were:
latex2html -split 3 -local_icons cours

The translation was initiated by Bruno Torresani on 2009-02-18


Généralités sur les vecteurs Notion de vecteur Vu dans http://www.maths-cours.fr/

Définition

Un vecteur est défini par sa direction, son sens et sa longueur.

Remarque

Le mot direction désigne la direction de la droite qui "porte" ce vecteur; le mot sens permet de définir un sens de parcours sur cette droite parmi les deux possibles.

Exemple

Les vecteurs AB et CD ont la même direction, le même sens, la même longueur. Ils sont égaux.

Remarque

Nommer un vecteur
Pour nommer un vecteur on peut :
  • utiliser l'origine et l'extrémité d'un représentant du vecteur : on parlera du vecteur AB
  • lui donner un nom à l'aide d'une lettre (en générale minuscule) : on parlera alors du vecteur u

Définition

AA, BB, ... représentent un même vecteur de longueur nulle appelé vecteur nul et noté 0.

Remarque

Le vecteur nul est assez particulier. En effet, contrairement aux autres vecteurs, il n'a ni direction, ni sens! Mais il intervient souvent dans les calculs.

Définition

La « longueur » d'un vecteur u s'appelle sa norme et se note ||u||.

Remarque

On a donc ||AB||=AB.

Propriété

M est le milieu du segment [AB] si et seulement si AM=MB.
Vecteurs et milieu

Remarque

On rappelle que l'égalité de distance AM=MB est insuffisante pour montrer que M est le milieu de [AB] (cette égalité montre seulement que M est équidistant de A et B c'est à dire est sur la médiatrice de [AB]). L'égalité de vecteurs AM=MB, par contre, suffit à montrer que M est le milieu de [AB].

Propriété

Le quadrilatère (ABCD) est un parallélogramme si et seulement si AB=DC.
Vecteurs et parallélogramme
Vecteurs et parallélogramme

Remarques

  • Attention à l'inversion des points C et D dans l'égalité AB=DC
  • Avec cette propriété, il suffit de prouver une seule égalité pour montrer qu'un quadrilatère est un parallélogramme. C'est une méthode plus puissante que celles vues en 4ème qui nécessitaient de démontrer deux propriétés (double parallélisme ou parallélisme et égalité de longueurs, etc.)

Définition

La translation de vecteur u est la transformation du plan qui à tout point M du plan associe l'unique point M′ tel que MM′=u
translation de vecteur u

Translation de vecteur u

2. Addition de vecteurs

On définit l'addition de deux vecteurs à l'aide de la relation de Chasles:

Propriété

Pour tous points A, B et C du plan : AB+BC=AC (Relation de Chasles)
Relation de Chasles
Relation de Chasles
Pour appliquer la relation de Chasles, il faut que l'extrémité du premier vecteur coïncide avec l'origine du second. Pour additionner deux vecteurs qui ne sont pas dans cette configuration, on "reporte l'un des vecteurs à la suite de l'autre".

Exemple

Somme de deux vecteurs
Pour tracer la somme des vecteurs AB et CD on reporte le vecteur CD à la suite du vecteur AB; cela donne le vecteur BE qui est égal au vecteur CD. On applique alors la relation de Chasles : AB+BE=AE . La somme cherchée peut donc être représentée par le vecteur AE

Cas particulier

Somme de deux vecteurs de même origine
Si les vecteurs à additionner, ont la même origine, la méthode précédente aboutit à la construction d'un parallélogramme (ABDC) :
AB+AC=AB+BD=AD

Propriété et définition

Pour tout point A et B du plan : AB+BA=AA=0
On dit que les vecteurs AB et BA sont opposés et l'on écrit AB=−BA

Remarque

Deux vecteurs opposés ont la même direction, la même longueur et des sens contraires.

Conséquence

On peut donc définir la différence de 2 vecteurs par :
AB−CD=AB+DC

3. Produit d'un vecteur par un nombre réel

Définition

Soit u un vecteur du plan et soit k un nombre réel.
On définit le vecteur k u de la manière suivante :

Si k est strictement positif :
  • Les vecteurs u et k u ont la même direction
  • Les vecteurs u et k u ont le même sens
  • La norme de k u est k ||u||
Si k est strictement négatif :
  • Les vecteurs u et k u ont la même direction
  • Les vecteurs u et k u ont des sens opposés
  • La norme de k u est −k ||u||
Si k est nul : k u = 0u est le vecteur nul

Exemple

Produit d'un vecteur par un nombre réel
Produit d'un vecteur par un nombre réel

Définition

On dit que deux vecteurs u et v sont colinéaires s'il existe un réel k tel que u = k v ou un réel k′ tel que v = k′u

Remarques

  • Deux vecteurs non nuls sont colinéaires si et seulement si ils ont la même direction (mais ils peuvent avoir des sens opposés)
  • Le vecteur nul est colinéaire à tout vecteur. En effet 0 = 0u

Propriétés

Pour tous vecteurs u et v du plan et tous réels k et k′ :
  • k (u+v) = k u+k v
  • (k+k′) u = k u+k′u
  • k (k′u) = (kk′) u

Exemple

2 (AB+3AC) = 2AB + 2 (3AC) = 2AB + 6AC

Poser une question sur cette fiche >>