Sommaire

GLADIR DLL API ASM
Musique "Invention BWV784" J.S. BACH 1685-1750

GLADIR DLL API ASM

- Prgm Windows -

Nous veillons aux respects des droits d'auteur : si par erreur un contenu protégé est disponible sans indication sur ce site, merci de contacter l'administrateur, il sera retiré ou mis à jour dans les plus brefs délais.


C pour Windows - EXE, DLL et modules de Windows

Voici les DLL les plus communes contenu les API de Windows :

comctl32dl
Fichier | Type | Description
2_0_1browserhelper2.dll | Spyware | Ce fichier contient le code du «BlazeFind WebSearch».
aaplay.dll | Système | Ce fichier contient le pilote «Autodesk Windows Animation Player»
aavga.dll | Système | Ce fichier contient le pilote «Autodesk VGA Full Screen FLI Player»
advapi32.dll | Système | Ce fichier contient les APIs avancé de Windows 32 bits
anioapi.dll | Application | Ce fichier contient la bibliothèque d'aide d'«ANIO» d'«Alpha Networks»
aswcmnos.dll | Application | Ce fichier contient la bibliothèque de l'anti-virus d'«ANIO» d'«Avast»
avicap.dll | Système | Ce fichier contient la bibliothèque «AVI Capture DLL»
avifile.dll | Système | Ce fichier contient la bibliothèque «AVI File Read/Write Library»
bmsubset.dll | Système | Ce fichier contient la bibliothèque contenant un sous-ensemble BitMap
bridge.dll | Spyware | Ce fichier contient le code du «Bridge (Flingstone)».
browseui.dll | Système | Ce fichier contient la bibliothèque de l'interface du navigateur Internet.
caaplay.dll | Système | Ce fichier contient le pilote «Autodesk Windows Animation Player for Corel»
ciodm.dll | Système | Ce fichier contient l'objet d'automatisation d'index de service administrateur
comctl32.dll | Système | Ce fichier contient la bibliothèque d'API de contrôle de boîte de dialogue commune
comdlg32.dll | Système | Ce fichier contient la bibliothèque d'API de boîte de dialogue commune
crpe32.dll | Application | Ce fichier contient la composante du moteur d'impression de «Crystal Report»
d3d8.dll | Système | Ce fichier contient la composante de «DirectX 3D» version 8.
diskcopy.dll | Système | Ce fichier contient la bibliothèque d'outil pour copier des unités de disquette
dlcapi.dll | Système | Ce fichier contient la bibliothèque d'API de la gestion du protocole DLC (Data Link Control).
faultrep.dll | Système | Ce fichier contient la bibliothèque de rapport d'erreur
gdi32.dll | Système | Ce fichier contient la bibliothèque d'interface graphique 32 bits
gpl.dll | Spyware | Ce fichier contient le code du «BHO»
hal.dll | Système | Ce fichier contient la bibliothèque de la couche abstraite matériel (HAL).
hhctrl.ocx | Système | Ce fichier contient le «Centre d'Aide HTML».
hid.dll | Système | Ce fichier contient la bibliothèque d'interface du HID pour les périphériques USB.
hlink.dll | Système | Ce fichier contient la bibliothèque Hypertexte.
itss.dll | Système | Ce fichier contient la bibliothèque «Infotech Storage System Library»
icmp.dll | Système | Ce fichier contient la bibliothèque de protocole ICMP (Internet Control Message Protocol).
imagehlp.dll | Système | Ce fichier contient la bibliothèque d'API d'aide aux services d'image.
iphlpapi.dll | Système | Ce fichier contient la bibliothèque d'API d'aide aux services IP.
kernel32.dll | Système | Ce fichier contient la bibliothèque du noyau du système d'exploitation : Gestion de la mémoire, ses processus, des tâches, du module,...
lz32.dll | Système | Ce fichier contient la bibliothèque de routines de compression 32 bits
mcshield.dll | Application | Ce fichier contient l'application Anti-Virus de McAfee
mmsystem.dll | Système | Ce fichier contient la bibliothèque Multimédia du système d'exploitation
mobsync.dll | Système | Ce fichier contient le gestionnaire de synchronisation
moricons.dll | Système | Ce fichier contient les icônes d'application par défaut et du système d'exploitation.
mpr.dll | Système | Ce fichier contient la bibliothèque de routeurs de fournisseurs multiples (WNet)
mshtmled.dll | Système | Ce fichier contient les fonctions de la bibliothèque de l'éditeur HTML de Microsoft, composante de l'Internet Explorer.
netapi32.dll | Système | Ce fichier contient la bibliothèque d'API réseau 32 bits
netevent.dll | Système | Ce fichier contient le gestionnaire d'événements réseau
odbc32.dll | Système | Ce fichier contient la bibliothèque de procédures et fonctions d'ODBC (Connexion de base de données ouvert)
odbccp32.dll | Système | Ce fichier contient la bibliothèque de procédures et fonctions de composante d'ODBC (Connexion de base de données ouvert)
ole32.dll | Système | Ce fichier contient la bibliothèque d'API d'OLE, soit le partage d'information entre applications
oleadm32.dll | Spyware | Ce fichier contient le code du «Smitfraud».
opengl32.dll | Système | Ce fichier contient la bibliothèque de procédures et fonctions d'OpenGL
pdh.dll | Système | Ce fichier contient la bibliothèque d'API du Performance Counters, soit le service le module permettant d'effectuer des statistiques sur les compteurs de performance du système à partir du système d'exploitation Windows XP.
penwin32.dll | Système | Ce fichier contient la bibliothèque d'API pour la gestion du crayon lumineux
shell32.dll | Système | Ce fichier contient la bibliothèque des APIs du «Shell» en 32 bits
shlwapi.dll | Système | Ce fichier contient la bibliothèque des APIs du «Shell» pour Windows
tb30dlg.dll | Système | Ce fichier contient la bibliothèque de boite de dialogue de l'entreprise «Asymetrix Corp».
user32.dll | Système | Ce fichier contient la bibliothèque de l'interface utilisateur du système d'exploitation
version.dll | Système | Ce fichier contient la bibliothèque de versions du système d'exploitation
wininet.dll | Système | Ce fichier contient la bibliothèque d'API de service Internet
winmm.dll | Système | Ce fichier contient la bibliothèque multimédia de Windows (multimédia, son, midi, ...)
winsock.dll | Système | Ce fichier contient la bibliothèque d'accès au réseau
winspool.drv | Système | Ce fichier contient la bibliothèque de la gestion du tampon d'impression des imprimantes
wintrust.dll | Système | Ce fichier contient la bibliothèque les services de vérification du système d'exploitation Windows.
... | ... | ...

Légende

Cette couleur permet d'indiquer des DLL étant des virus ou des fonctionnalités indésirables.

Dernière mise à jour : Mercredi, le 6 août 2014


C pour Windows - API de Windows

Reference API pour C Windows Description

Vu dans ... http://www.gladir.com

Nom de l'API | Bibliothèque | Description
AbnormalTermination |  | Cette fonction permet d'indiquer que le «TRY-FINALLY» d'un bloc s'est exécuté normalement.
AbortDoc | gdi32.dll | Cette fonction permet d'effectuer l'annulation d'une impression d'un document.
AbortPath | gdi32.dll | Cette fonction permet de terminer et de restituer toutes les palettes du périphérique de contexte.
AbortPrinter | winspool.drv | Cette fonction permet d'effacer un fichier dans le tampon d'impression si l'imprimante est configurée avec un tampon d'impression.
AbortSystemShutdownA | advapi32.dll | Cette fonction permet d'annuler l'opération de fermeture ou de redémarrage en cours d'exécution du système d'exploitation Windows.
AbortSystemShutdownW | advapi32.dll | Cette fonction permet d'annuler l'opération de fermeture ou de redémarrage en cours d'exécution du système d'exploitation Windows avec des paramètres de chaine de caractères étendue (Unicode).
AccessCheck | advapi32.dll | Cette fonction permet, à une application serveur, de vérifier les accès client à un objet de contrôle d'accès.
AccessCheckAndAuditAlarmA | advapi32.dll | Cette fonction permet d'effectuer une validation d'accès et de provoquer le message approprié.
AccessCheckAndAuditAlarmW | advapi32.dll | Cette fonction permet d'effectuer une validation d'accès et de provoquer le message approprié avec des paramètres de chaine de caractères étendue (Unicode).
AcsLan | dlcapi.dll | Cette fonction permet de communiquer avec d'autres ordinateurs ou par périphérique réseau, comme des imprimantes, en utilisant le protocole DLC (Data Link Control).
ActivateKeyboardLayout | user32.dll | Cette fonction permet d'activer une disposition différente du clavier pour le processus courant.
AddAccessAllowedAce | advapi32.dll | Cette fonction permet d'ajouter un accès autorisé à l'ACE d'un ACL.
AddAccessDeniedAce | advapi32.dll | Cette fonction permet d'ajouter un accès refusé à l'ACE d'un ACL.
AddAce | advapi32.dll | Cette fonction permet d'ajouter un ACE à un ACL spécifié.
AddAuditAccessAce | advapi32.dll | Cette fonction permet d'ajouter un ACE système à un ACL système.
AddAtomA | kernel32.dll | Cette fonction permet d'ajouter une chaine de caractères ASCIZ à l'Atom global.
AddAtomW | kernel32.dll | Cette fonction permet d'ajouter un caractère étendue (Unicode) à l'Atom global.
AddFontResourceA | gdi32.dll | Cette fonction permet d'ajouter une police de caractères à partir d'un fichier.
AddFontResourceW | gdi32.dll | Cette fonction permet d'ajouter une police de caractères à partir d'un fichier avec des paramètres de chaine de caractères étendues (Unicode).
AddFormA | winspool.drv | Cette fonction permet d'ajouter un formulaire à la liste des formulaires de l'imprimante spécifié.
AddInksetInterval | penwin32.dll | Cette fonction permet de fixer l'intervalle de la cartouche d'encre de l'imprimante.
AddJobA | winspool.drv | Cette fonction permet de fixer la chaine de caractères du répertoire contenant les fichiers du tampon d'imprimante.
AddMonitorA | winspool.drv | Cette fonction permet d'installer un moniteur d'imprimante local et des liens de configuration, de données et de fichiers du moniteur.
AddPenDataHRC | penwin32.dll | Cette fonction permet d'ajouter un objet de données de crayon lumineux.
AddPenInputHRC | penwin32.dll | Cette fonction permet d'ajouter un objet de données de crayon lumineux exporté.
AddPointsPenData | penwin32.dll | Cette fonction permet d'ajouter un ensemble de point de données à l'objet de crayon lumineux.
AddPortA | winspool.drv | Cette fonction permet d'ajouter un nom de port à la liste des ports supporté par l'imprimante.
AddPrinterA | winspool.drv | Cette fonction permet d'ajouter une imprimante à la liste des imprimantes.
AddPrinterConnectionA | winspool.drv | Cette fonction permet d'ajouter une connexion à l'imprimante pour l'utilisateur courant.
AddPrinterDriverA | winspool.drv | Cette fonction permet d'installer un pilote d'imprimante avec la configuration, les données et les fichiers du pilote.
AddPrintProcessorA | winspool.drv | Cette fonction permet d'installer un processeur d'imprimante à partir d'un serveur et d'une liste processeur d'imprimante supporté.
AddPrintProvidorA | winspool.drv | Cette fonction permet d'installer un fournisseur d'imprimante avec la configuration, les données et les fichiers du fournisseur.
AddWordsHWL | penwin32.dll | Cette fonction permet d'ajouter des mots dans une liste de mots.
AdjustTokenGroups | advapi32.dll | Cette fonction permet d'ajuster des groupes dans une liste d'objet à saisir.
AdjustTokenPrivileges | advapi32.dll | Cette fonction permet d'ajuster des prévilèges dans une liste d'objet à saisir.
AdjustWindowRect | user32.dll | Cette fonction permet de calculer l'espace requis par le rectangle d'une fenêtre basé sur un rectangle client.
AdjustWindowRectEx | user32.dll | Cette fonction permet de calculer l'espace requis par le rectangle d'une fenêtre avec un style étendue basé sur un rectangle client.
AdvancedDocumentPropertiesA | winspool.drv | Cette fonction permet d'afficher la configuration de l'imprimante spécifiée dans une boite de dialogue.
AllocateAndInitializeSid | advapi32.dll | Cette fonction permet d'alloué ainsi que d'initialiser l'identificateur de sécurité (SID) avec jusqu'à 8 sous-autorités.
AllocateLocallyUniqueId | advapi32.dll | Cette fonction permet d'alloué un identificateur local unique (LUID).
AllocConsole | kernel32.dll | Cette fonction permet de créer une nouvelle console.
AngleArc | gdi32.dll | Cette fonction permet de dessiner une ligne de segment et d'un arc de cercle.
AnimatePalette | gdi32.dll | Cette fonction permet de fixer la valeur des palettes de couleur logique.
AnyPopup | user32.dll | Cette fonction permet d'indiquer s'il existe un moins une fenêtre visible ou invisible sur le bureau de l'écran.
AppendMenuA | user32.dll | Cette fonction permet d'ajouter un nouvel item au menu courant.
AppendMenuW | user32.dll | Cette fonction permet d'ajouter un nouvel item au menu courant avec des paramètres de chaine de caractères étendues (Unicode).
Arc | gdi32.dll | Cette fonction permet de dessiner l'arc d'une ellipse.
ArcTo | gdi32.dll | Cette fonction permet de dessiner un arc d'une ellipse.
AreAllAccessesGranted | advapi32.dll | Cette fonction permet d'effectuer la vérification sur un ensemble de requête d'accès garantie.
AreAnyAccessesGranted | advapi32.dll | Cette fonction permet d'effectuer la vérification sur n'importe quel élément d'un ensemble de requête d'accès garantie.
AreFileApisANSI | kernel32.dll | Cette fonction permet d'indiquer si les fonctions pour fichier du Win32 utilise un ensemble de police de caractères ANSI ou une page OEM.
ArrangeIconicWindows | user32.dll | Cette fonction permet de minimiser les fenêtres enfants d'une fenêtre parente.
AttachThreadInput | user32.dll | Cette fonction permet de relier un processus avec un autre.
auxGetDevCapsA | winmm.dll | Cette fonction permet de demander les informations concernant le système audio auxiliaire.
auxGetNumDevs | winmm.dll | Cette fonction permet de demander le nombre de système audio auxiliaire reconnu par Windows.
BackupEventLogA | advapi32.dll | Cette fonction permet d'effectuer une sauvegarde du journal de bord dans un fichier de copie de sécurité.
BackupEventLogW | advapi32.dll | Cette fonction permet d'effectuer une sauvegarde du journal de bord dans un fichier de copie de sécurité avec des paramètres de chaine de caractères étendue (Unicode).
BackupRead | kernel32.dll | Cette fonction permet d'effectuer la lecture de flux de données associé avec un fichier ou un répertoire spécifié d'un tampon.
BackupSeek | kernel32.dll | Cette fonction permet de fixer la position dans le flux de données accessible par les fonctions «BackupRead» et «BackupWrite».
BackupWrite | kernel32.dll | Cette fonction permet d'effectuer l'écriture de flux de données associé avec un fichier ou un répertoire spécifié d'un tampon.
Beep | kernel32.dll | Cette fonction permet d'émettre un signal sonore sur le PC Speaker.
BeginDeferWindowPos | user32.dll | Cette fonction permet d'allouer de la mémoire sur de multiples positions de fenêtres d'une structure de données.
BeginPaint | user32.dll | Cette fonction permet de préparé les spécifications de la fenêtre pour la peindre et la remplir avec les informations de la structure spécifié.
BeginPath | gdi32.dll | Cette fonction permet d'ouvrir une braquette de chemin pour le périphérique de contexte (DC) spécifié.
BeginUpdateResourceA | kernel32.dll | Cette fonction permet de retourner l'identificateur Handle qu'utilise une fonction «UpdateResource» pour ajouter, supprimer ou remplacer dans un fichier exécutable.
BeginUpdateResourceW | kernel32.dll | Cette fonction permet de retourner l'identificateur Handle qu'utilise une fonction «UpdateResource» pour ajouter, supprimer ou remplacer dans un fichier exécutable avec des paramètres de chaine de caractères étendue (Unicode).
BitBlt | gdi32.dll | Cette fonction permet d'effectuer la copie d'un Bitmap vers l'écran.
BlockInput | user32.dll | Cette fonction permet d'arrêter les événements d'entrer comme le clavier, la souris,...
BringWindowToTop | user32.dll | Cette fonction permet d'activer et de porter, en haut de la pile des fenêtres, la fenêtre spécifiée.
BroadcastSystemMessageA | user32.dll | Cette fonction permet d'envoyer un message vers un récipient spécifié.
BroadcastSystemMessageW | user32.dll | Cette fonction permet d'envoyer un message vers un récipient spécifié avec des paramètres de chaine de caractères étendues (Unicode).
BuildCommDCBA | kernel32.dll | Cette fonction permet de remplir une structure DCB avec les valeurs spécifiées par une chaine de caractères de périphérique de contrôle.
BuildCommDCBW | kernel32.dll | Cette fonction permet de remplir une structure DCB avec les valeurs spécifiées par une chaine de caractères de périphérique de contrôle avec des paramètres de chaine de caractères étendue (Unicode).
BuildCommDCBAndTimeoutsA | kernel32.dll | Cette fonction permet de convertir la chaine de caractères des définitions d'un périphérique en un bloc de périphérique de contrôle et de placer les codes dans un bloc dans le périphérique de contrôle.
BuildCommDCBAndTimeoutsW | kernel32.dll | Cette fonction permet de convertir la chaine de caractères des définitions d'un périphérique en un bloc de périphérique de contrôle et de placer les codes dans un bloc dans le périphérique de contrôle avec des paramètres de chaine de caractères étendue (Unicode).
CallMsgFilterA | user32.dll | Cette fonction permet de passer un message à la fonction de filtre de message courant.
CallMsgFilterW | user32.dll | Cette fonction permet de passer un message à la fonction de filtre de message courant avec des paramètres de chaine de caractères étendues (Unicode).
CallNamedPipeA | kernel32.dll | Cette fonction permet d'effectuer une connection à l'aide d'un tuyau de type de message et de lire et d'écrire dans se tuyau et d'ensuite fermer le tuyau.
CallNamedPipeW | kernel32.dll | Cette fonction permet d'effectuer une connection à l'aide d'un tuyau de type de message et de lire et d'écrire dans se tuyau et d'ensuite fermer le tuyau avec des paramètres de chaine de caractères étendue (Unicode).
CallNextHookEx | user32.dll | Cette fonction permet de passer au prochain crochet des informations de crochet dans une chaine de crochet.
CallWindowProcA | user32.dll | Cette fonction permet d'appeler et de passer des informations de message à la fonction de fenêtre spécifié.
CallWindowProcW | user32.dll | Cette fonction permet d'appeler et de passer des informations de message à la fonction de fenêtre spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CancelDC | gdi32.dll | Cette fonction permet d'annuler une opération en attente pour le périphérique de contexte (DC) spécifié.
CancelIo | kernel32.dll | Cette fonction permet d'annuler une opération d'entrée/sortie initié par un processus léger dans un fichier.
CancelWaitableTimer | kernel32.dll | Cette fonction permet de fixer le délai d'attente de l'horloge à un état inactif.
CascadeWindows | user32.dll | Cette fonction permet d'effectuer des cascades de fenêtre spécifié ou de fenêtre enfant dans la fenêtre parent spécifié.
ChangeClipboardChain | user32.dll | Cette fonction permet d'enlever le premier élément de la chaine du visualisateur de presse-papier et de le remplacer par le deuxième élément spécifié.
ChangeDisplaySettingsA | user32.dll | Cette fonction permet de modifier les paramètres du mode d'affichage graphique
ChangeDisplaySettingsW | user32.dll | Cette fonction permet de modifier les paramètres du mode d'affichage graphique avec des paramètres de chaine de caractères étendues (Unicode).
ChangeDisplaySettingsExA | user32.dll | Cette fonction permet de modifier les paramètres du mode d'affichage graphique pour le périphérique d'affichage spécifié.
ChangeDisplaySettingsExW | user32.dll | Cette fonction permet de modifier les paramètres du mode d'affichage graphique pour le périphérique d'affichage spécifié avec des paramètres de chaine de caractères étendues (Unicode).
ChangeMenuA | user32.dll | Cette fonction permet de modifier un élément du menu spécifié.
ChangeMenuW | user32.dll | Cette fonction permet de modifier un élément du menu spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CharLowerA | user32.dll | Cette fonction permet d'effectuer la conversion d'une chaine de caractères spécifié en minuscule.
CharLowerBuffA | user32.dll | Cette fonction permet d'effectuer la conversion des caractères majuscules contenu dans un tampon en caractères minuscule.
CharLowerBuffW | user32.dll | Cette fonction permet d'effectuer la conversion des caractères majuscules contenu dans un tampon en caractères minuscule avec des paramètres de chaine de caractères étendues (Unicode).
CharLowerW | user32.dll | Cette fonction permet d'effectuer la conversion d'une chaine de caractères spécifié en minuscule avec des paramètres de chaine de caractères étendues (Unicode).
CharNextA | user32.dll | Cette fonction permet de retourner un pointeur sur le prochaine caractère contenu dans une chaine de caractères.
CharNextExA | user32.dll | Cette fonction permet de retourner l'adresse du prochaine caractère contenu dans une chaine de caractères.
CharNextW | user32.dll | Cette fonction permet de retourner un pointeur sur le prochaine caractère contenu dans une chaine de caractères avec des paramètres de chaine de caractères étendues (Unicode).
CharPrevA | user32.dll | Cette fonction permet de retourner un pointeur sur le caractère précédent contenu dans une chaine de caractères.
CharPrevExA | user32.dll | Cette fonction permet de retourner l'adresse du caractère précédent contenu dans une chaine de caractères.
CharPrevW | user32.dll | Cette fonction permet de retourner un pointeur sur le caractère précédent contenu dans une chaine de caractères avec des paramètres de chaine de caractères étendues (Unicode).
CharToOemA | user32.dll | Cette fonction permet d'effectuer la transformation d'une chaine de caractères en ensemble de caractères OEM utilisateur.
CharToOemBuffA | user32.dll | Cette fonction permet d'effectuer la transformation d'un nombre spécifique de caractères dans une chaine de caractères d'un ensemble de caractères OEM utilisateur.
CharToOemBuffW | user32.dll | Cette fonction permet d'effectuer la transformation d'un nombre spécifique de caractères dans une chaine de caractères d'un ensemble de caractères OEM utilisateur avec des paramètres de chaine de caractères étendues (Unicode).
CharToOemW | user32.dll | Cette fonction permet d'effectuer la transformation d'une chaine de caractères en ensemble de caractères OEM utilisateur avec des paramètres de chaine de caractères étendues (Unicode).
CharUpperA | user32.dll | Cette fonction permet d'effectuer la conversion d'une chaine de caractères spécifié en majuscule.
CharUpperBuffA | user32.dll | Cette fonction permet d'effectuer la conversion des caractères minuscules contenu dans un tampon en caractères majuscule.
CharUpperBuffW | user32.dll | Cette fonction permet d'effectuer la conversion des caractères minuscules contenu dans un tampon en caractères majuscule avec des paramètres de chaine de caractères étendues (Unicode).
CharUpperW | user32.dll | Cette fonction permet d'effectuer la conversion d'une chaine de caractères spécifié en majuscule avec des paramètres de chaine de caractères étendues (Unicode).
CheckColorsInGamut | gdi32.dll | Cette fonction permet d'indiquer si les valeurs de couleurs spécifiés sont dans la gamme du périphérique spécifié.
CheckDlgButton | user32.dll | Cette fonction permet de fixer ou d'enlever une marque de vérification d'un bouton de contrôle ou de changer l'état d'un contrôle d'arbre de bouton.
CheckMenuItem | user32.dll | Cette fonction permet de fixer ou d'enlever un marque de vérification d'un item de menu dans un menu contextuel.
CheckMenuRadioItem | user32.dll | Cette fonction permet de vérifier l'item de menu spécifié et de fabriquer un item radio.
CheckRadioButton | user32.dll | Cette fonction permet de vérifier ou d'enlever un marque de vérification d'un groupe de bouton radio spécifié.
ChildWindowFromPoint | user32.dll | Cette fonction permet de demander le propriétaire de la fenêtre enfant à l'aide d'une coordonnée spécifié.
ChildWindowFromPointEx | user32.dll | Cette fonction permet de demander lequel des fenêtres enfants, si possible, appartient à la fenêtre parent du point spécifié.
ChooseColorA | comdlg32.dll | Cette fonction permet de lancer une boite de dialogue offrant la possibilité à l'utilisateur de choisir une couleur
ChooseFontA | comdlg32.dll | Cette fonction permet de lancer une boite de dialogue offrant la possibilité à l'utilisateur de choisir une police de caractères
ChoosePixelFormat | gdi32.dll | Cette fonction permet de tenter de faire correspondre à un format de pixel approprié supporté par un périphérique de contexte d'un format de pixel donné spécifié.
Chord | gdi32.dll | Cette fonction permet de dessiner la corde de limite à l'aide d'une intersection d'une ellipse avec le centre d'un rectangle et d'une ligne de segment.
ClearCommBreak | kernel32.dll | Cette fonction permet de restituer les caractères transmis par un périphérique de communications spécifié et place ligne de transmission dans un état non arrêtable.
ClearCommError | kernel32.dll | Cette fonction permet de demander des informations à propos d'erreur de communications et un rapport d'état actuel sur un périphérique de communication.
ClearEventLogA | advapi32.dll | Cette fonction permet d'effacer le journal de bord spécifié et sauvegarde une copie du journal du bord courant dans un fichier si désiré.
ClearEventLogW | advapi32.dll | Cette fonction permet d'effacer le journal de bord spécifié et sauvegarde une copie du journal du bord courant dans un fichier si désiré avec des paramètres de chaine de caractères étendue (Unicode).
ClientToScreen | user32.dll | Cette fonction permet d'effectuer la transformation des coordonnées logique du client en coordonnées physiquement sur l'écran
ClipCursor | user32.dll | Cette fonction permet de définir une fenêtre limitant le déplacement du pointeur de la souris.
CloseClipboard | user32.dll | Cette fonction permet d'indiquer que le traitement avec le presse-papier est terminé et que les autres applications peuvent maintenant avoir accès aux données qu'elle contient.
CloseDesktop | user32.dll | Cette fonction permet de fermer ou d'ouvrir le Handle de l'objet de bureau.
CloseEnhMetaFile | gdi32.dll | Cette fonction permet de fermer un périphérique de contexte de fichier méta étendue et retourne le Handle identifiant un format de fichier méta étendue.
CloseEventLog | advapi32.dll | Cette fonction permet de fermer le fichier de journal de bord d'événement spécifié
CloseFigure | gdi32.dll | Cette fonction permet de fermer une figure dans une spécification de chemin.
CloseHandle | kernel32.dll | Cette fonction permet d'effectuer la fermeture d'un Handle.
CloseMetaFile | gdi32.dll | Cette fonction permet de fermer et de créer le fichier de méta pour pouvoir jouer son contenu.
ClosePrinter | winspool.drv | Cette fonction permet d'indiquer que le traitement avec le tampon d'impression de l'imprimante est terminé.
CloseWindow | user32.dll | Cette fonction permet de minimiser (sans la détruire) la fenêtre spécifié.
CloseWindowStation | user32.dll | Cette fonction permet de fermer un Handle de fenêtre de station ouverte.
CoCreateGuid | ole32.dll | Cette fonction permet de créer un identificateur global unique GUID (Global Unique ID) générer sur une base de 128-bits pouvant être utilisé par exemple pour les identificateurs de classe CLSID.
ColorMatchToTarget | gdi32.dll | Cette fonction permet d'activer ou désactiver le prévisualisation du périphérique de contexte spécifié.
CombineRgn | gdi32.dll | Cette fonction permet de créer une nouvelle région pour combiné deux régions existantes.
CombineTransform | gdi32.dll | Cette fonction permet d'effectuer la concaténation de double espace mondiale vers une transformation d'espace de page.
CommConfigDialogA | kernel32.dll | Cette fonction permet d'afficher une configuration de pilote de fournisseur dans une boite de dialogue.
CommConfigDialogW | kernel32.dll | Cette fonction permet d'afficher une configuration de pilote de fournisseur dans une boite de dialogue avec des paramètres de chaine de caractères étendue (Unicode).
CompareFileTime | kernel32.dll | Cette fonction permet de comparer deux temps de fichier de 64-bits.
CompareStringA | kernel32.dll | Cette fonction permet d'effectuer la comparaison de deux chaines de caractères ASCIZ.
CompareStringW | kernel32.dll | Cette fonction permet d'effectuer la comparaison de deux chaines de caractères Unicode.
ConfigurePortA | winspool.drv | Cette fonction permet de lancer une boite de dialogue offrant la possibilité à l'utilisateur de choisir le port parallèle ou USB d'imprimante
ConnectNamedPipe | kernel32.dll | Cette fonction permet d'activé un nom de tuyau d'un processus serveur en attente pour un processus client de connexion.
ContinueDebugEvent | kernel32.dll | Cette fonction permet d'activer un débogueur pour qu'il continue un processus précédemment rapporter comme un bogue d'événement.
ConvertDefaultLocale | kernel32.dll | Cette fonction permet de convertir une valeur locale spécial par défaut en un identificateur local courant.
ConvertThreadToFiber | kernel32.dll | Cette fonction permet d'effectuer la conversion d'un processus léger vers un fibre.
CopyAcceleratorTableA | user32.dll | Cette fonction permet de copier la table d'accélérateur spécifié.
CopyAcceleratorTableW | user32.dll | Cette fonction permet de copier la table d'accélérateur spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CopyEnhMetaFileA | gdi32.dll | Cette fonction permet de copier le contenu d'un fichier méta de format étendue vers un fichier spécifié.
CopyEnhMetaFileW | gdi32.dll | Cette fonction permet de copier le contenu d'un fichier méta de format étendue vers un fichier spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CopyFileA | kernel32.dll | Cette fonction permet d'effectuer la copie d'un fichier d'un emplacement à un autre emplacement
CopyFileExA | kernel32.dll | Cette fonction permet d'effectuer la copie d'un fichier d'un emplacement à un autre emplacement tout en effectuant un processus d'arrière plan indiquant sa progression.
CopyFileExW | kernel32.dll | Cette fonction permet d'effectuer la copie d'un fichier d'un emplacement à un autre emplacement tout en effectuant un processus d'arrière plan indiquant sa progression avec des paramètres de chaine de caractères étendue (Unicode).
CopyFileW | kernel32.dll | Cette fonction permet d'effectuer la copie d'un fichier d'un emplacement à un autre emplacement avec des paramètres de chaine de caractères étendue (Unicode).
CopyIcon | user32.dll | Cette fonction permet de copier un icône spécifié d'un autre module vers le module courant.
CopyImage | user32.dll | Cette fonction permet de créer une nouvelle image (icône, image ou Bitmap) et de copier les attributs de l'image donnée dans une nouvelle image.
CopyMetaFileA | gdi32.dll | Cette fonction permet de copier le contenu d'un format de méta fichier Windows vers un fichier spécifié.
CopyMetaFileW | gdi32.dll | Cette fonction permet de copier le contenu d'un format de méta fichier Windows vers un fichier spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CopyRect | user32.dll | Cette fonction permet d'effectuer la copie des coordonnées d'un rectangle dans un autre rectangle.
CopySid | advapi32.dll | Cette fonction permet de copier l'identificateur de sécurité (SID) dans un tampon spécifié.
CountClipboardFormats | user32.dll | Cette fonction permet de demander le nombre de différentes données de formats courant que contient le presse-papier.
CreateAcceleratorTableA | user32.dll | Cette fonction permet de créer une table d'accélérateur.
CreateAcceleratorTableW | user32.dll | Cette fonction permet de créer une table d'accélérateur avec des paramètres de chaine de caractères étendues (Unicode).
CreateBitmap | gdi32.dll | Cette fonction permet de créer un périphérique de Bitmap en mémoire avec la largeur, hauteur et la palette de bits spécifié.
CreateBitmapIndirect | gdi32.dll | Cette fonction permet de créer un Bitmap avec la largeur, la hauteur et la palette de bits spécifié dans une structure BITMAP.
CreateBrushIndirect | gdi32.dll | Cette fonction permet de créer une brosse avec le style, la couleur et la palette spécifié dans la structure «LOGBRUSH».
CreateCaret | user32.dll | Cette fonction permet de créer un nouveau signe pour le curseur texte et associe le propriétaire à la fenêtre spécifié.
CreateColorSpaceA | gdi32.dll | Cette fonction permet de créer un espace de couleur logique.
CreateColorSpaceW | gdi32.dll | Cette fonction permet de créer un espace de couleur logique avec des paramètres de chaine de caractères étendues (Unicode).
CreateCompatibleBitmap | gdi32.dll | Cette fonction permet de créer un Bitmap compatible avec le périphérique spécifié.
CreateCompatibleDC | gdi32.dll | Cette fonction permet de créer un contexte de périphérique mémoire compatible avec le périphérique spécifié.
CreateConsoleScreenBuffer | kernel32.dll | Cette fonction permet de créer un tampon de console écran et de retourner un identificateur Handle associée à celui-ci.
CreateCursor | user32.dll | Cette fonction permet d'effectuer la création d'une nouvelle image de pointeur de souris
CreateDCA | gdi32.dll | Cette fonction permet d'effectuer la création d'un objet de contexte (DC)
CreateDCW | gdi32.dll | Cette fonction permet d'effectuer la création d'un objet de contexte (DC) avec des paramètres de chaines de caractères étendues (Unicode).
CreateDesktopA | user32.dll | Cette fonction permet de créer un nouveau bureau dans une fenêtre de station associé avec le processus appelant.
CreateDesktopW | user32.dll | Cette fonction permet de créer un nouveau bureau dans une fenêtre de station associé avec le processus appelant avec des paramètres de chaine de caractères étendues (Unicode).
CreateDialogIndirectParamA | user32.dll | Cette fonction permet de créer un modèle de boite de dialogue pour un gabarit de boite de dialogue en mémoire et après son affichage, la fonction passe une valeur d'application à la procédure de boite de dialogue avec les paramètres spécifié du message «WM_INITDIALOG».
CreateDialogIndirectParamW | user32.dll | Cette fonction permet de créer un modèle de boite de dialogue pour un gabarit de boite de dialogue en mémoire et après son affichage, la fonction passe une valeur d'application à la procédure de boite de dialogue avec les paramètres spécifié du message «WM_INITDIALOG» avec des paramètres de chaine de caractères étendues (Unicode).
CreateDialogParamA | user32.dll | Cette fonction permet de créer un modèle de boite de dialogue pour une ressource de gabarit de boite de dialogue et après son affichage, la fonction passe une valeur d'application à la procédure de boite de dialogue avec les paramètres spécifié du message «WM_INITDIALOG».
CreateDialogParamW | user32.dll | Cette fonction permet de créer un modèle de boite de dialogue pour une ressource de gabarit de boite de dialogue et après son affichage, la fonction passe une valeur d'application à la procédure de boite de dialogue avec les paramètres spécifié du message «WM_INITDIALOG» avec des paramètres de chaine de caractères étendues (Unicode).
CreateDIBPatternBrush | gdi32.dll | Cette fonction permet de créer une brosse avec la palette spécifié par un périphérique de Bitmap indépendant (DIB).
CreateDIBPatternBrushPt | gdi32.dll | Cette fonction permet de créer une brosse logique avec la palette spécifié par un périphérique de Bitmap indépendant (DIB).
CreateDIBSection | gdi32.dll | Cette fonction permet de créer un Bitmap de périphérique indépendant (DIB) avec les applications pouvant y être écrit directement.
CreateDIBitmap | gdi32.dll | Cette fonction permet de créer un périphérique mémoire spécifié pour un périphérique de Bitmap indépendant (DIB) spécifié et un ensemble de bits optionnel pour le Bitmap.
CreateDirectoryA | kernel32.dll | Cette fonction permet d'effectuer la création d'un répertoire
CreateDirectoryW | kernel32.dll | Cette fonction permet d'effectuer la création d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
CreateDirectoryExA | kernel32.dll | Cette fonction permet d'effectuer la création d'un répertoire étendue
CreateDirectoryExW | kernel32.dll | Cette fonction permet d'effectuer la création d'un répertoire étendue avec des paramètres de chaine de caractères étendue (Unicode).
CreateDirectoryTransactedA | kernel32.dll | Cette fonction permet d'effectuer la création d'un répertoire dans une opération de transaction
CreateDirectoryTransactedW | kernel32.dll | Cette fonction permet d'effectuer la création d'un répertoire dans une opération de transaction avec des paramètres de chaine de caractères étendue (Unicode).
CreateDiscardableBitmap | gdi32.dll | Cette fonction permet de créer un Bitmap compatible avec un périphérique spécifié.
CreateEllipticRgn | gdi32.dll | Cette fonction permet de créer une région elliptique.
CreateEllipticRgnIndirect | gdi32.dll | Cette fonction permet de créer une région elliptique à l'aide d'une structure de données.
CreateEnhMetaFileA | gdi32.dll | Cette fonction permet de créer un contexte de périphérique pour un méta fichier de format étendue.
CreateEnhMetaFileW | gdi32.dll | Cette fonction permet de créer un contexte de périphérique pour un méta fichier de format étendue avec des paramètres de chaine de caractères étendues (Unicode).
CreateEventA | kernel32.dll | Cette fonction permet de créer un objet d'événement nommé ou non-nommé.
CreateEventW | kernel32.dll | Cette fonction permet de créer un objet d'événement nommé ou non-nommé avec des paramètres de chaine de caractères étendue (Unicode).
CreateFiber | kernel32.dll | Cette fonction permet d'allouer un objet de fibre, en lui attribuant une pile, et en fixant le début de l'exécutant à l'adresse de début spécifié.
CreateFileA | kernel32.dll | Cette fonction permet d'effectuer la création ou l'ouverture d'un fichier ou d'un périphérique
CreateFileW | kernel32.dll | Cette fonction permet d'effectuer la création ou l'ouverture d'un fichier ou d'un périphérique avec des paramètres de chaine de caractères étendue (Unicode).
CreateFileMappingA | kernel32.dll | Cette fonction permet de créer un objet mapping, nommé ou non-nommé, pour un fichier spécifié.
CreateFileMappingW | kernel32.dll | Cette fonction permet de créer un objet mapping, nommé ou non-nommé, pour un fichier spécifié avec des paramètres de chaine de caractères étendue (Unicode).
CreateFontA | gdi32.dll | Cette fonction permet d'effectuer la création d'une police de caractères logique avec les caractéristiques spécifiés.
CreateFontIndirectA | gdi32.dll | Cette fonction permet de créer une police de caractères logique avec les caractéristiques spécifié dans la structure spécifié.
CreateFontIndirectW | gdi32.dll | Cette fonction permet de créer une police de caractères logique avec les caractéristiques spécifié dans la structure spécifié avec les paramètres de chaines de caractères étendues (Unicode).
CreateFontW | gdi32.dll | Cette fonction permet d'effectuer la création d'une police de caractères logique avec les caractéristiques spécifiés avec les paramètres de chaine de caractères étendues (Unicode).
CreateHalftonePalette | gdi32.dll | Cette fonction permet de créer une demi-teinte d'une palette pour le périphérique de contexte spécifié.
CreateHatchBrush | gdi32.dll | Cette fonction permet de créer une brosse logique spécifiant un motif de hachure et de couleur.
CreateICA | gdi32.dll | Cette fonction permet de créer une information de contexte pour un périphérique spécifié.
CreateICW | gdi32.dll | Cette fonction permet de créer une information de contexte pour un périphérique spécifié avec des paramètres de chaines de caractères étendues (Unicode).
CreateIcon | user32.dll | Cette fonction permet d'effectuer la création d'une icône
CreateIconFromResource | user32.dll | Cette fonction permet d'effectuer la création d'un icône ou d'un curseur à partir de bits de ressources décrit dans l'icône.
CreateIconFromResourceEx | user32.dll | Cette fonction permet d'effectuer la création d'un icône ou d'un curseur à partir de bits de ressources décrit dans l'icône avec des options complémentaires.
CreateIconIndirect | user32.dll | Cette fonction permet d'effectuer la création d'un icône ou d'un curseur à partir d'une structure de données.
CreateMailslotA | kernel32.dll | Cette fonction permet de créer une slot de courriel avec un nom spécifié et retourne un identificateur Handle associé à celle-ci.
CreateMailslotW | kernel32.dll | Cette fonction permet de créer une slot de courriel avec un nom spécifié et retourne un identificateur Handle associé à celle-ci avec des paramètres de chaine de caractères étendue (Unicode).
CreateMDIWindowA | user32.dll | Cette fonction permet d'effectuer la création de fenêtre enfant MDI (Interface de multiple document).
CreateMDIWindowW | user32.dll | Cette fonction permet d'effectuer la création de fenêtre enfant MDI (Interface de multiple document) avec des paramètres de chaine de caractères étendues (Unicode).
CreateMenu | user32.dll | Cette fonction permet d'effectuer la création d'un menu.
CreateMetaFileA | gdi32.dll | Cette fonction permet de créer un périphérique de contexte pour un format de fichier méta Windows.
CreateMetaFileW | gdi32.dll | Cette fonction permet de créer un périphérique de contexte pour un format de fichier méta Windows avec des paramètres de chaines de caractères étendues (Unicode).
CreateMutexA | kernel32.dll | Cette fonction permet de créer un objet Mutex nommé ou non-nommé.
CreateMutexW | kernel32.dll | Cette fonction permet de créer un objet Mutex nommé ou non-nommé avec des paramètres de chaine de caractères étendue (Unicode).
CreateNamedPipeA | kernel32.dll | Cette fonction permet de créer un tuyau avec un instance de nom spécifié et de retourner un identificateur Handle associé à celle-ci.
CreateNamedPipeW | kernel32.dll | Cette fonction permet de créer un tuyau avec un instance de nom spécifié et de retourner un identificateur Handle associé à celle-ci avec des paramètres de chaine de caractères étendue (Unicode).
CreatePalette | gdi32.dll | Cette fonction permet d'effectuer la création d'une palette logique.
CreatePatternBrush | gdi32.dll | Cette fonction permet d'effectuer la création d'une brosse logique avec la palette Bitmap spécifié.
CreatePen | gdi32.dll | Cette fonction permet d'effectuer la création d'un crayon logique avec le style, la largeur et la couleur spécifié.
CreatePenIndirect | gdi32.dll | Cette fonction permet d'effectuer la création d'un crayon logique avec le style, la largeur et la couleur à l'aide la structure de données spécifié.
CreatePipe | kernel32.dll | Cette fonction permet de créer un tuyau anonyme et de retourner un identificateur Handle attribué en lecture et écriture pour celle-ci.
CreatePolyPolygonRgn | gdi32.dll | Cette fonction permet d'effectuer la création d'une région contenant une série de fermeture de polygone.
CreatePolygonRgn | gdi32.dll | Cette fonction permet d'effectuer la création d'une région en forme de polygone.
CreatePopupMenu | user32.dll | Cette fonction permet d'effectuer la création d'un menu contextuel
CreatePrivateObjectSecurity | advapi32.dll | Cette fonction permet d'alloué et d'initialiser un descripteur de sécurité relatif à l'objet pour un un serveur d'objet protégé.
CreateProcessA | kernel32.dll | Cette fonction permet de créer un nouveau processus et de le fixer comme processus léger primaire.
CreateProcessW | kernel32.dll | Cette fonction permet de créer un nouveau processus et de le fixer comme processus léger primaire avec des paramètres de chaine de caractères étendue (Unicode).
CreateProcessAsUserA | advapi32.dll | Cette fonction permet de créer un nouveau processus et de le mettre comme processus primaire.
CreateProcessAsUserW | advapi32.dll | Cette fonction permet de créer un nouveau processus et de le mettre comme processus primaire avec des paramètres de chaine de caractères étendue (Unicode).
CreateRectRgn | gdi32.dll | Cette fonction permet d'effectuer la création d'une région rectangulaire.
CreateRectRgnIndirect | gdi32.dll | Cette fonction permet d'effectuer la création d'une région rectangulaire à l'aide d'une structure de données.
CreateRemoteThread | kernel32.dll | Cette fonction permet de créer un processus léger exécuté dans l'espace d'une adresse d'un autre processus.
CreateRoundRectRgn | gdi32.dll | Cette fonction permet d'effectuer la création d'une région rectangulaire avec les coins arrondies.
CreateScalableFontResourceA | gdi32.dll | Cette fonction permet de créer un fichier de ressource de police de caractères avec une police de caractères vectorielle.
CreateScalableFontResourceW | gdi32.dll | Cette fonction permet de créer un fichier de ressource de police de caractères avec une police de caractères vectorielle avec des paramètres de chaine de caractères étendue (Unicode).
CreateSemaphoreA | kernel32.dll | Cette fonction permet de créer un objet de sémaphore nommé ou non-nommé.
CreateSemaphoreW | kernel32.dll | Cette fonction permet de créer un objet de sémaphore nommé ou non-nommé avec des paramètres de chaine de caractères étendue (Unicode).
CreateSolidBrush | gdi32.dll | Cette fonction permet d'effectuer la création d'une brosse logique avec la couleur et le motif solide spécifié.
CreateStatusWindowA | comctl32.dll | Cette fonction permet d'effectuer la création d'une barre d'état dans le bas d'une fenêtre d'application
CreateTapePartition | kernel32.dll | Cette fonction permet de reformatée une unité de sauvegarde de bande magnétique (Tape Backup).
CreateToolhelp32Snapshot | kernel32.dll | Cette fonction permet d'effectuer une capture de l'écran sous forme d'un Bitmap
CreateThread | kernel32.dll | Cette fonction permet de créer un processus pour exécuter un processus appelant dans un espace d'adressage.
CreateWaitableTimerA | kernel32.dll | Cette fonction permet d'effectuer la création d'une horloge de délai d'attente.
CreateWaitableTimerW | kernel32.dll | Cette fonction permet d'effectuer la création d'une horloge de délai d'attente avec des paramètres de chaine de caractères étendue (Unicode).
CreateWindowExA | user32.dll | Cette fonction permet d'effectuer la création d'une sous-fenêtre (PopUp).
CreateWindowExW | user32.dll | Cette fonction permet d'effectuer la création d'une sous-fenêtre (PopUp) avec des paramètres de chaine de caractères étendues (Unicode).
CreateWindowStationA | user32.dll | Cette fonction permet d'effectuer la création d'un objet de fenêtre de station.
CreateWindowStationW | user32.dll | Cette fonction permet d'effectuer la création d'un objet de fenêtre de station avec des paramètres de chaine de caractères étendues (Unicode).
DdeSetQualityOfService | user32.dll | Cette fonction permet de spécifier le service de qualité (QoS) des applications d'échanges de données dynamique brute (DDE) désiré pour de future initialisation de conversion DDE.
DebugActiveProcess | kernel32.dll | Cette fonction permet d'allouer une débogueur à attaché avec un processus actif
DebugBreak | kernel32.dll | Cette fonction permet de provoqué une exception sur un point d'arrêt dans le processus courant.
DefDlgProcA | user32.dll | Cette fonction permet d'effectuer le traitement de processus de fenêtre de message par défaut.
DefDlgProcW | user32.dll | Cette fonction permet d'effectuer le traitement de processus de fenêtre de message par défaut avec des paramètres de chaine de caractères étendues (Unicode).
DeferWindowPos | user32.dll | Cette fonction permet de mettre à jour la structure de positionnement d'une fenêtre.
DefFrameProcA | user32.dll | Cette fonction permet d'effectuer le processus de message par défaut du cadre d'une fenêtre MDI.
DefFrameProcW | user32.dll | Cette fonction permet d'effectuer le processus de message par défaut du cadre d'une fenêtre MDI avec des paramètres de chaine de caractères étendues (Unicode).
DefineDosDeviceA | kernel32.dll | Cette fonction permet de définir, redéfinir ou supprimer un nom de périphérique DOS.
DefineDosDeviceW | kernel32.dll | Cette fonction permet de définir, redéfinir ou supprimer un nom de périphérique DOS avec des paramètres de chaine de caractères étendue (Unicode).
DefMDIChildProcA | user32.dll | Cette fonction permet de définir le processus de message de la fenêtre enfant MDI.
DefMDIChildProcW | user32.dll | Cette fonction permet de définir le processus de message de la fenêtre enfant MDI avec des paramètres de chaine de caractères étendues (Unicode).
DefWindowProcA | user32.dll | Cette fonction permet de créer un événement produit par défaut lorsqu'une action est effectuer dans la fenêtre.
DefWindowProcW | user32.dll | Cette fonction permet de créer un événement produit par défaut lorsqu'une action est effectué dans la fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
DeleteAce | advapi32.dll | Cette fonction permet d'effacer une entrée de contrôle d'accès (ACE) d'une liste de contrôle d'accès (ACL).
DeleteAtom | kernel32.dll | Cette fonction permet de décrémenter le compteur de référence de chaine de caractères d'Atom local.
DeleteColorSpace | gdi32.dll | Cette fonction permet de supprimer l'espace de couleur spécifié et libérer tous les ressources internes associé avec celui-ci.
DeleteCriticalSection | kernel32.dll | Cette fonction permet de terminer et restituer tous les ressources associé à l'objet de section critique.
DeleteDC | gdi32.dll | Cette fonction permet d'effectuer la suppression d'un périphérique de contexte (DC).
DeleteEnhMetaFile | gdi32.dll | Cette fonction permet de supprimer le format étendue du fichier méta ou le Handle du fichier méta de format étendue.
DeleteFiber | kernel32.dll | Cette fonction permet de supprimer une fibre existante.
DeleteFileA | kernel32.dll | Cette fonction permet de supprimer un fichier existant.
DeleteFileW | kernel32.dll | Cette fonction permet de supprimer un fichier existant avec des paramètres de chaine de caractères étendue (Unicode).
DeleteMenu | user32.dll | Cette fonction permet de supprimer un item de menu.
DeleteMetaFile | gdi32.dll | Cette fonction permet de supprimer un fichier de méta de format Windows ou le Handle d'un fichier méta de format Windows.
DeleteObject | gdi32.dll | Cette fonction permet de supprimer un crayon, une brosse, une police de caractères, un Bitmap ou une palette logique et d'ainsi libérer les ressources systèmes associé avec cette objet.
DeletePrinter | winspool.drv | Cette fonction permet de supprimer un objet d'imprimante.
DeregisterEventSource | advapi32.dll | Cette fonction permet de fermer un identificateur Handle d'enregistrement d'événement retourner par une fonction «RegisterEventSource».
DescribePixelFormat | gdi32.dll | Cette fonction permet de demander les informations à propos du format d'un pixel spécifié d'un périphérique spécifié.
DestroyAcceleratorTable | user32.dll | Cette fonction permet de détruire la table d'accélérateur.
DestroyCaret | user32.dll | Cette fonction permet de supprimer le caret courant.
DestroyCursor | user32.dll | Cette fonction permet de supprimer une image de pointeur de souris
DestroyIcon | user32.dll | Cette fonction permet de supprimer une icône
DestroyMenu | user32.dll | Cette fonction permet de supprimer un menu contextuel
DestroyPrivateObjectSecurity | advapi32.dll | Cette fonction permet d'effacer un descripteur de sécurité d'un objet serveur protégé.
DestroyWindow | user32.dll | Cette fonction permet de supprimer une fenêtre
DeviceCapabilitiesExA | gdi32.dll | Cette fonction permet de demander la compatibilité pour le pilote d'imprimante spécifié.
DeviceCapabilitiesExW | gdi32.dll | Cette fonction permet de demander la compatibilité pour le pilote d'imprimante spécifié avec des paramètres de chaine de caractères étendues (Unicode).
DeviceIoControl | kernel32.dll | Cette fonction permet d'envoyer des codes de contrôles directement à un pilote de périphérique.
DialogBoxIndirectParamA | user32.dll | Cette fonction permet de créer une boite de dialogue modèle à l'aide d'un gabarit en mémoire et des paramètres spécifiés.
DialogBoxIndirectParamW | user32.dll | Cette fonction permet de créer une boite de dialogue modèle à l'aide d'un gabarit en mémoire et des paramètres spécifiés avec des paramètres de chaine de caractères étendues (Unicode).
DialogBoxParamA | user32.dll | Cette fonction permet de créer une boite de dialogue modèle et des paramètres spécifiés.
DialogBoxParamW | user32.dll | Cette fonction permet de créer une boite de dialogue modèle et des paramètres spécifiés avec des paramètres de chaine de caractères étendues (Unicode).
DisableThreadLibraryCalls | kernel32.dll | Cette fonction permet de désactiver les avertissements «DLL_THREAD_ATTACH» et «DLL_THREAD_DETACH» des bibliothèques de lien dynamique (DLL) spécifié.
DisconnectNamedPipe | kernel32.dll | Cette fonction permet de déconnecter le serveur de fin de tuyau nommé pour un processus client.
DiskCopyRunDll | diskcopy.dll | Cette fonction permet de lancer une boite de dialogue offrant la possibilité d'effectuer une copie d'unité de disquette
DispatchMessageA | user32.dll | Cette fonction permet de redistribuer le messages de fenêtre.
DispatchMessageW | user32.dll | Cette fonction permet de redistribuer le messages de fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
DlgDirListA | user32.dll | Cette fonction permet de remplir une boite de dialogue avec une liste de fichiers et de répertoires.
DlgDirListW | user32.dll | Cette fonction permet de remplir une boite de dialogue avec une liste de fichiers et de répertoires avec des paramètres de chaine de caractères étendues (Unicode).
DlgDirListComboBoxA | user32.dll | Cette fonction permet de remplir une boite combinée (Combo Box) avec une liste de fichiers et de répertoires.
DlgDirListComboBoxW | user32.dll | Cette fonction permet de remplir une boite combinée (Combo Box) avec une liste de fichiers et de répertoires avec des paramètres de chaine de caractères étendues (Unicode).
DlgDirSelectComboBoxExA | user32.dll | Cette fonction permet de demander la sélection courante d'une boite combinée remplit par la fonction DlgDirListComboBox.
DlgDirSelectComboBoxExW | user32.dll | Cette fonction permet de demander la sélection courante d'une boite combinée remplit par la fonction DlgDirListComboBox avec des paramètres de chaine de caractères étendues (Unicode).
DlgDirSelectExA | user32.dll | Cette fonction permet de demander la sélection courante étendue d'une liste de boite.
DlgDirSelectExW | user32.dll | Cette fonction permet de demander la sélection courante étendue d'une liste de boite avec des paramètres de chaine de caractères étendues (Unicode).
DllGetVersion | shell32.dll | Cette fonction permet de demander les informations de la version de DLL
DosDateTimeToFileTime | kernel32.dll | Cette fonction permet de convertir la valeur d'une date et d'une heure du DOS en un temps fichier de 64 bits.
DPtoLP | gdi32.dll | Cette fonction permet d'effectuer la conversion des coordonnées d'un périphérique en coordonnées logique.
DragAcceptFiles | shell32.dll | Cette fonction permet de fixer l'état du drapeau indiquant si la fenêtre accepte les fichiers glissées
DragDetect | user32.dll | Cette fonction permet de déterminer quand une fonction de glisser-déposer (drag and drop) est mis en place.
DragObject | user32.dll | Cette fonction permet d'intéger une composante serveur de glisser-déposer (drag and drop).
DragFinish | shell32.dll | Cette fonction permet de restituer la mémoire employé pour le transfert des noms de fichiers vers une fenêtre d'application
DragQueryFile | shell32.dll | Cette fonction permet de demander les noms de fichiers lors d'un transfert des noms de fichiers vers une fenêtre d'application
DrawAnimatedRects | user32.dll | Cette fonction permet de dessiner un cadre de rectangle et d'animer l'icône ouvert.
DrawCaption | user32.dll | Cette fonction permet de dessiner une fenêtre de légende.
DrawEdge | user32.dll | Cette fonction permet de dessiner une ou plusieurs bordures d'un rectangle.
DrawEscape | gdi32.dll | Cette fonction permet d'accéder à la compatibilité de dessinage de l'affichage d'un vidéo n'étant pas directement disponible par le GDI (Graphics Device Interface).
DrawFocusRect | user32.dll | Cette fonction permet de dessiner un rectangle avec un style indiquant qu'il est focusé.
DrawFrameControl | user32.dll | Cette fonction permet de dessiner un cadre de contrôle pour le type et le style spécifié.
DrawIcon | user32.dll | Cette fonction permet d'afficher une icône dans la fenêtre d'application du contexte de l'objet
DrawIconEx | user32.dll | Cette fonction permet d'afficher un icône ou un curseur dans une région client d'une fenêtre d'un périphérique de contexte donnée, d'effectuer des opérations de traitement de trame spécifié et d'étirement ou de compression de l'icône ou le curseur spécifié.
DrawMenuBar | user32.dll | Cette fonction permet de réafficher la barre de menu de la fenêtre d'application.
DrawStateA | user32.dll | Cette fonction permet d'afficher une image et d'appliquer un effet visuel indiquant son état, laquelle peut être désactiver ou un état par défaut.
DrawStateW | user32.dll | Cette fonction permet d'afficher une image et d'appliquer un effet visuel indiquant son état, laquelle peut être désactiver ou un état par défaut avec des paramètres de chaine de caractères étendues (Unicode).
DrawTextA | user32.dll | Cette fonction permet de dessiner le texte formaté dans le rectangle spécifié.
DrawTextW | user32.dll | Cette fonction permet de dessiner le texte formaté dans le rectangle spécifié avec des paramètres de chaine de caractères étendues (Unicode).
DrawTextExA | user32.dll | Cette fonction permet de dessiner le texte formaté dans le rectangle spécifié avec des paramètres supplémentaires.
DrawTextExW | user32.dll | Cette fonction permet de dessiner le texte formaté dans le rectangle spécifié avec des paramètres supplémentaires et des chaines de caractères étendues (Unicode).
DuplicateHandle | kernel32.dll | Cette fonction permet de dupliquer un objet d'identificateur Handle existant.
DuplicateIcon | shell32.dll | Cette fonction permet d'effectuer la création d'un nouvel icône identique à une autre icône spécifié.
DuplicateToken | advapi32.dll | Cette fonction permet de créer un nouvel accès de jeton dupliqué sur un autre jeton déjà existant.
DuplicateTokenEx | advapi32.dll | Cette fonction permet d'effectuer la conversion d'un jeton spécifié par un jeton principal.
DvdLauncher | storprop.dll | Cette fonction permet de vérifier si la région que contient le DVD correspond avec celle du système d'exploitation.
Ellipse | gdi32.dll | Cette fonction permet d'effectuer l'afficher d'une ellipse (forme d'ovale).
EmptyClipboard | user32.dll | Cette fonction permet de vider complètement le tampon du presse-papier.
EnableMenuItem | user32.dll | Cette fonction permet d'activer ou de désactiver un item de menu déroulant.
EnableScrollBar | user32.dll | Cette fonction permet d'activer ou de désactiver les barres de défilement dans une fenêtre d'application.
EnableWindow | user32.dll | Cette fonction permet d'activer ou de désactiver les événements clavier et souris et les contrôles dans une fenêtre d'application.
EndDeferWindowPos | user32.dll | Cette fonction permet d'effectuer la simulation de mise-à-jour de position et de taille d'une ou plusieurs fenêtres dans un simple cycle de rafraichissement d'écran.
EndDialog | user32.dll | Cette fonction permet de cacher un modèle de boite de dialogue.
EndDoc | gdi32.dll | Cette fonction permet d'indiquer que l'application a terminé d'envoyer des données au tampon d'impression de l'imprimante.
EndPage | gdi32.dll | Cette fonction permet d'indiquer que l'application a terminé d'envoyer une page de données au tampon d'impression de l'imprimante.
EndPaint | user32.dll | Cette fonction permet de marquer la fin du traitement de peinture d'une fenêtre spécifié.
EndPath | gdi32.dll | Cette fonction permet de fermer une braquette de chemin et sélectionne le chemin définit par la braquette dans le périphérique de contexte (DC) spécifié.
EndUpdateResourceA | kernel32.dll | Cette fonction permet de terminer la mise-à-jour d'une ressource d'un fichier exécutable.
EndUpdateResourceW | kernel32.dll | Cette fonction permet de terminer la mise-à-jour d'une ressource d'un fichier exécutable avec des paramètres de chaine de caractères étendue (Unicode).
EnterCriticalSection | kernel32.dll | Cette fonction permet d'attendre après un propriétaire d'objet de section critique spécifié.
EnumCalendarInfoA | kernel32.dll | Cette fonction permet d'énumérer des informations de calendrier d'une région local spécifié
EnumCalendarInfoW | kernel32.dll | Cette fonction permet d'énumérer des informations de calendrier d'une région local spécifié avec des paramètres de chaine de caractères étendue (Unicode).
EnumChildWindows | user32.dll | Cette fonction permet d'énumérer les fenêtres enfants de la fenêtre parent en passant le Handle de chaque fenêtre enfant avec une fonction d'application utilisateur.
EnumClipboardFormats | user32.dll | Cette fonction permet de retourner les formats de presse-papier disponibles.
EnumDateFormatsA | kernel32.dll | Cette fonction permet d'énumérer le format de la date courte ou longue disponible pour la région locale.
EnumDateFormatsW | kernel32.dll | Cette fonction permet d'énumérer le format de la date courte ou longue disponible pour la région locale avec des paramètres de chaine de caractères étendue (Unicode).
EnumDesktopsA | user32.dll | Cette fonction permet de demander l'énumération de tous les bureaux d'une fenêtre de travail associé avec un processus appelant.
EnumDesktopsW | user32.dll | Cette fonction permet de demander l'énumération de tous les bureaux d'une fenêtre de travail associé avec un processus appelant avec des paramètres de chaine de caractères étendues (Unicode).
EnumDesktopWindows | user32.dll | Cette fonction permet de demander l'énumération de tous les bureaux passé par le Handle de chaque fenêtre, par l'entremise d'une fonction utilisateur.
EnumDisplaySettingsA | user32.dll | Cette fonction permet de demander des informations sur le système d'affichage.
EnumDisplaySettingsW | user32.dll | Cette fonction permet de demander des informations sur le système d'affichage avec des paramètres de chaine de caractères étendues (Unicode).
EnumEnhMetaFile | gdi32.dll | Cette fonction permet d'énumérer les enregistrements d'un format étendue d'un méta fichier afin de demander chaques enregistrements et de les passés par une fonction utilisateur.
EnumFontFamiliesA | gdi32.dll | Cette fonction permet d'énumérer les polices de caractères d'une famille de police de caractères spécifié étant disponible pour un périphérique spécifié.
EnumFontFamiliesW | gdi32.dll | Cette fonction permet d'énumérer les polices de caractères d'une famille de police de caractères spécifié étant disponible pour un périphérique spécifié avec des paramètres de chaine de caractères étendues (Unicode).
EnumFontFamiliesExA | gdi32.dll | Cette fonction permet d'énumérer toutes les polices de caractères système correspondant aux caractéristiques de polices de caractères spécifié par une structure.
EnumFontFamiliesExW | gdi32.dll | Cette fonction permet d'énumérer toutes les polices de caractères système correspondant aux caractéristiques de polices de caractères spécifié par une structure avec des paramètres de chaine de caractères étendues (Unicode).
EnumFontsA | gdi32.dll | Cette fonction permet d'énumérer les polices de caractères disponibles pour le périphérique spécifié.
EnumFontsW | gdi32.dll | Cette fonction permet d'énumérer les polices de caractères disponibles pour le périphérique spécifié avec des paramètres de chaine de caractères étendues (Unicode).
EnumICMProfilesA | gdi32.dll | Cette fonction permet d'énumérer les différents profiles de couleurs étant supporté par le système pour le périphérique de contexte spécifié.
EnumICMProfilesW | gdi32.dll | Cette fonction permet d'énumérer les différents profiles de couleurs étant supporté par le système pour le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
EnumJobsA | winspool.drv | Cette fonction permet de définir les travaux d'impressions d'une imprimante.
EnumMetaFile | gdi32.dll | Cette fonction permet de demander d'énumérer les enregistrements de fichier méta de format Windows en utilisant une fonction d'application utilisateur.
EnumObjects | gdi32.dll | Cette fonction permet d'énumérer les crayons et les brosses disponibles pour le périphérique de contexte spécifié.
EnumPortsA | winspool.drv | Cette fonction permet de demander les ports d'impressions d'imprimante disponible.
EnumPrintersA | winspool.drv | Cette fonction permet de demander des informations sur une imprimante.
EnumPropsA | user32.dll | Cette fonction permet d'effectuer le passage de la liste des entrées de propriétés par l'intermédiaire d'une fonction utilisateur.
EnumPropsExA | user32.dll | Cette fonction permet d'effectuer le passage de la liste des entrées de propriétés par l'intermédiaire d'une fonction utilisateur avec des paramètres supplémentaires.
EnumPropsExW | user32.dll | Cette fonction permet d'effectuer le passage de la liste des entrées de propriétés par l'intermédiaire d'une fonction utilisateur avec des paramètres supplémentaires et des chaines de caractères étendues (Unicode).
EnumPropsW | user32.dll | Cette fonction permet d'effectuer le passage de la liste des entrées de propriétés par l'intermédiaire d'une fonction utilisateur avec des paramètres de chaine de caractères étendues (Unicode).
EnumResourceLanguagesA | kernel32.dll | Cette fonction permet de rechercher un module pour chaque ressource d'un type spécifié et de passé le langage pour chaque ressource trouvé dans une fonction définie en arrière plan.
EnumResourceLanguagesW | kernel32.dll | Cette fonction permet de rechercher un module pour chaque ressource d'un type spécifié et de passé le langage pour chaque ressource trouvé dans une fonction définie en arrière plan avec des paramètres de chaine de caractères étendue (Unicode).
EnumResourceNamesA | kernel32.dll | Cette fonction permet de rechercher un module pour chaque ressource d'un type spécifié et de passé le langage pour chaque ressource trouvé dans une fonction d'application définie en arrière plan.
EnumResourceNamesW | kernel32.dll | Cette fonction permet de rechercher un module pour chaque ressource d'un type spécifié et de passé le langage pour chaque ressource trouvé dans une fonction d'application définie en arrière plan avec des paramètres de chaine de caractères étendue (Unicode).
EnumResourceTypesA | kernel32.dll | Cette fonction permet de rechercher un module pour une ressource et de passé chaque type de ressource dans une fonction d'application définie en arrière plan.
EnumResourceTypesW | kernel32.dll | Cette fonction permet de rechercher un module pour une ressource et de passé chaque type de ressource dans une fonction d'application définie en arrière plan avec des paramètres de chaine de caractères étendue (Unicode).
EnumSystemCodePagesA | kernel32.dll | Cette fonction permet d'énumérer un code de page installé ou supporté par le système d'exploitation.
EnumSystemCodePagesW | kernel32.dll | Cette fonction permet d'énumérer un code de page installé ou supporté par le système d'exploitation avec des paramètres de chaine de caractères étendue (Unicode).
EnumSystemLocalesA | kernel32.dll | Cette fonction permet d'énumérer la région locale installé ou supporté par le système d'exploitation.
EnumSystemLocalesW | kernel32.dll | Cette fonction permet d'énumérer la région locale installé ou supporté par le système d'exploitation avec des paramètres de chaine de caractères étendue (Unicode).
EnumTimeFormatsA | kernel32.dll | Cette fonction permet d'énumérer le format de temps disponible pour la région locale.
EnumTimeFormatsW | kernel32.dll | Cette fonction permet d'énumérer le format de temps disponible pour la région locale avec des paramètres de chaine de caractères étendue (Unicode).
EnumThreadWindows | user32.dll | Cette fonction permet d'effectuer l'énumération de toutes les fenêtres non-enfant associé avec un processus par passage d'un Handle pour chaque fenêtre avec une fonction d'application utilisateur.
EnumWindowStationsA | user32.dll | Cette fonction permet d'effectuer l'énumération de toutes les fenêtres de station dans le système par passage du nom pour chaque fenêtre de station avec une fonction d'application utilisateur.
EnumWindowStationsW | user32.dll | Cette fonction permet d'effectuer l'énumération de toutes les fenêtres de station dans le système par passage du nom pour chaque fenêtre de station avec une fonction d'application utilisateur et des paramètres de chaine de caractères étendues (Unicode).
EnumWindows | user32.dll | Cette fonction permet d'effectuer le passage des fenêtres parent par l'intermédiaire d'une fonction utilisateur.
EqualPrefixSid | advapi32.dll | Cette fonction permet de vérifie sur les valeurs de deux préfixes SID (identificateur de sécurité) sont égales à l'exception de la dernière valeur de sous-autorité.
EqualRect | user32.dll | Cette fonction permet de demander lequel des deux rectangles spécifiés sont égales par comparaison des coordonnées de leur coin supérieur gauche et de leur coin inférieur droit.
EqualRgn | gdi32.dll | Cette fonction permet de demander lequel des deux régions spécifiés sont égales par comparaison des coordonnées de leur coin supérieur gauche et de leur coin inférieur droit.
EqualSid | advapi32.dll | Cette fonction permet de vérifie sur les valeurs de deux préfixes SID (identificateur de sécurité) sont égales.
EraseTape | kernel32.dll | Cette fonction permet de tout supprimer ou supprimer des parties de bande magnétique de sauvegarde.
Escape | gdi32.dll | Cette fonction permet d'activer les applications de compatibilité d'accès d'un périphérique particulier non accessible directement par le GDI.
EscapeCommFunction | kernel32.dll | Cette fonction permet d'effectuer directement une communication d'un périphérique spécifié à une fonction étendue.
ExcludeClipRect | gdi32.dll | Cette fonction permet de créer une nouvelle région de Clip consistant en une minuscule région existante du rectangle spécifié.
ExcludeUpdateRgn | user32.dll | Cette fonction permet d'exclure la région mise-à-jour d'une région de capture.
ExitProcess | kernel32.dll | Cette fonction permet de terminer un processus et tous ses processus légers.
ExitThread | kernel32.dll | Cette fonction permet de terminer un processus léger.
ExitWindowsEx | user32.dll | Cette fonction permet d'effectuer l'arrêt ou le redémarrage de Windows et/ou de l'ordinateur.
ExpandEnvironmentStringsA | kernel32.dll | Cette fonction permet d'étendre une chaine de caractères de variable d'environnement et de remplacer leurs valeurs par celle correspondante.
ExpandEnvironmentStringsW | kernel32.dll | Cette fonction permet d'étendre une chaine de caractères de variable d'environnement et de remplacer leurs valeurs par celle correspondante avec des paramètres de chaine de caractères étendue (Unicode).
ExtCreatePen | gdi32.dll | Cette focntion permet de créer un crayon cosmétique ou géométrique logique ayant les attributs de style, de largeur et brosses spécifiés.
ExtCreateRegion | gdi32.dll | Cette fonction permet de créer une région avec la région et la transformation de données spécifié.
ExtEscape | gdi32.dll | Cette fonction permet d'allouer les applications vers une capacité d'accès d'un périphérique particulier n'étant pas disponible pour le GDI.
ExtFloodFill | gdi32.dll | Cette fonction permet de remplir une région d'une surface d'affichage avec la brosse courante.
ExtractAssociatedIconA | shell32.dll | Cette fonction permet de demander le Handle dans icône indexé dans un fichier.
ExtractIconA | shell32.dll | Cette fonction permet de demander une unique icône dans un fichier.
ExtractIconExA | shell32.dll | Cette fonction permet de demander plusieurs icônes dans un fichier.
ExtSelectClipRgn | gdi32.dll | Cette fonction permet de combiner la région spécifié avec la région de capture courante en utilisant le mode spécifié.
ExtTextOutA | gdi32.dll | Cette fonction permet de dessiner une chaine de caractères en utilisant la police de caractères courante.
ExtTextOutW | gdi32.dll | Cette fonction permet de dessiner une chaine de caractères en utilisant la police de caractères courante avec des paramètres de chaines de caractères étendues (Unicode).
FatalAppExitA | kernel32.dll | Cette fonction permet d'afficher la boite de dialogue d'erreur fatal amenant la terminaison anormale du programme.
FatalAppExitW | kernel32.dll | Cette fonction permet d'afficher la boite de dialogue d'erreur fatal amenant la terminaison anormale du programme avec des paramètres de chaine de caractères étendue (Unicode).
FatalExit | kernel32.dll | Cette fonction permet de transférer le contrôle d'exécution au débogueur.
FileTimeToDosDateTime | kernel32.dll | Cette fonction permet de convertir un temps de fichier 64 bits en des valeurs de date et temps.
FileTimeToLocalFileTime | kernel32.dll | Cette fonction permet d'effectuer la conversion du temps d'un fichier de format UTC (Coordonnée de Temps Universelle) en format de temps local.
FileTimeToSystemTime | kernel32.dll | Cette fonction permet de convertir un temps fichier de 64 bits à un temps de format système.
FillConsoleOutputAttribute | kernel32.dll | Cette fonction permet de fixer la couleur de texte et d'arrière plan pour un nombre spécifié de caractères en commençant au coordonnées du tampon d'écran spécifié.
FillConsoleOutputCharacterA | kernel32.dll | Cette fonction permet d'écrire un caractère dans le tampon d'écran un certain nombre de fois en commençant au coordonnées du tampon d'écran spécifié.
FillConsoleOutputCharacterW | kernel32.dll | Cette fonction permet d'écrire un caractère dans le tampon d'écran un certain nombre de fois en commençant au coordonnées du tampon d'écran spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FillPath | gdi32.dll | Cette fonction permet de fermer n'importe quel figures ouvertes dans le chemin courant et remplis l'intérieur du chemin en utilisant la brosses courante et le mode de remplissage de polygone.
FillRect | user32.dll | Cette fonction permet de remplir un rectangle avec la brosse spécifié.
FillRgn | gdi32.dll | Cette fonction permet de remplir la région avec le brosse spécifié.
FindAtomA | kernel32.dll | Cette fonction permet de rechercher dans un table d'Atom local la chaine de caractères spécifié et demande l'Atom associé avec cette chaine de caractères.
FindAtomW | kernel32.dll | Cette fonction permet de rechercher dans un table d'Atom local la chaine de caractères spécifié et demande l'Atom associé avec cette chaine de caractères avec des paramètres de chaine de caractères étendue (Unicode).
FindClose | kernel32.dll | Cette fonction permet d'indiquer que la recherche des fichiers et réperoires que contient un répertoire est terminé.
FindCloseChangeNotification | kernel32.dll | Cette fonction permet d'indiquer que la recherche et modifications des fichiers et répertoires que contient un répertoire est terminé.
FindExecutableA | shell32.dll | Cette fonction permet de demander le fichier devant être exécuté lorsque la sorte d'extension de fichier est rencontré.
FindFirstChangeNotificationA | kernel32.dll | Cette fonction permet de créer un identificateur Handle d'avertissement de changement et fixe la condition d'avertissement de changement initial.
FindFirstChangeNotificationW | kernel32.dll | Cette fonction permet de créer un identificateur Handle d'avertissement de changement et fixe la condition d'avertissement de changement initial avec des paramètres de chaine de caractères étendue (Unicode).
FindFirstChangeNotification | kernel32.dll | Cette fonction permet de spécifier une recherche et modifications des fichiers et répertoires que contient un répertoire.
FindFirstFileA | kernel32.dll | Cette fonction permet de spécifier une recherche des fichiers et répertoires que contient un répertoire.
FindFirstFileExA | kernel32.dll | Cette fonction permet de rechercher dans un répertoire un fichier ou un sous-répertoire avec une correspondance de nom et d'attribut spécifié.
FindFirstFileExW | kernel32.dll | Cette fonction permet de rechercher dans un répertoire un fichier ou un sous-répertoire avec une correspondance de nom et d'attribut spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FindFirstFileW | kernel32.dll | Cette fonction permet de spécifier une recherche des fichiers et répertoires que contient un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
FindFirstFreeAce | advapi32.dll | Cette fonction permet de retourner un pointeur sur le premier octet de libre sur une liste de contrôle d'accès (ACL).
FindNextChangeNotification | kernel32.dll | Cette fonction permet demander l'entrée suivant lors de la recherche et modifications des fichiers et répertoire que contient un répertoire.
FindNextFileA | kernel32.dll | Cette fonction permet demander l'entrée suivante lors de la recherche des fichiers et répertoires que contient un répertoire.
FindNextFileW | kernel32.dll | Cette fonction permet demander l'entrée suivante lors de la recherche des fichiers et répertoire que contient un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
FindResourceA | kernel32.dll | Cette fonction permet de demander l'emplacement d'une ressource avec un nom et un type spécifié dans un module spécifié.
FindResourceW | kernel32.dll | Cette fonction permet de demander l'emplacement d'une ressource avec un nom et un type spécifié dans un module spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FindResourceExA | kernel32.dll | Cette fonction permet de demander l'emplacement d'une ressource avec un type, un nom et une langue spécifié dans un module spécifié.
FindResourceExW | kernel32.dll | Cette fonction permet de demander l'emplacement d'une ressource avec un type, un nom et une langue spécifié dans un module spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FindWindowA | user32.dll | Cette fonction permet de demander le Handle de la première fenêtre d'application correspondant au nom de la fenêtre.
FindWindowExA | user32.dll | Cette fonction permet de demander le Handle d'une fenêtre enfant d'une fenêtre d'application.
FindWindowW | user32.dll | Cette fonction permet de demander le Handle de la première fenêtre d'application correspondant au nom de la fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
FlashWindow | user32.dll | Cette fonction permet de faire clignoter une fois une fenêtre d'application.
FlashWindowEx | user32.dll | Cette fonction permet de faire clignoter plusieurs fois une fenêtre d'application.
FlattenPath | gdi32.dll | Cette fonction permet de transformer n'importe quel courbe d'un chemin étant sélectionné dans le périphérique de contexte courant de façon à tourner chaque courbe une séquences de lignes.
FloodFill | gdi32.dll | Cette fonction permet d'effectuer le remplissage d'une région de la surface de l'écran en utilisant la brosse courante.
FlushConsoleInputBuffer | kernel32.dll | Cette fonction permet de vider le tampon d'entrée de la console.
FlushFileBuffers | kernel32.dll | Cette fonction permet d'effacer le tampon pour le fichier spécifié et provoquer l'écriture des données dans le fichier.
FlushInstructionCache | kernel32.dll | Cette fonction permet de vider les instructions en cache pour le processus spécifié.
FlushViewOfFile | kernel32.dll | Cette fonction permet d'écrire sur le disque un rang d'octets dans une vue d'un fichier.
FoldStringA | kernel32.dll | Cette fonction permet de cartographier une chaine de caractères vers une autre en effectuant les options de transformations spécifié.
FoldStringW | kernel32.dll | Cette fonction permet de cartographier une chaine de caractères vers une autre en effectuant les options de transformations spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FormatMessageA | kernel32.dll | Cette fonction permet de demander un message affecté par un certain format.
FormatMessageW | kernel32.dll | Cette fonction permet de demander le dernier message d'erreur contenu dans le fichier d'erreur système.
FrameRect | user32.dll | Cette fonction permet de dessiner une bordure autour d'un rectangle, en utilisant la brosse spécifié.
FrameRgn | gdi32.dll | Cette fonction permet de dessiner une bordure entourant une région spécifié et en utilisant la brosse spécifié.
FreeConsole | kernel32.dll | Cette fonction permet de libérer une console existante.
FreeDDElParam | user32.dll | Cette fonction permet de libérer la mémoire spécifié d'un message DDE posté.
FreeEnvironmentStringsA | kernel32.dll | Cette fonction permet de libérer un bloc de chaine de caractères d'environnement.
FreeEnvironmentStringsW | kernel32.dll | Cette fonction permet de libérer un bloc de chaine de caractères d'environnement avec des paramètres de chaine de caractères étendue (Unicode).
FreeLibrary | kernel32.dll | Cette fonction permet d'incrémenter un compteur de référence pour un chargement de module de lien dynamique (DLL).
FreeLibraryAndExitThread | kernel32.dll | Cette fonction permet de décrémenté le compteur de référence d'une des bibliothèque de liens dynamique (DLL) et appel alors la fonction «ExitThread».
FreeResource | kernel32.dll | Cette fonction permet de libérer une ressource.
FreeSid | advapi32.dll | Cette fonction permet de libérer un identificateur de sécurité (SID) précédemment alloué par la fonction «AllocateAndInitializeSid».
FtpCreateDirectoryA | wininet.dll | Cette fonction permet d'effectuer la création d'un répertoire sur un protocole FTP.
FtpOpenFileA | wininet.dll | Cette fonction permet d'ouvrir un fichier avec une chaine de caractères ASCIZ sur un protocole FTP.
FtpOpenFileW | wininet.dll | Cette fonction permet d'ouvrir un fichier avec une chaine de caractères étendue (Unicode) sur un protocole FTP.
GdiComment | gdi32.dll | Cette fonction permet de copier un commentaire d'un tampon vers un méta fichier spécifié de format étendue.
GdiFlush | gdi32.dll | Cette fonction permet de vider le traitement en lot courant du processus appelant.
GdiGetBatchLimit | gdi32.dll | Cette fonction permet de retourner le nombre maximum d'appels de fonction étant accumulé dans le traitement par lot courant du processus léger courant.
GdiSetBatchLimit | gdi32.dll | Cette fonction permet de fixer le nombre maximum d'appels de fonction étant accumulé dans le traitement par lot courant du processus léger courant.
GenerateConsoleCtrlEvent | kernel32.dll | Cette fonction permet d'envoyer un signal spécifique à un groupe de processus de console.
GetAce | advapi32.dll | Cette fonction permet de demander un pointeur sur une structure d'une entrée de contrôle d'accès (ACE) d'une liste de contrôle d'accès (ACL).
GetAclInformation | advapi32.dll | Cette fonction permet de demander les informations concernant une liste de contrôle d'accès (ACL).
GetACP | kernel32.dll | Cette fonction permet de demander l'identificateur de code de page ANSI courant pour le système d'exploitation.
GetActiveWindow | user32.dll | Cette fonction permet de demander le Handle de la fenêtre active.
GetArcDirection | gdi32.dll | Cette fonction permet de demander la direction de l'arc courant pour le périphérique de contexte spécifié.
GetAspectRatioFilterEx | gdi32.dll | Cette fonction permet de demander l'ajustement de filtre d'aspect ratio courant.
GetAsyncKeyState | user32.dll | Cette fonction permet de retourner l'état de la touche spécifié.
GetAtomNameA | kernel32.dll | Cette fonction permet de demander une copie de chaine de caractères associé avec un Atom local spécifié.
GetAtomNameW | kernel32.dll | Cette fonction permet de demander une copie de chaine de caractères associé avec un Atom local spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetBinaryTypeA | kernel32.dll | Cette fonction permet de demander si le fichier est exécutable, et s'il l'est, quel type de fichier exécutable s'agit-il.
GetBinaryTypeW | kernel32.dll | Cette fonction permet de demander si le fichier est exécutable, et s'il l'est, quel type de fichier exécutable s'agit-il avec des paramètres de chaine de caractères étendue (Unicode).
GetBitmapBits | gdi32.dll | Cette fonction permet de copier les bits du Bitmap spécifié dans un tampon.
GetBitmapDimensionEx | gdi32.dll | Cette fonction permet de demander les dimensions d'un Bitmap.
GetBkColor | gdi32.dll | Cette fonction permet de retourner la couleur d'arrière-plan courante.
GetBkMode | gdi32.dll | Cette fonction permet de demander le mode mixte d'arrière-plan pour le contexte de périphérique spécifié.
GetBoundsRect | gdi32.dll | Cette fonction permet de retourner l'accumulation d'informations de limite rectangulaire d'un périphérique de contexte.
GetBrushOrgEx | gdi32.dll | Cette fonction permet de demander l'origine de la brosse courante dans un périphérique de contexte courant.
GetCapture | user32.dll | Cette fonction permet de demander le Handle de la fenêtre où la souris est capturé.
GetCaretBlinkTime | user32.dll | Cette fonction permet de demander le taux de clignotement du caret.
GetCaretPos | user32.dll | Cette fonction permet de demander la position courante d'un caret.
GetCharABCWidthsA | gdi32.dll | Cette fonction permet de demander la largeur, dans son unité de mesure logique, de caractères consécutifs dans une rangée données d'une police de caractères TrueType courant.
GetCharABCWidthsW | gdi32.dll | Cette fonction permet de demander la largeur, dans son unité de mesure logique, de caractères consécutifs dans une rangée données d'une police de caractères TrueType courant avec des paramètres de chaines de caractères étendues (Unicode).
GetCharABCWidthsFloatA | gdi32.dll | Cette fonction permet de demander la largeur, dans son unité de mesure logique, de caractères consécutifs dans une rangée données d'une police de caractères courant.
GetCharABCWidthsFloatW | gdi32.dll | Cette fonction permet de demander la largeur, dans son unité de mesure logique, de caractères consécutifs dans une rangée données d'une police de caractères courant avec des paramètres de chaine de caractères étendues (Unicode).
GetCharWidth32A | gdi32.dll | Cette fonction permet demander la largeur, dans des coordonnées logiques, de caractères consécutifs dans une rangée spécifié d'une police de caractères courante.
GetCharWidth32W | gdi32.dll | Cette fonction permet demander la largeur, dans des coordonnées logiques, de caractères consécutifs dans une rangée spécifié d'une police de caractères courante avec des paramètres de chaine de caractères étendues (Unicode).
GetCharWidthA | gdi32.dll | Cette fonction permet demander la largeur, dans des coordonnées logiques, de caractères consécutifs dans une rangée spécifié d'une police de caractères courante dans un contexte de compatibilité avec les fonctions 16 bits.
GetCharWidthW | gdi32.dll | Cette fonction permet demander la largeur, dans des coordonnées logiques, de caractères consécutifs dans une rangée spécifié d'une police de caractères courante dans un contexte de compatibilité avec les fonctions 16 bits avec des paramètres de chaine de caractères étendues (Unicode).
GetCharWidthFloatA | gdi32.dll | Cette fonction permet de demander la largeur fractionné de caractères consécutifs dans une rangée spécifié de la police de caractères courante.
GetCharWidthFloatW | gdi32.dll | Cette fonction permet de demander la largeur fractionné de caractères consécutifs dans une rangée spécifié de la police de caractères courante avec des paramètres de chaine de caractères étendues (Unicode).
GetCharacterPlacementA | gdi32.dll | Cette fonction permet de demander les informations à propos d'une chaine de caractères, comme la largeur des caractères, le positionnement des carets, l'ordre dans la chaine de caractères et la rendue du glyphe.
GetCharacterPlacementW | gdi32.dll | Cette fonction permet de demander les informations à propos d'une chaine de caractères, comme la largeur des caractères, le positionnement des carets, l'ordre dans la chaine de caractères et la rendue du glyphe avec des paramètres de chaine de caractères étendues (Unicode).
GetClassInfoA | user32.dll | Cette fonction permet de demander les informations à propos d'une classe de fenêtre.
GetClassInfoExA | user32.dll | Cette fonction permet de demander les informations à propos d'une classe de fenêtre en incluant le Handle du petit icône associé avec la fenêtre de classe.
GetClassInfoExW | user32.dll | Cette fonction permet de demander les informations à propos d'une classe de fenêtre en incluant le Handle du petit icône associé avec la fenêtre de classe avec des paramètres de chaine de caractères étendues (Unicode).
GetClassInfoW | user32.dll | Cette fonction permet de demander les informations à propos d'une classe de fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
GetClassLongA | user32.dll | Cette fonction permet de demander des valeurs d'informations en 32 bits sur une classe.
GetClassLongW | user32.dll | Cette fonction permet de demander des valeurs d'informations en 32 bits sur une classe avec des paramètres de chaine de caractères étendues (Unicode).
GetClassNameA | user32.dll | Cette fonction permet de demander le nom d'une classe.
GetClassNameW | user32.dll | Cette fonction permet de demander le nom d'une classe avec des paramètres de chaine de caractères étendues (Unicode).
GetClassWord | user32.dll | Cette fonction permet de demander une valeur 16 bits de déplacement spécifié dans une classe de mémoire supplémentaire pour la classe de fenêtre à laquelle la fenêtre appartient.
GetClientRect | user32.dll | Cette fonction permet de demander les coordonnées client de la région de fenêtre client.
GetClipboardData | user32.dll | Cette fonction permet de demander le Handle du presse-papier de données courant avec le format spécifié.
GetClipboardFormatNameA | user32.dll | Cette fonction permet de demander le nom de format de presse-papier enregistré.
GetClipboardFormatNameW | user32.dll | Cette fonction permet de demander le nom de format de presse-papier enregistré avec des paramètres de chaine de caractères étendues (Unicode).
GetClipboardOwner | user32.dll | Cette fonction permet de demander le Handle de la fenêtre associé à un presse-papier.
GetClipboardViewer | user32.dll | Cette fonction permet de demander le Handle de la première fenêtre d'une chaine visualisation de presse-papier.
GetClipBox | gdi32.dll | Cette fonction permet de demander les dimensions d'un petit rectangle complètement contenu dans la région de clip courant.
GetClipCursor | user32.dll | Cette fonction permet de demander les coordonnées de la fenêtre limitant le déplacement du pointeur de la souris.
GetClipRgn | gdi32.dll | Cette fonction permet de demander le Handle d'une région de clip affecté par un périphérique de contexte spécifié.
GetColorAdjustment | gdi32.dll | Cette fonction permet de demander les valeurs de couleurs d'ajustement pour le contexte de périphérique spécifié.
GetColorSpace | gdi32.dll | Cette fonction permet de demander le Handle courant de l'espace de couleur logique du périphérique de contexte spécifié.
GetCommandLineA | kernel32.dll | Cette fonction permet de retourner la ligne de commande de l'application courante.
GetCommandLineW | kernel32.dll | Cette fonction permet de retourner la ligne de commande de l'application courante avec des paramètres de chaine de caractères étendue (Unicode).
GetCommConfig | kernel32.dll | Cette fonction permet de demander la configuration courante pour un périphérique de communication.
GetCommMask | kernel32.dll | Cette fonction permet de demander la valeur d'un masque d'événement pour un périphérique de communication spécifié.
GetCommModemStatus | kernel32.dll | Cette fonction permet de demander les valeurs du registre de contrôle du modem.
GetCommProperties | kernel32.dll | Cette fonction permet de remplir le tampon avec des informations concernant les propriétés de communications pour un périphérique de communication spécifié.
GetCommState | kernel32.dll | Cette fonction permet de remplir un bloc de contrôle de périphérique (une structure DCB) avec les ajustements de contrôle courant pour un périphérique de communication spécifié.
GetCommTimeouts | kernel32.dll | Cette fonction permet de demander les paramètres de dépassement de délai pour toutes les opérations de lecture ou d'écriture pour un périphérique de communication spécifié.
GetCompressedFileSizeA | kernel32.dll | Cette fonction permet de demander le nombre d'octets d'une unité d'entreposage actuellement utilisé pour un fichier spécifié.
GetCompressedFileSizeW | kernel32.dll | Cette fonction permet de demander le nombre d'octets d'une unité d'entreposage actuellement utilisé pour un fichier spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetComputerNameA | kernel32.dll | Cette fonction permet de demander le nom de l'ordinateur sous forme d'une chaine de caractères ASCIZ.
GetComputerNameW | kernel32.dll | Cette fonction permet de demander le nom de l'ordinateur sous forme d'une chaine de caractères ASCIZ avec des paramètres de chaine de caractères étendue (Unicode).
GetComputerNameExA | kernel32.dll | Cette fonction permet de retourner la nom NetBIOS ou DNS de l'ordinateur local.
GetComputerObjectNameA | secur32.dll | Cette fonction permet de retourner le nom de l'ordinateur dans un format spécifié.
GetConsoleCursorInfo | kernel32.dll | Cette fonction permet de demander des informations à propos de la taille et de la visibilité du curseur pour le tampon de console écran spécifié.
GetConsoleCP | kernel32.dll | Cette fonction permet de demander l'identité de code de page utilisé pour la console associé avec le processus appelant.
GetConsoleMode | kernel32.dll | Cette fonction permet de demander le mode d'entrée courant pour le tampon d'entrée de la console ou le mode de sortie courant pour le tampon d'écran de la console.
GetConsoleOutputCP | kernel32.dll | Cette fonction permet de retourner l'identité de code de page de sortie utilisé par la console associé avec le processus appelant.
GetConsoleScreenBufferInfo | kernel32.dll | Cette fonction permet de demander les informations à propos du tampon d'écran de la console spécifié.
GetConsoleTitleA | kernel32.dll | Cette fonction permet de retourner le nom de la console courante.
GetConsoleTitleW | kernel32.dll | Cette fonction permet de retourner le nom de la console courante avec des paramètres de chaine de caractères étendue (Unicode).
GetCPInfo | kernel32.dll | Cette fonction permet de retourner des informations sur le code de page spécifié.
GetCurrencyFormatA | kernel32.dll | Cette fonction permet de demander la chaine de caractères du format d'un nombre avec une chaine de caractères de monnaie pour une localité spécifié.
GetCurrencyFormatW | kernel32.dll | Cette fonction permet de demander la chaine de caractères du format d'un nombre avec une chaine de caractères de monnaie pour une localité spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetCurrentDirectoryA | kernel32.dll | Cette fonction permet de demander le répertoire courant du processus courant.
GetCurrentDirectoryW | kernel32.dll | Cette fonction permet de demander le répertoire courant du processus courant avec des paramètres de chaine de caractères étendue (Unicode).
GetCurrentHwProfileA | advapi32.dll | Cette fonction pemret de demander le profile matériel courant.
GetCurrentHwProfileW | advapi32.dll | Cette fonction pemret de demander le profile matériel courant avec des paramètres de chaine de caractères étendue (Unicode).
GetCurrentObject | gdi32.dll | Cette fonction permet de retourner l'objet sélectionné courant du type spécifié.
GetCurrentPositionEx | gdi32.dll | Cette fonction permet de demander la position courante dans des coordonnées logiques.
GetCurrentProcess | kernel32.dll | Cette fonction permet de retourner le Handle du processus courant.
GetCurrentProcessId | kernel32.dll | Cette fonction permet de demander l'identificateur de processus courant
GetCurrentProcessorNumber | kernel32.dll | Cette fonction permet de demander le nombre de processeur du processus courant lors de l'appel d'une fonction
GetCurrentThread | kernel32.dll | Cette fonction permet de retourner le Handle du processus courant.
GetCurrentThreadId | kernel32.dll | Cette fonction permet de retourner l'identificateur du processus courant.
GetCursor | user32.dll | Cette fonction permet de demander le Handle du curseur courant.
GetCursorPos | user32.dll | Cette fonction permet de demander la position du pointeur de souris à l'écran
GetDateFormatA | kernel32.dll | Cette fonction permet de demander le date dans une chaine de caractères ASCIZ selon le format spécifié.
GetDateFormatW | kernel32.dll | Cette fonction permet de demander la date dans une chaine de caractères ASCIZ selon le format spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetDC | user32.dll | Cette fonction permet de demander le contexte d'objet d'une fenêtre d'application.
GetDCEx | user32.dll | Cette fonction permet de demander le Handle du périphérique de contexte pour la fenêtre spécifié.
GetDCOrgEx | gdi32.dll | Cette fonction permet de demander l'origine de translation final d'un périphérique de contexte spécifié.
GetDefaultCommConfigA | kernel32.dll | Cette fonction permet de demander la configuration par défaut d'un périphérique de communication.
GetDefaultCommConfigW | kernel32.dll | Cette fonction permet de demander la configuration par défaut d'un périphérique de communication avec des paramètres de chaine de caractères étendue (Unicode).
GetDesktopWindow | user32.dll | Cette fonction permet de demander le Handle attribué à la fenêtre du bureau.
GetDeviceCaps | gdi32.dll | Cette fonction permet de demander les informations d'un périphérique spécifié à propos du périphérique d'affichage.
GetDeviceGammaRamp | gdi32.dll | Cette fonction permet de demander la rampe gamma d'un panneau d'affichage de couleur directe.
GetDialogBaseUnits | user32.dll | Cette fonction permet de retourner l'unité de base de la boite de dialogue qu'utilise Windows quand il créer une boite de dialogue.
GetDIBColorTable | gdi32.dll | Cette fonction permet de demander les valeurs de couleurs RVB (rouge, vert, bleu) d'une rangée d'entrées d'une table de couleurs d'une section DIB Bitmap étant actuellement sélectionné dans un périphérique de contexte spécifié.
GetDIBits | gdi32.dll | Cette fonction permet de demander les bits d'un Bitmap compatible et copie celui-ci dans un tampon DIB en utilisant le format spécifié.
GetDiskFreeSpaceA | kernel32.dll | Cette fonction permet de demander l'espace de libre sur une unité disque.
GetDiskFreeSpaceExA | kernel32.dll | Cette fonction permet de demander des informations global sur l'espace de libre sur une unité disque.
GetDiskFreeSpaceExW | kernel32.dll | Cette fonction permet de demander des informations global sur l'espace de libre sur une unité disque avec des paramètres de chaine de caractères étendue (Unicode).
GetDiskFreeSpaceW | kernel32.dll | Cette fonction permet de demander l'espace de libre sur une unité disque avec des paramètres de chaine de caractères étendue (Unicode).
GetDlgCtrlID | user32.dll | Cette fonction permet de retourner le Handle de la fenêtre enfant.
GetDlgItem | user32.dll | Cette fonction permet de demander le Handle d'un contrôle étant données par la boite de dialogue.
GetDlgItemInt | user32.dll | Cette fonction permet d'effectuer la translation du texte d'un contrôle d'une boite de dialogue en une valeur entière.
GetDlgItemTextA | user32.dll | Cette fonction permet de demander le titre ou le texte associé avec un contrôle de boite de dialogue.
GetDlgItemTextW | user32.dll | Cette fonction permet de demander le titre ou le texte associé avec un contrôle de boite de dialogue avec des paramètres de chaine de caractères étendues (Unicode).
GetDoubleClickTime | user32.dll | Cette fonction permet de demander le temps maximal autorisé pour que des clics sur les boutons de la souris soit considéré comme un double-clic.
GetDriveTypeA | kernel32.dll | Cette fonction permet de demander le type d'unité disque.
GetDriveTypeW | kernel32.dll | Cette fonction permet de demander le type d'unité disque avec des paramètres de chaine de caractères étendue (Unicode).
GetEnhMetaFileA | gdi32.dll | Cette fonction permet de créer un Handle étant identifié par un fichier méta de format étendue entreposé dans le fichier spécifié.
GetEnhMetaFileW | gdi32.dll | Cette fonction permet de créer un Handle étant identifié par un fichier méta de format étendue entreposé dans le fichier spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetEnhMetaFileBits | gdi32.dll | Cette fonction permet de demander le contenu d'un fichier méta spécifié de format étendue et le copie dans un tampon.
GetEnhMetaFileDescriptionA | gdi32.dll | Cette fonction permet de demander une description texte optionnel d'un fichier méta de format étendue et copie la chaine de caractères dans un tampon spécifié.
GetEnhMetaFileDescriptionW | gdi32.dll | Cette fonction permet de demander une description texte optionnel d'un fichier méta de format étendue et copie la chaine de caractères dans un tampon spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetEnhMetaFileHeader | gdi32.dll | Cette fonction permet de demander l'enregistrement contenu dans l'entête du fichier méta spécifié de format étendue.
GetEnhMetaFilePaletteEntries | gdi32.dll | Cette fonction permet de demander les entrées de palette optionnel pour le fichier méta étendue spécifié.
GetEnhMetaFilePixelFormat | gdi32.dll | Cette fonction permet de demander les informations de format de pixel pour un fichier méta étendue.
GetEnvironmentStringsA | kernel32.dll | Cette fonction permet de demander les variables d'environnements du processus courant.
GetEnvironmentStringsW | kernel32.dll | Cette fonction permet de demander les variables d'environnements du processus courant avec des paramètres de chaine de caractères étendue (Unicode).
GetEnvironmentVariableA | kernel32.dll | Cette fonction permet de demander la valeur d'une variable d'environnement du système d'exploitation.
GetEnvironmentVariableW | kernel32.dll | Cette fonction permet de demander la valeur d'une variable d'environnement du système d'exploitation avec des paramètres de chaine de caractères étendue (Unicode).
GetExitCodeProcess | kernel32.dll | Cette fonction permet de demander le code d'état de terminaison d'un processus spécifié.
GetExitCodeThread | kernel32.dll | Cette fonction permet de demander le code d'état de terminaison d'un processus léger (Thread) spécifié.
GetFileAttributesA | kernel32.dll | Cette fonction permet de demander les attributs d'un fichier ou d'un répertoire.
GetFileAttributesExA | kernel32.dll | Cette fonction permet de demander les informations étendues d'attributs d'un fichier ou d'un répertoire.
GetFileAttributesExW | kernel32.dll | Cette fonction permet de demander les informations étendues d'attributs d'un fichier ou d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
GetFileAttributesW | kernel32.dll | Cette fonction permet de demander les attributs d'un fichier ou d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
GetFileInformationByHandle | kernel32.dll | Cette fonction permet de demander les informations associé au fichier spécifié.
GetFileSecurityA | advapi32.dll | Cette fonction permet de demander les informations spécifié sur la sécurité d'un fichier ou d'un répertoire.
GetFileSecurityW | advapi32.dll | Cette fonction permet de demander les informations spécifié sur la sécurité d'un fichier ou d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
GetFileSize | kernel32.dll | Cette fonction permet de demander la taille, en octets, d'un fichier spécifié.
GetFileTime | kernel32.dll | Cette fonction permet de demander la date et l'heure d'un fichier de sa création, de sa dernière modification ou de son dernière accès.
GetFileType | kernel32.dll | Cette fonction permet de retourner le type d'un fichier spécifié.
GetFileVersionInfoSizeA | version.dll | Cette fonction permet de demander la taille de l'entête d'information de version du fichier spécifié.
GetFocus | user32.dll | Cette fonction permet de demander le focus d'entrée de la fenêtre spécifié.
GetFontData | gdi32.dll | Cette fonction permet de demander les données de police de caractères métriques pour une police de caractères TrueType.
GetFontLanguageInfo | gdi32.dll | Cette fonction permet de retourner les informations à propos de sélection de police de caractères courante dans l'affichage de contexte spécifié.
GetForegroundWindow | user32.dll | Cette fonction permet de demander le Handle de la fenêtre d'application courante.
GetFullPathNameA | kernel32.dll | Cette fonction permet de demander le chemin et le nom de fichier complet pour un fichier spécifié.
GetFullPathNameW | kernel32.dll | Cette fonction permet de demander le chemin et le nom de fichier complet pour un fichier spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetGlyphOutlineA | gdi32.dll | Cette fonction permet de demander ligne de limite ou du Bitmap d'un caractère d'une police de caractères TrueType étant sélectionné dans le périphérique de contexte spécifié.
GetGlyphOutlineW | gdi32.dll | Cette fonction permet de demander ligne de limite ou du Bitmap d'un caractère d'une police de caractères TrueType étant sélectionné dans le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetGraphicsMode | gdi32.dll | Cette fonction permet de demander le mode graphique courant pour le périphérique de contexte courant.
GetGuiResources | kernel32.dll | Cette fonction permet de demander le nombre d'identificateur de GUI (Interface graphique utilisateur) du processus courant.
GetHandleInformation | kernel32.dll | Cette fonction permet de demander les informations conçernant certaines propriétés d'un objet avec un identificateur Handle.
GetICMProfileA | gdi32.dll | Cette fonction permet de demander le nom du fichier de profile de couleurs pour le périphérique associé avec le périphérique de contexte spécifié.
GetICMProfileW | gdi32.dll | Cette fonction permet de demander le nom du fichier de profile de couleurs pour le périphérique associé avec le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetIconInfo | user32.dll | Cette fonction permet de demander les informations à propos de l'icône ou du curseur spécifié.
GetInputState | user32.dll | Cette fonction permet d'indiquer si un événement de clic de souris ou de clavier est survenue dans la file d'attente du système du traitement requis.
GetIpStatistics | iphlpapi.dll | Cette fonction permet de demander les informations de statistique sur le IP de l'ordinateur.
GetJobA | winspool.drv | Cette fonction permet de demander les données d'un travail contenu dans le tampon d'impressions de l'imprimante.
GetKBCodePage | user32.dll | Cette fonction retourne le code de page chargé par le système d'exploitation Windows.
GetKernelObjectSecurity | advapi32.dll | Cette fonction permet de demander une copie du descripteur de sécurité protégé d'un objet du noyau du système d'exploitation.
GetKerningPairs | gdi32.dll | Cette fonction permet de demander les paires de crénages de caractères pour la police de caractères courante sélectionné du périphérique de contexte spécifié.
GetKeyboardLayout | user32.dll | Cette fonction permet de demander la couche de clavier active pour le processus léger spécifié.
GetKeyboardLayoutList | user32.dll | Cette fonction permet de demander le Handle de la couche de clavier correspondant à l'ensemble d'entrée courant local dans le système.
GetKeyboardLayoutNameA | user32.dll | Cette fonction permet de demander le nom des couches de clavier active.
GetKeyboardLayoutNameW | user32.dll | Cette fonction permet de demander le nom des couches de clavier active avec des paramètres de chaine de caractères étendues (Unicode).
GetKeyboardState | user32.dll | Cette fonction permet de demander l'état des 256 touches virtuel de clavier.
GetKeyboardType | user32.dll | Cette fonction permet de demander les informations à propos du clavier courant.
GetKeyNameTextA | user32.dll | Cette fonction permet de demander une chaine de caractères représentant le nom d'une touche du clavier.
GetKeyNameTextW | user32.dll | Cette fonction permet de demander une chaine de caractères représentant le nom d'une touche du clavier avec des paramètres de chaine de caractères étendues (Unicode).
GetKeyState | user32.dll | Cette fonction permet de demander l'état d'une touche virtuel de clavier.
GetLargestConsoleWindowSize | kernel32.dll | Cette fonction permet de demander la taille de la fenêtre de console la plus large possible en se basant sur la police de caractères et la taille d'affichage.
GetLastActivePopup | user32.dll | Cette fonction permet de demander laquelle des fenêtres du propriétaire de la fenêtre POP-UP a été récemment activé.
GetLastError | kernel32.dll | Cette fonction permet de demander la dernière erreur s'étant produite dans une API.
GetLengthSid | advapi32.dll | Cette fonction permet de retourner la longueur, en octets, d'une structure valide d'identificateur de sécurité (SID).
GetLocaleInfoA | kernel32.dll | Cette fonction permet de demander des informations de nature local sur le système.
GetLocaleInfoW | kernel32.dll | Cette fonction permet de demander des informations de nature local sur le système avec des paramètres de chaine de caractères étendue (Unicode).
GetLocalTime | kernel32.dll | Cette fonction permet de demander la date et l'heure local du système.
GetLogColorSpaceA | gdi32.dll | Cette fonction permet de demander les informations à propos de l'espace de couleurs logiques identifié par le Handle spécifié.
GetLogColorSpaceW | gdi32.dll | Cette fonction permet de demander les informations à propos de l'espace de couleurs logiques identifié par le Handle spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetLogicalDrives | kernel32.dll | Cette fonction permet de demander quel sont les unités de disque valide.
GetLogicalDriveStringsA | kernel32.dll | Cette fonction permet de remplir un tampon avec une chaine de caractères spécifiant une unité de disque système valide.
GetLogicalDriveStringsW | kernel32.dll | Cette fonction permet de remplir un tampon avec une chaine de caractères spécifiant une unité de disque système valide avec des paramètres de chaine de caractères étendue (Unicode).
GetLogicalProcessorInformation | kernel32.dll | Cette fonction permet de demander des informations concernant les processeurs logiques et le matériel associé.
GetMailslotInfo | kernel32.dll | Cette fonction permet de demander des informations pour une slot de courriel.
GetMapMode | gdi32.dll | Cette fonction permet de demander le mode de cartographie courant.
GetMenu | user32.dll | Cette fonction permet de demander le Handle du menu déroulant de la fenêtre d'application spécifié.
GetMenuCheckMarkDimensions | user32.dll | Cette fonction permet de retourner les dimensions du Bitmap marqué par défaut.
GetMenuContextHelpId | user32.dll | Cette fonction permet de demander l'identifiant de contexte d'aide associé avec le menu spécifié.
GetMenuDefaultItem | user32.dll | Cette fonction permet de demander l'item de menu par défaut du menu spécifié.
GetMenuItemCount | user32.dll | Cette fonction permet de demander le nombre d'item que contient menu déroulant.
GetMenuItemID | user32.dll | Cette fonction permet de demander les identificateurs d'un emplacement d'item de menu d'une position spécifié.
GetMenuItemInfoA | user32.dll | Cette fonction permet de demander les informations à propos de l'item de menu.
GetMenuItemInfoW | user32.dll | Cette fonction permet de demander les informations à propos de l'item de menu avec des paramètres de chaine de caractères étendues (Unicode).
GetMenuItemRect | user32.dll | Cette fonction permet de demander les limites rectangulaires pour l'item de menu spécifié.
GetMenuState | user32.dll | Cette fonction permet de demander l'état des drapeaux associés avec l'item de menu spécifié.
GetMenuStringA | user32.dll | Cette fonction permet de copier l'étiquette d'un item de menu dans un tampon.
GetMenuStringW | user32.dll | Cette fonction permet de copier l'étiquette d'un item de menu dans un tampon avec des paramètres de chaine de caractères étendues (Unicode).
GetMessageA | user32.dll | Cette fonction permet de demander un message d'une application de file d'attente de message dans une structure spécifié.
GetMessageW | user32.dll | Cette fonction permet de demander un message d'une application de file d'attente de message dans une structure spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetMessageExtraInfo | user32.dll | Cette fonction permet de demander les informations supplémentaires associés avec le dernier message des fonctions GetMessage ou PeekMessage.
GetMessagePos | user32.dll | Cette fonction permet de retourner une valeur long représentant une position de curseur dans une coordonnée d'écran.
GetMessageTime | user32.dll | Cette fonction permet de retourner l'heure du dernier message reçu par la fonction GetMessage.
GetMetaFileA | gdi32.dll | Cette fonction permet de créer un Handle identifiant le format Windows de fichier de méta données.
GetMetaFileW | gdi32.dll | Cette fonction permet de créer un Handle identifiant le format Windows de fichier de méta données avec des paramètres de chaine de caractères étendues (Unicode).
GetMetaFileBitsEx | gdi32.dll | Cette fonction permet de demander le contenu d'un fichier méta de format Windows et copie le contenu dans un tampon spécifié.
GetMetaRgn | gdi32.dll | Cette fonction permet de demander la région méta courante pour le périphérique de contexte spécifié.
GetMiterLimit | gdi32.dll | Cette fonction permet de demander la limite mitre pour le périphérique de contexte spécifié.
GetModuleFileNameA | kernel32.dll | Cette fonction permet de demander un nom de fichier long ou demande le nom complet de chemin et nom de fichier pour un fichier exécutable contenu dans le module spécifié.
GetModuleFileNameW | kernel32.dll | Cette fonction permet de demander un nom de fichier long ou demande le nom complet de chemin et nom de fichier pour un fichier exécutable contenu dans le module spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetModuleHandleA | kernel32.dll | Cette fonction permet de retourner l'identificateur Handle du module spécifié si le fichier est situé dans l'espace d'adresse d'un processus appelant.
GetModuleHandleW | kernel32.dll | Cette fonction permet de retourner l'identificateur Handle du module spécifié si le fichier est situé dans l'espace d'adresse d'un processus appelant avec des paramètres de chaine de caractères étendue (Unicode).
GetNamedPipeHandleStateA | kernel32.dll | Cette fonction permet de demander les informations d'état conçernant le nom du tuyau spécifié.
GetNamedPipeHandleStateW | kernel32.dll | Cette fonction permet de demander les informations d'état conçernant le nom du tuyau spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetNamedPipeInfo | kernel32.dll | Cette fonction permet de demander les informations conçernant le nom de tuyau spécifié.
GetNearestColor | gdi32.dll | Cette fonction permet de demander la couleur solide correspondant le mieux à la couleur logique.
GetNearestPaletteIndex | gdi32.dll | Cette fonction permet de demander l'index d'une entrée de palette logique correspondant le mieux à la valeur de couleur spécifié.
GetNextDlgGroupItem | user32.dll | Cette fonction permet de rechercher le contrôle précédent ou suivant d'un groupe de contrôle dans une boite de dialogue.
GetNextDlgTabItem | user32.dll | Cette fonction permet de demander le Handle du premier contrôle d'un style WS_TABSTOP du contrôle spécifié.
GetNextWindow | user32.dll | Cette fonction permet de rechercher le Handle de la prochaine ou précédente fenêtre dans la liste du gestionnaire de fenêtre.
GetNumaAvailableMemoryNode | kernel32.dll | Cette fonction permet de demander la quantité de mémoire disponible dans le noeud spécifié.
GetNumberFormatA | kernel32.dll | Cette fonction permet de transformer un nombre selon le format d'affichage spécifié.
GetNumberFormatW | kernel32.dll | Cette fonction permet de transformer un nombre selon le format d'affichage spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetNumberOfConsoleInputEvents | kernel32.dll | Cette fonction permet de demander le nombre d'enregistrement d'entrée non lue dans le tampon d'entrée de console.
GetNumberOfConsoleMouseButtons | kernel32.dll | Cette fonction permet de demander le nombre de boutons de la souris qu'utilise la console courante.
GetNumberOfEventLogRecords | advapi32.dll | Cette fonction permet de demander le nombre d'enregistrement de l'événement du journal de bord spécifié.
GetObjectA | gdi32.dll | Cette fonction permet de remplir un tampon avec les informations définit dans la région spécifié.
GetObjectW | gdi32.dll | Cette fonction permet de remplir un tampon avec les informations définit dans la région spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetObjectType | gdi32.dll | Cette fonction permet de demander l'identifiant de type d'objet spécifié.
GetOEMCP | kernel32.dll | Cette fonction permet de demander le code de page OEM du système d'exploitation.
GetOldestEventLogRecord | advapi32.dll | Cette fonction permet de demander le nombre d'enregistrement dans les anciens enregistrement du journal de bord spécifié.
GetOpenClipboardWindow | user32.dll | Cette fonction permet de demander le Handle de la fenêtre actuellement ouverte dans le presse-papier.
GetOpenFileNameA | comdlg32.dll | Cette fonction permet d'afficher une boite de dialogue offrant la possibilité de choisir un fichier.
GetOutlineTextMetricsA | gdi32.dll | Cette fonction permet de demander le métrique du texte pour la police de caractères TrueType.
GetOutlineTextMetricsW | gdi32.dll | Cette fonction permet de demander le métrique du texte pour la police de caractères TrueType avec des paramètres de chaine de caractères étendues (Unicode).
GetOverlappedResult | kernel32.dll | Cette fonction permet de retourner le résultat d'une opération de recouvrement sur un fichier, un tuyau ou un périphérique de communications spécifié
GetPaletteEntries | gdi32.dll | Cette fonction permet de demander le rang des entrées d'une palette dans une palette logique.
GetParent | user32.dll | Cette fonction permet de demander le Handle de la fenêtre parent spécifié.
GetPath | gdi32.dll | Cette fonction permet de demander les coordonnées définit par des points de fin de lignes et une courbe de point de contrôle trouvé dans un chemin étant sélectionné dans un périphérique de contexte spécifié.
GetPixel | gdi32.dll | Cette fonction permet de demander la couleur sous format RVB (RGB) d'un pixel affiché à l'écran.
GetPixelFormat | gdi32.dll | Cette fonction permet de demander l'index du format de pixel actuellement sélectionné dans le périphérique de contexte spécifié.
GetPolyFillMode | gdi32.dll | Cette fonction permet de demander le mode de remplissage d'un polygone.
GetPrinterA | winspool.drv | Cette fonction permet de demander des informations sur une imprimante.
GetPriorityClass | kernel32.dll | Cette fonction permet de retourner la priorité d'une classe pour un processus spécifié.
GetPriorityClipboardFormat | user32.dll | Cette fonction permet de demander le format du premier presse-papier dans la liste de données existantes du presse-papier.
GetPrivateObjectSecurity | advapi32.dll | Cette fonction permet de demander des informations de descripteur de sécurité à un serveur d'objet protégé.
GetPrivateProfileIntA | kernel32.dll | Cette fonction permet de demander un entier associé avec une clef dans une section spécifié d'un fichier initialisé.
GetPrivateProfileIntW | kernel32.dll | Cette fonction permet de demander un entier associé avec une clef dans une section spécifié d'un fichier initialisé avec des paramètres de chaine de caractères étendue (Unicode).
GetPrivateProfileSectionA | kernel32.dll | Cette fonction permet de demander tous les valeurs et clefs pour la section initialisé spécifié.
GetPrivateProfileSectionW | kernel32.dll | Cette fonction permet de demander tous les valeurs et clefs pour la section initialisé spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetPrivateProfileSectionNamesA | kernel32.dll | Cette fonction permet de demander les noms de toutes les sections dans un fichier initialisé.
GetPrivateProfileSectionNamesW | kernel32.dll | Cette fonction permet de demander les noms de toutes les sections dans un fichier initialisé avec des paramètres de chaine de caractères étendue (Unicode).
GetPrivateProfileStringA | kernel32.dll | Cette fonction permet de demander une chaine de caractères de la section spécifié dans un fichier initialisé.
GetPrivateProfileStringW | kernel32.dll | Cette fonction permet de demander une chaine de caractères de la section spécifié dans un fichier initialisé avec des paramètres de chaine de caractères étendue (Unicode).
GetProcAddress | kernel32.dll | Cette fonction permet de demander l'adresse d'une fonction d'exportation de bibliothèque de liens dynamique (DLL).
GetProcessAffinityMask | kernel32.dll | Cette fonction permet de demander un masque de correspondance de processus spécifié avec le système.
GetProcessHeap | kernel32.dll | Cette fonction permet de demander un identificateur Handle pour la mémoire de tas d'un processus appelant.
GetProcessHeaps | kernel32.dll | Cette fonction permet de demander un identificateur Handle pour tous les mémoires de tas valides pour un processus appelant.
GetProcessPriorityBoost | kernel32.dll | Cette fonction permet de demander l'état de la priorité de contrôle d'amplificateur d'un processus spécifié.
GetProcessShutdownParameters | kernel32.dll | Cette fonction permet de demander les paramètres de fermetures et d'éteindre le système d'exploitation pour un le processus appelant courant.
GetProcessTimes | kernel32.dll | Cette fonction permet de demander les informations d'horloge pour le processus spécifié.
GetProcessVersion | kernel32.dll | Cette fonction permet de demander la version majeur et mineur pour un processus spécifié en exécution.
GetProcessWindowStation | user32.dll | Cette fonction permet de demander le Handle de la fenêtre de station associé avec le processus appelant.
GetProcessWorkingSetSize | kernel32.dll | Cette fonction permet de demander la taille de l'espace de travail minimum et maximum pour le processus spécifié.
GetProfileIntA | kernel32.dll | Cette fonction permet de demander un entier pour le nom de clef spécifié dans une section spécifié dans un fichier «WIN.INI».
GetProfileIntW | kernel32.dll | Cette fonction permet de demander un entier pour le nom de clef spécifié dans une section spécifié dans un fichier «WIN.INI» avec des paramètres de chaine de caractères étendue (Unicode).
GetProfileSectionA | kernel32.dll | Cette fonction permet de demander tous les valeurs et clefs pour la section spécifié dans un fichier «WIN.INI».
GetProfileSectionW | kernel32.dll | Cette fonction permet de demander tous les valeurs et clefs pour la section spécifié dans un fichier «WIN.INI» avec des paramètres de chaine de caractères étendue (Unicode).
GetProfileStringA | kernel32.dll | Cette fonction permet de demander une chaine de caractères associé avec la clef spécifié dans une section du fichier «WIN.INI».
GetProfileStringW | kernel32.dll | Cette fonction permet de demander une chaine de caractères associé avec la clef spécifié dans une section du fichier «WIN.INI» avec des paramètres de chaine de caractères étendue (Unicode).
GetPropA | user32.dll | Cette fonction permet de demander une données Handle d'une liste de propriété d'une fenêtre.
GetPropW | user32.dll | Cette fonction permet de demander une données Handle d'une liste de propriété d'une fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
GetQueuedCompletionStatus | kernel32.dll | Cette fonction permet d'essayer de compléter la file d'attente d'un paquet d'entrée/sortie spécifié pour un port d'entrée/sortie.
GetQueueStatus | user32.dll | Cette fonction permet de retourner une valeur indiquant le type de message dans la file d'attente.
GetRasterizerCaps | gdi32.dll | Cette fonction permet de retourner les drapeaux indiquant si la police de caractères TrueType est installé dans le système.
GetRegionData | gdi32.dll | Cette fonction permet de remplir le tampons spécifié avec une région de données décrites.
GetRgnBox | gdi32.dll | Cette fonction permet de demander les coordonnées des limites rectangulaires d'une région spécifié.
GetROP2 | gdi32.dll | Cette fonction permet de demander le mode dessinage courant.
GetScrollInfo | user32.dll | Cette fonction permet de demander les paramètres d'une barre de défilement, en incluant les positions de défilement minimum et maximum, la taille de la page et la position de la boite de défilement.
GetScrollPos | user32.dll | Cette fonction permet de demander la position courante de la boite de défilement d'une barre de défilement.
GetScrollRange | user32.dll | Cette fonction permet de demander la position minimum et maximum de la barre de défilement spécifié.
GetSecurityDescriptorControl | advapi32.dll | Cette fonction permet de demander le contrôle de descripteur de sécurité et les informations de révision.
GetSecurityDescriptorDacl | advapi32.dll | Cette fonction permet de demander un pointeur sur une liste de contrôle d'accès (ACL) discrétionnaire dans un descripteur de sécurité spécifié.
GetSecurityDescriptorGroup | advapi32.dll | Cette fonction permet de demander les informations de groupe primaire d'un descripteur de sécurité.
GetSecurityDescriptorLength | advapi32.dll | Cette fonction permet de retourner la longueur, en octets, d'une structure valide de descripteur de sécurité.
GetSecurityDescriptorOwner | advapi32.dll | Cette fonction permet de demander les informations du propriétaire d'un descripteur de sécurité
GetSecurityDescriptorSacl | advapi32.dll | Cette fonction permet de demander un pointeur sur la liste de contrôle d'accès système (ACL) dans un descripteur de sécurité spécifié.
GetShortPathNameA | kernel32.dll | Cette fonction permet de demander, à partir d'un nom long, le nom en format DOS (8 caractères de nom et 3 caractères d'extension) d'un fichier.
GetShortPathNameW | kernel32.dll | Cette fonction permet de demander, à partir d'un nom long, le nom en format DOS (8 caractères de nom et 3 caractères d'extension) d'un fichier avec des paramètres de chaine de caractères étendue (Unicode).
GetSidIdentifierAuthority | advapi32.dll | Cette fonction permet de retourner l'adresse de la structure d'un «SID_IDENTIFIER_AUTHORITY» dans l'identificateur de sécurité (SID) spécifié.
GetSidLengthRequired | advapi32.dll | Cette fonction permet de retourner la longueur, en octets, d'un tampon requis pour l'entreposage d'une structure SID avec le nombre de sous-autorisation spécifié.
GetSidSubAuthority | advapi32.dll | Cette fonction permet de retourner l'adresse d'une sous-autorité spécifié d'une structure SID.
GetSidSubAuthorityCount | advapi32.dll | Cette fonction permet de retourner l'adresse d'un champs d'une structure SID contenant le compteur de sous-autorité.
GetStartupInfoA | kernel32.dll | Cette fonction permet de demander le contenu de la structure «STARTUPINFO» spécifié quand un appel de processus est créé.
GetStartupInfoW | kernel32.dll | Cette fonction permet de demander le contenu de la structure «STARTUPINFO» spécifié quand un appel de processus est créé avec des paramètres de chaine de caractères étendue (Unicode).
GetStdHandle | kernel32.dll | Cette fonction permet de demander le Handle d'une entrée ou sortie standard.
GetStockObject | gdi32.dll | Cette fonction permet de demander le Handle d'un des outils de stylo, brosse, police de caractères,... des objets de Windows
GetStretchBltMode | gdi32.dll | Cette fonction permet de demander le mode d'étirement du Bitmap courant.
GetStringTypeA | kernel32.dll | Cette fonction permet de retourner des informations type de caractère pour la chaine de caractères spécifié.
GetStringTypeExA | kernel32.dll | Cette fonction permet de retourner des informations type de caractère pour la chaine de caractères spécifié en Win32.
GetStringTypeExW | kernel32.dll | Cette fonction permet de retourner des informations type de caractère pour la chaine de caractères spécifié en Win32 avec des paramètres de chaine de caractères étendue (Unicode).
GetStringTypeW | kernel32.dll | Cette fonction permet de retourner des informations type de caractère pour la chaine de caractères spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetSubMenu | user32.dll | Cette fonction permet de demander le Handle du menu contextuel.
GetSysColor | user32.dll | Cette fonction permet de demander la couleur d'un des objets affichés du système d'exploitations de Windows.
GetSysColorBrush | user32.dll | Cette fonction permet de demander le Handle identifiant la brosse logique correspondant à l'index de couleur spécifié.
GetSystemDefaultLCID | kernel32.dll | Cette fonction permet de demander l'identificateur locale du système par défaut.
GetSystemDefaultLangID | kernel32.dll | Cette fonction permet de demander l'identificateur de langage système par défaut.
GetSystemDirectoryA | kernel32.dll | Cette fonction permet de demander le répertoire dans lequel les fichiers systèmes du système d'exploitations de Windows sont situés.
GetSystemDirectoryW | kernel32.dll | Cette fonction permet de demander le répertoire dans lequel les fichiers systèmes du système d'exploitations de Windows sont situés avec des paramètres de chaine de caractères étendue (Unicode).
GetSystemInfo | kernel32.dll | Cette fonction permet de demander divers informations à propos du système courant et du microprocesseur.
GetSystemMenu | user32.dll | Cette fonction permet de demander le Handle du menu système d'une fenêtre d'application.
GetSystemMetrics | user32.dll | Cette fonction permet de demander le type de système métrique ou de ses paramètres utilisés.
GetSystemPaletteEntries | gdi32.dll | Cette fonction permet de demander un rang dans les entrées de palette de la palette système.
GetSystemPaletteUse | gdi32.dll | Cette fonction permet de demander si une application est accessible à une palette d'entrée système.
GetSystemPowerStatus | kernel32.dll | Cette fonction permet de demander l'état de l'alimentation en énergie de l'ordinateur.
GetSystemTime | kernel32.dll | Cette fonction permet de demander le temps (date et heure) courant du système d'exploitation. Le temps du système d'exploitation est une expression UTC (Coordinated Universal Time).
GetSystemTimeAsFileTime | kernel32.dll | Cette fonction permet de demander la date et l'heure du système d'exploitation.
GetSystemTimeAdjustment | kernel32.dll | Cette fonction permet de demander si le système applique périodiquement un ajustement du temps après chaque tic d'horloge.
GetTabbedTextExtentA | user32.dll | Cette fonction permet de calculer la largeur et la hauteur d'une chaine de caractères.
GetTabbedTextExtentW | user32.dll | Cette fonction permet de calculer la largeur et la hauteur d'une chaine de caractères avec des paramètres de chaine de caractères étendues (Unicode).
GetTapeParameters | kernel32.dll | Cette fonction permet de demander des informations descriptives sur l'unité de bande magnétique de copie de sauvegarde.
GetTapePosition | kernel32.dll | Cette fonction permet de demander l'adresse courante logique ou en bloc absolue sur une bande magnétique de copie de sauvegarde.
GetTapeStatus | kernel32.dll | Cette fonction permet de demander si la bande magnétique de copie de sauvegarde est prête à recevoir une commande de processus.
GetTcpStatistics | iphlpapi.dll | Cette fonction permet de demander les informations de statistique sur le TCP de l'ordinateur.
GetTempFileNameA | kernel32.dll | Cette fonction permet de demander un nom de fichier créer temporairement.
GetTempFileNameW | kernel32.dll | Cette fonction permet de demander un nom de fichier créer temporairement avec des paramètres de chaine de caractères étendue (Unicode).
GetTempPathA | kernel32.dll | Cette fonction permet de demander le répertoire par défaut des fichiers temporairement.
GetTempPathW | kernel32.dll | Cette fonction permet de demander le répertoire par défaut des fichiers temporairement avec des paramètres de chaine de caractères étendue (Unicode).
GetTextAlign | gdi32.dll | Cette fonction permet de demander l'état des drapeaux d'alignement de texte pour un périphérique de contexte spécifié.
GetTextCharacterExtra | gdi32.dll | Cette fonction permet de demander l'ajustement courant pour la quantité d'espacement entre les caractères.
GetTextCharset | gdi32.dll | Cette fonction permet de demander les informations à propos d'un ensemble de caractères de la police de caractères actuellement sélectionné.
GetTextCharsetInfo | gdi32.dll | Cette fonction permet de demander les informations supplémentaires à propos de l'ensemble de caractères de la police de caractères actuellement sélectionné.
GetTextColor | gdi32.dll | Cette fonction permet de demander la couleur de texte courante.
GetTextExtentExPointA | gdi32.dll | Cette fonction permet de demander le nombre de caractères dans la chaine de caractères correspondant à l'espace spécifié et remplit un tableau avec le texte étendue pour chacun de ses caractères.
GetTextExtentExPointW | gdi32.dll | Cette fonction permet de demander le nombre de caractères dans la chaine de caractères correspondant à l'espace spécifié et remplit un tableau avec le texte étendue pour chacun de ses caractères avec des paramètres de chaine de caractères étendues (Unicode).
GetTextExtentPoint32A | gdi32.dll | Cette fonction permet de calculer la largeur et la hauteur de la chaine de caractères de texte spécifié.
GetTextExtentPoint32W | gdi32.dll | Cette fonction permet de calculer la largeur et la hauteur de la chaine de caractères de texte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetTextExtentPointA | gdi32.dll | Cette fonction permet de calculer la largeur et la hauteur d'un chaine de caractères de texte spécifié dans un contexte de compatibilité 16 bits.
GetTextExtentPointW | gdi32.dll | Cette fonction permet de calculer la largeur et la hauteur d'un chaine de caractères de texte spécifié dans un contexte de compatibilité 16 bits avec des paramètres de chaine de caractères étendues (Unicode).
GetTextFaceA | gdi32.dll | Cette fonction permet de demander le nom de type de police de caractères étant sélectionné dans le périphérique de contexte spécifié.
GetTextFaceW | gdi32.dll | Cette fonction permet de demander le nom de type de police de caractères étant sélectionné dans le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetTextMetricsA | gdi32.dll | Cette fonction permet de demander les informations métriques d'une police de caractères courante.
GetTextMetricsW | gdi32.dll | Cette fonction permet de demander les informations métriques d'une police de caractères courante avec des paramètres de chaine de caractères étendues (Unicode).
GetThreadContext | kernel32.dll | Cette fonction permet de demander le contexte d'un processus léger spécifié.
GetThreadDesktop | user32.dll | Cette fonction permet de demander le Handle du bureau associé avec le processus spécifié.
GetThreadLocale | kernel32.dll | Cette fonction permet de demander l'identificateur local d'un processus.
GetThreadPriority | kernel32.dll | Cette fonction permet de retourner la valeur de priorité du processus léger spécifié.
GetThreadPriorityBoost | kernel32.dll | Cette fonction permet de retourner la priorité de lancement d'un processus léger.
GetThreadSelectorEntry | kernel32.dll | Cette fonction permet de retourner l'entrée de descripteur de table pour le sélecteur et le processus léger spécifié.
GetThreadTimes | kernel32.dll | Cette fonction permet de demander les informations de temps à propos du processus léger spécifié.
GetTickCount | kernel32.dll | Cette fonction permet de demander le nombre de milliseconde écoulé depuis le démarrage de Windows.
GetTimeFormatA | kernel32.dll | Cette fonction permet de retourner la chaine de caractères du format du temps localement.
GetTimeFormatW | kernel32.dll | Cette fonction permet de retourner la chaine de caractères du format du temps localement avec des paramètres de chaine de caractères étendue (Unicode).
GetTimeZoneInformation | kernel32.dll | Cette fonction permet de demander les informations de la zone horaire courante du système d'exploitation Windows.
GetTokenInformation | advapi32.dll | Cette fonction permet de demander le type d'information associé à un accès de jeton.
GetTopWindow | user32.dll | Cette fonction permet de demander le Handle du plus haut niveau de fenêtre enfant appartenant à la fenêtre parent spécifié.
GetUdpStatistics | iphlpapi.dll | Cette fonction permet de demander les informations de statistique sur le UDP de l'ordinateur.
GetUpdateRect | user32.dll | Cette fonction permet de demander les coordonnées d'un petit rectangle complètement enfermé dans une région mise à jour par la fenêtre donnée.
GetUpdateRgn | user32.dll | Cette fonction permet de demander la région mise à jour dans la fenêtre.
GetUserDefaultLCID | kernel32.dll | Cette fonction permet de demander l'identificateur local de l'utilisateur par défaut.
GetUserNameA | advapi32.dll | Cette fonction permet de demander le nom de l'utilisateur courant actuellement sous Windows.
GetUserNameW | advapi32.dll | Cette fonction permet de demander le nom de l'utilisateur courant actuellement sous le système d'exploitation Windows avec des paramètres de chaine de caractères étendue (Unicode).
GetUserNameExA | secur32.dll | Cette fonction permet de retourner le nom de l'utilisateur dans le format EXTENDED_NAME_FORMAT.
GetUserObjectInformationA | user32.dll | Cette fonction permet de demander les informations à propos d'une station de fenêtre ou d'un objet de bureau.
GetUserObjectInformationW | user32.dll | Cette fonction permet de demander les informations à propos d'une station de fenêtre ou d'un objet de bureau avec des paramètres de chaine de caractères étendues (Unicode).
GetUserObjectSecurity | user32.dll | Cette fonction permet de demander les informations de sécurité pour l'objet utilisateur spécifié.
GetVersion | kernel32.dll | Cette fonction permet de demander le numéro de version courante du système d'exploitation Windows et les informations à propos de la plateforme du système d'exploitation.
GetVersionExA | kernel32.dll | Cette fonction permet de demander la version du système d'exploitation Windows.
GetVersionExW | kernel32.dll | Cette fonction permet de demander la version du système d'exploitation Windows avec des paramètres de chaine de caractères étendue (Unicode).
GetViewportExtEx | gdi32.dll | Cette fonction permet de demander les extensions X et Y d'un point de vue d'un périphérique de contexte.
GetViewportOrgEx | gdi32.dll | Cette fonction permet de demander les coordonnées X et Y d'origine d'une association de point vue avec un périphérique de contexte spécifié.
GetVolumeInformationA | kernel32.dll | Cette fonction permet de demander les informations d'entête d'une unité disque.
GetVolumeInformationW | kernel32.dll | Cette fonction permet de demander les informations d'entête d'une unité disque avec des paramètres de chaine de caractères étendue (Unicode).
GetWindow | user32.dll | Cette fonction permet de demander le Handle d'une fenêtre d'application.
GetWindowContextHelpId | user32.dll | Cette fonction permet de demander l'identificateur de contexte, si possible, associé avec la fenêtre spécifié.
GetWindowDC | user32.dll | Cette fonction permet de demander un périphérique de contexte pour la fenêtre, la barre de titre, les menus et la barre de défilement.
GetWindowLongA | user32.dll | Cette fonction permet de demander, sous forme d'une valeur de 32 bits, une des propriétés d'une fenêtre d'application.
GetWindowLongW | user32.dll | Cette fonction permet de demander, sous forme d'une valeur de 32 bits, une des propriétés d'une fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
GetWindowPlacement | user32.dll | Cette fonction permet de demander l'état d'affichage et de restituer, minimiser et maximiser les positions d'une fenêtre.
GetWindowRect | user32.dll | Cette fonction permet de demander les coordonnées et la taille d'une fenêtre d'application.
GetWindowRgn | user32.dll | Cette fonction permet de demander une copie d'une région de fenêtre dans une fenêtre.
GetWindowsDirectoryA | kernel32.dll | Cette fonction permet de demander le répertoire dans lequel le système d'exploitation Windows est situés.
GetWindowsDirectoryW | kernel32.dll | Cette fonction permet de demander le répertoire dans lequel le système d'exploitation Windows est situés avec des paramètres de chaine de caractères étendue (Unicode).
GetWindowTextA | user32.dll | Cette fonction permet de demander du texte contenu dans une fenêtre d'application.
GetWindowTextLengthA | user32.dll | Cette fonction permet de demander la longueur du texte contenu dans une fenêtre d'application.
GetWindowTextLengthW | user32.dll | Cette fonction permet de demander la longueur du texte contenu dans une fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
GetWindowTextW | user32.dll | Cette fonction permet de demander du texte contenu dans une fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
GetWindowThreadProcessId | user32.dll | Cette fonction permet de demander l'identificateur de processus léger étant créer par la fenêtre spécifié et, optionnellement, l'identificateur du processus créant la fenêtre.
GetWindowWord | user32.dll | Cette fonction permet de demander une valeur 16 bits de déplacement spécifié dans une fenêtre en mémoire supplémentaire pour la fenêtre spécifié.
GetWinMetaFileBits | gdi32.dll | Cette fonction permet de convertir des enregistrements de format étendue en enregistrement de format Windows de fichier méta et d'entreposer les enregistrements convertie dans le tampon spécifié.
GetWindowExtEx | gdi32.dll | Cette fonction permet de demander les extensions X et Y d'une fenêtre associé avec un périphérique de contexte spécifié.
GetWindowOrgEx | gdi32.dll | Cette fonction permet de demander les coordonnées X et Y d'origine de la fenêtre associé avec le périphérique de contexte spécifié.
GetWorldTransform | gdi32.dll | Cette fonction permet de demander l'espace mondiale courant vers la transformation d'espace de page.
glAccum | opengl32.dll | Cette fonction permet d'effecter un contrôle du tampon d'accumulation sous OpenGL.
glAlphaFunc | opengl32.dll | Cette fonction permet de définir la fonction devant servir de test Alpha sous OpenGL.
glBegin | opengl32.dll | Cette fonction permet de définir le commencement de la limite d'une primitive ou d'un groupe de primitive sous OpenGL.
glBitmap | opengl32.dll | Cette fonction permet le contenu d'une image Bitmap sous OpenGL.
glBlendFunc | opengl32.dll | Cette fonction permet de définir les facteurs de blending sous OpenGL.
glCallList | opengl32.dll | Cette fonction permet d'appeler une liste de commande graphique OpenGL.
glCallLists | opengl32.dll | Cette fonction permet d'appeler plusieurs listes de commande graphique OpenGL.
glClear | opengl32.dll | Cette fonction permet de vider les tampons du OpenGL ainsi qu'effacement du contenu de la fenêtre.
glClearAccum | opengl32.dll | Cette fonction permet de vider le tampon d'accumulation du OpenGL.
glClearColor | opengl32.dll | Cette fonction permet de vider le tampon chromatique du OpenGL.
glClearDepth | opengl32.dll | Cette fonction permet de vider le tampon de profondeur du OpenGL.
glClearIndex | opengl32.dll | Cette fonction permet de vider le mode index du OpenGL.
glClearStencil | opengl32.dll | Cette fonction permet de vider le tampon stencil du OpenGL.
glClipPlane | opengl32.dll | Cette fonction permet de définir un nouveau plan de clipping du OpenGL.
glColor3b | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'octet dans OpenGL.
glColor3bv | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure d'octets dans OpenGL.
glColor3d | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'un réel double dans OpenGL.
glColor3dv | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure des réels doubles dans OpenGL.
glColor3f | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'un réel dans OpenGL.
glColor3fv | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure des réels dans OpenGL.
glColor3i | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'un entier long dans OpenGL.
glColor3iv | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure des entiers long dans OpenGL.
glColor3s | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'un entier court dans OpenGL.
glColor3sv | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure des entiers court dans OpenGL.
glEnd | opengl32.dll | Cette fonction permet de définir la fin de la limite d'une primitive ou d'un groupe de primitive sous OpenGL.
GlobalAddAtomA | kernel32.dll | Cette fonction permet d'ajouter un caractère à une table global d'Atom et retourne une valeur unique d'identificateur par chaine de caractères.
GlobalAddAtomW | kernel32.dll | Cette fonction permet d'ajouter un caractère à une table global d'Atom et retourne une valeur unique d'identificateur par chaine de caractères avec des paramètres de chaine de caractères étendue (Unicode).
GlobalAlloc | kernel32.dll | Cette fonction permet d'allouer de la mémoire dans les ressources global du système d'exploitation.
GlobalCompact | kernel32.dll | Cette fonction permet de réorganiser les allocations de mémoire dynamique du tas global en spécifiant une taille de mémoire minimum.
GlobalDeleteAtom | kernel32.dll | Cette fonction permet de décrémenté le compteur de référence de la chaine de caractères d'Atom global.
GlobalFindAtomA | kernel32.dll | Cette fonction permet de rechercher une table d'Atom global dans la chaine de caractères spécifié et demande l'Atom global associé avec la chaine de caractères.
GlobalFindAtomW | kernel32.dll | Cette fonction permet de rechercher une table d'Atom global dans la chaine de caractères spécifié et demande l'Atom global associé avec la chaine de caractères étendue (Unicode).
GlobalFix | kernel32.dll | Cette fonction permet de prévenir l'objet de mémoire global donnée contre un mouvement de mémoire linéaire. Cette fonction est obsolète.
GlobalFlags | kernel32.dll | Cette fonction permet de retourner les informations à propos de l'objet de mémoire global spécifié.
GlobalFree | kernel32.dll | Cette fonction permet de libérer de la mémoire dans les ressources global du système d'exploitation.
GlobalGetAtomNameA | kernel32.dll | Cette fonction permet de demander une copie de la chaine de caractères associé avec l'Atom global donnée.
GlobalGetAtomNameW | kernel32.dll | Cette fonction permet de demander une copie de la chaine de caractères associé avec l'Atom global donnée avec des paramètres de chaine de caractères étendue (Unicode).
GlobalHandle | kernel32.dll | Cette fonction permet de demander le Handle de l'objet de mémoire global spécifié.
GlobalLock | kernel32.dll | Cette fonction permet de verrouiller l'emplacement du bloc de mémoire dans les ressources global du système d'exploitation.
GlobalMemoryStatus | kernel32.dll | Cette fonction permet de demander l'état de la mémoire du système d'exploitation.
GlobalMemoryStatusEx | kernel32.dll | Cette fonction permet de demander l'état de la mémoire du système d'exploitation ayant plus de 4 Go de RAM d'installer sur l'ordinateur.
GlobalReAlloc | kernel32.dll | Cette fonction permet de changer la taille ou les attributs de l'objet de mémoire global spécifié.
GlobalSize | kernel32.dll | Cette fonction permet de demander la taille courante, en octets, de l'objet de mémoire global.
GlobalUnfix | kernel32.dll | Cette fonction permet d'annuler les effets d'une fonction GlobalFix et d'allouer l'objet de mémoire global a être déplacé dans la mémoire linéaire. Cette fonction est obsolète.
GlobalUnlock | kernel32.dll | Cette fonction permet de déverrouiller l'emplacement du bloc de mémoire dans les ressources global du système d'exploitation.
GlobalUnWire | kernel32.dll | Cette fonction permet de restituer la conversion d'un pointeur de processus 32 bits après une allocation de mémoire.
GrayStringA | user32.dll | Cette fonction permet de dessiner du texte grisé à l'emplacement donnée par l'écriture du texte dans un Bitmap en mémoire, grisonnant le Bitmap, et copie alors le Bitmap dans l'affichage.
GrayStringW | user32.dll | Cette fonction permet de dessiner du texte grisé à l'emplacement donnée par l'écriture du texte dans un Bitmap en mémoire, grisonnant le Bitmap, et copie alors le Bitmap dans l'affichage avec des paramètres de chaine de caractères étendues (Unicode).
HeapAlloc | kernel32.dll | Cette fonction permet d'allouer un bloc de mémoire à l'aide d'un tas.
HeapCompact | kernel32.dll | Cette fonction permet de demander la taille de la largeur d'un bloc de mémoire disponible dans le tas spécifié.
HeapCreate | kernel32.dll | Cette fonction permet de créer un objet de tas privé pouvant être utilisé par le processus appelant.
HeapDestroy | kernel32.dll | Cette fonction permet de détruire l'objet de tas spécifié.
HeapFree | kernel32.dll | Cette fonction permet de libérer un bloc de mémoire précédemment alloué d'un tas par la fonction HeapAlloc ou HeapReAlloc.
HeapLock | kernel32.dll | Cette fonction permet de verrouiller l'association avec le tas spécifié dans un objet de section critique.
HeapReAlloc | kernel32.dll | Cette fonction permet de réallouer un bloc de mémoire d'un tas.
HeapSize | kernel32.dll | Cette fonction permet de demander la taille d'un bloc de mémoire alloué dans le tas par la fonction HeapAlloc ou HeapReAlloc.
HeapUnlock | kernel32.dll | Cette fonction permet de déverrouiller l'association avec le tas spécifié dans un objet de section critique.
HeapValidate | kernel32.dll | Cette fonction permet de valider le tas spécifié.
HeapWalk | kernel32.dll | Cette fonction permet d'énumérer les blocs de mémoire dans le tas spécifié.
HideCaret | user32.dll | Cette fonction permet de cacher un caret en l'enlevant de l'écran.
HiliteMenuItem | user32.dll | Cette fonction permet de faire passer un item de menu en mode de surbrillance.
IcmpCloseHandle | icmp.dll | Cette fonction permet de fermer un fichier sur le protocole ICMP (Internet Control Message Protocol).
IcmpCreateFile | icmp.dll | Cette fonction permet de créer un fichier sur le protocole ICMP (Internet Control Message Protocol).
IcmpSendEcho | icmp.dll | Cette fonction permet d'envoyer une requête en écho par le protocole ICMP (Internet Control Message Protocol).
ImpersonateDdeClientWindow | user32.dll | Cette fonction permet d'activer l'échange de données dynamique (DDE) vers un contexte d'application sécurisé d'imitation de client DDE.
ImpersonateLoggedOnUser | advapi32.dll | Cette fonction permet d'appeler une processus léger utilisateur impersonnel.
ImpersonateNamedPipeClient | advapi32.dll | Cette fonction permet de demmander si l'application client a un nom de canal impersonnel.
ImpersonateSelf | advapi32.dll | Cette fonction permet de demander le jeton d'accès au contexte de sécurité impersonnel d'un processus appelant.
inet_addr | Wsock32.dll | Cette fonction permet l'adresse IP contenu dans une chaine de caractères sous sa forme numérique 32 bits.
InflateRect | user32.dll | Cette fonction permet d'agrandir ou diminuer la taille d'un objet de rectangle.
InitAtomTable | kernel32.dll | Cette fonction permet d'initialiser la table d'Atom local et fixe la taille spécifié.
InitCommonControlsEx | comctl32.dll | Cette fonction permet d'initialiser une classe de contrôle commun.
InitializeAcl | advapi32.dll | Cette fonction permet de créer une nouvelle structure de liste de contrôle d'accès (ACL).
InitializeCriticalSection | kernel32.dll | Cette fonction permet d'initialiser un objet de section critique.
InitializeSecurityDescriptor | advapi32.dll | Cette fonction permet d'initialiser un nouveau descripteur de sécurité.
InitializeSid | advapi32.dll | Cette fonction permet d'initialiser une structure d'identificateur de sécurité (SID).
InitiateSystemShutdownA | advapi32.dll | Cette fonction permet d'initier l'opération de fermeture ou de redémarrage en cours d'exécution du système d'exploitation Windows.
InitiateSystemShutdownW | advapi32.dll | Cette fonction permet d'initier l'opération de fermeture ou de redémarrage en cours d'exécution du système d'exploitation Windows avec des paramètres de chaine de caractères étendue (Unicode).
InSendMessage | user32.dll | Cette fonction permet de spécifier si la procédure de la fenêtre courante est en traitement d'un message d'envoi d'une autre tâche par appel de la fonction SendMessage.
InsertMenuA | user32.dll | Cette fonction permet d'insérer un nouvel item de menu dans un menu et déplace les autres items en bas du menu.
InsertMenuItemA | user32.dll | Cette fonction permet d'insérer un nouvel item de menu à la position spécifié dans la barre de menu ou un menu contextuel.
InsertMenuItemW | user32.dll | Cette fonction permet d'insérer un nouvel item de menu à la position spécifié dans la barre de menu ou un menu contextuel avec les paramètres de chaine de caractères étendues (Unicode).
InsertMenuW | user32.dll | Cette fonction permet d'insérer un nouvel item de menu dans un menu et déplace les autres items en bas du menu avec des paramètres de chaine de caractères étendues (Unicode).
InstallNewDevice | newdev.dll | Cette fonction permet d'installer un nouveau périphérique.
InterlockedCompareExchange | kernel32.dll | Cette fonction permet d'effectuer un traitement de comparaison atomique de valeurs spécifiés et échange les valeurs en se basant sur le résultat de la comparaison.
InterlockedDecrement | kernel32.dll | Cette fonction permet de décrémenter les deux valeurs spécifié de un et vérifie le résultat des valeurs.
InterlockedExchange | kernel32.dll | Cette fonction permet d'échanger automatiquement une paire de valeurs 32 bits.
InterlockedExchangeAdd | kernel32.dll | Cette fonction permet d'effectuer un traitement automatique d'ajouter d'une valeur incrémenté à une variable ajouté.
InterlockedIncrement | kernel32.dll | Cette fonction permet d'incrémenter les deux valeurs des variables spécifiés et vérifie la valeur du résultat.
InternetAutodial | wininet.dll | Cette fonction permet de provoquer une connexion Internet en utilisant le protocole TCP/IP.
InternetAutodialHangup | wininet.dll | Cette fonction permet d'arrêter une connexion Internet en utilisant le protocole TCP/IP.
InternetGetConnectedState | wininet.dll | Cette fonction permet de demander le type de connexion Internet qu'utilise le TCP/IP de Windows.
IntersectClipRect | gdi32.dll | Cette fonction permet de créer une nouvelle région de capture vers l'intersection de la région courante et du rectangle spécifié.
IntersectRect | user32.dll | Cette fonction permet de calculer l'intersection de 2 sources rectangulaires et place les coordonnées du rectangle d'intersection dans le rectangle de destination.
InvalidateRect | user32.dll | Cette fonction permet d'ajouter un rectangle pour la mise à jour d'une région d'une fenêtre.
InvalidateRgn | user32.dll | Cette fonction permet d'ajouter une région à une région de fenêtre à mettre à jour.
InvertRect | user32.dll | Cette fonction permet d'inverser une région rectangulaire.
InvertRgn | gdi32.dll | Cette fonction permet d'inverser les couleurs d'une région spécifié.
IsBadCodePtr | kernel32.dll | Cette fonction permet de demander si l'appel du processus a un accès de mémoire en lecture à l'adresse spécifié.
IsBadHugeReadPtr | kernel32.dll | Cette fonction permet de vérifier si l'appel du processus a un accès en lecture dans les rangs de mémoire spécifié.
IsBadHugeWritePtr | kernel32.dll | Cette fonction permet de vérifier si l'appel du processus a un accès en écriture dans les rangs de mémoire spécifié.
IsBadReadPtr | kernel32.dll | Cette fonction permet de vérifier si l'appel du processus a un accès en lecture dans les rangs de mémoire spécifié.
IsBadStringPtrA | kernel32.dll | Cette fonction permet de vérifier que l'appel du processus à un accès en lecture dans les rangs de mémoire pointer sur une chaine de caractères.
IsBadStringPtrW | kernel32.dll | Cette fonction permet de vérifier que l'appel du processus à un accès en lecture dans les rangs de mémoire pointer sur une chaine de caractères étendue (Unicode).
IsBadWritePtr | kernel32.dll | Cette fonction permet de vérifier si l'appel du processus a un accès en écriture dans les rangs de mémoire spécifié.
IsDBCSLeadByte | kernel32.dll | Cette fonction permet de demander si un caractère spécifié est un octet de tête, le premier octet d'un caractère est un DBCS (Double-Byte Character Set).
IsDBCSLeadByteEx | kernel32.dll | Cette fonction permet de demander si un caractère spécifié est un octet de tête, le premier octet d'un caractère est un DBCS (Double-Byte Character Set) avec un code de page.
IsCharAlphaA | user32.dll | Cette fonction permet de demander si un caractère fait partie de l'ensemble de caractères alphabétiques de la langue.
IsCharAlphaNumericA | user32.dll | Cette fonction permet de demander si un caractère est une lettre ou un chiffre arabes.
IsCharAlphaNumericW | user32.dll | Cette fonction permet de demander si un caractère est une lettre ou un chiffre arabes avec des paramètres de chaine de caractères étendues (Unicode).
IsCharAlphaW | user32.dll | Cette fonction permet de demander si un caractère fait partie de l'ensemble de caractères alphabétiques de la langue avec des paramètres de chaine de caractères étendues (Unicode).
IsCharLowerA | user32.dll | Cette fonction permet de demander si un caractère est une lettre en minuscule.
IsCharLowerW | user32.dll | Cette fonction permet de demander si un caractère est une lettre en minuscule avec des paramètres de chaine de caractères étendues (Unicode).
IsCharUpperA | user32.dll | Cette fonction permet de demander si un caractère est une lettre en majuscule.
IsCharUpperW | user32.dll | Cette fonction permet de demander si un caractère est une lettre en majuscule avec des paramètres de chaine de caractères étendues (Unicode).
IsChild | user32.dll | Cette fonction permet de demander si la fenêtre spécifié est l'enfant ou d'une autre descendance direct de la fenêtre parent spécifié.
IsClipboardFormatAvailable | user32.dll | Cette fonction permet de demander si les données d'un certain format existe dans le presse-papier.
IsDebuggerPresent | kernel32.dll | Cette fonction permet de demander si l'application en cours est sous l'influence d'un débogueur.
IsDialogMessageA | user32.dll | Cette fonction permet de demander si le message spécifié est prévu dans la modélisation de la boite de dialogue donnée et, si c'est le cas, traite le message.
IsDialogMessageW | user32.dll | Cette fonction permet de demander si le message spécifié est prévu dans la modélisation de la boite de dialogue donnée et, si c'est le cas, traite le message avec des paramètres de chaine de caractères étendues (Unicode).
IsDlgButtonChecked | user32.dll | Cette fonction permet de demander si un bouton a une coche à côté de lui et si un bouton à trois états de gris, est coché ou pas.
IsIconic | user32.dll | Cette fonction permet de demander si la fenêtre spécifié est minimisé (en état d'icône).
IsMenu | user32.dll | Cette fonction permet d'indiquer si le Handle spécifié est un Handle de menu.
IsProcessorFeaturePresent | kernel32.dll | Cette fonction permet de demander si les fonctionnalités du microprocessseur sont supportés par l'un des microprocesseur de la machine courante.
IsRectEmpty | user32.dll | Cette fonction permet de déterminer si le rectangle spécifié est vide.
IsTextUnicode | advapi32.dll | Cette fonction permet de demander l'adresse du tampon contenant probablement une forme de texte Unicode.
IsValidAcl | advapi32.dll | Cette fonction permet de valider une liste de contrôle d'accès (ACL).
IsValidCodePage | kernel32.dll | Cette fonction permet d'indiquer si la page de code spécifié est valide.
IsValidLocale | kernel32.dll | Cette fonction permet d'appliquer un test de validité à un identificateur locale.
IsValidSecurityDescriptor | advapi32.dll | Cette fonction permet de valider une structure de descripteur de sécurité «SECURITY_DESCRIPTOR».
IsValidSid | advapi32.dll | Cette fonction permet de valider une structure SID en vérifiant que le numéro de version est situé dans le rang et les intervalles de nombres de sous-autorité.
IsWindow | user32.dll | Cette fonction permet de demander si la fenêtre de Handle spécifié est valide.
IsWindowEnabled | user32.dll | Cette fonction permet de demander si la fenêtre spécifié est activé par la souris ou l'entrée clavier.
IsWindowUnicode | user32.dll | Cette fonction permet de demander si la fenêtre spécifié est une fenêtre Unicode native.
IsWindowVisible | user32.dll | Cette fonction permet de demander si la fenêtre spécifié est dans un état de visibilité.
IsZoomed | user32.dll | Cette fonction permet de demander si la fenêtre spécifié est maximisé (ou prend toute l'écran).
keybd_event | user32.dll | Cette fonction permet de provoquer un événement d'appui de touche clavier.
KillTimer | user32.dll | Cette fonction permet de détruire la minuterie spécifié.
LCMapStringA | kernel32.dll | Cette fonction permet de cartographier une chaine de caractères vers une autre en effectuant le traitement de transformation de dépendance locale.
LCMapStringW | kernel32.dll | Cette fonction permet de cartographier une chaine de caractères étendue (Unicode) vers une autre en effectuant le traitement de transformation de dépendance locale.
LeaveCriticalSection | kernel32.dll | Cette fonction permet de libérer le propriétaire d'un objet de section critique spécifié.
LineDDA | gdi32.dll | Cette fonction permet de calculer tous les points successifs d'une ligne spécifié par les coordonnées de début et de fin.
LineTo | gdi32.dll | Cette fonction permet de tracer une ligne des coordonnées courante à la position spécifié.
LoadAcceleratorsA | user32.dll | Cette fonction permet d'effectuer le chargement d'une table d'accélérateur d'une ressource.
LoadAcceleratorsW | user32.dll | Cette fonction permet d'effectuer le chargement d'une table d'accélérateur d'une ressource avec des paramètres de chaine de caractères étendues (Unicode).
LoadBitmapA | user32.dll | Cette fonction permet de charger la ressource de Bitmap spécifié du fichier de module d'exécutable donnée.
LoadBitmapW | user32.dll | Cette fonction permet de charger la ressource de Bitmap spécifié du fichier de module d'exécutable donnée avec des paramètres de chaine de caractères étendues (Unicode).
LoadCursorA | user32.dll | Cette fonction permet de sélectionner un pointeur de souris.
LoadCursorFromFileA | user32.dll | Cette fonction permet de charger à partir d'un fichier un pointeur de souris.
LoadCursorFromFileW | user32.dll | Cette fonction permet de charger à partir d'un fichier un pointeur de souris avec des paramètres de chaine de caractères étendues (Unicode).
LoadCursorW | user32.dll | Cette fonction permet de sélectionner un pointeur de souris avec des paramètres de chaine de caractères étendues (Unicode).
LoadIconA | user32.dll | Cette fonction permet de charger une icône à partir d'un fichier.
LoadIconW | user32.dll | Cette fonction permet de charger une icône à partir d'un fichier avec des paramètres de chaine de caractères étendues (Unicode).
LoadImageA | user32.dll | Cette fonction permet de charger une image à partir d'une icône, un curseur ou un Bitmap.
LoadImageW | user32.dll | Cette fonction permet de charger une image à partir d'une icône, un curseur ou un Bitmap avec des paramètres de chaine de caractères étendues (Unicode).
LoadKeyboardLayoutA | user32.dll | Cette fonction permet de charger une nouvelle couche clavier dans le système.
LoadKeyboardLayoutW | user32.dll | Cette fonction permet de charger une nouvelle couche clavier dans le système avec des paramètres de chaine de caractères étendues (Unicode).
LoadLibraryA | kernel32.dll | Cette fonction permet d'effectuer le chargement du module de bibliothèque spécifié.
LoadLibraryW | kernel32.dll | Cette fonction permet d'effectuer le chargement du module de bibliothèque spécifié avec des paramètres de chaine de caractères étendue (Unicode).
LoadLibraryExA | kernel32.dll | Cette fonction permet de cartographier un module exécutable spécifié dans l'espace d'adressage du processus d'appel.
LoadLibraryExW | kernel32.dll | Cette fonction permet de cartographier un module exécutable spécifié dans l'espace d'adressage du processus d'appel avec des paramètres de chaine de caractères étendue (Unicode).
LoadMenuA | user32.dll | Cette fonction permet d'effectuer le chargement de la ressource de menu spécifié du fichier exécutable avec l'instance d'application donnée.
LoadMenuIndirectA | user32.dll | Cette fonction permet de charger le gabarit de menu spécifié en mémoire.
LoadMenuIndirectW | user32.dll | Cette fonction permet de charger le gabarit de menu spécifié en mémoire avec des paramètres de chaine de caractères étendues (Unicode).
LoadMenuW | user32.dll | Cette fonction permet d'effectuer le chargement de la ressource de menu spécifié du fichier exécutable avec l'instance d'application donnée avec des paramètres de chaine de caractères étendues (Unicode).
LoadModule | kernel32.dll | Cette fonction permet de charger et d'exécution une application Windows ou crée un nouvel instance dans un application Windows existante.
LoadResource | kernel32.dll | Cette fonction permet de charger la ressource spécifié dans la mémoire global.
LoadStringA | user32.dll | Cette fonction permet d'effectuer le chargement de la chaine de caractères spécifié d'une ressource.
LoadStringW | user32.dll | Cette fonction permet d'effectuer le chargement de la chaine de caractères spécifié d'une ressource avec des paramètres de chaine de caractères étendues (Unicode).
LocalAlloc | kernel32.dll | Cette fonction permet d'allouer le nombre d'octets spécifiés pour le tas local.
LocalCompact | kernel32.dll | Cette fonction permet de réarranger le tas local si la quantité de mémoire spécifié est disponible.
LocalFileTimeToFileTime | kernel32.dll | Cette fonction permet de convertir un temps de fichier local en temps de fichier basé sur l'UTC (Coordinated Universal Time).
LocalFlags | kernel32.dll | Cette fonction permet de demander les informations à propos de l'objet de mémoire local.
LocalFree | kernel32.dll | Cette fonction permet de demander l'objet de mémoire local et d'invalider un Handle.
LocalLock | kernel32.dll | Cette fonction permet de demander un pointeur sur l'objet de mémoire local.
LocalReAlloc | kernel32.dll | Cette fonction permet de changer la taille ou les attributs d'un objet de mémoire local spécifié.
LocalShrink | kernel32.dll | Cette fonction rapetisser le tas local du segment spécifié.
LocalSize | kernel32.dll | Cette fonction permet de demander la taille, en octets, de l'objet de mémoire local spécifié.
LocalUnlock | kernel32.dll | Cette fonction permet de déverrouiller un objet de mémoire local spécifié.
LockFile | kernel32.dll | Cette fonction permet de verrouiller une région d'un fichier ouvert.
LockFileEx | kernel32.dll | Cette fonction permet de verrouiller un rang d'octets dans un fichier ouvert avec un accès de partage ou d'exclusivité.
LockResource | kernel32.dll | Cette fonction permet de verrouiller une ressource spécifié.
LockWindowUpdate | user32.dll | Cette fonction permet d'activer ou désactiver l'affichage du contenu d'une fenêtre d'application.
LockWorkStation | user32.dll | Cette fonction permet verrouiller la poste de travail avec le mot de passe de l'utilisateur courant. Cette fonction est l'équivalent de Ctrl+Alt+Delete et «Verrouiller Station de Travail».
LogonUserA | advapi32.dll | Cette fonction permet d'effectuer une opération de connexion d'un utilisateur.
LogonUserW | advapi32.dll | Cette fonction permet d'effectuer une opération de connexion d'un utilisateur avec des paramètres de chaine de caractères étendue (Unicode).
LookupAccountNameA | advapi32.dll | Cette fonction permet d'accepter le nom d'un système ou d'un compte en entrée.
LookupAccountNameW | advapi32.dll | Cette fonction permet d'accepter le nom d'un système ou d'un compte en entrée avec des paramètres de chaine de caractères étendue (Unicode).
LookupAccountSidA | advapi32.dll | Cette fonction permet d'accepter un identificateur de sécurité (SID) en entrée
LookupAccountSidW | advapi32.dll | Cette fonction permet d'accepter un identificateur de sécurité (SID) en entrée avec des paramètres de chaine de caractères étendue (Unicode).
LookupIconIdFromDirectory | user32.dll | Cette fonction permet d'effectuer la recherche de données d'icône ou de curseur dans un icône ou curseur étant la meilleure correspondance avec le périphérique d'affichage courant.
LookupIconIdFromDirectoryEx | user32.dll | Cette fonction permet d'effectuer la recherche de données d'icône ou de curseur dans un icône ou curseur étant la meilleure correspondance avec le périphérique d'affichage courant avec des options particulières.
LookupPrivilegeDisplayNameA | advapi32.dll | Cette fonction permet de demander le nom d'affichage représenté par le privilège spécifié.
LookupPrivilegeDisplayNameW | advapi32.dll | Cette fonction permet de demander le nom d'affichage représenté par le privilège spécifié avec des paramètres de chaine de caractères étendue (Unicode).
LookupPrivilegeNameA | advapi32.dll | Cette fonction permet de demander le nom correspondant au privilège représenté par un système spécifié par identificateur local unique (LUID).
LookupPrivilegeNameW | advapi32.dll | Cette fonction permet de demander le nom correspondant au privilège représenté par un système spécifié par identificateur local unique (LUID) avec des paramètres de chaine de caractères étendue (Unicode)
LookupPrivilegeValueA | advapi32.dll | Cette fonction permet de demander l'identificateur local unique (LUID) utilisé par un système spécifié par une représentation local d'un nom de prévilège.
LookupPrivilegeValueW | advapi32.dll | Cette fonction permet de demander l'identificateur local unique (LUID) utilisé par un système spécifié par une représentation local d'un nom de prévilège avec des paramètres de chaine de caractères étendue (Unicode)
LPtoDP | gdi32.dll | Cette fonction permet de convertir les coordonnées logiques (points) en coordonnées d'un périphérique.
lstrcatA | kernel32.dll | Cette fonction permet d'ajouter une chaine de caractères à une autre.
lstrcatW | kernel32.dll | Cette fonction permet d'ajouter une chaine de caractères étendue (Unicode) à une autre.
lstrcmpA | kernel32.dll | Cette fonction permet d'effectuer la comparaison de deux chaines de caractères ASCIZ.
lstrcmpW | kernel32.dll | Cette fonction permet d'effectuer la comparaison de deux chaines de caractères étendues (Unicode).
lstrcmpiA | kernel32.dll | Cette fonction permet d'effectuer une comparaison de deux chaines de caractères sans tenir compte des majuscules ou minuscules.
lstrcmpiW | kernel32.dll | Cette fonction permet d'effectuer une comparaison de deux chaines de caractères étendues (Unicode) sans tenir compte des majuscules ou minuscules.
lstrcpyA | kernel32.dll | Cette fonction permet de copier une chaine de caractères dans un tampon.
lstrcpyW | kernel32.dll | Cette fonction permet de copier une chaine de caractères étendues (Unicode) dans un tampon.
lstrcpynA | kernel32.dll | Cette fonction permet d'effectuer une copie du nombre de caractères spécifié d'une chaine de caractères vers un tampon en mémoire.
lstrcpynW | kernel32.dll | Cette fonction permet d'effectuer une copie du nombre de caractères spécifié d'une chaine de caractères étendue (Unicode) vers un tampon en mémoire.
lstrlenA | kernel32.dll | Cette fonction permet de retourner la longueur, en octets, de la chaine de caractères spécifié.
lstrlenW | kernel32.dll | Cette fonction permet de retourner la longueur, en octets, de la chaine de caractères étendue (Unicode) spécifié.
LZClose | lz32.dll | Cette fonction permet de fermer un fichier compressé.
LZCopy | lz32.dll | Cette fonction permet de copier un fichier en dehors du fichier compressé ou permet de le compresser et de l'inclure avec le fichier compressé.
LZOpenFileA | lz32.dll | Cette fonction permet de créer, ouvrir ou supprimer un fichier compressé.
MakeAbsoluteSD | advapi32.dll | Cette fonction permet de créer un descripteur de sécurité dans un format absolue en utilisant un gabarit de format relatif de descripteur de sécurité.
MakeSelfRelativeSD | advapi32.dll | Cette fonction permet de créer un descripteur de sécurité dans un format relatif en utilisant un gabarit de format absolue de descripteur de sécurité.
MakeSureDirectoryPathExists | imagehlp.dll | Cette fonction permet de s'assurer que toutes l'arborescente d'un chemin de répertoires existent et ont été créés.
MapDialogRect | user32.dll | Cette fonction permet d'effectuer la conversion de l'unité de boite de dialogue à l'unité d'écran (pixels).
MapGenericMask | advapi32.dll | Cette fonction permet de générer une carte de masque de bon accès spécifié et de bon accès standard
MAPISendDocuments | mapi32.dll | Cette fonction permet d'effectuer l'envoie d'un message de style standard avec des fichiers attachés.
MapViewOfFile | kernel32.dll | Cette fonction permet de cartographier une vue d'un fichier dans l'espace d'adressage d'un processus appelant.
MapViewOfFileEx | kernel32.dll | Cette fonction permet de cartographier une vue d'un fichier dans l'espace d'adressage d'un processus appelant avec un adresse de mémoire spécifié.
MapVirtualKeyA | user32.dll | Cette fonction permet d'effectuer la conversion du code de touche virtuel en une valeur de caractère et un code de balayage (scan code) ou convertie le code de balayage en code de touche virtuel.
MapVirtualKeyExA | user32.dll | Cette fonction permet d'effectuer la conversion du code de touche virtuel en une valeur de caractère et un code de balayage (scan code) ou convertie le code de balayage en code de touche virtuel en utilisant des options supplémentaires.
MapVirtualKeyExW | user32.dll | Cette fonction permet d'effectuer la conversion du code de touche virtuel en une valeur de caractère et un code de balayage (scan code) ou convertie le code de balayage en code de touche virtuel en utilisant des options supplémentaires avec des paramètres de chaine de caractères étendues (Unicode).
MapVirtualKeyW | user32.dll | Cette fonction permet d'effectuer la conversion du code de touche virtuel en une valeur de caractère et un code de balayage (scan code) ou convertie le code de balayage en code de touche virtuel avec des paramètres de chaine de caractères étendues (Unicode).
MapWindowPoints | user32.dll | Cette fonction permet de convertir (cartographié) un ensemble de points d'une espace de coordonnées relatif d'une fenêtre vers une autre fenêtre d'espace de coordonnées relatif.
MaskBlt | gdi32.dll | Cette fonction permet de fusionner les données de couleur du Bitmap de la source et la destination en utilisant les opérations de masque et de raster spécifié.
mciSendStringA | winmm.dll | Cette fonction permet d'envoyer des commandes au pilote matériel MCI s'occupant du multimédia.
MenuItemFromPoint | user32.dll | Cette fonction permet de demander quel est l'item de menu situé à l'emplacement spécifié, peut importe lequel.
MessageBeep | user32.dll | Cette fonction permet de faire jouer un de ses sons standard du système d'exploitation Windows.
MessageBoxA | user32.dll | Cette fonction permet d'afficher une boite de dialogue contenant un message et des boutons d'actions.
MessageBoxExA | user32.dll | Cette fonction permet de créer, d'afficher et d'effectuer des opérations sur une boite de message.
MessageBoxExW | user32.dll | Cette fonction permet de créer, d'afficher et d'effectuer des opérations sur une boite de message avec des paramètres de chaine de caractères étendues (Unicode).
MessageBoxIndirectA | user32.dll | Cette fonction permet de créer, d'afficher et d'effectuer des opérations sur une boite de message à l'aide d'une structure de données.
MessageBoxIndirectW | user32.dll | Cette fonction permet de créer, d'afficher et d'effectuer des opérations sur une boite de message à l'aide d'une structure de données avec des paramètres de chaine de caractères étendues (Unicode).
MessageBoxW | user32.dll | Cette fonction permet d'afficher une boite de dialogue contenant un message et des boutons d'actions avec des paramètres de chaine de caractères étendues (Unicode).
ModifyMenuA | user32.dll | Cette fonction permet d'effectuer une modification sur un item de menu existant.
ModifyMenuW | user32.dll | Cette fonction permet d'effectuer une modification sur un item de menu existant avec des paramètres de chaine de caractères étendues (Unicode).
ModifyWorldTransform | gdi32.dll | Cette fonction permet de changer la transformation mondiale pour le périphérique de contexte utilisant le mode spécifié.
mouse_event | user32.dll | Cette fonction permet de provoquer un événement de déplacement de pointeur de souris ou d'actions de bouton de souris.
MoveFileA | kernel32.dll | Cette fonction permet de renommer ou déplacer un fichier ou un répertoire
MoveFileExA | kernel32.dll | Cette fonction permet de renommer un fichier existant.
MoveFileExW | kernel32.dll | Cette fonction permet de renommer un fichier existant avec un paramètre de chaine de caractères étendue (Unicode).
MoveFileW | kernel32.dll | Cette fonction permet de renommer ou déplacer un fichier ou un répertoire avec un paramètre de chaine de caractères étendue (Unicode).
MoveToEx | gdi32.dll | Cette fonction permet de changer la position du pointeur graphique
MoveWindow | user32.dll | Cette fonction permet de changer l'emplacement d'une fenêtre d'application
MsgWaitForMultipleObjects | user32.dll | Cette fonction permet de retourner un objet spécifié suite à un état, un type spécifié étant disponible de l'entrée de la file d'attente d'un processus léger ou intervalle de dépassement de délai.
MsgWaitForMultipleObjectsEx | user32.dll | Cette fonction permet de retourner un objet spécifié suite à un état, un type spécifié étant disponible de l'entrée de la file d'attente d'un processus léger ou intervalle de dépassement de délai avec des paramètres supplémentaires.
MulDiv | kernel32.dll | Cette fonction permet de diviser le produit de deux entiers long
MultiByteToWideChar | kernel32.dll | Cette fonction permet de convertir une chaine de caractères ASCII en chaine de caractères Unicode.
MultinetGetConnectionPerformanceA | mpr.dll | Cette fonction permet de demander les informations à propos des performances attendu d'une connexion utilisé pour l'accès à une ressource de réseau.
MultinetGetConnectionPerformanceW | mpr.dll | Cette fonction permet de demander les informations à propos des performances attendu d'une connexion utilisé pour l'accès à une ressource de réseau avec des paramètres de chaine de caractères étendues (Unicode).
NotifyChangeEventLog | advapi32.dll | Cette fonction permet de recevoir des avertissements d'application lorsqu'un événement écrit dans le fichier de journal de bord spécifié.
ObjectCloseAuditAlarmA | advapi32.dll | Cette fonction permet de généré des messages dans le journal de bord quand un identificateur Handle d'objet est supprimé.
ObjectCloseAuditAlarmW | advapi32.dll | Cette fonction permet de généré des messages dans le journal de bord quand un identificateur Handle d'objet est supprimé avec des paramètres de chaine de caractères étendue (Unicode).
ObjectDeleteAuditAlarmA | advapi32.dll | Cette fonction permet de supprimer un message dans le journal de bord.
ObjectDeleteAuditAlarmW | advapi32.dll | Cette fonction permet de supprimer un message dans le journal de bord avec des paramètres de chaine de caractères étendue (Unicode).
ObjectOpenAuditAlarmA | advapi32.dll | Cette fonction permet de générer des messages dans le journal de bord quand une application client tente d'obtenir l'accès à un objet ou dans créer un nouveau.
ObjectOpenAuditAlarmW | advapi32.dll | Cette fonction permet de générer des messages dans le journal de bord quand une application client tente d'obtenir l'accès à un objet ou dans créer un nouveau avec des paramètres de chaine de caractères étendue (Unicode).
ObjectPrivilegeAuditAlarmA | advapi32.dll | Cette fonction permet de générer un message dans le journal de bord quand un résultat d'un client est effectué avec des opérations de privilège sur un serveur d'application déjà ouvert avec l'identificateur Handle de l'objet.
ObjectPrivilegeAuditAlarmW | advapi32.dll | Cette fonction permet de générer un message dans le journal de bord quand un résultat d'un client est effectué avec des opérations de privilège sur un serveur d'application déjà ouvert avec l'identificateur Handle de l'objet avec des paramètres de chaine de caractères étendue (Unicode).
OemKeyScan | user32.dll | Cette fonction permet de demander le code ASCII OEM entre 0 et FFh situé dans les codes de balayage et des touches états (Ctrl, Alt et Shift).
OemToCharA | user32.dll | Cette fonction permet d'effectuer la conversion d'une chaine de caractères contenant un ensemble de caractères OEM vers du ANSI ou du Unicode.
OemToCharBuffA | user32.dll | Cette fonction permet d'effectuer la conversion d'un certain nombre de caractères OEM vers du ANSI ou du Unicode.
OemToCharBuffW | user32.dll | Cette fonction permet d'effectuer la conversion d'un certain nombre de caractères OEM vers du ANSI ou du Unicode avec des paramètres de chaine de caractères étendues (Unicode).
OemToCharW | user32.dll | Cette fonction permet d'effectuer la conversion d'une chaine de caractères contenant un ensemble de caractères OEM vers du ANSI ou du Unicode avec des paramètres de chaine de caractères étendues (Unicode).
OffsetClipRgn | gdi32.dll | Cette fonction permet de déplacer la région de clip dans le périphérique spécifié et par le déplacement spécifié.
OffsetRect | user32.dll | Cette fonction permet de déplacer le rectangle spécifié avec le nombre de déplacements spécifié.
OffsetRgn | gdi32.dll | Cette fonction permet de déplacer la région spécifié par le déplacement spécifié.
OffsetViewportOrgEx | gdi32.dll | Cette fonction permet de modifier le point de vue d'origine relatif pour un périphérique de contexte en utilisant le déplacement horizontal et vertical spécifié.
OffsetWindowOrgEx | gdi32.dll | Cette fonction permet de modifier le point de vue de la fenêtre d'origine relatif de la valeur courante.
OpenBackupEventLogA | advapi32.dll | Cette fonction permet d'ouvrir un identificateur Handle pour un événement de copie de sauvegarde du journal de bord.
OpenBackupEventLogW | advapi32.dll | Cette fonction permet d'ouvrir un identificateur Handle pour un événement de copie de sauvegarde du journal de bord avec des paramètres de chaine de caractères étendue (Unicode).
OpenClipboard | user32.dll | Cette fonction permet de commencer un traitement avec le presse-papier.
OpenDesktopA | user32.dll | Cette fonction permet de demander le Handle d'un bureau existant.
OpenDesktopW | user32.dll | Cette fonction permet de demander le Handle d'un bureau existant avec des paramètres de chaine de caractères étendues (Unicode).
OpenEventA | kernel32.dll | Cette fonction permet de demander un Handle dans objet existant d'événement nommé.
OpenEventW | kernel32.dll | Cette fonction permet de demander un Handle dans objet existant d'événement nommé avec des paramètres de chaines de caractères étendue (Unicode).
OpenEventLogA | advapi32.dll | Cette fonction permet d'ouvrir un identificateur Handle d'un événement de journal de bord.
OpenEventLogW | advapi32.dll | Cette fonction permet d'ouvrir un identificateur Handle d'un événement de journal de bord avec des paramètres de chaine de caractères étendue (Unicode).
OpenFile | kernel32.dll | Cette fonction permet de créer, d'ouvrir, de réouvrir ou de supprimer un fichier.
OpenFileMappingA | kernel32.dll | Cette fonction permet d'ouvrir un objet de cartographie de fichier nommé.
OpenFileMappingW | kernel32.dll | Cette fonction permet d'ouvrir un objet de cartographie de fichier nommé avec des paramètres de chaine de caractères étendue (Unicode).
OpenIcon | user32.dll | Cette fonction permet de passer en mode actif l'icône d'une fenêtre.
OpenInputDesktop | user32.dll | Cette fonction permet de demander le Handle d'un bureau recevant une entrée utilisateur.
OpenMutexA | kernel32.dll | Cette fonction permet d'ouvrir un objet Mutex nommé.
OpenMutexW | kernel32.dll | Cette fonction permet d'ouvrir un objet Mutex nommé avec des paramètres de chaine de caractères étendue (Unicode).
OpenPrinterA | winspool.drv | Cette fonction permet d'ouvrir la communication avec une imprimante.
OpenProcess | kernel32.dll | Cette fonction permet d'ouvrir un accès de jeton associé avec un processus.
OpenProcessToken | advapi32.dll | Cette fonction permet d'ouvrir un accès de jeton associé avec un processus.
OpenSemaphoreA | kernel32.dll | Cette fonction permet de retourner le Handle d'objet existant de sémaphore nommé.
OpenSemaphoreW | kernel32.dll | Cette fonction permet de retourner le Handle d'objet existant de sémaphore nommé avec des paramètres de chaine de caractères étendue (Unicode).
OpenThreadToken | advapi32.dll | Cette fonction permet d'ouvrir un accès de jeton associé avec un processus léger.
OpenWaitableTimerA | kernel32.dll | Cette fonction permet d'ouvrir une minuterie d'attente existante nommé.
OpenWaitableTimerW | kernel32.dll | Cette fonction permet d'ouvrir une minuterie d'attente existante nommé avec des paramètres de chaine de caractères étendue (Unicode).
OpenWindowStationA | user32.dll | Cette fonction permet de demander le Handle d'une fenêtre de station existante.
OpenWindowStationW | user32.dll | Cette fonction permet de demander le Handle d'une fenêtre de station existante avec des paramètres de chaine de caractères étendues (Unicode).
OutputDebugStringA | kernel32.dll | Cette fonction permet d'envoyer une chaine de caractères au débogueur de l'application courante.
OutputDebugStringW | kernel32.dll | Cette fonction permet d'envoyer une chaine de caractères au débogueur de l'application courante avec des paramètres de chaine de caractères étendue (Unicode).
PackDDElParam | user32.dll | Cette fonction permet de compacté la valeur DDE spécifié dans une structure interne utilisé dans le partage de données DDE entre le traitement de processus.
PaintDesktop | user32.dll | Cette fonction permet de remplir le bureau avec une couleur ou un papier-peint.
PaintRgn | gdi32.dll | Cette fonction permet de remplir une région, en utilisant la brosse courante, pour un périphérique de contexte spécifié.
PatBlt | gdi32.dll | Cette fonction permet de créer une palette de bits pour un périphérique spécifié.
PathAddBackslashA | shlwapi.dll | Cette fonction permet d'ajouter une barre oblique inversé à la fin du chemin de répertoire spécifié.
PathAddExtension | shlwapi.dll | Cette fonction permet d'ajouter une extension à nom de fichiers.
PathAppendA | shlwapi.dll | Cette fonction permet d'ajouter un chemin de répertoire à la fin d'un autre chemin de répertoire.
PathBuildRootA | shlwapi.dll | Cette fonction permet de créer un répertoire racine pour unité disque spécifié.
PathCanonicalizeA | shlwapi.dll | Cette fonction permet de transformer un chemin de répertoire de sa forme absolue à relative, c'est-à-dire de remplacer des "../" pour atteinte le répertoire en court par exemple.
PathCombine | shlwapi.dll | Cette fonction permet d'ajouter un chemin de répertoire à la fin d'un autre chemin de répertoire.
PathCommonPrefix | shlwapi.dll | Cette fonction permet d'effectuer la comparaison de deux répertoires et de vérifier les préfixes communs.
PathCompactPathA | shlwapi.dll | Cette fonction permet de réduire la longueur en pixel d'un chemin de répertoire en remplaçant la partie trop longue par des abréviations pour qu'il soit affichable à l'écran par exemple.
PathCompactPathExA | shlwapi.dll | Cette fonction permet de réduire la longueur en caractères d'un chemin de répertoire en remplaçant la partie trop longue par des abréviations pour qu'il soit affichable à l'écran par exemple.
PathCreateFromUrlA | shlwapi.dll | Cette fonction permet de convertir un URL sous sa forme du système d'exploitation de style DOS.
PathFindOnPathA | shlwapi.dll | Cette fonction permet d'effectuer la recherche d'un nom de fichier dans un répertoire.
PathGetDriveNumberA | shlwapi.dll | Cette fonction permet de demander le numéro de l'unité disque contenu dans un chemin de répertoire.
PathIsDirectoryEmptyA | shlwapi.dll | Cette fonction permet de demander si le répertoire spécifier est vide.
PathIsSystemFolder | shlwapi.dll | Cette fonction permet de demander si le répertoire spécifier à l'attribut de dossier système.
PathIsUNCA | shlwapi.dll | Cette fonction permet de demander si le répertoire est un répertoire UNC (Universal Naming Convention) valide.
PathIsUNCServerA | shlwapi.dll | Cette fonction permet de demander si le répertoire est un répertoire UNC (Universal Naming Convention) valide pour un serveur.
PathIsURLA | shlwapi.dll | Cette fonction permet de demander si le répertoire est un répertoire URL valide.
PathToRegion | gdi32.dll | Cette fonction permet de créer un chemin vers une région sélectionné dans le périphérique de contexte spécifié.
PathUndecorateA | shlwapi.dll | Cette fonction permet d'illiminer les séquences à numéro d'un nom fichier.
PathUnmakeSystemFolderA | shlwapi.dll | Cette fonction permet d'enlever l'attribut système d'un répertoire spécifié.
PdhAddCounterA | pdh.dll | Cette fonction permet d'ajouter le compteur spécifié à la requête pour les compteurs de performance.
PdhAddCounterW | pdh.dll | Cette fonction permet d'ajouter le compteur spécifié à la requête pour les compteurs de performance avec des paramètres de chaine de caractères étendue (Unicode).
PdhAddEnglishCounterA | pdh.dll | Cette fonction permet d'ajouter un compteur dans un langage humain neutre à la requête pour le compteur de performance.
PdhAddEnglishCounterW | pdh.dll | Cette fonction permet d'ajouter un compteur dans un langage humain neutre à la requête pour le compteur de performance avec des paramètres de chaine de caractères étendue (Unicode).
PdhAddRelogCounter | pdh.dll | Cette fonction permet d'effectuer la liaison d'un ou plusieurs fichiers binaires de journal de bord afin d'obtenir un ensemble dans le but de lire les données.
PdhAddV1Counter | pdh.dll | Cette fonction permet d'ajouter la première valeur pour le compteur de performance.
PdhAddV2Counter | pdh.dll | Cette fonction permet d'ajouter la seconde valeur pour le compteur de performance.
PdhBindInputDataSourceA | pdh.dll | Cette fonction permet d'effectuer la liaison d'un ou plusieurs fichiers binaires de journal de bord source afin d'obtenir un ensemble dans le but de lire les données.
PdhBindInputDataSourceW | pdh.dll | Cette fonction permet d'effectuer la liaison d'un ou plusieurs fichiers binaires de journal de bord source afin d'obtenir un ensemble dans le but de lire les données avec des paramètres de chaine de caractères étendue (Unicode).
PdhBrowseCountersA | pdh.dll | Cette fonction permet d'afficher une boite de dialogue de navigation de compteur que l'utilisateur peut utiliser afin de sélectionner un ou plusieurs compteurs quand il l'ajoute à la requête.
PdhBrowseCountersHA | pdh.dll | Cette fonction permet d'afficher une boite de dialogue de navigation de compteur que l'utilisateur peut utiliser afin de sélectionner un ou plusieurs compteurs quand il l'ajoute à la requête en utilisant un Handle.
PdhBrowseCountersHW | pdh.dll | Cette fonction permet d'afficher une boite de dialogue de navigation de compteur que l'utilisateur peut utiliser afin de sélectionner un ou plusieurs compteurs quand il l'ajoute à la requête en utilisant un Handle avec des paramètres de chaine de caractères étendue (Unicode).
PdhBrowseCountersW | pdh.dll | Cette fonction permet d'afficher une boite de dialogue de navigation de compteur que l'utilisateur peut utiliser afin de sélectionner un ou plusieurs compteurs quand il l'ajoute à la requête avec des paramètres de chaine de caractères étendue (Unicode).
PdhCalculateCounterFromRawValue | pdh.dll | Cette fonction permet d'effectuer le calcul des valeurs affichables de 2 valeurs brutes de compteur.
PdhCloseLog | pdh.dll | Cette fonction permet d'effectuer la fermeture d'un fichier de journal bord spécifié.
PdhCloseQuery | pdh.dll | Cette fonction permet de fermer toutes les compteurs contenant la requête spécifié, ferme tous les gestionnaires ayant la requête et libère toute la mémoire associé avec cette requête.
PdhCollectQueryData | pdh.dll | Cette fonction permet de collecter la donnée de valeur brute courante pour tous les compteurs dans la requête spécifié et met à jour le code d'état pour chaque compteur.
PdhCollectQueryDataEx | pdh.dll | Cette fonction permet d'utiliser un processus léger séparant la donnée de valeur brute courante pour tous les compteurs dans la requête spécifié.
PdhCollectQueryDataWithTime | pdh.dll | Cette fonction permet de collecter la données de valeur brute courante pour tous les compteurs dans la requête spécifié et met à jour le code d'état pour chaque compteur.
PdhComputeCounterStatistics | pdh.dll | Cette fonction permet d'effectuer les calculs statistiques pour un compteur dans un tableau de valeurs brute.
PdhConnectMachineA | pdh.dll | Cette fonction permet d'effectuer une connexion vers l'ordinateur spécifié pour les compteurs de performance.
PdhConnectMachineW | pdh.dll | Cette fonction permet d'effectuer une connexion vers l'ordinateur spécifié pour les compteurs de performance avec des paramètres de chaine de caractères étendue (Unicode).
PdhCreateSQLTablesA | pdh.dll | Cette fonction permet de créer des tables SQL pour le compteur performance.
PdhCreateSQLTablesW | pdh.dll | Cette fonction permet de créer des tables SQL pour le compteur performance avec des paramètres de chaine de caractères étendue (Unicode).
PdhEnumObjectItemsA | pdh.dll | Cette fonction permet de demander l'objet de compteur spécifié et les noms d'instance existant dans l'ordinateur spécifié ou le fichier de journal de bord spécifié.
PdhEnumObjectItemsW | pdh.dll | Cette fonction permet de demander l'objet de compteur spécifié et les noms d'instance existant dans l'ordinateur spécifié ou le fichier de journal de bord spécifié avec des paramètres de chaine de caractères étendue (Unicode).
PeekConsoleInputA | kernel32.dll | Cette fonction permet d'effectuer la lecture des données du tampon d'entrée de la console spécifié sans retirer le contenu lue du tampon.
PeekConsoleInputW | kernel32.dll | Cette fonction permet d'effectuer la lecture des données du tampon d'entrée de la console spécifié sans retirer le contenu lue du tampon avec des paramètres de chaine de caractères étendue (Unicode).
PeekMessageA | user32.dll | Cette fonction permet de poster un message dans une fenêtre de file d'attente de message et retourne sans attendre la correspondance à un processus de message.
PeekMessageW | user32.dll | Cette fonction permet de poster un message dans une fenêtre de file d'attente de message et retourne sans attendre la correspondance à un processus de message avec des paramètres de chaine de caractères étendue (Unicode).
PeekNamedPipe | kernel32.dll | Cette fonction permet de copier les données d'un tuyau nommé ou anonyme dans un tampon sans le retirer du tuyau.
Pie | gdi32.dll | Cette fonction permet de dessiner une pointe de tarte en effectuant un arc elliptique d'un centre et de deux points joins par des lignes.
PlayEnhMetaFile | gdi32.dll | Cette fonction permet d'afficher l'image entreposé dans le fichier méta de format étendue spécifié.
PlayEnhMetaFileRecord | gdi32.dll | Cette fonction permet de jouer un enregistrement de fichier méta étendue par exécution de fonction GDI (Graphics Device Interface) identifié par l'enregistrement.
PlayMetaFile | gdi32.dll | Cette fonction permet de jouer le contenu d'un fichier méta de format Windows spécifié dans un périphérique spécifié.
PlayMetaFileRecord | gdi32.dll | Cette fonction permet de jouer un enregistrement d'un fichier méta de format Windows par exécution du GDI contenu dans l'enregistrement.
PlaySoundA | winmm.dll | Cette fonction permet de faire jouer un fichier de son de format Wave (.WAV).
PlgBlt | gdi32.dll | Cette fonction permet d'effectuer un traitement de transfert de bloc de bits d'une donnée de bits de couleurs d'un rectangle spécifié dans une source de périphérique de contexte vers la destination de périphérique de contexte de parallélogramme spécifié.
PolyBezier | gdi32.dll | Cette fonction permet de dessiner une ou plusieurs courbes de Bézier.
PolyBezierTo | gdi32.dll | Cette fonction permet de dessiner une ou plusieurs courbes de Bézier spécifié.
PolyDraw | gdi32.dll | Cette fonction permet de dessiner un ensemble de ligne de segments et de courbes de Bézier.
PolyPolygon | gdi32.dll | Cette fonction permet de créer deux ou plusieurs polygone étant rempli par un mode de remplissage de polygone.
PolyTextOutA | gdi32.dll | Cette fonction permet de dessiner une chaine de caractères en utilisant la police de caractères et les couleurs textes courante dans le périphérique de contexte spécifié.
PolyTextOutW | gdi32.dll | Cette fonction permet de dessiner une chaine de caractères en utilisant la police de caractères et les couleurs textes courante dans le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues.
Polygon | gdi32.dll | Cette fonction permet de dessiner un polygone de deux ou plusieurs points (sommets) connectés par des lignes.
Polyline | gdi32.dll | Cette fonction permet de dessiner un ensemble de segments de lignes, connecté par les points spécifiés.
PolylineTo | gdi32.dll | Cette fonction permet de dessiner une ou plusieurs lignes droite.
PostMessageA | user32.dll | Cette fonction permet d'envoyer un message à un objet du système d'exploitation Windows.
PostMessageW | user32.dll | Cette fonction permet d'envoyer un message à un objet du système d'exploitation Windows avec des paramètres de chaine de caractères étendues (Unicode).
PostQueuedCompletionStatus | kernel32.dll | Cette fonction permet de poster une paquet d'achèvement d'entrée/sortie vers un port d'achèvement d'entrée/sortie.
PostQuitMessage | user32.dll | Cette fonction permet de poster un message à Windows afin d'indiquer que l'application reçoit une requête de terminaison d'exécution (quitte).
PostThreadMessageA | user32.dll | Cette fonction permet de poster un message dans la file d'attente du processus léger spécifié et retourne sans attendre que le processus léger traite le message.
PostThreadMessageW | user32.dll | Cette fonction permet de poster un message dans la file d'attente du processus léger spécifié et retourne sans attendre que le processus léger traite le message avec des paramètres de chaine de caractères étendues (Unicode).
PrepareTape | kernel32.dll | Cette fonction permet de préparer le ruban pour être accédé ou enlevé.
PrintDlgA | comdlg32.dll | Cette fonction permet d'afficher une boite de dialogue d'impression.
PrinterProperties | winspool.drv | Cette fonction permet d'afficher une boite de dialogue de propriété de l'imprimante.
PrivilegeCheck | advapi32.dll | Cette fonction permet de tester le contexte de sécurité représenté par un accès de jeton spécifié contenu dans un privilège spécifié.
PrivilegedServiceAuditAlarmA | advapi32.dll | Cette fonction permet de générer un message de journal de bord quand une opération de service de privilège système s'effectue.
PrivilegedServiceAuditAlarmW | advapi32.dll | Cette fonction permet de générer un message de journal de bord quand une opération de service de privilège système s'effectue avec des paramètres de chaine de caractères étendue (Unicode).
Process32First | kernel32.dll | Cette fonction permet de demander le premier processus provenant de la liste contenu dans une photo du système d'exploitation.
Process32Next | kernel32.dll | Cette fonction permet de demander le processus suivant provenant de la liste contenu dans une photo du système d'exploitation.
PtInRect | user32.dll | Cette fonction permet de déterminer si le point spécifié est lié avec le rectangle spécifié.
PtInRegion | gdi32.dll | Cette fonction permet de demander si un point spécifié est dans une région spécifié.
PtVisible | gdi32.dll | Cette fonction permet de demander si le point spécifié est dans la région clip d'un périphérique de contexte.
PulseEvent | kernel32.dll | Cette fonction permet de fournir une simple opération fixant l'état d'un objet d'événement spécifié et réinitialisant après qu'un délai d'attente de processus approprié s'est produit.
PurgeComm | kernel32.dll | Cette fonction permet de débarrasser de tous les caractères d'un tampon de sortie ou d'entrée d'une ressource de communication spécifié.
PwdChangePasswordA | mpr.dll | Cette fonction permet de modifier le mot de passe de l'utilisateur ou d'un fournisseur du système d'exploitation.
QueryDosDeviceA | kernel32.dll | Cette fonction permet à une application de demander des informations à propre d'un nom de périphérique DOS.
QueryDosDeviceW | kernel32.dll | Cette fonction permet à une application de demander des informations à propre d'un nom de périphérique DOS avec des paramètres de chaine de caractères étendue (Unicode).
QueryPerformanceCounter | kernel32.dll | Cette fonction permet de demander la valeur actuel du compteur de haute performance de la machine.
QueryPerformanceFrequency | kernel32.dll | Cette fonction permet de demander la valeur de la fréquence du compteur de haute performance de la machine.
QueueUserAPC | kernel32.dll | Cette fonction permet d'ajouter une objet de procédure d'appel désynchronisée (APC) en mode utilisateur dans une file d'attente APC d'un processus léger spécifié.
RaiseException | kernel32.dll | Cette fonction permet de déclencher une exception dans le processus léger appelant.
RasEnumEntriesA | rasapi32.dll | Cette fonction permet de demander la liste de tous les noms d'entrées contenu dans le carnet pour les connexions téléphoniques à distance.
ReadConsoleA | kernel32.dll | Cette fonction permet d'effectuer la lecture d'un caractère en provenance de la console.
ReadConsoleW | kernel32.dll | Cette fonction permet d'effectuer la lecture d'un caractère en provenance de la console avec des paramètres de chaine de caractères étendue (Unicode).
ReadConsoleInputA | kernel32.dll | Cette fonction permet d'effectuer la lecture de données du tampon d'entrée d'une console et retire les données du tampon.
ReadConsoleInputW | kernel32.dll | Cette fonction permet d'effectuer la lecture de données du tampon d'entrée d'une console et retire les données du tampon avec des paramètres de chaine de caractères étendue (Unicode).
ReadConsoleOutputA | kernel32.dll | Cette fonction permet d'effectuer la lecture de données de caractère et de couleur d'attribut dans un bloc rectangulaire d'une cellule de caractères d'un tampon de console d'écran et écrire le résultat de ses données dans un tampon spécifié.
ReadConsoleOutputW | kernel32.dll | Cette fonction permet d'effectuer la lecture de données de caractère et de couleur d'attribut dans un bloc rectangulaire d'une cellule de caractères d'un tampon de console d'écran et écrire le résultat de ses données dans un tampon spécifié avec des paramètres de chaine de caractères étendue (Unicode).
ReadConsoleOutputAttribute | kernel32.dll | Cette fonction permet de copier le nombre spécifié dans la couleur d'attribut d'arrière-plan ou de premier plan d'une cellule consécutive d'un tampon de console d'écran en débutant à la position spécifié.
ReadConsoleOutputCharacterA | kernel32.dll | Cette fonction permet de copier un nombre de caractères d'une cellule consécutif d'un tampon de console écran en débutant à la position spécifié.
ReadConsoleOutputCharacterW | kernel32.dll | Cette fonction permet de copier un nombre de caractères d'une cellule consécutif d'un tampon de console écran en débutant à la position spécifié avec des paramètres de chaine de caractères étendue (Unicode).
ReadDirectoryChangesW | kernel32.dll | Cette fonction permet de demander les informations descriptives de changement ayant eu lieu dans le répertoire spécifié.
ReadEventLogA | advapi32.dll | Cette fonction permet de lire un nombre d'entrées spécifié dans un journal de bord des événements.
ReadEventLogW | advapi32.dll | Cette fonction permet de lire un nombre d'entrées spécifié dans un journal de bord des événements avec des paramètres de chaine de caractères étendue (Unicode).
ReadFile | kernel32.dll | Cette fonction permet d'effectuer la lecture d'un fichier, en débutant à la position spécifié par le pointeur de fichier.
ReadFileEx | kernel32.dll | Cette fonction permet d'effectuer la lecture de données d'un fichier désynchronisé.
ReadProcessMemory | kernel32.dll | Cette fonction permet d'effectuer la lecture de mémoire dans un processus spécifié.
RealizePalette | gdi32.dll | Cette fonction permet de cartographier l'entrée de palette de la palette logique courante de la palette système.
Rectangle | gdi32.dll | Cette fonction permet d'afficher un rectangle.
RectInRegion | gdi32.dll | Cette fonction permet de demander si une partie du rectangle spécifié est dans une des limites d'une région spécifié.
RectVisible | gdi32.dll | Cette fonction permet de demander n'importe quel partie d'un rectangle spécifié dans une région de clip d'un périphérique de contexte spécifié.
RedrawWindow | user32.dll | Cette fonction permet de mettre à jour le rectangle ou la région spécifié de la région de la fenêtre client.
RegCloseKey | advapi32.dll | Cette fonction permet de fermer le Handle de la clef de registre spécifié.
RegConnectRegistryA | advapi32.dll | Cette fonction permet d'établir une connexion avec un registre de Handle prédéfinie ou autre ordinateur.
RegConnectRegistryW | advapi32.dll | Cette fonction permet d'établir une connexion avec un registre de Handle prédéfinie ou autre ordinateur avec des paramètres de chaine de caractères étendue (Unicode).
RegCreateKeyA | advapi32.dll | Cette fonction permet de créer la clef de registre spécifié. Si la clef existe dans les registres, la fonction l'ouvre.
RegCreateKeyW | advapi32.dll | Cette fonction permet de créer la clef de registre spécifié avec des paramètres de chaine de caractères étendue (Unicode). Si la clef existe dans les registres, la fonction l'ouvre.
RegCreateKeyExA | advapi32.dll | Cette fonction permet de créer une clef de registre spécifié avec des systèmes de la famille NT. Si la clef existe dans les registres, la fonction l'ouvre.
RegCreateKeyExW | advapi32.dll | Cette fonction permet de créer une clef de registre spécifié avec des systèmes de la famille NT avec des paramètres de chaine de caractères étendue (Unicode). Si la clef existe dans les registres, la fonction l'ouvre.
RegDeleteKeyA | advapi32.dll | Cette fonction permet de supprimer la clef de registre spécifié.
RegDeleteKeyW | advapi32.dll | Cette fonction permet de supprimer la clef de registre spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegDeleteValueA | advapi32.dll | Cette fonction permet de supprimer la valeur du nom spécifié dans la clef de la base de registre.
RegDeleteValueW | advapi32.dll | Cette fonction permet de supprimer la valeur du nom spécifié dans la clef de la base de registre avec des paramètres de chaine de caractères étendue (Unicode).
RegEnumKeyA | advapi32.dll | Cette fonction permet d'énuméré les sous-clefs d'une clef de registre ouverte spécifié.
RegEnumKeyW | advapi32.dll | Cette fonction permet d'énuméré les sous-clefs d'une clef de registre ouverte spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegEnumKeyExA | advapi32.dll | Cette fonction permet d'énuméré les sous-clefs d'une clef de registre ouverte spécifié avec des systèmes de la famille NT.
RegEnumKeyExW | advapi32.dll | Cette fonction permet d'énuméré les sous-clefs d'une clef de registre ouverte spécifié avec des systèmes de la famille NT avec des paramètres de chaine de caractères étendue (Unicode).
RegEnumValueA | advapi32.dll | Cette fonction permet d'énuméré les valeurs pour la clef de registre ouverte spécifié.
RegEnumValueW | advapi32.dll | Cette fonction permet d'énuméré les valeurs pour la clef de registre ouverte spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegFlushKey | advapi32.dll | Cette fonction permet d'écrire tous les attributs de la clef de la base de registre ouverte spécifié.
RegGetKeySecurity | advapi32.dll | Cette fonction permet de copier le descripteur de sécurité de la clef de registre ouverte spécifié.
RegisterClassA | user32.dll | Cette fonction permet d'effectuer l'enregistrement d'une classe de fenêtre subséquente aux appels des fonctions CreateWindow ou CreateWindowEx.
RegisterClassExA | user32.dll | Cette fonction permet d'effectuer l'enregistrement d'une classe de fenêtre subséquente aux appels des fonctions CreateWindow ou CreateWindowEx avec des options supplémentaires.
RegisterClassExW | user32.dll | Cette fonction permet d'effectuer l'enregistrement d'une classe de fenêtre subséquente aux appels des fonctions CreateWindow ou CreateWindowEx avec des options supplémentaires et des paramètres de chaine de caractères étendues (Unicode).
RegisterClassW | user32.dll | Cette fonction permet d'effectuer l'enregistrement d'une classe de fenêtre subséquente aux appels des fonctions CreateWindow ou CreateWindowEx avec des paramètres de chaine de caractères étendues (Unicode).
RegisterClipboardFormatA | user32.dll | Cette fonction permet d'enregistrer un nouveau format de presse-papier.
RegisterClipboardFormatW | user32.dll | Cette fonction permet d'enregistrer un nouveau format de presse-papier avec des paramètres de chaine de caractères étendues (Unicode).
RegisterDeviceNotificationA | user32.dll | Cette fonction permet d'enregistrer un périphérique ou un type de périphérique pour que la fenêtre reçoivent des avertissements de changements.
RegisterHotKey | user32.dll | Cette fonction permet de définir l'état des touches de combinaison (Alt, Ctrl, Shift) pour le processus léger courant.
RegisterServiceProcess | kernel32.dll | Cette fonction permet de cacher un programme de façon à ce qu'il ne soit pas afficher lorsqu'on appuis sur Ctrl+Alt+Delete pour voir la liste des programmes dans le Gestionnaire de tâche.
RegisterWindowMessageA | user32.dll | Cette fonction permet de définir une nouvelle fenêtre de message garantissant qu'elle est unique au système.
RegisterWindowMessageW | user32.dll | Cette fonction permet de définir une nouvelle fenêtre de message garantissant qu'elle est unique au système avec des paramètres de chaine de caractères étendues (Unicode).
RegLoadKeyA | advapi32.dll | Cette fonction permet de créer une sous-clef dans «HKEY_USER» ou «HKEY_LOCAL_MACHINE» et d'entreposer les informations d'enregistrement dans le fichier spécifié d'une sous-clef.
RegLoadKeyW | advapi32.dll | Cette fonction permet de créer une sous-clef dans «HKEY_USER» ou «HKEY_LOCAL_MACHINE» et d'entreposer les informations d'enregistrement dans le fichier spécifié d'une sous-clef avec des paramètres de chaine de caractères étendue (Unicode).
RegNotifyChangeKeyValue | advapi32.dll | Cette fonction permet d'indiquer quand une clef de registre, ou élément rattaché à celle-ci, a changé.
RegOpenKeyA | advapi32.dll | Cette fonction permet d'ouvrir une clef spécifié dans une base de registre.
RegOpenKeyW | advapi32.dll | Cette fonction permet d'ouvrir une clef spécifié dans une base de registre avec des paramètres de chaine de caractères étendue (Unicode).
RegOpenKeyExA | advapi32.dll | Cette fonction permet d'ouvrir une clef spécifié dans une base de registre.
RegOpenKeyExW | advapi32.dll | Cette fonction permet d'ouvrir une clef spécifié dans une base de registre avec des paramètres de chaine de caractères étendue (Unicode).
RegQueryInfoKeyA | advapi32.dll | Cette fonction permet de demander les informations d'une clef de registre spécifié.
RegQueryInfoKeyW | advapi32.dll | Cette fonction permet de demander les informations d'une clef de registre spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegQueryMultipleValuesA | advapi32.dll | Cette fonction permet de demander le type et la donnée pour une liste de noms de valeur associé avec une clef de registre ouverte.
RegQueryMultipleValuesW | advapi32.dll | Cette fonction permet de demander le type et la donnée pour une liste de noms de valeur associé avec une clef de registre ouverte avec des paramètres de chaine de caractères étendue (Unicode).
RegQueryValueA | advapi32.dll | Cette fonction permet de demander la valeur associé avec une valeur non-nommé pour la clef du registre spécifié.
RegQueryValueW | advapi32.dll | Cette fonction permet de demander la valeur associé avec une valeur non-nommé pour la clef du registre spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegQueryValueExA | advapi32.dll | Cette fonction permet de demander la valeur associé avec une valeur non-nommé pour la clef du registre spécifié avec des systèmes de la famille NT.
RegQueryValueExW | advapi32.dll | Cette fonction permet de demander la valeur associé avec une valeur non-nommé pour la clef du registre spécifié avec des systèmes de la famille NT avec des paramètres de chaine de caractères étendue (Unicode).
RegReplaceKeyA | advapi32.dll | Cette fonction permet de remplacer un fichier de copie de sauvegarde d'un clef et tous les sous-clef d'une autre fichier.
RegReplaceKeyW | advapi32.dll | Cette fonction permet de remplacer un fichier de copie de sauvegarde d'un clef et tous les sous-clef d'une autre fichier avec des paramètres de chaine de caractères étendue (Unicode).
RegRestoreKeyA | advapi32.dll | Cette fonction permet de lire des informations registre dans un fichier spécifié et de copier la clef spécifié.
RegRestoreKeyW | advapi32.dll | Cette fonction permet de lire des informations registre dans un fichier spécifié et de copier la clef spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegSaveKeyA | advapi32.dll | Cette fonction permet de sauvegarder tous les clefs, sous-clefs et les valeurs spécifié dans un nouveau fichier.
RegSaveKeyW | advapi32.dll | Cette fonction permet de sauvegarder tous les clefs, sous-clefs et les valeurs spécifié dans un nouveau fichier avec des paramètres de chaine de caractères étendue (Unicode).
RegSetKeySecurity | advapi32.dll | Cette fonction permet fixer la sécurité d'une clef de registre ouvert.
RegSetValueA | advapi32.dll | Cette fonction permet d'associer une valeur avec une clef spécifié.
RegSetValueW | advapi32.dll | Cette fonction permet d'associer une valeur avec une clef spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegSetValueExA | advapi32.dll | Cette fonction permet d'entreposer les données d'un champs de valeur d'une clef de registre ouvert.
RegSetValueExW | advapi32.dll | Cette fonction permet d'entreposer les données d'un champs de valeur d'une clef de registre ouvert avec des paramètres de chaine de caractères étendue (Unicode).
RegUnLoadKeyA | advapi32.dll | Cette fonction permet de décharger la clef et sous-clefs de registre spécifié
RegUnLoadKeyW | advapi32.dll | Cette fonction permet de décharger la clef et sous-clefs de registre spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegisterEventSourceA | advapi32.dll | Cette fonction permet de retourner l'identificateur Handle utilisé avec la fonction d'événement «ReportEvent» du journal de bord.
RegisterEventSourceW | advapi32.dll | Cette fonction permet de retourner l'identificateur Handle utilisé avec la fonction d'événement «ReportEvent» du journal de bord avec des paramètres de chaine de caractères étendue (Unicode).
ReleaseCapture | user32.dll | Cette fonction permet de relâcher la capture de souris et de restituer l'entrée de traitement normal.
ReleaseDC | user32.dll | Cette fonction permet de relâcher un périphérique de contexte, de libérer son utilisation pour les autres applications.
ReleaseMutex | kernel32.dll | Cette fonction permet de relâcher la propriété de l'objet Mutex spécifié.
ReleaseSemaphore | kernel32.dll | Cette fonction permet d'augmenter le compteur de l'objet de sémaphore spécifié par une quantité spécifié.
RemoveDirectoryA | kernel32.dll | Cette fonction permet de supprimer un répertoire.
RemoveDirectoryW | kernel32.dll | Cette fonction permet de supprimer un répertoire avec les paramètres de chaine de caractères étendues (Unicode).
RemoveDirectoryTransactedA | kernel32.dll | Cette fonction permet de supprimer un répertoire d'une opération de transaction.
RemoveDirectoryTransactedW | kernel32.dll | Cette fonction permet de supprimer un répertoire d'une opération de transaction avec des paramètres de chaine de caractères étendue (Unicode).
RemoveFontResourceA | gdi32.dll | Cette fonction permet d'enlever un ajout de ressource de police de caractères d'un fichier spécifié ou d'une table de police de caractères de Windows.
RemoveFontResourceW | gdi32.dll | Cette fonction permet d'enlever un ajout de ressource de police de caractères d'un fichier spécifié ou d'une table de police de caractères de Windows avec des paramètres de chaine de caractères étendues (Unicode).
RemoveMenu | user32.dll | Cette fonction permet de supprimer un item de menu déroulant.
RemovePropA | user32.dll | Cette fonction permet d'enlever une entrée de la liste de propriété de la fenêtre spécifié.
RemovePropW | user32.dll | Cette fonction permet d'enlever une entrée de la liste de propriété de la fenêtre spécifié avec des paramètres de chaine de caractères étendues (Unicode).
ReplyMessage | user32.dll | Cette fonction permet de répondre à un message envoyé par la fonction SendMessage sans rendre le contrôle à la fonction ayant appelé SendMessage.
ReportEventA | advapi32.dll | Cette fonction permet d'écrire une entrée à la fin du journal de bord des événements spécifié.
ReportEventW | advapi32.dll | Cette fonction permet d'écrire une entrée à la fin du journal de bord des événements spécifié avec des paramètres de chaine de caractères étendue (Unicode).
ResetDCA | gdi32.dll | Cette fonction permet de mettre à jour le périphérique de contexte, en se basant sur les informations de la structure spécifié.
ResetDCW | gdi32.dll | Cette fonction permet de mettre à jour le périphérique de contexte, en se basant sur les informations de la structure spécifié avec des paramètres de chaine de caractères étendues (Unicode).
ResetEvent | kernel32.dll | Cette fonction permet de fixer l'état de l'objet d'événement spécifié dans un sans signal.
ResizePalette | gdi32.dll | Cette fonction permet de changer la taille de la palette logique spécifié.
RestoreDC | gdi32.dll | Cette fonction permet de restaurer un périphérique de contexte à l'état précédent.
RestoreMyDocsFolder | mydocs.dll | Cette fonction permet de recréer l'icône de «Mes Documents» sur le bureau du système d'exploitation Windows.
ResumeThread | kernel32.dll | Cette fonction permet de décrémenter le compteur de processus léger suspendu.
ReuseDDElParam | user32.dll | Cette fonction permet d'allouer une application vers la réutilisation de paramètre DDE compacté spécifié et en réallouant un nouveau paquet spécifié.
RevertToSelf | advapi32.dll | Cette fonction permet de terminé la personnification d'une application client.
RtlFillMemory | kernel32.dll | Cette fonction permet de remplir une zone de mémoire avec une valeur spécifié.
RtlMoveMemory | kernel32.dll | Cette fonction permet de copier un bloc de mémoire vers un autre emplacement mémoire.
RoundRect | gdi32.dll | Cette fonction permet de dessiner un rectangle avec les coins arrondies, en utilisant le crayon courant.
SaveDC | gdi32.dll | Cette fonction permet de sauvegarder l'état courant du périphérique de contexte courant en copiant les informations d'état (clip de région, sélection d'objets, et mode de cartographie) dans la pile de contexte.
ScaleViewportExtEx | gdi32.dll | Cette fonction permet de modifier les extensions du point de vue relative avec des valeurs courante.
ScaleWindowExtEx | gdi32.dll | Cette fonction permet de modifier les extensions de la fenêtre de périphérique de contexte en utilisant le ratio formé par le multiplicateur et le diviseur spécifié.
ScreenToClient | user32.dll | Cette fonction permet de convertir les coordonnées d'écrans d'un point spécifié de l'écran à des coordonnées clients.
ScrollConsoleScreenBufferA | kernel32.dll | Cette fonction permet de déplacer un bloc de données dans un tampon d'écran.
ScrollConsoleScreenBufferW | kernel32.dll | Cette fonction permet de déplacer un bloc de données dans un tampon d'écran avec des paramètres de chaine de caractères étendues (Unicode).
ScrollDC | user32.dll | Cette fonction permet de faire défiler un rectangle d'un nombre de bits horizontal et vertical.
ScrollWindow | user32.dll | Cette fonction permet d'effectuer un défilement du contenu d'une région de fenêtre client.
ScrollWindowEx | user32.dll | Cette fonction permet d'effectuer un défilement du contenu d'une région de fenêtre client avec des options supplémentaires.
SearchPathA | kernel32.dll | Cette fonction permet d'effectuer une recherche dans le fichier spécifié.
SearchPathW | kernel32.dll | Cette fonction permet d'effectuer une recherche dans le fichier spécifié avec des paramètres de chaine de caractères étendues (Unicode).
SearchTreeForFile | imagehlp.dll | Cette fonction permet d'effectuer la recherche d'un fichier dans un arbre de répertoire.
SelectClipPath | gdi32.dll | Cette fonction permet de sélectionner le chemin courant dans la région de capture d'un périphérique de contexte en combinant la nouvelle région avec n'importe quel région de capture existante par utilisation de mode spécifié.
SelectClipRgn | gdi32.dll | Cette fonction permet de sélectionner une région spécifié et la capture de région courant pour un périphérique de contexte courant.
SelectObject | gdi32.dll | Cette fonction permet de sélectionner un objet dans le périphérique de contexte spécifié.
SelectPalette | gdi32.dll | Cette fonction permet de sélectionner la palette logique dans le périphérique de contexte donnée.
SendDlgItemMessageA | user32.dll | Cette fonction permet d'envoyer un message à un contrôle de boite de dialogue.
SendDlgItemMessageW | user32.dll | Cette fonction permet d'envoyer un message à un contrôle de boite de dialogue avec des paramètres de chaine de caractères étendues (Unidcode).
SendMessageA | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message à une fenêtre où à un objet d'une fenêtre.
SendMessageCallbackA | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message spécifié vers une ou des fenêtres.
SendMessageCallbackW | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message spécifié vers une ou des fenêtres avec des paramètres de chaine de caractères étendues (Unicode).
SendMessageTimeoutA | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message avec un dépassement de délai spécifié vers une ou des fenêtres.
SendMessageTimeoutW | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message avec un dépassement de délai spécifié vers une ou des fenêtres avec des paramètres de chaine de caractères étendues (Unicode).
SendMessageW | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message à une fenêtre où à un objet d'une fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
SendNotifyMessageA | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message d'avertissement spécifié vers une fenêtre.
SendNotifyMessageW | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message d'avertissement spécifié vers une fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
SetAbortProc | gdi32.dll | Cette fonction permet de fixer la procédure d'application définit par le programmeur pour alloué un travail d'impression afin d'être annuler durant sa tamporisation dans le tampon d'impression.
SetActiveWindow | user32.dll | Cette fonction permet de rendre le plus haut niveau d'une fenêtre spécifié en une fenêtre active.
SetAclInformation | advapi32.dll | Cette fonction permet de fixer les informations à propos de la liste de contrôle d'accès (ACL).
SetArcDirection | gdi32.dll | Cette fonction permet de fixer la direction du dessinage pour être utilisé dans les fonctions d'arc et de rectangle.
SetBitmapBits | gdi32.dll | Cette fonction permet de fixer l'ensemble de bits d'un Bitmap spécifié avec les valeurs de bits spécifié.
SetBitmapDimensionEx | gdi32.dll | Cette fonction permet de fixer la taille souhaité d'un Bitmap, dans une unité de mesure de 0,01 millimètre.
SetBkColor | gdi32.dll | Cette fonction permet de fixer la couleur de l'arrière-plan de la couleur spécifié.
SetBkMode | gdi32.dll | Cette fonction permet de fixer le mode d'arrière-plan spécifié.
SetBoundsRect | gdi32.dll | Cette fonction permet de contrôler l'accumulation d'informations de limite rectangulaire d'un périphérique de contexte.
SetBrushOrgEx | gdi32.dll | Cette fonction permet de fixer l'origine de la brosse GDI étant associé avec la prochaine brosse d'une application sélectionné dans le périphérique de contexte spécifié.
SetCapture | user32.dll | Cette fonction permet de fixer la capture de la souris dans la fenêtre spécifié.
SetCaretBlinkTime | user32.dll | Cette fonction permet de fixer le taux de clignotement du caret.
SetCaretPos | user32.dll | Cette fonction permet de fixer la position d'un caret.
SetClassLongA | user32.dll | Cette fonction permet de fixer des valeurs d'informations en 32 bits sur une classe.
SetClassLongW | user32.dll | Cette fonction permet de fixer des valeurs d'informations en 32 bits sur une classe avec des paramètres de chaine de caractères étendues (Unicode).
SetClassWord | user32.dll | Cette fonction permet de fixer la valeur d'un mot dans le déplacement spécifié de la classe de mémoire supplémentaire de la classe de fenêtre à laquelle la fenêtre appartient.
SetClipboardData | user32.dll | Cette fonction permet de fixer des données dans le presse-papier.
SetClipboardViewer | user32.dll | Cette fonction permet d'ajouter une fenêtre donnée à la chaine de fenêtre ayant un avertissement si le contenu du presse-papier a changé.
SetColorAdjustment | gdi32.dll | Cette fonction permet de fixer les valeurs de couleurs d'ajustements pour un périphérique de contexte utilisant les valeurs spécifiés.
SetColorSpace | gdi32.dll | Cette fonction permet de fixer l'espace de couleur du périphérique de contexte spécifié en définissant la fin des points d'un espace RVB (RGB) logique dans l'espace CIE XYZ.
SetCommBreak | kernel32.dll | Cette fonction permet de suspendre la transmission de caractères pour un périphérique de communications spécifié et place la ligne de transmission dans un état d'arrêt jusqu'à ce que la fonction ClearCommBreak soit appelée.
SetCommConfig | kernel32.dll | Cette fonction permet de fixer la configuration courante dans un périphérique de communication.
SetCommMask | kernel32.dll | Cette fonction permet de spécifier un ensemble d'événement être surveillé par un périphérique de communication.
SetCommState | kernel32.dll | Cette fonction permet de configurer un périphérique de communication en accord avec bloc de contrôle de périphérique (DCB) spécifié.
SetCommTimeouts | kernel32.dll | Cette fonction permet de fixer les paramètres de dépassement de délai pour tous les opérations de lecture ou d'écriture dans un périphérique de communication spécifié.
SetComputerNameA | kernel32.dll | Cette fonction permet de fixer le nom de l'ordinateur pour le système d'exploitation Windows.
SetComputerNameW | kernel32.dll | Cette fonction permet de fixer le nom de l'ordinateur pour le système d'exploitation Windows avec des paramètres de chaine de caractères étendues (Unicode).
SetConsoleActiveScreenBuffer | kernel32.dll | Cette fonction permet de fixer le tampon d'écran spécifié devant être actuellement affiché dans le tampon de la console d'écran.
SetConsoleCP | kernel32.dll | Cette fonction permet de fixer l'entrée de code de page utilisé par la console associé avec le processus appelant.
SetConsoleCtrlHandler | kernel32.dll | Cette fonction permet d'ajouter un d'enlever une définition d'application de la fonction HandlerRoutine de la liste des fonctions de gestionnaire pour un processus appelant.
SetConsoleCursorInfo | kernel32.dll | Cette fonction permet de fixer la taille et la visibilité du curseur dans le tampon de la console d'écran spécifié.
SetConsoleCursorPosition | kernel32.dll | Cette fonction permet de fixer la position du curseur pour l'affichage sur la console de texte.
SetConsoleMode | kernel32.dll | Cette fonction permet de fixer le mode d'entrée du tampon d'entrée de la console ou du mode de sortie d'un tampon de console d'écran.
SetConsoleOutputCP | kernel32.dll | Cette fonction permet de fixer le code de page de sortie utilisé par la console associé avec le processus appelant.
SetConsoleScreenBufferSize | kernel32.dll | Cette fonction permet de changer la taille d'un tampon de console d'écran spécifié.
SetConsoleTextAttribute | kernel32.dll | Cette fonction permet de fixer les attributs (couleur de fond et d'écriture) pour l'affichage sur la console de texte. C'est l'équivalent d'un octet d'attribut dans un écran de texte matériel.
SetConsoleTitleA | kernel32.dll | Cette fonction permet de fixer le titre de la barre de titre de la fenêtre d'application.
SetConsoleTitleW | kernel32.dll | Cette fonction permet de fixer le titre de la barre de titre de la fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
SetConsoleWindowInfo | kernel32.dll | Cette fonction permet de fixer la taille courante et la position de la fenêtre du tampon de la console d'écran.
SetCurrentDirectoryA | kernel32.dll | Cette fonction permet de fixer le répertoire courant du processus courant.
SetCurrentDirectoryW | kernel32.dll | Cette fonction permet de fixer le répertoire courant du processus courant avec des paramètres de chaine de caractères étendues (Unicode).
SetCursor | user32.dll | Cette fonction permet de fixer l'image du pointeur de la souris.
SetCursorPos | user32.dll | Cette fonction permet de fixer les coordonnées du pointeur de la souris.
SetDebugErrorLevel | user32.dll | Cette fonction permet de fxer le niveau d'erreur minimum dans chaque fenêtre étant généré par les événements de déboguage et passe celui-ci au débogueur.
SetDefaultCommConfigA | kernel32.dll | Cette fonction permet de fixer la configuration par défaut pour un périphérique de communication.
SetDefaultCommConfigW | kernel32.dll | Cette fonction permet de fixer la configuration par défaut pour un périphérique de communication avec des paramètres de chaine de caractères étendues (Unicode).
SetDeviceGammaRamp | gdi32.dll | Cette fonction permet de fixer la rampe gamma d'un panneau d'affichage de couleur directe.
SetDIBColorTable | gdi32.dll | Cette fonction permet de fixer les valeurs de couleurs RVB (rouge, vert, bleu) dans une rangée de table de couleurs d'un périphérique de Bitmap indépendant (DIB) étant actuellement sélectionné dans un périphérique de contexte spécifié.
SetDIBits | gdi32.dll | Cette fonction permet de fixer le pixel dans un Bitmap compatible (DDB) en utilisant les données de couleur trouvé dans le DIB spécifié.
SetDIBitsToDevice | gdi32.dll | Cette fonction permet de fixer les bits d'un périphérique de Bitmap indépendant (DIB) directement dans un périphérique de surface.
SetDlgItemInt | user32.dll | Cette fonction permet de fixer le texte d'un contrôle donnée dans une boite de dialogue vers la chaine de caractères de représentation spécifiant la valeur entière.
SetDlgItemTextA | user32.dll | Cette fonction permet de fixer le titre ou le texte d'un contrôle d'une boite de dialogue.
SetDlgItemTextW | user32.dll | Cette fonction permet de fixer le titre ou le texte d'un contrôle d'une boite de dialogue avec des paramètres de chaine de caractères étendues (Unicode).
SetDoubleClickTime | user32.dll | Cette fonction permet de fixer le temps maximal autorisé pour que des clics sur les boutons de la souris soit considéré comme un double-clic.
SetEndOfFile | kernel32.dll | Cette fonction permet de fixer la position du pointeur de fichier à la fin du fichier utilisant un Handle.
SetEnhMetaFileBits | gdi32.dll | Cette fonction permet de créer un fichier méta de format étendue, basé en mémoire, de données fournit.
SetEnvironmentVariableA | kernel32.dll | Cette fonction permet de fixer la valeur d'une variable d'environnement du système d'exploitation.
SetEnvironmentVariableW | kernel32.dll | Cette fonction permet de fixer la valeur d'une variable d'environnement du système d'exploitation avec des paramètres de chaine de caractères étendues (Unicode).
SetErrorMode | kernel32.dll | Cette fonction permet de contrôler comment le système d'exploitation gère les types sévères dans les erreurs sérieuses.
SetEvent | kernel32.dll | Cette fonction permet de fixer l'état de l'objet d'événement spécifié par un signal.
SetFileApisToANSI | kernel32.dll | Cette fonction permet de faire provoquer, à une série de fonctions de fichiers Win32, l'utilisation d'un ensemble de code de page de caractères ANSI.
SetFileApisToOEM | kernel32.dll | Cette fonction permet de faire provoquer, à une série de fonctions de fichiers Win32, l'utilisation d'un ensemble de code de page de caractères OEM.
SetFileAttributesA | kernel32.dll | Cette fonction permet de fixer les attributs d'un fichier ou d'un répertoire.
SetFileAttributesW | kernel32.dll | Cette fonction permet de fixer les attributs d'un fichier ou d'un répertoire avec des paramètres de chaine de caractères étendues (Unicode).
SetFilePointer | kernel32.dll | Cette fonction permet de déplacer un pointeur de ficher dans un fichier ouvert.
SetFileSecurityA | advapi32.dll | Cette fonction permet de fixer la sécurité d'un objet de fichier ou d'un répertoire.
SetFileSecurityW | advapi32.dll | Cette fonction permet de fixer la sécurité d'un objet de fichier ou d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
SetFileTime | kernel32.dll | Cette fonction permet de fixer la date et l'heure de la création, du dernière accès et de la dernière modification d'un fichier.
SetFocus | user32.dll | Cette fonction permet de fixer le focus d'entrée de la fenêtre spécifié.
SetForegroundWindow | user32.dll | Cette fonction permet de mettre le processus léger étant créer pour la fenêtre spécifié dans une fenêtre active ou de premier plan.
SetGraphicsMode | gdi32.dll | Cette fonction permet de fixer le mode graphique pour le périphérique de contexte spécifié.
SetHandleCount | kernel32.dll | Cette fonction permet de changer le nombre de fichier Handle disponible pour un processus.
SetHandleInformation | kernel32.dll | Cette fonction permet de fixer certaines propriétés d'un objet Handle.
SetICMMode | gdi32.dll | Cette fonction permet d'activer ou désactiver la correspondance de couleur d'image pour le périphérique de contexte spécifié.
SetICMProfileA | gdi32.dll | Cette fonction permet de fixer la couleur de profile pour le périphérique de contexte spécifié.
SetICMProfileW | gdi32.dll | Cette fonction permet de fixer la couleur de profile pour le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
SetJobA | winspool.drv | Cette fonction permet de fixer l'état du traitement d'un travail contenu dans le tampon d'impressions de l'imprimante.
SetKeyboardState | user32.dll | Cette fonction permet de fixer l'état des 256 touches virtuel de clavier.
SetKernelObjectSecurity | advapi32.dll | Cette fonction permet de fixer la sécurité de l'objet du noyau du système d'exploitation.
SetLastError | kernel32.dll | Cette fonction permet de fixer le code de la dernière erreur d'un appel de processus léger.
SetLastErrorEx | user32.dll | Cette fonction permet de fixer le code de la dernière erreur avec un type d'erreur.
SetLocalTime | kernel32.dll | Cette fonction permet de fixer la date et l'heure locale courante.
SetLocaleInfoA | kernel32.dll | Cette fonction permet de fixer un item d'information local.
SetLocaleInfoW | kernel32.dll | Cette fonction permet de fixer un item d'information local avec des paramètres de chaine de caractères étendues (Unicode).
SetMailslotInfo | kernel32.dll | Cette fonction permet de fixer la valeur de dépassement de délai utilisable pour le mailslot spécifié d'une opération de lecture.
SetMapMode | gdi32.dll | Cette fonction permet de fixer le mode de cartographie d'un périphérique de contexte spécifié.
SetMapperFlags | gdi32.dll | Cette fonction permet de changer la méthode utilisé pour la cartographie d'une police de caractères lors d'une conversion de police de caractères logique vers une police de caractères physique.
SetMenu | user32.dll | Cette fonction permet d'attribué un menu à une fenêtre.
SetMenuContextHelpId | user32.dll | Cette fonction permet d'associer un identificateur de contexte d'aide avec un menu.
SetMenuDefaultItem | user32.dll | Cette fonction permet de fixer l'item par défaut d'un menu déroulant.
SetMenuItemBitmaps | user32.dll | Cette fonction permet d'associer le Bitmap donnée avec un item de menu.
SetMenuItemInfoA | user32.dll | Cette fonction permet de modifier les informations conçernant un item de menu.
SetMenuItemInfoW | user32.dll | Cette fonction permet de modifier les informations conçernant un item de menu avec des paramètres de chaine de caractères étendues (Unicode).
SetMessageQueue | user32.dll | Cette fonction permet de créer un nouveau message dans la file d'attente.
SetMetaFileBitsEx | gdi32.dll | Cette fonction permet de créer un fichier méta de format Windows, basé en mémoire, pour les données fournit.
SetMetaRgn | gdi32.dll | Cette fonction permet d'effectuer l'intersection de la région de capture courante pour le périphérique de contexte spécifié avec la région méta courante et sauvegarde la combinaison des régions dans une nouvelle région méta.
SetMiterLimit | gdi32.dll | Cette fonction permet de fixer la limite pour la longueur d'une jointure de mitre pour le périphérique de contexte spécifié.
SetNamedPipeHandleState | kernel32.dll | Cette fonction permet de fixer le mode de lecture et le mode de bloc d'un tuyau nommé spécifié.
SetPaletteEntries | gdi32.dll | Cette fonction permet de fixer les valeurs de couleurs RVB (ou RGB en anglais) et les drapeaux d'un rang des entrées dans une palette logique spécifié.
SetParent | user32.dll | Cette fonction permet de transférer un objet d'une fenêtre vers une autre.
SetPixel | gdi32.dll | Cette fonction permet de fixer la couleur sous format RVB (RGB) d'un pixel affiché à l'écran.
SetPixelFormat | gdi32.dll | Cette fonction permet de fixer le format de pixel du périphérique de contexte spécifié au format spécifié par l'index spécifié.
SetPixelV | gdi32.dll | Cette fonction permet de fixer le pixel aux coordonnées de fermeture approximatifs spécifiées avec la couleur spécifié.
SetPolyFillMode | gdi32.dll | Cette fonction permet de fixer le mode de remplissage d'un polygone spécifié.
SetPrinterA | winspool.drv | Cette fonction permet d'envoyer une commande à l'imprimante.
SetPriorityClass | kernel32.dll | Cette fonction permet de fixer la priorité d'une classe pour le processus spécifié.
SetPrivateObjectSecurity | advapi32.dll | Cette fonction permet de modifier un descripteur de sécurité d'objet privé.
SetProcessAffinityMask | kernel32.dll | Cette fonction permet de fixer un masque d'affinité de processeur pour le processus léger d'un processus spécifié.
SetProcessPriorityBoost | kernel32.dll | Cette fonction permet d'activer ou désactiver les habilitées du système pour stimuler temporairement la priorité d'un processus léger dans un processus spécifié.
SetProcessShutdownParameters | kernel32.dll | Cette fonction permet de fixer les paramètres de fermeture du système pour le processus appelant courant.
SetProcessWindowStation | user32.dll | Cette fonction permet de fixer une fenêtre de station vers un processus appellant.
SetProcessWorkingSetSize | kernel32.dll | Cette fonction permet de fixer la taille du travail minimum et maximum d'un processus spécifié.
SetPropA | user32.dll | Cette fonction permet d'ajouter une nouvelle entrée ou changer une entrée existante dans la liste de propriété d'une fenêtre spécifié.
SetPropW | user32.dll | Cette fonction permet d'ajouter une nouvelle entrée ou changer une entrée existante dans la liste de propriété d'une fenêtre spécifié avec des paramètres de chaine de caractères étendues (Unicode).
SetRect | user32.dll | Cette fonction permet de fixer la taille et la position d'un rectangle.
SetRectEmpty | user32.dll | Cette fonction permet de créer un rectangle vide (tous les coordonnées sont fixées à 0).
SetRectRgn | gdi32.dll | Cette fonction permet de changer la région spécifié dans un région rectangulaire avec les coordonnées spécifiés.
SetROP2 | gdi32.dll | Cette fonction permet de fixer le mode de dessinage courant.
SetScrollInfo | user32.dll | Cette fonction permet de fixer les paramètres de barre de défilement, en incluant les positions minimums et maximums, la taille de la page et la position de la boite de défilement.
SetScrollPos | user32.dll | Cette fonction permet de fixer la position d'une boite de défilement et, si requis, redessiner la barre de défilement reflétant la nouvelle position de la boite de défilement.
SetScrollRange | user32.dll | Cette fonction permet de fixer les valeurs de position minimum et maximum de la barre de défilement spécifié.
SetSecurityDescriptorDacl | advapi32.dll | Cette fonction permet de fixer les informations dans une liste de contrôle d'accès (ACL) discrétionnaire.
SetSecurityDescriptorGroup | advapi32.dll | Cette fonction permet de fixer le groupe primaire d'information d'un format absolue de descripteur de sécurité, remplacer par un groupe d'information primaire déjà présent dans un descripteur de sécurité.
SetSecurityDescriptorOwner | advapi32.dll | Cette fonction permet de fixer les informations de propriétaire d'un format absolue de descripteur de sécurité.
SetSecurityDescriptorSacl | advapi32.dll | Cette fonction permet de fixer les informations d'une liste de contrôle d'accès (ACL) système.
SetStdHandle | kernel32.dll | Cette fonction permet d'utiliser un ensemble de gestionnaire pour l'entrée standard, la sortie standard ou le périphérique d'erreur standard.
SetStretchBltMode | gdi32.dll | Cette fonction permet de fixer le mode d'étirement Bitmap.
SetSysColors | user32.dll | Cette fonction permet de fixer la/les couleurs d'un/des objet(s) affiché(s) du système d'exploitations Windows.
SetSystemCursor | user32.dll | Cette fonction permet de modifier un des curseurs qu'utilise le système d'exploitations Windows.
SetSystemPaletteUse | gdi32.dll | Cette fonction permet de fixer l'utilisation de la couleur statique dans une palette du système.
SetSystemPowerState | kernel32.dll | Cette fonction permet de fixer l'état de l'alimentation en énergie de l'ordinateur.
SetSystemTime | kernel32.dll | Cette fonction permet de fixer la date et l'heure système courante.
SetSystemTimeAdjustment | kernel32.dll | Cette fonction permet d'activer ou désactiver l'ajustement du temps périodique de l'horloge de l'heure de la journée.
SetTapeParameters | kernel32.dll | Cette fonction permet de fixer la taille d'un bloc de bande magnétique ou configure le périphérique de bande magnétique.
SetTapePosition | kernel32.dll | Cette fonction permet de fixer la position de la bande magnétique dans un périphérique spécifié.
SetTextAlign | gdi32.dll | Cette fonction permet de fixer le contexte d'alignement d'un objet de texte.
SetTextColor | gdi32.dll | Cette fonction permet de fixer la couleur du texte de la couleur spécifié.
SetTextCharacterExtra | gdi32.dll | Cette fonction permet de fixer la quantité d'espacement entre les caractères.
SetTextJustification | gdi32.dll | Cette fonction permet d'ajouter de l'espacement dans les caractères de saut d'une chaine de caractères.
SetThreadAffinityMask | kernel32.dll | Cette fonction permet de fixer le masque d'affinité du microprocesseur pour le processus léger spécifié.
SetThreadContext | kernel32.dll | Cette fonction permet de fixer le contexte d'un processus léger spécifié.
SetThreadDesktop | user32.dll | Cette fonction permet de fixer le bureau au processus léger appellant.
SetThreadIdealProcessor | kernel32.dll | Cette fonction permet de fixer le microprocesseur préféré pour un processus léger.
SetThreadLocale | kernel32.dll | Cette fonction permet de fixer l'appel de processus léger locale courant.
SetThreadPriority | kernel32.dll | Cette fonction permet de fixer la valeur de priorité pour le processus léger spécifié.
SetThreadPriorityBoost | kernel32.dll | Cette fonction permet d'activer ou désactiver l'habilité d'un système à temporairement stimuler la priorité d'un processus léger.
SetThreadToken | advapi32.dll | Cette fonction permet de fixer une personnification de jeton à un processus léger.
SetTimer | user32.dll | Cette fonction permet d'installer une minuterie système.
SetTimeZoneInformation | kernel32.dll | Cette fonction permet de fixer les paramètres de fuseau horaire courant.
SetTokenInformation | advapi32.dll | Cette fonction permet de fixer une variété de type d'information pour un accès à un jeton spécifié.
SetUnhandledExceptionFilter | kernel32.dll | Cette fonction permet à une application de remplacer le gestionnaire d'exception de bas niveau dans les places Win32 du haut de chaque processus léger et processus.
SetupComm | kernel32.dll | Cette fonction permet d'initialiser les paramètres de communications pour un périphérique de communications spécifié.
SetupCopyErrorA | setupapi.dll | Cette fonction permet d'afficher une boite de dialogue pour indiquer à l'utilisateur qu'une erreur pendant la copie s'est produit.
SetupDeleteErrorA | setupapi.dll | Cette fonction permet d'afficher une boite de dialogue pour indiquer à l'utilisateur qu'une erreur pendant l'effacement d'un fichier s'est produit.
SetUserObjectInformationA | user32.dll | Cette fonction permet de fixer les informations à propos d'une fenêtre de station ou d'un objet de bureau.
SetUserObjectInformationW | user32.dll | Cette fonction permet de fixer les informations à propos d'une fenêtre de station ou d'un objet de bureau avec des paramètres de chaine de caractères étendues (Unicode).
SetUserObjectSecurity | user32.dll | Cette fonction permet de fixer la sécurité d'un objet utilisateur.
SetViewportExtEx | gdi32.dll | Cette fonction permet de fixer les extensions X et Y d'un point de vue d'un périphérique de contexte spécifié.
SetViewportOrgEx | gdi32.dll | Cette fonction permet de fixer le point de vue d'origine d'un périphérique de contexte spécifié.
SetVolumeLabelA | kernel32.dll | Cette fonction permet de fixer le nom de volume d'une unité de disque.
SetVolumeLabelW | kernel32.dll | Cette fonction permet de fixer le nom de volume d'une unité de disque avec des paramètres de chaine de caractères étendues (Unicode).
SetWaitableTimer | kernel32.dll | Cette fonction permet d'activer la minuterie d'attente spécifié.
SetWindowContextHelpId | user32.dll | Cette fonction permet d'associer un identificateur de contexte d'aide avec la fenêtre spécifié.
SetWindowLongA | user32.dll | Cette fonction permet de placer une valeur 32 bits dans le déplacement spécifié dans une fenêtre en mémoire supplémentaire pour la fenêtre spécifié.
SetWindowLongW | user32.dll | Cette fonction permet de placer une valeur 32 bits dans le déplacement spécifié dans une fenêtre en mémoire supplémentaire pour la fenêtre spécifié avec des paramètres de chaine de caractères étendues (Unicode).
SetWindowPlacement | user32.dll | Cette fonction permet de fixer l'état d'affichage et de restituer, minimiser et maximiser les positions d'une fenêtre.
SetWindowPos | user32.dll | Cette fonction permet de fixer la position d'une fenêtre à une nouvelle coordonnées à l'écran.
SetWindowRgn | user32.dll | Cette fonction permet de fixer la région de fenêtre dans une fenêtre.
SetWindowsHookA | user32.dll | Cette fonction permet d'installer une fonction de crochet utilisateur dans une chaine de crochet.
SetWindowsHookExA | user32.dll | Cette fonction permet d'installer un crochet de fonction utilisateur dans une chaine de crochet.
SetWindowsHookExW | user32.dll | Cette fonction permet d'installer un crochet de fonction utilisateur dans une chaine de crochet avec des paramètres de chaine de caractères étendues (Unicode).
SetWindowsHookW | user32.dll | Cette fonction permet d'installer une fonction de crochet utilisateur dans une chaine de crochet avec des paramètres de chaine de caractères étendues (Unicode).
SetWindowTextA | user32.dll | Cette fonction permet de définir le contenu texte d'une fenêtre.
SetWindowTextW | user32.dll | Cette fonction permet de définir le contenu texte d'une fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
SetWindowWord | user32.dll | Cette fonction permet de placer une valeur 16 bits dans le déplacement spécifié dans une fenêtre en mémoire supplémentaire pour la fenêtre spécifié.
SetWinMetaFileBits | gdi32.dll | Cette fonction permet de convertir un fichier méta d'un ancien format Windows vers un nouveau format étendue et entrepose le fichier méta en mémoire.
SetWindowOrgEx | gdi32.dll | Cette fonction permet de fixer la fenêtre d'origine d'un périphérique de contexte spécifié.
SetWorldTransform | gdi32.dll | Cette fonction permet de fixer une transformation de double dimensions linéaire entre l'espace mondiale et l'espace de page pour le périphérique de contexte spécifié.
SHAddToRecentDocs | shell32.dll | Cette fonction permet d'ajouter un lien vers un document dans la liste des documents récamment utilisé.
SHAppBarMessage | shell32.dll | Cette fonction permet d'envoyer des commandes à la barrre de tâche.
SHBrowseForFolder | shell32.dll | Cette fonction permet d'afficher la boite de dialogue sélectionnant un répertoire.
SHCopyKeyA | shell32.dll | Cette fonction permet de copier les clefs de registre d'un répertoire à un autre dans la base de registres en tenant compte de bien copier toutes les sous-branches de répertoire inclus dans la clef source.
ShellAboutA | shell32.dll | Cette fonction permet d'afficher la boite de dialogue «A propos» de l'application spécifié.
ShellExecuteA | shell32.dll | Cette fonction permet de lancer une application externe.
ShellExecuteEx | shell32.dll | Cette fonction permet de lancer une application externe en utilisant l'interpréteur de commande (Shell) du système d'exploitation Windows.
Shell_NotifyIconA | shell32.dll | Cette fonction permet d'effectuer l'action d'ajouter, modifier ou supprimer une icône dans la barre de tâche.
SHEmptyRecycleBinA | shell32.dll | Cette fonction permet de vider le contenu de la corbeille.
SHFileOperationA | shell32.dll | Cette fonction permet d'effectuer une copie, renommer, déplacer ou de supprimer un objet de fichier.
SHFormatDrive | shell32.dll | Cette fonction permet d'effectuer le formattage d'une unité de disque.
SHGetPathFromIDList | shell32.dll | Cette fonction permet de retourner un pointeur dans un arbre de répertoire à l'emplacement ou se trouve un fichier.
ShowCaret | user32.dll | Cette fonction permet d'afficher un caret à l'écran à la position courant du caret.
ShowCursor | user32.dll | Cette fonction permet d'afficher ou de faire disparaitre le pointeur de la souris.
ShowOwnedPopups | user32.dll | Cette fonction permet d'afficher ou de cacher tous les fenêtres POP-UP du propriétaire de la fenêtre spécifié.
ShowScrollBar | user32.dll | Cette fonction permet d'afficher ou de faire disparaitre la barre de défilement d'une fenêtre ou d'un objet.
ShowWindow | user32.dll | Cette fonction permet de définir l'état visuel d'une fenêtre d'application.
ShowWindowAsync | user32.dll | Cette fonction permet de fixer l'affichage d'état de la création d'une fenêtre par différent processus léger.
SHSetValueA | shlwapi.dll | Cette fonction permet de fixer une valeur dans la base de registres.
SignalObjectAndWait | kernel32.dll | Cette fonction permet de signaler un objet et d'attendre après un autre objet, une simple opération.
SizeofResource | kernel32.dll | Cette fonction permet de demander la taille, en octets, d'une ressource spécifié.
Sleep | kernel32.dll | Cette fonction permet de faire passer en mode d'attente pendant un certain délai en milliseconde le processus courant.
SleepEx | kernel32.dll | Cette fonction permet de faire en sorte que le processus léger courant entre dans un état d'attente jusqu'à ce que l'intervalle de temps spécifié est passé ou jusqu'à l'achèvement d'une fonction d'appel arrière d'entrée/sortie soit appelé.
sndPlaySoundA | winmm.dll | Cette fonction permet de faire jouer un son de format Wave à partir d'un fichier.
SQLAllocConnect | odbc32.dll | Cette fonction permet d'effectuer de l'allocation de mémoire pour un identificateur de connexion ODBC avec un environnement spécifié.
SQLAllocEnv | odbc32.dll | Cette fonction permet d'effectuer de l'allocation de mémoire pour un identificateur d'environnement ODBC.
SQLAllocStmt | odbc32.dll | Cette fonction permet d'effectuer de l'allocation de mémoire pour un identificateur d'instruction ODBC.
SQLBindCol | odbc32.dll | Cette fonction permet d'effectuer de la lecture d'une colonne du résultat d'une requête par ODBC.
SQLBindParameter | odbc32.dll | Cette fonction permet d'envoyer un tampon de paramètres dans une instruction SQL par ODBC.
SQLConfigDataSource | odbccp32.dll | Cette fonction permet d'envoyer des commandes au pilote ODBC (Open Data Base Connectivity).
StartDocA | gdi32.dll | Cette fonction permet d'indiquer le commencement d'un travail d'impression pour l'imprimante.
StartDocW | gdi32.dll | Cette fonction permet d'indiquer le commencement d'un travail d'impression pour l'imprimante avec des paramètres de chaine de caractères étendues (Unicode).
StartPage | gdi32.dll | Cette fonction permet d'indiquer le début d'une page de document pour l'impression pour l'imprimante.
StretchBlt | gdi32.dll | Cette fonction permet de copier un morceau dans une autre image.
StretchDIBits | gdi32.dll | Cette fonction permet de copier les données de couleur d'un rectangle de pixels dans un DIB de la destination rectangulaire spécifié.
StrIsIntlEqualA | shlwapi.dll | Cette fonction permet de comparer le début de deux chaines de caractères ASCIZ.
StrNCatA | shlwapi.dll | Cette fonction permet d'ajouter à la fin d'une chaine de caractères ASCIZ le contenu d'une chaine de caractères ASCIZ.
StrokeAndFillPath | gdi32.dll | Cette fonction permet de fermer n'importe quel figures ouvertes dans un chemin, traitant les lignes en dehors du chemin en utilisant le crayon courant, et remplissant l'intérieur en utilisant la brosse.
StrokePath | gdi32.dll | Cette fonction permet d'effectuer un traitement d'un chemin spécifié en utilisant le crayon courant.
StrToIntExA | shlwapi.dll | Cette fonction permet de convertir une chaine de caractères ASCIZ ayant un nombre décimal ou hexadécimal en une valeur numérique entière.
StrTrimA | shlwapi.dll | Cette fonction permet d'enlever les caractères spécifié au début et à la fin d'une chaine de caractères ASCIZ.
SubtractRect | user32.dll | Cette fonction permet de demander les coordonnées d'un rectangle par soustraction d'un rectangle par un autre.
SuspendThread | kernel32.dll | Cette fonction permet de suspendre le processus léger spécifié.
SwapBuffers | gdi32.dll | Cette fonction permet d'échanger le tampon de premier plan avec l'arrière-plan si le format du pixel courant pour la fenêtre est référencée par le périphérique de contexte spécifié inclus dans le tampon d'arrière plan.
SwapMouseButton | user32.dll | Cette fonction permet d'échanger le comportement des boutons de gauche de la souris devienne celui de droite et que celui de droite devienne celui de gauche.
SwitchDesktop | user32.dll | Cette fonction permet de fixer le bureau visible et actif.
SwitchToFiber | kernel32.dll | Cette fonction permet de planifier une fibre.
SwitchToThread | kernel32.dll | Cette fonction permet de provoquer l'exécution d'un rendement de processus léger vers un autre processus léger étant prêt a être exécuté par le microprocesseur courant.
SystemParametersInfoA | user32.dll | Cette fonction permet de fixer certain paramètre du système d'exploitation Windows.
SystemParametersInfoW | user32.dll | Cette fonction permet de fixer certain paramètre du système d'exploitation Windows avec des paramètres de chaine de caractères étendues (Unicode).
SystemTimeToFileTime | kernel32.dll | Cette fonction permet de convertir le temps système vers le temps fichier.
SystemTimeToTzSpecificLocalTime | kernel32.dll | Cette fonction permet de convertir l'UTC (Coordinated Universal Time) vers un fuseau horaire spécifié correspondant au temps locale.
TabbedTextOutA | user32.dll | Cette fonction permet d'écrire une chaine de caractères à l'emplacement spécifié, en étendant la tabulation des valeurs spécifiés dans des positions d'une tableau de tabulation sans arrêt.
TabbedTextOutW | user32.dll | Cette fonction permet d'écrire une chaine de caractères à l'emplacement spécifié, en étendant la tabulation des valeurs spécifiés dans des positions d'une tableau de tabulation sans arrêt avec des paramètres de chaine de caractères étendues (Unicode).
TerminateProcess | kernel32.dll | Cette fonction permet de terminer le processus spécifié et tous ses processus légers.
TerminateThread | kernel32.dll | Cette fonction permet de terminer le processus léger spécifié.
TextOutA | gdi32.dll | Cette fonction permet d'afficher une chaine de caractères dans une fenêtre d'application.
TextOutW | gdi32.dll | Cette fonction permet d'afficher une chaine de caractères dans une fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
TileWindows | user32.dll | Cette fonction permet de présenter sous forme mosaïque les sous-fenêtre d'une fenêtre d'application MDI.
TlsAlloc | kernel32.dll | Cette fonction permet d'allouer un processus léger d'entrepose d'index locale (TLS).
TlsFree | kernel32.dll | Cette fonction permet de libérer un processus léger d'entrepose d'index locale (TLS).
TlsGetValue | kernel32.dll | Cette fonction permet de demander la valeur dans un appel de processus d'entreposage d'une fente locale (TLS) pour un index TLS spécifié.
TlsSetValue | kernel32.dll | Cette fonction permet d'entreposer la valeur d'un appel de processus d'entreposage d'une fente locale (TLS) pour un index TLS spécifié.
ToAscii | user32.dll | Cette fonction permet de traduire le code de touche virtuel spécifié et l'état du clavier en sa correspondance de caractère Windows ou de caractères.
ToAsciiEx | user32.dll | Cette fonction permet de traduire le code de touche virtuel spécifié et l'état du clavier en sa correspondance de caractère Windows ou de caractères avec des options supplémentaires.
TouchFileTimes | imagehlp.dll | Cette fonction permet de fixer la date et l'heure d'un fichier avec un Handle.
ToUnicode | user32.dll | Cette fonction permet de traduire le code de touche virtuel spécifié et l'état du clavier en sa correspondance de caractère Unicode ou de caractères.
ToUnicodeEx | user32.dll | Cette fonction permet de traduire le code de touche virtuel spécifié et l'état du clavier en sa correspondance de caractère Unicode ou de caractères avec des options supplémentaires.
TrackMouseEvent | user32.dll | Cette fonction permet de poster les messages lorsque le pointeur de souris laisse une fenêtre ou passe dessus une fenêtre pour un nombre de temps spécifié.
TrackPopupMenu | user32.dll | Cette fonction permet d'afficher un menu contextuel.
TrackPopupMenuEx | user32.dll | Cette fonction permet d'afficher un menu contextuel à l'emplacement spécifié et trace les items de sélection dans un menu contextuel.
TransactNamedPipe | kernel32.dll | Cette fonction permet de combiner dans une simple opération réseau les fonctions d'écriture d'un message et de lecture de message d'un tuyau nommé spécifié.
TranslateAcceleratorA | user32.dll | Cette fonction permet d'effectuer le traitement des touches d'accélérations pour les commandes de menu.
TranslateAcceleratorW | user32.dll | Cette fonction permet d'effectuer le traitement des touches d'accélérations pour les commandes de menu avec des paramètres de chaine de caractères étendues (Unicode).
TranslateCharsetInfo | user32.dll | Cette fonction permet d'effectuer une conversion, basé sur ensemble de caractères spécifié, un code de page ou une valeur de signature de police de caractères, ajustant tous les membres d'une structure de destination aux valeurs approprié.
TranslateMDISysAccel | user32.dll | Cette fonction permet d'effectuer le traitement d'une combinaison de touches d'accélération pour une interface de document multiple (MDI) de la fenêtre enfant.
TranslateMessage | user32.dll | Cette fonction permet d'effectuer une transformation de message de touche virtuel en caractères de messages.
TransmitCommChar | kernel32.dll | Cette fonction permet de transmettre un caractère spécifié à venir dans des données en attente dans un tampon de sortie du périphérique de communication spécifié.
TryEnterCriticalSection | kernel32.dll | Cette fonction permet d'effectuer une tentative pour entrer dans une section critique sans blocage.
UnhandledExceptionFilter | kernel32.dll | Cette fonction permet de passer une exception non définit au débogueur si le processus de déboguage est actif.
UnhookWindowsHook | user32.dll | Cette fonction permet d'enlever la fonction crochet utilisateur pour une chaine de fonctions crochet.
UnhookWindowsHookEx | user32.dll | Cette fonction permet d'enlever un crochet de fonction utilisateur d'une chaine de crochet.
UnionRect | user32.dll | Cette fonction permet d'effectuer la création de l'union de 2 rectangles.
UnloadKeyboardLayout | user32.dll | Cette fonction permet d'enlever une schéma de clavier.
UnlockFile | kernel32.dll | Cette fonction permet de déverrouiller une région d'un fichier ouvert.
UnlockFileEx | kernel32.dll | Cette fonction permet de déverrouiller une rangée d'octets précédemment verrouillé dans un fichier ouvert.
UnmapViewOfFile | kernel32.dll | Cette fonction permet de cartographier une vue cartographier dans un fichier d'un espace d'adressage d'un processus appelant.
UnpackDDElParam | user32.dll | Cette fonction permet d'effectuer un décompactage d'une valeur DDE reçu spécifié vers un message DDE posté.
UnrealizeObject | gdi32.dll | Cette fonction permet de réinitialiser l'origine de la brosse ou de réinitialiser la palette logique.
UnregisterClassA | user32.dll | Cette fonction permet d'enlever une classe de fenêtre et libère l'entreposage requis par la classe.
UnregisterClassW | user32.dll | Cette fonction permet d'enlever une classe de fenêtre et libère l'entreposage requis par la classe avec des paramètres de chaine de caractères étendues (Unicode).
UnregisterDeviceNotification | user32.dll | Cette fonction permet de désenregistrer un périphérique ou un type de périphérique pour que la fenêtre reçoivent des avertissements de changements.
UnregisterHotKey | user32.dll | Cette fonction permet de désenregistrer l'état des touches de combinaison (Alt, Ctrl, Shift) pour le processus léger.
UpdateColors | gdi32.dll | Cette fonction permet de mettre-à-jour la région client d'un périphérique de contexte spécifié en faisant correspondre les couleurs courantes dans une région client, pixel par pixel, à une palette de système.
UpdateResourceA | kernel32.dll | Cette fonction permet d'ajouter, supprimer ou remplacer une ressource dans un fichier exécutable.
UpdateResourceW | kernel32.dll | Cette fonction permet d'ajouter, supprimer ou remplacer une ressource dans un fichier exécutable avec des paramètres de chaine de caractères étendues (Unicode).
UpdateWindow | user32.dll | Cette fonction permet de mettre à jour la région client de la fenêtre donnée par l'envoie du message WM_PAINT à la fenêtre si la région à mettre à jour de la fenêtre n'est pas vide.
UrlCanonicalizeA | shlwapi.dll | Cette fonction permet de transformer un chemin d'un URL de sa forme absolue à relative, c'est-à-dire de remplacer des "../" pour atteinte le répertoire en court par exemple.
UrlCombineA | shlwapi.dll | Cette fonction permet d'ajouter un chemin d'un URL à la fin d'un autre chemin d'URL.
UrlCreateFromPathA | shlwapi.dll | Cette fonction permet de convertir un chemin de système d'exploitation de style DOS sous sa forme URL.
UrlEscapeA | shlwapi.dll | Cette fonction permet de convertir les caractères particulier en format acceptable pour un URL.
UrlGetPartA | shlwapi.dll | Cette fonction permet d'extraire une partie de l'URL.
UrlIsOpaqueA | shlwapi.dll | Cette fonction permet de demander si le URL est opaque.
UrlUnescapeA | shlwapi.dll | Cette fonction permet de convertir les caractères particulier du URL en une chaine de caractères ASCIZ.
ValidateRect | user32.dll | Cette fonction permet de valider une région client avec le rectangle donnée par suppression du rectangle de la région à mettre à jour de la fenêtre donnée.
ValidateRgn | user32.dll | Cette fonction permet de valider la région client avec la région donnée par suppression de la région de la mise à jour courante d'une région de fenêtre spécifié.
VerifyScreenSavePwd | password.cpl | Cette fonction permet d'effectuer la vérification du mots de passe lors du lancement d'un écran de veille.
VerLanguageNameA | kernel32.dll | Cette fonction permet de demander le MID identifiant le langage utilisé par le système d'exploitation.
VerLanguageNameW | kernel32.dll | Cette fonction permet de demander le MID identifiant le langage utilisé par le système d'exploitation avec des paramètres de chaines de caractères étendues (Unicode).
VirtualAlloc | kernel32.dll | Cette fonction permet de réservé ou d'engager une région de pages dans un espace d'adressage virtuel d'un processus appelant.
VirtualAllocEx | kernel32.dll | Cette fonction permet de réservé ou d'engager une région de pages dans un espace d'adressage virtuel pour le processus spécifié.
VirtualFree | kernel32.dll | Cette fonction permet de relâcher ou désengager (ou les deux) une région de pages dans une espace de d'adressage virtuel d'un processus appelant.
VirtualFreeEx | kernel32.dll | Cette fonction permet de relâcher ou désengager (ou les deux) une région de pages dans une espace de d'adressage virtuel pour un processus spécifié.
VirtualLock | kernel32.dll | Cette fonction permet de verrouiller une région spécifié dans un espace d'adressage virtuel de la mémoire en s'assurant que l'accès ultérieur à la région ne soit pas passible d'une erreur de page.
VirtualQuery | kernel32.dll | Cette fonction permet de fournir les informations à propos d'un rang de pages dans un espace d'adressage virtuel pour un processus appelant.
VirtualQueryEx | kernel32.dll | Cette fonction permet de fournir les informations à propos d'un rang de pages dans un espace d'adressage virtuel dans un processus spécifié.
VirtualUnlock | kernel32.dll | Cette fonction permet de déverrouiller un range de pages spécifié dans un espace d'adressage virtuel d'un processus et activant le système pour l'échange de pages dans le fichier de pagination si nécessaire.
VkKeyScanA | user32.dll | Cette fonction permet d'effectuer la conversion de caractère correspondant un code de touche virtuel et de l'état de touche de combinaison du clavier courant.
VkKeyScanExA | user32.dll | Cette fonction permet d'effectuer la conversion de caractère correspondant un code de touche virtuel et de l'état de touche de combinaison du clavier courant en utilisant le langage et la couche physique du clavier.
VkKeyScanExW | user32.dll | Cette fonction permet d'effectuer la conversion de caractère correspondant un code de touche virtuel et de l'état de touche de combinaison du clavier courant en utilisant le langage et la couche physique du clavier avec des paramètres de chaine de caractères étendues (Unicode).
VkKeyScanW | user32.dll | Cette fonction permet d'effectuer la conversion de caractère correspondant un code de touche virtuel et de l'état de touche de combinaison du clavier courant avec des paramètres de chaine de caractères étendues (Unicode).
WaitCommEvent | kernel32.dll | Cette fonction permet d'attendre qu'un événement se produise sur le périphérique de communication spécifié.
WaitForDebugEvent | kernel32.dll | Cette fonction permet d'attendre qu'un événement de déboguage se produise dans un processus en déboguage.
WaitForInputIdle | user32.dll | Cette fonction permet d'attendre tant que le processus données est en attente d'une entrée utilisateur sans attendre d'entrée ou de dépassement d'intervalle de temps.
WaitForMultipleObjects | kernel32.dll | Cette fonction permet de retourner lorsque l'un des objets indiqués est dans l'état signalé, ou lorsque le délai d'attente spécifié s'est écoulé.
WaitForMultipleObjectsEx | kernel32.dll | Cette fonction permet d'attendre que la fonction soit utilisés pour un traitement d'attendre d'alerte.
WaitForSingleObject | kernel32.dll | Cette fonction permet d'attendre qu'un objet retourne un signal ou que le délai spécifié soit écoulé.
WaitForSingleObjectEx | kernel32.dll | Cette fonction permet d'étendre la fonction d'attente étant utilisés pour un traitement d'attendre d'alerte.
WaitMessage | user32.dll | Cette fonction permet de rendre le contrôle à une autre application quand une application n'a pas une autre tâche en traitement.
WaitNamedPipeA | kernel32.dll | Cette fonction permet d'attendre jusqu'à ce qu'un dépassement d'intervalle ou d'une instance d'un tuyau nommé spécifié soit disponible pour être connecté à processus en attente d'une opération ConnectNamedPipe se produise.
WaitNamedPipeW | kernel32.dll | Cette fonction permet d'attendre jusqu'à ce qu'un dépassement d'intervalle ou d'une instance d'un tuyau nommé spécifié soit disponible pour être connecté à processus en attente d'une opération ConnectNamedPipe se produise avec des paramètres de chaine de caractères étendue (Unicode).
waveOutGetNumDevs | winmm.dll | Cette fonction permet de demander le nombre de sortie Wave disponible sur le système d'explotation Windows.
WideCharToMultiByte | kernel32.dll | Cette fonction permet de cartographier une chaine de caractères Unicode en une nouvelle chaine de caractères.
WidenPath | gdi32.dll | Cette fonction permet de redéfinir le chemin courant de la région devant être repeinte si le chemin est un trait utilisant le crayon courant sélectionné dans le périphérique de contexte spécifié.
WindowFromDC | user32.dll | Cette fonction permet de demander le Handle de la fenêtre correspondante au périphérique de contexte spécifié.
WindowFromPoint | user32.dll | Cette fonction permet de demander le Handle associé à une fenêtre correspondant au coordonnées pixel spécifié.
WinExec | kernel32.dll | Cette fonction permet de lancer l'exécution d'un programme externe.
WinHelpA | user32.dll | Cette fonction permet de démarrer la fenêtre d'aide (WINHELP.EXE) et passe les données optionnels indiquant la nature de la requête d'aide pour l'application.
WinHelpW | user32.dll | Cette fonction permet de démarrer la fenêtre d'aide (WINHELP.EXE) et passe les données optionnels indiquant la nature de la requête d'aide pour l'application avec des paramètres de chaine de caractères étendues (Unicode).
WNetAddConnection2A | mpr.dll | Cette fonction permet de fabriquer une connexion vers une ressource réseau.
WNetAddConnection2W | mpr.dll | Cette fonction permet de fabriquer une connexion vers une ressource réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetAddConnection3A | mpr.dll | Cette fonction permet de fabriquer une connexion vers une ressource réseau en utilisant des options supplémentaires.
WNetAddConnection3W | mpr.dll | Cette fonction permet de fabriquer une connexion vers une ressource réseau en utilisant des options supplémentaires avec des paramètres de chaine de caractères étendues (Unicode).
WNetAddConnectionA | mpr.dll | Cette fonction permet d'effectuer la connexion d'une unité de disque à une ressource réseau.
WNetAddConnectionW | mpr.dll | Cette fonction permet d'effectuer la connexion d'une unité de disque à une ressource réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetCancelConnection2A | mpr.dll | Cette fonction permet d'effectuer l'arrêt d'une connexion réseau existante.
WNetCancelConnection2W | mpr.dll | Cette fonction permet d'effectuer l'arrêt d'une connexion réseau existante avec des paramètres de chaine de caractères étendues (Unicode).
WNetCancelConnectionA | mpr.dll | Cette fonction permet d'effectuer la déconnexion d'une unité de disque à une ressource réseau.
WNetCancelConnectionW | mpr.dll | Cette fonction permet d'effectuer la déconnexion d'une unité de disque à une ressource réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetCloseEnum | mpr.dll | Cette fonction permet de terminer l'énumération d'une ressource réseau débuté par la fonction WNetOpenEnum.
WNetConnectionDialog | mpr.dll | Cette fonction permet d'afficher une boite de dialogue permettant à une unité de disque de se connecter à une ressource réseau.
WNetConnectionDialog1A | mpr.dll | Cette fonction permet d'introduire une boite de dialogue de navigation général pour la connexion des ressources de réseau.
WNetConnectionDialog1W | mpr.dll | Cette fonction permet d'introduire une boite de dialogue de navigation général pour la connexion des ressources de réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetDisconnectDialog | mpr.dll | Cette fonction permet d'afficher une boite de dialogue permettant à une unité de disque de se déconnecter à une ressource réseau.
WNetDisconnectDialog1A | mpr.dll | Cette fonction permet d'effectuer la déconnexion d'une ressource de réseau.
WNetDisconnectDialog1W | mpr.dll | Cette fonction permet d'effectuer la déconnexion d'une ressource de réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetEnumResourceA | mpr.dll | Cette fonction permet de continuer l'énumération de ressource réseau commencé par la fonction WNetOpenEnum.
WNetEnumResourceW | mpr.dll | Cette fonction permet de continuer l'énumération de ressource réseau commencé par la fonction WNetOpenEnum avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetConnectionA | mpr.dll | Cette fonction permet de demander le nom de la ressource réseau associé avec un périphérique local.
WNetGetConnectionW | mpr.dll | Cette fonction permet de demander le nom de la ressource réseau associé avec un périphérique local avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetLastErrorA | mpr.dll | Cette fonction permet de demander le plus récent des derniers code d'erreur étendue des fonctions réseau du système d'exploitation.
WNetGetLastErrorW | mpr.dll | Cette fonction permet de demander le plus récent des derniers code d'erreur étendue des fonctions réseau du système d'exploitation avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetNetworkInformationA | mpr.dll | Cette fonction permet de demander les informations étendues à propos d'un fournisseur de réseau spécifié dont le nom a été retourné lors d'une énumération réseau précédente.
WNetGetNetworkInformationW | mpr.dll | Cette fonction permet de demander les informations étendues à propos d'un fournisseur de réseau spécifié dont le nom a été retourné lors d'une énumération réseau précédente avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetProviderNameA | mpr.dll | Cette fonction permet de demander le nom de fournisseur pour un type spécifié dans un réseau.
WNetGetProviderNameW | mpr.dll | Cette fonction permet de demander le nom de fournisseur pour un type spécifié dans un réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetResourceParentA | mpr.dll | Cette fonction permet de naviguer à partir d'une ressource.
WNetGetResourceParentW | mpr.dll | Cette fonction permet de naviguer à partir d'une ressource avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetUniversalNameA | mpr.dll | Cette fonction permet de prendre un chemin, avec comme base une unité de disque, pour un réseau de ressource et demande la structure de données contenant des formes universel de ce nom.
WNetGetUniversalNameW | mpr.dll | Cette fonction permet de prendre un chemin, avec comme base une unité de disque, pour un réseau de ressource et demande la structure de données contenant des formes universel de ce nom avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetUserA | mpr.dll | Cette fonction permet de connaitre le nom de l'utilisateur utilisé pour la connexion réseau.
WNetGetUserW | mpr.dll | Cette fonction permet de connaitre le nom de l'utilisateur utilisé pour la connexion réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetOpenEnumA | mpr.dll | Cette fonction permet de démarrer l'énumération de ressource réseau ou de connexions existantes.
WNetOpenEnumW | mpr.dll | Cette fonction permet de démarrer l'énumération de ressource réseau ou de connexions existantes avec des paramètres de chaine de caractères étendues (Unicode).
WNetSetConnectionA | mpr.dll | Cette fonction permet de modifier les caractéristiques d'une connexion réseau.
WNetSetConnectionW | mpr.dll | Cette fonction permet de modifier les caractéristiques d'une connexion réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetUseConnectionA | mpr.dll | Cette fonction permet de fabriquer une connexion vers une ressource réseau.
WNetUseConnectionW | mpr.dll | Cette fonction permet de fabriquer une connexion vers une ressource réseau avec des paramètres de chaine de caractères étendues (Unicode).
WriteConsoleA | kernel32.dll | Cette fonction permet d'effectuer l'écriture d'une chaine de caractères dans la sortie de la console standard.
WriteConsoleW | kernel32.dll | Cette fonction permet d'effectuer l'écriture d'une chaine de caractères dans la sortie de la console standard avec des paramètres de chaine de caractères étendues (Unicode).
WriteConsoleInputA | kernel32.dll | Cette fonction permet d'écrire des données directement dans l'entrée du tampon de la console.
WriteConsoleInputW | kernel32.dll | Cette fonction permet d'écrire des données directement dans l'entrée du tampon de la console avec des paramètres de chaine de caractères étendues (Unicode).
WriteConsoleOutputA | kernel32.dll | Cette fonction permet d'écrire le caractère et la donnée d'attribut de couleur vers un bloc rectangulaire spécifié dans une cellule de caractères d'un tampon de console d'écran.
WriteConsoleOutputW | kernel32.dll | Cette fonction permet d'écrire le caractère et la donnée d'attribut de couleur vers un bloc rectangulaire spécifié dans une cellule de caractères d'un tampon de console d'écran avec des paramètres de chaine de caractères étendue (Unicode).
WriteConsoleOutputAttribute | kernel32.dll | Cette fonction permet de copier un nombre d'attributs de couleurs de premier plan et d'arrière-plan dans une cellule consécutive d'un tampon de console d'écran en débutant à l'emplacement spécifié.
WriteConsoleOutputCharacterA | kernel32.dll | Cette fonction permet d'effectuer une copie d'un nombre de caractères à une cellule consécutive d'un tampon de console d'écran en débutant à l'emplacement spécifié.
WriteConsoleOutputCharacterW | kernel32.dll | Cette fonction permet d'effectuer une copie d'un nombre de caractères à une cellule consécutive d'un tampon de console d'écran en débutant à l'emplacement spécifié avec des paramètres de chaine de caractères étendue (Unicode).
WriteFile | kernel32.dll | Cette fonction permet d'écrire des données dans un fichier et est conçue pour des opérations sychronisé ou désychronisé.
WriteFileEx | kernel32.dll | Cette fonction permet d'écrire des données dans un fichier.
WritePrivateProfileSectionA | kernel32.dll | Cette fonction permet de remplacer les clefs et les valeurs dans la section spécifié d'un fichier d'initialisation.
WritePrivateProfileSectionW | kernel32.dll | Cette fonction permet de remplacer les clefs et les valeurs dans la section spécifié d'un fichier d'initialisation avec des paramètres de chaine de caractères étendue (Unicode).
WritePrivateProfileStringA | kernel32.dll | Cette fonction permet de copier une chaine de caractères dans une section spécifié d'un fichier d'initialisation spécifié.
WritePrivateProfileStringW | kernel32.dll | Cette fonction permet de copier une chaine de caractères dans une section spécifié d'un fichier d'initialisation spécifié avec des paramètres de chaine de caractères étendue (Unicode).
WriteProcessMemory | kernel32.dll | Cette fonction permet d'écrire en mémoire pour le processus spécifié.
WriteProfileSectionA | kernel32.dll | Cette fonction permet de remplacer le contenu de la section spécifié dans le fichier «WIN.INI» avec les clefs et les valeurs spécifiés.
WriteProfileSectionW | kernel32.dll | Cette fonction permet de remplacer le contenu de la section spécifié dans le fichier «WIN.INI» avec les clefs et les valeurs spécifiés et avec les paramètres de chaine de caractères étendues (Unicode).
WriteProfileStringA | kernel32.dll | Cette fonction permet de copier une chaine de caractères dans la section spécifié d'un fichier «WIN.INI».
WriteProfileStringW | kernel32.dll | Cette fonction permet de copier une chaine de caractères dans la section spécifié d'un fichier «WIN.INI» avec des paramètres de chaine de caractères étendues (Unicode).
WriteTapemark | kernel32.dll | Cette fonction permet d'écrire une marque de fichier, un fixeur de marque, une marque de fichier court ou une long marque de fichier dans un périphérique de bande magnétique.
wsprintfA | user32.dll | Cette fonction permet d'écrire des données formatté d'une chaine de caractères vers un tampon.
wsprintfW | user32.dll | Cette fonction permet d'écrire des données formatté d'une chaine de caractères vers un tampon avec des paramètres de chaine de caractères étendues (Unicode).
wvsprintfA | user32.dll | Cette fonction permet de formatter et d'entreposer une série de caractères et de valeurs virtuel dans un tampon.
wvsprintfW | user32.dll | Cette fonction permet de formatter et d'entreposer une série de caractères et de valeurs virtuel dans un tampon avec des paramètres de chaine de caractères étendues (Unicode).
_hread | kernel32.dll | Cette fonction permet d'effectuer la lecture de données dans le fichier spécifié.
_hwrite | kernel32.dll | Cette fonction permet d'effectuer l'écriture de données dans le fichier spécifié.
_lclose | kernel32.dll | Cette fonction permet de fermer le fichier Handle spécifié.
_lcreat | kernel32.dll | Cette fonction permet de créer ou ouvrir un fichier spécifié.
_llseek | kernel32.dll | Cette fonction permet de positionner le pointeur du fichier Handle spécifié.
_lread | kernel32.dll | Cette fonction permet d'effectuer la lecture de données dans un fichier spécifié.

Voir également

Articles - Les géants de l'informatique - Microsoft

Dernière mise à jour : Samedi, 5 décembre 2015


C pour Windows - API de Windows avec prototypes

Reference API pour C Windows Prototype

Vu dans ... http://www.gladir.com

Nom de l'API | Prototype | Bibliothèque | Description
AbnormalTermination | BOOL AbnormalTermination(VOID); |  | Cette fonction permet d'indiquer que le «TRY-FINALLY» d'un bloc s'est exécuté normalement.
AbortDoc | int AbortDoc(HDC hdc); | gdi32.dll | Cette fonction permet d'effectuer l'annulation d'une impression d'un document.
AbortPath | BOOL AbortPath(HDC hdc); | gdi32.dll | Cette fonction permet de terminer et de restituer toutes les palettes du périphérique de contexte.
AbortPrinter | BOOL AbortPrinter(HANDLE hPrinter); | winspool.drv | Cette fonction permet d'effacer un fichier dans le tampon d'impression si l'imprimante est configuré avec un tampon d'impression.
AbortSystemShutdownA | BOOL AbortSystemShutdownA(LPSTR lpMachineName); | advapi32.dll | Cette fonction permet d'annuler l'opération de fermeture ou de redémarrage en cours d'exécution du système d'exploitation Windows.
AbortSystemShutdownW | BOOL AbortSystemShutdownW(LPWSTR lpMachineName) | advapi32.dll | Cette fonction permet d'annuler l'opération de fermeture ou de redémarrage en cours d'exécution du système d'exploitation Windows avec des paramètres de chaine de caractères étendue (Unicode).
AccessCheck | BOOL AccessCheck( PSECURITY_DESCRIPTOR pSecurityDescriptor, HANDLE ClientToken, DWORD DesiredAccess, PGENERIC_MAPPING GenericMapping, PPRIVILEGE_SET PrivilegeSet, LPDWORD PrivilegeSetLength, LPDWORD GrantedAccess, LPBOOL AccessStatus ); | advapi32.dll | Cette fonction permet, à une application serveur, de vérifier les accès client à un objet de contrôle d'accès.
AccessCheckAndAuditAlarmA | BOOL AccessCheckAndAuditAlarmA( LPCTSTR SubsystemName, LPVOID HandleId, LPTSTR ObjectTypeName, LPTSTR ObjectName, PSECURITY_DESCRIPTOR SecurityDescriptor, DWORD DesiredAccess, PGENERIC_MAPPING GenericMapping, BOOL ObjectCreation, LPDWORD GrantedAccess, LPBOOL AccessStatus, LPBOOL pfGenerateOnClose ); | advapi32.dll | Cette fonction permet d'effectuer une validation d'accès et de provoquer le message approprié.
AccessCheckAndAuditAlarmW | BOOL AccessCheckAndAuditAlarmW( LPCWSTR SubsystemName, LPVOID HandleId, LPWSTR ObjectTypeName, LPWSTR ObjectName, PSECURITY_DESCRIPTOR SecurityDescriptor, DWORD DesiredAccess, PGENERIC_MAPPING GenericMapping, BOOL ObjectCreation, LPDWORD GrantedAccess, LPBOOL AccessStatus, LPBOOL pfGenerateOnClose); | advapi32.dll | Cette fonction permet d'effectuer une validation d'accès et de provoquer le message approprié avec des paramètres de chaine de caractères étendue (Unicode).
AcsLan | ACSLAN_STATUS AcsLan(PLLC_CCB pCcb,PLLC_CCB * ppBadCcb); | dlcapi.dll | Cette fonction permet de communiquer avec d'autres ordinateurs ou par périphérique réseau, comme des imprimantes, en utilisant le protocole DLC (Data Link Control).
ActivateKeyboardLayout | HKL ActivateKeyboardLayout(HKL hkl,UINT Flags); | user32.dll | Cette fonction permet d'activer une disposition différente du clavier pour le processus courant.
AddAccessAllowedAce | BOOL AddAccessAllowedAce(PACL pAcl, DWORD dwAceRevision, DWORD AccessMask, PSID pSid); | advapi32.dll | Cette fonction permet d'ajouter un accès autorisé à l'ACE d'un ACL.
AddAccessDeniedAce | BOOL AddAccessDeniedAce(PACL pAcl, DWORD dwAceRevision, DWORD AccessMask,PSID pSid); | advapi32.dll | Cette fonction permet d'ajouter un accès refusé à l'ACE d'un ACL.
AddAce | BOOL AddAce(PACL pAcl, DWORD dwAceRevision, DWORD dwStartingAceIndex, LPVOID pAceList, DWORD nAceListLength); | advapi32.dll | Cette fonction permet d'ajouter un ACE à un ACL spécifié.
AddAtomA | ATOM AddAtomA(LPCSTR lpString); | kernel32.dll | Cette fonction permet d'ajouter une chaine de caractères ASCIZ à l'Atom global.
AddAtomW | ATOM AddAtomW(LPCWSTR lpString); | kernel32.dll | Cette fonction permet d'ajouter un caractère étendue (Unicode) à l'Atom global.
AddAuditAccessAce | BOOL AddAuditAccessAce(PACL pAcl,DWORD dwAceRevision,DWORD dwAccessMask,PSID pSid,BOOL bAuditSuccess,BOOL bAuditFailure); | advapi32.dll | Cette fonction permet d'ajouter un ACE système à un ACL système.
AddFontResourceA | int AddFontResourceA(LPCTSTR lpszFilename); | gdi32.dll | Cette fonction permet d'ajouter une police de caractères à partir d'un fichier.
AddFontResourceW | int AddFontResourceW(LPCWSTR lpszFilename); | gdi32.dll | Cette fonction permet d'ajouter une police de caractères à partir d'un fichier avec des paramètres de chaine de caractères étendues (Unicode).
AddFormA | BOOL AddFormA(HANDLE hPrinter,DWORD Level,LPBYTE pForm); | winspool.drv | Cette fonction permet d'ajouter un formulaire à la liste des formulaires de l'imprimante spécifié.
AddInksetInterval | BOOL AddInksetInterval(HINKSET hinkset, LPINTERVAL lpiNew); | penwin32.dll | Cette fonction permet de fixer l'intervalle de la cartouche d'encre de l'imprimante.
AddJobA | BOOL AddJobA(HANDLE hPrinter, DWORD Level, LPBYTE pData, DWORD cbBuf, LPDWORD pcbNeeded ); | winspool.drv | Cette fonction permet de fixer la chaine de caractères du répertoire contenant les fichiers du tampon d'imprimante.
AddMonitorA | BOOL AddMonitorA( LPTSTR pName, DWORD Level, LPBYTE pMonitors ); | winspool.drv | Cette fonction permet d'installer un moniteur d'imprimante local et des liens de configuration, de données et de fichiers du moniteur.
AddPenDataHRC | int AddPenDataHRC(HRC hrc, HPENDATA hpndt); | penwin32.dll | Cette fonction permet d'ajouter un objet de données de crayon limineux.
AddPenInputHRC | int AddPenInputHRC( HRC hrc, LPPOINT lppt, LPVOID lpvOem, UINT fuOem, LPSTROKEINFO lpsi ); | penwin32.dll | Cette fonction permet d'ajouter un objet de données de crayon limineux exporté.
AddPointsPenData | HPENDATA AddPointsPenData( HPENDATA hpendata, LPPOINT lppt, LPVOID lpvOem, LPSTROKEINFO lpsiNew ) | penwin32.dll | Cette fonction permet d'ajouter un ensemble de point de données à l'objet de crayon limineux.
AddPortA | BOOL AddPortA(LPTSTR pName, HWND hWnd, LPTSTR pMonitorName); | winspool.drv | Cette fonction permet d'ajouter un nom de port à la liste des ports supporté par l'imprimante.
AddPrinterA | HANDLE AddPrinterA( LPTSTR pName, DWORD Level, LPBYTE pPrinter ); | winspool.drv | Cette fonction permet d'ajouter une imprimante à la liste des imprimantes.
AddPrinterConnectionA | BOOL AddPrinterConnectionA(LPTSTR pName); | winspool.drv | Cette fonction permet d'ajouter une connexion à l'imprimante pour l'utilisateur courant.
AddPrinterDriverA | BOOL AddPrinterDriverA( LPTSTR pName, DWORD Level, LPBYTE pDriverInfo ); | winspool.drv | Cette fonction permet d'installer un pilote d'imprimante avec la configuration, les données et les fichiers du pilote.
AddPrintProcessorA | BOOL AddPrintProcessorA( LPTSTR pName, LPTSTR pEnvironment, LPTSTR pPathName, LPTSTR pPrintProcessorName ); | winspool.drv | Cette fonction permet d'installer un processeur d'imprimante à partir d'un serveur et d'une liste processeur d'imprimante supporté.
AddPrintProvidorA | BOOL AddPrintProvidorA( LPTSTR pName, DWORD Level, LPBYTE pProvidorInfo ); | winspool.drv | Cette fonction permet d'installer un fournisseur d'imprimante avec la configuration, les données et les fichiers du fournisseur.
AddWordsHWL | int AddWordsHWL( HWL hwl, LPSTR lpsz, UINT uType ); | penwin32.dll | Cette fonction permet d'ajouter des mots dans une liste de mots.
AdjustTokenGroups | BOOL AdjustTokenGroups( HANDLE TokenHandle, BOOL ResetToDefault, PTOKEN_GROUPS NewState, DWORD BufferLength, PTOKEN_GROUPS PreviousState, PDWORD ReturnLength ); | advapi32.dll | Cette fonction permet d'ajuster des groupes dans une liste d'objet à saisir.
AdjustTokenPrivileges | BOOL AdjustTokenPrivileges( HANDLE TokenHandle, BOOL DisableAllPrivileges, PTOKEN_PRIVILEGES NewState, DWORD BufferLength, PTOKEN_PRIVILEGES PreviousState, PDWORD ReturnLength ); | advapi32.dll | Cette fonction permet d'ajuster des prévilèges dans une liste d'objet à saisir.
AdjustWindowRect | BOOL AdjustWindowRect( LPRECT lpRect, DWORD dwStyle, BOOL bMenu ); | user32.dll | Cette fonction permet de calculer l'espace requis par le rectangle d'une fenêtre basé sur un rectangle client.
AdjustWindowRectEx | BOOL AdjustWindowRectEx( LPRECT lpRect, DWORD dwStyle, BOOL bMenu, DWORD dwExStyle ); | user32.dll | Cette fonction permet de calculer l'espace requis par le rectangle d'une fenêtre avec un style étendue basé sur un rectangle client.
AdvancedDocumentPropertiesA | LONG AdvancedDocumentPropertiesA( HWND hWnd, HANDLE hPrinter, LPTSTR pDeviceName, PDEVMODE pDevModeOutput, PDEVMODE pDevModeInput ); | winspool.drv | Cette fonction permet d'afficher la configuration de l'imprimante spécifié dans une boite de dialogue.
AllocateAndInitializeSid | BOOL AllocateAndInitializeSid( PSID_IDENTIFIER_AUTHORITY pIdentifierAuthority, BYTE nSubAuthorityCount, DWORD dwSubAuthority0, DWORD dwSubAuthority1, DWORD dwSubAuthority2, DWORD dwSubAuthority3, DWORD dwSubAuthority4, DWORD dwSubAuthority5, DWORD dwSubAuthority6, DWORD dwSubAuthority7, PSID *pSid ); | advapi32.dll | Cette fonction permet d'alloué ainsi que d'initialiser l'identificateur de sécurité (SID) avec jusqu'à 8 sous-autorités.
AllocateLocallyUniqueId | BOOL AllocateLocallyUniqueId(PLUID Luid); | advapi32.dll | Cette fonction permet d'alloué un identificateur local unique (LUID).
AllocConsole | BOOL AllocConsole(void); | kernel32.dll | Cette fonction permet de créer une nouvelle console.
AngleArc | BOOL AngleArc( HDC hdc, int X, int Y, DWORD dwRadius, FLOAT eStartAngle, FLOAT eSweepAngle ); | gdi32.dll | Cette fonction permet de dessiner une ligne de segment et d'un arc de cercle.
AnimatePalette | BOOL AnimatePalette( HPALETTE hpal, UINT iStartIndex, UINT cEntries, CONST PALETTEENTRY *ppe ); | gdi32.dll | Cette fonction permet de fixer la valeur des palettes de couleur logique.
AnyPopup | BOOL AnyPopup(VOID); | user32.dll | Cette fonction permet d'indiquer s'il existe un moins une fenêtre visible ou invisible sur le bureau de l'écran.
AppendMenuA | BOOL AppendMenuA(HMENU hMenu, UINT uFlags, UINT uIDNewItem, LPCTSTR lpNewItem); | user32.dll | Cette fonction permet d'ajouter un nouvel item au menu courant.
AppendMenuW | BOOL AppendMenuW(HMENU hMenu, UINT uFlags, UINT uIDNewItem, LPCWSTR lpNewItem); | user32.dll | Cette fonction permet d'ajouter un nouvel item au menu courant avec des paramètres de chaine de caractères étendues (Unicode).
Arc | BOOL Arc( HDC hdc, int nLeftRect, int nTopRect, int nRightRect, int nBottomRect, int nXStartArc, int nYStartArc, int nXEndArc, int nYEndArc ); | gdi32.dll | Cette fonction permet de dessiner l'arc d'une ellipse.
ArcTo | BOOL ArcTo( HDC hdc, int nLeftRect, int nTopRect, int nRightRect, int nBottomRect, int nXRadial1, int nYRadial1, int nXRadial2, int nYRadial2 ); | gdi32.dll | Cette fonction permet de dessiner un arc d'une ellipse.
AreAllAccessesGranted | BOOL AreAllAccessesGranted( DWORD GrantedAccess, DWORD DesiredAccess ); | advapi32.dll | Cette fonction permet d'effectuer la vérification sur un ensemble de requête d'accès garantie.
AreAnyAccessesGranted | BOOL AreAnyAccessesGranted( DWORD GrantedAccess, DWORD DesiredAccess ); | advapi32.dll | Cette fonction permet d'effectuer la vérification sur n'importe quel élément d'un ensemble de requête d'accès garantie.
AreFileApisANSI | BOOL AreFileApisANSI(VOID); | kernel32.dll | Cette fonction permet d'indiquer si les fonctions pour fichier du Win32 utilise un ensemble de police de caractères ANSI ou une page OEM.
ArrangeIconicWindows | UINT ArrangeIconicWindows(HWND hWnd); | user32.dll | Cette fonction permet de minimiser les fenêtres enfants d'une fenêtre parente.
AttachThreadInput | BOOL AttachThreadInput( DWORD idAttach, DWORD idAttachTo, BOOL fAttach ); | user32.dll | Cette fonction permet de relier un processus avec un autre.
auxGetDevCapsA | MMRESULT auxGetDevCaps(UINT uDeviceID, LPAUXCAPS lpCaps, UINT cbCaps); | winmm.dll | Cette fonction permet de demander les informations concernant le système audio auxiliaire.
auxGetNumDevs | UINT auxGetNumDevs(void); | winmm.dll | Cette fonction permet de demander le nombre de système audio auxiliaire reconnu par Windows.
BackupEventLogA | BOOL BackupEventLogA( HANDLE hEventLog, LPCTSTR lpBackupFileName ); | advapi32.dll | Cette fonction permet d'effectuer une sauvegarde du journal de bord dans un fichier de copie de sécurité.
BackupEventLogW | BOOL BackupEventLogW( HANDLE hEventLog, LPCWSTR lpBackupFileName ); | advapi32.dll | Cette fonction permet d'effectuer une sauvegarde du journal de bord dans un fichier de copie de sécurité avec des paramètres de chaine de caractères étendue (Unicode).
BackupRead | BOOL BackupRead( HANDLE hFile, LPBYTE lpBuffer, DWORD nNumberOfBytesToRead, LPDWORD lpNumberOfBytesRead, BOOL bAbort, BOOL bProcessSecurity, LPVOID *lpContext ); | kernel32.dll | Cette fonction permet d'effectuer la lecture de flux de données associé avec un fichier ou un répertoire spécifié d'un tampon.
BackupSeek | BOOL BackupSeek( HANDLE hFile, DWORD dwLowBytesToSeek, DWORD dwHighBytesToSeek, LPDWORD lpdwLowByteSeeked, LPDWORD lpdwHighByteSeeked, LPVOID * lpContext ); | kernel32.dll | Cette fonction permet de fixer la position dans le flux de données accessible par les fonctions «BackupRead» et «BackupWrite».
BackupWrite | BOOL BackupWrite( HANDLE hFile, LPBYTE lpBuffer, DWORD nNumberOfBytesToWrite, LPDWORD lpNumberOfBytesWritten, BOOL bAbort, BOOL bProcessSecurity, LPVOID *lpContext ); | kernel32.dll | Cette fonction permet d'effectuer l'écriture de flux de données associé avec un fichier ou un répertoire spécifié d'un tampon.
Beep | bool Beep(UInt32 dwFreq, UInt32 dwDuration); | kernel32.dll | Cette fonction permet d'émettre un signal sonore sur le PC Speaker.
BeginDeferWindowPos | HDWP BeginDeferWindowPos(int nNumWindows); | user32.dll | Cette fonction permet d'allouer de la mémoire sur de multiples position de fenêtres d'une structure de données.
BeginPaint | HDC BeginPaint(HWND hwnd, LPPAINTSTRUCT lpPaint); | user32.dll | Cette fonction permet de préparé les spécifications de la fenêtre pour la peindre et la remplir avec les informations de la structure spécifié.
BeginPath | BOOL BeginPath(HDC hdc); | gdi32.dll | Cette fonction permet d'ouvrir une braquette de chemin pour le périphérique de contexte (DC) spécifié.
BeginUpdateResourceA | HANDLE BeginUpdateResourceA( LPCTSTR pFileName, BOOL bDeleteExistingResources ); | kernel32.dll | Cette fonction permet de retourner l'identificateur Handle qu'utilise une fonction «UpdateResource» pour ajouter, supprimer ou remplacer dans un fichier exécutable.
BeginUpdateResourceW | HANDLE BeginUpdateResourceW(LPCWSTR pFileName,BOOL bDeleteExistingResources); | kernel32.dll | Cette fonction permet de retourner l'identificateur Handle qu'utilise une fonction «UpdateResource» pour ajouter, supprimer ou remplacer dans un fichier exécutable avec des paramètres de chaine de caractères étendue (Unicode).
BitBlt | BOOL BitBlt( HDC hdcDest, int nXDest, int nYDest, int nWidth, int nHeight, HDC hdcSrc, int nXSrc, int nYSrc, DWORD dwRop ); | gdi32.dll | Cette fonction permet d'effectuer la copie d'un Bitmap vers l'écran.
BlockInput | BOOL BlockInput(BOOL fBlockIt); | user32.dll | Cette fonction permet d'arrêter les événements d'entrer comme le clavier, la souris,...
BringWindowToTop | BOOL BringWindowToTop(HWND hWnd); | user32.dll | Cette fonction permet d'activer et de porter, en haut de la pile des fenêtres, la fenêtre spécifié.
BroadcastSystemMessageA | long BroadcastSystemMessageA(DWORD dwFlags, LPDWORD lpdwRecipients, UINT uiMessage, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'envoyer un message vers un récipient spécifié.
BroadcastSystemMessageW | long BroadcastSystemMessageW(DWORD dwFlags, LPDWORD lpdwRecipients, UINT uiMessage, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'envoyer un message vers un récipient spécifié avec des paramètres de chaine de caractères étendues (Unicode).
BuildCommDCBA | BOOL BuildCommDCBA( LPCTSTR lpDef, LPDCB lpDCB ); | kernel32.dll | Cette fonction permet de remplir une structure DCB avec les valeurs spécifié par une chaine de caractères de périphérique de contrôle.
BuildCommDCBW | BOOL BuildCommDCBW(LPCWSTR devid, LPDCB lpdcb); | kernel32.dll | Cette fonction permet de remplir une structure DCB avec les valeurs spécifié par une chaine de caractères de périphérique de contrôle avec des paramètres de chaine de caractères étendue (Unicode).
BuildCommDCBAndTimeoutsA | BOOL BuildCommDCBAndTimeoutsA( LPCTSTR lpDef, LPDCB lpDCB, LPCOMMTIMEOUTS lpCommTimeouts ); | kernel32.dll | Cette fonction permet de convertir la chaine de caractères des définitions d'un périphérique en un bloc de périphérique de contrôle et de placer les codes dans un bloc dans le périphérique de contrôle.
BuildCommDCBAndTimeoutsW | BOOL BuildCommDCBAndTimeoutsW( LPCWSTR devid, LPDCB lpdcb, LPCOMMTIMEOUTS lptimeouts ); | kernel32.dll | Cette fonction permet de convertir la chaine de caractères des définitions d'un périphérique en un bloc de périphérique de contrôle et de placer les codes dans un bloc dans le périphérique de contrôle avec des paramètres de chaine de caractères étendue (Unicode).
CallMsgFilterA | BOOL CallMsgFilterA(LPMSG lpMsg, int nCode); | user32.dll | Cette fonction permet de passer un message à la fonction de filtre de message courant.
CallMsgFilterW | BOOL CallMsgFilterW(LPMSG lpMsg, int nCode); | user32.dll | Cette fonction permet de passer un message à la fonction de filtre de message courant avec des paramètres de chaine de caractères étendues (Unicode).
CallNamedPipeA | BOOL CallNamedPipeA( LPCTSTR lpNamedPipeName, LPVOID lpInBuffer, DWORD nInBufferSize, LPVOID lpOutBuffer, DWORD nOutBufferSize, LPDWORD lpBytesRead, DWORD nTimeOut ); | kernel32.dll | Cette fonction permet d'effectuer une connection à l'aide d'un tuyau de type de message et de lire et d'écrire dans se tuyau et d'ensuite fermer le tuyau.
CallNamedPipeW | BOOL CallNamedPipeW( LPCWSTR lpNamedPipeName, PVOID lpInBuffer, DWORD nInBufferSize, LPVOID lpOutBuffer, DWORD nOutBufferSize, PDWORD lpBytesRead, DWORD nTimeOut ); | kernel32.dll | Cette fonction permet d'effectuer une connection à l'aide d'un tuyau de type de message et de lire et d'écrire dans se tuyau et d'ensuite fermer le tuyau avec des paramètres de chaine de caractères étendue (Unicode).
CallNextHookEx | LRESULT CallNextHookEx(HHOOK hhk, int nCode, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet de passer au prochain crochet des informations de crochet dans une chaine de crochet.
CallWindowProcA | LRESULT CallWindowProcA(WNDPROC lpPrevWndFunc, HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'appeler et de passer des informations de message à la fonction de fenêtre spécifié.
CallWindowProcW | LRESULT CallWindowProcW(WNDPROC func, HWND hwnd, UINT msg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'appeler et de passer des informations de message à la fonction de fenêtre spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CancelDC | BOOL CancelDC(HDC hdc); | gdi32.dll | Cette fonction permet d'annuler une opération en attente pour le périphérique de contexte (DC) spécifié.
CancelIo | BOOL CancelIo(HANDLE handle); | kernel32.dll | Cette fonction permet d'annuler une opération d'entrée/sortie initié par un processus léger dans un fichier.
CancelWaitableTimer | BOOL CancelWaitableTimer(HANDLE hTimer); | kernel32.dll | Cette fonction permet de fixer le délai d'attente de l'horloge à un état inactif.
CascadeWindows | WORD CascadeWindows(HWND hwndParent, UINT wHow, CONST RECT * lpRect, UINT cKids, const HWND FAR * lpKids); | user32.dll | Cette fonction permet d'effectuer des cascades de fenêtre spécifié ou de fenêtre enfant dans la fenêtre parent spécifié.
ChangeClipboardChain | BOOL ChangeClipboardChain(HWND hWndRemove, HWND hWndNewNext); | user32.dll | Cette fonction permet d'enlever le premier élément de la chaine du visualisateur de presse-papier et de le remplacer par le deuxième élément spécifié.
ChangeDisplaySettingsA | LONG ChangeDisplaySettingsA(LPDEVMODE lpDevMode, DWORD dwflags); | user32.dll | Cette fonction permet de modifier les paramètres du mode d'affichage graphique
ChangeDisplaySettingsW | LONG ChangeDisplaySettingsW(PDEVMODEW lpDevMode, DWORD dwflags); | user32.dll | Cette fonction permet de modifier les paramètres du mode d'affichage graphique avec des paramètres de chaine de caractères étendues (Unicode).
ChangeDisplaySettingsExA | LONG ChangeDisplaySettingsExA(LPCTSTR lpszDeviceName, DEVMODE *lpDevMode, HWND hwnd, DWORD dwflags, LPVOID lParam); | user32.dll | Cette fonction permet de modifier les paramètres du mode d'affichage graphique pour le périphérique d'affichage spécifié.
ChangeDisplaySettingsExW | LONG ChangeDisplaySettingsExW(LPCWSTR lpszDeviceName, LPDEVMODEW *lpDevMode, HWND hwnd, DWORD dwflags, LPVOID lParam); | user32.dll | Cette fonction permet de modifier les paramètres du mode d'affichage graphique pour le périphérique d'affichage spécifié avec des paramètres de chaine de caractères étendues (Unicode).
ChangeMenuA | int ChangeMenuA(HMENU hMenu, UINT wID, LPCSTR lpszNew, UINT wIDNew, UINT wChange); | user32.dll | Cette fonction permet de modifier un élément du menu spécifié.
ChangeMenuW | int ChangeMenuW(HMENU hMenu, UINT wID, LPCWSTR lpszNew, UINT wIDNew, UINT wChange); | user32.dll | Cette fonction permet de modifier un élément du menu spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CharLowerA | LPTSTR CharLowerA(LPTSTR lpsz); | user32.dll | Cette fonction permet d'effectuer la conversion d'une chaine de caractères spécifié en minuscule.
CharLowerBuffA | DWORD CharLowerBuffA(LPTSTR lpsz, DWORD cchLength); | user32.dll | Cette fonction permet d'effectuer la conversion des caractères majuscules contenu dans un tampon en caractères minuscule.
CharLowerBuffW | DWORD CharLowerBuffW(LPWSTR lpsz, DWORD cchLength); | user32.dll | Cette fonction permet d'effectuer la conversion des caractères majuscules contenu dans un tampon en caractères minuscule avec des paramètres de chaine de caractères étendues (Unicode).
CharLowerW | LPWSTR CharLowerW(LPWSTR lpsz); | user32.dll | Cette fonction permet d'effectuer la conversion d'une chaine de caractères spécifié en minuscule avec des paramètres de chaine de caractères étendues (Unicode).
CharNextA | LPTSTR CharNextA(LPCTSTR lpsz); | user32.dll | Cette fonction permet de retourner un pointeur sur le prochaine caractère contenu dans une chaine de caractères.
CharNextExA | LPSTR CharNextExA(WORD CodePage, LPCSTR lpCurrentChar, DWORD dwFlags); | user32.dll | Cette fonction permet de retourner l'adresse du prochaine caractère contenu dans une chaine de caractères.
CharNextW | LPWSTR CharNextW(LPCWSTR lpsz); | user32.dll | Cette fonction permet de retourner un pointeur sur le prochaine caractère contenu dans une chaine de caractères avec des paramètres de chaine de caractères étendues (Unicode).
CharPrevA | LPTSTR CharPrevA(LPCTSTR lpszStart, LPCTSTR lpszCurrent); | user32.dll | Cette fonction permet de retourner un pointeur sur le caractère précédent contenu dans une chaine de caractères.
CharPrevExA | LPSTR CharPrevExA(WORD CodePage, LPCSTR lpStart, LPCSTR lpCurrentChar, DWORD dwFlags); | user32.dll | Cette fonction permet de retourner l'adresse du caractère précédent contenu dans une chaine de caractères.
CharPrevW | LPWSTR CharPrevW(LPCWSTR lpszStart, LPCWSTR lpszCurrent); | user32.dll | Cette fonction permet de retourner un pointeur sur le caractère précédent contenu dans une chaine de caractères avec des paramètres de chaine de caractères étendues (Unicode).
CharToOemA | BOOL CharToOemA(LPCTSTR lpszSrc, LPSTR lpszDst); | user32.dll | Cette fonction permet d'effectuer la transformation d'une chaine de caractères en ensemble de caractères OEM utilisateur.
CharToOemBuffA | BOOL CharToOemBuffA(LPCTSTR lpszSrc, LPSTR lpszDst, DWORD cchDstLength); | user32.dll | Cette fonction permet d'effectuer la transformation d'un nombre spécifique de caractères dans une chaine de caractères d'un ensemble de caractères OEM utilisateur.
CharToOemBuffW | BOOL CharToOemBuffW(LPCWSTR lpszSrc, LPSTR lpszDst, DWORD cchDstLength); | user32.dll | Cette fonction permet d'effectuer la transformation d'un nombre spécifique de caractères dans une chaine de caractères d'un ensemble de caractères OEM utilisateur avec des paramètres de chaine de caractères étendues (Unicode).
CharToOemW | BOOL CharToOemW(LPCWSTR lpszSrc, LPSTR lpszDst); | user32.dll | Cette fonction permet d'effectuer la transformation d'une chaine de caractères en ensemble de caractères OEM utilisateur avec des paramètres de chaine de caractères étendues (Unicode).
CharUpperA | LPTSTR CharUpperA(LPTSTR lpsz); | user32.dll | Cette fonction permet d'effectuer la conversion d'une chaine de caractères spécifié en majuscule.
CharUpperBuffA | DWORD CharUpperBuffA(LPTSTR lpsz, DWORD cchLength); | user32.dll | Cette fonction permet d'effectuer la conversion des caractères minuscules contenu dans un tampon en caractères majuscule.
CharUpperBuffW | DWORD CharUpperBuffW(LPWSTR lpsz, DWORD cchLength); | user32.dll | Cette fonction permet d'effectuer la conversion des caractères minuscules contenu dans un tampon en caractères majuscule avec des paramètres de chaine de caractères étendues (Unicode).
CharUpperW | LPWSTR CharUpperW(LPWSTR lpsz); | user32.dll | Cette fonction permet d'effectuer la conversion d'une chaine de caractères spécifié en majuscule avec des paramètres de chaine de caractères étendues (Unicode).
CheckColorsInGamut | BOOL CheckColorsInGamut(HDC hdc, LPVOID lpaRGBQuad, LPVOID lpResult, DWORD nCount); | gdi32.dll | Cette fonction permet d'indiquer si les valeurs de couleurs spécifiés sont dans la gamme du périphérique spécifié.
CheckDlgButton | BOOL CheckDlgButton(HWND hDlg, int nIDButton, UINT uCheck); | user32.dll | Cette fonction permet de fixer ou d'enlever une marque de vérification d'un bouton de contrôle ou de changer l'état d'un contrôle d'arbre de bouton.
CheckMenuItem | DWORD CheckMenuItem(HMENU hmenu, UINT uIDCheckItem, UINT uCheck); | user32.dll | Cette fonction permet de fixer ou d'enlever un marque de vérification d'un item de menu dans un menu contextuel.
CheckMenuRadioItem | BOOL CheckMenuRadioItem(HMENU hmenu, UINT idFirst, UINT idLast, UINT idCheck, UINT uFlags); | user32.dll | Cette fonction permet de vérifier l'item de menu spécifié et de fabriquer un item radio.
CheckRadioButton | BOOL CheckRadioButton(HWND hDlg, int nIDFirstButton, int nIDLastButton, int nIDCheckButton); | user32.dll | Cette fonction permet de vérifier ou d'enlever un marque de vérification d'un groupe de bouton radio spécifié.
ChildWindowFromPoint | HWND ChildWindowFromPoint(HWND hWndParent, POINT Point); | user32.dll | Cette fonction permet de demander le propriétaire de la fenêtre enfant à l'aide d'une coordonnée spécifié.
ChildWindowFromPointEx | HWND ChildWindowFromPointEx(HWND hwndParent, POINT pt, UINT uFlags); | user32.dll | Cette fonction permet de demander lequel des fenêtres enfants, si possible, appartient à la fenêtre parent du point spécifié.
ChooseColorA | BOOL ChooseColorA(LPCHOOSECOLOR lpcc); | comdlg32.dll | Cette fonction permet de lancer une boite de dialogue offrant la possibilité à l'utilisateur de choisir une couleur
ChooseFontA | BOOL ChooseFontA(LPCHOOSEFONT lpcf); | comdlg32.dll | Cette fonction permet de lancer une boite de dialogue offrant la possibilité à l'utilisateur de choisir une police de caractères
ChoosePixelFormat | int ChoosePixelFormat(HDC hdc, const PIXELFORMATDESCRIPTOR *ppfd); | gdi32.dll | Cette fonction permet de tenter de faire correspondre à un format de pixel approprié supporté par un périphérique de contexte d'un format de pixel donné spécifié.
Chord | BOOL Chord(HDC hdc, int nLeftRect, int nTopRect, int nRightRect, int nBottomRect, int nXRadial1, int nYRadial1, int nXRadial2, int nYRadial2); | gdi32.dll | Cette fonction permet de dessiner la corde de limite à l'aide d'une intersection d'une ellipse avec le centre d'un rectangle et d'une ligne de segment.
ClearCommBreak | BOOL ClearCommBreak(HANDLE hFile); | kernel32.dll | Cette fonction permet de restituer les caractères transmis par un périphérique de communications spécifié et place ligne de transmission dans un état non arrêtable.
ClearCommError | BOOL ClearCommError( HANDLE hFile, LPDWORD lpErrors, LPCOMSTAT lpStat ); | kernel32.dll | Cette fonction permet de demander des informations à propos d'erreur de communications et un rapport d'état actuel sur un périphérique de communication.
ClearEventLogA | BOOL ClearEventLogA( HANDLE hEventLog, LPCTSTR lpBackupFileName ); | advapi32.dll | Cette fonction permet d'effacer le journal de bord spécifié et sauvegarde une copie du journal du bord courant dans un fichier si désiré.
ClearEventLogW | BOOL ClearEventLogW( HANDLE hEventLog, LPCWSTR lpBackupFileName ); | advapi32.dll | Cette fonction permet d'effacer le journal de bord spécifié et sauvegarde une copie du journal du bord courant dans un fichier si désiré avec des paramètres de chaine de caractères étendue (Unicode).
ClientToScreen | BOOL ClientToScreen(HWND hWnd,LPPOINT lpPoint); | user32.dll | Cette fonction permet d'effectuer la transformation des coordonnées logique du client en coordonnées physiquement sur l'écran
ClipCursor | BOOL ClipCursor(CONST RECT * lpRect); | user32.dll | Cette fonction permet de définir une fenêtre limitant le déplacement du pointeur de la souris.
CloseClipboard | BOOL CloseClipboard(VOID); | user32.dll | Cette fonction permet d'indiquer que le traitement avec le presse-papier est terminé et que les autres applications peuvent maintenant avoir accès aux données qu'elle contient.
CloseDesktop | BOOL CloseDesktop(HDESK hDesktop); | user32.dll | Cette fonction permet de fermer ou d'ouvrir le Handle de l'objet de bureau.
CloseEnhMetaFile | HENHMETAFILE CloseEnhMetaFile(HDC hdc); | gdi32.dll | Cette fonction permet de fermer un périphérique de contexte de fichier méta étendue et retourne le Handle identifiant un format de fichier méta étendue.
CloseEventLog | BOOL CloseEventLog(HANDLE hEventLog); | advapi32.dll | Cette fonction permet de fermer le fichier de journal de bord d'événement spécifié
CloseFigure | BOOL CloseFigure(HDC hdc); | gdi32.dll | Cette fonction permet de fermer une figure dans une spécification de chemin.
CloseHandle | BOOL CloseHandle(HANDLE hObject); | kernel32.dll | Cette fonction permet d'effectuer la fermeture d'un Handle.
CloseMetaFile | HMETAFILE CloseMetaFile(HDC hdc); | gdi32.dll | Cette fonction permet de fermer et de créer le fichier de méta pour pouvoir jouer son contenu.
ClosePrinter | BOOL ClosePrinter(HANDLE hPrinter); | winspool.drv | Cette fonction permet d'indiquer que le traitement avec le tampon d'impression de l'imprimante est terminé.
CloseWindow | BOOL CloseWindow(HWND hWnd); | user32.dll | Cette fonction permet de minimiser (sans la détruire) la fenêtre spécifié.
CloseWindowStation | BOOL CloseWindowStation(HWINSTA hWinSta); | user32.dll | Cette fonction permet de fermer un Handle de fenêtre de station ouverte.
CoCreateGuid | HRESULT CoCreateGuid(GUID * pguid); | ole32.dll | Cette fonction permet de créer un identificateur global unique GUID (Global Unique ID) générer sur une base de 128-bits pouvant être utilisé par exemple pour les identificateurs de classe CLSID.
ColorMatchToTarget | BOOL ColorMatchToTarget(HDC hdc, HDC hdcTarget, DWORD uiAction); | gdi32.dll | Cette fonction permet d'activer ou désactiver le prévisualisation du périphérique de contexte spécifié.
CombineRgn | int CombineRgn(HRGN hrgnDest, HRGN hrgnSrc1, HRGN hrgnSrc2, int fnCombineMode); | gdi32.dll | Cette fonction permet de créer une nouvelle région pour combiné deux régions existantes.
CombineTransform | BOOL CombineTransform(LPXFORM lpxformResult, const XFORM *lpxform1, const XFORM *lpxform2); | gdi32.dll | Cette fonction permet d'effectuer la concaténation de double espace mondiale vers une transformation d'espace de page.
CommConfigDialogA | BOOL CommConfigDialogA( LPTSTR lpszName, HWND hWnd, LPCOMMCONFIG lpCC, ); | kernel32.dll | Cette fonction permet d'afficher une configuration de pilote de fournisseur dans une boite de dialogue.
CommConfigDialogW | BOOL CommConfigDialogW( LPCWSTR lpszDevice, HWND hWnd, LPCOMMCONFIG lpCommConfig ); | kernel32.dll | Cette fonction permet d'afficher une configuration de pilote de fournisseur dans une boite de dialogue avec des paramètres de chaine de caractères étendue (Unicode).
CompareFileTime | LONG CompareFileTime( CONST FILETIME *lpFileTime1, CONST FILETIME *lpFileTime2 ); | kernel32.dll | Cette fonction permet de comparer deux temps de fichier de 64-bits.
CompareStringA | int CompareStringA(LCID Locale, DWORD dwCmpFlags, LPCTSTR lpString1, int cchCount1, LPCTSTR lpString2, int cchCount2 ); | kernel32.dll | Cette fonction permet d'effectuer la comparaison de deux chaines de caractères ASCIZ.
CompareStringW | INT CompareStringW( LCID lcid, DWORD style, LPCWSTR str1, INT len1, LPCWSTR str2, INT len2 ); | kernel32.dll | Cette fonction permet d'effectuer la comparaison de deux chaines de caractères Unicode.
ConfigurePortA | BOOL ConfigurePortA(LPTSTR pName,HWND hWnd,LPTSTR pPortName); | winspool.drv | Cette fonction permet de lancer une boite de dialogue offrant la possibilité à l'utilisateur de choisir le port parallèle ou USB d'imprimante
ConnectNamedPipe | BOOL ConnectNamedPipe( HANDLE hNamedPipe, LPOVERLAPPED lpOverlapped ); | kernel32.dll | Cette fonction permet d'activé un nom de tuyau d'un processus serveur en attente pour un processus client de connexion.
ContinueDebugEvent | BOOL ContinueDebugEvent( DWORD dwProcessId, DWORD dwThreadId, DWORD dwContinueStatus ); | kernel32.dll | Cette fonction permet d'activer un débogueur pour qu'il continue un processus précédemment rapporter comme un bogue d'événement.
ConvertDefaultLocale | LCID ConvertDefaultLocale(LCID Locale); | kernel32.dll | Cette fonction permet de convertir une valeur locale spécial par défaut en un identificatuer local courant.
ConvertThreadToFiber | LPVOID ConvertThreadToFiber(LPVOID lpParameter); | kernel32.dll | Cette fonction permet d'effectuer la conversion d'un processus léger vers un fibre.
CopyAcceleratorTableA | int CopyAcceleratorTableA(HACCEL hAccelSrc, LPACCEL lpAccelDst, int cAccelEntries); | user32.dll | Cette fonction permet de copier la table d'accélérateur spécifié.
CopyAcceleratorTableW | int CopyAcceleratorTableW(HACCEL hAccelSrc, LPACCEL lpAccelDst, int cAccelEntries); | user32.dll | Cette fonction permet de copier la table d'accélérateur spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CopyEnhMetaFileA | HENHMETAFILE CopyEnhMetaFileA(HENHMETAFILE hemfSrc, LPCTSTR lpszFile); | gdi32.dll | Cette fonction permet de copier le contenu d'un fichier méta de format étendue vers un fichier spécifié.
CopyEnhMetaFileW | HENHMETAFILE CopyEnhMetaFileW(HENHMETAFILE hmfSrc, LPCWSTR file); | gdi32.dll | Cette fonction permet de copier le contenu d'un fichier méta de format étendue vers un fichier spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CopyFileA | BOOL CopyFileA(LPCTSTR lpExistingFileName,LPCTSTR lpNewFileName,BOOL bFailIfExists); | kernel32.dll | Cette fonction permet d'effectuer la copie d'un fichier d'un emplacement à un autre emplacement
CopyFileExA | BOOL CopyFileExA( LPCSTR lpExistingFileName, LPCSTR lpNewFileName, LPPROGRESS_ROUTINE lpProgressRoutine, LPVOID lpData, LPBOOL pbCancel, DWORD dwCopyFlags ); | kernel32.dll | Cette fonction permet d'effectuer la copie d'un fichier d'un emplacement à un autre emplacement tout en effectuant un processus d'arrière plan indiquant sa progression.
CopyFileExW | BOOL CopyFileExW( LPCWSTR lpExistingFileName, LPCWSTR lpNewFileName, LPPROGRESS_ROUTINE lpProgressRoutine, LPVOID lpData, LPBOOL pbCancel, DWORD dwCopyFlags); | kernel32.dll | Cette fonction permet d'effectuer la copie d'un fichier d'un emplacement à un autre emplacement tout en effectuant un processus d'arrière plan indiquant sa progression avec des paramètres de chaine de caractères étendue (Unicode).
CopyFileW | BOOL CopyFileW( WCHAR *from, WCHAR *to, BOOL bFailIfExists); | kernel32.dll | Cette fonction permet d'effectuer la copie d'un fichier d'un emplacement à un autre emplacement avec des paramètres de chaine de caractères étendue (Unicode).
CopyIcon | HICON CopyIcon(HICON hIcon); | user32.dll | Cette fonction permet de copier un icône spécifié d'un autre module vers le module courant.
CopyImage | HANDLE CopyImage(HANDLE hImage, UINT uType, int cxDesired, int cyDesired, UINT fuFlags); | user32.dll | Cette fonction permet de créer une nouvelle image (icône, image ou Bitmap) et de copier les attributs de l'image donnée dans une nouvelle image.
CopyMetaFileA | HMETAFILE CopyMetaFileA(HMETAFILE hmfSrc, LPCTSTR lpszFile); | gdi32.dll | Cette fonction permet de copier le contenu d'un format de méta fichier Windows vers un fichier spécifié.
CopyMetaFileW | HMETAFILE CopyMetaFileW(HMETAFILE hSrcMetaFile, LPCWSTR lpFilename); | gdi32.dll | Cette fonction permet de copier le contenu d'un format de méta fichier Windows vers un fichier spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CopyRect | BOOL CopyRect(LPRECT lprcDst, CONST RECT *lprcSrc); | user32.dll | Cette fonction permet d'effectuer la copie des coordonnées d'un rectangle dans un autre rectangle.
CopySid | BOOL CopySid( DWORD nDestinationSidLength, PSID pDestinationSid, PSID pSourceSid ); | advapi32.dll | Cette fonction permet de copier l'identificateur de sécurité (SID) dans un tampon spécifié.
CountClipboardFormats | int CountClipboardFormats(VOID); | user32.dll | Cette fonction permet de demander le nombre de différentes données de formats courant que contient le presse-papier.
CreateAcceleratorTableA | HACCEL CreateAcceleratorTableA(LPACCEL lpaccl, int cEntries); | user32.dll | Cette fonction permet de créer une table d'accélérateur.
CreateAcceleratorTableW | HACCEL CreateAcceleratorTableW(LPACCEL lpaccl, int cEntries); | user32.dll | Cette fonction permet de créer une table d'accélérateur avec des paramètres de chaine de caractères étendues (Unicode).
CreateBitmap | HBITMAP CreateBitmap(int nWidth, int nHeight, UINT cPlanes, UINT cBitsPerPel, const void *lpvBits); | gdi32.dll | Cette fonction permet de créer un périphérique de Bitmap en mémoire avec la largeur, hauteur et la palette de bits spécifié.
CreateBitmapIndirect | HBITMAP CreateBitmapIndirect(CONST BITMAP *lpbm); | gdi32.dll | Cette fonction permet de créer un Bitmap avec la largeur, la hauteur et la palette de bits spécifié dans une structure BITMAP.
CreateBrushIndirect | HBRUSH CreateBrushIndirect(CONST LOGBRUSH * lplb); | gdi32.dll | Cette fonction permet de créer une brosse avec le style, la couleur et la palette spécifié dans la structure «LOGBRUSH».
CreateCaret | BOOL CreateCaret(HWND hWnd, HBITMAP hBitmap, int nWidth, int nHeight); | user32.dll | Cette fonction permet de créer un nouveau signe pour le curseur texte et associe le propriétaire à la fenêtre spécifié.
CreateColorSpaceA | HCOLORSPACE CreateColorSpaceA(LPLOGCOLORSPACE lpLogColorSpace); | gdi32.dll | Cette fonction permet de créer un espace de couleur logique.
CreateColorSpaceW | HCOLORSPACE CreateColorSpaceW(LPLOGCOLORSPACEW lpLogColorSpace); | gdi32.dll | Cette fonction permet de créer un espace de couleur logique avec des paramètres de chaine de caractères étendues (Unicode).
CreateCompatibleBitmap | HBITMAP CreateCompatibleBitmap(HDC hdc, int nWidth, int nHeight); | gdi32.dll | Cette fonction permet de créer un Bitmap compatible avec le périphérique spécifié.
CreateCompatibleDC | HDC CreateCompatibleDC(HDC hdc); | gdi32.dll | Cette fonction permet de créer un contexte de périphérique mémoire compatible avec le périphérique spécifié.
CreateConsoleScreenBuffer | HANDLE CreateConsoleScreenBuffer( DWORD dwDesiredAccess, DWORD dwShareMode, LPSECURITY_ATTRIBUTES *lpSecurityAttributes, DWORD dwFlags, LPVOID lpScreenBufferData ); | kernel32.dll | Cette fonction permet de créer un tampon de console écran et de retourner un identificateur Handle associée à celui-ci.
CreateCursor | HCURSOR CreateCursor(HINSTANCE hInst, int xHotSpot, int yHotSpot, int nWidth, int nHeight, CONST VOID *pvANDPlane, CONST VOID *pvXORPlane ); | user32.dll | Cette fonction permet d'effectuer la création d'une nouvelle image de pointeur de souris
CreateDCA | HDC CreateDCA( LPCTSTR lpszDriver, LPCTSTR lpszDevice, LPCTSTR lpszOutput, CONST DEVMODE *lpInitData ); | gdi32.dll | Cette fonction permet d'effectuer la création d'un objet de contexte (DC)
CreateDCW | HDC CreateDCW(LPCWSTR lpszDriver, LPCWSTR lpszDevice,LPCWSTR lpszOutput,const DEVMODEW * lpInitData); | gdi32.dll | Cette fonction permet d'effectuer la création d'un objet de contexte (DC) avec des paramètres de chaines de caractères étendues (Unicode).
CreateDesktopA | HDESK CreateDesktopA(LPCTSTR lpszDesktop, LPCTSTR lpszDevice, LPDEVMODE pDevMode, DWORD dwFlags, DWORD dwDesiredAccess, LPSECURITY_ATTRIBUTES lpsa); | user32.dll | Cette fonction permet de créer un nouveau bureau dans une fenêtre de station associé avec le processus appelant.
CreateDesktopW | HDESK CreateDesktopW(LPCWSTR lpszDesktop, LPCWSTR lpszDevice, LPDEVMODEW pDevMode, DWORD dwFlags, DWORD dwDesiredAccess, LPSECURITY_ATTRIBUTES lpsa); | user32.dll | Cette fonction permet de créer un nouveau bureau dans une fenêtre de station associé avec le processus appelant avec des paramètres de chaine de caractères étendues (Unicode).
CreateDialogIndirectParamA | HWND CreateDialogIndirectParamA(HINSTANCE hInstance, LPCDLGTEMPLATE lpTemplate, HWND hWndParent, DLGPROC lpDialogFunc, LPARAM lParamInit); | user32.dll | Cette fonction permet de créer un modèle de boite de dialogue pour un gabarit de boite de dialogue en mémoire et après son affichage, la fonction passe une valeur d'application à la procédure de boite de dialogue avec les paramètres spécifié du message «WM_INITDIALOG».
CreateDialogIndirectParamW | HWND CreateDialogIndirectParamW(HINSTANCE hInstance, LPCDLGTEMPLATE lpTemplate, HWND hWndParent, DLGPROC lpDialogFunc, LPARAM lParamInit); | user32.dll | Cette fonction permet de créer un modèle de boite de dialogue pour un gabarit de boite de dialogue en mémoire et après son affichage, la fonction passe une valeur d'application à la procédure de boite de dialogue avec les paramètres spécifié du message «WM_INITDIALOG» avec des paramètres de chaine de caractères étendues (Unicode).
CreateDialogParamA | HWND CreateDialogParamA(HINSTANCE hInstance, LPCTSTR lpTemplateName, HWND hWndParent, DLGPROC lpDialogFunc, LPARAM dwInitParam); | user32.dll | Cette fonction permet de créer un modèle de boite de dialogue pour une ressource de gabarit de boite de dialogue et après son affichage, la fonction passe une valeur d'application à la procédure de boite de dialogue avec les paramètres spécifié du message «WM_INITDIALOG».
CreateDialogParamW | HWND CreateDialogParamW(HINSTANCE hInstance, LPCWSTR lpTemplateName, HWND hWndParent, DLGPROC lpDialogFunc, LPARAM dwInitParam); | user32.dll | Cette fonction permet de créer un modèle de boite de dialogue pour une ressource de gabarit de boite de dialogue et après son affichage, la fonction passe une valeur d'application à la procédure de boite de dialogue avec les paramètres spécifié du message «WM_INITDIALOG» avec des paramètres de chaine de caractères étendues (Unicode).
CreateDIBPatternBrush | HBRUSH CreateDIBPatternBrush(HGLOBAL hglbDIBPacked, UINT fuColorSpec); | gdi32.dll | Cette fonction permet de créer une brosse avec la palette spécifié par un périphérique de Bitmap indépendant (DIB).
CreateDIBPatternBrushPt | HBRUSH CreateDIBPatternBrushPt(CONST VOID * lpPackedDIB, UINT iUsage); | gdi32.dll | Cette fonction permet de créer une brosse logique avec la palette spécifié par un périphérique de Bitmap indépendant (DIB).
CreateDIBSection | HBITMAP CreateDIBSection(HDC hdc, CONST BITMAPINFO *pbmi, UINT iUsage, VOID **ppvBits, HANDLE hSection, DWORD dwOffset); | gdi32.dll | Cette fonction permet de créer un Bitmap de périphérique indépendant (DIB) avec les applications pouvant y être écrit directement.
CreateDIBitmap | HBITMAP CreateDIBitmap(HDC hdc, CONST BITMAPINFOHEADER * lpbmih, DWORD fdwInit, CONST VOID *lpbInit, CONST BITMAPINFO * lpbmi, UINT fuUsage); | gdi32.dll | Cette fonction permet de créer un périphérique mémoire spécifié pour un périphérique de Bitmap indépendant (DIB) spécifié et un ensemble de bits optionnel pour le Bitmap.
CreateDirectoryA | BOOL CreateDirectoryA( LPCTSTR lpPathName, LPSECURITY_ATTRIBUTES lpSecurityAttributes ); | kernel32.dll | Cette fonction permet d'effectuer la création d'un répertoire
CreateDirectoryW | BOOL CreateDirectoryW(LPCWSTR lpPathName,LPSECURITY_ATTRIBUTES lpSecurityAttributes); | kernel32.dll | Cette fonction permet d'effectuer la création d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
CreateDirectoryExA | BOOL CreateDirectoryExA( LPCTSTR lpTemplateDirectory, LPCTSTR lpNewDirectory, LPSECURITY_ATTRIBUTES lpSecurityAttributes ); | kernel32.dll | Cette fonction permet d'effectuer la création d'un répertoire étendue
CreateDirectoryExW | BOOL CreateDirectoryExW( LPCWSTR lpTemplateDirectory, LPCWSTR lpNewDirectory, LPSECURITY_ATTRIBUTES lpSecurityAttributes ); | kernel32.dll | Cette fonction permet d'effectuer la création d'un répertoire étendue avec des paramètres de chaine de caractères étendue (Unicode).
CreateDirectoryTransactedA | BOOL CreateDirectoryTransactedA( LPCTSTR lpTemplateDirectory, LPCTSTR lpNewDirectory, LPSECURITY_ATTRIBUTES lpSecurityAttributes, HANDLE hTransaction ); | kernel32.dll | Cette fonction permet d'effectuer la création d'un répertoire dans une opération de transaction
CreateDirectoryTransactedW | BOOL CreateDirectoryTransactedW( LPCTWSTR lpTemplateDirectory, LPCTWSTR lpNewDirectory, LPSECURITY_ATTRIBUTES lpSecurityAttributes, HANDLE hTransaction ); | kernel32.dll | Cette fonction permet d'effectuer la création d'un répertoire dans une opération de transaction avec des paramètres de chaine de caractères étendue (Unicode).
CreateDiscardableBitmap | HBITMAP CreateDiscardableBitmap(HDC hdc, int nWidth, int nHeight); | gdi32.dll | Cette fonction permet de créer un Bitmap compatible avec un périphérique spécifié.
CreateEllipticRgn | HRGN CreateEllipticRgn(int nLeftRect, int nTopRect, int nRightRect, int nBottomRect); | gdi32.dll | Cette fonction permet de créer une région elliptique.
CreateEllipticRgnIndirect | HRGN CreateEllipticRgnIndirect(CONST RECT *lprc); | gdi32.dll | Cette fonction permet de créer une région elliptique à l'aide d'une structure de données.
CreateEnhMetaFileA | HDC CreateEnhMetaFileA(HDC hdcRef, LPCTSTR lpFilename, CONST RECT * lpRect, LPCTSTR lpDescription); | gdi32.dll | Cette fonction permet de créer un contexte de périphérique pour un méta fichier de format étendue.
CreateEnhMetaFileW | HDC CreateEnhMetaFileW(HDC hdcRef, LPCWSTR lpFilename, const RECT *lpRect, LPCWSTR lpDescription); | gdi32.dll | Cette fonction permet de créer un contexte de périphérique pour un méta fichier de format étendue avec des paramètres de chaine de caractères étendues (Unicode).
CreateEventA | HANDLE CreateEventA( LPSECURITY_ATTRIBUTES lpEventAttributes, BOOL bManualReset, BOOL bInitialState, LPCTSTR lpName ); | kernel32.dll | Cette fonction permet de créer un objet d'événement nommé ou non-nommé.
CreateEventW | HANDLE CreateEventW( LPSECURITY_ATTRIBUTES lpEventAttributes, BOOL bManualReset, BOOL bInitialState, LPCWSTR lpName ); | kernel32.dll | Cette fonction permet de créer un objet d'événement nommé ou non-nommé avec des paramètres de chaine de caractères étendue (Unicode).
CreateFiber | LPVOID CreateFiber( SIZE_T dwStackSize, LPFIBER_START_ROUTINE lpStartAddress, LPVOID lpParameter ); | kernel32.dll | Cette fonction permet d'allouer un objet de fibre, en lui attribuant une pile, et en fixant le début de l'exécutant à l'adresse de début spécifié.
CreateFileA | HANDLE CreateFileA( LPCTSTR lpFileName, DWORD dwDesiredAccess, DWORD dwShareMode, LPSECURITY_ATTRIBUTES lpSecurityAttributes, DWORD dwCreationDistribution, DWORD dwFlagsAndAttributes, HANDLE hTemplateFile ); | kernel32.dll | Cette fonction permet d'effectuer la création ou l'ouverture d'un fichier ou d'un périphérique.
CreateFileW | HANDLE CreateFileW( LPCWSTR filename, DWORD access, DWORD sharing, LPSECURITY_ATTRIBUTES sa, DWORD creation, DWORD attributes, HANDLE template ); | kernel32.dll | Cette fonction permet d'effectuer la création ou l'ouverture d'un fichier ou d'un périphérique avec des paramètres de chaine de caractères étendue (Unicode).
CreateFileMappingA | HANDLE CreateFileMappingA( HANDLE hFile, LPSECURITY_ATTRIBUTES lpFileMappingAttributes, DWORD flProtect, DWORD dwMaximumSizeHigh, DWORD dwMaximumSizeLow, LPCTSTR lpName ); | kernel32.dll | Cette fonction permet de créer un objet mapping, nommé ou non-nommé, pour un fichier spécifié.
CreateFileMappingW | HANDLE CreateFileMappingW( HANDLE hFile, LPSECURITY_ATTRIBUTES sa, DWORD protect, DWORD size_high, DWORD size_low, LPCWSTR name ); | kernel32.dll | Cette fonction permet de créer un objet mapping, nommé ou non-nommé, pour un fichier spécifié avec des paramètres de chaine de caractères étendue (Unicode).
CreateFontA | HFONT CreateFontA( int nHeight, int nWidth, int nEscapement, int nOrientation, int fnWeight, DWORD fdwItalic, DWORD fdwUnderline, DWORD fdwStrikeOut, DWORD fdwCharSet, DWORD fdwOutputPrecision, DWORD fdwClipPrecision, DWORD fdwQuality, DWORD fdwPitchAndFamily, LPCTSTR lpszFace ); | gdi32.dll | Cette fonction permet d'effectuer la création d'une police de caractères logique avec les caractéristiques spécifiés.
CreateFontIndirectA | HFONT CreateFontIndirectA(CONST LOGFONT *lplf); | gdi32.dll | Cette fonction permet de créer une police de caractères logique avec les caractéristiques spécifié dans la structure spécifié.
CreateFontIndirectW | HFONT CreateFontIndirectW(CONST LOGFONTW *lplf); | gdi32.dll | Cette fonction permet de créer une police de caractères logique avec les caractéristiques spécifié dans la structure spécifié avec les paramètres de chaines de caractères étendues (Unicode).
CreateFontW | HFONT CreateFontW( int nHeight, int nWidth, int nEscapement, int nOrientation, int fnWeight, DWORD fdwItalic, DWORD fdwUnderline, DWORD fdwStrikeOut, DWORD fdwCharSet, DWORD fdwOutputPrecision, DWORD fdwClipPrecision, DWORD fdwQuality, DWORD fdwPitchAndFamily, LPCWSTR lpszFace ); | gdi32.dll | Cette fonction permet d'effectuer la création d'une police de caractères logique avec les caractéristiques spécifiés avec les paramètres de chaines de caractères étendues (Unicode).
CreateHalftonePalette | HPALETTE CreateHalftonePalette(HDC hdc); | gdi32.dll | Cette fonction permet de créer une demi-teinte d'une palette pour le périphérique de contexte spécifié.
CreateHatchBrush | HBRUSH CreateHatchBrush(int fnStyle, COLORREF clrref); | gdi32.dll | Cette fonction permet de créer une brosse logique spécifiant un motif de hachure et de couleur.
CreateICA | HDC CreateICA( LPCTSTR lpszDriver, LPCTSTR lpszDevice, LPCTSTR lpszOutput, CONST DEVMODE * lpdvmInit ); | gdi32.dll | Cette fonction permet de créer une information de contexte pour un périphérique spécifié.
CreateICW | HDC CreateICW(LPCWSTR lpszDriver, LPCWSTR lpszDevice, LPCWSTR lpszOutput, CONST DEVMODEW * lpdvmInit); | gdi32.dll | Cette fonction permet de créer une information de contexte pour un périphérique spécifié avec des paramètres de chaines de caractères étendues (Unicode).
CreateIcon | HICON CreateIcon( HINSTANCE hInstance, int nWidth, int nHeight, BYTE cPlanes, BYTE cBitsPixel, CONST BYTE *lpbANDbits, CONST BYTE *lpbXORbits ); | user32.dll | Cette fonction permet d'effectuer la création d'une icône
CreateIconFromResource | HICON CreateIconFromResource(PBYTE presbits, DWORD dwResSize, BOOL fIcon, DWORD dwVer); | user32.dll | Cette fonction permet d'effectuer la création d'un icône ou d'un curseur à partir de bits de ressources décrit dans l'icône.
CreateIconFromResourceEx | HICON CreateIconFromResourceEx(PBYTE pbIconBits, DWORD cbIconBits, BOOL fIcon, DWORD dwVersion, int cxDesired, int cyDesired, UINT uFlags); | user32.dll | Cette fonction permet d'effectuer la création d'un icône ou d'un curseur à partir de bits de ressources décrit dans l'icône avec des options complémentaires.
CreateIconIndirect | HICON CreateIconIndirect(PICONINFO piconinfo); | user32.dll | Cette fonction permet d'effectuer la création d'un icône ou d'un curseur à partir d'une structure de données.
CreateMailslotA | HANDLE CreateMailslotA( LPCTSTR lpName, DWORD nMaxMessageSize, DWORD lReadTimeout, LPSECURITY_ATTRIBUTES lpSecurityAttributes ); | kernel32.dll | Cette fonction permet de créer une slot de courriel avec un nom spécifié et retourne un identificateur Handle associé à celle-ci.
CreateMailslotW | HANDLE CreateMailslotW( LPCWSTR lpName, DWORD nMaxMessageSize, DWORD lReadTimeout, LPSECURITY_ATTRIBUTES sa ); | kernel32.dll | Cette fonction permet de créer une slot de courriel avec un nom spécifié et retourne un identificateur Handle associé à celle-ci avec des paramètres de chaine de caractères étendue (Unicode).
CreateMDIWindowA | HWND CreateMDIWindowA(LPTSTR lpClassName, LPTSTR lpWindowName, DWORD dwStyle, int X, int Y, int nWidth, int nHeight, HWND hWndParent, HINSTANCE hInstance, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer la création de fenêtre enfant MDI (Interface de mutiple document).
CreateMDIWindowW | HWND CreateMDIWindowW(LPCWSTR lpClassName, LPCWSTR lpWindowName, DWORD dwStyle, int X, int Y, int nWidth, int nHeight, HWND hWndParent, HINSTANCE hInstance, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer la création de fenêtre enfant MDI (Interface de mutiple document) avec des paramètres de chaine de caractères étendues (Unicode).
CreateMenu | HMENU CreateMenu(VOID); | user32.dll | Cette fonction permet d'effectuer la création d'un menu.
CreateMetaFileA | HDC CreateMetaFileA(LPCTSTR lpszFile); | gdi32.dll | Cette fonction permet de créer un périphérique de contexte pour un format de fichier méta Windows.
CreateMetaFileW | HDC CreateMetaFileW(LPCWSTR filename); | gdi32.dll | Cette fonction permet de créer un périphérique de contexte pour un format de fichier méta Windows avec des paramètres de chaines de caractères étendues (Unicode).
CreateMutexA | HANDLE CreateMutexA( LPSECURITY_ATTRIBUTES lpMutexAttributes, BOOL bInitialOwner, LPCTSTR lpName ); | kernel32.dll | Cette fonction permet de créer un objet Mutex nommé ou non-nommé.
CreateMutexW | HANDLE CreateMutexW( LPSECURITY_ATTRIBUTES lpMutexAttributes, BOOL bInitialOwner, LPCWSTR lpName ); | kernel32.dll | Cette fonction permet de créer un objet Mutex nommé ou non-nommé avec des paramètres de chaine de caractères étendue (Unicode).
CreateNamedPipeA | HANDLE CreateNamedPipeA( LPCTSTR lpName, DWORD dwOpenMode, DWORD dwPipeMode, DWORD nMaxInstances, DWORD nOutBufferSize, DWORD nInBufferSize, DWORD nDefaultTimeOut, LPSECURITY_ATTRIBUTES lpSecurityAttributes ); | kernel32.dll | Cette fonction permet de créer un tuyau avec un instance de nom spécifié et de retourner un identificateur Handle associé à celle-ci.
CreateNamedPipeW | HANDLE CreateNamedPipeW( LPCWSTR lpName, DWORD dwOpenMode, DWORD nMaxInstances, DWORD nOutBufferSize, DWORD nInBufferSize, DWORD nDefaultTimeOut, DWORD nDefaultTimeOut, LPSECURITY_ATTRIBUTES lpSecurityAttributes ); | kernel32.dll | Cette fonction permet de créer un tuyau avec un instance de nom spécifié et de retourner un identificateur Handle associé à celle-ci avec des paramètres de chaine de caractères étendue (Unicode).
CreatePalette | HPALETTE CreatePalette(CONST LOGPALETTE *lplgpl); | gdi32.dll | Cette fonction permet d'effectuer la création d'une palette logique.
CreatePatternBrush | HBRUSH CreatePatternBrush(HBITMAP hbmp); | gdi32.dll | Cette fonction permet d'effectuer la création d'une brosse logique avec la palette Bitmap spécifié.
CreatePen | HPEN CreatePen(int fnPenStyle, int nWidth, COLORREF crColor); | gdi32.dll | Cette fonction permet d'effectuer la création d'un crayon logique avec le style, la largeur et la couleur spécifié.
CreatePenIndirect | HPEN CreatePenIndirect(CONST LOGPEN * lplgpn); | gdi32.dll | Cette fonction permet d'effectuer la création d'un crayon logique avec le style, la largeur et la couleur à l'aide la structure de données spécifié.
CreatePipe | BOOL CreatePipe( PHANDLE hReadPipe, PHANDLE hWritePipe, LPSECURITY_ATTRIBUTES lpPipeAttributes, DWORD nSize ); | kernel32.dll | Cette fonction permet de créer un tuyau anonyme et de retourner un identificateur Handle attribué en lecture et écriture pour celle-ci.
CreatePolyPolygonRgn | HRGN CreatePolyPolygonRgn(CONST POINT *lppt, CONST INT *lpPolyCounts, int nCount, int fnPolyFillMode); | gdi32.dll | Cette fonction permet d'effectuer la création d'une région contenant une série de fermeture de polygone.
CreatePolygonRgn | HRGN CreatePolygonRgn(CONST POINT *lppt, int cPoints, int fnPolyFillMode); | gdi32.dll | Cette fonction permet d'effectuer la création d'une région en forme de polygone.
CreatePopupMenu | HMENU CreatePopupMenu(VOID) | user32.dll | Cette fonction permet d'effectuer la création d'un menu contextuel
CreatePrivateObjectSecurity | BOOL CreatePrivateObjectSecurity( PSECURITY_DESCRIPTOR ParentDescriptor, PSECURITY_DESCRIPTOR CreatorDescriptor, PSECURITY_DESCRIPTOR * NewDescriptor, BOOL IsDirectoryObject, HANDLE Token, PGENERIC_MAPPING GenericMapping ); | advapi32.dll | Cette fonction permet d'alloué et d'initialiser un descripteur de sécurité relatif à l'objet pour un un serveur d'objet protégé.
CreateProcessA | BOOL CreateProcessA( LPCTSTR lpApplicationName, LPTSTR lpCommandLine, LPSECURITY_ATTRIBUTES lpProcessAttributes, LPSECURITY_ATTRIBUTES lpThreadAttributes, BOOL bInheritHandles, DWORD dwCreationFlags, LPVOID lpEnvironment, LPCTSTR lpCurrentDirectory, LPSTARTUPINFO lpStartupInfo, LPPROCESS_INFORMATION lpProcessInformation ); | kernel32.dll | Cette fonction permet de créer un nouveau processus et de le fixer comme processus léger primaire.
CreateProcessW | BOOL CreateProcessW( LPCWSTR lpApplicationName, LPWSTR lpCommandLine, LPSECURITY_ATTRIBUTES lpProcessAttributes, LPSECURITY_ATTRIBUTES lpThreadAttributes, BOOL bInheritHandles, DWORD dwCreationFlags, PVOID lpEnvironment, LPCWSTR lpCurrentDirectory, LPSTARTUPINFOW lpStartupInfo, LPPROCESS_INFORMATION lpProcessInformation ); | kernel32.dll | Cette fonction permet de créer un nouveau processus et de le fixer comme processus léger primaire avec des paramètres de chaine de caractères étendue (Unicode).
CreateProcessAsUserA | BOOL CreateProcessAsUserA( HANDLE hToken LPCTSTR lpApplicationName, LPTSTR lpCommandLine, LPSECURITY_ATTRIBUTES lpProcessAttributes, LPSECURITY_ATTRIBUTES lpThreadAttributes, BOOL bInheritHandles, DWORD dwCreationFlags, LPVOID lpEnvironment, LPCTSTR lpCurrentDirectory, LPSTARTUPINFO lpStartupInfo, LPPROCESS_INFORMATION lpProcessInformation ); | advapi32.dll | Cette fonction permet de créer un nouveau processus et de le mettre comme processus primaire.
CreateProcessAsUserW | BOOL CreateProcessAsUserW( HANDLE hToken LPCWSTR lpApplicationName, LPWSTR lpCommandLine, LPSECURITY_ATTRIBUTES lpProcessAttributes, LPSECURITY_ATTRIBUTES lpThreadAttributes, BOOL bInheritHandles, DWORD dwCreationFlags, LPVOID lpEnvironment, LPWSTR lpCurrentDirectory, LPSTARTUPINFO lpStartupInfo, LPPROCESS_INFORMATION lpProcessInformation ); | advapi32.dll | Cette fonction permet de créer un nouveau processus et de le mettre comme processus primaire avec des paramètres de chaine de caractères étendue (Unicode).
CreateRectRgn | HRGN CreateRectRgn(int nLeftRect, int nTopRect, int nRightRect, int nBottomRect); | gdi32.dll | Cette fonction permet d'effectuer la création d'une région rectangulaire.
CreateRectRgnIndirect | HRGN CreateRectRgnIndirect(CONST RECT *lprc); | gdi32.dll | Cette fonction permet d'effectuer la création d'une région rectangulaire à l'aide d'une structure de données.
CreateRemoteThread | HANDLE CreateRemoteThread( HANDLE hProcess, LPSECURITY_ATTRIBUTES lpThreadAttributes, DWORD dwStackSize, LPTHREAD_START_ROUTINE lpStartAddress, LPVOID lpParameter, DWORD dwCreationFlags, LPDWORD lpThreadId ); | kernel32.dll | Cette fonction permet de créer un processus léger exécuté dans l'espace d'une adresse d'un autre processus.
CreateRoundRectRgn | HRGN CreateRoundRectRgn(int nLeftRect, int nTopRect, int nRightRect, int nBottomRect, int nWidthEllipse, int nHeightEllipse); | gdi32.dll | Cette fonction permet d'effectuer la création d'une région rectangulaire avec les coins arrondies.
CreateScalableFontResourceA | BOOL CreateScalableFontResourceA(DWORD fdwHidden, LPCTSTR lpszFontRes, LPCTSTR lpszFontFile, LPCTSTR lpszCurrentPath); | gdi32.dll | Cette fonction permet de créer un fichier de ressource de police de caractères avec une police de caractères vectorielle.
CreateScalableFontResourceW | BOOL CreateScalableFontResourceW(DWORD fdwHidden, LPCWSTR lpszFontRes, LPCWSTR lpszFontFile, LPCWSTR lpszCurrentPath); | gdi32.dll | Cette fonction permet de créer un fichier de ressource de police de caractères avec une police de caractères vectorielle avec des paramètres de chaine de caractères étendue (Unicode).
CreateSemaphoreA | HANDLE CreateSemaphoreA( LPSECURITY_ATTRIBUTES lpSemaphoreAttributes, LONG lInitialCount, LONG lMaximumCount, LPCTSTR lpName ); | kernel32.dll | Cette fonction permet de créer un objet de sémaphore nommé ou non-nommé.
CreateSemaphoreW | HANDLE CreateSemaphoreW( LPSECURITY_ATTRIBUTES lpSemaphoreAttributes, LONG lInitialCount, LONG lMaximumCount, LPCWSTR lpName ); | kernel32.dll | Cette fonction permet de créer un objet de sémaphore nommé ou non-nommé avec des paramètres de chaine de caractères étendue (Unicode).
CreateSolidBrush | HBRUSH CreateSolidBrush(COLORREF crColor); | gdi32.dll | Cette fonction permet d'effectuer la création d'une brosse logique avec la couleur et le motif solide spécifié.
CreateStatusWindowA | HWND CreateStatusWindowA( LONG style, LPCTSTR lpszText, HWND hwndParent, UINT wID ); | comctl32.dll | Cette fonction permet d'effectuer la création d'une barre d'état dans le bas d'une fenêtre d'application
CreateTapePartition | DWORD CreateTapePartition( HANDLE hDevice, DWORD dwPartitionMethod, DWORD dwCount, DWORD dwSize ); | kernel32.dll | Cette fonction permet de reformatté une unité de sauvegarde de bande magnétique (Tape Backup).
CreateToolhelp32Snapshot | HANDLE CreateToolhelp32Snapshot(DWORD dwFlags,DWORD th32ProcessID); | kernel32.dll | Cette fonction permet d'effectuer une capture de l'écran sous forme d'un Bitmap
CreateThread | HANDLE CreateThread( LPSECURITY_ATTRIBUTES lpThreadAttributes, DWORD dwStackSize, LPTHREAD_START_ROUTINE lpStartAddress, LPVOID lpParameter, DWORD dwCreationFlags, LPDWORD lpThreadId ); | kernel32.dll | Cette fonction permet de créer un processus pour exécuter un processus appelant dans un espace d'adressage.
CreateWaitableTimerA | HANDLE CreateWaitableTimerA( LPSECURITY_ATTRIBUTES lpTimerAttributes, BOOL bManualReset, LPCSTR lpTimerName ); | kernel32.dll | Cette fonction permet d'effectuer la création d'une horloge de délai d'attente.
CreateWaitableTimerW | HANDLE CreateWaitableTimerW( LPSECURITY_ATTRIBUTES lpTimerAttributes, BOOL bManualReset, LPCWSTR lpTimerName ); | kernel32.dll | Cette fonction permet d'effectuer la création d'une horloge de délai d'attente avec des paramètres de chaine de caractères étendue (Unicode).
CreateWindowExA | HWND CreateWindowExA( DWORD dwExStyle, LPCTSTR lpClassName, LPCTSTR lpWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU hMenu, HINSTANCE hInstance, LPVOID lpParam ); | user32.dll | Cette fonction permet d'effectuer la création d'une sous-fenêtre (PopUp).
CreateWindowExW | HWND CreateWindowExW(DWORD dwExStyle, LPCWSTR lpClassName, LPCWSTR lpWindowName, DWORD dwStyle, int x, int y, int nWidth, int nHeight, HWND hWndParent, HMENU hMenu, HINSTANCE hInstance, LPVOID lpParam); | user32.dll | Cette fonction permet d'effectuer la création d'une sous-fenêtre (PopUp) avec des paramètres de chaine de caractères étendues (Unicode).
CreateWindowStationA | HWINSTA CreateWindowStationA(LPTSTR lpwinsta, DWORD dwReserved, DWORD dwDesiredAccess, LPSECURITY_ATTRIBUTES lpsa); | user32.dll | Cette fonction permet d'effectuer la création d'un objet de fenêtre de station.
CreateWindowStationW | HWINSTA CreateWindowStationW(LPCWSTR lpwinsta, DWORD dwReserved, DWORD dwDesiredAccess, LPSECURITY_ATTRIBUTES lpsa); | user32.dll | Cette fonction permet d'effectuer la création d'un objet de fenêtre de station avec des paramètres de chaine de caractères étendues (Unicode).
DdeSetQualityOfService | BOOL DdeSetQualityOfService(HWND hwndClient, const SECURITY_QUALITY_OF_SERVICE *pqosNew, PSECURITY_QUALITY_OF_SERVICE pqosPrev); | user32.dll | Cette fonction permet de spécifier le service de qualité (QoS) des applications d'échanges de données dynamique brute (DDE) désiré pour de future initialisation de conversion DDE.
DebugActiveProcess | BOOL DebugActiveProcess( DWORD dwProcessId ); | kernel32.dll | Cette fonction permet d'allouer une débogueur à attaché avec un processus actif
DebugBreak | VOID DebugBreak(VOID); | kernel32.dll | Cette fonction permet de provoqué une exception sur un point d'arrêt dans le processus courant.
DefDlgProcA | LRESULT DefDlgProcA(HWND hDlg, UINT Msg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer le traitement de processus de fenêtre de message par défaut.
DefDlgProcW | LRESULT DefDlgProcW(HWND hDlg, UINT Msg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer le traitement de processus de fenêtre de message par défaut avec des paramètres de chaine de caractères étendues (Unicode).
DeferWindowPos | HDWP DeferWindowPos(HDWP hWinPosInfo, HWND hWnd, HWND hWndInsertAfter, int x, int y, int cx, int cy, UINT uFlags); | user32.dll | Cette fonction permet de mettre à jour la structure de positionnement d'une fenêtre.
DefFrameProcA | LRESULT DefFrameProcA(HWND hWnd, HWND hWndMDIClient, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer le processus de message par défaut du cadre d'une fenêtre MDI.
DefFrameProcW | LRESULT DefFrameProcW(HWND hWnd, HWND hWndMDIClient, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer le processus de message par défaut du cadre d'une fenêtre MDI avec des paramètres de chaine de caractères étendues (Unicode).
DefineDosDeviceA | BOOL DefineDosDeviceA( DWORD dwFlags, LPCTSTR lpDeviceName, LPCTSTR lpTargetPath ); | kernel32.dll | Cette fonction permet de définir, redéfinir ou supprimer un nom de périphérique DOS.
DefineDosDeviceW | BOOL DefineDosDeviceW( DWORD dwFlags, LPCWSTR lpDeviceName, LPCWSTR lpTargetPath ); | kernel32.dll | Cette fonction permet de définir, redéfinir ou supprimer un nom de périphérique DOS avec des paramètres de chaine de caractères étendue (Unicode).
DefMDIChildProcA | LRESULT DefMDIChildProcA(HWND hWnd, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet de définir le processus de message de la fenêtre enfant MDI.
DefMDIChildProcW | LRESULT DefMDIChildProcW(HWND hWnd, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet de définir le processus de message de la fenêtre enfant MDI avec des paramètres de chaine de caractères étendues (Unicode).
DefWindowProcA | LRESULT DefWindowProcA(HWND hWnd, UINT Msg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet de créer un événement produit par défaut lorsqu'une action est effectuer dans la fenêtre.
DefWindowProcW | LRESULT DefWindowProcW(HWND hwnd, UINT msg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet de créer un événement produit par défaut lorsqu'une action est effectué dans la fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
DeleteAce | BOOL DeleteAce( PACL pAcl, DWORD dwAceIndex ); | advapi32.dll | Cette fonction permet d'effacer une entrée de contrôle d'accès (ACE) d'une liste de contrôle d'accès (ACL).
DeleteAtom | ATOM DeleteAtom( ATOM nAtom ); | kernel32.dll | Cette fonction permet de décrémenter le compteur de référence de chaine de caractères d'Atom local.
DeleteColorSpace | BOOL DeleteColorSpace(HCOLORSPACE hColorSpace); | gdi32.dll | Cette fonction permet de supprimer l'espace de couleur spécifié et libérer tous les ressources internes associé avec celui-ci.
DeleteCriticalSection | VOID DeleteCriticalSection( LPCRITICAL_SECTION lpCriticalSection ); | kernel32.dll | Cette fonction permet de terminer et restituer tous les ressources associé à l'objet de section critique.
DeleteDC | BOOL DeleteDC(HDC hdc); | gdi32.dll | Cette fonction permet d'effectuer la suppression d'un périphérique de contexte (DC).
DeleteEnhMetaFile | BOOL DeleteEnhMetaFile(HENHMETAFILE hemf); | gdi32.dll | Cette fonction permet de supprimer le format étendue du fichier méta ou le Handle du fichier méta de format étendue.
DeleteFiber | VOID DeleteFiber( LPVOID lpFiber ); | kernel32.dll | Cette fonction permet de supprimer une fibre existante.
DeleteFileA | BOOL DeleteFileA( LPCTSTR lpFileName ); | kernel32.dll | Cette fonction permet de supprimer un fichier existant.
DeleteFileW | BOOL DeleteFileW( LPCWSTR path ); | kernel32.dll | Cette fonction permet de supprimer un fichier existant avec des paramètres de chaine de caractères étendue (Unicode).
DeleteMenu | BOOL DeleteMenu(HMENU hMenu,UINT uPosition,UINT uFlags); | user32.dll | Cette fonction permet de supprimer un item de menu.
DeleteMetaFile | BOOL DeleteMetaFile(HMETAFILE hmf); | gdi32.dll | Cette fonction permet de supprimer un fichier de méta de format Windows ou le Handle d'un fichier méta de format Windows.
DeleteObject | BOOL DeleteObject(HGDIOBJ hObject); | gdi32.dll | Cette fonction permet de supprimer un crayon, une brosse, une police de caractères, un Bitmap ou une palette logique et d'ainsi libérer les ressources systèmes associé avec cette objet.
DeletePrinter | BOOL DeletePrinter(HANDLE hPrinter); | winspool.drv | Cette fonction permet de supprimer un objet d'imprimante.
DeregisterEventSource | BOOL DeregisterEventSource( HANDLE hEventLog ); | advapi32.dll | Cette fonction permet de fermer un identificateur Handle d'enregistrement d'événement retourner par une fonction «RegisterEventSource».
DescribePixelFormat | int DescribePixelFormat(HDC hdc, int iPixelFormat, UINT nBytes, LPPIXELFORMATDESCRIPTOR ppfd); | gdi32.dll | Cette fonction permet de demander les informations à propos du format d'un pixel spécifié d'un périphérique spécifié.
DestroyAcceleratorTable | BOOL DestroyAcceleratorTable(HACCEL hAccel); | user32.dll | Cette fonction permet de détruire la table d'accélérateur.
DestroyCaret | BOOL DestroyCaret(VOID); | user32.dll | Cette fonction permet de supprimer le caret courant.
DestroyCursor | BOOL DestroyCursor(HCURSOR hCursor); | user32.dll | Cette fonction permet de supprimer une image de pointeur de souris
DestroyIcon | BOOL DestroyIcon(HICON hIcon); | user32.dll | Cette fonction permet de supprimer une icône
DestroyMenu | BOOL DestroyMenu(HMENU hMenu); | user32.dll | Cette fonction permet de supprimer un menu contextuel
DestroyPrivateObjectSecurity | BOOL DestroyPrivateObjectSecurity( PSECURITY_DESCRIPTOR * ObjectDescriptor ); | advapi32.dll | Cette fonction permet d'effacer un descripteur de sécurité d'un objet serveur protégé.
DestroyWindow | BOOL DestroyWindow(HWND hWnd); | user32.dll | Cette fonction permet de supprimer une fenêtre
DeviceCapabilitiesExA | DWORD DeviceCapabilitiesA(LPCSTR pDriverName, LPCSTR pDeviceName, LPCSTR pPort, WORD iIndex, LPSTR pOutput, const DEVMODEA* DevMode); | gdi32.dll | Cette fonction permet de demander la compatibilité pour le pilote d'imprimante spécifié.
DeviceCapabilitiesExW | DWORD DeviceCapabilitiesExW(LPCWSTR pDriverName, LPCWSTR pDeviceName, LPCWSTR pPort, WORD iIndex, LPWSTR pOutput, CONST DEVMODEW* DevMode); | gdi32.dll | Cette fonction permet de demander la compatibilité pour le pilote d'imprimante spécifié avec des paramètres de chaine de caractères étendues (Unicode).
DeviceIoControl | BOOL DeviceIoControl( HANDLE hDevice, DWORD dwIoControlCode, LPVOID lpInBuffer, DWORD nInBufferSize, LPVOID lpOutBuffer, DWORD nOutBufferSize, LPDWORD lpBytesReturned, LPOVERLAPPED lpOverlapped ); | kernel32.dll | Cette fonction permet d'envoyer des codes de contrôles directement à un pilote de périphérique.
DialogBoxIndirectParamA | int DialogBoxIndirectParamA(HINSTANCE hInstance, LPCDLGTEMPLATE hDialogTemplate, HWND hWndParent, DLGPROC lpDialogFunc, LPARAM dwInitParam); | user32.dll | Cette fonction permet de créer une boite de dialogue modèle à l'aide d'un gabarit en mémoire et des paramètres spécifiés.
DialogBoxIndirectParamW | int DialogBoxIndirectParamW(HINSTANCE hInstance, LPCDLGTEMPLATE hDialogTemplate, HWND hWndParent, DLGPROC lpDialogFunc, LPARAM dwInitParam); | user32.dll | Cette fonction permet de créer une boite de dialogue modèle à l'aide d'un gabarit en mémoire et des paramètres spécifiés avec des parmètres de chaine de caractères étendues (Unicode).
DialogBoxParamA | int DialogBoxParamA(HINSTANCE hInstance, LPCTSTR lpTemplateName, HWND hWndParent, DLGPROC lpDialogFunc, LPARAM dwInitParam); | user32.dll | Cette fonction permet de créer une boite de dialogue modèle et des paramètres spécifiés.
DialogBoxParamW | int DialogBoxParamW(HINSTANCE hInstance, LPCWSTR lpTemplateName, HWND hWndParent, DLGPROC lpDialogFunc, LPARAM dwInitParam); | user32.dll | Cette fonction permet de créer une boite de dialogue modèle et des paramètres spécifiés avec des paramètres de chaine de caractères étendues (Unicode).
DisableThreadLibraryCalls | BOOL DisableThreadLibraryCalls( HMODULE hLibModule ); | kernel32.dll | Cette fonction permet de désactiver les avertissements «DLL_THREAD_ATTACH» et «DLL_THREAD_DETACH» des bibliothèques de lien dynamique (DLL) spécifié.
DisconnectNamedPipe | BOOL DisconnectNamedPipe( HANDLE hNamedPipe ); | kernel32.dll | Cette fonction permet de déconnecter le serveur de fin de tuyau nommé pour un processus client.
DiskCopyRunDll | int DiskCopyRunDll(IN LPSTR Unuse1,IN LPSTR Unuse2,IN LPSTR pszDriveNumber,IN LPSTR Unuse3); | diskcopy.dll | Cette fonction permet de lancer une boite de dialogue offrant la possibilité d'effectuer une copie d'unité de disquette
DispatchMessageA | LONG DispatchMessageA(CONST MSG * lpmsg); | user32.dll | Cette fonction permet de redistribuer le messages de fenêtre.
DispatchMessageW | LRESULT DispatchMessageW(const MSG* msg); | user32.dll | Cette fonction permet de redistribuer le messages de fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
DlgDirListA | int DlgDirListA(HWND hDlg, LPTSTR lpPathSpec, int nIDListBox, int nIDStaticPath, UINT uFileType); | user32.dll | Cette fonction permet de remplir une boite de dialogue avec une liste de fichiers et de répertoires.
DlgDirListW | int DlgDirListW(HWND hDlg, LPWSTR lpPathSpec, int nIDListBox, int nIDStaticPath, UINT uFileType); | user32.dll | Cette fonction permet de remplir une boite de dialogue avec une liste de fichiers et de répertoires avec des paramètres de chaine de caractères étendues (Unicode).
DlgDirListComboBoxA | int DlgDirListComboBoxA(HWND hDlg, LPTSTR lpPathSpec, int nIDComboBox, int nIDStaticPath, UINT uFiletype); | user32.dll | Cette fonction permet de remplir une boite combinée (Combo Box) avec une liste de fichiers et de répertoires.
DlgDirListComboBoxW | int DlgDirListComboBoxW(HWND hDlg, LPWSTR lpPathSpec, int nIDComboBox, int nIDStaticPath, UINT uFiletype); | user32.dll | Cette fonction permet de remplir une boite combinée (Combo Box) avec une liste de fichiers et de répertoires avec des paramètres de chaine de caractères étendues (Unicode).
DlgDirSelectComboBoxExA | BOOL DlgDirSelectComboBoxExA(HWND hDlg, LPTSTR lpString, int nCount, int nIDComboBox); | user32.dll | Cette fonction permet de demander la sélection courante d'une boite combinée remplit par la fonction DlgDirListComboBox.
DlgDirSelectComboBoxExW | BOOL DlgDirSelectComboBoxExW(HWND hDlg, LPWSTR lpString, int nCount, int nIDComboBox); | user32.dll | Cette fonction permet de demander la sélection courante d'une boite combinée remplit par la fonction DlgDirListComboBox avec des paramètres de chaine de caractères étendues (Unicode).
DlgDirSelectExA | BOOL DlgDirSelectExA(HWND hDlg, LPTSTR lpString, int nCount, int nIDListBox); | user32.dll | Cette fonction permet de demander la sélection courante étendue d'une liste de boite.
DlgDirSelectExW | BOOL DlgDirSelectExW(HWND hDlg, LPWSTR lpString, int nCount, int nIDListBox); | user32.dll | Cette fonction permet de demander la sélection courante étendue d'une liste de boite avec des paramètres de chaine de caractères étendues (Unicode).
DllGetVersion | HRESULT CALLBACK DllGetVersion(DLLVERSIONINFO *pdvi); | shell32.dll | Cette fonction permet de demander les informations de la version de DLL
DosDateTimeToFileTime | BOOL DosDateTimeToFileTime( WORD wFatDate, WORD wFatTime, LPFILETIME lpFileTime ); | kernel32.dll | Cette fonction permet de convertir la valeur d'une date et d'une heure du DOS en un temps fichier de 64 bits.
DPtoLP | BOOL DPtoLP(HDC hdc, LPPOINT lpPoints, int nCount); | gdi32.dll | Cette fonction permet d'effectuer la conversion des coordonnées d'un périphérique en coordonnées logique.
DragAcceptFiles | VOID DragAcceptFiles(HWND hWnd,BOOL fAccept); | shell32.dll | Cette fonction permet de fixer l'état du drapeau indiquant si la fenêtre accepte les fichiers glissées
DragDetect | BOOL DragDetect(HWND hwnd, POINT pt); | user32.dll | Cette fonction permet de déterminer quand une fonction de glisser-déposer (drag and drop) est mis en place.
DragObject | DWORD DragObject(HWND hWndScope, HWND hWndObj, UINT wObjType, DWORD hOfStruct, HCURSOR hDragCursor); | user32.dll | Cette fonction permet d'intéger une composante serveur de glisser-déposer (drag and drop).
DragFinish | VOID DragFinish(HDROP hDrop); | shell32.dll | Cette fonction permet de restituer la mémoire employé pour le transfert des noms de fichiers vers une fenêtre d'application
DragQueryFile | UINT DragQueryFile(HDROP hDrop,UINT iFile,LPTSTR lpszFile,UINT cch); | shell32.dll | Cette fonction permet de demander les noms de fichiers lors d'un transfert des noms de fichiers vers une fenêtre d'application
DrawAnimatedRects | BOOL DrawAnimatedRects(HWND hwnd, int idAni, CONST RECT * lprcFrom, CONST RECT * lprcTo); | user32.dll | Cette fonction permet de dessiner un cadre de rectangle et d'animer l'icône ouvert.
DrawCaption | void DrawCaption(HDC hdc, LPRECT lprc, HFONT hfont, HICON hicon, LPSTR lpszText, WORD wFlags); | user32.dll | Cette fonction permet de dessiner une fenêtre de légende.
DrawEdge | BOOL DrawEdge(HDC hdc, LPRECT qrc, UINT edge, UINT grfFlags); | user32.dll | Cette fonction permet de dessiner une ou plusieurs bordures d'un rectangle.
DrawEscape | int DrawEscape(HDC hdc, int nEscape, int cbInput, LPCSTR lpszInData); | gdi32.dll | Cette fonction permet d'accéder à la compatibilité de dessinage de l'affichage d'un vidéo n'étant pas directement disponible par le GDI (Graphics Device Interface).
DrawFocusRect | BOOL DrawFocusRect(HDC hDC, CONST RECT * lprc); | user32.dll | Cette fonction permet de dessiner un rectangle avec un style indiquant qu'il est focusé.
DrawFrameControl | BOOL DrawFrameControl(HDC hdc, LPRECT lprc, UINT uType, UINT uState); | user32.dll | Cette fonction permet de dessiner un cadre de contrôle pour le type et le style spécifié.
DrawIcon | BOOL DrawIcon(HDC hDC,int X,int Y,HICON hIcon); | user32.dll | Cette fonction permet d'afficher une icône dans la fenêtre d'application du contexte de l'objet
DrawIconEx | BOOL DrawIconEx(HDC hdc, int xLeft, int yTop, HICON hIcon, int cxWidth, int cyWidth, UINT istepIfAniCur, HBRUSH hbrFlickerFreeDraw, UINT diFlags); | user32.dll | Cette fonction permet d'afficher un icône ou un curseur dans une région client d'une fenêtre d'un périphérique de contexte donnée, d'effectuer des opérations de traitement de trame spécifié et d'étirement ou de compression de l'icône ou le curseur spécifié.
DrawMenuBar | BOOL DrawMenuBar(HWND hWnd); | user32.dll | Cette fonction permet de réafficher la barre de menu de la fenêtre d'application.
DrawStateA | BOOL DrawStateA(HDC hdc, HBRUSH hbr, DRAWSTATEPROC lpOutputFunc, LPARAM lData, WPARAM wData, int x, int y, int cx, int cy, UINT fuFlags); | user32.dll | Cette fonction permet d'afficher une image et d'appliquer un effet visuel indiquant son état, laquelle peut être désactiver ou un état par défaut.
DrawStateW | BOOL DrawStateW(HDC hdc, HBRUSH hbr, DRAWSTATEPROC lpOutputFunc, LPARAM lData, WPARAM wData, int x, int y, int cx, int cy, UINT fuFlags); | user32.dll | Cette fonction permet d'afficher une image et d'appliquer un effet visuel indiquant son état, laquelle peut être désactiver ou un état par défaut avec des paramètres de chaine de caractères étendues (Unicode).
DrawTextA | int DrawTextA(HDC hDC, LPCTSTR lpString, int nCount, LPRECT lpRect, UINT uFormat); | user32.dll | Cette fonction permet de dessiner le texte formatté dans le rectangle spécifié.
DrawTextW | int DrawTextW(HDC hDC, LPCWSTR lpString, int nCount, LPRECT lpRect, UINT uFormat); | user32.dll | Cette fonction permet de dessiner le texte formatté dans le rectangle spécifié avec des paramètres de chaine de caractères étendues (Unicode).
DrawTextExA | int DrawTextExA(HDC hdc, LPTSTR lpchText, int cchText, LPRECT lprc, UINT dwDTFormat, LPDRAWTEXTPARAMS lpDTParams); | user32.dll | Cette fonction permet de dessiner le texte formatté dans le rectangle spécifié avec des paramètres supplémentaires.
DrawTextExW | int DrawTextExW(HDC hdc, LPWSTR lpchText, int cchText, LPRECT lprc, UINT dwDTFormat, LPDRAWTEXTPARAMS lpDTParams); | user32.dll | Cette fonction permet de dessiner le texte formatté dans le rectangle spécifié avec des paramètres supplémentaires et des chaines de caractères étendues (Unicode).
DuplicateHandle | BOOL DuplicateHandle( HANDLE hSourceProcessHandle, HANDLE hSourceHandle, HANDLE hTargetProcessHandle, LPHANDLE lpTargetHandle, DWORD dwDesiredAccess, BOOL bInheritHandle, DWORD dwOptions ); | kernel32.dll | Cette fonction permet de dupliquer un objet d'identificateur Handle existant.
DuplicateIcon | HICON DuplicateIcon(HINSTANCE hInst,HICON hIcon); | shell32.dll | Cette fonction permet d'effectuer la création d'un nouvel icône identique à une autre icône spécifié.
DuplicateToken | BOOL DuplicateToken( HANDLE ExistingTokenHandle, SECURITY_IMPERSONATION_LEVEL ImpersonationLevel, PHANDLE DuplicateTokenHandle ); | advapi32.dll | Cette fonction permet de créer un nouvel accès de jeton dupliqué sur un autre jeton déjà existant.
DuplicateTokenEx | BOOL DuplicateTokenEx( HANDLE hExistingToken, DWORD dwDesiredAccess, LPSECURITY_ATTRIBUTES lpTokenAttributes, SECURITY_IMPERSONATION_LEVEL ImpersonationLevel, TOKEN_TYPE TokenType, PHANDLE phNewToken ); | advapi32.dll | Cette fonction permet d'effectuer la conversion d'un jeton spécifié par un jeton principal.
DvdLauncher | BOOL DvdLauncher(HWND HWnd,CHAR DriveLetter); | storprop.dll | Cette fonction permet de vérifier si la région que contient le DVD correspond avec celle du système d'exploitation.
Ellipse | BOOL Ellipse(HDC hdc,int nLeftRect,int nTopRect,int nRightRect,int nBottomRect); | gdi32.dll | Cette fonction permet d'effectuer l'afficher d'une ellipse (forme d'ovale).
EmptyClipboard | BOOL EmptyClipboard(VOID); | user32.dll | Cette fonction permet de vider complètement le tampon du presse-papier.
EnableMenuItem | BOOL EnableMenuItem(HMENU hMenu,UINT uIDEnableItem,UINT uEnable); | user32.dll | Cette fonction permet d'activer ou de désactiver un item de menu déroulant.
EnableScrollBar | BOOL EnableScrollBar(HWND hWnd,UINT wSBflags, UINT wArrows); | user32.dll | Cette fonction permet d'activer ou de désactiver les barres de défilement dans une fenêtre d'application.
EnableWindow | BOOL EnableWindow(HWND hWnd,BOOL bEnable); | user32.dll | Cette fonction permet d'activer ou de désactiver les événements clavier et souris et les contrôles dans une fenêtre d'application.
EndDeferWindowPos | BOOL EndDeferWindowPos(HDWP hWinPosInfo); | user32.dll | Cette fonction permet d'effectuer la simulation de mise-à-jour de position et de taille d'une ou plusieurs fenêtres dans un simple cycle de rafraichissement d'écran.
EndDialog | BOOL EndDialog(HWND hDlg, int nResult); | user32.dll | Cette fonction permet de cacher un modèle de boite de dialogue.
EndDoc | int EndDoc(HDC hdc); | gdi32.dll | Cette fonction permet d'indiquer que l'application a terminé d'envoyer des données au tampon d'impression de l'imprimante.
EndPage | int EndPage(HDC hdc); | gdi32.dll | Cette fonction permet d'indiquer que l'application a terminé d'envoyer une page de données au tampon d'impression de l'imprimante.
EndPaint | BOOL EndPaint(HWND hWnd, CONST PAINTSTRUCT *lpPaint); | user32.dll | Cette fonction permet de marquer la fin du traitement de peinture d'une fenêtre spécifié.
EndPath | BOOL EndPath(HDC hdc); | gdi32.dll | Cette fonction permet de fermer une braquette de chemin et sélectionne le chemin définit par la braquette dans le périphérique de contexte (DC) spécifié.
EndUpdateResourceA | BOOL EndUpdateResourceA( HANDLE hUpdate, BOOL fDiscard ); | kernel32.dll | Cette fonction permet de terminer la mise-à-jour d'une ressource d'un fichier exécutable.
EndUpdateResourceW | BOOL EndUpdateResourceW(HANDLE hUpdate,BOOL fDiscard); | kernel32.dll | Cette fonction permet de terminer la mise-à-jour d'une ressource d'un fichier exécutable avec des paramètres de chaine de caractères étendue (Unicode).
EnterCriticalSection | VOID EnterCriticalSection( LPCRITICAL_SECTION lpCriticalSection ); | kernel32.dll | Cette fonction permet d'attendre après un propriétaire d'objet de section critique spécifié.
EnumCalendarInfoA | BOOL EnumCalendarInfoA( CALINFO_ENUMPROC lpCalInfoEnumProc, LCID Locale, CALID Calendar, CALTYPE CalType ); | kernel32.dll | Cette fonction permet d'énumérer des informations de calendrier d'une région local spécifié
EnumCalendarInfoW | BOOL EnumCalendarInfoW( CALINFO_ENUMPROCW calinfoproc, LCID locale, CALID calendar, CALTYPE caltype ); | kernel32.dll | Cette fonction permet d'énumérer des informations de calendrier d'une région local spécifié avec des paramètres de chaine de caractères étendue (Unicode).
EnumChildWindows | BOOL EnumChildWindows(HWND hWndParent, WNDENUMPROC lpEnumFunc, LPARAM lParam); | user32.dll | Cette fonction permet d'énumérer les fenêtres enfants de la fenêtre parent en passant le Handle de chaque fenêtre enfant avec une fonction d'application utilisateur.
EnumClipboardFormats | UINT EnumClipboardFormats(UINT format); | user32.dll | Cette fonction permet de retourner les formats de presse-papier disponibles.
EnumDateFormatsA | BOOL EnumDateFormatsA( DATEFMT_ENUMPROC lpDateFmtEnumProc, LCID Locale, DWORD dwFlags ); | kernel32.dll | Cette fonction permet d'énumérer le format de la date courte ou longue disponible pour la région locale.
EnumDateFormatsW | BOOL EnumDateFormatsW( DATEFMT_ENUMPROCW lpDateFmtEnumProc, LCID Locale, DWORD dwFlags); | kernel32.dll | Cette fonction permet d'énumérer le format de la date courte ou longue disponible pour la région locale avec des paramètres de chaine de caractères étendue (Unicode).
EnumDesktopsA | BOOL EnumDesktopsA(HWINSTA hwinsta, DESKTOPENUMPROC lpEnumFunc, LPARAM lParam); | user32.dll | Cette fonction permet de demander l'énumération de tous les bureaux d'une fenêtre de travail associé avec un processus appelant.
EnumDesktopsW | BOOL EnumDesktopsW(HWINSTA hwinsta, DESKTOPENUMPROCW lpEnumFunc, LPARAM lParam); | user32.dll | Cette fonction permet de demander l'énumération de tous les bureaux d'une fenêtre de travail associé avec un processus appelant avec des paramètres de chaine de caractères étendues (Unicode).
EnumDesktopWindows | BOOL EnumDesktopWindows(HDESK hDesktop, WNDENUMPROC lpfn, LPARAM lParam); | user32.dll | Cette fonction permet de demander l'énumération de tous les bureaux passé par le Handle de chaque fenêtre, par l'entremise d'une fonction utilisateur.
EnumDisplaySettingsA | BOOL EnumDisplaySettingsA(LPCTSTR lpszDeviceName,DWORD iModeNum,LPDEVMODE lpDevMode); | user32.dll | Cette fonction permet de demander des informations sur le système d'affichage.
EnumDisplaySettingsW | BOOL EnumDisplaySettingsW(LPCWSTR lpszDeviceName, DWORD iModeNum, PDEVMODEW lpDevMode); | user32.dll | Cette fonction permet de demander des informations sur le système d'affichage avec des paramètres de chaine de caractères étendues (Unicode).
EnumEnhMetaFile | BOOL EnumEnhMetaFile(HDC hdc, HENHMETAFILE hemf, ENHMFENUMPROC lpEnhMetaFunc, LPVOID lpData, CONST RECT * lpRect); | gdi32.dll | Cette fonction permet d'énumérer les enregistrements d'un format étendue d'un méta fichier afin de demander chaques enregistrements et de les passés par une fonction utilisateur.
EnumFontFamiliesA | int EnumFontFamiliesA(HDC hdc, LPCTSTR lpszFamily, FONTENUMPROC lpEnumFontFamProc, LPARAM lParam); | gdi32.dll | Cette fonction permet d'énumérer les polices de caractères d'une famille de police de caractères spécifié étant disponible pour un périphérique spécifié.
EnumFontFamiliesW | int EnumFontFamiliesW(HDC hdc, PLOGFONTW lpszFamily, FONTENUMPROCW lpEnumFontFamProc, LPARAM lParam); | gdi32.dll | Cette fonction permet d'énumérer les polices de caractères d'une famille de police de caractères spécifié étant disponible pour un périphérique spécifié avec des paramètres de chaine de caractères étendues (Unicode).
EnumFontFamiliesExA | int EnumFontFamiliesExA(HDC hdc, LPLOGFONT lpLogfont, FONTENUMPROC lpEnumFontFamExProc, LPARAM lParam, DWORD dwFlags); | gdi32.dll | Cette fonction permet d'énumérer toutes les polices de caractères système correspondant aux caractéristiques de polices de caractères spécifié par une structure.
EnumFontFamiliesExW | int EnumFontFamiliesExW(HDC hdc, LPLOGFONTW lpLogfont, FONTENUMPROCW lpEnumFontFamExProc, LPARAM lParam, DWORD dwFlags); | gdi32.dll | Cette fonction permet d'énumérer toutes les polices de caractères système correspondant aux caractéristiques de polices de caractères spécifié par une structure avec des paramètres de chaine de caractères étendues (Unicode).
EnumFontsA | int EnumFontsA(HDC hdc, LPCTSTR lpFaceName, FONTENUMPROC lpFontFunc, LPARAM lParam); | gdi32.dll | Cette fonction permet d'énumérer les polices de caractères disponibles pour le périphérique spécifié.
EnumFontsW | int EnumFontsW(HDC hDC, LPCWSTR lpFaceName, FONTENUMPROCW FontFunc, LPARAM lParam); | gdi32.dll | Cette fonction permet d'énumérer les polices de caractères disponibles pour le périphérique spécifié avec des paramètres de chaine de caractères étendues (Unicode).
EnumICMProfilesA | int EnumICMProfilesA(HDC hdc, ICMENUMPROC lpICMEnumFunc, LPARAM lParam); | gdi32.dll | Cette fonction permet d'énumérer les différents profiles de couleurs étant supporté par le système pour le périphérique de contexte spécifié.
EnumICMProfilesW | int EnumICMProfilesW(HDC hDC, ICMENUMPROCW lpEnumICMProfilesFunc, LPARAM lParam); | gdi32.dll | Cette fonction permet d'énumérer les différents profiles de couleurs étant supporté par le système pour le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
EnumJobsA | BOOL EnumJobsA( HANDLE hPrinter, DWORD FirstJob, DWORD NoJobs, DWORD Level, LPBYTE pJob, DWORD cbBuf, LPDWORD pcbNeeded, LPDWORD pcReturned ); | winspool.drv | Cette fonction permet de définir les travaux d'impressions d'une imprimante.
EnumMetaFile | BOOL EnumMetaFile(HDC hdc, HMETAFILE hmf, MFENUMPROC lpMetaFunc, LPARAM lParam); | gdi32.dll | Cette fonction permet de demander d'énumérer les enregistrements de fichier méta de format Windows en utilisant une fonction d'application utilisateur.
EnumObjects | int EnumObjects(HDC hdc, int nObjectType, GOBJENUMPROC lpObjectFunc, LPARAM lParam); | gdi32.dll | Cette fonction permet d'énumérer les crayons et les brosses disponibles pour le périphérique de contexte spécifié.
EnumPortsA | BOOL EnumPortsA( LPTSTR pName, DWORD Level, LPBYTE pPorts, DWORD cbBuf, LPDWORD pcbNeeded, LPDWORD pcReturned ); | winspool.drv | Cette fonction permet de demander les ports d'impressions d'imprimante disponible.
EnumPrintersA | BOOL EnumPrintersA( DWORD Flags, LPTSTR Name, DWORD Level, LPBYTE pPrinterEnum, DWORD cbBuf, LPDWORD pcbNeeded, LPDWORD pcReturned ); | winspool.drv | Cette fonction permet de demander des informations sur une imprimante.
EnumPropsA | int EnumPropsA(HWND hWnd, PROPENUMPROC lpEnumFunc); | user32.dll | Cette fonction permet d'effectuer le passage de la liste des entrées de propriétés par l'intermédiaire d'une fonction utilisateur.
EnumPropsExA | int EnumPropsExA(HWND hWnd, PROPENUMPROCEX lpEnumFunc, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer le passage de la liste des entrées de propriétés par l'intermédiaire d'une fonction utilisateur avec des paramètres supplémentaires.
EnumPropsExW | int EnumPropsExW(HWND hWnd, PROPENUMPROCEXW lpEnumFunc, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer le passage de la liste des entrées de propriétés par l'intermédiaire d'une fonction utilisateur avec des paramètres supplémentaires et des chaines de caractères étendues (Unicode).
EnumPropsW | int EnumPropsW(HWND hWnd, PROPENUMPROCW lpEnumFunc); | user32.dll | Cette fonction permet d'effectuer le passage de la liste des entrées de propriétés par l'intermédiaire d'une fonction utilisateur avec des paramètres de chaine de caractères étendues (Unicode).
EnumResourceLanguagesA | BOOL EnumResourceLanguagesA( HMODULE hModule, LPCTSTR lpType, LPCTSTR lpName, ENUMRESLANGPROC lpEnumFunc, LONG lParam ); | kernel32.dll | Cette fonction permet de rechercher un module pour chaque ressource d'un type spécifié et de passé le langage pour chaque ressource trouvé dans une fonction définie en arrière plan.
EnumResourceLanguagesW | BOOL EnumResourceLanguagesW( HMODULE hModule, LPCWSTR lpType, LPCWSTR lpName, ENUMRESLANGPROC lpEnumFunc, LONG_PTR lParam ); | kernel32.dll | Cette fonction permet de rechercher un module pour chaque ressource d'un type spécifié et de passé le langage pour chaque ressource trouvé dans une fonction définie en arrière plan avec des paramètres de chaine de caractères étendue (Unicode).
EnumResourceNamesA | BOOL EnumResourceNamesA( HINSTANCE hModule, LPCTSTR lpszType, ENUMRESNAMEPROC lpEnumFunc, LONG lParam ); | kernel32.dll | Cette fonction permet de rechercher un module pour chaque ressource d'un type spécifié et de passé le langage pour chaque ressource trouvé dans une fonction d'application définie en arrière plan.
EnumResourceNamesW | BOOL EnumResourceNamesW( HMODULE hModule, LPCWSTR lpszType, ENUMRESNAMEPROC lpEnumFunc, LONG_PTR lParam ); | kernel32.dll | Cette fonction permet de rechercher un module pour chaque ressource d'un type spécifié et de passé le langage pour chaque ressource trouvé dans une fonction d'application définie en arrière plan avec des paramètres de chaine de caractères étendue (Unicode).
EnumResourceTypesA | BOOL EnumResourceTypesA( HMODULE hModule, ENUMRESTYPEPROC lpEnumFunc, LONG lParam ); | kernel32.dll | Cette fonction permet de rechercher un module pour une ressource et de passé chaque type de ressource dans une fonction d'application définie en arrière plan.
EnumResourceTypesW | BOOL EnumResourceTypesW( HMODULE hModule, ENUMRESTYPEPROC lpEnumFunc, , LONG_PTR lParam ); | kernel32.dll | Cette fonction permet de rechercher un module pour une ressource et de passé chaque type de ressource dans une fonction d'application définie en arrière plan avec des paramètres de chaine de caractères étendue (Unicode).
EnumSystemCodePagesA | BOOL EnumSystemCodePagesA( CODEPAGE_ENUMPROC lpCodePageEnumProc, DWORD dwFlags ); | kernel32.dll | Cette fonction permet d'énumérer un code de page installé ou supporté par le système d'exploitation.
EnumSystemCodePagesW | BOOL EnumSystemCodePagesW( CODEPAGE_ENUMPROCW lpfnCodePageEnum, DWORD flags ); | kernel32.dll | Cette fonction permet d'énumérer un code de page installé ou supporté par le système d'exploitation avec des paramètres de chaine de caractères étendue (Unicode).
EnumSystemLocalesA | BOOL EnumSystemLocalesA( LOCALE_ENUMPROC lpLocaleEnumProc, DWORD dwFlags ); | kernel32.dll | Cette fonction permet d'énumérer la région locale installé ou supporté par le système d'exploitation.
EnumSystemLocalesW | BOOL EnumSystemLocalesW( LOCALE_ENUMPROCW lpfnLocaleEnum, DWORD dwFlags ); | kernel32.dll | Cette fonction permet d'énumérer la région locale installé ou supporté par le système d'exploitation avec des paramètres de chaine de caractères étendue (Unicode).
EnumTimeFormatsA | BOOL EnumTimeFormatsA( TIMEFMT_ENUMPROC lpTimeFmtEnumProc, LCID Locale, DWORD dwFlags ); | kernel32.dll | Cette fonction permet d'énumérer le format de temps disponible pour la région locale.
EnumTimeFormatsW | BOOL EnumTimeFormatsW( TIMEFMT_ENUMPROCW lpTimeFmtEnumProc, LCID Locale, DWORD dwFlags ); | kernel32.dll | Cette fonction permet d'énumérer le format de temps disponible pour la région locale avec des paramètres de chaine de caractères étendue (Unicode).
EnumThreadWindows | BOOL EnumThreadWindows(DWORD dwThreadId, WNDENUMPROC lpfn, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer l'énumération de toutes les fenêtres non-enfant associé avec un processus par passage d'un Handle pour chaque fenêtre avec une fonction d'application utilisateur.
EnumWindows | BOOL EnumWindows(WNDENUMPROC lpEnumFunc, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer le passage des fenêtres parent par l'intermédiaire d'une fonction utilisateur.
EnumWindowStationsA | BOOL EnumWindowStationsA(WINSTAENUMPROC lpEnumFunc, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer l'énumération de toutes les fenêtres de station dans le système par passage du nom pour chaque fenêtre de station avec une fonction d'application utilisateur.
EnumWindowStationsW | BOOL EnumWindowStationsW(WINSTAENUMPROCW EnumFunc, LPARAM Context); | user32.dll | Cette fonction permet d'effectuer l'énumération de toutes les fenêtres de station dans le système par passage du nom pour chaque fenêtre de station avec une fonction d'application utilisateur et des paramètres de chaine de caractères étendues (Unicode).
EqualPrefixSid | BOOL EqualPrefixSid( PSID pSid1, PSID pSid2 ); | advapi32.dll | Cette fonction permet de vérifie sur les valeurs de deux préfixes SID (identificateur de sécurité) sont égales à l'exception de la dernière valeur de sous-autorité.
EqualRect | BOOL EqualRect(CONST RECT *lprc1, CONST RECT *lprc2); | user32.dll | Cette fonction permet de demander lequel des deux rectangles spécifiés sont égales par comparaison des coordonnées de leur coin supérieur gauche et de leur coin inférieur droit.
EqualRgn | BOOL EqualRgn(HRGN hSrcRgn1, HRGN hSrcRgn2); | gdi32.dll | Cette fonction permet de demander lequel des deux régions spécifiés sont égales par comparaison des coordonnées de leur coin supérieur gauche et de leur coin inférieur droit.
EqualSid | BOOL EqualSid( PSID pSid1, PSID pSid2 ); | advapi32.dll | Cette fonction permet de vérifie sur les valeurs de deux préfixes SID (identificateur de sécurité) sont égales.
EraseTape | DWORD EraseTape( HANDLE hDevice, DWORD dwEraseType, BOOL bImmediate ); | kernel32.dll | Cette fonction permet de tout supprimer ou supprimer des parties de bande magnétique de sauvegarde.
Escape | int Escape(HDC hdc, int nEscape, int cbInput, LPCSTR lpvInData, LPVOID lpvOutData); | gdi32.dll | Cette fonction permet d'activer les applications de compatibilité d'accès d'un périphérique particulier non accessible directement par le GDI.
EscapeCommFunction | BOOL EscapeCommFunction( HANDLE hFile, DWORD dwFunc ); | kernel32.dll | Cette fonction permet d'effectuer directement une communication d'un périphérique spécifié à une fonction étendue.
ExcludeClipRect | int ExcludeClipRect(HDC hdc, int nLeftRect, int nTopRect, int nRightRect, int nBottomRect); | gdi32.dll | Cette fonction permet de créer une nouvelle région de Clip consistant en une minuscule région existante du rectangle spécifié.
ExcludeUpdateRgn | int ExcludeUpdateRgn(HDC hDC, HWND hWnd); | user32.dll | Cette fonction permet d'exclure la région mise-à-jour d'une région de capture.
ExitProcess | VOID ExitProcess( UINT uExitCode ); | kernel32.dll | Cette fonction permet de terminer un processus et tous ses processus légers.
ExitThread | VOID ExitThread( DWORD dwExitCode ); | kernel32.dll | Cette fonction permet de terminer un processus léger.
ExitWindowsEx | BOOL ExitWindowsEx(UINT uFlags,DWORD dwReserved); | user32.dll | Cette fonction permet d'effectuer l'arrêt ou le redémarrage de Windows et/ou de l'ordinateur.
ExpandEnvironmentStringsA | DWORD ExpandEnvironmentStringsA( LPCTSTR lpSrc, LPTSTR lpDst, DWORD nSize ); | kernel32.dll | Cette fonction permet d'étendre une chaine de caractères de variable d'environnement et de remplacer leurs valeurs par celle correspondante.
ExpandEnvironmentStringsW | DWORD ExpandEnvironmentStringsW( LPCWSTR src, LPWSTR dst, DWORD len ); | kernel32.dll | Cette fonction permet d'étendre une chaine de caractères de variable d'environnement et de remplacer leurs valeurs par celle correspondante avec des paramètres de chaine de caractères étendue (Unicode).
ExtCreatePen | HPEN ExtCreatePen(DWORD dwPenStyle, DWORD dwWidth, CONST LOGBRUSH * lplb, DWORD dwStyleCount, CONST DWORD * lpStyle); | gdi32.dll | Cette focntion permet de créer un crayon cosmétique ou géométrique logique ayant les attributs de style, de largeur et brosses spécifiés.
ExtCreateRegion | HRGN ExtCreateRegion(CONST XFORM * lpXform, DWORD nCount, CONST RGNDATA * lpRgnData); | gdi32.dll | Cette fonction permet de créer une région avec la région et la transformation de données spécifié.
ExtEscape | int ExtEscape(HDC hdc, int nEscape, int cbInput, LPCSTR lpszInData, int cbOutput, LPSTR lpszOutData); | gdi32.dll | Cette fonction permet d'allouer les applications vers une capacité d'accès d'un périphérique particulier n'étant pas disponible pour le GDI.
ExtFloodFill | BOOL ExtFloodFill(HDC hdc, int nXStart, int nYStart, COLORREF crColor, UINT fuFillType); | gdi32.dll | Cette fonction permet de remplir une région d'une surface d'affichage avec la brosse courante.
ExtractAssociatedIconA | HICON ExtractAssociatedIconA( HINSTANCE hInst, LPTSTR lpIconPath, LPWORD lpiIcon ); | shell32.dll | Cette fonction permet de demander le Handle dans icône indexé dans un fichier.
ExtractIconA | HICON ExtractIconA(HINSTANCE hInst,LPCTSTR lpszExeFileName,UINT nIconIndex); | shell32.dll | Cette fonction permet de demander une unique icône dans un fichier.
ExtractIconExA | UINT ExtractIconExA(LPCTSTR lpszFile,int nIconIndex,HICON *phiconLarge,HICON *phiconSmall,UINT nIcons); | shell32.dll | Cette fonction permet de demander plusieurs icônes dans un fichier.
ExtSelectClipRgn | int ExtSelectClipRgn(HDC hdc, HRGN hrgn, int fnMode); | gdi32.dll | Cette fonction permet de combiner la région spécifié avec la région de capture courante en utilisant le mode spécifié.
ExtTextOutA | BOOL ExtTextOutA(HDC hdc, int X, int Y, UINT fuOptions, CONST RECT *lprc, LPCTSTR lpString, UINT cbCount, CONST INT * lpDx ); | gdi32.dll | Cette fonction permet de dessiner une chaine de caractères en utilisant la police de caractères courante.
ExtTextOutW | BOOL ExtTextOutW(HDC hdc, INT x, INT y, UINT flags, const RECT* lprect, LPCWSTR str, UINT count, const INT* lpDx); | gdi32.dll | Cette fonction permet de dessiner une chaine de caractères en utilisant la police de caractères courante avec des paramètres de chaines de caractères étendues (Unicode).
FatalAppExitA | VOID FatalAppExitA(UINT uAction,LPCTSTR lpMessageText); | kernel32.dll | Cette fonction permet d'afficher la boite de dialogue d'erreur fatal amenant la terminaison anormale du programme.
FatalAppExitW | void FatalAppExitW( UINT uAction, LPCWSTR lpMessageText ); | kernel32.dll | Cette fonction permet d'afficher la boite de dialogue d'erreur fatal amenant la terminaison anormale du programme avec des paramètres de chaine de caractères étendue (Unicode).
FatalExit | VOID FatalExit( int ExitCode ); | kernel32.dll | Cette fonction permet de transférer le contrôle d'exécution au débogueur.
FileTimeToDosDateTime | BOOL FileTimeToDosDateTime( CONST FILETIME * lpFileTime, LPWORD lpFatDate, LPWORD lpFatTime ); | kernel32.dll | Cette fonction permet de convertir un temps de fichier 64 bits en des valeurs de date et temps.
FileTimeToLocalFileTime | BOOL FileTimeToLocalFileTime( CONST FILETIME * lpFileTime, LPFILETIME lpLocalFileTime ); | kernel32.dll | Cette fonction permet d'effectuer la conversion du temps d'un fichier de format UTC (Coordonnée de Temps Universelle) en format de temps local.
FileTimeToSystemTime | BOOL FileTimeToSystemTime( CONST FILETIME * lpFileTime, LPSYSTEMTIME lpSystemTime ); | kernel32.dll | Cette fonction permet de convertir un temps fichier de 64 bits à un temps de format système.
FillConsoleOutputAttribute | BOOL FillConsoleOutputAttribute( HANDLE hConsoleOutput, WORD wAttribute, DWORD nLength, COORD dwWriteCoord, LPDWORD lpNumberOfAttrsWritten ); | kernel32.dll | Cette fonction permet de fixer la couleur de texte et d'arrière plan pour un nombre spécifié de caractères en commençant au coordonnées du tampon d'écran spécifié.
FillConsoleOutputCharacterA | BOOL FillConsoleOutputCharacterA( HANDLE hConsoleOutput, TCHAR cCharacter, DWORD nLength, COORD dwWriteCoord, LPDWORD lpNumberOfCharsWritten ); | kernel32.dll | Cette fonction permet d'écrire un caractère dans le tampon d'écran un certain nombre de fois en commençant au coordonnées du tampon d'écran spécifié.
FillConsoleOutputCharacterW | BOOL FillConsoleOutputCharacterW( HANDLE hConsoleOutput, WCHAR ch, DWORD length, COORD coord, LPDWORD lpNumCharsWritten ); | kernel32.dll | Cette fonction permet d'écrire un caractère dans le tampon d'écran un certain nombre de fois en commençant au coordonnées du tampon d'écran spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FillPath | BOOL FillPath(HDC hdc); | gdi32.dll | Cette fonction permet de fermer n'importe quel figures ouvertes dans le chemin courant et remplis l'intérieur du chemin en utilisant la brosses courante et le mode de remplissage de polygone.
FillRect | int FillRect(HDC hDC, CONST RECT *lprc, HBRUSH hbr); | user32.dll | Cette fonction permet de remplir un rectangle avec la brosse spécifié.
FillRgn | BOOL FillRgn(HDC hdc, HRGN hrgn, HBRUSH hbr); | gdi32.dll | Cette fonction permet de remplir la région avec le brosse spécifié.
FindAtomA | ATOM FindAtomA( LPCTSTR lpString ); | kernel32.dll | Cette fonction permet de rechercher dans un table d'Atom local la chaine de caractères spécifié et demande l'Atom associé avec cette chaine de caractères.
FindAtomW | ATOM FindAtomW( LPCWSTR str ); | kernel32.dll | Cette fonction permet de rechercher dans un table d'Atom local la chaine de caractères spécifié et demande l'Atom associé avec cette chaine de caractères avec des paramètres de chaine de caractères étendue (Unicode).
FindClose | BOOL FindClose(HANDLE hFindFile); | kernel32.dll | Cette fonction permet d'indiquer que la recherche des fichiers et répertoires que contient un répertoire est terminé.
FindCloseChangeNotification | BOOL FindCloseChangeNotification(HANDLE hChangeHandle); | kernel32.dll | Cette fonction permet d'indiquer que la recherche et modifications des fichiers et répertoires que contient un répertoire est terminé.
FindExecutableA | HINSTANCE FindExecutableA(LPCTSTR lpFile,LPCTSTR lpDirectory,LPTSTR lpResult); | shell32.dll | Cette fonction permet de demander le fichier devant être exécuté lorsque la sorte d'extension de fichier est rencontré.
FindFirstChangeNotificationA | HANDLE FindFirstChangeNotificationA( LPCTSTR lpPathName, BOOL bWatchSubtree, DWORD dwNotifyFilter ); | kernel32.dll | Cette fonction permet de créer un identificateur Handle d'avertissement de changement et fixe la condition d'avertissement de changement initial.
FindFirstChangeNotificationW | HANDLE FindFirstChangeNotificationW(LPCWSTR lpPathName, BOOL bWatchSubtree, DWORD dwNotifyFilter); | kernel32.dll | Cette fonction permet de créer un identificateur Handle d'avertissement de changement et fixe la condition d'avertissement de changement initial avec des paramètres de chaine de caractères étendue (Unicode).
FindFirstChangeNotification | HANDLE FindFirstChangeNotification( LPCTSTR lpPathName, BOOL bWatchSubtree, DWORD dwNotifyFilter ); | kernel32.dll | Cette fonction permet de spécifier une recherche et modifications des fichiers et répertoires que contient un répertoire.
FindFirstFileA | HANDLE FindFirstFileA(LPCTSTR lpFileName,LPWIN32_FIND_DATA lpFindFileData); | kernel32.dll | Cette fonction permet de spécifier une recherche des fichiers et répertoires que contient un répertoire.
FindFirstFileExA | HANDLE FindFirstFileExA( LPCSTR lpFileName, FINDEX_INFO_LEVELS fInfoLevelId, PVOID lpFindFileData, FINDEX_SEARCH_OPS fSearchOp, PVOID lpSearchFilter, DWORD dwAdditionalFlags ); | kernel32.dll | Cette fonction permet de rechercher dans un répertoire un fichier ou un sous-répertoire avec une correspondance de nom et d'attribut spécifié.
FindFirstFileExW | HANDLE FindFirstFileExW( LPCWSTR lpFileName, FINDEX_INFO_LEVELS fInfoLevelId, PVOID lpFindFileData, FINDEX_SEARCH_OPS fSearchOp, PVOID lpSearchFilter, DWORD dwAdditionalFlags ); | kernel32.dll | Cette fonction permet de rechercher dans un répertoire un fichier ou un sous-répertoire avec une correspondance de nom et d'attribut spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FindFirstFileW | HANDLE FindFirstFileW( LPCWSTR lpFileName, LPWIN32_FIND_DATAW lpFindFileData ); | kernel32.dll | Cette fonction permet de spécifier une recherche des fichiers et répertoires que contient un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
FindFirstFreeAce | BOOL FindFirstFreeAce( PACL pAcl, LPVOID *pAce ); | advapi32.dll | Cette fonction permet de retourner un pointeur sur le premier octet de libre sur une liste de contrôle d'accès (ACL).
FindNextChangeNotification | BOOL FindNextChangeNotification(HANDLE hChangeHandle); | kernel32.dll | Cette fonction permet demander l'entrée suivant lors de la recherche et modifications des fichiers et répertoire que contient un répertoire.
FindNextFileA | BOOL FindNextFileA(HANDLE hFindFile,LPWIN32_FIND_DATA lpFindFileData); | kernel32.dll | Cette fonction permet demander l'entrée suivante lors de la recherche des fichiers et répertoire que contient un répertoire.
FindNextFileW | BOOL FindNextFileW( HANDLE hFindFile, LPWIN32_FIND_DATAW lpFindFileData ); | kernel32.dll | Cette fonction permet demander l'entrée suivante lors de la recherche des fichiers et répertoire que contient un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
FindResourceA | HRSRC FindResourceA( HMODULE hModule, LPCTSTR lpName, LPCTSTR lpType ); | kernel32.dll | Cette fonction permet de demander l'emplacement d'une ressource avec un nom et un type spécifié dans un module spécifié.
FindResourceW | HRSRC FindResourceW( HINSTANCE hModule, LPCWSTR lpName, LPCWSTR lpType ); | kernel32.dll | Cette fonction permet de demander l'emplacement d'une ressource avec un nom et un type spécifié dans un module spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FindResourceExA | HRSRC FindResourceExA( HMODULE hModule, LPCTSTR lpType, LPCTSTR lpName, WORD wLanguage ); | kernel32.dll | Cette fonction permet de demander l'emplacement d'une ressource avec un type, un nom et une langue spécifié dans un module spécifié.
FindResourceExW | HRSRC FindResourceExW( HINSTANCE hModule, LPCWSTR lpType, LPCWSTR lpName, WORD wLanguage ); | kernel32.dll | Cette fonction permet de demander l'emplacement d'une ressource avec un type, un nom et une langue spécifié dans un module spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FindWindowA | HWND FindWindowA(LPCTSTR lpClassName, LPCTSTR lpWindowName); | user32.dll | Cette fonction permet de demander le Handle de la première fenêtre d'application correspondant au nom de la fenêtre.
FindWindowExA | HWND FindWindowExA(HWND hwndParent,HWND hwndChildAfter,LPCTSTR lpszClass,LPCTSTR lpszWindow); | user32.dll | Cette fonction permet de demander le Handle d'une fenêtre enfant d'une fenêtre d'application.
FindWindowExW | HWND FindWindowExW(HWND hwndParent,HWND hwndChildAfter, LPCWSTR lpszClass, LPCWSTR lpszWindow); | user32.dll | Cette fonction permet de demander le Handle d'une fenêtre enfant d'une fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
FindWindowW | HWND FindWindowW(LPCWSTR lpClassName, LPCWSTR lpWindowName); | user32.dll | Cette fonction permet de demander le Handle de la première fenêtre d'application correspondant au nom de la fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
FlashWindow | BOOL FlashWindow(HWND hWnd,BOOL bInvert); | user32.dll | Cette fonction permet de faire clignoter une fois une fenêtre d'application.
FlashWindowEx | BOOL FlashWindowEx(PFLASHWINFO pfwi); | user32.dll | Cette fonction permet de faire clignoter plusieurs fois une fenêtre d'application.
FlattenPath | BOOL FlattenPath(HDC hdc); | gdi32.dll | Cette fonction permet de transformer n'importe quel courbe d'un chemin étant sélectionné dans le périphérique de contexte courant de façon à tourner chaque courbe une séquences de lignes.
FloodFill | BOOL FloodFill(HDC hdc, int nXStart, int nYStart, COLORREF crFill); | gdi32.dll | Cette fonction permet d'effectuer le remplissage d'une région de la surface de l'écran en utilisant la brosse courante.
FlushConsoleInputBuffer | BOOL FlushConsoleInputBuffer( HANDLE hConsoleInput ); | kernel32.dll | Cette fonction permet de vider le tampon d'entrée de la console.
FlushFileBuffers | BOOL FlushFileBuffers( HANDLE hFile ); | kernel32.dll | Cette fonction permet d'effacer le tampon pour le fichier spécifié et provoquer l'écriture des données dans le fichier.
FlushInstructionCache | BOOL FlushInstructionCache( HANDLE hProcess, LPCVOID lpBaseAddress, DWORD dwSize ); | kernel32.dll | Cette fonction permet de vider les instructions en cache pour le processus spécifié.
FlushViewOfFile | BOOL FlushViewOfFile( LPCVOID lpBaseAddress, DWORD dwNumberOfBytesToFlush ); | kernel32.dll | Cette fonction permet d'écrire sur le disque un rang d'octets dans une vue d'un fichier.
FoldStringA | int FoldStringA( DWORD dwMapFlags, LPCTSTR lpSrcStr, int cchSrc, LPTSTR lpDestStr, int cchDest ); | kernel32.dll | Cette fonction permet de cartographier une chaine de caractères vers une autre en effectuant les options de transformations spécifié.
FoldStringW | INT FoldStringW( DWORD dwFlags, LPCWSTR src, INT srclen, LPWSTR dst, INT dstlen ); | kernel32.dll | Cette fonction permet de cartographier une chaine de caractères vers une autre en effectuant les options de transformations spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FormatMessageA | DWORD FormatMessageA( DWORD dwFlags, LPCVOID lpSource, DWORD dwMessageId, DWORD dwLanguageId, LPTSTR lpBuffer, DWORD nSize, va_list * Arguments ); | kernel32.dll | Cette fonction permet de demander un message affecté par un certain format.
FormatMessageW | DWORD FormatMessageW( DWORD dwFlags, PCVOID lpSource, DWORD dwMessageId, DWORD dwLanguageId, LPWSTR lpBuffer, DWORD nSize, va_list * Arguments ); | kernel32.dll | Cette fonction permet de demander le dernier message d'erreur contenu dans le fichier d'erreur système.
FrameRect | int FrameRect(HDC hDC, CONST RECT * lprc, HBRUSH hbr); | user32.dll | Cette fonction permet de dessiner une bordure autour d'un rectangle, en utilisant la brosse spécifié.
FrameRgn | BOOL FrameRgn(HDC hdc, HRGN hrgn, HBRUSH hbr, int nWidth, int nHeight); | gdi32.dll | Cette fonction permet de dessiner une bordure entourant une région spécifié et en utilisant la brosse spécifié.
FreeConsole | BOOL FreeConsole(VOID); | kernel32.dll | Cette fonction permet de libérer une console existante.
FreeDDElParam | BOOL FreeDDElParam(UINT msg, LONG lParam); | user32.dll | Cette fonction permet de libérer la mémoire spécifié d'un message DDE posté.
FreeEnvironmentStringsA | BOOL FreeEnvironmentStringsA( LPTSTR lpszEnvironmentBlock ); | kernel32.dll | Cette fonction permet de libérer un bloc de chaine de caractères d'environnement.
FreeEnvironmentStringsW | BOOL FreeEnvironmentStringsW( LPWSTR lpszEnvironmentBlock ); | kernel32.dll | Cette fonction permet de libérer un bloc de chaine de caractères d'environnement avec des paramètres de chaine de caractères étendue (Unicode).
FreeLibrary | BOOL FreeLibrary(HMODULE hModule); | kernel32.dll | Cette fonction permet d'incrémenter un compteur de référence pour un chargement de module de lien dynamique (DLL).
FreeLibraryAndExitThread | VOID FreeLibraryAndExitThread( HMODULE hLibModule, DWORD dwExitCode ); | kernel32.dll | Cette fonction permet de décrémenté le compteur de référence d'une des bibliothèque de liens dynamique (DLL) et appel alors la fonction «ExitThread».
FreeResource | BOOL FreeResource(HGLOBAL hResource); | kernel32.dll | Cette fonction permet de libérer une ressource.
FreeSid | PVOID FreeSid( PSID pSid ); | advapi32.dll | Cette fonction permet de libérer un identificateur de sécurité (SID) précédemment alloué par la fonction «AllocateAndInitializeSid».
FtpCreateDirectoryA | BOOL FtpCreateDirectory( IN HINTERNET hFtpSession, IN LPCTSTR lpszDirectory ); | wininet.dll | Cette fonction permet d'effectuer la création d'un répertoire sur un protocole FTP.
FtpOpenFileA | HINTERNET FtpOpenFileA( HINTERNET hConnect, LPCTSTR lpszFileName, DWORD dwAccess, DWORD dwFlags, DWORD dwContext ); | wininet.dll | Cette fonction permet d'ouvrir un fichier avec une chaine de caractères ASCIZ sur un protocole FTP.
FtpOpenFileW | static void FtpOpenFileW(WORKREQUEST* workRequest); | wininet.dll | Cette fonction permet d'ouvrir un fichier avec une chaine de caractères étendue (Unicode) sur un protocole FTP.
GdiComment | BOOL GdiComment(HDC hdc, UINT cbSize, CONST BYTE * lpData); | gdi32.dll | Cette fonction permet de copier un commentaire d'un tampon vers un méta fichier spécifié de format étendue.
GdiFlush | BOOL GdiFlush(VOID); | gdi32.dll | Cette fonction permet de vider le traitement en lot courant du processus appelant.
GdiGetBatchLimit | DWORD GdiGetBatchLimit(VOID); | gdi32.dll | Cette fonction permet de retourner le nombre maximum d'appels de fonction étant accumulé dans le traitement par lot courant du processus léger courant.
GdiSetBatchLimit | DWORD GdiSetBatchLimit(DWORD dwLimit); | gdi32.dll | Cette fonction permet de fixer le nombre maximum d'appels de fonction étant accumulé dans le traitement par lot courant du processus léger courant.
GenerateConsoleCtrlEvent | BOOL GenerateConsoleCtrlEvent( DWORD dwCtrlEvent, DWORD dwProcessGroupId ); | kernel32.dll | Cette fonction permet d'envoyer un signal spécifique à un groupe de processus de console.
GetAce | BOOL GetAce( PACL pAcl, DWORD dwAceIndex, LPVOID *pAce ); | advapi32.dll | Cette fonction permet de demander un pointeur sur une structure d'une entrée de contrôle d'accès (ACE) d'une liste de contrôle d'accès (ACL).
GetAclInformation | BOOL GetAclInformation( PACL pAcl, LPVOID pAclInformation, DWORD nAclInformationLength, ACL_INFORMATION_CLASS dwAclInformationClass ); | advapi32.dll | Cette fonction permet de demander les informations concernant une liste de contrôle d'accès (ACL).
GetACP | UINT GetACP(VOID); | kernel32.dll | Cette fonction permet de demander l'identificateur de code de page ANSI courant pour le système d'exploitation.
GetActiveWindow | HWND GetActiveWindow(VOID); | user32.dll | Cette fonction permet de demander le Handle de la fenêtre active.
GetArcDirection | int GetArcDirection(HDC hdc); | gdi32.dll | Cette fonction permet de demander la direction de l'arc courant pour le périphérique de contexte spécifié.
GetAspectRatioFilterEx | BOOL GetAspectRatioFilterEx(HDC hdc, LPSIZE lpAspectRatio); | gdi32.dll | Cette fonction permet de demander l'ajustement de filtre d'aspect ratio courant.
GetAsyncKeyState | SHORT GetAsyncKeyState(int vKey); | user32.dll | Cette fonction permet de retourner l'état de la touche spécifié.
GetAtomNameA | UINT GetAtomNameA( ATOM nAtom, LPTSTR lpBuffer, int nSize ); | kernel32.dll | Cette fonction permet de demander une copie de chaine de caractères associé avec un Atom local spécifié.
GetAtomNameW | UINT GetAtomNameW( ATOM atom, LPWSTR buffer, INT count ); | kernel32.dll | Cette fonction permet de demander une copie de chaine de caractères associé avec un Atom local spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetBinaryTypeA | BOOL GetBinaryTypeA( LPCTSTR lpApplicationName, LPDWORD lpBinaryType ); | kernel32.dll | Cette fonction permet de demander si le fichier est exécutable, et s'il l'est, quel type de fichier exécutable s'agit-il.
GetBinaryTypeW | BOOL GetBinaryTypeW( LPCWSTR lpApplicationName, LPDWORD lpBinaryType ); | kernel32.dll | Cette fonction permet de demander si le fichier est exécutable, et s'il l'est, quel type de fichier exécutable s'agit-il avec des paramètres de chaine de caractères étendue (Unicode).
GetBitmapBits | LONG GetBitmapBits(HBITMAP hbmp, LONG cbBuffer, LPVOID lpvBits); | gdi32.dll | Cette fonction permet de copier les bits du Bitmap spécifié dans un tampon.
GetBitmapDimensionEx | BOOL GetBitmapDimensionEx(HBITMAP hBitmap, LPSIZE lpDimension); | gdi32.dll | Cette fonction permet de demander les dimensions d'un Bitmap.
GetBkColor | COLORREF GetBkColor(HDC hdc); | gdi32.dll | Cette fonction permet de retourner la couleur d'arrière-plan courante.
GetBkMode | int GetBkMode(HDC hdc); | gdi32.dll | Cette fonction permet de demander le mode mixte d'arrière-plan pour le contexte de périphérique spécifié.
GetBoundsRect | UINT GetBoundsRect(HDC hdc, LPRECT lprcBounds, UINT flags); | gdi32.dll | Cette fonction permet de retourner l'accumulation d'informations de limite rectangulaire d'un périphérique de contexte.
GetBrushOrgEx | BOOL GetBrushOrgEx(HDC hdc, LPPOINT lppt); | gdi32.dll | Cette fonction permet de demander l'origine de la brosse courante dans un périphérique de contexte courant.
GetCapture | HWND GetCapture(VOID); | user32.dll | Cette fonction permet de demander le Handle de la fenêtre où la souris est capturé.
GetCaretBlinkTime | UINT GetCaretBlinkTime(VOID); | user32.dll | Cette fonction permet de demander le taux de clignotement du caret.
GetCaretPos | BOOL GetCaretPos(LPPOINT lpPoint); | user32.dll | Cette fonction permet de demander la position courante d'un caret.
GetCharABCWidthsA | BOOL GetCharABCWidthsA(HDC hdc, UINT uFirstChar, UINT uLastChar, LPABC lpabc); | gdi32.dll | Cette fonction permet de demander la largeur, dans son unité de mesure logique, de caractères consécutifs dans une rangée données d'une police de caractères TrueType courant.
GetCharABCWidthsW | BOOL GetCharABCWidthsW(HDC hdc, UINT firstChar, UINT lastChar, LPABC abc); | gdi32.dll | Cette fonction permet de demander la largeur, dans son unité de mesure logique, de caractères consécutifs dans une rangée données d'une police de caractères TrueType courant avec des paramètres de chaines de caractères étendues (Unicode).
GetCharABCWidthsFloatA | BOOL GetCharABCWidthsFloatA(HDC hdc, UINT iFirstChar, UINT iLastChar, LPABCFLOAT lpABCF); | gdi32.dll | Cette fonction permet de demander la largeur, dans son unité de mesure logique, de caractères consécutifs dans une rangée données d'une police de caractères courant.
GetCharABCWidthsFloatW | BOOL GetCharABCWidthsFloatW(HDC hdc, UINT first, UINT last, LPABCFLOAT abcf); | gdi32.dll | Cette fonction permet de demander la largeur, dans son unité de mesure logique, de caractères consécutifs dans une rangée données d'une police de caractères courant avec des paramètres de chaine de caractères étendues (Unicode).
GetCharWidth32A | BOOL GetCharWidth32A(HDC hdc, UINT iFirstChar, UINT iLastChar, LPINT lpBuffer); | gdi32.dll | Cette fonction permet demander la largeur, dans des coordonnées logiques, de caractères consécutifs dans une rangée spécifié d'une police de caractères courante.
GetCharWidth32W | BOOL GetCharWidth32W(HDC hdc, UINT iFirstChar, UINT iLastChar, LPINT lpBuffer); | gdi32.dll | Cette fonction permet demander la largeur, dans des coordonnées logiques, de caractères consécutifs dans une rangée spécifié d'une police de caractères courante avec des paramètres de chaine de caractères étendues (Unicode).
GetCharWidthA | BOOL GetCharWidthA(HDC hdc, UINT iFirstChar, UINT iLastChar, LPINT lpBuffer); | gdi32.dll | Cette fonction permet demander la largeur, dans des coordonnées logiques, de caractères consécutifs dans une rangée spécifié d'une police de caractères courante dans un contexte de compatibilité avec les fonctions 16 bits.
GetCharWidthW | BOOL GetCharWidthW(HDC hdc, UINT iFirstChar, UINT iLastChar, LPINT lpBuffer); | gdi32.dll | Cette fonction permet demander la largeur, dans des coordonnées logiques, de caractères consécutifs dans une rangée spécifié d'une police de caractères courante dans un contexte de compatibilité avec les fonctions 16 bits avec des paramètres de chaine de caractères étendues (Unicode).
GetCharWidthFloatA | BOOL GetCharWidthFloatA(HDC hdc, UINT iFirstChar, UINT iLastChar, PFLOAT pxBuffer); | gdi32.dll | Cette fonction permet de demander la largeur fractionné de caractères consécutifs dans une rangée spécifié de la police de caractères courante.
GetCharWidthFloatW | BOOL GetCharWidthFloatW(HDC hdc, UINT iFirstChar, UINT iLastChar, PFLOAT pxBuffer); | gdi32.dll | Cette fonction permet de demander la largeur fractionné de caractères consécutifs dans une rangée spécifié de la police de caractères courante avec des paramètres de chaine de caractères étendues (Unicode).
GetCharacterPlacementA | DWORD GetCharacterPlacementA(HDC hdc, LPCTSTR lpString, int nCount, int nMaxExtent, LPGCP_RESULTS *lpResults, DWORD dwFlags); | gdi32.dll | Cette fonction permet de demander les informations à propos d'une chaine de caractères, comme la largeur des caractères, le positionnement des carets, l'ordre dans la chaine de caractères et la rendue du glyphe.
GetCharacterPlacementW | DWORD GetCharacterPlacementW(HDC hdc, LPCWSTR lpString, int uCount, int nMaxExtent, GCP_RESULTSW* lpResults, DWORD dwFlags); | gdi32.dll | Cette fonction permet de demander les informations à propos d'une chaine de caractères, comme la largeur des caractères, le positionnement des carets, l'ordre dans la chaine de caractères et la rendue du glyphe avec des paramètres de chaine de caractères étendues (Unicode).
GetClassInfoA | BOOL GetClassInfoA(HINSTANCE hInstance, LPCTSTR lpClassName, LPWNDCLASS lpWndClass); | user32.dll | Cette fonction permet de demander les informations à propos d'une classe de fenêtre.
GetClassInfoExA | BOOL GetClassInfoExA(HINSTANCE hinst, LPCTSTR lpszClass, LPWNDCLASSEX lpwcx); | user32.dll | Cette fonction permet de demander les informations à propos d'une classe de fenêtre en incluant le Handle du petit icône associé avec la fenêtre de classe.
GetClassInfoExW | BOOL GetClassInfoExW(HINSTANCE hinst, LPCWSTR lpszClass, LPWNDCLASSEXW lpwcx); | user32.dll | Cette fonction permet de demander les informations à propos d'une classe de fenêtre en incluant le Handle du petit icône associé avec la fenêtre de classe avec des paramètres de chaine de caractères étendues (Unicode).
GetClassInfoW | BOOL GetClassInfoW(HINSTANCE hInstance, LPCTSTR lpClassName, LPWNDCLASS lpWndClass); | user32.dll | Cette fonction permet de demander les informations à propos d'une classe de fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
GetClassLongA | DWORD GetClassLongA(HWND hWnd,int nIndex); | user32.dll | Cette fonction permet de demander des valeurs d'informations en 32 bits sur une classe.
GetClassLongW | DWORD GetClassLongW(HWND hWnd, int nIndex); | user32.dll | Cette fonction permet de demander des valeurs d'informations en 32 bits sur une classe avec des paramètres de chaine de caractères étendues (Unicode).
GetClassNameA | int GetClassNameA(HWND hWnd,LPTSTR lpClassName,int nMaxCount); | user32.dll | Cette fonction permet de demander le nom d'une classe.
GetClassNameW | int GetClassNameW(HWND hWnd, LPWSTR lpClassName, int nMaxCount); | user32.dll | Cette fonction permet de demander le nom d'une classe avec des paramètres de chaine de caractères étendues (Unicode).
GetClassWord | WORD GetClassWord(HWND hWnd, int nIndex); | user32.dll | Cette fonction permet de demander une valeur 16 bits de déplacement spécifié dans une classe de mémoire supplémentaire pour la classe de fenêtre à laquelle la fenêtre appartient.
GetClientRect | BOOL GetClientRect(HWND hWnd, LPRECT lpRect); | user32.dll | Cette fonction permet de demander les coordonnées client de la région de fenêtre client.
GetClipboardData | HANDLE GetClipboardData(UINT uFormat); | user32.dll | Cette fonction permet de demander le Handle du presse-papier de données courant avec le format spécifié.
GetClipboardFormatNameA | int GetClipboardFormatNameA(UINT format, LPTSTR lpszFormatName, int cchMaxCount); | user32.dll | Cette fonction permet de demander le nom de format de presse-papier enregistré.
GetClipboardFormatNameW | int GetClipboardFormatNameW(UINT format, LPWSTR lpszFormatName, int cchMaxCount); | user32.dll | Cette fonction permet de demander le nom de format de presse-papier enregistré avec des paramètres de chaine de caractères étendues (Unicode).
GetClipboardOwner | HWND GetClipboardOwner(VOID); | user32.dll | Cette fonction permet de demander le Handle de la fenêtre associé à un presse-papier.
GetClipboardViewer | HWND GetClipboardViewer(VOID); | user32.dll | Cette fonction permet de demander le Handle de la première fenêtre d'une chaine visualisation de presse-papier.
GetClipBox | int GetClipBox(HDC hdc, LPRECT lprc); | gdi32.dll | Cette fonction permet de demander les dimensions d'un petit rectangle complètement contenu dans la région de clip courant.
GetClipCursor | BOOL GetClipCursor(LPRECT lpRect); | user32.dll | Cette fonction permet de demander les coordonnées de la fenêtre limitant le déplacement du pointeur de la souris.
GetClipRgn | int GetClipRgn(HDC hdc, HRGN hrgn); | gdi32.dll | Cette fonction permet de demander le Handle d'une région de clip affecté par un périphérique de contexte spécifié.
GetColorAdjustment | BOOL GetColorAdjustment(HDC hdc, LPCOLORADJUSTMENT lpca); | gdi32.dll | Cette fonction permet de demander les valeurs de couleurs d'ajustement pour le contexte de périphérique spécifié.
GetColorSpace | HANDLE GetColorSpace(HDC hdc); | gdi32.dll | Cette fonction permet de demander le Handle courant de l'espace de couleur logique du périphérique de contexte spécifié.
GetCommandLineA | LPTSTR GetCommandLineA(void); | kernel32.dll | Cette fonction permet de retourner la ligne de commande de l'application courante.
GetCommandLineW | LPWSTR GetCommandLineW(VOID); | kernel32.dll | Cette fonction permet de retourner la ligne de commande de l'application courante avec des paramètres de chaine de caractères étendue (Unicode).
GetCommConfig | BOOL GetCommConfig( HANDLE hCommDev, LPCOMMCONFIG lpCC, LPDWORD lpdwSize ); | kernel32.dll | Cette fonction permet de demander la configuration courante pour un périphérique de communication.
GetCommMask | BOOL GetCommMask( HANDLE hFile, LPDWORD lpEvtMask ); | kernel32.dll | Cette fonction permet de demander la valeur d'un masque d'événement pour un périphérique de communication spécifié.
GetCommModemStatus | BOOL GetCommModemStatus( HANDLE hFile, LPDWORD lpModemStat ); | kernel32.dll | Cette fonction permet de demander les valeurs du registre de contrôle du modem.
GetCommProperties | BOOL GetCommProperties( HANDLE hFile, LPCOMMPROP lpCommProp ); | kernel32.dll | Cette fonction permet de remplir le tampon avec des informations concernant les propriétés de communications pour un périphérique de communication spécifié.
GetCommState | BOOL GetCommState( HANDLE hFile, LPDCB lpDCB ); | kernel32.dll | Cette fonction permet de remplir un bloc de contrôle de périphérique (une structure DCB) avec les ajustements de contrôle courant pour un périphérique de communication spécifié.
GetCommTimeouts | BOOL GetCommTimeouts( HANDLE hFile, LPCOMMTIMEOUTS lpCommTimeouts ); | kernel32.dll | Cette fonction permet de demander les paramètres de dépassement de délai pour toutes les opérations de lecture ou d'écriture pour un périphérique de communication spécifié.
GetCompressedFileSizeA | DWORD GetCompressedFileSizeA( LPCTSTR lpFileName, LPDWORD lpFileSizeHigh ); | kernel32.dll | Cette fonction permet de demander le nombre d'octets d'une unité d'entreposage actuellement utilisé pour un fichier spécifié.
GetCompressedFileSizeW | DWORD GetCompressedFileSizeW( LPCWSTR name, LPDWORD size_high ); | kernel32.dll | Cette fonction permet de demander le nombre d'octets d'une unité d'entreposage actuellement utilisé pour un fichier spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetComputerNameA | BOOL GetComputerNameA(LPTSTR lpBuffer,LPDWORD nSize); | kernel32.dll | Cette fonction permet de demander le nom de l'ordinateur sous forme d'une chaine de caractères ASCIZ.
GetComputerNameW | BOOL GetComputerNameW( LPWSTR lpBuffer, PDWORD nSize ); | kernel32.dll | Cette fonction permet de demander le nom de l'ordinateur sous forme d'une chaine de caractères ASCIZ avec des paramètres de chaine de caractères étendue (Unicode).
GetComputerNameExA | BOOL GetComputerNameExA(COMPUTER_NAME_FORMAT NameType, LPTSTR lpBuffer, LPDWORD lpnSize); | kernel32.dll | Cette fonction permet de retourner la nom NetBIOS ou DNS de l'ordinateur local.
GetComputerObjectNameA | BOOLEAN GetComputerObjectNameA( EXTENDED_NAME_FORMAT NameFormat, LPTSTR lpNameBuffer, PULONG lpnSize ); | secur32.dll | Cette fonction permet de retourner le nom de l'ordinateur dans un format spécifié.
GetConsoleCursorInfo | BOOL GetConsoleCursorInfo( HANDLE hConsoleOutput, PCONSOLE_CURSOR_INFO lpConsoleCursorInfo ); | kernel32.dll | Cette fonction permet de demander des informations à propos de la taille et de la visibilité du curseur pour le tampon de console écran spécifié.
GetConsoleCP | UINT GetConsoleCP(VOID); | kernel32.dll | Cette fonction permet de demander l'identité de code de page utilisé pour la console associé avec le processus appelant.
GetConsoleMode | BOOL GetConsoleMode( HANDLE hConsoleHandle, LPDWORD lpMode ); | kernel32.dll | Cette fonction permet de demander le mode d'entrée courant pour le tampon d'entrée de la console ou le mode de sortie courant pour le tampon d'écran de la console.
GetConsoleOutputCP | UINT GetConsoleOutputCP(VOID); | kernel32.dll | Cette fonction permet de retourner l'identité de code de page de sortie utilisé par la console associé avec le processus appelant.
GetConsoleScreenBufferInfo | BOOL GetConsoleScreenBufferInfo( HANDLE hConsoleOutput, PCONSOLE_SCREEN_BUFFER_INFO lpConsoleScreenBufferInfo ); | kernel32.dll | Cette fonction permet de demander les informations à propos du tampon d'écran de la console spécifié.
GetConsoleTitleA | DWORD GetConsoleTitleA(LPSTR title, DWORD size); | kernel32.dll | Cette fonction permet de retourner le nom de la console courante.
GetConsoleTitleW | DWORD GetConsoleTitleW( LPWSTR title, DWORD size ); | kernel32.dll | Cette fonction permet de retourner le nom de la console courante avec des paramètres de chaine de caractères étendue (Unicode).
GetCPInfo | BOOL GetCPInfo(UINT CodePage, LPCPINFO lpCPInfo); | kernel32.dll | Cette fonction permet de retourner des informations sur le code de page spécifié.
GetCurrencyFormatA | int GetCurrencyFormatA( LCID Locale, DWORD dwFlags, LPCTSTR lpValue, CONST CURRENCYFMT * lpFormat, LPTSTR lpCurrencyStr, int cchCurrency ); | kernel32.dll | Cette fonction permet de demander la chaine de caractères du format d'un nombre avec une chaine de caractères de monnaie pour une localité spécifié.
GetCurrencyFormatW | INT GetCurrencyFormatW( LCID lcid, DWORD dwFlags, LPCWSTR lpszValue, const CURRENCYFMTW* lpFormat, LPWSTR lpCurrencyStr, int cchOut ); | kernel32.dll | Cette fonction permet de demander la chaine de caractères du format d'un nombre avec une chaine de caractères de monnaie pour une localité spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetCurrentDirectoryA | DWORD GetCurrentDirectoryA( DWORD nBufferLength, LPTSTR lpBuffer); | kernel32.dll | Cette fonction permet de demander le répertoire courant du processus courant.
GetCurrentDirectoryW | DWORD GetCurrentDirectoryW( DWORD nBufferLength, LPWSTR lpBuffer ); | kernel32.dll | Cette fonction permet de demander le répertoire courant du processus courant avec des paramètres de chaine de caractères étendue (Unicode).
GetCurrentHwProfileA | BOOL GetCurrentHwProfileA( LPHW_PROFILE_INFOA pInfo ); | advapi32.dll | Cette fonction pemret de demander le profile matériel courant.
GetCurrentHwProfileW | BOOL GetCurrentHwProfileW( LPHW_PROFILE_INFOW pInfo ); | advapi32.dll | Cette fonction pemret de demander le profile matériel courant avec des paramètres de chaine de caractères étendue (Unicode).
GetCurrentObject | HGDIOBJ GetCurrentObject(HDC hdc, UINT uObjectType); | gdi32.dll | Cette fonction permet de retourner l'objet sélectionné courant du type spécifié.
GetCurrentPositionEx | BOOL GetCurrentPositionEx(HDC hdc, LPPOINT lpPoint); | gdi32.dll | Cette fonction permet de demander la position courante dans des coordonnées logiques.
GetCurrentProcess | HANDLE WINAPI GetCurrentProcess(void); | kernel32.dll | Cette fonction permet de retourner le Handle du processus courant.
GetCurrentProcessId | DWORD GetCurrentProcessId(VOID); | kernel32.dll | Cette fonction permet de demander l'identificateur de processus courant
GetCurrentProcessorNumber | DWORD GetCurrentProcessorNumber(void); | kernel32.dll | Cette fonction permet de demander le nombre de processeur du processus courant lors de l'appel d'une fonction
GetCurrentThread | HANDLE WINAPI GetCurrentThread(void); | kernel32.dll | Cette fonction permet de retourner le Handle du processus courant.
GetCurrentThreadId | DWORD WINAPI GetCurrentThreadId(void); | kernel32.dll | Cette fonction permet de retourner l'identificateur du processus courant.
GetCursor | HCURSOR GetCursor(VOID); | user32.dll | Cette fonction permet de demander le Handle du curseur courant.
GetCursorPos | BOOL GetCursorPos(LPPOINT lpPoint); | user32.dll | Cette fonction permet de demander la position du pointeur de souris à l'écran
GetDateFormatA | int GetDateFormatA( LCID Locale, DWORD dwFlags, CONST SYSTEMTIME * lpDate, LPCTSTR lpFormat, LPTSTR lpDateStr, int cchDate ); | kernel32.dll | Cette fonction permet de demander la date dans une chaine de caractères ASCIZ selon le format spécifié.
GetDateFormatW | int GetDateFormatW( LCID lcid, DWORD dwFlags, const SYSTEMTIME* lpTime, LPCWSTR lpFormat, LPWSTR lpDateStr, int cchOut ); | kernel32.dll | Cette fonction permet de demander la date dans une chaine de caractères ASCIZ selon le format spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetDC | HDC GetDC(HWND hWnd); | user32.dll | Cette fonction permet de demander le contexte d'objet d'une fenêtre d'application.
GetDCEx | HDC GetDCEx(HWND hWnd, HRGN hrgnClip, DWORD flags); | user32.dll | Cette fonction permet de demander le Handle du périphérique de contexte pour la fenêtre spécifié.
GetDCOrgEx | BOOL GetDCOrgEx(HDC hdc, LPPOINT lpPoint); | gdi32.dll | Cette fonction permet de demander l'origine de translation final d'un périphérique de contexte spécifié.
GetDefaultCommConfigA | BOOL GetDefaultCommConfigA( LPCSTR lpszName, LPCOMMCONFIG lpCC, LPDWORD lpdwSize ); | kernel32.dll | Cette fonction permet de demander la configuration par défaut d'un périphérique de communication.
GetDefaultCommConfigW | BOOL GetDefaultCommConfigW( LPCWSTR lpszName, LPCOMMCONFIG lpCC, LPDWORD lpdwSize ); | kernel32.dll | Cette fonction permet de demander la configuration par défaut d'un périphérique de communication avec des paramètres de chaine de caractères étendue (Unicode).
GetDesktopWindow | HWND GetDesktopWindow(VOID); | user32.dll | Cette fonction permet de demander le Handle attribué à la fenêtre du bureau.
GetDeviceCaps | int GetDeviceCaps(HDC hdc, int nIndex); | gdi32.dll | Cette fonction permet de demander les informations d'un périphérique spécifié à propos du périphérique d'affichage.
GetDeviceGammaRamp | BOOL GetDeviceGammaRamp(HDC hdc, LPVOID lpRamp); | gdi32.dll | Cette fonction permet de demander la rampe gamma d'un panneau d'affichage de couleur directe.
GetDialogBaseUnits | LONG GetDialogBaseUnits(VOID); | user32.dll | Cette fonction permet de retourner l'unité de base de la boite de dialogue qu'utilise Windows quand il créer une boite de dialogue.
GetDIBColorTable | UINT GetDIBColorTable(HDC hdc, UINT uStartIndex, UINT cEntries, RGBQUAD *pColors); | gdi32.dll | Cette fonction permet de demander les valeurs de couleurs RVB (rouge, vert, bleu) d'une rangée d'entrées d'une table de couleurs d'une section DIB Bitmap étant actuellement sélectionné dans un périphérique de contexte spécifié.
GetDIBits | int GetDIBits(HDC hdc, HBITMAP hbmp, UINT uStartScan, UINT cScanLines, LPVOID lpvBits, LPBITMAPINFO lpbi, UINT uUsage); | gdi32.dll | Cette fonction permet de demander les bits d'un Bitmap compatible et copie celui-ci dans un tampon DIB en utilisant le format spécifié.
GetDiskFreeSpaceA | BOOL GetDiskFreeSpaceA( LPCTSTR lpRootPathName, LPDWORD lpSectorsPerCluster, LPDWORD lpBytesPerSector, LPDWORD lpNumberOfFreeClusters, LPDWORD lpTotalNumberOfClusters ); | kernel32.dll | Cette fonction permet de demander l'espace de libre sur une unité disque.
GetDiskFreeSpaceExA | BOOL GetDiskFreeSpaceExA( LPCSTR root, PULARGE_INTEGER avail, PULARGE_INTEGER total, PULARGE_INTEGER totalfree ); | kernel32.dll | Cette fonction permet de demander des informations global sur l'espace de libre sur une unité disque.
GetDiskFreeSpaceExW | BOOL GetDiskFreeSpaceExW( LPCWSTR root, PULARGE_INTEGER avail, PULARGE_INTEGER total, PULARGE_INTEGER totalfree ); | kernel32.dll | Cette fonction permet de demander des informations global sur l'espace de libre sur une unité disque avec des paramètres de chaine de caractères étendue (Unicode).
GetDiskFreeSpaceW | BOOL GetDiskFreeSpaceW( LPCWSTR lpRootPathName, PDWORD lpSectorsPerCluster, PDWORD lpBytesPerSector, PDWORD lpNumberOfFreeClusters, PDWORD lpTotalNumberOfClusters ); | kernel32.dll | Cette fonction permet de demander l'espace de libre sur une unité disque avec des paramètres de chaine de caractères étendue (Unicode).
GetDlgCtrlID | int GetDlgCtrlID(HWND hwndCtl); | user32.dll | Cette fonction permet de retourner le Handle de la fenêtre enfant.
GetDlgItem | HWND GetDlgItem(HWND hDlg, int nIDDlgItem); | user32.dll | Cette fonction permet de demander le Handle d'un contrôle étant données par la boite de dialogue.
GetDlgItemInt | UINT GetDlgItemInt(HWND hDlg, int nIDDlgItem, BOOL* lpTranslated, BOOL bSigned); | user32.dll | Cette fonction permet d'effectuer la translation du texte d'un contrôle d'une boite de dialogue en une valeur entière.
GetDlgItemTextA | UINT GetDlgItemTextA(HWND hDlg, int nIDDlgItem, LPTSTR lpString, int nMaxCount); | user32.dll | Cette fonction permet de demander le titre ou le texte associé avec un contrôle de boite de dialogue.
GetDlgItemTextW | UINT GetDlgItemTextW(HWND hDlg, int nIDDlgItem, LPWSTR lpString, int nMaxCount); | user32.dll | Cette fonction permet de demander le titre ou le texte associé avec un contrôle de boite de dialogue avec des paramètres de chaine de caractères étendues (Unicode).
GetDoubleClickTime | UINT GetDoubleClickTime(VOID); | user32.dll | Cette fonction permet de demander le temps maximal autorisé pour que des clics sur les boutons de la souris soit considéré comme un double-clic.
GetDriveTypeA | UINT GetDriveTypeA(LPCTSTR lpRootPathName); | kernel32.dll | Cette fonction permet de demander le type d'unité disque.
GetDriveTypeW | UINT GetDriveTypeW(LPCWSTR root); | kernel32.dll | Cette fonction permet de demander le type d'unité disque avec des paramètres de chaine de caractères étendue (Unicode).
GetEnhMetaFileA | HENHMETAFILE GetEnhMetaFileA(LPCTSTR lpszMetaFile); | gdi32.dll | Cette fonction permet de créer un Handle étant identifié par un fichier méta de format étendue entreposé dans le fichier spécifié.
GetEnhMetaFileW | HENHMETAFILE GetEnhMetaFileW(LPCWSTR lpszMetaFile); | gdi32.dll | Cette fonction permet de créer un Handle étant identifié par un fichier méta de format étendue entreposé dans le fichier spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetEnhMetaFileBits | UINT GetEnhMetaFileBits(HENHMETAFILE hemf, UINT cbBuffer, LPBYTE lpbBuffer); | gdi32.dll | Cette fonction permet de demander le contenu d'un fichier méta spécifié de format étendue et le copie dans un tampon.
GetEnhMetaFileDescriptionA | UINT GetEnhMetaFileDescriptionA(HENHMETAFILE hemf, UINT cchBuffer, LPTSTR lpszDescription); | gdi32.dll | Cette fonction permet de demander une description texte optionnel d'un fichier méta de format étendue et copie la chaine de caractères dans un tampon spécifié.
GetEnhMetaFileDescriptionW | UINT GetEnhMetaFileDescriptionW(HENHMETAFILE hmf, UINT size, LPWSTR buf); | gdi32.dll | Cette fonction permet de demander une description texte optionnel d'un fichier méta de format étendue et copie la chaine de caractères dans un tampon spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetEnhMetaFileHeader | UINT GetEnhMetaFileHeader(HENHMETAFILE hemf, UINT cbBuffer, LPENHMETAHEADER lpemh); | gdi32.dll | Cette fonction permet de demander l'enregistrement contenu dans l'entête du fichier méta spécifié de format étendue.
GetEnhMetaFilePaletteEntries | UINT GetEnhMetaFilePaletteEntries(HENHMETAFILE hemf, UINT cEntries, LPPALETTEENTRY lppe); | gdi32.dll | Cette fonction permet de demander les entrées de palette optionnel pour le fichier méta étendue spécifié.
GetEnhMetaFilePixelFormat | UINT GetEnhMetaFilePixelFormat(HENHMETAFILE hemf, DWORD cbBuffer, const PIXELFORMATDESCRIPTOR *ppfd); | gdi32.dll | Cette fonction permet de demander les informations de format de pixel pour un fichier méta étendue.
GetEnvironmentStringsA | LPTCH GetEnvironmentStringsA(void); | kernel32.dll | Cette fonction permet de demander les variables d'environnements du processus courant.
GetEnvironmentStringsW | LPWSTR GetEnvironmentStringsW(void); | kernel32.dll | Cette fonction permet de demander les variables d'environnements du processus courant avec des paramètres de chaine de caractères étendue (Unicode).
GetEnvironmentVariableA | DWORD GetEnvironmentVariableA(LPCTSTR lpName,LPTSTR lpBuffer,DWORD nSize); | kernel32.dll | Cette fonction permet de demander la valeur d'une variable d'environnement du système d'exploitation.
GetEnvironmentVariableW | DWORD GetEnvironmentVariableW( LPCWSTR lpName, LPWSTR lpBuffer, DWORD nSize ); | kernel32.dll | Cette fonction permet de demander la valeur d'une variable d'environnement du système d'exploitation avec des paramètres de chaine de caractères étendue (Unicode).
GetExitCodeProcess | BOOL GetExitCodeProcess( HANDLE hProcess, LPDWORD lpExitCode); | kernel32.dll | Cette fonction permet de demander le code d'état de terminaison d'un processus spécifié.
GetExitCodeThread | BOOL GetExitCodeThread(HANDLE hThread,LPDWORD lpExitCode); | kernel32.dll | Cette fonction permet de demander le code d'état de terminaison d'un processus léger (Thread) spécifié.
GetFileAttributesA | DWORD GetFileAttributesA(LPCTSTR lpFileName); | kernel32.dll | Cette fonction permet de demander les attributs d'un fichier ou d'un répertoire.
GetFileAttributesExA | BOOL GetFileAttributesExA( LPCSTR lpFileName, GET_FILEEX_INFO_LEVELS fInfoLevelId, PVOID lpFileInformation ); | kernel32.dll | Cette fonction permet de demander les informations étendues d'attributs d'un fichier ou d'un répertoire.
GetFileAttributesExW | BOOL GetFileAttributesExW( LPCWSTR lpFileName, GET_FILEEX_INFO_LEVELS fInfoLevelId, PVOID lpFileInformation ); | kernel32.dll | Cette fonction permet de demander les informations étendues d'attributs d'un fichier ou d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
GetFileAttributesW | DWORD GetFileAttributesW(LPCWSTR lpFileName); | kernel32.dll | Cette fonction permet de demander les attributs d'un fichier ou d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
GetFileInformationByHandle | BOOL GetFileInformationByHandle( HANDLE hFile, LPBY_HANDLE_FILE_INFORMATION lpFileInformation, ); | kernel32.dll | Cette fonction permet de demander les informations associé au fichier spécifié.
GetFileSecurityA | BOOL GetFileSecurityA( LPCTSTR lpFileName, SECURITY_INFORMATION RequestedInformation, PSECURITY_DESCRIPTOR pSecurityDescriptor, DWORD nLength, LPDWORD lpnLengthNeeded ); | advapi32.dll | Cette fonction permet de demander les informations spécifié sur la sécurité d'un fichier ou d'un répertoire.
GetFileSecurityW | BOOL GetFileSecurityW( LPCWSTR lpFileName, SECURITY_INFORMATION RequestedInformation, PSECURITY_DESCRIPTOR pSecurityDescriptor, DWORD nLength, LPDWORD lpnLengthNeeded ); | advapi32.dll | Cette fonction permet de demander les informations spécifié sur la sécurité d'un fichier ou d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
GetFileSize | DWORD GetFileSize( HANDLE hFile, LPDWORD lpFileSizeHigh, ); | kernel32.dll | Cette fonction permet de demander la taille, en octets, d'un fichier spécifié.
GetFileTime | BOOL GetFileTime(HANDLE hFile,LPFILETIME lpCreationTime,LPFILETIME lpLastAccessTime,LPFILETIME lpLastWriteTime); | kernel32.dll | Cette fonction permet de demander la date et l'heure d'un fichier de sa création, de sa dernière modification ou de son dernière accès.
GetFileType | DWORD GetFileType(HANDLE hFile); | kernel32.dll | Cette fonction permet de retourner le type d'un fichier spécifié.
GetFileVersionInfoSizeA | DWORD GetFileVersionInfoSizeA(LPTSTR lptstrFilename,LPDWORD lpdwHandle); | version.dll | Cette fonction permet de demander la taille de l'entête d'information de version du fichier spécifié.
GetFocus | HWND GetFocus(VOID); | user32.dll | Cette fonction permet de demander le focus d'entrée de la fenêtre spécifié.
GetFontData | DWORD GetFontData(HDC hdc, DWORD dwTable, DWORD dwOffset, LPVOID lpvBuffer, DWORD cbData); | gdi32.dll | Cette fonction permet de demander les données de police de caractères métriques pour une police de caractères TrueType.
GetFontLanguageInfo | DWORD GetFontLanguageInfo(HDC hdc); | gdi32.dll | Cette fonction permet de retourner les informations à propos de sélection de police de caractères courante dans l'affichage de contexte spécifié.
GetForegroundWindow | HWND GetForegroundWindow(VOID); | user32.dll | Cette fonction permet de demander le Handle de la fenêtre d'application courante.
GetFullPathNameA | DWORD GetFullPathNameA( LPCTSTR lpFileName, DWORD nBufferLength, LPTSTR lpBuffer, LPTSTR *lpFilePart ); | kernel32.dll | Cette fonction permet de demander le chemin et le nom de fichier complet pour un fichier spécifié.
GetFullPathNameW | DWORD GetFullPathNameW( LPCWSTR lpFileName, DWORD nBufferLength, LPWSTR lpBuffer, LPWSTR *lpFilePart ); | kernel32.dll | Cette fonction permet de demander le chemin et le nom de fichier complet pour un fichier spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetGlyphOutlineA | DWORD GetGlyphOutlineA(HDC hdc, UINT uChar, UINT uFormat, LPGLYPHMETRICS lpgm, DWORD cbBuffer, LPVOID lpvBuffer, CONST MAT2 * lpmat2); | gdi32.dll | Cette fonction permet de demander ligne de limite ou du Bitmap d'un caractère d'une police de caractères TrueType étant sélectionné dans le périphérique de contexte spécifié.
GetGlyphOutlineW | DWORD GetGlyphOutlineW(HDC hdc, UINT uChar, UINT uFormat, LPGLYPHMETRICS lpgm, DWORD cbBuffer, LPVOID lpvBuffer, CONST MAT2 * lpmat2); | gdi32.dll | Cette fonction permet de demander ligne de limite ou du Bitmap d'un caractère d'une police de caractères TrueType étant sélectionné dans le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetGraphicsMode | int GetGraphicsMode(HDC hdc); | gdi32.dll | Cette fonction permet de demander le mode graphique courant pour le périphérique de contexte courant.
GetGuiResources | DWORD GetGuiResources(HANDLE hProcess, DWORD uiFlags); | kernel32.dll | Cette fonction permet de demander le nombre d'identificateur de GUI (Interface graphique utilisateur) du processus courant.
GetHandleInformation | BOOL GetHandleInformation( HANDLE hObject, LPDWORD lpdwFlags ); | kernel32.dll | Cette fonction permet de demander les informations conçernant certaines propriétés d'un objet avec un identificateur Handle.
GetICMProfileA | BOOL GetICMProfileA(HDC hdc, DWORD cbName, LPTSTR lpszFilename); | gdi32.dll | Cette fonction permet de demander le nom du fichier de profile de couleurs pour le périphérique associé avec le périphérique de contexte spécifié.
GetICMProfileW | BOOL GetICMProfileW(HDC hdc, LPDWORD size, LPWSTR filename); | gdi32.dll | Cette fonction permet de demander le nom du fichier de profile de couleurs pour le périphérique associé avec le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetIconInfo | BOOL GetIconInfo(HICON hIcon,PICONINFO piconinfo); | user32.dll | Cette fonction permet de demander les informations à propos de l'icône ou du curseur spécifié.
GetInputState | BOOL GetInputState(VOID); | user32.dll | Cette fonction permet d'indiquer si un événement de clic de souris ou de clavier est survenue dans la file d'attente du système du traitement requis.
GetIpStatistics | DWORD GetIpStatistics(PMIB_IPSTATS pStats); | iphlpapi.dll | Cette fonction permet de demander les informations de statistique sur le IP de l'ordinateur.
GetJobA | BOOL GetJobA( HANDLE hPrinter, DWORD JobId, DWORD Level, LPBYTE pJob, DWORD cbBuf, LPDWORD pcbNeeded ); | winspool.drv | Cette fonction permet de demander les données d'un travail contenu dans le tampon d'impressions de l'imprimante.
GetKBCodePage | UINT GetKBCodePage(VOID); | user32.dll | Cette fonction retourne le code de page chargé par le système d'exploitation Windows.
GetKernelObjectSecurity | BOOL GetKernelObjectSecurity( HANDLE Handle, SECURITY_INFORMATION RequestedInformation, PSECURITY_DESCRIPTOR pSecurityDescriptor, DWORD nLength, LPDWORD lpnLengthNeeded ); | advapi32.dll | Cette fonction permet de demander une copie du descripteur de sécurité protégé d'un objet du noyau du système d'exploitation.
GetKerningPairs | DWORD GetKerningPairs(HDC hdc, DWORD nNumPairs, LPKERNINGPAIR lpkrnpair); | gdi32.dll | Cette fonction permet de demander les paires de crénages de caractères pour la police de caractères courante sélectionné du périphérique de contexte spécifié.
GetKeyboardLayout | HKL GetKeyboardLayout(DWORD dwLayout); | user32.dll | Cette fonction permet de demander la couche de clavier active pour le processus léger spécifié.
GetKeyboardLayoutList | UINT GetKeyboardLayoutList(int nBuff, HKL FAR * lpList); | user32.dll | Cette fonction permet de demander le Handle de la couche de clavier correspondant à l'ensemble d'entrée courant local dans le système.
GetKeyboardLayoutNameA | BOOL GetKeyboardLayoutNameA(LPTSTR pwszKLID); | user32.dll | Cette fonction permet de demander le nom des couches de clavier active.
GetKeyboardLayoutNameW | BOOL GetKeyboardLayoutNameW(LPWSTR pwszKLID); | user32.dll | Cette fonction permet de demander le nom des couches de clavier active avec des paramètres de chaine de caractères étendues (Unicode).
GetKeyboardState | BOOL GetKeyboardState(PBYTE lpKeyState); | user32.dll | Cette fonction permet de demander l'état des 256 touches virtuel de clavier.
GetKeyboardType | int GetKeyboardType(int nTypeFlag); | user32.dll | Cette fonction permet de demander les informations à propos du clavier courant.
GetKeyNameTextA | int GetKeyNameTextA(LONG lParam, LPTSTR lpString, int nSize); | user32.dll | Cette fonction permet de demander une chaine de caractères représentant le nom d'une touche du clavier.
GetKeyNameTextW | int GetKeyNameTextW(LONG lParam, LPWSTR lpString, int nSize); | user32.dll | Cette fonction permet de demander une chaine de caractères représentant le nom d'une touche du clavier avec des paramètres de chaine de caractères étendues (Unicode).
GetKeyState | SHORT GetKeyState(int nVirtKey); | user32.dll | Cette fonction permet de demander l'état d'une touche virtuel de clavier.
GetLargestConsoleWindowSize | COORD GetLargestConsoleWindowSize( HANDLE hConsoleOutput ); | kernel32.dll | Cette fonction permet de demander la taille de la fenêtre de console la plus large possible en se basant sur la police de caractères et la taille d'affichage.
GetLastActivePopup | HWND GetLastActivePopup(HWND hWnd); | user32.dll | Cette fonction permet de demander laquelle des fenêtres du propriétaire de la fenêtre POP-UP a été récamment activé.
GetLastError | DWORD GetLastError(VOID); | kernel32.dll | Cette fonction permet de demander la dernière erreur s'étant produite dans une API.
GetLengthSid | DWORD GetLengthSid( PSID pSid ); | advapi32.dll | Cette fonction permet de retourner la longueur, en octets, d'une structure valide d'identificateur de sécurité (SID).
GetLocaleInfoA | int GetLocaleInfoA(LCID Locale,LCTYPE LCType,LPTSTR lpLCData,int cchData); | kernel32.dll | Cette fonction permet de demander des informations de nature local sur le système.
GetLocaleInfoW | INT GetLocaleInfoW( LCID lcid, LCTYPE lctype, LPWSTR buffer, INT len ); | kernel32.dll | Cette fonction permet de demander des informations de nature local sur le système avec des paramètres de chaine de caractères étendue (Unicode).
GetLocalTime | VOID GetLocalTime( LPSYSTEMTIME lpSystemTime ); | kernel32.dll | Cette fonction permet de demander la date et l'heure local du système.
GetLogColorSpaceA | BOOL GetLogColorSpaceA(HCOLORSPACE hColorSpace, LPLOGCOLORSPACE lpbuffer, DWORD nSize); | gdi32.dll | Cette fonction permet de demander les informations à propos de l'espace de couleurs logiques identifié par le Handle spécifié.
GetLogColorSpaceW | BOOL GetLogColorSpaceW(HCOLORSPACE a0, LPLOGCOLORSPACEW a1, DWORD a2); | gdi32.dll | Cette fonction permet de demander les informations à propos de l'espace de couleurs logiques identifié par le Handle spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetLogicalDrives | DWORD GetLogicalDrives(VOID); | kernel32.dll | Cette fonction permet de demander quel sont les unités de disque valide.
GetLogicalDriveStringsA | DWORD GetLogicalDriveStringsA( DWORD nBufferLength, LPTSTR lpBuffer ); | kernel32.dll | Cette fonction permet de remplir un tampon avec une chaine de caractères spécifiant une unité de disque système valide.
GetLogicalDriveStringsW | DWORD GetLogicalDriveStringsW( DWORD nBufferLength, LPWSTR lpBuffer ); | kernel32.dll | Cette fonction permet de remplir un tampon avec une chaine de caractères spécifiant une unité de disque système valide avec des paramètres de chaine de caractères étendue (Unicode).
GetLogicalProcessorInformation | BOOL GetLogicalProcessorInformation( PSYSTEM_LOGICAL_PROCESSOR_INFORMATION Buffer, PDWORD ReturnLength); | kernel32.dll | Cette fonction permet de demander des informations concernant les processeurs logiques et le matériel associé.
GetMailslotInfo | BOOL GetMailslotInfo( HANDLE hMailslot, LPDWORD lpMaxMessageSize, LPDWORD lpNextSize, LPDWORD lpMessageCount, LPDWORD lpReadTimeout ); | kernel32.dll | Cette fonction permet de demander des informations pour une slot de courriel.
GetMapMode | int GetMapMode(HDC hdc); | gdi32.dll | Cette fonction permet de demander le mode de cartographie courant.
GetMenu | HMENU GetMenu(HWND hWnd); | user32.dll | Cette fonction permet de demander le Handle du menu déroulant de la fenêtre d'application spécifié.
GetMenuCheckMarkDimensions | LONG GetMenuCheckMarkDimensions(VOID); | user32.dll | Cette fonction permet de retourner les dimensions du Bitmap marqué par défaut.
GetMenuContextHelpId | DWORD GetMenuContextHelpId(HMENU hmenu); | user32.dll | Cette fonction permet de demander l'identifiant de contexte d'aide associé avec le menu spécifié.
GetMenuDefaultItem | UINT GetMenuDefaultItem(HMENU hMenu, UINT fByPos, UINT gmdiFlags); | user32.dll | Cette fonction permet de demander l'item de menu par défaut du menu spécifié.
GetMenuItemCount | int GetMenuItemCount(HMENU hMenu); | user32.dll | Cette fonction permet de demander le nombre d'item que contient menu déroulant.
GetMenuItemID | UINT GetMenuItemID(HMENU hMenu, int nPos); | user32.dll | Cette fonction permet de demander les identificateurs d'un emplacement d'item de menu d'une position spécifié.
GetMenuItemInfoA | BOOL GetMenuItemInfoA(HMENU hMenu, UINT uItem, BOOL fByPosition, LPMENUITEMINFO lpmii); | user32.dll | Cette fonction permet de demander les informations à propos de l'item de menu.
GetMenuItemInfoW | BOOL GetMenuItemInfoW(HMENU hMenu, UINT uItem, BOOL fByPosition, LPMENUITEMINFOW lpmii); | user32.dll | Cette fonction permet de demander les informations à propos de l'item de menu avec des paramètres de chaine de caractères étendues (Unicode).
GetMenuItemRect | BOOL GetMenuItemRect(HWND hWnd, HMENU hMenu, UINT uItem, LPRECT lprcItem); | user32.dll | Cette fonction permet de demander les limites rectangulaires pour l'item de menu spécifié.
GetMenuState | UINT GetMenuState(HMENU hMenu, UINT uId, UINT uFlags); | user32.dll | Cette fonction permet de demander l'état des drapeaux associés avec l'item de menu spécifié.
GetMenuStringA | int GetMenuStringA(HMENU hMenu, UINT uIDItem, LPTSTR lpString, int nMaxCount, UINT uFlag); | user32.dll | Cette fonction permet de copier l'étiquette d'un item de menu dans un tampon.
GetMenuStringW | int GetMenuStringW(HMENU hMenu, UINT uIDItem, LPWSTR lpString, int nMaxCount, UINT uFlag); | user32.dll | Cette fonction permet de copier l'étiquette d'un item de menu dans un tampon avec des paramètres de chaine de caractères étendues (Unicode).
GetMessageA | BOOL GetMessageA(LPMSG lpMsg, HWND hWnd, UINT wMsgFilterMin, UINT wMsgFilterMax); | user32.dll | Cette fonction permet de demander un message d'une application de file d'attente de message dans une structure spécifié.
GetMessageW | BOOL GetMessageW(LPMSG lpMsg, HWND hWnd, UINT wMsgFilterMin, UINT wMsgFilterMax); | user32.dll | Cette fonction permet de demander un message d'une application de file d'attente de message dans une structure spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetMessageExtraInfo | LONG GetMessageExtraInfo(VOID); | user32.dll | Cette fonction permet de demander les informations supplémentaires associés avec le dernier message des fonctions GetMessage ou PeekMessage.
GetMessagePos | DWORD GetMessagePos(VOID); | user32.dll | Cette fonction permet de retourner une valeur long représentant une position de curseur dans une coordonnée d'écran.
GetMessageTime | LONG GetMessageTime(VOID); | user32.dll | Cette fonction permet de retourner l'heure du dernier message reçu par la fonction GetMessage.
GetMetaFileA | HMETAFILE GetMetaFileA(LPCTSTR lpszFile); | gdi32.dll | Cette fonction permet de créer un Handle identifiant le format Windows de fichier de méta données.
GetMetaFileW | HMETAFILE GetMetaFileW(LPCWSTR lpszMetaFile); | gdi32.dll | Cette fonction permet de créer un Handle identifiant le format Windows de fichier de méta données avec des paramètres de chaine de caractères étendues (Unicode).
GetMetaFileBitsEx | UINT GetMetaFileBitsEx(HMETAFILE hmf, UINT nSize, LPVOID lpvData); | gdi32.dll | Cette fonction permet de demander le contenu d'un fichier méta de format Windows et copie le contenu dans un tampon spécifié.
GetMetaRgn | int GetMetaRgn(HDC hdc, HRGN hrgn); | gdi32.dll | Cette fonction permet de demander la région méta courante pour le périphérique de contexte spécifié.
GetMiterLimit | BOOL GetMiterLimit(HDC hdc, PFLOAT peLimit); | gdi32.dll | Cette fonction permet de demander la limite mitre pour le périphérique de contexte spécifié.
GetModuleFileNameA | DWORD GetModuleFileNameA( HMODULE hModule, LPTSTR lpFilename, DWORD nSize ); | kernel32.dll | Cette fonction permet de demander un nom de fichier long ou demande le nom complet de chemin et nom de fichier pour un fichier exécutable contenu dans le module spécifié.
GetModuleFileNameW | DWORD GetModuleFileNameW ( HMODULE hModule, LPWSTR lpFileName, DWORD size ); | kernel32.dll | Cette fonction permet de demander un nom de fichier long ou demande le nom complet de chemin et nom de fichier pour un fichier exécutable contenu dans le module spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetModuleHandleA | HMODULE GetModuleHandleA( LPCTSTR lpModuleName ); | kernel32.dll | Cette fonction permet de retourner l'identificateur Handle du module spécifié si le fichier est situé dans l'espace d'adresse d'un processus appelant.
GetModuleHandleW | HMODULE GetModuleHandleW( LPCWSTR module ); | kernel32.dll | Cette fonction permet de retourner l'identificateur Handle du module spécifié si le fichier est situé dans l'espace d'adresse d'un processus appelant avec des paramètres de chaine de caractères étendue (Unicode).
GetNamedPipeHandleStateA | BOOL GetNamedPipeHandleStateA( HANDLE hNamedPipe, LPDWORD lpState, LPDWORD lpCurInstances, LPDWORD lpMaxCollectionCount, LPDWORD lpCollectDataTimeout, LPTSTR lpUserName, DWORD nMaxUserNameSize ); | kernel32.dll | Cette fonction permet de demander les informations d'état conçernant le nom du tuyau spécifié.
GetNamedPipeHandleStateW | BOOL GetNamedPipeHandleStateW( HANDLE hNamedPipe, PDWORD lpState, PDWORD lpCurInstances, PDWORD lpMaxCollectionCount, PDWORD lpCollectDataTimeout, LPWSTR lpUserName, DWORD nMaxUserNameSize ); | kernel32.dll | Cette fonction permet de demander les informations d'état conçernant le nom du tuyau spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetNamedPipeInfo | BOOL GetNamedPipeInfo( HANDLE hNamedPipe, LPDWORD lpFlags, LPDWORD lpOutBufferSize, LPDWORD lpInBufferSize, LPDWORD lpMaxInstances ); | kernel32.dll | Cette fonction permet de demander les informations conçernant le nom de tuyau spécifié.
GetNearestColor | COLORREF GetNearestColor(HDC hdc, COLORREF crColor); | gdi32.dll | Cette fonction permet de demander la couleur solide correspondant le mieux à la couleur logique.
GetNearestPaletteIndex | UINT GetNearestPaletteIndex(HPALETTE hpal, COLORREF crColor); | gdi32.dll | Cette fonction permet de demander l'index d'une entrée de palette logique correspondant le mieux à la valeur de couleur spécifié.
GetNextDlgGroupItem | HWND GetNextDlgGroupItem(HWND hDlg, HWND hCtl, BOOL bPrevious); | user32.dll | Cette fonction permet de rechercher le contrôle précédent ou suivant d'un groupe de contrôle dans une boite de dialogue.
GetNextDlgTabItem | HWND GetNextDlgTabItem(HWND hDlg, HWND hCtl, BOOL bPrevious); | user32.dll | Cette fonction permet de demander le Handle du premier contrôle d'un style WS_TABSTOP du contrôle spécifié.
GetNextWindow | HWND GetNextWindow(HWND hWnd, UINT wCmd); | user32.dll | Cette fonction permet de rechercher le Handle de la prochaine ou précédente fenêtre dans la liste du gestionnaire de fenêtre.
GetNumaAvailableMemoryNode | BOOL GetNumaAvailableMemoryNode(UCHAR Node,PULONGLONG AvailableBytes); | kernel32.dll | Cette fonction permet de demander la quantité de mémoire disponible dans le noeud spécifié.
GetNumberFormatA | int GetNumberFormatA( LCID Locale, DWORD dwFlags, LPCTSTR lpValue, CONST NUMBERFMT * lpFormat, LPTSTR lpNumberStr, int cchNumber ); | kernel32.dll | Cette fonction permet de transformer un nombre selon le format d'affichage spécifié.
GetNumberFormatW | int GetNumberFormatW( LCID lcid, DWORD dwFlags, LPCWSTR lpszValue, const NUMBERFMTW* lpFormat, LPWSTR lpNumberStr, int cchOut ); | kernel32.dll | Cette fonction permet de transformer un nombre selon le format d'affichage spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetNumberOfConsoleInputEvents | BOOL GetNumberOfConsoleInputEvents( HANDLE hConsoleInput, LPDWORD lpcNumberOfEvents ); | kernel32.dll | Cette fonction permet de demander le nombre d'enregistrement d'entrée non lue dans le tampon d'entrée de console.
GetNumberOfConsoleMouseButtons | BOOL GetNumberOfConsoleMouseButtons( LPDWORD lpNumberOfMouseButtons ); | kernel32.dll | Cette fonction permet de demander le nombre de boutons de la souris qu'utilise la console courante.
GetNumberOfEventLogRecords | BOOL GetNumberOfEventLogRecords( HANDLE hEventLog, PDWORD NumberOfRecords ); | advapi32.dll | Cette fonction permet de demander le nombre d'enregistrement de l'événement du journal de bord spécifié.
GetObjectA | int GetObjectA(HGDIOBJ hgdiobj, int cbBuffer, LPVOID lpvObject); | gdi32.dll | Cette fonction permet de remplir un tampon avec les informations définit dans la région spécifié.
GetObjectW | int GetObjectW(HGDIOBJ hgdiobj, int cbBuffer, LPVOID lpvObject); | gdi32.dll | Cette fonction permet de remplir un tampon avec les informations définit dans la région spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetObjectType | DWORD GetObjectType(HGDIOBJ h); | gdi32.dll | Cette fonction permet de demander l'identifiant de type d'objet spécifié.
GetOEMCP | UINT GetOEMCP(VOID); | kernel32.dll | Cette fonction permet de demander le code de page OEM du système d'exploitation.
GetOldestEventLogRecord | BOOL GetOldestEventLogRecord( HANDLE hEventLog, PDWORD OldestRecord ); | advapi32.dll | Cette fonction permet de demander le nombre d'enregistrement dans les anciens enregistrement du journal de bord spécifié.
GetOpenClipboardWindow | HWND GetOpenClipboardWindow(VOID); | user32.dll | Cette fonction permet de demander le Handle de la fenêtre actuellement ouverte dans le presse-papier.
GetOpenFileNameA | BOOL GetOpenFileNameA(LPOPENFILENAME lpofn); | comdlg32.dll | Cette fonction permet d'afficher une boite de dialogue offrant la possibilité de choisir un fichier.
GetOutlineTextMetricsA | UINT GetOutlineTextMetricsA(HDC hdc, UINT cbData, LPOUTLINETEXTMETRIC lpOTM); | gdi32.dll | Cette fonction permet de demander le métrique du texte pour la police de caractères TrueType.
GetOutlineTextMetricsW | UINT GetOutlineTextMetricsW(HDC hdc, UINT cbData, LPOUTLINETEXTMETRICW lpOTM); | gdi32.dll | Cette fonction permet de demander le métrique du texte pour la police de caractères TrueType avec des paramètres de chaine de caractères étendues (Unicode).
GetOverlappedResult | BOOL GetOverlappedResult( HANDLE hFile, LPOVERLAPPED lpOverlapped, LPDWORD lpNumberOfBytesTransferred, BOOL bWait ); | kernel32.dll | Cette fonction permet de retourner le résultat d'une opération de recouvrement sur un fichier, un tuyau ou un périphérique de communications spécifié
GetPaletteEntries | UINT GetPaletteEntries(HPALETTE hpal, UINT iStartIndex, UINT nEntries, LPPALETTEENTRY lppe); | gdi32.dll | Cette fonction permet de demander le rang des entrées d'une palette dans une palette logique.
GetParent | HWND GetParent(HWND hWnd); | user32.dll | Cette fonction permet de demander le Handle de la fenêtre parent spécifié.
GetPath | int GetPath(HDC hdc, LPPOINT lpPoints, LPBYTE lpTypes, int nSize); | gdi32.dll | Cette fonction permet de demander les coordonnées définit par des points de fin de lignes et une courbe de point de contrôle trouvé dans un chemin étant sélectionné dans un périphérique de contexte spécifié.
GetPixel | COLORREF GetPixel(HDC hdc,int nXPos,int nYPos); | gdi32.dll | Cette fonction permet de demander la couleur sous format RVB (RGB) d'un pixel affiché à l'écran.
GetPixelFormat | int GetPixelFormat(HDC hdc); | gdi32.dll | Cette fonction permet de demander l'index du format de pixel actuellement sélectionné dans le périphérique de contexte spécifié.
GetPolyFillMode | int GetPolyFillMode(HDC hdc); | gdi32.dll | Cette fonction permet de demander le mode de remplissage d'un polygone.
GetPrinterA | BOOL GetPrinterA( HANDLE hPrinter, DWORD Level, LPBYTE pPrinter, DWORD cbBuf, LPDWORD pcbNeeded ); | winspool.drv | Cette fonction permet de demander des informations sur une imprimante.
GetPriorityClass | DWORD GetPriorityClass( HANDLE hProcess ); | kernel32.dll | Cette fonction permet de retourner la priorité d'une classe pour un processus spécifié.
GetPriorityClipboardFormat | int GetPriorityClipboardFormat(UINT * paFormatPriorityList, int cFormats); | user32.dll | Cette fonction permet de demander le format du premier presse-papier dans la liste de données existantes du presse-papier.
GetPrivateObjectSecurity | BOOL GetPrivateObjectSecurity( PSECURITY_DESCRIPTOR ObjectDescriptor, SECURITY_INFORMATION SecurityInformation, PSECURITY_DESCRIPTOR ResultantDescriptor, DWORD DescriptorLength, PDWORD ReturnLength ); | advapi32.dll | Cette fonction permet de demander des informations de descripteur de sécurité à un serveur d'objet protégé.
GetPrivateProfileIntA | UINT GetPrivateProfileIntA( LPCTSTR lpAppName, LPCTSTR lpKeyName, INT nDefault, LPCTSTR lpFileName ); | kernel32.dll | Cette fonction permet de demander un entier associé avec une clef dans une section spécifié d'un fichier initialisé.
GetPrivateProfileIntW | UINT GetPrivateProfileIntW( LPCWSTR lpAppName, LPCWSTR lpKeyName, INT nDefault, LPCWSTR lpFileName ); | kernel32.dll | Cette fonction permet de demander un entier associé avec une clef dans une section spécifié d'un fichier initialisé avec des paramètres de chaine de caractères étendue (Unicode).
GetPrivateProfileSectionA | DWORD GetPrivateProfileSectionA( LPCTSTR lpAppName, LPTSTR lpReturnedString, DWORD nSize, LPCTSTR lpFileName ); | kernel32.dll | Cette fonction permet de demander tous les valeurs et clefs pour la section initialisé spécifié.
GetPrivateProfileSectionW | DWORD GetPrivateProfileSectionW( LPCWSTR lpAppName, LPWSTR lpReturnedString, DWORD nSize, LPCWSTR lpFileName ); | kernel32.dll | Cette fonction permet de demander tous les valeurs et clefs pour la section initialisé spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetPrivateProfileSectionNamesA | DWORD GetPrivateProfileSectionNamesA( LPTSTR lpszReturnBuffer, DWORD nSize, LPCTSTR lpFileName ); | kernel32.dll | Cette fonction permet de demander les noms de toutes les sections dans un fichier initialisé.
GetPrivateProfileSectionNamesW | DWORD GetPrivateProfileSectionNamesW( LPWSTR lpszReturnBuffer, DWORD nSize, LPCWSTR lpFileName ); | kernel32.dll | Cette fonction permet de demander les noms de toutes les sections dans un fichier initialisé avec des paramètres de chaine de caractères étendue (Unicode).
GetPrivateProfileStringA | DWORD GetPrivateProfileStringA( LPCTSTR lpAppName, LPCTSTR lpKeyName, LPCTSTR lpDefault, LPTSTR lpReturnedString, DWORD nSize, LPCTSTR lpFileName ); | kernel32.dll | Cette fonction permet de demander une chaine de caractères de la section spécifié dans un fichier initialisé.
GetPrivateProfileStringW | DWORD GetPrivateProfileStringW( LPCWSTR lpAppName, LPCWSTR lpKeyName, LPCWSTR lpDefault, LPWSTR lpReturnedString, DWORD nSize, LPCWSTR lpFileName ); | kernel32.dll | Cette fonction permet de demander une chaine de caractères de la section spécifié dans un fichier initialisé avec des paramètres de chaine de caractères étendue (Unicode).
GetProcAddress | FARPROC GetProcAddress( HMODULE hModule, LPCSTR lpProcName ); | kernel32.dll | Cette fonction permet de demander l'adresse d'une fonction d'exportation de bibliothèque de liens dynamique (DLL).
GetProcessAffinityMask | BOOL GetProcessAffinityMask( HANDLE hProcess, LPDWORD lpProcessAffinityMask, LPDWORD lpSystemAffinityMask ); | kernel32.dll | Cette fonction permet de demander un masque de correspondance de processus spécifié avec le système.
GetProcessHeap | HANDLE GetProcessHeap(VOID); | kernel32.dll | Cette fonction permet de demander un identificateur Handle pour la mémoire de tas d'un processus appelant.
GetProcessHeaps | DWORD GetProcessHeaps( DWORD NumberOfHeaps, PHANDLE ProcessHeaps ); | kernel32.dll | Cette fonction permet de demander un identificateur Handle pour tous les mémoires de tas valides pour un processus appelant.
GetProcessPriorityBoost | BOOL GetProcessPriorityBoost( HANDLE hProcess, PBOOL pDisablePriorityBoost ); | kernel32.dll | Cette fonction permet de demander l'état de la priorité de contrôle d'amplificateur d'un processus spécifié.
GetProcessShutdownParameters | BOOL GetProcessShutdownParameters( LPDWORD lpdwLevel, LPDWORD lpdwFlags ); | kernel32.dll | Cette fonction permet de demander les paramètres de fermetures et d'éteindre le système d'exploitation pour un le processus appelant courant.
GetProcessTimes | BOOL GetProcessTimes( HANDLE hProcess, LPFILETIME lpCreationTime, LPFILETIME lpExitTime, LPFILETIME lpKernelTime, LPFILETIME lpUserTime ); | kernel32.dll | Cette fonction permet de demander les informations d'horloge pour le processus spécifié.
GetProcessVersion | DWORD GetProcessVersion( DWORD ProcessId ); | kernel32.dll | Cette fonction permet de demander la version majeur et mineur pour un processus spécifié en exécution.
GetProcessWindowStation | HWINSTA GetProcessWindowStation(VOID); | user32.dll | Cette fonction permet de demander le Handle de la fenêtre de station associé avec le processus appelant.
GetProcessWorkingSetSize | BOOL GetProcessWorkingSetSize( HANDLE hProcess, LPDWORD lpMinimumWorkingSetSize, LPDWORD lpMaximumWorkingSetSize ); | kernel32.dll | Cette fonction permet de demander la taille de l'espace de travail minimum et maximum pour le processus spécifié.
GetProfileIntA | UINT GetProfileIntA( LPCTSTR lpAppName, LPCTSTR lpKeyName, INT nDefault ); | kernel32.dll | Cette fonction permet de demander un entier pour le nom de clef spécifié dans une section spécifié dans un fichier «WIN.INI».
GetProfileIntW | UINT GetProfileIntW( LPCWSTR lpAppName, LPCWSTR lpKeyName, INT nDefault ); | kernel32.dll | Cette fonction permet de demander un entier pour le nom de clef spécifié dans une section spécifié dans un fichier «WIN.INI» avec des paramètres de chaine de caractères étendue (Unicode).
GetProfileSectionA | DWORD GetProfileSectionA( LPCTSTR lpAppName, LPTSTR lpReturnedString, DWORD nSize ); | kernel32.dll | Cette fonction permet de demander tous les valeurs et clefs pour la section spécifié dans un fichier «WIN.INI».
GetProfileSectionW | DWORD GetProfileSectionW( LPCWSTR lpAppName, LPWSTR lpReturnedString, DWORD nSize ); | kernel32.dll | Cette fonction permet de demander tous les valeurs et clefs pour la section spécifié dans un fichier «WIN.INI» avec des paramètres de chaine de caractères étendue (Unicode).
GetProfileStringA | DWORD GetProfileStringA( LPCTSTR lpAppName, LPCTSTR lpKeyName, LPCTSTR lpDefault, LPTSTR lpReturnedString, DWORD nSize ); | kernel32.dll | Cette fonction permet de demander une chaine de caractères associé avec la clef spécifié dans une section du fichier «WIN.INI».
GetProfileStringW | DWORD GetProfileStringW( LPCWSTR lpAppName, LPCWSTR lpKeyName, LPCWSTR lpDefault, LPWSTR lpReturnedString, DWORD nSize ); | kernel32.dll | Cette fonction permet de demander une chaine de caractères associé avec la clef spécifié dans une section du fichier «WIN.INI» avec des paramètres de chaine de caractères étendue (Unicode).
GetPropA | HANDLE GetPropA(HWND hWnd, LPCTSTR lpString); | user32.dll | Cette fonction permet de demander une données Handle d'une liste de propriété d'une fenêtre.
GetPropW | HANDLE GetPropW(HWND hWnd, LPCWSTR lpString); | user32.dll | Cette fonction permet de demander une données Handle d'une liste de propriété d'une fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
GetQueuedCompletionStatus | BOOL GetQueuedCompletionStatus( HANDLE CompletionPort, LPDWORD lpNumberOfBytesTransferred, LPDWORD lpCompletionKey, LPOVERLAPPED * lpOverlapped, DWORD dwMilliseconds ); | kernel32.dll | Cette fonction permet d'essayer de compléter la file d'attente d'un paquet d'entrée/sortie spécifié pour un port d'entrée/sortie.
GetQueueStatus | DWORD GetQueueStatus(UINT flags); | user32.dll | Cette fonction permet de retourner une valeur indiquant le type de message dans la file d'attente.
GetRasterizerCaps | BOOL GetRasterizerCaps(LPRASTERIZER_STATUS lprs, UINT cb); | gdi32.dll | Cette fonction permet de retourner les drapeaux indiquant si la police de caractères TrueType est installé dans le système.
GetRegionData | DWORD GetRegionData(HRGN hRgn, DWORD dwCount, LPRGNDATA lpRgnData); | gdi32.dll | Cette fonction permet de remplir le tampons spécifié avec une région de données décrites.
GetRgnBox | int GetRgnBox(HRGN hrgn, LPRECT lprc); | gdi32.dll | Cette fonction permet de demander les coordonnées des limites rectangulaires d'une région spécifié.
GetROP2 | int GetROP2(HDC hdc); | gdi32.dll | Cette fonction permet de demander le mode dessinage courant.
GetScrollInfo | BOOL GetScrollInfo(HWND hwnd, int fnBar, LPSCROLLINFO lpsi); | user32.dll | Cette fonction permet de demander les paramètres d'une barre de défilement, en incluant les positions de défilement minimum et maximum, la taille de la page et la position de la boite de défilement.
GetScrollPos | int GetScrollPos(HWND hWnd, int nBar); | user32.dll | Cette fonction permet de demander la position courante de la boite de défilement d'une barre de défilement.
GetScrollRange | BOOL GetScrollRange(HWND hWnd, int nBar, LPINT lpMinPos, LPINT lpMaxPos); | user32.dll | Cette fonction permet de demander la position minimum et maximum de la barre de défilement spécifié.
GetSecurityDescriptorControl | BOOL GetSecurityDescriptorControl( PSECURITY_DESCRIPTOR pSecurityDescriptor, PSECURITY_DESCRIPTOR_CONTROL pControl, LPDWORD lpdwRevision ); | advapi32.dll | Cette fonction permet de demander le contrôle de descripteur de sécurité et les informations de révision.
GetSecurityDescriptorDacl | BOOL GetSecurityDescriptorDacl( PSECURITY_DESCRIPTOR pSecurityDescriptor, LPBOOL lpbDaclPresent, PACL *pDacl, LPBOOL lpbDaclDefaulted ); | advapi32.dll | Cette fonction permet de demander un pointeur sur une liste de contrôle d'accès (ACL) discrétionnaire dans un descripteur de sécurité spécifié.
GetSecurityDescriptorGroup | BOOL GetSecurityDescriptorGroup( PSECURITY_DESCRIPTOR pSecurityDescriptor, PSID * pGroup, LPBOOL lpbGroupDefaulted ); | advapi32.dll | Cette fonction permet de demander les informations de groupe primaire d'un descripteur de sécurité.
GetSecurityDescriptorLength | DWORD GetSecurityDescriptorLength( PSECURITY_DESCRIPTOR pSecurityDescriptor ); | advapi32.dll | Cette fonction permet de retourner la longueur, en octets, d'une structure valide de descripteur de sécurité.
GetSecurityDescriptorOwner | BOOL GetSecurityDescriptorOwner( PSECURITY_DESCRIPTOR pSecurityDescriptor, PSID * pOwner, LPBOOL lpbOwnerDefaulted ); | advapi32.dll | Cette fonction permet de demander les informations du propriétaire d'un descripteur de sécurité
GetSecurityDescriptorSacl | BOOL GetSecurityDescriptorSacl( PSECURITY_DESCRIPTOR pSecurityDescriptor, LPBOOL lpbSaclPresent, PACL *pSacl, LPBOOL lpbSaclDefaulted ); | advapi32.dll | Cette fonction permet de demander un pointeur sur la liste de contrôle d'accès système (ACL) dans un descripteur de sécurité spécifié.
GetShortPathNameA | DWORD GetShortPathNameA( LPCTSTR lpszLongPath, LPTSTR lpszShortPath, DWORD cchBuffer ); | kernel32.dll | Cette fonction permet de demander, à partir d'un nom long, le nom en format DOS (8 caractères de nom et 3 caractères d'extension) d'un fichier.
GetShortPathNameW | DWORD GetShortPathNameW( LPCWSTR lpszLongPath, LPWSTR lpszShortPath, DWORD cchBuffer ); | kernel32.dll | Cette fonction permet de demander, à partir d'un nom long, le nom en format DOS (8 caractères de nom et 3 caractères d'extension) d'un fichier avec des paramètres de chaine de caractères étendue (Unicode).
GetSidIdentifierAuthority | PSID_IDENTIFIER_AUTHORITY GetSidIdentifierAuthority( PSID pSid ); | advapi32.dll | Cette fonction permet de retourner l'adresse de la structure d'un «SID_IDENTIFIER_AUTHORITY» dans l'identificateur de sécurité (SID) spécifié.
GetSidLengthRequired | DWORD GetSidLengthRequired( UCHAR nSubAuthorityCount ); | advapi32.dll | Cette fonction permet de retourner la longueur, en octets, d'un tampon requis pour l'entreposage d'une structure SID avec le nombre de sous-autorisation spécifié.
GetSidSubAuthority | PDWORD GetSidSubAuthority( PSID pSid, DWORD nSubAuthority ); | advapi32.dll | Cette fonction permet de retourner l'adresse d'une sous-autorité spécifié d'une structure SID.
GetSidSubAuthorityCount | PUCHAR GetSidSubAuthorityCount( PSID pSid ); | advapi32.dll | Cette fonction permet de retourner l'adresse d'un champs d'une structure SID contenant le compteur de sous-autorité.
GetStartupInfoA | VOID GetStartupInfoA( LPSTARTUPINFO lpStartupInfo ); | kernel32.dll | Cette fonction permet de demander le contenu de la structure «STARTUPINFO» spécifié quand un appel de processus est créé.
GetStartupInfoW | VOID GetStartupInfoW( LPSTARTUPINFOW lpStartupInfo ); | kernel32.dll | Cette fonction permet de demander le contenu de la structure «STARTUPINFO» spécifié quand un appel de processus est créé avec des paramètres de chaine de caractères étendue (Unicode).
GetStdHandle | HANDLE GetStdHandle(DWORD nStdHandle); | kernel32.dll | Cette fonction permet de demander le Handle d'une entrée ou sortie standard.
GetStockObject | HGDIOBJ GetStockObject(int fnObject); | gdi32.dll | Cette fonction permet de demander le Handle d'un des outils de stylo, brosse, police de caractères,... des objets de Windows
GetStretchBltMode | int GetStretchBltMode(HDC hdc); | gdi32.dll | Cette fonction permet de demander le mode d'étirement du Bitmap courant.
GetStringTypeA | BOOL GetStringTypeA( LCID Locale, DWORD dwInfoType, LPCSTR lpSrcStr, int cchSrc, LPWORD lpCharType ); | kernel32.dll | Cette fonction permet de retourner des informations type de caractère pour la chaine de caractères spécifié.
GetStringTypeExA | BOOL GetStringTypeExA( LCID Locale, DWORD dwInfoType, LPCTSTR lpSrcStr, int cchSrc, LPWORD lpCharType ); | kernel32.dll | Cette fonction permet de retourner des informations type de caractère pour la chaine de caractères spécifié en Win32.
GetStringTypeExW | BOOL GetStringTypeExW( LCID locale, DWORD type, LPCWSTR src, INT count, LPWORD chartype ); | kernel32.dll | Cette fonction permet de retourner des informations type de caractère pour la chaine de caractères spécifié en Win32 avec des paramètres de chaine de caractères étendue (Unicode).
GetStringTypeW | BOOL GetStringTypeW( DWORD type, LPCWSTR src, INT count, LPWORD chartype ); | kernel32.dll | Cette fonction permet de retourner des informations type de caractère pour la chaine de caractères spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetSubMenu | HMENU GetSubMenu(HMENU hMenu, int nPos); | user32.dll | Cette fonction permet de demander le Handle du menu contextuel.
GetSysColor | DWORD GetSysColor(int nIndex); | user32.dll | Cette fonction permet de demander la couleur d'un des objets affichés du système d'exploitations de Windows.
GetSysColorBrush | HBRUSH GetSysColorBrush(int nIndex); | user32.dll | Cette fonction permet de demander le Handle identifiant la brosse logique correspondant à l'index de couleur spécifié.
GetSystemDefaultLCID | LCID GetSystemDefaultLCID(VOID); | kernel32.dll | Cette fonction permet de demander l'identificateur locale du système par défaut.
GetSystemDefaultLangID | LANGID GetSystemDefaultLangID(VOID); | kernel32.dll | Cette fonction permet de demander l'identificateur de langage système par défaut.
GetSystemDirectoryA | UINT GetSystemDirectoryA(LPTSTR lpBuffer,UINT uSize); | kernel32.dll | Cette fonction permet de demander le répertoire dans lequel les fichiers systèmes du système d'exploitations de Windows sont situés.
GetSystemDirectoryW | UINT GetSystemDirectoryW(LPWSTR lpBuffer, UINT uSize); | kernel32.dll | Cette fonction permet de demander le répertoire dans lequel les fichiers systèmes du système d'exploitations de Windows sont situés avec des paramètres de chaine de caractères étendue (Unicode).
GetSystemInfo | VOID GetSystemInfo(LPSYSTEM_INFO lpSystemInfo); | kernel32.dll | Cette fonction permet de demander divers informations à propos du système courant et du microprocesseur.
GetSystemMenu | HMENU GetSystemMenu(HWND hWnd,BOOL bRevert); | user32.dll | Cette fonction permet de demander le Handle du menu système d'une fenêtre d'application.
GetSystemMetrics | int GetSystemMetrics(int nIndex); | user32.dll | Cette fonction permet de demander le type de système métrique ou de ses paramètres utilisés.
GetSystemPaletteEntries | UINT GetSystemPaletteEntries(HDC hdc, UINT iStartIndex, UINT nEntries, LPPALETTEENTRY lppe); | gdi32.dll | Cette fonction permet de demander un rang dans les entrées de palette de la palette système.
GetSystemPaletteUse | UINT GetSystemPaletteUse(HDC hdc); | gdi32.dll | Cette fonction permet de demander si une application est accessible à une palette d'entrée système.
GetSystemPowerStatus | BOOL GetSystemPowerStatus(LPSYSTEM_POWER_STATUS lpSystemPowerStatus); | kernel32.dll | Cette fonction permet de demander l'état de l'alimentation en énergie de l'ordinateur.
GetSystemTime | VOID GetSystemTime(LPSYSTEMTIME lpSystemTime); | kernel32.dll | Cette fonction permet de demander le temps (date et heure) courant du système d'exploitation. Le temps du système d'exploitation est une expression UTC (Coordinated Universal Time).
GetSystemTimeAsFileTime | VOID GetSystemTimeAsFileTime(LPFILETIME lpSystemTimeAsFileTime); | kernel32.dll | Cette fonction permet de demander la date et l'heure du système d'exploitation.
GetSystemTimeAdjustment | BOOL GetSystemTimeAdjustment( PDWORD lpTimeAdjustment, PDWORD lpTimeIncrement, PBOOL lpTimeAdjustmentDisabled ); | kernel32.dll | Cette fonction permet de demander si le système applique périodiquement un ajustement du temps après chaque tic d'horloge.
GetTabbedTextExtentA | DWORD GetTabbedTextExtentA(HDC hDC, LPCTSTR lpString, int nCount, int nTabPositions, LPINT lpnTabStopPositions); | user32.dll | Cette fonction permet de calculer la largeur et la hauteur d'une chaine de caractères.
GetTabbedTextExtentW | DWORD GetTabbedTextExtentW(HDC hDC, LPCWSTR lpString, int nCount, int nTabPositions, LPINT lpnTabStopPositions); | user32.dll | Cette fonction permet de calculer la largeur et la hauteur d'une chaine de caractères avec des paramètres de chaine de caractères étendues (Unicode).
GetTapeParameters | DWORD GetTapeParameters( HANDLE hDevice, DWORD dwOperation, LPDWORD lpdwSize, LPVOID lpTapeInformation ); | kernel32.dll | Cette fonction permet de demander des informations descriptives sur l'unité de bande magnétique de copie de sauvegarde.
GetTapePosition | DWORD GetTapePosition( HANDLE hDevice, DWORD dwPositionType, LPDWORD lpdwPartition, LPDWORD lpdwOffsetLow, LPDWORD lpdwOffsetHigh ); | kernel32.dll | Cette fonction permet de demander l'adresse courante logique ou en bloc absolue sur une bande magnétique de copie de sauvegarde.
GetTapeStatus | DWORD GetTapeStatus(HANDLE hDevice); | kernel32.dll | Cette fonction permet de demander si la bande magnétique de copie de sauvegarde est prête à recevoir une commande de processus.
GetTcpStatistics | DWORD GetTcpStatistics(PMIB_TCPSTATS pStats); | iphlpapi.dll | Cette fonction permet de demander les informations de statistique sur le TCP de l'ordinateur.
GetTempFileNameA | UINT GetTempFileNameA(LPCTSTR lpPathName, LPCTSTR lpPrefixString, UINT uUnique, LPTSTR lpTempFileName); | kernel32.dll | Cette fonction permet de demander un nom de fichier créer temporairement.
GetTempFileNameW | UINT GetTempFileNameW( LPCWSTR lpPathName, LPCWSTR lpPrefixString, UINT unique, LPWSTR lpTempFileName ); | kernel32.dll | Cette fonction permet de demander un nom de fichier créer temporairement avec des paramètres de chaine de caractères étendue (Unicode).
GetTempPathA | DWORD GetTempPathA(DWORD nBufferLength,LPTSTR lpBuffer); | kernel32.dll | Cette fonction permet de demander le répertoire par défaut des fichiers temporairement.
GetTempPathW | DWORD GetTempPathW(DWORD nBufferLength,LPWSTR lpBuffer); | kernel32.dll | Cette fonction permet de demander le répertoire par défaut des fichiers temporairement avec des paramètres de chaine de caractères étendue (Unicode).
GetTextAlign | UINT GetTextAlign(HDC hdc); | gdi32.dll | Cette fonction permet de demander l'état des drapeaux d'alignement de texte pour un périphérique de contexte spécifié.
GetTextCharacterExtra | int GetTextCharacterExtra(HDC hdc); | gdi32.dll | Cette fonction permet de demander l'ajustement courant pour la quantité d'espacement entre les caractères.
GetTextCharset | UINT GetTextCharsetInfo(HDC hdc, LPFONTSIGNATURE * lpSig, DWORD dwFlags); | gdi32.dll | Cette fonction permet de demander les informations à propos d'un ensemble de caractères de la police de caractères actuellement sélectionné.
GetTextCharsetInfo | UINT GetTextCharsetInfo(HDC hdc, LPFONTSIGNATURE * lpSig, DWORD dwFlags); | gdi32.dll | Cette fonction permet de demander les informations supplémentaires à propos de l'ensemble de caractères de la police de caractères actuellement sélectionné.
GetTextColor | COLORREF GetTextColor(HDC hdc); | gdi32.dll | Cette fonction permet de demander la couleur de texte courante.
GetTextExtentExPointA | BOOL GetTextExtentExPointA(HDC hdc, LPCTSTR lpszStr, int cchString, int nMaxExtent, LPINT lpnFit, LPINT alpDx, LPSIZE lpSize); | gdi32.dll | Cette fonction permet de demander le nombre de caractères dans la chaine de caractères correspondant à l'espace spécifié et remplit un tableau avec le texte étendue pour chacun de ses caractères.
GetTextExtentExPointW | BOOL GetTextExtentExPointW(HDC hdc, LPCWSTR lpszStr, int cchString, int nMaxExtent, LPINT lpnFit, LPINT alpDx, LPSIZE lpSize); | gdi32.dll | Cette fonction permet de demander le nombre de caractères dans la chaine de caractères correspondant à l'espace spécifié et remplit un tableau avec le texte étendue pour chacun de ses caractères avec des paramètres de chaine de caractères étendues (Unicode).
GetTextExtentPoint32A | BOOL GetTextExtentPoint32A(HDC hdc, LPCTSTR lpString, int cbString, LPSIZE lpSize); | gdi32.dll | Cette fonction permet de calculer la largeur et la hauteur de la chaine de caractères de texte spécifié.
GetTextExtentPoint32W | BOOL GetTextExtentPoint32W(HDC hdc, LPCWSTR str, INT count, LPSIZE size); | gdi32.dll | Cette fonction permet de calculer la largeur et la hauteur de la chaine de caractères de texte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetTextExtentPointA | BOOL GetTextExtentPointA(HDC hdc, LPCTSTR lpString, int cbString, LPSIZE lpSize); | gdi32.dll | Cette fonction permet de calculer la largeur et la hauteur d'un chaine de caractères de texte spécifié dans un contexte de compatibilité 16 bits.
GetTextExtentPointW | BOOL GetTextExtentPointW(HDC hdc, LPCWSTR lpString, int cbString, LPSIZE lpSize); | gdi32.dll | Cette fonction permet de calculer la largeur et la hauteur d'un chaine de caractères de texte spécifié dans un contexte de compatibilité 16 bits avec des paramètres de chaine de caractères étendues (Unicode).
GetTextFaceA | int GetTextFaceA(HDC hdc, int nCount, LPTSTR lpFaceName); | gdi32.dll | Cette fonction permet de demander le nom de type de police de caractères étant sélectionné dans le périphérique de contexte spécifié.
GetTextFaceW | int GetTextFaceW(HDC hdc, int nCount, LPWSTR lpFaceName); | gdi32.dll | Cette fonction permet de demander le nom de type de police de caractères étant sélectionné dans le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetTextMetricsA | BOOL GetTextMetricsA(HDC hdc, LPTEXTMETRIC lptm); | gdi32.dll | Cette fonction permet de demander les informations métriques d'une police de caractères courante.
GetTextMetricsW | BOOL GetTextMetricsW(HDC hdc, LPTEXTMETRICW lptm); | gdi32.dll | Cette fonction permet de demander les informations métriques d'une police de caractères courante avec des paramètres de chaine de caractères étendues (Unicode).
GetThreadContext | BOOL GetThreadContext( HANDLE hThread, LPCONTEXT lpContext ); | kernel32.dll | Cette fonction permet de demander le contexte d'un processus léger spécifié.
GetThreadDesktop | HDESK GetThreadDesktop(DWORD dwThreadId); | user32.dll | Cette fonction permet de demander le Handle du bureau associé avec le processus spécifié.
GetThreadLocale | LCID GetThreadLocale(VOID); | kernel32.dll | Cette fonction permet de demander l'identificateur local d'un processus.
GetThreadPriority | int GetThreadPriority(HANDLE hThread); | kernel32.dll | Cette fonction permet de retourner la valeur de priorité du processus léger spécifié.
GetThreadPriorityBoost | BOOL GetThreadPriorityBoost(HANDLE hthread, PBOOL pstate); | kernel32.dll | Cette fonction permet de retourner la priorité de lancement d'un processus léger.
GetThreadSelectorEntry | BOOL GetThreadSelectorEntry( HANDLE hThread, DWORD dwSelector, LPLDT_ENTRY lpSelectorEntry ); | kernel32.dll | Cette fonction permet de retourner l'entrée de descripteur de table pour le sélecteur et le processus léger spécifié.
GetThreadTimes | BOOL GetThreadTimes( HANDLE hThread, LPFILETIME lpCreationTime, LPFILETIME lpExitTime, LPFILETIME lpKernelTime, LPFILETIME lpUserTime ); | kernel32.dll | Cette fonction permet de demander les informations de temps à propos du processus léger spécifié.
GetTickCount | DWORD GetTickCount(VOID); | kernel32.dll | Cette fonction permet de demander le nombre de milliseconde écoulé depuis le démarrage de Windows.
GetTimeFormatA | int GetTimeFormatA( LCID Locale, DWORD dwFlags, CONST SYSTEMTIME * lpTime, LPCTSTR lpFormat, LPTSTR lpTimeStr, int cchTime ); | kernel32.dll | Cette fonction permet de retourner la chaine de caractères du format du temps localement.
GetTimeFormatW | int GetTimeFormatW( LCID lcid, DWORD dwFlags, const SYSTEMTIME* lpTime, LPCWSTR lpFormat, LPWSTR lpTimeStr, int cchOut ); | kernel32.dll | Cette fonction permet de retourner la chaine de caractères du format du temps localement avec des paramètres de chaine de caractères étendue (Unicode).
GetTimeZoneInformation | DWORD GetTimeZoneInformation(LPTIME_ZONE_INFORMATION lpTimeZoneInformation); | kernel32.dll | Cette fonction permet de demander les informations de la zone horaire courante du système d'exploitation Windows.
GetTokenInformation | BOOL GetTokenInformation( HANDLE TokenHandle, TOKEN_INFORMATION_CLASS TokenInformationClass, LPVOID TokenInformation, DWORD TokenInformationLength, PDWORD ReturnLength ); | advapi32.dll | Cette fonction permet de demander le type d'information associé à un accès de jeton.
GetTopWindow | HWND GetTopWindow(HWND hWnd); | user32.dll | Cette fonction permet de demander le Handle du plus haut niveau de fenêtre enfant appartenant à la fenêtre parent spécifié.
GetUdpStatistics | DWORD GetUdpStatistics(PMIB_UDPSTATS pStats); | iphlpapi.dll | Cette fonction permet de demander les informations de statistique sur le UDP de l'ordinateur.
GetUpdateRect | BOOL GetUpdateRect(HWND hWnd, LPRECT lpRect, BOOL bErase); | user32.dll | Cette fonction permet de demander les coordonnées d'un petit rectangle complètement enfermé dans une région mise à jour par la fenêtre donnée.
GetUpdateRgn | int GetUpdateRgn(HWND hWnd, HRGN hRgn, BOOL bErase); | user32.dll | Cette fonction permet de demander la région mise à jour dans la fenêtre.
GetUserDefaultLCID | LCID GetUserDefaultLCID(VOID); | kernel32.dll | Cette fonction permet de demander l'identificateur local de l'utilisateur par défaut.
GetUserNameA | BOOL GetUserNameA(LPTSTR lpBuffer, LPDWORD nSize); | advapi32.dll | Cette fonction permet de demander le nom de l'utilisateur courant actuellement sous Windows.
GetUserNameW | BOOL GetUserNameW( LPWSTR lpszName, LPDWORD lpSize ); | advapi32.dll | Cette fonction permet de demander le nom de l'utilisateur courant actuellement sous le système d'exploitation Windows avec des paramètres de chaine de caractères étendue (Unicode).
GetUserNameExA | BOOLEAN GetUserNameExA( EXTENDED_NAME_FORMAT NameFormat, LPTSTR lpNameBuffer, PULONG nSize ); | secur32.dll | Cette fonction permet de retourner le nom de l'utilisateur dans le format EXTENDED_NAME_FORMAT.
GetUserObjectInformationA | BOOL GetUserObjectInformationA(HANDLE hObj, int nIndex, PVOID pvInfo, DWORD nLength,LPDWORD lpnLengthNeeded); | user32.dll | Cette fonction permet de demander les informations à propos d'une station de fenêtre ou d'un objet de bureau.
GetUserObjectInformationW | BOOL GetUserObjectInformationW(HANDLE hObj, int nIndex, PVOID pvInfo, DWORD nLength,LPDWORD lpnLengthNeeded); | user32.dll | Cette fonction permet de demander les informations à propos d'une station de fenêtre ou d'un objet de bureau avec des paramètres de chaine de caractères étendues (Unicode).
GetUserObjectSecurity | BOOL GetUserObjectSecurity(HANDLE hObj, PSECURITY_INFORMATION pSIRequested, PSECURITY_DESCRIPTOR pSID, DWORD nLength, LPDWORD lpnLengthNeeded); | user32.dll | Cette fonction permet de demander les informations de sécurité pour l'objet utilisateur spécifié.
GetVersion | DWORD GetVersion(VOID); | kernel32.dll | Cette fonction permet de demander le numéro de version courante du système d'exploitation Windows et les informations à propos de la plateforme du système d'exploitation.
GetVersionExA | BOOL GetVersionExA(LPOSVERSIONINFO lpVersionInformation); | kernel32.dll | Cette fonction permet de demander la version du système d'exploitation Windows.
GetVersionExW | BOOL GetVersionExW(LPOSVERSIONINFOW lpVersionInformation); | kernel32.dll | Cette fonction permet de demander la version du système d'exploitation Windows avec des paramètres de chaine de caractères étendue (Unicode).
GetViewportExtEx | BOOL GetViewportExtEx(HDC hdc, LPSIZE lpSize); | gdi32.dll | Cette fonction permet de demander les extensions X et Y d'un point de vue d'un périphérique de contexte.
GetViewportOrgEx | BOOL GetViewportOrgEx(HDC hdc, LPPOINT lpPoint); | gdi32.dll | Cette fonction permet de demander les coordonnées X et Y d'origine d'une association de point vue avec un périphérique de contexte spécifié.
GetVolumeInformationA | BOOL GetVolumeInformationA( LPCTSTR lpRootPathName, LPTSTR lpVolumeNameBuffer, DWORD nVolumeNameSize, LPDWORD lpVolumeSerialNumber, LPDWORD lpMaximumComponentLength, LPDWORD lpFileSystemFlags, LPTSTR lpFileSystemNameBuffer, DWORD nFileSystemNameSize ); | kernel32.dll | Cette fonction permet de demander les informations d'entête d'une unité disque.
GetVolumeInformationW | BOOL GetVolumeInformationW( LPCWSTR lpRootPathName, LPWSTR lpVolumeNameBuffer, DWORD nVolumeNameSize, PDWORD lpVolumeSerialNumber, PDWORD lpMaximumComponentLength, PDWORD lpFileSystemFlags, LPWSTR lpFileSystemNameBuffer, DWORD nFileSystemNameSize ); | kernel32.dll | Cette fonction permet de demander les informations d'entête d'une unité disque avec des paramètres de chaine de caractères étendue (Unicode).
GetWindow | HWND GetWindow(HWND hWnd,UINT uCmd); | user32.dll | Cette fonction permet de demander le Handle d'une fenêtre d'application.
GetWindowContextHelpId | DWORD GetWindowContextHelpId(HWND hwnd); | user32.dll | Cette fonction permet de demander l'identificateur de contexte, si possible, associé avec la fenêtre spécifié.
GetWindowDC | HDC GetWindowDC(HWND hWnd); | user32.dll | Cette fonction permet de demander un périphérique de contexte pour la fenêtre, la barre de titre, les menus et la barre de défilement.
GetWindowLongA | LONG GetWindowLongA(HWND hWnd,int nIndex); | user32.dll | Cette fonction permet de demander, sous forme d'une valeur de 32 bits, une des propriétés d'une fenêtre d'application.
GetWindowLongW | LONG GetWindowLongW(HWND hWnd, int nIndex); | user32.dll | Cette fonction permet de demander, sous forme d'une valeur de 32 bits, une des propriétés d'une fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
GetWindowPlacement | BOOL GetWindowPlacement(HWND hWnd, WINDOWPLACEMENT * lpwndpl); | user32.dll | Cette fonction permet de demander l'état d'affichage et de restituer, minimiser et maximiser les positions d'une fenêtre.
GetWindowRect | BOOL GetWindowRect(HWND hWnd,LPRECT lpRect); | user32.dll | Cette fonction permet de demander les coordonnées et la taille d'une fenêtre d'application.
GetWindowRgn | int GetWindowRgn(HWND hWnd, HRGN hRgn); | user32.dll | Cette fonction permet de demander une copie d'une région de fenêtre dans une fenêtre.
GetWindowsDirectoryA | UINT GetWindowsDirectoryA(LPTSTR lpBuffer,UINT uSize); | kernel32.dll | Cette fonction permet de demander le répertoire dans lequel le système d'exploitation Windows est situés.
GetWindowsDirectoryW | UINT GetWindowsDirectoryW(LPWSTR lpBuffer,UINT uSize); | kernel32.dll | Cette fonction permet de demander le répertoire dans lequel le système d'exploitation Windows est situés avec des paramètres de chaine de caractères étendue (Unicode).
GetWindowTextA | int GetWindowTextA(HWND hWnd, LPTSTR lpString, int nMaxCount); | user32.dll | Cette fonction permet de demander du texte contenu dans une fenêtre d'application.
GetWindowTextLengthA | int GetWindowTextLengthA(HWND hWnd); | user32.dll | Cette fonction permet de demander la longueur du texte contenu dans une fenêtre d'application.
GetWindowTextLengthW | int GetWindowTextLengthW(HWND hWnd); | user32.dll | Cette fonction permet de demander la longueur du texte contenu dans une fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
GetWindowTextW | int GetWindowTextW(HWND hWnd, LPWSTR lpString, int nMaxCount); | user32.dll | Cette fonction permet de demander du texte contenu dans une fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
GetWindowThreadProcessId | DWORD GetWindowThreadProcessId(HWND hWnd, LPDWORD lpdwProcessId); | user32.dll | Cette fonction permet de demander l'identificateur de processus léger étant créer par la fenêtre spécifié et, optionnellement, l'identificateur du processus créant la fenêtre.
GetWindowWord | WORD GetWindowWord(HWND hWnd, int nIndex); | user32.dll | Cette fonction permet de demander une valeur 16 bits de déplacement spécifié dans une fenêtre en mémoire supplémentaire pour la fenêtre spécifié.
GetWinMetaFileBits | UINT GetWinMetaFileBits(HENHMETAFILE hemf, UINT cbBuffer, LPBYTE lpbBuffer, INT fnMapMode, HDC hdcRef); | gdi32.dll | Cette fonction permet de convertir des enregistrements de format étendue en enregistrement de format Windows de fichier méta et d'entreposer les enregistrements convertie dans le tampon spécifié.
GetWindowExtEx | BOOL GetWindowExtEx(HDC hdc, LPSIZE lpSize); | gdi32.dll | Cette fonction permet de demander les extensions X et Y d'une fenêtre associé avec un périphérique de contexte spécifié.
GetWindowOrgEx | BOOL GetWindowOrgEx(HDC hdc, LPPOINT lpPoint); | gdi32.dll | Cette fonction permet de demander les coordonnées X et Y d'origine de la fenêtre associé avec le périphérique de contexte spécifié.
GetWorldTransform | BOOL GetWorldTransform(HDC hdc, LPXFORM lpXform); | gdi32.dll | Cette fonction permet de demander l'espace mondiale courant vers la transformation d'espace de page.
glAccum | void glAccum(GLenum op,GLfloat value); | opengl32.dll | Cette fonction permet d'effecter un contrôle du tampon d'accumulation sous OpenGL.
glAlphaFunc | void glAlphaFunc(GLenum func,GLclampf ref); | opengl32.dll | Cette fonction permet de définir la fonction devant servir de test Alpha sous OpenGL.
glBegin | void glBegin(GLenum mode); | opengl32.dll | Cette fonction permet de définir le commencement de la limite d'une primitive ou d'un groupe de primitive sous OpenGL.
glBitmap | void glBitmap(GLsizei width, GLsizei height, GLfloat xorig, GLfloat yorig, GLfloat xmove, GLfloat ymove, const GLubyte *bitmap); | opengl32.dll | Cette fonction permet le contenu d'une image Bitmap sous OpenGL.
glBlendFunc | void glBlendFunc(GLenum sfactor, GLenum dfactor); | opengl32.dll | Cette fonction permet de définir les facteurs de blending sous OpenGL.
glCallList | void glCallList(GLuint list); | opengl32.dll | Cette fonction permet d'appeler une liste de commande graphique OpenGL.
glCallLists | void glCallLists(GLsizei n, GLenum type, const GLvoid *lists); | opengl32.dll | Cette fonction permet d'appeler plusieurs listes de commande graphique OpenGL.
glClear | void glClear(GLbitfield mask); | opengl32.dll | Cette fonction permet de vider les tampons du OpenGL ainsi qu'effacement du contenu de la fenêtre.
glClearAccum | void glClearAccum(GLfloat red, GLfloat green, GLfloat blue, GLfloat alpha); | opengl32.dll | Cette fonction permet de vider le tampon d'accumulation du OpenGL.
glClearColor | void glClearColor(GLclampf red, GLclampf green, GLclampf blue,GLclampf alpha); | opengl32.dll | Cette fonction permet de vider le tampon chromatique du OpenGL.
glClearDepth | void glClearDepth(GLclampd depth); | opengl32.dll | Cette fonction permet de vider le tampon de profondeur du OpenGL.
glClearIndex | void glClearIndex(GLfloat c); | opengl32.dll | Cette fonction permet de vider le mode index du OpenGL.
glClearStencil | void glClearStencil(GLint s); | opengl32.dll | Cette fonction permet de vider le tampon stencil du OpenGL.
glClipPlane | void glClipPlane(GLenum plane, const GLdouble *equation); | opengl32.dll | Cette fonction permet de définir un nouveau plan de clipping du OpenGL.
glColor3b | void glColor3b(GLbyte red,GLbyte green,GLbyte blue); | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'octet dans OpenGL.
glColor3bv | void glColor3bv(const GLbyte *v); | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure d'octets dans OpenGL.
glColor3d | void glColor3d(GLdouble red, GLdouble green, GLdouble blue); | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'un réel double dans OpenGL.
glColor3dv | void glColor3dv(const GLdouble *v); | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure des réels doubles dans OpenGL.
glColor3f | void glColor3f(GLfloat red, GLfloat green, GLfloat blue); | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'un réel dans OpenGL.
glColor3fv | void glColor3fv(const GLfloat *v); | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure des réels dans OpenGL.
glColor3i | void glColor3i(GLint red, GLint green, GLint blue); | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'un entier long dans OpenGL.
glColor3iv | void glColor3iv(const GLint *v); | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure des entiers long dans OpenGL.
glColor3s | void glColor3s(GLshort red, GLshort green, GLshort blue, GLshort alpha); | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'un entier court dans OpenGL.
glColor3sv | void glColor3sv(const GLshort *v); | opengl32.dll | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure des entiers court dans OpenGL.
glEnd | void glEnd(void); | opengl32.dll | Cette fonction permet de définir la fin de la limite d'une primitive ou d'un groupe de primitive sous OpenGL.
GlobalAddAtomA | ATOM GlobalAddAtomA(LPCTSTR lpString); | kernel32.dll | Cette fonction permet d'ajouter un caractère à une table global d'Atom et retourne une valeur unique d'identificateur par chaine de caractères.
GlobalAddAtomW | ATOM GlobalAddAtomW(LPCWSTR str); | kernel32.dll | Cette fonction permet d'ajouter un caractère à une table global d'Atom et retourne une valeur unique d'identificateur par chaine de caractères avec des paramètres de chaine de caractères étendue (Unicode).
GlobalAlloc | HGLOBAL GlobalAlloc(UINT uFlags, DWORD dwBytes); | kernel32.dll | Cette fonction permet d'allouer de la mémoire dans les ressources global du système d'exploitation.
GlobalCompact | SIZE_T GlobalCompact(DWORD MinFree); | kernel32.dll | Cette fonction permet de réorganiser les allocations de mémoire dynamique du tas global en spécifiant une taille de mémoire minimum.
GlobalDeleteAtom | ATOM GlobalDeleteAtom(ATOM nAtom); | kernel32.dll | Cette fonction permet de décrémenté le compteur de référence de la chaine de caractères d'Atom global.
GlobalFindAtomA | ATOM GlobalFindAtomA(LPCTSTR lpString); | kernel32.dll | Cette fonction permet de rechercher une table d'Atom global dans la chaine de caractères spécifié et demande l'Atom global associé avec la chaine de caractères.
GlobalFindAtomW | ATOM GlobalFindAtomW(LPCWSTR str); | kernel32.dll | Cette fonction permet de rechercher une table d'Atom global dans la chaine de caractères spécifié et demande l'Atom global associé avec la chaine de caractères étendue (Unicode).
GlobalFix | void GlobalFix(HGLOBAL hglb); | kernel32.dll | Cette fonction permet de prévenir l'objet de mémoire global donnée contre un mouvement de mémoire linéaire. Cette fonction est obsolète.
GlobalFlags | UINT GlobalFlags(HGLOBAL hMem); | kernel32.dll | Cette fonction permet de retourner les informations à propos de l'objet de mémoire global spécifié.
GlobalFree | HGLOBAL GlobalFree(HGLOBAL hMem); | kernel32.dll | Cette fonction permet de libérer de la mémoire dans les ressources global du système d'exploitation.
GlobalGetAtomNameA | UINT GlobalGetAtomNameA(ATOM nAtom, LPTSTR lpBuffer, int nSize); | kernel32.dll | Cette fonction permet de demander une copie de la chaine de caractères associé avec l'Atom global donnée.
GlobalGetAtomNameW | UINT GlobalGetAtomNameW(ATOM atom, LPWSTR buffer, INT count); | kernel32.dll | Cette fonction permet de demander une copie de la chaine de caractères associé avec l'Atom global donnée avec des paramètres de chaine de caractères étendue (Unicode).
GlobalHandle | HGLOBAL GlobalHandle(LPCVOID pMem); | kernel32.dll | Cette fonction permet de demander le Handle de l'objet de mémoire global spécifié.
GlobalLock | LPVOID GlobalLock(HGLOBAL hMem); | kernel32.dll | Cette fonction permet de verrouiller l'emplacement du bloc de mémoire dans les ressources global du système d'exploitation.
GlobalMemoryStatus | VOID GlobalMemoryStatus(LPMEMORYSTATUS lpBuffer); | kernel32.dll | Cette fonction permet de demander l'état de la mémoire du système d'exploitation.
GlobalMemoryStatusEx | BOOL GlobalMemoryStatusEx(LPMEMORYSTATUSEX lpBuffer); | kernel32.dll | Cette fonction permet de demander l'état de la mémoire du système d'exploitation ayant plus de 4 Go de RAM d'installer sur l'ordinateur.
GlobalReAlloc | HGLOBAL GlobalReAlloc(HGLOBAL hMem, DWORD dwBytes, UINT uFlags); | kernel32.dll | Cette fonction permet de changer la taille ou les attributs de l'objet de mémoire global spécifié.
GlobalSize | DWORD GlobalSize(HGLOBAL hMem); | kernel32.dll | Cette fonction permet de demander la taille courante, en octets, de l'objet de mémoire global.
GlobalUnfix | VOID GlobalUnfix(HGLOBAL hMem); | kernel32.dll | Cette fonction permet d'annuler les effets d'une fonction GlobalFix et d'allouer l'objet de mémoire global a être déplacé dans la mémoire linéaire. Cette fonction est obsolète.
GlobalUnlock | BOOL GlobalUnlock(HGLOBAL hMem); | kernel32.dll | Cette fonction permet de déverrouiller l'emplacement du bloc de mémoire dans les ressources global du système d'exploitation.
GlobalUnWire | BOOL GlobalUnWire(HGLOBAL hMem); | kernel32.dll | Cette fonction permet de restituer la convertion d'un pointeur de processus 32 bits après une allocation de mémoire.
GrayStringA | BOOL GrayStringA(HDC hDC, HBRUSH hBrush, GRAYSTRINGPROC lpOutputFunc, LPARAM lpData, int nCount, int X, int Y, int nWidth, int nHeight); | user32.dll | Cette fonction permet de dessiner du texte grisé à l'emplacement donnée par l'écriture du texte dans un Bitmap en mémoire, grisonnant le Bitmap, et copie alors le Bitmap dans l'affichage.
GrayStringW | BOOL GrayStringW(HDC hDC, HBRUSH hBrush, GRAYSTRINGPROC lpOutputFunc, LPARAM lpData, int nCount, int X, int Y, int nWidth, int nHeight); | user32.dll | Cette fonction permet de dessiner du texte grisé à l'emplacement donnée par l'écriture du texte dans un Bitmap en mémoire, grisonnant le Bitmap, et copie alors le Bitmap dans l'affichage avec des paramètres de chaine de caractères étendues (Unicode).
HeapAlloc | LPVOID HeapAlloc(HANDLE hHeap, DWORD dwFlags, SIZE_T dwBytes); | kernel32.dll | Cette fonction permet d'allouer un bloc de mémoire à l'aide d'un tas.
HeapCompact | SIZE_T HeapCompact(HANDLE hHeap, DWORD dwFlags); | kernel32.dll | Cette fonction permet de demander la taille de la largeur d'un bloc de mémoire disponible dans le tas spécifié.
HeapCreate | HANDLE HeapCreate(DWORD flOptions, SIZE_T dwInitialSize, SIZE_T dwMaximumSize); | kernel32.dll | Cette fonction permet de créer un objet de tas privé pouvant être utilisé par le processus appelant.
HeapDestroy | BOOL HeapDestroy(HANDLE hHeap); | kernel32.dll | Cette fonction permet de détruire l'objet de tas spécifié.
HeapFree | BOOL HeapFree(HANDLE hHeap, DWORD dwFlags, LPVOID lpMem); | kernel32.dll | Cette fonction permet de libérer un bloc de mémoire précédemment alloué d'un tas par la fonction HeapAlloc ou HeapReAlloc.
HeapLock | BOOL HeapLock(HANDLE hHeap); | kernel32.dll | Cette fonction permet de verrouiller l'association avec le tas spécifié dans un objet de section critique.
HeapReAlloc | LPVOID HeapReAlloc(HANDLE hHeap, DWORD dwFlags, LPVOID lpMem, SIZE_T dwBytes); | kernel32.dll | Cette fonction permet de réallouer un bloc de mémoire d'un tas.
HeapSize | SIZE_T HeapSize(HANDLE hHeap, DWORD dwFlags, LPCVOID lpMem); | kernel32.dll | Cette fonction permet de demander la taille d'un bloc de mémoire alloué dans le tas par la fonction HeapAlloc ou HeapReAlloc.
HeapUnlock | BOOL HeapUnlock(HANDLE hHeap); | kernel32.dll | Cette fonction permet de déverrouiller l'association avec le tas spécifié dans un objet de section critique.
HeapValidate | BOOL HeapValidate(HANDLE hHeap, DWORD dwFlags, LPCVOID lpMem); | kernel32.dll | Cette fonction permet de valider le tas spécifié.
HeapWalk | BOOL HeapWalk(HANDLE hHeap, LPPROCESS_HEAP_ENTRY lpEntry); | kernel32.dll | Cette fonction permet d'énumérer les blocs de mémoire dans le tas spécifié.
HideCaret | BOOL HideCaret(HWND hWnd); | user32.dll | Cette fonction permet de cacher un caret en l'enlevant de l'écran.
HiliteMenuItem | BOOL HiliteMenuItem(HWND hwnd, HMENU hmenu, UINT uItemHilite, UINT uHilite); | user32.dll | Cette fonction permet de faire passer un item de menu en mode de surbrillance.
IcmpCloseHandle | BOOL IcmpCloseHandle(HANDLE IcmpHandle); | icmp.dll | Cette fonction permet de fermer un fichier sur le protocole ICMP (Internet Control Message Protocol).
IcmpCreateFile | HANDLE IcmpCreateFile(void); | icmp.dll | Cette fonction permet de créer un fichier sur le protocole ICMP (Internet Control Message Protocol).
IcmpSendEcho | DWORD IcmpSendEcho( HANDLE IcmpHandle, IPAddr DestinationAddress, LPVOID RequestData, WORD RequestSize, PIP_OPTION_INFORMATION RequestOptions, LPVOID ReplyBuffer, DWORD ReplySize, DWORD Timeout ); | icmp.dll | Cette fonction permet d'envoyer une requête en écho par le protocole ICMP (Internet Control Message Protocol).
ImpersonateDdeClientWindow | BOOL ImpersonateDdeClientWindow(HWND hWndClient, HWND hWndServer); | user32.dll | Cette fonction permet d'activer l'échange de données dynamique (DDE) vers un contexte d'application sécurisé d'imitation de client DDE.
ImpersonateLoggedOnUser | BOOL ImpersonateLoggedOnUser( HANDLE hToken ); | advapi32.dll | Cette fonction permet d'appeler une processus léger utilisateur impersonnel.
ImpersonateNamedPipeClient | BOOL ImpersonateNamedPipeClient( HANDLE hNamedPipe ); | advapi32.dll | Cette fonction permet de demmander si l'application client a un nom de canal impersonnel.
ImpersonateSelf | BOOL ImpersonateSelf( SECURITY_IMPERSONATION_LEVEL ImpersonationLevel ); | advapi32.dll | Cette fonction permet de demander le jeton d'accès au contexte de sécurité impersonnel d'un processus appelant.
inet_addr | unsigned long inet_addr (const char FAR * cp); | Wsock32.dll | Cette fonction permet l'adresse IP contenu dans une chaine de caractères sous sa forme numérique 32 bits.
InflateRect | BOOL InflateRect(LPRECT lprc, int dx, int dy); | user32.dll | Cette fonction permet d'agrandir ou diminuer la taille d'un objet de rectangle.
InitAtomTable | BOOL InitAtomTable(DWORD nSize); | kernel32.dll | Cette fonction permet d'initialiser la table d'Atom local et fixe la taille spécifié.
InitCommonControlsEx | BOOL InitCommonControlsEx(LPINITCOMMONCONTROLSEX pInitCtrls); | comctl32.dll | Cette fonction permet d'initialiser une classe de contrôle commun.
InitializeAcl | BOOL InitializeAcl( PACL pAcl, DWORD nAclLength, DWORD dwAclRevision ); | advapi32.dll | Cette fonction permet de créer une nouvelle structure de liste de contrôle d'accès (ACL).
InitializeCriticalSection | VOID InitializeCriticalSection(LPCRITICAL_SECTION lpCriticalSection); | kernel32.dll | Cette fonction permet d'initialiser un objet de section critique.
InitializeSecurityDescriptor | BOOL InitializeSecurityDescriptor( PSECURITY_DESCRIPTOR pSecurityDescriptor, DWORD dwRevision ); | advapi32.dll | Cette fonction permet d'initialiser un nouveau descripteur de sécurité.
InitializeSid | BOOL InitializeSid( PSID Sid, PSID_IDENTIFIER_AUTHORITY pIdentifierAuthority, BYTE nSubAuthorityCount ); | advapi32.dll | Cette fonction permet d'initialiser une structure d'identificateur de sécurité (SID).
InitiateSystemShutdownA | BOOL InitiateSystemShutdownA( LPSTR lpMachineName, LPSTR lpMessage, DWORD dwTimeout, BOOL bForceAppsClosed, BOOL bRebootAfterShutdown ); | advapi32.dll | Cette fonction permet d'initier l'opération de fermeture ou de redémarrage en cours d'exécution du système d'exploitation Windows.
InitiateSystemShutdownW | BOOL InitiateSystemShutdownW( LPWSTR lpMachineName, LPWSTR lpMessage, DWORD dwTimeout, BOOL bForceAppsClosed, BOOL bRebootAfterShutdown ); | advapi32.dll | Cette fonction permet d'initier l'opération de fermeture ou de redémarrage en cours d'exécution du système d'exploitation Windows avec des paramètres de chaine de caractères étendue (Unicode).
InSendMessage | BOOL InSendMessage(VOID); | user32.dll | Cette fonction permet de spécifier si la procédure de la fenêtre courante est en traitement d'un message d'envoi d'une autre tâche par appel de la fonction SendMessage.
InsertMenuA | BOOL InsertMenuA(HMENU hMenu, UINT uPosition, UINT uFlags, UINT uIDNewItem, LPCTSTR lpNewItem); | user32.dll | Cette fonction permet d'insérer un nouvel item de menu dans un menu et déplace les autres items en bas du menu.
InsertMenuItemA | BOOL InsertMenuItemA(HMENU hMenu, UINT uItem, BOOL fByPosition, LPMENUITEMINFO lpmii); | user32.dll | Cette fonction permet d'insérer un nouvel item de menu à la position spécifié dans la barre de menu ou un menu contextuel.
InsertMenuItemW | BOOL InsertMenuItemW(HMENU hMenu, UINT uItem, BOOL fByPosition, LPCMENUITEMINFOW lpmii); | user32.dll | Cette fonction permet d'insérer un nouvel item de menu à la position spécifié dans la barre de menu ou un menu contextuel avec les paramètres de chaine de caractères étendues (Unicode).
InsertMenuW | BOOL InsertMenuW(HMENU hMenu, UINT uPosition, UINT uFlags, UINT uIDNewItem, LPCWSTR lpNewItem); | user32.dll | Cette fonction permet d'insérer un nouvel item de menu dans un menu et déplace les autres items en bas du menu avec des paramètres de chaine de caractères étendues (Unicode).
InstallNewDevice | BOOL InstallNewDevice( HWND hwndParent, LPGUID ClassGuid, PDWORD pReboot ); | newdev.dll | Cette fonction permet d'installer un nouveau périphérique.
InterlockedCompareExchange | PVOID InterlockedCompareExchange(PVOID *Destination, PVOID Exchange, PVOID Comperand); | kernel32.dll | Cette fonction permet d'effectuer un traitement de comparaison atomique de valeurs spécifiés et échange les valeurs en se basant sur le résultat de la comparaison.
InterlockedDecrement | LONG InterlockedDecrement(LPLONG lpAddend); | kernel32.dll | Cette fonction permet de décrémenter les deux valeurs spécifié de un et vérifie le résultat des valeurs.
InterlockedExchange | LONG InterlockedExchange(LPLONG Target, LONG Value); | kernel32.dll | Cette fonction permet d'échanger automatiquement une paire de valeurs 32 bits.
InterlockedExchangeAdd | LONG InterlockedExchangeAdd(PLONG Addend, LONG Increment); | kernel32.dll | Cette fonction permet d'effectuer un traitement automatique d'ajouter d'une valeur incrémenté à une variable ajouté.
InterlockedIncrement | LONG InterlockedIncrement(LPLONG lpAddend); | kernel32.dll | Cette fonction permet d'incrémenter les deux valeurs des variables spécifiés et vérifie la valeur du résultat.
InternetAutodial | BOOL InternetAutodial(DWORD dwFlags,HWND hwndParent); | wininet.dll | Cette fonction permet de provoquer une connexion Internet en utilisant le protocole TCP/IP.
InternetAutodialHangup | BOOL InternetAutodialHangup(DWORD dwReserved); | wininet.dll | Cette fonction permet d'arrêter une connexion Internet en utilisant le protocole TCP/IP.
InternetGetConnectedState | BOOL InternetGetConnectedState(LPDWORD lpdwFlags,DWORD dwReserved); | wininet.dll | Cette fonction permet de demander le type de connexion Internet qu'utilise le TCP/IP de Windows.
IntersectClipRect | int IntersectClipRect(HDC hdc, int nLeftRect, int nTopRect, int nRightRect, int nBottomRect); | gdi32.dll | Cette fonction permet de créer une nouvelle région de capture vers l'intersection de la région courante et du rectangle spécifié.
IntersectRect | BOOL IntersectRect(LPRECT lprcDst, CONST RECT * lprcSrc1, CONST RECT * lprcSrc2); | user32.dll | Cette fonction permet de calculer l'intersection de 2 sources rectangulaires et place les coordonnées du rectangle d'intersection dans le rectangle de destination.
InvalidateRect | BOOL InvalidateRect(HWND hWnd, CONST RECT * lpRect, BOOL bErase); | user32.dll | Cette fonction permet d'ajouter un rectangle pour la mise à jour d'une région d'une fenêtre.
InvalidateRgn | BOOL InvalidateRgn(HWND hWnd, HRGN hRgn, BOOL bErase); | user32.dll | Cette fonction permet d'ajouter une région à une région de fenêtre à mettre à jour.
InvertRect | BOOL InvertRect(HDC hDC, CONST RECT * lprc); | user32.dll | Cette fonction permet d'inverser une région rectangulaire.
InvertRgn | BOOL InvertRgn(HDC hdc, HRGN hrgn); | gdi32.dll | Cette fonction permet d'inverser les couleurs d'une région spécifié.
IsBadCodePtr | BOOL IsBadCodePtr(FARPROC lpfn); | kernel32.dll | Cette fonction permet de demander si l'appel du processus a un accès de mémoire en lecture à l'adresse spécifié.
IsBadHugeReadPtr | BOOL IsBadHugeReadPtr(CONST VOID *lp, UINT ucb); | kernel32.dll | Cette fonction permet de vérifier si l'appel du processus a un accès en lecture dans les rangs de mémoire spécifié.
IsBadHugeWritePtr | BOOL IsBadHugeWritePtr(LPVOID lp, UINT ucb); | kernel32.dll | Cette fonction permet de vérifier si l'appel du processus a un accès en écriture dans les rangs de mémoire spécifié.
IsBadReadPtr | BOOL IsBadReadPtr(CONST VOID *lp, UINT ucb); | kernel32.dll | Cette fonction permet de vérifier si l'appel du processus a un accès en lecture dans les rangs de mémoire spécifié.
IsBadStringPtrA | BOOL IsBadStringPtrA(LPCTSTR lpsz, UINT ucchMax); | kernel32.dll | Cette fonction permet de vérifier que l'appel du processus à un accès en lecture dans les rangs de mémoire pointer sur une chaine de caractères.
IsBadStringPtrW | BOOL IsBadStringPtrW(LPCWSTR str, UINT max); | kernel32.dll | Cette fonction permet de vérifier que l'appel du processus à un accès en lecture dans les rangs de mémoire pointer sur une chaine de caractères étendue (Unicode).
IsBadWritePtr | BOOL IsBadWritePtr(LPVOID lp, UINT ucb); | kernel32.dll | Cette fonction permet de vérifier si l'appel du processus a un accès en écriture dans les rangs de mémoire spécifié.
IsDBCSLeadByte | BOOL IsDBCSLeadByte(BYTE TestChar); | kernel32.dll | Cette fonction permet de demander si un caractère spécifié est un octet de tête, le premier octet d'un caractère est un DBCS (Double-Byte Character Set).
IsDBCSLeadByteEx | BOOL IsDBCSLeadByteEx(UINT CodePage, BYTE TestChar); | kernel32.dll | Cette fonction permet de demander si un caractère spécifié est un octet de tête, le premier octet d'un caractère est un DBCS (Double-Byte Character Set) avec un code de page.
IsCharAlphaA | BOOL IsCharAlphaA(TCHAR ch); | user32.dll | Cette fonction permet de demander si un caractère fait partie de l'ensemble de caractères alphabéthique de la langue.
IsCharAlphaNumericA | BOOL IsCharAlphaNumericA(TCHAR ch); | user32.dll | Cette fonction permet de demander si un caractère est une lettre ou un chiffre arabes.
IsCharAlphaNumericW | BOOL IsCharAlphaNumericW(WCHAR ch); | user32.dll | Cette fonction permet de demander si un caractère est une lettre ou un chiffre arabes avec des paramètres de chaine de caractères étendues (Unicode).
IsCharAlphaW | BOOL IsCharAlphaW(WCHAR ch); | user32.dll | Cette fonction permet de demander si un caractère fait partie de l'ensemble de caractères alphabéthique de la langue avec des paramètres de chaine de caractères étendues (Unicode).
IsCharLowerA | BOOL IsCharLowerA(TCHAR ch); | user32.dll | Cette fonction permet de demander si un caractère est une lettre en minuscule.
IsCharLowerW | BOOL IsCharLowerW(WCHAR ch); | user32.dll | Cette fonction permet de demander si un caractère est une lettre en minuscule avec des paramètres de chaine de caractères étendues (Unicode).
IsCharUpperA | BOOL IsCharUpperA(TCHAR ch); | user32.dll | Cette fonction permet de demander si un caractère est une lettre en majuscule.
IsCharUpperW | BOOL IsCharUpperW(WCHAR ch); | user32.dll | Cette fonction permet de demander si un caractère est une lettre en majuscule avec des paramètres de chaine de caractères étendues (Unicode).
IsChild | BOOL IsChild(HWND hWndParent, HWND hWnd); | user32.dll | Cette fonction permet de demander si la fenêtre spécifié est l'enfant ou d'une autre descendance direct de la fenêtre parent spécifié.
IsClipboardFormatAvailable | BOOL IsClipboardFormatAvailable(UINT format); | user32.dll | Cette fonction permet de demander si les données d'un certain format exist dans le presse-papier.
IsDebuggerPresent | BOOL IsDebuggerPresent(void); | kernel32.dll | Cette fonction permet de demander si l'application en cours est sous l'influence d'un débogueur.
IsDialogMessageA | BOOL IsDialogMessageA(HWND hDlg, LPMSG lpMsg); | user32.dll | Cette fonction permet de demander si le message spécifié est prévu dans la modélisation de la boite de dialogue donnée et, si c'est le cas, traite le message.
IsDialogMessageW | BOOL IsDialogMessageW(HWND hDlg, LPMSG lpMsg); | user32.dll | Cette fonction permet de demander si le message spécifié est prévu dans la modélisation de la boite de dialogue donnée et, si c'est le cas, traite le message avec des paramètres de chaine de caractères étendues (Unicode).
IsDlgButtonChecked | UINT IsDlgButtonChecked(HWND hDlg, int nIDButton); | user32.dll | Cette fonction permet de demander si un bouton a une coche à côté de lui et si un bouton à trois états de gris, est coché ou pas.
IsIconic | BOOL IsIconic(HWND hWnd); | user32.dll | Cette fonction permet de demander si la fenêtre spécifié est minimisé (en état d'icône).
IsMenu | BOOL IsMenu(HMENU hMenu); | user32.dll | Cette fonction permet d'indiquer si le Handle spécifié est un Handle de menu.
IsProcessorFeaturePresent | BOOL IsProcessorFeaturePresent(DWORD ProcessorFeature); | kernel32.dll | Cette fonction permet de demander si les fonctionnalités du microprocessseur sont supportés par l'un des microprocesseur de la machine courante.
IsRectEmpty | BOOL IsRectEmpty(CONST RECT * lprc); | user32.dll | Cette fonction permet de déterminer si le rectangle spécifié est vide.
IsTextUnicode | DWORD IsTextUnicode( CONST LPVOID lpBuffer, int cb, LPINT lpi ); | advapi32.dll | Cette fonction permet de demander l'adresse du tampon contenant probablement une forme de texte Unicode.
IsValidAcl | BOOL IsValidAcl( PACL pAcl ); | advapi32.dll | Cette fonction permet de valider une liste de contrôle d'accès (ACL).
IsValidCodePage | BOOL IsValidCodePage(UINT CodePage); | kernel32.dll | Cette fonction permet d'indiquer si la page de code spécifié est valide.
IsValidLocale | BOOL IsValidLocale(LCID Locale, DWORD dwFlags); | kernel32.dll | Cette fonction permet d'appliquer un test de validité à un identificateur locale.
IsValidSecurityDescriptor | BOOL IsValidSecurityDescriptor( PSECURITY_DESCRIPTOR pSecurityDescriptor ); | advapi32.dll | Cette fonction permet de valider une structure de descripteur de sécurité «SECURITY_DESCRIPTOR».
IsValidSid | BOOL IsValidSid( PSID pSid ); | advapi32.dll | Cette fonction permet de valider une structure SID en vérifiant que le numéro de version est situé dans le rang et les intervalles de nombres de sous-autorité.
IsWindow | BOOL IsWindow(HWND hWnd); | user32.dll | Cette fonction permet de demander si la fenêtre de Handle spécifié est valide.
IsWindowEnabled | BOOL IsWindowEnabled(HWND hWnd); | user32.dll | Cette fonction permet de demander si la fenêtre spécifié est activé par la souris ou l'entrée clavier.
IsWindowUnicode | BOOL IsWindowUnicode(HWND hWnd); | user32.dll | Cette fonction permet de demander si la fenêtre spécifié est une fenêtre Unicode native.
IsWindowVisible | BOOL IsWindowVisible(HWND hWnd); | user32.dll | Cette fonction permet de demander si la fenêtre spécifié est dans un état de visibilité.
IsZoomed | BOOL IsZoomed(HWND hWnd); | user32.dll | Cette fonction permet de demander si la fenêtre spécifié est maximisé (ou prend toute l'écran).
keybd_event | VOID keybd_event(BYTE bVk, BYTE bScan, DWORD dwFlags, DWORD dwExtraInfo); | user32.dll | Cette fonction permet de provoquer un événement d'appui de touche clavier.
KillTimer | BOOL KillTimer(HWND hWnd, UINT uIDEvent); | user32.dll | Cette fonction permet de détruire la minuterie spécifié.
LCMapStringA | int LCMapStringA(LCID Locale, DWORD dwMapFlags, LPCTSTR lpSrcStr, int cchSrc, LPTSTR lpDestStr, int cchDest); | kernel32.dll | Cette fonction permet de cartographier une chaine de caractères vers une autre en effectuant le traitement de transformation de dépendance locale.
LCMapStringW | INT LCMapStringW(LCID lcid, DWORD flags, LPCWSTR src, INT srclen, LPWSTR dst, INT dstlen); | kernel32.dll | Cette fonction permet de cartographier une chaine de caractères étendue (Unicode) vers une autre en effectuant le traitement de transformation de dépendance locale.
LeaveCriticalSection | VOID LeaveCriticalSection(LPCRITICAL_SECTION lpCriticalSection); | kernel32.dll | Cette fonction permet de libérer le propriétaire d'un objet de section critique spécifié.
LineDDA | BOOL LineDDA(int nXStart, int nYStart, int nXEnd, int nYEnd, LINEDDAPROC lpLineFunc, LPARAM lpData); | gdi32.dll | Cette fonction permet de calculer tous les points successifs d'une ligne spécifié par les coordonnées de début et de fin.
LineTo | BOOL LineTo(HDC hdc, int nXEnd, int nYEnd); | gdi32.dll | Cette fonction permet de tracer une ligne des coordonnées courante à la position spécifié.
LoadAcceleratorsA | HACCEL LoadAcceleratorsA(HINSTANCE hInstance, LPCTSTR lpTableName); | user32.dll | Cette fonction permet d'effectuer le chargement d'une table d'accélérateur d'une ressource.
LoadAcceleratorsW | HACCEL LoadAcceleratorsW(HINSTANCE hInstance, LPCWSTR lpTableName); | user32.dll | Cette fonction permet d'effectuer le chargement d'une table d'accélérateur d'une ressource avec des paramètres de chaine de caractères étendues (Unicode).
LoadBitmapA | HBITMAP LoadBitmapA(HINSTANCE hInstance, LPCTSTR lpBitmapName); | user32.dll | Cette fonction permet de charger la ressource de Bitmap spécifié du fichier de module d'exécutable donnée.
LoadBitmapW | HBITMAP LoadBitmapW(HINSTANCE hInstance, LPCWSTR lpBitmapName); | user32.dll | Cette fonction permet de charger la ressource de Bitmap spécifié du fichier de module d'exécutable donnée avec des paramètres de chaine de caractères étendues (Unicode).
LoadCursorA | HCURSOR LoadCursorA(HINSTANCE hInstance, LPCTSTR lpCursorName); | user32.dll | Cette fonction permet de sélectionner un pointeur de souris.
LoadCursorFromFileA | HCURSOR LoadCursorFromFileA(LPCTSTR lpFileName); | user32.dll | Cette fonction permet de charger à partir d'un fichier un pointeur de souris.
LoadCursorFromFileW | HCURSOR LoadCursorFromFileW(LPCWSTR lpFileName); | user32.dll | Cette fonction permet de charger à partir d'un fichier un pointeur de souris avec des paramètres de chaine de caractères étendues (Unicode).
LoadCursorW | HCURSOR LoadCursorW(HINSTANCE hInstance, LPCWSTR lpCursorName); | user32.dll | Cette fonction permet de sélectionner un pointeur de souris avec des paramètres de chaine de caractères étendues (Unicode).
LoadIconA | HICON LoadIconA(HINSTANCE hInstance, LPCTSTR lpIconName); | user32.dll | Cette fonction permet de charger une icône à partir d'un fichier.
LoadIconW | HICON LoadIconW(HINSTANCE hInstance, LPCWSTR lpIconName); | user32.dll | Cette fonction permet de charger une icône à partir d'un fichier avec des paramètres de chaine de caractères étendues (Unicode).
LoadImageA | HANDLE LoadImageA( HINSTANCE hinst, LPCTSTR lpszName, UINT uType, int cxDesired, int cyDesired, UINT fuLoad ); | user32.dll | Cette fonction permet de charger une image à partir d'une icône, un curseur ou un Bitmap.
LoadImageW | HANDLE LoadImageW(HINSTANCE hinst, LPCWSTR lpszName, UINT uType, int cxDesired, int cyDesired, UINT fuLoad); | user32.dll | Cette fonction permet de charger une image à partir d'une icône, un curseur ou un Bitmap avec des paramètres de chaine de caractères étendues (Unicode).
LoadKeyboardLayoutA | HKL LoadKeyboardLayoutA(LPCTSTR pwszKLID, UINT Flags); | user32.dll | Cette fonction permet de charger une nouvelle couche clavier dans le système.
LoadKeyboardLayoutW | HKL LoadKeyboardLayoutW(LPCWSTR pwszKLID, UINT Flags); | user32.dll | Cette fonction permet de charger une nouvelle couche clavier dans le système avec des paramètres de chaine de caractères étendues (Unicode).
LoadLibraryA | HINSTANCE LoadLibraryA(LPCTSTR lpLibFileName); | kernel32.dll | Cette fonction permet d'effectuer le chargement du module de bibliothèque spécifié.
LoadLibraryW | HMODULE LoadLibraryW(LPCWSTR libnameW); | kernel32.dll | Cette fonction permet d'effectuer le chargement du module de bibliothèque spécifié avec des paramètres de chaine de caractères étendue (Unicode).
LoadLibraryExA | HINSTANCE LoadLibraryExA(LPCTSTR lpLibFileName, HANDLE hFile, DWORD dwFlags); | kernel32.dll | Cette fonction permet de cartographier un module exécutable spécifié dans l'espace d'adressage du processus d'appel.
LoadLibraryExW | HMODULE LoadLibraryExW(LPCWSTR libnameW, HANDLE hfile, DWORD flags); | kernel32.dll | Cette fonction permet de cartographier un module exécutable spécifié dans l'espace d'adressage du processus d'appel avec des paramètres de chaine de caractères étendue (Unicode).
LoadMenuA | HMENU LoadMenuA(HINSTANCE hInstance, LPCTSTR lpMenuName); | user32.dll | Cette fonction permet d'effectuer le chargement de la ressource de menu spécifié du fichier exécutable avec l'instance d'application donnée.
LoadMenuIndirectA | HMENU LoadMenuIndirectA(CONST MENUTEMPLATE *lpMenuTemplate); | user32.dll | Cette fonction permet de charger le gabarit de menu spécifié en mémoire.
LoadMenuIndirectW | HMENU LoadMenuIndirectW(CONST MENUTEMPLATE *lpMenuTemplate); | user32.dll | Cette fonction permet de charger le gabarit de menu spécifié en mémoire avec des paramètres de chaine de caractères étendues (Unicode).
LoadMenuW | HMENU LoadMenuW(HINSTANCE hInstance, LPCWSTR lpMenuName); | user32.dll | Cette fonction permet d'effectuer le chargement de la ressource de menu spécifié du fichier exécutable avec l'instance d'application donnée avec des paramètres de chaine de caractères étendues (Unicode).
LoadModule | DWORD LoadModule(LPCSTR lpModuleName, LPVOID lpParameterBlock); | kernel32.dll | Cette fonction permet de charger et d'exécution une application Windows ou crée un nouvel instance dans un application Windows existante.
LoadResource | HGLOBAL LoadResource(HMODULE hModule, HRSRC hResInfo); | kernel32.dll | Cette fonction permet de charger la ressource spécifié dans la mémoire global.
LoadStringA | int LoadStringA(HINSTANCE hInstance, UINT uID, LPTSTR lpBuffer, int nBufferMax); | user32.dll | Cette fonction permet d'effectuer le chargement de la chaine de caractères spécifié d'une ressource.
LoadStringW | int LoadStringW(HINSTANCE hInstance, UINT uID, LPWSTR lpBuffer, int nBufferMax); | user32.dll | Cette fonction permet d'effectuer le chargement de la chaine de caractères spécifié d'une ressource avec des paramètres de chaine de caractères étendues (Unicode).
LocalAlloc | HLOCAL LocalAlloc(UINT uFlags, UINT uBytes); | kernel32.dll | Cette fonction permet d'allouer le nombre d'octets spécifiés pour le tas local.
LocalCompact | UINT LocalCompact(UINT uMinFree); | kernel32.dll | Cette fonction permet de réarranger le tas local si la quantité de mémoire spécifié est disponible.
LocalFileTimeToFileTime | BOOL LocalFileTimeToFileTime(CONST FILETIME * lpLocalFileTime, LPFILETIME lpFileTime); | kernel32.dll | Cette fonction permet de convertir un temps de fichier local en temps de fichier basé sur l'UTC (Coordinated Universal Time).
LocalFlags | UINT LocalFlags(HLOCAL hMem); | kernel32.dll | Cette fonction permet de demander les informations à propos de l'objet de mémoire local.
LocalFree | HLOCAL LocalFree(HLOCAL hMem); | kernel32.dll | Cette fonction permet de demander l'objet de mémoire local et d'invalider un Handle.
LocalLock | LPVOID LocalLock(HLOCAL hMem); | kernel32.dll | Cette fonction permet de demander un pointeur sur l'objet de mémoire local.
LocalReAlloc | HLOCAL LocalReAlloc(HLOCAL hMem, UINT uBytes, UINT uFlags); | kernel32.dll | Cette fonction permet de changer la taille ou les attributs d'un objet de mémoire local spécifié.
LocalShrink | UINT LocalShrink(HLOCAL hloc, UINT cbNewSize); | kernel32.dll | Cette fonction rapetisser le tas local du segment spécifié.
LocalSize | UINT LocalSize(HLOCAL hMem); | kernel32.dll | Cette fonction permet de demander la taille, en octets, de l'objet de mémoire local spécifié.
LocalUnlock | BOOL LocalUnlock(HLOCAL hMem); | kernel32.dll | Cette fonction permet de déverrouiller un objet de mémoire local spécifié.
LockFile | BOOL LockFile(HANDLE hFile, DWORD dwFileOffsetLow, DWORD dwFileOffsetHigh, DWORD nNumberOfBytesToLockLow, DWORD nNumberOfBytesToLockHigh); | kernel32.dll | Cette fonction permet de verrouiller une région d'un fichier ouvert.
LockFileEx | BOOL LockFileEx(HANDLE hFile, DWORD dwFlags, DWORD dwReserved, DWORD nNumberOfBytesToLockLow, DWORD nNumberOfBytesToLockHigh, LPOVERLAPPED lpOverlapped ); | kernel32.dll | Cette fonction permet de verrouiller un rang d'octets dans un fichier ouvert avec un accès de partage ou d'exclusivité.
LockResource | LPVOID LockResource(HGLOBAL hResData); | kernel32.dll | Cette fonction permet de verrouiller une ressource spécifié.
LockWindowUpdate | BOOL LockWindowUpdate(HWND hWndLock); | user32.dll | Cette fonction permet d'activer ou désactiver l'affichage du contenu d'une fenêtre d'application.
LockWorkStation | BOOL LockWorkStation(VOID); | user32.dll | Cette fonction permet verrouiller la poste de travail avec le mot de passe de l'utilisateur courant. Cette fonction est l'équivalent de Ctrl+Alt+Delete et «Verrouiller Station de Travail».
LogonUserA | BOOL LogonUserA( LPTSTR lpszUsername, LPTSTR lpszDomain, LPTSTR lpszPassword, DWORD dwLogonType, DWORD dwLogonProvider, PHANDLE phToken ); | advapi32.dll | Cette fonction permet d'effectuer une opération de connexion d'un utilisateur.
LogonUserW | BOOL LogonUserW(LPWSTR lpszUsername, LPWSTR lpszDomain, LPWSTR lpszPassword, DWORD dwLogonType, DWORD dwLogonProvider, PHANDLE phToken ); | advapi32.dll | Cette fonction permet d'effectuer une opération de connexion d'un utilisateur avec des paramètres de chaine de caractères étendue (Unicode).
LookupAccountNameA | BOOL LookupAccountNameA( LPCTSTR lpSystemName, LPCTSTR lpAccountName, PSID Sid, LPDWORD cbSid, LPTSTR ReferencedDomainName, LPDWORD cbReferencedDomainName, PSID_NAME_USE peUse ); | advapi32.dll | Cette fonction permet d'accepter le nom d'un système ou d'un compte en entrée.
LookupAccountNameW | BOOL LookupAccountNameW( LPCWSTR lpSystemName, LPCWSTR lpAccountName, PSID Sid, LPDWORD cbSid, LPWSTR ReferencedDomainName, LPDWORD cchReferencedDomainName, PSID_NAME_USE peUse ); | advapi32.dll | Cette fonction permet d'accepter le nom d'un système ou d'un compte en entrée avec des paramètres de chaine de caractères étendue (Unicode).
LookupAccountSidA | BOOL LookupAccountSidA( LPCTSTR lpSystemName, PSID Sid, LPTSTR Name, LPDWORD cbName, LPTSTR ReferencedDomainName, LPDWORD cbReferencedDomainName, PSID_NAME_USE peUse ); | advapi32.dll | Cette fonction permet d'accepter un identificateur de sécurité (SID) en entrée
LookupAccountSidW | BOOL LookupAccountSidW( LPCWSTR lpSystemName, PSID Sid, LPWSTR Name, LPDWORD cbName, LPWSTR ReferencedDomainName, LPDWORD cbReferencedDomainName, PSID_NAME_USE peUse); | advapi32.dll | Cette fonction permet d'accepter un identificateur de sécurité (SID) en entrée avec des paramètres de chaine de caractères étendue (Unicode).
LookupIconIdFromDirectory | int LookupIconIdFromDirectory(PBYTE presbits, BOOL fIcon); | user32.dll | Cette fonction permet d'effectuer la recherche de données d'icône ou de curseur dans un icône ou curseur étant la meilleure correspondance avec le périphérique d'affichage courant.
LookupIconIdFromDirectoryEx | int LookupIconIdFromDirectoryEx(PBYTE presbits, BOOL fIcon, int cxDesired, int cyDesired, UINT Flags); | user32.dll | Cette fonction permet d'effectuer la recherche de données d'icône ou de curseur dans un icône ou curseur étant la meilleure correspondance avec le périphérique d'affichage courant avec des options particulières.
LookupPrivilegeDisplayNameA | BOOL LookupPrivilegeDisplayNameA( LPCTSTR lpSystemName, LPCTSTR lpName, LPTSTR lpDisplayName, LPDWORD cbDisplayName, LPDWORD lpLanguageId ); | advapi32.dll | Cette fonction permet de demander le nom d'affichage représenté par le prévilège spécifié.
LookupPrivilegeDisplayNameW | BOOL LookupPrivilegeDisplayNameW ( LPCWSTR lpSystemName, LPCWSTR lpName, LPWSTR lpDisplayName, LPDWORD cbDisplayName, LPDWORD lpLanguageId ); | advapi32.dll | Cette fonction permet de demander le nom d'affichage représenté par le prévilège spécifié avec des paramètres de chaine de caractères étendue (Unicode).
LookupPrivilegeNameA | BOOL LookupPrivilegeNameA( LPCTSTR lpSystemName, PLUID lpLuid, LPTSTR lpName, LPDWORD cbName ); | advapi32.dll | Cette fonction permet de demander le nom correspondant au prévilège représenté par un système spécifié par identificateur local unique (LUID).
LookupPrivilegeNameW | BOOL LookupPrivilegeNameW ( LPCWSTR lpSystemName, PLUID lpLuid, LPWSTR lpName, LPDWORD cchName ); | advapi32.dll | Cette fonction permet de demander le nom correspondant au prévilège représenté par un système spécifié par identificateur local unique (LUID) avec des paramètres de chaine de caractères étendue (Unicode)
LookupPrivilegeValueA | BOOL LookupPrivilegeValueA( LPCTSTR lpSystemName, LPCTSTR lpName, PLUID lpLuid ); | advapi32.dll | Cette fonction permet de demander l'identificateur local unique (LUID) utilisé par un système spécifié par une représentation local d'un nom de prévilège.
LookupPrivilegeValueW | BOOL LookupPrivilegeValueW( LPCWSTR lpSystemName, LPCWSTR lpName, PLUID lpLuid ); | advapi32.dll | Cette fonction permet de demander l'identificateur local unique (LUID) utilisé par un système spécifié par une représentation local d'un nom de prévilège avec des paramètres de chaine de caractères étendue (Unicode)
LPtoDP | BOOL LPtoDP(HDC hdc, LPPOINT lpPoints, int nCount); | gdi32.dll | Cette fonction permet de convertir les coordonnées logiques (points) en coordonnées d'un périphérique.
lstrcatA | LPTSTR lstrcatA(LPTSTR lpString1, LPCTSTR lpString2); | kernel32.dll | Cette fonction permet d'ajouter une chaine de caractères à une autre.
lstrcatW | LPWSTR lstrcatW(LPWSTR lpString1, LPWSTR lpString2); | kernel32.dll | Cette fonction permet d'ajouter une chaine de caractères étendue (Unicode) à une autre.
lstrcmpA | int lstrcmpA(LPCTSTR lpString1, LPCTSTR lpString2); | kernel32.dll | Cette fonction permet d'effectuer la comparaison de deux chaines de caractères ASCIZ.
lstrcmpW | int lstrcmpW(LPCWSTR str1, LPCWSTR str2); | kernel32.dll | Cette fonction permet d'effectuer la comparaison de deux chaines de caractères étendues (Unicode).
lstrcmpiA | int lstrcmpiA(LPCTSTR lpString1, LPCTSTR lpString2); | kernel32.dll | Cette fonction permet d'effectuer une comparaison de deux chaines de caractères sans tenir compte des majuscules ou minuscules.
lstrcmpiW | int lstrcmpiW(LPCWSTR str1, LPCWSTR str2); | kernel32.dll | Cette fonction permet d'effectuer une comparaison de deux chaines de caractères étendues (Unicode) sans tenir compte des majuscules ou minuscules.
lstrcpyA | LPTSTR lstrcpyA(LPTSTR lpString1, LPCTSTR lpString2); | kernel32.dll | Cette fonction permet de copier une chaine de caractères dans un tampon.
lstrcpyW | LPCWSTR lstrcpyW(LPCWSTR lpString1, LPCWSTR lpString2); | kernel32.dll | Cette fonction permet de copier une chaine de caractères étendues (Unicode) dans un tampon.
lstrcpynA | LPTSTR lstrcpynA(LPTSTR lpString1, LPCTSTR lpString2, int iMaxLength); | kernel32.dll | Cette fonction permet d'effectuer une copie du nombre de caractères spécifié d'une chaine de caractères vers un tampon en mémoire.
lstrcpynW | LPCWSTR lstrcpynW(LPCWSTR lpString1, LPCWSTR lpString2, int iMaxLength); | kernel32.dll | Cette fonction permet d'effectuer une copie du nombre de caractères spécifié d'une chaine de caractères étendue (Unicode) vers un tampon en mémoire.
lstrlenA | int lstrlenA(LPCTSTR lpString); | kernel32.dll | Cette fonction permet de retourner la longueur, en octets, de la chaine de caractères spécifié.
lstrlenW | int lstrlenW(LPCWSTR lpString); | kernel32.dll | Cette fonction permet de retourner la longueur, en octets, de la chaine de caractères étendue (Unicode) spécifié.
LZClose | VOID LZClose(INT hFile); | lz32.dll | Cette fonction permet de fermer un fichier compressé.
LZCopy | LONG LZCopy(INT hfSource,INT hfDest); | lz32.dll | Cette fonction permet de copier un fichier en dehors du fichier compressé ou permet de le compresser et de l'inclure avec le fichier compressé.
LZOpenFileA | INT LZOpenFileA(LPTSTR lpFileName,LPOFSTRUCT lpReOpenBuf, WORD wStyle); | lz32.dll | Cette fonction permet de créer, ouvrir ou supprimer un fichier compressé.
MakeAbsoluteSD | BOOL MakeAbsoluteSD( PSECURITY_DESCRIPTOR pSelfRelativeSecurityDescriptor, PSECURITY_DESCRIPTOR pAbsoluteSecurityDescriptor, LPDWORD lpdwAbsoluteSecurityDescriptorSize, PACL pDacl, LPDWORD lpdwDaclSize, PACL pSacl, LPDWORD lpdwSaclSize, PSID pOwner, LPDWORD lpdwOwnerSize, PSID pPrimaryGroup, LPDWORD lpdwPrimaryGroupSize ); | advapi32.dll | Cette fonction permet de créer un descripteur de sécurité dans un format absolue en utilisant un gabarit de format relatif de descripteur de sécurité.
MakeSelfRelativeSD | BOOL MakeSelfRelativeSD( PSECURITY_DESCRIPTOR pAbsoluteSecurityDescriptor, PSECURITY_DESCRIPTOR pSelfRelativeSecurityDescriptor, LPDWORD lpdwBufferLength ); | advapi32.dll | Cette fonction permet de créer un descripteur de sécurité dans un format relatif en utilisant un gabarit de format absolue de descripteur de sécurité.
MakeSureDirectoryPathExists | BOOL MakeSureDirectoryPathExists(IN LPSTR Path); | imagehlp.dll | Cette fonction permet de s'assurer que toutes l'arborescente d'un chemin de répertoires existent et ont été créés.
MapDialogRect | BOOL MapDialogRect(HWND hDlg, LPRECT lpRect); | user32.dll | Cette fonction permet d'effectuer la conversion de l'unité de boite de dialogue à l'unité d'écran (pixels).
MapGenericMask | VOID MapGenericMask( PDWORD AccessMask, PGENERIC_MAPPING GenericMapping ); | advapi32.dll | Cette fonction permet de générer une carte de masque de bon accès spécifié et de bon accès standard
MAPISendDocuments | ULONG FAR PASCAL MAPISendDocuments(ULONG ulUIParam, LPTSTR lpszDelimChar, LPTSTR lpszFullPaths, LPTSTR lpszFileNames, ULONG ulReserved); | mapi32.dll | Cette fonction permet d'effectuer l'envoye d'un message de style standard avec des fichiers attachés.
MapViewOfFile | LPVOID MapViewOfFile(HANDLE hFileMappingObject, DWORD dwDesiredAccess, DWORD dwFileOffsetHigh, DWORD dwFileOffsetLow, DWORD dwNumberOfBytesToMap); | kernel32.dll | Cette fonction permet de cartographier une vue d'un fichier dans l'espace d'adressage d'un processus appelant.
MapViewOfFileEx | LPVOID MapViewOfFileEx(HANDLE hFileMappingObject, DWORD dwDesiredAccess, DWORD dwFileOffsetHigh, DWORD dwFileOffsetLow, DWORD dwNumberOfBytesToMap, LPVOID lpBaseAddress); | kernel32.dll | Cette fonction permet de cartographier une vue d'un fichier dans l'espace d'adressage d'un processus appelant avec un adresse de mémoire spécifié.
MapVirtualKeyA | UINT MapVirtualKeyA(UINT uCode, UINT uMapType); | user32.dll | Cette fonction permet d'effectuer la conversion du code de touche virtuel en une valeur de caractère et un code de balayage (scan code) ou convertie le code de balayage en code de touche virtuel.
MapVirtualKeyExA | UINT MapVirtualKeyExA(UINT uCode, UINT uMapType, HKL dwhkl); | user32.dll | Cette fonction permet d'effectuer la conversion du code de touche virtuel en une valeur de caractère et un code de balayage (scan code) ou convertie le code de balayage en code de touche virtuel en utilisant des options supplémentaires.
MapVirtualKeyExW | UINT MapVirtualKeyExW(UINT uCode, UINT uMapType, HKL dwhkl); | user32.dll | Cette fonction permet d'effectuer la conversion du code de touche virtuel en une valeur de caractère et un code de balayage (scan code) ou convertie le code de balayage en code de touche virtuel en utilisant des options supplémentaires avec des paramètres de chaine de caractères étendues (Unicode).
MapVirtualKeyW | UINT MapVirtualKeyW(UINT uCode, UINT uMapType); | user32.dll | Cette fonction permet d'effectuer la conversion du code de touche virtuel en une valeur de caractère et un code de balayage (scan code) ou convertie le code de balayage en code de touche virtuel avec des paramètres de chaine de caractères étendues (Unicode).
MapWindowPoints | int MapWindowPoints(HWND hWndFrom, HWND hWndTo, LPPOINT lpPoints, UINT cPoints); | user32.dll | Cette fonction permet de convertir (cartographié) un ensemble de points d'une espace de coordonnées relatif d'une fenêtre vers une autre fenêtre d'espace de coordonnées relatif.
MaskBlt | BOOL MaskBlt(HDC hdcDest, int nXDest, int nYDest, int nWidth, int nHeight, HDC hdcSrc, int nXSrc, int nYSrc, HBITMAP hbmMask, int xMask, int yMask, DWORD dwRop); | gdi32.dll | Cette fonction permet de fusionner les données de couleur du Bitmap de la source et la destination en utilisant les opérations de masque et de raster spécifié.
mciSendStringA | MCIERROR mciSendStringA(LPCTSTR lpszCommand, LPTSTR lpszReturnString, UINT cchReturn, HANDLE hwndCallback); | winmm.dll | Cette fonction permet d'envoyer des commandes au pilote matériel MCI s'occupant du multimédia.
MenuItemFromPoint | UINT MenuItemFromPoint(HWND hWnd, HMENU hMenu, POINT ptScreen); | user32.dll | Cette fonction permet de demander quel est l'item de menu situé à l'emplacement spécifié, peut importe lequel.
MessageBeep | BOOL MessageBeep(UINT uType); | user32.dll | Cette fonction permet de faire jouer un de ses sons standard du système d'exploitation Windows.
MessageBoxA | int MessageBoxA(HWND hWnd, LPCTSTR lpText, LPCTSTR lpCaption, UINT uType); | user32.dll | Cette fonction permet d'afficher une boite de dialogue contenant un message et des boutons d'actions.
MessageBoxExA | int MessageBoxExA(HWND hWnd, LPCTSTR lpText, LPCTSTR lpCaption, UINT uType, WORD wLanguageId); | user32.dll | Cette fonction permet de créer, d'afficher et d'effectuer des opérations sur une boite de message.
MessageBoxExW | int MessageBoxExW(HWND hWnd, LPCWSTR lpText, LPCWSTR lpCaption, UINT uType, WORD wLanguageId); | user32.dll | Cette fonction permet de créer, d'afficher et d'effectuer des opérations sur une boite de message avec des paramètres de chaine de caractères étendues (Unicode).
MessageBoxIndirectA | BOOL MessageBoxIndirectA(LPMSGBOXPARAMS lpMsgBoxParams); | user32.dll | Cette fonction permet de créer, d'afficher et d'effectuer des opérations sur une boite de message à l'aide d'une structure de données.
MessageBoxIndirectW | BOOL MessageBoxIndirectW(MSGBOXPARAMSW lpMsgBoxParams); | user32.dll | Cette fonction permet de créer, d'afficher et d'effectuer des opérations sur une boite de message à l'aide d'une structure de données avec des paramètres de chaine de caractères étendues (Unicode).
MessageBoxW | int MessageBoxW(HWND hWnd, LPCWSTR lpText, LPCWSTR lpCaption, UINT uType); | user32.dll | Cette fonction permet d'afficher une boite de dialogue contenant un message et des boutons d'actions avec des paramètres de chaine de caractères étendues (Unicode).
ModifyMenuA | BOOL ModifyMenuA(HMENU hMnu, UINT uPosition, UINT uFlags, UINT uIDNewItem, LPCTSTR lpNewItem); | user32.dll | Cette fonction permet d'effectuer une modification sur un item de menu existant.
ModifyMenuW | BOOL ModifyMenuW(HMENU hMnu, UINT uPosition, UINT uFlags, UINT uIDNewItem, LPCWSTR lpNewItem); | user32.dll | Cette fonction permet d'effectuer une modification sur un item de menu existant avec des paramètres de chaine de caractères étendues (Unicode).
ModifyWorldTransform | BOOL ModifyWorldTransform(HDC hdc, CONST XFORM * lpXform, DWORD iMode); | gdi32.dll | Cette fonction permet de changer la transformation mondiale pour le périphérique de contexte utilisant le mode spécifié.
mouse_event | VOID mouse_event(DWORD dwFlags, DWORD dx, DWORD dy, DWORD cButtons, DWORD dwExtraInfo); | user32.dll | Cette fonction permet de provoquer un événement de déplacement de pointeur de souris ou d'actions de bouton de souris.
MoveFileA | BOOL MoveFileA(LPCTSTR lpExistingFileName, LPCTSTR lpNewFileName); | kernel32.dll | Cette fonction permet de renommer ou déplacer un fichier ou un répertoire
MoveFileExA | BOOL MoveFileExA(LPCTSTR lpExistingFileName, LPCTSTR lpNewFileName, DWORD dwFlags); | kernel32.dll | Cette fonction permet de renommer un fichier existant.
MoveFileExW | BOOL MoveFileExW(LPCWSTR source, LPCWSTR dest, DWORD flag); | kernel32.dll | Cette fonction permet de renommer un fichier existant avec un paramètre de chaine de caractères étendue (Unicode).
MoveFileW | BOOL MoveFileW(LPCWSTR lpExistingFileName, LPCWSTR lpNewFileName); | kernel32.dll | Cette fonction permet de renommer ou déplacer un fichier ou un répertoire avec un paramètre de chaine de caractères étendue (Unicode).
MoveToEx | BOOL MoveToEx(HDC hdc, int X, int Y, LPPOINT lpPoint); | gdi32.dll | Cette fonction permet de changer la position du pointeur graphique
MoveWindow | BOOL MoveWindow(HWND hWnd, int X, int Y, int nWidth, int nHeight, BOOL bRepaint); | user32.dll | Cette fonction permet de changer l'emplacement d'une fenêtre d'application
MsgWaitForMultipleObjects | DWORD MsgWaitForMultipleObjects(DWORD nCount, LPHANDLE pHandles, BOOL fWaitAll, DWORD dwMilliseconds, DWORD dwWakeMask); | user32.dll | Cette fonction permet de retourner un objet spécifié suite à un état, un type spécifié étant disponible de l'entrée de la file d'attente d'un processus léger ou intervalle de dépassement de délai.
MsgWaitForMultipleObjectsEx | DWORD MsgWaitForMultipleObjectsEx(DWORD nCount, const HANDLE *pHandles, DWORD dwMilliseconds, DWORD dwWakeMask, DWORD dwFlags); | user32.dll | Cette fonction permet de retourner un objet spécifié suite à un état, un type spécifié étant disponible de l'entrée de la file d'attente d'un processus léger ou intervalle de dépassement de délai avec des paramètres supplémentaires.
MulDiv | int MulDiv(int nNumber, int nNumerator, int nDenominator); | kernel32.dll | Cette fonction permet de diviser le produit de deux entiers long
MultiByteToWideChar | int MultiByteToWideChar(UINT CodePage, DWORD dwFlags, LPCSTR lpMultiByteStr, int cchMultiByte, LPWSTR lpWideCharStr, int cchWideChar); | kernel32.dll | Cette fonction permet de convertir une chaine de caractères ASCII en chaine de caractères Unicode.
MultinetGetConnectionPerformanceA | DWORD MultinetGetConnectionPerformanceA(LPNETRESOURCE lpNetResource, LPNETCONNECTINFOSTRUCT lpNetConnectInfoStruct); | mpr.dll | Cette fonction permet de demander les informations à propos des performances attendu d'une connexion utilisé pour l'accès à une ressource de réseau.
MultinetGetConnectionPerformanceW | DWORD MultinetGetConnectionPerformanceW(LPNETRESOURCEW lpNetResource, LPNETCONNECTINFOSTRUCT lpNetConnectInfoStruct); | mpr.dll | Cette fonction permet de demander les informations à propos des performances attendu d'une connexion utilisé pour l'accès à une ressource de réseau avec des paramètres de chaine de caractères étendues (Unicode).
NotifyChangeEventLog | BOOL NotifyChangeEventLog( HANDLE hEventLog, HANDLE hEvent ); | advapi32.dll | Cette fonction permet de recevoir des avertissements d'application lorsqu'un événement écrit dans le fichier de journal de bord spécifié.
ObjectCloseAuditAlarmA | BOOL ObjectCloseAuditAlarmA( LPCTSTR SubsystemName, LPVOID HandleId, BOOL GenerateOnClose ); | advapi32.dll | Cette fonction permet de générer des messages dans le journal de bord quand un identificateur Handle d'objet est supprimé.
ObjectCloseAuditAlarmW | BOOL ObjectCloseAuditAlarmW(LPCWSTR SubsystemName, LPVOID HandleId, BOOL GenerateOnClose); | advapi32.dll | Cette fonction permet de généré des messages dans le journal de bord quand un identificateur Handle d'objet est supprimé avec des paramètres de chaine de caractères étendue (Unicode).
ObjectDeleteAuditAlarmA | BOOL ObjectDeleteAuditAlarmA(LPCSTR SubsystemName, LPVOID HandleId, BOOL GenerateOnClose); | advapi32.dll | Cette fonction permet de supprimer un message dans le journal de bord.
ObjectDeleteAuditAlarmW | BOOL ObjectDeleteAuditAlarmW(LPCWSTR SubsystemName,LPVOID HandleId,BOOL GenerateOnClose); | advapi32.dll | Cette fonction permet de supprimer un message dans le journal de bord avec des paramètres de chaine de caractères étendue (Unicode).
ObjectOpenAuditAlarmA | BOOL ObjectOpenAuditAlarmA( LPCTSTR SubsystemName, LPVOID HandleId, LPTSTR ObjectTypeName, LPTSTR ObjectName, PSECURITY_DESCRIPTOR pSecurityDescriptor, HANDLE ClientToken, DWORD DesiredAccess, DWORD GrantedAccess, PPRIVILEGE_SET Privileges, BOOL ObjectCreation, BOOL AccessGranted, LPBOOL GenerateOnClose ); | advapi32.dll | Cette fonction permet de générer des messages dans le journal de bord quand une application client tente d'obtenir l'accès à un objet ou dans créer un nouveau.
ObjectOpenAuditAlarmW | BOOL ObjectOpenAuditAlarmW(LPCWSTR SubsystemName, LPVOID HandleId, LPWSTR ObjectTypeName, LPWSTR ObjectName, PSECURITY_DESCRIPTOR pSecurityDescriptor, HANDLE ClientToken, DWORD DesiredAccess, DWORD GrantedAccess, PPRIVILEGE_SET Privileges, BOOL ObjectCreation, BOOL AccessGranted, LPBOOL GenerateOnClose ); | advapi32.dll | Cette fonction permet de générer des messages dans le journal de bord quand une application client tente d'obtenir l'accès à un objet ou dans créer un nouveau avec des paramètres de chaine de caractères étendue (Unicode).
ObjectPrivilegeAuditAlarmA | BOOL ObjectPrivilegeAuditAlarmA( LPCTSTR lpszSubsystem, LPVOID lpvHandleId, HANDLE hClientToken, DWORD dwDesiredAccess, PPRIVILEGE_SET pps, BOOL fAccessGranted ); | advapi32.dll | Cette fonction permet de générer un message dans le journal de bord quand un résultat d'un client est effectué avec des opérations de prévilège sur un serveur d'application déjà ouvert avec l'identificateur Handle de l'objet.
ObjectPrivilegeAuditAlarmW | BOOL ObjectPrivilegeAuditAlarmW( LPCWSTR SubsystemName, LPVOID HandleId, HANDLE ClientToken, DWORD DesiredAccess, PPRIVILEGE_SET Privileges, BOOL AccessGranted ); | advapi32.dll | Cette fonction permet de générer un message dans le journal de bord quand un résultat d'un client est effectué avec des opérations de prévilège sur un serveur d'application déjà ouvert avec l'identificateur Handle de l'objet avec des paramètres de chaine de caractères étendue (Unicode).
OemKeyScan | DWORD OemKeyScan(WORD wOemChar); | user32.dll | Cette fonction permet de demander le code ASCII OEM entre 0 et FFh situé dans les codes de balayage et des touches états (Ctrl, Alt et Shift).
OemToCharA | BOOL OemToCharA(LPCSTR lpszOemStr, LPTSTR lpszStr); | user32.dll | Cette fonction permet d'effectuer la conversion d'une chaine de caractères contenant un ensemble de caractères OEM vers du ANSI ou du Unicode.
OemToCharBuffA | BOOL OemToCharBuffA(LPCSTR lpOemStr, LPTSTR lpszStr, DWORD cchString); | user32.dll | Cette fonction permet d'effectuer la conversion d'un certain nombre de caractères OEM vers du ANSI ou du Unicode.
OemToCharBuffW | BOOL OemToCharBuffW(LPCSTR lpOemStr, LPWSTR lpszStr, DWORD cchString); | user32.dll | Cette fonction permet d'effectuer la conversion d'un certain nombre de caractères OEM vers du ANSI ou du Unicode avec des paramètres de chaine de caractères étendues (Unicode).
OemToCharW | BOOL OemToCharW(LPCSTR lpszOemStr, LPWSTR lpszStr); | user32.dll | Cette fonction permet d'effectuer la conversion d'une chaine de caractères contenant un ensemble de caractères OEM vers du ANSI ou du Unicode avec des paramètres de chaine de caractères étendues (Unicode).
OffsetClipRgn | int OffsetClipRgn(HDC hdc, int nXOffset, int nYOffset); | gdi32.dll | Cette fonction permet de déplacer la région de clip dans le périphérique spécifié et par le déplacement spécifié.
OffsetRect | BOOL OffsetRect(LPRECT lprc, int x, int y); | user32.dll | Cette fonction permet de déplacer le rectangle spécifié avec le nombre de déplacements spécifié.
OffsetRgn | int OffsetRgn(HRGN hrgn, int nXOffset, int nYOffset); | gdi32.dll | Cette fonction permet de déplacer la région spécifié par le déplacement spécifié.
OffsetViewportOrgEx | BOOL OffsetViewportOrgEx(HDC hdc, int nXOffset, int nYOffset, LPPOINT lpPoint); | gdi32.dll | Cette fonction permet de modifier le point de vue d'origine relatif pour un périphérique de contexte en utilisant le déplacement horizontal et vertical spécifié.
OffsetWindowOrgEx | BOOL OffsetWindowOrgEx(HDC hdc, int nXOffset, int nYOffset, LPPOINT lpPoint); | gdi32.dll | Cette fonction permet de modifier le point de vue de la fenêtre d'origine relatif de la valeur courante.
OpenBackupEventLogA | HANDLE OpenBackupEventLogA( LPCTSTR lpszUNCServerName, LPCTSTR lpszFileName ); | advapi32.dll | Cette fonction permet d'ouvir un identificateur Handle pour un événement de copie de sauvegarde du journal de bord.
OpenBackupEventLogW | HANDLE OpenBackupEventLogW( LPCWSTR lpUNCServerName, LPCWSTR lpFileName ); | advapi32.dll | Cette fonction permet d'ouvir un identificateur Handle pour un événement de copie de sauvegarde du journal de bord avec des paramètres de chaine de caractères étendue (Unicode).
OpenClipboard | BOOL OpenClipboard(HWND hwnd); | user32.dll | Cette fonction permet de commencer un traitement avec le presse-papier.
OpenDesktopA | HDESK OpenDesktopA(LPCTSTR lpszDesktopName, DWORD dwFlags, BOOL fInherit, DWORD dwDesiredAccess); | user32.dll | Cette fonction permet de demander le Handle d'un bureau existant.
OpenDesktopW | HDESK OpenDesktopW(LPWSTR lpszDesktopName, DWORD dwFlags, BOOL fInherit, DWORD dwDesiredAccess); | user32.dll | Cette fonction permet de demander le Handle d'un bureau existant avec des paramètres de chaine de caractères étendues (Unicode).
OpenEventA | HANDLE OpenEventA(DWORD fdwAccess, BOOL fInherit, LPCTSTR lpszEventName); | kernel32.dll | Cette fonction permet de demander un Handle dans objet existant d'événement nommé.
OpenEventW | HANDLE OpenEventW(DWORD dwDesiredAccess, BOOL bInheritHandle, LPCWSTR lpName); | kernel32.dll | Cette fonction permet de demander un Handle dans objet existant d'événement nommé avec des paramètres de chaines de caractères étendue (Unicode).
OpenEventLogA | HANDLE OpenEventLogA( LPCTSTR lpszUNCServerName, LPCTSTR lpszSourceName ); | advapi32.dll | Cette fonction permet d'ouvrir un identificateur Handle d'un événement de journal de bord.
OpenEventLogW | HANDLE OpenEventLogW( LPCWSTR uncname, LPCWSTR source ); | advapi32.dll | Cette fonction permet d'ouvrir un identificateur Handle d'un événement de journal de bord avec des paramètres de chaine de caractères étendue (Unicode).
OpenFile | HFILE OpenFile( LPCSTR lpszFile, LPOFSTRUCT lpOpenBuff, UINT fuMode ); | kernel32.dll | Cette fonction permet de créer, d'ouvrir, de réouvrir ou de supprimer un fichier.
OpenFileMappingA | HANDLE OpenFileMappingA(DWORD dwDesiredAccess, BOOL bInheritHandle, LPCTSTR lpName); | kernel32.dll | Cette fonction permet d'ouvrir un objet de cartographie de fichier nommé.
OpenFileMappingW | HANDLE OpenFileMappingW(DWORD access, BOOL inherit, LPCWSTR name); | kernel32.dll | Cette fonction permet d'ouvrir un objet de cartographie de fichier nommé avec des paramètres de chaine de caractères étendue (Unicode).
OpenIcon | BOOL OpenIcon(HWND hwnd); | user32.dll | Cette fonction permet de passer en mode actif l'icône d'une fenêtre.
OpenInputDesktop | HDESK OpenInputDesktop(DWORD dwFlags, BOOL fInherit, DWORD dwDesiredAccess); | user32.dll | Cette fonction permet de demander le Handle d'un bureau reçevant une entrée utilisateur.
OpenMutexA | HANDLE OpenMutexA(DWORD dwDesiredAccess, BOOL bInheritHandle, LPCTSTR lpName); | kernel32.dll | Cette fonction permet d'ouvrir un objet Mutex nommé.
OpenMutexW | HANDLE OpenMutexW(DWORD dwDesiredAccess, BOOL bInheritHandle, LPCWSTR lpName); | kernel32.dll | Cette fonction permet d'ouvrir un objet Mutex nommé avec des paramètres de chaine de caractères étendue (Unicode).
OpenPrinterA | BOOL OpenPrinterA(LPTSTR pPrinterName, LPHANDLE phPrinter, LPPRINTER_DEFAULTS pDefault); | winspool.drv | Cette fonction permet d'ouvrir la communication avec une imprimante.
OpenProcess | HANDLE OpenProcess(DWORD dwDesiredAccess, BOOL bInheritHandle, DWORD dwProcessId); | kernel32.dll | Cette fonction permet d'ouvrir un accès de jeton associé avec un processus.
OpenProcessToken | BOOL OpenProcessToken( HANDLE hProcess, DWORD dwAccessMask, PHANDLE phToken ); | advapi32.dll | Cette fonction permet d'ouvrir un accès de jeton associé avec un processus.
OpenSemaphoreA | HANDLE OpenSemaphoreA(DWORD fdwAccess, BOOL fInherit, LPCTSTR lpszSemName); | kernel32.dll | Cette fonction permet de retourner le Handle d'objet existant de sémaphore nommé.
OpenSemaphoreW | HANDLE OpenSemaphoreW(DWORD dwDesiredAccess, BOOL bInheritHandle, LPCWSTR lpName); | kernel32.dll | Cette fonction permet de retourner le Handle d'objet existant de sémaphore nommé avec des paramètres de chaine de caractères étendue (Unicode).
OpenThreadToken | BOOL OpenThreadToken( HANDLE hThread, DWORD dwAccessMask, BOOL fOpenAsSelf, PHANDLE phToken ); | advapi32.dll | Cette fonction permet d'ouvrir un accès de jeton associé avec un processus léger.
OpenWaitableTimerA | HANDLE OpenWaitableTimerA(DWORD dwDesiredAccess, BOOL bInheritHandle, LPCTSTR lpTimerName); | kernel32.dll | Cette fonction permet d'ouvrir une minuterie d'attente existante nommé.
OpenWaitableTimerW | HANDLE OpenWaitableTimerW(DWORD dwDesiredAccess, BOOL bInheritHandle, LPCWSTR lpTimerName); | kernel32.dll | Cette fonction permet d'ouvrir une minuterie d'attente existante nommé avec des paramètres de chaine de caractères étendue (Unicode).
OpenWindowStationA | HWINSTA OpenWindowStationA(LPCTSTR lpszWinStaName, BOOL fInherit, DWORD dwDesiredAccess); | user32.dll | Cette fonction permet de demander le Handle d'une fenêtre de station existante.
OpenWindowStationW | HWINSTA OpenWindowStationW(LPWSTR lpszWinStaName, BOOL fInherit, DWORD dwDesiredAccess); | user32.dll | Cette fonction permet de demander le Handle d'une fenêtre de station existante avec des paramètres de chaine de caractères étendues (Unicode).
OutputDebugStringA | VOID OutputDebugStringA(LPCTSTR lpszOutputString); | kernel32.dll | Cette fonction permet d'envoyer une chaine de caractères au débogueur de l'application courante.
OutputDebugStringW | VOID OutputDebugStringW(LPCWSTR str); | kernel32.dll | Cette fonction permet d'envoyer une chaine de caractères au débogueur de l'application courante avec des paramètres de chaine de caractères étendue (Unicode).
PackDDElParam | LONG PackDDElParam(UINT uMsg, UINT uLow, UINT uHigh); | user32.dll | Cette fonction permet de compacté la valeur DDE spécifié dans une structure interne utilisé dans le partage de données DDE entre le traitement de processus.
PaintDesktop | BOOL WINAPI PaintDesktop(HDC hdc); | user32.dll | Cette fonction permet de remplir le bureau avec une couleur ou un papier-peint.
PaintRgn | BOOL PaintRgn(HDC hdc, HRGN hrgn); | gdi32.dll | Cette fonction permet de remplir une région, en utilisant la brosse courante, pour un périphérique de contexte spécifié.
PatBlt | BOOL PatBlt(HDC hdc, int nXLeft, int nYLeft, int nWidth, int nHeight, DWORD dwRop); | gdi32.dll | Cette fonction permet de créer une palette de bits pour un périphérique spécifié.
PathAddBackslashA | LPSTR PathAddBackslashA(LPSTR lpszPath); | shlwapi.dll | Cette fonction permet d'ajouter une barre oblique inversé à la fin du chemin de répertoire spécifié.
PathAddExtension | BOOL PathAddExtension(LPTSTR pszPath, LPCTSTR pszExtension); | shlwapi.dll | Cette fonction permet d'ajouter une extension à nom de fichiers.
PathAppendA | BOOL PathAppendA(LPSTR lpszPath, LPCSTR lpszAppend); | shlwapi.dll | Cette fonction permet d'ajouter un chemin de répertoire à la fin d'un autre chemin de répertoire.
PathBuildRootA | LPSTR PathBuildRootA(LPSTR lpszPath, int drive); | shlwapi.dll | Cette fonction permet de créer un répertoire racine pour unité disque spécifié.
PathCanonicalizeA | BOOL PathCanonicalizeA( LPSTR lpszBuf, LPCSTR lpszPath); | shlwapi.dll | Cette fonction permet de transformer un chemin de répertoire de sa forme absolue à relative, c'est-à-dire de remplacer des "../" pour atteinte le répertoire en court par exemple.
PathCombine | LPTSTR PathCombine(LPTSTR lpszDest, LPCTSTR lpszDir, LPCTSTR lpszFile); | shlwapi.dll | Cette fonction permet d'ajouter un chemin de répertoire à la fin d'un autre chemin de répertoire.
PathCommonPrefix | int PathCommonPrefix(LPCTSTR pszFile1, LPCTSTR pszFile2, LPTSTR pszPath); | shlwapi.dll | Cette fonction permet d'effectuer la comparaison de deux répertoires et de vérifier les préfixes communs.
PathCompactPathA | BOOL PathCompactPathA( HDC hDC, LPSTR lpszPath, UINT dx); | shlwapi.dll | Cette fonction permet de réduire la longueur en pixel d'un chemin de répertoire en remplaçant la partie trop longue par des abréviations pour qu'il soit affichable à l'écran par exemple.
PathCompactPathExA | BOOL PathCompactPathExA(LPSTR lpszDest,LPCSTR lpszPath, UINT cchMax, DWORD dwFlags); | shlwapi.dll | Cette fonction permet de réduire la longueur en caractères d'un chemin de répertoire en remplaçant la partie trop longue par des abréviations pour qu'il soit affichable à l'écran par exemple.
PathCreateFromUrlA | HRESULT PathCreateFromUrlA( LPCTSTR pszUrl, LPTSTR pszPath, LPDWORD pcchPath, DWORD dwReserved); | shlwapi.dll | Cette fonction permet de convertir un URL sous sa forme du système d'exploitation de style DOS.
PathFindOnPathA | BOOL PathFindOnPathA(LPTSTR pszFile, LPCTSTR *ppszOtherDirs); | shlwapi.dll | Cette fonction permet d'effectuer la recherche d'un nom de fichier dans un répertoire.
PathGetDriveNumberA | int PathGetDriveNumberA(LPCTSTR lpsz); | shlwapi.dll | Cette fonction permet de demander le numéro de l'unité disque contenu dans un chemin de répertoire.
PathIsDirectoryEmptyA | BOOL PathIsDirectoryEmptyA(LPCTSTR pszPath); | shlwapi.dll | Cette fonction permet de demander si le répertoire spécifier est vide.
PathIsSystemFolder | BOOL PathIsSystemFolder(LPCTSTR pszPath, DWORD dwAttrb); | shlwapi.dll | Cette fonction permet de demander si le répertoire spécifier à l'attribut de dossier système.
PathIsUNCA | BOOL PathIsUNCA(LPCTSTR pszPath); | shlwapi.dll | Cette fonction permet de demander si le répertoire est un répertoire UNC (Universal Naming Convention) valide.
PathIsUNCServerA | BOOL PathIsUNCServerA( LPCTSTR pszPath); | shlwapi.dll | Cette fonction permet de demander si le répertoire est un répertoire UNC (Universal Naming Convention) valide pour un serveur.
PathIsURLA | BOOL PathIsURLA(LPCTSTR pszPath); | shlwapi.dll | Cette fonction permet de demander si le répertoire est un répertoire URL valide.
PathToRegion | HRGN PathToRegion(HDC hdc); | gdi32.dll | Cette fonction permet de créer un chemin vers une région sélectionné dans le périphérique de contexte spécifié.
PathUndecorateA | void PathUndecorateA(LPTSTR pszPath); | shlwapi.dll | Cette fonction permet d'illiminer les séquences à numéro d'un nom fichier.
PathUnmakeSystemFolderA | BOOL PathUnmakeSystemFolderA(LPTSTR pszPath); | shlwapi.dll | Cette fonction permet d'enlever l'attribut système d'un répertoire spécifié.
PeekConsoleInputA | BOOL PeekConsoleInputA(HANDLE hConsoleInput, PINPUT_RECORD pirBuffer, DWORD cInRecords, LPDWORD lpcRead); | kernel32.dll | Cette fonction permet d'effectuer la lecture des données du tampon d'entrée de la console spécifié sans retirer le contenu lue du tampon.
PeekConsoleInputW | BOOL PeekConsoleInputW(HANDLE hConsoleInput,PINPUT_RECORD pirBuffer,DWORD cInRecords,PDWORD lpcRead); | kernel32.dll | Cette fonction permet d'effectuer la lecture des données du tampon d'entrée de la console spécifié sans retirer le contenu lue du tampon avec des paramètres de chaine de caractères étendue (Unicode).
PeekMessageA | BOOL PeekMessageA(LPMSG lpMsg, HWND hWnd, UINT uMsgFilterMin, UINT uMsgFilterMax, UINT wRemoveMsg); | user32.dll | Cette fonction permet de poster un message dans une fenêtre de file d'attente de message et retourne sans attendre la correspondance à un processus de message.
PeekMessageW | BOOL PeekMessageW(LPMSG lpMsg, HWND hWnd, UINT uMsgFilterMin, UINT uMsgFilterMax, UINT wRemoveMsg); | user32.dll | Cette fonction permet de poster un message dans une fenêtre de file d'attente de message et retourne sans attendre la correspondance à un processus de message avec des paramètres de chaine de caractères étendue (Unicode).
PeekNamedPipe | BOOL PeekNamedPipe(HANDLE hPipe, LPVOID lpvBuffer, DWORD cbBuffer, LPDWORD lpcbRead, LPDWORD lpcbAvail, LPDWORD lpcbMessage); | kernel32.dll | Cette fonction permet de copier les données d'un tuyau nommé ou anonyme dans un tampon sans le retirer du tuyau.
Pie | BOOL Pie(HDC hdc, int nLeftRect, int nTopRect, int nRightRect, int nBottomRect, int nXRadial1, int nYRadial1, int nXRadial2, int nYRadial2); | gdi32.dll | Cette fonction permet de dessiner une pointe de tarte en effectuant un arc elliptique d'un centre et de deux points join par des lignes.
PlayEnhMetaFile | BOOL PlayEnhMetaFile(HDC hdc, HENHMETAFILE hemf, CONST RECT * lpRect); | gdi32.dll | Cette fonction permet d'afficher l'image entreposé dans le fichier méta de format étendue spécifié.
PlayEnhMetaFileRecord | BOOL PlayEnhMetaFileRecord(HDC hdc, LPHANDLETABLE lpHandletable, CONST ENHMETARECORD * lpEnhMetaRecord, UINT nHandles); | gdi32.dll | Cette fonction permet de jouer un enregistrement de fichier méta étendue par exécution de fonction GDI (Graphics Device Interface) identifié par l'enregistrement.
PlayMetaFile | BOOL PlayMetaFile(HDC hdc, HMETAFILE hmf); | gdi32.dll | Cette fonction permet de jouer le contenu d'un fichier méta de format Windows spécifié dans un périphérique spécifié.
PlayMetaFileRecord | BOOL PlayMetaFileRecord(HDC hdc, LPHANDLETABLE lpHandletable, LPMETARECORD lpMetaRecord, UINT nHandles); | gdi32.dll | Cette fonction permet de jouer un enregistrement d'un fichier méta de format Windows par exécution du GDI contenu dans l'enregistrement.
PlaySoundA | BOOL PlaySoundA(LPCSTR pszSound, HMODULE hmod, DWORD fdwSound); | winmm.dll | Cette fonction permet de faire jouer un fichier de son de format Wave (.WAV).
PlgBlt | BOOL PlgBlt(HDC hdcDest, CONST POINT * lpPoint, HDC hdcSrc, int nXSrc, int nYSrc, int nWidth, int nHeight, HBITMAP hbmMask, int xMask, int yMask); | gdi32.dll | Cette fonction permet d'effectuer un traitement de transfert de bloc de bits d'une donnée de bits de couleurs d'un rectangle spécifié dans une source de périphérique de contexte vers la destination de périphérique de contexte de parallélogramme spécifié.
PolyBezier | BOOL PolyBezier(HDC hdc, CONST POINT * lppt, DWORD cPoints); | gdi32.dll | Cette fonction permet de dessiner une ou plusieurs courbes de Bézier.
PolyBezierTo | BOOL PolyBezierTo(HDC hdc, CONST POINT * lppt, DWORD cCount); | gdi32.dll | Cette fonction permet de dessiner une ou plusieurs courbes de Bézier spécifié.
PolyDraw | BOOL PolyDraw(HDC hdc, CONST POINT * lppt, CONST BYTE * lpbTypes, int cCount); | gdi32.dll | Cette fonction permet de dessiner un ensemble de ligne de segments et de courbes de Bézier.
PolyPolygon | BOOL PolyPolygon(HDC hdc, CONST POINT *lpPoints, LPINT lpPolyCounts, int nCount); | gdi32.dll | Cette fonction permet de créer deux ou plusieurs polygone étant rempli par un mode de remplissage de polygone.
PolyTextOutA | BOOL PolyTextOutA(HDC hdc, CONST POLYTEXT * pptxt, int cStrings); | gdi32.dll | Cette fonction permet de dessiner une chaine de caractères en utilisant la police de caractères et les couleurs textes courante dans le périphérique de contexte spécifié.
PolyTextOutW | BOOL PolyTextOutW(HDC hdc, const POLYTEXTW* pptxt, INT cStrings); | gdi32.dll | Cette fonction permet de dessiner une chaine de caractères en utilisant la police de caractères et les couleurs textes courante dans le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues.
Polygon | BOOL Polygon(HDC hdc, CONST POINT *lpPoints, int nCount); | gdi32.dll | Cette fonction permet de dessiner un polygone de deux ou plusieurs points (sommets) connectés par des lignes.
Polyline | BOOL Polyline(HDC hdc, CONST POINT *lppt, int cPoints); | gdi32.dll | Cette fonction permet de dessiner un ensemble de segments de lignes, connecté par les points spécifiés.
PolylineTo | BOOL PolylineTo(HDC hdc, CONST POINT * lppt, DWORD cCount); | gdi32.dll | Cette fonction permet de dessiner une ou plusieurs lignes droite.
PostMessageA | BOOL PostMessageA(HWND hwnd, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'envoyer un message à un objet du système d'exploitation Windows.
PostMessageW | BOOL PostMessageW(HWND hwnd, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'envoyer un message à un objet du système d'exploitation Windows avec des paramètres de chaine de caractères étendues (Unicode).
PostQueuedCompletionStatus | BOOL PostQueuedCompletionStatus(HANDLE CompletionPort, DWORD dwNumberOfBytesTransferred, DWORD dwCompletionKey, LPOVERLAPPED lpOverlapped); | kernel32.dll | Cette fonction permet de poster une paquet d'achèvement d'entrée/sortie vers un port d'achèvement d'entrée/sortie.
PostQuitMessage | VOID PostQuitMessage(int nExitCode); | user32.dll | Cette fonction permet de poster un message à Windows afin d'indiquer que l'application reçoit une requête de terminaison d'exécution (quitte).
PostThreadMessageA | BOOL PostThreadMessageA(DWORD dwThreadId, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet de poster un message dans la file d'attente du processus léger spécifié et retourne sans attendre que le processus léger traite le message.
PostThreadMessageW | BOOL PostThreadMessageW(DWORD dwThreadId, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet de poster un message dans la file d'attente du processus léger spécifié et retourne sans attendre que le processus léger traite le message avec des paramètres de chaine de caractères étendues (Unicode).
PrepareTape | DWORD PrepareTape(HANDLE hDevice, DWORD dwOperation, BOOL bImmediate); | kernel32.dll | Cette fonction permet de préparer le ruban pour être accédé ou enlevé.
PrintDlgA | BOOL PrintDlgA(LPPRINTDLG lppd); | comdlg32.dll | Cette fonction permet d'afficher une boite de dialogue d'impression.
PrinterProperties | BOOL PrinterProperties(hwnd hwnd,HANDLE hPrinter); | winspool.drv | Cette fonction permet d'afficher une boite de dialogue de propriété de l'imprimante.
PrivilegeCheck | BOOL PrivilegeCheck( HANDLE hClientToken, PPRIVILEGE_SET pps, LPBOOL lpfResult ); | advapi32.dll | Cette fonction permet de tester le contexte de sécurité représenté par un accès de jeton spécifié contenu dans un prévilège spécifié.
PrivilegedServiceAuditAlarmA | BOOL PrivilegedServiceAuditAlarmA( LPCTSTR lpszSubsystem, LPCTSTR lpszService, HANDLE hClientToken, PPRIVILEGE_SET pps, BOOL fAccessGranted ); | advapi32.dll | Cette fonction permet de générer un message de journal de bord quand une opération de service de prévilège système s'effectue.
PrivilegedServiceAuditAlarmW | BOOL PrivilegedServiceAuditAlarmW(LPCWSTR SubsystemName, LPCWSTR ServiceName, HANDLE ClientToken, PPRIVILEGE_SET Privileges, BOOL AccessGranted ); | advapi32.dll | Cette fonction permet de générer un message de journal de bord quand une opération de service de prévilège système s'effectue avec des paramètres de chaine de caractères étendue (Unicode).
Process32First | BOOL WINAPI Process32First(HANDLE hSnapshot,LPPROCESSENTRY32 lppe); | kernel32.dll | Cette fonction permet de demander le premier processus provenant de la liste contenu dans une photo du système d'exploitation.
Process32Next | BOOL WINAPI Process32Next( HANDLE hSnapshot, LPPROCESSENTRY32 lppe); | kernel32.dll | Cette fonction permet de demander le processus suivant provenant de la liste contenu dans une photo du système d'exploitation.
PtInRect | BOOL PtInRect(CONST RECT *lprc, POINT pt); | user32.dll | Cette fonction permet de déterminer si le point spécifié est lié avec le rectangle spécifié.
PtInRegion | BOOL PtInRegion(HRGN hrgn, int X, int Y); | gdi32.dll | Cette fonction permet de demander si un point spécifié est dans une région spécifié.
PtVisible | BOOL PtVisible(HDC hdc, int X, int Y); | gdi32.dll | Cette fonction permet de demander si le point spécifié est dans la région clip d'un périphérique de contexte.
PulseEvent | BOOL PulseEvent(HANDLE hEvent); | kernel32.dll | Cette fonction permet de fournir une simple opération fixant l'état d'un objet d'événement spécifié et réinitialisant après qu'un délai d'attente de processus approprié s'est produit.
PurgeComm | BOOL PurgeComm(HANDLE hCommDev, DWORD fdwAction); | kernel32.dll | Cette fonction permet de débarrasser de tous les caractères d'un tampon de sortie ou d'entrée d'une ressource de communication spécifié.
PwdChangePasswordA | DWORD WINAPI PwdChangePasswordA(LPCSTR lpProvider, HWND hWnd, DWORD flags, LPCHANGEPWDINFOA info); | mpr.dll | Cette fonction permet de modifier le mot de passe de l'utilisateur ou d'un fournisseur du système d'exploitation.
QueryDosDeviceA | DWORD QueryDosDeviceA(LPCTSTR lpDeviceName, LPTSTR lpTargetPath, DWORD ucchMax); | kernel32.dll | Cette fonction permet à une application de demander des informations à propre d'un nom de périphérique DOS.
QueryDosDeviceW | DWORD QueryDosDeviceW(LPCWSTR lpDeviceName, LPCWSTR lpTargetPath, DWORD ucchMax); | kernel32.dll | Cette fonction permet à une application de demander des informations à propre d'un nom de périphérique DOS avec des paramètres de chaine de caractères étendue (Unicode).
QueryPerformanceCounter | BOOL QueryPerformanceCounter(LARGE_INTEGER *lpliPerformanceCount); | kernel32.dll | Cette fonction permet de demander la valeur actuel du compteur de haute performance de la machine.
QueryPerformanceFrequency | BOOL QueryPerformanceFrequency(LARGE_INTEGER *lpliPerformanceFreq); | kernel32.dll | Cette fonction permet de demander la valeur de la fréquence du compteur de haute performance de la machine.
QueueUserAPC | DWORD QueueUserAPC(PAPCFUNC pfnAPC, HANDLE hThread, ULONG_PTR dwData); | kernel32.dll | Cette fonction permet d'ajouter une objet de procédure d'appel désychronisée (APC) en mode utilisateur dans une file d'attente APC d'un processus léger spécifié.
RaiseException | VOID RaiseException(DWORD dwExceptionCode, DWORD dwExceptionFlags, DWORD cArguments, CONST DWORD * lpArguments); | kernel32.dll | Cette fonction permet de déclencher une exception dans le processus léger appelant.
RasEnumEntriesA | DWORD RasEnumEntriesA( LPTSTR reserved, LPTSTR lpszPhonebook, LPRASENTRYNAME lprasentryname, LPDWORD lpcb, LPDWORD lpcEntries ); | rasapi32.dll | Cette fonction permet de demander la liste de tous les noms d'entrées contenu dans le carnet pour les connexions téléphoniques à distance.
ReadConsoleA | BOOL ReadConsoleA(HANDLE hConsoleInput, LPVOID lpvBuffer, DWORD cchToRead, LPDWORD lpcchRead, LPVOID lpvReserved); | kernel32.dll | Cette fonction permet d'effectuer la lecture d'un caractère en provenance de la console.
ReadConsoleW | BOOL ReadConsoleW(HANDLE hConsoleInput, LPVOID lpBuffer, DWORD nNumberOfCharsToRead, LPDWORD lpNumberOfCharsRead, LPVOID lpReserved); | kernel32.dll | Cette fonction permet d'effectuer la lecture d'un caractère en provenance de la console avec des paramètres de chaine de caractères étendue (Unicode).
ReadConsoleInputA | BOOL ReadConsoleInputA(HANDLE hConsoleInput, PINPUT_RECORD pirBuffer, DWORD cInRecords, LPDWORD lpcRead); | kernel32.dll | Cette fonction permet d'effectuer la lecture de données du tampon d'entrée d'une console et retire les données du tampon.
ReadConsoleInputW | BOOL ReadConsoleInputW(HANDLE hConsoleInput, PINPUT_RECORD pirBuffer, DWORD cInRecords, LPDWORD lpcRead); | kernel32.dll | Cette fonction permet d'effectuer la lecture de données du tampon d'entrée d'une console et retire les données du tampon avec des paramètres de chaine de caractères étendue (Unicode).
ReadConsoleOutputA | BOOL ReadConsoleOutputA(HANDLE hConsoleOutput, PCHAR_INFO pchiDestBuffer, COORD coordDestBufferSize, COORD coordDestBufferCoord, PSMALL_RECT psrctSourceRect); | kernel32.dll | Cette fonction permet d'effectuer la lecture de données de caractère et de couleur d'attribut dans un bloc rectangulaire d'une cellule de caractères d'un tampon de console d'écran et écrire le résultat de ses données dans un tampon spécifié.
ReadConsoleOutputW | BOOL ReadConsoleOutputW(HANDLE hConsoleOutput, PCHAR_INFO pchiDestBuffer, COORD coordDestBufferSize, COORD coordDestBufferCoord, PSMALL_RECT psrctSourceRect); | kernel32.dll | Cette fonction permet d'effectuer la lecture de données de caractère et de couleur d'attribut dans un bloc rectangulaire d'une cellule de caractères d'un tampon de console d'écran et écrire le résultat de ses données dans un tampon spécifié avec des paramètres de chaine de caractères étendue (Unicode).
ReadConsoleOutputAttribute | BOOL ReadConsoleOutputAttribute(HANDLE hConsoleOutput, LPWORD lpwAttribute, DWORD cReadCells, COORD coordReadCoord, LPDWORD lpcNumberRead); | kernel32.dll | Cette fonction permet de copier le nombre spécifié dans la couleur d'attribut d'arrière-plan ou de premier plan d'une cellule consécutive d'un tampon de console d'écran en débutant à la position spécifié.
ReadConsoleOutputCharacterA | BOOL ReadConsoleOutputCharacterA(HANDLE hConsoleOutput, LPTSTR lpReadBuffer, DWORD cchRead, COORD coordReadCoord, LPDWORD lpcNumberRead); | kernel32.dll | Cette fonction permet de copier un nombre de caractères d'une cellule consécutif d'un tampon de console écran en débutant à la position spécifié.
ReadConsoleOutputCharacterW | BOOL ReadConsoleOutputCharacterW(HANDLE hConsoleOutput, LPCWSTR lpReadBuffer, DWORD cchRead, COORD coordReadCoord, LPDWORD lpcNumberRead); | kernel32.dll | Cette fonction permet de copier un nombre de caractères d'une cellule consécutif d'un tampon de console écran en débutant à la position spécifié avec des paramètres de chaine de caractères étendue (Unicode).
ReadDirectoryChangesW | BOOL ReadDirectoryChangesW( HANDLE hDirectory, LPVOID lpBuffer, DWORD nBufferLength, BOOL bWatchSubtree, DWORD dwNotifyFilter, LPDWORD lpBytesReturned, LPOVERLAPPED lpOverlapped, LPOVERLAPPED_COMPLETION_ROUTINE lpCompletionRoutine ); | kernel32.dll | Cette fonction permet de demander les informations descriptives de changement ayant eu lieu dans le répertoire spécifié.
ReadEventLogA | BOOL ReadEventLogA( HANDLE hEventLog, DWORD dwReadFlags, DWORD dwRecordOffset, LPVOID lpBuffer, DWORD nNumberOfBytesToRead, DWORD *pnBytesRead, DWORD *pnMinNumberOfBytesNeeded ); | advapi32.dll | Cette fonction permet de lire un nombre d'entrées spécifié dans un journal de bord des événements.
ReadEventLogW | BOOL ReadEventLogW( HANDLE hEventLog, DWORD dwReadFlags, DWORD dwRecordOffset, LPVOID lpBuffer, DWORD nNumberOfBytesToRead, DWORD* pnBytesRead, DWORD* pnMinNumberOfBytesNeeded ); | advapi32.dll | Cette fonction permet de lire un nombre d'entrées spécifié dans un journal de bord des événements avec des paramètres de chaine de caractères étendue (Unicode).
ReadFile | BOOL ReadFile(HANDLE hFile, LPVOID lpBuffer, DWORD nNumberOfBytesToRead, LPDWORD lpNumberOfBytesRead, LPOVERLAPPED lpOverlapped); | kernel32.dll | Cette fonction permet d'effectuer la lecture d'un fichier, en débutant à la position spécifié par le pointeur de fichier.
ReadFileEx | BOOL ReadFileEx(HANDLE hFile, LPVOID lpBuffer, DWORD nNumberOfBytesToRead, LPOVERLAPPED lpOverlapped, LPOVERLAPPED_COMPLETION_ROUTINE lpCompletionRoutine); | kernel32.dll | Cette fonction permet d'effectuer la lecture de données d'un fichier désychronisé.
ReadProcessMemory | BOOL ReadProcessMemory(HANDLE hProcess, LPCVOID lpBaseAddress, LPVOID lpBuffer, DWORD cbRead, LPDWORD lpNumberOfBytesRead); | kernel32.dll | Cette fonction permet d'effectuer la lecture de mémoire dans un processus spécifié.
RealizePalette | UINT RealizePalette(HDC hdc); | gdi32.dll | Cette fonction permet de cartographier l'entrée de palette de la palette logique courante de la palette système.
Rectangle | BOOL Rectangle(HDC hdc, int nLeftRect, int nTopRect, int nRightRect, int nBottomRect); | gdi32.dll | Cette fonction permet d'afficher un rectangle.
RectInRegion | BOOL RectInRegion(HRGN hrgn, CONST RECT *lprc); | gdi32.dll | Cette fonction permet de demander si une partie du rectangle spécifié est dans une des limites d'une région spécifié.
RectVisible | BOOL RectVisible(HDC hdc, CONST RECT *lprc); | gdi32.dll | Cette fonction permet de demander n'importe quel partie d'un rectangle spécifié dans une région de clip d'un périphérique de contexte spécifié.
RedrawWindow | BOOL RedrawWindow(HWND hwnd, CONST RECT *lprcUpdate, HRGN hrgnUpdate, UINT afuRedraw); | user32.dll | Cette fonction permet de mettre à jour le rectangle ou la région spécifié de la région de la fenêtre client.
RegCloseKey | LONG RegCloseKey( HKEY hKey ); | advapi32.dll | Cette fonction permet de fermer le Handle de la clef de registre spécifié.
RegConnectRegistryA | LONG RegConnectRegistryA( LPTSTR lpszComputerName, HKEY hKey, PHKEY phkResult ); | advapi32.dll | Cette fonction permet d'établir une connexion avec un registre de Handle prédéfinie ou autre ordinateur.
RegConnectRegistryW | LSTATUS RegConnectRegistryW( LPCWSTR lpMachineName, HKEY hKey, PHKEY phkResult ); | advapi32.dll | Cette fonction permet d'établir une connexion avec un registre de Handle prédéfinie ou autre ordinateur avec des paramètres de chaine de caractères étendue (Unicode).
RegCreateKeyA | LONG RegCreateKeyA( HKEY hKey, LPCTSTR lpszSubKey, PHKEY phkResult ); | advapi32.dll | Cette fonction permet de créer la clef de registre spécifié. Si la clef existe dans les registres, la fonction l'ouvre.
RegCreateKeyW | LSTATUS RegCreateKeyW( HKEY hkey, LPCWSTR lpSubKey, PHKEY phkResult ); | advapi32.dll | Cette fonction permet de créer la clef de registre spécifié avec des paramètres de chaine de caractères étendue (Unicode). Si la clef existe dans les registres, la fonction l'ouvre.
RegCreateKeyExA | LONG RegCreateKeyExA( HKEY hKey, LPCTSTR lpszSubKey, DWORD dwReserved, LPTSTR lpszClass, DWORD fdwOptions, REGSAM samDesired, LPSECURITY_ATTRIBUTES lpSecurityAttributes, PHKEY phkResult, LPDWORD lpdwDisposition ); | advapi32.dll | Cette fonction permet de créer une clef de registre spécifié avec des systèmes de la famille NT. Si la clef existe dans les registres, la fonction l'ouvre.
RegCreateKeyExW | LSTATUS RegCreateKeyExW( HKEY hkey, LPCWSTR name, DWORD reserved, LPWSTR class, DWORD options, REGSAM access, SECURITY_ATTRIBUTES* sa, PHKEY retkey, LPDWORD dispos ); | advapi32.dll | Cette fonction permet de créer une clef de registre spécifié avec des systèmes de la famille NT avec des paramètres de chaine de caractères étendue (Unicode). Si la clef existe dans les registres, la fonction l'ouvre.
RegDeleteKeyA | LONG RegDeleteKeyA( HKEY hKey, LPCTSTR lpszSubKey ); | advapi32.dll | Cette fonction permet de supprimer la clef de registre spécifié.
RegDeleteKeyW | LSTATUS RegDeleteKeyW( HKEY hkey, LPCWSTR name ); | advapi32.dll | Cette fonction permet de supprimer la clef de registre spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegDeleteValueA | LONG RegDeleteValueA( HKEY hKey, LPTSTR lpszValue ); | advapi32.dll | Cette fonction permet de supprimer la valeur du nom spécifié dans la clef de la base de registre.
RegDeleteValueW | LSTATUS RegDeleteValueW( HKEY hkey, LPCWSTR name ); | advapi32.dll | Cette fonction permet de supprimer la valeur du nom spécifié dans la clef de la base de registre avec des paramètres de chaine de caractères étendue (Unicode).
RegEnumKeyA | LONG RegEnumKeyA( HKEY hKey, DWORD iSubKey, LPTSTR lpszName, DWORD cchName ); | advapi32.dll | Cette fonction permet d'énuméré les sous-clefs d'une clef de registre ouverte spécifié.
RegEnumKeyW | LSTATUS RegEnumKeyW( HKEY hkey, DWORD index, LPWSTR name, DWORD name_len ); | advapi32.dll | Cette fonction permet d'énuméré les sous-clefs d'une clef de registre ouverte spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegEnumKeyExA | LONG RegEnumKeyExA( HKEY hKey, DWORD iSubkey, LPTSTR lpszName, LPDWORD lpcchName, LPDWORD lpdwReserved, LPTSTR lpszClass, LPDWORD lpcchClass, PFILETIME lpftLastWrite ); | advapi32.dll | Cette fonction permet d'énuméré les sous-clefs d'une clef de registre ouverte spécifié avec des systèmes de la famille NT.
RegEnumKeyExW | LSTATUS RegEnumKeyExW( HKEY hkey, DWORD index, LPWSTR name, LPDWORD name_len, LPDWORD reserved, LPWSTR class, LPDWORD class_len, FILETIME* ft ); | advapi32.dll | Cette fonction permet d'énuméré les sous-clefs d'une clef de registre ouverte spécifié avec des systèmes de la famille NT avec des paramètres de chaine de caractères étendue (Unicode).
RegEnumValueA | LONG RegEnumValueA( HKEY hKey, DWORD iValue, LPTSTR lpszValue, LPDWORD lpcchValue, LPDWORD lpdwReserved, LPDWORD lpdwType, LPBYTE lpbData, LPDWORD lpcbData ); | advapi32.dll | Cette fonction permet d'énuméré les valeurs pour la clef de registre ouverte spécifié.
RegEnumValueW | LSTATUS RegEnumValueW( HKEY hkey, DWORD index, LPWSTR value, LPDWORD val_count, LPDWORD reserved, LPDWORD type, LPBYTE data, LPDWORD count ); | advapi32.dll | Cette fonction permet d'énuméré les valeurs pour la clef de registre ouverte spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegFlushKey | LONG RegFlushKey(HKEY hKey); | advapi32.dll | Cette fonction permet d'écrire tous les attributs de la clef de la base de registre ouverte spécifié.
RegGetKeySecurity | LSTATUS RegGetKeySecurity( HKEY hkey, SECURITY_INFORMATION SecurityInformation, PSECURITY_DESCRIPTOR pSecurityDescriptor, LPDWORD lpcbSecurityDescriptor ); | advapi32.dll | Cette fonction permet de copier le descripteur de sécurité de la clef de registre ouverte spécifié.
RegisterClassA | ATOM RegisterClassA(CONST WNDCLASS *lpwc); | user32.dll | Cette fonction permet d'effectuer l'enregistrement d'une classe de fenêtre subséquente aux appels des fonctions CreateWindow ou CreateWindowEx.
RegisterClassExA | ATOM RegisterClassExA(CONST WNDCLASSEX FAR *lpwcx); | user32.dll | Cette fonction permet d'effectuer l'enregistrement d'une classe de fenêtre subséquente aux appels des fonctions CreateWindow ou CreateWindowEx avec des options supplémentaires.
RegisterClassExW | ATOM RegisterClassExW(CONST WNDCLASSEXW FAR *lpwcx); | user32.dll | Cette fonction permet d'effectuer l'enregistrement d'une classe de fenêtre subséquente aux appels des fonctions CreateWindow ou CreateWindowEx avec des options supplémentaires et des paramètres de chaine de caractères étendues (Unicode).
RegisterClassW | ATOM RegisterClassW(CONST WNDCLASSW *lpwc); | user32.dll | Cette fonction permet d'effectuer l'enregistrement d'une classe de fenêtre subséquente aux appels des fonctions CreateWindow ou CreateWindowEx avec des paramètres de chaine de caractères étendues (Unicode).
RegisterClipboardFormatA | UINT RegisterClipboardFormatA(LPCTSTR lpszFormat); | user32.dll | Cette fonction permet d'enregistrer un nouveau format de presse-papier.
RegisterClipboardFormatW | UINT RegisterClipboardFormatW(LPCWSTR lpszFormat); | user32.dll | Cette fonction permet d'enregistrer un nouveau format de presse-papier avec des paramètres de chaine de cararactères étendues (Unicode).
RegisterDeviceNotificationA | HDEVNOTIFY RegisterDeviceNotificationA( HANDLE hRecipient, LPVOID NotificationFilter, DWORD Flags ); | user32.dll | Cette fonction permet d'enregistrer un périphérique ou un type de périphérique pour que la fenêtre reçoivent des avertissements de changements.
RegisterHotKey | BOOL RegisterHotKey(HWND hwnd, int idHotKey, UINT fuModifiers, UINT uVirtKey); | user32.dll | Cette fonction permet de définir l'état des touches de combinaison (Alt, Ctrl, Shift) pour le processus léger courant.
RegisterServiceProcess | DWORD RegisterServiceProcess(DWORD dwProcessId,DWORD dwType); | kernel32.dll | Cette fonction permet de cacher un programme de facon à ce qu'il ne soit pas afficher lorsqu'on appuis sur Ctrl+Alt+Delete pour voir la liste des programmes dans le Gestionnaire de tâche.
RegisterWindowMessageA | UINT RegisterWindowMessageA(LPCTSTR lpsz); | user32.dll | Cette fonction permet de définir une nouvelle fenêtre de message garantissant qu'elle est unique au système.
RegisterWindowMessageW | UINT RegisterWindowMessageW(LPCWSTR lpsz); | user32.dll | Cette fonction permet de définir une nouvelle fenêtre de message garantissant qu'elle est unique au système avec des paramètres de chaine de caractères étendues (Unicode).
RegLoadKeyA | LONG RegLoadKeyA( HKEY hKey, LPCTSTR lpszSubKey, LPCTSTR lpszFile ); | advapi32.dll | Cette fonction permet de créer une sous-clef dans «HKEY_USER» ou «HKEY_LOCAL_MACHINE» et d'entreposer les informations d'enregistrement dans le fichier spécifié d'une sous-clef.
RegLoadKeyW | LSTATUS RegLoadKeyW( HKEY hkey, LPCWSTR subkey, LPCWSTR filename ); | advapi32.dll | Cette fonction permet de créer une sous-clef dans «HKEY_USER» ou «HKEY_LOCAL_MACHINE» et d'entreposer les informations d'enregistrement dans le fichier spécifié d'une sous-clef avec des paramètres de chaine de caractères étendue (Unicode).
RegNotifyChangeKeyValue | LONG RegNotifyChangeKeyValue( HKEY hKey, BOOL fWatchSubTree, DWORD fdwNotifyFilter, HANDLE hEvent, BOOL fAsync ); | advapi32.dll | Cette fonction permet d'indiquer quand une clef de registre, ou élément rattaché à celle-ci, a changé.
RegOpenKeyA | LONG RegOpenKeyA( HKEY hKey, LPCTSTR lpszSubKey, PHKEY phkResult ); | advapi32.dll | Cette fonction permet d'ouvrir une clef spécifié dans une base de registre.
RegOpenKeyW | LSTATUS RegOpenKeyW( HKEY hkey, LPCWSTR name, PHKEY retkey ); | advapi32.dll | Cette fonction permet d'ouvrir une clef spécifié dans une base de registre avec des paramètres de chaine de caractères étendue (Unicode).
RegOpenKeyExA | LONG RegOpenKeyExA( HKEY hKey, LPCTSTR lpszSubKey, DWORD dwReserved, REGSAM samDesired, PHKEY phkResult ); | advapi32.dll | Cette fonction permet d'ouvrir une clef spécifié dans une base de registre.
RegOpenKeyExW | LSTATUS RegOpenKeyExW( HKEY hkey, LPCWSTR name, DWORD reserved, REGSAM access, PHKEY retkey ); | advapi32.dll | Cette fonction permet d'ouvrir une clef spécifié dans une base de registre avec des paramètres de chaine de caractères étendue (Unicode).
RegQueryInfoKeyA | LONG RegQueryInfoKeyA( HKEY hKey, LPTSTR lpszClass, LPDWORD lpcchClass, LPDWORD lpdwReserved, LPDWORD lpcSubKeys, LPDWORD lpcchMaxSubkey, LPDWORD lpcchMaxClass, LPDWORD lpcValues, LPDWORD lpcchMaxValueName, LPDWORD lpcbMaxValueData, LPDWORD lpcbSecurityDescriptor, PFILETIME lpftLastWriteTime ); | advapi32.dll | Cette fonction permet de demander les informations d'une clef de registre spécifié.
RegQueryInfoKeyW | LSTATUS RegQueryInfoKeyW( HKEY hkey, LPWSTR class, LPDWORD class_len, LPDWORD reserved, LPDWORD subkeys, LPDWORD max_subkey, LPDWORD max_class, LPDWORD values, LPDWORD max_value, LPDWORD max_data, LPDWORD security, FILETIME* modif ); | advapi32.dll | Cette fonction permet de demander les informations d'une clef de registre spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegQueryMultipleValuesA | LONG RegQueryMultipleValuesA( HKEY hKey, PVALENT val_list, DWORD num_vals, LPTSTR lpValueBuf, LPDWORD ldwTotsize ); | advapi32.dll | Cette fonction permet de demander le type et la donnée pour une liste de noms de valeur associé avec une clef de registre ouverte.
RegQueryMultipleValuesW | LSTATUS RegQueryMultipleValuesW( HKEY hkey, PVALENTW val_list, DWORD num_vals, LPWSTR lpValueBuf, LPDWORD ldwTotsize ); | advapi32.dll | Cette fonction permet de demander le type et la donnée pour une liste de noms de valeur associé avec une clef de registre ouverte avec des paramètres de chaine de caractères étendue (Unicode).
RegQueryValueA | LONG RegQueryValueA( HKEY hKey, LPCTSTR lpszSubKey, LPTSTR lpszValue, PLONG pcbValue ); | advapi32.dll | Cette fonction permet de demander la valeur associé avec une valeur non-nommé pour la clef du registre spécifié.
RegQueryValueW | LSTATUS RegQueryValueW( HKEY hkey, LPCWSTR name, LPWSTR data, LPLONG count ); | advapi32.dll | Cette fonction permet de demander la valeur associé avec une valeur non-nommé pour la clef du registre spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegQueryValueExA | LONG RegQueryValueExA( HKEY hKey, LPTSTR lpszValueName, LPDWORD lpdwReserved, LPDWORD lpdwType, LPBYTE lpbData, LPDWORD lpcbData ); | advapi32.dll | Cette fonction permet de demander la valeur associé avec une valeur non-nommé pour la clef du registre spécifié avec des systèmes de la famille NT.
RegQueryValueExW | LSTATUS RegQueryValueExW ( HKEY hkey, LPCWSTR name, LPDWORD reserved, LPDWORD type, LPBYTE data, LPDWORD count ); | advapi32.dll | Cette fonction permet de demander la valeur associé avec une valeur non-nommé pour la clef du registre spécifié avec des systèmes de la famille NT avec des paramètres de chaine de caractères étendue (Unicode).
RegReplaceKeyA | LONG RegReplaceKeyA( HKEY hKey, LPCTSTR lpSubKey, LPCTSTR lpNewFile, LPCTSTR lpOldFile ); | advapi32.dll | Cette fonction permet de remplacer un fichier de copie de sauvegarde d'un clef et tous les sous-clef d'une autre fichier.
RegReplaceKeyW | LSTATUS RegReplaceKeyW( HKEY hkey, LPCWSTR lpSubKey, LPCWSTR lpNewFile, LPCWSTR lpOldFile ); | advapi32.dll | Cette fonction permet de remplacer un fichier de copie de sauvegarde d'un clef et tous les sous-clef d'une autre fichier avec des paramètres de chaine de caractères étendue (Unicode).
RegRestoreKeyA | LONG RegRestoreKeyA( HKEY hKey, LPCTSTR lpszFile, DWORD fdw ); | advapi32.dll | Cette fonction permet de lire des informations registre dans un fichier spécifié et de copier la clef spécifié.
RegRestoreKeyW | LSTATUS RegRestoreKeyW( HKEY hkey, LPCWSTR lpFile, DWORD dwFlags ); | advapi32.dll | Cette fonction permet de lire des informations registre dans un fichier spécifié et de copier la clef spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegSaveKeyA | LONG RegSaveKeyA( HKEY hKey, LPCTSTR lpszFile, LPSECURITY_ATTRIBUTES lpsa ); | advapi32.dll | Cette fonction permet de sauvegarder tous les clefs, sous-clefs et les valeurs spécifié dans un nouveau fichier.
RegSaveKeyW | LSTATUS RegSaveKeyW ( HKEY hkey, LPCWSTR file, LPSECURITY_ATTRIBUTES sa ); | advapi32.dll | Cette fonction permet de sauvegarder tous les clefs, sous-clefs et les valeurs spécifié dans un nouveau fichier avec des paramètres de chaine de caractères étendue (Unicode).
RegSetKeySecurity | LONG RegSetKeySecurity( HKEY hKey, SECURITY_INFORMATION si, PSECURITY_DESCRIPTOR psd ); | advapi32.dll | Cette fonction permet fixer la sécurité d'une clef de registre ouvert.
RegSetValueA | LONG RegSetValueA( HKEY hKey, LPCTSTR lpSubKey, DWORD dwType, LPCTSTR lpData, DWORD cbData ); | advapi32.dll | Cette fonction permet d'associer une valeur avec une clef spécifié.
RegSetValueW | LSTATUS RegSetValueW ( HKEY hkey, LPCWSTR name, DWORD type, LPCWSTR data, DWORD count ); | advapi32.dll | Cette fonction permet d'associer une valeur avec une clef spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegSetValueExA | LONG RegSetValueExA( HKEY hKey, LPCTSTR lpValueName, DWORD Reserved, DWORD dwType, CONST BYTE * lpData, DWORD cbData ); | advapi32.dll | Cette fonction permet d'entreposer les données d'un champs de valeur d'une clef de registre ouvert.
RegSetValueExW | LSTATUS RegSetValueExW( HKEY hkey, LPCWSTR name, DWORD reserved, DWORD type, CONST BYTE* data, DWORD count ); | advapi32.dll | Cette fonction permet d'entreposer les données d'un champs de valeur d'une clef de registre ouvert avec des paramètres de chaine de caractères étendue (Unicode).
RegUnLoadKeyA | LONG RegUnLoadKeyA( HKEY hKey, LPCTSTR lpszSubKey ); | advapi32.dll | Cette fonction permet de décharger la clef et sous-clefs de registre spécifié
RegUnLoadKeyW | LSTATUS RegUnLoadKeyW( HKEY hkey, LPCWSTR lpSubKey ); | advapi32.dll | Cette fonction permet de décharger la clef et sous-clefs de registre spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegisterEventSourceA | HANDLE RegisterEventSourceA( LPCTSTR lpszUNCServer, LPCTSTR lpszSource ); | advapi32.dll | Cette fonction permet de retourner l'identificateur Handle utilisé avec la fonction d'événement «ReportEvent» du journal de bord.
RegisterEventSourceW | HANDLE RegisterEventSourceW( LPCWSTR lpUNCServerName, LPCWSTR lpSourceName ); | advapi32.dll | Cette fonction permet de retourner l'identificateur Handle utilisé avec la fonction d'événement «ReportEvent» du journal de bord avec des paramètres de chaine de caractères étendue (Unicode).
ReleaseCapture | BOOL ReleaseCapture(VOID); | user32.dll | Cette fonction permet de relâcher la capture de souris et de restituer l'entrée de traitement normal.
ReleaseDC | int ReleaseDC(HWND hwnd, HDC hdc); | user32.dll | Cette fonction permet de relâcher un périphérique de contexte, de libérer son utilisation pour les autres applications.
ReleaseMutex | BOOL ReleaseMutex(HANDLE hMutex); | kernel32.dll | Cette fonction permet de relâcher la propriété de l'objet Mutex spécifié.
ReleaseSemaphore | BOOL ReleaseSemaphore(HANDLE hSemaphore, LONG cReleaseCount, LPLONG lplPreviousCount); | kernel32.dll | Cette fonction permet d'augmenter le compteur de l'objet de sémaphore spécifié par une quantité spécifié.
RemoveDirectoryA | BOOL RemoveDirectoryA(LPCTSTR lpszDir); | kernel32.dll | Cette fonction permet de supprimer un répertoire.
RemoveDirectoryW | BOOL RemoveDirectoryW(LPCWSTR lpszDir); | kernel32.dll | Cette fonction permet de supprimer un répertoire avec les paramètres de chaine de caractères étendues (Unicode).
RemoveDirectoryTransactedA | BOOL RemoveDirectoryTransactedA(LPCTSTR lpPathName, HANDLE hTransaction); | kernel32.dll | Cette fonction permet de supprimer un répertoire d'une opération de transaction.
RemoveDirectoryTransactedW | BOOL RemoveDirectoryTransactedW(LPCTWSTR lpPathName, HANDLE hTransaction); | kernel32.dll | Cette fonction permet de supprimer un répertoire d'une opération de transaction avec des paramètres de chaine de caractères étendue (Unicode).
RemoveFontResourceA | BOOL RemoveFontResourceA(LPCTSTR lpFileName); | gdi32.dll | Cette fonction permet d'enlever un ajout de ressource de police de caractères d'un fichier spécifié ou d'une table de police de caractères de Windows.
RemoveFontResourceW | BOOL RemoveFontResourceW(LPCWSTR lpFileName); | gdi32.dll | Cette fonction permet d'enlever un ajout de ressource de police de caractères d'un fichier spécifié ou d'une table de police de caractères de Windowsavec des paramètres de chaine de caractères étendues (Unicode).
RemoveMenu | BOOL RemoveMenu(HMENU hmenu, UINT uItem, UINT fuFlags); | user32.dll | Cette fonction permet de supprimer un item de menu déroulant.
RemovePropA | HANDLE RemovePropA(HWND hwnd, LPCTSTR lpsz); | user32.dll | Cette fonction permet d'enlever une entrée de la liste de propriété de la fenêtre spécifié.
RemovePropW | HANDLE RemovePropW(HWND hwnd, LPCWSTR lpsz); | user32.dll | Cette fonction permet d'enlever une entrée de la liste de propriété de la fenêtre spécifié avec des paramètres de chaine de caractères étendues (Unicode).
ReplyMessage | BOOL ReplyMessage(LRESULT lResult); | user32.dll | Cette fonction permet de répondre à un message envoyé par la fonction SendMessage sans rendre le contrôle à la fonction ayant appelé SendMessage.
ReportEventA | BOOL ReportEventA( HANDLE hEventSource, WORD fwEventType, WORD fwCategory, DWORD IDEvent, PSID pUserSid, WORD cStrings, DWORD cbData, LPCTSTR *plpszStrings, LPVOID lpvData ); | advapi32.dll | Cette fonction permet d'écrire une entrée à la fin du journal de bord des événements spécifié.
ReportEventW | BOOL ReportEventW( HANDLE hEventLog, WORD wType, WORD wCategory, DWORD dwEventID, PSID lpUserSid, WORD wNumStrings, DWORD dwDataSize, LPCWSTR* lpStrings, LPVOID lpRawData ); | advapi32.dll | Cette fonction permet d'écrire une entrée à la fin du journal de bord des événements spécifié avec des paramètres de chaine de caractères étendue (Unicode).
ResetDCA | HDC ResetDCA(HDC hdc, CONST DEVMODE * lpInitData); | gdi32.dll | Cette fonction permet de mettre à jour le périphérique de contexte, en se basant sur les informations de la structure spécifié.
ResetDCW | HDC ResetDCW(HDC hdc,const DEVMODEW * lpInitData); | gdi32.dll | Cette fonction permet de mettre à jour le périphérique de contexte, en se basant sur les informations de la structure spécifié avec des paramètres de chaine de caractères étendues (Unicode).
ResetEvent | BOOL ResetEvent(HANDLE hEvent); | kernel32.dll | Cette fonction permet de fixer l'état de l'objet d'événement spécifié dans un sans signal.
ResizePalette | BOOL ResizePalette(HPALETTE hpal, UINT nEntries); | gdi32.dll | Cette fonction permet de changer la taille de la palette logique spécifié.
RestoreDC | BOOL ResizePalette(HPALETTE hpal, UINT nEntries); | gdi32.dll | Cette fonction permet de restaurer un périphérique de contexte à l'état précédent.
RestoreMyDocsFolder | long RestoreMyDocsFolder(); | mydocs.dll | Cette fonction permet de recréer l'icône de «Mes Documents» sur le bureau du système d'exploitation Windows.
ResumeThread | DWORD ResumeThread(HANDLE hThread); | kernel32.dll | Cette fonction permet de décrémenter le compteur de processus léger suspendu.
ReuseDDElParam | LONG ReuseDDElParam(LONG lParam, UINT uMsgIn, UINT uMsgOut, UINT uLow, UINT uHigh); | user32.dll | Cette fonction permet d'allouer une application vers la réutilisation de paramètre DDE compacté spécifié et en réallouant un nouveau paquet spécifié.
RevertToSelf | BOOL RevertToSelf(VOID); | advapi32.dll | Cette fonction permet de terminé la personnification d'une application client.
RtlFillMemory | VOID RtlFillMemory(VOID* Destination, SIZE_T Length, BYTE Fill); | kernel32.dll | Cette fonction permet de remplir une zone de mémoire avec une valeur spécifié.
RtlMoveMemory | VOID RtlMoveMemory(VOID* Destination, CONST VOID* Source,SIZE_T Length); | kernel32.dll | Cette fonction permet de copier un bloc de mémoire vers un autre emplacement mémoire.
RoundRect | BOOL RoundRect(HDC hdc, int nLeftRect, int nTopRect, int nRightRect, int nBottomRect, int nWidth, int nHeight); | gdi32.dll | Cette fonction permet de dessiner un rectangle avec les coins arrondies, en utilisant le crayon courant.
SaveDC | int SaveDC(HDC hdc); | gdi32.dll | Cette fonction permet de sauvegarder l'état courant du périphérique de contexte courant en copiant les informations d'état (clip de région, sélection d'objets, et mode de cartographie) dans la pile de contexte.
ScaleViewportExtEx | BOOL ScaleViewportExtEx(HDC hdc, int Xnum, int Xdenom, int Ynum, int Ydenom, LPSIZE lpSize); | gdi32.dll | Cette fonction permet de modifier les extensions du point de vue relative avec des valeurs courante.
ScaleWindowExtEx | BOOL ScaleWindowExtEx(HDC hdc, int Xnum, int Xdenom, int Ynum, int Ydenom, LPSIZE lpSize); | gdi32.dll | Cette fonction permet de modifier les extensions de la fenêtre de périphérique de contexte en utilisant le ratio formé par le multiplicateur et le diviseur spécifié.
ScreenToClient | BOOL ScreenToClient(HWND hwnd, LPPOINT lpPoint); | user32.dll | Cette fonction permet de convertir les coordonnées d'écrans d'un point spécifié de l'écran à des coordonnées clients.
ScrollConsoleScreenBufferA | BOOL ScrollConsoleScreenBufferA(HANDLE hConsoleOutput, PSMALL_RECT psrctSourceRect, PSMALL_RECT psrctClipRect, COORD coordDestOrigin, PCHAR_INFO pchiFill); | kernel32.dll | Cette fonction permet de déplacer un bloc de données dans un tampon d'écran.
ScrollConsoleScreenBufferW | BOOL ScrollConsoleScreenBufferW(HANDLE hConsoleOutput, PSMALL_RECT psrctSourceRect, PSMALL_RECT psrctClipRect, COORD coordDestOrigin, PCHAR_INFO pchiFill); | kernel32.dll | Cette fonction permet de déplacer un bloc de données dans un tampon d'écran avec des paramètres de chaine de caractères étendues (Unicode).
ScrollDC | BOOL ScrollDC(HDC hdc, int dx, int dy, CONST RECT *lprcScroll, CONST RECT *lprcClip, HRGN hrgnUpdate, LPRECT lprcUpdate); | user32.dll | Cette fonction permet de faire défiler un rectangle d'un nombre de bits horizontal et vertical.
ScrollWindow | BOOL ScrollWindow(HWND hwnd, int dx, int dy, CONST RECT * lprcScroll, CONST RECT * lprcClip); | user32.dll | Cette fonction permet d'effectuer un défilement du contenu d'une région de fenêtre client.
ScrollWindowEx | int ScrollWindowEx(HWND hwnd, int dx, int dy, CONST RECT *lprcScroll, CONST RECT *lprcClip, HRGN hrgnUpdate, LPRECT lprcUpdate, UINT fuScroll); | user32.dll | Cette fonction permet d'effectuer un défilement du contenu d'une région de fenêtre client avec des options supplémentaires.
SearchPathA | DWORD SearchPathA(LPCTSTR lpszPath, LPCTSTR lpszFile, LPCTSTR lpszExtension, DWORD cchReturnBuffer, LPTSTR lpszReturnBuffer, LPTSTR *plpszFilePart); | kernel32.dll | Cette fonction permet d'effectuer une recherche dans le fichier spécifié.
SearchPathW | DWORD SearchPathW(LPCWSTR path, LPCWSTR name, LPCWSTR ext, DWORD buflen, LPWSTR buffer, LPWSTR* lastpart); | kernel32.dll | Cette fonction permet d'effectuer une recherche dans le fichier spécifié avec des paramètres de chaine de caractères étendues (Unicode).
SearchTreeForFile | BOOL SearchTreeForFile(PCTSTR RootPath, PCTSTR InputPathName,PTSTR OutputPathBuffer); | imagehlp.dll | Cette fonction permet d'effectuer la recherche d'un fichier dans un arbre de répertoire.
SelectClipPath | BOOL SelectClipPath(HDC hdc, int iMode); | gdi32.dll | Cette fonction permet de sélectionner le chemin courant dans la région de capture d'un périphérique de contexte en combinant la nouvelle région avec n'importe quel région de capture existante par utilisation de mode spécifié.
SelectClipRgn | int SelectClipRgn(HDC hdc, HRGN hrgn); | gdi32.dll | Cette fonction permet de sélectionner une région spécifié et la capture de région courant pour un périphérique de contexte courant.
SelectObject | HGDIOBJ SelectObject(HDC hdc, HGDIOBJ hgdiobj); | gdi32.dll | Cette fonction permet de sélectionner un objet dans le périphérique de contexte spécifié.
SelectPalette | HPALETTE SelectPalette(HDC hdc, HPALETTE hpal, BOOL bForceBackground); | gdi32.dll | Cette fonction permet de sélectionner la palette logique dans le périphérique de contexte donnée.
SendDlgItemMessageA | LONG SendDlgItemMessageA(HWND hwndDlg, int idControl, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'envoyer un message à un contrôle de boite de dialogue.
SendDlgItemMessageW | LONG SendDlgItemMessageW(HWND hwndDlg, int idControl, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'envoyer un message à un contrôle de boite de dialogue avec des paramètres de chaine de caractères étendues (Unidcode).
SendMessageA | LRESULT SendMessageA(HWND hwnd, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message à une fenêtre où à un objet d'une fenêtre.
SendMessageCallbackA | BOOL SendMessageCallbackA(HWND hwnd, UINT uMsg, WPARAM wParam, PARAM lParam, SENDASYNCPROC lpResultCallBack, DWORD dwData); | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message spécifié vers une ou des fenêtres.
SendMessageCallbackW | BOOL SendMessageCallbackW(HWND hwnd, UINT uMsg, WPARAM wParam, PARAM lParam, SENDASYNCPROC lpResultCallBack, DWORD dwData); | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message spécifié vers une ou des fenêtres avec des paramètres de chaine de caractères étendues (Unicode).
SendMessageTimeoutA | LRESULT SendMessageTimeoutA(HWND hwnd, UINT uMsg, WPARAM wParam, LPARAM lParam, UINT fuFlags, UINT uTimeout, LPDWORD lpdwResult); | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message avec un dépassement de délai spécifié vers une ou des fenêtres.
SendMessageTimeoutW | LRESULT SendMessageTimeoutW(HWND hwnd, UINT uMsg, WPARAM wParam, LPARAM lParam, UINT fuFlags, UINT uTimeout, LPDWORD lpdwResult); | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message avec un dépassement de délai spécifié vers une ou des fenêtres avec des paramètres de chaine de caractères étendues (Unicode).
SendMessageW | LRESULT SendMessageW(HWND hwnd, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message à une fenêtre où à un objet d'une fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
SendNotifyMessageA | BOOL SendNotifyMessageA(HWND hwnd, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message d'avertissement spécifié vers une fenêtre.
SendNotifyMessageW | BOOL SendNotifyMessageW(HWND hwnd, UINT uMsg, WPARAM wParam, LPARAM lParam); | user32.dll | Cette fonction permet d'effectuer l'envoi d'un message d'avertissement spécifié vers une fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
SetAbortProc | int SetAbortProc(HDC hdc, ABORTPROC lpAbortProc); | gdi32.dll | Cette fonction permet de fixer la procédure d'application définit par le programmeur pour alloué un travail d'impression afin d'être annuler durant sa tamporisation dans le tampon d'impression.
SetAclInformation | BOOL SetAclInformation( PACL pAcl, LPVOID lpvAclInfo, DWORD cbAclInfo, ACL_INFORMATION_CLASS aclic ); | advapi32.dll | Cette fonction permet de fixer les informations à propos de la liste de contrôle d'accès (ACL).
SetActiveWindow | HWND SetActiveWindow(HWND hwnd); | user32.dll | Cette fonction permet de rendre le plus haut niveau d'une fenêtre spécifié en une fenêtre active.
SetArcDirection | int SetArcDirection(HDC hdc, int ArcDirection); | gdi32.dll | Cette fonction permet de fixer la direction du dessinage pour être utilisé dans les fonctions d'arc et de rectangle.
SetBitmapBits | LONG SetBitmapBits(HBITMAP hbmp, DWORD cBytes, CONST VOID *lpBits); | gdi32.dll | Cette fonction permet de fixer l'ensemble de bits d'un Bitmap spécifié avec les valeurs de bits spécifié.
SetBitmapDimensionEx | BOOL SetBitmapDimensionEx(HBITMAP hBitmap, int nWidth, int nHeight, LPSIZE lpSize); | gdi32.dll | Cette fonction permet de fixer la taille souhaité d'un Bitmap, dans une unité de mesure de 0,01 millimètre.
SetBkColor | COLORREF SetBkColor(HDC hdc, COLORREF crColor); | gdi32.dll | Cette fonction permet de fixer la couleur de l'arrière-plan de la couleur spécifié.
SetBkMode | int SetBkMode(HDC hdc, int iBkMode); | gdi32.dll | Cette fonction permet de fixer le mode d'arrière-plan spécifié.
SetBoundsRect | UINT SetBoundsRect(HDC hdc, CONST RECT *lprcBounds, UINT flags); | gdi32.dll | Cette fonction permet de contrôler l'accumulation d'informations de limite rectangulaire d'un périphérique de contexte.
SetBrushOrgEx | BOOL SetBrushOrgEx(HDC hdc, int nXOrg, int nYOrg, LPPOINT lppt); | gdi32.dll | Cette fonction permet de fixer l'origine de la brosse GDI étant associé avec la prochaine brosse d'une application sélectionné dans le périphérique de contexte spécifié.
SetCapture | HWND SetCapture(HWND hwnd); | user32.dll | Cette fonction permet de fixer la capture de la souris dans la fenêtre spécifié.
SetCaretBlinkTime | BOOL SetCaretBlinkTime(UINT wMSeconds); | user32.dll | Cette fonction permet de fixer le taux de clignotement du caret.
SetCaretPos | BOOL SetCaretPos(int nX, int nY); | user32.dll | Cette fonction permet de fixer la position d'un caret.
SetClassLongA | DWORD SetClassLongA(HWND hwnd, int nIndex, LONG lNewVal); | user32.dll | Cette fonction permet de fixer des valeurs d'informations en 32 bits sur une classe.
SetClassLongW | DWORD SetClassLongW(HWND hwnd, int nIndex, LONG lNewVal); | user32.dll | Cette fonction permet de fixer des valeurs d'informations en 32 bits sur une classe avec des paramètres de chaine de caractères étendues (Unicode).
SetClassWord | WORD SetClassWord(HWND hwnd, int nIndex, WORD wNewWord); | user32.dll | Cette fonction permet de fixer la valeur d'un mot dans le déplacement spécifié de la classe de mémoire supplémentaire de la classe de fenêtre à laquelle la fenêtre appartient.
SetClipboardData | HANDLE SetClipboardData(UINT uFormat, HANDLE hData); | user32.dll | Cette fonction permet de fixer des données dans le presse-papier.
SetClipboardViewer | HWND SetClipboardViewer(HWND hwnd); | user32.dll | Cette fonction permet d'ajouter une fenêtre donnée à la chaine de fenêtre ayant un avertissement si le contenu du presse-papier a changé.
SetColorAdjustment | BOOL SetColorAdjustment(HDC hdc, CONST COLORADJUSTMENT * lpca); | gdi32.dll | Cette fonction permet de fixer les valeurs de couleurs d'ajustements pour un périphérique de contexte utilisant les valeurs spécifiés.
SetColorSpace | BOOL SetColorSpace(HDC hdc, HCOLORSPACE hColorSpace); | gdi32.dll | Cette fonction permet de fixer l'espace de couleur du périphérique de contexte spécifié en définissant la fin des points d'un espace RVB (RGB) logique dans l'espace CIE XYZ.
SetCommBreak | BOOL SetCommBreak(HANDLE hCommDev); | kernel32.dll | Cette fonction permet de suspendre la transmission de caractères pour un périphérique de communications spécifié et place la ligne de transmission dans un état d'arrêt jusqu'à ce que la fonction ClearCommBreak soit appelée.
SetCommConfig | BOOL SetCommConfig(HANDLE hCommDev, LPBYTE lpCC, DWORD dwSize); | kernel32.dll | Cette fonction permet de fixer la configuration courante dans un périphérique de communication.
SetCommMask | BOOL SetCommMask(HANDLE hCommDev, DWORD fdwEvtMask); | kernel32.dll | Cette fonction permet de spécifier un ensemble d'événement être surveillé par un périphérique de communication.
SetCommState | BOOL SetCommState(HANDLE hCommDev, LPDCB lpdcb); | kernel32.dll | Cette fonction permet de configurer un périphérique de communication en accord avec bloc de contrôle de périphérique (DCB) spécifié.
SetCommTimeouts | BOOL SetCommTimeouts(HANDLE hCommDev, LPCOMMTIMEOUTS lpctmo); | kernel32.dll | Cette fonction permet de fixer les paramètres de dépassement de délai pour tous les opérations de lecture ou d'écriture dans un périphérique de communication spécifié.
SetComputerNameA | BOOL SetComputerNameA(LPCTSTR lpszName); | kernel32.dll | Cette fonction permet de fixer le nom de l'ordinateur pour le système d'exploitation Windows.
SetComputerNameW | BOOL SetComputerNameW(LPCWSTR lpComputerName); | kernel32.dll | Cette fonction permet de fixer le nom de l'ordinateur pour le système d'exploitation Windows avec des paramètres de chaine de caractères étendues (Unicode).
SetConsoleActiveScreenBuffer | BOOL SetConsoleActiveScreenBuffer(HANDLE hConsoleOutput); | kernel32.dll | Cette fonction permet de fixer le tampon d'écran spécifié devant être actuellement affiché dans le tampon de la console d'écran.
SetConsoleCP | BOOL SetConsoleCP(UINT IDCodePage); | kernel32.dll | Cette fonction permet de fixer l'entrée de code de page utilisé par la console associé avec le processus appelant.
SetConsoleCtrlHandler | BOOL SetConsoleCtrlHandler(PHANDLER_ROUTINE pHandlerRoutine, BOOL fAdd); | kernel32.dll | Cette fonction permet d'ajouter un d'enlever une définition d'application de la fonction HandlerRoutine de la liste des fonctions de gestionnaire pour un processus appelant.
SetConsoleCursorInfo | BOOL SetConsoleCursorInfo(HANDLE hConsoleOutput, PCONSOLE_CURSOR_INFO pcci); | kernel32.dll | Cette fonction permet de fixer la taille et la visibilité du curseur dans le tampon de la console d'écran spécifié.
SetConsoleCursorPosition | BOOL SetConsoleCursorPosition( HANDLE hConsoleOutput, COORD coordCursor ); | kernel32.dll | Cette fonction permet de fixer la position du curseur pour l'affichage sur la console de texte.
SetConsoleMode | BOOL SetConsoleMode(HANDLE hConsole, DWORD fdwMode); | kernel32.dll | Cette fonction permet de fixer le mode d'entrée du tampon d'entrée de la console ou du mode de sortie d'un tampon de console d'écran.
SetConsoleOutputCP | BOOL SetConsoleOutputCP(UINT IDCodePage); | kernel32.dll | Cette fonction permet de fixer le code de page de sortie utilisé par la console associé avec le processus appelant.
SetConsoleScreenBufferSize | BOOL SetConsoleScreenBufferSize(HANDLE hConsoleOutput, COORD coordSize); | kernel32.dll | Cette fonction permet de changer la taille d'un tampon de console d'écran spécifié.
SetConsoleTextAttribute | BOOL SetConsoleTextAttribute(HANDLE hConsoleOutput, WORD wAttr); | kernel32.dll | Cette fonction permet de fixer les attributs (couleur de fond et d'écriture) pour l'affichage sur la console de texte. C'est l'équivalent d'un octet d'attribut dans un écran de texte matériel.
SetConsoleTitleA | BOOL SetConsoleTitleA(LPTSTR lpszTitle); | kernel32.dll | Cette fonction permet de fixer le titre de la barre de titre de la fenêtre d'application.
SetConsoleTitleW | BOOL SetConsoleTitleW(LPCWSTR title); | kernel32.dll | Cette fonction permet de fixer le titre de la barre de titre de la fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
SetConsoleWindowInfo | BOOL SetConsoleWindowInfo(HANDLE hConsoleOutput, BOOL fAbsolute, PSMALL_RECT psrctWindowRect); | kernel32.dll | Cette fonction permet de fixer la taille courante et la position de la fenêtre du tampon de la console d'écran.
SetCurrentDirectoryA | BOOL SetCurrentDirectoryA(LPCTSTR lpPathName); | kernel32.dll | Cette fonction permet de fixer le répertoire courant du processus courant.
SetCurrentDirectoryW | BOOL SetCurrentDirectoryW(LPCWSTR lpPathName); | kernel32.dll | Cette fonction permet de fixer le répertoire courant du processus courant avec des paramètres de chaine de caractères étendues (Unicode).
SetCursor | HCURSOR SetCursor(HCURSOR hcur); | user32.dll | Cette fonction permet de fixer l'image du pointeur de la souris.
SetCursorPos | BOOL SetCursorPos(int X, int Y); | user32.dll | Cette fonction permet de fixer les coordonnées du pointeur de la souris.
SetDebugErrorLevel | VOID SetDebugErrorLevel(DWORD dwLevel); | user32.dll | Cette fonction permet de fxer le niveau d'erreur minimum dans chaque fenêtre étant généré par les événements de déboguage et passe celui-ci au débogueur.
SetDefaultCommConfigA | BOOL SetDefaultCommConfigA(LPCSTR lpszName, LPCOMMCONFIG lpCC, DWORD dwSize); | kernel32.dll | Cette fonction permet de fixer la configuration par défaut pour un périphérique de communication.
SetDefaultCommConfigW | BOOL SetDefaultCommConfigW(LPCWSTR lpszDevice, LPCOMMCONFIG lpCommConfig, DWORD dwSize); | kernel32.dll | Cette fonction permet de fixer la configuration par défaut pour un périphérique de communication avec des paramètres de chaine de caractères étendues (Unicode).
SetDeviceGammaRamp | BOOL SetDeviceGammaRamp(HDC hdc, LPVOID lpRamp); | gdi32.dll | Cette fonction permet de fixer la rampe gamma d'un panneau d'affichage de couleur directe.
SetDIBColorTable | UINT SetDIBColorTable(HDC hdc, UINT uStartIndex, UINT cEntries, RGBQUAD *pColors); | gdi32.dll | Cette fonction permet de fixer les valeurs de couleurs RVB (rouge, vert, bleu) dans une rangée de table de couleurs d'un périphérique de Bitmap indépendant (DIB) étant actuellement sélectionné dans un périphérique de contexte spécifié.
SetDIBits | int SetDIBits(HDC hdc, HBITMAP hbmp, UINT uStartScan, UINT cScanLines, CONST VOID * lpvBits, CONST BITMAPINFO * lpbmi, UINT fuColorUse); | gdi32.dll | Cette fonction permet de fixer le pixel dans un Bitmap compatible (DDB) en utilisant les données de couleur trouvé dans le DIB spécifié.
SetDIBitsToDevice | int SetDIBitsToDevice(HDC hdc, int XDest, int YDest, DWORD dwWidth, DWORD dwHeight, int XSrc, int YSrc, UINT uStartScan, UINT cScanLines, CONST VOID * lpvBits, CONST BITMAPINFO * lpbmi, UINT fuColorUse); | gdi32.dll | Cette fonction permet de fixer les bits d'un périphérique de Bitmap indépendant (DIB) directement dans un périphérique de surface.
SetDlgItemInt | BOOL SetDlgItemInt(HWND hwndDlg, int idControl, UINT uValue, BOOL fSigned); | user32.dll | Cette fonction permet de fixer le texte d'un contrôle donnée dans une boite de dialogue vers la chaine de caractères de représentation spécifiant la valeur entière.
SetDlgItemTextA | BOOL SetDlgItemTextA(HWND hwndDlg, int idControl, LPCTSTR lpsz); | user32.dll | Cette fonction permet de fixer le titre ou le texte d'un contrôle d'une boite de dialogue.
SetDlgItemTextW | BOOL SetDlgItemTextW(HWND hwndDlg, int idControl, LPCWSTR lpsz); | user32.dll | Cette fonction permet de fixer le titre ou le texte d'un contrôle d'une boite de dialogue avec des paramètres de chaine de caractères étendues (Unicode).
SetDoubleClickTime | BOOL SetDoubleClickTime(UINT uInterval); | user32.dll | Cette fonction permet de fixer le temps maximal autorisé pour que des clics sur les boutons de la souris soit considéré comme un double-clic.
SetEndOfFile | BOOL SetEndOfFile(HANDLE hFile); | kernel32.dll | Cette fonction permet de fixer la position du pointeur de fichier à la fin du fichier utilisant un Handle.
SetEnhMetaFileBits | HENHMETAFILE SetEnhMetaFileBits(UINT cbBuffer, CONST BYTE * lpData); | gdi32.dll | Cette fonction permet de créer un fichier méta de format étendue, basé en mémoire, de données fournit.
SetEnvironmentVariableA | BOOL SetEnvironmentVariableA(LPCTSTR lpszName, LPCTSTR lpszValue); | kernel32.dll | Cette fonction permet de fixer la valeur d'une variable d'environnement du système d'exploitation.
SetEnvironmentVariableW | BOOL SetEnvironmentVariableW(LPCWSTR lpszName, LPCWSTR lpszValue); | kernel32.dll | Cette fonction permet de fixer la valeur d'une variable d'environnement du système d'exploitation avec des paramètres de chaine de caractères étendues (Unicode).
SetErrorMode | UINT SetErrorMode(UINT fuErrorMode); | kernel32.dll | Cette fonction permet de contrôler comment le système d'exploitation gère les types sévères dans les erreurs sérieuses.
SetEvent | BOOL SetEvent(HANDLE hEvent); | kernel32.dll | Cette fonction permet de fixer l'état de l'objet d'événement spécifié par un signal.
SetFileApisToANSI | VOID SetFileApisToANSI(VOID); | kernel32.dll | Cette fonction permet de faire provoquer, à une série de fonctions de fichiers Win32, l'utilisation d'un ensemble de code de page de caractères ANSI.
SetFileApisToOEM | VOID SetFileApisToOEM(VOID); | kernel32.dll | Cette fonction permet de faire provoquer, à une série de fonctions de fichiers Win32, l'utilisation d'un ensemble de code de page de caractères OEM.
SetFileAttributesA | BOOL SetFileAttributesA(LPCTSTR lpFileName, DWORD dwFileAttributes); | kernel32.dll | Cette fonction permet de fixer les attributs d'un fichier ou d'un répertoire.
SetFileAttributesW | BOOL SetFileAttributesW(LPCWSTR lpFileName, DWORD dwFileAttributes); | kernel32.dll | Cette fonction permet de fixer les attributs d'un fichier ou d'un répertoire avec des paramètres de chaine de caractères étendues (Unicode).
SetFilePointer | DWORD SetFilePointer(HANDLE hFile, LONG lDistanceToMove, PLONG lpDistanceToMoveHigh, DWORD dwMoveMethod); | kernel32.dll | Cette fonction permet de déplacer un pointeur de ficher dans un fichier ouvert.
SetFileSecurityA | BOOL SetFileSecurityA( LPCTSTR lpszFile, SECURITY_INFORMATION si, PSECURITY_DESCRIPTOR psd ); | advapi32.dll | Cette fonction permet de fixer la sécurité d'un objet de fichier ou d'un répertoire.
SetFileSecurityW | BOOL SetFileSecurityW( LPCWSTR lpFileName, SECURITY_INFORMATION RequestedInformation, PSECURITY_DESCRIPTOR pSecurityDescriptor ); | advapi32.dll | Cette fonction permet de fixer la sécurité d'un objet de fichier ou d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
SetFileTime | BOOL SetFileTime(HANDLE hFile, CONST FILETIME * lpftCreation, CONST FILETIME * lpftLastAccess, CONST FILETIME * lpftLastWrite); | kernel32.dll | Cette fonction permet de fixer la date et l'heure de la création, du dernière accès et de la dernière modification d'un fichier.
SetFocus | HWND SetFocus(HWND hwnd); | user32.dll | Cette fonction permet de fixer le focus d'entrée de la fenêtre spécifié.
SetForegroundWindow | BOOL SetForegroundWindow(HWND hwnd); | user32.dll | Cette fonction permet de mettre le processus léger étant créer pour la fenêtre spécifié dans une fenêtre active ou de premier plan.
SetGraphicsMode | int SetGraphicsMode(HDC hdc, int iMode); | gdi32.dll | Cette fonction permet de fixer le mode graphique pour le périphérique de contexte spécifié.
SetHandleCount | UINT SetHandleCount(UINT cHandles); | kernel32.dll | Cette fonction permet de changer le nombre de fichier Handle disponible pour un processus.
SetHandleInformation | BOOL SetHandleInformation(HANDLE hObject, DWORD dwMask, DWORD dwFlags); | kernel32.dll | Cette fonction permet de fixer certaines propriétés d'un objet Handle.
SetICMMode | int SetICMMode(HDC hdc, int fICM); | gdi32.dll | Cette fonction permet d'activer ou désactiver la correspondance de couleur d'image pour le périphérique de contexte spécifié.
SetICMProfileA | BOOL SetICMProfileA(HDC hdc, LPTSTR lpFileName); | gdi32.dll | Cette fonction permet de fixer la couleur de profile pour le périphérique de contexte spécifié.
SetICMProfileW | BOOL SetICMProfileW(HDC hdc, LPWSTR lpFileName); | gdi32.dll | Cette fonction permet de fixer la couleur de profile pour le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
SetJobA | BOOL SetJobA(HANDLE hPrinter, DWORD dwJob, DWORD dwLevel, LPBYTE lpbJob, DWORD dwCommand); | winspool.drv | Cette fonction permet de fixer l'état du traitement d'un travail contenu dans le tampon d'impressions de l'imprimante.
SetKeyboardState | BOOL SetKeyboardState(LPBYTE lpbKeyState); | user32.dll | Cette fonction permet de fixer l'état des 256 touches virtuel de clavier.
SetKernelObjectSecurity | BOOL SetKernelObjectSecurity( HANDLE hObject, SECURITY_INFORMATION si, PSECURITY_DESCRIPTOR psd ); | advapi32.dll | Cette fonction permet de fixer la sécurité de l'objet du noyau du système d'exploitation.
SetLastError | VOID SetLastError(DWORD fdwError); | kernel32.dll | Cette fonction permet de fixer le code de la dernière erreur d'un appel de processus léger.
SetLastErrorEx | VOID SetLastErrorEx(DWORD fdwError, DWORD fdwType); | user32.dll | Cette fonction permet de fixer le code de la dernière erreur avec un type d'erreur.
SetLocalTime | BOOL SetLocalTime(CONST SYSTEMTIME * lpst); | kernel32.dll | Cette fonction permet de fixer la date et l'heure locale courante.
SetLocaleInfoA | BOOL SetLocaleInfoA(LCID Locale, LCTYPE LCType, LPCTSTR lpLCData); | kernel32.dll | Cette fonction permet de fixer un item d'information local.
SetLocaleInfoW | BOOL SetLocaleInfoW(LCID lcid, LCTYPE lctype, LPCWSTR data); | kernel32.dll | Cette fonction permet de fixer un item d'information local avec des paramètres de chaine de caractères étendues (Unicode).
SetMailslotInfo | BOOL SetMailslotInfo(HANDLE hMailslot, DWORD dwReadTimeout); | kernel32.dll | Cette fonction permet de fixer la valeur de dépassement de délai utilisable pour le mailslot spécifié d'une opération de lecture.
SetMapMode | int SetMapMode(HDC hdc, int fnMapMode); | gdi32.dll | Cette fonction permet de fixer le mode de cartographie d'un périphérique de contexte spécifié.
SetMapperFlags | DWORD SetMapperFlags(HDC hdc, DWORD dwFlag); | gdi32.dll | Cette fonction permet de changer la méthode utilisé pour la cartographie d'une police de caractères lors d'une conversion de police de caractères logique vers une police de caractères physique.
SetMenu | BOOL SetMenu(HWND hwnd, HMENU hmenu); | user32.dll | Cette fonction permet d'attribué un menu à une fenêtre.
SetMenuContextHelpId | BOOL SetMenuContextHelpId(HMENU hmenu, DWORD dwContextHelpId); | user32.dll | Cette fonction permet d'associer un identificateur de contexte d'aide avec un menu.
SetMenuDefaultItem | BOOL SetMenuDefaultItem(HMENU hMenu, UINT uItem, UINT fByPos); | user32.dll | Cette fonction permet de fixer l'item par défaut d'un menu déroulant.
SetMenuItemBitmaps | BOOL SetMenuItemBitmaps(HMENU hmenu, UINT uItem, UINT fuFlags, HBITMAP hbmUnchecked, HBITMAP hbmChecked); | user32.dll | Cette fonction permet d'associer le Bitmap donnée avec un item de menu.
SetMenuItemInfoA | BOOL SetMenuItemInfoA(HMENU hMenu, UINT uItem, BOOL fByPosition, LPMENUITEMINFO lpmii); | user32.dll | Cette fonction permet de modifier les informations conçernant un item de menu.
SetMenuItemInfoW | BOOL SetMenuItemInfoW(HMENU hMenu, UINT uItem, BOOL fByPosition, LPCMENUITEMINFOW lpmii); | user32.dll | Cette fonction permet de modifier les informations conçernant un item de menu avec des paramètres de chaine de caractères étendues (Unicode).
SetMessageQueue | BOOL SetMessageQueue(int cMessagesMax); | user32.dll | Cette fonction permet de créer un nouveau message dans la file d'attente.
SetMetaFileBitsEx | HMETAFILE SetMetaFileBitsEx(UINT nSize, CONST BYTE * lpData); | gdi32.dll | Cette fonction permet de créer un fichier méta de format Windows, basé en mémoire, pour les données fournit.
SetMetaRgn | int SetMetaRgn(HDC hdc); | gdi32.dll | Cette fonction permet d'effectuer l'intersection de la région de capture courante pour le périphérique de contexte spécifié avec la région méta courante et sauvegarde la combinaison des régions dans une nouvelle région méta.
SetMiterLimit | BOOL SetMiterLimit(HDC hdc, FLOAT eNewLimit, PFLOAT peOldLimit); | gdi32.dll | Cette fonction permet de fixer la limite pour la longueur d'une jointure de mitre pour le périphérique de contexte spécifié.
SetNamedPipeHandleState | BOOL SetNamedPipeHandleState(HANDLE hNamedPipe, LPDWORD lpdwMode, LPDWORD lpcbMaxCollect, LPDWORD lpdwCollectDataTimeout); | kernel32.dll | Cette fonction permet de fixer le mode de lecture et le mode de bloc d'un tuyau nommé spécifié.
SetPaletteEntries | UINT SetPaletteEntries(HPALETTE hpal, UINT iStart, UINT cEntries, CONST PALETTEENTRY *lppe); | gdi32.dll | Cette fonction permet de fixer les valeurs de couleurs RVB (ou RGB en anglais) et les drapeaux d'un rang des entrées dans une palette logique spécifié.
SetParent | HWND SetParent(HWND hwndChild, HWND hwndNewParent); | user32.dll | Cette fonction permet de transférer un objet d'une fenêtre vers une autre.
SetPixel | COLORREF SetPixel(HDC hdc, int X, int Y, COLORREF crColor); | gdi32.dll | Cette fonction permet de fixer la couleur sous format RVB (RGB) d'un pixel affiché à l'écran.
SetPixelFormat | BOOL SetPixelFormat(HDC hdc, int iPixelFormat, const PIXELFORMATDESCRIPTOR *ppfd); | gdi32.dll | Cette fonction permet de fixer le format de pixel du périphérique de contexte spécifié au format spécifié par l'index spécifié.
SetPixelV | BOOL SetPixelV(HDC hdc, int X, int Y, COLORREF crColor); | gdi32.dll | Cette fonction permet de fixer le pixel aux coordonnées de fermeture approximatifs spécifiées avec la couleur spécifié.
SetPolyFillMode | int SetPolyFillMode(HDC hdc, int iPolyFillMode); | gdi32.dll | Cette fonction permet de fixer le mode de remplissage d'un polygone spécifié.
SetPrinterA | BOOL SetPrinterA(HANDLE hPrinter, DWORD dwLevel, LPBYTE lpbPrinter, DWORD dwCommand); | winspool.drv | Cette fonction permet d'envoyer une commande à l'imprimante.
SetPriorityClass | BOOL SetPriorityClass(HANDLE hProcess, DWORD fdwPriority); | kernel32.dll | Cette fonction permet de fixer la priorité d'une classe pour le processus spécifié.
SetPrivateObjectSecurity | BOOL SetPrivateObjectSecurity( SECURITY_INFORMATION si, PSECURITY_DESCRIPTOR psdSource, PSECURITY_DESCRIPTOR *lppsdTarget, PGENERIC_MAPPING pgm, HANDLE hClientToken ); | advapi32.dll | Cette fonction permet de modifier un descripteur de sécurité d'objet privé.
SetProcessAffinityMask | BOOL SetProcessAffinityMask(HANDLE hProcess, DWORD_PTR dwProcessAffinityMask); | kernel32.dll | Cette fonction permet de fixer un masque d'affinité de processeur pour le processus léger d'un processus spécifié.
SetProcessPriorityBoost | BOOL SetProcessPriorityBoost(HANDLE hProcess, BOOL DisablePriorityBoost); | kernel32.dll | Cette fonction permet d'activer ou désactiver les habilitées du système pour stimuler temporairement la priorité d'un processus léger dans un processus spécifié.
SetProcessShutdownParameters | BOOL SetProcessShutdownParameters(DWORD dwLevel, DWORD dwFlags); | kernel32.dll | Cette fonction permet de fixer les paramètres de fermeture du système pour le processus appelant courant.
SetProcessWindowStation | BOOL SetProcessWindowStation(HWINSTA hWinSta); | user32.dll | Cette fonction permet de fixer une fenêtre de station vers un processus appellant.
SetProcessWorkingSetSize | BOOL SetProcessWorkingSetSize(HANDLE hProcess, DWORD dwMinimumWorkingSetSize, DWORD dwMaximumWorkingSetSize); | kernel32.dll | Cette fonction permet de fixer la taille du travail minimum et maximum d'un processus spécifié.
SetPropA | BOOL SetPropA(HWND hwnd, LPCTSTR lpsz, HANDLE hData); | user32.dll | Cette fonction permet d'ajouter une nouvelle entrée ou changer une entrée existante dans la liste de propriété d'une fenêtre spécifié.
SetPropW | BOOL SetPropW(HWND hwnd, LPCWSTR lpsz, HANDLE hData); | user32.dll | Cette fonction permet d'ajouter une nouvelle entrée ou changer une entrée existante dans la liste de propriété d'une fenêtre spécifié avec des paramètres de chaine de caractères étendues (Unicode).
SetRect | BOOL SetRect(LPRECT lprc, int nLeft, int nTop, int nRight, int nBottom); | user32.dll | Cette fonction permet de fixer la taille et la position d'un rectangle.
SetRectEmpty | BOOL SetRectEmpty(LPRECT lprc); | user32.dll | Cette fonction permet de créer un rectangle vide (tous les coordonnées sont fixées à 0).
SetRectRgn | BOOL SetRectRgn(HRGN hrgn, int nLeftRect, int nTopRect, int nRightRect, int nBottomRect); | gdi32.dll | Cette fonction permet de changer la région spécifié dans un région rectangulaire avec les coordonnées spécifiés.
SetROP2 | int SetROP2(HDC hdc, int fnDrawMode); | gdi32.dll | Cette fonction permet de fixer le mode de dessinage courant.
SetScrollInfo | int SetScrollInfo(HWND hwnd, int fnBar, LPSCROLLINFO lpsi, BOOL fRedraw); | user32.dll | Cette fonction permet de fixer les paramètres de barre de défilement, en incluant les positions minimums et maximums, la taille de la page et la position de la boite de défilement.
SetScrollPos | int SetScrollPos(HWND hwnd, int fnBar, int nPos, BOOL fRedraw); | user32.dll | Cette fonction permet de fixer la position d'une boite de défilement et, si requis, redessiner la barre de défilement reflétant la nouvelle position de la boite de défilement.
SetScrollRange | BOOL SetScrollRange(HWND hwnd, int fnBar, int nMinPos, int nMaxPos, BOOL fRedraw); | user32.dll | Cette fonction permet de fixer les valeurs de position minimum et maximum de la barre de défilement spécifié.
SetSecurityDescriptorDacl | BOOL SetSecurityDescriptorDacl( PSECURITY_DESCRIPTOR psd, BOOL fDaclPresent, PACL pAcl, BOOL fDaclDefaulted ); | advapi32.dll | Cette fonction permet de fixer les informations dans une liste de contrôle d'accès (ACL) discrétionnaire.
SetSecurityDescriptorGroup | BOOL SetSecurityDescriptorGroup( PSECURITY_DESCRIPTOR psd, PSID psidGroup, BOOL fGroupDefaulted ); | advapi32.dll | Cette fonction permet de fixer le groupe primaire d'information d'un format absolue de descripteur de sécurité, remplacer par un groupe d'information primaire déjà présent dans un descripteur de sécurité.
SetSecurityDescriptorOwner | BOOL SetSecurityDescriptorOwner( PSECURITY_DESCRIPTOR psd, PSID psidOwner, BOOL fOwnerDefaulted ); | advapi32.dll | Cette fonction permet de fixer les informations de propriétaire d'un format absolue de descripteur de sécurité.
SetSecurityDescriptorSacl | BOOL SetSecurityDescriptorSacl( PSECURITY_DESCRIPTOR psd, BOOL fSaclPresent, PACL pAcl, BOOL fSaclDefaulted ); | advapi32.dll | Cette fonction permet de fixer les informations d'une liste de contrôle d'accès (ACL) système.
SetStdHandle | BOOL SetStdHandle(DWORD IDStdHandle, HANDLE hHandle); | kernel32.dll | Cette fonction permet d'utiliser un ensemble de gestionnaire pour l'entrée standard, la sortie standard ou le périphérique d'erreur standard.
SetStretchBltMode | int SetStretchBltMode(HDC hdc, int iStretchMode); | gdi32.dll | Cette fonction permet de fixer le mode d'étirement Bitmap.
SetSysColors | BOOL WINAPI SetSysColors(int cDspElements, CONST INT *lpnDspElements, CONST COLORREF *lpdwRgbValues); | user32.dll | Cette fonction permet de fixer la/les couleurs d'un/des objet(s) affiché(s) du système d'exploitations Windows.
SetSystemCursor | BOOL SetSystemCursor(HCURSOR hCursor, DWORD dwCursorID); | user32.dll | Cette fonction permet de modifier un des curseurs qu'utilise le système d'exploitations Windows.
SetSystemPaletteUse | UINT SetSystemPaletteUse(HDC hdc, UINT uUsage); | gdi32.dll | Cette fonction permet de fixer l'utilisation de la couleur statique dans une palette du système.
SetSystemPowerState | BOOL SetSystemPowerState(BOOL fSuspend, BOOL fForce); | kernel32.dll | Cette fonction permet de fixer l'état de l'alimentation en énergie de l'ordinateur.
SetSystemTime | BOOL SetSystemTime(CONST SYSTEMTIME * lpst); | kernel32.dll | Cette fonction permet de fixer la date et l'heure système courante.
SetSystemTimeAdjustment | BOOL SetSystemTimeAdjustment(DWORD dwTimeAdjustment, PBOOL bTimeAdjustmentDisabled); | kernel32.dll | Cette fonction permet d'activer ou désactiver l'ajustement du temps périodique de l'horloge de l'heure de la journée.
SetTapeParameters | DWORD SetTapeParameters(HANDLE hDevice, DWORD dwOperation, LPVOID lpTapeInformation); | kernel32.dll | Cette fonction permet de fixer la taille d'un bloc de bande magnétique ou configure le périphérique de bande magnétique.
SetTapePosition | DWORD SetTapePosition(HANDLE hDevice, DWORD dwPositionMethod, DWORD dwPartition, DWORD dwOffsetLow, DWORD dwOffsetHigh, BOOL bImmediate); | kernel32.dll | Cette fonction permet de fixer la position de la bande magnétique dans un périphérique spécifié.
SetTextAlign | UINT SetTextAlign(HDC hdc, UINT fMode); | gdi32.dll | Cette fonction permet de fixer le contexte d'alignement d'un objet de texte.
SetTextColor | COLORREF SetTextColor(HDC hdc, COLORREF crColor); | gdi32.dll | Cette fonction permet de fixer la couleur du texte de la couleur spécifié.
SetTextCharacterExtra | int SetTextCharacterExtra(HDC hdc, int nCharExtra); | gdi32.dll | Cette fonction permet de fixer le quantité d'espacement entre les caractères.
SetTextJustification | BOOL SetTextJustification(HDC hdc, int nBreakExtra, int nBreakCount); | gdi32.dll | Cette fonction permet d'ajouter de l'espacement dans les caractères de saut d'une chaine de caractères.
SetThreadAffinityMask | DWORD SetThreadAffinityMask(HANDLE hThread, DWORD dwThreadAffinityMask); | kernel32.dll | Cette fonction permet de fixer le masque d'affinité du microprocesseur pour le processus léger spécifié.
SetThreadContext | BOOL SetThreadContext(HANDLE hThread, CONST CONTEXT * lpContext); | kernel32.dll | Cette fonction permet de fixer le contexte d'un processus léger spécifié.
SetThreadDesktop | BOOL SetThreadDesktop(HDESK hDesk); | user32.dll | Cette fonction permet de fixer le bureau au processus léger appellant.
SetThreadIdealProcessor | DWORD SetThreadIdealProcessor(HANDLE hThread, DWORD dwIdealProcessor); | kernel32.dll | Cette fonction permet de fixer le microprocesseur préféré pour un processus léger.
SetThreadLocale | BOOL SetThreadLocale(LCID Locale); | kernel32.dll | Cette fonction permet de fixer l'appel de processus léger locale courant.
SetThreadPriority | BOOL SetThreadPriority(HANDLE hThread, int nPriority); | kernel32.dll | Cette fonction permet de fixer la valeur de priorité pour le processus léger spécifié.
SetThreadPriorityBoost | BOOL SetThreadPriorityBoost(HANDLE hThread, BOOL DisablePriorityBoost); | kernel32.dll | Cette fonction permet d'activer ou désactiver l'habilité d'un système à temporairement stimuler la priorité d'un processus léger.
SetThreadToken | BOOL SetThreadToken( PHANDLE Thread, HANDLE Token ); | advapi32.dll | Cette fonction permet de fixer une personnification de jeton à un processus léger.
SetTimer | UINT SetTimer(HWND hwnd, UINT idTimer, UINT uTimeout, TIMERPROC tmprc); | user32.dll | Cette fonction permet d'installer une minuterie système.
SetTimeZoneInformation | BOOL SetTimeZoneInformation(CONST TIME_ZONE_INFORMATION * lptzi); | kernel32.dll | Cette fonction permet de fixer les paramètres de fuseau horaire courant.
SetTokenInformation | BOOL SetTokenInformation( HANDLE hToken, TOKEN_INFORMATION_CLASS tic, LPVOID lpvInformation, DWORD cbInformation ); | advapi32.dll | Cette fonction permet de fixer une variété de type d'information pour un accès à un jeton spécifié.
SetUnhandledExceptionFilter | LPTOP_LEVEL_EXCEPTION_FILTER SetUnhandledExceptionFilter(LPTOP_LEVEL_EXCEPTION_FILTER lpTopLevelExceptionFilter); | kernel32.dll | Cette fonction permet à une application de remplacer le gestionnaire d'exception de bas niveau dans les places Win32 du haut de chaque processus léger et processus.
SetupComm | BOOL SetupComm(HANDLE hCommDev, DWORD cbInQueue, DWORD cbOutQueue); | kernel32.dll | Cette fonction permet d'initialiser les paramètres de communications pour un périphérique de communications spécifié.
SetupCopyErrorA | UINT SetupCopyErrorA( HWND hwndParent, PCTSTR DialogTitle, PCTSTR DiskName, PCTSTR PathToSource, PCTSTR SourceFile, PCTSTR TargetPathFile, UINT Win32ErrorCode, DWORD Style, PTSTR PathBuffer, DWORD PathBufferSize, PDWORD PathRequiredSize ); | setupapi.dll | Cette fonction permet d'afficher une boite de dialogue pour indiquer à l'utilisateur qu'une erreur pendant la copie s'est produit.
SetupDeleteErrorA | UINT SetupDeleteErrorA( HWND hwndParent, PCTSTR DialogTitle, PCTSTR File, UINT Win32ErrorCode, DWORD Style ); | setupapi.dll | Cette fonction permet d'afficher une boite de dialogue pour indiquer à l'utilisateur qu'une erreur pendant l'effacement d'un fichier s'est produit.
SetUserObjectInformationA | BOOL SetUserObjectInformationA(HANDLE hObject, int nIndex, PVOID lpvInfo, DWORD cbInfo); | user32.dll | Cette fonction permet de fixer les informations à propos d'une fenêtre de station ou d'un objet de bureau.
SetUserObjectInformationW | BOOL SetUserObjectInformationW(HANDLE hObject, int nIndex, PVOID lpvInfo, DWORD cbInfo); | user32.dll | Cette fonction permet de fixer les informations à propos d'une fenêtre de station ou d'un objet de bureau avec des paramètres de chaine de caractères étendues (Unicode).
SetUserObjectSecurity | BOOL SetUserObjectSecurity(HANDLE hObject, PSECURITY_INFORMATION psi, PSECURITY_DESCRIPTOR psd); | user32.dll | Cette fonction permet de fixer la sécurité d'un objet utilisateur.
SetViewportExtEx | BOOL SetViewportExtEx(HDC hdc, int nXExtent, int nYExtent, LPSIZE lpSize); | gdi32.dll | Cette fonction permet de fixer les extensions X et Y d'un point de vue d'un périphérique de contexte spécifié.
SetViewportOrgEx | BOOL SetViewportOrgEx(HDC hdc, int X, int Y, LPPOINT lpPoint); | gdi32.dll | Cette fonction permet de fixer le point de vue d'origine d'un périphérique de contexte spécifié.
SetVolumeLabelA | BOOL SetVolumeLabelA(LPCTSTR lpRootPathName, LPCTSTR lpVolumeName); | kernel32.dll | Cette fonction permet de fixer le nom de volume d'une unité de disque.
SetVolumeLabelW | BOOL SetVolumeLabelW(LPCWSTR lpRootPathName, PCWSTR lpVolumeName); | kernel32.dll | Cette fonction permet de fixer le nom de volume d'une unité de disque avec des paramètres de chaine de caractères étendues (Unicode).
SetWaitableTimer | BOOL SetWaitableTimer(HANDLE hTimer, const LARGE_INTEGER *pDueTime, LONG lPeriod, PTIMERAPCROUTINE pfnCompletionRoutine, LPVOID lpArgToCompletionRoutine, BOOL fResume); | kernel32.dll | Cette fonction permet d'activer la minuterie d'attente spécifié.
SetWindowContextHelpId | BOOL SetWindowContextHelpId(HWND hwnd, DWORD dwContextHelpId); | user32.dll | Cette fonction permet d'associer un identificateur de contexte d'aide avec la fenêtre spécifié.
SetWindowLongA | LONG SetWindowLongA(HWND hwnd, int nIndex, LONG lNewLong); | user32.dll | Cette fonction permet de placer une valeur 32 bits dans le déplacement spécifié dans une fenêtre en mémoire supplémentaire pour la fenêtre spécifié.
SetWindowLongW | LONG SetWindowLongW(HWND hwnd, int nIndex, LONG lNewLong); | user32.dll | Cette fonction permet de placer une valeur 32 bits dans le déplacement spécifié dans une fenêtre en mémoire supplémentaire pour la fenêtre spécifié avec des paramètres de chaine de caractères étendues (Unicode).
SetWindowPlacement | BOOL SetWindowPlacement(HWND hwnd, CONST WINDOWPLACEMENT * lpwndpl); | user32.dll | Cette fonction permet de fixer l'état d'affichage et de restituer, minimiser et maximiser les positions d'une fenêtre.
SetWindowPos | BOOL SetWindowPos(HWND hwnd, HWND hwndInsertAfter, int x, int y, int cx, int cy, UINT fuFlags); | user32.dll | Cette fonction permet de fixer la position d'une fenêtre à une nouvelle coordonnées à l'écran.
SetWindowRgn | int SetWindowRgn(HWND hWnd, HRGN hRgn, BOOL bRedraw); | user32.dll | Cette fonction permet de fixer la région de fenêtre dans une fenêtre.
SetWindowsHookA | HHOOK SetWindowsHookA(int idHook, HOOKPROC hkprc); | user32.dll | Cette fonction permet d'installer une fonction de crochet utilisateur dans une chaine de crochet.
SetWindowsHookExA | HHOOK SetWindowsHookExA(int idHook, HOOKPROC hkprc, HINSTANCE hMod, DWORD dwThreadID); | user32.dll | Cette fonction permet d'installer un crochet de fonction utilisateur dans une chaine de crochet.
SetWindowsHookExW | HHOOK SetWindowsHookExW(int idHook, HOOKPROC hkprc, HINSTANCE hMod, DWORD dwThreadID); | user32.dll | Cette fonction permet d'installer un crochet de fonction utilisateur dans une chaine de crochet avec des paramètres de chaine de caractères étendues (Unicode).
SetWindowsHookW | HHOOK SetWindowsHookW(int idHook, HOOKPROC hkprc); | user32.dll | Cette fonction permet d'installer une fonction de crochet utilisateur dans une chaine de crochet avec des paramètres de chaine de caractères étendues (Unicode).
SetWindowTextA | BOOL SetWindowTextA(HWND hwnd, LPCTSTR lpsz); | user32.dll | Cette fonction permet de définir le contenu texte d'une fenêtre.
SetWindowTextW | BOOL SetWindowTextW(HWND hwnd, LPCWSTR lpsz); | user32.dll | Cette fonction permet de définir le contenu texte d'une fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
SetWindowWord | WORD SetWindowWord(HWND hwnd, int nIndex, WORD wNewWord); | user32.dll | Cette fonction permet de placer une valeur 16 bits dans le déplacement spécifié dans une fenêtre en mémoire supplémentaire pour la fenêtre spécifié.
SetWinMetaFileBits | HENHMETAFILE SetWinMetaFileBits(UINT cbBuffer, CONST BYTE * lpbBuffer, HDC hdcRef, CONST METAFILEPICT * lpmfp); | gdi32.dll | Cette fonction permet de convertir un fichier méta d'un ancien format Windows vers un nouveau format étendue et entrepose le fichier méta en mémoire.
SetWindowOrgEx | BOOL SetWindowOrgEx(HDC hdc, int X, int Y, LPPOINT lpPoint); | gdi32.dll | Cette fonction permet de fixer la fenêtre d'origine d'un périphérique de contexte spécifié.
SetWorldTransform | BOOL SetWorldTransform(HDC hdc, CONST XFORM * lpXform); | gdi32.dll | Cette fonction permet de fixer une transformation de double dimensions linéaire entre l'espace mondiale et l'espace de page pour le périphérique de contexte spécifié.
SHAddToRecentDocs | WINSHELLAPI void WINAPI SHAddToRecentDocs(UINT uFlags, LPCVOID pv); | shell32.dll | Cette fonction permet d'ajouter un lien vers un document dans la liste des documents récamment utilisé.
SHAppBarMessage | WINSHELLAPI UINT APIENTRY SHAppBarMessage(DWORD dwMessage, PAPPBARDATA pabd); | shell32.dll | Cette fonction permet d'envoyer des commandes à la barre de tâche.
SHBrowseForFolder | WINSHELLAPI LPITEMIDLIST WINAPI SHBrowseForFolder(LPBROWSEINFO lpbi); | shell32.dll | Cette fonction permet d'afficher la boite de dialogue sélectionnant un répertoire.
SHCopyKeyA | DWORD SHCopyKeyA(HKEY hKeySrc, LPCSTR lpszSrcSubKey, HKEY hKeyDst, DWORD dwReserved); | shell32.dll | Cette fonction permet de copier les clefs de registre d'un répertoire à un autre dans la base de registres en tenant compte de bien copier toutes les sous-branches de répertoire inclus dans la clef source.
ShellAboutA | int ShellAboutA(HWND hWnd, LPCTSTR szApp, LPCTSTR szOtherStuff, HICON hIcon); | shell32.dll | Cette fonction permet d'afficher la boite de dialogue «A propos» de l'application spécifié.
ShellExecuteA | HINSTANCE ShellExecuteA( HWND hwnd, LPCTSTR lpOperation, LPCTSTR lpFile, LPTSTR lpParameters, LPCTSTR lpDirectory, INT nShowCmd ); | shell32.dll | Cette fonction permet de lancer une application externe.
ShellExecuteEx | WINSHELLAPI BOOL WINAPI ShellExecuteEx(LPSHELLEXECUTEINFO lpExecInfo); | shell32.dll | Cette fonction permet de lancer une application externe en utilisant l'interpréteur de commande (Shell) du système d'exploitation Windows.
Shell_NotifyIconA | BOOL Shell_NotifyIconA( DWORD dwMessage, PNOTIFYICONDATA lpdata); | shell32.dll | Cette fonction permet d'effectuer l'action d'ajouter, modifier ou supprimer une icône dans la barre de tâche.
SHEmptyRecycleBinA | HRESULT SHEmptyRecycleBinA( HWND hwnd, LPCTSTR pszRootPath, DWORD dwFlags); | shell32.dll | Cette fonction permet de vider le contenu de la corbeille.
SHFileOperationA | WINSHELLAPI int WINAPI SHFileOperationA(LPSHFILEOPSTRUCT lpFileOp); | shell32.dll | Cette fonction permet d'effectuer une copie, renommer, déplacer ou de supprimer un objet de fichier.
SHFormatDrive | DWORD SHFormatDrive( HWND hwnd, UINT drive, UINT fmtID, UINT options); | shell32.dll | Cette fonction permet d'effectuer le formattage d'une unité de disque.
SHGetPathFromIDList | WINSHELLAPI BOOL WINAPI SHGetPathFromIDList(LPCITEMIDLIST pidl, LPSTR pszPath); | shell32.dll | Cette fonction permet de retourner un pointeur dans un arbre de répertoire à l'emplacement ou se trouve un fichier.
ShowCaret | BOOL ShowCaret(HWND hwnd); | user32.dll | Cette fonction permet d'afficher un caret à l'écran à la position courant du caret.
ShowCursor | int ShowCursor( BOOL bShow); | user32.dll | Cette fonction permet d'afficher ou de faire disparaitre le pointeur de la souris.
ShowOwnedPopups | BOOL ShowOwnedPopups(HWND hwnd, BOOL fShow); | user32.dll | Cette fonction permet d'afficher ou de cacher tous les fenêtres POP-UP du propriétaire de la fenêtre spécifié.
ShowScrollBar | BOOL ShowScrollBar(HWND hwnd, int fnBar, BOOL fShow); | user32.dll | Cette fonction permet d'afficher ou de faire disparaitre la barre de défilement d'une fenêtre ou d'un objet.
ShowWindow | BOOL ShowWindow( HWND hwnd, int nCmdShow); | user32.dll | Cette fonction permet de définir l'état visuel d'une fenêtre d'application.
ShowWindowAsync | BOOL ShowWindowAsync(HWND hwnd, int nCmdShow); | user32.dll | Cette fonction permet de fixer l'affichage d'état de la création d'une fenêtre par différent processus léger.
SHSetValueA | DWORD SHSetValueA(HKEY hKey, LPCSTR lpszSubKey, LPCSTR lpszValue, DWORD dwType, LPCVOID pvData, DWORD cbData); | shlwapi.dll | Cette fonction permet de fixer une valeur dans la base de registres.
SignalObjectAndWait | DWORD SignalObjectAndWait(HANDLE hObjectToSignal, HANDLE hObjectToWaitOn, DWORD dwMilliseconds, BOOL bAlertable); | kernel32.dll | Cette fonction permet de signaler un objet et d'attendre après un autre objet, une simple opération.
SizeofResource | DWORD SizeofResource(HINSTANCE hModule, HRSRC hrsrc); | kernel32.dll | Cette fonction permet de demander la taille, en octets, d'une ressource spécifié.
Sleep | VOID Sleep(DWORD cMilliseconds); | kernel32.dll | Cette fonction permet de faire passer en mode d'attente pendant un certain délai en milliseconde le processus courant.
SleepEx | DWORD SleepEx(DWORD dwTimeout, BOOL fAlertable); | kernel32.dll | Cette fonction permet de faire en sorte que le processus léger courant entre dans un état d'attente jusqu'à ce que l'intervalle de temps spécifié est passé ou jusqu'à l'achèvement d'une fonction d'appel arrière d'entrée/sortie soit appelé.
sndPlaySoundA | BOOL sndPlaySoundA(LPCSTR lpszSound, UINT fuSound); | winmm.dll | Cette fonction permet de faire jouer un son de format Wave à partir d'un fichier.
SQLAllocConnect | RETCODE SQLAllocConnect(HENV henv, HDBC FAR * phdbc); | odbc32.dll | Cette fonction permet d'effectuer de l'allocation de mémoire pour un identificateur de connexion ODBC avec un environnement spécifié.
SQLAllocEnv | RETCODE SQLAllocEnv(HENV FAR *phenv); | odbc32.dll | Cette fonction permet d'effectuer de l'allocation de mémoire pour un identificateur d'environnement ODBC.
SQLAllocStmt | RETCODE SQLAllocStmt(HDBC hdbc, HSTMT FAR * phstmt); | odbc32.dll | Cette fonction permet d'effectuer de l'allocation de mémoire pour un identificateur d'instruction ODBC.
SQLBindCol | UL_FN_SPEC SQLRETURN UL_FN_MOD SQLBindCol( SQLHSTMT StatementHandle, SQLUSMALLINT ColumnNumber, SQLSMALLINT TargetType, SQLPOINTER TargetValue, SQLLEN BufferLength, SQLLEN * pcbValue); | odbc32.dll | Cette fonction permet d'effectuer de la lecture d'une colonne du résultat d'une requête par ODBC.
SQLBindParameter | SQLRETURN SQLBindParameter( SQLHSTMT StatementHandle, SQLUSMALLINT ParameterNumber, SQLSMALLINT InputOutputType, SQLSMALLINT ValueType, SQLSMALLINT ParameterType, SQLUINTEGER ColumnSize, SQLSMALLINT DecimalDigits, SQLPOINTER ParameterValuePtr, SQLINTEGER BufferLength, SQLINTEGER * StrLen_or_IndPtr); | odbc32.dll | Cette fonction permet d'envoyer un tampon de paramètres dans une instruction SQL par ODBC.
SQLConfigDataSource | BOOL SQLConfigDataSource( HWND hwndParent, WORD fRequest, LPCSTR lpszDriver, LPCSTR lpszAttributes); | odbccp32.dll | Cette fonction permet d'envoyer des commandes au pilote ODBC (Open Data Base Connectivity).
StartDocA | int StartDocA( HDC hdc, CONST DOCINFO * lpdi); | gdi32.dll | Cette fonction permet d'indiquer le commencement d'un travail d'impression pour l'imprimante.
StartDocW | int StartDocW(HDC hdc, CONST DOCINFOW * lpdi); | gdi32.dll | Cette fonction permet d'indiquer le commencement d'un travail d'impression pour l'imprimante avec des paramètres de chaine de caractères étendues (Unicode).
StartPage | int StartPage(HDC hDC); | gdi32.dll | Cette fonction permet d'indiquer le début d'une page de document pour l'impression pour l'imprimante.
StretchBlt | BOOL StretchBlt( HDC hdcDest, int nXOriginDest, int nYOriginDest, int nWidthDest, int nHeightDest, HDC hdcSrc, int nXOriginSrc, int nYOriginSrc, int nWidthSrc, int nHeightSrc, DWORD dwRop ); | gdi32.dll | Cette fonction permet de copier un morceau dans une autre image.
StretchDIBits | int StretchDIBits(HDC hdc, int XDest, int YDest, int nDestWidth, int nDestHeight, int XSrc, int YSrc, int nSrcWidth, int nSrcHeight, CONST VOID *lpBits, CONST BITMAPINFO * lpBitsInfo, UINT iUsage, DWORD dwRop); | gdi32.dll | Cette fonction permet de copier les données de couleur d'un rectangle de pixels dans un DIB de la destination rectangulaire spécifié.
StrIsIntlEqualA | BOOL StrIsIntlEqualA(BOOL fCaseSens, LPCTSTR String1, LPCTSTR String2, INT nChar); | shlwapi.dll | Cette fonction permet de comparer le début de deux chaines de caractères ASCIZ.
StrNCatA | LPSTR StrNCatA(LPSTR lpszStr, LPCSTR lpszCat, INT cchMax); | shlwapi.dll | Cette fonction permet d'ajouter à la fin d'une chaine de caractères ASCIZ le contenu d'une chaine de caractères ASCIZ.
StrokeAndFillPath | BOOL StrokeAndFillPath(HDC hdc); | gdi32.dll | Cette fonction permet de fermer n'importe quel figures ouvertes dans un chemin, traitant les lignes en dehors du chemin en utilisant le crayon courant, et remplissant l'intérieur en utilisant la brosse.
StrokePath | BOOL StrokePath(HDC hdc); | gdi32.dll | Cette fonction permet d'effectuer un traitement d'un chemin spécifié en utilisant le crayon courant.
StrToIntExA | BOOL StrToIntExA( LPCSTR lpszStr, DWORD dwFlags, LPINT lpiRet); | shlwapi.dll | Cette fonction permet de convertir une chaine de caractères ASCIZ ayant un nombre décimal ou hexadécimal en une valeur numérique entière.
StrTrimA | BOOL StrTrimA( LPSTR lpszStr, LPCSTR lpszTrim); | shlwapi.dll | Cette fonction permet d'enlever les caractères spécifié au début et à la fin d'une chaine de caractères ASCIZ.
SubtractRect | BOOL SubtractRect(LPRECT lprcDest, CONST RECT * lprcSrc1, CONST RECT * lprcSrc2); | user32.dll | Cette fonction permet de demander les coordonnées d'un rectangle par soustraction d'un rectangle par un autre.
SuspendThread | DWORD SuspendThread(HANDLE hThread); | kernel32.dll | Cette fonction permet de suspendre le processus léger spécifié.
SwapBuffers | BOOL SwapBuffers(HDC hdc); | gdi32.dll | Cette fonction permet d'échanger le tampon de premier plan avec l'arrière-plan si le format du pixel courant pour la fenêtre est référencée par le périphérique de contexte spécifié inclus dans le tampon d'arrière plan.
SwapMouseButton | BOOL SwapMouseButton(BOOL fSwap); | user32.dll | Cette fonction permet d'échanger le comportement des boutons de gauche de la souris devienne celui de droite et que celui de droite devienne celui de gauche.
SwitchDesktop | BOOL SwitchDesktop(HDESK hDesk); | user32.dll | Cette fonction permet de fixer le bureau visible et actif.
SwitchToFiber | VOID SwitchToFiber(LPVOID lpFiber); | kernel32.dll | Cette fonction permet de planifier une fibre.
SwitchToThread | BOOL SwitchToThread(void); | kernel32.dll | Cette fonction permet de provoquer l'exécution d'un rendement de processus léger vers un autre processus léger étant prêt a être exécuté par le microprocesseur courant.
SystemParametersInfoA | BOOL SystemParametersInfoA(UINT uiAction, UINT uiParam, PVOID pvParam, UINT fWinIni); | user32.dll | Cette fonction permet de fixer certain paramètre du système d'exploitation Windows.
SystemParametersInfoW | BOOL SystemParametersInfoW(UINT uiAction, UINT uiParam, PVOID pvParam, UINT fWinIni); | user32.dll | Cette fonction permet de fixer certain paramètre du système d'exploitation Windows avec des paramètres de chaine de caractères étendues (Unicode).
SystemTimeToFileTime | BOOL SystemTimeToFileTime(CONST SYSTEMTIME * lpst, LPFILETIME lpft); | kernel32.dll | Cette fonction permet de convertir le temps système vers le temps fichier.
SystemTimeToTzSpecificLocalTime | BOOL SystemTimeToTzSpecificLocalTime(LPTIME_ZONE_INFORMATION lpTimeZoneInformation, LPSYSTEMTIME lpUniversalTime, LPSYSTEMTIME lpLocalTime); | kernel32.dll | Cette fonction permet de convertir l'UTC (Coordinated Universal Time) vers un fuseau horaire spécifié correspondant au temps locale.
TabbedTextOutA | LONG TabbedTextOutA(HDC hdc, int x, int y, LPCTSTR lpString, int nCount, int nTabPositions, LPINT lpnTabStopPositions, int nTabOrigin); | user32.dll | Cette fonction permet d'écrire une chaine de caractères à l'emplacement spécifié, en étendant la tabulation des valeurs spécifiés dans des positions d'une tableau de tabulation sans arrêt.
TabbedTextOutW | LONG TabbedTextOutW(HDC hdc, int x, int y, LPCWSTR lpString, int nCount, int nTabPositions, LPINT lpnTabStopPositions, int nTabOrigin); | user32.dll | Cette fonction permet d'écrire une chaine de caractères à l'emplacement spécifié, en étendant la tabulation des valeurs spécifiés dans des positions d'une tableau de tabulation sans arrêt avec des paramètres de chaine de caractères étendues (Unicode).
TerminateProcess | BOOL TerminateProcess(HANDLE hProcess, UINT uExitCode); | kernel32.dll | Cette fonction permet de terminer le processus spécifié et tous ses processus légers.
TerminateThread | BOOL TerminateThread(HANDLE hThread, DWORD dwExitCode); | kernel32.dll | Cette fonction permet de terminer le processus léger spécifié.
TextOutA | BOOL TextOutA(HDC hdc, int nXStart, int nYStart, LPCTSTR lpString, int cbString); | gdi32.dll | Cette fonction permet d'afficher une chaine de caractères dans une fenêtre d'application.
TextOutW | BOOL TextOutW(HDC hdc, int nXStart, int nYStart, LPCWSTR lpString, int cbString); | gdi32.dll | Cette fonction permet d'afficher une chaine de caractères dans une fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
TileWindows | WORD WINAPI TileWindows( HWND hwndParent, WORD wFlags, LPCRECT lpRect, WORD cChildrenb, const HWND FAR *ahwndChildren ); | user32.dll | Cette fonction permet de présenter sous forme mosaïque les sous-fenêtre d'une fenêtre d'application MDI.
TlsAlloc | DWORD TlsAlloc(VOID); | kernel32.dll | Cette fonction permet d'allouer un processus léger d'entrepose d'index locale (TLS).
TlsFree | BOOL TlsFree(DWORD dwTlsIndex); | kernel32.dll | Cette fonction permet de libérer un processus léger d'entrepose d'index locale (TLS).
TlsGetValue | LPVOID TlsGetValue(DWORD dwTlsIndex); | kernel32.dll | Cette fonction permet de demander la valeur dans un appel de processus d'entreposage d'une fente locale (TLS) pour un index TLS spécifié.
TlsSetValue | BOOL TlsSetValue(DWORD dwTlsIndex, LPVOID lpvTlsValue); | kernel32.dll | Cette fonction permet d'entreposer la valeur d'un appel de processus d'entreposage d'une fente locale (TLS) pour un index TLS spécifié.
ToAscii | int ToAscii(UINT uVirtKey, UINT uScanCode, PBYTE lpbKeyState, LPWORD lpwTransKey, UINT fuState); | user32.dll | Cette fonction permet de traduire le code de touche virtuel spécifié et l'état du clavier en sa correspondance de caractère Windows ou de caractères.
ToAsciiEx | int ToAsciiEx(UINT uVirtKey, UINT ScanCode, BYTE *lpbKeyState, DWORD *lpdwTransKey, UINT fuState, HKL hkl); | user32.dll | Cette fonction permet de traduire le code de touche virtuel spécifié et l'état du clavier en sa correspondance de caractère Windows ou de caractères avec des options supplémentaires.
TouchFileTimes | BOOL TouchFileTimes( HANDLE FileHandle, PSYSTEMTIME pSystemTime); | imagehlp.dll | Cette fonction permet de fixer la date et l'heure d'un fichier avec un Handle.
ToUnicode | int ToUnicode(UINT wVirtKey, UINT wScanCode, PBYTE lpKeyState, LPWSTR pwszBuff, int cchBuff, UINT wFlags); | user32.dll | Cette fonction permet de traduire le code de touche virtuel spécifié et l'état du clavier en sa correspondance de caractère Unicode ou de caractères.
ToUnicodeEx | int ToUnicodeEx(UINT wVirtKey, UINT wScanCode, const BYTE *lpKeyState, LPWSTR pwszBuff, int cchBuff, UINT wFlags, HKL dwhkl); | user32.dll | Cette fonction permet de traduire le code de touche virtuel spécifié et l'état du clavier en sa correspondance de caractère Unicode ou de caractères avec des options supplémentaires.
TrackMouseEvent | BOOL TrackMouseEvent(LPTRACKMOUSEEVENT lpEventTrack); | user32.dll | Cette fonction permet de poster les messages lorsque le pointeur de souris laisse une fenêtre ou passe dessus une fenêtre pour un nombre de temps spécifié.
TrackPopupMenu | BOOL TrackPopupMenu( HMENU hMenu, UINT uFlags, int x, int y, int nReserved, HWND hWnd, CONST RECT * prcRect ); | user32.dll | Cette fonction permet d'afficher un menu contextuelle.
TrackPopupMenuEx | BOOL TrackPopupMenuEx(HMENU hmenu, UINT fuFlags, int x, int y, HWND hwnd, LPTPMPARAMS lptpm); | user32.dll | Cette fonction permet d'afficher un menu contextuel à l'emplacement spécifié et trace les items de sélection dans un menu contextuel.
TransactNamedPipe | BOOL TransactNamedPipe(HANDLE hNamedPipe, LPVOID lpvWriteBuf, DWORD cbWriteBuf, LPVOID lpvReadBuf, DWORD cbReadBuf, LPDWORD lpcbRead, LPOVERLAPPED lpo); | kernel32.dll | Cette fonction permet de combiner dans une simple opération réseau les fonctions d'écriture d'un message et de lecture de message d'un tuyau nommé spécifié.
TranslateAcceleratorA | int TranslateAcceleratorA(HWND hwnd, HACCEL haccl, LPMSG lpmsg); | user32.dll | Cette fonction permet d'effectuer le traitement des touches d'accélérations pour les commandes de menu.
TranslateAcceleratorW | int TranslateAcceleratorW(HWND hwnd, HACCEL haccl, LPMSG lpmsg); | user32.dll | Cette fonction permet d'effectuer le traitement des touches d'accélérations pour les commandes de menu avec des paramètres de chaine de caractères étendues (Unicode).
TranslateCharsetInfo | UINT TranslateCharsetInfo(DWORD FAR * lpSrc, LPCHARSETINFO lpCs, DWORD dwFlags); | user32.dll | Cette fonction permet d'effectuer une conversion, basé sur ensemble de caractères spécifié, un code de page ou une valeur de signature de police de caractères, ajustant tous les membres d'une structure de destination aux valeurs approprié.
TranslateMDISysAccel | BOOL TranslateMDISysAccel(HWND hwndClient, LPMSG lpmsg); | user32.dll | Cette fonction permet d'effectuer le traitement d'une combinaison de touches d'accélération pour une interface de document multiple (MDI) de la fenêtre enfant.
TranslateMessage | BOOL TranslateMessage(CONST MSG *lpmsg); | user32.dll | Cette fonction permet d'effectuer une transformation de message de touche virtuel en caractères de messages.
TransmitCommChar | BOOL TransmitCommChar(HANDLE hCommDev, char chTransmit); | kernel32.dll | Cette fonction permet de transmettre un caractère spécifié à venir dans des données en attente dans un tampon de sortie du périphérique de communication spécifié.
TryEnterCriticalSection | BOOL TryEnterCriticalSection(LPCRITICAL_SECTION lpCriticalSection); | kernel32.dll | Cette fonction permet d'effectuer une tentative pour entrer dans une section critique sans blocage.
UnhandledExceptionFilter | LONG UnhandledExceptionFilter(STRUCT _EXCEPTION_POINTERS * lpexpExceptionInfo); | kernel32.dll | Cette fonction permet de passer une exception non définit au débogueur si le processus de déboguage est actif.
UnhookWindowsHook | BOOL UnhookWindowsHook(int nCode, HOOKPROC hkprc); | user32.dll | Cette fonction permet d'enlever la fonction crochet utilisateur pour une chaine de fonctions crochet.
UnhookWindowsHookEx | BOOL UnhookWindowsHookEx(HHOOK hhook); | user32.dll | Cette fonction permet d'enlever un crochet de fonction utilisateur d'une chaine de crochet.
UnionRect | BOOL UnionRect(LPRECT lprcDst, CONST RECT *lprcSrc1, CONST RECT *lprcSrc2); | user32.dll | Cette fonction permet d'effectuer la création de l'union de 2 rectangles.
UnloadKeyboardLayout | BOOL UnloadKeyboardLayout(HKL hkl); | user32.dll | Cette fonction permet d'enlever une schéma de clavier.
UnlockFile | BOOL UnlockFile(HANDLE hFile, DWORD dwFileOffsetLow, DWORD dwFileOffsetHigh, DWORD cbUnlockLow, DWORD cbUnlockHigh); | kernel32.dll | Cette fonction permet de déverrouiller une région d'un fichier ouvert.
UnlockFileEx | BOOL UnlockFileEx(HANDLE hFile, DWORD dwReserved, DWORD nNumberOfBytesToUnlockLow, DWORD nNumberOfBytesToUnlockHigh, LPOVERLAPPED lpOverlapped); | kernel32.dll | Cette fonction permet de déverrouiller une rangée d'octets précédemment verrouillé dans un fichier ouvert.
UnmapViewOfFile | BOOL UnmapViewOfFile(LPVOID lpBaseAddress); | kernel32.dll | Cette fonction permet de cartographier une vue cartographier dans un fichier d'un espace d'adressage d'un processus appelant.
UnpackDDElParam | BOOL UnpackDDElParam(UINT uMsg, LONG lParam, PUINT puLow, PUINT puHigh); | user32.dll | Cette fonction permet d'effectuer un décompactage d'une valeur DDE reçu spécifié vers un message DDE posté.
UnrealizeObject | BOOL UnrealizeObject(HGDIOBJ hgdiobj); | gdi32.dll | Cette fonction permet de réinitialiser l'origine de la brosse ou de réinitialiser la palette logique.
UnregisterClassA | BOOL UnregisterClassA(LPCTSTR lpszClass, HINSTANCE hinst); | user32.dll | Cette fonction permet d'enlever une classe de fenêtre et libère l'entreposage requis par la classe.
UnregisterClassW | BOOL UnregisterClassW(LPCWSTR lpszClass, HINSTANCE hinst); | user32.dll | Cette fonction permet d'enlever une classe de fenêtre et libère l'entreposage requis par la classe avec des paramètres de chaine de caractères étendues (Unicode).
UnregisterDeviceNotification | BOOL UnregisterDeviceNotification(HDEVNOTIFY Handle); | user32.dll | Cette fonction permet de désenregistrer un périphérique ou un type de périphérique pour que la fenêtre reçoivent des avertissements de changements.
UnregisterHotKey | BOOL UnregisterHotKey(HWND hwnd, int idHotKey); | user32.dll | Cette fonction permet de désenregistrer l'état des touches de combinaison (Alt, Ctrl, Shift) pour le processus léger.
UpdateColors | BOOL UpdateColors(HDC hdc); | gdi32.dll | Cette fonction permet de mettre-à-jour la région client d'un périphérique de contexte spécifié en faisant correspondre les couleurs courantes dans une région client, pixel par pixel, à une palette de système.
UpdateResourceA | BOOL UpdateResourceA(HANDLE hUpdateFile, LPCTSTR lpszType, LPCTSTR lpszName, WORD IDLanguage, LPVOID lpvData, DWORD cbData); | kernel32.dll | Cette fonction permet d'ajouter, supprimer ou remplacer une ressource dans un fichier exécutable.
UpdateResourceW | BOOL UpdateResourceW(HANDLE hUpdate, LPCWSTR lpType, LPCWSTR lpName, WORD wLanguage, LPVOID lpData, DWORD cbData); | kernel32.dll | Cette fonction permet d'ajouter, supprimer ou remplacer une ressource dans un fichier exécutable avec des paramètres de chaine de caractères étendues (Unicode).
UpdateWindow | BOOL UpdateWindow(HWND hwnd); | user32.dll | Cette fonction permet de mettre à jour la région client de la fenêtre donnée par l'envoie du message WM_PAINT à la fenêtre si la région à mettre à jour de la fenêtre n'est pas vide.
UrlCanonicalizeA | HRESULT UrlCanonicalizeA( LPCSTR pszUrl, LPSTR pszCanonicalized, LPDWORD pcchCanonicalized, DWORD dwFlags); | shlwapi.dll | Cette fonction permet de transformer un chemin d'un URL de sa forme absolue à relative, c'est-à-dire de remplacer des "../" pour atteinte le répertoire en court par exemple.
UrlCombineA | HRESULT UrlCombineA( LPCSTR pszBase, LPCSTR pszRelative, LPSTR pszCombined, LPDWORD pcchCombined, DWORD dwFlags); | shlwapi.dll | Cette fonction permet d'ajouter un chemin d'un URL à la fin d'un autre chemin d'URL.
UrlCreateFromPathA | HRESULT UrlCreateFromPathA( LPCTSTR pszPath, LPTSTR pszUrl, LPDWORD pcchUrl, DWORD dwReserved); | shlwapi.dll | Cette fonction permet de convertir un chemin de système d'exploitation de style DOS sous sa forme URL.
UrlEscapeA | HRESULT UrlEscapeA( LPCTSTR pszURL, LPTSTR pszEscaped, LPDWORD pcchEscaped, DWORD dwFlags ); | shlwapi.dll | Cette fonction permet de convertir les caractères particulier en format acceptable pour un URL.
UrlGetPartA | HRESULT UrlGetPartA( LPCSTR pszIn, LPSTR pszOut, LPDWORD pcchOut, DWORD dwPart, DWORD dwFlags ); | shlwapi.dll | Cette fonction permet d'extraire une partie de l'URL.
UrlIsOpaqueA | BOOL UrlIsOpaqueA( LPCSTR pszUrl); | shlwapi.dll | Cette fonction permet de demander si le URL est opaque.
UrlUnescapeA | HRESULT UrlUnescapeA( LPSTR pszUrl, LPSTR pszUnescaped, LPDWORD pcchUnescaped, DWORD dwFlags ); | shlwapi.dll | Cette fonction permet de convertir les caractères particulier du URL en une chaine de caractères ASCIZ.
ValidateRect | BOOL ValidateRect(HWND hwnd, CONST RECT *lprc); | user32.dll | Cette fonction permet de valider une région client avec le rectangle donnée par suppression du rectangle de la région à mettre à jour de la fenêtre donnée.
ValidateRgn | BOOL ValidateRgn(HWND hwnd, HRGN hrgn); | user32.dll | Cette fonction permet de valider la région client avec la région donnée par suppression de la région de la mise à jour courante d'une région de fenêtre spécifié.
VerifyScreenSavePwd | BOOL VerifyScreenSavePwd(HWND hwnd); | password.cpl | Cette fonction permet d'effectuer la vérification du mots de passe lors du lancement d'un écran de veille.
VerLanguageNameA | DWORD VerLanguageNameA( DWORD idLang,LPTSTR lpszLang, DWORD cbLang); | kernel32.dll | Cette fonction permet de demander le MID identifiant le langage utilisé par le système d'exploitation.
VerLanguageNameW | DWORD VerLanguageNameW(DWORD wLang, LPWSTR szLang, DWORD nSize); | kernel32.dll | Cette fonction permet de demander le MID identifiant le langage utilisé par le système d'exploitation avec des paramètres de chaines de caractères étendues (Unicode).
VirtualAlloc | LPVOID VirtualAlloc(LPVOID lpvAddress, DWORD cbSize, DWORD fdwAllocationType, DWORD fdwProtect); | kernel32.dll | Cette fonction permet de réservé ou d'engager une région de pages dans un espace d'adressage virtuel d'un processus appelant.
VirtualAllocEx | LPVOID VirtualAllocEx(HANDLE hProcess, LPVOID lpAddress, SIZE_T dwSize, DWORD flAllocationType, DWORD flProtect); | kernel32.dll | Cette fonction permet de réservé ou d'engager une région de pages dans un espace d'adressage virtuel pour le processus spécifié.
VirtualFree | BOOL VirtualFree(LPVOID lpvAddress, DWORD cbSize, DWORD fdwFreeType); | kernel32.dll | Cette fonction permet de relâcher ou désengager (ou les deux) une région de pages dans une espace de d'adressage virtuel d'un processus appelant.
VirtualFreeEx | BOOL VirtualFreeEx(HANDLE hProcess, LPVOID lpAddress, SIZE_T dwSize, DWORD dwFreeType); | kernel32.dll | Cette fonction permet de relâcher ou désengager (ou les deux) une région de pages dans une espace de d'adressage virtuel pour un processus spécifié.
VirtualLock | BOOL VirtualLock(LPVOID lpvAddress, DWORD cbSize); | kernel32.dll | Cette fonction permet de verrouiller une région spécifié dans un espace d'adressage virtuel de la mémoire en s'assurant que l'accès ultérieur à la région ne soit pas passible d'une erreur de page.
VirtualProtect | BOOL VirtualProtect(LPVOID lpvAddress, DWORD cbSize, DWORD fdwNewProtect, PDWORD pfdwOldProtect); | kernel32.dll | Cette fonction permet de changer la protection d'accès d'une région de pages engagé dans un espace d'adressage virtuel d'un processus appelant.
VirtualProtectEx | BOOL VirtualProtectEx(HANDLE hProcess, LPVOID lpvAddress, DWORD cbSize, DWORD fdwNewProtect, PDWORD pfdwOldProtect); | kernel32.dll | Cette fonction permet de changer la protection d'accès d'une région de pages engagé dans un espace d'adressage virtuel d'un processus spécifié.
VirtualQuery | DWORD VirtualQuery(LPCVOID lpvAddress, PMEMORY_BASIC_INFORMATION pmbiBuffer, DWORD cbLength); | kernel32.dll | Cette fonction permet de fournir les informations à propos d'un rang de pages dans un espace d'adressage virtuel pour un processus appelant.
VirtualQueryEx | DWORD VirtualQueryEx(HANDLE hProcess, LPCVOID lpvAddress, PMEMORY_BASIC_INFORMATION pmbiBuffer, DWORD cbLength); | kernel32.dll | Cette fonction permet de fournir les informations à propos d'un rang de pages dans un espace d'adressage virtuel dans un processus spécifié.
VirtualUnlock | BOOL VirtualUnlock(LPVOID lpvAddress, DWORD cbSize); | kernel32.dll | Cette fonction permet de déverrouiller un range de pages spécifié dans un espace d'adressage virtuel d'un processus et activant le système pour l'échange de pages dans le fichier de pagination si nécessaire.
VkKeyScanA | SHORT VkKeyScanA(TCHAR ch); | user32.dll | Cette fonction permet d'effectuer la conversion de caractère correspondant un code de touche virtuel et de l'état de touche de combinaison du clavier courant.
VkKeyScanExA | SHORT VkKeyScanExA(UINT uChar, HKL hkl); | user32.dll | Cette fonction permet d'effectuer la conversion de caractère correspondant un code de touche virtuel et de l'état de touche de combinaison du clavier courant en utilisant le langage et la couche physique du clavier.
VkKeyScanExW | SHORT VkKeyScanExW(WCHAR uChar, HKL hkl); | user32.dll | Cette fonction permet d'effectuer la conversion de caractère correspondant un code de touche virtuel et de l'état de touche de combinaison du clavier courant en utilisant le langage et la couche physique du clavier avec des paramètres de chaine de caractères étendues (Unicode).
VkKeyScanW | SHORT VkKeyScanW(WCHAR ch); | user32.dll | Cette fonction permet d'effectuer la conversion de caractère correspondant un code de touche virtuel et de l'état de touche de combinaison du clavier courant avec des paramètres de chaine de caractères étendues (Unicode).
WaitCommEvent | BOOL WaitCommEvent(HANDLE hCommDev, LPDWORD lpfdwEvtMask, LPOVERLAPPED lpo); | kernel32.dll | Cette fonction permet d'attendre qu'un événement se produise sur le périphérique de communication spécifié.
WaitForDebugEvent | BOOL WaitForDebugEvent(LPDEBUG_EVENT lpde, DWORD dwTimeout); | kernel32.dll | Cette fonction permet d'attendre qu'un événement de déboguage se produise dans un processus en déboguage.
WaitForInputIdle | DWORD WaitForInputIdle(HANDLE hProcess, DWORD dwTimeout); | user32.dll | Cette fonction permet d'attendre tant que le processus données est en attente d'une entrée utilisateur sans attendre d'entrée ou de dépassement d'intervalle de temps.
WaitForMultipleObjects | DWORD WaitForMultipleObjects(DWORD cObjects, CONST HANDLE * lphObjects, BOOL fWaitAll, DWORD dwTimeout); | kernel32.dll | Cette fonction permet de retourner lorsque l'un des objets indiqués est dans l'état signalé, ou lorsque le délai d'attente spécifié s'est écoulé.
WaitForMultipleObjectsEx | DWORD WaitForMultipleObjectsEx(DWORD cObjects, CONST HANDLE * lphObjects, BOOL fWaitAll, DWORD dwTimeout, BOOL fAlertable); | kernel32.dll | Cette fonction permet d'attendre que la fonction soit utilisés pour un traitement d'attendre d'alerte.
WaitForSingleObject | DWORD WaitForSingleObject( HANDLE hObject, DWORD dwTimeout ); | kernel32.dll | Cette fonction permet d'attendre qu'un objet retourne un signal ou que le délai spécifié soit écoulé.
WaitForSingleObjectEx | DWORD WaitForSingleObjectEx(HANDLE hObject, DWORD dwTimeout, BOOL fAlertable); | kernel32.dll | Cette fonction permet d'étendre la fonction d'attente étant utilisés pour un traitement d'attendre d'alerte.
WaitMessage | BOOL WaitMessage(VOID); | user32.dll | Cette fonction permet de rendre le contrôle à une autre application quand une application n'a pas une autre tâche en traitement.
WaitNamedPipeA | BOOL WaitNamedPipeA(LPCTSTR lpszPipeName, DWORD dwTimeout); | kernel32.dll | Cette fonction permet d'attendre jusqu'à ce qu'un dépassement d'intervalle ou d'une instance d'un tuyau nommé spécifié soit disponible pour être connecté à processus en attente d'une opération ConnectNamedPipe se produise.
WaitNamedPipeW | BOOL WaitNamedPipeW(LPCWSTR name, DWORD nTimeOut); | kernel32.dll | Cette fonction permet d'attendre jusqu'à ce qu'un dépassement d'intervalle ou d'une instance d'un tuyau nommé spécifié soit disponible pour être connecté à processus en attente d'une opération ConnectNamedPipe se produise avec des paramètres de chaine de caractères étendue (Unicode).
waveOutGetNumDevs | UINT waveOutGetNumDevs(VOID); | winmm.dll | Cette fonction permet de demander le nombre de sortie Wave disponible sur le système d'explotation Windows.
WideCharToMultiByte | int WideCharToMultiByte(UINT CodePage, DWORD dwFlags, LPCWSTR lpWideCharStr, int cchWideChar, LPSTR lpMultiByteStr, int cchMultiByte, LPCSTR lpDefaultChar, LPBOOL lpUsedDefaultChar); | kernel32.dll | Cette fonction permet de cartographier une chaine de caractères Unicode en une nouvelle chaine de caractères.
WidenPath | BOOL WidenPath(HDC hdc); | gdi32.dll | Cette fonction permet de redéfinir le chemin courant de la région devant être repeinte si le chemin est un trait utilisant le crayon courant sélectionné dans le périphérique de contexte spécifié.
WindowFromDC | HWND WindowFromDC(HDC hdc); | user32.dll | Cette fonction permet de demander le Handle de la fenêtre correspondante au périphérique de contexte spécifié.
WindowFromPoint | HWND WindowFromPoint(POINT pt); | user32.dll | Cette fonction permet de demander le Handle associé à une fenêtre correspondant au coordonnées pixel spécifié.
WinExec | UINT WinExec( LPCSTR lpszCmdLine, UINT fuCmdShow ); | kernel32.dll | Cette fonction permet de lancer l'exécution d'un programme externe.
WinHelpA | BOOL WinHelpA(HWND hwnd, LPCTSTR lpszHelp, UINT uCommand, DWORD dwData); | user32.dll | Cette fonction permet de démarrer la fenêtre d'aide (WINHELP.EXE) et passe les données optionnels indiquant la nature de la requête d'aide pour l'application.
WinHelpW | BOOL WinHelpW(HWND hwnd, LPCTSTR lpszHelp, UINT uCommand, DWORD dwData); | user32.dll | Cette fonction permet de démarrer la fenêtre d'aide (WINHELP.EXE) et passe les données optionnels indiquant la nature de la requête d'aide pour l'application avec des paramètres de chaine de caractères étendues (Unicode).
WNetAddConnection2A | DWORD WNetAddConnection2A(LPNETRESOURCE lpNetResource, LPCTSTR lpPassword, LPCTSTR lpUsername, DWORD fdwConnection); | mpr.dll | Cette fonction permet de fabriquer une connexion vers une ressource réseau.
WNetAddConnection2W | DWORD WNetAddConnection2W(LPNETRESOURCEW lpNetResource, LPCWSTR lpPassword, LPCWSTR lpUsername, DWORD fdwConnection); | mpr.dll | Cette fonction permet de fabriquer une connexion vers une ressource réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetAddConnection3A | DWORD WNetAddConnection3A(HWND hwndOwner, LPNETRESOURCE lpNetResource, LPTSTR lpPassword, LPTSTR lpUserName, DWORD fdwConnection); | mpr.dll | Cette fonction permet de fabriquer une connexion vers une ressource réseau en utilisant des options supplémentaires.
WNetAddConnection3W | DWORD WNetAddConnection3W(HWND hwndOwner, LPNETRESOURCEW lpNetResource, LPCWSTR lpPassword, LPCWSTR lpUserName, DWORD fdwConnection); | mpr.dll | Cette fonction permet de fabriquer une connexion vers une ressource réseau en utilisant des options supplémentaires avec des paramètres de chaine de caractères étendues (Unicode).
WNetAddConnectionA | DWORD WNetAddConnectionA(LPTSTR lpszRemoteName, LPTSTR lpszPassword,LPTSTR lpszLocalName); | mpr.dll | Cette fonction permet d'effectuer la connexion d'une unité de disque à une ressource réseau.
WNetAddConnectionW | DWORD WNetAddConnectionW(LPCWSTR lpszRemoteName, LPCWSTR lpszPassword, LPCWSTR lpszLocalName); | mpr.dll | Cette fonction permet d'effectuer la connexion d'une unité de disque à une ressource réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetCancelConnection2A | DWORD WNetCancelConnection2A(LPTSTR lpszName, DWORD fdwConnection, BOOL fForce); | mpr.dll | Cette fonction permet d'effectuer l'arrêt d'une connexion réseau existante.
WNetCancelConnection2W | DWORD WNetCancelConnection2W(LPCWSTR lpszName, DWORD fdwConnection, BOOL fForce); | mpr.dll | Cette fonction permet d'effectuer l'arrêt d'une connexion réseau existante avec des paramètres de chaine de caractères étendues (Unicode).
WNetCancelConnectionA | DWORD WNetCancelConnectionA(LPTSTR lpszName, BOOL fForce); | mpr.dll | Cette fonction permet d'effectuer la déconnexion d'une unité de disque à une ressource réseau.
WNetCancelConnectionW | DWORD WNetCancelConnectionW(LPCWSTR lpszName, BOOL fForce); | mpr.dll | Cette fonction permet d'effectuer la déconnexion d'une unité de disque à une ressource réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetCloseEnum | DWORD WNetCloseEnum(HANDLE hEnum); | mpr.dll | Cette fonction permet de terminer l'énumération d'une ressource réseau débuté par la fonction WNetOpenEnum.
WNetConnectionDialog | DWORD WNetConnectionDialog( HWND hwnd, DWORD fdwResourceType ); | mpr.dll | Cette fonction permet d'afficher une boite de dialogue permettant à une unité de disque de se connecter à une ressource réseau.
WNetConnectionDialog1A | DWORD WNetConnectionDialog1A(LPCONNECTDLGSTRUCT lpConnDlgStruct); | mpr.dll | Cette fonction permet d'introduire une boite de dialogue de navigation général pour la connexion des ressources de réseau.
WNetConnectionDialog1W | DWORD WNetConnectionDialog1W(LPCONNECTDLGSTRUCTW lpConnDlgStruct); | mpr.dll | Cette fonction permet d'introduire une boite de dialogue de navigation général pour la connexion des ressources de réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetDisconnectDialog | DWORD WNetDisconnectDialog( HWND hwnd, DWORD fdwResourceType ); | mpr.dll | Cette fonction permet d'afficher une boite de dialogue permettant à une unité de disque de se déconnecter à une ressource réseau.
WNetDisconnectDialog1A | DWORD WNetDisconnectDialog1A(LPDISCDLGSTRUCT lpConnDlgStruct); | mpr.dll | Cette fonction permet d'effectuer la déconnexion d'une ressource de réseau.
WNetDisconnectDialog1W | DWORD WNetDisconnectDialog1W(LPDISCDLGSTRUCTW lpConnDlgStruct); | mpr.dll | Cette fonction permet d'effectuer la déconnexion d'une ressource de réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetEnumResourceA | DWORD WNetEnumResourceA(HANDLE hEnum, LPDWORD lpcEntries, LPVOID lpvBuffer, LPDWORD lpcbBuffer); | mpr.dll | Cette fonction permet de continuer l'énumération de ressource réseau commencé par la fonction WNetOpenEnum.
WNetEnumResourceW | DWORD WNetEnumResourceW(HANDLE hEnum, LPDWORD lpcEntries, LPVOID lpvBuffer, LPDWORD lpcbBuffer); | mpr.dll | Cette fonction permet de continuer l'énumération de ressource réseau commencé par la fonction WNetOpenEnum avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetConnectionA | DWORD WNetGetConnectionA(LPTSTR lpszLocalName, LPTSTR lpszRemoteName, LPDWORD lpcchBuffer); | mpr.dll | Cette fonction permet de demander le nom de la ressource réseau associé avec un périphérique local.
WNetGetConnectionW | DWORD WNetGetConnectionW(LPCWSTR lpszLocalName, LPWSTR lpszRemoteName, LPDWORD lpcchBuffer); | mpr.dll | Cette fonction permet de demander le nom de la ressource réseau associé avec un périphérique local avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetLastErrorA | DWORD WNetGetLastErrorA(LPDWORD lpdwErrorCode, LPTSTR lpszDescription, DWORD cchDescription, LPTSTR lpszName, DWORD cchName); | mpr.dll | Cette fonction permet de demander le plus récent des derniers code d'erreur étendue des fonctions réseau du système d'exploitation.
WNetGetLastErrorW | DWORD WNetGetLastErrorW(LPDWORD lpdwErrorCode, LPWSTR lpszDescription, DWORD cchDescription, LPWSTR lpszName, DWORD cchName); | mpr.dll | Cette fonction permet de demander le plus récent des derniers code d'erreur étendue des fonctions réseau du système d'exploitation avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetNetworkInformationA | DWORD WNetGetNetworkInformationA(LPCTSTR lpProvider, LPNETINFOSTRUCT lpNetInfoStruct); | mpr.dll | Cette fonction permet de demander les informations étendues à propos d'un fournisseur de réseau spécifié dont le nom a été retourné lors d'une énumération réseau précédente.
WNetGetNetworkInformationW | DWORD WNetGetNetworkInformationW(LPCWSTR lpProvider, LPNETINFOSTRUCT lpNetInfoStruct); | mpr.dll | Cette fonction permet de demander les informations étendues à propos d'un fournisseur de réseau spécifié dont le nom a été retourné lors d'une énumération réseau précédente avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetProviderNameA | DWORD WNetGetProviderNameA(DWORD dwNetType, LPTSTR lpProviderName, LPDWORD lpBufferSize); | mpr.dll | Cette fonction permet de demander le nom de fournisseur pour un type spécifié dans un réseau.
WNetGetProviderNameW | DWORD WNetGetProviderNameW(DWORD dwNetType, LPWSTR lpProviderName, LPDWORD lpBufferSize); | mpr.dll | Cette fonction permet de demander le nom de fournisseur pour un type spécifié dans un réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetResourceParentA | DWORD WNetGetResourceParentA(LPNETRESOURCE lpNetResource, LPVOID lpBuffer, LPDWORD lpBufferSize); | mpr.dll | Cette fonction permet de naviguer à partir d'une ressource.
WNetGetResourceParentW | DWORD WNetGetResourceParentW(LPNETRESOURCEW lpNetResource, LPVOID lpBuffer, LPDWORD lpBufferSize); | mpr.dll | Cette fonction permet de naviguer à partir d'une ressource avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetUniversalNameA | DWORD WNetGetUniversalNameA(LPCTSTR lpLocalPath, DWORD dwInfoLevel, LPVOID lpBuffer, LPDWORD lpBufferSize); | mpr.dll | Cette fonction permet de prendre un chemin, avec comme base une unité de disque, pour un réseau de ressource et demande la structure de données contenant des formes universel de ce nom.
WNetGetUniversalNameW | DWORD WNetGetUniversalNameW(LPCWSTR lpLocalPath, DWORD dwInfoLevel, LPVOID lpBuffer, LPDWORD lpBufferSize); | mpr.dll | Cette fonction permet de prendre un chemin, avec comme base une unité de disque, pour un réseau de ressource et demande la structure de données contenant des formes universel de ce nom avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetUserA | DWORD WNetGetUserA(LPTSTR lpszLocalName,LPTSTR lpszUserName,LPDWORD lpcchBuffer); | mpr.dll | Cette fonction permet de connaitre le nom de l'utilisateur utilisé pour la connexion réseau.
WNetGetUserW | DWORD WNetGetUserW(LPCWSTR lpszLocalName, LPWSTR lpszUserName,LPDWORD lpcchBuffer); | mpr.dll | Cette fonction permet de connaitre le nom de l'utilisateur utilisé pour la connexion réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetOpenEnumA | DWORD WNetOpenEnumA(DWORD fdwScope, DWORD fdwType, DWORD fdwUsage, LPNETRESOURCE lpNetResource, LPHANDLE lphEnum); | mpr.dll | Cette fonction permet de démarrer l'énumération de ressource réseau ou de connexions existantes.
WNetOpenEnumW | DWORD WNetOpenEnumW(DWORD fdwScope, DWORD fdwType, DWORD fdwUsage, LPNETRESOURCEW lpNetResource, LPHANDLE lphEnum); | mpr.dll | Cette fonction permet de démarrer l'énumération de ressource réseau ou de connexions existantes avec des paramètres de chaine de caractères étendues (Unicode).
WNetSetConnectionA | DWORD WNetSetConnectionA(LPCTSTR lpName, DWORD dwProperty, LPVOID pvValue); | mpr.dll | Cette fonction permet de modifier les caractéristiques d'une connexion réseau.
WNetSetConnectionW | DWORD WNetSetConnectionW(LPCWSTR lpName, DWORD dwProperty, LPVOID pvValue); | mpr.dll | Cette fonction permet de modifier les caractéristiques d'une connexion réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetUseConnectionA | DWORD WNetUseConnectionA(HWND hwndOwner, LPNETRESOURCE lpNetResource, LPCTSTR lpPassword, LPCTSTR lpUserID, DWORD dwFlags, LPTSTR lpAccessName, LPDWORD lpBufferSize, LPDWORD lpResult); | mpr.dll | Cette fonction permet de fabriquer une connexion vers une ressource réseau.
WNetUseConnectionW | DWORD WNetUseConnectionW(HWND hwndOwner, LPNETRESOURCEW lpNetResource, LPCWSTR lpPassword, LPCWSTR lpUserID, DWORD dwFlags, LPWSTR lpAccessName, LPDWORD lpBufferSize, LPDWORD lpResult); | mpr.dll | Cette fonction permet de fabriquer une connexion vers une ressource réseau avec des paramètres de chaine de caractères étendues (Unicode).
WriteConsoleA | BOOL WriteConsoleA(HANDLE hConsoleOutput, CONST VOID *lpvBuffer, DWORD cchToWrite, LPDWORD lpcchWritten, LPVOID lpvReserved); | kernel32.dll | Cette fonction permet d'effectuer l'écriture d'une chaine de caractères dans la sortie de la console standard.
WriteConsoleW | BOOL WriteConsoleW(HANDLE hConsoleOutput, CONST VOID *lpvBuffer, DWORD cchToWrite, LPDWORD lpcchWritten, LPVOID lpvReserved); | kernel32.dll | Cette fonction permet d'effectuer l'écriture d'une chaine de caractères dans la sortie de la console standard avec des paramètres de chaine de caractères étendues (Unicode).
WriteConsoleInputA | BOOL WriteConsoleInputA(HANDLE hConsoleInput, PINPUT_RECORD pirBuffer, DWORD cInRecords, LPDWORD lpcWritten); | kernel32.dll | Cette fonction permet d'écrire des données directement dans l'entrée du tampon de la console.
WriteConsoleInputW | BOOL WriteConsoleInputW(HANDLE hConsoleInput, CONST INPUT_RECORD *lpBuffer, DWORD nLength, LPDWORD lpNumberOfEventsWritten); | kernel32.dll | Cette fonction permet d'écrire des données directement dans l'entrée du tampon de la console avec des paramètres de chaine de caractères étendues (Unicode).
WriteConsoleOutputA | BOOL WriteConsoleOutputA(HANDLE hConsoleOutput, PCHAR_INFO pchiSrcBuffer, COORD coordSrcBufferSize, COORD coordSrcBufferCoord, PSMALL_RECT psrctDestRect); | kernel32.dll | Cette fonction permet d'écrire le caractère et la donnée d'attribut de couleur vers un bloc rectangulaire spécifié dans une cellule de caractères d'un tampon de console d'écran.
WriteConsoleOutputW | BOOL WriteConsoleOutputW(HANDLE hConsoleOutput, PCHAR_INFO pchiSrcBuffer, COORD coordSrcBufferSize, COORD coordSrcBufferCoord, PSMALL_RECT psrctDestRect); | kernel32.dll | Cette fonction permet d'écrire le caractère et la donnée d'attribut de couleur vers un bloc rectangulaire spécifié dans une cellule de caractères d'un tampon de console d'écran avec des paramètres de chaine de caractères étendue (Unicode).
WriteConsoleOutputAttribute | BOOL WriteConsoleOutputAttribute(HANDLE hConsoleOutput, LPWORD lpwAttribute, DWORD cWriteCells, COORD coordWrite, LPDWORD lpcWritten); | kernel32.dll | Cette fonction permet de copier un nombre d'attributs de couleurs de premier plan et d'arrière-plan dans une cellule consécutive d'un tampon de console d'écran en débutant à l'emplacement spécifié.
WriteConsoleOutputCharacterA | BOOL WriteConsoleOutputCharacterA(HANDLE hConsoleOutput, LPTSTR lpWriteBuffer, DWORD cchWrite, COORD coordWriteCoord, LPDWORD lpcWritten); | kernel32.dll | Cette fonction permet d'effectuer une copie d'un nombre de caractères à une cellule consécutive d'un tampon de console d'écran en débutant à l'emplacement spécifié.
WriteConsoleOutputCharacterW | BOOL WriteConsoleOutputCharacterW(HANDLE hConsoleOutput, LPCWSTR str, DWORD length, COORD coord, LPDWORD lpNumCharsWritten); | kernel32.dll | Cette fonction permet d'effectuer une copie d'un nombre de caractères à une cellule consécutive d'un tampon de console d'écran en débutant à l'emplacement spécifié avec des paramètres de chaine de caractères étendue (Unicode).
WriteFile | BOOL WriteFile(HANDLE hFile, LPCVOID lpBuffer, DWORD nNumberOfBytesToWrite, LPDWORD lpNumberOfBytesWritten, LPOVERLAPPED lpOverlapped); | kernel32.dll | Cette fonction permet d'écrire des données dans un fichier et est conçue pour des opérations sychronisé ou désychronisé.
WriteFileEx | BOOL WriteFileEx(HANDLE hFile, LPCVOID lpBuffer, DWORD nNumberOfBytesToWrite, LPOVERLAPPED lpOverlapped,LPOVERLAPPED_COMPLETION_ROUTINE lpCompletionRoutine); | kernel32.dll | Cette fonction permet d'écrire des données dans un fichier.
WritePrivateProfileSectionA | BOOL WritePrivateProfileSectionA(LPCTSTR lpszSection, LPCTSTR lpszKeysAndValues, LPCTSTR lpszFile); | kernel32.dll | Cette fonction permet de remplacer les clefs et les valeurs dans la section spécifié d'un fichier d'initialisation.
WritePrivateProfileSectionW | BOOL WritePrivateProfileSectionW(LPCWSTR section, LPCWSTR string, LPCWSTR filename); | kernel32.dll | Cette fonction permet de remplacer les clefs et les valeurs dans la section spécifié d'un fichier d'initialisation avec des paramètres de chaine de caractères étendue (Unicode).
WritePrivateProfileStringA | BOOL WritePrivateProfileStringA(LPCTSTR lpszSection, LPCTSTR lpszKey, LPCTSTR lpszString, LPCTSTR lpszFile); | kernel32.dll | Cette fonction permet de copier une chaine de caractères dans une section spécifié d'un fichier d'initialisation spécifié.
WritePrivateProfileStringW | BOOL WritePrivateProfileStringW(LPCWSTR lpszSection, LPCWSTR lpszKey, LPCWSTR lpszString, LPCWSTR lpszFile); | kernel32.dll | Cette fonction permet de copier une chaine de caractères dans une section spécifié d'un fichier d'initialisation spécifié avec des paramètres de chaine de caractères étendue (Unicode).
WriteProcessMemory | BOOL WriteProcessMemory(HANDLE hProcess, LPVOID lpBaseAddress, LPVOID lpBuffer, DWORD cbWrite, LPDWORD lpNumberOfBytesWritten); | kernel32.dll | Cette fonction permet d'écrire en mémoire pour le processus spécifié.
WriteProfileSectionA | BOOL WriteProfileSectionA(LPCTSTR lpszSection, LPCTSTR lpszKeysAndValues); | kernel32.dll | Cette fonction permet de remplacer le contenu de la section spécifié dans le fichier «WIN.INI» avec les clefs et les valeurs spécifiés.
WriteProfileSectionW | BOOL WriteProfileSectionW(LPCWSTR lpszSection, LPCWSTR lpszKeysAndValues); | kernel32.dll | Cette fonction permet de remplacer le contenu de la section spécifié dans le fichier «WIN.INI» avec les clefs et les valeurs spécifiés et avec les paramètres de chaine de caractères étendues (Unicode).
WriteProfileStringA | BOOL WriteProfileStringA(LPCTSTR lpszSection, LPCTSTR lpszKey, LPCTSTR lpszString); | kernel32.dll | Cette fonction permet de copier une chaine de caractères dans la section spécifié d'un fichier «WIN.INI».
WriteProfileStringW | BOOL WriteProfileStringW(LPCWSTR section, LPCWSTR entry, LPCWSTR string); | kernel32.dll | Cette fonction permet de copier une chaine de caractères dans la section spécifié d'un fichier «WIN.INI» avec des paramètres de chaine de caractères étendues (Unicode).
WriteTapemark | DWORD WriteTapemark(HANDLE hDevice, DWORD dwTapemarkType, DWORD dwTapemarkCount, BOOL bImmediate); | kernel32.dll | Cette fonction permet d'écrire une marque de fichier, un fixeur de marque, une marque de fichier court ou une long marque de fichier dans un périphérique de bande magnétique.
wsprintfA | int wsprintfA(LPTSTR lpOut, LPCTSTR lpFmt, ...); | user32.dll | Cette fonction permet d'écrire des données formatté d'une chaine de caractères vers un tampon.
wsprintfW | int wsprintfW(LPWSTR lpOut, LPCWSTR lpFmt, ...); | user32.dll | Cette fonction permet d'écrire des données formatté d'une chaine de caractères vers un tampon avec des paramètres de chaine de caractères étendues (Unicode).
wvsprintfA | int wvsprintfA(LPTSTR lpOutput, LPCTSTR lpFormat, va_list arglist); | user32.dll | Cette fonction permet de formatter et d'entreposer une série de caractères et de valeurs virtuel dans un tampon.
wvsprintfW | int wvsprintfW(LPWSTR lpOutput, LPCWSTR lpFormat, va_list arglist); | user32.dll | Cette fonction permet de formatter et d'entreposer une série de caractères et de valeurs virtuel dans un tampon avec des paramètres de chaine de caractères étendues (Unicode).
_hread | long _hread(HFILE hFile, LPVOID lpBuffer, long lBytes); | kernel32.dll | Cette fonction permet d'effectuer la lecture de données dans le fichier spécifié.
_hwrite | long _hwrite(HFILE hFile, LPCSTR lpBuffer, long lBytes); | kernel32.dll | Cette fonction permet d'effectuer l'écriture de données dans le fichier spécifié.
_lclose | HFILE _lclose(HFILE hFile); | kernel32.dll | Cette fonction permet de fermer le fichier Handle spécifié.
_lcreat | HFILE _lcreat(LPCSTR lpPathName, int iAttribute); | kernel32.dll | Cette fonction permet de créer ou ouvrir un fichier spécifié.
_llseek | LONG _llseek(HFILE hFile, LONG lOffset, int iOrigin ); | kernel32.dll | Cette fonction permet de positionner le pointeur du fichier Handle spécifié.
_lopen | HFILE _lopen(LPCSTR lpPathName, int iReadWrite); | kernel32.dll | Cette fonction permet d'ouvrir un fichier existant et de fixer le pointeur de fichier au début du fichier.
_lread | UINT _lread(HFILE hFile, LPVOID lpBuffer, UINT uBytes); | kernel32.dll | Cette fonction permet d'effectuer la lecture de données dans un fichier spécifié.
_lwrite | UINT _lwrite(HFILE hFile, LPCSTR lpBuffer, UINT uBytes); | kernel32.dll | Cette fonction permet d'effectuer l'écriture de données du fichier spécifié.

Vu dans http://www.gladir.com

Articles - Les géants de l'informatique - Microsoft

Dernière mise à jour: Dimanche, le 27 septembre 2009


C pour Windows - EXE, DLL et modules de Windows - «advapi32.dll»

Description

Ce fichier contient les APIs avancé de Windows 32 bits.

Liste des fonctions d'API Windows

Nom de l'API | Description
AbortSystemShutdownA | Cette fonction permet d'annuler l'opération de fermeture ou de redémarrage en cours d'exécution du système d'exploitation Windows.
AbortSystemShutdownW | Cette fonction permet d'annuler l'opération de fermeture ou de redémarrage en cours d'exécution du système d'exploitation Windows avec des paramètres de chaine de caractères étendue (Unicode).
AccessCheck | Cette fonction permet, à une application serveur, de vérifier les accès client à un objet de contrôle d'accès.
AccessCheckAndAuditAlarmA | Cette fonction permet d'effectuer validation d'accès et de provoquer le message approprié.
AccessCheckAndAuditAlarmW | Cette fonction permet d'effectuer une validation d'accès et de provoquer le message approprié avec des paramètres de chaine de caractères étendue (Unicode).
AddAccessAllowedAce | Cette fonction permet d'ajouter un accès autorisé à l'ACE d'un ACL.
AddAccessDeniedAce | Cette fonction permet d'ajouter un accès refusé à l'ACE d'un ACL.
AddAce | Cette fonction permet d'ajouter un ACE à un ACL spécifié.
AddAuditAccessAce | Cette fonction permet d'ajouter un ACE système à un ACL système.
AdjustTokenGroups | Cette fonction permet d'ajuster des groupes dans une liste d'objet à saisir.
AdjustTokenPrivileges | Cette fonction permet d'ajuster des prévilèges dans une liste d'objet à saisir.
AllocateAndInitializeSid | Cette fonction permet d'alloué ainsi que d'initialiser l'identificateur de sécurité (SID) avec jusqu'à 8 sous-autorités.
AllocateLocallyUniqueId | Cette fonction permet d'alloué un identificateur local unique (LUID).
AreAllAccessesGranted | Cette fonction permet d'effectuer la vérification sur un ensemble de requête d'accès garantie.
AreAnyAccessesGranted | Cette fonction permet d'effectuer la vérification sur n'importe quel élément d'un ensemble de requête d'accès garantie.
BackupEventLogA | Cette fonction permet d'effectuer une sauvegarde du journal de bord dans un fichier de copie de sécurité.
BackupEventLogW | Cette fonction permet d'effectuer une sauvegarde du journal de bord dans un fichier de copie de sécurité avec des paramètres de chaine de caractères étendue (Unicode).
ClearEventLogA | Cette fonction permet d'effacer le journal de bord spécifié et sauvegarde une copie du journal du bord courant dans un fichier si désiré.
ClearEventLogW | Cette fonction permet d'effacer le journal de bord spécifié et sauvegarde une copie du journal du bord courant dans un fichier si désiré avec des paramètres de chaine de caractères étendue (Unicode).
CloseEventLog | Cette fonction permet de fermer le fichier de journal de bord d'événement spécifié
CopySid | Cette fonction permet de copier l'identificateur de sécurité (SID) dans un tampon spécifié.
CreatePrivateObjectSecurity | Cette fonction permet d'alloué et d'initialiser un descripteur de sécurité relatif à l'objet pour un un serveur d'objet protégé.
CreateProcessAsUserA | Cette fonction permet de créer un nouveau processus et de le mettre comme processus primaire.
CreateProcessAsUserW | Cette fonction permet de créer un nouveau processus et de le mettre comme processus primaire avec des paramètres de chaine de caractères étendue (Unicode).
DeleteAce | Cette fonction permet d'effacer une entrée de contrôle d'accès (ACE) d'une liste de contrôle d'accès (ACL).
DeregisterEventSource | Cette fonction permet de fermer un identificateur Handle d'enregistrement d'événement retourner par une fonction «RegisterEventSource».
DestroyPrivateObjectSecurity | Cette fonction permet d'effacer un descripteur de sécurité d'un objet serveur protégé.
DuplicateToken | Cette fonction permet de créer un nouvel accès de jeton dupliqué sur un autre jeton déjà existant.
DuplicateTokenEx | Cette fonction permet d'effectuer la conversion d'un jeton spécifié par un jeton principal.
EqualPrefixSid | Cette fonction permet de vérifie sur les valeurs de deux préfixes SID (identificateur de sécurité) sont égales à l'exception de la dernière valeur de sous-autorité.
EqualSid | Cette fonction permet de vérifie sur les valeurs de deux préfixes SID (identificateur de sécurité) sont égales.
FindFirstFreeAce | Cette fonction permet de retourner un pointeur sur le premier octet de libre sur une liste de contrôle d'accès (ACL).
FreeSid | Cette fonction permet de libérer un identificateur de sécurité (SID) précédemment alloué par la fonction «AllocateAndInitializeSid».
GetAce | Cette fonction permet de demander un pointeur sur une structure d'une entrée de contrôle d'accès (ACE) d'une liste de contrôle d'accès (ACL).
GetAclInformation | Cette fonction permet de demander les informations concernant une liste de contrôle d'accès (ACL).
GetCurrentHwProfileA | Cette fonction permet de demander le profile matériel courant.
GetCurrentHwProfileW | Cette fonction permet de demander le profile matériel courant avec des paramètres de chaine de caractères étendue (Unicode).
GetFileSecurityA | Cette fonction permet de demander les informations spécifié sur la sécurité d'un fichier ou d'un répertoire.
GetFileSecurityW | Cette fonction permet de demander les informations spécifié sur la sécurité d'un fichier ou d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
GetKernelObjectSecurity | Cette fonction permet de demander une copie du descripteur de sécurité protégé d'un objet du noyau du système d'exploitation.
GetLengthSid | Cette fonction permet de retourner la longueur, en octets, d'une structure valide d'identificateur de sécurité (SID).
GetNumberOfEventLogRecords | Cette fonction permet de demander le nombre d'enregistrement de l'événement du journal de bord spécifié.
GetOldestEventLogRecord | Cette fonction permet de demander le nombre d'enregistrement dans les anciens enregistrement du journal de bord spécifié.
GetPrivateObjectSecurity | Cette fonction permet de demander des informations de descripteur de sécurité à un serveur d'objet protégé.
GetSecurityDescriptorControl | Cette fonction permet de demander le contrôle de descripteur de sécurité et les informations de révision.
GetSecurityDescriptorDacl | Cette fonction permet de demander un pointeur sur une liste de contrôle d'accès (ACL) discrétionnaire dans un descripteur de sécurité spécifié.
GetSecurityDescriptorGroup | Cette fonction permet de demander les informations de groupe primaire d'un descripteur de sécurité.
GetSecurityDescriptorLength | Cette fonction permet de retourner la longueur, en octets, d'une structure valide de descripteur de sécurité.
GetSecurityDescriptorOwner | Cette fonction permet de demander les informations du propriétaire d'un descripteur de sécurité
GetSecurityDescriptorSacl | Cette fonction permet de demander un pointeur sur la liste de contrôle d'accès système (ACL) dans un descripteur de sécurité spécifié.
GetSidIdentifierAuthority | Cette fonction permet de retourner l'adresse de la structure d'un «SID_IDENTIFIER_AUTHORITY» dans l'identificateur de sécurité (SID) spécifié.
GetSidLengthRequired | Cette fonction permet de retourner la longueur, en octets, d'un tampon requis pour l'entreposage d'une structure SID avec le nombre de sous-autorisation spécifié.
GetSidSubAuthority | Cette fonction permet de retourner l'adresse d'une sous-autorité spécifié d'une structure SID.
GetSidSubAuthorityCount | Cette fonction permet de retourner l'adresse d'un champs d'une structure SID contenant le compteur de sous-autorité.
GetTokenInformation | Cette fonction permet de demander le type d'information associé à un accès de jeton.
GetUserNameA | Cette fonction permet de demander le nom de l'utilisateur courant actuellement sous Windows.
GetUserNameW | Cette fonction permet de demander le nom de l'utilisateur courant actuellement sous le système d'exploitation Windows avec des paramètres de chaine de caractères étendue (Unicode).
ImpersonateLoggedOnUser | Cette fonction permet d'appeler une processus léger utilisateur impersonnel.
ImpersonateNamedPipeClient | Cette fonction permet de demander si l'application client a un nom de canal impersonnel.
ImpersonateSelf | Cette fonction permet de demander le jeton d'accès au contexte de sécurité impersonnel d'un processus appelant.
InitializeAcl | Cette fonction permet de créer une nouvelle structure de liste de contrôle d'accès (ACL).
InitializeSecurityDescriptor | Cette fonction permet d'initialiser un nouveau descripteur de sécurité.
InitializeSid | Cette fonction permet d'initialiser une structure d'identificateur de sécurité (SID).
InitiateSystemShutdownA | Cette fonction permet d'initier l'opération de fermeture ou de redémarrage en cours d'exécution du système d'exploitation Windows.
InitiateSystemShutdownW | Cette fonction permet d'initier l'opération de fermeture ou de redémarrage en cours d'exécution du système d'exploitation Windows avec des paramètres de chaine de caractères étendue (Unicode).
IsTextUnicode | Cette fonction permet de demander l'adresse du tampon contenant probablement une forme de texte Unicode.
IsValidAcl | Cette fonction permet de valider une liste de contrôle d'accès (ACL).
IsValidSecurityDescriptor | Cette fonction permet de valider une structure de descripteur de sécurité «SECURITY_DESCRIPTOR».
IsValidSid | Cette fonction permet de valider une structure SID en vérifiant que le numéro de version est situé dans le rang et les intervalles de nombres de sous-autorité.
LogonUserA | Cette fonction permet d'effectuer une opération de connexion d'un utilisateur.
LogonUserW | Cette fonction permet d'effectuer une opération de connexion d'un utilisateur avec des paramètres de chaine de caractères étendue (Unicode).
LookupAccountNameA | Cette fonction permet d'accepter le nom d'un système ou d'un compte en entrée.
LookupAccountNameW | Cette fonction permet d'accepter le nom d'un système ou d'un compte en entrée avec des paramètres de chaine de caractères étendue (Unicode).
LookupAccountSidA | Cette fonction permet d'accepter un identificateur de sécurité (SID) en entrée
LookupAccountSidW | Cette fonction permet d'accepter un identificateur de sécurité (SID) en entrée avec des paramètres de chaine de caractères étendue (Unicode).
LookupPrivilegeDisplayNameA | Cette fonction permet de demander le nom d'affichage représenté par le prévilège spécifié.
LookupPrivilegeDisplayNameW | Cette fonction permet de demander le nom d'affichage représenté par le prévilège spécifié avec des paramètres de chaine de caractères étendue (Unicode).
LookupPrivilegeNameA | Cette fonction permet de demander le nom correspondant au prévilège représenté par un système spécifié par identificateur local unique (LUID).
LookupPrivilegeNameW | Cette fonction permet de demander le nom correspondant au prévilège représenté par un système spécifié par identificateur local unique (LUID) avec des paramètres de chaine de caractères étendue (Unicode)
LookupPrivilegeValueA | Cette fonction permet de demander l'identificateur local unique (LUID) utilisé par un système spécifié par une représentation local d'un nom de prévilège.
LookupPrivilegeValueW | Cette fonction permet de demander l'identificateur local unique (LUID) utilisé par un système spécifié par une représentation local d'un nom de prévilège avec des paramètres de chaine de caractères étendue (Unicode)
MakeAbsoluteSD | Cette fonction permet de créer un descripteur de sécurité dans un format absolue en utilisant un gabarit de format relatif de descripteur de sécurité.
MakeSelfRelativeSD | Cette fonction permet de créer un descripteur de sécurité dans un format relatif en utilisant un gabarit de format absolue de descripteur de sécurité.
MapGenericMask | Cette fonction permet de générer une carte de masque de bon accès spécifié et de bon accès standard
NotifyChangeEventLog | Cette fonction permet de recevoir des avertissements d'application lorsqu'un événement écrit dans le fichier de journal de bord spécifié.
ObjectCloseAuditAlarmA | Cette fonction permet de généré des messages dans le journal de bord quand un identificateur Handle d'objet est supprimé.
ObjectCloseAuditAlarmW | Cette fonction permet de généré des messages dans le journal de bord quand un identificateur Handle d'objet est supprimé avec des paramètres de chaine de caractères étendue (Unicode).
ObjectDeleteAuditAlarmA | Cette fonction permet de supprimer un message dans le journal de bord.
ObjectDeleteAuditAlarmW | Cette fonction permet de supprimer un message dans le journal de bord avec des paramètres de chaine de caractères étendue (Unicode).
ObjectOpenAuditAlarmA | Cette fonction permet de générer des messages dans le journal de bord quand une application client tente d'obtenir l'accès à un objet ou dans créer un nouveau.
ObjectOpenAuditAlarmW | Cette fonction permet de générer des messages dans le journal de bord quand une application client tente d'obtenir l'accès à un objet ou dans créer un nouveau avec des paramètres de chaine de caractères étendue (Unicode).
ObjectPrivilegeAuditAlarmA | Cette fonction permet de générer un message dans le journal de bord quand un résultat d'un client est effectué avec des opérations de prévilège sur un serveur d'application déjà ouvert avec l'identificateur Handle de l'objet.
ObjectPrivilegeAuditAlarmW | Cette fonction permet de générer un message dans le journal de bord quand un résultat d'un client est effectué avec des opérations de prévilège sur un serveur d'application déjà ouvert avec l'identificateur Handle de l'objet avec des paramètres de chaine de caractères étendue (Unicode).
OpenBackupEventLogA | Cette fonction permet d'ouvrir un identificateur Handle pour un événement de copie de sauvegarde du journal de bord.
OpenBackupEventLogW | Cette fonction permet d'ouvrir un identificateur Handle pour un événement de copie de sauvegarde du journal de bord avec des paramètres de chaine de caractères étendue (Unicode).
OpenEventLogA | Cette fonction permet d'ouvrir un identificateur Handle d'un événement de journal de bord.
OpenEventLogW | Cette fonction permet d'ouvrir un identificateur Handle d'un événement de journal de bord avec des paramètres de chaine de caractères étendue (Unicode).
OpenProcessToken | Cette fonction permet d'ouvrir un accès de jeton associé avec un processus.
OpenThreadToken | Cette fonction permet d'ouvrir un accès de jeton associé avec un processus léger.
PrivilegeCheck | Cette fonction permet de tester le contexte de sécurité représenté par un accès de jeton spécifié contenu dans un prévilège spécifié.
PrivilegedServiceAuditAlarmA | Cette fonction permet de générer un message de journal de bord quand une opération de service de prévilège système s'effectue.
PrivilegedServiceAuditAlarmW | Cette fonction permet de générer un message de journal de bord quand une opération de service de prévilège système s'effectue avec des paramètres de chaine de caractères étendue (Unicode).
ReadEventLogA | Cette fonction permet de lire un nombre d'entrées spécifié dans un journal de bord des événements.
ReadEventLogW | Cette fonction permet de lire un nombre d'entrées spécifié dans un journal de bord des événements avec des paramètres de chaine de caractères étendue (Unicode).
RegCloseKey | Cette fonction permet de fermer le Handle de la clef de registre spécifié.
RegConnectRegistryA | Cette fonction permet d'établir une connexion avec un registre de Handle prédéfinie ou autre ordinateur.
RegConnectRegistryW | Cette fonction permet d'établir une connexion avec un registre de Handle prédéfinie ou autre ordinateur avec des paramètres de chaine de caractères étendue (Unicode).
RegCreateKeyA | Cette fonction permet de créer la clef de registre spécifié. Si la clef existe dans les registres, la fonction l'ouvre.
RegCreateKeyW | Cette fonction permet de créer la clef de registre spécifié avec des paramètres de chaine de caractères étendue (Unicode). Si la clef existe dans les registres, la fonction l'ouvre.
RegCreateKeyExA | Cette fonction permet de créer une clef de registre spécifié avec des systèmes de la famille NT. Si la clef existe dans les registres, la fonction l'ouvre.
RegCreateKeyExW | Cette fonction permet de créer une clef de registre spécifié avec des systèmes de la famille NT avec des paramètres de chaine de caractères étendue (Unicode). Si la clef existe dans les registres, la fonction l'ouvre.
RegDeleteKeyA | Cette fonction permet de supprimer la clef de registre spécifié.
RegDeleteKeyW | Cette fonction permet de supprimer la clef de registre spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegDeleteValueA | Cette fonction permet de supprimer la valeur du nom spécifié dans la clef de la base de registre.
RegDeleteValueW | Cette fonction permet de supprimer la valeur du nom spécifié dans la clef de la base de registre avec des paramètres de chaine de caractères étendue (Unicode).
RegEnumKeyA | Cette fonction permet d'énuméré les sous-clefs d'une clef de registre ouverte spécifié.
RegEnumKeyW | Cette fonction permet d'énuméré les sous-clefs d'une clef de registre ouverte spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegEnumKeyExA | Cette fonction permet d'énuméré les sous-clefs d'une clef de registre ouverte spécifié avec des systèmes de la famille NT.
RegEnumKeyExW | Cette fonction permet d'énuméré les sous-clefs d'une clef de registre ouverte spécifié avec des systèmes de la famille NT avec des paramètres de chaine de caractères étendue (Unicode).
RegEnumValueA | Cette fonction permet d'énuméré les valeurs pour la clef de registre ouverte spécifié.
RegEnumValueW | Cette fonction permet d'énuméré les valeurs pour la clef de registre ouverte spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegFlushKey | Cette fonction permet d'écrire tous les attributs de la clef de la base de registre ouverte spécifié.
RegGetKeySecurity | Cette fonction permet de copier le descripteur de sécurité de la clef de registre ouverte spécifié.
RegLoadKeyA | Cette fonction permet de créer une sous-clef dans «HKEY_USER» ou «HKEY_LOCAL_MACHINE» et d'entreposer les informations d'enregistrement dans le fichier spécifié d'une sous-clef.
RegLoadKeyW | Cette fonction permet de créer une sous-clef dans «HKEY_USER» ou «HKEY_LOCAL_MACHINE» et d'entreposer les informations d'enregistrement dans le fichier spécifié d'une sous-clef avec des paramètres de chaine de caractères étendue (Unicode).
RegNotifyChangeKeyValue | Cette fonction permet d'indiquer quand une clef de registre, ou élément rattaché à celle-ci, a changé.
RegOpenKeyA | Cette fonction permet d'ouvrir une clef spécifié dans une base de registre.
RegOpenKeyW | Cette fonction permet d'ouvrir une clef spécifié dans une base de registre avec des paramètres de chaine de caractères étendue (Unicode).
RegOpenKeyExA | Cette fonction permet d'ouvrir une clef spécifié dans une base de registre.
RegOpenKeyExW | Cette fonction permet d'ouvrir une clef spécifié dans une base de registre avec des paramètres de chaine de caractères étendue (Unicode).
RegQueryInfoKeyA | Cette fonction permet de demander les informations d'une clef de registre spécifié.
RegQueryInfoKeyW | Cette fonction permet de demander les informations d'une clef de registre spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegQueryMultipleValuesA | Cette fonction permet de demander le type et la donnée pour une liste de noms de valeur associé avec une clef de registre ouverte.
RegQueryMultipleValuesW | Cette fonction permet de demander le type et la donnée pour une liste de noms de valeur associé avec une clef de registre ouverte avec des paramètres de chaine de caractères étendue (Unicode).
RegQueryValueA | Cette fonction permet de demander la valeur associé avec une valeur non-nommé pour la clef du registre spécifié.
RegQueryValueW | Cette fonction permet de demander la valeur associé avec une valeur non-nommé pour la clef du registre spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegQueryValueExA | Cette fonction permet de demander la valeur associé avec une valeur non-nommé pour la clef du registre spécifié avec des systèmes de la famille NT.
RegQueryValueExW | Cette fonction permet de demander la valeur associé avec une valeur non-nommé pour la clef du registre spécifié avec des systèmes de la famille NT avec des paramètres de chaine de caractères étendue (Unicode).
RegReplaceKeyA | Cette fonction permet de remplacer un fichier de copie de sauvegarde d'un clef et tous les sous-clef d'une autre fichier.
RegReplaceKeyW | Cette fonction permet de remplacer un fichier de copie de sauvegarde d'un clef et tous les sous-clef d'une autre fichier avec des paramètres de chaine de caractères étendue (Unicode).
RegRestoreKeyA | Cette fonction permet de lire des informations registre dans un fichier spécifié et de copier la clef spécifié.
RegRestoreKeyW | Cette fonction permet de lire des informations registre dans un fichier spécifié et de copier la clef spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegSaveKeyA | Cette fonction permet de sauvegarder tous les clefs, sous-clefs et les valeurs spécifié dans un nouveau fichier.
RegSaveKeyW | Cette fonction permet de sauvegarder tous les clefs, sous-clefs et les valeurs spécifié dans un nouveau fichier avec des paramètres de chaine de caractères étendue (Unicode).
RegSetKeySecurity | Cette fonction permet fixer la sécurité d'une clef de registre ouvert.
RegSetValueA | Cette fonction permet d'associer une valeur avec une clef spécifié.
RegSetValueW | Cette fonction permet d'associer une valeur avec une clef spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegSetValueExA | Cette fonction permet d'entreposer les données d'un champs de valeur d'une clef de registre ouvert.
RegSetValueExW | Cette fonction permet d'entreposer les données d'un champs de valeur d'une clef de registre ouvert avec des paramètres de chaine de caractères étendue (Unicode).
RegUnLoadKeyA | Cette fonction permet de décharger la clef et sous-clefs de registre spécifié
RegUnLoadKeyW | Cette fonction permet de décharger la clef et sous-clefs de registre spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RegisterEventSourceA | Cette fonction permet de retourner l'identificateur Handle utilisé avec la fonction d'événement «ReportEvent» du journal de bord.
RegisterEventSourceW | Cette fonction permet de retourner l'identificateur Handle utilisé avec la fonction d'événement «ReportEvent» du journal de bord avec des paramètres de chaine de caractères étendue (Unicode).
ReportEventA | Cette fonction permet d'écrire une entrée à la fin du journal de bord des événements spécifié.
ReportEventW | Cette fonction permet d'écrire une entrée à la fin du journal de bord des événements spécifié avec des paramètres de chaine de caractères étendue (Unicode).
RevertToSelf | Cette fonction permet de terminé la personnification d'une application client.
SetAclInformation | Cette fonction permet de fixer les informations à propos de la liste de contrôle d'accès (ACL).
SetFileSecurityA | Cette fonction permet de fixer la sécurité d'un objet de fichier ou d'un répertoire.
SetFileSecurityW | Cette fonction permet de fixer la sécurité d'un objet de fichier ou d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
SetKernelObjectSecurity | Cette fonction permet de fixer la sécurité de l'objet du noyau du système d'exploitation.
SetPrivateObjectSecurity | Cette fonction permet de modifier un descripteur de sécurité d'objet privé.
SetSecurityDescriptorDacl | Cette fonction permet de fixer les informations dans une liste de contrôle d'accès (ACL) discrétionnaire.
SetSecurityDescriptorGroup | Cette fonction permet de fixer le groupe primaire d'information d'un format absolue de descripteur de sécurité, remplacer par un groupe d'information primaire déjà présent dans un descripteur de sécurité.
SetSecurityDescriptorOwner | Cette fonction permet de fixer les informations de propriétaire d'un format absolue de descripteur de sécurité.
SetSecurityDescriptorSacl | Cette fonction permet de fixer les informations d'une liste de contrôle d'accès (ACL) système.
SetThreadToken | Cette fonction permet de fixer une personnification de jeton à un processus léger.
SetTokenInformation | Cette fonction permet de fixer une variété de type d'information pour un accès à un jeton spécifié.


C pour Windows - EXE, DLL et modules de Windows - «comctl32.dll»

Description

Ce fichier contient la bibliothèque d'API de contrôle de boîte de dialogue commune.

Liste des fonctions d'API Windows

Nom de l'API | Description
CreateStatusWindowA | Cette fonction permet d'effectuer la création d'une barre d'état dans le bas d'une fenêtre d'application
InitCommonControlsEx | Cette fonction permet d'initialiser une classe de contrôle commun.


C pour Windows - EXE, DLL et modules de Windows - «comdlg32.dll»

Description

Ce fichier contient la bibliothèque d'API de boîte de dialogue commune.

Liste des fonctions d'API Windows

Nom de l'API | Description
ChooseColorA | Cette fonction permet de lancer une boite de dialogue offrant la possibilité à l'utilisateur de choisir une couleur
ChooseFontA | Cette fonction permet de lancer une boite de dialogue offrant la possibilité à l'utilisateur de choisir une police de caractères
GetOpenFileNameA | Cette fonction permet d'afficher une boite de dialogue offrant la possibilité de choisir un fichier.
PrintDlgA | Cette fonction permet d'afficher une boite de dialogue d'impression.


C pour Windows - EXE, DLL et modules de Windows - «diskcopy.dll»

Description

Ce fichier contient la bibliothèque d'outil pour copier des unités de disquette.

Liste des fonctions d'API Windows

Nom de l'API | Description
DiskCopyRunDll | Cette fonction permet de lancer une boite de dialogue offrant la possibilité d'effectuer une copie d'unité de disquette


C pour Windows - EXE, DLL et modules de Windows - «dlcapi.dll»

Description

Ce fichier contient la bibliothèque d'API de la gestion du protocole DLC (Data Link Control).

Liste des fonctions d'API Windows

Nom de l'API | Description
AcsLan | Cette fonction permet de communiquer avec d'autres ordinateurs ou par périphérique réseau, comme des imprimantes, en utilisant le protocole DLC (Data Link Control).

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «gdi32.dll»

Description

Ce fichier contient la bibliothèque d'interface graphique 32 bits.

Liste des fonctions d'API Windows

Nom de l'API | Description
AbortDoc | Cette fonction permet d'effectuer l'annulation d'une impression d'un document.
AbortPath | Cette fonction permet de terminer et de restituer toutes les palettes du périphérique de contexte.
AddFontResourceA | Cette fonction permet d'ajouter une police de caractères à partir d'un fichier.
AddFontResourceW | Cette fonction permet d'ajouter une police de caractères à partir d'un fichier avec des paramètres de chaine de caractères étendues (Unicode).
AngleArc | Cette fonction permet de dessiner une ligne de segment et d'un arc de cercle.
AnimatePalette | Cette fonction permet de fixer la valeur des palettes de couleur logique.
Arc | Cette fonction permet de dessiner l'arc d'une ellipse.
ArcTo | Cette fonction permet de dessiner un arc d'une ellipse.
BeginPath | Cette fonction permet d'ouvrir une braquette de chemin pour le périphérique de contexte (DC) spécifié.
BitBlt | Cette fonction permet d'effectuer la copie d'un Bitmap vers l'écran.
CancelDC | Cette fonction permet d'annuler une opération en attente pour le périphérique de contexte (DC) spécifié.
CheckColorsInGamut | Cette fonction permet d'indiquer si les valeurs de couleurs spécifiés sont dans la gamme du périphérique spécifié.
ChoosePixelFormat | Cette fonction permet de tenter de faire correspondre à un format de pixel approprié supporté par un périphérique de contexte d'un format de pixel donné spécifié.
Chord | Cette fonction permet de dessiner la corde de limite à l'aide d'une intersection d'une ellipse avec le centre d'un rectangle et d'une ligne de segment.
CloseEnhMetaFile | Cette fonction permet de fermer un périphérique de contexte de fichier méta étendue et retourne le Handle identifiant un format de fichier méta étendue.
CloseFigure | Cette fonction permet de fermer une figure dans une spécification de chemin.
CloseMetaFile | Cette fonction permet de fermer et de créer le fichier de méta pour pouvoir jouer son contenu.
ColorMatchToTarget | Cette fonction permet d'activer ou désactiver le prévisualisation du périphérique de contexte spécifié.
CombineRgn | Cette fonction permet de créer une nouvelle région pour combiné deux régions existantes.
CombineTransform | Cette fonction permet d'effectuer la concaténation de double espace mondiale vers une transformation d'espace de page.
CopyEnhMetaFileA | Cette fonction permet de copier le contenu d'un fichier méta de format étendue vers un fichier spécifié.
CopyEnhMetaFileW | Cette fonction permet de copier le contenu d'un fichier méta de format étendue vers un fichier spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CopyMetaFileA | Cette fonction permet de copier le contenu d'un format de méta fichier Windows vers un fichier spécifié.
CopyMetaFileW | Cette fonction permet de copier le contenu d'un format de méta fichier Windows vers un fichier spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CreateBitmap | Cette fonction permet de créer un périphérique de Bitmap en mémoire avec la largeur, hauteur et la palette de bits spécifié.
CreateBitmapIndirect | Cette fonction permet de créer un Bitmap avec la largeur, la hauteur et la palette de bits spécifié dans une structure BITMAP.
CreateBrushIndirect | Cette fonction permet de créer une brosse avec le style, la couleur et la palette spécifié dans la structure «LOGBRUSH».
CreateColorSpaceA | Cette fonction permet de créer un espace de couleur logique.
CreateColorSpaceW | Cette fonction permet de créer un espace de couleur logique avec des paramètres de chaine de caractères étendues (Unicode).
CreateCompatibleBitmap | Cette fonction permet de créer un Bitmap compatible avec le périphérique spécifié.
CreateCompatibleDC | Cette fonction permet de créer un contexte de périphérique mémoire compatible avec le périphérique spécifié.
CreateDCA | Cette fonction permet d'effectuer la création d'un objet de contexte (DC)
CreateDCW | Cette fonction permet d'effectuer la création d'un objet de contexte (DC) avec des paramètres de chaines de caractères étendues (Unicode).
CreateDIBPatternBrush | Cette fonction permet de créer une brosse avec la palette spécifié par un périphérique de Bitmap indépendant (DIB).
CreateDIBPatternBrushPt | Cette fonction permet de créer une brosse logique avec la palette spécifié par un périphérique de Bitmap indépendant (DIB).
CreateDIBSection | Cette fonction permet de créer un Bitmap de périphérique indépendant (DIB) avec les applications pouvant y être écrit directement.
CreateDIBitmap | Cette fonction permet de créer un périphérique mémoire spécifié pour un périphérique de Bitmap indépendant (DIB) spécifié et un ensemble de bits optionnel pour le Bitmap.
CreateDiscardableBitmap | Cette fonction permet de créer un Bitmap compatible avec un périphérique spécifié.
CreateEllipticRgn | Cette fonction permet de créer une région elliptique.
CreateEllipticRgnIndirect | Cette fonction permet de créer une région elliptique à l'aide d'une structure de données.
CreateEnhMetaFileA | Cette fonction permet de créer un contexte de périphérique pour un méta fichier de format étendue.
CreateEnhMetaFileW | Cette fonction permet de créer un contexte de périphérique pour un méta fichier de format étendue avec des paramètres de chaine de caractères étendues (Unicode).
CreateFontA | Cette fonction permet d'effectuer la création d'une police de caractères logique avec les caractéristiques spécifiés.
CreateFontIndirectA | Cette fonction permet de créer une police de caractères logique avec les caractéristiques spécifié dans la structure spécifié.
CreateFontIndirectW | Cette fonction permet de créer une police de caractères logique avec les caractéristiques spécifié dans la structure spécifié avec les paramètres de chaines de caractères étendues (Unicode).
CreateFontW | Cette fonction permet d'effectuer la création d'une police de caractères logique avec les caractéristiques spécifiés avec les paramètres de chaine de caractères étendues (Unicode).
CreateHalftonePalette | Cette fonction permet de créer une demi-teinte d'une palette pour le périphérique de contexte spécifié.
CreateHatchBrush | Cette fonction permet de créer une brosse logique spécifiant un motif de hachure et de couleur.
CreateICA | Cette fonction permet de créer une information de contexte pour un périphérique spécifié.
CreateICW | Cette fonction permet de créer une information de contexte pour un périphérique spécifié avec des paramètres de chaines de caractères étendues (Unicode).
CreateMetaFileA | Cette fonction permet de créer un périphérique de contexte pour un format de fichier méta Windows.
CreateMetaFileW | Cette fonction permet de créer un périphérique de contexte pour un format de fichier méta Windows avec des paramètres de chaines de caractères étendues (Unicode).
CreatePalette | Cette fonction permet d'effectuer la création d'une palette logique.
CreatePatternBrush | Cette fonction permet d'effectuer la création d'une brosse logique avec la palette Bitmap spécifié.
CreatePen | Cette fonction permet d'effectuer la création d'un crayon logique avec le style, la largeur et la couleur spécifié.
CreatePenIndirect | Cette fonction permet d'effectuer la création d'un crayon logique avec le style, la largeur et la couleur à l'aide la structure de données spécifié.
CreatePolyPolygonRgn | Cette fonction permet d'effectuer la création d'une région contenant une série de fermeture de polygone.
CreatePolygonRgn | Cette fonction permet d'effectuer la création d'une région en forme de polygone.
CreateRectRgn | Cette fonction permet d'effectuer la création d'une région rectangulaire.
CreateRectRgnIndirect | Cette fonction permet d'effectuer la création d'une région rectangulaire à l'aide d'une structure de données.
CreateRoundRectRgn | Cette fonction permet d'effectuer la création d'une région rectangulaire avec les coins arrondies.
CreateScalableFontResourceA | Cette fonction permet de créer un fichier de ressource de police de caractères avec une police de caractères vectorielle.
CreateScalableFontResourceW | Cette fonction permet de créer un fichier de ressource de police de caractères avec une police de caractères vectorielle avec des paramètres de chaine de caractères étendue (Unicode).
CreateSolidBrush | Cette fonction permet d'effectuer la création d'une brosse logique avec la couleur et le motif solide spécifié.
DeleteColorSpace | Cette fonction permet de supprimer l'espace de couleur spécifié et libérer tous les ressources internes associé avec celui-ci.
DeleteDC | Cette fonction permet d'effectuer la suppression d'un périphérique de contexte (DC).
DeleteEnhMetaFile | Cette fonction permet de supprimer le format étendue du fichier méta ou le Handle du fichier méta de format étendue.
DeleteMetaFile | Cette fonction permet de supprimer un fichier de méta de format Windows ou le Handle d'un fichier méta de format Windows.
DeleteObject | Cette fonction permet de supprimer un crayon, une brosse, une police de caractères, un Bitmap ou une palette logique et d'ainsi libérer les ressources systèmes associé avec cette objet.
DescribePixelFormat | Cette fonction permet de demander les informations à propos du format d'un pixel spécifié d'un périphérique spécifié.
DeviceCapabilitiesExA | Cette fonction permet de demander la compatibilité pour le pilote d'imprimante spécifié.
DeviceCapabilitiesExW | Cette fonction permet de demander la compatibilité pour le pilote d'imprimante spécifié avec des paramètres de chaine de caractères étendues (Unicode).
DPtoLP | Cette fonction permet d'effectuer la conversion des coordonnées d'un périphérique en coordonnées logique.
DrawEscape | Cette fonction permet d'accéder à la compatibilité de dessinage de l'affichage d'un vidéo n'étant pas directement disponible par le GDI (Graphics Device Interface).
Ellipse | Cette fonction permet d'effectuer l'afficher d'une ellipse (forme d'ovale).
EndDoc | Cette fonction permet d'indiquer que l'application a terminé d'envoyer des données au tampon d'impression de l'imprimante.
EndPage | Cette fonction permet d'indiquer que l'application a terminé d'envoyer une page de données au tampon d'impression de l'imprimante.
EndPath | Cette fonction permet de fermer une braquette de chemin et sélectionne le chemin définit par la braquette dans le périphérique de contexte (DC) spécifié.
EnumEnhMetaFile | Cette fonction permet d'énumérer les enregistrements d'un format étendue d'un méta fichier afin de demander chaques enregistrements et de les passés par une fonction utilisateur.
EnumFontFamiliesA | Cette fonction permet d'énumérer les polices de caractères d'une famille de police de caractères spécifié étant disponible pour un périphérique spécifié.
EnumFontFamiliesW | Cette fonction permet d'énumérer les polices de caractères d'une famille de police de caractères spécifié étant disponible pour un périphérique spécifié avec des paramètres de chaine de caractères étendues (Unicode).
EnumFontFamiliesExA | Cette fonction permet d'énumérer toutes les polices de caractères système correspondant aux caractéristiques de polices de caractères spécifié par une structure.
EnumFontFamiliesExW | Cette fonction permet d'énumérer toutes les polices de caractères système correspondant aux caractéristiques de polices de caractères spécifié par une structure avec des paramètres de chaine de caractères étendues (Unicode).
EnumFontsA | Cette fonction permet d'énumérer les polices de caractères disponibles pour le périphérique spécifié.
EnumFontsW | Cette fonction permet d'énumérer les polices de caractères disponibles pour le périphérique spécifié avec des paramètres de chaine de caractères étendues (Unicode).
EnumICMProfilesA | Cette fonction permet d'énumérer les différents profiles de couleurs étant supporté par le système pour le périphérique de contexte spécifié.
EnumICMProfilesW | Cette fonction permet d'énumérer les différents profiles de couleurs étant supporté par le système pour le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
EnumMetaFile | Cette fonction permet de demander d'énumérer les enregistrements de fichier méta de format Windows en utilisant une fonction d'application utilisateur.
EnumObjects | Cette fonction permet d'énumérer les crayons et les brosses disponibles pour le périphérique de contexte spécifié.
EqualRgn | Cette fonction permet de demander lequel des deux régions spécifiés sont égales par comparaison des coordonnées de leur coin supérieur gauche et de leur coin inférieur droit.
Escape | Cette fonction permet d'activer les applications de compatibilité d'accès d'un périphérique particulier non accessible directement par le GDI.
ExcludeClipRect | Cette fonction permet de créer une nouvelle région de Clip consistant en une minuscule région existante du rectangle spécifié.
ExtCreatePen | Cette focntion permet de créer un crayon cosmétique ou géométrique logique ayant les attributs de style, de largeur et brosses spécifiés.
ExtCreateRegion | Cette fonction permet de créer une région avec la région et la transformation de données spécifié.
ExtEscape | Cette fonction permet d'allouer les applications vers une capacité d'accès d'un périphérique particulier n'étant pas disponible pour le GDI.
ExtFloodFill | Cette fonction permet de remplir une région d'une surface d'affichage avec la brosse courante.
ExtSelectClipRgn | Cette fonction permet de combiner la région spécifié avec la région de capture courante en utilisant le mode spécifié.
ExtTextOutA | Cette fonction permet de dessiner une chaine de caractères en utilisant la police de caractères courante.
ExtTextOutW | Cette fonction permet de dessiner une chaine de caractères en utilisant la police de caractères courante avec des paramètres de chaines de caractères étendues (Unicode).
FillPath | Cette fonction permet de fermer n'importe quel figures ouvertes dans le chemin courant et remplis l'intérieur du chemin en utilisant la brosses courante et le mode de remplissage de polygone.
FillRgn | Cette fonction permet de remplir la région avec le brosse spécifié.
FlattenPath | Cette fonction permet de transformer n'importe quel courbe d'un chemin étant sélectionné dans le périphérique de contexte courant de façon à tourner chaque courbe une séquences de lignes.
FloodFill | Cette fonction permet d'effectuer le remplissage d'une région de la surface de l'écran en utilisant la brosse courante.
FrameRgn | Cette fonction permet de dessiner une bordure entourant une région spécifié et en utilisant la brosse spécifié.
GdiComment | Cette fonction permet de copier un commentaire d'un tampon vers un méta fichier spécifié de format étendue.
GdiFlush | Cette fonction permet de vider le traitement en lot courant du processus appelant.
GdiGetBatchLimit | Cette fonction permet de retourner le nombre maximum d'appels de fonction étant accumulé dans le traitement par lot courant du processus léger courant.
GdiSetBatchLimit | Cette fonction permet de fixer le nombre maximum d'appels de fonction étant accumulé dans le traitement par lot courant du processus léger courant.
GetArcDirection | Cette fonction permet de demander la direction de l'arc courant pour le périphérique de contexte spécifié.
GetAspectRatioFilterEx | Cette fonction permet de demander l'ajustement de filtre d'aspect ratio courant.
GetBitmapBits | Cette fonction permet de copier les bits du Bitmap spécifié dans un tampon.
GetBitmapDimensionEx | Cette fonction permet de demander les dimensions d'un Bitmap.
GetBkColor | Cette fonction permet de retourner la couleur d'arrière-plan courante.
GetBkMode | Cette fonction permet de demander le mode mixte d'arrière-plan pour le contexte de périphérique spécifié.
GetBoundsRect | Cette fonction permet de retourner l'accumulation d'informations de limite rectangulaire d'un périphérique de contexte.
GetBrushOrgEx | Cette fonction permet de demander l'origine de la brosse courante dans un périphérique de contexte courant.
GetCharABCWidthsA | Cette fonction permet de demander la largeur, dans son unité de mesure logique, de caractères consécutifs dans une rangée données d'une police de caractères TrueType courant.
GetCharABCWidthsW | Cette fonction permet de demander la largeur, dans son unité de mesure logique, de caractères consécutifs dans une rangée données d'une police de caractères TrueType courant avec des paramètres de chaines de caractères étendues (Unicode).
GetCharABCWidthsFloatA | Cette fonction permet de demander la largeur, dans son unité de mesure logique, de caractères consécutifs dans une rangée données d'une police de caractères courant.
GetCharABCWidthsFloatW | Cette fonction permet de demander la largeur, dans son unité de mesure logique, de caractères consécutifs dans une rangée données d'une police de caractères courant avec des paramètres de chaine de caractères étendues (Unicode).
GetCharWidth32A | Cette fonction permet demander la largeur, dans des coordonnées logiques, de caractères consécutifs dans une rangée spécifié d'une police de caractères courante.
GetCharWidth32W | Cette fonction permet demander la largeur, dans des coordonnées logiques, de caractères consécutifs dans une rangée spécifié d'une police de caractères courante avec des paramètres de chaine de caractères étendues (Unicode).
GetCharWidthA | Cette fonction permet demander la largeur, dans des coordonnées logiques, de caractères consécutifs dans une rangée spécifié d'une police de caractères courante dans un contexte de compatibilité avec les fonctions 16 bits.
GetCharWidthW | Cette fonction permet demander la largeur, dans des coordonnées logiques, de caractères consécutifs dans une rangée spécifié d'une police de caractères courante dans un contexte de compatibilité avec les fonctions 16 bits avec des paramètres de chaine de caractères étendues (Unicode).
GetCharWidthFloatA | Cette fonction permet de demander la largeur fractionné de caractères consécutifs dans une rangée spécifié de la police de caractères courante.
GetCharWidthFloatW | Cette fonction permet de demander la largeur fractionné de caractères consécutifs dans une rangée spécifié de la police de caractères courante avec des paramètres de chaine de caractères étendues (Unicode).
GetCharacterPlacementA | Cette fonction permet de demander les informations à propos d'une chaine de caractères, comme la largeur des caractères, le positionnement des carets, l'ordre dans la chaine de caractères et la rendue du glyphe.
GetCharacterPlacementW | Cette fonction permet de demander les informations à propos d'une chaine de caractères, comme la largeur des caractères, le positionnement des carets, l'ordre dans la chaine de caractères et la rendue du glyphe avec des paramètres de chaine de caractères étendues (Unicode).
GetClipBox | Cette fonction permet de demander les dimensions d'un petit rectangle complètement contenu dans la région de clip courant.
GetClipRgn | Cette fonction permet de demander le Handle d'une région de clip affecté par un périphérique de contexte spécifié.
GetColorAdjustment | Cette fonction permet de demander les valeurs de couleurs d'ajustement pour le contexte de périphérique spécifié.
GetColorSpace | Cette fonction permet de demander le Handle courant de l'espace de couleur logique du périphérique de contexte spécifié.
GetCurrentObject | Cette fonction permet de retourner l'objet sélectionné courant du type spécifié.
GetCurrentPositionEx | Cette fonction permet de demander la position courante dans des coordonnées logiques.
GetDCOrgEx | Cette fonction permet de demander l'origine de translation final d'un périphérique de contexte spécifié.
GetDeviceCaps | Cette fonction permet de demander les informations d'un périphérique spécifié à propos du périphérique d'affichage.
GetDeviceGammaRamp | Cette fonction permet de demander la rampe gamma d'un panneau d'affichage de couleur directe.
GetDIBColorTable | Cette fonction permet de demander les valeurs de couleurs RVB (rouge, vert, bleu) d'une rangée d'entrées d'une table de couleurs d'une section DIB Bitmap étant actuellement sélectionné dans un périphérique de contexte spécifié.
GetDIBits | Cette fonction permet de demander les bits d'un Bitmap compatible et copie celui-ci dans un tampon DIB en utilisant le format spécifié.
GetEnhMetaFileA | Cette fonction permet de créer un Handle étant identifié par un fichier méta de format étendue entreposé dans le fichier spécifié.
GetEnhMetaFileW | Cette fonction permet de créer un Handle étant identifié par un fichier méta de format étendue entreposé dans le fichier spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetEnhMetaFileBits | Cette fonction permet de demander le contenu d'un fichier méta spécifié de format étendue et le copie dans un tampon.
GetEnhMetaFileDescriptionA | Cette fonction permet de demander une description texte optionnel d'un fichier méta de format étendue et copie la chaine de caractères dans un tampon spécifié.
GetEnhMetaFileDescriptionW | Cette fonction permet de demander une description texte optionnel d'un fichier méta de format étendue et copie la chaine de caractères dans un tampon spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetEnhMetaFileHeader | Cette fonction permet de demander l'enregistrement contenu dans l'entête du fichier méta spécifié de format étendue.
GetEnhMetaFilePaletteEntries | Cette fonction permet de demander les entrées de palette optionnel pour le fichier méta étendue spécifié.
GetEnhMetaFilePixelFormat | Cette fonction permet de demander les informations de format de pixel pour un fichier méta étendue.
GetFontData | Cette fonction permet de demander les données de police de caractères métriques pour une police de caractères TrueType.
GetFontLanguageInfo | Cette fonction permet de retourner les informations à propos de sélection de police de caractères courante dans l'affichage de contexte spécifié.
GetGlyphOutlineA | Cette fonction permet de demander ligne de limite ou du Bitmap d'un caractère d'une police de caractères TrueType étant sélectionné dans le périphérique de contexte spécifié.
GetGlyphOutlineW | Cette fonction permet de demander ligne de limite ou du Bitmap d'un caractère d'une police de caractères TrueType étant sélectionné dans le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetGraphicsMode | Cette fonction permet de demander le mode graphique courant pour le périphérique de contexte courant.
GetICMProfileA | Cette fonction permet de demander le nom du fichier de profile de couleurs pour le périphérique associé avec le périphérique de contexte spécifié.
GetICMProfileW | Cette fonction permet de demander le nom du fichier de profile de couleurs pour le périphérique associé avec le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetKerningPairs | Cette fonction permet de demander les paires de crénages de caractères pour la police de caractères courante sélectionné du périphérique de contexte spécifié.
GetLogColorSpaceA | Cette fonction permet de demander les informations à propos de l'espace de couleurs logiques identifié par le Handle spécifié.
GetLogColorSpaceW | Cette fonction permet de demander les informations à propos de l'espace de couleurs logiques identifié par le Handle spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetMapMode | Cette fonction permet de demander le mode de cartographie courant.
GetMetaFileA | Cette fonction permet de créer un Handle identifiant le format Windows de fichier de méta données.
GetMetaFileW | Cette fonction permet de créer un Handle identifiant le format Windows de fichier de méta données avec des paramètres de chaine de caractères étendues (Unicode).
GetMetaFileBitsEx | Cette fonction permet de demander le contenu d'un fichier méta de format Windows et copie le contenu dans un tampon spécifié.
GetMetaRgn | Cette fonction permet de demander la région méta courante pour le périphérique de contexte spécifié.
GetMiterLimit | Cette fonction permet de demander la limite mitre pour le périphérique de contexte spécifié.
GetNearestColor | Cette fonction permet de demander la couleur solide correspondant le mieux à la couleur logique.
GetNearestPaletteIndex | Cette fonction permet de demander l'index d'une entrée de palette logique correspondant le mieux à la valeur de couleur spécifié.
GetObjectA | Cette fonction permet de remplir un tampon avec les informations définit dans la région spécifié.
GetObjectW | Cette fonction permet de remplir un tampon avec les informations définit dans la région spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetObjectType | Cette fonction permet de demander l'identifiant de type d'objet spécifié.
GetOutlineTextMetricsA | Cette fonction permet de demander le métrique du texte pour la police de caractères TrueType.
GetOutlineTextMetricsW | Cette fonction permet de demander le métrique du texte pour la police de caractères TrueType avec des paramètres de chaine de caractères étendues (Unicode).
GetPaletteEntries | Cette fonction permet de demander le rang des entrées d'une palette dans une palette logique.
GetPath | Cette fonction permet de demander les coordonnées définit par des points de fin de lignes et une courbe de point de contrôle trouvé dans un chemin étant sélectionné dans un périphérique de contexte spécifié.
GetPixel | Cette fonction permet de demander la couleur sous format RVB (RGB) d'un pixel affiché à l'écran.
GetPixelFormat | Cette fonction permet de demander l'index du format de pixel actuellement sélectionné dans le périphérique de contexte spécifié.
GetPolyFillMode | Cette fonction permet de demander le mode de remplissage d'un polygone.
GetRasterizerCaps | Cette fonction permet de retourner les drapeaux indiquant si la police de caractères TrueType est installé dans le système.
GetRegionData | Cette fonction permet de remplir le tampons spécifié avec une région de données décrites.
GetRgnBox | Cette fonction permet de demander les coordonnées des limites rectangulaires d'une région spécifié.
GetROP2 | Cette fonction permet de demander le mode dessinage courant.
GetStockObject | Cette fonction permet de demander le Handle d'un des outils de stylo, brosse, police de caractères,... des objets de Windows
GetStretchBltMode | Cette fonction permet de demander le mode d'étirement du Bitmap courant.
GetSystemPaletteEntries | Cette fonction permet de demander un rang dans les entrées de palette de la palette système.
GetSystemPaletteUse | Cette fonction permet de demander si une application est accessible à une palette d'entrée système.
GetTextAlign | Cette fonction permet de demander l'état des drapeaux d'alignement de texte pour un périphérique de contexte spécifié.
GetTextCharacterExtra | Cette fonction permet de demander l'ajustement courant pour la quantité d'espacement entre les caractères.
GetTextCharset | Cette fonction permet de demander les informations à propos d'un ensemble de caractères de la police de caractères actuellement sélectionné.
GetTextCharsetInfo | Cette fonction permet de demander les informations supplémentaires à propos de l'ensemble de caractères de la police de caractères actuellement sélectionné.
GetTextColor | Cette fonction permet de demander la couleur de texte courante.
GetTextExtentExPointA | Cette fonction permet de demander le nombre de caractères dans la chaine de caractères correspondant à l'espace spécifié et remplit un tableau avec le texte étendue pour chacun de ses caractères.
GetTextExtentExPointW | Cette fonction permet de demander le nombre de caractères dans la chaine de caractères correspondant à l'espace spécifié et remplit un tableau avec le texte étendue pour chacun de ses caractères avec des paramètres de chaine de caractères étendues (Unicode).
GetTextExtentPoint32A | Cette fonction permet de calculer la largeur et la hauteur de la chaine de caractères de texte spécifié.
GetTextExtentPoint32W | Cette fonction permet de calculer la largeur et la hauteur de la chaine de caractères de texte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetTextExtentPointA | Cette fonction permet de calculer la largeur et la hauteur d'un chaine de caractères de texte spécifié dans un contexte de compatibilité 16 bits.
GetTextExtentPointW | Cette fonction permet de calculer la largeur et la hauteur d'un chaine de caractères de texte spécifié dans un contexte de compatibilité 16 bits avec des paramètres de chaine de caractères étendues (Unicode).
GetTextFaceA | Cette fonction permet de demander le nom de type de police de caractères étant sélectionné dans le périphérique de contexte spécifié.
GetTextFaceW | Cette fonction permet de demander le nom de type de police de caractères étant sélectionné dans le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetTextMetricsA | Cette fonction permet de demander les informations métriques d'une police de caractères courante.
GetTextMetricsW | Cette fonction permet de demander les informations métriques d'une police de caractères courante avec des paramètres de chaine de caractères étendues (Unicode).
GetViewportExtEx | Cette fonction permet de demander les extensions X et Y d'un point de vue d'un périphérique de contexte.
GetViewportOrgEx | Cette fonction permet de demander les coordonnées X et Y d'origine d'une association de point vue avec un périphérique de contexte spécifié.
GetWinMetaFileBits | Cette fonction permet de convertir des enregistrements de format étendue en enregistrement de format Windows de fichier méta et d'entreposer les enregistrements convertie dans le tampon spécifié.
GetWindowExtEx | Cette fonction permet de demander les extensions X et Y d'une fenêtre associé avec un périphérique de contexte spécifié.
GetWindowOrgEx | Cette fonction permet de demander les coordonnées X et Y d'origine de la fenêtre associé avec le périphérique de contexte spécifié.
GetWorldTransform | Cette fonction permet de demander l'espace mondiale courant vers la transformation d'espace de page.
IntersectClipRect | Cette fonction permet de créer une nouvelle région de capture vers l'intersection de la région courante et du rectangle spécifié.
InvertRgn | Cette fonction permet d'inverser les couleurs d'une région spécifié.
LineDDA | Cette fonction permet de calculer tous les points successifs d'une ligne spécifié par les coordonnées de début et de fin.
LineTo | Cette fonction permet de tracer une ligne des coordonnées courante à la position spécifié.
LPtoDP | Cette fonction permet de convertir les coordonnées logiques (points) en coordonnées d'un périphérique.
MaskBlt | Cette fonction permet de fusionner les données de couleur du Bitmap de la source et la destination en utilisant les opérations de masque et de raster spécifié.
ModifyWorldTransform | Cette fonction permet de changer la transformation mondiale pour le périphérique de contexte utilisant le mode spécifié.
MoveToEx | Cette fonction permet de changer la position du pointeur graphique
OffsetClipRgn | Cette fonction permet de déplacer la région de clip dans le périphérique spécifié et par le déplacement spécifié.
OffsetRgn | Cette fonction permet de déplacer la région spécifié par le déplacement spécifié.
OffsetViewportOrgEx | Cette fonction permet de modifier le point de vue d'origine relatif pour un périphérique de contexte en utilisant le déplacement horizontal et vertical spécifié.
OffsetWindowOrgEx | Cette fonction permet de modifier le point de vue de la fenêtre d'origine relatif de la valeur courante.
PaintRgn | Cette fonction permet de remplir une région, en utilisant la brosse courante, pour un périphérique de contexte spécifié.
PatBlt | Cette fonction permet de créer une palette de bits pour un périphérique spécifié.
PathToRegion | Cette fonction permet de créer un chemin vers une région sélectionné dans le périphérique de contexte spécifié.
Pie | Cette fonction permet de dessiner une pointe de tarte en effectuant un arc elliptique d'un centre et de deux points join par des lignes.
PlayEnhMetaFile | Cette fonction permet d'afficher l'image entreposé dans le fichier méta de format étendue spécifié.
PlayEnhMetaFileRecord | Cette fonction permet de jouer un enregistrement de fichier méta étendue par exécution de fonction GDI (Graphics Device Interface) identifié par l'enregistrement.
PlayMetaFile | Cette fonction permet de jouer le contenu d'un fichier méta de format Windows spécifié dans un périphérique spécifié.
PlayMetaFileRecord | Cette fonction permet de jouer un enregistrement d'un fichier méta de format Windows par exécution du GDI contenu dans l'enregistrement.
PlgBlt | Cette fonction permet d'effectuer un traitement de transfert de bloc de bits d'une donnée de bits de couleurs d'un rectangle spécifié dans une source de périphérique de contexte vers la destination de périphérique de contexte de parallélogramme spécifié.
PolyBezier | Cette fonction permet de dessiner une ou plusieurs courbes de Bézier.
PolyBezierTo | Cette fonction permet de dessiner une ou plusieurs courbes de Bézier spécifié.
PolyDraw | Cette fonction permet de dessiner un ensemble de ligne de segments et de courbes de Bézier.
PolyPolygon | Cette fonction permet de créer deux ou plusieurs polygone étant rempli par un mode de remplissage de polygone.
PolyTextOutA | Cette fonction permet de dessiner une chaine de caractères en utilisant la police de caractères et les couleurs textes courante dans le périphérique de contexte spécifié.
PolyTextOutW | Cette fonction permet de dessiner une chaine de caractères en utilisant la police de caractères et les couleurs textes courante dans le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues.
Polygon | Cette fonction permet de dessiner un polygone de deux ou plusieurs points (sommets) connectés par des lignes.
Polyline | Cette fonction permet de dessiner un ensemble de segments de lignes, connecté par les points spécifiés.
PolylineTo | Cette fonction permet de dessiner une ou plusieurs lignes droite.
PtInRegion | Cette fonction permet de demander si un point spécifié est dans une région spécifié.
PtVisible | Cette fonction permet de demander si le point spécifié est dans la région clip d'un périphérique de contexte.
RealizePalette | Cette fonction permet de cartographier l'entrée de palette de la palette logique courante de la palette système.
Rectangle | Cette fonction permet d'afficher un rectangle.
RectInRegion | Cette fonction permet de demander si une partie du rectangle spécifié est dans une des limites d'une région spécifié.
RectVisible | Cette fonction permet de demander n'importe quel partie d'un rectangle spécifié dans une région de clip d'un périphérique de contexte spécifié.
RemoveFontResourceA | Cette fonction permet d'enlever un ajout de ressource de police de caractères d'un fichier spécifié ou d'une table de police de caractères de Windows.
RemoveFontResourceW | Cette fonction permet d'enlever un ajout de ressource de police de caractères d'un fichier spécifié ou d'une table de police de caractères de Windows avec des paramètres de chaine de caractères étendues (Unicode).
ResetDCA | Cette fonction permet de mettre à jour le périphérique de contexte, en se basant sur les informations de la structure spécifié.
ResetDCW | Cette fonction permet de mettre à jour le périphérique de contexte, en se basant sur les informations de la structure spécifié avec des paramètres de chaine de caractères étendues (Unicode).
ResizePalette | Cette fonction permet de changer la taille de la palette logique spécifié.
RestoreDC | Cette fonction permet de restaurer un périphérique de contexte à l'état précédent.
RoundRect | Cette fonction permet de dessiner un rectangle avec les coins arrondies, en utilisant le crayon courant.
SaveDC | Cette fonction permet de sauvegarder l'état courant du périphérique de contexte courant en copiant les informations d'état (clip de région, sélection d'objets, et mode de cartographie) dans la pile de contexte.
ScaleViewportExtEx | Cette fonction permet de modifier les extensions du point de vue relative avec des valeurs courante.
ScaleWindowExtEx | Cette fonction permet de modifier les extensions de la fenêtre de périphérique de contexte en utilisant le ratio formé par le multiplicateur et le diviseur spécifié.
SelectClipPath | Cette fonction permet de sélectionner le chemin courant dans la région de capture d'un périphérique de contexte en combinant la nouvelle région avec n'importe quel région de capture existante par utilisation de mode spécifié.
SelectClipRgn | Cette fonction permet de sélectionner une région spécifié et la capture de région courant pour un périphérique de contexte courant.
SelectObject | Cette fonction permet de sélectionner un objet dans le périphérique de contexte spécifié.
SelectPalette | Cette fonction permet de sélectionner la palette logique dans le périphérique de contexte donnée.
SetAbortProc | Cette fonction permet de fixer la procédure d'application définit par le programmeur pour alloué un travail d'impression afin d'être annuler durant sa tamporisation dans le tampon d'impression.
SetArcDirection | Cette fonction permet de fixer la direction du dessinage pour être utilisé dans les fonctions d'arc et de rectangle.
SetBitmapBits | Cette fonction permet de fixer l'ensemble de bits d'un Bitmap spécifié avec les valeurs de bits spécifié.
SetBitmapDimensionEx | Cette fonction permet de fixer la taille souhaité d'un Bitmap, dans une unité de mesure de 0,01 millimètre.
SetBkColor | Cette fonction permet de fixer la couleur de l'arrière-plan de la couleur spécifié.
SetBkMode | Cette fonction permet de fixer le mode d'arrière-plan spécifié.
SetBoundsRect | Cette fonction permet de contrôler l'accumulation d'informations de limite rectangulaire d'un périphérique de contexte.
SetBrushOrgEx | Cette fonction permet de fixer l'origine de la brosse GDI étant associé avec la prochaine brosse d'une application sélectionné dans le périphérique de contexte spécifié.
SetColorAdjustment | Cette fonction permet de fixer les valeurs de couleurs d'ajustements pour un périphérique de contexte utilisant les valeurs spécifiés.
SetColorSpace | Cette fonction permet de fixer l'espace de couleur du périphérique de contexte spécifié en définissant la fin des points d'un espace RVB (RGB) logique dans l'espace CIE XYZ.
SetDeviceGammaRamp | Cette fonction permet de fixer la rampe gamma d'un panneau d'affichage de couleur directe.
SetDIBColorTable | Cette fonction permet de fixer les valeurs de couleurs RVB (rouge, vert, bleu) dans une rangée de table de couleurs d'un périphérique de Bitmap indépendant (DIB) étant actuellement sélectionné dans un périphérique de contexte spécifié.
SetDIBits | Cette fonction permet de fixer le pixel dans un Bitmap compatible (DDB) en utilisant les données de couleur trouvé dans le DIB spécifié.
SetDIBitsToDevice | Cette fonction permet de fixer les bits d'un périphérique de Bitmap indépendant (DIB) directement dans un périphérique de surface.
SetEnhMetaFileBits | Cette fonction permet de créer un fichier méta de format étendue, basé en mémoire, de données fournit.
SetGraphicsMode | Cette fonction permet de fixer le mode graphique pour le périphérique de contexte spécifié.
SetICMMode | Cette fonction permet d'activer ou désactiver la correspondance de couleur d'image pour le périphérique de contexte spécifié.
SetICMProfileA | Cette fonction permet de fixer la couleur de profile pour le périphérique de contexte spécifié.
SetICMProfileW | Cette fonction permet de fixer la couleur de profile pour le périphérique de contexte spécifié avec des paramètres de chaine de caractères étendues (Unicode).
SetMapMode | Cette fonction permet de fixer le mode de cartographie d'un périphérique de contexte spécifié.
SetMapperFlags | Cette fonction permet de changer la méthode utilisé pour la cartographie d'une police de caractères lors d'une conversion de police de caractères logique vers une police de caractères physique.
SetMetaFileBitsEx | Cette fonction permet de créer un fichier méta de format Windows, basé en mémoire, pour les données fournit.
SetMetaRgn | Cette fonction permet d'effectuer l'intersection de la région de capture courante pour le périphérique de contexte spécifié avec la région méta courante et sauvegarde la combinaison des régions dans une nouvelle région méta.
SetMiterLimit | Cette fonction permet de fixer la limite pour la longueur d'une jointure de mitre pour le périphérique de contexte spécifié.
SetPaletteEntries | Cette fonction permet de fixer les valeurs de couleurs RVB (ou RGB en anglais) et les drapeaux d'un rang des entrées dans une palette logique spécifié.
SetPixel | Cette fonction permet de fixer la couleur sous format RVB (RGB) d'un pixel affiché à l'écran.
SetPixelFormat | Cette fonction permet de fixer le format de pixel du périphérique de contexte spécifié au format spécifié par l'index spécifié.
SetPixelV | Cette fonction permet de fixer le pixel aux coordonnées de fermeture approximatifs spécifiées avec la couleur spécifié.
SetPolyFillMode | Cette fonction permet de fixer le mode de remplissage d'un polygone spécifié.
SetRectRgn | Cette fonction permet de changer la région spécifié dans un région rectangulaire avec les coordonnées spécifiés.
SetROP2 | Cette fonction permet de fixer le mode de dessinage courant.
SetStretchBltMode | Cette fonction permet de fixer le mode d'étirement Bitmap.
SetSystemPaletteUse | Cette fonction permet de fixer l'utilisation de la couleur statique dans une palette du système.
SetTextAlign | Cette fonction permet de fixer le contexte d'alignement d'un objet de texte.
SetTextColor | Cette fonction permet de fixer la couleur du texte de la couleur spécifié.
SetTextCharacterExtra | Cette fonction permet de fixer le quantité d'espacement entre les caractères.
SetTextJustification | Cette fonction permet d'ajouter de l'espacement dans les caractères de saut d'une chaine de caractères.
SetViewportExtEx | Cette fonction permet de fixer les extensions X et Y d'un point de vue d'un périphérique de contexte spécifié.
SetViewportOrgEx | Cette fonction permet de fixer le point de vue d'origine d'un périphérique de contexte spécifié.
SetWinMetaFileBits | Cette fonction permet de convertir un fichier méta d'un ancien format Windows vers un nouveau format étendue et entrepose le fichier méta en mémoire.
SetWindowOrgEx | Cette fonction permet de fixer la fenêtre d'origine d'un périphérique de contexte spécifié.
SetWorldTransform | Cette fonction permet de fixer une transformation de double dimensions linéaire entre l'espace mondiale et l'espace de page pour le périphérique de contexte spécifié.
StartDocA | Cette fonction permet d'indiquer le commencement d'un travail d'impression pour l'imprimante.
StartDocW | Cette fonction permet d'indiquer le commencement d'un travail d'impression pour l'imprimante avec des paramètres de chaine de caractères étendues (Unicode).
StartPage | Cette fonction permet d'indiquer le début d'une page de document pour l'impression pour l'imprimante.
StretchBlt | Cette fonction permet de copier un morceau dans une autre image.
StretchDIBits | Cette fonction permet de copier les données de couleur d'un rectangle de pixels dans un DIB de la destination rectangulaire spécifié.
StrokeAndFillPath | Cette fonction permet de fermer n'importe quel figures ouvertes dans un chemin, traitant les lignes en dehors du chemin en utilisant le crayon courant, et remplissant l'intérieur en utilisant la brosse.
StrokePath | Cette fonction permet d'effectuer un traitement d'un chemin spécifié en utilisant le crayon courant.
SwapBuffers | Cette fonction permet d'échanger le tampon de premier plan avec l'arrière-plan si le format du pixel courant pour la fenêtre est référencée par le périphérique de contexte spécifié inclus dans le tampon d'arrière plan.
TextOutA | Cette fonction permet d'afficher une chaine de caractères dans une fenêtre d'application.
TextOutW | Cette fonction permet d'afficher une chaine de caractères dans une fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
UnrealizeObject | Cette fonction permet de réinitialiser l'origine de la brosse ou de réinitialiser la palette logique.
UpdateColors | Cette fonction permet de mettre-à-jour la région client d'un périphérique de contexte spécifié en faisant correspondre les couleurs courantes dans une région client, pixel par pixel, à une palette de système.
WidenPath | Cette fonction permet de redéfinir le chemin courant de la région devant être repeinte si le chemin est un trait utilisant le crayon courant sélectionné dans le périphérique de contexte spécifié.


C pour Windows - EXE, DLL et modules de Windows - «icmp.dll»

Description

Ce fichier contient la bibliothèque de protocole ICMP (Internet Control Message Protocol).

Liste des fonctions d'API Windows

Nom de l'API | Description
IcmpCloseHandle | Cette fonction permet de fermer un fichier sur le protocole ICMP (Internet Control Message Protocol).
IcmpCreateFile | Cette fonction permet de créer un fichier sur le protocole ICMP (Internet Control Message Protocol).
IcmpSendEcho | Cette fonction permet d'envoyer une requête en écho par le protocole ICMP (Internet Control Message Protocol).


C pour Windows - EXE, DLL et modules de Windows - «imagehlp.dll»

Description

Ce fichier contient la bibliothèque d'API d'aide aux services d'image.

Liste des fonctions d'API Windows

Nom de l'API | Description
MakeSureDirectoryPathExists | Cette fonction permet de s'assurer que toutes l'arborescente d'un chemin de répertoires existent et ont été créés.
SearchTreeForFile | Cette fonction permet d'effectuer la recherche d'un fichier dans un arbre de répertoire.
TouchFileTimes | Cette fonction permet de fixer la date et l'heure d'un fichier avec un Handle.

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «iphlpapi.dll»

Description

Ce fichier contient la bibliothèque d'API d'aide aux services IP.

Liste des fonctions d'API Windows

Nom de l'API | Description
GetIpStatistics | Cette fonction permet de demander les informations de statistique sur le IP de l'ordinateur.
GetTcpStatistics | Cette fonction permet de demander les informations de statistique sur le TCP de l'ordinateur.
GetUdpStatistics | Cette fonction permet de demander les informations de statistique sur le UDP de l'ordinateur.

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «kernel32.dll»

Description

Ce fichier contient la bibliothèque du noyau du système d'exploitation : Gestion de la mémoire, ses processus, des tâches, du module,...

Liste des fonctions d'API Windows

Nom de l'API | Description
AddAtomA | Cette fonction permet d'ajouter une chaine de caractères ASCIZ à l'Atom global.
AddAtomW | Cette fonction permet d'ajouter un caractère étendue (Unicode) à l'Atom global.
AllocConsole | Cette fonction permet de créer une nouvelle console.
AreFileApisANSI | Cette fonction permet d'indiquer si les fonctions pour fichier du Win32 utilise un ensemble de police de caractères ANSI ou une page OEM.
BackupRead | Cette fonction permet d'effectuer la lecture de flux de données associé avec un fichier ou un répertoire spécifié d'un tampon.
BackupSeek | Cette fonction permet de fixer la position dans le flux de données accessible par les fonctions «BackupRead» et «BackupWrite».
BackupWrite | Cette fonction permet d'effectuer l'écriture de flux de données associé avec un fichier ou un répertoire spécifié d'un tampon.
Beep | Cette fonction permet d'émettre un signal sonore sur le PC Speaker.
BeginUpdateResourceA | Cette fonction permet de retourner l'identificateur Handle qu'utilise une fonction «UpdateResource» pour ajouter, supprimer ou remplacer dans un fichier exécutable.
BeginUpdateResourceW | Cette fonction permet de retourner l'identificateur Handle qu'utilise une fonction «UpdateResource» pour ajouter, supprimer ou remplacer dans un fichier exécutable avec des paramètres de chaine de caractères étendue (Unicode).
BuildCommDCBA | Cette fonction permet de remplir une structure DCB avec les valeurs spécifié par une chaine de caractères de périphérique de contrôle.
BuildCommDCBW | Cette fonction permet de remplir une structure DCB avec les valeurs spécifié par une chaine de caractères de périphérique de contrôle avec des paramètres de chaine de caractères étendue (Unicode).
BuildCommDCBAndTimeoutsA | Cette fonction permet de convertir la chaine de caractères des définitions d'un périphérique en un bloc de périphérique de contrôle et de placer les codes dans un bloc dans le périphérique de contrôle.
BuildCommDCBAndTimeoutsW | Cette fonction permet de convertir la chaine de caractères des définitions d'un périphérique en un bloc de périphérique de contrôle et de placer les codes dans un bloc dans le périphérique de contrôle avec des paramètres de chaine de caractères étendue (Unicode).
CallNamedPipeA | Cette fonction permet d'effectuer une connection à l'aide d'un tuyau de type de message et de lire et d'écrire dans se tuyau et d'ensuite fermer le tuyau.
CallNamedPipeW | Cette fonction permet d'effectuer une connection à l'aide d'un tuyau de type de message et de lire et d'écrire dans se tuyau et d'ensuite fermer le tuyau avec des paramètres de chaine de caractères étendue (Unicode).
CancelIo | Cette fonction permet d'annuler une opération d'entrée/sortie initié par un processus léger dans un fichier.
CancelWaitableTimer | Cette fonction permet de fixer le délai d'attente de l'horloge à un état inactif.
ClearCommBreak | Cette fonction permet de restituer les caractères transmis par un périphérique de communications spécifié et place la ligne de transmission dans un état non arrêtable.
ClearCommError | Cette fonction permet de demander des informations à propos d'erreur de communications et un rapport d'état actuel sur un périphérique de communication.
CloseHandle | Cette fonction permet d'effectuer la fermeture d'un Handle.
CommConfigDialogA | Cette fonction permet d'afficher une configuration de pilote de fournisseur dans une boite de dialogue.
CommConfigDialogW | Cette fonction permet d'afficher une configuration de pilote de fournisseur dans une boite de dialogue avec des paramètres de chaine de caractères étendue (Unicode).
CompareFileTime | Cette fonction permet de comparer deux temps de fichier de 64-bits.
CompareStringA | Cette fonction permet d'effectuer la comparaison de deux chaines de caractères ASCIZ.
CompareStringW | Cette fonction permet d'effectuer la comparaison de deux chaines de caractères Unicode.
ConnectNamedPipe | Cette fonction permet d'activé un nom de tuyau d'un processus serveur en attente pour un processus client de connexion.
ContinueDebugEvent | Cette fonction permet d'activer un débogueur pour qu'il continue un processus précédamment rapporter comme un bogue d'événement.
ConvertThreadToFiber | Cette fonction permet d'effectuer la conversion d'un processus léger vers un fibre.
ConvertDefaultLocale | Cette fonction permet de convertir une valeur locale spécial par défaut en un identificatuer local courant.
CopyFileA | Cette fonction permet d'effectuer la copie d'un fichier d'un emplacement à un autre emplacement
CopyFileExA | Cette fonction permet d'effectuer la copie d'un fichier d'un emplacement à un autre emplacement tout en effectuant un processus d'arrière plan indiquant sa progression.
CopyFileExW | Cette fonction permet d'effectuer la copie d'un fichier d'un emplacement à un autre emplacement tout en effectuant un processus d'arrière plan indiquant sa progression avec des paramètres de chaine de caractères étendue (Unicode).
CopyFileW | Cette fonction permet d'effectuer la copie d'un fichier d'un emplacement à un autre emplacement avec des paramètres de chaine de caractères étendue (Unicode).
CreateConsoleScreenBuffer | Cette fonction permet de créer un tampon de console écran et de retourner un identificateur Handle associée à celui-ci.
CreateDirectoryA | Cette fonction permet d'effectuer la création d'un répertoire
CreateDirectoryW | Cette fonction permet d'effectuer la création d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
CreateDirectoryExA | Cette fonction permet d'effectuer la création d'un répertoire étendue
CreateDirectoryExW | Cette fonction permet d'effectuer la création d'un répertoire étendue avec des paramètres de chaine de caractères étendue (Unicode).
CreateDirectoryTransactedA | Cette fonction permet d'effectuer la création d'un répertoire dans une opération de transaction
CreateDirectoryTransactedW | Cette fonction permet d'effectuer la création d'un répertoire dans une opération de transaction avec des paramètres de chaine de caractères étendue (Unicode).
CreateEventA | Cette fonction permet de créer un objet d'événement nommé ou non-nommé.
CreateEventW | Cette fonction permet de créer un objet d'événement nommé ou non-nommé avec des paramètres de chaine de caractères étendue (Unicode).
CreateFiber | Cette fonction permet d'allouer un objet de fibre, en lui attribuant une pile, et en fixant le début de l'exécutant à l'adresse de début spécifié.
CreateFileA | Cette fonction permet d'effectuer la création ou l'ouverture d'un fichier ou d'un périphérique
CreateFileW | Cette fonction permet d'effectuer la création ou l'ouverture d'un fichier ou d'un périphérique avec des paramètres de chaine de caractères étendue (Unicode).
CreateFileMappingA | Cette fonction permet de créer un objet mapping, nommé ou non-nommé, pour un fichier spécifié.
CreateFileMappingW | Cette fonction permet de créer un objet mapping, nommé ou non-nommé, pour un fichier spécifié avec des paramètres de chaine de caractères étendue (Unicode).
CreateMailslotA | Cette fonction permet de créer une slot de courriel avec un nom spécifié et retourne un identificateur Handle associé à celle-ci.
CreateMailslotW | Cette fonction permet de créer une slot de courriel avec un nom spécifié et retourne un identificateur Handle associé à celle-ci avec des paramètres de chaine de caractères étendue (Unicode).
CreateMutexA | Cette fonction permet de créer un objet Mutex nommé ou non-nommé.
CreateMutexW | Cette fonction permet de créer un objet Mutex nommé ou non-nommé avec des paramètres de chaine de caractères étendue (Unicode).
CreateNamedPipeA | Cette fonction permet de créer un tuyau avec un instance de nom spécifié et de retourner un identificateur Handle associé à celle-ci.
CreateNamedPipeW | Cette fonction permet de créer un tuyau avec un instance de nom spécifié et de retourner un identificateur Handle associé à celle-ci avec des paramètres de chaine de caractères étendue (Unicode).
CreatePipe | Cette fonction permet de créer un tuyau anonyme et de retourner un identificateur Handle attribué en lecture et écriture pour celle-ci.
CreateProcessA | Cette fonction permet de créer un nouveau processus et de le fixer comme processus léger primaire.
CreateProcessW | Cette fonction permet de créer un nouveau processus et de le fixer comme processus léger primaire avec des paramètres de chaine de caractères étendue (Unicode).
CreateRemoteThread | Cette fonction permet de créer un processus léger exécuté dans l'espace d'une adresse d'un autre processus.
CreateSemaphoreA | Cette fonction permet de créer un objet de sémaphore nommé ou non-nommé.
CreateSemaphoreW | Cette fonction permet de créer un objet de sémaphore nommé ou non-nommé avec des paramètres de chaine de caractères étendue (Unicode).
CreateTapePartition | Cette fonction permet de reformatté une unité de sauvegarde de bande magnétique (Tape Backup).
CreateToolhelp32Snapshot | Cette fonction permet d'effectuer une capture de l'écran sous forme d'un Bitmap
CreateThread | Cette fonction permet de créer un processus pour exécuter un processus appelant dans un espace d'adressage.
CreateWaitableTimerA | Cette fonction permet d'effectuer la création d'une horloge de délai d'attente.
CreateWaitableTimerW | Cette fonction permet d'effectuer la création d'une horloge de délai d'attente avec des paramètres de chaine de caractères étendue (Unicode).
DebugActiveProcess | Cette fonction permet d'allouer une débogueur à attaché avec un processus actif
DebugBreak | Cette fonction permet de provoqué une exception sur un point d'arrêt dans le processus courant.
DefineDosDeviceA | Cette fonction permet de définir, redéfinir ou supprimer un nom de périphérique DOS.
DefineDosDeviceW | Cette fonction permet de définir, redéfinir ou supprimer un nom de périphérique DOS avec des paramètres de chaine de caractères étendue (Unicode).
DeleteAtom | Cette fonction permet de décrémenter le compteur de référence de chaine de caractères d'Atom local.
DeleteCriticalSection | Cette fonction permet de terminer et restituer tous les ressources associé à l'objet de section critique.
DeleteFiber | Cette fonction permet de supprimer une fibre existante.
DeleteFileA | Cette fonction permet de supprimer un fichier existant.
DeleteFileW | Cette fonction permet de supprimer un fichier existant avec des paramètres de chaine de caractères étendue (Unicode).
DeviceIoControl | Cette fonction permet d'envoyer des codes de contrôles directement à un pilote de périphérique.
DisableThreadLibraryCalls | Cette fonction permet de désactiver les avertissements «DLL_THREAD_ATTACH» et «DLL_THREAD_DETACH» des bibliothèques de lien dynamique (DLL) spécifié.
DisconnectNamedPipe | Cette fonction permet de déconnecter le serveur de fin de tuyau nommé pour un processus client.
DosDateTimeToFileTime | Cette fonction permet de convertir la valeur d'une date et d'une heure du DOS en un temps fichier de 64 bits.
DuplicateHandle | Cette fonction permet de dupliquer un objet d'identificateur Handle existant.
EndUpdateResourceA | Cette fonction permet de terminer la mise-à-jour d'une ressource d'un fichier exécutable.
EndUpdateResourceW | Cette fonction permet de terminer la mise-à-jour d'une ressource d'un fichier exécutable avec des paramètres de chaine de caractères étendue (Unicode).
EnterCriticalSection | Cette fonction permet d'attendre après un propriétaire d'objet de section critique spécifié.
EnumCalendarInfoA | Cette fonction permet d'énumérer des informations de calendrier d'une région local spécifié
EnumCalendarInfoW | Cette fonction permet d'énumérer des informations de calendrier d'une région local spécifié avec des paramètres de chaine de caractères étendue (Unicode).
EnumDateFormatsA | Cette fonction permet d'énumérer le format de la date courte ou longue disponible pour la région locale.
EnumDateFormatsW | Cette fonction permet d'énumérer le format de la date courte ou longue disponible pour la région locale avec des paramètres de chaine de caractères étendue (Unicode).
EnumResourceLanguagesA | Cette fonction permet de rechercher un module pour chaque ressource d'un type spécifié et de passé le langage pour chaque ressource trouvé dans une fonction définie en arrière plan.
EnumResourceLanguagesW | Cette fonction permet de rechercher un module pour chaque ressource d'un type spécifié et de passé le langage pour chaque ressource trouvé dans une fonction définie en arrière plan avec des paramètres de chaine de caractères étendue (Unicode).
EnumResourceNamesA | Cette fonction permet de rechercher un module pour chaque ressource d'un type spécifié et de passé le langage pour chaque ressource trouvé dans une fonction d'application définie en arrière plan.
EnumResourceNamesW | Cette fonction permet de rechercher un module pour chaque ressource d'un type spécifié et de passé le langage pour chaque ressource trouvé dans une fonction d'application définie en arrière plan avec des paramètres de chaine de caractères étendue (Unicode).
EnumResourceTypesA | Cette fonction permet de rechercher un module pour une ressource et de passé chaque type de ressource dans une fonction d'application définie en arrière plan.
EnumResourceTypesW | Cette fonction permet de rechercher un module pour une ressource et de passé chaque type de ressource dans une fonction d'application définie en arrière plan avec des paramètres de chaine de caractères étendue (Unicode).
EnumSystemCodePagesA | Cette fonction permet d'énumérer un code de page installé ou supporté par le système d'exploitation.
EnumSystemCodePagesW | Cette fonction permet d'énumérer un code de page installé ou supporté par le système d'exploitation avec des paramètres de chaine de caractères étendue (Unicode).
EnumSystemLocalesA | Cette fonction permet d'énumérer la région locale installé ou supporté par le système d'exploitation.
EnumSystemLocalesW | Cette fonction permet d'énumérer la région locale installé ou supporté par le système d'exploitation avec des paramètres de chaine de caractères étendue (Unicode).
EnumTimeFormatsA | Cette fonction permet d'énumérer le format de temps disponible pour la région locale.
EnumTimeFormatsW | Cette fonction permet d'énumérer le format de temps disponible pour la région locale avec des paramètres de chaine de caractères étendue (Unicode).
EraseTape | Cette fonction permet de tout supprimer ou supprimer des parties de bande magnétique de sauvegarde.
EscapeCommFunction | Cette fonction permet d'effectuer directement une communication d'un périphérique spécifié à une fonction étendue.
ExitProcess | Cette fonction permet de terminer un processus et tous ses processus légers.
ExitThread | Cette fonction permet de terminer un processus léger.
ExpandEnvironmentStringsA | Cette fonction permet d'étendre une chaine de caractères de variable d'environnement et de remplacer leurs valeurs par celle correspondante.
ExpandEnvironmentStringsW | Cette fonction permet d'étendre une chaine de caractères de variable d'environnement et de remplacer leurs valeurs par celle correspondante avec des paramètres de chaine de caractères étendue (Unicode).
FatalAppExitA | Cette fonction permet d'afficher la boite de dialogue d'erreur fatal amenant la terminaison anormale du programme.
FatalAppExitW | Cette fonction permet d'afficher la boite de dialogue d'erreur fatal amenant la terminaison anormale du programme avec des paramètres de chaine de caractères étendue (Unicode).
FatalExit | Cette fonction permet de transférer le contrôle d'exécution au débogueur.
FileTimeToDosDateTime | Cette fonction permet de convertir un temps de fichier 64 bits en des valeurs de date et temps.
FileTimeToLocalFileTime | Cette fonction permet d'effectuer la conversion du temps d'un fichier de format UTC (Coordonnée de Temps Universelle) en format de temps local.
FileTimeToSystemTime | Cette fonction permet de convertir un temps fichier de 64 bits à un temps de format système.
FillConsoleOutputAttribute | Cette fonction permet de fixer la couleur de texte et d'arrière plan pour un nombre spécifié de caractères en commençant au coordonnées du tampon d'écran spécifié.
FillConsoleOutputCharacterA | Cette fonction permet d'écrire un caractère dans le tampon d'écran un certain nombre de fois en commençant au coordonnées du tampon d'écran spécifié.
FillConsoleOutputCharacterW | Cette fonction permet d'écrire un caractère dans le tampon d'écran un certain nombre de fois en commençant au coordonnées du tampon d'écran spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FindAtomA | Cette fonction permet de rechercher dans un table d'Atom local la chaine de caractères spécifié et demande l'Atom associé avec cette chaine de caractères.
FindAtomW | Cette fonction permet de rechercher dans un table d'Atom local la chaine de caractères spécifié et demande l'Atom associé avec cette chaine de caractères avec des paramètres de chaine de caractères étendue (Unicode).
FindClose | Cette fonction permet d'indiquer que la recherche des fichiers et réperoires que contient un répertoire est terminé.
FindCloseChangeNotification | Cette fonction permet d'indiquer que la recherche et modifications des fichiers et répertoires que contient un répertoire est terminé.
FindFirstChangeNotificationA | Cette fonction permet de créer un identificateur Handle d'avertissement de changement et fixe la condition d'avertissement de changement initial.
FindFirstChangeNotificationW | Cette fonction permet de créer un identificateur Handle d'avertissement de changement et fixe la condition d'avertissement de changement initial avec des paramètres de chaine de caractères étendue (Unicode).
FindFirstChangeNotification | Cette fonction permet de spécifier une recherche et modifications des fichiers et répertoires que contient un répertoire.
FindFirstFileA | Cette fonction permet de spécifier une recherche des fichiers et répertoires que contient un répertoire.
FindFirstFileExA | Cette fonction permet de rechercher dans un répertoire un fichier ou un sous-répertoire avec une correspondance de nom et d'attribut spécifié.
FindFirstFileExW | Cette fonction permet de rechercher dans un répertoire un fichier ou un sous-répertoire avec une correspondance de nom et d'attribut spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FindFirstFileW | Cette fonction permet de spécifier une recherche des fichiers et répertoires que contient un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
FindNextChangeNotification | Cette fonction permet demander l'entrée suivant lors de la recherche et modifications des fichiers et répertoire que contient un répertoire.
FindNextFileA | Cette fonction permet demander l'entrée suivante lors de la recherche des fichiers et répertoires que contient un répertoire.
FindNextFileW | Cette fonction permet demander l'entrée suivante lors de la recherche des fichiers et répertoire que contient un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
FindResourceA | Cette fonction permet de demander l'emplacement d'une ressource avec un nom et un type spécifié dans un module spécifié.
FindResourceW | Cette fonction permet de demander l'emplacement d'une ressource avec un nom et un type spécifié dans un module spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FindResourceExA | Cette fonction permet de demander l'emplacement d'une ressource avec un type, un nom et une langue spécifié dans un module spécifié.
FindResourceExW | Cette fonction permet de demander l'emplacement d'une ressource avec un type, un nom et une langue spécifié dans un module spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FlushConsoleInputBuffer | Cette fonction permet de vider le tampon d'entrée de la console.
FlushFileBuffers | Cette fonction permet d'effacer le tampon pour le fichier spécifié et provoquer l'écriture des données dans le fichier.
FlushInstructionCache | Cette fonction permet de vider les instructions en cache pour le processus spécifié.
FlushViewOfFile | Cette fonction permet d'écrire sur le disque un rang d'octets dans une vue d'un fichier.
FoldStringA | Cette fonction permet de cartographier une chaine de caractères vers une autre en effectuant les options de transformations spécifié.
FoldStringW | Cette fonction permet de cartographier une chaine de caractères vers une autre en effectuant les options de transformations spécifié avec des paramètres de chaine de caractères étendue (Unicode).
FormatMessageA | Cette fonction permet de demander un message affecté par un certain format.
FormatMessageW | Cette fonction permet de demander le dernier message d'erreur contenu dans le fichier d'erreur système.
FreeConsole | Cette fonction permet de libérer une console existante.
FreeEnvironmentStringsA | Cette fonction permet de libérer un bloc de chaine de caractères d'environnement.
FreeEnvironmentStringsW | Cette fonction permet de libérer un bloc de chaine de caractères d'environnement avec des paramètres de chaine de caractères étendue (Unicode).
FreeLibrary | Cette fonction permet d'incrémenter un compteur de référence pour un chargement de module de lien dynamique (DLL).
FreeLibraryAndExitThread | Cette fonction permet de décrémenté le compteur de référence d'une des bibliothèque de liens dynamique (DLL) et appel alors la fonction «ExitThread».
FreeResource | Cette fonction permet de libérer une ressource.
GenerateConsoleCtrlEvent | Cette fonction permet d'envoyer un signal spécifique à un groupe de processus de console.
GetACP | Cette fonction permet de demander l'identificateur de code de page ANSI courant pour le système d'exploitation.
GetAtomNameA | Cette fonction permet de demander une copie de chaine de caractères associé avec un Atom local spécifié.
GetAtomNameW | Cette fonction permet de demander une copie de chaine de caractères associé avec un Atom local spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetBinaryTypeA | Cette fonction permet de demander si le fichier est exécutable, et s'il l'est, quel type de fichier exécutable s'agit-il.
GetBinaryTypeW | Cette fonction permet de demander si le fichier est exécutable, et s'il l'est, quel type de fichier exécutable s'agit-il avec des paramètres de chaine de caractères étendue (Unicode).
GetCommandLineA | Cette fonction permet de retourner la ligne de commande de l'application courante.
GetCommandLineW | Cette fonction permet de retourner la ligne de commande de l'application courante avec des paramètres de chaine de caractères étendue (Unicode).
GetCommConfig | Cette fonction permet de demander la configuration courante pour un périphérique de communication.
GetCommMask | Cette fonction permet de demander la valeur d'un masque d'événement pour un périphérique de communication spécifié.
GetCommModemStatus | Cette fonction permet de demander les valeurs du registre de contrôle du modem.
GetCommProperties | Cette fonction permet de remplir le tampon avec des informations concernant les propriétés de communications pour un périphérique de communication spécifié.
GetCommState | Cette fonction permet de remplir un bloc de contrôle de périphérique (une structure DCB) avec les ajustements de contrôle courant pour un périphérique de communication spécifié.
GetCommTimeouts | Cette fonction permet de demander les paramètres de dépassement de délai pour toutes les opérations de lecture ou d'écriture pour un périphérique de communication spécifié.
GetCompressedFileSizeA | Cette fonction permet de demander le nombre d'octets d'une unité d'entreposage actuellement utilisé pour un fichier spécifié.
GetCompressedFileSizeW | Cette fonction permet de demander le nombre d'octets d'une unité d'entreposage actuellement utilisé pour un fichier spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetComputerNameA | Cette fonction permet de demander le nom de l'ordinateur sous forme d'une chaine de caractères ASCIZ.
GetComputerNameW | Cette fonction permet de demander le nom de l'ordinateur sous forme d'une chaine de caractères ASCIZ avec des paramètres de chaine de caractères étendue (Unicode).
GetComputerNameExA | Cette fonction permet de retourner la nom NetBIOS ou DNS de l'ordinateur local.
GetConsoleCursorInfo | Cette fonction permet de demander des informations à propos de la taille et de la visibilité du curseur pour le tampon de console écran spécifié.
GetConsoleCP | Cette fonction permet de demander l'identité de code de page utilisé pour la console associé avec le processus appelant.
GetConsoleMode | Cette fonction permet de demander le mode d'entrée courant pour le tampon d'entrée de la console ou le mode de sortie courant pour le tampon d'écran de la console.
GetConsoleOutputCP | Cette fonction permet de retourner l'identité de code de page de sortie utilisé par la console associé avec le processus appelant.
GetConsoleScreenBufferInfo | Cette fonction permet de demander les informations à propos du tampon d'écran de la console spécifié.
GetConsoleTitleA | Cette fonction permet de retourner le nom de la console courante.
GetConsoleTitleW | Cette fonction permet de retourner le nom de la console courante avec des paramètres de chaine de caractères étendue (Unicode).
GetCPInfo | Cette fonction permet de retourner des informations sur le code de page spécifié.
GetCurrencyFormatA | Cette fonction permet de demander la chaine de caractères du format d'un nombre avec une chaine de caractères de monnaie pour une localité spécifié.
GetCurrencyFormatW | Cette fonction permet de demander la chaine de caractères du format d'un nombre avec une chaine de caractères de monnaie pour une localité spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetCurrentDirectoryA | Cette fonction permet de demander le répertoire courant du processus courant.
GetCurrentDirectoryW | Cette fonction permet de demander le répertoire courant du processus courant avec des paramètres de chaine de caractères étendue (Unicode).
GetCurrentProcess | Cette fonction permet de retourner le Handle du processus courant.
GetCurrentProcessId | Cette fonction permet de demander l'identificateur de processus courant
GetCurrentProcessorNumber | Cette fonction permet de demander le nombre de processeur du processus courant lors de l'appel d'une fonction
GetCurrentThread | Cette fonction permet de retourner le Handle du processus courant.
GetCurrentThreadId | Cette fonction permet de retourner l'identificateur du processus courant.
GetDateFormatA | Cette fonction permet de demander le date dans une chaine de caractères ASCIZ selon le format spécifié.
GetDateFormatW | Cette fonction permet de demander la date dans une chaine de caractères ASCIZ selon le format spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetDefaultCommConfigA | Cette fonction permet de demander la configuration par défaut d'un périphérique de communication.
GetDefaultCommConfigW | Cette fonction permet de demander la configuration par défaut d'un périphérique de communication avec des paramètres de chaine de caractères étendue (Unicode).
GetDiskFreeSpaceA | Cette fonction permet de demander l'espace de libre sur une unité disque.
GetDiskFreeSpaceExA | Cette fonction permet de demander des informations global sur l'espace de libre sur une unité disque.
GetDiskFreeSpaceExW | Cette fonction permet de demander des informations global sur l'espace de libre sur une unité disque avec des paramètres de chaine de caractères étendue (Unicode).
GetDiskFreeSpaceW | Cette fonction permet de demander l'espace de libre sur une unité disque avec des paramètres de chaine de caractères étendue (Unicode).
GetDriveTypeA | Cette fonction permet de demander le type d'unité disque.
GetDriveTypeW | Cette fonction permet de demander le type d'unité disque avec des paramètres de chaine de caractères étendue (Unicode).
GetEnvironmentStringsA | Cette fonction permet de demander les variables d'environnements du processus courant.
GetEnvironmentStringsW | Cette fonction permet de demander les variables d'environnements du processus courant avec des paramètres de chaine de caractères étendue (Unicode).
GetEnvironmentVariableA | Cette fonction permet de demander la valeur d'une variable d'environnement du système d'exploitation.
GetEnvironmentVariableW | Cette fonction permet de demander la valeur d'une variable d'environnement du système d'exploitation avec des paramètres de chaine de caractères étendue (Unicode).
GetExitCodeProcess | Cette fonction permet de demander le code d'état de terminaison d'un processus spécifié.
GetExitCodeThread | Cette fonction permet de demander le code d'état de terminaison d'un processus léger (Thread) spécifié.
GetFileAttributesA | Cette fonction permet de demander les attributs d'un fichier ou d'un répertoire.
GetFileAttributesExA | Cette fonction permet de demander les informations étendues d'attributs d'un fichier ou d'un répertoire.
GetFileAttributesExW | Cette fonction permet de demander les informations étendues d'attributs d'un fichier ou d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
GetFileAttributesW | Cette fonction permet de demander les attributs d'un fichier ou d'un répertoire avec des paramètres de chaine de caractères étendue (Unicode).
GetFileInformationByHandle | Cette fonction permet de demander les informations associé au fichier spécifié.
GetFileSize | Cette fonction permet de demander la taille, en octets, d'un fichier spécifié.
GetFileTime | Cette fonction permet de demander la date et l'heure d'un fichier de sa création, de sa dernière modification ou de son dernière accès.
GetFileType | Cette fonction permet de retourner le type d'un fichier spécifié.
GetFullPathNameA | Cette fonction permet de demander le chemin et le nom de fichier complet pour un fichier spécifié.
GetFullPathNameW | Cette fonction permet de demander le chemin et le nom de fichier complet pour un fichier spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetGuiResources | Cette fonction permet de demander le nombre d'identificateur de GUI (Interface graphique utilisateur) du processus courant.
GetHandleInformation | Cette fonction permet de demander les informations conçernant certaines propriétés d'un objet avec un identificateur Handle.
GetLargestConsoleWindowSize | Cette fonction permet de demander la taille de la fenêtre de console la plus large possible en se basant sur la police de caractères et la taille d'affichage.
GetLastError | Cette fonction permet de demander la dernière erreur s'étant produite dans une API.
GetLocaleInfoA | Cette fonction permet de demander des informations de nature local sur le système.
GetLocaleInfoW | Cette fonction permet de demander des informations de nature local sur le système avec des paramètres de chaine de caractères étendue (Unicode).
GetLocalTime | Cette fonction permet de demander la date et l'heure local du système.
GetLogicalDrives | Cette fonction permet de demander quel sont les unités de disque valide.
GetLogicalDriveStringsA | Cette fonction permet de remplir un tampon avec une chaine de caractères spécifiant une unité de disque système valide.
GetLogicalDriveStringsW | Cette fonction permet de remplir un tampon avec une chaine de caractères spécifiant une unité de disque système valide avec des paramètres de chaine de caractères étendue (Unicode).
GetLogicalProcessorInformation | Cette fonction permet de demander des informations concernant les processeurs logiques et le matériel associé.
GetMailslotInfo | Cette fonction permet de demander des informations pour une slot de courriel.
GetModuleFileNameA | Cette fonction permet de demander un nom de fichier long ou demande le nom complet de chemin et nom de fichier pour un fichier exécutable contenu dans le module spécifié.
GetModuleFileNameW | Cette fonction permet de demander un nom de fichier long ou demande le nom complet de chemin et nom de fichier pour un fichier exécutable contenu dans le module spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetModuleHandleA | Cette fonction permet de retourner l'identificateur Handle du module spécifié si le fichier est situé dans l'espace d'adresse d'un processus appelant.
GetModuleHandleW | Cette fonction permet de retourner l'identificateur Handle du module spécifié si le fichier est situé dans l'espace d'adresse d'un processus appelant avec des paramètres de chaine de caractères étendue (Unicode).
GetNamedPipeHandleStateA | Cette fonction permet de demander les informations d'état conçernant le nom du tuyau spécifié.
GetNamedPipeHandleStateW | Cette fonction permet de demander les informations d'état conçernant le nom du tuyau spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetNamedPipeInfo | Cette fonction permet de demander les informations conçernant le nom de tuyau spécifié.
GetNumaAvailableMemoryNode | Cette fonction permet de demander la quantité de mémoire disponible dans le noeud spécifié.
GetNumberFormatA | Cette fonction permet de transformer un nombre selon le format d'affichage spécifié.
GetNumberFormatW | Cette fonction permet de transformer un nombre selon le format d'affichage spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetNumberOfConsoleInputEvents | Cette fonction permet de demander le nombre d'enregistrement d'entrée non lue dans le tampon d'entrée de console.
GetNumberOfConsoleMouseButtons | Cette fonction permet de demander le nombre de boutons de la souris qu'utilise la console courante.
GetOEMCP | Cette fonction permet de demander le code de page OEM du système d'exploitation.
GetOverlappedResult | Cette fonction permet de retourner le résultat d'une opération de recouvrement sur un fichier, un tuyau ou un périphérique de communications spécifié
GetPriorityClass | Cette fonction permet de retourner la priorité d'une classe pour un processus spécifié.
GetPrivateProfileIntA | Cette fonction permet de demander un entier associé avec une clef dans une section spécifié d'un fichier initialisé.
GetPrivateProfileIntW | Cette fonction permet de demander un entier associé avec une clef dans une section spécifié d'un fichier initialisé avec des paramètres de chaine de caractères étendue (Unicode).
GetPrivateProfileSectionA | Cette fonction permet de demander tous les valeurs et clefs pour la section initialisé spécifié.
GetPrivateProfileSectionW | Cette fonction permet de demander tous les valeurs et clefs pour la section initialisé spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetPrivateProfileSectionNamesA | Cette fonction permet de demander les noms de toutes les sections dans un fichier initialisé.
GetPrivateProfileSectionNamesW | Cette fonction permet de demander les noms de toutes les sections dans un fichier initialisé avec des paramètres de chaine de caractères étendue (Unicode).
GetPrivateProfileStringA | Cette fonction permet de demander une chaine de caractères de la section spécifié dans un fichier initialisé.
GetPrivateProfileStringW | Cette fonction permet de demander une chaine de caractères de la section spécifié dans un fichier initialisé avec des paramètres de chaine de caractères étendue (Unicode).
GetProcAddress | Cette fonction permet de demander l'adresse d'une fonction d'exportation de bibliothèque de liens dynamique (DLL).
GetProcessAffinityMask | Cette fonction permet de demander un masque de correspondance de processus spécifié avec le système.
GetProcessHeap | Cette fonction permet de demander un identificateur Handle pour la mémoire de tas d'un processus appelant.
GetProcessHeaps | Cette fonction permet de demander un identificateur Handle pour tous les mémoires de tas valides pour un processus appelant.
GetProcessPriorityBoost | Cette fonction permet de demander l'état de la priorité de contrôle d'amplificateur d'un processus spécifié.
GetProcessShutdownParameters | Cette fonction permet de demander les paramètres de fermetures et d'éteindre le système d'exploitation pour un le processus appelant courant.
GetProcessTimes | Cette fonction permet de demander les informations d'horloge pour le processus spécifié.
GetProcessVersion | Cette fonction permet de demander la version majeur et mineur pour un processus spécifié en exécution.
GetProcessWorkingSetSize | Cette fonction permet de demander la taille de l'espace de travail minimum et maximum pour le processus spécifié.
GetProfileIntA | Cette fonction permet de demander un entier pour le nom de clef spécifié dans une section spécifié dans un fichier «WIN.INI».
GetProfileIntW | Cette fonction permet de demander un entier pour le nom de clef spécifié dans une section spécifié dans un fichier «WIN.INI» avec des paramètres de chaine de caractères étendue (Unicode).
GetProfileSectionA | Cette fonction permet de demander tous les valeurs et clefs pour la section spécifié dans un fichier «WIN.INI».
GetProfileSectionW | Cette fonction permet de demander tous les valeurs et clefs pour la section spécifié dans un fichier «WIN.INI» avec des paramètres de chaine de caractères étendue (Unicode).
GetProfileStringA | Cette fonction permet de demander une chaine de caractères associé avec la clef spécifié dans une section du fichier «WIN.INI».
GetProfileStringW | Cette fonction permet de demander une chaine de caractères associé avec la clef spécifié dans une section du fichier «WIN.INI» avec des paramètres de chaine de caractères étendue (Unicode).
GetQueuedCompletionStatus | Cette fonction permet d'essayer de compléter la file d'attente d'un paquet d'entrée/sortie spécifié pour un port d'entrée/sortie.
GetShortPathNameA | Cette fonction permet de demander, à partir d'un nom long, le nom en format DOS (8 caractères de nom et 3 caractères d'extension) d'un fichier.
GetShortPathNameW | Cette fonction permet de demander, à partir d'un nom long, le nom en format DOS (8 caractères de nom et 3 caractères d'extension) d'un fichier avec des paramètres de chaine de caractères étendue (Unicode).
GetStartupInfoA | Cette fonction permet de demander le contenu de la structure «STARTUPINFO» spécifié quand un appel de processus est créé.
GetStartupInfoW | Cette fonction permet de demander le contenu de la structure «STARTUPINFO» spécifié quand un appel de processus est créé avec des paramètres de chaine de caractères étendue (Unicode).
GetStdHandle | Cette fonction permet de demander le Handle d'une entrée ou sortie standard.
GetStringTypeA | Cette fonction permet de retourner des informations type de caractère pour la chaine de caractères spécifié.
GetStringTypeExA | Cette fonction permet de retourner des informations type de caractère pour la chaine de caractères spécifié en Win32.
GetStringTypeExW | Cette fonction permet de retourner des informations type de caractère pour la chaine de caractères spécifié en Win32 avec des paramètres de chaine de caractères étendue (Unicode).
GetStringTypeW | Cette fonction permet de retourner des informations type de caractère pour la chaine de caractères spécifié avec des paramètres de chaine de caractères étendue (Unicode).
GetSystemDefaultLCID | Cette fonction permet de demander l'identificateur locale du système par défaut.
GetSystemDefaultLangID | Cette fonction permet de demander l'identificateur de langage système par défaut.
GetSystemDirectoryA | Cette fonction permet de demander le répertoire dans lequel les fichiers systèmes du système d'exploitations de Windows sont situés.
GetSystemDirectoryW | Cette fonction permet de demander le répertoire dans lequel les fichiers systèmes du système d'exploitations de Windows sont situés avec des paramètres de chaine de caractères étendue (Unicode).
GetSystemInfo | Cette fonction permet de demander divers informations à propos du système courant et du microprocesseur.
GetSystemPowerStatus | Cette fonction permet de demander l'état de l'alimentation en énergie de l'ordinateur.
GetSystemTime | Cette fonc tion permet de demander le temps (date et heure) courant du système d'exploitation. Le temps du système d'exploitation est une expression UTC (Coordinated Universal Time).
GetSystemTimeAsFileTime | Cette fonction permet de demander la date et l'heure du système d'exploitation.
GetSystemTimeAdjustment | Cette fonction permet de demander si le système applique périodiquement un ajustement du temps après chaque tic d'horloge.
GetTapeParameters | Cette fonction permet de demander des informations descriptives sur l'unité de bande magnétique de copie de sauvegarde.
GetTapePosition | Cette fonction permet de demander l'adresse courante logique ou en bloc absolue sur une bande magnétique de copie de sauvegarde.
GetTapeStatus | Cette fonction permet de demander si la bande magnétique de copie de sauvegarde est prête à recevoir une commande de processus.
GetTempFileNameA | Cette fonction permet de demander un nom de fichier créer temporairement.
GetTempFileNameW | Cette fonction permet de demander un nom de fichier créer temporairement avec des paramètres de chaine de caractères étendue (Unicode).
GetTempPathA | Cette fonction permet de demander le répertoire par défaut des fichiers temporairement.
GetTempPathW | Cette fonction permet de demander le répertoire par défaut des fichiers temporairement avec des paramètres de chaine de caractères étendue (Unicode).
GetThreadContext | Cette fonction permet de demander le contexte d'un processus léger spécifié.
GetThreadLocale | Cette fonction permet de demander l'identificateur local d'un processus.
GetThreadPriority | Cette fonction permet de retourner la valeur de priorité du processus léger spécifié.
GetThreadPriorityBoost | Cette fonction permet de retourner la priorité de lancement d'un processus léger.
GetThreadSelectorEntry | Cette fonction permet de retourner l'entrée de descripteur de table pour le sélecteur et le processus léger spécifié.
GetThreadTimes | Cette fonction permet de demander les informations de temps à propos du processus léger spécifié.
GetTickCount | Cette fonction permet de demander le nombre de milliseconde écoulé depuis le démarrage de Windows.
GetTimeFormatA | Cette fonction permet de retourner la chaine de caractères du format du temps localement.
GetTimeFormatW | Cette fonction permet de retourner la chaine de caractères du format du temps localement avec des paramètres de chaine de caractères étendue (Unicode).
GetTimeZoneInformation | Cette fonction permet de demander les informations de la zone horaire courante du système d'exploitation Windows.
GetUserDefaultLCID | Cette fonction permet de demander l'identificateur local de l'utilisateur par défaut.
GetVersion | Cette fonction permet de demander le numéro de version courante du système d'exploitation Windows et les informations à propos de la plateforme du système d'exploitation.
GetVersionExA | Cette fonction permet de demander la version du système d'exploitation Windows.
GetVersionExW | Cette fonction permet de demander la version du système d'exploitation Windows avec des paramètres de chaine de caractères étendue (Unicode).
GetVolumeInformationA | Cette fonction permet de demander les informations d'entête d'une unité disque.
GetVolumeInformationW | Cette fonction permet de demander les informations d'entête d'une unité disque avec des paramètres de chaine de caractères étendue (Unicode).
GetWindowsDirectoryA | Cette fonction permet de demander le répertoire dans lequel le système d'exploitation Windows est situés.
GetWindowsDirectoryW | Cette fonction permet de demander le répertoire dans lequel le système d'exploitation Windows est situés avec des paramètres de chaine de caractères étendue (Unicode).
GlobalAddAtomA | Cette fonction permet d'ajouter un caractère à une table global d'Atom et retourne une valeur unique d'identificateur par chaine de caractères.
GlobalAddAtomW | Cette fonction permet d'ajouter un caractère à une table global d'Atom et retourne une valeur unique d'identificateur par chaine de caractères avec des paramètres de chaine de caractères étendue (Unicode).
GlobalAlloc | Cette fonction permet d'allouer de la mémoire dans les ressources global du système d'exploitation.
GlobalCompact | Cette fonction permet de réorganiser les allocations de mémoire dynamique du tas global en spécifiant une taille de mémoire minimum.
GlobalDeleteAtom | Cette fonction permet de décrémenté le compteur de référence de la chaine de caractères d'Atom global.
GlobalFindAtomA | Cette fonction permet de rechercher une table d'Atom global dans la chaine de caractères spécifié et demande l'Atom global associé avec la chaine de caractères.
GlobalFindAtomW | Cette fonction permet de rechercher une table d'Atom global dans la chaine de caractères spécifié et demande l'Atom global associé avec la chaine de caractères étendue (Unicode).
GlobalFix | Cette fonction permet de prévenir l'objet de mémoire global donnée contre un mouvement de mémoire linéaire. Cette fonction est obsolète.
GlobalFlags | Cette fonction permet de retourner les informations à propos de l'objet de mémoire global spécifié.
GlobalFree | Cette fonction permet de libérer de la mémoire dans les ressources global du système d'exploitation.
GlobalGetAtomNameA | Cette fonction permet de demander une copie de la chaine de caractères associé avec l'Atom global donnée.
GlobalGetAtomNameW | Cette fonction permet de demander une copie de la chaine de caractères associé avec l'Atom global donnée avec des paramètres de chaine de caractères étendue (Unicode).
GlobalHandle | Cette fonction permet de demander le Handle de l'objet de mémoire global spécifié.
GlobalLock | Cette fonction permet de verrouiller l'emplacement du bloc de mémoire dans les ressources global du système d'exploitation.
GlobalMemoryStatus | Cette fonction permet de demander l'état de la mémoire du système d'exploitation.
GlobalMemoryStatusEx | Cette fonction permet de demander l'état de la mémoire du système d'exploitation ayant plus de 4 Go de RAM d'installer sur l'ordinateur.
GlobalReAlloc | Cette fonction permet de changer la taille ou les attributs de l'objet de mémoire global spécifié.
GlobalSize | Cette fonction permet de demander la taille courante, en octets, de l'objet de mémoire global.
GlobalUnfix | Cette fonction permet d'annuler les effets d'une fonction GlobalFix et d'allouer l'objet de mémoire global a être déplacé dans la mémoire linéaire. Cette fonction est obsolète.
GlobalUnlock | Cette fonction permet de déverrouiller l'emplacement du bloc de mémoire dans les ressources global du système d'exploitation.
GlobalUnWire | Cette fonction permet de restituer la convertion d'un pointeur de processus 32 bits après une allocation de mémoire.
HeapAlloc | Cette fonction permet d'allouer un bloc de mémoire à l'aide d'un tas.
HeapCompact | Cette fonction permet de demander la taille de la largeur d'un bloc de mémoire disponible dans le tas spécifié.
HeapCreate | Cette fonction permet de créer un objet de tas privé pouvant être utilisé par le processus appelant.
HeapDestroy | Cette fonction permet de détruire l'objet de tas spécifié.
HeapFree | Cette fonction permet de libérer un bloc de mémoire précédamment alloué d'un tas par la fonction HeapAlloc ou HeapReAlloc.
HeapLock | Cette fonction permet de verrouiller l'association avec le tas spécifié dans un objet de section critique.
HeapReAlloc | Cette fonction permet de réallouer un bloc de mémoire d'un tas.
HeapSize | Cette fonction permet de demander la taille d'un bloc de mémoire alloué dans le tas par la fonction HeapAlloc ou HeapReAlloc.
HeapUnlock | Cette fonction permet de déverrouiller l'association avec le tas spécifié dans un objet de section critique.
HeapValidate | Cette fonction permet de valider le tas spécifié.
HeapWalk | Cette fonction permet d'énumérer les blocs de mémoire dans le tas spécifié.
InitAtomTable | Cette fonction permet d'initialiser la table d'Atom local et fixe la taille spécifié.
InitializeCriticalSection | Cette fonction permet d'initialiser un objet de section critique.
InterlockedCompareExchange | Cette fonction permet d'effectuer un traitement de comparaison atomique de valeurs spécifiés et échange les valeurs en se basant sur le résultat de la comparaison.
InterlockedDecrement | Cette fonction permet de décrémenter les deux valeurs spécifié de un et vérifie le résultat des valeurs.
InterlockedExchange | Cette fonction permet d'échanger automatiquement une paire de valeurs 32 bits.
InterlockedExchangeAdd | Cette fonction permet d'effectuer un traitement automatique d'ajouter d'une valeur incrémenté à une variable ajouté.
InterlockedIncrement | Cette fonction permet d'incrémenter les deux valeurs des variables spécifiés et vérifie la valeur du résultat.
IsBadCodePtr | Cette fonction permet de demander si l'appel du processus a un accès de mémoire en lecture à l'adresse spécifié.
IsBadHugeReadPtr | Cette fonction permet de vérifier si l'appel du processus a un accès en lecture dans les rangs de mémoire spécifié.
IsBadHugeWritePtr | Cette fonction permet de vérifier si l'appel du processus a un accès en écriture dans les rangs de mémoire spécifié.
IsBadReadPtr | Cette fonction permet de vérifier si l'appel du processus a un accès en lecture dans les rangs de mémoire spécifié.
IsBadStringPtrA | Cette fonction permet de vérifier que l'appel du processus à un accès en lecture dans les rangs de mémoire pointer sur une chaine de caractères.
IsBadStringPtrW | Cette fonction permet de vérifier que l'appel du processus à un accès en lecture dans les rangs de mémoire pointer sur une chaine de caractères étendue (Unicode).
IsBadWritePtr | Cette fonction permet de vérifier si l'appel du processus a un accès en écriture dans les rangs de mémoire spécifié.
IsDBCSLeadByte | Cette fonction permet de demander si un caractère spécifié est un octet de tête, le premier octet d'un caractère est un DBCS (Double-Byte Character Set).
IsDBCSLeadByteEx | Cette fonction permet de demander si un caractère spécifié est un octet de tête, le premier octet d'un caractère est un DBCS (Double-Byte Character Set) avec un code de page.
IsDebuggerPresent | Cette fonction permet de demander si l'application en cours est sous l'influence d'un débogueur.
IsProcessorFeaturePresent | Cette fonction permet de demander si les fonctionnalités du microprocessseur sont supportés par l'un des microprocesseur de la machine courante.
IsValidCodePage | Cette fonction permet d'indiquer si la page de code spécifié est valide.
IsValidLocale | Cette fonction permet d'appliquer un test de validité à un identificateur locale.
LCMapStringA | Cette fonction permet de cartographier une chaine de caractères vers une autre en effectuant le traitement de transformation de dépendance locale.
LCMapStringW | Cette fonction permet de cartographier une chaine de caractères étendue (Unicode) vers une autre en effectuant le traitement de transformation de dépendance locale.
LeaveCriticalSection | Cette fonction permet de libérer le propriétaire d'un objet de section critique spécifié.
LoadLibraryA | Cette fonction permet d'effectuer le chargement du module de bibliothèque spécifié.
LoadLibraryW | Cette fonction permet d'effectuer le chargement du module de bibliothèque spécifié avec des paramètres de chaine de caractères étendue (Unicode).
LoadLibraryExA | Cette fonction permet de cartographier un module exécutable spécifié dans l'espace d'adressage du processus d'appel.
LoadLibraryExW | Cette fonction permet de cartographier un module exécutable spécifié dans l'espace d'adressage du processus d'appel avec des paramètres de chaine de caractères étendue (Unicode).
LoadModule | Cette fonction permet de charger et d'exécution une application Windows ou crée un nouvel instance dans un application Windows existante.
LoadResource | Cette fonction permet de charger la ressource spécifié dans la mémoire global.
LocalAlloc | Cette fonction permet d'allouer le nombre d'octets spécifiés pour le tas local.
LocalCompact | Cette fonction permet de réarranger le tas local si la quantité de mémoire spécifié est disponible.
LocalFileTimeToFileTime | Cette fonction permet de convertir un temps de fichier local en temps de fichier basé sur l'UTC (Coordinated Universal Time).
LocalFlags | Cette fonction permet de demander les informations à propos de l'objet de mémoire local.
LocalFree | Cette fonction permet de demander l'objet de mémoire local et d'invalider un Handle.
LocalLock | Cette fonction permet de demander un pointeur sur l'objet de mémoire local.
LocalReAlloc | Cette fonction permet de changer la taille ou les attributs d'un objet de mémoire local spécifié.
LocalShrink | Cette fonction rapetisser le tas local du segment spécifié.
LocalSize | Cette fonction permet de demander la taille, en octets, de l'objet de mémoire local spécifié.
LocalUnlock | Cette fonction permet de déverrouiller un objet de mémoire local spécifié.
LockFile | Cette fonction permet de verrouiller une région d'un fichier ouvert.
LockFileEx | Cette fonction permet de verrouiller un rang d'octets dans un fichier ouvert avec un accès de partage ou d'exclusivité.
LockResource | Cette fonction permet de verrouiller une ressource spécifié.
lstrcatA | Cette fonction permet d'ajouter une chaine de caractères à une autre.
lstrcatW | Cette fonction permet d'ajouter une chaine de caractères étendue (Unicode) à une autre.
lstrcmpA | Cette fonction permet d'effectuer la comparaison de deux chaines de caractères ASCIZ.
lstrcmpW | Cette fonction permet d'effectuer la comparaison de deux chaines de caractères étendues (Unicode).
lstrcmpiA | Cette fonction permet d'effectuer une comparaison de deux chaines de caractères sans tenir compte des majuscules ou minuscules.
lstrcmpiW | Cette fonction permet d'effectuer une comparaison de deux chaines de caractères étendues (Unicode) sans tenir compte des majuscules ou minuscules.
lstrcpyA | Cette fonction permet de copier une chaine de caractères dans un tampon.
lstrcpyW | Cette fonction permet de copier une chaine de caractères étendues (Unicode) dans un tampon.
lstrcpynA | Cette fonction permet d'effectuer une copie du nombre de caractères spécifié d'une chaine de caractères vers un tampon en mémoire.
lstrcpynW | Cette fonction permet d'effectuer une copie du nombre de caractères spécifié d'une chaine de caractères étendue (Unicode) vers un tampon en mémoire.
lstrlenA | Cette fonction permet de retourner la longueur, en octets, de la chaine de caractères spécifié.
lstrlenW | Cette fonction permet de retourner la longueur, en octets, de la chaine de caractères étendue (Unicode) spécifié.
MapViewOfFile | Cette fonction permet de cartographier une vue d'un fichier dans l'espace d'adressage d'un processus appelant.
MapViewOfFileEx | Cette fonction permet de cartographier une vue d'un fichier dans l'espace d'adressage d'un processus appelant avec un adresse de mémoire spécifié.
MoveFileA | Cette fonction permet de renommer ou déplacer un fichier ou un répertoire
MoveFileExA | Cette fonction permet de renommer un fichier existant.
MoveFileExW | Cette fonction permet de renommer un fichier existant avec un paramètre de chaine de caractères étendue (Unicode).
MoveFileW | Cette fonction permet de renommer ou déplacer un fichier ou un répertoire avec un paramètre de chaine de caractères étendue (Unicode).
MulDiv | Cette fonction permet de diviser le produit de deux entiers long
MultiByteToWideChar | Cette fonction permet de convertir une chaine de caractères ASCII en chaine de caractères Unicode.
OpenEventA | Cette fonction permet de demander un Handle dans objet existant d'événement nommé.
OpenEventW | Cette fonction permet de demander un Handle dans objet existant d'événement nommé avec des paramètres de chaines de caractères étendue (Unicode).
OpenFile | Cette fonction permet de créer, d'ouvrir, de réouvrir ou de supprimer un fichier.
OpenFileMappingA | Cette fonction permet d'ouvrir un objet de cartographie de fichier nommé.
OpenFileMappingW | Cette fonction permet d'ouvrir un objet de cartographie de fichier nommé avec des paramètres de chaine de caractères étendue (Unicode).
OpenMutexA | Cette fonction permet d'ouvrir un objet Mutex nommé.
OpenMutexW | Cette fonction permet d'ouvrir un objet Mutex nommé avec des paramètres de chaine de caractères étendue (Unicode).
OpenProcess | Cette fonction permet d'ouvrir un accès de jeton associé avec un processus.
OpenSemaphoreA | Cette fonction permet de retourner le Handle d'objet existant de sémaphore nommé.
OpenSemaphoreW | Cette fonction permet de retourner le Handle d'objet existant de sémaphore nommé avec des paramètres de chaine de caractères étendue (Unicode).
OpenWaitableTimerA | Cette fonction permet d'ouvrir une minuterie d'attente existante nommé.
OpenWaitableTimerW | Cette fonction permet d'ouvrir une minuterie d'attente existante nommé avec des paramètres de chaine de caractères étendue (Unicode).
OutputDebugStringA | Cette fonction permet d'envoyer une chaine de caractères au débogueur de l'application courante.
OutputDebugStringW | Cette fonction permet d'envoyer une chaine de caractères au débogueur de l'application courante avec des paramètres de chaine de caractères étendue (Unicode).
PeekConsoleInputA | Cette fonction permet d'effectuer la lecture des données du tampon d'entrée de la console spécifié sans retirer le contenu lue du tampon.
PeekConsoleInputW | Cette fonction permet d'effectuer la lecture des données du tampon d'entrée de la console spécifié sans retirer le contenu lue du tampon avec des paramètres de chaine de caractères étendue (Unicode).
PeekNamedPipe | Cette fonction permet de copier les données d'un tuyau nommé ou anonyme dans un tampon sans le retirer du tuyau.
PostQueuedCompletionStatus | Cette fonction permet de poster une paquet d'achèvement d'entrée/sortie vers un port d'achèvement d'entrée/sortie.
PrepareTape | Cette fonction permet de préparer le ruban pour être accédé ou enlevé.
Process32First | Cette fonction permet de demander le premier processus provenant de la liste contenu dans une photo du système d'exploitation.
Process32Next | Cette fonction permet de demander le processus suivant provenant de la liste contenu dans une photo du système d'exploitation.
PulseEvent | Cette fonction permet de fournir une simple opération fixant l'état d'un objet d'événement spécifié et réinitialisant après qu'un délai d'attente de processus approprié s'est produit.
PurgeComm | Cette fonction permet de débarrasser de tous les caractères d'un tampon de sortie ou d'entrée d'une ressource de communication spécifié.
QueryDosDeviceA | Cette fonction permet à une application de demander des informations à propre d'un nom de périphérique DOS.
QueryDosDeviceW | Cette fonction permet à une application de demander des informations à propre d'un nom de périphérique DOS avec des paramètres de chaine de caractères étendue (Unicode).
QueryPerformanceCounter | Cette fonction permet de demander la valeur actuel du compteur de haute performance de la machine.
QueryPerformanceFrequency | Cette fonction permet de demander la valeur de la fréquence du compteur de haute performance de la machine.
QueueUserAPC | Cette fonction permet d'ajouter une objet de procédure d'appel désychronisée (APC) en mode utilisateur dans une file d'attente APC d'un processus léger spécifié.
RaiseException | Cette fonction permet de déclencher une exception dans le processus léger appelant.
ReadConsoleA | Cette fonction permet d'effectuer la lecture d'un caractère en provenance de la console.
ReadConsoleW | Cette fonction permet d'effectuer la lecture d'un caractère en provenance de la console avec des paramètres de chaine de caractères étendue (Unicode).
ReadConsoleInputA | Cette fonction permet d'effectuer la lecture de données du tampon d'entrée d'une console et retire les données du tampon.
ReadConsoleInputW | Cette fonction permet d'effectuer la lecture de données du tampon d'entrée d'une console et retire les données du tampon avec des paramètres de chaine de caractères étendue (Unicode).
ReadConsoleOutputA | Cette fonction permet d'effectuer la lecture de données de caractère et de couleur d'attribut dans un bloc rectangulaire d'une cellule de caractères d'un tampon de console d'écran et écrire le résultat de ses données dans un tampon spécifié.
ReadConsoleOutputW | Cette fonction permet d'effectuer la lecture de données de caractère et de couleur d'attribut dans un bloc rectangulaire d'une cellule de caractères d'un tampon de console d'écran et écrire le résultat de ses données dans un tampon spécifié avec des paramètres de chaine de caractères étendue (Unicode).
ReadConsoleOutputAttribute | Cette fonction permet de copier le nombre spécifié dans la couleur d'attribut d'arrière-plan ou de premier plan d'une cellule consécutive d'un tampon de console d'écran en débutant à la position spécifié.
ReadConsoleOutputCharacterA | Cette fonction permet de copier un nombre de caractères d'une cellule consécutif d'un tampon de console écran en débutant à la position spécifié.
ReadConsoleOutputCharacterW | Cette fonction permet de copier un nombre de caractères d'une cellule consécutif d'un tampon de console écran en débutant à la position spécifié avec des paramètres de chaine de caractères étendue (Unicode).
ReadDirectoryChangesW | Cette fonction permet de demander les informations descriptives de changement ayant eu lieu dans le répertoire spécifié.
ReadFile | Cette fonction permet d'effectuer la lecture d'un fichier, en débutant à la position spécifié par le pointeur de fichier.
ReadFileEx | Cette fonction permet d'effectuer la lecture de données d'un fichier désychronisé.
ReadProcessMemory | Cette fonction permet d'effectuer la lecture de mémoire dans un processus spécifié.
RegisterServiceProcess | Cette fonction permet de cacher un programme de facon à ce qu'il ne soit pas afficher lorsqu'on appuis sur Ctrl+Alt+Delete pour voir la liste des programmes dans le Gestionnaire de tâche.
ReleaseMutex | Cette fonction permet de relâcher la propriété de l'objet Mutex spécifié.
ReleaseSemaphore | Cette fonction permet d'augmenter le compteur de l'objet de sémaphore spécifié par une quantité spécifié.
RemoveDirectoryA | Cette fonction permet de supprimer un répertoire.
RemoveDirectoryW | Cette fonction permet de supprimer un répertoire avec les paramètres de chaine de caractères étendues (Unicode).
RemoveDirectoryTransactedA | Cette fonction permet de supprimer un répertoire d'une opération de transaction.
RemoveDirectoryTransactedW | Cette fonction permet de supprimer un répertoire d'une opération de transaction avec des paramètres de chaine de caractères étendue (Unicode).
ResetEvent | Cette fonction permet de fixer l'état de l'objet d'événement spécifié dans un sans signal.
ResumeThread | Cette fonction permet de décrémenter le compteur de processus léger suspendu.
RtlFillMemory | Cette fonction permet de remplir une zone de mémoire avec une valeur spécifié.
RtlMoveMemory | Cette fonction permet de copier un bloc de mémoire vers un autre emplacement mémoire.
ScrollConsoleScreenBufferA | Cette fonction permet de déplacer un bloc de données dans un tampon d'écran.
ScrollConsoleScreenBufferW | Cette fonction permet de déplacer un bloc de données dans un tampon d'écran avec des paramètres de chaine de caractères étendues (Unicode).
SearchPathA | Cette fonction permet d'effectuer une recherche dans le fichier spécifié.
SearchPathW | Cette fonction permet d'effectuer une recherche dans le fichier spécifié avec des paramètres de chaine de caractères étendues (Unicode).
SetCommBreak | Cette fonction permet de suspendre la transmission de caractères pour un périphérique de communications spécifié et place la ligne de transmission dans un état d'arrêt jusqu'à ce que la fonction ClearCommBreak soit appelée.
SetCommConfig | Cette fonction permet de fixer la configuration courante dans un périphérique de communication.
SetCommMask | Cette fonction permet de spécifier un ensemble d'événement être surveillé par un périphérique de communication.
SetCommState | Cette fonction permet de configurer un périphérique de communication en accord avec bloc de contrôle de périphérique (DCB) spécifié.
SetCommTimeouts | Cette fonction permet de fixer les paramètres de dépassement de délai pour tous les opérations de lecture ou d'écriture dans un périphérique de communication spécifié.
SetComputerNameA | Cette fonction permet de fixer le nom de l'ordinateur pour le système d'exploitation Windows.
SetComputerNameW | Cette fonction permet de fixer le nom de l'ordinateur pour le système d'exploitation Windows avec des paramètres de chaine de caractères étendues (Unicode).
SetConsoleActiveScreenBuffer | Cette fonction permet de fixer le tampon d'écran spécifié devant être actuellement affiché dans le tampon de la console d'écran.
SetConsoleCP | Cette fonction permet de fixer l'entrée de code de page utilisé par la console associé avec le processus appelant.
SetConsoleCtrlHandler | Cette fonction permet d'ajouter un d'enlever une définition d'application de la fonction HandlerRoutine de la liste des fonctions de gestionnaire pour un processus appelant.
SetConsoleCursorInfo | Cette fonction permet de fixer la taille et la visibilité du curseur dans le tampon de la console d'écran spécifié.
SetConsoleCursorPosition | Cette fonction permet de fixer la position du curseur pour l'affichage sur la console de texte.
SetConsoleMode | Cette fonction permet de fixer le mode d'entrée du tampon d'entrée de la console ou du mode de sortie d'un tampon de console d'écran.
SetConsoleOutputCP | Cette fonction permet de fixer le code de page de sortie utilisé par la console associé avec le processus appelant.
SetConsoleScreenBufferSize | Cette fonction permet de changer la taille d'un tampon de console d'écran spécifié.
SetConsoleTextAttribute | Cette fonction permet de fixer les attributs (couleur de fond et d'écriture) pour l'affichage sur la console de texte. C'est l'équivalent d'un octet d'attribut dans un écran de texte matériel.
SetConsoleTitleA | Cette fonction permet de fixer le titre de la barre de titre de la fenêtre d'application.
SetConsoleTitleW | Cette fonction permet de fixer le titre de la barre de titre de la fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
SetConsoleWindowInfo | Cette fonction permet de fixer la taille courante et la position de la fenêtre du tampon de la console d'écran.
SetCurrentDirectoryA | Cette fonction permet de fixer le répertoire courant du processus courant.
SetCurrentDirectoryW | Cette fonction permet de fixer le répertoire courant du processus courant avec des paramètres de chaine de caractères étendues (Unicode).
SetDefaultCommConfigA | Cette fonction permet de fixer la configuration par défaut pour un périphérique de communication.
SetDefaultCommConfigW | Cette fonction permet de fixer la configuration par défaut pour un périphérique de communication avec des paramètres de chaine de caractères étendues (Unicode).
SetEndOfFile | Cette fonction permet de fixer la position du pointeur de fichier à la fin du fichier utilisant un Handle.
SetEnvironmentVariableA | Cette fonction permet de fixer la valeur d'une variable d'environnement du système d'exploitation.
SetEnvironmentVariableW | Cette fonction permet de fixer la valeur d'une variable d'environnement du système d'exploitation avec des paramètres de chaine de caractères étendues (Unicode).
SetErrorMode | Cette fonction permet de contrôler comment le système d'exploitation gère les types sévères dans les erreurs sérieuses.
SetEvent | Cette fonction permet de fixer l'état de l'objet d'événement spécifié par un signal.
SetFileApisToANSI | Cette fonction permet de faire provoquer, à une série de fonctions de fichiers Win32, l'utilisation d'un ensemble de code de page de caractères ANSI.
SetFileApisToOEM | Cette fonction permet de faire provoquer, à une série de fonctions de fichiers Win32, l'utilisation d'un ensemble de code de page de caractères OEM.
SetFileAttributesA | Cette fonction permet de fixer les attributs d'un fichier ou d'un répertoire.
SetFileAttributesW | Cette fonction permet de fixer les attributs d'un fichier ou d'un répertoire avec des paramètres de chaine de caractères étendues (Unicode).
SetFilePointer | Cette fonction permet de déplacer un pointeur de ficher dans un fichier ouvert.
SetFileTime | Cette fonction permet de fixer la date et l'heure de la création, du dernière accès et de la dernière modification d'un fichier.
SetHandleCount | Cette fonction permet de changer le nombre de fichier Handle disponible pour un processus.
SetHandleInformation | Cette fonction permet de fixer certaines propriétés d'un objet Handle.
SetLastError | Cette fonction permet de fixer le code de la dernière erreur d'un appel de processus léger.
SetLocalTime | Cette fonction permet de fixer la date et l'heure locale courante.
SetLocaleInfoA | Cette fonction permet de fixer un item d'information local.
SetLocaleInfoW | Cette fonction permet de fixer un item d'information local avec des paramètres de chaine de caractères étendues (Unicode).
SetMailslotInfo | Cette fonction permet de fixer la valeur de dépassement de délai utilisable pour le mailslot spécifié d'une opération de lecture.
SetNamedPipeHandleState | Cette fonction permet de fixer le mode de lecture et le mode de bloc d'un tuyau nommé spécifié.
SetPriorityClass | Cette fonction permet de fixer la priorité d'une classe pour le processus spécifié.
SetProcessAffinityMask | Cette fonction permet de fixer un masque d'affinité de processeur pour le processus léger d'un processus spécifié.
SetProcessPriorityBoost | Cette fonction permet d'activer ou désactiver les habilitées du système pour stimuler temporairement la priorité d'un processus léger dans un processus spécifié.
SetProcessShutdownParameters | Cette fonction permet de fixer les paramètres de fermeture du système pour le processus appelant courant.
SetProcessWorkingSetSize | Cette fonction permet de fixer la taille du travail minimum et maximum d'un processus spécifié.
SetStdHandle | Cette fonction permet d'utiliser un ensemble de gestionnaire pour l'entrée standard, la sortie standard ou le périphérique d'erreur standard.
SetSystemPowerState | Cette fonction permet de fixer l'état de l'alimentation en énergie de l'ordinateur.
SetSystemTime | Cette fonction permet de fixer la date et l'heure système courante.
SetSystemTimeAdjustment | Cette fonction permet d'activer ou désactiver l'ajustement du temps périodique de l'horloge de l'heure de la journée.
SetTapeParameters | Cette fonction permet de fixer la taille d'un bloc de bande magnétique ou configure le périphérique de bande magnétique.
SetTapePosition | Cette fonction permet de fixer la position de la bande magnétique dans un périphérique spécifié.
SetThreadAffinityMask | Cette fonction permet de fixer le masque d'affinité du microprocesseur pour le processus léger spécifié.
SetThreadContext | Cette fonction permet de fixer le contexte d'un processus léger spécifié.
SetThreadIdealProcessor | Cette fonction permet de fixer le microprocesseur préféré pour un processus léger.
SetThreadLocale | Cette fonction permet de fixer l'appel de processus léger locale courant.
SetThreadPriority | Cette fonction permet de fixer la valeur de priorité pour le processus léger spécifié.
SetThreadPriorityBoost | Cette fonction permet d'activer ou désactiver l'habilité d'un système à temporairement stimuler la priorité d'un processus léger.
SetTimeZoneInformation | Cette fonction permet de fixer les paramètres de fuseau horaire courant.
SetUnhandledExceptionFilter | Cette fonction permet à une application de remplacer le gestionnaire d'exception de bas niveau dans les places Win32 du haut de chaque processus léger et processus.
SetupComm | Cette fonction permet d'initialiser les paramètres de communications pour un périphérique de communications spécifié.
SetVolumeLabelA | Cette fonction permet de fixer le nom de volume d'une unité de disque.
SetVolumeLabelW | Cette fonction permet de fixer le nom de volume d'une unité de disque avec des paramètres de chaine de caractères étendues (Unicode).
SetWaitableTimer | Cette fonction permet d'activer la minuterie d'attente spécifié.
SignalObjectAndWait | Cette fonction permet de signaler un objet et d'attendre après un autre objet, une simple opération.
SizeofResource | Cette fonction permet de demander la taille, en octets, d'une ressource spécifié.
Sleep | Cette fonction permet de faire passer en mode d'attente pendant un certain délai en milliseconde le processus courant.
SleepEx | Cette fonction permet de faire en sorte que le processus léger courant entre dans un état d'attente jusqu'à ce que l'intervalle de temps spécifié est passé ou jusqu'à l'achèvement d'une fonction d'appel arrière d'entrée/sortie soit appelé.
SuspendThread | Cette fonction permet de suspendre le processus léger spécifié.
SwitchToFiber | Cette fonction permet de planifier une fibre.
SwitchToThread | Cette fonction permet de provoquer l'exécution d'un rendement de processus léger vers un autre processus léger étant prêt a être exécuté par le microprocesseur courant.
SystemTimeToFileTime | Cette fonction permet de convertir le temps système vers le temps fichier.
SystemTimeToTzSpecificLocalTime | Cette fonction permet de convertir l'UTC (Coordinated Universal Time) vers un fuseau horaire spécifié correspondant au temps locale.
TerminateProcess | Cette fonction permet de terminer le processus spécifié et tous ses processus légers.
TerminateThread | Cette fonction permet de terminer le processus léger spécifié.
TlsAlloc | Cette fonction permet d'allouer un processus léger d'entrepose d'index locale (TLS).
TlsFree | Cette fonction permet de libérer un processus léger d'entrepose d'index locale (TLS).
TlsGetValue | Cette fonction permet de demander la valeur dans un appel de processus d'entreposage d'une fente locale (TLS) pour un index TLS spécifié.
TlsSetValue | Cette fonction permet d'entreposer la valeur d'un appel de processus d'entreposage d'une fente locale (TLS) pour un index TLS spécifié.
TransactNamedPipe | Cette fonction permet de combiner dans une simple opération réseau les fonctions d'écriture d'un message et de lecture de message d'un tuyau nommé spécifié.
TransmitCommChar | Cette fonction permet de transmettre un caractère spécifié à venir dans des données en attente dans un tampon de sortie du périphérique de communication spécifié.
TryEnterCriticalSection | Cette fonction permet d'effectuer une tentative pour entrer dans une section critique sans blocage.
UnhandledExceptionFilter | Cette fonction permet de passer une exception non définit au débogueur si le processus de déboguage est actif.
UnlockFile | Cette fonction permet de déverrouiller une région d'un fichier ouvert.
UnlockFileEx | Cette fonction permet de déverrouiller une rangée d'octets précédamment verrouillé dans un fichier ouvert.
UnmapViewOfFile | Cette fonction permet de cartographier une vue cartographier dans un fichier d'un espace d'adressage d'un processus appelant.
UpdateResourceA | Cette fonction permet d'ajouter, supprimer ou remplacer une ressource dans un fichier exécutable.
UpdateResourceW | Cette fonction permet d'ajouter, supprimer ou remplacer une ressource dans un fichier exécutable avec des paramètres de chaine de caractères étendues (Unicode).
VerLanguageNameA | Cette fonction permet de demander le MID identifiant le langage utilisé par le système d'exploitation.
VerLanguageNameW | Cette fonction permet de demander le MID identifiant le langage utilisé par le système d'exploitation avec des paramètres de chaines de caractères étendues (Unicode).
VirtualAlloc | Cette fonction permet de réservé ou d'engager une région de pages dans un espace d'adressage virtuel d'un processus appelant.
VirtualAllocEx | Cette fonction permet de réservé ou d'engager une région de pages dans un espace d'adressage virtuel pour le processus spécifié.
VirtualFree | Cette fonction permet de relâcher ou désengager (ou les deux) une région de pages dans une espace de d'adressage virtuel d'un processus appelant.
VirtualFreeEx | Cette fonction permet de relâcher ou désengager (ou les deux) une région de pages dans une espace de d'adressage virtuel pour un processus spécifié.
VirtualLock | Cette fonction permet de verrouiller une région spécifié dans un espace d'adressage virtuel de la mémoire en s'assurant que l'accès ultérieur à la région ne soit pas passible d'une erreur de page.
VirtualQuery | Cette fonction permet de fournir les informations à propos d'un rang de pages dans un espace d'adressage virtuel pour un processus appelant.
VirtualQueryEx | Cette fonction permet de fournir les informations à propos d'un rang de pages dans un espace d'adressage virtuel dans un processus spécifié.
VirtualUnlock | Cette fonction permet de déverrouiller un range de pages spécifié dans un espace d'adressage virtuel d'un processus et activant le système pour l'échange de pages dans le fichier de pagination si nécessaire.
WaitCommEvent | Cette fonction permet d'attendre qu'un événement se produise sur le périphérique de communication spécifié.
WaitForDebugEvent | Cette fonction permet d'attendre qu'un événement de déboguage se produise dans un processus en déboguage.
WaitForMultipleObjects | Cette fonction permet de retourner lorsque l'un des objets indiqués est dans l'état signalé, ou lorsque le délai d'attente spécifié s'est écoulé.
WaitForMultipleObjectsEx | Cette fonction permet d'attendre que la fonction soit utilisés pour un traitement d'attendre d'alerte.
WaitForSingleObject | Cette fonction permet d'attendre qu'un objet retourne un signal ou que le délai spécifié soit écoulé.
WaitForSingleObjectEx | Cette fonction permet d'étendre la fonction d'attente étant utilisés pour un traitement d'attendre d'alerte.
WaitNamedPipeA | Cette fonction permet d'attendre jusqu'à ce qu'un dépassement d'intervalle ou d'une instance d'un tuyau nommé spécifié soit disponible pour être connecté à processus en attente d'une opération ConnectNamedPipe se produise.
WaitNamedPipeW | Cette fonction permet d'attendre jusqu'à ce qu'un dépassement d'intervalle ou d'une instance d'un tuyau nommé spécifié soit disponible pour être connecté à processus en attente d'une opération ConnectNamedPipe se produise avec des paramètres de chaine de caractères étendue (Unicode).
WideCharToMultiByte | Cette fonction permet de cartographier une chaine de caractères Unicode en une nouvelle chaine de caractères.
WinExec | Cette fonction permet de lancer l'exécution d'un programme externe.
WriteConsoleA | Cette fonction permet d'effectuer l'écriture d'une chaine de caractères dans la sortie de la console standard.
WriteConsoleW | Cette fonction permet d'effectuer l'écriture d'une chaine de caractères dans la sortie de la console standard avec des paramètres de chaine de caractères étendues (Unicode).
WriteConsoleInputA | Cette fonction permet d'écrire des données directement dans l'entrée du tampon de la console.
WriteConsoleInputW | Cette fonction permet d'écrire des données directement dans l'entrée du tampon de la console avec des paramètres de chaine de caractères étendues (Unicode).
WriteConsoleOutputA | Cette fonction permet d'écrire le caractère et la donnée d'attribut de couleur vers un bloc rectangulaire spécifié dans une cellule de caractères d'un tampon de console d'écran.
WriteConsoleOutputW | Cette fonction permet d'écrire le caractère et la donnée d'attribut de couleur vers un bloc rectangulaire spécifié dans une cellule de caractères d'un tampon de console d'écran avec des paramètres de chaine de caractères étendue (Unicode).
WriteConsoleOutputAttribute | Cette fonction permet de copier un nombre d'attributs de couleurs de premier plan et d'arrière-plan dans une cellule consécutive d'un tampon de console d'écran en débutant à l'emplacement spécifié.
WriteConsoleOutputCharacterA | Cette fonction permet d'effectuer une copie d'un nombre de caractères à une cellule consécutive d'un tampon de console d'écran en débutant à l'emplacement spécifié.
WriteConsoleOutputCharacterW | Cette fonction permet d'effectuer une copie d'un nombre de caractères à une cellule consécutive d'un tampon de console d'écran en débutant à l'emplacement spécifié avec des paramètres de chaine de caractères étendue (Unicode).
WriteFile | Cette fonction permet d'écrire des données dans un fichier et est conçue pour des opérations sychronisé ou désychronisé.
WriteFileEx | Cette fonction permet d'écrire des données dans un fichier.
WritePrivateProfileSectionA | Cette fonction permet de remplacer les clefs et les valeurs dans la section spécifié d'un fichier d'initialisation.
WritePrivateProfileSectionW | Cette fonction permet de remplacer les clefs et les valeurs dans la section spécifié d'un fichier d'initialisation avec des paramètres de chaine de caractères étendue (Unicode).
WritePrivateProfileStringA | Cette fonction permet de copier une chaine de caractères dans une section spécifié d'un fichier d'initialisation spécifié.
WritePrivateProfileStringW | Cette fonction permet de copier une chaine de caractères dans une section spécifié d'un fichier d'initialisation spécifié avec des paramètres de chaine de caractères étendue (Unicode).
WriteProcessMemory | Cette fonction permet d'écrire en mémoire pour le processus spécifié.
WriteProfileSectionA | Cette fonction permet de remplacer le contenu de la section spécifié dans le fichier «WIN.INI» avec les clefs et les valeurs spécifiés.
WriteProfileSectionW | Cette fonction permet de remplacer le contenu de la section spécifié dans le fichier «WIN.INI» avec les clefs et les valeurs spécifiés et avec les paramètres de chaine de caractères étendues (Unicode).
WriteProfileStringA | Cette fonction permet de copier une chaine de caractères dans la section spécifié d'un fichier «WIN.INI».
WriteProfileStringW | Cette fonction permet de copier une chaine de caractères dans la section spécifié d'un fichier «WIN.INI» avec des paramètres de chaine de caractères étendues (Unicode).
WriteTapemark | Cette fonction permet d'écrire une marque de fichier, un fixeur de marque, une marque de fichier court ou une long marque de fichier dans un périphérique de bande magnétique.
_hread | Cette fonction permet d'effectuer la lecture de données dans le fichier spécifié.
_hwrite | Cette fonction permet d'effectuer l'écriture de données dans le fichier spécifié.
_lclose | Cette fonction permet de fermer le fichier Handle spécifié.
_lcreat | Cette fonction permet de créer ou ouvrir un fichier spécifié.
_llseek | Cette fonction permet de positionner le pointeur du fichier Handle spécifié.
_lread | Cette fonction permet d'effectuer la lecture de données dans un fichier spécifié.

Voir également

Langage de programmation - C pour OS/2 - EXE, DLL et modules de OS/2 (Support de Windows 3.1) - KERNEL.EXE
Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «lz32.dll»

Description

Ce fichier contient la bibliothèque de routines de compression 32 bits.

Liste des fonctions d'API Windows

Nom de l'API | Description
LZClose | Cette fonction permet de fermer un fichier compressé.
LZCopy | Cette fonction permet de copier un fichier en dehors du fichier compressé ou permet de le compresser et de l'inclure avec le fichier compressé.
LZOpenFileA | Cette fonction permet de créer, ouvrir ou supprimer un fichier compressé.

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «mpr.dll»

Description

Ce fichier contient la bibliothèque de routeurs de fournisseurs multiples (WNet).

Liste des fonctions d'API Windows

Nom de l'API | Description
MultinetGetConnectionPerformanceA | Cette fonction permet de demander les informations à propos des performances attendu d'une connexion utilisé pour l'accès à une ressource de réseau.
MultinetGetConnectionPerformanceW | Cette fonction permet de demander les informations à propos des performances attendu d'une connexion utilisé pour l'accès à une ressource de réseau avec des paramètres de chaine de caractères étendues (Unicode).
PwdChangePasswordA | Cette fonction permet de modifier le mot de passe de l'utilisateur ou d'un fournisseur du système d'exploitation.
WNetAddConnection2A | Cette fonction permet de fabriquer une connexion vers une ressource réseau.
WNetAddConnection2W | Cette fonction permet de fabriquer une connexion vers une ressource réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetAddConnection3A | Cette fonction permet de fabriquer une connexion vers une ressource réseau en utilisant des options supplémentaires.
WNetAddConnection3W | Cette fonction permet de fabriquer une connexion vers une ressource réseau en utilisant des options supplémentaires avec des paramètres de chaine de caractères étendues (Unicode).
WNetAddConnectionA | Cette fonction permet d'effectuer la connexion d'une unité de disque à une ressource réseau.
WNetAddConnectionW | Cette fonction permet d'effectuer la connexion d'une unité de disque à une ressource réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetCancelConnection2A | Cette fonction permet d'effectuer l'arrêt d'une connexion réseau existante.
WNetCancelConnection2W | Cette fonction permet d'effectuer l'arrêt d'une connexion réseau existante avec des paramètres de chaine de caractères étendues (Unicode).
WNetCancelConnectionA | Cette fonction permet d'effectuer la déconnexion d'une unité de disque à une ressource réseau.
WNetCancelConnectionW | Cette fonction permet d'effectuer la déconnexion d'une unité de disque à une ressource réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetCloseEnum | Cette fonction permet de terminer l'énumération d'une ressource réseau débuté par la fonction WNetOpenEnum.
WNetConnectionDialog | Cette fonction permet d'afficher une boite de dialogue permettant à une unité de disque de se connecter à une ressource réseau.
WNetConnectionDialog1A | Cette fonction permet d'introduire une boite de dialogue de navigation général pour la connexion des ressources de réseau.
WNetConnectionDialog1W | Cette fonction permet d'introduire une boite de dialogue de navigation général pour la connexion des ressources de réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetDisconnectDialog | Cette fonction permet d'afficher une boite de dialogue permettant à une unité de disque de se déconnecter à une ressource réseau.
WNetDisconnectDialog1A | Cette fonction permet d'effectuer la déconnexion d'une ressource de réseau.
WNetDisconnectDialog1W | Cette fonction permet d'effectuer la déconnexion d'une ressource de réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetEnumResourceA | Cette fonction permet de continuer l'énumération de ressource réseau commencé par la fonction WNetOpenEnum.
WNetEnumResourceW | Cette fonction permet de continuer l'énumération de ressource réseau commencé par la fonction WNetOpenEnum avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetConnectionA | Cette fonction permet de demander le nom de la ressource réseau associé avec un périphérique local.
WNetGetConnectionW | Cette fonction permet de demander le nom de la ressource réseau associé avec un périphérique local avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetLastErrorA | Cette fonction permet de demander le plus récent des derniers code d'erreur étendue des fonctions réseau du système d'exploitation.
WNetGetLastErrorW | Cette fonction permet de demander le plus récent des derniers code d'erreur étendue des fonctions réseau du système d'exploitation avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetNetworkInformationA | Cette fonction permet de demander les informations étendues à propos d'un fournisseur de réseau spécifié dont le nom a été retourné lors d'une énumération réseau précédente.
WNetGetNetworkInformationW | Cette fonction permet de demander les informations étendues à propos d'un fournisseur de réseau spécifié dont le nom a été retourné lors d'une énumération réseau précédente avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetProviderNameA | Cette fonction permet de demander le nom de fournisseur pour un type spécifié dans un réseau.
WNetGetProviderNameW | Cette fonction permet de demander le nom de fournisseur pour un type spécifié dans un réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetResourceParentA | Cette fonction permet de naviguer à partir d'une ressource.
WNetGetResourceParentW | Cette fonction permet de naviguer à partir d'une ressource avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetUniversalNameA | Cette fonction permet de prendre un chemin, avec comme base une unité de disque, pour un réseau de ressource et demande la structure de données contenant des formes universel de ce nom.
WNetGetUniversalNameW | Cette fonction permet de prendre un chemin, avec comme base une unité de disque, pour un réseau de ressource et demande la structure de données contenant des formes universel de ce nom avec des paramètres de chaine de caractères étendues (Unicode).
WNetGetUserA | Cette fonction permet de connaitre le nom de l'utilisateur utilisé pour la connexion réseau.
WNetGetUserW | Cette fonction permet de connaitre le nom de l'utilisateur utilisé pour la connexion réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetOpenEnumA | Cette fonction permet de démarrer l'énumération de ressource réseau ou de connexions existantes.
WNetOpenEnumW | Cette fonction permet de démarrer l'énumération de ressource réseau ou de connexions existantes avec des paramètres de chaine de caractères étendues (Unicode).
WNetSetConnectionA | Cette fonction permet de modifier les caractéristiques d'une connexion réseau.
WNetSetConnectionW | Cette fonction permet de modifier les caractéristiques d'une connexion réseau avec des paramètres de chaine de caractères étendues (Unicode).
WNetUseConnectionA | Cette fonction permet de fabriquer une connexion vers une ressource réseau.
WNetUseConnectionW | Cette fonction permet de fabriquer une connexion vers une ressource réseau avec des paramètres de chaine de caractères étendues (Unicode).

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «odbc32.dll»

Description

Ce fichier contient la bibliothèque de procédures et fonctions d'ODBC (Connexion de base de données ouvert).

Liste des fonctions d'API Windows

Nom de l'API | Description
SQLAllocConnect | Cette fonction permet d'effectuer de l'allocation de mémoire pour un identificateur de connexion ODBC avec un environnement spécifié.
SQLAllocEnv | Cette fonction permet d'effectuer de l'allocation de mémoire pour un identificateur d'environnement ODBC.
SQLAllocStmt | Cette fonction permet d'effectuer de l'allocation de mémoire pour un identificateur d'instruction ODBC.
SQLBindCol | Cette fonction permet d'effectuer de la lecture d'une colonne du résultat d'une requête par ODBC.
SQLBindParameter | Cette fonction permet d'envoyer un tampon de paramètres dans une instruction SQL par ODBC.

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «odbccp32.dll»

Description

Ce fichier contient la bibliothèque de procédures et fonctions de composante d'ODBC (Connexion de base de données ouvert).

Liste des fonctions d'API Windows

Nom de l'API | Description
SQLConfigDataSource | Cette fonction permet d'envoyer des commandes au pilote ODBC (Open Data Base Connectivity).

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «ole32.dll»

Description

Ce fichier contient la bibliothèque d'API d'OLE, soit le partage d'information entre applications.

Liste des fonctions d'API Windows

Nom de l'API | Description
CoCreateGuid | Cette fonction permet de créer un identificateur global unique GUID (Global Unique ID) générer sur une base de 128-bits pouvant être utilisé par exemple pour les identificateurs de classe CLSID.

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «opengl32.dll»

Description

Ce fichier contient la bibliothèque de procédures et fonctions d'OpenGL.

Liste des fonctions d'API Windows

Nom de l'API | Description
glAccum | Cette fonction permet d'effecter un contrôle du tampon d'accumulation sous OpenGL.
glAlphaFunc | Cette fonction permet de définir la fonction devant servir de test Alpha sous OpenGL.
glBegin | Cette fonction permet de définir le commencement de la limite d'une primitive ou d'un groupe de primitive sous OpenGL.
glBitmap | Cette fonction permet le contenu d'une image Bitmap sous OpenGL.
glBlendFunc | Cette fonction permet de définir les facteurs de blending sous OpenGL.
glCallList | Cette fonction permet d'appeler une liste de commande graphique OpenGL.
glCallLists | Cette fonction permet d'appeler plusieurs listes de commande graphique OpenGL.
glClear | Cette fonction permet de vider les tampons du OpenGL ainsi qu'effacement du contenu de la fenêtre.
glClearAccum | Cette fonction permet de vider le tampon d'accumulation du OpenGL.
glClearColor | Cette fonction permet de vider le tampon chromatique du OpenGL.
glClearDepth | Cette fonction permet de vider le tampon de profondeur du OpenGL.
glClearIndex | Cette fonction permet de vider le mode index du OpenGL.
glClearStencil | Cette fonction permet de vider le tampon stencil du OpenGL.
glClipPlane | Cette fonction permet de définir un nouveau plan de clipping du OpenGL.
glColor3b | Cette fonction permet de définir la couleur RVB (RGB) sous format d'octet dans OpenGL.
glColor3bv | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure d'octets dans OpenGL.
glColor3d | Cette fonction permet de définir la couleur RVB (RGB) sous format d'un réel double dans OpenGL.
glColor3dv | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure des réels doubles dans OpenGL.
glColor3f | Cette fonction permet de définir la couleur RVB (RGB) sous format d'un réel dans OpenGL.
glColor3fv | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure des réels dans OpenGL.
glColor3i | Cette fonction permet de définir la couleur RVB (RGB) sous format d'un entier long dans OpenGL.
glColor3iv | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure des entiers long dans OpenGL.
glColor3s | Cette fonction permet de définir la couleur RVB (RGB) sous format d'un entier court dans OpenGL.
glColor3sv | Cette fonction permet de définir la couleur RVB (RGB) sous format d'une structure des entiers court dans OpenGL.
glEnd | Cette fonction permet de définir la fin de la limite d'une primitive ou d'un groupe de primitive sous OpenGL.

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «pdh.dll»

Description

Ce fichier contient la bibliothèque d'API du Performance Counters, soit le service le module permettant d'effectuer des statistiques sur les compteurs de performance du système à partir du système d'exploitation Windows XP.

Liste des fonctions d'API Windows

Nom de l'API | Description
PdhAddCounterA | Cette fonction permet d'ajouter le compteur spécifié à la requête pour les compteurs de performance.
PdhAddCounterW | Cette fonction permet d'ajouter le compteur spécifié à la requête pour les compteurs de performance avec des paramètres de chaine de caractères étendue (Unicode).
PdhAddEnglishCounterA | Cette fonction permet d'ajouter un compteur dans un langage humain neutre à la requête pour le compteur de performance.
PdhAddEnglishCounterW | Cette fonction permet d'ajouter un compteur dans un langage humain neutre à la requête pour le compteur de performance avec des paramètres de chaine de caractères étendue (Unicode).
PdhAddRelogCounter | Cette fonction permet d'effectuer la liaison d'un ou plusieurs fichiers binaires de journal de bord afin d'obtenir un ensemble dans le but de lire les données.
PdhAddV1Counter | Cette fonction permet d'ajouter la première valeur pour le compteur de performance.
PdhAddV2Counter | Cette fonction permet d'ajouter la seconde valeur pour le compteur de performance.
PdhBindInputDataSourceA | Cette fonction permet d'effectuer la liaison d'un ou plusieurs fichiers binaires de journal de bord source afin d'obtenir un ensemble dans le but de lire les données.
PdhBindInputDataSourceW | Cette fonction permet d'effectuer la liaison d'un ou plusieurs fichiers binaires de journal de bord source afin d'obtenir un ensemble dans le but de lire les données avec des paramètres de chaine de caractères étendue (Unicode).
PdhBrowseCountersA | Cette fonction permet d'afficher une boite de dialogue de navigation de compteur que l'utilisateur peut utiliser afin de sélectionner un ou plusieurs compteurs quand il l'ajoute à la requête.
PdhBrowseCountersHA | Cette fonction permet d'afficher une boite de dialogue de navigation de compteur que l'utilisateur peut utiliser afin de sélectionner un ou plusieurs compteurs quand il l'ajoute à la requête en utilisant un Handle.
PdhBrowseCountersHW | Cette fonction permet d'afficher une boite de dialogue de navigation de compteur que l'utilisateur peut utiliser afin de sélectionner un ou plusieurs compteurs quand il l'ajoute à la requête en utilisant un Handle avec des paramètres de chaine de caractères étendue (Unicode).
PdhBrowseCountersW | Cette fonction permet d'afficher une boite de dialogue de navigation de compteur que l'utilisateur peut utiliser afin de sélectionner un ou plusieurs compteurs quand il l'ajoute à la requête avec des paramètres de chaine de caractères étendue (Unicode).
PdhCalculateCounterFromRawValue | Cette fonction permet d'effectuer le calcul des valeurs affichables de 2 valeurs brutes de compteur.
PdhCloseLog | Cette fonction permet d'effectuer la fermeture d'un fichier de journal bord spécifié.
PdhCloseQuery | Cette fonction permet de fermer toutes les compteurs contenant la requête spécifié, ferme tous les gestionnaires ayant la requête et libère toute la mémoire associé avec cette requête.
PdhCollectQueryData | Cette fonction permet de collecter la donnée de valeur brute courante pour tous les compteurs dans la requête spécifié et met à jour le code d'état pour chaque compteur.
PdhCollectQueryDataEx | Cette fonction permet d'utiliser un processus léger séparant la donnée de valeur brute courante pour tous les compteurs dans la requête spécifié.
PdhCollectQueryDataWithTime | Cette fonction permet de collecter la données de valeur brute courante pour tous les compteurs dans la requête spécifié et met à jour le code d'état pour chaque compteur.
PdhComputeCounterStatistics | Cette fonction permet d'effectuer les calculs statistiques pour un compteur dans un tableau de valeurs brute.
PdhConnectMachineA | Cette fonction permet d'effectuer une connexion vers l'ordinateur spécifié pour les compteurs de performance.
PdhConnectMachineW | Cette fonction permet d'effectuer une connexion vers l'ordinateur spécifié pour les compteurs de performance avec des paramètres de chaine de caractères étendue (Unicode).
PdhCreateSQLTablesA | Cette fonction permet de créer des tables SQL pour le compteur performance.
PdhCreateSQLTablesW | Cette fonction permet de créer des tables SQL pour le compteur performance avec des paramètres de chaine de caractères étendue (Unicode).
PdhEnumObjectItemsA | Cette fonction permet de demander l'objet de compteur spécifié et les noms d'instance existant dans l'ordinateur spécifié ou le fichier de journal de bord spécifié.
PdhEnumObjectItemsW | Cette fonction permet de demander l'objet de compteur spécifié et les noms d'instance existant dans l'ordinateur spécifié ou le fichier de journal de bord spécifié avec des paramètres de chaine de caractères étendue (Unicode).

Voir également

Articles - Les géants de l'informatique - Microsoft

Dernière mise à jour : Samedi, le 5 décembre 2015


C pour Windows - EXE, DLL et modules de Windows - «penwin32.dll»

Description

Ce fichier contient la bibliothèque d'API pour la gestion du crayon lumineux.

Liste des fonctions d'API Windows

Nom de l'API | Description
AddInksetInterval | Cette fonction permet de fixer l'intervalle de la cartouche d'encre de l'imprimante.
AddPenDataHRC | Cette fonction permet d'ajouter un objet de données de crayon limineux.
AddPenInputHRC | Cette fonction permet d'ajouter un objet de données de crayon limineux exporté.
AddPointsPenData | Cette fonction permet d'ajouter un ensemble de point de données à l'objet de crayon limineux.
AddWordsHWL | Cette fonction permet d'ajouter des mots dans une liste de mots.

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «shell32.dll»

Description

Ce fichier contient la bibliothèque des APIs du «Shell» en 32 bits.

Liste des fonctions d'API Windows

Nom de l'API | Description
DllGetVersion | Cette fonction permet de demander les informations de la version de DLL
DragAcceptFiles | Cette fonction permet de fixer l'état du drapeau indiquant si la fenêtre accepte les fichiers glissées
DragFinish | Cette fonction permet de restituer la mémoire employé pour le transfert des noms de fichiers vers une fenêtre d'application
DragQueryFile | Cette fonction permet de demander les noms de fichiers lors d'un transfert des noms de fichiers vers une fenêtre d'application
DuplicateIcon | Cette fonction permet d'effectuer la création d'un nouvel icône identique à une autre icône spécifié.
ExtractAssociatedIconA | Cette fonction permet de demander le Handle dans icône indexé dans un fichier.
ExtractIconA | Cette fonction permet de demander une unique icône dans un fichier.
ExtractIconExA | Cette fonction permet de demander plusieurs icônes dans un fichier.
FindExecutableA | Cette fonction permet de demander le fichier devant être exécuté lorsque la sorte d'extension de fichier est rencontré.
SHAddToRecentDocs | Cette fonction permet d'ajouter un lien vers un document dans la liste des documents récamment utilisé.
SHAppBarMessage | Cette fonction permet d'envoyer des commandes à la barrre de tâche.
SHBrowseForFolder | Cette fonction permet d'afficher la boite de dialogue sélectionnant un répertoire.
SHCopyKeyA | Cette fonction permet de copier les clefs de registre d'un répertoire à un autre dans la base de registres en tenant compte de bien copier toutes les sous-branches de répertoire inclus dans la clef source.
ShellAboutA | Cette fonction permet d'afficher la boite de dialogue «A propos» de l'application spécifié.
ShellExecuteA | Cette fonction permet de lancer une application externe.
ShellExecuteEx | Cette fonction permet de lancer une application externe en utilisant l'interpréteur de commande (Shell) du système d'exploitation Windows.
Shell_NotifyIconA | Cette fonction permet d'effectuer l'action d'ajouter, modifier ou supprimer une icône dans la barre de tâche.
SHEmptyRecycleBinA | Cette fonction permet de vider le contenu de la corbeille.
SHFileOperationA | Cette fonction permet d'effectuer une copie, renommer, déplacer ou de supprimer un objet de fichier.
SHFormatDrive | Cette fonction permet d'effectuer le formattage d'une unité de disque.
SHGetPathFromIDList | Cette fonction permet de retourner un pointeur dans un arbre de répertoire à l'emplacement ou se trouve un fichier.

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «shlwapi.dll»

Description

Ce fichier contient la bibliothèque des APIs du «Shell» pour Windows.

Liste des fonctions d'API Windows

Nom de l'API | Description
PathAddBackslashA | Cette fonction permet d'ajouter une barre oblique inversé à la fin du chemin de répertoire spécifié.
PathAddExtension | Cette fonction permet d'ajouter une extension à nom de fichiers.
PathAppendA | Cette fonction permet d'ajouter un chemin de répertoire à la fin d'un autre chemin de répertoire.
PathBuildRootA | Cette fonction permet de créer un répertoire racine pour unité disque spécifié.
PathCanonicalizeA | Cette fonction permet de transformer un chemin de répertoire de sa forme absolue à relative, c'est-à-dire de remplacer des "../" pour atteinte le répertoire en court par exemple.
PathCombine | Cette fonction permet d'ajouter un chemin de répertoire à la fin d'un autre chemin de répertoire.
PathCommonPrefix | Cette fonction permet d'effectuer la comparaison de deux répertoires et de vérifier les préfixes communs.
PathCompactPathA | Cette fonction permet de réduire la longueur en pixel d'un chemin de répertoire en remplaçant la partie trop longue par des abréviations pour qu'il soit affichable à l'écran par exemple.
PathCompactPathExA | Cette fonction permet de réduire la longueur en caractères d'un chemin de répertoire en remplaçant la partie trop longue par des abréviations pour qu'il soit affichable à l'écran par exemple.
PathCreateFromUrlA | Cette fonction permet de convertir un URL sous sa forme du système d'exploitation de style DOS.
PathFindOnPathA | Cette fonction permet d'effectuer la recherche d'un nom de fichier dans un répertoire.
PathGetDriveNumberA | Cette fonction permet de demander le numéro de l'unité disque contenu dans un chemin de répertoire.
PathIsDirectoryEmptyA | Cette fonction permet de demander si le répertoire spécifier est vide.
PathIsSystemFolder | Cette fonction permet de demander si le répertoire spécifier à l'attribut de dossier système.
PathIsUNCA | Cette fonction permet de demander si le répertoire est un répertoire UNC (Universal Naming Convention) valide.
PathIsUNCServerA | Cette fonction permet de demander si le répertoire est un répertoire UNC (Universal Naming Convention) valide pour un serveur.
PathIsURLA | Cette fonction permet de demander si le répertoire est un répertoire URL valide.
PathUndecorateA | Cette fonction permet d'illiminer les séquences à numéro d'un nom fichier.
PathUnmakeSystemFolderA | Cette fonction permet d'enlever l'attribut système d'un répertoire spécifié.
SHSetValueA | Cette fonction permet de fixer une valeur dans la base de registres.
StrIsIntlEqualA | Cette fonction permet de comparer le début de deux chaines de caractères ASCIZ.
StrNCatA | Cette fonction permet d'ajouter à la fin d'une chaine de caractères ASCIZ le contenu d'une chaine de caractères ASCIZ.
StrToIntExA | Cette fonction permet de convertir une chaine de caractères ASCIZ ayant un nombre décimal ou hexadécimal en une valeur numérique entière.
StrTrimA | Cette fonction permet d'enlever les caractères spécifié au début et à la fin d'une chaine de caractères ASCIZ.
UrlCanonicalizeA | Cette fonction permet de transformer un chemin d'un URL de sa forme absolue à relative, c'est-à-dire de remplacer des "../" pour atteinte le répertoire en court par exemple.
UrlCombineA | Cette fonction permet d'ajouter un chemin d'un URL à la fin d'un autre chemin d'URL.
UrlCreateFromPathA | Cette fonction permet de convertir un chemin de système d'exploitation de style DOS sous sa forme URL.
UrlEscapeA | Cette fonction permet de convertir les caractères particulier en format acceptable pour un URL.
UrlGetPartA | Cette fonction permet d'extraire une partie de l'URL.
UrlIsOpaqueA | Cette fonction permet de demander si le URL est opaque.
UrlUnescapeA | Cette fonction permet de convertir les caractères particulier du URL en une chaine de caractères ASCIZ.

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «tb30dlg.dll»

Description

Ce fichier contient la bibliothèque de boite de dialogue de l'entreprise «Asymetrix Corp».

Liste des fonctions d'API Windows

Nom de l'API | Description
addComboBoxItem | Cette fonction permet d'ajouter un élément dans la liste déroulante d'un contrôle de formulaire.
addListBoxItem | Cette fonction permet d'ajouter un élément dans une boite de liste d'un contrôle de formulaire.
addListBoxItem | Cette fonction permet d'ajouter un élément dans une boite de liste d'un contrôle de formulaire.

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «user32.dll»

Description

Ce fichier contient la bibliothèque de l'interface utilisateur du système d'exploitation.

Liste des fonctions d'API Windows

Nom de l'API | Description
ActivateKeyboardLayout | Cette fonction permet d'activer une disposition différente du clavier pour le processus courant.
AdjustWindowRect | Cette fonction permet de calculer l'espace requis par le rectangle d'une fenêtre basé sur un rectangle client.
AdjustWindowRectEx | Cette fonction permet de calculer l'espace requis par le rectangle d'une fenêtre avec un style étendue basé sur un rectangle client.
AnyPopup | Cette fonction permet d'indiquer s'il existe un moins une fenêtre visible ou invisible sur le bureau de l'écran.
AppendMenuA | Cette fonction permet d'ajouter un nouvel item au menu courant.
AppendMenuW | Cette fonction permet d'ajouter un nouvel item au menu courant avec des paramètres de chaine de caractères étendues (Unicode).
ArrangeIconicWindows | Cette fonction permet de minimiser les fenêtres enfants d'une fenêtre parente.
AttachThreadInput | Cette fonction permet de relier un processus avec un autre.
BeginDeferWindowPos | Cette fonction permet d'allouer de la mémoire sur de multiples position de fenêtres d'une structure de données.
BeginPaint | Cette fonction permet de préparé les spécifications de la fenêtre pour la peindre et la remplir avec les informations de la structure spécifié.
BlockInput | Cette fonction permet d'arrêter les événements d'entrer comme le clavier, la souris,...
BringWindowToTop | Cette fonction permet d'activer et de porter, en haut de la pile des fenêtres, la fenêtre spécifié.
BroadcastSystemMessageA | Cette fonction permet d'envoyer un message vers un récipient spécifié.
BroadcastSystemMessageW | Cette fonction permet d'envoyer un message vers un récipient spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CallMsgFilterA | Cette fonction permet de passer un message à la fonction de filtre de message courant.
CallMsgFilterW | Cette fonction permet de passer un message à la fonction de filtre de message courant avec des paramètres de chaine de caractères étendues (Unicode).
CallNextHookEx | Cette fonction permet de passer au prochain crochet des informations de crochet dans une chaine de crochet.
CallWindowProcA | Cette fonction permet d'appeler et de passer des informations de message à la fonction de fenêtre spécifié.
CallWindowProcW | Cette fonction permet d'appeler et de passer des informations de message à la fonction de fenêtre spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CascadeWindows | Cette fonction permet d'effectuer des cascades de fenêtre spécifié ou de fenêtre enfant dans la fenêtre parent spécifié.
ChangeClipboardChain | Cette fonction permet d'enlever le premier élément de la chaine du visualisateur de presse-papier et de le remplacer par le deuxième élément spécifié.
ChangeDisplaySettingsA | Cette fonction permet de modifier les paramètres du mode d'affichage graphique
ChangeDisplaySettingsW | Cette fonction permet de modifier les paramètres du mode d'affichage graphique avec des paramètres de chaine de caractères étendues (Unicode).
ChangeDisplaySettingsExA | Cette fonction permet de modifier les paramètres du mode d'affichage graphique pour le périphérique d'affichage spécifié.
ChangeDisplaySettingsExW | Cette fonction permet de modifier les paramètres du mode d'affichage graphique pour le périphérique d'affichage spécifié avec des paramètres de chaine de caractères étendues (Unicode).
ChangeMenuA | Cette fonction permet de modifier un élément du menu spécifié.
ChangeMenuW | Cette fonction permet de modifier un élément du menu spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CharLowerA | Cette fonction permet d'effectuer la conversion d'une chaine de caractères spécifié en minuscule.
CharLowerBuffA | Cette fonction permet d'effectuer la conversion des caractères majuscules contenu dans un tampon en caractères minuscule.
CharLowerBuffW | Cette fonction permet d'effectuer la conversion des caractères majuscules contenu dans un tampon en caractères minuscule avec des paramètres de chaine de caractères étendues (Unicode).
CharLowerW | Cette fonction permet d'effectuer la conversion d'une chaine de caractères spécifié en minuscule avec des paramètres de chaine de caractères étendues (Unicode).
CharNextA | Cette fonction permet de retourner un pointeur sur le prochaine caractère contenu dans une chaine de caractères.
CharNextExA | Cette fonction permet de retourner l'adresse du prochaine caractère contenu dans une chaine de caractères.
CharNextW | Cette fonction permet de retourner un pointeur sur le prochaine caractère contenu dans une chaine de caractères avec des paramètres de chaine de caractères étendues (Unicode).
CharPrevA | Cette fonction permet de retourner un pointeur sur le caractère précédent contenu dans une chaine de caractères.
CharPrevExA | Cette fonction permet de retourner l'adresse du caractère précédent contenu dans une chaine de caractères.
CharPrevW | Cette fonction permet de retourner un pointeur sur le caractère précédent contenu dans une chaine de caractères avec des paramètres de chaine de caractères étendues (Unicode).
CharToOemA | Cette fonction permet d'effectuer la transformation d'une chaine de caractères en ensemble de caractères OEM utilisateur.
CharToOemBuffA | Cette fonction permet d'effectuer la transformation d'un nombre spécifique de caractères dans une chaine de caractères d'un ensemble de caractères OEM utilisateur.
CharToOemBuffW | Cette fonction permet d'effectuer la transformation d'un nombre spécifique de caractères dans une chaine de caractères d'un ensemble de caractères OEM utilisateur avec des paramètres de chaine de caractères étendues (Unicode).
CharToOemW | Cette fonction permet d'effectuer la transformation d'une chaine de caractères en ensemble de caractères OEM utilisateur avec des paramètres de chaine de caractères étendues (Unicode).
CharUpperA | Cette fonction permet d'effectuer la conversion d'une chaine de caractères spécifié en majuscule.
CharUpperBuffA | Cette fonction permet d'effectuer la conversion des caractères minuscules contenu dans un tampon en caractères majuscule.
CharUpperBuffW | Cette fonction permet d'effectuer la conversion des caractères minuscules contenu dans un tampon en caractères majuscule avec des paramètres de chaine de caractères étendues (Unicode).
CharUpperW | Cette fonction permet d'effectuer la conversion d'une chaine de caractères spécifié en majuscule avec des paramètres de chaine de caractères étendues (Unicode).
CheckDlgButton | Cette fonction permet de fixer ou d'enlever une marque de vérification d'un bouton de contrôle ou de changer l'état d'un contrôle d'arbre de bouton.
CheckMenuItem | Cette fonction permet de fixer ou d'enlever un marque de vérification d'un item de menu dans un menu contextuel.
CheckMenuRadioItem | Cette fonction permet de vérifier l'item de menu spécifié et de fabriquer un item radio.
CheckRadioButton | Cette fonction permet de vérifier ou d'enlever un marque de vérification d'un groupe de bouton radio spécifié.
ChildWindowFromPoint | Cette fonction permet de demander le propriétaire de la fenêtre enfant à l'aide d'une coordonnée spécifié.
ChildWindowFromPointEx | Cette fonction permet de demander lequel des fenêtres enfants, si possible, appartient à la fenêtre parent du point spécifié.
ClientToScreen | Cette fonction permet d'effectuer la transformation des coordonnées logique du client en coordonnées phyisquement sur l'écran
ClipCursor | Cette fonction permet de définir une fenêtre limitant le déplacement du pointeur de la souris.
CloseClipboard | Cette fonction permet d'indiquer que le traitement avec le presse-papier est terminé et que les autres applications peuvent maintenant avoir accès aux données qu'elle contient.
CloseDesktop | Cette fonction permet de fermer ou d'ouvrir le Handle de l'objet de bureau.
CloseWindow | Cette fonction permet de minimiser (sans la détruire) la fenêtre spécifié.
CloseWindowStation | Cette fonction permet de fermer un Handle de fenêtre de station ouverte.
CopyAcceleratorTableA | Cette fonction permet de copier la table d'accélérateur spécifié.
CopyAcceleratorTableW | Cette fonction permet de copier la table d'accélérateur spécifié avec des paramètres de chaine de caractères étendues (Unicode).
CopyIcon | Cette fonction permet de copier un icône spécifié d'un autre module vers le module courant.
CopyImage | Cette fonction permet de créer une nouvelle image (icône, image ou Bitmap) et de copier les attributs de l'image donnée dans une nouvelle image.
CopyRect | Cette fonction permet d'effectuer la copie des coordonnées d'un rectangle dans un autre rectangle.
CountClipboardFormats | Cette fonction permet de demander le nombre de différentes données de formats courant que contient le presse-papier.
CreateAcceleratorTableA | Cette fonction permet de créer une table d'accélérateur.
CreateAcceleratorTableW | Cette fonction permet de créer une table d'accélérateur avec des paramètres de chaine de caractères étendues (Unicode).
CreateCaret | Cette fonction permet de créer un nouveau signe pour le curseur texte et associe le propriétaire à la fenêtre spécifié.
CreateCursor | Cette fonction permet d'effectuer la création d'une nouvelle image de pointeur de souris
CreateDesktopA | Cette fonction permet de créer un nouveau bureau dans une fenêtre de station associé avec le processus appelant.
CreateDesktopW | Cette fonction permet de créer un nouveau bureau dans une fenêtre de station associé avec le processus appelant avec des paramètres de chaine de caractères étendues (Unicode).
CreateDialogIndirectParamA | Cette fonction permet de créer un modèle de boite de dialogue pour un gabarit de boite de dialogue en mémoire et après son affichage, la fonction passe une valeur d'application à la procédure de boite de dialogue avec les paramètres spécifié du message «WM_INITDIALOG».
CreateDialogIndirectParamW | Cette fonction permet de créer un modèle de boite de dialogue pour un gabarit de boite de dialogue en mémoire et après son affichage, la fonction passe une valeur d'application à la procédure de boite de dialogue avec les paramètres spécifié du message «WM_INITDIALOG» avec des paramètres de chaine de caractères étendues (Unicode).
CreateDialogParamA | Cette fonction permet de créer un modèle de boite de dialogue pour une ressource de gabarit de boite de dialogue et après son affichage, la fonction passe une valeur d'application à la procédure de boite de dialogue avec les paramètres spécifié du message «WM_INITDIALOG».
CreateDialogParamW | Cette fonction permet de créer un modèle de boite de dialogue pour une ressource de gabarit de boite de dialogue et après son affichage, la fonction passe une valeur d'application à la procédure de boite de dialogue avec les paramètres spécifié du message «WM_INITDIALOG» avec des paramètres de chaine de caractères étendues (Unicode).
CreateIcon | Cette fonction permet d'effectuer la création d'une icône
CreateIconFromResource | Cette fonction permet d'effectuer la création d'un icône ou d'un curseur à partir de bits de ressources décrit dans l'icône.
CreateIconFromResourceEx | Cette fonction permet d'effectuer la création d'un icône ou d'un curseur à partir de bits de ressources décrit dans l'icône avec des options complémentaires.
CreateIconIndirect | Cette fonction permet d'effectuer la création d'un icône ou d'un curseur à partir d'une structure de données.
CreateMDIWindowA | Cette fonction permet d'effectuer la création de fenêtre enfant MDI (Interface de mutiple document).
CreateMDIWindowW | Cette fonction permet d'effectuer la création de fenêtre enfant MDI (Interface de mutiple document) avec des paramètres de chaine de caractères étendues (Unicode).
CreateMenu | Cette fonction permet d'effectuer la création d'un menu.
CreatePopupMenu | Cette fonction permet d'effectuer la création d'un menu contextuel
CreateWindowExA | Cette fonction permet d'effectuer la création d'une sous-fenêtre (PopUp).
CreateWindowExW | Cette fonction permet d'effectuer la création d'une sous-fenêtre (PopUp) avec des paramètres de chaine de caractères étendues (Unicode).
CreateWindowStationA | Cette fonction permet d'effectuer la création d'un objet de fenêtre de station.
CreateWindowStationW | Cette fonction permet d'effectuer la création d'un objet de fenêtre de station avec des paramètres de chaine de caractères étendues (Unicode).
DdeSetQualityOfService | Cette fonction permet de spécifier le service de qualité (QoS) des applications d'échanges de données dynamique brute (DDE) désiré pour de future initialisation de conversion DDE.
DefDlgProcA | Cette fonction permet d'effectuer le traitement de processus de fenêtre de message par défaut.
DefDlgProcW | Cette fonction permet d'effectuer le traitement de processus de fenêtre de message par défaut avec des paramètres de chaine de caractères étendues (Unicode).
DeferWindowPos | Cette fonction permet de mettre à jour la structure de positionnement d'une fenêtre.
DefFrameProcA | Cette fonction permet d'effectuer le processus de message par défaut du cadre d'une fenêtre MDI.
DefFrameProcW | Cette fonction permet d'effectuer le processus de message par défaut du cadre d'une fenêtre MDI avec des paramètres de chaine de caractères étendues (Unicode).
DefMDIChildProcA | Cette fonction permet de définir le processus de message de la fenêtre enfant MDI.
DefMDIChildProcW | Cette fonction permet de définir le processus de message de la fenêtre enfant MDI avec des paramètres de chaine de caractères étendues (Unicode).
DefWindowProcA | Cette fonction permet de créer un événement produit par défaut lorsqu'une action est effectuer dans la fenêtre.
DefWindowProcW | Cette fonction permet de créer un événement produit par défaut lorsqu'une action est effectué dans la fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
DeleteMenu | Cette fonction permet de supprimer un item de menu.
DestroyAcceleratorTable | Cette fonction permet de détruire la table d'accélérateur.
DestroyCaret | Cette fonction permet de supprimer le caret courant.
DestroyCursor | Cette fonction permet de supprimer une image de pointeur de souris
DestroyIcon | Cette fonction permet de supprimer une icône
DestroyMenu | Cette fonction permet de supprimer un menu contextuel
DestroyWindow | Cette fonction permet de supprimer une fenêtre
DialogBoxIndirectParamA | Cette fonction permet de créer une boite de dialogue modèle à l'aide d'un gabarit en mémoire et des paramètres spécifiés.
DialogBoxIndirectParamW | Cette fonction permet de créer une boite de dialogue modèle à l'aide d'un gabarit en mémoire et des paramètres spécifiés avec des parmètres de chaine de caractères étendues (Unicode).
DialogBoxParamA | Cette fonction permet de créer une boite de dialogue modèle et des paramètres spécifiés.
DialogBoxParamW | Cette fonction permet de créer une boite de dialogue modèle et des paramètres spécifiés avec des paramètres de chaine de caractères étendues (Unicode).
DispatchMessageA | Cette fonction permet de redistribuer le messages de fenêtre.
DispatchMessageW | Cette fonction permet de redistribuer le messages de fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
DlgDirListA | Cette fonction permet de remplir une boite de dialogue avec une liste de fichiers et de répertoires.
DlgDirListW | Cette fonction permet de remplir une boite de dialogue avec une liste de fichiers et de répertoires avec des paramètres de chaine de caractères étendues (Unicode).
DlgDirListComboBoxA | Cette fonction permet de remplir une boite combinée (Combo Box) avec une liste de fichiers et de répertoires.
DlgDirListComboBoxW | Cette fonction permet de remplir une boite combinée (Combo Box) avec une liste de fichiers et de répertoires avec des paramètres de chaine de caractères étendues (Unicode).
DlgDirSelectComboBoxExA | Cette fonction permet de demander la sélection courante d'une boite combinée remplit par la fonction DlgDirListComboBox.
DlgDirSelectComboBoxExW | Cette fonction permet de demander la sélection courante d'une boite combinée remplit par la fonction DlgDirListComboBox avec des paramètres de chaine de caractères étendues (Unicode).
DlgDirSelectExA | Cette fonction permet de demander la sélection courante étendue d'une liste de boite.
DlgDirSelectExW | Cette fonction permet de demander la sélection courante étendue d'une liste de boite avec des paramètres de chaine de caractères étendues (Unicode).
DragDetect | Cette fonction permet de déterminer quand une fonction de glisser-déposer (drag and drop) est mis en place.
DragObject | Cette fonction permet d'intéger une composante serveur de glisser-déposer (drag and drop).
DrawAnimatedRects | Cette fonction permet de dessiner un cadre de rectangle et d'animer l'icône ouvert.
DrawCaption | Cette fonction permet de dessiner une fenêtre de légende.
DrawEdge | Cette fonction permet de dessiner une ou plusieurs bordures d'un rectangle.
DrawFocusRect | Cette fonction permet de dessiner un rectangle avec un style indiquant qu'il est focusé.
DrawFrameControl | Cette fonction permet de dessiner un cadre de contrôle pour le type et le style spécifié.
DrawIcon | Cette fonction permet d'afficher une icône dans la fenêtre d'application du contexte de l'objet
DrawIconEx | Cette fonction permet d'afficher un icône ou un curseur dans une région client d'une fenêtre d'un périphérique de contexte donnée, d'effectuer des opérations de traitement de trame spécifié et d'étirement ou de compression de l'icône ou le curseur spécifié.
DrawMenuBar | Cette fonction permet de réafficher la barre de menu de la fenêtre d'application.
DrawStateA | Cette fonction permet d'afficher une image et d'appliquer un effet visuel indiquant son état, laquelle peut être désactiver ou un état par défaut.
DrawStateW | Cette fonction permet d'afficher une image et d'appliquer un effet visuel indiquant son état, laquelle peut être désactiver ou un état par défaut avec des paramètres de chaine de caractères étendues (Unicode).
DrawTextA | Cette fonction permet de dessiner le texte formatté dans le rectangle spécifié.
DrawTextW | Cette fonction permet de dessiner le texte formatté dans le rectangle spécifié avec des paramètres de chaine de caractères étendues (Unicode).
DrawTextExA | Cette fonction permet de dessiner le texte formatté dans le rectangle spécifié avec des paramètres supplémentaires.
DrawTextExW | Cette fonction permet de dessiner le texte formatté dans le rectangle spécifié avec des paramètres supplémentaires et des chaines de caractères étendues (Unicode).
EmptyClipboard | Cette fonction permet de vider complètement le tampon du presse-papier.
EnableMenuItem | Cette fonction permet d'activer ou de désactiver un item de menu déroulant.
EnableScrollBar | Cette fonction permet d'activer ou de désactiver les barres de défilement dans une fenêtre d'application.
EnableWindow | Cette fonction permet d'activer ou de désactiver les événements clavier et souris et les contrôles dans une fenêtre d'application.
EndDeferWindowPos | Cette fonction permet d'effectuer la simulation de mise-à-jour de position et de taille d'une ou plusieurs fenêtres dans un simple cycle de rafraichissement d'écran.
EndDialog | Cette fonction permet de cacher un modèle de boite de dialogue.
EndPaint | Cette fonction permet de marquer la fin du traitement de peinture d'une fenêtre spécifié.
EnumChildWindows | Cette fonction permet d'énumérer les fenêtres enfants de la fenêtre parent en passant le Handle de chaque fenêtre enfant avec une fonction d'application utilisateur.
EnumClipboardFormats | Cette fonction permet de retourner les formats de presse-papier disponibles.
EnumDesktopsA | Cette fonction permet de demander l'énumération de tous les bureaux d'une fenêtre de travail associé avec un processus appelant.
EnumDesktopsW | Cette fonction permet de demander l'énumération de tous les bureaux d'une fenêtre de travail associé avec un processus appelant avec des paramètres de chaine de caractères étendues (Unicode).
EnumDesktopWindows | Cette fonction permet de demander l'énumération de tous les bureaux passé par le Handle de chaque fenêtre, par l'entremise d'une fonction utilisateur.
EnumDisplaySettingsA | Cette fonction permet de demander des informations sur le système d'affichage.
EnumDisplaySettingsW | Cette fonction permet de demander des informations sur le système d'affichage avec des paramètres de chaine de caractères étendues (Unicode).
EnumPropsA | Cette fonction permet d'effectuer le passage de la liste des entrées de propriétés par l'intermédiaire d'une fonction utilisateur.
EnumPropsExA | Cette fonction permet d'effectuer le passage de la liste des entrées de propriétés par l'intermédiaire d'une fonction utilisateur avec des paramètres supplémentaires.
EnumPropsExW | Cette fonction permet d'effectuer le passage de la liste des entrées de propriétés par l'intermédiaire d'une fonction utilisateur avec des paramètres supplémentaires et des chaines de caractères étendues (Unicode).
EnumPropsW | Cette fonction permet d'effectuer le passage de la liste des entrées de propriétés par l'intermédiaire d'une fonction utilisateur avec des paramètres de chaine de caractères étendues (Unicode).
EnumThreadWindows | Cette fonction permet d'effectuer l'énumération de toutes les fenêtres non-enfant associé avec un processus par passage d'un Handle pour chaque fenêtre avec une fonction d'application utilisateur.
EnumWindows | Cette fonction permet d'effectuer le passage des fenêtres parent par l'intermédiaire d'une fonction utilisateur.
EnumWindowStationsA | Cette fonction permet d'effectuer l'énumération de toutes les fenêtres de station dans le système par passage du nom pour chaque fenêtre de station avec une fonction d'application utilisateur.
EnumWindowStationsW | Cette fonction permet d'effectuer l'énumération de toutes les fenêtres de station dans le système par passage du nom pour chaque fenêtre de station avec une fonction d'application utilisateur et des paramètres de chaine de caractères étendues (Unicode).
EqualRect | Cette fonction permet de demander lequel des deux rectangles spécifiés sont égales par comparaison des coordonnées de leur coin supérieur gauche et de leur coin inférieur droit.
ExcludeUpdateRgn | Cette fonction permet d'exclure la région mise-à-jour d'une région de capture.
ExitWindowsEx | Cette fonction permet d'effectuer l'arrêt ou le redémarrage de Windows et/ou de l'ordinateur.
FillRect | Cette fonction permet de remplir un rectangle avec la brosse spécifié.
FindWindowA | Cette fonction permet de demander le Handle de la première fenêtre d'application correspondant au nom de la fenêtre.
FindWindowExA | Cette fonction permet de demander le Handle d'une fenêtre enfant d'une fenêtre d'application.
FindWindowW | Cette fonction permet de demander le Handle de la première fenêtre d'application correspondant au nom de la fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
FlashWindow | Cette fonction permet de faire clignoter une fois une fenêtre d'application.
FlashWindowEx | Cette fonction permet de faire clignoter plusieurs fois une fenêtre d'application.
FrameRect | Cette fonction permet de dessiner une bordure autour d'un rectangle, en utilisant la brosse spécifié.
FreeDDElParam | Cette fonction permet de libérer la mémoire spécifié d'un message DDE posté.
GetActiveWindow | Cette fonction permet de demander le Handle de la fenêtre active.
GetCapture | Cette fonction permet de demander le Handle de la fenêtre où la souris est capturé.
GetCaretBlinkTime | Cette fonction permet de demander le taux de clignotement du caret.
GetCaretPos | Cette fonction permet de demander la position courante d'un caret.
GetClassInfoA | Cette fonction permet de demander les informations à propos d'une classe de fenêtre.
GetClassInfoExA | Cette fonction permet de demander les informations à propos d'une classe de fenêtre en incluant le Handle du petit icône associé avec la fenêtre de classe.
GetClassInfoExW | Cette fonction permet de demander les informations à propos d'une classe de fenêtre en incluant le Handle du petit icône associé avec la fenêtre de classe avec des paramètres de chaine de caractères étendues (Unicode).
GetClassInfoW | Cette fonction permet de demander les informations à propos d'une classe de fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
GetClassLongA | Cette fonction permet de demander des valeurs d'informations en 32 bits sur une classe.
GetClassLongW | Cette fonction permet de demander des valeurs d'informations en 32 bits sur une classe avec des paramètres de chaine de caractères étendues (Unicode).
GetClassNameA | Cette fonction permet de demander le nom d'une classe.
GetClassNameW | Cette fonction permet de demander le nom d'une classe avec des paramètres de chaine de caractères étendues (Unicode).
GetClassWord | Cette fonction permet de demander une valeur 16 bits de déplacement spécifié dans une classe de mémoire supplémentaire pour la classe de fenêtre à laquelle la fenêtre appartient.
GetClientRect | Cette fonction permet de demander les coordonnées client de la région de fenêtre client.
GetClipboardData | Cette fonction permet de demander le Handle du presse-papier de données courant avec le format spécifié.
GetClipboardFormatNameA | Cette fonction permet de demander le nom de format de presse-papier enregistré.
GetClipboardFormatNameW | Cette fonction permet de demander le nom de format de presse-papier enregistré avec des paramètres de chaine de caractères étendues (Unicode).
GetClipboardOwner | Cette fonction permet de demander le Handle de la fenêtre associé à un presse-papier.
GetClipCursor | Cette fonction permet de demander les coordonnées de la fenêtre limitant le déplacement du pointeur de la souris.
GetClipboardViewer | Cette fonction permet de demander le Handle de la première fenêtre d'une chaine visualisation de presse-papier.
GetCursor | Cette fonction permet de demander le Handle du curseur courant.
GetCursorPos | Cette fonction permet de demander la position du pointeur de souris à l'écran
GetDC | Cette fonction permet de demander le contexte d'objet d'une fenêtre d'application.
GetDCEx | Cette fonction permet de demander le Handle du périphérique de contexte pour la fenêtre spécifié.
GetDesktopWindow | Cette fonction permet de demander le Handle attribué à la fenêtre du bureau.
GetDialogBaseUnits | Cette fonction permet de retourner l'unité de base de la boite de dialogue qu'utilise Windows quand il créer une boite de dialogue.
GetDlgCtrlID | Cette fonction permet de retourner le Handle de la fenêtre enfant.
GetDlgItem | Cette fonction permet de demander le Handle d'un contrôle étant données par la boite de dialogue.
GetDlgItemInt | Cette fonction permet d'effectuer la translation du texte d'un contrôle d'une boite de dialogue en une valeur entière.
GetDlgItemTextA | Cette fonction permet de demander le titre ou le texte associé avec un contrôle de boite de dialogue.
GetDlgItemTextW | Cette fonction permet de demander le titre ou le texte associé avec un contrôle de boite de dialogue avec des paramètres de chaine de caractères étendues (Unicode).
GetDoubleClickTime | Cette fonction permet de demander le temps maximal autorisé pour que des clics sur les boutons de la souris soit considéré comme un double-clic.
GetFocus | Cette fonction permet de demander le focus d'entrée de la fenêtre spécifié.
GetForegroundWindow | Cette fonction permet de demander le Handle de la fenêtre d'application courante.
GetIconInfo | Cette fonction permet de demander les informations à propos de l'icône ou du curseur spécifié.
GetInputState | Cette fonction permet d'indiquer si un événement de clic de souris ou de clavier est survenue dans la file d'attente du système du traitement requis.
GetKBCodePage | Cette fonction retourne le code de page chargé par le système d'exploitation Windows.
GetKeyboardLayout | Cette fonction permet de demander la couche de clavier active pour le processus léger spécifié.
GetKeyboardLayoutList | Cette fonction permet de demander le Handle de la couche de clavier correspondant à l'ensemble d'entrée courant local dans le système.
GetKeyboardState | Cette fonction permet de demander l'état des 256 touches virtuel de clavier.
GetKeyboardType | Cette fonction permet de demander les informations à propos du clavier courant.
GetKeyNameTextA | Cette fonction permet de demander une chaine de caractères représentant le nom d'une touche du clavier.
GetKeyNameTextW | Cette fonction permet de demander une chaine de caractères représentant le nom d'une touche du clavier avec des paramètres de chaine de caractères étendues (Unicode).
GetKeyboardLayoutNameA | Cette fonction permet de demander le nom des couches de clavier active.
GetKeyboardLayoutNameW | Cette fonction permet de demander le nom des couches de clavier active avec des paramètres de chaine de caractères étendues (Unicode).
GetKeyState | Cette fonction permet de demander l'état d'une touche virtuel de clavier.
GetLastActivePopup | Cette fonction permet de demander laquelle des fenêtres du propriétaire de la fenêtre POP-UP a été récamment activé.
GetMenu | Cette fonction permet de demander le Handle du menu déroulant de la fenêtre d'application spécifié.
GetMenuCheckMarkDimensions | Cette fonction permet de retourner les dimensions du Bitmap marqué par défaut.
GetMenuContextHelpId | Cette fonction permet de demander l'identifiant de contexte d'aide associé avec le menu spécifié.
GetMenuDefaultItem | Cette fonction permet de demander l'item de menu par défaut du menu spécifié.
GetMenuItemCount | Cette fonction permet de demander le nombre d'item que contient menu déroulant.
GetMenuItemID | Cette fonction permet de demander les identificateurs d'un emplacement d'item de menu d'une position spécifié.
GetMenuItemInfoA | Cette fonction permet de demander les informations à propos de l'item de menu.
GetMenuItemInfoW | Cette fonction permet de demander les informations à propos de l'item de menu avec des paramètres de chaine de caractères étendues (Unicode).
GetMenuItemRect | Cette fonction permet de demander les limites rectangulaires pour l'item de menu spécifié.
GetMenuState | Cette fonction permet de demander l'état des drapeaux associés avec l'item de menu spécifié.
GetMenuStringA | Cette fonction permet de copier l'étiquette d'un item de menu dans un tampon.
GetMenuStringW | Cette fonction permet de copier l'étiquette d'un item de menu dans un tampon avec des paramètres de chaine de caractères étendues (Unicode).
GetMessageA | Cette fonction permet de demander un message d'une application de file d'attente de message dans une structure spécifié.
GetMessageW | Cette fonction permet de demander un message d'une application de file d'attente de message dans une structure spécifié avec des paramètres de chaine de caractères étendues (Unicode).
GetMessageExtraInfo | Cette fonction permet de demander les informations supplémentaires associés avec le dernier message des fonctions GetMessage ou PeekMessage.
GetMessagePos | Cette fonction permet de retourner une valeur long représentant une position de curseur dans une coordonnée d'écran.
GetMessageTime | Cette fonction permet de retourner l'heure du dernier message reçu par la fonction GetMessage.
GetNextDlgGroupItem | Cette fonction permet de rechercher le contrôle précédent ou suivant d'un groupe de contrôle dans une boite de dialogue.
GetNextDlgTabItem | Cette fonction permet de demander le Handle du premier contrôle d'un style WS_TABSTOP du contrôle spécifié.
GetNextWindow | Cette fonction permet de rechercher le Handle de la prochaine ou précédente fenêtre dans la liste du gestionnaire de fenêtre.
GetOpenClipboardWindow | Cette fonction permet de demander le Handle de la fenêtre actuellement ouverte dans le presse-papier.
GetParent | Cette fonction permet de demander le Handle de la fenêtre parent spécifié.
GetPriorityClipboardFormat | Cette fonction permet de demander le format du premier presse-papier dans la liste de données existantes du presse-papier.
GetProcessWindowStation | Cette fonction permet de demander le Handle de la fenêtre de station associé avec le processus appelant.
GetPropA | Cette fonction permet de demander une données Handle d'une liste de propriété d'une fenêtre.
GetPropW | Cette fonction permet de demander une données Handle d'une liste de propriété d'une fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
GetQueueStatus | Cette fonction permet de retourner une valeur indiquant le type de message dans la file d'attente.
GetScrollInfo | Cette fonction permet de demander les paramètres d'une barre de défilement, en incluant les positions de défilement minimum et maximum, la taille de la page et la position de la boite de défilement.
GetScrollPos | Cette fonction permet de demander la position courante de la boite de défilement d'une barre de défilement.
GetScrollRange | Cette fonction permet de demander la position minimum et maximum de la barre de défilement spécifié.
GetSubMenu | Cette fonction permet de demander le Handle du menu contextuel.
GetSysColor | Cette fonction permet de demander la couleur d'un des objets affichés du système d'exploitations de Windows.
GetSysColorBrush | Cette fonction permet de demander le Handle identifiant la brosse logique correspondant à l'index de couleur spécifié.
GetSystemMenu | Cette fonction permet de demander le Handle du menu système d'une fenêtre d'application.
GetSystemMetrics | Cette fonction permet de demander le type de système métrique ou de ses paramètres utilisés.
GetTabbedTextExtentA | Cette fonction permet de calculer la largeur et la hauteur d'une chaine de caractères.
GetTabbedTextExtentW | Cette fonction permet de calculer la largeur et la hauteur d'une chaine de caractères avec des paramètres de chaine de caractères étendues (Unicode).
GetThreadDesktop | Cette fonction permet de demander le Handle du bureau associé avec le processus spécifié.
GetTopWindow | Cette fonction permet de demander le Handle du plus haut niveau de fenêtre enfant appartenant à la fenêtre parent spécifié.
GetUpdateRect | Cette fonction permet de demander les coordonnées d'un petit rectangle complètement enfermé dans une région mise à jour par la fenêtre donnée.
GetUpdateRgn | Cette fonction permet de demander la région mise à jour dans la fenêtre.
GetUserObjectInformationA | Cette fonction permet de demander les informations à propos d'une station de fenêtre ou d'un objet de bureau.
GetUserObjectInformationW | Cette fonction permet de demander les informations à propos d'une station de fenêtre ou d'un objet de bureau avec des paramètres de chaine de caractères étendues (Unicode).
GetUserObjectSecurity | Cette fonction permet de demander les informations de sécurité pour l'objet utilisateur spécifié.
GetWindow | Cette fonction permet de demander le Handle d'une fenêtre d'application.
GetWindowContextHelpId | Cette fonction permet de demander l'identificateur de contexte, si possible, associé avec la fenêtre spécifié.
GetWindowDC | Cette fonction permet de demander un périphérique de contexte pour la fenêtre, la barre de titre, les menus et la barre de défilement.
GetWindowLongA | Cette fonction permet de demander, sous forme d'une valeur de 32 bits, une des propriétés d'une fenêtre d'application.
GetWindowLongW | Cette fonction permet de demander, sous forme d'une valeur de 32 bits, une des propriétés d'une fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
GetWindowPlacement | Cette fonction permet de demander l'état d'affichage et de restituer, minimiser et maximiser les positions d'une fenêtre.
GetWindowRect | Cette fonction permet de demander les coordonnées et la taille d'une fenêtre d'application.
GetWindowRgn | Cette fonction permet de demander une copie d'une région de fenêtre dans une fenêtre.
GetWindowTextA | Cette fonction permet de demander du texte contenu dans une fenêtre d'application.
GetWindowTextLengthA | Cette fonction permet de demander la longueur du texte contenu dans une fenêtre d'application.
GetWindowTextLengthW | Cette fonction permet de demander la longueur du texte contenu dans une fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
GetWindowTextW | Cette fonction permet de demander du texte contenu dans une fenêtre d'application avec des paramètres de chaine de caractères étendues (Unicode).
GetWindowThreadProcessId | Cette fonction permet de demander l'identificateur de processus léger étant créer par la fenêtre spécifié et, optionnellement, l'identificateur du processus créant la fenêtre.
GetWindowWord | Cette fonction permet de demander une valeur 16 bits de déplacement spécifié dans une fenêtre en mémoire supplémentaire pour la fenêtre spécifié.
GrayStringA | Cette fonction permet de dessiner du texte grisé à l'emplacement donnée par l'écriture du texte dans un Bitmap en mémoire, grisonnant le Bitmap, et copie alors le Bitmap dans l'affichage.
GrayStringW | Cette fonction permet de dessiner du texte grisé à l'emplacement donnée par l'écriture du texte dans un Bitmap en mémoire, grisonnant le Bitmap, et copie alors le Bitmap dans l'affichage avec des paramètres de chaine de caractères étendues (Unicode).
HideCaret | Cette fonction permet de cacher un caret en l'enlevant de l'écran.
HiliteMenuItem | Cette fonction permet de faire passer un item de menu en mode de surbrillance.
ImpersonateDdeClientWindow | Cette fonction permet d'activer l'échange de données dynamique (DDE) vers un contexte d'application sécurisé d'imitation de client DDE.
InflateRect | Cette fonction permet d'agrandir ou diminuer la taille d'un objet de rectangle.
InSendMessage | Cette fonction permet de spécifier si la procédure de la fenêtre courante est en traitement d'un message d'envoi d'une autre tâche par appel de la fonction SendMessage.
InsertMenuA | Cette fonction permet d'insérer un nouvel item de menu dans un menu et déplace les autres items en bas du menu.
InsertMenuItemA | Cette fonction permet d'insérer un nouvel item de menu à la position spécifié dans la barre de menu ou un menu contextuel.
InsertMenuItemW | Cette fonction permet d'insérer un nouvel item de menu à la position spécifié dans la barre de menu ou un menu contextuel avec les paramètres de chaine de caractères étendues (Unicode).
InsertMenuW | Cette fonction permet d'insérer un nouvel item de menu dans un menu et déplace les autres items en bas du menu avec des paramètres de chaine de caractères étendues (Unicode).
IntersectRect | Cette fonction permet de calculer l'intersection de 2 sources rectangulaires et place les coordonnées du rectangle d'intersection dans le rectangle de destination.
InvalidateRect | Cette fonction permet d'ajouter un rectangle pour la mise à jour d'une région d'une fenêtre.
InvalidateRgn | Cette fonction permet d'ajouter une région à une région de fenêtre à mettre à jour.
InvertRect | Cette fonction permet d'inverser une région rectangulaire.
IsCharAlphaA | Cette fonction permet de demander si un caractère fait partie de l'ensemble de caractères alphabéthique de la langue.
IsCharAlphaNumericA | Cette fonction permet de demander si un caractère est une lettre ou un chiffre arabes.
IsCharAlphaNumericW | Cette fonction permet de demander si un caractère est une lettre ou un chiffre arabes avec des paramètres de chaine de caractères étendues (Unicode).
IsCharAlphaW | Cette fonction permet de demander si un caractère fait partie de l'ensemble de caractères alphabéthique de la langue avec des paramètres de chaine de caractères étendues (Unicode).
IsCharLowerA | Cette fonction permet de demander si un caractère est une lettre en minuscule.
IsCharLowerW | Cette fonction permet de demander si un caractère est une lettre en minuscule avec des paramètres de chaine de caractères étendues (Unicode).
IsCharUpperA | Cette fonction permet de demander si un caractère est une lettre en majuscule.
IsCharUpperW | Cette fonction permet de demander si un caractère est une lettre en majuscule avec des paramètres de chaine de caractères étendues (Unicode).
IsChild | Cette fonction permet de demander si la fenêtre spécifié est l'enfant ou d'une autre descendance direct de la fenêtre parent spécifié.
IsClipboardFormatAvailable | Cette fonction permet de demander si les données d'un certain format exist dans le presse-papier.
IsDialogMessageA | Cette fonction permet de demander si le message spécifié est prévu dans la modélisation de la boite de dialogue donnée et, si c'est le cas, traite le message.
IsDialogMessageW | Cette fonction permet de demander si le message spécifié est prévu dans la modélisation de la boite de dialogue donnée et, si c'est le cas, traite le message avec des paramètres de chaine de caractères étendues (Unicode).
IsDlgButtonChecked | Cette fonction permet de demander si un bouton a une coche à côté de lui et si un bouton à trois états de gris, est coché ou pas.
IsIconic | Cette fonction permet de demander si la fenêtre spécifié est minimisé (en état d'icône).
IsMenu | Cette fonction permet d'indiquer si le Handle spécifié est un Handle de menu.
IsRectEmpty | Cette fonction permet de déterminer si le rectangle spécifié est vide.
IsWindow | Cette fonction permet de demander si la fenêtre de Handle spécifié est valide.
IsWindowEnabled | Cette fonction permet de demander si la fenêtre spécifié est activé par la souris ou l'entrée clavier.
IsWindowUnicode | Cette fonction permet de demander si la fenêtre spécifié est une fenêtre Unicode native.
IsWindowVisible | Cette fonction permet de demander si la fenêtre spécifié est dans un état de visibilité.
IsZoomed | Cette fonction permet de demander si la fenêtre spécifié est maximisé (ou prend toute l'écran).
keybd_event | Cette fonction permet de provoquer un événement d'appui de touche clavier.
KillTimer | Cette fonction permet de détruire la minuterie spécifié.
LoadAcceleratorsA | Cette fonction permet d'effectuer le chargement d'une table d'accélérateur d'une ressource.
LoadAcceleratorsW | Cette fonction permet d'effectuer le chargement d'une table d'accélérateur d'une ressource avec des paramètres de chaine de caractères étendues (Unicode).
LoadBitmapA | Cette fonction permet de charger la ressource de Bitmap spécifié du fichier de module d'exécutable donnée.
LoadBitmapW | Cette fonction permet de charger la ressource de Bitmap spécifié du fichier de module d'exécutable donnée avec des paramètres de chaine de caractères étendues (Unicode).
LoadCursorA | Cette fonction permet de sélectionner un pointeur de souris.
LoadCursorFromFileA | Cette fonction permet de charger à partir d'un fichier un pointeur de souris.
LoadCursorFromFileW | Cette fonction permet de charger à partir d'un fichier un pointeur de souris avec des paramètres de chaine de caractères étendues (Unicode).
LoadCursorW | Cette fonction permet de sélectionner un pointeur de souris avec des paramètres de chaine de caractères étendues (Unicode).
LoadIconA | Cette fonction permet de charger une icône à partir d'un fichier.
LoadIconW | Cette fonction permet de charger une icône à partir d'un fichier avec des paramètres de chaine de caractères étendues (Unicode).
LoadImageA | Cette fonction permet de charger une image à partir d'une icône, un curseur ou un Bitmap.
LoadImageW | Cette fonction permet de charger une image à partir d'une icône, un curseur ou un Bitmap avec des paramètres de chaine de caractères étendues (Unicode).
LoadKeyboardLayoutA | Cette fonction permet de charger une nouvelle couche clavier dans le système.
LoadKeyboardLayoutW | Cette fonction permet de charger une nouvelle couche clavier dans le système avec des paramètres de chaine de caractères étendues (Unicode).
LoadMenuA | Cette fonction permet d'effectuer le chargement de la ressource de menu spécifié du fichier exécutable avec l'instance d'application donnée.
LoadMenuIndirectA | Cette fonction permet de charger le gabarit de menu spécifié en mémoire.
LoadMenuIndirectW | Cette fonction permet de charger le gabarit de menu spécifié en mémoire avec des paramètres de chaine de caractères étendues (Unicode).
LoadMenuW | Cette fonction permet d'effectuer le chargement de la ressource de menu spécifié du fichier exécutable avec l'instance d'application donnée avec des paramètres de chaine de caractères étendues (Unicode).
LoadStringA | Cette fonction permet d'effectuer le chargement de la chaine de caractères spécifié d'une ressource.
LoadStringW | Cette fonction permet d'effectuer le chargement de la chaine de caractères spécifié d'une ressource avec des paramètres de chaine de caractères étendues (Unicode).
LockWindowUpdate | Cette fonction permet d'activer ou désactiver l'affichage du contenu d'une fenêtre d'application.
LockWorkStation | Cette fonction permet verrouiller la poste de travail avec le mot de passe de l'utilisateur courant. Cette fonction est l'équivalent de Ctrl+Alt+Delete et «Verrouiller Station de Travail».
LookupIconIdFromDirectory | Cette fonction permet d'effectuer la recherche de données d'icône ou de curseur dans un icône ou curseur étant la meilleure correspondance avec le périphérique d'affichage courant.
LookupIconIdFromDirectoryEx | Cette fonction permet d'effectuer la recherche de données d'icône ou de curseur dans un icône ou curseur étant la meilleure correspondance avec le périphérique d'affichage courant avec des options particulières.
MapDialogRect | Cette fonction permet d'effectuer la conversion de l'unité de boite de dialogue à l'unité d'écran (pixels).
MapVirtualKeyA | Cette fonction permet d'effectuer la conversion du code de touche virtuel en une valeur de caractère et un code de balayage (scan code) ou convertie le code de balayage en code de touche virtuel.
MapVirtualKeyExA | Cette fonction permet d'effectuer la conversion du code de touche virtuel en une valeur de caractère et un code de balayage (scan code) ou convertie le code de balayage en code de touche virtuel en utilisant des options supplémentaires.
MapVirtualKeyExW | Cette fonction permet d'effectuer la conversion du code de touche virtuel en une valeur de caractère et un code de balayage (scan code) ou convertie le code de balayage en code de touche virtuel en utilisant des options supplémentaires avec des paramètres de chaine de caractères étendues (Unicode).
MapVirtualKeyW | Cette fonction permet d'effectuer la conversion du code de touche virtuel en une valeur de caractère et un code de balayage (scan code) ou convertie le code de balayage en code de touche virtuel avec des paramètres de chaine de caractères étendues (Unicode).
MapWindowPoints | Cette fonction permet de convertir (cartographié) un ensemble de points d'une espace de coordonnées relatif d'une fenêtre vers une autre fenêtre d'espace de coordonnées relatif.
MenuItemFromPoint | Cette fonction permet de demander quel est l'item de menu situé à l'emplacement spécifié, peut importe lequel.
MessageBeep | Cette fonction permet de faire jouer un de ses sons standard du système d'exploitation Windows.
MessageBoxA | Cette fonction permet d'afficher une boite de dialogue contenant un message et des boutons d'actions.
MessageBoxExA | Cette fonction permet de créer, d'afficher et d'effectuer des opérations sur une boite de message.
MessageBoxExW | Cette fonction permet de créer, d'afficher et d'effectuer des opérations sur une boite de message avec des paramètres de chaine de caractères étendues (Unicode).
MessageBoxIndirectA | Cette fonction permet de créer, d'afficher et d'effectuer des opérations sur une boite de message à l'aide d'une structure de données.
MessageBoxIndirectW | Cette fonction permet de créer, d'afficher et d'effectuer des opérations sur une boite de message à l'aide d'une structure de données avec des paramètres de chaine de caractères étendues (Unicode).
MessageBoxW | Cette fonction permet d'afficher une boite de dialogue contenant un message et des boutons d'actions avec des paramètres de chaine de caractères étendues (Unicode).
ModifyMenuA | Cette fonction permet d'effectuer une modification sur un item de menu existant.
ModifyMenuW | Cette fonction permet d'effectuer une modification sur un item de menu existant avec des paramètres de chaine de caractères étendues (Unicode).
mouse_event | Cette fonction permet de provoquer un événement de déplacement de pointeur de souris ou d'actions de bouton de souris.
MoveWindow | Cette fonction permet de changer l'emplacement d'une fenêtre d'application
MsgWaitForMultipleObjects | Cette fonction permet de retourner un objet spécifié suite à un état, un type spécifié étant disponible de l'entrée de la file d'attente d'un processus léger ou intervalle de dépassement de délai.
MsgWaitForMultipleObjectsEx | Cette fonction permet de retourner un objet spécifié suite à un état, un type spécifié étant disponible de l'entrée de la file d'attente d'un processus léger ou intervalle de dépassement de délai avec des paramètres supplémentaires.
OemKeyScan | Cette fonction permet de demander le code ASCII OEM entre 0 et FFh situé dans les codes de balayage et des touches états (Ctrl, Alt et Shift).
OemToCharA | Cette fonction permet d'effectuer la conversion d'une chaine de caractères contenant un ensemble de caractères OEM vers du ANSI ou du Unicode.
OemToCharBuffA | Cette fonction permet d'effectuer la conversion d'un certain nombre de caractères OEM vers du ANSI ou du Unicode.
OemToCharBuffW | Cette fonction permet d'effectuer la conversion d'un certain nombre de caractères OEM vers du ANSI ou du Unicode avec des paramètres de chaine de caractères étendues (Unicode).
OemToCharW | Cette fonction permet d'effectuer la conversion d'une chaine de caractères contenant un ensemble de caractères OEM vers du ANSI ou du Unicode avec des paramètres de chaine de caractères étendues (Unicode).
OffsetRect | Cette fonction permet de déplacer le rectangle spécifié avec le nombre de déplacements spécifié.
OpenClipboard | Cette fonction permet de commencer un traitement avec le presse-papier.
OpenDesktopA | Cette fonction permet de demander le Handle d'un bureau existant.
OpenDesktopW | Cette fonction permet de demander le Handle d'un bureau existant avec des paramètres de chaine de caractères étendues (Unicode).
OpenIcon | Cette fonction permet de passer en mode actif l'icône d'une fenêtre.
OpenInputDesktop | Cette fonction permet de demander le Handle d'un bureau reçevant une entrée utilisateur.
OpenWindowStationA | Cette fonction permet de demander le Handle d'une fenêtre de station existante.
OpenWindowStationW | Cette fonction permet de demander le Handle d'une fenêtre de station existante avec des paramètres de chaine de caractères étendues (Unicode).
PackDDElParam | Cette fonction permet de compacté la valeur DDE spécifié dans une structure interne utilisé dans le partage de données DDE entre le traitement de processus.
PaintDesktop | Cette fonction permet de remplir le bureau avec une couleur ou un papier-peint.
PeekMessageA | Cette fonction permet de poster un message dans une fenêtre de file d'attente de message et retourne sans attendre la correspondance à un processus de message.
PeekMessageW | Cette fonction permet de poster un message dans une fenêtre de file d'attente de message et retourne sans attendre la correspondance à un processus de message avec des paramètres de chaine de caractères étendue (Unicode).
PostMessageA | Cette fonction permet d'envoyer un message à un objet du système d'exploitation Windows.
PostMessageW | Cette fonction permet d'envoyer un message à un objet du système d'exploitation Windows avec des paramètres de chaine de caractères étendues (Unicode).
PostQuitMessage | Cette fonction permet de poster un message à Windows afin d'indiquer que l'application reçoit une requête de terminaison d'exécution (quitte).
PostThreadMessageA | Cette fonction permet de poster un message dans la file d'attente du processus léger spécifié et retourne sans attendre que le processus léger traite le message.
PostThreadMessageW | Cette fonction permet de poster un message dans la file d'attente du processus léger spécifié et retourne sans attendre que le processus léger traite le message avec des paramètres de chaine de caractères étendues (Unicode).
PtInRect | Cette fonction permet de déterminer si le point spécifié est lié avec le rectangle spécifié.
RedrawWindow | Cette fonction permet de mettre à jour le rectangle ou la région spécifié de la région de la fenêtre client.
RegisterClassA | Cette fonction permet d'effectuer l'enregistrement d'une classe de fenêtre subséquente aux appels des fonctions CreateWindow ou CreateWindowEx.
RegisterClassExA | Cette fonction permet d'effectuer l'enregistrement d'une classe de fenêtre subséquente aux appels des fonctions CreateWindow ou CreateWindowEx avec des options supplémentaires.
RegisterClassExW | Cette fonction permet d'effectuer l'enregistrement d'une classe de fenêtre subséquente aux appels des fonctions CreateWindow ou CreateWindowEx avec des options supplémentaires et des paramètres de chaine de caractères étendues (Unicode).
RegisterClassW | Cette fonction permet d'effectuer l'enregistrement d'une classe de fenêtre subséquente aux appels des fonctions CreateWindow ou CreateWindowEx avec des paramètres de chaine de caractères étendues (Unicode).
RegisterClipboardFormatA | Cette fonction permet d'enregistrer un nouveau format de presse-papier.
RegisterClipboardFormatW | Cette fonction permet d'enregistrer un nouveau format de presse-papier avec des paramètres de chaine de cararactères étendues (Unicode).
RegisterHotKey | Cette fonction permet de définir l'état des touches de combinaison (Alt, Ctrl, Shift) pour le processus léger courant.
RegisterWindowMessageA | Cette fonction permet de définir une nouvelle fenêtre de message garantissant qu'elle est unique au système.
RegisterWindowMessageW | Cette fonction permet de définir une nouvelle fenêtre de message garantissant qu'elle est unique au système avec des paramètres de chaine de caractères étendues (Unicode).
ReleaseCapture | Cette fonction permet de relâcher la capture de souris et de restituer l'entrée de traitement normal.
ReleaseDC | Cette fonction permet de relâcher un périphérique de contexte, de libérer son utilisation pour les autres applications.
RemoveMenu | Cette fonction permet de supprimer un item de menu déroulant.
RemovePropA | Cette fonction permet d'enlever une entrée de la liste de propriété de la fenêtre spécifié.
RemovePropW | Cette fonction permet d'enlever une entrée de la liste de propriété de la fenêtre spécifié avec des paramètres de chaine de caractères étendues (Unicode).
ReplyMessage | Cette fonction permet de répondre à un message envoyé par la fonction SendMessage sans rendre le contrôle à la fonction ayant appelé SendMessage.
ReuseDDElParam | Cette fonction permet d'allouer une application vers la réutilisation de paramètre DDE compacté spécifié et en réallouant un nouveau paquet spécifié.
ScreenToClient | Cette fonction permet de convertir les coordonnées d'écrans d'un point spécifié de l'écran à des coordonnées clients.
ScrollDC | Cette fonction permet de faire défiler un rectangle d'un nombre de bits horizontal et vertical.
ScrollWindow | Cette fonction permet d'effectuer un défilement du contenu d'une région de fenêtre client.
ScrollWindowEx | Cette fonction permet d'effectuer un défilement du contenu d'une région de fenêtre client avec des options supplémentaires.
SendDlgItemMessageA | Cette fonction permet d'envoyer un message à un contrôle de boite de dialogue.
SendDlgItemMessageW | Cette fonction permet d'envoyer un message à un contrôle de boite de dialogue avec des paramètres de chaine de caractères étendues (Unidcode).
SendMessageA | Cette fonction permet d'effectuer l'envoi d'un message à une fenêtre où à un objet d'une fenêtre.
SendMessageCallbackA | Cette fonction permet d'effectuer l'envoi d'un message spécifié vers une ou des fenêtres.
SendMessageCallbackW | Cette fonction permet d'effectuer l'envoi d'un message spécifié vers une ou des fenêtres avec des paramètres de chaine de caractères étendues (Unicode).
SendMessageTimeoutA | Cette fonction permet d'effectuer l'envoi d'un message avec un dépassement de délai spécifié vers une ou des fenêtres.
SendMessageTimeoutW | Cette fonction permet d'effectuer l'envoi d'un message avec un dépassement de délai spécifié vers une ou des fenêtres avec des paramètres de chaine de caractères étendues (Unicode).
SendMessageW | Cette fonction permet d'effectuer l'envoi d'un message à une fenêtre où à un objet d'une fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
SendNotifyMessageA | Cette fonction permet d'effectuer l'envoi d'un message d'avertissement spécifié vers une fenêtre.
SendNotifyMessageW | Cette fonction permet d'effectuer l'envoi d'un message d'avertissement spécifié vers une fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
SetActiveWindow | Cette fonction permet de rendre le plus haut niveau d'une fenêtre spécifié en une fenêtre active.
SetCapture | Cette fonction permet de fixer la capture de la souris dans la fenêtre spécifié.
SetCaretBlinkTime | Cette fonction permet de fixer le taux de clignotement du caret.
SetCaretPos | Cette fonction permet de fixer la position d'un caret.
SetClassLongA | Cette fonction permet de fixer des valeurs d'informations en 32 bits sur une classe.
SetClassLongW | Cette fonction permet de fixer des valeurs d'informations en 32 bits sur une classe avec des paramètres de chaine de caractères étendues (Unicode).
SetClassWord | Cette fonction permet de fixer la valeur d'un mot dans le déplacement spécifié de la classe de mémoire supplémentaire de la classe de fenêtre à laquelle la fenêtre appartient.
SetClipboardData | Cette fonction permet de fixer des données dans le presse-papier.
SetClipboardViewer | Cette fonction permet d'ajouter une fenêtre donnée à la chaine de fenêtre ayant un avertissement si le contenu du presse-papier a changé.
SetCursor | Cette fonction permet de fixer l'image du pointeur de la souris.
SetCursorPos | Cette fonction permet de fixer les coordonnées du pointeur de la souris.
SetDebugErrorLevel | Cette fonction permet de fxer le niveau d'erreur minimum dans chaque fenêtre étant généré par les événements de déboguage et passe celui-ci au débogueur.
SetDlgItemInt | Cette fonction permet de fixer le texte d'un contrôle donnée dans une boite de dialogue vers la chaine de caractères de représentation spécifiant la valeur entière.
SetDlgItemTextA | Cette fonction permet de fixer le titre ou le texte d'un contrôle d'une boite de dialogue.
SetDlgItemTextW | Cette fonction permet de fixer le titre ou le texte d'un contrôle d'une boite de dialogue avec des paramètres de chaine de caractères étendues (Unicode).
SetDoubleClickTime | Cette fonction permet de fixer le temps maximal autorisé pour que des clics sur les boutons de la souris soit considéré comme un double-clic.
SetFocus | Cette fonction permet de fixer le focus d'entrée de la fenêtre spécifié.
SetForegroundWindow | Cette fonction permet de mettre le processus léger étant créer pour la fenêtre spécifié dans une fenêtre active ou de premier plan.
SetKeyboardState | Cette fonction permet de fixer l'état des 256 touches virtuel de clavier.
SetLastErrorEx | Cette fonction permet de fixer le code de la dernière erreur avec un type d'erreur.
SetMenu | Cette fonction permet d'attribué un menu à une fenêtre.
SetMenuContextHelpId | Cette fonction permet d'associer un identificateur de contexte d'aide avec un menu.
SetMenuDefaultItem | Cette fonction permet de fixer l'item par défaut d'un menu déroulant.
SetMenuItemBitmaps | Cette fonction permet d'associer le Bitmap donnée avec un item de menu.
SetMenuItemInfoA | Cette fonction permet de modifier les informations conçernant un item de menu.
SetMenuItemInfoW | Cette fonction permet de modifier les informations conçernant un item de menu avec des paramètres de chaine de caractères étendues (Unicode).
SetMessageQueue | Cette fonction permet de créer un nouveau message dans la file d'attente.
SetParent | Cette fonction permet de transférer un objet d'une fenêtre vers une autre.
SetProcessWindowStation | Cette fonction permet de fixer une fenêtre de station vers un processus appellant.
SetPropA | Cette fonction permet d'ajouter une nouvelle entrée ou changer une entrée existante dans la liste de propriété d'une fenêtre spécifié.
SetPropW | Cette fonction permet d'ajouter une nouvelle entrée ou changer une entrée existante dans la liste de propriété d'une fenêtre spécifié avec des paramètres de chaine de caractères étendues (Unicode).
SetRect | Cette fonction permet de fixer la taille et la position d'un rectangle.
SetRectEmpty | Cette fonction permet de créer un rectangle vide (tous les coordonnées sont fixées à 0).
SetScrollInfo | Cette fonction permet de fixer les paramètres de barre de défilement, en incluant les positions minimums et maximums, la taille de la page et la position de la boite de défilement.
SetScrollPos | Cette fonction permet de fixer la position d'une boite de défilement et, si requis, redessiner la barre de défilement reflétant la nouvelle position de la boite de défilement.
SetScrollRange | Cette fonction permet de fixer les valeurs de position minimum et maximum de la barre de défilement spécifié.
SetSysColors | Cette fonction permet de fixer la/les couleurs d'un/des objet(s) affiché(s) du système d'exploitations Windows.
SetSystemCursor | Cette fonction permet de modifier un des curseurs qu'utilise le système d'exploitations Windows.
SetThreadDesktop | Cette fonction permet de fixer le bureau au processus léger appellant.
SetTimer | Cette fonction permet d'installer une minuterie système.
SetUserObjectInformationA | Cette fonction permet de fixer les informations à propos d'une fenêtre de station ou d'un objet de bureau.
SetUserObjectInformationW | Cette fonction permet de fixer les informations à propos d'une fenêtre de station ou d'un objet de bureau avec des paramètres de chaine de caractères étendues (Unicode).
SetUserObjectSecurity | Cette fonction permet de fixer la sécurité d'un objet utilisateur.
SetWindowContextHelpId | Cette fonction permet d'associer un identificateur de contexte d'aide avec la fenêtre spécifié.
SetWindowLongA | Cette fonction permet de placer une valeur 32 bits dans le déplacement spécifié dans une fenêtre en mémoire supplémentaire pour la fenêtre spécifié.
SetWindowLongW | Cette fonction permet de placer une valeur 32 bits dans le déplacement spécifié dans une fenêtre en mémoire supplémentaire pour la fenêtre spécifié avec des paramètres de chaine de caractères étendues (Unicode).
SetWindowPlacement | Cette fonction permet de fixer l'état d'affichage et de restituer, minimiser et maximiser les positions d'une fenêtre.
SetWindowPos | Cette fonction permet de fixer la position d'une fenêtre à une nouvelle coordonnées à l'écran.
SetWindowRgn | Cette fonction permet de fixer la région de fenêtre dans une fenêtre.
SetWindowsHookA | Cette fonction permet d'installer une fonction de crochet utilisateur dans une chaine de crochet.
SetWindowsHookExA | Cette fonction permet d'installer un crochet de fonction utilisateur dans une chaine de crochet.
SetWindowsHookExW | Cette fonction permet d'installer un crochet de fonction utilisateur dans une chaine de crochet avec des paramètres de chaine de caractères étendues (Unicode).
SetWindowsHookW | Cette fonction permet d'installer une fonction de crochet utilisateur dans une chaine de crochet avec des paramètres de chaine de caractères étendues (Unicode).
SetWindowTextA | Cette fonction permet de définir le contenu texte d'une fenêtre.
SetWindowTextW | Cette fonction permet de définir le contenu texte d'une fenêtre avec des paramètres de chaine de caractères étendues (Unicode).
SetWindowWord | Cette fonction permet de placer une valeur 16 bits dans le déplacement spécifié dans une fenêtre en mémoire supplémentaire pour la fenêtre spécifié.
ShowCaret | Cette fonction permet d'afficher un caret à l'écran à la position courant du caret.
ShowCursor | Cette fonction permet d'afficher ou de faire disparaitre le pointeur de la souris.
ShowOwnedPopups | Cette fonction permet d'afficher ou de cacher tous les fenêtres POP-UP du propriétaire de la fenêtre spécifié.
ShowScrollBar | Cette fonction permet d'afficher ou de faire disparaitre la barre de défilement d'une fenêtre ou d'un objet.
ShowWindow | Cette fonction permet de définir l'état visuel d'une fenêtre d'application.
ShowWindowAsync | Cette fonction permet de fixer l'affichage d'état de la création d'une fenêtre par différent processus léger.
SubtractRect | Cette fonction permet de demander les coordonnées d'un rectangle par soustraction d'un rectangle par un autre.
SwapMouseButton | Cette fonction permet d'échanger le comportement des boutons de gauche de la souris devienne celui de droite et que celui de droite devienne celui de gauche.
SwitchDesktop | Cette fonction permet de fixer le bureau visible et actif.
SystemParametersInfoA | Cette fonction permet de fixer certain paramètre du système d'exploitation Windows.
SystemParametersInfoW | Cette fonction permet de fixer certain paramètre du système d'exploitation Windows avec des paramètres de chaine de caractères étendues (Unicode).
TabbedTextOutA | Cette fonction permet d'écrire une chaine de caractères à l'emplacement spécifié, en étendant la tabulation des valeurs spécifiés dans des positions d'une tableau de tabulation sans arrêt.
TabbedTextOutW | Cette fonction permet d'écrire une chaine de caractères à l'emplacement spécifié, en étendant la tabulation des valeurs spécifiés dans des positions d'une tableau de tabulation sans arrêt avec des paramètres de chaine de caractères étendues (Unicode).
TileWindows | Cette fonction permet de présenter sous forme mosaïque les sous-fenêtre d'une fenêtre d'application MDI.
ToAscii | Cette fonction permet de traduire le code de touche virtuel spécifié et l'état du clavier en sa correspondance de caractère Windows ou de caractères.
ToAsciiEx | Cette fonction permet de traduire le code de touche virtuel spécifié et l'état du clavier en sa correspondance de caractère Windows ou de caractères avec des options supplémentaires.
ToUnicode | Cette fonction permet de traduire le code de touche virtuel spécifié et l'état du clavier en sa correspondance de caractère Unicode ou de caractères.
ToUnicodeEx | Cette fonction permet de traduire le code de touche virtuel spécifié et l'état du clavier en sa correspondance de caractère Unicode ou de caractères avec des options supplémentaires.
TrackMouseEvent | Cette fonction permet de poster les messages lorsque le pointeur de souris laisse une fenêtre ou passe dessus une fenêtre pour un nombre de temps spécifié.
TrackPopupMenu | Cette fonction permet d'afficher un menu contextuelle.
TrackPopupMenuEx | Cette fonction permet d'afficher un menu contextuel à l'emplacement spécifié et trace les items de sélection dans un menu contextuel.
TranslateAcceleratorA | Cette fonction permet d'effectuer le traitement des touches d'accélérations pour les commandes de menu.
TranslateAcceleratorW | Cette fonction permet d'effectuer le traitement des touches d'accélérations pour les commandes de menu avec des paramètres de chaine de caractères étendues (Unicode).
TranslateCharsetInfo | Cette fonction permet d'effectuer une conversion, basé sur ensemble de caractères spécifié, un code de page ou une valeur de signature de police de caractères, ajustant tous les membres d'une structure de destination aux valeurs approprié.
TranslateMDISysAccel | Cette fonction permet d'effectuer le traitement d'une combinaison de touches d'accélération pour une interface de document multiple (MDI) de la fenêtre enfant.
TranslateMessage | Cette fonction permet d'effectuer une transformation de message de touche virtuel en caractères de messages.
UnhookWindowsHook | Cette fonction permet d'enlever la fonction crochet utilisateur pour une chaine de fonctions crochet.
UnhookWindowsHookEx | Cette fonction permet d'enlever un crochet de fonction utilisateur d'une chaine de crochet.
UnionRect | Cette fonction permet d'effectuer la création de l'union de 2 rectangles.
UnloadKeyboardLayout | Cette fonction permet d'enlever une schéma de clavier.
UnpackDDElParam | Cette fonction permet d'effectuer un décompactage d'une valeur DDE reçu spécifié vers un message DDE posté.
UnregisterClassA | Cette fonction permet d'enlever une classe de fenêtre et libère l'entreposage requis par la classe.
UnregisterClassW | Cette fonction permet d'enlever une classe de fenêtre et libère l'entreposage requis par la classe avec des paramètres de chaine de caractères étendues (Unicode).
UnregisterDeviceNotification | Cette fonction permet de désenregistrer un périphérique ou un type de périphérique pour que la fenêtre reçoivent des avertissements de changements.
UnregisterHotKey | Cette fonction permet de désenregistrer l'état des touches de combinaison (Alt, Ctrl, Shift) pour le processus léger.
UpdateWindow | Cette fonction permet de mettre à jour la région client de la fenêtre donnée par l'envoie du message WM_PAINT à la fenêtre si la région à mettre à jour de la fenêtre n'est pas vide.
ValidateRect | Cette fonction permet de valider une région client avec le rectangle donnée par suppression du rectangle de la région à mettre à jour de la fenêtre donnée.
ValidateRgn | Cette fonction permet de valider la région client avec la région donnée par suppression de la région de la mise à jour courante d'une région de fenêtre spécifié.
VkKeyScanA | Cette fonction permet d'effectuer la conversion de caractère correspondant un code de touche virtuel et de l'état de touche de combinaison du clavier courant.
VkKeyScanExA | Cette fonction permet d'effectuer la conversion de caractère correspondant un code de touche virtuel et de l'état de touche de combinaison du clavier courant en utilisant le langage et la couche physique du clavier.
VkKeyScanExW | Cette fonction permet d'effectuer la conversion de caractère correspondant un code de touche virtuel et de l'état de touche de combinaison du clavier courant en utilisant le langage et la couche physique du clavier avec des paramètres de chaine de caractères étendues (Unicode).
VkKeyScanW | Cette fonction permet d'effectuer la conversion de caractère correspondant un code de touche virtuel et de l'état de touche de combinaison du clavier courant avec des paramètres de chaine de caractères étendues (Unicode).
WaitForInputIdle | Cette fonction permet d'attendre tant que le processus données est en attente d'une entrée utilisateur sans attendre d'entrée ou de dépassement d'intervalle de temps.
WaitMessage | Cette fonction permet de rendre le contrôle à une autre application quand une application n'a pas une autre tâche en traitement.
WindowFromDC | Cette fonction permet de demander le Handle de la fenêtre correspondante au périphérique de contexte spécifié.
WindowFromPoint | Cette fonction permet de demander le Handle associé à une fenêtre correspondant au coordonnées pixel spécifié.
WinHelpA | Cette fonction permet de démarrer la fenêtre d'aide (WINHELP.EXE) et passe les données optionnels indiquant la nature de la requête d'aide pour l'application.
WinHelpW | Cette fonction permet de démarrer la fenêtre d'aide (WINHELP.EXE) et passe les données optionnels indiquant la nature de la requête d'aide pour l'application avec des paramètres de chaine de caractères étendues (Unicode).
wsprintfA | Cette fonction permet d'écrire des données formatté d'une chaine de caractères vers un tampon.
wsprintfW | Cette fonction permet d'écrire des données formatté d'une chaine de caractères vers un tampon avec des paramètres de chaine de caractères étendues (Unicode).
wvsprintfA | Cette fonction permet de formatter et d'entreposer une série de caractères et de valeurs virtuel dans un tampon.
wvsprintfW | Cette fonction permet de formatter et d'entreposer une série de caractères et de valeurs virtuel dans un tampon avec des paramètres de chaine de caractères étendues (Unicode).

Voir également

Langage de programmation - C pour OS/2 - EXE, DLL et modules de OS/2 (Support de Windows 3.1) - USER.EXE
Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «version.dll»

Description

Ce fichier contient la bibliothèque de versions du système d'exploitation.

Liste des fonctions d'API Windows

Nom de l'API | Description
GetFileVersionInfoSizeA | Cette fonction permet de demander la taille de l'entête d'information de version du fichier spécifié.

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «wininet.dll»

Description

Ce fichier contient la bibliothèque d'API de service Internet.

Liste des fonctions d'API Windows

Nom de l'API | Description
FtpOpenFileA | Cette fonction permet d'ouvrir un fichier avec une chaine de caractères ASCIZ sur un protocole FTP.
FtpOpenFileW | Cette fonction permet d'ouvrir un fichier avec une chaine de caractères étendue (Unicode) sur un protocole FTP.
InternetAutodial | Cette fonction permet de provoquer une connexion Internet en utilisant le protocole TCP/IP.
InternetAutodialHangup | Cette fonction permet d'arrêter une connexion Internet en utilisant le protocole TCP/IP.
InternetGetConnectedState | Cette fonction permet de demander le type de connexion Internet qu'utilise le TCP/IP de Windows.

Voir également

Références des protocoles réseaux - FTP (File Transfer Protocol)
Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «winmm.dll»

Description

Ce fichier contient la bibliothèque multimédia de Windows (multimédia, son, midi, ...)

Liste des fonctions d'API Windows

Nom de l'API | Description
auxGetDevCapsA | Cette fonction permet de demander les informations concernant le système audio auxiliaire.
auxGetNumDevs | Cette fonction permet de demander le nombre de système audio auxiliaire reconnu par Windows.
mciSendStringA | Cette fonction permet d'envoyer des commandes au pilote matériel MCI s'occupant du multimédia.
PlaySoundA | Cette fonction permet de faire jouer un fichier de son de format Wave (.WAV).
sndPlaySoundA | Cette fonction permet de faire jouer un son de format Wave à partir d'un fichier.
waveOutGetNumDevs | Cette fonction permet de demander le nombre de sortie Wave disponible sur le système d'explotation Windows.

Voir également

Articles - Les géants de l'informatique - Microsoft


C pour Windows - EXE, DLL et modules de Windows - «winspool.drv»

Description

Ce fichier contient la bibliothèque de la gestion du tampon d'impression des imprimantes.

Liste des fonctions d'API Windows

Nom de l'API | Description
AbortPrinter | Cette fonction permet d'effacer un fichier dans le tampon d'impression si l'imprimante est configuré avec un tampon d'impression.
AddFormA | Cette fonction permet d'ajouter un formulaire à la liste des formulaires de l'imprimante spécifié.
AddJobA | Cette fonction permet de fixer la chaine de caractères du répertoire contenant les fichiers du tampon d'imprimante.
AddMonitorA | Cette fonction permet d'installer un moniteur d'imprimante local et des liens de configuration, de données et de fichiers du moniteur.
AddPortA | Cette fonction permet d'ajouter un nom de port à la liste des ports supporté par l'imprimante.
AddPrinterA | Cette fonction permet d'ajouter une imprimante à la liste des imprimantes.
AddPrinterConnectionA | Cette fonction permet d'ajouter une connexion à l'imprimante pour l'utilisateur courant.
AddPrinterDriverA | Cette fonction permet d'installer un pilote d'imprimante avec la configuration, les données et les fichiers du pilote.
AddPrintProcessorA | Cette fonction permet d'installer un processeur d'imprimante à partir d'un serveur et d'une liste processeur d'imprimante supporté.
AddPrintProvidorA | Cette fonction permet d'installer un fournisseur d'imprimante avec la configuration, les données et les fichiers du fournisseur.
AdvancedDocumentPropertiesA | Cette fonction permet d'afficher la configuration de l'imprimante spécifié dans une boite de dialogue.
ClosePrinter | Cette fonction permet d'indiquer que le traitement avec le tampon d'impression de l'imprimante est terminé.
ConfigurePortA | Cette fonction permet de lancer une boite de dialogue offrant la possibilité à l'utilisateur de choisir le port parallèle ou USB d'imprimante
DeletePrinter | Cette fonction permet de supprimer un objet d'imprimante.
EnumJobsA | Cette fonction permet de définir les travaux d'impressions d'une imprimante.
EnumPortsA | Cette fonction permet de demander les ports d'impressions d'imprimante disponible.
EnumPrintersA | Cette fonction permet de demander des informations sur une imprimante.
GetJobA | Cette fonction permet de demander les données d'un travail contenu dans le tampon d'impressions de l'imprimante.
GetPrinterA | Cette fonction permet de demander des informations sur une imprimante.
OpenPrinterA | Cette fonction permet d'ouvrir la communication avec une imprimante.
PrinterProperties | Cette fonction permet d'afficher une boite de dialogue de propriété de l'imprimante.
SetJobA | Cette fonction permet de fixer l'état du traitement d'un travail contenu dans le tampon d'impressions de l'imprimante.
SetPrinterA | Cette fonction permet d'envoyer une commande à l'imprimante.

Voir également

Articles - Les géants de l'informatique - Microsoft