Sommaire

BONJOUR
Musique "Invention BWV784" J.S. BACH 1685-1750

Algébre de BOOLE

LOGIQUE Electronique

Nous veillons aux respects des droits d'auteur : si par erreur un contenu protégé est disponible sans indication sur ce site, merci de contacter l'administrateur, il sera retiré ou mis à jour dans les plus brefs délais.


Accueil

Accueil CHM

Normal, dit comme ça,
vous ne risquez pas de comprendre.


Simulateur de portes logiques | Christian Pc

Vu dans ... http://christianpc.fr/simulateur-de-portes-logiques

Symboles et tables de vérités de portes logiques
Type Symbole américain Symbole européen Opération
booléenne 		Table de vérité
ET { A . B}
Entrée |  | Sortie
A | B | A ET B
0 | 0 | 0
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1
OU { A+B}
Entrée |  | Sortie
A | B | A OU B
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 1
NON {A}
Entrée | Sortie
A | NON A
0 | 1
1 | 0
NON-ET (NAND) ! {A . B}
Entrée |  | Sortie
A | B | A NAND B
0 | 0 | 1
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0
NON-OU (NOR) ! {A+B}
Entrée |  | Sortie
A | B | A NOR B
0 | 0 | 1
0 | 1 | 0
1 | 0 | 0
1 | 1 | 0
OU exclusif (XOR) {A xor B}
Entrée |  | Sortie
A | B | A XOR B
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0
ET-inclusif ou
OU-exclusif complémenté (XNOR) ou
Identité ou
NON-OU exclusif 		! { A xor B}
Entrée |  | Sortie
A | B | A XNOR B
0 | 0 | 1
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1


Logique CMOS/TTL

La logique CMOS-TTL

Les différences

La principale différence est la tension d'utilisation. La logique TTL fonctionne en 5V uniquement, alors que la famille C-MOS supporte une plage de 3 à 15V.

Voici un petit tableau extrait du "Guide des Circuits Intégrés" :

Paramètre TTL stand. 74L 74LS CMOS 4000B alim 5V CMOS 4000B alim 10V
Temps de propagation par porte
Fréquence de commutation des bascules
Courant de repos par porte
Immunité au bruit
Sortance
10 ns
35 MHz
10 mW
1V
10
33 ns
3 MHz
1 mW
1V
10
5 ns
45 MHz
2 mW
0.8V
20
40 ns
8 MHz
10 mW
2V
50
20 ns
16 MHz
10 mW
4V
50

Spécificités :

1. La famille C-MOS :

Les valeurs données en xx/xx/xx sont pour des alims de 5V/10V/15V :

  • Plage des tensions d'utilisation : 3 à 15V
  • Courant de repos par porte : 1 à 4 µA
  • Courant de repos par tampon/bascule : 4 à 16 µA
  • Courant de repos par MSI : 20 à 80 µA
  • Tension de sortie au niveau logique bas : 0.05V
  • Tension de sortie au niveau logique haut : 4.95V / 9.95V / 14.95V
  • Courant de sortie au niv. log. bas (DRAIN) : 0.44mA / 1.1mA / 3 mA
  • Courant de sortie au niv. log. haut (FOURNI) : -0.16mA / -0.4mA / -1.2 mA
  • Courant d'entrée : +/- 0.3 µA
Exceptions : quelques boitiers possedent des sorties pouvant supporter un grand courant (transistors de 'puissance') : drivers d'afficheurs numeriques, etc...
Précautions : décharges electrostatiques nuisibles ; de plus toute entrée ou sortie non utilisée doit être reliée soit à Vdd soit à Vss (masse)

2. La famille TTL :

Alim. 5V seulement (+/- 5 à 10 % selon les séries)

Abréviations :

  • L : Low Power : dissipation de puissance tres faible
  • LS : Low Power Schottky : idem et temps de propagation court
  • ALS : Advanced Low Power Schottky : dissipation extremement faible et temps de prop. extremement court
  • S : Schottky : dissipation normale et temps de prop. court
  • AS : Advanced Schottky : dissipation normale et temps de prop. extremement court
  • Aucune indic. : caract. normales

Entrance et sortance :

  • TTL standard :
 | Entrance | Sortance
Niveau logique haut | 1 (40 µA) | 10 (-400 µA)
Niveau logique bas | 1 (-1.6 mA) | 10 (16 mA)
  • TTL - LS :
 | Entrance | Sortance
Niveau logique haut | 1 (20 µA) | 20 (-400 µA)
Niveau logique bas | 1 (-0.4 mA) | 20 (8 mA)

Glossaire :

  • Frequence d'horloge fmax : fréquence maximale admise par l'entrée d'horloge d'un circuit bistable
  • Courant d'entrée au niveau logique haut Iih : courant circulant dans une entrée lorsqu'elle est mise au niveau logique haut
  • Idem au niv. log. bas : Iil : courant circulant dans une entrée mise au niv. bas
  • Courant de sortie au niv.haut Ioh : courant circulant dans une sortie à l'etat haut
  • Idem à l'etat bas Iol : courant circuulant dans une sortie à l'etat bas
  • Courant d'alimentation Icc : courant circulant dans la broche d'alim du circuit
  • Temps de maintien th : intervalle de temps pendant lequel le signal doit être appliqué sur une broche d'entrée donnée apres qu'un flanc actif se soit produit sur une broche d'entrée donnée. C'est le temps réel entre 2 evenements : la valeur minimale garantit le fonctionnement du circuit. Si la valeur est négative, elle définit l'intervalle le plus long pour lequel le fonctionnement du circuit est garantit.
  • Temps de propagation : tplh = temps de retard pour une transistion d'un niveau logique bas vers un niveau haut en sortie ; tphl = l'inverse
  • Largeur d'impulsion tw : temps entre les ponts de reference indiqués par les flancs ascendants et descendants d'une impulsion
  • Tension d'entrée au niv. log. haut Vih
  • Tension d'entrée au niv. log. bas Vil
  • Tension de sortie au niv. log. haut Voh
  • Tension de sortie au niv. log. bas Vol

Pour en savoir plus sur les caractéristiques générales des circuits logiques, téléchargez ces 2 documents en pdf : logique.zip (325 Ko) par Yvan Crévits

Tables de vérité :

Tout d'abord vous pouvez télécharger ce document .doc : boole.zip (30 Ko) par Rémi Lechartier sur la logique booléenne
On distingue les fonctions suivantes : OR, AND, NOR, NAND, EXOR, EXNOR, NOT (inverseur)

OR NOR
X1 X2 Y
1
1
0
0
1
0
1
0
1
1
1
0
X1 X2 Y
1
1
0
0
1
0
1
0
0
0
0
1
AND NAND
X1 X2 Y
1
1
0
0
1
0
1
0
1
0
0
0
X1 X2 Y
1
1
0
0
1
0
1
0
0
1
1
1
EXOR EXNOR
X1 X2 Y
1
1
0
0
1
0
1
0
0
1
1
0
X1 X2 Y
1
1
0
0
1
0
1
0
1
0
0
1

Pour NOT, c'est simple : 1 donne 0 et 0 donne 1

Liste complète et description :


Technologie des fonctions logiques TTL et CMOS

Technologie des fonctions logiques TTL et CMOS 08/04/2002 André BONNET
Liste des cours

L'objectif de ce chapitre est de donner des ordres de grandeur et de mieux connaître les propriétés des fonctions logiques. Pour limiter le champ de l'étude nous étudierons de façon générale les deux grandes familles TTL et CMOS sans aborder les nuances entre les nombreuses sous-familles.

1- Alimentation

En TTL
L'alimentation doit être impérativement continue et stable. Vcc = 5V +/- 5%

En CMOS
Le choix de la tension d'alimentation est plus large de 3V à 18V. Mais les performances dynamiques se dégradent aux faibles niveaux d'alimentation.

2- Niveaux d'entrée et de sortie

Chaque entrée de fonction logique traduit le niveau de tension reçu en état logique.

L'immunité aux bruits correspond à l'amplitude de la tension parasite qui peut exister entre la sortie d'une fonction logique et l'entrée d'une autre fonction logique qui sont reliées.

En TTL
Vohmini = 2,4 V Volmaxi = 0,4 V
Vihmini = 2 V Vilmaxi = 0,8 V L'immunité aux bruits est de 0,4 V

En CMOS
Vohmini = 0,95.Vcc Volmaxi = 0,05.Vcc
Vihmini = 0,55.Vcc Vilmaxi = 0,45.Vcc L'immunité aux bruits est de 0,4.Vcc

3- Courant à l'entrée et à la sortie

En TTL
A l'état bas une entrée de fonction TTL a besoin d'un courant sortant Iilmaxi = 1,6mA
A l'état haut le courant d'entrée est Iihmaxi = 40µA
La sortie peut délivrer Ioh maxi = 400µA au 1L et absorber Iolmaxi = 16mA au 0L
La sortance est donc de 10 en TTL. La sortance correspond au nombre d'entrées qu'une sortie peut commander.

En CMOS
Les courants d'entrée sont inférieurs à 1µA et les sorties peuvent véhiculer plus de 1 mA.
La sortance est limitée non pas par les courants d'entrée-sortie mais par les capacités parasites (5pF) d'entrée qui réduisent les temps de commutation.

4- Paramètres dynamiques

Quand une fonction logique change l'état d'une sortie, celui-ci n'est pas instantané. Il faut considérer un temps de montée tm (passage du 0L au 1L) ou un temps de descente td (passage du 1L au 0L).
Le traitement de l'information n'est pas immédiat. Il existe un temps de propagation tp.
Pour une porte inverseuse :

En TTL
Tp varie selon la sous-famille de 10ns (TTL " N ") à 1,5ns (TTL " AS ")

En CMOS

Tp varie en fonction du niveau de l'alimentation Vcc. La vitesse augmente quand on fait croître Vcc.
Mais chaque entrée CMOS présente une capacité parasite de 5pF. La capacité vue par la sortie influe fortement sur le temps de réponse.

Comparaison de la consommation des fonctions TTL et CMOS par porte :

La consommation des CMOS est quasi nulle aux basses fréquences. Mais elle atteint celle de la TTL autour de 1MHz.

A chaque commutation la fonction appelle une impulsion de courant (di/dt) sur les broches d'alimentation. Pour que Vcc ne varie pas du fait des inductances de cablage (L.di/dt), on place des condensateurs de découplage (0,1µF) sur l'alimentation de chaque circuit intégré.

5- Interfaçage

Sorties en collecteur ouvert

La plupart des fonctions TTL ont des sorties " totempole " dont la tension évolue de 0 à Vcc. Mais pour faciliter l'élaboration d'interfaces ou pour réaliser une fonction " ET câblé ", certaines fonctions spéciales ont des sorties en " collecteur ouvert ".

Capteur " tout ou rien " en entrée de fonction

En TTL
R1 doit imposer 1L sur l'entrée quand l'interrupteur est ouvert. R1 = 10 k omega par exemple.
La fermeture de l'interrupteur impose un 0L sans problème.
R2 doit imposer 0L sur l'entrée quand l'interrupteur est ouvert. R1 = 390 omega par exemple.
La fermeture de l'interrupteur impose un 1L sans problème.

En CMOS
R1 = R2 = 10K omega par exemple.


Understanding Digital Logic ICs - Part 2 - Nuts & Volts Magazine - For The Electronics Hobbyist

Vu dans ... http://www.nutsvolts.com/magazine

Understanding Digital Logic ICs - Part 2

By Ray Marston View Digital Edition

» Skip to the Extras

Modern digital electronics are dominated by two major logic IC families: the low-speed ‘4000-series’ of CMOS ICs and the ‘74-series’ of fast TTL and CMOS ICs. The 74 family was originally based entirely on TTL technology, which first hit the electronics scene in a big way around 1972, when the 74-series suddenly arrived in the form of an entire range of versatile and cleverly conceived TTL digital logic ICs that were each designed to operate from a single-ended five-volt supply and to directly and easily interconnect with each other without hassle (each output could directly drive several inputs). This made it relatively easy for any moderately competent engineer to design and develop fairly complex digital logic systems. The series was an instant and brilliant international success, and almost immediately became the world’s leading IC logic system. Its ICs were produced in both commercial and military grades, and carried prefixes of 74 and 54, respectively; the commercial product range rapidly became known simply as the 74-series of ICs.

A major feature of the 74-series is that all devices within the range function as black boxes that operate at similar input and output threshold levels; the user does not need to understand their internal circuitry in order to use them, but simply needs to know their basic usage rules. Also, the input sensitivity or ‘fan-in’ of each device conforms to a fixed standard, and its output drive capability or ‘fan-out’ has a guaranteed minimum value that indicates the number of external 74-series inputs that it can safely directly drive, making it very easy to interconnect various devices. The output of a 74 gate with a fan-out of 10 can directly drive as many as 10 parallel-connected standard inputs on other 74-series ICs.

The type of TTL technology used in the initial (1972) 74-series ICs resulted in a range of devices that were moderately fast but consumed fairly heavy currents. Within a year or so, sub-families of the original TTL were introduced, offering a trade-off between speed and power, i.e., twice the speed but at twice the current consumption (in the H or high speed sub-family), or one-tenth of the current consumption but only one-third of the normal speed (in the L or low power sub-family), etc.

This trend of seeking a good or ever-better trade-off between speed and power consumption has continued until present day, and so far, a total of eight commercially successful sub-families of TTL (and five sub-families of CMOS) have appeared in the 74-series of digital ICs. Many of these sub-families have subsequently become obsolete or obsolescent, but the practical design/maintainance engineer or technician still needs a basic knowledge of all of them, since they are often found in old equipment that needs repairing or upgrading.

Note that each sub-family of the 74-series of ICs is almost directly compatible with all other sub-families in the series. Thus, if you open up an old piece of equipment and find (for example) that an old 74L90 decade counter IC needs replacing but is no longer available, you will probably find that a modern 74LS90 decade counter IC can be used as a direct plug-in replacement, or that any other 74XX90 ICs can be used as a replacement either directly or with slight circuit modification (depending on the basic characteristics of the two sub-families). In either case, the first thing that you will need to do is identify the device of interest from its printed code number. Figure 1 explains the basic scheme that is used in formating the 74-series code numbers.

FIGURE 1. Basic coding system used on the 74-series ICs.

All ICs in the 74 family are identified by an alpha-numeric code which — in its simplest form — consists of three sub-codes strung together as shown in Figure 1. The first (left hand) sub-code consists of two digits that read either 74, 54, or 75. The 74 identifies the IC as a commercial-grade member of the family. These devices are usually encapsulated in a plastic 14-pin, 16-pin, or 24-pin dual-in-line package (DIP), can be used with supplies within the limit +4.75 V to +5.25 V, and can be operated over the temperature range 0° C to +70° C. The 54 identifies the IC as a high-quality military-grade member of the family. These devices are encapsulated in exotic packages, can use supplies within the limit +4.5 V to +5.5 V, and can operate over the temperature range -55° C to +125° C. The 75 identifies the IC as a commercial-grade interface device that is designed to support the 74 range of devices.

The second (central) sub-code consists of up to three letters, and identifies the precise technology or sub-family used in the construction of the device, as shown in the diagram. Note that standard TTL devices carry either no central code at all, or an N. Each of the other seven major TTL sub-family devices carry a central identifying code, and the five major CMOS 74 sub-families carry a central code that includes the letter C.

The last (right hand) sub-code usually consists of two to five digits (but occasionally includes a letter A or a star), and identifies the precise function of the IC (e.g., quad two-input NAND gate, decade counter, four-bit shift register, etc.). The precise relationship between this sub-code and the device function can be ascertained from the manufacturer’s lists.

Thus, a 74 type of IC may carry a code that, in its simplest form, reads something like 7400, 74N00, or 7414, etc., if it is a standard TTL device, or 74L14, 74LS38, or 74HC03, etc., if it is some other sub-member of the 74 family. Note that in practice 74-series ICs often carry an elaborated form of the basic code that includes a two-letter pre-fix that identifies the manufacturer, plus a lettered manufacturer’s suffix that indicates the packaging style, etc., as shown in Figure 2.

FIGURE 2. The basic 74-series code is often elaborated with a manufacturer’s prefix and/or suffix.

Hence, a device marked SN74LS90N is a normal 74LS90 IC, manufactured by Texas Instruments and housed in a plastic DIP.

TTL Sub-Families

Eight major sub-families of TTL have been used in the 74-series throughout its lifetime, as follows:

Standard TTL — Standard TTL is similar to the basic type already described, except that each of its inputs are provided with a protection diode that helps suppress transients and speeds up its switching action. Figure 3 shows the actual circuit of a 7400 two-input NAND gate. Its power consumption is 10 mW, and its propagation delay is 9 nS when driving a 15pF/400Ω load.

FIGURE 3. Circuit of a Standard TTL 7400 two-input NAND gate.

Low-Power (L) TTL (now obsolete) — Low-power TTL is a modified version of the standard type, with its resistance values greatly increased to give a dramatic reduction in power consumption at the expense of reduced speed. Figure 4 shows the circuit of a 74L00 two-input NAND gate. Its power consumption is 1 mW, and its propagation delay is typically 33 nS.

FIGURE 4. Circuit of a low-power (L) TTL 74L00 two-input NAND gate.

High-Speed (H) TTL (now obsolete) — High-speed TTL is a modified version of the standard type, with its resistance values reduced to give an increase in speed at the expense of increased power consumption. Figure 5 shows the circuit of a 74H00 two-input NAND gate. Its power consumption is 22 mW, and its propagation delay is typically 6 nS.

FIGURE 5. Circuit of a high-speed (H) TTL 74H00 two-input NAND gate.

Schottky (S) TTL (now obsolete) — A transistor switch can be designed to give either a saturated or an unsaturated switching action. Saturated switching — in which the transistor’s collector voltage falls far below that of the base under the on condition — is very easy to implement, but produces propagation delays that are about 2.5 times longer than those available from unsaturated circuits.

Standard TTL operates its transistors in a heavily-saturated switching mode in which the collector falls some 400 mV below the base under the on condition, and is thus intrinsically slow. Schottky TTL, on the other hand, operates its transistors in a lightly-saturated switching mode in which the collector only falls some 180 mV below the base voltage under the on condition, and is almost as fast as an unsaturated circuit (such as an ECL design).

Basically, this action is achieved by connecting a Schottky diode (which is fast-acting and has a typical forward volt drop of only 180 mV) between the transistor’s collector and base as shown in Figure 6(a), in which Rs represents the input pulse’s source impedance. Thus, if the collector goes more than 180 mV negative to the base, the Schottky diode becomes forward-biased and starts to shunt base current directly into the transistor’s collector, thus automatically preventing deeper saturation. In reality, the Schottky diode can easily be incorporated in the transistor’s structure, and a ‘Schottky-clamped transistor’ of this type uses the symbol shown in (b).

FIGURE 6. (a) A Schottky diode used to limit the saturation depth of an NPN transistor; (b) Symbol of an NPN ‘Schottky’ transistor, with a built-in clamping diode between its collector and base.

In a practical Schottky TTL IC, Schottky-clamped transistors are widely used, and most resistance values are reduced, thus giving a good increase in speed at the expense of power consumption. The totem-pole output stage uses a Darlington transistor pair to give active pull-up, plus a modified active pull-down network that gives an improved waveform-squaring action. Figure 7 shows the circuit of a 74S00 two-input NAND gate. Its power consumption is 20 mW and its propagation delay is 3 nS when driving a 15pF/280Ω load.

FIGURE 7. Circuit of a Schottky (S) TTL 74S00 two-input NAND gate.

Low-Power Schottky (LS) TTL — Low-power Schottky uses a modified form of Schottky technology, using improved manufacturing techniques, combined with a diode-transistor (rather than multi-emitter) form of input network that has a high impedance and gives fast switching. Figure 8 shows the circuit of a 74LS00 two-input NAND gate. Its power consumption is 2 mW and its propagation delay is 8 nS when driving a 12pF/2K load.

FIGURE 8. Circuit of a low-power Schottky (LS) TTL 74LS00 two-input NAND gate.

Advanced Low-Power Schottky (ALS) TTL — This sub-family is similar to LS but uses an advanced fabrication process which, combined with minor design modifications, yields active devices that are faster and have higher gains than LS types. Figure 9 shows the circuit of a 74ALS00 two-input NAND gate. Its power consumption is 1 mW and its propagation delay is 4 nS when driving a 50pF/2K load.

FIGURE 9. Circuit of an advanced low-power Schottky (ALS) 74ALS00 two-input NAND gate.

Advanced Schottky (AS) TTL — This sub-family is similar to ALS, but its design is optimized to give very high speed at the expense of power consumption. Figure 10 shows the circuit of a 74AS00 two-input NAND gate. Its power consumption is 22 mW and its propagation delay is a mere 2 nS when driving a 50pF/2K load.

FIGURE 10. Circuit of an advanced Schottky (AS) TTL 74AS00 two-input NAND gate.

FAST (F) TTL — FAST (Fairchild Advanced Schottky TTL) is Fairchild’s version of ‘AS’ TTL. It is manufactured under license by several companies (including Philips and National Semiconductor). Its performance is similar (in terms of speed and power consumption) to that of the AS sub-family.

CMOS 74-Series Sub-Families

When the 74-series of ICs were first released in 1972, all devices in the range were based on bipolar TTL technology, which inherently consumes a fairly large amount of power, irrespective of its operating speed. In about 1975, the rival CMOS digital ICs technology arrived on the scene, and although it was not as fast as TTL, it offered the outstanding advantage of having a power consumption that was directly proportional to operating speed, being virtually zero under quiescent conditions and rising to the same value as TTL at about 10 MHz. In the late 1970s, CMOS was introduced as a sub-family within the 74-series range of devices, carrying the central code C. The graph in Figure 11 compares the frequency/current-consumption curves of a single gate from the standard TTL and the CMOS C versions of the 7400 quad two-input NAND gate IC.

FIGURE 11. Frequency-current graphs of 7400 (TTL) and 74C00 (CMOS) two-input NAND gates (with a squarewave input).

In its early form, the 74-series C sub-family was slow and had a very weak output-drive capability (its fan-out drive was equal to two L type inputs). In subsequent years, however, considerable improvements took place in both the design and production of CMOS-type devices. The salient details of this subject will be covered in greater detail in Part 4, but in the meantime, it is sufficient to know that a total of five CMOS sub-families have been introduced in the 74-series, as follows:

Standard (C) CMOS (now obsolete) — This sub-family was virtually normal CMOS in a 74-series format. Typically, a single 74C00 two-input NAND gate consumed about 15 mW at 10 MHz, and had a propagation delay of 60 nS.

High-Speed (HC) CMOS — In the early 1980s, advances in CMOS fabrication techniques yielded speed performances similar to LS TTL, but with CMOS levels of power consumption. HC 74-series devices using this technology have CMOS-compatible inputs. Typically, a single 74HC00 two-input NAND gate consumes less than 1µA of quiescent current, and has a propagation delay of 8 nS.

High-Speed (HCT) CMOS — These are HC-type devices, but have TTL compatible inputs. Typically, a 74HCT00 two-input NAND gate consumes less than 1µA of quiescent current and has a propagation delay of 18 nS.

Advanced High-Speed (AC) CMOS — In the late 1980s, advances in CMOS design and further advances in CMOS fabrication techniques yielded speed performance similar to those of ALS. AC 74-series devices using this technology have CMOS-compatible inputs. Typically, a 74AC00 two-input NAND gate has a propagation delay of 5 nS.

Advanced High-Speed (ACT) CMOS — These are AC-type devices, but have TTL-compatible inputs. Typically, a 74ACT00 two-input NAND gate has a propagation delay of 7 nS.

Which Logic Family is Best?

Two major general-purpose logic families are currently available: the 4000-series low-speed CMOS family and the high-speed 74-series TTL/CMOS family (a third family, using ECL technology, is very specialized and intended for use in very high-speed applications). The 4000-series (which will be described in Part 4) is of particular value in circuits operating below frequencies of a few MHz in which a minimal figure of quiescent current consumption is desired. Other major advantages of the series are that its ICs can operate from any supply in the 3 to 15 V range, have excellent noise immunity, and have ultra-high input impedances.

The 74-series is of special value in circuits operating at frequencies up to several tens of MHz, in which low quiescent current consumption is not too important and in which the ICs can be powered from a well-regulated DC supply (typically of +5 V). If you decide to use a 74-series IC, you are faced with the problem of deciding “which sub-family is best for my application?”

Which 74-Series Sub-Family is Best?

When designing a new logic circuit, ICs should always be selected on a basis of commercial (rather than purely technical) superiority. It would, for example, be foolish to use a really fast ALS gate in an application in which a slower LS or HC device would be perfectly adequate and was readily available at a fraction of the cost of the ALS device. With this point in mind, note that the five 74-series IC sub-families most widely available at the time of writing are Standard and LS TTL, and HC, HCT and AC CMOS. Of these, Standard TTL is technically and commercially inferior to LS and is not recommended for use in new designs. The AC CMOS cost approximately 2.5 times as much as LS TTL or HC/HCT CMOS and should thus only be used in special applications. HCT is only meant to be used as a replacement for TTL devices in existing designs and should not really be used in new designs. That leaves just LS TTL and HC CMOS.

Of these two 74-series sub-families, LS is slightly faster than HC and is available in a far greater range of functional device types, but generally consumes more supply current/power than HC at frequencies below about 5 MHz. (Figure 12 compares the performances of 74LS00 and 74HC00 gates.)

FIGURE 12. Frequency versus current/power graphs of 74LS00 and 74HC00 two-input NAND gates (with a square wave input).

Thus, for most new design applications, the LS TTL and HC CMOS sub-families deserve a joint ‘best’ award, with a slight edge perhaps going to LS.

TTL Logic Levels and Noise Immunity

All digital ICs handle input and output signals that switch between the high (logic-1) or low (logic-0) states. In TTL, each of these logic levels must fall within a defined range of voltage limits. Figure 13 shows the typical input-to-output voltage curve of a Standard TTL inverter that operates from a +5 V supply and has a lightly loaded output.

FIGURE 13. Standard-TTL input-to-output voltage graph.

Note that the output is high, at +3.5 V, until the input rises to 0.7 V, and then falls fairly linearly as the input is further increased, and eventually stabilizes at a low value of about 0.25 V when the input rises above 1.5 V.

In practice, all Standard and LS TTL ICs are — when using a +5 V supply — guaranteed to recognize any input voltage of up to 0.8 V as being a logic-0 input, and of 2.0 V or above as being a logic-1 input. Note that the area between these two levels is known as the IC’s indeterminate zone or region, and operation within this zone should be avoided.

In TTL circuitry, different logic levels are used to define input and output signals, since TTL output voltage levels vary considerably with loading conditions. Figure 14 shows how — when an input of 0.4 V is applied to the above TTL inverter — the logic-1 output voltage falls from +3.5 V at near-zero load current, to a mere 2.0 V at a load current of 13 mA, and so on.

FIGURE 14. Standard-TTL logic-1 output voltage-current graph.

In practice, all Standard TTL ICs are guaranteed (when using a +5 V supply) to recognize any output voltage of up to 0.4 V as being a logic-0 output, and of 2.4 V or above as being a logic-1 output. On LS TTL ICs, these levels are 0.5 V for logic-0, and 2.7 V for logic-1.

When one TTL output is connected directly to a following TTL input, any excessive noise on the output signal may cause incorrect operation of the following input stage. Thus, taking a worst-case situation, a logic-1 Standard TTL output may be as low as 2.4 V, and any superimposed negative-going noise pulse greater than 0.4 V will drive the following input below the 2.0 V ‘logic-0’ defined threshold and may cause it to erroneously recognize its input as being a logic-0 (rather than logic-1) signal.

The maximum worst-case magnitude of noise that a digital IC can ignore under these conditions is known as its noise immunity or noise margin value, and equals the difference between the logic-0 or logic-1 output/input threshold values. With Standard TTL, noise margins for both logic-1 (NM-H) and logic-0 (NM-L) have defined worst-case values of 400 mV. With LS TTL, the noise margins are 700 mV for logic-1, and 300 mV for logic-0. With CMOS, both margins have values of VDD/3. Figure 15 illustrates the values of these three sets of threshold and margin values.

FIGURE 15. Logic level and noise margin values of Standard TTL, LS TTL, and CMOS.

Figure 16 expands the above information and shows actual defined threshold voltage and noise margin values, together with typical propagation and power dissipation values for single 00-type two-input NAND gates, for the seven major sub-families of TTL (FAST TTL is regarded here as simply a minor variation of AS TTL).

FIGURE 16. Typical propagation delay and power dissipation figures for single 00-type NAND gates within the TTL sub-family ranges, together with sub-family voltage threshold and noise-margin values.

Fan-In and Fan-Out

In TTL circuitry, an element’s input drive requirements are known as its fan-in values, and its output driving capability limits are known as its fan-out values. Figure 17 illustrates the meanings and worst-case values of these items when applied to a Standard TTL element.

FIGURE 17. Basic input and output parameters of a Standard TTL logic element.

Thus, (a) shows that when the TTL element is driven from a Standard TTL output stage, it draws a worst-case input current (IIH) of 40µA when fed with a 2.4 V logic-1 input, but — as shown in (b) — feeds 1.6 mA (IIL) into the driver when it provides a 0.4 V logic-0 input. Diagram (c) shows that the TTL element’s output can, when in the logic-1 state, provide up to 400µA (IOH) before its output voltage falls below 2.4 V; it is thus capable of feeding up to 10 Standard inputs, and is said to have a logic-1 fan-out (= IOH/IIH) of 10.

Similarly, (d) shows that the output stage can — when in the logic-0 state — absorb up to 16 mA before its output voltage falls below 0.4 V; it is thus capable of driving up to 10 Standard inputs, and is said to have a logic-0 fan-out (= IOL/IIL) of 10. Thus, the element has a worst-case fan-out of 10, and it can be used to directly drive as many as 10 Standard inputs.

Figure 18 presents the above data in tabular form, together with similar data for all other major TTL sub-families.

FIGURE 18. Fan-in and fan-out values of the major TTL sub-families.

When working within any one sub-family, note that the most important figure here is the ‘worst case fan-out (F-O)’ value. Thus, if you are (for example) designing a system based entirely on LS ICs, you can confidently connect an ordinary output directly to as many as 20 normal inputs, without risk of a malfunction due to overloading (if you need to drive more than 20 inputs, you can do so via one or more high-fan-out buffers, etc.). Note that, within any given sub-family, all ordinary inputs are said (in TTL jargon) to have a fan-in of unity (1), but that in practice some MSI or LSI ICs (such as counters and registers, etc.) may have special inputs (such as Reset or Preset, etc.) with fan-in values of two or greater.

Sometimes, an engineer may have to mix TTL sub-families, usually so that an obsolete IC can be replaced by a readily-available modern plug-in close-equivalent. In such a case, it is necessary to relate the fan-out data of one sub-family to that of another, to check that the mix can be made without causing an input or output overload. One easy way of doing this is to simply transpose the data of Figure 18 into ‘Standard TTL’ fan-in units, as shown in Figure 19, to gain an approximate idea of the relative fan values of various sub-families. Thus, it can be seen at a glance that LS TTL has only half of the fan-in requirement of Standard TTL, but also has only half of its fan-out capability, etc.

FIGURE 19. TTL fan-in and fan-out in terms of Standard TTL units.

An even more useful way of applying the basic data of Figure 18 is to convert it into an easily-used form that relates the fan-in and fan-out data of each TTL sub-family to all other TTL sub-families, as shown in Figure 20.

FIGURE 20. Maximum number of TTL inputs that may be driven from any TTL sub-family output.

Here, by reading across the left-hand columns, it can (for example) be seen that a normal LS output can drive up to five Standard TTL inputs, and that a Standard TTL output can safely drive up to 20 LS inputs.

Thus, if an engineer is faced with a problem such as that illustrated in Figure 21 — in which a fault on an old Standard TTL circuit is traced to a defective 74XXX-type IC (IC2) which is used to directly drive four other Standard TTL inputs — it can be quickly seen that a 74LSXXX plug-in equivalent IC can be safely used to directly replace the IC2 Standard TTL device without incurring overload problems.

FIGURE 21. IC2 is defective; it is a Standard TTL device. Can it be replaced directly by a 74LSXXX IC? Figure 20 shows that the answer is yes.

TTL Basic Usage Rules

It is usually a fairly easy matter to design logic circuitry using TTL ICs, providing that a set of TTL basic usage rules are observed. Assuming that the matter of fan-in and fan-out has already been taken care of, there are four basic usage themes outstanding, and these will be described in our next installment, under the general headings of Power Supplies, Input Signals, Unused Inputs, and Interfacing. NV

Vu dans ... http://www.nutsvolts.com/magazine

text | .gif


Vu dans ... http://www.allaboutcircuits.com/textbook/digital/

Logic Signal Voltage Levels

Chapter 3 - Logic Gates

Logic gate circuits are designed to input and output only two types of signals: “high” (1) and “low” (0), as represented by a variable voltage: full power supply voltage for a “high” state and zero voltage for a “low” state. In a perfect world, all logic circuit signals would exist at these extreme voltage limits, and never deviate from them (i.e., less than full voltage for a “high,” or more than zero voltage for a “low”). However, in reality, logic signal voltage levels rarely attain these perfect limits due to stray voltage drops in the transistor circuitry, and so we must understand the signal level limitations of gate circuits as they try to interpret signal voltages lying somewhere between full supply voltage and zero.

TTL gates operate on a nominal power supply voltage of 5 volts, +/- 0.25 volts. Ideally, a TTL “high” signal would be 5.00 volts exactly, and a TTL “low” signal 0.00 volts exactly. However, real TTL gate circuits cannot output such perfect voltage levels, and are designed to accept “high” and “low” signals deviating substantially from these ideal values. “Acceptable” input signal voltages range from 0 volts to 0.8 volts for a “low” logic state, and 2 volts to 5 volts for a “high” logic state. “Acceptable” output signal voltages (voltage levels guaranteed by the gate manufacturer over a specified range of load conditions) range from 0 volts to 0.5 volts for a “low” logic state, and 2.7 volts to 5 volts for a “high” logic state:

If a voltage signal ranging between 0.8 volts and 2 volts were to be sent into the input of a TTL gate, there would be no certain response from the gate. Such a signal would be considered uncertain, and no logic gate manufacturer would guarantee how their gate circuit would interpret such a signal.

As you can see, the tolerable ranges for output signal levels are narrower than for input signal levels, to ensure that any TTL gate outputting a digital signal into the input of another TTL gate will transmit voltages acceptable to the receiving gate. The difference between the tolerable output and input ranges is called the noise margin of the gate. For TTL gates, the low-level noise margin is the difference between 0.8 volts and 0.5 volts (0.3 volts), while the high-level noise margin is the difference between 2.7 volts and 2 volts (0.7 volts). Simply put, the noise margin is the peak amount of spurious or “noise” voltage that may be superimposed on a weak gate output voltage signal before the receiving gate might interpret it wrongly:

CMOS gate circuits have input and output signal specifications that are quite different from TTL. For a CMOS gate operating at a power supply voltage of 5 volts, the acceptable input signal voltages range from 0 volts to 1.5 volts for a “low” logic state, and 3.5 volts to 5 volts for a “high” logic state. “Acceptable” output signal voltages (voltage levels guaranteed by the gate manufacturer over a specified range of load conditions) range from 0 volts to 0.05 volts for a “low” logic state, and 4.95 volts to 5 volts for a “high” logic state:

It should be obvious from these figures that CMOS gate circuits have far greater noise margins than TTL: 1.45 volts for CMOS low-level and high-level margins, versus a maximum of 0.7 volts for TTL. In other words, CMOS circuits can tolerate over twice the amount of superimposed “noise” voltage on their input lines before signal interpretation errors will result.

CMOS noise margins widen even further with higher operating voltages. Unlike TTL, which is restricted to a power supply voltage of 5 volts, CMOS may be powered by voltages as high as 15 volts (some CMOS circuits as high as 18 volts). Shown here are the acceptable “high” and “low” states, for both input and output, of CMOS integrated circuits operating at 10 volts and 15 volts, respectively:

The margins for acceptable “high” and “low” signals may be greater than what is shown in the previous illustrations. What is shown represents “worst-case” input signal performance, based on manufacturer’s specifications. In practice, it may be found that a gate circuit will tolerate “high” signals of considerably less voltage and “low” signals of considerably greater voltage than those specified here.

Conversely, the extremely small output margins shown—guaranteeing output states for “high” and “low” signals to within 0.05 volts of the power supply “rails”—are optimistic. Such “solid” output voltage levels will be true only for conditions of minimum loading. If the gate is sourcing or sinking substantial current to a load, the output voltage will not be able to maintain these optimum levels, due to internal channel resistance of the gate’s final output MOSFETs.

Within the “uncertain” range for any gate input, there will be some point of demarcation dividing the gate’s actual “low” input signal range from its actual “high” input signal range. That is, somewhere between the lowest “high” signal voltage level and the highest “low” signal voltage level guaranteed by the gate manufacturer, there is a threshold voltage at which the gate will actually switch its interpretation of a signal from “low” or “high” or vice versa. For most gate circuits, this unspecified voltage is a single point:

In the presence of AC “noise” voltage superimposed on the DC input signal, a single threshold point at which the gate alters its interpretation of logic level will result in an erratic output:

If this scenario looks familiar to you, its because you remember a similar problem with (analog) voltage comparator op-amp circuits. With a single threshold point at which an input causes the output to switch between “high” and “low” states, the presence of significant noise will cause erratic changes in the output:

The solution to this problem is a bit of positive feedback introduced into the amplifier circuit. With an op-amp, this is done by connecting the output back around to the noninverting (+) input through a resistor. In a gate circuit, this entails redesigning the internal gate circuitry, establishing the feedback inside the gate package rather than through external connections. A gate so designed is called a Schmitt trigger. Schmitt triggers interpret varying input voltages according to two threshold voltages: a positive-going threshold (VT+), and a negative-going threshold (VT-):

Schmitt trigger gates are distinguished in schematic diagrams by the small “hysteresis” symbol drawn within them, reminiscent of the B-H curve for a ferromagnetic material. Hysteresis engendered by positive feedback within the gate circuitry adds an additional level of noise immunity to the gate’s performance. Schmitt trigger gates are frequently used in applications where noise is expected on the input signal line(s), and/or where an erratic output would be very detrimental to system performance.

The differing voltage level requirements of TTL and CMOS technology present problems when the two types of gates are used in the same system. Although operating CMOS gates on the same 5.00 volt power supply voltage required by the TTL gates is no problem, TTL output voltage levels will not be compatible with CMOS input voltage requirements.

Take for instance a TTL NAND gate outputting a signal into the input of a CMOS inverter gate. Both gates are powered by the same 5.00 volt supply (Vcc). If the TTL gate outputs a “low” signal (guaranteed to be between 0 volts and 0.5 volts), it will be properly interpreted by the CMOS gate’s input as a “low” (expecting a voltage between 0 volts and 1.5 volts):

However, if the TTL gate outputs a “high” signal (guaranteed to be between 5 volts and 2.7 volts), it might not be properly interpreted by the CMOS gate’s input as a “high” (expecting a voltage between 5 volts and 3.5 volts):

Given this mismatch, it is entirely possible for the TTL gate to output a valid “high” signal (valid, that is, according to the standards for TTL) that lies within the “uncertain” range for the CMOS input, and may be (falsely) interpreted as a “low” by the receiving gate. An easy “fix” for this problem is to augment the TTL gate’s “high” signal voltage level by means of a pullup resistor:

Something more than this, though, is required to interface a TTL output with a CMOS input, if the receiving CMOS gate is powered by a greater power supply voltage:

There will be no problem with the CMOS gate interpreting the TTL gate’s “low” output, of course, but a “high” signal from the TTL gate is another matter entirely. The guaranteed output voltage range of 2.7 volts to 5 volts from the TTL gate output is nowhere near the CMOS gate’s acceptable range of 7 volts to 10 volts for a “high” signal. If we use an open-collector TTL gate instead of a totem-pole output gate, though, a pullup resistor to the 10 volt Vdd supply rail will raise the TTL gate’s “high” output voltage to the full power supply voltage supplying the CMOS gate. Since an open-collector gate can only sink current, not source current, the “high” state voltage level is entirely determined by the power supply to which the pullup resistor is attached, thus neatly solving the mismatch problem:

Due to the excellent output voltage characteristics of CMOS gates, there is typically no problem connecting a CMOS output to a TTL input. The only significant issue is the current loading presented by the TTL inputs, since the CMOS output must sink current for each of the TTL inputs while in the “low” state.

When the CMOS gate in question is powered by a voltage source in excess of 5 volts (Vcc), though, a problem will result. The “high” output state of the CMOS gate, being greater than 5 volts, will exceed the TTL gate’s acceptable input limits for a “high” signal. A solution to this problem is to create an “open-collector” inverter circuit using a discrete NPN transistor, and use it to interface the two gates together:

The “Rpullup” resistor is optional, since TTL inputs automatically assume a “high” state when left floating, which is what will happen when the CMOS gate output is “low” and the transistor cuts off. Of course, one very important consequence of implementing this solution is the logical inversion created by the transistor: when the CMOS gate outputs a “low” signal, the TTL gate sees a “high” input; and when the CMOS gate outputs a “high” signal, the transistor saturates and the TTL gate sees a “low” input. So long as this inversion is accounted for in the logical scheme of the system, all will be well.


Circuits intégrés logiques CMOS 26/09/2000 Patrick ABATI
Liste des cours

CMOS = Complementary Metal Oxyde Semiconductor

Ces circuits sont réalisés à partir de transistors à effet de champ de type MOS. Ils sont plus faciles à fabriquer que les circuits de type TTL, permettent une plus grande intégration à grande échelle. Leur principal inconvénient est leur vitesse de fonctionnement relativement faible par rapport à celle de la famille bipolaire

Transistor MOS

Fonctionnement

si Vgs = 0v, Rds = exp omega = Rds(off), le transistor est bloqué
si Vgs = +5v, Rds = 1000 omega = Rds(on), le transistor est passant

si Vgs = +5v, Rds = exp omega = Rds(off), le transistor est bloqué
si Vgs = 0v, Rds = 1000 omega = Rds(on), le transistor est passant

La technologie MOS complémentaires réunit sur le même cristal de silicium, des transistors à canal P et à canal N

Caractéristique de transfert d'un inverseur CMOS

La commutation se fait à VTR » VDD / 2

Les entrées CMOS ont une résistance très grande exp omega qui ne tire pratiquement aucun courant. Cependant il existe une capacité d'entrée de l'ordre de 5pF qui augmente sensiblement la consommation en régime dynamique et limite la fréquence de fonctionnement

Caractéristiques électriques | - | Minimum | Maximum
Tension d'alimentation | VDD | 3v | 18v
Tension de sortie à l'état haut | VOH | » VDD | -
Tension de sortie à l'état bas | VOL | - | » 0v
Tension d'entrée à l'état haut | VIH | 70% VDD | -
Tension d'entrée à l'état bas | VIL | - | 30% VDD
Consommation en régime continu | - | - | 2,5 nW (à VDD=5v)
Consommation à 1 MHz | - | - | 1 mW

Entrées inutilisées
Les entrées CMOS ne doivent jamais rester non branchées, mais raccordées au 0v, au VDD, à une autre entrée utilisée ou mises à la masse ou à VDD à travers une résistance. En effet, une entrée non connectée capte les signaux parasites, ce qui peut se traduire par une plus grande consommation et une surchauffe importante

Marge de sensibilité aux bruits
Elle dépend de VDD (30% VDD). Elle est d'autant plus élevée que VDD est important (1,5v pour VDD=5v, 4,5v pour VDD=15v)

Interfaçage avec les circuits TTL

CMOS piloté par TTL : la sortie TTL délivre une tension VOH très proche de VIH(min) de l'entrée CMOS. Il est donc préférable de relever le potentiel de la sortie TTL. La solution la plus simple consiste à utiliser une résistance de rappel à la source Rp = 1K omega à 10K omega

TTL piloté par CMOS : Il n'y a aucun problème dans le cas où une seule charge TTL-LS est pilotée par une sortie CMOS. Dans les autres cas, il faut recourir à des interfaçages plus complexes

Comparaison des circuits CMOS et TTL
A l'origine, les circuits CMOS étaient moins rapides que les circuits TTL mais ils avaient une consommation beaucoup moins importante. A l'heure actuelle, ces différences tendent à s'estomper puisqu'on fabrique des TTL à faible consommation et des CMOS rapides

Voir aussi : circuits intégrés logiques TTL


[Technologie] TTL et CMOS - Electronique - Tutoriels - Robot Maker

Vu dans ... http://www.robot-maker.com/forum/tutorials/article/

[Technologie] TTL et CMOS - Electronique

La famille TTL :

TTL est l'abréviation de ''Transistor-Transistor Logic''. Elle a été inventée en 1960. Cette famille est réalisée avec des transistors bipolaires. (De nos jours, la technologie TTL tend à être remplacée par la technologie CMOS).

Les avantages de cette famille :
  • Les entrées laissées en 'l'air' ont un état logique à 1 par défaut.
  • Une bonne immunité au bruit.
  • Un temps de propagation faible.
Les inconvénients de cette famille :
  • L'alimentation doit être précise à 5V +/- 5 % sinon on risque de détruire le circuit.
  • Du fait qu'elle est réalisée avec des transistors bipolaires elle consomme pas mal de courant comparer à la famille CMOS. (Car les transistors bipolaires sont commandés en courant).
Le nom des circuits de cette famille commencent par 74 suivi d'une ou plusieurs lettres représentant la série et suivi d'un code à 2 ou 3 chiffres représentant le modèle du circuit.

Exemple : le circuit 74LS08 (porte ET).

Les lettres au milieu du nom représente donc la série. On décline plusieurs séries :
74xx : série standard.
74Lxx : série faible consommation.
74Sxx, 74ASxx, 74ALSxx 74Fxx, 74AFxx : série rapide.
74LSxx : mélange des technologies L et S, c'est une des séries la plus répandue.

Il existe aussi des séries 74HCxx et 74HCTxx qui est le résultat d'une combinaison de la technologie TTL et CMOS afin d'ajouter leurs avantages.

La famille CMOS :

CMOS est l'abréviation de ''Complementary Metal Oxide Semi-conductor''. Le premier dispositif MOS est apparu en 1960. Son développement a été rendu possible par les progrès réaliser par la technologie TTL. Cette famille est réalisée avec des transistors à effet de champs.

Les avantages de cette famille :
  • L'alimentation peut aller de 3V à 18V.
  • Le courant d'entrée est nul, car elle est réalisée avec des transistors à effet de champs. (Les transistors à effet de champs sont commandés en tension).
  • Une excellente immunité au bruit.
Les inconvénients de cette famille :
  • La vitesse de commutation est plus faible que pour la technologie TTL.
Le nom des circuits de cette famille commencent par 40 suivi de deux chiffres représentant le modèle du circuit.

Exemple : le circuit 4081 (porte ET).
Prochain chapitre : Alimentation.
4Aklisme

Alimentation

Circuit TTL :
L'alimentation doit être continue et stable de 5V à +/- 5 %.

Circuit CMOS :
On a un choix d'alimentation plus large de 3V à 18V. Mais en faible alimentation, les performances dynamiques sont moins bonnes. (Certaines séries peuvent maintenant être alimenté à moins de 3V...)
Image IPB Prochain chapitre : Niveaux d'entrée et de sortie.

4Aklisme

Niveaux d'entrée et de sortie

Une fonction TTL reçoit une tension de 5V sur une de ses entrées. Elle la traduit en un état logique haut, c'est-à-dire un '1' logique. Imaginons maintenant qu'elle reçoit 4,7V à cause des parasites. Comment va telle traduire cette information ?

C'est pour cela que les entrées et les sorties des fonctions logiques ont des marges pour qualifier un état logique :
Image IPB
(VCC = tension d'alimentation)

Technologie TTL : (VCC = 5V)
Image IPB
Image IPB
Image IPB
Image IPB

Technologie CMOS : (dépend de VCC)
Image IPB
Image IPB
Image IPB
Image IPB

Exemple : Si une fonction TTL reçoit une tension d'entrée comprise entre 5V et 2V celle-ci sera considérée comme un état logique haut. Si elle reçoit une tension d'entrée entre 0V et 0,8V elle la considèrera comme un état logique bas. Entre 2V et 0,8V l'état sera aléatoire.

Prochain chapitre : Courant d'entrée et de sortie.
4Aklisme

Courant d'entrée et de sortie

1- En TTL :

Les circuits TTL étant réalisés à l'aide de transistors bipolaires NPN ou PNP, la commande se fait par l'intermédiaire du courant de base, donc le courant d'entrée des opérateurs TTL est différent de 0.

Courant d'entrée :
A l'état bas une entrée TTL a besoin d'un courant sortant maxi de 1,6mA.
A l'état haut une entrée TTL a besoin d'un d'un courant entrant maxi de 40µA.

Courant de sortie :
A l'état bas une sortie TTL peut absorber un courant maxi de 16mA.
A l'état haut une sortie TTL peut délivrer un courant maxi de 400µA.

On voit qu'une sortie TTL peut commander 10 entrées TTL.

2- En CMOS :

Les circuits CMOS étant réalisés à l'aide de transistors à effet de champs, la commande se fait par une tension, donc le courant d'entrée des opérateurs CMOS est quasi nul.

Courant d'entrée :
Inférieur à 1µA.

Courant de sortie :
Une sortie peut fournir jusqu'à plus de 1mA selon les modèles.
Prochain chapitre : Types de sorties.
4Aklisme

Types de sorties

Certain circuit on une sortie spéciale dite à ''collecteur ouvert'' qui permet des commandes sur des charges reliées à une alimentation de tension supérieure à l'alimentation du circuit. Pour savoir si un circuit est à sortie à collecteur ouvert il suffit de regarder dans la documentation technique du constructeur. On trouve ce symbole sur les portes logiques :
Image IPB

'Sortie à collecteur ouvert' veut dire que la sortie du circuit est composée d'un transistor dont la borne du collecteur est en ''l'air'' :
Image IPB

Il faut donc prévoir des composants externes permettant la polarisation du transistor.
On câblera donc la sortie de cette manière :
Image IPB

Ainsi avec notre sortie à collecteur ouvert (TTL) on peut avoir une commande en 12V. (sans collecteur ouvert on aurait eu une commande en 5V).
Prochain chapitre : Tableau récapitulatif et exemples de nom de CI.
4Aklisme

Tableau récapitulatif et exemples de nom de CI

VI- a : Tableau récapitulatif :

Image IPB

VI- b : Exemples de nom de CI :

Technologie TTL :

7400 -> Quadruple porte NON - ET à 2 entrées
7402 -> Quadruple porte NON - OU à 2 entrées
7404 -> 6 portes inverseuses
7408 -> Quadruple porte ET à 2 entrées
7413 -> Double porte NON - ET à 4 entrées
7420 -> Double porte NON - ET à 4 entrées
7428 -> Quadruple porte NOR à 2 entrées
7430 -> Porte NON - ET à 8 entrées
7442 -> Décodeur décimal BCD
7448 -> Décodeur BCD 7 segments
7470 -> Flip-Flop JK à 2 x 3 entrées
7482 -> Additionneur complet à 2 bits
7486 -> Quadruple porte OU Exclusif
7493 -> Compteur binaire
74121 -> Monostable
Etc ...

Technologie CMOS :

4001 -> Quadruple porte NON - OU à 2 entrées
4008 -> Additionneur 4 bits avec retenue
4011 -> Quadruple porte NON - ET
4016 -> Quadruple interrupteur bidirectionnel
4023 -> Triple porte NON - ET à 3 entrées
4030 -> Quadruple porte OU – EXCLUSIF
4047 -> Monostable
4054 -> Driver pour afficheur 4 segments LCD
4068 -> Porte NON - ET à 8 entrées
4070 -> Quadruple porte OU – EXCLUSIF
4071 -> Quadruple porte OU à 2 entrées
4081 -> Quadruple porte ET à 2 entrées
4098 -> Double monostable re-déclenchable
4518 -> Double compteur décimal
4721 -> Mémoire vive 1 024 bits (256 x 4)
40195 -> Registre à décalage universel 4 bits
Etc...


Électronique/Les familles MOS : PMOS, NOMS et CMOS — Wikilivres

Électronique/Les familles MOS : PMOS, NOMS et CMOS

Un livre de Wikilivres.

Les portes logiques vues dans le chapitre précédent sont fabriquées en utilisant des transistors. Il existe de nombreuses manières pour concevoir des circuits à base de transistors, auxquelles on a donné le nom de familles logiques.. les plus connues portent les noms de DTL, RTL, TLL, CMOS et bien d'autre. En voici la liste et une description sommaire :

  • Les logiques MOS (Metal Oxyde Silicium) utilisent des transistors à effet de champ, parfois couplés à des résistances. On distingue :
    • La logique NMOS, qui utilise des transistors NMOS associés à des résistances.
    • La logique PMOS, qui utilise des transistors PMOS associés à des résistances.
    • La logique CMOS, qui utilise des transistors PMOS et NMOS, sans résistances associées.
  • Les autres logiques utilisent des transistors bipolaires et/ou des diodes
    • La logique à diodes n'utilise que des diodes pour fabriquer des portes logiques ;
    • La logique RTL (Resistance-Transistor Logic) utilise des résistances couplées à des transistors bipolaires ;
    • La logique DTL (Diode-Transistor Logic) utilise des diodes couplées à des transistors bipolaires ;
    • La logique TTL (Transistor-Transistor Logic) utilise uniquement des transistors bipolaires ;

Ce chapitre aborde les familles logiques qui utilisent des transistors à effet de champ. Il s'agit des technologies MOS, PMOS, NMOS et CMOS.

Sections

  • 1 La technologie NMOS
    • 1.1 La porte NON
    • 1.2 La porte NOR
    • 1.3 La porte NAND
  • 2 La technologie PMOS
  • 3 La technologie CMOS
    • 3.1 La porte NON
    • 3.2 La porte NAND
    • 3.3 La porte NOR
    • 3.4 Portes XOR et NXOR
  • 4 Les avantages et inconvénients respectifs du NMOS, PMOS et CMOS

La technologie NMOS

Nous allons commencer avec la technologie NMOS, mais les circuits PMOS sont relativement similaires. Ceux-ci sont fabriqués avec des transistors MOS intercalés avec une résistance, qui relie directement la tension d'alimentation à la sortie.

Circuit en logique NMOS.

Leur fonctionnement est assez facile à expliquer. Quand la sortie doit être à 1, tous les transistors sont ouverts. Il n'y a pas de chemin qui relie la sortie à la masse. Par contre, la sortie est connectée à la tension d'alimentation, ce qui fait qu'elle est mise à 1. On place une résistance entre la tension d'alimentation et la sortie pour éviter que le courant qui la traverse soit trop fort dans cette situation. Quand la sortie doit être à 0, il y a au moins un transistor NMOS qui se ferme. Mais si un transistor NMOS se ferme et connecte l'alimentation à la masse, les choses changent. Les lois compliquées de l'électricité nous disent alors que la sortie est connectée à la masse, soit au zéro volts. Elle est donc mise à 0.

Fonctionnement d'un circuit en technologie NMOS.

Voici les circuits obtenus :

Les portes de base, utilisées pour fabriquer toutes les autres, sont les portes NON, NAND et NOR. Les portes ET et OU sont fabriqués en plaçant une porte NON à la suite d'une porte ET/OU.

La porte NON

Le circuit d'une porte NON en technologie NMOS est illustré ci-dessous. Le principe de ce circuit est assez simple : l'étude de seulement deux cas permet de le comprendre en détail. Si on envoie un 0 sur la grille du transistor, celui-ci s'ouvre et la sortie est reliée à la tension d'alimentation. A l'inverse, quand on met un 1 sur la grille, le transistor se ferme et la sortie est reliée à la masse, mise à 0. Le résultat est bien un circuit inverseur.

Porte NON NMOS. Porte NON NMOS : fonctionnement.

La porte NOR

La porte NOR est similaire à la porte NON, si ce n'est qu'il y a maintenant deux transistors en parallèles. Si une des grilles est mise à 1, un des transistors se fermera et la sortie est mise à 0. Par contre, quand les deux entrées sont à 0, les transistors s'ouvrent tous deux et la sortie est mise à 1. Le comportement obtenu est bien celui d'une NOR.

NMOS-NOR-gate Fonctionnement d'une porte NOR NMOS.

La porte NAND

La porte NAND fonctionne sur un principe similaire au précédent, si ce n'est qu'il faut que les deux grilles soient à zéro pour obtenir une sortie à 1. Pour mettre la sortie à 0 quand seulement les deux transistors sont ouverts, il suffit de les mettre en série, comme dans le schéma ci-dessous. Le circuit obtenu est bien une porte NAND.

NMOS-NAND-gate
Funktionsprinzip eines NAND-Gatters

Il existe des variantes de la porte précédente, où la résistance est remplacée par un générateur de courant, fabriqué avec des transistors NMOS.

Variantes de la porte NAND NMOS de base
Nmos enhancement non-saturated nand Nmos enhancement saturated nand

La technologie PMOS

Les circuits en technologie PMOS ressemblent beaucoup aux circuits en technologie NMOS, si ce n'est qu'ils sont inversés. Rien d'étonnant à cela, les deux types de transistors, PMOS et NMOS, ayant un fonctionnement inverse. Là encore, les circuits PMOS sont construits d'une manière assez similaire aux circuits CMOS, si ce n'est que les transistors NMOS sont remplacés par une résistance qui relie ici la masse à la sortie.

PMOS NOT PMOS NAND corr PMOS NOR corr

Il est aussi possible de câbler les portes logiques autrement, en remplaçant les transistors NMOS d'un circuit NMOS par des PMOS. Mais dans ce cas, la tensions liée à la résistance doit être négative, égale à l'opposé de la tension d’alimentation.

PMOS NOT PMOS NAND corr PMOS NOR corr

La technologie CMOS

Dans cette section, nous allons montrer comment fabriquer des portes logiques en utilisant la technologie CMOS. Avec celle-ci, chaque porte logique est fabriquée à la fois avec des transistors NMOS et des transistors PMOS. On peut la voir comme un mélange entre la technologie PMOS et NMOS. Tout circuit CMOS est divisé en deux parties : une intégralement composée de transistors PMOS et une autre de transistors NMOS. Chacune relie la sortie du circuit soit à la masse, soit à la tension d'alimentation.

Principe de conception d'une porte logique/d'un circuit en technologie CMOS.

La première partie relie la tension d'alimentation à la sortie, mais uniquement quand la sortie doit être à 1. Si la sortie doit être à 1, des transistors PMOS vont se fermer et connecter tension et sortie. Dans le cas contraire, des transistors s'ouvrent et cela déconnecte la liaison entre sortie et tension d'alimentation. L'autre partie du circuit fonctionne de la même manière que la partie de PMOS, sauf qu'elle relie la sortie à la masse et qu'elle se ferme quand la sortie doit être mise à 0

Fonctionnement d'un circuit en logique CMOS.

La porte NON

Cette porte est fabriquée avec seulement deux transistors, comme indiqué ci-dessous.

Porte NON fabriquée avec des transistors CMOS.

Si on met un 1 en entrée de ce circuit, le transistor du haut va fonctionner comme un interrupteur ouvert, et celui du bas comme un interrupteur fermé : la sortie est reliée au zéro volt, et vaut donc 0. Inversement, si on met un 0 en entrée de ce petit montage électronique, le transistor du bas va fonctionner comme un interrupteur ouvert, et celui du haut comme un interrupteur fermé : la sortie est reliée à la tension d'alimentation, et vaut donc 1.

Porte NON fabriquée avec des transistors CMOS - fonctionnement.

La porte NAND

Voici en exclusivité comment créer une porte NAND à deux entrées avec des transistors CMOS !

Porte NAND fabriquée avec des transistors.
Porte NAND fabriquée avec des transistors.

La porte NOR

Implémenter une porte NOR à deux entrées avec des transistors CMOS ressemble à ce qu'on a fait pour la porte NAND.

Porte NOR fabriquée avec des transistors.
Porte NOR fabriquée avec des transistors.

Portes XOR et NXOR

Il est possible de créer une porte XOR en combinant d'autres portes logiques. Il est notamment possible de la concevoir en utilisant uniquement des portes NOR ou des portes NAND. On peut cependant simplifier le circuit en remplaçant certaines portes NOR ou NAND par des inverseurs ou des portes ET/OU.

Circuits équivalents à une porte en CMOS
CmosXORGate | CMOS6TrXOR
CMOS XOR Gate | Cmos xor

Les avantages et inconvénients respectifs du NMOS, PMOS et CMOS

De nos jours, la quai-totalité des circuits électroniques est basé sur une technologie CMOS, les technologies NMOS et PMOS étant quasiment abandonnées. Les raisons à cela sont multiples, chaque technologie ayant des avantages et des inconvénients divers. L'avantage principal du CMOS sur les autres technologies tient surtout à sa faible consommation en énergie. Pour comprendre pourquoi le CMOS consomme moins, reprenons les schémas précédent pour une porte NON (les raisonnements que nous allons suivre valent pour toutes les portes logiques, mais sont plus simples avec une porte NON).

Avec les technologies NMOS et PMOS, la sortie est reliée à la tension VDD par une résistance. Quand la sortie est à 1, le courant passe dans la résistance, ce qui fait qu'une puissance égale à [image] est dissipée par la résistance. Il s'agit d'une perte sèche d'énergie, une consommation d'énergie inutile. Vu que cette perte continue tant que la sortie est maintenue à 1, on lui donne le nom de consommation statique. Par contre, les circuits CMOS n'ont pas de résistances, mais uniquement des transistors, ce qui fait qu'il n'y a pas de dissipation statique de puissance.

Cela ne signifie pas qu'il n'y a pas de consommation d'énergie dans les transistors. Par exemple, ils dissipent un peu d'énergie quand on les fait passer de l'état bloqué à passant (ou inversement). Mais cette consommation d'énergie n'a pas lieu en permanence, tant que la sortie est maintenue. Il faut au contraire que la sortie change de valeur pour que de l'énergie soit dissipée, raison pour laquelle cette consommation d'énergie est appelée la consommation dynamique. Elle est présente dans les circuits CMOS, mais aussi dans les NMOS et les PMOS, qui sont à égalité de ce point de vue. Pour résumer, si tous les circuits ont une dissipation d'énergie d'origine dynamique, les CMOS n'ont pas de consommation statique, ce qui leur donne un avantage en terme de consommation d'électricité.


Fonction logique — Wikipédia

De la roue dentée à la molécule[ | ]

Charles Babbage, vers 1837, conçut la « machine analytique », assemblage de portes reliées à des roues dentées pour effectuer des opérations logiques. Par la suite, les opérations logiques furent effectuées grâce à des relais électromagnétiques.

En 1891, Almon Strowger déposa un brevet pour un appareil contenant un commutateur basé sur une porte logique ((en) Brevet U.S. 0447918 [archive]). Son invention ne fut guère exploitée jusque dans les années 1920. À partir de 1898, Nikola Tesla déposa une série de brevets concernant des appareils basés sur des circuits à portes logiques. Finalement, les tubes à vides remplacèrent les relais pour les opérations logiques. En 1907, Lee De Forest modifia l'un de ces tubes et l'utilisa comme une porte logique ET. Claude E. Shannon introduisit l'utilisation de l'algèbre de Boole dans la conception de circuits en 1937. Walther Bothe, inventeur du circuit de coïncidence, reçut le prix Nobel de physique en 1954, pour la création de la première porte logique ET électronique moderne en 1924. Des travaux de recherche sont actuellement menés pour la génération de portes logiques moléculaires.

Les portes logiques à transistors[ | ]

La forme la plus simple de la logique électronique est la logique à diodes. Cela permet la fabrication de portes ET et OU, mais pas de portes NON ce qui conduit à une logique incomplète. Pour créer un système logique complet, il est nécessaire d'utiliser des lampes ou des transistors.

La famille la plus simple de portes logiques utilisant des transistors bipolaires est appelée résistance-transistor ou RTL (resistor-transistor logic). Au contraire des portes à diodes, les portes RTL peuvent être mises en cascade indéfiniment pour produire des fonctions logiques complexes. Pour diminuer le temps de retard, les résistances utilisées par les portes RTL furent remplacées par des diodes, ce qui donna naissance aux portes logiques diode-transistor ou DTL (diode-transistor logic). On découvrit ensuite qu'un transistor pouvait faire le travail de deux diodes en prenant la place d'une seule, ce qui mena à la création de portes logiques transistor-transistor ou TTL (transistor-transistor logic). Dans certains types de circuits, les transistors bipolaires furent remplacés par des transistors à effet de champ (MOSFET) ce qui donna naissance à la logique CMOS.

Circuit intégré 7400 contenant 4 portes NON-ET (NAND). Les deux autres broches servent à l'alimentation 0V / 5V.

Les concepteurs de circuits logiques utilisent actuellement des circuits intégrés préfabriqués, notamment en TTL, la série 7400 de Texas Instruments, et en CMOS, la série 4000 de RCA, ainsi que leurs dérivés plus récents. La plupart de ces circuits contiennent des transistors à plusieurs émetteurs, utilisés pour implémenter la fonction ET, et qui ne sont pas disponibles séparément. De plus en plus, ces circuits logiques fixes sont remplacés par des circuits programmables, qui permettent aux concepteurs d'intégrer un grand nombre de portes logiques diverses dans un seul circuit intégré. La nature programmable de ces circuits, parmi lesquels les FPGA, a enlevé au hardware son aspect "dur" : il est désormais possible de changer les fonctions logiques d'un système en reprogrammant certains de ses composants, ce qui permet de modifier les caractéristiques d'un circuit logique hardware.

Les portes logiques électroniques diffèrent de manière significative de leurs équivalents à relais et contacts. Elles sont bien plus rapides, moins gourmandes et beaucoup plus petites (au moins un million de fois dans la plupart des cas). De plus, il y a une différence fondamentale dans la structure. Les circuits à contacts créent un chemin continu, dans lequel le courant peut circuler dans les deux directions entre l'entrée et la sortie. La porte logique à semi-conducteurs, au contraire, agit comme un amplificateur de tension, qui reçoit un signal en entrée et produit une tension de basse impédance en sortie. Le courant ne peut pas circuler entre la sortie et l'entrée d'une porte à semi-conducteurs[pourquoi ?].

Un autre grand avantage des circuits logiques standardisés est qu'ils peuvent être mis en cascade. Autrement dit, la sortie d'une porte peut être reliée aux entrées d'une ou plusieurs portes, et ainsi de suite à l'infini, ce qui permet de construire des circuits d'une complexité quelconque sans avoir besoin de connaître le fonctionnement interne des portes. Dans la pratique, la sortie d'une porte ne peut être connectée qu'à un nombre fini d'entrées, mais cette limite est rarement atteinte dans les nouveaux circuits CMOS comparé aux circuits TTL. Il existe également un délai nommé temps de propagation entre la modification d'une entrée et la modification correspondante en sortie. Dans des portes en cascade, le temps de propagation total est à peu près égal à la somme des temps de propagation individuels, ce qui peut poser problème dans les circuits à grande vitesse.

Portes logiques à 3 états[ | ]

Article détaillé : Porte à trois états.

Les portes logiques dites « à trois états » possèdent une sortie qui peut prendre trois états différents : haut, bas comme sur tout autre circuit logique et un troisième état haute impédance nommé Z. L'état de haute impédance ne joue aucun rôle dans la logique proprement dite qui demeure binaire, mais il équivaut en fait à un circuit ouvert, ou à une « absence » de sortie. Cet état permet de ne pas "polluer" la valeur circulant sur le bus de données auquel il est connecté, lorsque ce circuit ne doit pas en changer l’état.

Ces portes sont utilisées dans les bus informatiques afin de choisir l’émetteur et le récepteur des données circulant sur le bus ; un groupe de portes à trois états contrôlées par un circuit approprié équivaut à un multiplexeur qui peut être réparti physiquement sur plusieurs appareils ou plusieurs cartes électroniques.

Classification[ | ]

Niveaux logiques[ | ]

En algèbre de Boole, une donnée, qu'elle soit en entrée ou en sortie, n'a que deux niveaux possibles. Selon les applications, ces deux niveaux peuvent porter des noms différents : marche / arrêt, haut / bas, un (1) / zéro (0), vrai / faux, positif / négatif, positif / nul, circuit ouvert / circuit fermé, différence de potentiel / pas de différence, oui / non.

Dans le cas de circuits électroniques, les deux niveaux sont représentés par deux niveaux de tension, « haut » et « bas ». Chaque type de circuit possède ses propres niveaux de tension, pour s'assurer de la connectivité entre les entrées et sorties des circuits. Habituellement, deux niveaux bien distincts (ne risquant pas de se chevaucher) sont définis ; la différence entre les deux niveaux varie entre 0,7 V et 28 V (ce dernier dans le cas des relais).

Pour harmoniser la notation, ces deux niveaux seront notés ici 1 et 0.

Fonctions logiques élémentaires[ | ]

Les portes peuvent être classées suivant leur nombre d'entrées :

  • « portes » sans entrée : VRAI, FAUX ;
  • portes à une entrée : NON (NOT), OUI ;
  • portes à deux entrées : ET (AND), NON-ET (NAND), OU (OR), NON-OU (NOR), OU exclusif (XOR), Coïncidence (informatique) dite aussi NON-OU exclusif ou équivalence (XNOR), implication ;
  • À partir de trois entrées, le nombre de fonctions commence à subir l'influence de l'explosion combinatoire. On note toutefois l'existence de : ET, OU, etc. à plus de deux entrées.

Il est possible de reconstituer les fonctions NON, ET et OU en utilisant uniquement soit la fonction NON-ET, soit la fonction NON-OU. On évoque cette caractéristique sous la notion d'universalité des opérateurs NON-OU et NON-ET (cf. le connecteur binaire d'incompatibilité, appelé aussi barre de Sheffer).

Lorsqu'on associe deux portes logiques compatibles, on peut connecter deux entrées ensemble, ou une entrée sur une sortie. Il ne faut en aucun cas connecter deux sorties différentes car elles peuvent produire des données différentes ; dans le cas de portes électroniques, cela équivaudrait à un court-circuit.

Représentation[ | ]

Pour définir chacune des fonctions logiques, nous donnerons plusieurs représentations :

  • une représentation algébrique : équation ;
  • une représentation arithmétique : table de vérité ;
  • une représentation graphique : symbole logique.

Dans le cas de portes électroniques, un niveau logique est représenté par un voltage défini (selon le type de composant utilisé). Chaque porte logique doit donc être alimentée pour délivrer la tension de sortie appropriée. Dans la représentation en symboles logiques, cette alimentation n'est pas représentée, mais elle doit l'être dans un schéma électronique complet.

La représentation d'un système combinatoire incluant plusieurs fonctions logiques peut aussi se faire grâce à un schéma à contact, une équation, une table de vérité et un schéma graphique. Dans ce dernier cas on parlera d'un logigramme.

Représentation graphique[ | ]

Deux ensembles de symboles sont utilisés pour représenter les fonctions logiques ; les deux sont définis par la norme ANSI/IEEE 91-1984 et son supplément 91a-1991. La représentation par « symboles distinctifs », basée sur les schématisations classiques, est utilisée pour les schémas simples et est plus facile à tracer à la main. Elle est parfois qualifiée de « militaire », ce qui reflète ses origines, sinon son usage actuel.

La représentation « rectangulaire » se base sur la norme CEI 60617-12 ; toutes les portes y sont représentées avec des bords rectangulaires et un symbole, ce qui permet la représentation d'un plus grand nombre de types de circuits. Ce système a été repris par d'autres standards comme EN 60617-12:1999 en Europe et BS EN 60617-12:1999 au Royaume-Uni.

Symboles et tables de vérités de portes logiques
Type Symbole américain Symbole européen Notation Opération
booléenne 		Table de vérité Diagramme de Venn
ET ET ET A ∧ B {\displaystyle A\land B} A ⋅ B {\displaystyle A\cdot B}
Entrée |  | Sortie
A | B | A ET B
0 | 0 | 0
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1
OU OU OU A ∨ B {\displaystyle A\lor B} A + B {\displaystyle \textstyle A+B}
Entrée |  | Sortie
A | B | A OU B
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 1
NON NON Fonctions logiques(2-ebis).png ⌜ A {\displaystyle \ulcorner A} A ¯ {\displaystyle {\overline {A}}}
Entrée | Sortie
A | NON A
0 | 1
1 | 0
NON-ET (NAND) NAND NAND ⌜ ( A ∧ B ) {\displaystyle \ulcorner (A\land B)} A ⋅ B ¯ {\displaystyle {\overline {A\cdot B}}}
Entrée |  | Sortie
A | B | A NAND B
0 | 0 | 1
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0
NON-OU (NOR) NOR NOR ⌜ ( A ∨ B ) {\displaystyle \ulcorner (A\lor B)} A + B ¯ {\displaystyle {\overline {A+B}}}
Entrée |  | Sortie
A | B | A NOR B
0 | 0 | 1
0 | 1 | 0
1 | 0 | 0
1 | 1 | 0
OU exclusif (XOR) XOR XOR A ⊕ B {\displaystyle A\oplus B} A ⊕ B {\displaystyle A\oplus B}
Entrée |  | Sortie
A | B | A XOR B
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0
Coïncidence, NON-OU exclusif XNOR XNOR A ⊙ B {\displaystyle A\odot B} A ⊙ B {\displaystyle A\odot B}
Entrée |  | Sortie
A | B | A XNOR B
0 | 0 | 1
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1
FAUX ⊥ {\displaystyle \perp }
Entrée |  | Sortie
A | B | FAUX
0 | 0 | 0
0 | 1 | 0
1 | 0 | 0
1 | 1 | 0
VRAI T
Entrée |  | Sortie
A | B | VRAI
0 | 0 | 1
0 | 1 | 1
1 | 0 | 1
1 | 1 | 1

Une porte NON-ET (NAND) peut également être représentée en utilisant le symbole OU avec des bulles (inverseurs) sur les entrées, et une porte NON-OU (NOR) peut être représentée par un symbole ET avec des bulles sur les entrées. Cela reflète les lois d'équivalence de De Morgan ; cela permet de rendre également un diagramme plus lisible, ou de fabriquer un circuit facilement avec des portes préfabriquées, car un circuit qui a des bulles des deux côtés peut être remplacé par un circuit non-inversé en changeant la porte. Si une porte NON-ET est représentée par un OU avec des entrées inversées, ou qu'un NON-OU est représenté par un ET avec des entrées inversées, le remplacement se fait automatiquement dans le schéma (les bulles « s'annulent »). C'est courant dans les diagrammes logiques réels — si bien que le lecteur ne doit pas s'habituer à associer les symboles aux portes OU et ET automatiquement, mais doit aussi prendre en compte les inverseurs pour déterminer la bonne fonction représentée. Les entrées inversées sont particulièrement utiles dans le cas de signaux « actifs à l'état bas ».

Les deux autres portes fréquemment rencontrées sont la fonction OU exclusif et son inverse. Un OU exclusif à deux entrées ne renvoie un 1 que quand les deux entrées sont différentes, et un 0 quand elles sont égales, quelle que soit leur valeur. S'il y a plus de deux entrées, la porte renvoie 1 si le nombre d'entrées égales à 1 est impair[1]. Dans la pratique, ces portes sont souvent réalisées à partir de combinaisons de portes logiques plus simples.

Convention d'écriture[ | ]

La notation surlignée est vite malcommode. On la remplace souvent par la notation " ' " et si nécessaire un parenthésage. Ainsi :

  • NON(x) = x', d'où (x')' = x.
  • NON·ET(x, y)= (x·y)' = x'+y'.
  • NON·OU(x, y)= (x+y)' = x'·y'.
  • NON·ET(NON·ET(a, b, c), NON·ET(d, f)) = ((a·b·c)')'+((d·f)')' = a·b·c + d·f.
  • NON·OU(NON·OU(a, b, c), NON·OU(d, f)) = ((a+b+c)')'·((d+f)')' = (a+b+c)·(d+f)

Les opérateurs physiques NON·ET/NON·OU étant peu commodes dans les calculs, les deux dernières relations (dites de double couche) facilitent la liaison entre calcul et dessin ; ainsi :

  • une double couche NON·ET réalise toute fonction donnée sous forme d'une somme de monômes booléens ;
  • de même, une double couche NON·OU réalise toute fonction donnée sous forme d'un produit de clauses booléennes.

Autres fonctions logiques[ | ]

Multiplexeurs[ | ]

Soient 8 entrées binaires x0 à x7, et 3 entrées de commande a, b, c, permettant d'afficher un nombre de 0 à 7. Un multiplexeur aligne sa sortie s sur l'entrée dont le numéro est affiché. Pour cela, s = a'·b'·c'·x0 + a'·b'·c·x1 + a'·b·c'·x2 + a'·b·c·x3 +....+ a·b·c·x7.

Commande |  |  | Sortie
a | b | c | s
0 | 0 | 0 | x0
0 | 0 | 1 | x1
0 | 1 | 0 | x2
0 | 1 | 1 | x3
* | * | * | *
1 | 1 | 0 | x6
1 | 1 | 1 | x7

Additionneurs[ | ]

Article détaillé : Additionneur.

C'est l'exemple type de cellules logiques, regroupements de fonctions des mêmes variables, utilisables comme briques ou boîtes noires dans des ensembles complexes.

simple[ | ]

Soient a et b deux bits à additionner ; le résultat est un couple (r, s) tel que, arithmétiquement a + b = 2r + s. En termes booléens, r = a·b et s = a ⊕ b {\displaystyle a\oplus b} [image] .

complet[ | ]

L'addition de deux bits a et b sera le plus souvent une addition intermédiaire recevant un report r. Le résultat est alors un couple (R, S) tel que, arithmétiquement, a+b+r = 2R+S. En termes booléens, S = a ⊕ b ⊕ r {\displaystyle a\oplus b\oplus r} [image] et R = MAJ(a, b, r), où la porte MAJ(orité) a pour définition MAJ(x, y, z)= xy + yz + xz.

soustracteur[ | ]

Un additionneur complet peut devenir additionneur/soustracteur en complément à un ou complément à deux s'il fait la somme des bits a, b ⊕ $ {\displaystyle b\oplus \$} [image] et r, où r est un report, et $ une commande valant 0 pour une addition et 1 pour une soustraction. Alors, le résultat est un couple (R, S) où S = a ⊕ b ⊕ $ ⊕ r {\displaystyle a\oplus b\oplus \$\oplus r} [image] et R = MAJ(a, b ⊕ $ {\displaystyle b\oplus \$} [image] , r).

multiplicateur[ | ]

Un additionneur complet peut devenir une cellule de multiplicateur s'il fait la somme des bits a, b·m et r, où a est un bit d'une somme partielle de produits, b un bit du multiplicande, m un bit du multiplicateur, et r un report. Alors S = a ⊕ b {\displaystyle a\oplus b} [image] · m ⊕ r {\displaystyle m\oplus r} [image] et R = MAJ(a, b·m, r).

Unités de stockage[ | ]

Au-delà des fonctions logiques purement combinatoires, se pose le problème du stockage d'un bit d'information. Les portes logiques présentées plus haut ne stockent pas de données : quand une entrée change, la sortie réagit immédiatement (au temps de propagation près). Il est possible de créer des éléments de stockage soit avec des condensateurs, soit en utilisant le feedback. En connectant la sortie d'une porte à son entrée, on renvoie la sortie dans le circuit logique ; elle peut ainsi être conservée ou modifiée en utilisant les autres entrées. En connectant des portes de cette manière, on crée un verrou (latch en anglais). D'autres circuits un peu plus complexes utilisent des signaux d'horloge (des signaux qui oscillent à une fréquence connue) et changent quand le signal d'horloge passe à 1 ; on les appelle des bascules ou bistables (flip-flops en anglais). En combinant plusieurs bascules en parallèle pour stocker une valeur de plusieurs bits, on crée un registre.

Les registres et autres circuits de stockage sont regroupés sous le terme de « mémoires électroniques ». Leurs performances varient en termes de vitesse, de complexité et de fiabilité de la mémoire. Leurs types peuvent être très différents selon les applications.

Automates à nombre fini d'états[ | ]

Ils comprennent :

  • un ensemble défini E de variables d'entrée,
  • un ensemble défini I de variables d'état internes, stockées dans un registre,
  • un ensemble défini S de variables de sortie,
  • un réseau combinatoire T : (E, I) → I assurant l'évolution de l'automate en fonction des entrées successives,
  • un réseau combinatoire R : (E, I) → S assurant la définition de la sortie, conformément aux entrées actuelles, et à la mémoire que I a gardé des situations antérieures.

Dès lors que toutes les variables se présentent sous forme binaire, ils sont réalisables à l'aide de circuits logiques.

Ils peuvent être simples, ou fédérés en automates plus complexes.

Unités fonctionnelles[ | ]

Les circuits logiques peuvent également réaliser des éléments comme des multiplexeurs, des unités arithmétiques et logiques (en anglais : Arithmetic and Logic Unit ou ALU), des mémoires, ou les automates animant un processeur. Les microprocesseurs rassemblent de tels éléments, et peuvent contenir plus de 100 millions de portes logiques.

Les composants de microprocesseurs sont à base de transistors à effet de champ, en particulier des MOSFET.


D:\CONTROL\EDITOR\PDF_Tomahawk PDF+\Pdf Conversion\Administrateur\HP813\HP813

BOITIER CMOS


Circuits intégrés CMOS 4000 - Go Tronic

Circuits logiques CD4000

La famille CMOS 4000 présente les caractéristiques suivantes:
- très faible dissipation de puissance
- haute immunité au bruit
- alimentation de 3 V à 15 V

Circuits ABC logiques 4000 en boîtier DIL

- boîtiers DIL (dual in line)
- alimentation de 3 V à 15 V

Article
Type Fonction Boîtier Code Prix
CD4001
CD4001
Code : 20261
En stockEn rupture
4 portes NOR à 2 entrées DIL14 20261 0,42 € HT0,50 € TTC
CD4011
CD4011
Code : 20271
En stockEn rupture
4 portes NAND à 2 entrées DIL14 20271 0,42 € HT0,50 € TTC
CD4013
CD4013
Code : 20273
En stockEn rupture
Double bascule type D DIL14 20273 0,42 € HT0,50 € TTC
CD4015
CD4015
Code : 20275
En stockEn rupture
Registre à décalage 2x4 bits DIL16 20275 0,50 € HT0,60 € TTC
CD4016
CD4016
Code : 20276
En stockEn rupture
4 interrupteurs analogiques DIL14 20276 0,46 € HT0,55 € TTC
CD4017
CD4017
Code : 20277
En stockEn rupture
Compteur à décades DIL16 20277 0,42 € HT0,50 € TTC
CD4020
CD4020
Code : 20280
En stockEn rupture
Compteur binaire 14 bits DIL16 20280 0,42 € HT0,50 € TTC
CD4024
CD4024
Code : 20284
En stockEn rupture
Compteur binaire 7 bits DIL14 20284 0,50 € HT0,60 € TTC
CD4026
CD4026
Code : 20286
En stockEn rupture
Compteur décod. 7 segments DIL16 20286 0,54 € HT0,65 € TTC
CD4027
CD4027
Code : 20287
En stockEn rupture
Double bascule JK DIL16 20287 0,42 € HT0,50 € TTC
CD4028
CD4028
Code : 20288
En stockEn rupture
Décodeur décimal/BCD DIL16 20288 0,42 € HT0,50 € TTC
CD4029
CD4029
Code : 20289
En stockEn rupture
Compt. décompteur progr. 4 bits DIL16 20289 0,33 € HT0,40 € TTC
CD4040
CD4040
Code : 20300
En stockEn rupture
Compteur binaire 12 bits DIL16 20300 0,54 € HT0,65 € TTC
CD4044
CD4044
Code : 20304
En stockEn rupture
Quadruple bascule NAND-RS DIL16 20304 0,42 € HT0,50 € TTC
CD4045
CD4045
Code : 20305
En stockEn rupture
Compteur à 21 étages DIL16 20305 1,21 € HT1,45 € TTC
CD4046
CD4046
Code : 20306
En stockEn rupture
Boucle à verrouillage de phase DIL16 20306 0,58 € HT0,70 € TTC
CD4047
CD4047
Code : 20307
En stockEn rupture
Multivibrateur monost. astable DIL14 20307 0,42 € HT0,50 € TTC
CD4049
CD4049
Code : 20309
En stockEn rupture
Sextuple inverseur tampon DIL16 20309 0,42 € HT0,50 € TTC
CD4050
CD4050
Code : 20310
En stockEn rupture
Sextuple tampon DIL16 20310 0,46 € HT0,55 € TTC
CD4051
CD4051
Code : 20311
En stockEn rupture
Multiplexeur analogique 8 canaux DIL16 20311 0,42 € HT0,50 € TTC
CD4052
CD4052
Code : 20312
En stockEn rupture
2 multiplexeurs analog. 4 canaux DIL16 20312 0,50 € HT0,60 € TTC
CD4060
CD4060
Code : 20318
En stockEn rupture
Compteur diviseur osc. 14 étages DIL16 20318 0,42 € HT0,50 € TTC
CD4066
CD4066
Code : 20322
En stockEn rupture
4 commutateurs analogiques DIL14 20322 0,42 € HT0,50 € TTC
CD4069
CD4069
Code : 20325
En stockEn rupture
Sextuple inverseur DIL14 20325 0,42 € HT0,50 € TTC
CD4070
CD4070
Code : 20326
En stockEn rupture
4 portes OR-EXCL à 2 entrées DIL14 20326 0,38 € HT0,45 € TTC
CD4071
CD4071
Code : 20327
En stockEn rupture
4 portes OR à 2 entrées DIL14 20327 0,42 € HT0,50 € TTC
CD4073
CD4073
Code : 20329
En stockEn rupture
3 portes AND à 3 entrées DIL14 20329 0,42 € HT0,50 € TTC
CD4075
CD4075
Code : 20330
En stockEn rupture
3 portes OR à 3 entrées DIL14 20330 0,42 € HT0,50 € TTC
CD4081
CD4081
Code : 20335
En stockEn rupture
4 portes AND à 2 entrées DIL14 20335 0,38 € HT0,45 € TTC
CD4093
CD4093
Code : 20342
En stockEn rupture
4 portes NAND trigger 2 entrées DIL14 20342 0,38 € HT0,45 € TTC
CD4094
CD4094
Code : 20343
En stockEn rupture
Registre universel de bus 8 bits DIL16 20343 0,42 € HT0,50 € TTC
CD4098
CD4098
Code : 20346
En stockEn rupture
Double multivibrateur monostable DIL16 20346 0,50 € HT0,60 € TTC
CD4099
CD4099
Code : 20347
En stockEn rupture
Bascule adressable 8 bits DIL16 20347 0,42 € HT0,50 € TTC
CD4503
CD4503
Code : 20351
En stockEn rupture
Sextuple tampon 3 états DIL16 20351 0,42 € HT0,50 € TTC
CD4507
CD4507
Code : 20354
En stockEn rupture
Double registre 64 bits DIL14 20354 0,92 € HT1,10 € TTC
CD4511
CD4511
Code : 20356
En stockEn rupture
Décodeur driver BCD/7 segments DIL16 20356 0,50 € HT0,60 € TTC
CD4518
CD4518
Code : 20363
En stockEn rupture
Double compteur BCD DIL16 20363 0,46 € HT0,55 € TTC
CD4538
CD4538
Code : 20376
En stockEn rupture
Double multivibrateur monostable DIL16 20376 0,42 € HT0,50 € TTC
CD4543
CD4543
Code : 20377
En stockEn rupture
Décodeur-driver BCD/7 seg. LCD DIL16 20377 0,46 € HT0,55 € TTC
CD4557
CD4557
Code : 20382
En stockEn rupture
Registre à longueur variable DIL16 20382 1,33 € HT1,60 € TTC
CD4582
CD4582
Code : 20385
En stockEn rupture
Look-ahead carry-block DIL16 20385 1,12 € HT1,35 € TTC
CD40104
CD40104
Code : 20394
En stockEn rupture
Registre 4 bits 3 étages DIL16 20394 0,92 € HT1,10 € TTC
CD40106
CD40106
Code : 20396
En stockEn rupture
Sextuple trigger de Schmitt DIL14 20396 0,58 € HT0,70 € TTC
CD40193
CD40193
Code : 20411
En stockEn rupture
Compteur décomp binaire prog. DIL16 20411 0,58 € HT0,70 € TTC
CD40244
CD40244
Code : 20415
En stockEn rupture
Octuple ampli de ligne de bus DIL20 20415 2,21 € HT2,65 € TTC

Circuits logiques 4000 en boîtier CMS

- boîtiers CMS (montage en surface)
- alimentation de 3 V à 15 V

Article
Type Fonction Boîtier Code Prix
4013BT
4013BT
Code : 16505
En stockEn rupture
Double bascule type D SO14 16505 0,25 € HT0,30 € TTC
4027BT
4027BT
Code : 16519
En stockEn rupture
Double bascule JK SO16 16519 0,50 € HT0,60 € TTC
4030BT
4030BT
Code : 16522
En stockEn rupture
4 portes OR-EXCL à 2 entrées SO14 16522 0,25 € HT0,30 € TTC
4040BT
4040BT
Code : 16524
En stockEn rupture
Compteur binaire 12 bits SO16 16524 0,25 € HT0,30 € TTC


Cours sur L'API Winodos de openclassrooms

Chiffre

Un article de Wikipédia, l'encyclopédie libre.

Cette page contient des caractères arabes. En cas de problème, consultez Aide:Unicode ou testez votre navigateur.

Typo chiffres bas de casse et capitale.png

Un chiffre est un signe, ou symbole, auquel est associée une valeur numérique et dont la fonction est de représenter les nombres ou écrire un numéro. Par extension de sens, le mot « chiffre » est aussi communément utilisé, au singulier comme au pluriel, avec le sens de « nombre ». D'autre part, en dehors du sens numérique ou mathématique, le chiffre est un arrangement de deux ou de plusieurs lettres initiales de noms, entrelacées l'une dans l'autre.

Sommaire

  • 1 Étymologie
  • 2 Synonymie partielle entre « chiffre » et « nombre »
  • 3 Signes et mode d'utilisation
    • 3.1 Systèmes additifs
    • 3.2 Systèmes hybrides
    • 3.3 Systèmes positionnels
  • 4 Histoire
    • 4.1 Des origines au Moyen-Âge
    • 4.2 Les chiffres arabes
  • 5 Mathématiques
  • 6 Musique
  • 7 Notes et références
  • 8 Voir aussi
    • 8.1 Bibliographie
    • 8.2 Articles connexes
      • 8.2.1 Blocs de caractères Unicode contenant des chiffres ou nombres
    • 8.3 Liens externes

Étymologie[modifier | modifier le code]

Le mot « chiffre » (chiffre, Philippe de Commynes, 1486), qui a probablement subi l'influence du picard pour la modification de la consonne initiale[1], provient de l'ancien français cifre (cifre, Gauthier de Coincy, 1220), d'après l'italien cifra, issu du latin médiéval cifra, lui-même emprunté à l'arabe sifr[2] (أَلصِّفْر ʾaṣ-ṣifr), utilisé pour « zéro » et signifiant « le vide », le « rien »[3], terme formé sur le modèle du sanskrit sunya, signifiant « vide ».

Synonymie partielle entre « chiffre » et « nombre »[modifier | modifier le code]

Si les termes « chiffre » et « nombre » sont parfois confondus, ils ne sont cependant pas équivalents. À titre de comparaison, les chiffres jouent le même rôle par rapport aux nombres que les lettres par rapport aux mots. À l'écrit, les nombres sont représentés par une juxtaposition de chiffres, de même que les mots sont représentés par une juxtaposition de lettres. Ainsi, 13 (treize) est un nombre qui, en base 10, s'écrit avec les chiffres « 1 » et « 3 ». Mais, de même qu'un mot peut être constitué d'une seule lettre, tel le mot « a » (verbe « avoir » conjugué à la troisième personne du singulier au présent de l'indicatif), un chiffre seul peut représenter un nombre. Par exemple, en base 10 toujours, le nombre 4 (quatre) s'écrit avec uniquement le chiffre « 4 ».

Toutefois, le mot « chiffre » est utilisé dans de nombreuses expressions avec le sens de « nombre ». Par exemple, le Dictionnaire de l'Académie française indique comme seconde définition de « chiffre » : « Le nombre que figurent les chiffres ; le montant total. Le chiffre de la population d'un pays, le nombre de ses habitants. COMMERCE. Chiffre d'affaires, montant des recettes d'un exercice annuel. »[4]. En effet, en démographie, on parle, des « chiffres de la population » et non des « nombres de la population » (voir Chiffres de population française, Chiffres de population de la France, etc.)[5] ; et, en économie, de « chiffre d'affaires », et non de « nombre d'affaires ».

Signes et mode d'utilisation[modifier | modifier le code]

Un nombre s'écrit comme une séquence de chiffres qui peut être de différentes longueurs. Le système unaire n'utilise qu'un seul chiffre, en forme de simple bâton et représentant la valeur 1, qui peut être répété indéfiniment pour exprimer tous les entiers naturels de façon additive. Mais il existe de nombreux systèmes de numération plus élaborés, mettant en jeu des chiffres représentant différentes valeurs. Les chiffres mis à contribution varient selon les cultures. En voici quelques exemples.

Valeur

0

1

2

3

4

5

6

7

8

9

10

20

30

40

50

60

70

80

90

100

200

300

400

500

600

700

800

900

1000

10 000

100 000

1 000 000

Hiéroglyphes égyptiens

Z1

V20

V1

M12

D50

I8

ou

I7

C11

Chiffres romains

Ⅰ

Ⅴ

Ⅹ

Ⅼ

Ⅽ

Ⅾ

Ⅿ

Chiffres hébreux

א

ב

ג

ד

ה

ו

ז

ח

ט

י

כ

ל

מ

נ

ס

ע

פ

צ

ק

ר

ש

ת

ת״ק ou ך

ת״ר ou ם

ת״ש ou ן

ת״ת ou ף

תת״ק ou ץ

Sinogrammes

〇

一

二

三

四

五

六

七

八

九

十

百

千

万

Chiffres européens,
dits « arabes »

0

1

2

3

4

5

6

7

8

9

Ainsi que le montrent ces exemples, tous les systèmes de numération ne disposent pas d'un chiffre zéro. Par conséquent, ils ne permettent pas tous de représenter le nombre nul.

Par ailleurs, dans certaines écritures, il existe, en plus de ceux représentant des valeurs entières, des chiffres représentant des fractions de l'unité. Ainsi, il existe un signe tibétain pour la demi-unité, et des chiffres peuvent exprimer diverses fractions de l'unité dans de nombreuses cultures indiennes.

Le nombre de chiffres d'une numération est étroitement lié au système de numération, c'est-à-dire au mode d'utilisation de ces chiffres. Pour les systèmes additifs et hybrides, la limite du nombre de chiffres disponibles rend les nombres difficiles à représenter au-delà d'une certaines borne. Seuls les systèmes positionnels permettent de représenter aisément tous les nombres à l'aide d'un nombre limité de chiffres.

Systèmes additifs[modifier | modifier le code]

Article détaillé : Notation additive.

Les systèmes additifs nécessitent, pour une base β, des chiffres pour représentant les puissances successives de β. C'est la somme de la valeur de chacun des chiffres détermine la valeur du nombre. La numération égyptienne, décimale, a ainsi des chiffres de valeur 1, 10, 100, 1000, 10 000, 100 000, 1 000 000.

Pour éviter les succession trop importantes, des chiffres de valeur intermédiaire sont parfois utilisés. C'est le cas pour la numération romaine, qui utilise des chiffres de valeur 1, 5, 10, 50, 100, 500, 1000. Cette dernière connait aussi une variante additive et soustractive, introduisant ainsi une notion d'ordre nécessaire pour interpréter la valeur d‘un nombre selon la position de ses chiffres, en leur conférant une valeur soit positive soit négative, en fonction de la comparaison de leur taille avec celle des chiffres suivants (sans que cela permette pour autant d'exprimer les nombres négatifs ou nuls).

Les numérations alphabétiques, quant à elles, utilisent des chiffres pour tous les multiples de β. Ainsi la numération hébraïque, par exemple, utilise des chiffres pour 1, 2, 3, ..., 9, 10, 20, 30, ..., 90, 100, 200, 300, ..., 900.

Systèmes hybrides[modifier | modifier le code]

Les systèmes hybrides nécessitent, pour une base β, des chiffres allant de 1 à β-1, plus des chiffres pour représenter les puissances successives β. Ces systèmes sont multiplicatifs et additifs : chaque chiffre utilisé représentant une puissances de β est, au besoin, précédé d'un chiffre représentant une unité (à partir de 2). La valeur du nombre est alors égal à la somme des nombres et produits de nombres en présence.

Systèmes positionnels[modifier | modifier le code]

Article détaillé : Notation positionnelle.

Les systèmes positionnels utilisent, en principe, β chiffres, de 0 à β-1, pour une base β. Le nombre de chiffre peut néanmoins être plus réduit.

  • Certaines numérations se passent du chiffre 0. Un simple espace palie alors à l'absence de zéro positionnel. Cela engendre toutefois des risques de mauvaises interprétations du nombre, en particulier pour les nombres se terminant par cet espace ou pour ceux nécessitant plusieurs espaces contigus.
  • Une base auxiliaire peut être utilisée. C'est le cas de la numération mésopotamienne, sexagésimale, qui utilise une base auxiliaire décimale. Cette numération utilise ainsi des chiffres pour les unités et pour les dizaines.

Comme le suggère la dénomination, dans un système de numération positionnel, une combinaison de chiffres représente un nombre différent selon la position qu'occupent ces chiffres. Dans une séquence de chiffres, les positions successives ont une valeur égale aux puissances successives de la base. La valeur totale d'un nombre est calculée en multipliant chacun des chiffres par la valeur de sa position, et en additionnant les résultats.

Par exemple, dans la séquence 153, le chiffre 3 occupe la première position qui, quelle que soit la base β, a pour valeur β0=1. Le chiffre 5 occupe la deuxième position, qui a pour valeur β1 = β. Et le chiffre 1 occupe la troisième position, qui a pour valeur β2.

Dans le cas d'une base dix, 153 vaut :

(3 × 100) + (5 × 101) + (1 × 102)

= (3 × 1) + (5 × 10) + (1 × 100)

= 3 + 50 + 100 = 153.

Enfin, pour des raisons de lisibilité, les chiffres peuvent être séparés par petits groupes au-delà d'un certain seuil. Le système de numération indo-arabe fait souvent intervenir, selon ce principe, un séparateur de positions. Le symbole utilisé pour cela est purement conventionnel ; la convention, et donc le symbole employé, varie d'ailleurs selon les pays.

Histoire[modifier | modifier le code]

Cette section est vide, insuffisamment détaillée ou incomplète. Votre aide est la bienvenue !

Des origines au Moyen-Âge[modifier | modifier le code]

Le plus ancien système de numération de l'humanité est le système unaire, qui n'utilise qu'un seul chiffre, en forme de bâton, se répétant autant de fois que nécessaire pour représenter un nombre. Ce système a notamment donné naissance à de nombreux systèmes additifs, certains groupes de chiffres ayant été remplacés par de nouveaux signes afin rendre les nombres plus lisibles. Aussi, divers systèmes additifs ont été utilisés au cours de l'Antiquité, comme celui de la numération romaine. Avec les conquêtes romaines, les chiffres romains se sont alors répandus dans une large partie de l'Europe. Ils étaient ensuite communs au Moyen Âge, et leur usage perdure aujourd'hui, puisqu'ils sont couramment employés pour noter les siècles, pour la numérotation des titres de sections des textes, ou pour représenter les heures en horlogerie ou sur les cadrans solaires.

Les chiffres arabes[modifier | modifier le code]

Article détaillé : Chiffres arabes.

Les chiffres arabes font partie des écritures de type logographique. C'est-à-dire que le symbole « 1 » se prononce de façon différente dans chaque langue, mais représente le même élément abstrait et reste donc compréhensible sous sa forme écrite.

Ces chiffres doivent leur nom au fait qu'ils proviennent des Arabes. L'ouvrage d'Al-Khawarizmi Traité du système de numération des Indiens (rendu accessible aux lettrés non-arabisants par ses traductions en latin, dont De numero indorum) laisse penser qu'ils seraient originaires d'Inde. Le zéro (représenté par un point) était utilisé comme marqueur de position vide par les astronomes babyloniens, mais ceux-ci n'avaient pas fait la démarche de le considérer comme chiffre à part entière.

Le concept du zéro, en tant que symbole numérique à parité avec les autres, qu'élément neutre de l'addition et élément absorbant de la multiplication, est en revanche présent dans les textes mathématiques indiens, en particulier l'analyse du problème de l'échiquier et des grains de blé.

Les chiffres de 1 à 9 ont été inventés en Inde. Ils apparaissent dans des inscriptions de Nana Ghât au IIIe siècle av. J.-C. La numération de position avec un zéro (un simple point à l'origine), a été développée au cours du Ve siècle. Dans un traité de cosmologie en sanskrit de 458, on voit apparaître le nombre 14 236 713 écrit en toutes lettres. On y trouve aussi le mot « sunya » (le vide), qui représente le zéro. C'est à ce jour le document le plus ancien faisant référence à cette numération.

Au Xe siècle, le moine occitan Gerbert d'Aurillac s'initie à la nouvelle numération et, grâce aux chaires qu'il occupe dans divers établissements religieux d'Europe, commence à le faire connaître aux lettrés d'Occident. Élu pape en 999 sous le nom de Sylvestre II, il en retire l'autorité nécessaire pour faire adopter à la chrétienté la numération indo-arabe malgré la réticence du milieu des clercs, utilisant pour leur part l'abaque, et qui voient cette simplification menacer une partie de leur métier.

Les dix chiffres indiens ont été adoptés dans le monde arabo-musulman, puis dans le monde chrétien. De nos jours, on écrit ces chiffres ainsi :

  • Au Moyen-Orient à l'exception du Maghreb : ٠, ١, ٢, ٣, ٤, ٥, ٦, ٧, ٨ et ٩.
  • En Occident et au Maghreb : 0, 1, 2, 3, 4, 5, 6, 7, 8 et 9.

Mathématiques[modifier | modifier le code]

En mathématiques, on utilise ordinairement les chiffres arabes, dont l'appellation est ambigüe puisque leur tracé a connu des évolutions en Europe après leur emprunt aux Arabes, et que les Arabes disposent de chiffres qui diffèrent de ceux-là.

Ces dix chiffres sont ceux du système décimal employé par défaut : 0, 1, 2, 3, 4, 5, 6, 7, 8, 9.

Le nombre de chiffres utilisés dépend de la base. En effet, n chiffres sont nécessaires pour représenter tous les entiers dans une base n fixe.

  • Si n est inférieur à 10, on utilise généralement les n premiers chiffres, à partir de 0. Par exemple, dans le système binaire n'emploie que deux chiffres : 0 et 1. Ce système est souvent utilisé pour représenter des valeurs telles que « vrai » et « faux », « marche » et « arrêt ». Il convient notamment pour représenter le fonctionnement de l'électronique numérique utilisée dans les ordinateurs, d'où son usage en informatique et en électronique.
  • Si n est strictement supérieur à 10 et inférieur à 36, on utilise les chiffres de 0 à 9, et, par convention, on poursuit avec (n−10) lettres de l'alphabet latin à partir de A. Ainsi, les chiffres du système hexadécimal sont 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A, B, C, D, E, F, leur valeur allant, dans l'ordre, de 0 à 15. Ce système est surtout utilisé en informatique.
  • Si n est strictement supérieur à 36, on utilise une base dix auxiliaire : les chiffres sont représenté par un nombre en base 10, et sont dissociés les uns des autres par un séparateur de position.

Généralement, le signe des nombres n'est pas indiqué par les chiffres eux-mêmes, mais par l'adjonction d'un signe supplémentaire, soit +, soit −. Cependant, les chiffres exprimant une valeur positive, le nombre représenté, sans indication supplémentaire de signe, est également positif. De ce fait, le signe + est rarement employé.

Cependant, il existe aussi des systèmes balancés, employant des chiffres signés. Par exemple, le système trinaire balancé utilise les chiffres 1, 0, 1, valant, respectivement, -1, 0, 1. Il est adapté pour représenter les booléens dont les valeurs sont « vrai », « faux » et « indéterminé », et est pratique pour l'informatique, car il évite l'ajout d'un chiffre supplémentaire pour indiquer le signe d'un nombre. Dans un tel système, les nombres positifs et négatifs bénéficient de la même représentation.

Un système de numération n'implique pas nécessairement l'utilisation du chiffre zéro. Notamment, la numération bijective en base k permet de représenter tous les entiers sans faire appel à ce dernier.

Il existe aussi des systèmes pour lesquels certains nombres peuvent être représentés par plusieurs séquences de chiffres différentes. Dans le système de numération d'Avizienis, par exemple, tous les nombres n'ont pas une représentation unique.

D'autre part, des chiffres supplémentaires sont aussi utilisés pour exprimer des nombres de certains ensembles de nombres. Par exemple, pour noter les nombres complexes, un chiffre est représenté par la lettre i (chiffre dit « imaginaire », parfois noté j dans les formules utilisées dans d'autres sciences comme l'électricité, l'électromagnétisme et le traitement du signal) et s'emploie comme une quantité multiplicative, combinable par des opérations arithmétiques simples pour exprimer le nombre complexe quelconque. Dans d'autre cas, on lui préfère une notation algébrique sous forme de couple (aussi utilisée pour noter les coordonnées).

Enfin, il existe des représentations des nombres pour lesquelles le nombre de chiffres nécessaires n'est pas limité. C'est le cas, par exemple de la suite des exposants dans la décomposition d'un nombre entier sous forme de produit de puissances de nombre premiers : il est alors nécessaire d'utiliser un séparateur entre les chiffres qui eux-mêmes sont des nombres entiers qui sont exprimés sous forme positionnelle dans une base fixe.

Musique[modifier | modifier le code]

La forme ou le fond de cet article est à vérifier.

Améliorez-le ou discutez des points à vérifier. Si vous venez d’apposer le bandeau, merci d’indiquer ici les points à vérifier.

En musique, les chiffres placés au début de la portée indiquent sous forme de fraction le nombre de temps contenus dans une mesure. Ce procédé se nomme « chiffrage ». Il existe aussi le chiffrage des accords.

Les chiffres servent à doigter les notes d'une partition, c'est-à-dire que le chiffre placé au-dessus d'une note indique le doigt utilisé pour réaliser la note. Ainsi, au violon le « 1 » représente l'index, le « 2 » le majeur, le « 3 » l'annulaire et le « 4 » l'auriculaire. Au piano, le « 1 » représente le pouce, le « 2 » l'index et ainsi de suite.

Notes et références[modifier | modifier le code]

  1. ↑ Trésor de la langue française informatisé.
  2. ↑ Albert Dauzat, Jean Dubois, Henri Mitterand, Nouveau dictionnaire étymologique et historique, Librairie Larousse, 1971. P. 162.
  3. ↑ Étymologie donnée par le Robert des collèges.
  4. ↑ Dictionnaire de l'Académie française, neuvième édition. Version informatisée. Le Dictionnaire de l'Académie française donne pour premières définitions de « chiffrer » (dérivé de « chiffre ») : « 1. Numéroter, distinguer par des chiffres. Chiffrer les pages d'un registre. 2. Évaluer en chiffres. Chiffrer une dépense, un projet. Noter quelqu'un ou quelque chose par une appréciation chiffrée ». Pour « chiffrage » (dérivé de chiffrer) il donne en première définition : « Action d'évaluer en chiffres ; résultat de cette action. Le chiffrage d'un stock de marchandises. Le chiffrage du prix de revient d'une construction ».
  5. ↑ Article R25-1 du code électoral français

Voir aussi[modifier | modifier le code]

Bibliographie[modifier | modifier le code]

  • Georges Ifrah, Histoire universelle des chiffres • L'intelligence des hommes racontée par les nombres et les calculs, 2 tomes, Paris, éd. Robert Laffont, 1994 (ISBN 978-2-221-05779-7 et 978-2-221-07837-2)

Articles connexes[modifier | modifier le code]

  • Nombre
  • Système de numération
  • Chiffre significatif
  • Chiffre arabo-indien
  • Numération chinoise
  • Chiffres grecs • Épisémon (maths)
  • Chiffres romains
  • Chiffres japonais
  • Symbolique des chiffres

Blocs de caractères Unicode contenant des chiffres ou nombres[modifier | modifier le code]

  • Table des caractères Unicode - commandes C0 et latin de base
  • Table des caractères Unicode - commandes C1 et supplément latin-1
  • Table des caractères Unicode - arabe
  • Table des caractères Unicode - n’ko
  • Table des caractères Unicode - dévanâgarî
  • Table des caractères Unicode - bengali
  • Table des caractères Unicode - gourmoukhî
  • Table des caractères Unicode - goudjarâtî
  • Table des caractères Unicode - oriya
  • Table des caractères Unicode - tamoul
  • Table des caractères Unicode - télougou
  • Table des caractères Unicode - kannara
  • Table des caractères Unicode - malayalam
  • Table des caractères Unicode - thaï
  • Table des caractères Unicode - lao
  • Table des caractères Unicode - tibétain
  • Table des caractères Unicode - birman
  • Table des caractères Unicode - éthiopien
  • Table des caractères Unicode - khmer
  • Table des caractères Unicode - mongol
  • Table des caractères Unicode - limbou
  • Table des caractères Unicode - nouveau taï lü
  • Table des caractères Unicode - symboles khmers
  • Table des caractères Unicode - taï tham
  • Table des caractères Unicode - balinais
  • Table des caractères Unicode - sundanais
  • Table des caractères Unicode - lepcha
  • Table des caractères Unicode - ol tchiki
  • Table des caractères Unicode - exposants et indices
  • Table des caractères Unicode - formes numérales
  • Table des caractères Unicode - alphanumériques cerclés
  • Table des caractères Unicode - casseau
  • Table des caractères Unicode - ponctuation CJC
  • Table des caractères Unicode - kanboun
  • Table des caractères Unicode - lettres et mois CJC cerclés
  • Table des caractères Unicode - compatibilité CJC
  • Table des caractères Unicode - vaï
  • Table des caractères Unicode - bamoun
  • Table des caractères Unicode - formes numériques communes indiennes
  • Table des caractères Unicode - saurachtra
  • Table des caractères Unicode - dévanâgarî étendu
  • Table des caractères Unicode - kayah li
  • Table des caractères Unicode - javanais
  • Table des caractères Unicode - cham
  • Table des caractères Unicode - meitei mayek
  • Table des caractères Unicode - formes de demi et pleine chasse
  • Table des caractères Unicode - nombres égéens
  • Table des caractères Unicode - nombres grecs anciens
  • Table des caractères Unicode - alphabet italique
  • Table des caractères Unicode - gotique
  • Table des caractères Unicode - vieux perse
  • Table des caractères Unicode - osmanya
  • Table des caractères Unicode - araméen impérial
  • Table des caractères Unicode - phénicien
  • Table des caractères Unicode - kharochthî
  • Table des caractères Unicode - sud-arabique
  • Table des caractères Unicode - parthe des inscriptions
  • Table des caractères Unicode - pehlevi des inscriptions
  • Table des caractères Unicode - chiffres rûmî
  • Table des caractères Unicode - brahmî
  • Table des caractères Unicode - sora sompeng
  • Table des caractères Unicode - chakma
  • Table des caractères Unicode - charada
  • Table des caractères Unicode - tâkrî
  • Table des caractères Unicode - ponctuation et nombres cunéiformes
  • Table des caractères Unicode - chiffres-bâtonnets chinois
  • Table des caractères Unicode - symboles mathématiques alphanumériques
  • Table des caractères Unicode - supplément alphanumérique cerclé

Liens externes[modifier | modifier le code]

v · d · m Notion de nombre
Ensembles usuels | Entier naturel ( [image] ) · Entier relatif ( [image] ) · Nombre décimal ( [image] ) · Nombre rationnel ( [image] ) · Nombre réel ( [image] ) · Nombre complexe ( [image] ) | Mathématiques
Extensions | Quaternion ( [image] ) · Octonion ( [image] ) · Sédénion ( [image] ) · Nombre complexe déployé · Tessarine · Nombre bicomplexe ( [image] ) · Nombre multicomplexe ( [image] ) · Biquaternion · Coquaternion · Quaternion hyperbolique · Octonion déployé · Nombre hypercomplexe · Nombre p-adique ( [image] ) · Nombre hyperréel · Nombre superréel · Nombre dual · Droite réelle achevée · Nombre cardinal · Nombre ordinal · Nombre surréel · Nombre pseudo-réel
Propriétés particulières | Parité · Nombre premier · Nombre composé · Carré parfait · Nombre parfait · Nombre positif · Nombre négatif · Fraction dyadique · Nombre irrationnel · Nombre algébrique · Nombre transcendant · Nombre imaginaire pur · Nombre de Liouville · Période · Nombre normal · Nombre univers · Nombre constructible · Nombre réel calculable · Nombre transfini · Infiniment petit
Exemples | Pi (π) · Racine carrée de deux (√2) · Nombre d’or (φ) · Zéro (0) · Unité imaginaire (i) · Constante de Neper (e) · Aleph-zéro (ℵ0) · Table de constantes mathématiques
Articles liés | Chiffre · Numération · Fraction · Opération · Calcul · Algèbre · Arithmétique · Suite d'entiers · Infini (∞) · Chiffre significatif

· Portail de l’écriture Portail de l’écriture

· Portail des mathématiques Portail des mathématiques

· Portail du monde indien Portail du monde indien

· Portail du monde arabo-musulman Portail du monde arabo-musulman

Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Chiffre&oldid=106310030 ».

Catégorie :

  • Système de numération

Catégories cachées :

  • Article manquant de référence depuis juin 2010
  • Article manquant de référence/Liste complète
  • Article à vérifier
  • Portail:Écriture/Articles liés
  • Portail:Mathématiques/Articles liés
  • Portail:Sciences/Articles liés
  • Projet:Mathématiques/Articles
  • Portail:Monde indien/Articles liés
  • Portail:Asie/Articles liés
  • Portail:Monde arabo-musulman/Articles liés


Base (arithmétique)

Un article de Wikipédia, l'encyclopédie libre.

En arithmétique, une base désigne la valeur dont les puissances successives interviennent dans l'écriture des nombres dans la numération N-adique, ces puissances définissant l'ordre de grandeur de chacune des positions occupées par les chiffres composant tout nombre. Par commodité, on utilise usuellement, pour les bases entières à partir de deux, un nombre de chiffres égal à la base. En effet, l'écriture d'un nombre en base N à l'aide de N chiffres allant de 0 à N-1 correspond à son développement en base N.

Sommaire

  • 1 Bases courantes
  • 2 Symboles utilisés
  • 3 Notations courantes
  • 4 Conversion d'une base à une autre
  • 5 Systèmes balancés
  • 6 Bases non standard
  • 7 Quelques propriétés
  • 8 Culture
  • 9 Articles connexes

Bases courantes

Certaines bases sont couramment employées :

  • la base deux (système binaire), en électronique numérique et informatique,
  • la base trois (système trinaire), dans les mêmes domaines, bien que moins fréquemment,
  • la base huit (système octal), en informatique, davantage à l'échelle humaine que la base deux, aujourd'hui abandonnée au profit de la base seize. Il a été utilisé par les yuki,
  • la base neuf (système nonaire), davantage à l'échelle humaine que la base 3,
  • la base dix (système décimal), la plus commune, aujourd'hui la référence dans le domaine des sciences,
  • la base douze (système duodécimal), de manière embryonnaire, a été utilisé par les Égyptiens pour le compte en heures et mois,
  • la base seize (système hexadécimal), en informatique, facilitant les conversions en base 2 en regroupant des chiffres binaires, 16 étant une puissance de 2,
  • la base vingt (système vigésimal) a été utilisée par les Mayas et les Aztèques, ainsi que de manière alternative en France (dont on garde en l'héritage pour quatre-vingt)
  • la base soixante (système sexagésimal), dans la mesure du temps et des angles, il a été utilisé par les Sumériens, les Akkadiens, puis les Babyloniens. (voir Numération babylonienne)
  • la base cent cinquante ou base indienne, utilisée notamment dans la table astronomique appelée Table indienne d’al-Khawarizmi

De nombreuses bases sont, et ont été, aussi utilisées par différents peuples ; consulter Numération pour plus de détails.

Bien que peu utilisée, la base trente a l'intérêt d'exprimer simplement le résultat de la majorité des petites fractions (à dénominateurs de la forme 2n.3p.5q), et les factorielles. De plus, à la différence de la base 60, elle peut être représentée à l'aide des 10 chiffres courants et des 20 premières lettres de l'alphabet.

Pour des applications spécifiques, l'informatique peut utiliser des base ad hoc : pour un entier représenté par une chaîne d'octets, on peut considérer un octet comme un chiffre en base 256 ; on peut voir un identificateur comme un nombre en base 40 ; pour des applications décimales, on peut avoir avantage à utiliser une base 1000.

Symboles utilisés

Pour les bases jusqu'à 10 inclus, on utilise les chiffres 0, 1, 2, 3, 4, 5, 6, 7, 8 et 9.

Au-delà, on utilise les lettres. Par exemple, pour la base 16, les symboles utilisés sont 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A, B, C, D, E, F.

L'usage du zéro positionnel est une convention pratique et élégante, mais non nécessaire pour représenter les entiers naturels, comme l'illustre le système décimal sans zéro. Il est, par contre, indispensable pour généraliser l'écriture positionnelle aux nombres fractionnaires.

Notations courantes

Pour n'importe quelle base, on a l'habitude de l'indiquer en indice du nombre. Par exemple [image] pour le nombre 100111 en base 2, ou encore [image] pour le nombre 172 en base 8.

En plus de cette notation, il en existe d'autres, notamment employées en informatique.

  • Base 8 : on peut indiquer le nombre avec un zéro au début. Par exemple 0157 pour [image].
  • Base 16 : on peut indiquer de diverses manières qu'un nombre est en hexadécimal (voir tableau ci-dessous). Une autre écriture courante est l'ajout du suffixe "h" à la fin du nombre, ce qui avec notre exemple donne AE4Fh.
Préfixe | Exemple | Langages
0x | 0xAE4F | C, C++, Java
$ | $AE4F | Pascal
&h | &hAE4F | Basic
# | #AE4F | HTML

Conversion d'une base à une autre

Un nombre dans une base n donnée s'écrit sous la forme d'additions des puissances successives de cette base.

  • Le nombre [image] en base b, constitué des chiffres [image], ..., [image], [image], [image], peut aussi s'écrire sous la forme c_n b^n + ... + c_2 b^2 + c_1 b^1 + c_0 b^0, c'est-à-dire un polynôme dont les coefficients sont les chiffres et l'inconnue est la base.

Lorsqu'on veut passer d'une base à une autre, on utilisera 2 méthodes (algorithmes) suivant que l'on sait calculer dans la base de départ ou dans la base d'arrivée.

Si on sait calculer dans la base de départ, des divisions entières successives par la base donneront en reste les chiffres du résultat, en commençant par les unités. Plus précisément :

(le nombre à convertir) ; [image];

tant que [image] faire

les [image] sont les chiffres du nombre converti, en partant des unités.

Si on sait calculer dans la base d'arrivée, on évalue le polynôme (en représentant les coefficients et la base de départ dans la base d'arrivée). La méthode de Horner est généralement utilisée :

; [image];

pour i:=n-1 a 0 faire v := v *b +c_i ;

v est le nombre dans la base d'arrivée.

Si on ne sait calculer ni dans la base de départ ni dans celle d'arrivée, on passe par une base intermédiaire où l'on sait calculer.

Si la base d'arrivée est une puissance de la base de départ (exemple : de la base 2 à la base 16), on peut convertir groupes de chiffres à chiffre, localement et directement.

Systèmes balancés

Un système numérique de base 2N ou 2N+1 peut également être doté des 2N+1 chiffres signés N, ..., 2, 1, 0, 1, 2, ..., N. On parle alors de système balancé ou symétrique.

Bases non standard

On peut également employer des bases :

  • négatives, pour lesquelles les nombres sont signés mais pas les chiffres ;
  • non-entières, on parle alors de bêta-numération (la base d'or en est un exemple) ;
  • imaginaires (par exemple, le système quater-imaginaire ou la base [image], dans laquelle tout nombre complexe peut se développer, est une généralisation aux complexes du développement binaire) ;
  • base mixte (en), pour lesquels la base varie d'une position à une autre. Par exemple [image] [réf. souhaitée]
  • ...

Quelques propriétés

  • Zéro s'écrit 0 dans toutes les bases.
  • De la même manière, le nombre un s'écrit 1 dans toutes les bases, puisque quelle que soit la base, [image] égale 1.
  • L'égalité « 121 = 11^2 » est vraie dans toutes les bases naturelles strictement supérieures à 2.
  • En base dix, un nombre est pair s'il se termine par un multiple de 2, c'est-à-dire 0, 2, 4, 6 ou 8 ; en base 2, il est pair s'il se termine par 0. Inversement, en base dix, un nombre est impair s'il se termine par un chiffre impair, soit 1, 3, 5, 7 ou 9, et en base deux s'il se termine par 1.
  • L'alternance des chiffres 0 et 1 en binaire se fait avec les chiffres 5 ou A en hexadécimal.

55516 = 0101010101012

AAA16 = 1010101010102

  • Un nombre s'écrivant de la même façon dans deux bases naturelles différentes est plus grand dans la plus grande base.

5716 (=8710) > 5710 > 578 (=4710)

  • De même, un grand nombre aura besoin de moins de chiffres pour s'écrire dans une grande base naturelle que dans une petite.

F424016 (5 chiffres) = 1 000 00010 (7 chiffres) = 1111 0100 0010 0100 00002 (20 chiffres)

  • 10 < 1 en base n, avec n appartenant à l'intervalle ]0;1[, 10 = 1 en base 1, et 10 > 1 en base n, avec n appartenant à l'intervalle ]1;+∞[.
  • la base s'écrit 10 dans toutes les bases. 102 = 2, 1016 = 16, 1060 = 60
  • En base N, un nombre est divisible par N-1 (ou un diviseur de N-1) si la somme de ses chiffres est divisible par N-1 (ou un diviseur de N-1) (exemple connu: la divisibilité par 3 ou par 9 en base 10).

Culture

  • Le nombre π est irrationnel et donc, quelle que soit la base naturelle utilisée, les chiffres après la virgule sont infinis et ne présentent pas de répétition, au contraire des fractions comme 1/7 = 0.142857 142857...
  • Boby Lapointe avait imaginé un usage comique du système hexadécimal, qu'il avait baptisé Système bibi-binaire. Ce système présentait l'avantage de rendre les nombres binaires faciles à prononcer et à mémoriser.
  • La RFC 1924 propose la base 85 pour la notation des adresses IPv6, mais ce n'est qu'un poisson d'avril.
  • Dans le jeu vidéo Portal, lors du combat final, GlaDOS annonce que 2+2 font 10, avant de se rattraper en complétant avec "En base 4, tout va bien !".
  • Les Shadoks comptent en quaternaire.

Articles connexes

  • Numération, système de numération
  • Base d'or (base φ)
  • Système négabinaire

v · d · m

Systèmes de numération

Numérations

Numération arabo-indienne | arabe · khmer · indienne · mongole · thaï
Numérations d’origine chinoise | chinoise · japonaise · à bâtons · suzhou
Autres numérations positionnelles | maya · mésopotamienne
Numérations alphabétiques | arménienne · cyrillique · d'Âryabhata · éthiopienne · hébraïque · grecque · gotique
Autres numérations additives | attique · brahmi · champs d'urnes · égyptienne · étrusque · forestière · inuite · romaine · tchouvache

Bases de numération

Système décimal (base 10)

2 · 4 · 8 · 16 · 32 · 64

1 · 3 · 6 · 9 · 12 · 20 · 24 · 30 · 36 · 60 · plus…

v · d · m Base de numération positionnelle
1 à 9 | unaire (1), binaire (2), trinaire (3), quaternaire (4), quinaire (5), sénaire (6), septénaire (7), octal (8), nonaire (9) | Mathématiques
10 à 60 | décimal (10), duodécimal (12), tridécimal (13), hexadécimal (16), vicésimal (20), base 36, sexagésimal (60)
Autre base | base d'or (φ),
Notions | base • chiffre • nombre • notation positionnelle • numération • numération Bibi

· Portail de l’arithmétique et de la théorie des nombres Portail de l’arithmétique et de la théorie des nombres

Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Base_(arithmétique)&oldid=101757402 ».

Catégorie :

  • Arithmétique

Catégories cachées :

  • Article contenant un appel à traduction en anglais
  • Article à référence souhaitée
  • Portail:Arithmétique et théorie des nombres/Articles liés
  • Portail:Sciences/Articles liés
  • Projet:Mathématiques/Articles


Système décimal

Un article de Wikipédia, l'encyclopédie libre.

Le système décimal est un système de numération utilisant la base dix. Dans ce système, les puissances de dix et leurs multiples bénéficient d'une représentation privilégiée.

Sommaire

  • 1 Numérations décimales
  • 2 Systèmes de notation
  • 3 Historique
  • 4 Bases combinées
    • 4.1 Numération décimale combinée avec une base auxiliaire
    • 4.2 Numération décimale utilisée comme système auxiliaire
  • 5 Systèmes d'unités
  • 6 Avantages et inconvénients
  • 7 Mathématiques
    • 7.1 Conversion vers la base N d'un nombre écrit en base décimale
    • 7.2 Conversion vers la base décimale d'un nombre écrit en base N
  • 8 Voir aussi
    • 8.1 Bibliographie
    • 8.2 Articles connexes
  • 9 Notes et références

Numérations décimales

Le système décimal est largement le plus répandu. Ainsi sont constituées, par exemple, les numérations :

  • arabe,
  • arménienne,
  • chinoise,
  • égyptienne,
  • gotique,
  • grecque,
  • hébraïque,
  • indienne,
  • japonaise,
  • mongole,
  • romaine,
  • tchouvache,
  • thaï.

Systèmes de notation

Les peuples ayant une base de numération décimale ont employé, au cours du temps, des techniques variées pour représenter les nombres. En voici quelques exemples.

  • Avec des chiffres pour un, dix, cent, mille, etc.

Les systèmes de numération dont les chiffres représentent les puissances de dix sont de type additif. C'est le cas de la numération égyptienne. Exemple : 1506 s'écrit

Hiero chiffre 100.png Hiero chiffre 100.png Hiero chiffre 100.png | Hiero chiffre 1.png Hiero chiffre 1.png Hiero chiffre 1.png
Hiero chiffre 100.png Hiero chiffre 100.png | Hiero chiffre 1.png Hiero chiffre 1.png Hiero chiffre 1.png

en écriture hiéroglyphique (1000+100+100+100+100+100+1+1+1+1+1+1).

  • Avec des chiffres pour un, cinq, dix, cinquante, cent, cinq cents, etc.

De tels systèmes de numération sont aussi de type additif, mais font intervenir un système quinaire auxiliaire. C'est le cas des numérations attique, étrusque, romaine et tchouvache. Exemple : 2604 s'écrit MMDCIIII. en chiffres romains (1000+1000+500+100+1+1+1+1). La numération romaine connait également une variante additive et soustractive : 2604, de cette manière, s'écrit MMDCIV. (1000+1000+500+100-1+5).

  • Avec des chiffres pour un, deux, ..., neuf, dix, vingt, ..., cent, deux cents, ..., neuf cents, etc.

Les systèmes de numération employant neuf chiffres pour les unités, ainsi que pour les dizaines, les centaines, etc. sont encore de type additif. C'est le cas des numérations arménienne, arabe alphabétique, gotique, grecque et hébraïque. Exemple : 704 s'écrit ψδ en chiffres grecs ioniques (700+4).

  • Avec des chiffres de un à neuf, et pour dix, cent, mille, etc.

Les systèmes de numération dont les chiffres représentent les unités et les puissances de dix sont de type hybride. C'est le cas des numérations chinoise et japonaise. Exemple : 41007 s'écrit 四万千七 dans le système japonais (4×10000+1000+7). Le système chinois utilise en plus le zéro pour indiquer des positions vides avant les unités : 41007, s'écrit 四萬千〇七 en chiffres chinois (4×10000+1000+0+7).

  • Avec des chiffres de zéro à neuf

Les systèmes de numération dont les chiffres représentent les unités sont de type positionnel. C'est le cas des numérations arabe non-alphabétique, européenne, de la plupart des numérations indiennes et des numérations mongole et thaï. Exemple : 8002 s'écrit ๘๐๐๒ en chiffres thaïs (8002).

Historique

Article détaillé : Écriture décimale positionnelle.

La base dix est très ancienne. Elle découle d'un choix naturel, dicté par le nombre des doigts des deux mains. Les Proto-indo-européens comptaient probablement en base dix. Un système de notation décimale a été mis au point :

  • au IIIe millénaire av. J.-C., par les Égyptiens[1],[2] (le système égyptien était toutefois un système décimal sans positionnement[3],[4]) ;
  • avant -1350, par les Chinois [5] ;
  • vers -650, par les Étrusques ;
  • vers -500, par les Indusiens en sanskrit.

Noter cependant l'usage de systèmes non décimaux, dont voici quelques exemples.

  • Les anciennes civilisations de Mésopotamie (Sumer, Babylone…) utilisaient un système positionnel de base sexagésimale (60) [6],[7],[8],[9].
  • À noter également l'usage de systèmes proto-élamites mixtes, dit bisexagésimaux (binaire, décimal ou sexagésimal suivant la qualification des objets ou des êtres vivants à décompter)[10],[11].
  • La civilisation maya utilisait un système de base 20 en introduisant quelques variantes[12].
  • Le basque (ainsi que les langues celtiques) se fonde aussi sur la base 20. Il en reste quelques traces en français avec la dénomination « quatre-vingt ».

Bases combinées

Numération décimale combinée avec une base auxiliaire

Les numérations décimales utilisent parfois des bases auxiliaires :

  • Un système quinaire auxiliaire est utilisé dans certains systèmes de notation (voir plus haut) et pour l'énonciation des nombres dans certaines langues, comme le wolof.
  • Un système vigésimal auxiliaire est utilisé pour l'énonciation des nombres dans certaines langues, comme en basque, ou « quatre-vingts » en français.

Numération décimale utilisée comme système auxiliaire

  • En français et dans la plupart des langues du monde, le système décimal s'applique, au sens le plus strict, jusqu'à 9 999, chaque puissance de dix étant, de l'exposant un à l'exposant trois, désignée par un terme approprié (101=« dix » ; 102=« cent » ;103=« mille »). Stricto sensu, l'énonciation des nombres supérieurs à 9 999 n'est cependant plus décimale lorsque, parmi les puissances de dix d'exposant supérieur à trois, ne bénéficient d'une dénomination propre que celles qui correspondent à des puissances de mille.
  • La base mille modifie l'écriture en chiffres de la partie entière des grands nombres, afin d'en faciliter la lecture (ex. 12 345 678 s'écrit soit avec des espaces comme en français 12 345 678 soit avec des séparateurs (apostrophe: 12'345'678 le point :12.345.678 ou les virgules 12,345,678 selon les pays), mais on ne doit pas séparer les chiffres de la partie décimale les uns des autres.
  • La numération babylonienne et les systèmes de mesure du temps et des angles en minutes et secondes, sexagésimaux, utilisent un système décimal auxiliaire.
  • La numération maya, bien que vigésimale, laisse apparaitre un système décimal auxilaire dans l'énonciation des nombres.
  • Les langues chinoise et japonaise utilisent la base dix mille avec dix comme base auxiliaire.

Systèmes d'unités

En Chine les mesures de capacité et de poids sont décimalisées vers 170 av. J.-C.. Aux États-Unis, le système monétaire est décimal en 1786. En Europe, la décimalisation des unités est initiée en France à partir du 22 août 1790, date à laquelle Louis XVI demande à l'Académie des Sciences de nommer une commission pour définir les poids et mesures. Cette dernière préconise la division décimale.

Avantages et inconvénients

La plupart des langues vivantes décomposent les nombres en base 10 en raison de certains atouts de celle-ci :

  • le compte sur les dix doigts est très intuitif ainsi que cela a été mentionné ci-dessus ;
  • son ordre de grandeur est satisfaisant, car il permet de réduire considérablement la longueur d'un grand nombre par rapport à la base 2, tout en conservant des tableaux d'additions et de multiplications mémorisables.

Cependant, il a fallu attendre la généralisation de la notation positionnelle, et l'existence d'un algorithme de division adapté à cette notation pour que les unités de mesure perdent progressivement leurs sous-multiples non décimaux. Quand la livre comprenait en France 20 sous de 12 deniers (ou en Grande-Bretagne 20 shillings de 12 pence) les agents économiques appréciaient que cette unité pût être divisée de manière exacte par 20 diviseurs différents (y compris 1 et 240). En 1971, malgré l'informatique qui permet désormais de gérer facilement l'hétérogénéité de rapports non décimaux entre sous-multiples, la Grande-Bretagne n'a pourtant pas hésité à décimaliser sa monnaie.

Mathématiques

Conversion vers la base N d'un nombre écrit en base décimale

Pour passer d'un nombre en base décimale à un nombre en base N, on peut appliquer la méthode suivante :

Soit K le nombre en base décimale à convertir en base N.

  1. Effectuer la division entière de K par N. Soit D le résultat de cette division et R le reste
  2. Si D >= N, recommencer en 1
  3. Sinon, l'écriture en base N de K est égal à la concaténation du dernier résultat et de tous les restes en commençant par le dernier.

Exemple : conversion en base hexadécimale (base seize) du nombre 3257 écrit en base décimale

  • 3257 / 16 = 203,5625 soit
  • 3257 = 203 × 16 + 9
  • 203 = 12 × 16 + 11

Sachant que 11 (onze) se note B et que 12 (douze) se note C, l'écriture de 3257 (trois-mille-deux-cent-cinquante-sept) en base hexadécimale est CB9.

Conversion vers la base décimale d'un nombre écrit en base N

Pour passer d'un nombre en base N à un nombre en base décimale, on peut appliquer la méthode suivante ::

Soit K le nombre en base N à convertir. Pour tout chiffre c de rang r dans K, on calcule c×N r. La représentation de K en base dix est la somme de tous les produits.

Le comptage de r commence à zéro de la droite vers la gauche.

Exemple
Le nombre « 10110 » en base binaire s'écrit en base dix :

1×24 + 0×23 + 1×22 + 1×21 + 0×20 = 22 (base dix)

Exemple
Le nombre « 3FA » en base seize s'écrit en base décimale :

3×162 + 15×161 + 10×160 = 1 018 (base dix)

Rappel : F en base seize vaut quinze, A en base seize vaut dix.

Voir aussi

Bibliographie

  • Maurice Caveing, Essai sur le savoir mathématique dans la Mésopotamie et l'Égypte anciennes, Presses Univ. Septentrion,‎ 1994, 417 p. (ISBN 285939415X), p. 243,244
  • Walter William Rouse Ball, A Short account of the history of mathematics, réédition (2001), Dover Publications,(ISBN 1402700539) Document utilisé pour la rédaction de l’article
  • (en) Robert Temple, Le génie de la Chine: 3 000 ans de découvertes et d'inventions,‎ 2007 (ISBN 9782877309479)
  • (ru) Igor Mikhailovich Diakonov, « Some reflections on numerals in Sumerian towards a history of mathematical speculation', Journal of the American Oriental Society, » Moscou, 1983 Document utilisé pour la rédaction de l’article
  • (ru) Igor Mikhailovich Diakonov Scientific concepts in the ancient East Sumer, Babylon and the Near East, Historical outlines of natural scientific knowledge in antiquity, édition Shamin, Moscou, 1982 Document utilisé pour la rédaction de l’article
  • (en) Asger Aaboe, « Some Seleucid mathematical tables, Journal of Cuneiform Studies » Yale University, New Haven, Connecticut, États-Unis, 1968, The American Schools of Oriental Research.
  • Évolution des cultures de l'humanité (Les informations présentes sur ce site ne sont plus a jour.)
  • Mesurer

Articles connexes[modifier | modifier le code]

  • Chiffre
  • Système de numération
  • Écriture décimale positionnelle
  • Développement décimal
  • Nombre décimal
  • Décimalisation
  • Système quinaire
  • Système vigésimal
  • Système sexagésimal
  • Nombres en français
  • Notation positionnelle
  • Système décimal sans zéro
  • Bureau international des poids et mesures

Notes et références[modifier | modifier le code]

  1. ↑ Maurice Caveing, Essai sur le savoir mathématique dans la Mésopotamie et l'Égypte anciennes, Presses Univ. Septentrion,‎ 1994, 417 p. (ISBN 285939415X), p. 243,244.
  2. ↑ Walter William Rouse Ball A Short account of the history of mathematics, Dover Publications, 2001, chapitre I, p. 2, et 4 early egyptian arithmetic ( l'arithmétique dans la haute antiquité égyptienne), p. 3 early egyptian mathemathic, p. 5 egyptian and phoenician mathematics, p. 6, 7 et 8 early egyptian geometry (avec référence au papyrus de Rhind et à PI), p. (ISBN 1402700539)
  3. ↑ Voir page 13 in The mathematics of Egypt, Mesopotamia, China, India, and Islam: a sourcebook, Victor J. Katz & Annette Imhausen, Princeton University Press, 2007
  4. ↑ Voir [ http://books.google.com/books?id=WHjO9K6xEm4C&pg=PA118#v=onepage&q=&f=false page 118] in Encyclopedic dictionary of mathematics - EDM 2, Kiyosi Itô, MIT Press, 2000
  5. ↑ Temple 2007, p. 152-154.
  6. ↑ Voir page 104 in La science antique et médiévale, René Taton, Quadrige P.U.F., 1966
  7. ↑ Voir pages 20-21 in Histoire des sciences sous la direction de Philippe de la Cotardière, Tallandier, 2004 - Extraits : « Au début du IIe millénaire, alors que l'écriture cunéiforme est désormais en place, un système numérique unique s'impose. Il s'agit d'un système de numération sexagésimale, c'est-à-dire fondé sur la base soixante, et non sur la base décimale qui nous est familière. »
  8. ↑ Voir pages 40-41 in The Technology of Mesopotamia, Graham Faiella, Rosen Publishing, 2006
  9. ↑ Voir page 77 in The Princeton companion to mathematics sous la direction de Timothy Gowers, June Barrow-Green et Imre Leader, Princeton University Press, 2008
  10. ↑ Voir pages 111-114 in 'The first writing: script invention as history and process, sous la direction de Stephen D. Houston, Cambridge University Press, 2004
  11. ↑ Voir aussi page 341 in Abstraction and representation: essays on the cultural evolution of thinking, Peter Damerow, Luwer Academic Publishers, 1996
  12. ↑ Voir page 16 in Fleeting Footsteps – Tracing the Conception of Arithmetic and Algebra in Ancient China, Lay Yong Lam & Tian Se Ang, World Scientific Publishing, 2004. Extraits (concernant la base de numération maya): « it began as vigesimal after the unit 1 to 19, but then went on to three hundred and sixties, and eventually (in the four place) to seven thousand two hundred).»
v · d · m Base de numération positionnelle
1 à 9 | unaire (1), binaire (2), trinaire (3), quaternaire (4), quinaire (5), sénaire (6), septénaire (7), octal (8), nonaire (9) | Mathématiques
10 à 60 | décimal (10), duodécimal (12), tridécimal (13), hexadécimal (16), vicésimal (20), base 36, sexagésimal (60)
Autre base | base d'or (φ),
Notions | base • chiffre • nombre • notation positionnelle • numération • numération Bibi

· Portail des mathématiques Portail des mathématiques

Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Système_décimal&oldid=106061310 ».

Catégorie :

  • Système de numération

Catégories cachées :

  • Portail:Mathématiques/Articles liés
  • Portail:Sciences/Articles liés
  • Projet:Mathématiques/Articles


Système hexadécimal

Un article de Wikipédia, l'encyclopédie libre.

0hex | = | 0dec | = | 0oct | 0 | 0 | 0 | 0
1hex | = | 1dec | = | 1oct | 0 | 0 | 0 | 1
2hex | = | 2dec | = | 2oct | 0 | 0 | 1 | 0
3hex | = | 3dec | = | 3oct | 0 | 0 | 1 | 1
4hex | = | 4dec | = | 4oct | 0 | 1 | 0 | 0
5hex | = | 5dec | = | 5oct | 0 | 1 | 0 | 1
6hex | = | 6dec | = | 6oct | 0 | 1 | 1 | 0
7hex | = | 7dec | = | 7oct | 0 | 1 | 1 | 1
8hex | = | 8dec | = | 10oct | 1 | 0 | 0 | 0
9hex | = | 9dec | = | 11oct | 1 | 0 | 0 | 1
Ahex | = | 10dec | = | 12oct | 1 | 0 | 1 | 0
Bhex | = | 11dec | = | 13oct | 1 | 0 | 1 | 1
Chex | = | 12dec | = | 14oct | 1 | 1 | 0 | 0
Dhex | = | 13dec | = | 15oct | 1 | 1 | 0 | 1
Ehex | = | 14dec | = | 16oct | 1 | 1 | 1 | 0
Fhex | = | 15dec | = | 17oct | 1 | 1 | 1 | 1

Le système hexadécimal est un système de numération positionnel en base 16. Il utilise ainsi 16 symboles, en général les chiffres arabes pour les dix premiers chiffres et les lettres A à F pour les six suivants.

Le système hexadécimal est utilisé notamment en électronique numérique et en informatique car il est particulièrement commode et permet un compromis entre le code binaire des machines et une base de numération pratique à utiliser pour les ingénieurs. En effet, chaque chiffre hexadécimal correspond exactement à quatre chiffres binaires (ou bits), rendant les conversions très simples et fournissant une écriture plus compacte. L'hexadécimal a été utilisé la première fois en 1956 par les ingénieurs de l'ordinateur Bendix G-15.

Sommaire

  • 1 Étymologie
  • 2 Écriture des entiers
  • 3 Utilisation, avantages et inconvénients
  • 4 Conversion
  • 5 Notation
  • 6 Système bibi-binaire
  • 7 Codage des couleurs
  • 8 Notes et références
  • 9 Voir aussi

Étymologie[modifier | modifier le code]

L'adjectif hexadécimal provient de la juxtaposition de hexa et de décimal. Le préfixe hexa provient du grec ἕξ (hex) qui signifie six alors que décimal est un terme de provenance latine. Le choix a été fait dans l'appellation d'écrire 6+10 au lieu de 16, pour insister sur l'ajout de six chiffres supplémentaires par rapport au système décimal, système largement diffusé aux États-Unis.

Pour obtenir une cohérence dans l'étymologie tout en conservant l'écriture 6+10, la documentation Bendix utilisait l'appellation sexadécimal ; mais l'appellation fut rejetée, jugée trop risquée. Selon Schwartzman[1], les pirates informatiques auraient été tentés d'utiliser l'abréviation sex. Selon Knuth [2] la bonne appellation aurait dû être senidenary ou en français système sénidénaire, dont la construction étymologique est la même que système binaire.

Écriture des entiers[modifier | modifier le code]

Le système hexadécimal nécessite l'introduction de 16 chiffres, représentant les 16 premiers entiers naturels :

0 ; 1 ; 2 ; 3 ; 4 ; 5 ; 6 ; 7 ; 8 ; 9 ; A ; B ; C ; D ; E ; F.

Un entier est écrit comme la concaténation de ces chiffres, et sa lecture s'effectue de droite à gauche. Sa valeur vaut la somme des chiffres affectés de poids correspondant aux puissances successives du nombre 16. Par exemple, 4D516 vaut 5 * 160 + 13 * 161 + 4 * 16 2 = 123710.

L'addition s'effectue à partir de la technique de l'addition et de la table d'addition suivante :

+ | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | A | B | C | D | E | F
0 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | A | B | C | D | E | F
1 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | A | B | C | D | E | F | 10
2 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | A | B | C | D | E | F | 10 | 11
3 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | A | B | C | D | E | F | 10 | 11 | 12
4 | 4 | 5 | 6 | 7 | 8 | 9 | A | B | C | D | E | F | 10 | 11 | 12 | 13
5 | 5 | 6 | 7 | 8 | 9 | A | B | C | D | E | F | 10 | 11 | 12 | 13 | 14
6 | 6 | 7 | 8 | 9 | A | B | C | D | E | F | 10 | 11 | 12 | 13 | 14 | 15
7 | 7 | 8 | 9 | A | B | C | D | E | F | 10 | 11 | 12 | 13 | 14 | 15 | 16
8 | 8 | 9 | A | B | C | D | E | F | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17
9 | 9 | A | B | C | D | E | F | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18
A | A | B | C | D | E | F | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19
B | B | C | D | E | F | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 1A
C | C | D | E | F | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 1A | 1B
D | D | E | F | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 1A | 1B | 1C
E | E | F | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 1A | 1B | 1C | 1D
F | F | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 1A | 1B | 1C | 1D | 1E

La multiplication s'effectue à partir de la technique de la multiplication par glissement par jalousies et en utilisant la table de multiplication suivante :

x | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | A | B | C | D | E | F
0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
1 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | A | B | C | D | E | F
2 | 0 | 2 | 4 | 6 | 8 | A | C | E | 10 | 12 | 14 | 16 | 18 | 1A | 1C | 1E
3 | 0 | 3 | 6 | 9 | C | F | 12 | 15 | 18 | 1B | 1E | 21 | 24 | 27 | 2A | 2D
4 | 0 | 4 | 8 | C | 10 | 14 | 18 | 1C | 20 | 24 | 28 | 2C | 30 | 34 | 38 | 3C
5 | 0 | 5 | A | F | 14 | 19 | 1E | 23 | 28 | 2D | 32 | 37 | 3C | 41 | 46 | 4B
6 | 0 | 6 | C | 12 | 18 | 1E | 24 | 2A | 30 | 36 | 3C | 42 | 48 | 4E | 54 | 5A
7 | 0 | 7 | E | 15 | 1C | 23 | 2A | 31 | 38 | 3F | 46 | 4D | 54 | 5B | 62 | 69
8 | 0 | 8 | 10 | 18 | 20 | 28 | 30 | 38 | 40 | 48 | 50 | 58 | 60 | 68 | 70 | 78
9 | 0 | 9 | 12 | 1B | 24 | 2D | 36 | 3F | 48 | 51 | 5A | 63 | 6C | 75 | 7E | 87
A | 0 | A | 14 | 1E | 28 | 32 | 3C | 46 | 50 | 5A | 64 | 6E | 78 | 82 | 8C | 96
B | 0 | B | 16 | 21 | 2C | 37 | 42 | 4D | 58 | 63 | 6E | 79 | 84 | 8F | 9A | A5
C | 0 | C | 18 | 24 | 30 | 3C | 48 | 54 | 60 | 6C | 78 | 84 | 90 | 9C | A8 | B4
D | 0 | D | 1A | 27 | 34 | 41 | 4E | 5B | 68 | 75 | 82 | 8F | 9C | A9 | B6 | C3
E | 0 | E | 1C | 2A | 38 | 46 | 54 | 62 | 70 | 7E | 8C | 9A | A8 | B6 | C4 | D2
F | 0 | F | 1E | 2D | 3C | 4B | 5A | 69 | 78 | 87 | 96 | A5 | B4 | C3 | D2 | E1

Utilisation, avantages et inconvénients[modifier | modifier le code]

Ce format est largement utilisé en informatique car il offre une conversion facile avec le système binaire, système employé par les ordinateurs.

Il est en effet possible de traduire du binaire vers de l'hexadécimal et réciproquement, groupe de chiffres par groupe de chiffres. Cette caractéristique s'explique par le fait que 16 (nombre de chiffres dans la base hexadécimale) est lui-même une puissance de 2 (nombre de chiffres de la base binaire), et donc que la quantité d'information d'un chiffre hexadécimal vérifie :

Cette égalité revient à dire que : « À un chiffre dans la base 16, correspondent exactement quatre chiffres dans la base 2. »

Cette facilité de conversion a conduit la notation hexadécimale à être utilisée pour noter des nombres initialement quantifiés ou à destination d'être quantifiés en binaire, l'hexadécimal étant plus compact (quatre fois moins de chiffres) et offrant une meilleure lisibilité pour l'œil humain.

Un avantage supplémentaire de la base 16 est sa concordance avec l'octet, mot de 8 bits auquel correspond aujourd'hui fréquemment un byte, la plus petite unité de stockage adressable. En se basant sur la formule précédente, nous pouvons facilement constater qu'à 8 bits correspondent exactement deux chiffres hexadécimaux :

Il est donc commode de noter la valeur d'un octet sur deux chiffres hexadécimaux.

La table ASCII a été construite de façon à faire commencer les suites de symboles élémentaires (chiffres, lettres minuscule, lettres majuscules) à des positions remarquables lorsqu'elles sont exprimés en binaire, octal ou hexadécimal.

Par exemple, la lettre « A » correspond ainsi au code hexadécimal 41 (40 + la position de la lettre dans l'alphabet), le chiffre « 0 » correspond au code hexadécimal 30 (30 + la valeur du chiffre).

Les conversions entre le système décimal et l'hexadécimal sont moins aisées que les conversions entre le système décimal et le binaire [3].

Conversion[modifier | modifier le code]

La conversion de binaire en hexadécimal se fait en regroupant les chiffres (les bits) quatre par quatre, ou inversement en remplaçant chaque chiffre hexadécimal par 4 chiffres binaires :

binaire | 1.0101.1010.1010.1100.1111.0111
regroupé par 4 | 1 | 0101 | 1010 | 1010 | 1100 | 1111 | 0111
regroupé en hexadécimal | 1 | 5 | A | A | C | F | 7
hexadécimal | 15AACF7
(Décimal) | 22719735

La conversion vers le système décimal est réalisée en effectuant la somme

où n est le nombre de chiffres et où [image] est la valeur du chiffre hexadécimal à la position i.

Ainsi 15AACF7 se convertit en décimal de la façon suivante

1×166 + 5×165 + 10×164 + 10×163 + 12×162 + 15×161 + 7×160 = 22719735.

La conversion du décimal vers l'hexadécimal se fait par une suite de divisions entières ou bien en utilisant le binaire comme base intermédiaire.

Notation[modifier | modifier le code]

Des notations sont utilisées, notamment dans les langages informatiques, pour différencier sans ambiguïté les chiffres hexadécimaux des autres :

  • notation préfixée : 0x123 (langage C et dérivés), &h123 (BASIC), $123 (en Pascal, et dérivés comme le VHDL en électronique), mais aussi #123 (Common Lisp), 0h123 (Texas Instrument) ou X'123' (COBOL)
  • notation suffixée : 123h, [image] (arithmétique)

Voir aussi nombres hexadécimaux dans l'article Wikipédia:Conventions typographiques.

Système bibi-binaire[modifier | modifier le code]

Le chanteur et humoriste Boby Lapointe avait inventé en 1968 un système hexadécimal, appelé système bibi-binaire à la fois drôle et cohérent.

Codage des couleurs[modifier | modifier le code]

Le système hexadécimal est un des modes de codage informatique des couleurs des écrans d'ordinateurs.

Notes et références[modifier | modifier le code]

  1. ↑ (en) Steven Schwartzman, The Words of Mathematics: An Etymological Dictionary of Mathematical Terms Used in English,‎ 1996 (lire en ligne), p. 105
  2. ↑ (en) Donald Knuth, TAOCP, vol. 2,‎ 1969
  3. ↑ en considérant que le produit par 0 ou 1 d'un terme est plus "aisé" qu'un produit par un facteur compris entre 0 à 15

Voir aussi[modifier | modifier le code]

  • Base (arithmétique)
  • Système binaire
  • Système de numération
  • Temps hexadécimal
  • John W. Nystrom
  • Éditeur hexadécimal
v · d · m Base de numération positionnelle
1 à 9 | unaire (1), binaire (2), trinaire (3), quaternaire (4), quinaire (5), sénaire (6), septénaire (7), octal (8), nonaire (9) | Mathématiques
10 à 60 | décimal (10), duodécimal (12), tridécimal (13), hexadécimal (16), vicésimal (20), base 36, sexagésimal (60)
Autre base | base d'or (φ),
Notions | base • chiffre • nombre • notation positionnelle • numération • numération Bibi

· Portail de l’informatique Portail de l’informatique

· Portail des mathématiques Portail des mathématiques

Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Système_hexadécimal&oldid=104150914 ».


Système octal

Un article de Wikipédia, l'encyclopédie libre.

Le système de numération octal est le système de numération de base 8, et utilise les chiffres de 0 à 7. D'après l'ouvrage de Donald Knuth's, The Art of Computer Programming, il fut inventé par le roi Charles XII de Suède.

La numération octale peut être construite à partir de la numération binaire en groupant les chiffres consécutifs en triplets (à partir de la droite). Par exemple, la représentation binaire du nombre décimal 74 est 1001010, que l'on groupe en (00)1 001 010 ; ainsi, la représentation octale est 1 pour 1, 1 pour le groupe 001, et 2 pour le groupe 010, ce qui nous donne 112.

Le système octal est quelquefois utilisé en calcul à la place de l'hexadécimal. Il possède le double avantage de ne pas requérir de symbole supplémentaire pour ses chiffres et d'être une puissance de deux pour pouvoir grouper les chiffres.

Le décompte octal pourrait avoir été utilisé dans le passé à la place du décompte décimal, en comptant soit les trous entre les doigts ou les doigts différents des pouces. Ceci expliquerait l'homonymie en français du mot "neuf" (qui signifie aussi "nouveau"), et pourquoi le latin pour neuf novem est si proche du latin pour le mot nouveau novus. Il pourrait avoir le sens de nouveau nombre. Ce qui expliquerait aussi la racine semblable des mots arabes تسعٌ (neuf) et اتسع (étendre)[1].

Sommaire

  • 1 Notation en informatique
    • 1.1 En BASIC
    • 1.2 En C
    • 1.3 En Java
    • 1.4 En JavaScript
    • 1.5 En Perl
    • 1.6 En Python
  • 2 Notes et références
  • 3 Articles connexes

Notation en informatique

Un nombre qui commence par un 0 (zéro) est considéré dans certains langages comme exprimé dans le système octal. Dans ces langages, 045 est compris comme un nombre octal, qui vaut 37 en décimal. Cependant ce système est rarement utilisé de nos jours, et sa survivance provoque des confusions et des erreurs : la majorité des développeurs ignore ce principe et attend que 045 soit compris comme le nombre décimal 45. Ainsi dans les langages modernes, le préfixe 0 tend à être remplacé par des préfixes plus explicites, ou à être supprimé.

En BASIC

Un nombre octal commence par &O.

En C

Un nombre qui commence par un 0 (zéro) est considéré comme exprimé dans le système octal. Cette notation n'a pas été retenue en C#, où l'octal a disparu.

En Java

Un nombre qui commence par un 0 (zéro) est considéré comme exprimé dans le système octal.

En JavaScript

Le préfixe 0 pour les nombres en octal est officiellement abandonné à partir de la 5e édition d'ECMAScript, et pour éviter les confusions un nombre non nul ne peut plus être écrit en commençant par un 0. Ainsi l'écriture 045 est interdite dans cette version[2]. Cependant, pour des raisons de compatibilité avec les versions précédentes, ce standard n'est pas forcément respecté à la lettre par tous les navigateurs, et l'interprétation des nombres en octal perdure.

En Perl

En Perl 5, un nombre qui commence par un 0 (zéro) est considéré comme exprimé dans le système octal. En Perl 6, ce préfixe a été remplacé par 0o (zéro suivi de la lettre minuscule o)[3].

En Python

Le préfixe 0 pour les nombres en octal a été abandonné. À partir de la version 3 un nombre octal commence par 0o (zéro suivi de la lettre minuscule o) ou 0O (zéro suivi de la lettre capitale O)[4].

Notes et références

  1. ↑ The origin of numbers - Cover Story | UNESCO Courier | Find Articles at BNET.com
  2. ↑ ECMAScript 5e édition: http://www.ecma-international.org/publications/files/ECMA-ST/Ecma-262.pdf
  3. ↑ http://perlcabal.org/syn/S02.html#Radix_markers
  4. ↑ http://docs.python.org/3.1/reference/lexical_analysis.html#literals

Articles connexes

  • Système hexadécimal
v · d · m Base de numération positionnelle
1 à 9 | unaire (1), binaire (2), trinaire (3), quaternaire (4), quinaire (5), sénaire (6), septénaire (7), octal (8), nonaire (9) | Mathématiques
10 à 60 | décimal (10), duodécimal (12), tridécimal (13), hexadécimal (16), vicésimal (20), base 36, sexagésimal (60)
Autre base | base d'or (φ),
Notions |


Système quaternaire

Un article de Wikipédia, l'encyclopédie libre.

Le système quaternaire est le système de numération de base 4. Il utilise les chiffres 0, 1, 2 et 3 pour représenter n'importe quel nombre réel

Il partage avec tous les systèmes de numération à radical fixé plusieurs propriétés, telle que la capacité à représenter n'importe quel nombre réel avec une représentation canonique (presque unique) et les caractéristiques des représentations des nombres rationnels et des nombres irrationnels. Voir le système décimal et le système binaire pour une discussion de ces propriétés.

Comme le système octal et le système hexadécimal, le système quaternaire possède une relation spéciale avec le système binaire. Chaque base 4, 8 et 16 est une puissance de 2, donc la conversion de et vers le binaire est implémentée en faisant coïncider chaque chiffre avec 2, 3 ou 4 chiffres binaires, ou bits. Par exemple, en base 4,

302104 = 11 00 10 01 002

Alors que l'octal et l'hexadécimal sont largement utilisés en calcul et en programmation dans les analyses et les discussions d'arithmétique et logique binaire, le système quaternaire n'a pas le même statut.

De manière intéressante, des parallèles peuvent être faits entre le système quaternaire et la manière dont le code génétique est représenté par l'ADN. Les quatre nucléotides de l'ADN dans l'ordre alphabétique, en abrégé A, C, G et T, peuvent être prises pour représenter les chiffres quaternaires dans l'ordre numérique 0, 1, 2, et 3. Avec ce code, les paires de chiffres complémentaires 0 ↔ 3, et 1 ↔ 2 (binaire 00 ↔ 11 et 01 ↔ 10) coîncident avec la complémentarité des paires de bases : A ↔ T et C ↔ G.

Par exemple, la séquence de nucléotide GATTACA peut être représentée par le nombre quaternaire 20330104 (= 915610).

Anecdotes

Le système de numération Shadok utilise le système quarternaire (Ga = 0, Bu = 1, Zo = 2, Meu = 3).

Boby Lapointe surnomme le système quaternaire "bi-binaire" (et le système hexadécimal "bibi-binaire").


Système binaire

Exemple d'informations binaires 010110101100000101011010110000010101101011000001

Le système binaire est un système de numération utilisant la base 2. On nomme couramment bit (de l'anglais binary digit, soit « chiffre binaire ») les chiffres de la numération binaire positionnelle.

Ceux-ci ne peuvent prendre que deux valeurs, notées par convention 0 et 1.

C'est un concept essentiel de l'informatique. En effet, les processeurs des ordinateurs actuels sont composés de transistors ne gérant chacun que deux états.

Un calcul informatique n'est donc qu'une suite d'opérations sur des paquets de 0 et de 1, appelés octets lorsqu'ils sont regroupés par huit.

Sommaire

  • 1 Définition
    • 1.1 Énumération des premiers nombres
    • 1.2 Opérations
  • 2 Théorie informatique
    • 2.1 Représentation des entiers négatifs
      • 2.1.1 Complément à un
      • 2.1.2 Complément à deux
    • 2.2 Entre les bases 2, 8 et 16
      • 2.2.1 Du binaire vers octal ou hexadécimal
      • 2.2.2 Vers le binaire
    • 2.3 Table des valeurs des groupements de chiffres binaires
  • 3 Code de Gray ou binaire réfléchi
  • 4 Décimal codé binaire (« binary coded decimal », ou BCD)
  • 5 Applications
    • 5.1 Théorie de l'information
    • 5.2 Logique
    • 5.3 Informatique
  • 6 Histoire
  • 7 Notes et références
  • 8 Voir aussi
    • 8.1 Bibliographie
    • 8.2 Articles connexes
    • 8.3 Liens externes

Définition

Le système binaire le plus courant est l'équivalent en base deux de la numération de position que nous utilisons en base dix dans la vie courante.

Dans ce type de codage, chaque nombre est représenté de façon unique par une suite ordonnée de chiffres. Et chaque chiffre représente une puissance de la base. Si on se limite dans un premier temps aux nombres entiers positifs, en base dix ces puissances sont : un (1), dix (représenté par 10), cent (dix fois dix, représenté par 100), mille (dix fois cent, représenté par 1000), dix mille etc. En base deux, ces puissances sont : un (1), deux (représenté lui aussi par 10), quatre (deux fois deux, représenté par 100), huit (deux fois quatre, représenté par 1000), seize (deux fois huit, représenté par 10000) etc.

On voit que la signification des représentations 10, 100, 1000, etc. dépend de la base utilisée : 10 est toujours égale à la base, c'est-à-dire dix en base dix, mais deux en base deux[1]

En base dix, on a besoin de dix chiffres, de zéro à neuf ; en base n, on a besoin de n chiffres, de zéro à n-1 ; et donc en base deux, on a besoin de deux chiffres : zéro et un.

Un nombre qui s'exprime en base B par les quatre chiffres 1101 s'analyse :
, qui donne :

1101 en base B = 10 :

1101 en base B = 8 :

1101 en base B = 2 :

Énumération des premiers nombres

Les premiers nombres, et chiffres de la base de numération 10, s'écrivent :

décimal | binaire | commentaire
0 | 0 | Zéro
1 | 1 | un = base puissance zéro (valable pour toutes les bases, donc deux et dix)
2 | 10 | deux = deux puissance un (un zéro derrière le 1)
3 | 11 |
4 | 100 | quatre = deux puissance deux (deux zéro derrière le 1)
5 | 101 |
6 | 110 |
7 | 111 |
8 | 1000 | huit = deux puissance trois (trois zéro derrière le 1)
9 | 1001 |

Opérations

Les techniques des quatre opérations de base (addition, soustraction, multiplication et division) restent exactement les mêmes qu'en notation décimale, elles sont juste simplifiées de façon drastique parce qu'il n'y a que deux chiffres (zéro et un). Pour la multiplication par exemple, quelle que soit la base, la multiplication par 10 (c’est-à-dire par la base elle-même)[2] se fait en ajoutant un zéro à droite.

Seules changent d'une part la forme de la suite de chiffres qui exprime le résultat (elle ne compte que des zéros et un), d'autre part la signification de cette suite (10 signifie « deux » et non « dix », 100 signifie « quatre » et non « cent », etc.).

exemples : additions, soustractions

On passe d'un nombre binaire au suivant en ajoutant 1, comme en décimal, sans oublier les retenues et en utilisant la table ordinaire (mais réduite à sa plus simple expression) :

 0+0=0    0+1=1    1+0=1   1+1=0 avec 1 retenue
 0-0=0    0-1=1 avec 1 retenue   1-0=1   1-1=0

ainsi:

   11
+   1
 ____
  100

Détail :

1 + 1 = 10           => on pose 0 et on retient 1
1 + 1(retenue) = 10  => on pose 0 et on retient 1
0 + 1(retenue) = 1   => on pose 1 devant 00

Théorie informatique

L'arithmétique binaire (plus simplement le calcul binaire) est utilisé par les systèmes électroniques les plus courants (calculatrices, ordinateurs, etc.) car les deux chiffres 0 et 1 s'y traduisent facilement par la tension ou le passage d'un courant : 0 représentant l'état bas (tension ou courant nul) et 1 l'état haut (tension qui existe, courant qui passe).

Représentation des entiers négatifsPour compléter la représentation des entiers, il faut pouvoir écrire des entiers négatifs. La façon informatique de le faire est prévoir un bit de signe, placé en tête. Un bit de signe nul indique une valeur positive, un bit de signe positionné à 1 indique une valeur négative.

Les informaticiens utilisent deux représentations.

Complément à un

Ce codage, fort simple, consiste à inverser la valeur de chaque bit composant une valeur binaire. Par exemple, pour obtenir -7 :

0111 valeur décimale 7

1000 complément à un

Dans ce système, la valeur 0 a deux représentations : « +0 » et « -0 » (dans notre exemple : 0000 et 1111), ce qui oblige à réaliser 2 tests pour tester la valeur nulle d'un résultat.

Article détaillé : Complément à un.

Complément à deux

Afin de pallier ce défaut, on a introduit la représentation par complément à deux. Celle-ci consiste à réaliser un complément à un de la valeur, puis d'ajouter 1 au résultat.

Par exemple pour obtenir -7:

0111 codage de 7 en binaire
1000 complément à un
1001 on ajoute 1 : représentation de -7 en complément à deux

Le zéro est représenté seulement par 0000

Ce codage a l'avantage de ne pas nécessiter de différenciation spéciale des nombres positifs et négatifs, et évite en particulier le problème d'ordinateurs anciens (Control Data 6600) qui avaient un « +0 » et un « -0 » dont il fallait faire comprendre aux circuits de tests que c'était le même nombre ! Voici une addition de -7 et +9 réalisée en complément à deux sur 4 bits :

-7        1001
+9        1001
__        ____
 2    (1) 0010     (on 'ignore' la retenue)

Avec n bits, ce système permet de représenter les nombres entre -2n-1 et 2n-1-1.

Article détaillé : Complément à deux.

Entre les bases 2, 8 et 16

Du binaire vers octal ou hexadécimal]

Les bases 8 (octale) et 16 (hexadécimale) sont des bases multiples de la base 2. Ces deux bases ont été couramment employées en informatique et pour des raisons pratiques; ces bases étant fortement liées à la base 2 et les nombres écrits dans ces bases étant plus « manipulables » (car d'écriture plus courte) par l'intellect humain. L'écriture de nombres dans ces bases est facilement obtenue par regroupement de chiffres de l'écriture du nombre en base 2.

  • Octal : base 8 avec 8 = 2^3. Il suffit de parcourir le nombre binaire de la droite vers la gauche en regroupant les chiffres binaires 3 par 3 : chaque paquet de 3 (le dernier devant être parfois complété par des 0 à gauche) est l'écriture binaire d'un chiffre en base 8 (08=000, 18=001, 28=010, 38=011, 48=100, 58=101, 68=110, 78=111).
    • 101011011102 va s'écrire 10 101 101 110 et en convertissant la valeur de chacun des blocs en un chiffre octal, on obtient le nombre octal 25568.
  • Hexadécimal : base 16 avec 16 = 2^4. Il suffit de parcourir le nombre binaire de la droite vers la gauche en regroupant les chiffres binaires par 4 par 4 : chaque paquet de 4 bits est la représentation binaire d'un chiffre en base 16. En base 16, il faut 16 symboles et conventionnellement, on utilise les 10 chiffres décimaux suivis des 6 premiers caractères de l'alphabet selon la règle suivante: A16=1010=10102, B16=1110=10112, C16=1210=11002, D16=1310=11012, E16=1410=11102 et F16=1510=11112.
    • 101011011102 va s'écrire 101 0110 1110 et en convertissant la valeur de chacun des blocs en décimal on obtient : 5, 6, 14 c'est-à-dire 56E16.

On pourrait facilement étendre ce principe à toutes les bases qui sont puissances de 2.

Vers le binaire

Il suffit de convertir la valeur de chacun des chiffres sous leur forme binaire.

  • 1A2F16 va s'écrire 1, 10=8+2, 2, 15=8+4+2+1 soit 0001 1010 0010 11112
  • 1568 va s'écrire 1, 5=4+1, 6=4+2 soit 1 101 1102

Table des valeurs des groupements de chiffres binaires

Binaire | Décimal | Octal | Hexadécimal
0000 | 0 | 0 | 0
0001 | 1 | 1 | 1
0010 | 2 | 2 | 2
0011 | 3 | 3 | 3
0100 | 4 | 4 | 4
0101 | 5 | 5 | 5
0110 | 6 | 6 | 6
0111 | 7 | 7 | 7

Binaire | Décimal | Octal | Hexadécimal
1000 | 8 | 10 | 8
1001 | 9 | 11 | 9
1010 | 10 | 12 | A
1011 | 11 | 13 | B
1100 | 12 | 14 | C
1101 | 13 | 15 | D
1110 | 14 | 16 | E
1111 | 15 | 17 | F

Code de Gray ou binaire réfléchi

Article détaillé : code de Gray.

Cette section est vide, insuffisamment détaillée ou incomplète. Votre aide est la bienvenue !

Ce codage permet de ne faire changer qu'un seul bit à la fois quand un nombre est incrémenté ou décrémenté d'une unité.

Le code de Gray, également appelé binaire réfléchi, permet de ne faire changer qu'un seul bit à la fois quand un nombre est incrémenté ou décrémenté d'une unité. Le nom du code vient de l'ingénieur américain Frank Gray qui déposa un brevet sur ce code en 1947[3]. Monsieur Louis Gros publia, à Lyon, en 1872 un opuscule, Théorie du Baguenaudier, par un clerc de notaire lyonnais où ce code était présenté pour la première fois en lien avec un casse-tête[4]. Monsieur Gros fut clerc de notaire puis Conseiller à la Cour d'Appel de Lyon.

codage binaire classique |  | Codage Gray ou binaire réfléchi
0 | 0000 | 0 | 0000
1 | 0001 | 1 | 0001
2 | 0010 | 2 | 0011
3 | 0011 | 3 | 0010
4 | 0100 | 4 | 0110
5 | 0101 | 5 | 0111
6 | 0110 | 6 | 0101
7 | 0111 | 7 | 0100

Pour « calculer » directement le code de Gray d'un entier à partir de celui de son prédécesseur on peut procéder ainsi :

  • lorsqu'il y a un nombre pair de 1 on inverse le dernier bit
  • lorsqu'il y a un nombre impair de 1 on inverse le bit directement à gauche du 1 le plus à droite.

Le code de Gray est utilisé entre autres sur une roue codeuse.

Décimal codé binaire (« binary coded decimal », ou BCD)

Afin de concilier la logique binaire de l'ordinateur avec la logique humaine, on peut convertir en binaire, plutôt que les nombres eux-mêmes, chacun des chiffres qui les composent en notation décimale positionnelle. Chacun de ces chiffres est alors codé 4 bits :

1994 =  0001    1001   1001   0100
      1×1000 + 9×100 + 9×10 + 4×1

Avec n bits (n multiple de 4), il est possible de représenter les nombres entre 0 et 10n/4-1. Soit approximativement entre 0 et 1.778n-1. Le BCD est un code redondant, en effet certaines combinaisons ne sont pas utilisées (comme 1111 par exemple).

Cette représentation évite par construction tous les problèmes gênants de cumul d'arrondi qui interviendraient lors de la manipulation de grands nombres dépassant la taille des circuits en arithmétique entière et obligent à recourir au flottant. Il est cependant possible de manipuler des nombres à précision arbitraire en utilisant un codage plus efficace que le BCD.

Il existe des variantes du codage BCD :

  • code Aiken où 0, 1, 2, 3, 4 sont codés comme en BCD et 5, 6, 7, 8, 9 sont codés de 1011 à 1111. Il permet d'obtenir le complément à 9 en permutant les 1 et les 0.
  • codage binaire excédant 3 qui consiste à représenter le chiffre à coder + 3.

Article détaillé : Binary coded decimal.

Applications

Théorie de l'information

Article détaillé : Entropie de Shannon.

En théorie de l'information, l'entropie d'une source d'information est exprimée en bits. La théorie elle-même est indifférente à la représentation des grandeurs qu'elle utilise.

Logique

La logique classique est une logique bivalente: une proposition est soit vraie, soit fausse. Il est donc possible de représenter la vérité d'une proposition par un chiffre binaire. On peut par exemple modéliser les opérations de l'arithmétique binaire à l'aide de l'algèbre de Boole.

L'algèbre de Boole représente un cas très particulier d'usage des probabilités ne faisant intervenir que les seules valeurs de vérité 0 et 1. Voir Théorème de Cox-Jaynes.

Informatique

Le binaire est utilisé en informatique car il permet de modéliser le fonctionnement des composants de commutation comme le TTL ou le CMOS. La présence d'un seuil de tension aux bornes des transistors, en négligeant la valeur exacte de cette tension, représentera 0 ou 1. Par exemple le chiffre 0 sera utilisé pour signifier une absence de tension à 0,5V près, et le chiffre 1 pour signifier sa présence à plus de 0,5V. Cette marge de tolérance permet de pousser les cadences des microprocesseurs à des valeurs atteignant sans problème (hormis d'échauffement) plusieurs gigahertz.

En informatique, la représentation binaire permet de clairement manipuler des bits : chaque chiffre binaire correspond à un bit. Cependant, la représentation binaire nécessitant l'usage de beaucoup de chiffres (même pour des nombres assez petits), elle entraîne d'importants problèmes de lisibilité et donc de risques d'erreur de transcription pour les programmeurs. On préfère donc d'autres représentations : la notation hexadécimale, qui permet de manipuler l'information par paquets de 4 bits, est adaptée à la quasi-totalité des microprocesseurs actuels travaillant avec des mots de 8, 16, 32 ou 64 bits ; plus rare, la notation octale, populaire du temps des premiers mini-ordinateurs DEC à 12 ou 36 bits, qui permet de représenter l'information par paquets de 3 bits.

· 63 (10) = 111111 (2) = 77 (8) = 3F (16)

· 64 (10) = 1000000 (2) = 100 (8) = 40 (16)

· 255 (10) = 11111111 (2) = 377 (8) = FF (16)

· 256 (10) = 100000000 (2) = 400 (8) = 100 (16)


George Boole

Un article de Wikipédia, l'encyclopédie libre.

George Boole

Description de cette image, également commentée ci-après

George Boole, né le 2 novembre 1815 à Lincoln (Royaume-Uni) et mort le 8 décembre 1864 à Ballintemple (Irlande), est un logicien, mathématicien et philosophe britannique. Il est le créateur de la logique moderne, fondée sur une structure algébrique et sémantique, que l'on appelle algèbre de Boole en son honneur.

Il a aussi travaillé dans d'autres domaines mathématiques, des équations différentielles aux probabilités en passant par l'analyse. Autodidacte, il publia ses premiers travaux d'algèbre tout en exerçant son métier d'instituteur et de directeur d'école dans la région de Lincoln. Ses travaux lui valurent en 1844 la Royal Medal de la Royal Society, puis une chaire de mathématiques à l'université (Queen's College) de Cork en 1849.

Sommaire

  • 1 Biographie
  • 2 Postérité
  • 3 Bibliographie en français
  • 4 Note et référence
  • 5 Voir aussi
    • 5.1 Articles connexes
    • 5.2 Liens externes

Biographie

Issu d'une famille pauvre, George Boole n'a pas les moyens financiers d'aller à l'université. Ses capacités intellectuelles sont cependant remarquables ; seul (ou presque), il a appris le latin, l'allemand, le français et l'italien. Obligé de travailler pour soutenir sa famille, il devient enseignant à 16 ans.

Quatre ans plus tard, il fonde et dirige sa propre école. C'est à ce moment que le jeune autodidacte se plonge dans l'étude des mathématiques auxquelles son père l'avait initié dès l'enfance. Bénéficiant des moyens de l'Institut de mécanique de sa ville, il se confronte aux œuvres d'Isaac Newton, Pierre-Simon de Laplace et Joseph-Louis Lagrange. Mais très vite, il commence ses propres recherches. En 1839, il publie ainsi sa première étude dans le Cambridge Mathematical Journal. Cette publication et l'appui qu'il obtient du cercle des algébristes de Cambridge lui permettent de s'imposer petit à petit comme une personnalité importante du monde des mathématiques. En 1844, après la publication d'un mémoire dans les Philosophical Transactions[1] sur une approche algébrique de la théorie des équations différentielles, la Royal Society lui décerne une médaille.

Il épouse le 11 septembre 1855 Mary Everest, nièce de sir George Everest, le responsable de la mission cartographique qui baptisa le mont Everest.

C'est le début d'une série de travaux posant les bases de ce qu'on nommera plus tard l'algèbre de Boole. En 1847 sort Mathematical Analysis of Logic, puis An Investigation Into the Laws of Thought, on Which are Founded the Mathematical Theories of Logic and Probabilities en 1854. Boole y développe une nouvelle forme de logique, à la fois symbolique et mathématique. Le but : traduire des idées et des concepts en équations, leur appliquer certaines lois et retraduire le résultat en termes logiques. Pour cela, il crée une algèbre binaire n'acceptant que deux valeurs numériques : 0 et 1. Cette algèbre est définie par la donnée d'un ensemble E (non vide) muni de deux lois de composition interne (le ET et le OU) satisfaisant à un certain nombre de propriétés (commutativité, distributivité...). Les travaux de Boole, s'ils sont théoriques, n'en trouveront pas moins des applications primordiales dans des domaines aussi divers que les systèmes informatiques, la théorie des probabilités, les circuits électriques et téléphoniques, etc., grâce à des scientifiques comme Peirce, Frege, Russel, Turing et Shannon.

En 1849, George Boole se voit proposer une chaire de professeur des mathématiques au Queen's College de Cork, en Irlande. Et en 1857, il est nommé membre de la Royal Society. Il s'intéresse ensuite aux équations différentielles à travers deux traités qui auront une influence certaine : Treatise on Differential Equations (1859) et Treatise on the Calculus of Finite Differences (1860).

George Boole meurt d'une pneumonie le 8 décembre 1864. Il avait pris froid après s'être rendu au College. Croyant au principe d'analogie, Mary l'avait alité et aspergé d'eau pour le guérir.

Postérité

Ils ont eu cinq filles :

  • Mary, qui épousa le mathématicien Charles Howard Hinton ;
  • Margaret, mère du mathématicien Geoffrey Ingram Taylor ;
  • Alicia, mathématicienne qui collabora avec H.S.M. Coxeter ;
  • Lucy (1862–1904), première femme professeur de chimie au Royal Free Hospital de Londres ;
  • Ethel Lilian, qui se mariera avec Wilfrid M. Voynich en 1893.

Un cratère de la Lune porte son nom.

Bibliographie en français

  • Les lois de la pensée, texte traduit et introduit par Souleymane Bachir Diagne, Paris, Vrin, 1992

Note et référence

  1. ↑ (en) G. Boole, « On a general method in analysis », Philos. Trans. R. Soc., vol. 134,‎ 1844, p. 225-282

Voir aussi

Sur les autres projets Wikimedia :

· George Boole, sur Wikimedia Commons


Logique de base/Algèbre de Boole

Une page de Wikiversité.

Sommaire

  • 1 Introduction
  • 2 Les propriétés
    • 2.1 Propriété de la somme
    • 2.2 Propriété du produit
    • 2.3 Propriété de la négation
    • 2.4 Propriété de la commutativité
    • 2.5 Propriété de l'associativité
    • 2.6 Propriété de la distributivité
    • 2.7 Théorème de De Morgan
  • 3 Exercices

Introduction

Dérivée des mathématiques, l'algèbre de Boole est utilisée par les automaticiens afin de réduire les équations logiques pour éviter de prendre trop de place dans les mémoires d'automates programmables. À l'époque, et pour les automatismes assez importants, la mémoire était un critère important : Il fallait par tous les moyens possibles réduire au minimum cette prise de place.
L'algèbre de Boole est un très bon outil utilisant des règles relativement simples. En algèbre de Boole les variables (a, b, c ....) ne peuvent prendre que deux valeurs : 0 et 1

Les propriétés

Tout d'abord les symboles utilisés en algèbre de Boole bien qu'en apparence similaire à ceux des mathématiques diffèrent dans leurs significations. Ainsi

  • le symbole " + " se lit " ou ". En effet l'expression " a + b = 1 " se lit " a ou b égal à 1 ". Cette condition est vérifiée pour a ou pour b (ou pour les deux en même temps) égale à 1
  • le symbole " . " se lit " et ". En effet l'expression " a . b = 1 " se lit " a et b égal à 1 ". Cette condition est vérifiée pour a et b égal à 1. (Si l'un des deux vaut 0, l'équation n'est pas vérifiée)
  • la variable " [image] " se lit " a barre". Elle prend la valeur opposé de a. Si a = 1 alors [image] = 0 et inversement.

Propriété de la somme

  • a + 1 = 1
  • a + 0 = a
  • a + a = a
  • a + [image] = 1

Propriété du produit

  • a . 1 = a
  • a . 0 = 0
  • a . a = a
  • a . = 0

Propriété de la négation

Propriété de la commutativité

  • a + b = b + a
  • a . b = b . a

Propriété de l'associativité

  • a + b + c = ( a + b ) + c = a + ( b + c )
  • a . b . c = ( a . b ) . c = a . ( b . c )

Propriété de la distributivité

  • a . ( b + c ) = a.b + a.c
  • ( a + b ) . ( c + d ) = a.c + a.d + b.c + b.d
  • a + ( b . c ) = (a+b) . (a+c)

Théorème de De Morgan

Exercices

Image logo représentative de la faculté Voir les exercices sur : Algèbre de Boole.

Logique de base

bouton image vers le chapitre précédent Introduction

Tableau de Karnaugh bouton image vers le chapitre suivant

Récupérée de « http://fr.wikiversity.org/w/index.php?title=Logique_de_base/Algèbre_de_Boole&oldid=422001 »


Algèbre de Boole (structure)

Un article de Wikipédia, l'encyclopédie libre.

Cet article est une ébauche concernant les mathématiques.

Vous pouvez partager vos connaissances en l’améliorant (comment ?) selon les recommandations des projets correspondants.

En mathématiques, une algèbre de Boole, ou parfois anneau de Boole, est une structure algébrique étudiée en particulier en logique mathématique. Une algèbre de Boole peut être définie soit comme une structure ordonnée particulière — c'est un treillis avec plus grand et plus petit élément, dont chacune des deux opérations de borne inférieure et de borne supérieure est distributive par rapport à l'autre, et dont tout élément possède un complément, soit comme un anneau (unitaire) dont tout élément égale son carré.

Pour tout ensemble, l'ensemble de ses parties est une algèbre de Boole, l'ordre associé étant l'inclusion et les lois d'anneau la différence symétrique et l'intersection. Un autre exemple est donné par l'ensemble des formules du calcul propositionnel prises à équivalence (en logique classique) près (sur un nombre de variables de cardinal arbitraire), l'ordre associé est la relation de conséquence logique, les lois d'anneau la disjonction exclusive et la conjonction.

Sommaire

  • 1 Définitions
    • 1.1 Algèbre de Boole comme structure ordonnée
    • 1.2 Algèbre de Boole comme treillis
    • 1.3 Algèbre de Boole comme anneau
  • 2 Exemples d'algèbres de Boole
    • 2.1 L'algèbre de Boole binaire
    • 2.2 Algèbre de Boole des parties d'un ensemble
    • 2.3 Algèbre de Lindenbaum
  • 3 Dualité
  • 4 Sous-algèbres
  • 5 Morphismes
  • 6 Algèbre de Boole complète
  • 7 Atomes
    • 7.1 Définition
    • 7.2 Algèbres de Boole finies
  • 8 Idéaux et filtres
  • 9 Théorème de Stone
  • 10 Notes et références
  • 11 Bibliographie
  • 12 Article connexe

Définitions

Algèbre de Boole comme structure ordonnée

Une algèbre de Boole[1] est un ensemble ordonné (E, ≤) :

  • il existe un plus petit élément, noté dans la suite 0 (il est souvent noté également [image] ), et un plus grand élément noté dans la suite 1 (il est souvent noté également [image] ) ;
  • deux éléments a, b de E ont une borne supérieure, notée dans la suite a ∨ b, et une borne inférieure notée dans la suite a ∧ b (c'est-à-dire que c'est un treillis) ;
  • L'opération ∧ est distributive sur l'opération ∨, et l'opération ∨ est distributive sur l'opération ∧, c'est-à-dire que pour tous a, b et c de E :

a ∧ (b ∨ c) = (a ∧ b) ∨ (a ∧ c),

a ∨ (b ∧ c) = (a ∨ b) ∧ (a ∨ c) ;

  • pour tout élément a de E, il existe un élément a’ de E, appelé complément de E et vérifiant :

a ∧ a’ = 0 et a ∨ a’ = 1.

Ainsi une algèbre de Boole est un treillis distributif, borné (avec plus petit et plus grand élément), et complémenté. Il suffirait de donner une des lois de distributivité, l'une entraînant l'autre dans un treillis (voir l'article lié).

On montre que chaque élément possède un unique complément. En effet si a1 et a’ sont des compléments de a, en utilisant les propriétés des compléments, de l'ordre, et la distributivité on obtient :

a1 = (a ∧ a’) ∨ a1 = (a ∨ a1) ∧ (a’ ∨ a1) = a’ ∨ a1

c'est-à-dire que a1 ≤ a’. De la même façon a1 = a’ ∧ a1, donc a’ ≤ a1, d'où l'égalité.

Par unicité du complément, l'application qui à a associe son complément est involutive (a’’ = a). Elle échange 0 et 1. Également par unicité du complément et par distributivité on montre que le passage au complément échange ∧ et ∨, ce sont les lois de De Morgan (voir paragraphe suivant).

On déduit des axiomes d'ordres que les opérations ∧ et ∨ sont associatives, commutatives, que 0 est neutre pour ∨ et absorbant pour ∧, que 1 est neutre pour ∧ et absorbant pour ∨, et que ces opérations sont idempotentes.

Algèbre de Boole comme treillis

La structure ordonnée précédente est un treillis, et donc il est possible de la définir de façon algébrique, directement en termes des deux opérations binaires que sont la borne inférieure et la borne supérieure, de l'opération unaire de passage au complément, et des deux constantes 0 et 1. Une algèbre de Boole peut alors être définie comme une structure (E, ∧, ∨, (.)', 0, 1) vérifiant pour tous éléments a, b et c de E [2]:

Treillis distributif avec plus petit et plus grand éléments |  |  |
(a ∧ b) ∧ c = a ∧ (b ∧ c) | et | (a ∨ b) ∨ c = a ∨ (b ∨ c) | (associativité)
a ∧ b = b ∧ a | et | a ∨ b = b ∨ a | (commutativité)
a ∧ a = a | et | a ∨ a = a | (idempotence)
1 ∧ a = a | et | 0 ∨ a = a | (élément neutre)
0 ∧ a = 0 | et | 1 ∨ a = 1 | (élément absorbant)
a ∧ (b ∨ c) = (a ∧ b) ∨ (a ∧ c) | et | a ∨ (b ∧ c) = (a ∨ b) ∧ (a ∨ c) | (distributivité)
Complément |  |  |
a ∧ a’ = 0 | et | a ∨ a’ = 1 | (complément)
a’’ = a |  |  | (involutivité du complément)
(a ∧ b)’ = a’ ∨ b’ | et | (a ∨ b)’ = a’ ∧ b’ | (lois de De Morgan)

Les lois d'absorption se déduisent de la distributivité par les lois d'éléments neutres, absorbants et la commutativité ( a ∧ (a ∨ b) = (a ∨ 0 ) ∧ (a ∨ b) = a ∨ (0 ∧ b) = a ∨ 0 = a )

a ∧ (a ∨ b) = a

et

a ∨ (a ∧ b) = a

(absorption)

La relation d'ordre peut se définir de deux façons (la réflexivité de l'ordre se déduit de l'idempotence, l'antisymétrie de la commutativité et la transitivité de l'associativité pour l'opération en jeu) :

a ≤ b équivaut à a ∧ b = a

a ≤ b équivaut à a ∨ b = b

Ce système d'axiomes est facile à exploiter pour les démonstrations, mais il est très redondant. Comme on retrouve la définition de treillis en termes de relation d'ordre à partir des axiomes de treillis, l'involutivité du complément, les lois de De Morgan et le fait que 0 et 1 soient absorbants se déduisent des autres axiomes, comme au paragraphe précédent. Une possibilité (parmi d'autres) est de se restreindre aux seuls axiomes d'élément neutre, de complément, de commutativité et de distributivité[3].

La symétrie du système d'axiomes met en évidence la dualité dans les algèbres de Boole.

Algèbre de Boole comme anneau

De façon équivalente[4], une algèbre de Boole peut également être définie comme un anneau de Boole, c'est-à-dire un anneau dans lequel tout élément est idempotent. La structure (E, +, •, 0, 1) est donc un anneau de Boole si elle vérifie les identités :

(a+b)+c = a+(b+c) | (associativité +)
a+b = b+a | (commutativité +)
0 + a = a | (élément neutre +)
Tout élément a possède un opposé, noté −a :
(-a)+a = 0 | (opposé)
(a•b)•c = a•(b•c) | (associativité •)
1 • a = a | (élément neutre •)
a•(b+c) = a•b+a•c | (distributivité à gauche)
(b+c)•a = b•a+c•a | (distributivité à droite)
a•a = a | (idempotence)

On déduit de l'idempotence du produit, en calculant de deux façons (a + a)2 (distributivités) et en simplifiant, que chaque élément est son propre opposé, c'est-à-dire qu'un anneau de Boole est de caractéristique 2 :

a+a = 0

(un élément est son propre opposé)

On déduit toujours de l'idempotence, en calculant de deux façons (a + b)2, que a•b + b•a = 0, et donc la commutativité de la multiplication, d'après la propriété précédente :

a•b = b•a

(commutativité •)

Les lois d'anneau diffèrent des lois d'algèbre de Boole du paragraphe précédent, en particulier seule la multiplication est distributive sur l'addition.

À partir d'une algèbre de Boole (E, ∧, ∨, 0, 1), on obtient bien un anneau de Boole en posant[5]

  • a•b = a ∧ b
  • a + b = (a ∧ b’ ) ∨ (a’ ∧ b)

les constantes 0 et 1 sont conservées. La vérification des identités d'anneau se fait directement, en utilisant les identités d'algèbre de Boole du paragraphe précédent.

Réciproquement, à partir d'un anneau de Boole (E, +, •, 0, 1) on obtient une algèbre de Boole en posant :

  • a ∧ b = a•b
  • a’ = 1 + a

et en vérifiant que les éléments neutres 0 et 1 sont bien les plus petit et plus grand éléments, que a ∧ b = a•b et :

  • a ∨ b = a + b + a•b

En particulier dans un anneau de Boole on retrouve la structure ordonnée par :

  • a ≤ b si et seulement si a = a•b

Là aussi les vérifications des identités d'algèbre se fait simplement, en utilisant les identités d'anneau de Boole (commutativité et caractéristique 2 comprises).

Dans la suite on appelle algèbre ou anneau de Boole l'une comme l'autre structure.

Exemples d'algèbres de Boole

L'algèbre de Boole binaire

Une algèbre de Boole a au moins deux éléments distincts 0 et 1, et l'algèbre de Boole la plus simple est l'algèbre à deux éléments. On peut la voir comme l'ensemble des deux valeurs de vérité {Faux, Vrai} de la logique classique. En tant qu'anneau c'est Z/2Z, et, à cause de l'idempotence de la loi multiplicative, c'est le seul anneau de Boole intègre, donc le seul qui soit un corps.

Algèbre de Boole des parties d'un ensemble

Article détaillé : Algèbre des parties d'un ensemble.

L'ensemble des parties de n'importe quel ensemble non vide A, ordonné par inclusion est une algèbre de Boole. la borne inférieure est l'intersection, la borne supérieure la réunion, le complément le passage au complémentaire dans A, l'ensemble vide et A sont les éléments neutres, l'addition la différence symétrique. Quand A est un singleton, on retrouve l'algèbre de Boole à deux éléments du paragraphe précédent.

Algèbre de Lindenbaum

Article détaillé : Algèbre de Lindenbaum.

L'ensemble des formules du calcul propositionnel quotientés par la relation d'équivalence logique (deux formules propositionnelles sont équivalentes quand elles ont même table de vérité), avec la relation de déduction comme relation d'ordre est (en logique classique) une algèbre de Boole.

Plus généralement, pour n'importe quelle théorie T du calcul des prédicats, l'ensemble des énoncés (formules closes) du langage de cette théorie quotienté par la relation d'équivalence dans T et avec comme relation d'ordre la relation de déduction dans T, est une algèbre de Boole, l'algèbre de Lindenbaum de la théorie T.

La borne inférieure est donnée par la conjonction, la borne supérieure par la disjonction, le complément par la négation. La classe d'équivalence d'une proposition toujours fausse donne le neutre pour la disjonction, et la classe d'équivalence d'une proposition toujours vraie donne le neutre pour la conjonction. L'addition est donnée par la disjonction exclusive.

L'algèbre de Lindenbaum du calcul propositionnel sur une infinité, par exemple dénombrable, de variables est différente de l'ensemble des parties d'un ensemble, car tout élément possède un minorant strict non nul (par conjonction avec une variable propositionnelle non présente dans la formule) ce qui n'est pas le cas des singletons pour l'ensemble des parties d'un ensemble.

Dualité

Étant donné une expression booléenne écrite avec les seules constantes et opérations de treillis algébrique (0, 1, ∧, ∨, ( )'), le dual de cette expression est celle obtenue en échangeant la borne supérieure ∨ et la borne inférieure ∧ d'une part, 0 et 1 d'autre part. Par exemple voici l'expression de l'addition des anneaux de Boole (différence symétrique) et son expression duale :

le dual de (a ∧ b’ ) ∨ (a’ ∧ b) est (a ∨ b’ ) ∧ (a’ ∨ b)

Cette définition se généralise aux énoncés, par substitution. Pour la seconde définition comme treillis algébrique, les axiomes d'algèbre de Boole sont présentés par paire, l'un des axiomes étant l'énoncé dual de l'autre. Par conséquent à tout théorème des algèbres de Boole énoncé dans ce langage correspond un théorème dual : c'est le principe de dualité pour les algèbres de Boole.

Par exemple les lois d'absorption sont duales l'une de l'autre : il suffit donc d'en démontrer une, et on déduit que l'autre est un théorème par dualité.

La dualité transforme l'ordre en son ordre réciproque : le dual de a ≤ b (a ∧ b = a) est a ≥ b (a ∨ b = a).

On vérifie que le dual d'une expression booléenne f(p1, ... , pn) est (f(p’1, ... , p’n))'.

Sous-algèbres[modifier | modifier le code]

Une sous-algèbre de Boole est un sous-anneau de l'algèbre de Boole en tant qu'anneau unitaire, c'est-à-dire (dans ce cas particulier) un sous-ensemble stable par addition, multiplication et ayant même élément neutre multiplicatif. On montre que les sous-algèbres de Boole sont les sous-ensembles des algèbres de Boole contenant 0 et 1, stables par borne supérieure, borne inférieure et complémentaire (le fait que la sous-algèbre possède, en tant que sous-anneau, le même neutre multiplicatif est indispensable pour que la stabilité par passage au complément). Pour vérifier qu'un sous-ensemble d'une algèbre de Boole est une sous-algèbre, il suffit de vérifier la stabilité par complément, par l'une des deux opérations ∧, ∨ et que 0 ou 1 appartient au sous-ensemble.

Un exemple de sous-algèbre de Boole de l'ensemble des parties d'un ensemble infini est l'ensemble des parties finies et cofinies (c'est-à-dire de complémentaire fini) de ce même ensemble.

Si F est un sous-ensemble strict de E l'ensemble des parties de F est une algèbre de Boole qui est un sous-ensemble de l'ensemble des parties de E, mais qui n'est pas une sous-algèbre de Boole car les éléments maximaux (E et F) ne sont pas les mêmes, de même que les compléments.

Morphismes

Les morphismes d'algèbres de Boole sont les morphismes d'anneaux (unitaires) usuels pour la structure d'anneau de Boole.

De façon équivalente ce sont les morphismes de treillis qui passent au complément (il suffit alors de vérifier que soit les bornes supérieures soit les bornes inférieures sont conservées par les lois de Morgan).

Algèbre de Boole complète

Tout sous-ensemble fini d'une algèbre de Boole possède une borne supérieure et une borne inférieure.

Une algèbre de Boole est dite complète si c'est un treillis complet, c'est-à-dire si tous ses sous-ensembles (finis ou infinis) ont une borne supérieure et une borne inférieure (en fait l'une des deux hypothèses suffit).

Exemples et contre-exemples :

  • toute algèbre de Boole finie est évidemment complète ;
  • l'algèbre de Boole des parties d'un ensemble est complète : toute famille de sous-ensembles possède une borne supérieure, qui est la réunion de ces sous-ensembles, et une borne inférieure, qui est l'intersection de ces sous-ensembles ;
  • l'algèbre de Boole des parties finies et cofinies d'un ensemble infini n'est pas complète ;
  • l'algèbre de Lindenbaum du calcul propositionnel sur une infinité de variables non plus.

Atomes

Dans une algèbre de Boole, la notion d'atome est celle qui correspond aux singletons dans l'algèbre de Boole des parties d'un ensemble. Une algèbre de Boole n'a cependant pas nécessairement d'atomes.

Définition

Un atome[6] d'une algèbre de Boole B est un élément n'ayant d'autre minorant strict que 0 :

a est un atome si et seulement si pour tout élément x de B, 0 ≤ x ≤ a ⇒ (x = 0 ou x = a).

Il est immédiat que les singletons sont des atomes de l'algèbre de Boole des parties d'un ensemble. Celle-ci a de plus la propriété que tout élément non nul est minoré par au moins un atome : une telle algèbre de Boole est dite atomique. Il existe également des algèbres de Boole sans atomes, comme l'algèbre de Lindenbaum du calcul propositionnel sur une infinité de variables.

Algèbres de Boole finies

Toute algèbre de Boole finie est isomorphe à l'ensemble des parties d'un ensemble fini, qui est l'ensemble des atomes de l'algèbre. Son cardinal est donc une puissance de 2.

Idéaux et filtres

Les idéaux d'une algèbre de Boole sont les idéaux de l'algèbre en tant qu'anneau commutatif. La stabilité de l'idéal par multiplication par un élément quelconque de l'algèbre a pour conséquence qu'un idéal est une section initiale de la structure ordonnée. On peut caractériser les idéaux en termes de treillis ; le sous-ensemble I de E est un idéal de l'algèbre de Boole (E, ≤, ∧, ∨, 0, 1) quand il vérifie :

  • 0 ∈ I
  • ∀ x, y ∈ I x ∨ y ∈ I ;
  • ∀ x ∈ I ∀ y∈ E (y ≤ x ⇒ y ∈ I).

Un idéal propre est un idéal différent de l'algèbre tout entière, nécessairement il ne contient pas l'élément maximal 1. Il ne peut donc contenir un élément x et son complément 1 + x.

La notion duale d'idéal propre est celle de filtre : un sous-ensemble de l'algèbre est un filtre si l'ensemble de ses compléments est in idéal. Plus directement le sous-ensemble F de E est un filtre de l'algèbre de Boole (E, ≤, ∧, ∨, 0, 1) quand il vérifie :

  • 1 ∈ F et 0 ∉ F ;
  • ∀ x, y ∈ F x ∧ y ∈ F ;
  • ∀ x ∈ F ∀ y ∈ E (y ≥ x ⇒ y ∈ F).

Un idéal maximal est un idéal maximal au sens de l'inclusion parmi les idéaux propres. La notion duale est celle d'ultrafiltre : un ultrafiltre est un filtre maximal au sens de l'inclusion, et c'est aussi l'ensemble des compléments d'un idéal maximal.

Le théorème de l'idéal maximal, ou théorème de Krull, énonce que tout idéal est inclus dans un idéal maximal. Dans le cas des algèbres de Boole il donne par dualité le théorème de l'ultrafiltre : tout filtre est inclus dans un ultrafiltre.

Le quotient d'une algèbre de Boole par un idéal maximal est le corps à deux éléments {0, 1}, seul anneau de Boole qui soit un corps. De façon générale, dans une algèbre de Boole donnée, il est équivalent de se donner un idéal maximal, un ultrafiltre ou un morphisme de cette algèbre de Boole dans {0,1}.

Théorème de Stone

Article détaillé : Théorème de représentation de Stone pour les algèbres de Boole (en)

Notes et références[modifier | modifier le code]

  1. ↑ Voir Cori et Lascar 1993, p. 96 pour cette caractérisation
  2. ↑ Ce système d'axiomes pour les algèbres de Boole est donné dans Givant et Halmos 2009, p. 10
  3. ↑ d'après Givant et Halmos 2009, p. 10, caractérisation due « essentiellement » à E. V. Huntington (en), dans Sets of independent postulates for the algebra of logic, Transactions of the American Mathematical Society, vol. 5 (1904), pp. 288–309 ; Huntington en a donné plusieurs autres.
  4. ↑ Définition d'Algèbre de Boole dans Cori et Lascar 1993, p. 91
  5. ↑ On prendra garde qu'en calcul booléen, en particulier dans la conception des circuits logiques, notre loi + est notée [image] ou XOR, tandis que notre loi ∨ est notée +.
  6. ↑ Cori et Lascar 1993, p. 99

Bibliographie

  • René Cori et Daniel Lascar, Logique mathématique I. Calcul propositionnel, algèbres de Boole, calcul des prédicats,‎ 1993 [détail des éditions], chap. 2.
  • (en) Steven Givant et Paul Halmos, Introduction to Boolean Algebras, Springer,‎ 2009 (ISBN 978-0-387-40293-2).
  • Daniel Ponasse, Logique mathématique, Chapitre V : Aspect algébrique – Structure d’anneau booléien , éditeur O.C.D.L., Paris, 1967.

Article connexe

Algèbre de Boole libre (en)

· Portail des mathématiques Portail des mathématiques

· Portail de la logique Portail de la logique

Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Algèbre_de_Boole_(structure)&oldid=102895306 ».


Bascule (circuit logique)

Un article de Wikipédia, l'encyclopédie libre.

Une bascule est un circuit logique capable, dans certaines circonstances, de maintenir les valeurs de ses sorties malgré les changements de valeurs d'entrées.

On appellera plus loin verrous les bascules asynchrones (en anglais latch), et bascules les bascules synchrones (en anglais flip-flop).

Sommaire

  • 1 Description
  • 2 Bascules asynchrones, ou verrous (désigné en anglais par le terme latch ou latched)
  • 3 Bascules synchrones
    • 3.1 Avantage de l'horloge
  • 4 Métastabilité
  • 5 Types de bascules et de verrous
    • 5.1 Verrou RS avec porte OU-NON
    • 5.2 Verrou non R non S avec porte ET-NON
    • 5.3 Verrou D
    • 5.4 Bascule RSH - RST
    • 5.5 Bascule JK
      • 5.5.1 Origine du nom de la bascule JK
      • 5.5.2 Bascule D
      • 5.5.3 Bascule T
    • 5.6 Bascule de Schmitt
  • 6 Voir aussi

Description

Une bascule, ou verrou, est un circuit logique doté :

  • d'une ou plusieurs entrées ;
  • d'une ou deux sorties.

Les changements d'état de la sortie sont déterminés par les signaux appliqués aux entrées et le type d'opérateur.

Ce qui différencie les bascules des circuits logiques combinatoires (portes ET, OU, OU Exclusif, etc.), c'est que la sortie maintient son état même après disparition du signal de commande. Comme l'état précédent et la mémorisation interviennent, on parle de logique séquentielle.

La bascule est l'élément de base de la logique séquentielle. En effet, en assemblant des bascules, on peut réaliser des compteurs, des registres, des registres à décalage, des mémoires.

Certaines bascules, appelées à fonctionner dans des systèmes synchrones, possèdent une entrée d'horloge de synchronisation. Il existe donc des bascules asynchrones et des bascules synchrones.

Citons également la bascule de Schmitt, qui est commandée par une tension analogique appliquée à son entrée, mais on sort du domaine des opérateurs logiques séquentiels.

Bascules asynchrones, ou verrous (désigné en anglais par le terme latch ou latched)

Ce sont des bascules dont la sortie ou l'état de mémorisation dépend à tout instant de l'état simultané des entrées. Cette évolution ne dépend que de la succession des combinaisons appliquées, et n'est limitée que par la vitesse de commutation de la bascule et de ses entrées, tandis qu'une bascule synchrone évolue au rythme du signal d'horloge. Si les entrées ont des oscillations imprévisibles avant de se stabiliser, la sortie d'une bascule asynchrone pourra être modifiée selon cette combinaison, alors qu'une bascule synchrone ne tiendra compte que des valeurs à la réception du signal d'horloge. La porte C de Muller est un exemple de bascule asynchrone.

Bascules synchrones

Principe

Ici, l'action des entrées sur l'état de mémorisation ne sera effective qu'à la réception d'un front d'horloge, lorsqu'elle passe de l'état haut à l'état bas, ou inversement (parfois un seul des deux). La sortie est dite synchrone (à H) car directement liée à l'horloge H. De plus, ces bascules peuvent disposer d'entrées asynchrones (Set,Reset) pour prépositionner l'état de sortie à la mise sous tension.

Avantage de l'horloge

Le fait de synchroniser la bascule sur les pulsations d'une horloge permet de s'assurer que sa sortie est bien stabilisée : ce qui se passe entre deux fronts d'horloge ne compte pas. Les pulsations de l'horloge doivent simplement être suffisamment lentes pour que les entrées aient également atteint leur configuration finale.

Métastabilité

Les bascules peuvent entrer dans des états métastables lorsque plusieurs entrées changent simultanément, c'est-à-dire qu'elles peuvent n'offrir une sortie stable qu'au bout d'un temps arbitrairement long. Ce peut être le cas pour le verrou RS si les deux entrées passent ensemble de 1 à 0, ou pour une bascule où un changement de donnée d'entrée est trop proche d'un front d'horloge. On cherche à les éviter, mais ce n'est pas toujours possible, par exemple pour des éléments arbitrant entre deux signaux asynchrones.

Types de bascules et de verrous

Verrous et bascules sont en fait très proches. Dans le cas de verrous, il est possible de réaliser une bascule synchrone en ajoutant une entrée d'horloge CLK, la sortie ne pouvant changer qu'après un front de l'horloge. On ne citera pas alors la bascule ainsi créée, d'implémentation plus complexe.

Verrou RS avec porte OU-NON

R1, R2 = 1 kΩ R3, R4 = 10 kΩ.

Symbole du verrou RS.

L'implémentation utilisant des portes OU-NON.

  • Mise à 1 de S (Set) : la sortie Q passe à 1.
  • Mise à 1 de R (Reset) : la sortie Q passe à 0.
  • R = S = 0 : maintien de l'état précédent des sorties.
  • q est l'état avant le basculement
  • Q est la sortie, non Q est la sortie complémentée
Table de vérité
S | R | Q | non Q | remarque
0 | 0 | q | non q | mémorisation
0 | 1 | 0 | 1 | mise à 0
1 | 0 | 1 | 0 | mise à 1
1 | 1 | 0 | 0 | État Interdit

Verrou non R non S avec porte ET-NON

L'implémentation utilisant des portes ET-NON.

  • Mise à 0 de non S (Set) : la sortie Q passe à 1.
  • Mise à 0 de non R (Reset) : la sortie Q passe à 0.
  • non R = non S = 1 : maintien de l'état précédent des sorties.
  • q est l'état avant le basculement
  • Q est la sortie, non Q est la sortie complémentée
Table de vérité
non S | non R | Q | non Q | Remarque
0 | 0 | 1 | 1 | cas particulier
0 | 1 | 1 | 0 | mise à 1
1 | 0 | 0 | 1 | mise à 0
1 | 1 | q | non q | mémorisation

Verrou D

Ce circuit ressemble au verrou RS, dans la mesure où il possède deux entrées, notées D et H, et une sortie Q. Mais le fonctionnement est différent :

  • quand H est à 0, la sortie maintient son état, quel que soit le niveau appliqué à D ;
  • quand H est à 1, la sortie Q recopie l'état de D ;
  • la sortie Q recopie l'entrée D pour l'état actif de l'horloge H (CLK) ;
  • Q est la sortie, non Q est la sortie complémentée ;
  • q est l'état avant le basculement ;
  • d est l'état appliqué en entrée (optimisation de la table de vérité) ;
  • X est un état quelconque, 0 ou 1.
Table de vérité (optimisée)
D | H (CLK) | Q | non Q | remarque
d | 1 | d | non d | Q recopie D
X | 0 | q | non q | mémorisation

Bascule RSH - RST

Un verrou RSH (aussi appelé RST) est un verrou RS auquel on a ajouté une troisième entrée, généralement notée H (ou CLK pour horloge). Cette troisième entrée a la fonction suivante :

  • si H est au niveau logique 0, la sortie maintient son état, quels que soient les niveaux appliqués aux entrées R et S ;
  • si H est à 1, la bascule RS répond normalement aux commandes appliquées à ses entrées.

En chainant 2 verrous RSH (un maître, l'autre esclave), on réalise une bascule JK (maître-esclave). Équation du verrou :

Bascule JK

Symbole de la bascule JK à front montant.

  • Pour J = K = 0, le signal d'horloge est sans effet, il y a conservation du dernier état logique pris par Q et non Q : il n'y a jamais de basculement.
  • Pour J = K = 1, le système bascule à chaque front d'horloge (montant ou descendant selon les modèles).
  • Pour J différent de K, la sortie Q recopie l'entrée J et la sortie non Q recopie l'entrée K à chaque front d'horloge.
  • On utilise cette bascule pour faire des compteurs. On compte jusqu'à 2n avec n bascules à la suite et on compte dans l'ordre croissant avec des bascules à front descendant et dans l'ordre décroissant avec des bascules à front montant.
Table de vérité
J | K | Qn+1
0 | 0 | Qn
0 | 1 | 0
1 | 0 | 1
1 | 1 | non Qn

Table de vérité alternative
Qn | Qn+1 | J | K | remarque
0 | 0 | 0 | X | pour que la sortie reste à 0, il faut que J soit à 0, peu importe K.
0 | 1 | 1 | X | pour que la sortie passe de 0 à 1, il faut que J soit à 1, peu importe K.
1 | 0 | X | 1 | pour que la sortie passe de 1 à 0, il faut que K soit à 1, peu importe J.
1 | 1 | X | 0 | pour que la sortie reste à 1, il faut que K soit à 0, peu importe J.

Équation de la bascule :

Chronogramme.

Origine du nom de la bascule JK

L'origine du nom de la bascule JK est détaillée par P. L. Lindley, un ingénieur de JPL, dans un article du magazine de conception électronique EDN. L'article est daté du 13 juin 1968 et a été publié dans l'édition d'Août. Dans cet article, M. Lindley explique que c'est le docteur Eldred Nelson, un scientifique de Hughes Aircraft qui a inventé le terme de bascule JK.

Les bascules qui étaient utilisées à cette époque à Hughes étaient toutes du même type, celui de la future bascule J-K. Durant la conception d'un système logique le docteur Nelson a assigné des lettres à chaque entrée des bascules de la façon suivante :

  • bascule 1, les lettres A et B,
  • bascule 2, les lettres C et D,
    …
  • bascule 5, les lettres J et K,
    …

Étant donné la taille du système sur lequel travaillait le docteur Nelson, il s'est rendu compte qu'il allait être à court de lettres. Puisque les lettres J et K étaient peu utilisées dans les systèmes électroniques il a donc décidé d'utiliser ces lettres comme entrées "set" et "reset" pour toutes les bascules de son système (avec des indices pour les distinguer les unes des autres).

Le docteur Montgomery Phister, un membre de l'équipe du docteur Nelson à Hughes, a repris dans son livre Logical Design of Digital Computers (Wiley, 1958) l'idée que les entrées "set" et "reset" des bascules utilisées à Hughes Aircraft étaient nommées J et K. De ce fait il est alors amené à les désigner sous le terme de bascule JK. Dans ce même livre il a aussi défini les bascules R-S, T, D et R-S-T et a montré qu'en utilisant l'algèbre de Boole il était possible de les combiner afin de réaliser des fonctions complexes.

Bascule D

Symbole de la bascule D.

La bascule D (pour Data) est une bascule JK à laquelle on a ajouté un inverseur entre les entrées J et K. Il y a donc une seule entrée, qui est notée D (pour Donnée ou Data). La table de vérité est la table de vérité d'une JK, limitée aux deux lignes J = 0, K = 1 et J = 1, K = 0.

  • La bascule D la plus simple possède 2 entrées (entrée D et l'horloge) et une sortie Q. À chaque front (ici montant) d'horloge, Q recopie l'entrée D.
  • Parfois, un signal reset existe afin de pouvoir initialiser la valeur initiale de la bascule lors de la mise sous tension.
  • Il existe des versions où les changements d'état ont lieu au moment des fronts descendants de l'horloge. Elles se signalent par une barre supplémentaire (en dessous à 45°) sous l'entrée Clock.

Sa fonction est donc "mémoire" puisque l'information en entrée se retrouve en sortie après un "coup d'horloge" (un front).

Table de vérité
D | Ck | Qn+1 | non Qn+1
0 |  | 0 | 1
1 |  | 1 | 0
X | 0 | Qn | non Qn

Table de vérité (optimisée)
D | CLK | Q | non Q | remarque
d |  | d | non d | Q recopie D
X | 1,0,front descendant | q | non q | mémorisation

Équation de la bascule : Q_{n+1} = D

Bascule T

La bascule T tire son nom du terme anglais 'toggle'. Si son entrée T est active, elle bascule à chaque impulsion d'horloge d'où son nom. Si son entrée T est inactive, elle conserve son état.
Elle n'existe pas intégrée sauf dans des PLD, FPGA… mais on peut la fabriquer avec une bascule D en reliant la sortie non Q à l'entrée D (toutefois on ne réalise ainsi qu'une bascule T avec T=1), ou à l'aide d'une bascule JK en reliant J et K pour faire l'entrée T.
Comme la bascule T a la propriété de basculer à chaque impulsion d'horloge, elle réalise donc une division de fréquence par 2 ; elle servira aussi de base à la réalisation de compteurs (association simple si actives au front descendant de l'horloge).

  • Q est la sortie, non Q est la sortie complémenté
  • q est l'état avant le basculement
  • si T=1, on bascule à chaque impulsion d'horloge
  • si T=0, la sortie ne change pas (mémorisation)
  • intégrée dans un circuit, elle est souvent active sur un front descendant
  • francisation
Table de vérité (optimisée)
T | CLK | Q | non Q | remarque
1 |  | non Q | q | basculement
1 | 0,1, | q | non Q | mémorisation
0 | 0,1, [image] , | q | non Q | mémorisation

Bascule de Schmitt

Article détaillé : Bascule de Schmitt.

On l'appelle aussi Trigger de Schmitt ou bascule à seuil.

Symbole.

C'est une bascule à trois entrées V, SB et SH et une sortie Q. Contrairement aux bascules citées ci-dessus, qui sont commandées en appliquant des signaux logiques à leurs entrées, la bascule de Schmitt est conçue pour être pilotée par une tension analogique, c'est-à-dire qui peut prendre n'importe quelle valeur (dans l'intervalle 0 - Vcc afin de ne pas dégrader le circuit).

Les entrées SB et SH (seuil bas, seuil haut, ce dernier étant à un potentiel supérieur à SB) sont maintenues à des potentiels fixes ; ceci peut se faire par exemple grâce à un diviseur de tension composé de 3 résistances placées en série entre Vcc et la masse ; SH et SB sont reliés aux points intermédiaires du diviseur.

Chronogramme.

Le fonctionnement est le suivant :

  • supposons qu'au départ, V soit à 0 ; Q est alors à 0 ;
  • quand V augmente, Q reste à 0 jusqu'à ce que V dépasse SH ; à ce moment, Q passe à 1 ;
  • Q reste à 1 jusqu'au moment où V devient inférieur à SB ; à ce moment, Q passe à 0 ;
  • Q reste à 0 jusqu'à ce que V repasse au-dessus de SH.

La principale application de la bascule de Schmitt est la mise en forme de signaux analogiques pour les appliquer à des circuits logiques (par exemple une entrée de compteur).

La bascule de Schmitt peut aussi être utilisée pour :

  • débarrasser un signal du bruit ; il suffit que l'écart entre SH et SB soit supérieur à l'amplitude crête-à-crête du bruit ;
  • réaliser des circuits de contrôle avec hystérésis : thermostats, interrupteurs crépusculaires, maintien du niveau dans une cuve...
  • le trigger de Schmitt est l'ancêtre des générateurs de musique, miniaturisé dans les sonneries des montres électroniques, les sonneries des téléphones portables, les Game-Boy et autres jeux électroniques, les alarmes électroniques, les cartes de vœux parlantes, les boîtes à musique et horloges électroniques, etc. Le fameux bip des premiers ordinateurs dans les années 1980 était un signal rectangulaire.

Voir aussi

Sur les autres projets Wikimedia :

· Bascules électroniques, sur Wikiversity

· Portail de l’électricité et de l’électronique Portail de l’électricité et de l’électronique

Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Bascule_(circuit_logique)&oldid=105490086 ».

Catégorie :

  • Circuit intégré logique

Catégorie cachée :

  • Portail:Électricité et électronique/Articles liés


Fonction logique

Un article de Wikipédia, l'encyclopédie libre.

Il existe deux grands types de fonctions logiques :

  • les fonctions logiques « combinatoires », bases du calcul booléen, qui résultent de l'analyse combinatoire des variations des grandeurs d'entrées uniquement.
  • les fonctions logiques « séquentielles » ou bascules, qui résultent de l'association de plusieurs fonctions logiques « combinatoires » synchronisées grâce à une "horloge" qui donne le tempo; les valeurs de sorties dépendent non seulement des valeurs d'entrée, mais aussi de l'instant ou elles sont mesurées (avant ou après la synchronisation par l'horloge).

Les fonctions logiques combinatoires directement issues des mathématiques (algèbre de Boole) sont les outils de base de l'électronique numérique. Elles sont mises en œuvre en électronique sous forme de portes logiques. Ainsi les circuits électroniques calculent des fonctions logiques de l'algèbre de Boole. Ces portes électroniques sont construites à partir de plusieurs transistors connectés de manière adéquate.

Dans d'autres applications, on peut trouver des portes logiques à base de relais, de fluides ou d'éléments optiques ou mécaniques. Selon la modélisation utilisée, on prendra en compte les temps de retard ou pas dans les calculs.

NB: L'automatisme et l'informatique utilisent la logique combinatoire mais surtout la logique séquentielle.

Sommaire

  • 1 Historique
    • 1.1 De la roue dentée à la molécule
    • 1.2 Les portes logiques à transistors
    • 1.3 Portes logiques à 3 états
  • 2 Classification
    • 2.1 Niveaux logiques
    • 2.2 Fonctions logiques élémentaires
  • 3 Représentation
    • 3.1 Représentation graphique
    • 3.2 Convention d'écriture
  • 4 Autres fonctions logiques
    • 4.1 Multiplexeurs
    • 4.2 Additionneurs
      • 4.2.1 simple
      • 4.2.2 complet
      • 4.2.3 soustracteur
      • 4.2.4 multiplicateur
    • 4.3 Unités de stockage
    • 4.4 Automates à nombre fini d'états
    • 4.5 Unités fonctionnelles
  • 5 Notes et références
  • 6 Voir aussi
    • 6.1 Articles connexes
    • 6.2 Liens externes

Historique

De la roue dentée à la molécule

Les premières fonctions logiques furent réalisées de manière mécanique. Charles Babbage, vers 1837, conçut la « machine analytique », assemblage de portes reliées à des roues dentées pour effectuer des opérations logiques. Par la suite, les opérations logiques furent effectuées grâce à des relais électromagnétiques.

En 1891, Almon Strowger déposa un brevet pour un appareil contenant un commutateur basé sur une porte logique ((en) Brevet U.S. 0447918). Son brevet ne fut guère exploité jusque dans les années 1920. À partir de 1898, Nikola Tesla déposa une série de brevets concernant des appareils basés sur des circuits à portes logiques. Finalement, les tubes à vides remplacèrent les relais pour les opérations logiques. En 1907, Lee De Forest modifia l'un de ces tubes et l'utilisa comme une porte logique ET. Claude E. Shannon introduisit l'utilisation de l'algèbre de Boole dans la conception de circuits en 1937. Walther Bothe, inventeur du circuit de coïncidence, reçut le prix Nobel de physique en 1954, pour la création de la première porte logique ET électronique moderne en 1924. Des travaux de recherche sont actuellement menés pour la génération de portes logiques moléculaires.

Les portes logiques à transistors

La forme la plus simple de la logique électronique est la logique à diodes. Cela permet la fabrication de portes ET et OU, mais pas de portes NON ce qui conduit à une logique incomplète. Pour créer un système logique complet, il est nécessaire d'utiliser des lampes ou des transistors.

La famille la plus simple de portes logiques utilisant des transistors bipolaires est appelée résistance-transistor ou RTL (resistor-transistor logic). Au contraire des portes à diodes, les portes RTL peuvent être mises en cascade indéfiniment pour produire des fonctions logiques complexes. Pour diminuer le temps de retard, les résistances utilisées par les portes RTL furent remplacées par des diodes, ce qui donna naissance aux portes logiques diode-transistor ou DTL (diode-transistor logic). On découvrit ensuite qu'un transistor pouvait faire le travail de deux diodes en prenant la place d'une seule, ce qui mena à la création de portes logiques transistor-transistor ou TTL (transistor-transistor logic). Dans certains types de circuits, les transistors bipolaires furent remplacés par des transistors à effet de champ (MOSFET) ce qui donna naissance à la logique CMOS.

Circuit intégré 7400 contenant 4 portes NON-ET (NAND). Les deux autres broches servent à l'alimentation 0V / 5V.

Les concepteurs de circuits logiques utilisent actuellement des circuits intégrés préfabriqués, notamment en TTL, la série 7400 de Texas Instruments, et en CMOS, la série 4000 de RCA, ainsi que leurs dérivés plus récents. La plupart de ces circuits contiennent des transistors à plusieurs émetteurs, utilisés pour implémenter la fonction ET, et qui ne sont pas disponibles séparément. De plus en plus, ces circuits logiques fixes sont remplacés par des circuits programmables, qui permettent aux concepteurs d'intégrer un grand nombre de portes logiques diverses dans un seul circuit intégré. La nature programmable de ces circuits, parmi lesquels les FPGA, a enlevé au hardware son aspect "dur" : il est désormais possible de changer les fonctions logiques d'un système en reprogrammant certains de ses composants, ce qui permet de modifier les caractéristiques d'un circuit logique hardware.

Les portes logiques électroniques diffèrent de manière significative de leurs équivalents à relais et contacts. Elles sont bien plus rapides, moins gourmandes et beaucoup plus petites (au moins un million de fois dans la plupart des cas). De plus, il y a une différence fondamentale dans la structure. Les circuits à contacts créent un chemin continu, dans lequel le courant peut circuler dans les deux directions entre l'entrée et la sortie. La porte logique à semi-conducteurs, au contraire, agit comme un puissant amplificateur de tension, qui reçoit un courant faible en entrée et produit une tension de basse impédance en sortie. Le courant ne peut pas circuler entre la sortie et l'entrée d'une porte à semi-conducteurs.

Un autre grand avantage des circuits logiques standardisés est qu'ils peuvent être mis en cascade. Autrement dit, la sortie d'une porte peut être reliée aux entrées d'une ou plusieurs portes, et ainsi de suite à l'infini, ce qui permet de construire des circuits d'une complexité quelconque sans avoir besoin de connaître le fonctionnement interne des portes. Dans la pratique, la sortie d'une porte ne peut être connectée qu'à un nombre fini d'entrées, mais cette limite est rarement atteinte dans les nouveaux circuits CMOS comparé aux circuits TTL. Il existe également un délai nommé temps de propagation entre la modification d'une entrée et la modification correspondante en sortie. Dans des portes en cascade, le temps de propagation total est à peu près égal à la somme des temps de propagation individuels, ce qui peut poser problème dans les circuits à grande vitesse.

Portes logiques à 3 états

Les portes logiques dites « à trois états » possèdent une sortie qui peut prendre trois états différents : haut, bas comme sur tout autre circuit logique et un troisième état haute impédance nommé Z. L'état de haute impédance ne joue aucun rôle dans la logique proprement dite qui demeure binaire, mais il équivaut en fait à un circuit ouvert, ou à une « absence » de sortie. Cet état permet de ne pas "polluer" la valeur circulant sur le bus de données auquel il est connecté, lorsque ce circuit ne doit pas en changer l’état.

Ces portes sont utilisées dans les bus électroniques pour l'envoi de données ; un groupe de portes à trois états contrôlées par un circuit approprié équivaut à un multiplexeur qui peut être réparti physiquement sur plusieurs appareils ou plusieurs cartes électroniques.

Classification

Niveaux logiques

En algèbre de Boole, une donnée, qu'elle soit en entrée ou en sortie, n'a que deux niveaux possibles. Selon les applications, ces deux niveaux peuvent porter des noms différents : marche / arrêt, haut / bas, un (1) / zéro (0), vrai / faux, positif / négatif, positif / nul, circuit ouvert / circuit fermé, différence de potentiel / pas de différence, oui / non.

Dans le cas de circuits électroniques, les deux niveaux sont représentés par deux niveaux de tension, « haut » et « bas ». Chaque type de circuit possède ses propres niveaux de tension, pour s'assurer de la connectivité entre les entrées et sorties des circuits. Habituellement, deux niveaux bien distincts (ne risquant pas de se chevaucher) sont définis ; la différence entre les deux niveaux varie entre 0,7 V et 28 V (ce dernier dans le cas des relais).

Pour harmoniser la notation, ces deux niveaux seront notés ici 1 et 0.

Fonctions logiques élémentaires

Les portes peuvent être classées suivant leur nombre d'entrées :

  • « portes » sans entrée : VRAI, FAUX ;
  • portes à une entrée : NON (NOT), OUI ;
  • portes à deux entrées : ET (AND), NON-ET (NAND), OU (OR), NON-OU (NOR), OU exclusif (XOR), coïncidence dite aussi NON-OU exclusif ou équivalence (XNOR), implication ;
  • À partir de trois entrées, le nombre de fonctions commence à subir l'influence de l'explosion combinatoire. On note toutefois l'existence de : ET, OU, etc. à plus de deux entrées.

Il est possible de reconstituer les fonctions NON, ET et OU en utilisant uniquement soit la fonction NON-ET, soit la fonction NON-OU. On évoque cette caractéristique sous la notion d'universalité des opérateurs NON-OU et NON-ET (cf. le connecteur binaire d'incompatibilité, appelé aussi barre de Sheffer).

Lorsqu'on associe deux portes logiques compatibles, on peut connecter deux entrées ensemble, ou une entrée sur une sortie. Il ne faut en aucun cas connecter deux sorties différentes car elles peuvent produire des données différentes ; dans le cas de portes électroniques, cela équivaudrait à un court-circuit.

Représentation

Pour définir chacune des fonctions logiques, nous donnerons plusieurs représentations :

  • une représentation algébrique : équation ;
  • une représentation arithmétique : table de vérité ;
  • une représentation graphique : symbole logique.

Dans le cas de portes électroniques, un niveau logique est représenté par un voltage défini (selon le type de composant utilisé). Chaque porte logique doit donc être alimentée pour délivrer la tension de sortie appropriée. Dans la représentation en symboles logiques, cette alimentation n'est pas représentée, mais elle doit l'être dans un schéma électronique complet.

La représentation d'un système combinatoire incluant plusieurs fonctions logiques peut aussi se faire grâce à un schéma à contact, une équation, une table de vérité et un schéma graphique. Dans ce dernier cas on parlera d'un logigramme.

Représentation graphique

Deux ensembles de symboles sont utilisés pour représenter les fonctions logiques ; les deux sont définis par la norme ANSI/IEEE 91-1984 et son supplément 91a-1991. La représentation par « symboles distinctifs », basée sur les schématisations classiques, est utilisée pour les schémas simples et est plus facile à tracer à la main. Elle est parfois qualifiée de « militaire », ce qui reflète ses origines, sinon son usage actuel.

La représentation « rectangulaire » se base sur la norme CEI 60617-12 ; toutes les portes y sont représentées avec des bords rectangulaires et un symbole, ce qui permet la représentation d'un plus grand nombre de types de circuits. Ce système a été repris par d'autres standards comme EN 60617-12:1999 en Europe et BS EN 60617-12:1999 au Royaume-Uni.

Symboles et tables de vérités de portes logiques

Type

Symbole américain

Symbole européen

Opération booléenne entre A et B

Table de vérité

ET

ET

ET

Entrée |  | Sortie
A | B | A ET B
0 | 0 | 0
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1

OU

OU

OU

Entrée |  | Sortie
A | B | A OU B
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 1

NON

NON

NON

Entrée | Sortie
A | NON A
0 | 1
1 | 0

En électronique, une porte NON est plus communément appelée inverseur. Le cercle utilisé sur la représentation est appelé « bulle », et on l'utilise généralement dans les diagrammes pour montrer qu'une entrée ou une sortie est inversée.

NON-ET (NAND)

NAND

NAND

Entrée |  | Sortie
A | B | A NAND B
0 | 0 | 1
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0

NON-OU (NOR)

NOR

NOR

Entrée |  | Sortie
A | B | A NOR B
0 | 0 | 1
0 | 1 | 0
1 | 0 | 0
1 | 1 | 0

OU exclusif (XOR)

XOR

XOR

Entrée |  | Sortie
A | B | A XOR B
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0

NON-OU exclusif ou OU-exclusif complémenté (XNOR) ou Identité

XNOR

XNOR

Entrée |  | Sortie
A | B | A XNOR B
0 | 0 | 1
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1

Une porte NON-ET (NAND) peut également être représentée en utilisant le symbole OU avec des bulles (inverseurs) sur les entrées, et une porte NON-OU (NOR) peut être représentée par un symbole ET avec des bulles sur les entrées. Cela reflète les lois d'équivalence de De Morgan ; cela permet de rendre également un diagramme plus lisible, ou de fabriquer un circuit facilement avec des portes préfabriquées, car un circuit qui a des bulles des deux côtés peut être remplacé par un circuit non-inversé en changeant la porte. Si une porte NON-ET est représentée par un OU avec des entrées inversées, ou qu'un NON-OU est représenté par un ET avec des entrées inversées, le remplacement se fait automatiquement dans le schéma (les bulles « s'annulent »). C'est courant dans les diagrammes logiques réels — si bien que le lecteur ne doit pas s'habituer à associer les symboles aux portes OU et ET automatiquement, mais doit aussi prendre en compte les inverseurs pour déterminer la bonne fonction représentée. Les entrées inversées sont particulièrement utiles dans le cas de signaux « actifs à l'état bas ».

Les deux autres portes fréquemment rencontrées sont la fonction OU exclusif et son inverse. Un OU exclusif à deux entrées ne renvoie un 1 que quand les deux entrées sont différentes, et un 0 quand elles sont égales, quelle que soit leur valeur. S'il y a plus de deux entrées, la porte renvoie 1 si le nombre d'entrées égales à 1 est impair ([1]). Dans la pratique, ces portes sont souvent réalisées à partir de combinaisons de portes logiques plus simples.

Convention d'écriture

La notation surlignée est vite malcommode. On la remplace souvent par la notation " ' " et si nécessaire un parenthésage. Ainsi :

  • NON(x) = x', d'où (x')' = x.
  • NON·ET(x, y)= (x·y)' = x'+y'.
  • NON·OU(x, y)= (x+y)' = x'·y'.
  • NON·ET(NON·ET(a, b, c), NON·ET(d, f)) = ((a·b·c)')'+((d·f)')' = a·b·c + d·f.
  • NON·OU(NON·OU(a, b, c), NON·OU(d, f)) = ((a+b+c)')'·((d+f)')' = (a+b+c)·(d+f)

Les opérateurs physiques NON·ET/NON·OU étant peu commodes dans les calculs, les deux dernières relations (dites de double couche) facilitent la liaison entre calcul et dessin ; ainsi :

  • une double couche NON·ET réalise toute fonction donnée sous forme d'une somme de monômes booléens ;
  • de même, une double couche NON·OU réalise toute fonction donnée sous forme d'un produit de clauses booléennes.

Autres fonctions logiques

Multiplexeurs

Soient 8 entrées binaires x0 à x7, et 3 entrées de commande a, b, c, permettant d'afficher un nombre de 0 à 7. Un multiplexeur aligne sa sortie s sur l'entrée dont le numéro est affiché. Pour cela, s = a'·b'·c'·x0 + a'·b'·c·x1 + a'·b·c'·x2 + a'·b·c·x3 +....+ a·b·c·x7.

Commande |  |  | Sortie
a | b | c | s
0 | 0 | 0 | x0
0 | 0 | 1 | x1
0 | 1 | 0 | x2
0 | 1 | 1 | x3
* | * | * | *
1 | 1 | 0 | x6
1 | 1 | 1 | x7

Additionneurs

C'est l'exemple type de cellules logiques, regroupements de fonctions des mêmes variables, utilisables comme briques ou boîtes noires dans des ensembles complexes.

simple

Soient a et b deux bits à additionner ; le résultat est un couple (r, s) tel que, arithmétiquement a + b = 2r + s. En termes booléens, r = a·b et s = [image].

complet

L'addition de deux bits a et b sera le plus souvent une addition intermédiaire recevant un report r. Le résultat est alors un couple (R, S) tel que, arithmétiquement, a+b+r = 2R+S. En termes booléens, S = [image] et R = MAJ(a, b, r), où la porte MAJ(orité) a pour définition MAJ(x, y, z)= xy + yz + xz.

soustracteur

Un additionneur complet peut devenir additionneur/soustracteur en complément à un ou complément à deux s'il fait la somme des bits a, [image] et r, où r est un report, et $ une commande valant 0 pour une addition et 1 pour une soustraction. Alors, le résultat est un couple (R, S) où S = [image] et R = MAJ(a, [image], r).

multiplicateur

Un additionneur complet peut devenir une cellule de multiplicateur s'il fait la somme des bits a, b·m et r, où a est un bit d'une somme partielle de produits, b un bit du multiplicande, m un bit du multiplicateur, et r un report. Alors S = [image] · [image] et R = MAJ(a, b·m, r).

Unités de stockage

Au-delà fonctions logiques purement combinatoires, se pose le problème du stockage d'un bit d'information. Les portes logiques présentées plus haut ne stockent pas de données : quand une entrée change, la sortie réagit immédiatement (au temps de propagation près). Il est possible de créer des éléments de stockage soit avec des condensateurs, soit en utilisant le feedback. En connectant la sortie d'une porte à son entrée, on renvoie la sortie dans le circuit logique ; elle peut ainsi être conservée ou modifiée en utilisant les autres entrées. En connectant des portes de cette manière, on crée un verrou (latch en anglais). D'autres circuits un peu plus complexes utilisent des signaux d'horloge (des signaux qui oscillent à une fréquence connue) et changent quand le signal d'horloge passe à 1 ; on les appelle des bascules ou bistables (flip-flops en anglais). En combinant plusieurs bascules en parallèle pour stocker une valeur de plusieurs bits, on crée un registre.

Les registres et autres circuits de stockage sont regroupés sous le terme de « mémoires électroniques ». Leurs performances varient en termes de vitesse, de complexité et de fiabilité de la mémoire. Leurs types peuvent être très différents selon les applications.

Automates à nombre fini d'états

Ils comprennent :

  • un ensemble défini E de variables d'entrée,
  • un ensemble défini I de variables d'état internes, stockées dans un registre,
  • un ensemble défini S de variables de sortie,
  • un réseau combinatoire T : (E, I) → I assurant l'évolution de l'automate en fonction des entrées successives,
  • un réseau combinatoire R : (E, I) → S assurant la définition de la sortie, conformément aux entrées actuelles, et à la mémoire que I a gardé des situations antérieures.

Dès lors que toutes les variables se présentent sous forme binaire, ils sont réalisables à l'aide de circuits logiques.

Ils peuvent être simples, ou fédérés en automates plus complexes.

Unités fonctionnelles

Les circuits logiques peuvent également réaliser des éléments comme des multiplexeurs, des unités arithmétiques et logiques (en anglais : Arithmetic and Logic Unit ou ALU), des mémoires, ou les automates animant un processeur. Les microprocesseurs rassemblent de tels éléments, et peuvent contenir plus de 100 millions de portes logiques.

Les composants de microprocesseurs sont à base de transistors à effet de champ, en particulier des MOSFET.

Notes et références

  • (en) Cet article est partiellement ou en totalité issu de l’article de Wikipédia en anglais intitulé « Logic gate » (voir la liste des auteurs)

Voir aussi

Sur les autres projets Wikimedia :

· Fonctions logiques, sur Wikimedia Commons

· Électronique numérique : logique, sur Wikibooks

Articles connexes

  • Bascule
  • Algèbre de Boole (logique)
  • Sortance
  • Table de Karnaugh
  • Logique pneumatique
  • Connecteur logique


Connecteur logique

Un article de Wikipédia, l'encyclopédie libre.

Un connecteur logique (ou opérateur logique) est, en logique et en linguistique, un symbole ou un mot établissant une liaison entre deux énoncés.

Sommaire

  • 1 Linguistique
  • 2 Logique formelle
  • 3 Annexes
    • 3.1 Articles connexes
    • 3.2 Liens externes

Linguistique

En grammaire, les connecteurs logiques sont des morphèmes (adverbes, conjonctions de coordination ou de subordination, parfois même interjections), qui établissent une liaison entre deux énoncés, voire entre un énoncé et une énonciation. Ils regroupent des connecteurs logiques et des connecteurs argumentatifs comme «mais», c'est-à-dire des mots qui, en plus de leur rôle de jonction, insèrent les énoncés reliant dans un cadre argumentatif. L'étude des connecteurs intègre ainsi les perspectives de la grammaire de texte (soucieuse de la cohésion du texte) et celle de la pragmatique (intéressé par l'orientation argumentative des énoncés et la relation d'interlocution).

Leur rôle est de rendre un texte plus fluide et de mieux l'organiser.

L'absence de connecteur entre deux énoncés est en soi une forme de jonction.

On peut citer les connecteurs suivants :

  • Addition : et, de plus, puis, en outre, non seulement ... mais encore, de surcroît, ainsi que, également
  • Alternative : ou, soit ... soit, tantôt ... tantôt, ou ... ou, ou bien, seulement ... mais encore, l'un ... l'autre, d'un côté ... de l'autre, d'une part... d'autre part
  • But : afin que, pour que, de peur que, en vue que, de façon à ce que
  • Cause : car, pour,en effet, effectivement, comme, par, parce que, puisque, attendu que, vu que, étant donné que, grâce à, à cause de, par suite de, eu égard à, en raison de, du fait que, dans la mesure où, sous prétexte que, compte tenu de
  • Comparaison : comme, de même que, ainsi que, autant que, aussi ... que, si ... que, de la même façon que, semblablement, pareillement, plus que, moins que, non moins que, selon que, suivant que, comme si
  • Concession : malgré, en dépit de, quoique, bien que, alors que, quel que soit, même si, ce n'est pas que, certes, bien sûr, évidemment, il est vrai que, toutefois
  • Conclusion : en conclusion, pour conclure, en guise de conclusion, en somme, bref, ainsi, donc, en résumé, en un mot, par conséquent, finalement, enfin, en définitive
  • Condition, supposition : si, au cas où, à condition que, pourvu que, à moins que, en admettant que, pour peu que, à supposer que, en supposant que, dans l'hypothèse où, dans le cas où, probablement, sans doute, apparemment
  • Conséquence : donc, aussi, partant, alors, ainsi, ainsi donc, par conséquent, de ce fait, de si bien que, d'où, en conséquence, conséquemment, par suite, c'est pourquoi, de sorte que, en sorte que, de façon que, de manière que, si bien que, tant et si bien que
  • Classification, énumération : d'abord, tout d'abord, de prime abord, en premier lieu, premièrement, en deuxième lieu, en second lieu, deuxièmement, après, ensuite, de plus, quant à, en troisième lieu, puis, en dernier lieu, pour conclure, enfin
  • Explication : savoir, à savoir, c'est-à-dire, soit
  • Illustration : par exemple, comme ainsi, c'est ainsi que, c'est le cas de, notamment, entre autres, en particulier, à l'image de, comme l'illustre, comme le souligne, tel que
  • Justification : car, c'est-à-dire, en effet, parce que, puisque, de sorte que, ainsi, c'est ainsi que, non seulement ... mais encore, du fait de
  • Liaison : alors, ainsi, aussi, d'ailleurs, en fait, en effet, de surcroît, de même, également, puis, ensuite, de plus, en outre, au demeurant.
  • Opposition : mais, cependant, or, en revanche, alors que, pourtant, par contre, tandis que, néanmoins, au contraire, pour sa part, d'un autre côté, en dépit de, malgré, nonobstant, au lieu de, d'une part...d'autre part
  • Restriction : cependant, toutefois, néanmoins, pourtant, mis à part, ne ... que, en dehors de, hormis, à défaut de, excepté, sauf, uniquement, simplement
  • Temps : quand, lorsque, avant que, après que, alors que, dès lors que, depuis que, tandis que, en même temps que, pendant que, au moment où

Logique formelle

En toute généralité une logique p-valente possède [image] connecteurs n-aires.

Table des connecteurs logiques.

Connecteurs logiques organisés en un diagramme de Hasse.

Dans le cas de la logique bivalente classique le tableau suivant recense les seize fonctions booléennes associées aux entrées P et Q.

Connecteur

Notation

Formules équivalentes

Table de vérité

Diagramme de Venn

Contradiction

P [image] ¬P

 |  | Q
 |  | 0 | 1
P | 0 | 0 | 0
 | 1 | 0 | 0

Conjonction
(ET)

P [image] Q
P & Q
P · Q
P AND Q

P [image] ¬Q
¬P [image] Q
¬P [image] ¬Q

 |  | Q
 |  | 0 | 1
P | 0 | 0 | 0
 | 1 | 0 | 1

Non-implication réciproque

P [image] Q
P [image] Q

P ↓ ¬Q
¬P & Q
¬P [image] ¬Q

 |  | Q
 |  | 0 | 1
P | 0 | 0 | 1
 | 1 | 0 | 0

Proposition Q

Q

 |  | Q
 |  | 0 | 1
P | 0 | 0 | 1
 | 1 | 0 | 1

Non-implication

P [image] Q
P [image] Q

P & ¬Q
¬P ↓ Q
¬P [image] ¬Q

 |  | Q
 |  | 0 | 1
P | 0 | 0 | 0
 | 1 | 1 | 0

Proposition P

P

 |  | Q
 |  | 0 | 1
P | 0 | 0 | 0
 | 1 | 1 | 1

Disjonction exclusive
(OU exclusif)

P [image] Q
P [image] Q
P [image] Q
P XOR Q

P [image] ¬Q
¬P [image] Q
¬P [image] ¬Q

 |  | Q
 |  | 0 | 1
P | 0 | 0 | 1
 | 1 | 1 | 0

Disjonction
(OU)

P [image] Q
P ∨ Q
P OR Q

P [image] ¬Q
¬P → Q
¬P ↑ ¬Q

 |  | Q
 |  | 0 | 1
P | 0 | 0 | 1
 | 1 | 1 | 1

Disjonction réciproque
(NON-OU)

P ↓ Q
P NOR Q

P [image] ¬Q
¬P [image] Q
¬P & ¬Q

 |  | Q
 |  | 0 | 1
P | 0 | 1 | 0
 | 1 | 0 | 0

Équivalence

P [image] Q
P ≡ Q
P XNOR Q
P IFF Q

P [image] ¬Q
¬P [image] Q
¬P [image] ¬Q

 |  | Q
 |  | 0 | 1
P | 0 | 1 | 0
 | 1 | 0 | 1

Négation de P

¬P
~P

 |  | Q
 |  | 0 | 1
P | 0 | 1 | 1
 | 1 | 0 | 0

Implication

P → Q
P [image] Q

P ↑ ¬Q
¬P [image] Q
¬P ← ¬Q

 |  | Q
 |  | 0 | 1
P | 0 | 1 | 1
 | 1 | 0 | 1

Négation de Q

¬Q
~Q

 |  | Q
 |  | 0 | 1
P | 0 | 1 | 0
 | 1 | 1 | 0

Implication réciproque

P [image] Q
P [image] Q

P [image] ¬Q
¬P ↑ Q
¬P → ¬Q

 |  | Q
 |  | 0 | 1
P | 0 | 1 | 0
 | 1 | 1 | 1

NON-ET

P ↑ Q
P | Q
P NAND Q

P → ¬Q
¬P ← Q
¬P [image] ¬Q

 |  | Q
 |  | 0 | 1
P | 0 | 1 | 1
 | 1 | 1 | 0

Tautologie

P [image] ¬P

 |  | Q
 |  | 0 | 1
P | 0 | 1 | 1
 | 1 | 1 | 1

Annexes

Articles connexes

  • Mot
  • Syntaxe
  • Nature (grammaire)
  • Syntagme
  • Fonction syntaxique
  • Analyse morphosyntaxique
  • Représentation (grammaire)
  • Énonciation
  • Liste des notions utilisées en linguistique

Liens externes[modifier | modifier le code]

  • Les connecteurs logiques (exercices interactifs) sur le site Magister. Attention, dans ces exercices, la correction est identifiée au texte original, ce qui traite comme erreurs, même s'ils produisent des textes corrects, les autres connecteurs ou organisations de textes.
  • Tableau des connecteurs logiques. On peut y trouver des conjonctions de coordination, des adverbes, des locutions adverbiales, ainsi que des conjonctions et locutions conjonctives de subordination !!

· Portail de la linguistique Portail de la linguistique

· Portail de la logique Portail de la logique

Ce document provient de « http://fr.wikipedia.org/w/index.php?title=Connecteur_logique&oldid=102872003 ».


Algèbre de Boole (logique)

Un article de Wikipédia, l'encyclopédie libre.

L'algèbre de Boole, ou calcul booléen, est la partie des mathématiques, de la logique et de l'électronique qui s'intéresse aux opérations et aux fonctions sur les variables logiques. Plus spécifiquement, l'algèbre booléenne permet d'utiliser des techniques algébriques pour traiter les expressions à deux valeurs du calcul des propositions. Elle fut initiée en 1854 par le mathématicien britannique George Boole.

Aujourd'hui, l'algèbre de Boole trouve de nombreuses applications en informatique et dans la conception des circuits électroniques. Elle fut utilisée la première fois pour les circuits de commutation téléphoniques par Claude Shannon.

Sommaire

  • 1 Exemple introductif
  • 2 Algèbre de Boole des valeurs de vérité
    • 2.1 Conjonction
    • 2.2 Disjonction
    • 2.3 Négation
    • 2.4 Propriétés
      • 2.4.1 Propriétés des opérateurs
      • 2.4.2 Structure
      • 2.4.3 Priorité
      • 2.4.4 Théorème de De Morgan
  • 3 Fonctions logiques
    • 3.1 Fonctions logiques fondamentales
    • 3.2 Fonctions logiques composées
      • 3.2.1 Disjonction exclusive
      • 3.2.2 Équivalence
      • 3.2.3 Implication
      • 3.2.4 Inhibition
    • 3.3 Exemple de fonctions logiques à trois ou quatre variables
      • 3.3.1 Fonction logique à trois variables
      • 3.3.2 Fonction logique à quatre variables
    • 3.4 Minimisation d'une expression
  • 4 Arbre d'expression
  • 5 Bibliographie
  • 6 Voir aussi

Exemple introductif

L'algèbre de Boole des fonctions logiques permet de modéliser des raisonnements logiques, en exprimant un « état » en fonction de conditions. Par exemple dans les expressions

Communication = Émetteur ET Récepteur

Communication serait « VRAI » si à la fois Émetteur ET Récepteur étaient actif (c'est une fonction logique dépendant des variables Émetteur et Récepteur)

Décrocher = ( Décision de répondre ET Sonnerie ) OU décision d'appeler

Décrocher serait « VRAI » soit si à la fois on entend la sonnerie ET l'on décide de répondre, soit (OU) si simplement l'on décide d'appeler.

L'algèbre de Boole étant un domaine commun à trois disciplines, on rencontre des notations différentes pour désigner un même objet. Dans le reste de l'article, on indiquera les diverses notations, mais on en privilégiera une pour conserver une certaine homogénéité.

Algèbre de Boole des valeurs de vérité

On appelle B l'ensemble constitué de deux éléments appelés valeurs de vérité {VRAI, FAUX}. Cet ensemble est aussi noté

  • B = {1, 0}
  • B = [image] .

On privilégiera dans la suite la notation B = {1, 0}.

Sur cet ensemble on peut définir deux lois (ou opérations ou foncteurs), les lois ET et OU et une transformation appelée complémentaire, inversion ou contraire.

Conjonction

Articles connexes : Fonction ET et Conjonction logique.

Table de la loi ET
b\a | 0 | 1
0 | 0 | 0
1 | 0 | 1

Elle est définie de la manière suivante : a ET b est VRAI si et seulement si a est VRAI et b est VRAI. Cette loi est aussi notée

  • « & » ou « && » dans la plupart des langages de programmation (Perl, C, PHP…)
  • « AND » dans certains langages de programmation (Ada, Pascal, Perl, Python, PHP…)
  • « ∧ » dans quelques notations algébriques, ou en APL
  • « * » (une multiplication ordinaire), pour quelques langages ne disposant pas de fonction adaptée

On privilégiera dans la suite la notation [image] .

On peut construire la table de cette loi (comme une table d'addition ou de multiplication de notre enfance) mais on ne la confondra pas avec une table de vérité.

Disjonction

Table de la loi OU
b\a | 0 | 1
0 | 0 | 1
1 | 1 | 1

Articles connexes : Fonction OU et Disjonction logique.

Elle est définie de la manière suivante : a OU b est VRAI si et seulement si a est VRAI ou b est VRAI. (En particulier, si a est vrai et que b est vrai aussi, alors a OU b est vrai.) Cette loi est aussi notée

  • « ∨ » (« [image] ») en mathématiques (et en logique mathématique) ou en APL.
  • « | » ou « || » dans certains langages de programmation
  • En toute lettre « or » ou « OR » en logique ou dans certains langages de programmation ..

On privilégiera dans la suite la notation + mais on prendra garde que cette loi n'est pas l'addition usuelle dans Z/2Z. C'est pourquoi, en mathématiques et en logique mathématique, la notation + n'est pas utilisée pour désigner le "ou inclusif" : elle est réservée au "ou exclusif", opération qui (jointe au "et") fait de toute algèbre de Boole un anneau de Boole, en particulier une Z/2Z-algèbre.

Négation

Articles connexes : Fonction NON et Négation logique.

Le contraire de "a" est VRAI si et seulement si a est FAUX. Le contraire de a est noté

  • non-a
  • « ! » dans quelques langages de programmation (C, C++…)
  • « NOT » dans certains langages de programmation (ASM…)
  • « ~ » dans quelques notations algébriques, en APL et dans quelques langages d'interrogation de bases de données (SQL…).
  • « 1- » dans quelques langages ne disposant pas de fonction adaptée (Batch…) (puisque 1-0=1 et 1-1=0)

On privilégiera dans la suite la notation [image] .

On obtient alors [image] et

Propriétés

Propriétés des opérateurs

Associativité

Comme avec les opérations habituelles, certaines parenthèses sont inutiles:

( a + b ) + c = a + (b + c) = a + b + c

( a . b ) . c = a . (b . c) = a . b . c

Commutativité

L'ordre est sans importance:

a + b = b + a

a . b = b . a

Distributivité

a . ( b + c ) = a . b + a . c

a +( b . c ) = ( a + b ) . ( a + c )

Idempotence

a + a + a + [...] + a = a

a . a . a . [...] . a = a

Éléments neutres

Absorption

0 . a = 0

Simplification

Redondance

Complémentarité

(« La lumière est allumée » = « la lumière n'est pas non allumée »)

(« VRAI » SI lumière_allumée OU SI lumière_non_allumée → c'est toujours le cas → vrai dans tous les cas → toujours VRAI, donc =1)

(«FAUX » SI lumière_allumée ET SI lumière_non_allumée → impossible → faux dans tous les cas → toujours FAUX, donc =0)

Structure

On retrouve alors toutes les propriétés qui confèrent à B une structure d'algèbre de Boole

Priorité

Pour faciliter leur compréhension, il a été décidé que ces opérations seraient soumises aux mêmes règles que les opérations « de tous les jours », la fonction ET (multiplication logique) est ainsi prioritaire par rapport à la fonction OU (somme logique) ; on peut, pour s'aider, placer des parenthèses dans les opérations.

Exemple :

{ a = 0 ; b = 1 ; c = 1 }
On cherche a . b + c = ???

Solution

D'abord on calcule a . b :
a . b = 0 . 1
0 . 1 = 0
Puis, on calcule 0 + c :
0 + c = c
c = 1
Le résultat final est donc:
a . b + c = ( a . b )+ c = 1

Théorème de De Morgan[modifier | modifier le code]

Première loi de De Morgan (négation de la conjonction)

s'exprime par l'égalité suivante

Table de vérité/Table de fonctionnement
a | b | a+b |  |  |  |
0 | 0 | 0 | 1 | 1 | 1 | 1
0 | 1 | 1 | 0 | 1 | 0 | 0
1 | 0 | 1 | 0 | 0 | 1 | 0
1 | 1 | 1 | 0 | 0 | 0 | 0

Dans les deux cas, l'expression ne sera VRAIE
que si a et b sont fausses.

Deuxième loi de De Morgan (négation de la disjonction)

Table de vérité/Table de fonctionnement
a | b | a . b |  |  |  |
0 | 0 | 0 | 1 | 1 | 1 | 1
0 | 1 | 0 | 1 | 1 | 0 | 1
1 | 0 | 0 | 1 | 0 | 1 | 1
1 | 1 | 1 | 0 | 0 | 0 | 0

Dans les deux cas, l'expression ne sera FAUSSE
que si a et b sont vraies.

Fonctions logiques

Article détaillé : Fonction logique.

Mathématiquement, une fonction logique ou opérateur logique est une application de Bn dans B.

En électronique, une fonction logique est une boîte noire qui reçoit en entrée un certain nombre de variables logiques et qui rend en sortie une variable logique dépendant des variables d'entrée. L'article fonction logique précise comment construire les boîtes noires de quelques fonctions fondamentales.

Une table de vérité permet de préciser l'état de la sortie en fonction des états des entrées. Elle caractérise la fonction logique.

Toute table de vérité, et donc toute fonction logique, peut se décrire à l'aide des trois opérations de base :

  • disjonction (OU)
  • conjonction (ET)
  • négation (NON)

On démontre aussi qu'il existe exactement [image] fonctions logiques de n paramètres. Il suffit en effet de considérer toutes les tables de vérités possibles, ou de considérer le développement d'une fonction de n paramètres

Fonctions logiques fondamentales

Elles sont issues des trois opérations de base et définissent alors

  • une fonction de B dans B : le complémentaire ou inversion
  • deux fonctions de B2 dans B qui sont la somme (OU) et le produit (ET)

Table de vérité de l'inverse
a |
0 | 1
1 | 0

Table de vérité de la somme
a | b | a [image] b
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 1

Table de vérité du produit
a | b | a [image] b
0 | 0 | 0
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1

Fonctions logiques composées

Ce sont les fonctions logiques à deux variables. Parmi celles-ci, on en dénombre certaines suffisamment intéressantes pour qu'on leur donne un nom.

Disjonction exclusive

Table de vérité de XOR
a | b | a [image] b
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0

Article connexe : OU exclusif.

Le OU étudié jusqu'à présent doit se comprendre de la manière suivante : « l'un ou l'autre ou les deux ». Il est également appelé « OU inclusif ». Le OU exclusif (ou XOR pour ' eXclusive OR') s'entend comme : « l'un ou l'autre, mais pas les deux ».

a\ \operatorname{XOR}\ b

On peut également le définir avec un modulo sur une somme ordinaire :

Le « ou exclusif » est parfois noté par le signe arithmétique [image] (différent de). Fonctionnellement, on utilise aussi un + entouré: .

Équivalence

Table de vérité de EQV
a | b | a [image] b
0 | 0 | 1
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1

L'équivalence (notée EQV ou XNOR) est vraie si les deux entrées ont la même valeur et fausse sinon. C'est la négation du « ou exclusif ».

L'équivalence peut s'écrire

L'équivalence est souvent notée par le signe [image] . Elle peut aussi être notée "==" dans certains langages (C, C++, PHP…).

Implication

Table de vérité de IMP
a | b | a [image] b
0 | 0 | 1
0 | 1 | 1
1 | 0 | 0
1 | 1 | 1

Article détaillé : implication (logique).

L'implication (notée IMP) s'écrit de la manière suivante

Cette opération n'est pas commutative. a est une condition suffisante pour b, qui, elle, est une condition nécessaire pour a.

Mais

illustration :

de l'affirmation "Si j'habite en France, alors j'habite en Europe." on peut déduire "Si je n'habite pas en Europe, alors je n'habite pas en France." mais pas "Si je n'habite pas en France, alors je n'habite pas en Europe. car on ne sait pas si j'habite en Europe mais ailleurs qu'en France..

Inhibition

Table de vérité de INH
a | b |
0 | 0 | 0
0 | 1 | 0
1 | 0 | 1
1 | 1 | 0

L'inhibition (notée INH) se compose comme suit

Si a est VRAI, l'expression vaut VRAI, SAUF si b est VRAI.

Cette opération n'est pas commutative.

Exemple de fonctions logiques à trois ou quatre variables

Fonction logique à trois variables

Table de vérité de décrocher
a | b | c | d
0 | 0 | 0 | 0
0 | 0 | 1 | 1
0 | 1 | 0 | 0
0 | 1 | 1 | 1
1 | 0 | 0 | 0
1 | 0 | 1 | 1
1 | 1 | 0 | 1
1 | 1 | 1 | 1

L'égalité Décrocher = ( Sonnerie ET Décision de répondre ) OU Décision d'appeler traduit la situation pratique suivante : On décroche un téléphone quand on décide d'appeler quelqu'un ou lorsque le téléphone sonne et qu 'on décide de répondre.

Elle est constituée de trois variables :

  • a = "Sonnerie"
  • b = "Décision de répondre"
  • c = "Décision d'appeler"

la variable d = "Décrocher" est fonction logique des 3 précédentes et peut s'écrire d = a.b + c

La table de vérité de cette fonction d est alors la suivante (à droite) :

Table de vérité de décrocher2
a | b | c | d2
0 | 0 | 0 | 0
0 | 0 | 1 | 1
0 | 1 | 0 | 0
0 | 1 | 1 | 1
1 | 0 | 0 | 0
1 | 0 | 1 | 0
1 | 1 | 0 | 1
1 | 1 | 1 | 1

L'observation de la table met en évidence une situation absurde : quand on décide d'appeler quelqu'un et que le téléphone sonne sans qu'on ait envie de répondre, on décrocherait quand même. Une modification de la table comme ci-contre corrigerait cette absurdité. Cette table correspond à une fonction logique Décrocher2 ou d2 qu'il est possible de déterminer et simplifier en [image] .

Fonction logique à quatre variables

Un bon élève s'interroge s'il est sage de sortir un soir. Il doit décider en fonction de quatre variables :

  • a = il a assez d'argent
  • b = il a fini ses devoirs
  • c = le transport en commun est en grève
  • d = l'automobile de son père est disponible

Cet élève pourra sortir si :

  • il a assez d'argent, a = vrai
  • il a fini ses devoirs, donc b = vrai
  • le transport en commun n'est pas en grève, donc c = faux
  • ou si l'automobile de son père est disponible, donc d = vrai

L'expression logique de sortir en fonction de l'état des variables a, b, c et d peut donc s'écrire ainsi :

Sortir =

Minimisation d'une expression

Une fonction logique peut être déterminée

  • soit sous forme d'une expression faisant intervenir les 3 opérations ( [image] , [image] , )
  • soit sous forme de sa table de vérité. Dans ce cas il sera toujours possible d'effectuer un développement pour écrire cette fonction comme une somme de produits.

Exemple: Dans l'exemple de "Décrocher2", la lecture de la table montre que d2 égale 1 quand (a, b, c) = (0, 0, 1) ou (0, 1, 1) ou (1, 1, 0) ou (1, 1, 1).

Cela permet de définir d2 par

Il est possible de trouver une expression minimisant le nombre de termes et le nombre de lettres dans chaque terme. C'est l'objectif de certaines techniques comme la méthode de Quine-Mc Cluskey, les diagrammes de Karnaugh, la méthode des consensus, la double dualisation…

Exemple (suite) : la somme précédente peut être réduite en

par factorisation des deux premiers termes par [image] et factorisation des deux derniers termes par

Arbre d'expression

Les expressions logiques sont souvent représentées en informatique sous forme d'arborescence. À un premier sommet (racine) sont rattachés différents sous-arbres (ou branches). Les sommets sans issue sont appelés feuilles. Chaque sommet interne correspond à un sélecteur booléen S(x, y, z )= "si x alors y sinon z", qui ramène une question x à deux sous-questions plus simples, éventuellement réduites à 1/vrai ou 0/faux. L'évaluation d'une fonction f dépendant d'une variable q choisie pour la première question est alors f=S(q,f(q=1), f(q=0)), qui ramène à deux expressions indépendantes de q. Soit f = a.b+a.d.f+c.d+e.f ; on peut écrire f= S(a, f(a=1), f(a=0))= S(a, b+c.d+d.f+e.f, c.d+e.f)= S(a, S(b,1,d.f+c.d+e.f), S(c,d+e.f, e.f))... Les arbres dépendant de l'expression et de l'ordre des questions, pour une même expression certains questionnaires seront plus simples que d'autres.

Bibliographie

Kuntzmann J., 1968, Algèbre de Boole, Paris:Dunod.

Picard, C.F, 1965, Théorie des questionnaires, Paris:Gauthier-Villars.


Opération bit à bit

Un article de Wikipédia, l'encyclopédie libre.

En informatique, les opérations bit à bit apparaissent dans beaucoup des langages de programmation, et permettent de manipuler les données binaires, directement au niveau des bits. Elles sont utiles dès qu'il s'agit de manipuler les données à bas niveau : codages, couches basses du réseau (par exemple TCP/IP), cryptographie, où elles permettent également les opérations sur les corps finis de caractéristique 2.

Les opérations bit à bit courantes comprennent des opérations logiques bit par bit, et des opérations de décalage des bits, vers la droite ou vers la gauche.

Sommaire

  • 1 Opérateurs
    • 1.1 NOT
    • 1.2 AND
    • 1.3 OR
    • 1.4 XOR
  • 2 Décalage de bit
  • 3 Articles liés

Opérateurs

NOT

Représente la négation logique, le complément d'une expression.

Par exemple, NOT 7 = 8 :

NOT 0111
  = 1000

AND

Le et logique de deux expressions.

Ex : 5 AND 3 = 1 :

    0101
AND 0011
  = 0001

OR

Le ou logique de deux expressions.

Ex : 5 OR 3 = 7 :

   0101
OR 0011
 = 0111

XOR

Le ou exclusif de deux expressions.

Ex : 5 XOR 3 = 6 :

    0101
XOR 0011
  = 0110

Décalage de bit

Décalage de bit à gauche.

   00010111 (+23) LEFT-SHIFT
=  00101110 (+46)

Décalage de bit à droite.

   00010111 (+23) RIGHT-SHIFT
=  00001011 (+11)

Articles liés

  • Masquage
  • Système binaire

· Portail de la programmation informatique

Ce document provient de « http://fr.wikipedia.org/w/index.php?title=./Opération_bit_à_bit&oldid=105631205 ».